I2C.Java API: Packages

  • Main Page
  • Packages
  • Classes
  • Examples
  • Packages
Packages
Here are the packages with brief descriptions (if available):
[detail level 123]
▼N telos
▼N I2cApi
N Java
telos Systementwicklung GmbH (http://www.telos.info) Tue Mar 17 2015


I2C.Java API: Package telos.I2cApi.Java

  • Examples
  • Packages
  • telos
  • I2cApi
  • Java
Classes
Package telos.I2cApi.Java

Classes

class | Adc
class | AdcData
class | Board
class | I2cAddress
class | I2cApi
class | InputTestpins
class | InputTestpinsMessage
class | NegativeTester
class | NegativeTesterMaster
class | NegativeTesterSlave
class | PmbusMasterMessage
class | PmbusMasterMessageCmd
class | PmbusMasterMessageExtCmdByte
class | PmbusMasterMessageExtCmdWord
class | PmbusMasterMessageGroupCmd
class | PmbusMasterMessageReadByte
class | PmbusMasterMessageReadWord
class | PmbusMasterMessageWriteByte
class | PmbusMasterMessageWriteWord
class | SmbArpMaster
class | SmbMaster
class | SmbMasterMessage
class | SmbMasterMessageBlockRead
class | SmbMasterMessageBlockWrite
class | SmbMasterMessageBlockWriteRead
class | SmbMasterMessageCmd
class | SmbMasterMessageCmd32
class | SmbMasterMessageCmd64
class | SmbMasterMessageCmdBlock
class | SmbMasterMessageCmdByte
class | SmbMasterMessageCmdProcessCall
class | SmbMasterMessageCmdWord
class | SmbMasterMessageHostNotify
class | SmbMasterMessageQuickCommand
class | SmbMasterMessageRead32
class | SmbMasterMessageRead64
class | SmbMasterMessageReadByte
class | SmbMasterMessageReadWord
class | SmbMasterMessageReceiveByte
class | SmbMasterMessageSendByte
class | SmbMasterMessageWrite32
class | SmbMasterMessageWrite64
class | SmbMasterMessageWriteByte
class | SmbMasterMessageWriteWord
class | Tracer
class | TracerMessage

Detailed Description

This package contains the Java API for the I2C interfaces from telos.


I2C.Java API: Class List

  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123456]
▼N telos
▼N I2cApi
▼N Java
C Adc
C AdcData
▼C Board
C BoardType
C I2cAddress
▼C I2cApi
C BusType
C I2cBusState
C InputTestpins
C InputTestpinsMessage
▼C NegativeTester
C LevelsMaster
C LevelsSlave
C MessageSlave
C MessagesMaster
C MessagesSlave
C NackBehaviour
C StopTrigger
C NegativeTesterMaster
C NegativeTesterSlave
C PmbusMasterMessage
C PmbusMasterMessageCmd
C PmbusMasterMessageExtCmdByte
C PmbusMasterMessageExtCmdWord
C PmbusMasterMessageGroupCmd
C PmbusMasterMessageReadByte
C PmbusMasterMessageReadWord
C PmbusMasterMessageWriteByte
C PmbusMasterMessageWriteWord
▼C SmbArpMaster
▼C Udid
C AddressType
C SmbMaster
C SmbMasterMessage
C SmbMasterMessageBlockRead
C SmbMasterMessageBlockWrite
C SmbMasterMessageBlockWriteRead
C SmbMasterMessageCmd
C SmbMasterMessageCmd32
C SmbMasterMessageCmd64
C SmbMasterMessageCmdBlock
C SmbMasterMessageCmdByte
C SmbMasterMessageCmdProcessCall
C SmbMasterMessageCmdWord
C SmbMasterMessageHostNotify
C SmbMasterMessageQuickCommand
C SmbMasterMessageRead32
C SmbMasterMessageRead64
C SmbMasterMessageReadByte
C SmbMasterMessageReadWord
C SmbMasterMessageReceiveByte
C SmbMasterMessageSendByte
C SmbMasterMessageWrite32
C SmbMasterMessageWrite64
C SmbMasterMessageWriteByte
C SmbMasterMessageWriteWord
C Tracer
▼C TracerMessage
C TracerMessageData
C TracerMessageDataConfirmation
C TracerMessageType


I2C.Java API: telos.I2cApi.Java.Adc Class Reference

  • Class Members
  • telos
  • I2cApi
  • Java
  • Adc
Public Member Functions | List of all members
telos.I2cApi.Java.Adc Class Reference

Public Member Functions

synchronized native void | setSamplingRate (int sampling_rate)
synchronized native int | getSamplingRate ()
synchronized native void | setPreTrigger (int pretrigger)
synchronized native int | getPreTrigger ()
synchronized native void | setUseStartAsTrigger (boolean status)
synchronized native boolean | getUseStartAsTrigger ()
synchronized native void | setUseStopAsTrigger (boolean status)
synchronized native boolean | getUseStopAsTrigger ()
synchronized native void | setUseAckAsTrigger (boolean status)
synchronized native boolean | getUseAckAsTrigger ()
synchronized native void | setUseNackAsTrigger (boolean status)
synchronized native boolean | getUseNackAsTrigger ()
synchronized native void | setUseErrorAsTrigger (boolean status)
synchronized native boolean | getUseErrorAsTrigger ()
synchronized native void | setUseTestpin1AsTrigger (boolean status)
synchronized native boolean | getUseTestpin1AsTrigger ()
synchronized native void | setUseTestpin2AsTrigger (boolean status)
synchronized native boolean | getUseTestpin2AsTrigger ()
synchronized native void | setMessageCountTrigger (byte cnt)
synchronized native byte | getMessageCountTrigger ()
synchronized native void | setMessageDataTrigger (byte[] data, byte[] dont_care)
synchronized native byte[] | getMessageDataTriggerData ()
synchronized native byte[] | getMessageDataTriggerDontCare ()
synchronized native void | start ()
synchronized native void | startImmediately ()
synchronized native AdcData | transferData ()
synchronized native void | cancel ()

Detailed Description

This class can be used to control the A/D converter available on some I2C boards.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the I2cApi.getAdc() property.

Normally the following steps are necessary to use the A/D converter:

  1. Configure the A/D converter (sampling rate, pretrigger, trigger events).
  2. Use start() to start the converter.
  3. Call transferData() until it returns an AdcData object. Use I2cApi.waitForData() to sleep while waiting for the result.

Member Function Documentation

synchronized native void telos.I2cApi.Java.Adc.cancel ( )

Cancels the running A/D converter.

synchronized native byte telos.I2cApi.Java.Adc.getMessageCountTrigger ( )

Specifies the "message count" trigger. It triggers the A/D converter after receiving the specified number of I2C messages. A value of "0" disables this trigger.

Example: the following messages are sent to the I2C bus: SP, SSP, SSP. A value of "1" will trigger on the first start condition. A value of "3" will trigger on the fourth start condition.

The Board.adc_trigger_msg_cnt variable can be used to find out whether the used I2C interface supports this trigger.

Returns
message count
synchronized native byte [] telos.I2cApi.Java.Adc.getMessageDataTriggerData ( )

Returns the current configuration of the data trigger.

Returns
data bytes to be searched
synchronized native byte [] telos.I2cApi.Java.Adc.getMessageDataTriggerDontCare ( )

Returns the current configuration of the data trigger.

Returns
"don't care" mask
synchronized native int telos.I2cApi.Java.Adc.getPreTrigger ( )

Specifies how many samples should be stored before the trigger event [samples/channel].

The maximum value for the pretrigger can be found in the Board.adc_max_pretrigger variable.

Returns
pretrigger [samples/channel]
synchronized native int telos.I2cApi.Java.Adc.getSamplingRate ( )

Gets the sampling rate of the A/D converter [Hz].

Valid values for the sampling rate can be found in Board.adc_samplingrate variable.

Returns
sampling rate [Hz]
synchronized native boolean telos.I2cApi.Java.Adc.getUseAckAsTrigger ( )

Specifies whether an I2C ACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_ack variable can be used to find out whether the used I2C interface supports the use of the ACK condition as trigger event.

Returns
do not use as trigger (false), use as trigger (true)
synchronized native boolean telos.I2cApi.Java.Adc.getUseErrorAsTrigger ( )

Specifies whether an I2C ERROR should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_error variable can be used to find out whether the used I2C interface supports the use of the ERROR condition as trigger event.

Returns
do not use as trigger (false), use as trigger (true)
synchronized native boolean telos.I2cApi.Java.Adc.getUseNackAsTrigger ( )

Specifies whether an I2C NACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_ack variable can be used to find out whether the used I2C interface supports the use of the NACK condition as trigger event.

Returns
do not use as trigger (false), use as trigger (true)
synchronized native boolean telos.I2cApi.Java.Adc.getUseStartAsTrigger ( )

Specifies whether an I2C start condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_start variable can be used to find out whether the used I2C interface supports the use of the start condition as trigger event.

Returns
do not use as trigger (false), use as trigger (true)
synchronized native boolean telos.I2cApi.Java.Adc.getUseStopAsTrigger ( )

Specifies whether an I2C stop condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_stop variable can be used to find out whether the used I2C interface supports the use of the start condition as trigger event.

Returns
do not use as trigger (false), use as trigger (true)
synchronized native boolean telos.I2cApi.Java.Adc.getUseTestpin1AsTrigger ( )

Specifies whether testpin 1 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_testpin1 variable can be used to find out whether the used I2C interface supports the use of testpin 1 as trigger event.

Returns
do not use as trigger (false), use as trigger (true)
synchronized native boolean telos.I2cApi.Java.Adc.getUseTestpin2AsTrigger ( )

Specifies whether testpin 2 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_testpin1 variable can be used to find out whether the used I2C interface supports the use of testpin 2 as trigger event.

Returns
do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.setMessageCountTrigger ( byte cnt )

Specifies the "message count" trigger. It triggers the A/D converter after receiving the specified number of I2C messages. A value of "0" disables this trigger.

Example: the following messages are sent to the I2C bus: SP, SSP, SSP. A value of "1" will trigger on the first start condition. A value of "3" will trigger on the fourth start condition.

The Board.adc_trigger_msg_cnt variable can be used to find out whether the used I2C interface supports this trigger.

Parameters
cnt message count
synchronized native void telos.I2cApi.Java.Adc.setMessageDataTrigger | ( | byte[] | data,
 |  | byte[] | dont_care
 | ) |  |

This method sets the data trigger. It triggers the A/D converter when an I2C message is sent to the bus, whose data bytes after the START condition equal the data bytes specified to this trigger.

A "don't care" mask is offered so that individual bits can be excluded from the comparison ("0xff" means all bits are compared).

Both parameters passed to this method have to contain the same number of bytes. If both parameters are empty, this trigger gets disabled.

The Board.adc_trigger_data variable can be used to find out whether the used I2C interface supports this trigger and how many data bytes can be specified.

Parameters
data | data bytes to be searched
dont_care | "don't care" mask
synchronized native void telos.I2cApi.Java.Adc.setPreTrigger ( int pretrigger )

Specifies how many samples should be stored before the trigger event [samples/channel].

The maximum value for the pretrigger can be found in the Board.adc_max_pretrigger variable.

Parameters
pretrigger pretrigger [samples/channel]
synchronized native void telos.I2cApi.Java.Adc.setSamplingRate ( int sampling_rate )

Sets the sampling rate of the A/D converter [Hz].

Valid values for the sampling rate can be found in Board.adc_samplingrate variable.

Parameters
sampling_rate sampling rate [Hz]
synchronized native void telos.I2cApi.Java.Adc.setUseAckAsTrigger ( boolean status )

Specifies whether an I2C ACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_ack variable can be used to find out whether the used I2C interface supports the use of the ACK condition as trigger event.

Parameters
status do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.setUseErrorAsTrigger ( boolean status )

Specifies whether an I2C ERROR should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_error variable can be used to find out whether the used I2C interface supports the use of the ERROR condition as trigger event.

Parameters
status do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.setUseNackAsTrigger ( boolean status )

Specifies whether an I2C NACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_nack variable can be used to find out whether the used I2C interface supports the use of the NACK condition as trigger event.

Parameters
status do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.setUseStartAsTrigger ( boolean status )

Specifies whether an I2C start condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_start variable can be used to find out whether the used I2C interface supports the use of the start condition as trigger event.

Parameters
status do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.setUseStopAsTrigger ( boolean status )

Specifies whether an I2C stop condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_stop variable can be used to find out whether the used I2C interface supports the use of the start condition as trigger event.

Parameters
status do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.setUseTestpin1AsTrigger ( boolean status )

Specifies whether testpin 1 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_testpin1 variable can be used to find out whether the used I2C interface supports the use of testpin 1 as trigger event.

Parameters
status do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.setUseTestpin2AsTrigger ( boolean status )

Specifies whether testpin 2 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The Board.adc_trigger_testpin2 variable can be used to find out whether the used I2C interface supports the use of testpin 2 as trigger event.

Parameters
status do not use as trigger (false), use as trigger (true)
synchronized native void telos.I2cApi.Java.Adc.start ( )

Enables the A/D converter. The hardware will wait for one of the specified trigger events.

This functions works asynchronously and returns immediately to the caller.

After calling this method the program has to call transferData() until it returns an AdcData object.

synchronized native void telos.I2cApi.Java.Adc.startImmediately ( )

Enables the A/D converter. The hardware will not wait for one of the specified trigger events. Instead it starts the sampling process immediately.

This functions works asynchronously and returns immediately to the caller.

After calling this method the program has to call transferData() until it returns an AdcData object.

synchronized native AdcData telos.I2cApi.Java.Adc.transferData ( )

After starting the A/D converter using start() or startImmediately() this method returns the result. Until the result is available, this method returns null.

Returns
A/D data


I2C.Java API: Member List

  • Java
  • Adc
telos.I2cApi.Java.Adc Member List

This is the complete list of members for telos.I2cApi.Java.Adc, including all inherited members.

cancel() | telos.I2cApi.Java.Adc
getMessageCountTrigger() | telos.I2cApi.Java.Adc
getMessageDataTriggerData() | telos.I2cApi.Java.Adc
getMessageDataTriggerDontCare() | telos.I2cApi.Java.Adc
getPreTrigger() | telos.I2cApi.Java.Adc
getSamplingRate() | telos.I2cApi.Java.Adc
getUseAckAsTrigger() | telos.I2cApi.Java.Adc
getUseErrorAsTrigger() | telos.I2cApi.Java.Adc
getUseNackAsTrigger() | telos.I2cApi.Java.Adc
getUseStartAsTrigger() | telos.I2cApi.Java.Adc
getUseStopAsTrigger() | telos.I2cApi.Java.Adc
getUseTestpin1AsTrigger() | telos.I2cApi.Java.Adc
getUseTestpin2AsTrigger() | telos.I2cApi.Java.Adc
setMessageCountTrigger(byte cnt) | telos.I2cApi.Java.Adc
setMessageDataTrigger(byte[] data, byte[] dont_care) | telos.I2cApi.Java.Adc
setPreTrigger(int pretrigger) | telos.I2cApi.Java.Adc
setSamplingRate(int sampling_rate) | telos.I2cApi.Java.Adc
setUseAckAsTrigger(boolean status) | telos.I2cApi.Java.Adc
setUseErrorAsTrigger(boolean status) | telos.I2cApi.Java.Adc
setUseNackAsTrigger(boolean status) | telos.I2cApi.Java.Adc
setUseStartAsTrigger(boolean status) | telos.I2cApi.Java.Adc
setUseStopAsTrigger(boolean status) | telos.I2cApi.Java.Adc
setUseTestpin1AsTrigger(boolean status) | telos.I2cApi.Java.Adc
setUseTestpin2AsTrigger(boolean status) | telos.I2cApi.Java.Adc
start() | telos.I2cApi.Java.Adc
startImmediately() | telos.I2cApi.Java.Adc
transferData() | telos.I2cApi.Java.Adc


I2C.Java API: telos.I2cApi.Java.AdcData Class Reference

  • AdcData
Public Attributes | List of all members
telos.I2cApi.Java.AdcData Class Reference

Public Attributes

long | timestamp_start
timestamp of the first SCL/SDA sample
long | timestamp_stop
timestamp of the last SCL/SDA sample
byte[] | data_scl
all SCL samples
byte[] | data_sda
all SDA samples
byte | data_max
maximum value of SCL/SDA samples
int | sampling_rate
sampling rate
short | pretrigger
pretrigger [samples/channel]

Detailed Description

This class is used to store the data from the A/D converter. Instances of this class get passed to Adc.transferData().


I2C.Java API: Member List

  • AdcData
telos.I2cApi.Java.AdcData Member List

This is the complete list of members for telos.I2cApi.Java.AdcData, including all inherited members.

data_max | telos.I2cApi.Java.AdcData
data_scl | telos.I2cApi.Java.AdcData
data_sda | telos.I2cApi.Java.AdcData
pretrigger | telos.I2cApi.Java.AdcData
sampling_rate | telos.I2cApi.Java.AdcData
timestamp_start | telos.I2cApi.Java.AdcData
timestamp_stop | telos.I2cApi.Java.AdcData


I2C.Java API: telos.I2cApi.Java.Board Class Reference

  • Board
Classes | Public Member Functions | Public Attributes | List of all members
telos.I2cApi.Java.Board Class Reference

Classes

enum BoardType

Public Member Functions

String | getSerialNumberAsString ()
String | getBoardTypeAsString ()

Public Attributes

int | serial_number
serial number
BoardType board_type
I2C interface type (e.g. BOARD_TYPE_CONNII_MM)
int[] | master_bitrates
possible values for the master bitrate
int[] | master_bitrates_hs
possible values for the master high-speed bitrate
int[] | termination
possible values for SCL/SDA termination
int[] | i2c_vcc_supply
possible values for I2C Vcc supply
int[] | adc_samplingrate
possible sampling rates for the A/D converter
short | adc_vcc
voltage of the A/D value "255" (e.g. 5,5E3 mV) or N/A (-1)
int | adc_sampling_depth
A/D converter: sampling depth.
int | adc_max_pretrigger
A/D converter: maximum allowed pretrigger.
boolean | adc_trigger_start
A/D converter: START condition can be used as trigger event.
boolean | adc_trigger_stop
A/D converter: STOP condition can be used as trigger event.
boolean | adc_trigger_ack
A/D converter: ACK condition can be used as trigger event.
boolean | adc_trigger_nack
A/D converter: NACK condition can be used as trigger event.
boolean | adc_trigger_testpin1
A/D converter: testpin 1 can be used as trigger event.
boolean | adc_trigger_testpin2
A/D converter: testpin 2 can be used as trigger event.
boolean | adc_trigger_error
A/D converter: ERROR condition can be used as trigger event.
boolean | adc_trigger_immediately
A/D converter: can be started immediately without trigger event.
boolean | adc_trigger_msg_cnt
A/D converter: message count can be used as trigger event.
byte | adc_trigger_data
A/D converter: number of data bytes, which be can used as trigger event.
int | timestamp_timebase
timebase of the timestamps (e.g 3E6 Hz) or N/A (-1)
boolean | bus_type_smb
can be used with a SMBus?
byte[] | low_level_threshold
possible low level thresholds
byte[] | high_level_threshold
possible high level thresholds
boolean | testpin_start
START condition can trigger testpin (out)
boolean | testpin_stop
STOP condition can trigger testpin (out)
boolean | testpin_ack
ACK condition can trigger testpin (out)
boolean | testpin_error
ERROR condition can trigger testpin (out)
boolean | testpin_nack
NACK condition can trigger testpin (out)
int | testpins_in
number of input testpins
int | testpins_out
number of output testpins
boolean | master
master available?
boolean | tracer
tracer available?
boolean | adc
A/D converter available?
boolean | negative_tester
negative tester available?

Detailed Description

This class is used to store informations about one I2C interface, which has been found by I2cApi.findBoards().

Member Function Documentation

String telos.I2cApi.Java.Board.getBoardTypeAsString ( )

Returns the I2C interface type as string.

Returns
I2C interface type as string
String telos.I2cApi.Java.Board.getSerialNumberAsString ( )

Returns the serial number of an I2C interface as hex string.

Returns
serial number as hex string


I2C.Java API: Member List

  • Board
telos.I2cApi.Java.Board Member List

This is the complete list of members for telos.I2cApi.Java.Board, including all inherited members.

adc | telos.I2cApi.Java.Board
adc_max_pretrigger | telos.I2cApi.Java.Board
adc_sampling_depth | telos.I2cApi.Java.Board
adc_samplingrate | telos.I2cApi.Java.Board
adc_trigger_ack | telos.I2cApi.Java.Board
adc_trigger_data | telos.I2cApi.Java.Board
adc_trigger_error | telos.I2cApi.Java.Board
adc_trigger_immediately | telos.I2cApi.Java.Board
adc_trigger_msg_cnt | telos.I2cApi.Java.Board
adc_trigger_nack | telos.I2cApi.Java.Board
adc_trigger_start | telos.I2cApi.Java.Board
adc_trigger_stop | telos.I2cApi.Java.Board
adc_trigger_testpin1 | telos.I2cApi.Java.Board
adc_trigger_testpin2 | telos.I2cApi.Java.Board
adc_vcc | telos.I2cApi.Java.Board
board_type | telos.I2cApi.Java.Board
bus_type_smb | telos.I2cApi.Java.Board
getBoardTypeAsString() | telos.I2cApi.Java.Board
getSerialNumberAsString() | telos.I2cApi.Java.Board
high_level_threshold | telos.I2cApi.Java.Board
i2c_vcc_supply | telos.I2cApi.Java.Board
low_level_threshold | telos.I2cApi.Java.Board
master | telos.I2cApi.Java.Board
master_bitrates | telos.I2cApi.Java.Board
master_bitrates_hs | telos.I2cApi.Java.Board
negative_tester | telos.I2cApi.Java.Board
serial_number | telos.I2cApi.Java.Board
termination | telos.I2cApi.Java.Board
testpin_ack | telos.I2cApi.Java.Board
testpin_error | telos.I2cApi.Java.Board
testpin_nack | telos.I2cApi.Java.Board
testpin_start | telos.I2cApi.Java.Board
testpin_stop | telos.I2cApi.Java.Board
testpins_in | telos.I2cApi.Java.Board
testpins_out | telos.I2cApi.Java.Board
timestamp_timebase | telos.I2cApi.Java.Board
tracer | telos.I2cApi.Java.Board


I2C.Java API: telos.I2cApi.Java.Board.BoardType Enum Reference

  • Board
  • BoardType
Public Attributes | List of all members
telos.I2cApi.Java.Board.BoardType Enum Reference

Public Attributes

BOARD_TYPE_TRACII_XL
Tracii XL.
BOARD_TYPE_CONNII
Connii.
BOARD_TYPE_DUMMY
Dummy.
BOARD_TYPE_CONNII_MM
Connii MM.
BOARD_TYPE_TRACII_XL2
Tracii XL 2.0.
BOARD_TYPE_CONNII_MM2
Connii MM 2.0.

Detailed Description

Enumeration to specify the type of an I2C interface.


I2C.Java API: Member List

  • Board
  • BoardType
telos.I2cApi.Java.Board.BoardType Member List

This is the complete list of members for telos.I2cApi.Java.Board.BoardType, including all inherited members.

BOARD_TYPE_CONNII | telos.I2cApi.Java.Board.BoardType
BOARD_TYPE_CONNII_MM | telos.I2cApi.Java.Board.BoardType
BOARD_TYPE_CONNII_MM2 | telos.I2cApi.Java.Board.BoardType
BOARD_TYPE_DUMMY | telos.I2cApi.Java.Board.BoardType
BOARD_TYPE_TRACII_XL | telos.I2cApi.Java.Board.BoardType
BOARD_TYPE_TRACII_XL2 | telos.I2cApi.Java.Board.BoardType


I2C.Java API: telos.I2cApi.Java.I2cAddress Class Reference

  • I2cAddress
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
telos.I2cApi.Java.I2cAddress Class Reference

Public Member Functions

I2cAddress () throws Exception
I2cAddress (short address, boolean ten_bit_address) throws Exception
void | setAddress (short address, boolean ten_bit_address) throws Exception
short | getAddress ()
boolean | getIsTenBitAddress ()
boolean | equals (Object addr)
int | hashCode ()
java.lang.String | toString ()

Static Public Member Functions

static boolean | isValidI2cAddress (short address, boolean ten_bit_address)
static boolean | isValidSmbAddress (short address, boolean ten_bit_address)

Static Public Attributes

static final I2cAddress | GENERAL_CALL
general call I2C address
static final I2cAddress | SMBUS_HOST
SMBus host address.
static final I2cAddress | SMBUS_ALERT_RESPONSE
SMBus alert response address.
static final I2cAddress | SMBUS_DEVICE_DEFAULT
SMBus device default address.
static final I2cAddress | PMBUS_ZONE_READ
PMBus ZONE READ address.
static final I2cAddress | PMBUS_ZONE_WRITE
PMBus ZONE WRITE address.

Detailed Description

This class stores a 7 or 10 bit I2C address.

The I2C.Java API uses the I2C address format specified in the I2C standard. Some IC manufacturer use different formats in their datasheets. E.g. they specify 7 bit addresses in an 8 bit representation, where the whole address gets shifted one bit to the left.

Constructor & Destructor Documentation

telos.I2cApi.Java.I2cAddress.I2cAddress ( ) throws Exception

Constructor: the created instance contains a valid but undefined I2C address.

telos.I2cApi.Java.I2cAddress.I2cAddress | ( | short | address,
 |  | boolean | ten_bit_address
 | ) |  | throws Exception

Constructor: sets a 7 or 10 bit I2C address.

Parameters
address | I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address | 10 bit address?

Member Function Documentation

boolean telos.I2cApi.Java.I2cAddress.equals ( Object addr )

Tests whether both I2C addresses are equal.

Parameters
addr other I2C address
Returns
equal (true), not equal (false
See also
java.lang.Object::equals(java.lang.Object)
short telos.I2cApi.Java.I2cAddress.getAddress ( )

Returns the 7 or 10 bit I2C address stored in this object. To test whether the returned value specifies a 7 or 10 bit I2C address the getIsTenBitAddress() property has to be used.

Returns
address
boolean telos.I2cApi.Java.I2cAddress.getIsTenBitAddress ( )

Returns whether the value of getAddress() specifies a 7 or 10 bit I2C address.

Returns
7-bit address (false), 10-bit address (true)
int telos.I2cApi.Java.I2cAddress.hashCode ( )

Returns a hash code for this I2C address.

Returns
hash code of this I2C address
See also
java.lang.Object::hashCode()
static boolean telos.I2cApi.Java.I2cAddress.isValidI2cAddress | ( | short | address,
 |  | boolean | ten_bit_address
 | ) |  |
static

Tests whether the given I2C address is valid.

Parameters
address | I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address | 10 bit address?
static boolean telos.I2cApi.Java.I2cAddress.isValidSmbAddress | ( | short | address,
 |  | boolean | ten_bit_address
 | ) |  |
static

Tests whether the given I2C address is valid for SMBus devices.

Parameters
address | I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address | 10 bit address?
void telos.I2cApi.Java.I2cAddress.setAddress | ( | short | address,
 |  | boolean | ten_bit_address
 | ) |  | throws Exception

Sets a 7 or 10 bit I2C address to be stored in this object.

Parameters
address | I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address | 10 bit address?
java.lang.String telos.I2cApi.Java.I2cAddress.toString ( )

Returns the I2C address stored in this object as string.

Returns
I2C address
See also
java.lang.Object::toString()


I2C.Java API: Member List

  • I2cAddress
telos.I2cApi.Java.I2cAddress Member List

This is the complete list of members for telos.I2cApi.Java.I2cAddress, including all inherited members.

equals(Object addr) | telos.I2cApi.Java.I2cAddress |
GENERAL_CALL | telos.I2cApi.Java.I2cAddress | static
getAddress() | telos.I2cApi.Java.I2cAddress |
getIsTenBitAddress() | telos.I2cApi.Java.I2cAddress |
hashCode() | telos.I2cApi.Java.I2cAddress |
I2cAddress() | telos.I2cApi.Java.I2cAddress |
I2cAddress(short address, boolean ten_bit_address) | telos.I2cApi.Java.I2cAddress |
isValidI2cAddress(short address, boolean ten_bit_address) | telos.I2cApi.Java.I2cAddress | static
isValidSmbAddress(short address, boolean ten_bit_address) | telos.I2cApi.Java.I2cAddress | static
PMBUS_ZONE_READ | telos.I2cApi.Java.I2cAddress | static
PMBUS_ZONE_WRITE | telos.I2cApi.Java.I2cAddress | static
setAddress(short address, boolean ten_bit_address) | telos.I2cApi.Java.I2cAddress |
SMBUS_ALERT_RESPONSE | telos.I2cApi.Java.I2cAddress | static
SMBUS_DEVICE_DEFAULT | telos.I2cApi.Java.I2cAddress | static
SMBUS_HOST | telos.I2cApi.Java.I2cAddress | static
toString() | telos.I2cApi.Java.I2cAddress |


I2C.Java API: telos.I2cApi.Java.I2cApi Class Reference

  • I2cApi
Classes | Public Member Functions | List of all members
telos.I2cApi.Java.I2cApi Class Reference

Classes

enum | BusType
enum | I2cBusState

Public Member Functions

I2cApi ()
I2cApi (java.lang.String ip_address, int ip_port, java.lang.String password)
synchronized native void | dispose ()
synchronized native void | findBoards (java.util.Vector< Board > boards)
synchronized native void | open (Board board)
synchronized native void | close ()
synchronized native boolean | getIsOpen ()
synchronized native Board | getInfo ()
synchronized native void | setTermination (int termination)
synchronized native int | getTermination ()
synchronized native void | setLowLevelThreshold (byte level)
synchronized native byte | getLowLevelThreshold ()
synchronized native void | setHighLevelThreshold (byte level)
synchronized native byte | getHighLevelThreshold ()
synchronized native I2cBusState | getI2cState ()
synchronized native byte | getI2cBusLoad ()
synchronized native void | setBusType (BusType bus_type)
synchronized native BusType | getBusType ()
synchronized native int | getI2cVcc ()
synchronized native void | setI2cVccSupply (int i2c_vcc_supply)
synchronized native int | getI2cVccSupply ()
synchronized native void | setTestpinConfiguration (boolean start, boolean stop, boolean ack, boolean nack, boolean error)
synchronized native boolean | getTestpinConfigurationStart ()
synchronized native boolean | getTestpinConfigurationStop ()
synchronized native boolean | getTestpinConfigurationAck ()
synchronized native boolean | getTestpinConfigurationNack ()
synchronized native boolean | getTestpinConfigurationError ()
synchronized native boolean | getInputTestpin (int testpin)
synchronized native void | setOutputTestpin (int testpin, boolean level)
synchronized native boolean | getOutputTestpin (int testpin)
synchronized native void | setWatchdog (int timeout)
synchronized native int | getWatchdog ()
synchronized native void | setBitrate (int bitrate)
synchronized native int | getBitrate ()
synchronized native void | setBitrateHighspeed (int bitrate)
synchronized native int | getBitrateHighspeed ()
synchronized native void | setHighspeedMasterCode (byte master_code)
synchronized native byte | getHighspeedMasterCode ()
synchronized native void | transmit (I2cAddress address, java.util.Vector< Byte > data)
synchronized native void | transmit (I2cAddress address, byte[] data)
synchronized native void | receive (I2cAddress address, int nr_bytes, java.util.Vector< Byte > data)
synchronized native byte[] | receive (I2cAddress address, int nr_bytes)
synchronized native void | transmitReceive (I2cAddress address, java.util.Vector< Byte > tx_data, int rx_nr_bytes, java.util.Vector< Byte > rx_data)
synchronized native byte[] | transmitReceive (I2cAddress address, byte[] tx_data, int rx_nr_bytes)
synchronized native I2cAddress[] | scanAddresses (I2cAddress start, I2cAddress stop, int timeout)
synchronized native void | enableSlave (I2cAddress address, int memory_size, boolean auto_increment, short timeout_ms)
synchronized native void | disableSlave ()
synchronized native void | setSlaveData (byte[] data)
synchronized native byte[] | getSlaveData ()
synchronized native void | waitForData (int timeout_usec)
SmbMaster getSmbMaster ()
Tracer getTracer ()
Adc getAdc ()
NegativeTester getNegativeTester ()

Detailed Description

This class contains the Java API for the I2C interfaces from telos. This API can be used to write tools, which communicate with I2C slaves.

Because this API uses the JNI, only one operating system is supported: MS Windows.

To communicate with the I2C bus the following steps are necessaray:

  • Find all I2C interfaces using findBoards().
  • Open one of these I2C interfaces using open().
  • Transfer data as master transmitter or master receiver using transmit(), receive(), and transmitReceive().
  • Close the opened I2C interface using close().

If an instance of this class is no longer needed, it is very important to class dispose() manually.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.I2cApi.I2cApi ( )

Constructor

telos.I2cApi.Java.I2cApi.I2cApi | ( | java.lang.String | ip_address,
 |  | int | ip_port,
 |  | java.lang.String | password
 | ) |  |

Constructor.

Parameters
ip_address | IP address of the I2C scheduler
ip_port | TCP/IP port of the I2C scheduler
password | password of the I2C scheduler

Member Function Documentation

synchronized native void telos.I2cApi.Java.I2cApi.close ( )

Closes an I2C interface, which has been opened using the open() member function.

synchronized native void telos.I2cApi.Java.I2cApi.disableSlave ( )

Disables the I2C slave of Tracii XL 2.0.

synchronized native void telos.I2cApi.Java.I2cApi.dispose ( )

The number of connections to I2C interfaces is limited. Due to this fact it is very important to free all resources hold by an object of this class, when the object is no longer necessary. This can be fone using this function

synchronized native void telos.I2cApi.Java.I2cApi.enableSlave | ( | I2cAddress | address,
 |  | int | memory_size,
 |  | boolean | auto_increment,
 |  | short | timeout_ms
 | ) |  |

Configures and enables the I2C slave of Tracii XL 2.0.

Parameters
address | I2C address of the slave
memory_size | size size of the emulated RAM
auto_increment | auto increment: disabled (false), enabled (true)
timeout_ms | timeout [ms] or ~0 (N/A)
synchronized native void telos.I2cApi.Java.I2cApi.findBoards ( java.util.Vector< Board > boards )

Returns a list of all I2C interfaces attached to the PC.

Parameters
boards available I2C interfaces
Adc telos.I2cApi.Java.I2cApi.getAdc ( )

This function can be used to get access to the ADC functionality of the I2C interface connected to this object.

Returns
tracer object
synchronized native int telos.I2cApi.Java.I2cApi.getBitrate ( )

Gets the bitrate to be used by the I2C master.

Returns
bitrate of the I2C master
synchronized native int telos.I2cApi.Java.I2cApi.getBitrateHighspeed ( )

Gets the high-speed bitrate to be used by the I2C master.

Returns
high-speed bitrate of the I2C master
synchronized native BusType telos.I2cApi.Java.I2cApi.getBusType ( )

Some I2C interfaces supports variants of the I2C bus like e.g. the SMBus. This method can be used to get the type of the bus currently connected to the I2C interface.

Returns
bus type
synchronized native byte telos.I2cApi.Java.I2cApi.getHighLevelThreshold ( )

Gets the high level threshold.

The high level threshold defines the voltage range on SCL/SDA interpreted as logical "1".

Returns
high level threshold
synchronized native byte telos.I2cApi.Java.I2cApi.getHighspeedMasterCode ( )

Gets the high-speed master code to be used by the I2C master.

Returns
high-speed master code of the I2C master
synchronized native byte telos.I2cApi.Java.I2cApi.getI2cBusLoad ( )

Gets the load of the I2C bus.

For most I2C interfaces the tracer has to be enabled using Tracer.setEnabled() to use this functionality.

Returns
I2C bus load [%] or ~0 (N/A)
synchronized native I2cBusState telos.I2cApi.Java.I2cApi.getI2cState ( )

Returns the state of the I2C bus. This can be used to detect a hanging (more than 500 ms low) SCL and/or SDA.

Returns
state of the I2C bus
synchronized native int telos.I2cApi.Java.I2cApi.getI2cVcc ( )

Returns the Vcc voltage of the I2C bus.

Returns
Vcc of the I2C bus [mV] or ~0 (N/A)
synchronized native int telos.I2cApi.Java.I2cApi.getI2cVccSupply ( )

Returns the I2C Vcc supply voltage generated by the I2C interface.

To get the I2C Vcc voltage currently measured on the I2C interface (generated internally or externally) use getI2cVcc().

Returns
I2C Vcc supply voltage [mV]
synchronized native Board telos.I2cApi.Java.I2cApi.getInfo ( )

Gets the Board object describing the currently open I2C interface.

Returns
Board describing the currently open I2C interface
synchronized native boolean telos.I2cApi.Java.I2cApi.getInputTestpin ( int testpin )

Returns the current status of the specified input testpin.

The number of available input testpins is stored in the Board.input_testpins.

Parameters
testpin testpin to be read
Returns
level: high (true), low (false)
synchronized native boolean telos.I2cApi.Java.I2cApi.getIsOpen ( )

Tests whether an I2C interface has been opened.

Returns
open (true), closed (false)
synchronized native byte telos.I2cApi.Java.I2cApi.getLowLevelThreshold ( )

Gets the low level threshold.

The low level threshold defines the voltage range on SCL/SDA interpreted as logical "0".

Returns
low level threshold
NegativeTester telos.I2cApi.Java.I2cApi.getNegativeTester ( )

This function can be used to get access to the negative tester functionality of the I2C interface connected to this object.

Returns
negative tester object
synchronized native boolean telos.I2cApi.Java.I2cApi.getOutputTestpin ( int testpin )

Returns the configuration of the specified output testpin.

The number of available output testpins is stored in the Board.output_testpins.

Parameters
testpin testpin to be read
Returns
level: high (true), low (false)
synchronized native byte [] telos.I2cApi.Java.I2cApi.getSlaveData ( )

Gets the data, which is stored in the I2C slave of Tracii XL 2.0.

Returns
data to be set
SmbMaster telos.I2cApi.Java.I2cApi.getSmbMaster ( )

This function can be used to get access to the SMBus master functionality of the I2C interface connected to this object.

Returns
SMBus master object
synchronized native int telos.I2cApi.Java.I2cApi.getTermination ( )

Returns the value of the current termination of SCL/SDA.

Returns
termination of SCL/SDA [Ohm] or disabled (-1)
synchronized native boolean telos.I2cApi.Java.I2cApi.getTestpinConfigurationAck ( )

Returns the configuration of the output testpin. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Returns
use ACK condition as event?
synchronized native boolean telos.I2cApi.Java.I2cApi.getTestpinConfigurationError ( )

Returns the configuration of the output testpin. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Returns
use error condition as event?
synchronized native boolean telos.I2cApi.Java.I2cApi.getTestpinConfigurationNack ( )

Returns the configuration of the output testpin. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Returns
use NACK condition as event?
synchronized native boolean telos.I2cApi.Java.I2cApi.getTestpinConfigurationStart ( )

Returns the configuration of the output testpin. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Returns
use start condition as event?
synchronized native boolean telos.I2cApi.Java.I2cApi.getTestpinConfigurationStop ( )

Returns the configuration of the output testpin. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Returns
use stop condition as event?
Tracer telos.I2cApi.Java.I2cApi.getTracer ( )

This function can be used to get access to the tracer functionality of the I2C interface connected to this object.

Returns
tracer object
synchronized native int telos.I2cApi.Java.I2cApi.getWatchdog ( )

Returns the current timeout value of the watchdog.

Returns
timeout [s] or disabled (Integer.MAX_VALUE)
synchronized native void telos.I2cApi.Java.I2cApi.open ( Board board )

Opens the specified I2C interface. If the board is not longer needed, it has to be closed using close().

Parameters
board I2C interface to be opened
synchronized native void telos.I2cApi.Java.I2cApi.receive | ( | I2cAddress | address,
 |  | int | nr_bytes,
 |  | java.util.Vector< Byte > | data
 | ) |  |

Receives the given number of bytes from the slave with the given I2C address (master receiver).

Parameters
address | I2C slave address
nr_bytes | number of bytes to be read from slave
data | data read from slave
synchronized native byte [] telos.I2cApi.Java.I2cApi.receive | ( | I2cAddress | address,
 |  | int | nr_bytes
 | ) |  |

Receives the given number of bytes from the slave with the given I2C address (master receiver).

Parameters
address | I2C slave address
nr_bytes | number of bytes to be read from slave
Returns
data read from slave
synchronized native I2cAddress [] telos.I2cApi.Java.I2cApi.scanAddresses | ( | I2cAddress | start,
 |  | I2cAddress | stop,
 |  | int | timeout
 | ) |  |

Scans the I2C bus connected to the I2C interface for slaves. Therefor the method tries to read one byte from each I2C address within the specified range. The addresses of all found slaves are returned.

If the I2C bus is busy, this method tries to scan the I2C bus as long as the specified timeout has not expired.

Parameters
start | start I2C address
stop | stop I2C address
timeout | timeout for bus busy [s]
Returns
I2C addresses of found slaves
synchronized native void telos.I2cApi.Java.I2cApi.setBitrate ( int bitrate )

Sets the bitrate to be used by the I2C master.

Valid values for the bitrate can be found in the Board.master_bitrates.

Parameters
bitrate bitrate of the I2C master
synchronized native void telos.I2cApi.Java.I2cApi.setBitrateHighspeed ( int bitrate )

Sets the high-speed bitrate to be used by the I2C master.

Valid values for the bitrate can be found in the Board.master_bitrates_hs.

Parameters
bitrate high-speed bitrate of the I2C master
synchronized native void telos.I2cApi.Java.I2cApi.setBusType ( BusType bus_type )

Some I2C interfaces supports variants of the I2C bus like e.g. the SMBus. This method can be used to set the type of the bus currently connected to the I2C interface.

At the moment there are two bus types: I2C and SMB. All I2C interfaces support the I2C bus. Whether an I2C interface supports the SMBus can be determined by evaluating Board.bus_type_smb variable, which can be accessed using getInfo().

Parameters
bus_type bus type
synchronized native void telos.I2cApi.Java.I2cApi.setHighLevelThreshold ( byte level )

Sets the high level threshold.

The high level threshold defines the voltage range on SCL/SDA interpreted as logical "1".

Valid values for the high level threshold can be found in the Board.high_level_threshold variable.

Parameters
level high level threshold
synchronized native void telos.I2cApi.Java.I2cApi.setHighspeedMasterCode ( byte master_code )

Sets the high-speed master code to be used by the I2C master.

Valid values for the high-speed master code are 0x08, 0x0a, 0x0c, and 0x0e.

Parameters
master_code high-speed master code of the I2C master
synchronized native void telos.I2cApi.Java.I2cApi.setI2cVccSupply ( int i2c_vcc_supply )

Sets the I2C Vcc supply voltage.

Some I2C interfaces can supply the I2C Vcc pin. Valid values for the I2C Vcc supply voltage can be found in the Board.i2c_vcc_supply variable.

Parameters
i2c_vcc_supply I2C Vcc supply voltage [mV]
synchronized native void telos.I2cApi.Java.I2cApi.setLowLevelThreshold ( byte level )

Sets the low level threshold.

The low level threshold defines the voltage range on SCL/SDA interpreted as logical "0".

Valid values for the low level threshold can be found in the Board.low_level_threshold variable.

Parameters
level low level threshold
synchronized native void telos.I2cApi.Java.I2cApi.setOutputTestpin | ( | int | testpin,
 |  | boolean | level
 | ) |  |

Sets one of the hardware's output testpins to the specified level.

The number of available output testpins is stored in the Board.output_testpins.

Parameters
testpin | testpin to be written
level | level: high (true), low (false)
synchronized native void telos.I2cApi.Java.I2cApi.setSlaveData ( byte[] data )

Sets the data, which is stored in the I2C slave of Tracii XL 2.0.

Parameters
data data to be set
synchronized native void telos.I2cApi.Java.I2cApi.setTermination ( int termination )

Configures the termination of SCL/SDA.

Valid values for the termination can be found in the Board.termination variable.

Parameters
termination termination of SCL/SDA [Ohm] or disabled (-1)
synchronized native void telos.I2cApi.Java.I2cApi.setTestpinConfiguration | ( | boolean | start,
 |  | boolean | stop,
 |  | boolean | ack,
 |  | boolean | nack,
 |  | boolean | error
 | ) |  |

Configures the output testpin of the hardware. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Parameters
start | use start condition as event?
stop | use stop condition as event?
ack | use ack condition as event?
nack | use nack condition as event?
error | use error condition as event?
synchronized native void telos.I2cApi.Java.I2cApi.setWatchdog ( int timeout )

Enables/disables the watchdog of the master module.

If the watchdog expires during transferring data over the I2C bus, the function closes the I2C interface and throws an exception.

Under normal conditions this will never happen. This method is especially interesting for an industrial environment.

The watchdog is disabled by default (timeout is Integer.MAX_VALUE). Timeout values unequal Integer.MAX_VALUE enable the watchdog. The smallest possible timeout is 5 seconds.

Parameters
timeout timeout [s]
synchronized native void telos.I2cApi.Java.I2cApi.transmit | ( | I2cAddress | address,
 |  | java.util.Vector< Byte > | data
 | ) |  |

Sends the given data to the slave with the given I2C address via the I2C bus (master transmitter).

Parameters
address | I2C slave address
data | data to be sent
synchronized native void telos.I2cApi.Java.I2cApi.transmit | ( | I2cAddress | address,
 |  | byte[] | data
 | ) |  |

Sends the given data to the slave with the given I2C address via the I2C bus (master transmitter).

Parameters
address | I2C slave address
data | data to be sent
synchronized native void telos.I2cApi.Java.I2cApi.transmitReceive | ( | I2cAddress | address,
 |  | java.util.Vector< Byte > | tx_data,
 |  | int | rx_nr_bytes,
 |  | java.util.Vector< Byte > | rx_data
 | ) |  |

Implements the so-called combined mode. The given data is sent to the slave with the given I2C address. At the end no STOP condition is sent. Instead a REPEATED START is sent and the given number of bytes is read from the specified I2C slave.

A buffer with an adequate size to hold the data read from the slave has to be passed to this function.

Parameters
address | I2C slave address
tx_data | data to be sent to the slave
rx_nr_bytes | number of bytes to be read from slave
rx_data | data read from the slave
synchronized native byte [] telos.I2cApi.Java.I2cApi.transmitReceive | ( | I2cAddress | address,
 |  | byte[] | tx_data,
 |  | int | rx_nr_bytes
 | ) |  |

Implements the so-called combined mode. The given data is sent to the slave with the given I2C address. At the end no STOP condition is sent. Instead a REPEATED START is sent and the given number of bytes is read from the specified I2C slave.

A buffer with an adequate size to hold the data read from the slave has to be passed to this function.

Parameters
address | I2C slave address
tx_data | data to be sent to the slave
rx_nr_bytes | number of bytes to be read from slave
Returns
data read from the slave
synchronized native void telos.I2cApi.Java.I2cApi.waitForData ( int timeout_usec )

This function blocks until the API has received data from the scheduler. During this time the process sleeps and does not use CPU time.

Parameters
timeout_usec timeout [usec]


I2C.Java API: Member List

  • I2cApi
telos.I2cApi.Java.I2cApi Member List

This is the complete list of members for telos.I2cApi.Java.I2cApi, including all inherited members.

close() | telos.I2cApi.Java.I2cApi
disableSlave() | telos.I2cApi.Java.I2cApi
dispose() | telos.I2cApi.Java.I2cApi
enableSlave(I2cAddress address, int memory_size, boolean auto_increment, short timeout_ms) | telos.I2cApi.Java.I2cApi
findBoards(java.util.Vector< Board > boards) | telos.I2cApi.Java.I2cApi
getAdc() | telos.I2cApi.Java.I2cApi
getBitrate() | telos.I2cApi.Java.I2cApi
getBitrateHighspeed() | telos.I2cApi.Java.I2cApi
getBusType() | telos.I2cApi.Java.I2cApi
getHighLevelThreshold() | telos.I2cApi.Java.I2cApi
getHighspeedMasterCode() | telos.I2cApi.Java.I2cApi
getI2cBusLoad() | telos.I2cApi.Java.I2cApi
getI2cState() | telos.I2cApi.Java.I2cApi
getI2cVcc() | telos.I2cApi.Java.I2cApi
getI2cVccSupply() | telos.I2cApi.Java.I2cApi
getInfo() | telos.I2cApi.Java.I2cApi
getInputTestpin(int testpin) | telos.I2cApi.Java.I2cApi
getIsOpen() | telos.I2cApi.Java.I2cApi
getLowLevelThreshold() | telos.I2cApi.Java.I2cApi
getNegativeTester() | telos.I2cApi.Java.I2cApi
getOutputTestpin(int testpin) | telos.I2cApi.Java.I2cApi
getSlaveData() | telos.I2cApi.Java.I2cApi
getSmbMaster() | telos.I2cApi.Java.I2cApi
getTermination() | telos.I2cApi.Java.I2cApi
getTestpinConfigurationAck() | telos.I2cApi.Java.I2cApi
getTestpinConfigurationError() | telos.I2cApi.Java.I2cApi
getTestpinConfigurationNack() | telos.I2cApi.Java.I2cApi
getTestpinConfigurationStart() | telos.I2cApi.Java.I2cApi
getTestpinConfigurationStop() | telos.I2cApi.Java.I2cApi
getTracer() | telos.I2cApi.Java.I2cApi
getWatchdog() | telos.I2cApi.Java.I2cApi
I2cApi() | telos.I2cApi.Java.I2cApi
I2cApi(java.lang.String ip_address, int ip_port, java.lang.String password) | telos.I2cApi.Java.I2cApi
open(Board board) | telos.I2cApi.Java.I2cApi
receive(I2cAddress address, int nr_bytes, java.util.Vector< Byte > data) | telos.I2cApi.Java.I2cApi
receive(I2cAddress address, int nr_bytes) | telos.I2cApi.Java.I2cApi
scanAddresses(I2cAddress start, I2cAddress stop, int timeout) | telos.I2cApi.Java.I2cApi
setBitrate(int bitrate) | telos.I2cApi.Java.I2cApi
setBitrateHighspeed(int bitrate) | telos.I2cApi.Java.I2cApi
setBusType(BusType bus_type) | telos.I2cApi.Java.I2cApi
setHighLevelThreshold(byte level) | telos.I2cApi.Java.I2cApi
setHighspeedMasterCode(byte master_code) | telos.I2cApi.Java.I2cApi
setI2cVccSupply(int i2c_vcc_supply) | telos.I2cApi.Java.I2cApi
setLowLevelThreshold(byte level) | telos.I2cApi.Java.I2cApi
setOutputTestpin(int testpin, boolean level) | telos.I2cApi.Java.I2cApi
setSlaveData(byte[] data) | telos.I2cApi.Java.I2cApi
setTermination(int termination) | telos.I2cApi.Java.I2cApi
setTestpinConfiguration(boolean start, boolean stop, boolean ack, boolean nack, boolean error) | telos.I2cApi.Java.I2cApi
setWatchdog(int timeout) | telos.I2cApi.Java.I2cApi
transmit(I2cAddress address, java.util.Vector< Byte > data) | telos.I2cApi.Java.I2cApi
transmit(I2cAddress address, byte[] data) | telos.I2cApi.Java.I2cApi
transmitReceive(I2cAddress address, java.util.Vector< Byte > tx_data, int rx_nr_bytes, java.util.Vector< Byte > rx_data) | telos.I2cApi.Java.I2cApi
transmitReceive(I2cAddress address, byte[] tx_data, int rx_nr_bytes) | telos.I2cApi.Java.I2cApi
waitForData(int timeout_usec) | telos.I2cApi.Java.I2cApi


I2C.Java API: telos.I2cApi.Java.I2cApi.BusType Enum Reference

  • I2cApi
  • BusType
Public Attributes | List of all members
telos.I2cApi.Java.I2cApi.BusType Enum Reference

Public Attributes

BUS_TYPE_I2C
I2C bus.
BUS_TYPE_SMB
SMBus.

Detailed Description

Enumeration to specify the bus type.


I2C.Java API: Member List

  • I2cApi
  • BusType
telos.I2cApi.Java.I2cApi.BusType Member List

This is the complete list of members for telos.I2cApi.Java.I2cApi.BusType, including all inherited members.

BUS_TYPE_I2C | telos.I2cApi.Java.I2cApi.BusType
BUS_TYPE_SMB | telos.I2cApi.Java.I2cApi.BusType


I2C.Java API: telos.I2cApi.Java.I2cApi.I2cBusState Enum Reference

  • I2cApi
  • I2cBusState
Public Attributes | List of all members
telos.I2cApi.Java.I2cApi.I2cBusState Enum Reference

Public Attributes

I2C_BUS_STATE_UNKNOWN
the I2C interface does not support this feature
I2C_BUS_STATE_NORMAL
SCL and SDA are not low for more than 500 ms.
I2C_BUS_STATE_SCL_LOW
SCL is low for more than 500 ms.
I2C_BUS_STATE_SDA_LOW
SDA is low for more than 500 ms.
I2C_BUS_STATE_SCL_SDA_LOW
SCL and SDA are low for more than 500 ms.

Detailed Description

Enumeration to store the state of the I2C bus.


I2C.Java API: Member List

  • I2cApi
  • I2cBusState
telos.I2cApi.Java.I2cApi.I2cBusState Member List

This is the complete list of members for telos.I2cApi.Java.I2cApi.I2cBusState, including all inherited members.

I2C_BUS_STATE_NORMAL | telos.I2cApi.Java.I2cApi.I2cBusState
I2C_BUS_STATE_SCL_LOW | telos.I2cApi.Java.I2cApi.I2cBusState
I2C_BUS_STATE_SCL_SDA_LOW | telos.I2cApi.Java.I2cApi.I2cBusState
I2C_BUS_STATE_SDA_LOW | telos.I2cApi.Java.I2cApi.I2cBusState
I2C_BUS_STATE_UNKNOWN | telos.I2cApi.Java.I2cApi.I2cBusState


I2C.Java API: telos.I2cApi.Java.InputTestpins Class Reference

  • InputTestpins
Public Member Functions | List of all members
telos.I2cApi.Java.InputTestpins Class Reference

Public Member Functions

synchronized native void | setEnabled (boolean enabled)
synchronized native boolean | getEnabled ()
synchronized native
InputTestpinsMessage[] 		receiveMessages ()

Detailed Description

Some I2C interfaces contains input testpins. This class can be used to log transitions of these input testpins.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the Tracer.getInputTestpins() property.

Normally the following steps are necessary to use this class:

  1. Enable the logging functionality using the setEnabled() property.
  2. Call receiveMessages() to get messages.
  3. Disable logging functionality using the setEnabled() property.

Member Function Documentation

synchronized native boolean telos.I2cApi.Java.InputTestpins.getEnabled ( )

Gets whether the logging of the input testpins is enabled or disabled. Whenever one of the input testpins changes its status, the new status of all testpins and the timestamp of the transition get stored.

Returns
disabled (false), enabled (true)
synchronized native InputTestpinsMessage [] telos.I2cApi.Java.InputTestpins.receiveMessages ( )

Returns the stored messages.

Returns
messages
synchronized native void telos.I2cApi.Java.InputTestpins.setEnabled ( boolean enabled )

Enables or disables the logging of the input testpins. Whenever one of the input testpins changes its status, the new status of all testpins and the timestamp of the transition get stored.

Parameters
enabled disabled (false), enabled (true)


I2C.Java API: Member List

  • InputTestpins
telos.I2cApi.Java.InputTestpins Member List

This is the complete list of members for telos.I2cApi.Java.InputTestpins, including all inherited members.

getEnabled() | telos.I2cApi.Java.InputTestpins
receiveMessages() | telos.I2cApi.Java.InputTestpins
setEnabled(boolean enabled) | telos.I2cApi.Java.InputTestpins


I2C.Java API: telos.I2cApi.Java.InputTestpinsMessage Class Reference

  • InputTestpinsMessage
Public Attributes | List of all members
telos.I2cApi.Java.InputTestpinsMessage Class Reference

Public Attributes

byte | status
status after the transition
long | timestamp
timestamp of the transition
boolean | status_available
status available?

Detailed Description

Each time a InputTestpins object detects a transition of the input testpins, a message of this type gets generated. The message stores the status of the testpins after the transition and the timestamp of the transition.

The number of available input testpins can be determined using the Board.testpins_in variable. For each available input testpin one bit in the status variable is used to store the testpin level after the transition. The level of testpin 0 gets stored in bit 0 (LSB), testpin 1 in bit 1 and so on.

If status_available is "false", the status of the testpins should be considered as unknown starting from this time.


I2C.Java API: Member List

  • InputTestpinsMessage
telos.I2cApi.Java.InputTestpinsMessage Member List

This is the complete list of members for telos.I2cApi.Java.InputTestpinsMessage, including all inherited members.

status | telos.I2cApi.Java.InputTestpinsMessage
status_available | telos.I2cApi.Java.InputTestpinsMessage
timestamp | telos.I2cApi.Java.InputTestpinsMessage


I2C.Java API: telos.I2cApi.Java.NegativeTester Class Reference

  • NegativeTester
Classes | Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
telos.I2cApi.Java.NegativeTester Class Reference

Classes

class | LevelsMaster
class | LevelsSlave
class | MessageSlave
class | MessagesMaster
class | MessagesSlave
enum | NackBehaviour
enum | StopTrigger

Public Member Functions

synchronized native void | startMaster (MessagesMaster msgs)
synchronized native void | startSlave (MessagesSlave msgs)
synchronized native void | stop (boolean stop_immediately)
synchronized native boolean | getIsRunning ()

Static Public Member Functions

synchronized static native int | convertNanosecondsToTicks (long nanoseconds)
synchronized static native long | convertTicksToNanoseconds (int ticks)

Static Public Attributes

static final int TIMEBASE = 16000000
timebase: 16 MHz

Detailed Description

This class provides a negative tester.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the I2cApi.getNegativeTester() method.

Normally the following steps are necessary:

  1. Create a MessagesMaster or MessagesSlave object. This can be done manually or using the high-level interfaces NegativeTesterMaster or NegativeTesterSlave.
  2. Pass this object to the API and start the negative tester using startMaster() or startSlave().
  3. Wait until getIsRunning() returns "false".

The timebase of the times used by the negative tester is specified in TIMEBASE.

Member Function Documentation

synchronized static native int telos.I2cApi.Java.NegativeTester.convertNanosecondsToTicks ( long nanoseconds )
static

Converts a time in nanoseconds to the ticks used by this class.

Parameters
nanoseconds time [ns]
Returns
ticks
synchronized static native long telos.I2cApi.Java.NegativeTester.convertTicksToNanoseconds ( int ticks )
static

Converts the ticks used by this class to a time in nanoseconds.

Parameters
ticks ticks
Returns
time [ns]
synchronized native boolean telos.I2cApi.Java.NegativeTester.getIsRunning ( )

Returns whether the negative tester is currently running.

Returns
running (true), not running (false)
synchronized native void telos.I2cApi.Java.NegativeTester.startMaster ( MessagesMaster msgs )

Loads the given master messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterMaster.

While the negative tester is running, getIsRunning() returns "true".

Parameters
msgs messages to be sent
synchronized native void telos.I2cApi.Java.NegativeTester.startSlave ( MessagesSlave msgs )

Loads the given slave messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterSlave.

While the negative tester is running, getIsRunning() returns "true".

Parameters
msgs messages to be sent
synchronized native void telos.I2cApi.Java.NegativeTester.stop ( boolean stop_immediately )

Stops the negative tester.

If "stop_immediately" is set to "true", the negative tester stops immediately. Afterwards the I2C bus and its slave can be in an undefined state.

If it is set to "false", the negative tester stops after the current iteration of the image. This is only useful, if the the image gets executed in loop mode

Parameters
stop_immediately stop immediately


I2C.Java API: Member List

  • NegativeTester
telos.I2cApi.Java.NegativeTester Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTester, including all inherited members.

convertNanosecondsToTicks(long nanoseconds) | telos.I2cApi.Java.NegativeTester | static
convertTicksToNanoseconds(int ticks) | telos.I2cApi.Java.NegativeTester | static
getIsRunning() | telos.I2cApi.Java.NegativeTester |
startMaster(MessagesMaster msgs) | telos.I2cApi.Java.NegativeTester |
startSlave(MessagesSlave msgs) | telos.I2cApi.Java.NegativeTester |
stop(boolean stop_immediately) | telos.I2cApi.Java.NegativeTester |
TIMEBASE | telos.I2cApi.Java.NegativeTester | static


I2C.Java API: telos.I2cApi.Java.NegativeTester.LevelsMaster Class Reference

  • NegativeTester
  • LevelsMaster
Public Member Functions | Public Attributes | List of all members
telos.I2cApi.Java.NegativeTester.LevelsMaster Class Reference

Public Member Functions

LevelsMaster ()

Public Attributes

boolean | scl
level of the SCL line: high (true), low (false)
boolean | sda
level of the SDA line: high (true), low (false)
boolean | testpin1
level of the testpin1 line: high (true), low (false)
boolean | testpin2
level of the testpin1 line: high (true), low (false)
int | time
boolean | ignore_stretching
ignore clock (SCL) stretching
boolean | drive_sda
SDA line is driven by: master (true), slave (slave)
boolean | enable_high_speed_current_source
enables high-speed mode current source

Detailed Description

Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the master mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next LevelsMaster packet.

Constructor & Destructor Documentation

telos.I2cApi.Java.NegativeTester.LevelsMaster.LevelsMaster ( )

Constructor

Member Data Documentation

int telos.I2cApi.Java.NegativeTester.LevelsMaster.time

time to wait before executing next transition (see NegativeTester.TIMEBASE for the timebase)


I2C.Java API: Member List

  • NegativeTester
  • LevelsMaster
telos.I2cApi.Java.NegativeTester.LevelsMaster Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTester.LevelsMaster, including all inherited members.

drive_sda | telos.I2cApi.Java.NegativeTester.LevelsMaster
enable_high_speed_current_source | telos.I2cApi.Java.NegativeTester.LevelsMaster
ignore_stretching | telos.I2cApi.Java.NegativeTester.LevelsMaster
LevelsMaster() | telos.I2cApi.Java.NegativeTester.LevelsMaster
scl | telos.I2cApi.Java.NegativeTester.LevelsMaster
sda | telos.I2cApi.Java.NegativeTester.LevelsMaster
testpin1 | telos.I2cApi.Java.NegativeTester.LevelsMaster
testpin2 | telos.I2cApi.Java.NegativeTester.LevelsMaster
time | telos.I2cApi.Java.NegativeTester.LevelsMaster


I2C.Java API: telos.I2cApi.Java.NegativeTester.LevelsSlave Class Reference

  • NegativeTester
  • LevelsSlave
Public Attributes | List of all members
telos.I2cApi.Java.NegativeTester.LevelsSlave Class Reference

Public Attributes

boolean | scl
level of the SCL line: high (true), low (false)
boolean | sda
level of the SDA line: high (true), low (false)
boolean | testpin1
level of the testpin1 line: high (true), low (false)
boolean | testpin2
level of the testpin1 line: high (true), low (false)
int | time
boolean | drive_sda
SDA line is driven by: slave (true), master (slave)

Detailed Description

Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the slave mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next LevelsSlave packet.

Member Data Documentation

int telos.I2cApi.Java.NegativeTester.LevelsSlave.time

time to wait before executing next transition (see NegativeTester.TIMEBASE for the timebase)


I2C.Java API: Member List

  • NegativeTester
  • LevelsSlave
telos.I2cApi.Java.NegativeTester.LevelsSlave Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTester.LevelsSlave, including all inherited members.

drive_sda | telos.I2cApi.Java.NegativeTester.LevelsSlave
scl | telos.I2cApi.Java.NegativeTester.LevelsSlave
sda | telos.I2cApi.Java.NegativeTester.LevelsSlave
testpin1 | telos.I2cApi.Java.NegativeTester.LevelsSlave
testpin2 | telos.I2cApi.Java.NegativeTester.LevelsSlave
time | telos.I2cApi.Java.NegativeTester.LevelsSlave


I2C.Java API: telos.I2cApi.Java.NegativeTester.MessageSlave Class Reference

  • NegativeTester
  • MessageSlave
telos.I2cApi.Java.NegativeTester.MessageSlave Class Reference

Inherits Vector< LevelsSlave >.

Detailed Description

Contains the LevelsSlave objects for one I2C submessage (from the START condition to the next STOP or REPEATED START condition).


I2C.Java API: telos.I2cApi.Java.NegativeTester.MessagesMaster Class Reference

  • NegativeTester
  • MessagesMaster
Public Member Functions | Public Attributes | List of all members
telos.I2cApi.Java.NegativeTester.MessagesMaster Class Reference

Public Member Functions

MessagesMaster ()
synchronized native
java.lang.String 		getAsVhd ()

Public Attributes

java.util.Vector< LevelsMaster > | levels
levels to be sent to the I2C bus
short | loop_cnt
how often the levels get written to the I2C bus (0x400: infinite)
NackBehaviour nack_behaviour
behaviour of the negative tester after receiving a NACK

Detailed Description

Contains all information needed by the negative tester to work in master mode.

Constructor & Destructor Documentation

telos.I2cApi.Java.NegativeTester.MessagesMaster.MessagesMaster ( )

Constructor

Member Function Documentation

synchronized native java.lang.String telos.I2cApi.Java.NegativeTester.MessagesMaster.getAsVhd ( )

Gets the messages as VHDL stimuli (VHD).

Returns
VHDL stimuli


I2C.Java API: Member List

  • NegativeTester
  • MessagesMaster
telos.I2cApi.Java.NegativeTester.MessagesMaster Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTester.MessagesMaster, including all inherited members.

getAsVhd() | telos.I2cApi.Java.NegativeTester.MessagesMaster
levels | telos.I2cApi.Java.NegativeTester.MessagesMaster
loop_cnt | telos.I2cApi.Java.NegativeTester.MessagesMaster
MessagesMaster() | telos.I2cApi.Java.NegativeTester.MessagesMaster
nack_behaviour | telos.I2cApi.Java.NegativeTester.MessagesMaster


I2C.Java API: telos.I2cApi.Java.NegativeTester.MessagesSlave Class Reference

  • NegativeTester
  • MessagesSlave
Public Member Functions | Public Attributes | List of all members
telos.I2cApi.Java.NegativeTester.MessagesSlave Class Reference

Public Member Functions

MessagesSlave ()

Public Attributes

java.util.Vector< MessageSlave > | msgs
submessages to be sent to the I2C bus
boolean | restart_after_nack_or_stop
jump to the beginning of the first submessage after receiving a NACK or STOP?
boolean | loop
loop mode?

Detailed Description

Contains all information needed by the negative tester to work in slave mode.

Constructor & Destructor Documentation

telos.I2cApi.Java.NegativeTester.MessagesSlave.MessagesSlave ( )

Constructor


I2C.Java API: Member List

  • NegativeTester
  • MessagesSlave
telos.I2cApi.Java.NegativeTester.MessagesSlave Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTester.MessagesSlave, including all inherited members.

loop | telos.I2cApi.Java.NegativeTester.MessagesSlave
MessagesSlave() | telos.I2cApi.Java.NegativeTester.MessagesSlave
msgs | telos.I2cApi.Java.NegativeTester.MessagesSlave
restart_after_nack_or_stop | telos.I2cApi.Java.NegativeTester.MessagesSlave


I2C.Java API: telos.I2cApi.Java.NegativeTester.NackBehaviour Enum Reference

  • NegativeTester
  • NackBehaviour
Public Attributes | List of all members
telos.I2cApi.Java.NegativeTester.NackBehaviour Enum Reference

Public Attributes

NACK_RELEASE_SCL_SDA
no action, release SCL and SDA
NACK_GENERATE_STOP
generate a STOP condition with static timing
NACK_RESTART
release SCL and SDA and restart the negative tester script

Detailed Description

Enumeration to specify the behaviour after receiving a NACK on the I2C bus.


I2C.Java API: Member List

  • NegativeTester
  • NackBehaviour
telos.I2cApi.Java.NegativeTester.NackBehaviour Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTester.NackBehaviour, including all inherited members.

NACK_GENERATE_STOP | telos.I2cApi.Java.NegativeTester.NackBehaviour
NACK_RELEASE_SCL_SDA | telos.I2cApi.Java.NegativeTester.NackBehaviour
NACK_RESTART | telos.I2cApi.Java.NegativeTester.NackBehaviour


I2C.Java API: telos.I2cApi.Java.NegativeTester.StopTrigger Enum Reference

  • NegativeTester
  • StopTrigger
Public Attributes | List of all members
telos.I2cApi.Java.NegativeTester.StopTrigger Enum Reference

Public Attributes

STOP_TRIGGER_NONE
nothing stops the negative tester
STOP_TRIGGER_ARBITRATION_LOST
the negative tester stops when loosing the arbitration
STOP_TRIGGER_ARBITRATION_NOT_LOST
the negative tester stops when not loosing the arbitration

Detailed Description

Enumeration to specify trigger, which can stop the negative tester.


I2C.Java API: Member List

  • NegativeTester
  • StopTrigger
telos.I2cApi.Java.NegativeTester.StopTrigger Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTester.StopTrigger, including all inherited members.

STOP_TRIGGER_ARBITRATION_LOST | telos.I2cApi.Java.NegativeTester.StopTrigger
STOP_TRIGGER_ARBITRATION_NOT_LOST | telos.I2cApi.Java.NegativeTester.StopTrigger
STOP_TRIGGER_NONE | telos.I2cApi.Java.NegativeTester.StopTrigger


I2C.Java API: telos.I2cApi.Java.NegativeTesterMaster Class Reference

  • NegativeTesterMaster
Public Member Functions | List of all members
telos.I2cApi.Java.NegativeTesterMaster Class Reference

Public Member Functions

NegativeTesterMaster ()
synchronized native void | setBitrate (int bitrate)
synchronized native int | getBitrate ()
synchronized native void | setBitrateHighSpeed (int bitrate)
synchronized native int | getBitrateHighSpeed ()
synchronized native int | getTimeLowBeforeHigh ()
synchronized native void | setTimeLowBeforeHigh (int time)
synchronized native int | getTimeLowAfterHigh ()
synchronized native void | setTimeLowAfterHigh (int time)
synchronized native int | getTimeHigh ()
synchronized native void | setTimeHigh (int time)
synchronized native int | getTimeBuf ()
synchronized native void | setTimeBuf (int time)
synchronized native int | getTimeSuSta ()
synchronized native void | setTimeSuSta (int time)
synchronized native int | getTimeHdSta ()
synchronized native void | setTimeHdSta (int time)
synchronized native int | getTimeSuSto ()
synchronized native void | setTimeSuSto (int time)
synchronized native int | getTimeSp ()
synchronized native void | setTimeSp (int time)
synchronized native int | getTimeHighSpeedLowBeforeHigh ()
synchronized native void | setTimeHighSpeedLowBeforeHigh (int time)
synchronized native int | getTimeHighSpeedLowAfterHigh ()
synchronized native void | setTimeHighSpeedLowAfterHigh (int time)
synchronized native int | getTimeHighSpeedHigh ()
synchronized native void | setTimeHighSpeedHigh (int time)
synchronized native int | getTimeHighSpeedSuSta ()
synchronized native void | setTimeHighSpeedSuSta (int time)
synchronized native int | getTimeHighSpeedHdSta ()
synchronized native void | setTimeHighSpeedHdSta (int time)
synchronized native int | getTimeHighSpeedSuSto ()
synchronized native void | setTimeHighSpeedSuSto (int time)
synchronized native void | setIgnoreStretching (boolean stretching)
synchronized native boolean | getIgnoreStretching ()
synchronized native void | setStopAtArbitrationLost (boolean stop)
synchronized native boolean | getStopAtArbitrationLost ()
synchronized native void | setLoopCount (short cnt)
synchronized native short | getLoopCount ()
synchronized native void | setNackBehaviour (NegativeTester.NackBehaviour behaviour)
synchronized native
NegativeTester.NackBehaviour 		getNackBehaviour ()
synchronized native void | setCreateSpikes (boolean enabled)
synchronized native boolean | getCreateSpikes ()
synchronized native void | setHighSpeedToken (byte token)
synchronized native byte | getHighSpeedToken ()
synchronized native void | clear ()
synchronized native void | setTestpin1 (boolean level)
synchronized native boolean | getTestpin1 ()
synchronized native void | setTestpin2 (boolean level)
synchronized native boolean | getTestpin2 ()
synchronized native void | sendStart ()
synchronized native void | sendRepeatedStart ()
synchronized native void | sendStop ()
synchronized native void | sendRepeatedStartHighSpeed ()
synchronized native void | sendStopHighSpeed ()
synchronized native void | sendBit (boolean data)
synchronized native void | sendByte (byte data)
synchronized native void | sendAckBit ()
synchronized native void | sendNackBit ()
synchronized native void | sendBitHighSpeed (boolean data, boolean enable_current_source)
synchronized native void | sendByteHighSpeed (byte data)
synchronized native void | sendAckBitHighSpeed ()
synchronized native void | sendNackBitHighSpeed ()
synchronized native void | receiveBit ()
synchronized native void | receiveByte ()
synchronized native void | receiveAckBit (boolean ignore_nack)
synchronized native void | receiveBitHighSpeed (boolean enable_current_source)
synchronized native void | receiveByteHighSpeed ()
synchronized native void | receiveAckBitHighSpeed (boolean ignore_nack)
synchronized native void | sendTransmitterWithoutStop (boolean repeated_start, I2cAddress address, byte[] data)
synchronized native void | sendReceiverWithoutStop (boolean repeated_start, I2cAddress address, int cnt)
synchronized native void | sendHighSpeedToken ()
synchronized native void | sendTransmitterWithoutStopHighSpeed (boolean repeated_start, I2cAddress address, byte[] data)
synchronized native void | sendReceiverWithoutStopHighSpeed (boolean repeated_start, I2cAddress address, int cnt)
synchronized native void | sendTransmitter (I2cAddress address, byte[] data)
synchronized native void | sendReceiver (I2cAddress address, int cnt)
synchronized native void | sendTransmitterReceiver (I2cAddress address, byte[] tx_data, int rx_cnt)
synchronized native void | sendTransmitterHighSpeed (I2cAddress address, byte[] data)
synchronized native void | sendReceiverHighSpeed (I2cAddress address, int cnt)
synchronized native void | sendTransmitterReceiverHighSpeed (I2cAddress address, byte[] tx_data, int rx_cnt)
synchronized native void | sendSmbMasterMessage (SmbMasterMessage msg)
synchronized native void | sendPmbusMasterMessage (PmbusMasterMessage msg)
synchronized native void | sendPmbusMasterMessage (PmbusMasterMessageGroupCmd msg)
synchronized native void | delay (int time)
synchronized native
NegativeTester.MessagesMaster 		getMessages ()

Detailed Description

This class offers a high-level master interface for the negative tester implemented in the NegativeTester class.

Normally the following steps are necessary:

  1. Configure the interface:
    • Configure the bitrate using setBitrate().
    • Configure the behaviour regarding clock stretching using setIgnoreStretching().
    • Configure the behaviour regarding arbitration using setStopAtArbitrationLost().
    • Configure the loop counter using setLoopCount().
    • Configure the NACK behaviour using setNackBehaviour().
  2. Send conditions, bits, bytes, or even complete I2C messages using the "Send" and "Receive" methods.
  3. Create an object containing all transitions created by step two using getMessages().
  4. Pass this object to the NegativeTester class.

START Condition
A START condition gets transmitted like this:

SDA  High    *-----
     Low           *-----*-----
SCL  High    *-----*-----
     Low                 *-----
             |--1--|--2--|--3--|
  1. t_BUF/2 as specified by setTimeBuf().
  2. t_HD;STA as specified by setTimeHdSta().
  3. t_LOW after t_HIGH as specified by setTimeLowAfterHigh().

Repeated START Condition
A Repeated START condition gets transmitted like this:

SDA  High    *-----*-----
     Low                 *-----*-----
SCL  High          *-----*-----
     Low     *-----            *-----
             |--1--|--2--|--3--|--4--|
  1. t_LOW before t_HIGH as specified by setTimeLowBeforeHigh().
  2. t_SU;STA as specified by setTimeSuSta().
  3. t_HD;STA as specified by setTimeHdSta().
  4. t_LOW after t_HIGH as specified by setTimeLowAfterHigh().

STOP Condition
A STOP condition gets transmitted like this:

SDA  High                *-----
     Low     *-----*-----
SCL  High          *-----*-----
     Low     *-----
             |--1--|--2--|--3--|
  1. t_LOW before t_HIGH as specified by setTimeLowBeforeHigh().
  2. t_SU;STO as specified by setTimeSuSto().
  3. t_BUF/2 as specified by setTimeBuf().

Data Bits
A data bit gets transmitted like this:

SDA  High    *-----*-----*-----           SDA  High
     Low                                       Low     *-----*-----*-----
SCL  High          *-----                 SCL  High          *-----
     Low     *-----      *-----                Low     *-----      *-----
             |--1--|--2--|--3--|                       |--1--|--2--|--3--|
  1. t_LOW before t_HIGH as specified by setTimeLowBeforeHigh().
  2. t_HIGH as specified by setTimeHigh().
  3. t_LOW after t_HIGH as specified by setTimeLowAfterHigh().

The timebase of the times used by the negative tester is specified in NegativeTester.TIMEBASE.

Constructor & Destructor Documentation

telos.I2cApi.Java.NegativeTesterMaster.NegativeTesterMaster ( )

Constructor

Member Function Documentation

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.clear ( )

Clears the stored transitions and messages.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.delay ( int time )

Waits for the specified time. During this time the levels of the lines will not be changed. This can be used e.g. to add a gap between two transfers.

Parameters
time time to delay
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getBitrate ( )

Gets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Returns
bitrate
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getBitrateHighSpeed ( )

Gets the I2C high-speed bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 1 MHz.

Returns
bitrate
synchronized native boolean telos.I2cApi.Java.NegativeTesterMaster.getCreateSpikes ( )

Configures whether spikes with a length of getTimeSp() should be added to the I2C messages.

Returns
enabled (true), disabled (false)
synchronized native byte telos.I2cApi.Java.NegativeTesterMaster.getHighSpeedToken ( )

Gets the high-speed token.

Valid values are: 0x08, 0x0a, 0x0c, and 0x0e.

Returns
high-speed token
synchronized native boolean telos.I2cApi.Java.NegativeTesterMaster.getIgnoreStretching ( )

The detection of clock stretching in the hardware can be disabled. This property enables or disables the clock stretching support.

Returns
stretching enabled (true), stretching disabled (false)
synchronized native short telos.I2cApi.Java.NegativeTesterMaster.getLoopCount ( )

The loop count specifies how often the negative tester sends the NegativeTester.MessagesMaster data to the I2C bus. This property sets the loop count.

Valid values are: 1 .. 1024. The value 1024 sets the loop to infinite.

Returns
loop count
synchronized native NegativeTester.MessagesMaster telos.I2cApi.Java.NegativeTesterMaster.getMessages ( )

Returns the messages, which have been created using the "Send" and "Receive" methods of this class. This data can be passed to a NegativeTester instance.

To reset the messages use the Clear() method.

Returns
messages
synchronized native NegativeTester.NackBehaviour telos.I2cApi.Java.NegativeTesterMaster.getNackBehaviour ( )

Configures the behaviour of the negative tester after receiving a NACK on the I2C bus.

Returns
behaviour
synchronized native boolean telos.I2cApi.Java.NegativeTesterMaster.getStopAtArbitrationLost ( )

Configures whether the negative tester stops after the detection of arbitration lost. If this property is set to "false", an arbitration lost gets ignored.

Returns
stop (true), do not stop (false)
synchronized native boolean telos.I2cApi.Java.NegativeTesterMaster.getTestpin1 ( )

Sets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".

Returns
high (true), low (false);
synchronized native boolean telos.I2cApi.Java.NegativeTesterMaster.getTestpin2 ( )

Sets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".

Returns
high (true), low (false);
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeBuf ( )

Gets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHdSta ( )

Gets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHigh ( )

Gets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHighSpeedHdSta ( )

Gets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHighSpeedHigh ( )

Gets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHighSpeedLowAfterHigh ( )

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHighSpeedLowBeforeHigh ( )

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHighSpeedSuSta ( )

Gets the "set-up time repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeHighSpeedSuSto ( )

Gets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeLowAfterHigh ( )

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeLowBeforeHigh ( )

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeSp ( )

Gets the "pulse width of spikes" (t_SP) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeSuSta ( )

Gets the "set-up time repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Returns
time
synchronized native int telos.I2cApi.Java.NegativeTesterMaster.getTimeSuSto ( )

Gets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Returns
time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.receiveAckBit ( boolean ignore_nack )

Reads an ACK/NACK. It can be configured, whether the negative tester should stop after receiving a NACK.

Parameters
ignore_nack stop after NACK (false), continue after NACK (true)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.receiveAckBitHighSpeed ( boolean ignore_nack )

Reads an ACK/NACK (high-speed mode). It can be configured, whether the negative tester should stop after receiving a NACK.

Parameters
ignore_nack stop after NACK (false), continue after NACK (true)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.receiveBit ( )

Reads a data bit.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.receiveBitHighSpeed ( boolean enable_current_source )

Reads a data bit (high-speed mode).

Parameters
enable_current_source current source: enabled (true), disabled (false)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.receiveByte ( )

Reads a data byte.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.receiveByteHighSpeed ( )

Reads a data byte (high-speed mode).

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendAckBit ( )

Sends an ACK.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendAckBitHighSpeed ( )

Sends an ACK (high-speed mode).

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendBit ( boolean data )

Sends a data bit.

Parameters
data data bit: 1 (true), 0 (false)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendBitHighSpeed | ( | boolean | data,
 |  | boolean | enable_current_source
 | ) |  |

Sends a data bit (high-speed mode).

Parameters
data | data bit: 1 (true), 0 (false)
enable_current_source | current source: enabled (true), disabled (false)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendByte ( byte data )

Sends a data byte.

Parameters
data data byte
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendByteHighSpeed ( byte data )

Sends a data byte (high-speed mode).

Parameters
data data byte
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendHighSpeedToken ( )

Sends the high-speed token.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendNackBit ( )

Sends an NACK.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendNackBitHighSpeed ( )

Sends an NACK (high-speed mode).

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendPmbusMasterMessage ( PmbusMasterMessage msg )

Sends a PMBus message to the I2C slave.

Parameters
msg PMBus message
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendPmbusMasterMessage ( PmbusMasterMessageGroupCmd msg )

Sends a PMBus message to the I2C slave.

Parameters
msg PMBus message
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendReceiver | ( | I2cAddress | address,
 |  | int | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave.

Parameters
address | I2C address of the slave
cnt | number of bytes to be read
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendReceiverHighSpeed | ( | I2cAddress | address,
 |  | int | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The I2C high-speed mode is used.

Parameters
address | I2C address of the slave
cnt | number of bytes to be read
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendReceiverWithoutStop | ( | boolean | repeated_start,
 |  | I2cAddress | address,
 |  | int | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out.

Parameters
repeated_start | repeated start (true), normal start (false)
address | I2C address of the slave
cnt | number of bytes to be read
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendReceiverWithoutStopHighSpeed | ( | boolean | repeated_start,
 |  | I2cAddress | address,
 |  | int | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out. The I2C high-speed mode is used.

Parameters
repeated_start | repeated start (true), normal start (false)
address | I2C address of the slave
cnt | number of bytes to be read
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendRepeatedStart ( )

Sends a repeated start condition.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendRepeatedStartHighSpeed ( )

Sends a repeated start condition (high-speed mode).

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendSmbMasterMessage ( SmbMasterMessage msg )

Sends a SMBus message to the I2C slave.

Parameters
msg SMBus message
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendStart ( )

Sends a start condition.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendStop ( )

Sends a stop condition.

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendStopHighSpeed ( )

Sends a stop condition (high-speed mode).

synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendTransmitter | ( | I2cAddress | address,
 |  | byte[] | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message.

Parameters
address | I2C address of the slave
data | data to be transferred
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendTransmitterHighSpeed | ( | I2cAddress | address,
 |  | byte[] | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The I2C high-speed mode is used.

Parameters
address | I2C address of the slave
data | data to be transferred
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendTransmitterReceiver | ( | I2cAddress | address,
 |  | byte[] | tx_data,
 |  | int | rx_cnt
 | ) |  |

Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave.

Parameters
address | I2C address of the slave
tx_data | data to be transferred
rx_cnt | number of bytes to be read
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendTransmitterReceiverHighSpeed | ( | I2cAddress | address,
 |  | byte[] | tx_data,
 |  | int | rx_cnt
 | ) |  |

Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave. The I2C high-speed mode is used.

Parameters
address | I2C address of the slave
tx_data | data to be transferred
rx_cnt | number of bytes to be read
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendTransmitterWithoutStop | ( | boolean | repeated_start,
 |  | I2cAddress | address,
 |  | byte[] | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out.

Parameters
repeated_start | repeated start (true), normal start (false)
address | I2C address of the slave
data | data to be transferred
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.sendTransmitterWithoutStopHighSpeed | ( | boolean | repeated_start,
 |  | I2cAddress | address,
 |  | byte[] | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out. The I2C high-speed mode is used.

Parameters
repeated_start | repeated start (true), normal start (false)
address | I2C address of the slave
data | data to be transferred
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setBitrate ( int bitrate )

Sets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Parameters
bitrate bitrate
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setBitrateHighSpeed ( int bitrate )

Sets the I2C high-speed bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 1 MHz.

Parameters
bitrate bitrate
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setCreateSpikes ( boolean enabled )

Configures whether spikes with a length of getTimeSp() should be added to the I2C messages.

Parameters
enabled enabled (true), disabled (false)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setHighSpeedToken ( byte token )

Sets the high-speed token.

Valid values are: 0x08, 0x0a, 0x0c, and 0x0e.

Parameters
token high-speed token
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setIgnoreStretching ( boolean stretching )

The detection of clock stretching in the hardware can be disabled. This property enables or disables the clock stretching support.

Parameters
stretching enable stretching (true), disable stretching (false)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setLoopCount ( short cnt )

The loop count specifies how often the negative tester sends the NegativeTester.MessagesMaster data to the I2C bus. This property sets the loop count.

Valid values are: 1 .. 1024. The value 1024 sets the loop to infinite.

Parameters
cnt loop count
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setNackBehaviour ( NegativeTester.NackBehaviour behaviour )

Configures the behaviour of the negative tester after receiving a NACK on the I2C bus.

Parameters
behaviour behaviour
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setStopAtArbitrationLost ( boolean stop )

Configures whether the negative tester stops after the detection of arbitration lost. If this property is set to "false", an arbitration lost gets ignored.

Parameters
stop stop (true), do not stop (false)
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTestpin1 ( boolean level )

Sets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".

Parameters
level high (true), low (false);
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTestpin2 ( boolean level )

Sets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".

Parameters
level high (true), low (false);
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeBuf ( int time )

Sets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHdSta ( int time )

Sets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHigh ( int time )

Sets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHighSpeedHdSta ( int time )

Sets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHighSpeedHigh ( int time )

Sets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHighSpeedLowAfterHigh ( int time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHighSpeedLowBeforeHigh ( int time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHighSpeedSuSta ( int time )

Sets the "set-up time repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeHighSpeedSuSto ( int time )

Sets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeLowAfterHigh ( int time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeLowBeforeHigh ( int time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeSp ( int time )

Sets the "pulse width of spikes" (t_SP) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeSuSta ( int time )

Sets the "set-up time repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterMaster.setTimeSuSto ( int time )

Sets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time time


I2C.Java API: Member List

  • NegativeTesterMaster
telos.I2cApi.Java.NegativeTesterMaster Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTesterMaster, including all inherited members.

clear() | telos.I2cApi.Java.NegativeTesterMaster
delay(int time) | telos.I2cApi.Java.NegativeTesterMaster
getBitrate() | telos.I2cApi.Java.NegativeTesterMaster
getBitrateHighSpeed() | telos.I2cApi.Java.NegativeTesterMaster
getCreateSpikes() | telos.I2cApi.Java.NegativeTesterMaster
getHighSpeedToken() | telos.I2cApi.Java.NegativeTesterMaster
getIgnoreStretching() | telos.I2cApi.Java.NegativeTesterMaster
getLoopCount() | telos.I2cApi.Java.NegativeTesterMaster
getMessages() | telos.I2cApi.Java.NegativeTesterMaster
getNackBehaviour() | telos.I2cApi.Java.NegativeTesterMaster
getStopAtArbitrationLost() | telos.I2cApi.Java.NegativeTesterMaster
getTestpin1() | telos.I2cApi.Java.NegativeTesterMaster
getTestpin2() | telos.I2cApi.Java.NegativeTesterMaster
getTimeBuf() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHdSta() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHigh() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHighSpeedHdSta() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHighSpeedHigh() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHighSpeedLowAfterHigh() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHighSpeedLowBeforeHigh() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHighSpeedSuSta() | telos.I2cApi.Java.NegativeTesterMaster
getTimeHighSpeedSuSto() | telos.I2cApi.Java.NegativeTesterMaster
getTimeLowAfterHigh() | telos.I2cApi.Java.NegativeTesterMaster
getTimeLowBeforeHigh() | telos.I2cApi.Java.NegativeTesterMaster
getTimeSp() | telos.I2cApi.Java.NegativeTesterMaster
getTimeSuSta() | telos.I2cApi.Java.NegativeTesterMaster
getTimeSuSto() | telos.I2cApi.Java.NegativeTesterMaster
NegativeTesterMaster() | telos.I2cApi.Java.NegativeTesterMaster
receiveAckBit(boolean ignore_nack) | telos.I2cApi.Java.NegativeTesterMaster
receiveAckBitHighSpeed(boolean ignore_nack) | telos.I2cApi.Java.NegativeTesterMaster
receiveBit() | telos.I2cApi.Java.NegativeTesterMaster
receiveBitHighSpeed(boolean enable_current_source) | telos.I2cApi.Java.NegativeTesterMaster
receiveByte() | telos.I2cApi.Java.NegativeTesterMaster
receiveByteHighSpeed() | telos.I2cApi.Java.NegativeTesterMaster
sendAckBit() | telos.I2cApi.Java.NegativeTesterMaster
sendAckBitHighSpeed() | telos.I2cApi.Java.NegativeTesterMaster
sendBit(boolean data) | telos.I2cApi.Java.NegativeTesterMaster
sendBitHighSpeed(boolean data, boolean enable_current_source) | telos.I2cApi.Java.NegativeTesterMaster
sendByte(byte data) | telos.I2cApi.Java.NegativeTesterMaster
sendByteHighSpeed(byte data) | telos.I2cApi.Java.NegativeTesterMaster
sendHighSpeedToken() | telos.I2cApi.Java.NegativeTesterMaster
sendNackBit() | telos.I2cApi.Java.NegativeTesterMaster
sendNackBitHighSpeed() | telos.I2cApi.Java.NegativeTesterMaster
sendPmbusMasterMessage(PmbusMasterMessage msg) | telos.I2cApi.Java.NegativeTesterMaster
sendPmbusMasterMessage(PmbusMasterMessageGroupCmd msg) | telos.I2cApi.Java.NegativeTesterMaster
sendReceiver(I2cAddress address, int cnt) | telos.I2cApi.Java.NegativeTesterMaster
sendReceiverHighSpeed(I2cAddress address, int cnt) | telos.I2cApi.Java.NegativeTesterMaster
sendReceiverWithoutStop(boolean repeated_start, I2cAddress address, int cnt) | telos.I2cApi.Java.NegativeTesterMaster
sendReceiverWithoutStopHighSpeed(boolean repeated_start, I2cAddress address, int cnt) | telos.I2cApi.Java.NegativeTesterMaster
sendRepeatedStart() | telos.I2cApi.Java.NegativeTesterMaster
sendRepeatedStartHighSpeed() | telos.I2cApi.Java.NegativeTesterMaster
sendSmbMasterMessage(SmbMasterMessage msg) | telos.I2cApi.Java.NegativeTesterMaster
sendStart() | telos.I2cApi.Java.NegativeTesterMaster
sendStop() | telos.I2cApi.Java.NegativeTesterMaster
sendStopHighSpeed() | telos.I2cApi.Java.NegativeTesterMaster
sendTransmitter(I2cAddress address, byte[] data) | telos.I2cApi.Java.NegativeTesterMaster
sendTransmitterHighSpeed(I2cAddress address, byte[] data) | telos.I2cApi.Java.NegativeTesterMaster
sendTransmitterReceiver(I2cAddress address, byte[] tx_data, int rx_cnt) | telos.I2cApi.Java.NegativeTesterMaster
sendTransmitterReceiverHighSpeed(I2cAddress address, byte[] tx_data, int rx_cnt) | telos.I2cApi.Java.NegativeTesterMaster
sendTransmitterWithoutStop(boolean repeated_start, I2cAddress address, byte[] data) | telos.I2cApi.Java.NegativeTesterMaster
sendTransmitterWithoutStopHighSpeed(boolean repeated_start, I2cAddress address, byte[] data) | telos.I2cApi.Java.NegativeTesterMaster
setBitrate(int bitrate) | telos.I2cApi.Java.NegativeTesterMaster
setBitrateHighSpeed(int bitrate) | telos.I2cApi.Java.NegativeTesterMaster
setCreateSpikes(boolean enabled) | telos.I2cApi.Java.NegativeTesterMaster
setHighSpeedToken(byte token) | telos.I2cApi.Java.NegativeTesterMaster
setIgnoreStretching(boolean stretching) | telos.I2cApi.Java.NegativeTesterMaster
setLoopCount(short cnt) | telos.I2cApi.Java.NegativeTesterMaster
setNackBehaviour(NegativeTester.NackBehaviour behaviour) | telos.I2cApi.Java.NegativeTesterMaster
setStopAtArbitrationLost(boolean stop) | telos.I2cApi.Java.NegativeTesterMaster
setTestpin1(boolean level) | telos.I2cApi.Java.NegativeTesterMaster
setTestpin2(boolean level) | telos.I2cApi.Java.NegativeTesterMaster
setTimeBuf(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHdSta(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHigh(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHighSpeedHdSta(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHighSpeedHigh(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHighSpeedLowAfterHigh(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHighSpeedLowBeforeHigh(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHighSpeedSuSta(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeHighSpeedSuSto(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeLowAfterHigh(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeLowBeforeHigh(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeSp(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeSuSta(int time) | telos.I2cApi.Java.NegativeTesterMaster
setTimeSuSto(int time) | telos.I2cApi.Java.NegativeTesterMaster


I2C.Java API: telos.I2cApi.Java.NegativeTesterSlave Class Reference

  • NegativeTesterSlave
Public Member Functions | List of all members
telos.I2cApi.Java.NegativeTesterSlave Class Reference

Public Member Functions

NegativeTesterSlave ()
synchronized native void | clear ()
synchronized native void | setTestpin1 (boolean level)
synchronized native boolean | getTestpin1 ()
synchronized native void | setTestpin2 (boolean level)
synchronized native boolean | getTestpin2 ()
synchronized native void | setStretching (int time)
synchronized native int | getStretching ()
synchronized native void | setSlaveAddress (byte addr)
synchronized native byte | getSlaveAddress ()
synchronized native void | setSlaveAddressMask (byte addr)
synchronized native byte | getSlaveAddressMask ()
synchronized native void | setRestartAfterNackOrStop (boolean restart)
synchronized native boolean | getRestartAfterNackOrStop ()
synchronized native void | setLoopMode (boolean loop)
synchronized native boolean | getLoopMode ()
synchronized native void | createStart ()
synchronized native void | createTransmitterBit (boolean data)
synchronized native void | createTransmitterByte (byte data)
synchronized native void | createTransmitterAckBit ()
synchronized native void | createReceiverBit ()
synchronized native void | createReceiverByte ()
synchronized native void | createReceiverAckBit ()
synchronized native void | createReceiverNackBit ()
synchronized native void | createTransmitter (byte[] data)
synchronized native void | createReceiver (int cnt)
synchronized native
NegativeTester.MessagesSlave 		getMessages ()

Detailed Description

This class offers a high-level slave interface for the negative tester implemented in the NegativeTester class.

Normally the following steps are necessary:

  1. Configure the interface:
    • Configure the behaviour regarding clock stretching using setStretching().
    • Set the I2C address of the emulated slave using setSlaveAddress() and setSlaveAddressMask().
  2. Create the expected transfers using the "Create" methods.
  3. Create an object containing all transitions created by step two using getMessages().
  4. Pass this object to the NegativeTester class.

The timebase of the times used by the negative tester is specified in NegativeTester.TIMEBASE.

Constructor & Destructor Documentation

telos.I2cApi.Java.NegativeTesterSlave.NegativeTesterSlave ( )

Constructor

Member Function Documentation

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.clear ( )

Clears the stored transitions and messages.

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createReceiver ( int cnt )

Create the transitions to transfer the specified number of bytes as slave receiver.

Parameters
cnt number of bytes to be transferred
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createReceiverAckBit ( )

Creates the transitions to send an ACK as slave receiver.

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createReceiverBit ( )

Creates the transitions to transfer one data bit as slave receiver.

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createReceiverByte ( )

Creates the transitions to transfer one data byte as slave receiver.

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createReceiverNackBit ( )

Creates the transitions to send an NACK as slave receiver.

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createStart ( )

Creates the transitions to accept an I2C slave address and the following acknowledge.

This method has to be used at positions, where a START condition, an I2C address, and an acknowledge are expected.

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createTransmitter ( byte[] data )

Create the transitions to transfer the specified data as slave transmitter.

Parameters
data data to be transferred
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createTransmitterAckBit ( )

Creates the transitions to accept an ACK/NACK as slave transmitter.

synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createTransmitterBit ( boolean data )

Creates the transitions to transfer one data bit as slave transmitter.

Parameters
data bit to be transmitted
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.createTransmitterByte ( byte data )

Creates the transitions to transfer one data byte as slave transmitter.

Parameters
data byte to be transmitted
synchronized native boolean telos.I2cApi.Java.NegativeTesterSlave.getLoopMode ( )

The loop mode specifies the behaviour of the negative tester after processing the last specified submessage. It can stop the negative tester or restart with the first specified submessage.

Returns
stop (false), loop (true)
synchronized native NegativeTester.MessagesSlave telos.I2cApi.Java.NegativeTesterSlave.getMessages ( )

Returns the submessages, which have been created using the "Create" methods of this class. This data can be passed to a NegativeTester instance.

To reset the submessages use the clear() method.

Returns
submessages
synchronized native boolean telos.I2cApi.Java.NegativeTesterSlave.getRestartAfterNackOrStop ( )

If the negative tester detects a STOP condition on the I2C bus or sends a NACK as slave receiver, there are two possibilities on how to proceed: jump to the beginning of the first submessage or jump to the next submessage.

If this property is set to "true", the negative tester jumps to the first submessage.

Returns
jump to first submessage (true), jump to next submessage (true)
synchronized native byte telos.I2cApi.Java.NegativeTesterSlave.getSlaveAddress ( )

In the slave mode the negative tester is listening on an I2C slave address. This property sets/gets the I2C slave address.

Returns
I2C address
synchronized native byte telos.I2cApi.Java.NegativeTesterSlave.getSlaveAddressMask ( )

It is possible the set a don't care mask for the I2C slave address configured by setSlaveAddress(). This property contains the don't care mask.

Returns
I2C address
synchronized native int telos.I2cApi.Java.NegativeTesterSlave.getStretching ( )

Gets the stretching time. The slave will stretch the low level part of SCL to this time for each bit.

Returns
time
synchronized native boolean telos.I2cApi.Java.NegativeTesterSlave.getTestpin1 ( )

Gets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".

Returns
high (true), low (false)
synchronized native boolean telos.I2cApi.Java.NegativeTesterSlave.getTestpin2 ( )

Gets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".

Returns
high (true), low (false)
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.setLoopMode ( boolean loop )

The loop mode specifies the behaviour of the negative tester after processing the last specified submessage. It can stop the negative tester or restart with the first specified submessage.

Parameters
loop stop (false), loop (true)
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.setRestartAfterNackOrStop ( boolean restart )

If the negative tester detects a STOP condition on the I2C bus or sends a NACK as slave receiver, there are two possibilities on how to proceed: jump to the beginning of the first submessage or jump to the next submessage.

If this property is set to "true", the negative tester jumps to the first submessage.

Parameters
restart jump to first submessage (true), jump to next submessage (true)
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.setSlaveAddress ( byte addr )

In the slave mode the negative tester is listening on an I2C slave address. This property sets/gets the I2C slave address.

Parameters
addr I2C address
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.setSlaveAddressMask ( byte addr )

It is possible the set a don't care mask for the I2C slave address configured by setSlaveAddress(). This property contains the don't care mask.

Parameters
addr I2C address
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.setStretching ( int time )

Sets the stretching time. The slave will stretch the low level part of SCL to this time for each bit.

Parameters
time time
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.setTestpin1 ( boolean level )

Sets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".

Parameters
level high (true), low (false)
synchronized native void telos.I2cApi.Java.NegativeTesterSlave.setTestpin2 ( boolean level )

Sets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".

Parameters
level high (true), low (false)


I2C.Java API: Member List

  • NegativeTesterSlave
telos.I2cApi.Java.NegativeTesterSlave Member List

This is the complete list of members for telos.I2cApi.Java.NegativeTesterSlave, including all inherited members.

clear() | telos.I2cApi.Java.NegativeTesterSlave
createReceiver(int cnt) | telos.I2cApi.Java.NegativeTesterSlave
createReceiverAckBit() | telos.I2cApi.Java.NegativeTesterSlave
createReceiverBit() | telos.I2cApi.Java.NegativeTesterSlave
createReceiverByte() | telos.I2cApi.Java.NegativeTesterSlave
createReceiverNackBit() | telos.I2cApi.Java.NegativeTesterSlave
createStart() | telos.I2cApi.Java.NegativeTesterSlave
createTransmitter(byte[] data) | telos.I2cApi.Java.NegativeTesterSlave
createTransmitterAckBit() | telos.I2cApi.Java.NegativeTesterSlave
createTransmitterBit(boolean data) | telos.I2cApi.Java.NegativeTesterSlave
createTransmitterByte(byte data) | telos.I2cApi.Java.NegativeTesterSlave
getLoopMode() | telos.I2cApi.Java.NegativeTesterSlave
getMessages() | telos.I2cApi.Java.NegativeTesterSlave
getRestartAfterNackOrStop() | telos.I2cApi.Java.NegativeTesterSlave
getSlaveAddress() | telos.I2cApi.Java.NegativeTesterSlave
getSlaveAddressMask() | telos.I2cApi.Java.NegativeTesterSlave
getStretching() | telos.I2cApi.Java.NegativeTesterSlave
getTestpin1() | telos.I2cApi.Java.NegativeTesterSlave
getTestpin2() | telos.I2cApi.Java.NegativeTesterSlave
NegativeTesterSlave() | telos.I2cApi.Java.NegativeTesterSlave
setLoopMode(boolean loop) | telos.I2cApi.Java.NegativeTesterSlave
setRestartAfterNackOrStop(boolean restart) | telos.I2cApi.Java.NegativeTesterSlave
setSlaveAddress(byte addr) | telos.I2cApi.Java.NegativeTesterSlave
setSlaveAddressMask(byte addr) | telos.I2cApi.Java.NegativeTesterSlave
setStretching(int time) | telos.I2cApi.Java.NegativeTesterSlave
setTestpin1(boolean level) | telos.I2cApi.Java.NegativeTesterSlave
setTestpin2(boolean level) | telos.I2cApi.Java.NegativeTesterSlave


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessage Class Reference

  • PmbusMasterMessage
Public Member Functions | Static Public Attributes | List of all members
telos.I2cApi.Java.PmbusMasterMessage Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.PmbusMasterMessage:
telos.I2cApi.Java.PmbusMasterMessageExtCmdByte telos.I2cApi.Java.PmbusMasterMessageExtCmdWord telos.I2cApi.Java.PmbusMasterMessageReadByte telos.I2cApi.Java.PmbusMasterMessageWriteByte telos.I2cApi.Java.PmbusMasterMessageReadWord telos.I2cApi.Java.PmbusMasterMessageWriteWord

Public Member Functions

PmbusMasterMessage () throws Exception
PmbusMasterMessage (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte | getCommandExtension ()
void | setCommandExtension (byte cmd_ext)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Static Public Attributes

static final byte | PMBUS_COMMAND_EXT = (byte)0xff
command extension: PMBus
static final byte | MFR_SPECIFIC_COMMAND_EXT = (byte)0xff
command extension: manufacturer specific

Detailed Description

This class is used as a base class for the PMBus master messages supporting the "extended command" byte.

The PMBus is specified in:

PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added.

The number of commands, which is limited to 256 on the SMBus, has been extended by the introduction of the "extended command" byte.

There are different message types supporting the "extended command" byte:

  • Write Byte
  • Read Byte
  • Write Word
  • Read Word

A PMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the PMBus with the SmbMaster.transferData() method.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessage.PmbusMasterMessage ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command byte (0x00), the command extension byte (PMBUS_COMMAND_EXT), and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessage.PmbusMasterMessage | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | cmd_ext,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command byte, the command extension byte, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
cmd_ext | command extension
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

I2cAddress telos.I2cApi.Java.PmbusMasterMessage.getAddress ( )

Gets the I2C address of the slave.

Returns
I2C address of the slave
byte telos.I2cApi.Java.PmbusMasterMessage.getCommand ( )

Gets the command byte of the message.

Returns
command byte
byte telos.I2cApi.Java.PmbusMasterMessage.getCommandExtension ( )

Gets the command extension byte of the message.

Returns
command extension byte
boolean telos.I2cApi.Java.PmbusMasterMessage.getWithPec ( )

Gets whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void telos.I2cApi.Java.PmbusMasterMessage.setAddress ( I2cAddress i2c_address ) throws Exception

Sets the I2C address of the slave.

The PMBus supports only 7-bit I2C addresses.

Parameters
i2c_address I2C address of the slave
void telos.I2cApi.Java.PmbusMasterMessage.setCommand ( byte cmd )

Sets the command byte of the message.

Parameters
cmd command byte
void telos.I2cApi.Java.PmbusMasterMessage.setCommandExtension ( byte cmd_ext )

Sets the command extension byte of the message.

Parameters
cmd_ext command extension byte
void telos.I2cApi.Java.PmbusMasterMessage.setWithPec ( boolean with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • PmbusMasterMessage
telos.I2cApi.Java.PmbusMasterMessage Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessage, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessage |
getCommand() | telos.I2cApi.Java.PmbusMasterMessage |
getCommandExtension() | telos.I2cApi.Java.PmbusMasterMessage |
getWithPec() | telos.I2cApi.Java.PmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PmbusMasterMessage() | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessage(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessage |
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessage |
setCommandExtension(byte cmd_ext) | telos.I2cApi.Java.PmbusMasterMessage |
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageCmd Class Reference

  • PmbusMasterMessageCmd
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageCmd Class Reference

Public Member Functions

PmbusMasterMessageCmd () throws Exception
PmbusMasterMessageCmd (I2cAddress i2c_address, byte cmd, byte[] data) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte[] | getData ()
void | setData (byte[] data)

Detailed Description

This class contains a submessage of a "Group Command" PMBus master message. Instances of this class are stored in PmbusMasterMessageGroupCmd objects.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageCmd.PmbusMasterMessageCmd ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), and the data (empty).

telos.I2cApi.Java.PmbusMasterMessageCmd.PmbusMasterMessageCmd | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte[] | data
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, and the data.

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data

Member Function Documentation

I2cAddress telos.I2cApi.Java.PmbusMasterMessageCmd.getAddress ( )

Gets the I2C address of the slave.

Returns
I2C address of the slave
byte telos.I2cApi.Java.PmbusMasterMessageCmd.getCommand ( )

Gets the command byte of the message.

Returns
command byte
byte [] telos.I2cApi.Java.PmbusMasterMessageCmd.getData ( )

Gets the array of data bytes.

Returns
array of data bytes
void telos.I2cApi.Java.PmbusMasterMessageCmd.setAddress ( I2cAddress i2c_address ) throws Exception

Sets the I2C address of the slave.

The PMBus supports only 7-bit I2C addresses.

Parameters
i2c_address I2C address of the slave
void telos.I2cApi.Java.PmbusMasterMessageCmd.setCommand ( byte cmd )

Sets the command byte of the message.

Parameters
cmd command byte
void telos.I2cApi.Java.PmbusMasterMessageCmd.setData ( byte[] data )

Sets the array of data bytes.

Parameters
data array of data bytes


I2C.Java API: Member List

  • PmbusMasterMessageCmd
telos.I2cApi.Java.PmbusMasterMessageCmd Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageCmd, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessageCmd
getCommand() | telos.I2cApi.Java.PmbusMasterMessageCmd
getData() | telos.I2cApi.Java.PmbusMasterMessageCmd
PmbusMasterMessageCmd() | telos.I2cApi.Java.PmbusMasterMessageCmd
PmbusMasterMessageCmd(I2cAddress i2c_address, byte cmd, byte[] data) | telos.I2cApi.Java.PmbusMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessageCmd
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessageCmd
setData(byte[] data) | telos.I2cApi.Java.PmbusMasterMessageCmd


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageExtCmdByte Class Reference

  • PmbusMasterMessageExtCmdByte
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageExtCmdByte Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.PmbusMasterMessageExtCmdByte:
telos.I2cApi.Java.PmbusMasterMessage telos.I2cApi.Java.PmbusMasterMessageReadByte telos.I2cApi.Java.PmbusMasterMessageWriteByte

Public Member Functions

PmbusMasterMessageExtCmdByte () throws Exception
PmbusMasterMessageExtCmdByte (I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessage
PmbusMasterMessage () throws Exception
PmbusMasterMessage (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte | getCommandExtension ()
void | setCommandExtension (byte cmd_ext)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos.I2cApi.Java.PmbusMasterMessage
static final byte | PMBUS_COMMAND_EXT = (byte)0xff
command extension: PMBus
static final byte | MFR_SPECIFIC_COMMAND_EXT = (byte)0xff
command extension: manufacturer specific

Detailed Description

This class is used as a base class for the "Extended Command: Write Byte" and "Extended Command: Read Byte" PMBus master messages.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageExtCmdByte.PmbusMasterMessageExtCmdByte ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command byte (0x00), the command extension byte (PMBUS_COMMAND_EXT), the data byte (0x00), and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessageExtCmdByte.PmbusMasterMessageExtCmdByte | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | cmd_ext,
 |  | byte | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command byte, the command extension byte, the data byte, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
cmd_ext | command extension
data | data byte
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

byte telos.I2cApi.Java.PmbusMasterMessageExtCmdByte.getData ( )

Gets the data byte.

Returns
data byte
void telos.I2cApi.Java.PmbusMasterMessageExtCmdByte.setData ( byte data )

Sets the data byte.

Parameters
data data byte


I2C.Java API: Member List

  • PmbusMasterMessageExtCmdByte
telos.I2cApi.Java.PmbusMasterMessageExtCmdByte Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageExtCmdByte, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessage |
getCommand() | telos.I2cApi.Java.PmbusMasterMessage |
getCommandExtension() | telos.I2cApi.Java.PmbusMasterMessage |
getData() | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
getWithPec() | telos.I2cApi.Java.PmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PmbusMasterMessage() | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessage(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessageExtCmdByte() | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
PmbusMasterMessageExtCmdByte(I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessage |
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessage |
setCommandExtension(byte cmd_ext) | telos.I2cApi.Java.PmbusMasterMessage |
setData(byte data) | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageExtCmdWord Class Reference

  • PmbusMasterMessageExtCmdWord
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageExtCmdWord Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.PmbusMasterMessageExtCmdWord:
telos.I2cApi.Java.PmbusMasterMessage telos.I2cApi.Java.PmbusMasterMessageReadWord telos.I2cApi.Java.PmbusMasterMessageWriteWord

Public Member Functions

PmbusMasterMessageExtCmdWord () throws Exception
PmbusMasterMessageExtCmdWord (I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) throws Exception
short | getData ()
void | setData (short data)
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessage
PmbusMasterMessage () throws Exception
PmbusMasterMessage (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte | getCommandExtension ()
void | setCommandExtension (byte cmd_ext)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos.I2cApi.Java.PmbusMasterMessage
static final byte | PMBUS_COMMAND_EXT = (byte)0xff
command extension: PMBus
static final byte | MFR_SPECIFIC_COMMAND_EXT = (byte)0xff
command extension: manufacturer specific

Detailed Description

This class is used as a base class for the "Extended Command: Write Word" and "Extended Command: Read Word" PMBus master messages.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageExtCmdWord.PmbusMasterMessageExtCmdWord ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command byte (0x00), the command extension byte (PMBUS_COMMAND_EXT), the data word (0x0000), and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessageExtCmdWord.PmbusMasterMessageExtCmdWord | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | cmd_ext,
 |  | short | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command byte, the command extension byte, the data word, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
cmd_ext | command extension
data | data word
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

short telos.I2cApi.Java.PmbusMasterMessageExtCmdWord.getData ( )

Gets the data word.

Returns
data word
void telos.I2cApi.Java.PmbusMasterMessageExtCmdWord.setData ( short data )

Sets the data word.

Parameters
data data word


I2C.Java API: Member List

  • PmbusMasterMessageExtCmdWord
telos.I2cApi.Java.PmbusMasterMessageExtCmdWord Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageExtCmdWord, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessage |
getCommand() | telos.I2cApi.Java.PmbusMasterMessage |
getCommandExtension() | telos.I2cApi.Java.PmbusMasterMessage |
getData() | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
getWithPec() | telos.I2cApi.Java.PmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PmbusMasterMessage() | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessage(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessageExtCmdWord() | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
PmbusMasterMessageExtCmdWord(I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessage |
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessage |
setCommandExtension(byte cmd_ext) | telos.I2cApi.Java.PmbusMasterMessage |
setData(short data) | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageGroupCmd Class Reference

  • PmbusMasterMessageGroupCmd
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageGroupCmd Class Reference

Inherits Vector< PmbusMasterMessageCmd >.

Public Member Functions

PmbusMasterMessageGroupCmd ()
PmbusMasterMessageGroupCmd (java.util.Vector< PmbusMasterMessageCmd > cmds, boolean with_pec)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Detailed Description

This class specifies a "Group Command" (see section 5.2.3 in the standard) master message for the PMBus.

The PMBus is specified in:

PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added.

A PMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the PMBus with the CSmbMaster.transferData() method.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageGroupCmd.PmbusMasterMessageGroupCmd ( )

Constructor: sets the default commands (empty) and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessageGroupCmd.PmbusMasterMessageGroupCmd | ( | java.util.Vector< PmbusMasterMessageCmd > | cmds,
 |  | boolean | with_pec
 | ) |  |

Constructor: sets the commands and PEC.

Parameters
cmds | commands
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

boolean telos.I2cApi.Java.PmbusMasterMessageGroupCmd.getWithPec ( )

Gets whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void telos.I2cApi.Java.PmbusMasterMessageGroupCmd.setWithPec ( boolean with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • PmbusMasterMessageGroupCmd
telos.I2cApi.Java.PmbusMasterMessageGroupCmd Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageGroupCmd, including all inherited members.

getWithPec() | telos.I2cApi.Java.PmbusMasterMessageGroupCmd
PmbusMasterMessageGroupCmd() | telos.I2cApi.Java.PmbusMasterMessageGroupCmd
PmbusMasterMessageGroupCmd(java.util.Vector< PmbusMasterMessageCmd > cmds, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageGroupCmd
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageGroupCmd


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageReadByte Class Reference

  • PmbusMasterMessageReadByte
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageReadByte Class Reference
Inheritance diagram for telos.I2cApi.Java.PmbusMasterMessageReadByte:
telos.I2cApi.Java.PmbusMasterMessageExtCmdByte telos.I2cApi.Java.PmbusMasterMessage

Public Member Functions

PmbusMasterMessageReadByte () throws Exception
PmbusMasterMessageReadByte (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessageExtCmdByte
PmbusMasterMessageExtCmdByte () throws Exception
PmbusMasterMessageExtCmdByte (I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessage
PmbusMasterMessage () throws Exception
PmbusMasterMessage (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte | getCommandExtension ()
void | setCommandExtension (byte cmd_ext)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos.I2cApi.Java.PmbusMasterMessage
static final byte | PMBUS_COMMAND_EXT = (byte)0xff
command extension: PMBus
static final byte | MFR_SPECIFIC_COMMAND_EXT = (byte)0xff
command extension: manufacturer specific

Detailed Description

This class specifies a "Extended Command: Read Byte" (see section 5.2.4 in the standard) master message for the PMBus.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageReadByte.PmbusMasterMessageReadByte ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command byte (0x00), the command extension byte (PMBUS_COMMAND_EXT), and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessageReadByte.PmbusMasterMessageReadByte | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | cmd_ext,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command byte, the command extension byte, the data byte, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
cmd_ext | command extension
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • PmbusMasterMessageReadByte
telos.I2cApi.Java.PmbusMasterMessageReadByte Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageReadByte, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessage |
getCommand() | telos.I2cApi.Java.PmbusMasterMessage |
getCommandExtension() | telos.I2cApi.Java.PmbusMasterMessage |
getData() | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
getWithPec() | telos.I2cApi.Java.PmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PmbusMasterMessage() | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessage(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessageExtCmdByte() | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
PmbusMasterMessageExtCmdByte(I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
PmbusMasterMessageReadByte() | telos.I2cApi.Java.PmbusMasterMessageReadByte |
PmbusMasterMessageReadByte(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageReadByte |
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessage |
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessage |
setCommandExtension(byte cmd_ext) | telos.I2cApi.Java.PmbusMasterMessage |
setData(byte data) | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageReadWord Class Reference

  • PmbusMasterMessageReadWord
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageReadWord Class Reference
Inheritance diagram for telos.I2cApi.Java.PmbusMasterMessageReadWord:
telos.I2cApi.Java.PmbusMasterMessageExtCmdWord telos.I2cApi.Java.PmbusMasterMessage

Public Member Functions

PmbusMasterMessageReadWord () throws Exception
PmbusMasterMessageReadWord (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessageExtCmdWord
PmbusMasterMessageExtCmdWord () throws Exception
PmbusMasterMessageExtCmdWord (I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) throws Exception
short | getData ()
void | setData (short data)
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessage
PmbusMasterMessage () throws Exception
PmbusMasterMessage (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte | getCommandExtension ()
void | setCommandExtension (byte cmd_ext)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos.I2cApi.Java.PmbusMasterMessage
static final byte | PMBUS_COMMAND_EXT = (byte)0xff
command extension: PMBus
static final byte | MFR_SPECIFIC_COMMAND_EXT = (byte)0xff
command extension: manufacturer specific

Detailed Description

This class specifies a "Extended Command: Read Word" (see section 5.2.5 in the standard) master message for the PMBus.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageReadWord.PmbusMasterMessageReadWord ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command byte (0x00), the command extension byte (PMBUS_COMMAND_EXT), and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessageReadWord.PmbusMasterMessageReadWord | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | cmd_ext,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command byte, the command extension byte, the data byte, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
cmd_ext | command extension
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • PmbusMasterMessageReadWord
telos.I2cApi.Java.PmbusMasterMessageReadWord Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageReadWord, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessage |
getCommand() | telos.I2cApi.Java.PmbusMasterMessage |
getCommandExtension() | telos.I2cApi.Java.PmbusMasterMessage |
getData() | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
getWithPec() | telos.I2cApi.Java.PmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PmbusMasterMessage() | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessage(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessageExtCmdWord() | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
PmbusMasterMessageExtCmdWord(I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
PmbusMasterMessageReadWord() | telos.I2cApi.Java.PmbusMasterMessageReadWord |
PmbusMasterMessageReadWord(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageReadWord |
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessage |
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessage |
setCommandExtension(byte cmd_ext) | telos.I2cApi.Java.PmbusMasterMessage |
setData(short data) | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageWriteByte Class Reference

  • PmbusMasterMessageWriteByte
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageWriteByte Class Reference
Inheritance diagram for telos.I2cApi.Java.PmbusMasterMessageWriteByte:
telos.I2cApi.Java.PmbusMasterMessageExtCmdByte telos.I2cApi.Java.PmbusMasterMessage

Public Member Functions

PmbusMasterMessageWriteByte () throws Exception
PmbusMasterMessageWriteByte (I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessageExtCmdByte
PmbusMasterMessageExtCmdByte () throws Exception
PmbusMasterMessageExtCmdByte (I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessage
PmbusMasterMessage () throws Exception
PmbusMasterMessage (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte | getCommandExtension ()
void | setCommandExtension (byte cmd_ext)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos.I2cApi.Java.PmbusMasterMessage
static final byte | PMBUS_COMMAND_EXT = (byte)0xff
command extension: PMBus
static final byte | MFR_SPECIFIC_COMMAND_EXT = (byte)0xff
command extension: manufacturer specific

Detailed Description

This class specifies a "Extended Command: Write Byte" (see section 5.2.4 in the standard) master message for the PMBus.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageWriteByte.PmbusMasterMessageWriteByte ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command byte (0x00), the command extension byte (PMBUS_COMMAND_EXT), the data byte (0x00), and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessageWriteByte.PmbusMasterMessageWriteByte | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | cmd_ext,
 |  | byte | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command byte, the command extension byte, the data byte, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
cmd_ext | command extension
data | data byte
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • PmbusMasterMessageWriteByte
telos.I2cApi.Java.PmbusMasterMessageWriteByte Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageWriteByte, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessage |
getCommand() | telos.I2cApi.Java.PmbusMasterMessage |
getCommandExtension() | telos.I2cApi.Java.PmbusMasterMessage |
getData() | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
getWithPec() | telos.I2cApi.Java.PmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PmbusMasterMessage() | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessage(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessageExtCmdByte() | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
PmbusMasterMessageExtCmdByte(I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
PmbusMasterMessageWriteByte() | telos.I2cApi.Java.PmbusMasterMessageWriteByte |
PmbusMasterMessageWriteByte(I2cAddress i2c_address, byte cmd, byte cmd_ext, byte data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageWriteByte |
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessage |
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessage |
setCommandExtension(byte cmd_ext) | telos.I2cApi.Java.PmbusMasterMessage |
setData(byte data) | telos.I2cApi.Java.PmbusMasterMessageExtCmdByte |
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |


I2C.Java API: telos.I2cApi.Java.PmbusMasterMessageWriteWord Class Reference

  • PmbusMasterMessageWriteWord
Public Member Functions | List of all members
telos.I2cApi.Java.PmbusMasterMessageWriteWord Class Reference
Inheritance diagram for telos.I2cApi.Java.PmbusMasterMessageWriteWord:
telos.I2cApi.Java.PmbusMasterMessageExtCmdWord telos.I2cApi.Java.PmbusMasterMessage

Public Member Functions

PmbusMasterMessageWriteWord () throws Exception
PmbusMasterMessageWriteWord (I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessageExtCmdWord
PmbusMasterMessageExtCmdWord () throws Exception
PmbusMasterMessageExtCmdWord (I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) throws Exception
short | getData ()
void | setData (short data)
- Public Member Functions inherited from telos.I2cApi.Java.PmbusMasterMessage
PmbusMasterMessage () throws Exception
PmbusMasterMessage (I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
byte | getCommandExtension ()
void | setCommandExtension (byte cmd_ext)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos.I2cApi.Java.PmbusMasterMessage
static final byte | PMBUS_COMMAND_EXT = (byte)0xff
command extension: PMBus
static final byte | MFR_SPECIFIC_COMMAND_EXT = (byte)0xff
command extension: manufacturer specific

Detailed Description

This class specifies a "Extended Command: Write Word" (see section 5.2.5 in the standard) master message for the PMBus.

Constructor & Destructor Documentation

telos.I2cApi.Java.PmbusMasterMessageWriteWord.PmbusMasterMessageWriteWord ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command byte (0x00), the command extension byte (PMBUS_COMMAND_EXT), the data word (0x0000), and PEC (disabled).

telos.I2cApi.Java.PmbusMasterMessageWriteWord.PmbusMasterMessageWriteWord | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | cmd_ext,
 |  | short | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command byte, the command extension byte, the data word, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
cmd_ext | command extension
data | data word
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • PmbusMasterMessageWriteWord
telos.I2cApi.Java.PmbusMasterMessageWriteWord Member List

This is the complete list of members for telos.I2cApi.Java.PmbusMasterMessageWriteWord, including all inherited members.

getAddress() | telos.I2cApi.Java.PmbusMasterMessage |
getCommand() | telos.I2cApi.Java.PmbusMasterMessage |
getCommandExtension() | telos.I2cApi.Java.PmbusMasterMessage |
getData() | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
getWithPec() | telos.I2cApi.Java.PmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos.I2cApi.Java.PmbusMasterMessage | static
PmbusMasterMessage() | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessage(I2cAddress i2c_address, byte cmd, byte cmd_ext, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |
PmbusMasterMessageExtCmdWord() | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
PmbusMasterMessageExtCmdWord(I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
PmbusMasterMessageWriteWord() | telos.I2cApi.Java.PmbusMasterMessageWriteWord |
PmbusMasterMessageWriteWord(I2cAddress i2c_address, byte cmd, byte cmd_ext, short data, boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessageWriteWord |
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.PmbusMasterMessage |
setCommand(byte cmd) | telos.I2cApi.Java.PmbusMasterMessage |
setCommandExtension(byte cmd_ext) | telos.I2cApi.Java.PmbusMasterMessage |
setData(short data) | telos.I2cApi.Java.PmbusMasterMessageExtCmdWord |
setWithPec(boolean with_pec) | telos.I2cApi.Java.PmbusMasterMessage |


I2C.Java API: telos.I2cApi.Java.SmbArpMaster Class Reference

  • SmbArpMaster
Classes | Public Member Functions | List of all members
telos.I2cApi.Java.SmbArpMaster Class Reference

Classes

class Udid

Public Member Functions

SmbArpMaster (I2cApi i2c_api)
synchronized native void | prepareToArp ()
synchronized native void | resetDevice ()
synchronized native void | getUdid (Udid udid)
synchronized native void | assignAddress (Udid udid, I2cAddress addr)
synchronized native void | getUdid (I2cAddress addr, Udid udid)
synchronized native void | resetDevice (I2cAddress addr)
synchronized native Udid[] | executeArp (I2cAddress[] reserved_addr)

Detailed Description

This class implements the SMBus address resolution protocol (ARP).

The SMBus is specified in:

System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Normally only the executeArp() method has to be used. This method assigns I2C addresses to all found slave devices.

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbArpMaster.SmbArpMaster ( I2cApi i2c_api )

Constructor

Parameters
i2c_api I2cApi instance

Member Function Documentation

synchronized native void telos.I2cApi.Java.SmbArpMaster.assignAddress | ( | Udid | udid,
 |  | I2cAddress | addr
 | ) |  |

Sends a SMBus "Assign Address" command.

Parameters
udid | UDID of the slave device
addr | I2C address to be assigned to the slave device
synchronized native Udid [] telos.I2cApi.Java.SmbArpMaster.executeArp ( I2cAddress[] reserved_addr )

This method executes the complete ARP process. After sending "Prepare to ARP" to the SMBus, this method assigns an I2C address to each found slave device.

If there are slave devices on the SMBus, which do not support the ARP protocol, their I2C address must be added to the reserved_addr parameter.

Parameters
reserved_addr I2C addresses, which cannot be assigned to ARP slaves
Returns
UDID informations of the found slave devices
synchronized native void telos.I2cApi.Java.SmbArpMaster.getUdid ( Udid udid )

Sends a SMBus "Get UDID (General)" command.

Parameters
udid read UDID
synchronized native void telos.I2cApi.Java.SmbArpMaster.getUdid | ( | I2cAddress | addr,
 |  | Udid | udid
 | ) |  |

Sends a SMBus "Get UDID (Directed)" command.

Parameters
addr | I2C address of the slave device to be queried
udid | read UDID
synchronized native void telos.I2cApi.Java.SmbArpMaster.prepareToArp ( )

Sends a SMBus "Prepare to ARP" command.

synchronized native void telos.I2cApi.Java.SmbArpMaster.resetDevice ( )

Sends a SMBus "Reset Device (General)" command.

synchronized native void telos.I2cApi.Java.SmbArpMaster.resetDevice ( I2cAddress addr )

Sends a SMBus "Reset Device ARP (Directed)" command.

Parameters
addr I2C address of the the slave device


I2C.Java API: Member List

  • SmbArpMaster
telos.I2cApi.Java.SmbArpMaster Member List

This is the complete list of members for telos.I2cApi.Java.SmbArpMaster, including all inherited members.

assignAddress(Udid udid, I2cAddress addr) | telos.I2cApi.Java.SmbArpMaster
executeArp(I2cAddress[] reserved_addr) | telos.I2cApi.Java.SmbArpMaster
getUdid(Udid udid) | telos.I2cApi.Java.SmbArpMaster
getUdid(I2cAddress addr, Udid udid) | telos.I2cApi.Java.SmbArpMaster
prepareToArp() | telos.I2cApi.Java.SmbArpMaster
resetDevice() | telos.I2cApi.Java.SmbArpMaster
resetDevice(I2cAddress addr) | telos.I2cApi.Java.SmbArpMaster
SmbArpMaster(I2cApi i2c_api) | telos.I2cApi.Java.SmbArpMaster


I2C.Java API: telos.I2cApi.Java.SmbArpMaster.Udid Class Reference

  • SmbArpMaster
  • Udid
Classes | Public Member Functions | Public Attributes | List of all members
telos.I2cApi.Java.SmbArpMaster.Udid Class Reference

Classes

enum AddressType

Public Member Functions

Udid ()
AddressType getAddressType ()
boolean | getPecSupport ()
byte | getUdidVersion ()
byte | getSiliconRevision ()
short | getVendorId ()
short | getDeviceId ()
boolean | getZoneSupport ()
boolean | getIpmiSupport ()
boolean | getAsfSupport ()
boolean | getOemSupport ()
byte | getSmbusVersion ()
short | getSubsystemVendorId ()
short | getSubsystemDeviceId ()
int | getVendorSpecificId ()
boolean | isAddressAvailable ()
I2cAddress | getAddress () throws Exception
void | setAddress (I2cAddress address)

Public Attributes

byte | raw []
raw UDID bytes as used on the SMBus
byte | addr
raw "device slave addr" as used on the SMBus

Detailed Description

Each SMBus slave device supporting ARP has got an UDID.

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbArpMaster.Udid.Udid ( )

Constructor

Member Function Documentation

I2cAddress telos.I2cApi.Java.SmbArpMaster.Udid.getAddress ( ) throws Exception

Returns the I2C address of the slave device.

Returns
I2C slave address
AddressType telos.I2cApi.Java.SmbArpMaster.Udid.getAddressType ( )

Returns the "Address Type".

Returns
"Address Type"
boolean telos.I2cApi.Java.SmbArpMaster.Udid.getAsfSupport ( )

Returns "ASF Support".

Returns
"ASF Support"
short telos.I2cApi.Java.SmbArpMaster.Udid.getDeviceId ( )

Returns the "Device ID".

Returns
"Device ID"
boolean telos.I2cApi.Java.SmbArpMaster.Udid.getIpmiSupport ( )

Returns "IPMI Support".

Returns
"IPMI Support"
boolean telos.I2cApi.Java.SmbArpMaster.Udid.getOemSupport ( )

Returns "OEM Support".

Returns
"OEM Support"
boolean telos.I2cApi.Java.SmbArpMaster.Udid.getPecSupport ( )

Returns "PEC Supported".

Returns
"PEC Supported"
byte telos.I2cApi.Java.SmbArpMaster.Udid.getSiliconRevision ( )

Returns the "Silicon Revision ID".

Returns
"Silicon Revision ID"
byte telos.I2cApi.Java.SmbArpMaster.Udid.getSmbusVersion ( )

Returns the "SMBus Version".

Returns
"SMBus Version"
short telos.I2cApi.Java.SmbArpMaster.Udid.getSubsystemDeviceId ( )

Returns the "Subsystem Device ID".

Returns
"Subsystem Device ID"
short telos.I2cApi.Java.SmbArpMaster.Udid.getSubsystemVendorId ( )

Returns the "Subsystem Vendor ID".

Returns
"Subsystem Vendor ID"
byte telos.I2cApi.Java.SmbArpMaster.Udid.getUdidVersion ( )

Returns the "UDID Version".

Returns
"UDID Version"
short telos.I2cApi.Java.SmbArpMaster.Udid.getVendorId ( )

Returns the "Vendor ID".

Returns
"Vendor ID"
int telos.I2cApi.Java.SmbArpMaster.Udid.getVendorSpecificId ( )

Returns the "Vendor Specific ID".

Returns
"Vendor Specific ID"
boolean telos.I2cApi.Java.SmbArpMaster.Udid.getZoneSupport ( )

Returns "ZONE Support".

Returns
"ZONE Support"
boolean telos.I2cApi.Java.SmbArpMaster.Udid.isAddressAvailable ( )

Tests whether the slave device has got an I2C address.

Returns
I2C address available (true), I2C address not available (false)
void telos.I2cApi.Java.SmbArpMaster.Udid.setAddress ( I2cAddress address )

Sets the I2C address of the slave device.

Parameters
address I2C slave address


I2C.Java API: Member List

  • SmbArpMaster
  • Udid
telos.I2cApi.Java.SmbArpMaster.Udid Member List

This is the complete list of members for telos.I2cApi.Java.SmbArpMaster.Udid, including all inherited members.

addr | telos.I2cApi.Java.SmbArpMaster.Udid
getAddress() | telos.I2cApi.Java.SmbArpMaster.Udid
getAddressType() | telos.I2cApi.Java.SmbArpMaster.Udid
getAsfSupport() | telos.I2cApi.Java.SmbArpMaster.Udid
getDeviceId() | telos.I2cApi.Java.SmbArpMaster.Udid
getIpmiSupport() | telos.I2cApi.Java.SmbArpMaster.Udid
getOemSupport() | telos.I2cApi.Java.SmbArpMaster.Udid
getPecSupport() | telos.I2cApi.Java.SmbArpMaster.Udid
getSiliconRevision() | telos.I2cApi.Java.SmbArpMaster.Udid
getSmbusVersion() | telos.I2cApi.Java.SmbArpMaster.Udid
getSubsystemDeviceId() | telos.I2cApi.Java.SmbArpMaster.Udid
getSubsystemVendorId() | telos.I2cApi.Java.SmbArpMaster.Udid
getUdidVersion() | telos.I2cApi.Java.SmbArpMaster.Udid
getVendorId() | telos.I2cApi.Java.SmbArpMaster.Udid
getVendorSpecificId() | telos.I2cApi.Java.SmbArpMaster.Udid
getZoneSupport() | telos.I2cApi.Java.SmbArpMaster.Udid
isAddressAvailable() | telos.I2cApi.Java.SmbArpMaster.Udid
raw | telos.I2cApi.Java.SmbArpMaster.Udid
setAddress(I2cAddress address) | telos.I2cApi.Java.SmbArpMaster.Udid
Udid() | telos.I2cApi.Java.SmbArpMaster.Udid


I2C.Java API: telos.I2cApi.Java.SmbArpMaster.Udid.AddressType Enum Reference

  • SmbArpMaster
  • Udid
  • AddressType
Public Attributes | List of all members
telos.I2cApi.Java.SmbArpMaster.Udid.AddressType Enum Reference

Public Attributes

ADDR_TYPE_FIXED
fixed address device
ADDR_TYPE_DYNAMIC_PERSISTENT
dynamic and persistent address device
ADDR_TYPE_DYNAMIC_VOLATILE
dynamic and volatile address device
ADDR_TYPE_RANDOM
random number device

Detailed Description

This enumeration specifies the I2C address type used by a slave device.


I2C.Java API: Member List

  • SmbArpMaster
  • Udid
  • AddressType
telos.I2cApi.Java.SmbArpMaster.Udid.AddressType Member List

This is the complete list of members for telos.I2cApi.Java.SmbArpMaster.Udid.AddressType, including all inherited members.

ADDR_TYPE_DYNAMIC_PERSISTENT | telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
ADDR_TYPE_DYNAMIC_VOLATILE | telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
ADDR_TYPE_FIXED | telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
ADDR_TYPE_RANDOM | telos.I2cApi.Java.SmbArpMaster.Udid.AddressType


I2C.Java API: telos.I2cApi.Java.SmbMaster Class Reference

  • SmbMaster
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMaster Class Reference

Public Member Functions

synchronized native void | transferData (SmbMasterMessageQuickCommand msg)
synchronized native void | transferData (SmbMasterMessageSendByte msg)
synchronized native void | transferData (SmbMasterMessageReceiveByte msg)
synchronized native void | transferData (SmbMasterMessageWriteByte msg)
synchronized native void | transferData (SmbMasterMessageReadByte msg)
synchronized native void | transferData (SmbMasterMessageWriteWord msg)
synchronized native void | transferData (SmbMasterMessageReadWord msg)
synchronized native void | transferData (SmbMasterMessageWrite32 msg)
synchronized native void | transferData (SmbMasterMessageRead32 msg)
synchronized native void | transferData (SmbMasterMessageWrite64 msg)
synchronized native void | transferData (SmbMasterMessageRead64 msg)
synchronized native void | transferData (SmbMasterMessageCmdProcessCall msg)
synchronized native void | transferData (SmbMasterMessageBlockWrite msg)
synchronized native void | transferData (SmbMasterMessageBlockRead msg)
synchronized native void | transferData (SmbMasterMessageBlockWriteRead msg)
synchronized native void | transferData (SmbMasterMessageHostNotify msg)
void | transferData (SmbMasterMessage msg)
synchronized native void | transferData (PmbusMasterMessageWriteByte msg)
synchronized native void | transferData (PmbusMasterMessageReadByte msg)
synchronized native void | transferData (PmbusMasterMessageWriteWord msg)
synchronized native void | transferData (PmbusMasterMessageReadWord msg)
synchronized native void | transferData (PmbusMasterMessageGroupCmd msg)
void | transferData (PmbusMasterMessage msg)
synchronized native I2cAddress[] | getPendingAlerts (boolean ignore_alert_pin)

Detailed Description

This class can be used to send master messages to a SMBus and a PMBus.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the I2cApi.getSmbMaster() property.

The SMBus is specified in:

System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Different message types are defined by the SMBus:

  • Quick Command
  • Send Byte
  • Receive Byte
  • Write Byte
  • Read Byte
  • Write Word
  • Read Word
  • Write 32
  • Read 32
  • Write 64
  • Read 64
  • Process Call
  • Block Write
  • Block Read
  • Block Write - Block Read Process Call

A SMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

The PMBus is specified in:

PMBus
Revision 1.0
28 March 2005
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added:

  • Write Byte (with extension code)
  • Read Byte (with extension code)
  • Write Word (with extension code)
  • Read Word (with extension code)
  • Group Command
Author
telos Systementwicklung GmbH

Member Function Documentation

synchronized native I2cAddress [] telos.I2cApi.Java.SmbMaster.getPendingAlerts ( boolean ignore_alert_pin )

If at least one SMBus slave has pulled the SMBALERT line to low, this method sends "Alert Response" messages to get a list of devices in alert state (see section A.2 in the standard).

Parameters
ignore_alert_pin use SMBALERT line (false), ignore SMBALERT line (true)
Returns
devices in alert state
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageQuickCommand msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageSendByte msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageReceiveByte msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageWriteByte msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageReadByte msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageWriteWord msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageReadWord msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageWrite32 msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageRead32 msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageWrite64 msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageRead64 msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageCmdProcessCall msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageBlockWrite msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageBlockRead msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageBlockWriteRead msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessageHostNotify msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
void telos.I2cApi.Java.SmbMaster.transferData ( SmbMasterMessage msg )

Sends a master message to the SMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( PmbusMasterMessageWriteByte msg )

Sends a master message to the PMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( PmbusMasterMessageReadByte msg )

Sends a master message to the PMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( PmbusMasterMessageWriteWord msg )

Sends a master message to the PMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( PmbusMasterMessageReadWord msg )

Sends a master message to the PMBus.

Parameters
msg master message to be sent
synchronized native void telos.I2cApi.Java.SmbMaster.transferData ( PmbusMasterMessageGroupCmd msg )

Sends a master message to the PMBus.

Parameters
msg master message to be sent
void telos.I2cApi.Java.SmbMaster.transferData ( PmbusMasterMessage msg )

Sends a master message to the PMBus.

Parameters
msg master message to be sent


I2C.Java API: Member List

  • SmbMaster
telos.I2cApi.Java.SmbMaster Member List

This is the complete list of members for telos.I2cApi.Java.SmbMaster, including all inherited members.

getPendingAlerts(boolean ignore_alert_pin) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageQuickCommand msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageSendByte msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageReceiveByte msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageWriteByte msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageReadByte msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageWriteWord msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageReadWord msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageWrite32 msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageRead32 msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageWrite64 msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageRead64 msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageCmdProcessCall msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageBlockWrite msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageBlockRead msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageBlockWriteRead msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessageHostNotify msg) | telos.I2cApi.Java.SmbMaster
transferData(SmbMasterMessage msg) | telos.I2cApi.Java.SmbMaster
transferData(PmbusMasterMessageWriteByte msg) | telos.I2cApi.Java.SmbMaster
transferData(PmbusMasterMessageReadByte msg) | telos.I2cApi.Java.SmbMaster
transferData(PmbusMasterMessageWriteWord msg) | telos.I2cApi.Java.SmbMaster
transferData(PmbusMasterMessageReadWord msg) | telos.I2cApi.Java.SmbMaster
transferData(PmbusMasterMessageGroupCmd msg) | telos.I2cApi.Java.SmbMaster
transferData(PmbusMasterMessage msg) | telos.I2cApi.Java.SmbMaster


I2C.Java API: telos.I2cApi.Java.SmbMasterMessage Class Reference

  • SmbMasterMessage
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessage Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessage:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessageHostNotify telos.I2cApi.Java.SmbMasterMessageQuickCommand telos.I2cApi.Java.SmbMasterMessageReceiveByte telos.I2cApi.Java.SmbMasterMessageSendByte telos.I2cApi.Java.SmbMasterMessageBlockWriteRead telos.I2cApi.Java.SmbMasterMessageCmd32 telos.I2cApi.Java.SmbMasterMessageCmd64 telos.I2cApi.Java.SmbMasterMessageCmdBlock telos.I2cApi.Java.SmbMasterMessageCmdByte telos.I2cApi.Java.SmbMasterMessageCmdProcessCall telos.I2cApi.Java.SmbMasterMessageCmdWord telos.I2cApi.Java.SmbMasterMessageRead32 telos.I2cApi.Java.SmbMasterMessageWrite32 telos.I2cApi.Java.SmbMasterMessageRead64 telos.I2cApi.Java.SmbMasterMessageWrite64 telos.I2cApi.Java.SmbMasterMessageBlockRead telos.I2cApi.Java.SmbMasterMessageBlockWrite telos.I2cApi.Java.SmbMasterMessageReadByte telos.I2cApi.Java.SmbMasterMessageWriteByte telos.I2cApi.Java.SmbMasterMessageReadWord telos.I2cApi.Java.SmbMasterMessageWriteWord

Public Member Functions

SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class is used as a base class for all SMBus master messages.

The SMBus is specified in:

System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Different message types are defined by the SMBus:

  • Quick Command
  • Send Byte
  • Receive Byte
  • Write Byte
  • Read Byte
  • Write Word
  • Read Word
  • Write 32
  • Read 32
  • Write 64
  • Read 64
  • Process Call
  • Block Write
  • Block Read
  • Block Write - Block Read Process Call

A SMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the SMBus with the SmbMaster.transferData() method.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessage.SmbMasterMessage ( ) throws Exception

Constructs: sets the default I2C address (0x50).

telos.I2cApi.Java.SmbMasterMessage.SmbMasterMessage ( I2cAddress i2c_address ) throws Exception

Constructs: sets the I2C address.

Parameters
i2c_address I2C address of the slave

Member Function Documentation

I2cAddress telos.I2cApi.Java.SmbMasterMessage.getAddress ( )

Gets the I2C address of the slave.

Returns
I2C address of the slave
void telos.I2cApi.Java.SmbMasterMessage.setAddress ( I2cAddress i2c_address ) throws Exception

Sets the I2C address of the slave.

The SMBus supports only 7-bit I2C addresses.

Parameters
i2c_address I2C address of the slave


I2C.Java API: Member List

  • SmbMasterMessage
telos.I2cApi.Java.SmbMasterMessage Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessage, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageBlockRead Class Reference

  • SmbMasterMessageBlockRead
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageBlockRead Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageBlockRead:
telos.I2cApi.Java.SmbMasterMessageCmdBlock telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageBlockRead () throws Exception
SmbMasterMessageBlockRead (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmdBlock
SmbMasterMessageCmdBlock () throws Exception
SmbMasterMessageCmdBlock (I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) throws Exception
byte[] | getData ()
void | setData (byte[] data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Block Read" (see section 6.5.7 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageBlockRead.SmbMasterMessageBlockRead ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command (0x00), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageBlockRead.SmbMasterMessageBlockRead | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageBlockRead
telos.I2cApi.Java.SmbMasterMessageBlockRead Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageBlockRead, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdBlock
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(byte[] data) | telos.I2cApi.Java.SmbMasterMessageCmdBlock
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageBlockRead() | telos.I2cApi.Java.SmbMasterMessageBlockRead
SmbMasterMessageBlockRead(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageBlockRead
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdBlock() | telos.I2cApi.Java.SmbMasterMessageCmdBlock
SmbMasterMessageCmdBlock(I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdBlock


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageBlockWrite Class Reference

  • SmbMasterMessageBlockWrite
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageBlockWrite Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageBlockWrite:
telos.I2cApi.Java.SmbMasterMessageCmdBlock telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageBlockWrite () throws Exception
SmbMasterMessageBlockWrite (I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmdBlock
SmbMasterMessageCmdBlock () throws Exception
SmbMasterMessageCmdBlock (I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) throws Exception
byte[] | getData ()
void | setData (byte[] data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Block Write" (see section 6.5.7 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageBlockWrite.SmbMasterMessageBlockWrite ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command (0x00), the array of data bytes (empty), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageBlockWrite.SmbMasterMessageBlockWrite | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte[] | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command, the array of data bytes, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data | array of data bytes
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageBlockWrite
telos.I2cApi.Java.SmbMasterMessageBlockWrite Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageBlockWrite, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdBlock
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(byte[] data) | telos.I2cApi.Java.SmbMasterMessageCmdBlock
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageBlockWrite() | telos.I2cApi.Java.SmbMasterMessageBlockWrite
SmbMasterMessageBlockWrite(I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageBlockWrite
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdBlock() | telos.I2cApi.Java.SmbMasterMessageCmdBlock
SmbMasterMessageCmdBlock(I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdBlock


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageBlockWriteRead Class Reference

  • SmbMasterMessageBlockWriteRead
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageBlockWriteRead Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageBlockWriteRead:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageBlockWriteRead () throws Exception
SmbMasterMessageBlockWriteRead (I2cAddress i2c_address, byte cmd, byte[] data_tx, boolean with_pec) throws Exception
byte[] | getDataTx ()
void | setDataTx (byte[] data)
byte[] | getDataRx ()
void | setDataRx (byte[] data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Block Write - Block Read Process Call" (see section 6.5.8 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageBlockWriteRead.SmbMasterMessageBlockWriteRead ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command (0x00), the data to be transmitted (empty), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageBlockWriteRead.SmbMasterMessageBlockWriteRead | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte[] | data_tx,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command, the data to be transmitted, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data_tx | data to be transmitted
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

byte [] telos.I2cApi.Java.SmbMasterMessageBlockWriteRead.getDataRx ( )

Gets the array of received bytes.

Returns
array received bytes
byte [] telos.I2cApi.Java.SmbMasterMessageBlockWriteRead.getDataTx ( )

Gets the array of byte to be transmitted.

Returns
array of bytes to be transmitted
void telos.I2cApi.Java.SmbMasterMessageBlockWriteRead.setDataRx ( byte[] data )

Sets the array of received bytes.

Parameters
data array received bytes
void telos.I2cApi.Java.SmbMasterMessageBlockWriteRead.setDataTx ( byte[] data )

Sets the array of byte to be transmitted.

Parameters
data array of bytes to be transmitted


I2C.Java API: Member List

  • SmbMasterMessageBlockWriteRead
telos.I2cApi.Java.SmbMasterMessageBlockWriteRead Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageBlockWriteRead, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getDataRx() | telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
getDataTx() | telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setDataRx(byte[] data) | telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
setDataTx(byte[] data) | telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageBlockWriteRead() | telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
SmbMasterMessageBlockWriteRead(I2cAddress i2c_address, byte cmd, byte[] data_tx, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageCmd Class Reference

  • SmbMasterMessageCmd
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageCmd Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageCmd:
telos.I2cApi.Java.SmbMasterMessage telos.I2cApi.Java.SmbMasterMessageBlockWriteRead telos.I2cApi.Java.SmbMasterMessageCmd32 telos.I2cApi.Java.SmbMasterMessageCmd64 telos.I2cApi.Java.SmbMasterMessageCmdBlock telos.I2cApi.Java.SmbMasterMessageCmdByte telos.I2cApi.Java.SmbMasterMessageCmdProcessCall telos.I2cApi.Java.SmbMasterMessageCmdWord telos.I2cApi.Java.SmbMasterMessageRead32 telos.I2cApi.Java.SmbMasterMessageWrite32 telos.I2cApi.Java.SmbMasterMessageRead64 telos.I2cApi.Java.SmbMasterMessageWrite64 telos.I2cApi.Java.SmbMasterMessageBlockRead telos.I2cApi.Java.SmbMasterMessageBlockWrite telos.I2cApi.Java.SmbMasterMessageReadByte telos.I2cApi.Java.SmbMasterMessageWriteByte telos.I2cApi.Java.SmbMasterMessageReadWord telos.I2cApi.Java.SmbMasterMessageWriteWord

Public Member Functions

SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class is used as a base class for all SMBus master messages, which contain a command and an optional PEC byte.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageCmd.SmbMasterMessageCmd ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command (0x00), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageCmd.SmbMasterMessageCmd | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

byte telos.I2cApi.Java.SmbMasterMessageCmd.getCommand ( )

Gets the command byte of the message.

Returns
command byte
boolean telos.I2cApi.Java.SmbMasterMessageCmd.getWithPec ( )

Gets whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void telos.I2cApi.Java.SmbMasterMessageCmd.setCommand ( byte cmd )

Sets the command byte of the message.

Parameters
cmd command byte
void telos.I2cApi.Java.SmbMasterMessageCmd.setWithPec ( boolean with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageCmd32 Class Reference

  • SmbMasterMessageCmd32
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageCmd32 Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageCmd32:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage telos.I2cApi.Java.SmbMasterMessageRead32 telos.I2cApi.Java.SmbMasterMessageWrite32

Public Member Functions

SmbMasterMessageCmd32 () throws Exception
SmbMasterMessageCmd32 (I2cAddress i2c_address, byte cmd, int data, boolean with_pec) throws Exception
int | getData ()
void | setData (int data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class is used as a base class for the "Write 32" and "Read 32" SMBus master messages.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageCmd32.SmbMasterMessageCmd32 ( ) throws Exception

Constructor: set the default I2C address (0x50), the command (0x00), the data dword (0x00000000), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageCmd32.SmbMasterMessageCmd32 | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | int | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: set the I2C address, the command, the data dword, and PEC (disabled).

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data dword
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

int telos.I2cApi.Java.SmbMasterMessageCmd32.getData ( )

Gets the data dword.

Returns
data dword
void telos.I2cApi.Java.SmbMasterMessageCmd32.setData ( int data )

Sets the data dword.

Parameters
data data dword


I2C.Java API: Member List

  • SmbMasterMessageCmd32
telos.I2cApi.Java.SmbMasterMessageCmd32 Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageCmd32, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmd32
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(int data) | telos.I2cApi.Java.SmbMasterMessageCmd32
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd32() | telos.I2cApi.Java.SmbMasterMessageCmd32
SmbMasterMessageCmd32(I2cAddress i2c_address, byte cmd, int data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd32


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageCmd64 Class Reference

  • SmbMasterMessageCmd64
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageCmd64 Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageCmd64:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage telos.I2cApi.Java.SmbMasterMessageRead64 telos.I2cApi.Java.SmbMasterMessageWrite64

Public Member Functions

SmbMasterMessageCmd64 () throws Exception
SmbMasterMessageCmd64 (I2cAddress i2c_address, byte cmd, long data, boolean with_pec) throws Exception
long | getData ()
void | setData (long data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class is used as a base class for the "Write 64" and "Read 64" SMBus master messages.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageCmd64.SmbMasterMessageCmd64 ( ) throws Exception

Constructor: set the default I2C address (0x50), the command (0x00), the data (0x0000000000000000), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageCmd64.SmbMasterMessageCmd64 | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | long | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: set the I2C address, the command, the data, and PEC (disabled).

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

long telos.I2cApi.Java.SmbMasterMessageCmd64.getData ( )

Gets the data.

Returns
data
void telos.I2cApi.Java.SmbMasterMessageCmd64.setData ( long data )

Sets the data.

Parameters
data data


I2C.Java API: Member List

  • SmbMasterMessageCmd64
telos.I2cApi.Java.SmbMasterMessageCmd64 Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageCmd64, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmd64
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(long data) | telos.I2cApi.Java.SmbMasterMessageCmd64
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd64() | telos.I2cApi.Java.SmbMasterMessageCmd64
SmbMasterMessageCmd64(I2cAddress i2c_address, byte cmd, long data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd64


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageCmdBlock Class Reference

  • SmbMasterMessageCmdBlock
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageCmdBlock Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageCmdBlock:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage telos.I2cApi.Java.SmbMasterMessageBlockRead telos.I2cApi.Java.SmbMasterMessageBlockWrite

Public Member Functions

SmbMasterMessageCmdBlock () throws Exception
SmbMasterMessageCmdBlock (I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) throws Exception
byte[] | getData ()
void | setData (byte[] data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class is used as a base class for the "Block Write" and "Block Read" SMBus master messages.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageCmdBlock.SmbMasterMessageCmdBlock ( ) throws Exception

Constructor: set the default I2C address (0x50), the command (0x00), the byte array (empty), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageCmdBlock.SmbMasterMessageCmdBlock | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte[] | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: set the I2C address, the command, the byte array, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data | array of data bytes
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

byte [] telos.I2cApi.Java.SmbMasterMessageCmdBlock.getData ( )

Gets the array of data bytes.

Returns
array of data bytes
void telos.I2cApi.Java.SmbMasterMessageCmdBlock.setData ( byte[] data )

Sets the array of data bytes.

Parameters
data array of data bytes


I2C.Java API: Member List

  • SmbMasterMessageCmdBlock
telos.I2cApi.Java.SmbMasterMessageCmdBlock Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageCmdBlock, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdBlock
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(byte[] data) | telos.I2cApi.Java.SmbMasterMessageCmdBlock
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdBlock() | telos.I2cApi.Java.SmbMasterMessageCmdBlock
SmbMasterMessageCmdBlock(I2cAddress i2c_address, byte cmd, byte[] data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdBlock


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageCmdByte Class Reference

  • SmbMasterMessageCmdByte
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageCmdByte Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageCmdByte:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage telos.I2cApi.Java.SmbMasterMessageReadByte telos.I2cApi.Java.SmbMasterMessageWriteByte

Public Member Functions

SmbMasterMessageCmdByte () throws Exception
SmbMasterMessageCmdByte (I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class is used as a base class for the "Write Byte" and "Read Byte" SMBus master messages.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageCmdByte.SmbMasterMessageCmdByte ( ) throws Exception

Constructor: set the default I2C address (0x50), the command (0x00), the data byte (0x00), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageCmdByte.SmbMasterMessageCmdByte | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: set the I2C address, the command, the data byte, and PEC (disabled).

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data byte
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

byte telos.I2cApi.Java.SmbMasterMessageCmdByte.getData ( )

Gets the data byte.

Returns
data byte
void telos.I2cApi.Java.SmbMasterMessageCmdByte.setData ( byte data )

Sets the data byte.

Parameters
data data byte


I2C.Java API: Member List

  • SmbMasterMessageCmdByte
telos.I2cApi.Java.SmbMasterMessageCmdByte Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageCmdByte, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdByte
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(byte data) | telos.I2cApi.Java.SmbMasterMessageCmdByte
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdByte() | telos.I2cApi.Java.SmbMasterMessageCmdByte
SmbMasterMessageCmdByte(I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdByte


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageCmdProcessCall Class Reference

  • SmbMasterMessageCmdProcessCall
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageCmdProcessCall Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageCmdProcessCall:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageCmdProcessCall () throws Exception
SmbMasterMessageCmdProcessCall (I2cAddress i2c_address, byte cmd, short data_tx, boolean with_pec) throws Exception
short | getDataTx ()
void | setDataTx (short data)
short | getDataRx ()
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Process Call" (see section 6.5.6 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageCmdProcessCall.SmbMasterMessageCmdProcessCall ( ) throws Exception

Constructor: sets the default I2C address (0x50), the command (0x00), the TX data word (0x0000), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageCmdProcessCall.SmbMasterMessageCmdProcessCall | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | short | data_tx,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the command, the TX data word, and PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data_tx | data to be transmitted
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

short telos.I2cApi.Java.SmbMasterMessageCmdProcessCall.getDataRx ( )

Gets the received data word.

Returns
received data word
short telos.I2cApi.Java.SmbMasterMessageCmdProcessCall.getDataTx ( )

Gets the data word to be transmitted.

Returns
data word to be transmitted
void telos.I2cApi.Java.SmbMasterMessageCmdProcessCall.setDataTx ( short data )

Sets the data word to be transmitted.

Parameters
data word to be transmitted


I2C.Java API: Member List

  • SmbMasterMessageCmdProcessCall
telos.I2cApi.Java.SmbMasterMessageCmdProcessCall Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageCmdProcessCall, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getDataRx() | telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
getDataTx() | telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setDataTx(short data) | telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdProcessCall() | telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
SmbMasterMessageCmdProcessCall(I2cAddress i2c_address, byte cmd, short data_tx, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdProcessCall


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageCmdWord Class Reference

  • SmbMasterMessageCmdWord
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageCmdWord Class Referenceabstract
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageCmdWord:
telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage telos.I2cApi.Java.SmbMasterMessageReadWord telos.I2cApi.Java.SmbMasterMessageWriteWord

Public Member Functions

SmbMasterMessageCmdWord () throws Exception
SmbMasterMessageCmdWord (I2cAddress i2c_address, byte cmd, short data, boolean with_pec) throws Exception
short | getData ()
void | setData (short data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class is used as a base class for the "Write Word" and "Read Word" SMBus master messages.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageCmdWord.SmbMasterMessageCmdWord ( ) throws Exception

Constructor: set the default I2C address (0x50), the command (0x00), the data word (0x0000), and PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageCmdWord.SmbMasterMessageCmdWord | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | short | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: set the I2C address, the command, the data word, and PEC (disabled).

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data word
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

short telos.I2cApi.Java.SmbMasterMessageCmdWord.getData ( )

Gets the data word.

Returns
data word
void telos.I2cApi.Java.SmbMasterMessageCmdWord.setData ( short data )

Sets the data word.

Parameters
data data word


I2C.Java API: Member List

  • SmbMasterMessageCmdWord
telos.I2cApi.Java.SmbMasterMessageCmdWord Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageCmdWord, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdWord
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(short data) | telos.I2cApi.Java.SmbMasterMessageCmdWord
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdWord() | telos.I2cApi.Java.SmbMasterMessageCmdWord
SmbMasterMessageCmdWord(I2cAddress i2c_address, byte cmd, short data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdWord


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageHostNotify Class Reference

  • SmbMasterMessageHostNotify
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageHostNotify Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageHostNotify:
telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageHostNotify () throws Exception
SmbMasterMessageHostNotify (I2cAddress i2c_address, short data) throws Exception
short | getData ()
void | setData (short data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Host Notify" (see section 6.5.9 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageHostNotify.SmbMasterMessageHostNotify ( ) throws Exception

Constructs: sets the default I2C address (0x50) and the data word (0x0000).

telos.I2cApi.Java.SmbMasterMessageHostNotify.SmbMasterMessageHostNotify | ( | I2cAddress | i2c_address,
 |  | short | data
 | ) |  | throws Exception

Constructs: sets the I2C address and the data word.

Parameters
i2c_address | I2C address of the slave
data | data word to be transmitted

Member Function Documentation

short telos.I2cApi.Java.SmbMasterMessageHostNotify.getData ( )

Gets the data word.

Returns
data word
void telos.I2cApi.Java.SmbMasterMessageHostNotify.setData ( short data )

Sets the data word.

Parameters
data data word


I2C.Java API: Member List

  • SmbMasterMessageHostNotify
telos.I2cApi.Java.SmbMasterMessageHostNotify Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageHostNotify, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getData() | telos.I2cApi.Java.SmbMasterMessageHostNotify
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setData(short data) | telos.I2cApi.Java.SmbMasterMessageHostNotify
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageHostNotify() | telos.I2cApi.Java.SmbMasterMessageHostNotify
SmbMasterMessageHostNotify(I2cAddress i2c_address, short data) | telos.I2cApi.Java.SmbMasterMessageHostNotify


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageQuickCommand Class Reference

  • SmbMasterMessageQuickCommand
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageQuickCommand Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageQuickCommand:
telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageQuickCommand () throws Exception
SmbMasterMessageQuickCommand (I2cAddress i2c_address, boolean tx_direction) throws Exception
boolean | getTxDirection ()
void | setTxDirection (boolean tx_direction)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Quick Command" (see section 6.5.1 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageQuickCommand.SmbMasterMessageQuickCommand ( ) throws Exception

Constructor, which sets the default I2C address (0x50) and the default direction (master transmitter).

telos.I2cApi.Java.SmbMasterMessageQuickCommand.SmbMasterMessageQuickCommand | ( | I2cAddress | i2c_address,
 |  | boolean | tx_direction
 | ) |  | throws Exception

Constructor: sets the I2C address and the direction.

Parameters
i2c_address | I2C address of the slave
tx_direction | master transmitter (true), master receiver (false)

Member Function Documentation

boolean telos.I2cApi.Java.SmbMasterMessageQuickCommand.getTxDirection ( )

Gets the direction of the transfer.

Returns
master transmitter (true), master receiver (false)
void telos.I2cApi.Java.SmbMasterMessageQuickCommand.setTxDirection ( boolean tx_direction )

Sets the direction of the transfer.

Parameters
tx_direction master transmitter (true), master receiver (false)


I2C.Java API: Member List

  • SmbMasterMessageQuickCommand
telos.I2cApi.Java.SmbMasterMessageQuickCommand Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageQuickCommand, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getTxDirection() | telos.I2cApi.Java.SmbMasterMessageQuickCommand
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setTxDirection(boolean tx_direction) | telos.I2cApi.Java.SmbMasterMessageQuickCommand
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageQuickCommand() | telos.I2cApi.Java.SmbMasterMessageQuickCommand
SmbMasterMessageQuickCommand(I2cAddress i2c_address, boolean tx_direction) | telos.I2cApi.Java.SmbMasterMessageQuickCommand


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageRead32 Class Reference

  • SmbMasterMessageRead32
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageRead32 Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageRead32:
telos.I2cApi.Java.SmbMasterMessageCmd32 telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageRead32 () throws Exception
SmbMasterMessageRead32 (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd32
SmbMasterMessageCmd32 () throws Exception
SmbMasterMessageCmd32 (I2cAddress i2c_address, byte cmd, int data, boolean with_pec) throws Exception
int | getData ()
void | setData (int data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Read 32" (see section 6.5.11 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageRead32.SmbMasterMessageRead32 ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageRead32.SmbMasterMessageRead32 | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data dword, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageRead32
telos.I2cApi.Java.SmbMasterMessageRead32 Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageRead32, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmd32
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(int data) | telos.I2cApi.Java.SmbMasterMessageCmd32
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd32() | telos.I2cApi.Java.SmbMasterMessageCmd32
SmbMasterMessageCmd32(I2cAddress i2c_address, byte cmd, int data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd32
SmbMasterMessageRead32() | telos.I2cApi.Java.SmbMasterMessageRead32
SmbMasterMessageRead32(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageRead32


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageRead64 Class Reference

  • SmbMasterMessageRead64
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageRead64 Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageRead64:
telos.I2cApi.Java.SmbMasterMessageCmd64 telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageRead64 () throws Exception
SmbMasterMessageRead64 (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd64
SmbMasterMessageCmd64 () throws Exception
SmbMasterMessageCmd64 (I2cAddress i2c_address, byte cmd, long data, boolean with_pec) throws Exception
long | getData ()
void | setData (long data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Read 64" (see section 6.5.13 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageRead64.SmbMasterMessageRead64 ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageRead64.SmbMasterMessageRead64 | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageRead64
telos.I2cApi.Java.SmbMasterMessageRead64 Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageRead64, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmd64
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(long data) | telos.I2cApi.Java.SmbMasterMessageCmd64
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd64() | telos.I2cApi.Java.SmbMasterMessageCmd64
SmbMasterMessageCmd64(I2cAddress i2c_address, byte cmd, long data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd64
SmbMasterMessageRead64() | telos.I2cApi.Java.SmbMasterMessageRead64
SmbMasterMessageRead64(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageRead64


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageReadByte Class Reference

  • SmbMasterMessageReadByte
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageReadByte Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageReadByte:
telos.I2cApi.Java.SmbMasterMessageCmdByte telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageReadByte () throws Exception
SmbMasterMessageReadByte (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmdByte
SmbMasterMessageCmdByte () throws Exception
SmbMasterMessageCmdByte (I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Read Byte" (see section 6.5.5 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageReadByte.SmbMasterMessageReadByte ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageReadByte.SmbMasterMessageReadByte | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data byte, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageReadByte
telos.I2cApi.Java.SmbMasterMessageReadByte Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageReadByte, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdByte
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(byte data) | telos.I2cApi.Java.SmbMasterMessageCmdByte
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdByte() | telos.I2cApi.Java.SmbMasterMessageCmdByte
SmbMasterMessageCmdByte(I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdByte
SmbMasterMessageReadByte() | telos.I2cApi.Java.SmbMasterMessageReadByte
SmbMasterMessageReadByte(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageReadByte


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageReadWord Class Reference

  • SmbMasterMessageReadWord
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageReadWord Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageReadWord:
telos.I2cApi.Java.SmbMasterMessageCmdWord telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageReadWord () throws Exception
SmbMasterMessageReadWord (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmdWord
SmbMasterMessageCmdWord () throws Exception
SmbMasterMessageCmdWord (I2cAddress i2c_address, byte cmd, short data, boolean with_pec) throws Exception
short | getData ()
void | setData (short data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Read Word" (see section 6.5.5 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageReadWord.SmbMasterMessageReadWord ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageReadWord.SmbMasterMessageReadWord | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data word, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageReadWord
telos.I2cApi.Java.SmbMasterMessageReadWord Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageReadWord, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdWord
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(short data) | telos.I2cApi.Java.SmbMasterMessageCmdWord
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdWord() | telos.I2cApi.Java.SmbMasterMessageCmdWord
SmbMasterMessageCmdWord(I2cAddress i2c_address, byte cmd, short data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdWord
SmbMasterMessageReadWord() | telos.I2cApi.Java.SmbMasterMessageReadWord
SmbMasterMessageReadWord(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageReadWord


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageReceiveByte Class Reference

  • SmbMasterMessageReceiveByte
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageReceiveByte Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageReceiveByte:
telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageReceiveByte () throws Exception
SmbMasterMessageReceiveByte (I2cAddress i2c_address, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Receive Byte" (see section 6.5.2 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageReceiveByte.SmbMasterMessageReceiveByte ( ) throws Exception

Constructor: sets the default I2C address (0x50), the default data byte (0x00), and the default PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageReceiveByte.SmbMasterMessageReceiveByte | ( | I2cAddress | i2c_address,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address and the PEC.

Parameters
i2c_address | I2C address of the slave
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

byte telos.I2cApi.Java.SmbMasterMessageReceiveByte.getData ( )

Gets the data to be received from the slave.

Returns
received data
boolean telos.I2cApi.Java.SmbMasterMessageReceiveByte.getWithPec ( )

Gets whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void telos.I2cApi.Java.SmbMasterMessageReceiveByte.setData ( byte data )

Sets the data received from the slave.

Parameters
data received data
void telos.I2cApi.Java.SmbMasterMessageReceiveByte.setWithPec ( boolean with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageReceiveByte
telos.I2cApi.Java.SmbMasterMessageReceiveByte Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageReceiveByte, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getData() | telos.I2cApi.Java.SmbMasterMessageReceiveByte
getWithPec() | telos.I2cApi.Java.SmbMasterMessageReceiveByte
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setData(byte data) | telos.I2cApi.Java.SmbMasterMessageReceiveByte
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageReceiveByte
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageReceiveByte() | telos.I2cApi.Java.SmbMasterMessageReceiveByte
SmbMasterMessageReceiveByte(I2cAddress i2c_address, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageReceiveByte


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageSendByte Class Reference

  • SmbMasterMessageSendByte
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageSendByte Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageSendByte:
telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageSendByte () throws Exception
SmbMasterMessageSendByte (I2cAddress i2c_address, byte data, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Send Byte" (see section 6.5.2 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageSendByte.SmbMasterMessageSendByte ( ) throws Exception

Constructor: sets the default I2C address (0x50), the default data byte (0x00), and the default PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageSendByte.SmbMasterMessageSendByte | ( | I2cAddress | i2c_address,
 |  | byte | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructor: sets the I2C address, the data byte, and the PEC.

Parameters
i2c_address | I2C address of the slave
data | data byte
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

byte telos.I2cApi.Java.SmbMasterMessageSendByte.getData ( )

Gets the data to be sent to slave.

Returns
data to be sent
boolean telos.I2cApi.Java.SmbMasterMessageSendByte.getWithPec ( )

Gets whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void telos.I2cApi.Java.SmbMasterMessageSendByte.setData ( byte data )

Sets the data to be sent to slave.

Parameters
data data to be sent
void telos.I2cApi.Java.SmbMasterMessageSendByte.setWithPec ( boolean with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageSendByte
telos.I2cApi.Java.SmbMasterMessageSendByte Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageSendByte, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getData() | telos.I2cApi.Java.SmbMasterMessageSendByte
getWithPec() | telos.I2cApi.Java.SmbMasterMessageSendByte
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setData(byte data) | telos.I2cApi.Java.SmbMasterMessageSendByte
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageSendByte
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageSendByte() | telos.I2cApi.Java.SmbMasterMessageSendByte
SmbMasterMessageSendByte(I2cAddress i2c_address, byte data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageSendByte


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageWrite32 Class Reference

  • SmbMasterMessageWrite32
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageWrite32 Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageWrite32:
telos.I2cApi.Java.SmbMasterMessageCmd32 telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageWrite32 () throws Exception
SmbMasterMessageWrite32 (I2cAddress i2c_address, byte cmd, int data, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd32
SmbMasterMessageCmd32 () throws Exception
SmbMasterMessageCmd32 (I2cAddress i2c_address, byte cmd, int data, boolean with_pec) throws Exception
int | getData ()
void | setData (int data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Write 32" (see section 6.5.10 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageWrite32.SmbMasterMessageWrite32 ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), the data dword (0x00000000), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageWrite32.SmbMasterMessageWrite32 | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | int | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data dword, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data dword to be transmitted
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageWrite32
telos.I2cApi.Java.SmbMasterMessageWrite32 Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageWrite32, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmd32
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(int data) | telos.I2cApi.Java.SmbMasterMessageCmd32
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd32() | telos.I2cApi.Java.SmbMasterMessageCmd32
SmbMasterMessageCmd32(I2cAddress i2c_address, byte cmd, int data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd32
SmbMasterMessageWrite32() | telos.I2cApi.Java.SmbMasterMessageWrite32
SmbMasterMessageWrite32(I2cAddress i2c_address, byte cmd, int data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageWrite32


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageWrite64 Class Reference

  • SmbMasterMessageWrite64
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageWrite64 Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageWrite64:
telos.I2cApi.Java.SmbMasterMessageCmd64 telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageWrite64 () throws Exception
SmbMasterMessageWrite64 (I2cAddress i2c_address, byte cmd, long data, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd64
SmbMasterMessageCmd64 () throws Exception
SmbMasterMessageCmd64 (I2cAddress i2c_address, byte cmd, long data, boolean with_pec) throws Exception
long | getData ()
void | setData (long data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Write 64" (see section 6.5.12 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageWrite64.SmbMasterMessageWrite64 ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), the data (0x0000000000000000), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageWrite64.SmbMasterMessageWrite64 | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | long | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data to be transmitted
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageWrite64
telos.I2cApi.Java.SmbMasterMessageWrite64 Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageWrite64, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmd64
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(long data) | telos.I2cApi.Java.SmbMasterMessageCmd64
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd64() | telos.I2cApi.Java.SmbMasterMessageCmd64
SmbMasterMessageCmd64(I2cAddress i2c_address, byte cmd, long data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd64
SmbMasterMessageWrite64() | telos.I2cApi.Java.SmbMasterMessageWrite64
SmbMasterMessageWrite64(I2cAddress i2c_address, byte cmd, long data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageWrite64


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageWriteByte Class Reference

  • SmbMasterMessageWriteByte
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageWriteByte Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageWriteByte:
telos.I2cApi.Java.SmbMasterMessageCmdByte telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageWriteByte () throws Exception
SmbMasterMessageWriteByte (I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmdByte
SmbMasterMessageCmdByte () throws Exception
SmbMasterMessageCmdByte (I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) throws Exception
byte | getData ()
void | setData (byte data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Write Byte" (see section 6.5.4 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageWriteByte.SmbMasterMessageWriteByte ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), the data byte (0x00), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageWriteByte.SmbMasterMessageWriteByte | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | byte | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data byte, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data byte to be transmitted
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageWriteByte
telos.I2cApi.Java.SmbMasterMessageWriteByte Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageWriteByte, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdByte
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(byte data) | telos.I2cApi.Java.SmbMasterMessageCmdByte
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdByte() | telos.I2cApi.Java.SmbMasterMessageCmdByte
SmbMasterMessageCmdByte(I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdByte
SmbMasterMessageWriteByte() | telos.I2cApi.Java.SmbMasterMessageWriteByte
SmbMasterMessageWriteByte(I2cAddress i2c_address, byte cmd, byte data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageWriteByte


I2C.Java API: telos.I2cApi.Java.SmbMasterMessageWriteWord Class Reference

  • SmbMasterMessageWriteWord
Public Member Functions | List of all members
telos.I2cApi.Java.SmbMasterMessageWriteWord Class Reference
Inheritance diagram for telos.I2cApi.Java.SmbMasterMessageWriteWord:
telos.I2cApi.Java.SmbMasterMessageCmdWord telos.I2cApi.Java.SmbMasterMessageCmd telos.I2cApi.Java.SmbMasterMessage

Public Member Functions

SmbMasterMessageWriteWord () throws Exception
SmbMasterMessageWriteWord (I2cAddress i2c_address, byte cmd, short data, boolean with_pec) throws Exception
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmdWord
SmbMasterMessageCmdWord () throws Exception
SmbMasterMessageCmdWord (I2cAddress i2c_address, byte cmd, short data, boolean with_pec) throws Exception
short | getData ()
void | setData (short data)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd () throws Exception
SmbMasterMessageCmd (I2cAddress i2c_address, byte cmd, boolean with_pec) throws Exception
byte | getCommand ()
void | setCommand (byte cmd)
boolean | getWithPec ()
void | setWithPec (boolean with_pec)
- Public Member Functions inherited from telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage () throws Exception
SmbMasterMessage (I2cAddress i2c_address) throws Exception
I2cAddress getAddress ()
void | setAddress (I2cAddress i2c_address) throws Exception

Detailed Description

This class specifies a "Write Word" (see section 6.5.4 in the standard) master message for the SMBus.

Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

telos.I2cApi.Java.SmbMasterMessageWriteWord.SmbMasterMessageWriteWord ( ) throws Exception

Constructs: sets the default I2C address (0x50), the command (0x00), the data word (0x0000), and the PEC (disabled).

telos.I2cApi.Java.SmbMasterMessageWriteWord.SmbMasterMessageWriteWord | ( | I2cAddress | i2c_address,
 |  | byte | cmd,
 |  | short | data,
 |  | boolean | with_pec
 | ) |  | throws Exception

Constructs: sets the I2C address, the command, the data word, and the PEC.

Parameters
i2c_address | I2C address of the slave
cmd | command
data | data word to be transmitted
with_pec | use PEC (true), do not use PEC (false)


I2C.Java API: Member List

  • SmbMasterMessageWriteWord
telos.I2cApi.Java.SmbMasterMessageWriteWord Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageWriteWord, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getData() | telos.I2cApi.Java.SmbMasterMessageCmdWord
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setData(short data) | telos.I2cApi.Java.SmbMasterMessageCmdWord
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmdWord() | telos.I2cApi.Java.SmbMasterMessageCmdWord
SmbMasterMessageCmdWord(I2cAddress i2c_address, byte cmd, short data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmdWord
SmbMasterMessageWriteWord() | telos.I2cApi.Java.SmbMasterMessageWriteWord
SmbMasterMessageWriteWord(I2cAddress i2c_address, byte cmd, short data, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageWriteWord


I2C.Java API: telos.I2cApi.Java.Tracer Class Reference

  • Tracer
Public Member Functions | List of all members
telos.I2cApi.Java.Tracer Class Reference

Public Member Functions

synchronized native boolean | getEnabled ()
synchronized native void | setEnabled (boolean enabled)
synchronized native void | enableAddress (I2cAddress address)
synchronized native void | disableAddress (I2cAddress address)
synchronized native void | enableAllAddresses ()
synchronized native void | disableAllAddresses ()
synchronized native TracerMessage[] | receiveMessages ()
InputTestpins getInputTestpins ()

Detailed Description

This class can be used to use the tracer functionality of the I2C interfaces. It is possible to start/stop the tracer module and to filter I2C messages regarding their I2C slave addresses.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the I2cApi.getTracer() property.

Normally the following steps are necessary to use the tracer:

  1. Configure the I2C address filter (default: I2C address filter is disabled).
  2. Enable the tracer using the setEnabled() property.
  3. Wait for new trace messages using I2cApi.waitForData().
  4. Call receiveMessages() to get the trace messages.
  5. Disable the tracer using the setEnabled() property.

Member Function Documentation

synchronized native void telos.I2cApi.Java.Tracer.disableAddress ( I2cAddress address )

This function can be used to disable an address in the filter.

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

Parameters
address I2C address to be disabled
synchronized native void telos.I2cApi.Java.Tracer.disableAllAddresses ( )

This function can be used to disable all addresses in the filter.

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

synchronized native void telos.I2cApi.Java.Tracer.enableAddress ( I2cAddress address )

This function can be used to enable an address in the filter.

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

Parameters
address I2C address to be enabled
synchronized native void telos.I2cApi.Java.Tracer.enableAllAddresses ( )

This function can be used to enable all addresses in the filter. default)

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

synchronized native boolean telos.I2cApi.Java.Tracer.getEnabled ( )

Gets whether the tracer module is enabled or disabled.

Returns
tracer disabled (false), tracer enabled (true)
InputTestpins telos.I2cApi.Java.Tracer.getInputTestpins ( )

This function can be used to get access to the input testpin logging functionality of the I2C interface connected to this object.

Returns
input testpin logging
synchronized native TracerMessage [] telos.I2cApi.Java.Tracer.receiveMessages ( )

Tries to read I2C messages from the tracer module.

Returns
read I2C messages
synchronized native void telos.I2cApi.Java.Tracer.setEnabled ( boolean enabled )

Gets whether the tracer module is enabled or disabled.

Parameters
enabled tracer disabled (false), tracer enabled (true)


I2C.Java API: Member List

  • Tracer
telos.I2cApi.Java.Tracer Member List

This is the complete list of members for telos.I2cApi.Java.Tracer, including all inherited members.

disableAddress(I2cAddress address) | telos.I2cApi.Java.Tracer
disableAllAddresses() | telos.I2cApi.Java.Tracer
enableAddress(I2cAddress address) | telos.I2cApi.Java.Tracer
enableAllAddresses() | telos.I2cApi.Java.Tracer
getEnabled() | telos.I2cApi.Java.Tracer
getInputTestpins() | telos.I2cApi.Java.Tracer
receiveMessages() | telos.I2cApi.Java.Tracer
setEnabled(boolean enabled) | telos.I2cApi.Java.Tracer


I2C.Java API: telos.I2cApi.Java.TracerMessage Class Reference

  • TracerMessage
Classes | Public Attributes | List of all members
telos.I2cApi.Java.TracerMessage Class Reference

Classes

class | TracerMessageData
enum | TracerMessageDataConfirmation
enum | TracerMessageType

Public Attributes

TracerMessageType type
type of the message
TracerMessageData data
data of a TracerMessageType.MSG_FRAME_DATA message
long timestamp
timestamp of the message or N/A (-1)

Detailed Description

This class is used to store one trace message created by the methods of the Tracer class.


I2C.Java API: Member List

  • TracerMessage
telos.I2cApi.Java.TracerMessage Member List

This is the complete list of members for telos.I2cApi.Java.TracerMessage, including all inherited members.

data | telos.I2cApi.Java.TracerMessage
timestamp | telos.I2cApi.Java.TracerMessage
type | telos.I2cApi.Java.TracerMessage


I2C.Java API: telos.I2cApi.Java.TracerMessage.TracerMessageData Class Reference

  • TracerMessage
  • TracerMessageData
Public Attributes | List of all members
telos.I2cApi.Java.TracerMessage.TracerMessageData Class Reference

Public Attributes

byte data
transferred data byte
TracerMessageDataConfirmation confirmation
received confirmation

Detailed Description

This class is used for TracerMessageType.MSG_FRAME_DATA messages to store the data transferred over the I2C bus.


I2C.Java API: Member List

  • TracerMessage
  • TracerMessageData
telos.I2cApi.Java.TracerMessage.TracerMessageData Member List

This is the complete list of members for telos.I2cApi.Java.TracerMessage.TracerMessageData, including all inherited members.

confirmation | telos.I2cApi.Java.TracerMessage.TracerMessageData
data | telos.I2cApi.Java.TracerMessage.TracerMessageData


I2C.Java API: telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation Enum Reference

  • TracerMessage
  • TracerMessageDataConfirmation
Public Attributes | List of all members
telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation Enum Reference

Public Attributes

DATA_CONFIRMATION_NONE
none
DATA_CONFIRMATION_ACK
ACK.
DATA_CONFIRMATION_NACK
NACK.

Detailed Description

This enumeration is used for TracerMessageType.MSG_FRAME_DATA messages. It indicates whether an ACK or NACK has been received after the data message.


I2C.Java API: Member List

  • TracerMessage
  • TracerMessageDataConfirmation
telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation Member List

This is the complete list of members for telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation, including all inherited members.

DATA_CONFIRMATION_ACK | telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
DATA_CONFIRMATION_NACK | telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
DATA_CONFIRMATION_NONE | telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation


I2C.Java API: telos.I2cApi.Java.TracerMessage.TracerMessageType Enum Reference

  • TracerMessage
  • TracerMessageType
Public Attributes | List of all members
telos.I2cApi.Java.TracerMessage.TracerMessageType Enum Reference

Public Attributes

MSG_FRAME_START
frame mode: START
MSG_FRAME_STOP
frame mode: STOP
MSG_FRAME_DATA
frame mode: DATA
MSG_I2C_PROTOCOL_ERROR
I2C protocol error.
MSG_DATA_LOST
lost trace data (N/A)
MSG_SMB_POWER_ON
SMB power on.
MSG_SMB_POWER_OFF
SMB power off.
MSG_TRACER_RESTARTED
tracer has been restarted

Detailed Description

Enumeration to specify the type of an I2C message. The types can be categorized into two groups: frame-based messages, and protocol errors.


I2C.Java API: Member List

  • TracerMessage
  • TracerMessageType
telos.I2cApi.Java.TracerMessage.TracerMessageType Member List

This is the complete list of members for telos.I2cApi.Java.TracerMessage.TracerMessageType, including all inherited members.

MSG_DATA_LOST | telos.I2cApi.Java.TracerMessage.TracerMessageType
MSG_FRAME_DATA | telos.I2cApi.Java.TracerMessage.TracerMessageType
MSG_FRAME_START | telos.I2cApi.Java.TracerMessage.TracerMessageType
MSG_FRAME_STOP | telos.I2cApi.Java.TracerMessage.TracerMessageType
MSG_I2C_PROTOCOL_ERROR | telos.I2cApi.Java.TracerMessage.TracerMessageType
MSG_SMB_POWER_OFF | telos.I2cApi.Java.TracerMessage.TracerMessageType
MSG_SMB_POWER_ON | telos.I2cApi.Java.TracerMessage.TracerMessageType
MSG_TRACER_RESTARTED | telos.I2cApi.Java.TracerMessage.TracerMessageType


I2C.Java API: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
C telos.I2cApi.Java.Adc
C telos.I2cApi.Java.AdcData
C telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
C telos.I2cApi.Java.Board
C telos.I2cApi.Java.Board.BoardType
C telos.I2cApi.Java.I2cApi.BusType
C telos.I2cApi.Java.I2cAddress
C telos.I2cApi.Java.I2cApi
C telos.I2cApi.Java.I2cApi.I2cBusState
C telos.I2cApi.Java.InputTestpins
C telos.I2cApi.Java.InputTestpinsMessage
C telos.I2cApi.Java.NegativeTester.LevelsMaster
C telos.I2cApi.Java.NegativeTester.LevelsSlave
C telos.I2cApi.Java.NegativeTester.MessageSlave
C telos.I2cApi.Java.NegativeTester.MessagesMaster
C telos.I2cApi.Java.NegativeTester.MessagesSlave
C telos.I2cApi.Java.NegativeTester.NackBehaviour
C telos.I2cApi.Java.NegativeTester
C telos.I2cApi.Java.NegativeTesterMaster
C telos.I2cApi.Java.NegativeTesterSlave
▼C telos.I2cApi.Java.PmbusMasterMessage
▼C telos.I2cApi.Java.PmbusMasterMessageExtCmdByte
C telos.I2cApi.Java.PmbusMasterMessageReadByte
C telos.I2cApi.Java.PmbusMasterMessageWriteByte
▼C telos.I2cApi.Java.PmbusMasterMessageExtCmdWord
C telos.I2cApi.Java.PmbusMasterMessageReadWord
C telos.I2cApi.Java.PmbusMasterMessageWriteWord
C telos.I2cApi.Java.PmbusMasterMessageCmd
C telos.I2cApi.Java.PmbusMasterMessageGroupCmd
C telos.I2cApi.Java.SmbArpMaster
C telos.I2cApi.Java.SmbMaster
▼C telos.I2cApi.Java.SmbMasterMessage
▼C telos.I2cApi.Java.SmbMasterMessageCmd
C telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
▼C telos.I2cApi.Java.SmbMasterMessageCmd32
C telos.I2cApi.Java.SmbMasterMessageRead32
C telos.I2cApi.Java.SmbMasterMessageWrite32
▼C telos.I2cApi.Java.SmbMasterMessageCmd64
C telos.I2cApi.Java.SmbMasterMessageRead64
C telos.I2cApi.Java.SmbMasterMessageWrite64
▼C telos.I2cApi.Java.SmbMasterMessageCmdBlock
C telos.I2cApi.Java.SmbMasterMessageBlockRead
C telos.I2cApi.Java.SmbMasterMessageBlockWrite
▼C telos.I2cApi.Java.SmbMasterMessageCmdByte
C telos.I2cApi.Java.SmbMasterMessageReadByte
C telos.I2cApi.Java.SmbMasterMessageWriteByte
C telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
▼C telos.I2cApi.Java.SmbMasterMessageCmdWord
C telos.I2cApi.Java.SmbMasterMessageReadWord
C telos.I2cApi.Java.SmbMasterMessageWriteWord
C telos.I2cApi.Java.SmbMasterMessageHostNotify
C telos.I2cApi.Java.SmbMasterMessageQuickCommand
C telos.I2cApi.Java.SmbMasterMessageReceiveByte
C telos.I2cApi.Java.SmbMasterMessageSendByte
C telos.I2cApi.Java.NegativeTester.StopTrigger
C telos.I2cApi.Java.Tracer
C telos.I2cApi.Java.TracerMessage
C telos.I2cApi.Java.TracerMessage.TracerMessageData
C telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
C telos.I2cApi.Java.TracerMessage.TracerMessageType
C telos.I2cApi.Java.SmbArpMaster.Udid


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • adc : telos.I2cApi.Java.Board
  • adc_max_pretrigger : telos.I2cApi.Java.Board
  • adc_sampling_depth : telos.I2cApi.Java.Board
  • adc_samplingrate : telos.I2cApi.Java.Board
  • adc_trigger_ack : telos.I2cApi.Java.Board
  • adc_trigger_data : telos.I2cApi.Java.Board
  • adc_trigger_error : telos.I2cApi.Java.Board
  • adc_trigger_immediately : telos.I2cApi.Java.Board
  • adc_trigger_msg_cnt : telos.I2cApi.Java.Board
  • adc_trigger_nack : telos.I2cApi.Java.Board
  • adc_trigger_start : telos.I2cApi.Java.Board
  • adc_trigger_stop : telos.I2cApi.Java.Board
  • adc_trigger_testpin1 : telos.I2cApi.Java.Board
  • adc_trigger_testpin2 : telos.I2cApi.Java.Board
  • adc_vcc : telos.I2cApi.Java.Board
  • addr : telos.I2cApi.Java.SmbArpMaster.Udid
  • ADDR_TYPE_DYNAMIC_PERSISTENT : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
  • ADDR_TYPE_DYNAMIC_VOLATILE : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
  • ADDR_TYPE_FIXED : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
  • ADDR_TYPE_RANDOM : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
  • assignAddress() : telos.I2cApi.Java.SmbArpMaster


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • board_type : telos.I2cApi.Java.Board
  • BOARD_TYPE_CONNII : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_CONNII_MM : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_CONNII_MM2 : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_DUMMY : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_TRACII_XL : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_TRACII_XL2 : telos.I2cApi.Java.Board.BoardType
  • BUS_TYPE_I2C : telos.I2cApi.Java.I2cApi.BusType
  • bus_type_smb : telos.I2cApi.Java.Board
  • BUS_TYPE_SMB : telos.I2cApi.Java.I2cApi.BusType


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • cancel() : telos.I2cApi.Java.Adc
  • clear() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • close() : telos.I2cApi.Java.I2cApi
  • confirmation : telos.I2cApi.Java.TracerMessage.TracerMessageData
  • convertNanosecondsToTicks() : telos.I2cApi.Java.NegativeTester
  • convertTicksToNanoseconds() : telos.I2cApi.Java.NegativeTester
  • createReceiver() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverAckBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverByte() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverNackBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createStart() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitter() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitterAckBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitterBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitterByte() : telos.I2cApi.Java.NegativeTesterSlave


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data : telos.I2cApi.Java.TracerMessage , telos.I2cApi.Java.TracerMessage.TracerMessageData
  • DATA_CONFIRMATION_ACK : telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
  • DATA_CONFIRMATION_NACK : telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
  • DATA_CONFIRMATION_NONE : telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
  • data_max : telos.I2cApi.Java.AdcData
  • data_scl : telos.I2cApi.Java.AdcData
  • data_sda : telos.I2cApi.Java.AdcData
  • delay() : telos.I2cApi.Java.NegativeTesterMaster
  • disableAddress() : telos.I2cApi.Java.Tracer
  • disableAllAddresses() : telos.I2cApi.Java.Tracer
  • disableSlave() : telos.I2cApi.Java.I2cApi
  • dispose() : telos.I2cApi.Java.I2cApi
  • drive_sda : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • enable_high_speed_current_source : telos.I2cApi.Java.NegativeTester.LevelsMaster
  • enableAddress() : telos.I2cApi.Java.Tracer
  • enableAllAddresses() : telos.I2cApi.Java.Tracer
  • enableSlave() : telos.I2cApi.Java.I2cApi
  • equals() : telos.I2cApi.Java.I2cAddress
  • executeArp() : telos.I2cApi.Java.SmbArpMaster


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • findBoards() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GENERAL_CALL : telos.I2cApi.Java.I2cAddress
  • getAdc() : telos.I2cApi.Java.I2cApi
  • getAddress() : telos.I2cApi.Java.I2cAddress , telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbArpMaster.Udid , telos.I2cApi.Java.SmbMasterMessage
  • getAddressType() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getAsfSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getAsVhd() : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • getBitrate() : telos.I2cApi.Java.I2cApi , telos.I2cApi.Java.NegativeTesterMaster
  • getBitrateHighspeed() : telos.I2cApi.Java.I2cApi
  • getBitrateHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • getBoardTypeAsString() : telos.I2cApi.Java.Board
  • getBusType() : telos.I2cApi.Java.I2cApi
  • getCommand() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageCmd
  • getCommandExtension() : telos.I2cApi.Java.PmbusMasterMessage
  • getCreateSpikes() : telos.I2cApi.Java.NegativeTesterMaster
  • getData() : telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.PmbusMasterMessageExtCmdByte , telos.I2cApi.Java.PmbusMasterMessageExtCmdWord , telos.I2cApi.Java.SmbMasterMessageCmd32 , telos.I2cApi.Java.SmbMasterMessageCmd64 , telos.I2cApi.Java.SmbMasterMessageCmdBlock , telos.I2cApi.Java.SmbMasterMessageCmdByte , telos.I2cApi.Java.SmbMasterMessageCmdWord , telos.I2cApi.Java.SmbMasterMessageHostNotify , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • getDataRx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead , telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • getDataTx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead , telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • getDeviceId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getEnabled() : telos.I2cApi.Java.InputTestpins , telos.I2cApi.Java.Tracer
  • getHighLevelThreshold() : telos.I2cApi.Java.I2cApi
  • getHighspeedMasterCode() : telos.I2cApi.Java.I2cApi
  • getHighSpeedToken() : telos.I2cApi.Java.NegativeTesterMaster
  • getI2cBusLoad() : telos.I2cApi.Java.I2cApi
  • getI2cState() : telos.I2cApi.Java.I2cApi
  • getI2cVcc() : telos.I2cApi.Java.I2cApi
  • getI2cVccSupply() : telos.I2cApi.Java.I2cApi
  • getIgnoreStretching() : telos.I2cApi.Java.NegativeTesterMaster
  • getInfo() : telos.I2cApi.Java.I2cApi
  • getInputTestpin() : telos.I2cApi.Java.I2cApi
  • getInputTestpins() : telos.I2cApi.Java.Tracer
  • getIpmiSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getIsOpen() : telos.I2cApi.Java.I2cApi
  • getIsRunning() : telos.I2cApi.Java.NegativeTester
  • getIsTenBitAddress() : telos.I2cApi.Java.I2cAddress
  • getLoopCount() : telos.I2cApi.Java.NegativeTesterMaster
  • getLoopMode() : telos.I2cApi.Java.NegativeTesterSlave
  • getLowLevelThreshold() : telos.I2cApi.Java.I2cApi
  • getMessageCountTrigger() : telos.I2cApi.Java.Adc
  • getMessageDataTriggerData() : telos.I2cApi.Java.Adc
  • getMessageDataTriggerDontCare() : telos.I2cApi.Java.Adc
  • getMessages() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • getNackBehaviour() : telos.I2cApi.Java.NegativeTesterMaster
  • getNegativeTester() : telos.I2cApi.Java.I2cApi
  • getOemSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getOutputTestpin() : telos.I2cApi.Java.I2cApi
  • getPecSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getPendingAlerts() : telos.I2cApi.Java.SmbMaster
  • getPreTrigger() : telos.I2cApi.Java.Adc
  • getRestartAfterNackOrStop() : telos.I2cApi.Java.NegativeTesterSlave
  • getSamplingRate() : telos.I2cApi.Java.Adc
  • getSerialNumberAsString() : telos.I2cApi.Java.Board
  • getSiliconRevision() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getSlaveAddress() : telos.I2cApi.Java.NegativeTesterSlave
  • getSlaveAddressMask() : telos.I2cApi.Java.NegativeTesterSlave
  • getSlaveData() : telos.I2cApi.Java.I2cApi
  • getSmbMaster() : telos.I2cApi.Java.I2cApi
  • getSmbusVersion() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getStopAtArbitrationLost() : telos.I2cApi.Java.NegativeTesterMaster
  • getStretching() : telos.I2cApi.Java.NegativeTesterSlave
  • getSubsystemDeviceId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getSubsystemVendorId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getTermination() : telos.I2cApi.Java.I2cApi
  • getTestpin1() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • getTestpin2() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • getTestpinConfigurationAck() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationError() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationNack() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationStart() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationStop() : telos.I2cApi.Java.I2cApi
  • getTimeBuf() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeSp() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • getTracer() : telos.I2cApi.Java.I2cApi
  • getTxDirection() : telos.I2cApi.Java.SmbMasterMessageQuickCommand
  • getUdid() : telos.I2cApi.Java.SmbArpMaster
  • getUdidVersion() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getUseAckAsTrigger() : telos.I2cApi.Java.Adc
  • getUseErrorAsTrigger() : telos.I2cApi.Java.Adc
  • getUseNackAsTrigger() : telos.I2cApi.Java.Adc
  • getUseStartAsTrigger() : telos.I2cApi.Java.Adc
  • getUseStopAsTrigger() : telos.I2cApi.Java.Adc
  • getUseTestpin1AsTrigger() : telos.I2cApi.Java.Adc
  • getUseTestpin2AsTrigger() : telos.I2cApi.Java.Adc
  • getVendorId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getVendorSpecificId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getWatchdog() : telos.I2cApi.Java.I2cApi
  • getWithPec() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageGroupCmd , telos.I2cApi.Java.SmbMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • getZoneSupport() : telos.I2cApi.Java.SmbArpMaster.Udid


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • hashCode() : telos.I2cApi.Java.I2cAddress
  • high_level_threshold : telos.I2cApi.Java.Board


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • I2C_BUS_STATE_NORMAL : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_SCL_LOW : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_SCL_SDA_LOW : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_SDA_LOW : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_UNKNOWN : telos.I2cApi.Java.I2cApi.I2cBusState
  • i2c_vcc_supply : telos.I2cApi.Java.Board
  • I2cAddress() : telos.I2cApi.Java.I2cAddress
  • I2cApi() : telos.I2cApi.Java.I2cApi
  • ignore_stretching : telos.I2cApi.Java.NegativeTester.LevelsMaster
  • isAddressAvailable() : telos.I2cApi.Java.SmbArpMaster.Udid
  • isValidI2cAddress() : telos.I2cApi.Java.I2cAddress
  • isValidSmbAddress() : telos.I2cApi.Java.I2cAddress


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • levels : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • LevelsMaster() : telos.I2cApi.Java.NegativeTester.LevelsMaster
  • loop : telos.I2cApi.Java.NegativeTester.MessagesSlave
  • loop_cnt : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • low_level_threshold : telos.I2cApi.Java.Board


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • master : telos.I2cApi.Java.Board
  • master_bitrates : telos.I2cApi.Java.Board
  • master_bitrates_hs : telos.I2cApi.Java.Board
  • MessagesMaster() : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • MessagesSlave() : telos.I2cApi.Java.NegativeTester.MessagesSlave
  • MFR_SPECIFIC_COMMAND_EXT : telos.I2cApi.Java.PmbusMasterMessage
  • MSG_DATA_LOST : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_FRAME_DATA : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_FRAME_START : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_FRAME_STOP : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_I2C_PROTOCOL_ERROR : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_SMB_POWER_OFF : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_SMB_POWER_ON : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_TRACER_RESTARTED : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • msgs : telos.I2cApi.Java.NegativeTester.MessagesSlave


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • nack_behaviour : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • NACK_GENERATE_STOP : telos.I2cApi.Java.NegativeTester.NackBehaviour
  • NACK_RELEASE_SCL_SDA : telos.I2cApi.Java.NegativeTester.NackBehaviour
  • NACK_RESTART : telos.I2cApi.Java.NegativeTester.NackBehaviour
  • negative_tester : telos.I2cApi.Java.Board
  • NegativeTesterMaster() : telos.I2cApi.Java.NegativeTesterMaster
  • NegativeTesterSlave() : telos.I2cApi.Java.NegativeTesterSlave


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • open() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PMBUS_COMMAND_EXT : telos.I2cApi.Java.PmbusMasterMessage
  • PMBUS_ZONE_READ : telos.I2cApi.Java.I2cAddress
  • PMBUS_ZONE_WRITE : telos.I2cApi.Java.I2cAddress
  • PmbusMasterMessage() : telos.I2cApi.Java.PmbusMasterMessage
  • PmbusMasterMessageCmd() : telos.I2cApi.Java.PmbusMasterMessageCmd
  • PmbusMasterMessageExtCmdByte() : telos.I2cApi.Java.PmbusMasterMessageExtCmdByte
  • PmbusMasterMessageExtCmdWord() : telos.I2cApi.Java.PmbusMasterMessageExtCmdWord
  • PmbusMasterMessageGroupCmd() : telos.I2cApi.Java.PmbusMasterMessageGroupCmd
  • PmbusMasterMessageReadByte() : telos.I2cApi.Java.PmbusMasterMessageReadByte
  • PmbusMasterMessageReadWord() : telos.I2cApi.Java.PmbusMasterMessageReadWord
  • PmbusMasterMessageWriteByte() : telos.I2cApi.Java.PmbusMasterMessageWriteByte
  • PmbusMasterMessageWriteWord() : telos.I2cApi.Java.PmbusMasterMessageWriteWord
  • prepareToArp() : telos.I2cApi.Java.SmbArpMaster
  • pretrigger : telos.I2cApi.Java.AdcData


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • raw : telos.I2cApi.Java.SmbArpMaster.Udid
  • receive() : telos.I2cApi.Java.I2cApi
  • receiveAckBit() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveAckBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveBit() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveByte() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveByteHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveMessages() : telos.I2cApi.Java.InputTestpins , telos.I2cApi.Java.Tracer
  • resetDevice() : telos.I2cApi.Java.SmbArpMaster
  • restart_after_nack_or_stop : telos.I2cApi.Java.NegativeTester.MessagesSlave


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • sampling_rate : telos.I2cApi.Java.AdcData
  • scanAddresses() : telos.I2cApi.Java.I2cApi
  • scl : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • sda : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • sendAckBit() : telos.I2cApi.Java.NegativeTesterMaster
  • sendAckBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendBit() : telos.I2cApi.Java.NegativeTesterMaster
  • sendBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendByte() : telos.I2cApi.Java.NegativeTesterMaster
  • sendByteHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendHighSpeedToken() : telos.I2cApi.Java.NegativeTesterMaster
  • sendNackBit() : telos.I2cApi.Java.NegativeTesterMaster
  • sendNackBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendPmbusMasterMessage() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiver() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiverHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiverWithoutStop() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiverWithoutStopHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendRepeatedStart() : telos.I2cApi.Java.NegativeTesterMaster
  • sendRepeatedStartHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendSmbMasterMessage() : telos.I2cApi.Java.NegativeTesterMaster
  • sendStart() : telos.I2cApi.Java.NegativeTesterMaster
  • sendStop() : telos.I2cApi.Java.NegativeTesterMaster
  • sendStopHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitter() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterReceiver() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterReceiverHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterWithoutStop() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterWithoutStopHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • serial_number : telos.I2cApi.Java.Board
  • setAddress() : telos.I2cApi.Java.I2cAddress , telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbArpMaster.Udid , telos.I2cApi.Java.SmbMasterMessage
  • setBitrate() : telos.I2cApi.Java.I2cApi , telos.I2cApi.Java.NegativeTesterMaster
  • setBitrateHighspeed() : telos.I2cApi.Java.I2cApi
  • setBitrateHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • setBusType() : telos.I2cApi.Java.I2cApi
  • setCommand() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageCmd
  • setCommandExtension() : telos.I2cApi.Java.PmbusMasterMessage
  • setCreateSpikes() : telos.I2cApi.Java.NegativeTesterMaster
  • setData() : telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.PmbusMasterMessageExtCmdByte , telos.I2cApi.Java.PmbusMasterMessageExtCmdWord , telos.I2cApi.Java.SmbMasterMessageCmd32 , telos.I2cApi.Java.SmbMasterMessageCmd64 , telos.I2cApi.Java.SmbMasterMessageCmdBlock , telos.I2cApi.Java.SmbMasterMessageCmdByte , telos.I2cApi.Java.SmbMasterMessageCmdWord , telos.I2cApi.Java.SmbMasterMessageHostNotify , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • setDataRx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
  • setDataTx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead , telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • setEnabled() : telos.I2cApi.Java.InputTestpins , telos.I2cApi.Java.Tracer
  • setHighLevelThreshold() : telos.I2cApi.Java.I2cApi
  • setHighspeedMasterCode() : telos.I2cApi.Java.I2cApi
  • setHighSpeedToken() : telos.I2cApi.Java.NegativeTesterMaster
  • setI2cVccSupply() : telos.I2cApi.Java.I2cApi
  • setIgnoreStretching() : telos.I2cApi.Java.NegativeTesterMaster
  • setLoopCount() : telos.I2cApi.Java.NegativeTesterMaster
  • setLoopMode() : telos.I2cApi.Java.NegativeTesterSlave
  • setLowLevelThreshold() : telos.I2cApi.Java.I2cApi
  • setMessageCountTrigger() : telos.I2cApi.Java.Adc
  • setMessageDataTrigger() : telos.I2cApi.Java.Adc
  • setNackBehaviour() : telos.I2cApi.Java.NegativeTesterMaster
  • setOutputTestpin() : telos.I2cApi.Java.I2cApi
  • setPreTrigger() : telos.I2cApi.Java.Adc
  • setRestartAfterNackOrStop() : telos.I2cApi.Java.NegativeTesterSlave
  • setSamplingRate() : telos.I2cApi.Java.Adc
  • setSlaveAddress() : telos.I2cApi.Java.NegativeTesterSlave
  • setSlaveAddressMask() : telos.I2cApi.Java.NegativeTesterSlave
  • setSlaveData() : telos.I2cApi.Java.I2cApi
  • setStopAtArbitrationLost() : telos.I2cApi.Java.NegativeTesterMaster
  • setStretching() : telos.I2cApi.Java.NegativeTesterSlave
  • setTermination() : telos.I2cApi.Java.I2cApi
  • setTestpin1() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • setTestpin2() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • setTestpinConfiguration() : telos.I2cApi.Java.I2cApi
  • setTimeBuf() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeSp() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • setTxDirection() : telos.I2cApi.Java.SmbMasterMessageQuickCommand
  • setUseAckAsTrigger() : telos.I2cApi.Java.Adc
  • setUseErrorAsTrigger() : telos.I2cApi.Java.Adc
  • setUseNackAsTrigger() : telos.I2cApi.Java.Adc
  • setUseStartAsTrigger() : telos.I2cApi.Java.Adc
  • setUseStopAsTrigger() : telos.I2cApi.Java.Adc
  • setUseTestpin1AsTrigger() : telos.I2cApi.Java.Adc
  • setUseTestpin2AsTrigger() : telos.I2cApi.Java.Adc
  • setWatchdog() : telos.I2cApi.Java.I2cApi
  • setWithPec() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageGroupCmd , telos.I2cApi.Java.SmbMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • SmbArpMaster() : telos.I2cApi.Java.SmbArpMaster
  • SmbMasterMessage() : telos.I2cApi.Java.SmbMasterMessage
  • SmbMasterMessageBlockRead() : telos.I2cApi.Java.SmbMasterMessageBlockRead
  • SmbMasterMessageBlockWrite() : telos.I2cApi.Java.SmbMasterMessageBlockWrite
  • SmbMasterMessageBlockWriteRead() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
  • SmbMasterMessageCmd() : telos.I2cApi.Java.SmbMasterMessageCmd
  • SmbMasterMessageCmd32() : telos.I2cApi.Java.SmbMasterMessageCmd32
  • SmbMasterMessageCmd64() : telos.I2cApi.Java.SmbMasterMessageCmd64
  • SmbMasterMessageCmdBlock() : telos.I2cApi.Java.SmbMasterMessageCmdBlock
  • SmbMasterMessageCmdByte() : telos.I2cApi.Java.SmbMasterMessageCmdByte
  • SmbMasterMessageCmdProcessCall() : telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • SmbMasterMessageCmdWord() : telos.I2cApi.Java.SmbMasterMessageCmdWord
  • SmbMasterMessageHostNotify() : telos.I2cApi.Java.SmbMasterMessageHostNotify
  • SmbMasterMessageQuickCommand() : telos.I2cApi.Java.SmbMasterMessageQuickCommand
  • SmbMasterMessageRead32() : telos.I2cApi.Java.SmbMasterMessageRead32
  • SmbMasterMessageRead64() : telos.I2cApi.Java.SmbMasterMessageRead64
  • SmbMasterMessageReadByte() : telos.I2cApi.Java.SmbMasterMessageReadByte
  • SmbMasterMessageReadWord() : telos.I2cApi.Java.SmbMasterMessageReadWord
  • SmbMasterMessageReceiveByte() : telos.I2cApi.Java.SmbMasterMessageReceiveByte
  • SmbMasterMessageSendByte() : telos.I2cApi.Java.SmbMasterMessageSendByte
  • SmbMasterMessageWrite32() : telos.I2cApi.Java.SmbMasterMessageWrite32
  • SmbMasterMessageWrite64() : telos.I2cApi.Java.SmbMasterMessageWrite64
  • SmbMasterMessageWriteByte() : telos.I2cApi.Java.SmbMasterMessageWriteByte
  • SmbMasterMessageWriteWord() : telos.I2cApi.Java.SmbMasterMessageWriteWord
  • SMBUS_ALERT_RESPONSE : telos.I2cApi.Java.I2cAddress
  • SMBUS_DEVICE_DEFAULT : telos.I2cApi.Java.I2cAddress
  • SMBUS_HOST : telos.I2cApi.Java.I2cAddress
  • start() : telos.I2cApi.Java.Adc
  • startImmediately() : telos.I2cApi.Java.Adc
  • startMaster() : telos.I2cApi.Java.NegativeTester
  • startSlave() : telos.I2cApi.Java.NegativeTester
  • status : telos.I2cApi.Java.InputTestpinsMessage
  • status_available : telos.I2cApi.Java.InputTestpinsMessage
  • stop() : telos.I2cApi.Java.NegativeTester
  • STOP_TRIGGER_ARBITRATION_LOST : telos.I2cApi.Java.NegativeTester.StopTrigger
  • STOP_TRIGGER_ARBITRATION_NOT_LOST : telos.I2cApi.Java.NegativeTester.StopTrigger
  • STOP_TRIGGER_NONE : telos.I2cApi.Java.NegativeTester.StopTrigger


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • termination : telos.I2cApi.Java.Board
  • testpin1 : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • testpin2 : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • testpin_ack : telos.I2cApi.Java.Board
  • testpin_error : telos.I2cApi.Java.Board
  • testpin_nack : telos.I2cApi.Java.Board
  • testpin_start : telos.I2cApi.Java.Board
  • testpin_stop : telos.I2cApi.Java.Board
  • testpins_in : telos.I2cApi.Java.Board
  • testpins_out : telos.I2cApi.Java.Board
  • time : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • TIMEBASE : telos.I2cApi.Java.NegativeTester
  • timestamp : telos.I2cApi.Java.InputTestpinsMessage , telos.I2cApi.Java.TracerMessage
  • timestamp_start : telos.I2cApi.Java.AdcData
  • timestamp_stop : telos.I2cApi.Java.AdcData
  • timestamp_timebase : telos.I2cApi.Java.Board
  • toString() : telos.I2cApi.Java.I2cAddress
  • tracer : telos.I2cApi.Java.Board
  • transferData() : telos.I2cApi.Java.Adc , telos.I2cApi.Java.SmbMaster
  • transmit() : telos.I2cApi.Java.I2cApi
  • transmitReceive() : telos.I2cApi.Java.I2cApi
  • type : telos.I2cApi.Java.TracerMessage


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • Udid() : telos.I2cApi.Java.SmbArpMaster.Udid


I2C.Java API: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • waitForData() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- a -

  • assignAddress() : telos.I2cApi.Java.SmbArpMaster


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- c -

  • cancel() : telos.I2cApi.Java.Adc
  • clear() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • close() : telos.I2cApi.Java.I2cApi
  • convertNanosecondsToTicks() : telos.I2cApi.Java.NegativeTester
  • convertTicksToNanoseconds() : telos.I2cApi.Java.NegativeTester
  • createReceiver() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverAckBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverByte() : telos.I2cApi.Java.NegativeTesterSlave
  • createReceiverNackBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createStart() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitter() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitterAckBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitterBit() : telos.I2cApi.Java.NegativeTesterSlave
  • createTransmitterByte() : telos.I2cApi.Java.NegativeTesterSlave


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- d -

  • delay() : telos.I2cApi.Java.NegativeTesterMaster
  • disableAddress() : telos.I2cApi.Java.Tracer
  • disableAllAddresses() : telos.I2cApi.Java.Tracer
  • disableSlave() : telos.I2cApi.Java.I2cApi
  • dispose() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- e -

  • enableAddress() : telos.I2cApi.Java.Tracer
  • enableAllAddresses() : telos.I2cApi.Java.Tracer
  • enableSlave() : telos.I2cApi.Java.I2cApi
  • equals() : telos.I2cApi.Java.I2cAddress
  • executeArp() : telos.I2cApi.Java.SmbArpMaster


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- f -

  • findBoards() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- g -

  • getAdc() : telos.I2cApi.Java.I2cApi
  • getAddress() : telos.I2cApi.Java.I2cAddress , telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbArpMaster.Udid , telos.I2cApi.Java.SmbMasterMessage
  • getAddressType() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getAsfSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getAsVhd() : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • getBitrate() : telos.I2cApi.Java.I2cApi , telos.I2cApi.Java.NegativeTesterMaster
  • getBitrateHighspeed() : telos.I2cApi.Java.I2cApi
  • getBitrateHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • getBoardTypeAsString() : telos.I2cApi.Java.Board
  • getBusType() : telos.I2cApi.Java.I2cApi
  • getCommand() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageCmd
  • getCommandExtension() : telos.I2cApi.Java.PmbusMasterMessage
  • getCreateSpikes() : telos.I2cApi.Java.NegativeTesterMaster
  • getData() : telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.PmbusMasterMessageExtCmdByte , telos.I2cApi.Java.PmbusMasterMessageExtCmdWord , telos.I2cApi.Java.SmbMasterMessageCmd32 , telos.I2cApi.Java.SmbMasterMessageCmd64 , telos.I2cApi.Java.SmbMasterMessageCmdBlock , telos.I2cApi.Java.SmbMasterMessageCmdByte , telos.I2cApi.Java.SmbMasterMessageCmdWord , telos.I2cApi.Java.SmbMasterMessageHostNotify , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • getDataRx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead , telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • getDataTx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead , telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • getDeviceId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getEnabled() : telos.I2cApi.Java.InputTestpins , telos.I2cApi.Java.Tracer
  • getHighLevelThreshold() : telos.I2cApi.Java.I2cApi
  • getHighspeedMasterCode() : telos.I2cApi.Java.I2cApi
  • getHighSpeedToken() : telos.I2cApi.Java.NegativeTesterMaster
  • getI2cBusLoad() : telos.I2cApi.Java.I2cApi
  • getI2cState() : telos.I2cApi.Java.I2cApi
  • getI2cVcc() : telos.I2cApi.Java.I2cApi
  • getI2cVccSupply() : telos.I2cApi.Java.I2cApi
  • getIgnoreStretching() : telos.I2cApi.Java.NegativeTesterMaster
  • getInfo() : telos.I2cApi.Java.I2cApi
  • getInputTestpin() : telos.I2cApi.Java.I2cApi
  • getInputTestpins() : telos.I2cApi.Java.Tracer
  • getIpmiSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getIsOpen() : telos.I2cApi.Java.I2cApi
  • getIsRunning() : telos.I2cApi.Java.NegativeTester
  • getIsTenBitAddress() : telos.I2cApi.Java.I2cAddress
  • getLoopCount() : telos.I2cApi.Java.NegativeTesterMaster
  • getLoopMode() : telos.I2cApi.Java.NegativeTesterSlave
  • getLowLevelThreshold() : telos.I2cApi.Java.I2cApi
  • getMessageCountTrigger() : telos.I2cApi.Java.Adc
  • getMessageDataTriggerData() : telos.I2cApi.Java.Adc
  • getMessageDataTriggerDontCare() : telos.I2cApi.Java.Adc
  • getMessages() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • getNackBehaviour() : telos.I2cApi.Java.NegativeTesterMaster
  • getNegativeTester() : telos.I2cApi.Java.I2cApi
  • getOemSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getOutputTestpin() : telos.I2cApi.Java.I2cApi
  • getPecSupport() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getPendingAlerts() : telos.I2cApi.Java.SmbMaster
  • getPreTrigger() : telos.I2cApi.Java.Adc
  • getRestartAfterNackOrStop() : telos.I2cApi.Java.NegativeTesterSlave
  • getSamplingRate() : telos.I2cApi.Java.Adc
  • getSerialNumberAsString() : telos.I2cApi.Java.Board
  • getSiliconRevision() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getSlaveAddress() : telos.I2cApi.Java.NegativeTesterSlave
  • getSlaveAddressMask() : telos.I2cApi.Java.NegativeTesterSlave
  • getSlaveData() : telos.I2cApi.Java.I2cApi
  • getSmbMaster() : telos.I2cApi.Java.I2cApi
  • getSmbusVersion() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getStopAtArbitrationLost() : telos.I2cApi.Java.NegativeTesterMaster
  • getStretching() : telos.I2cApi.Java.NegativeTesterSlave
  • getSubsystemDeviceId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getSubsystemVendorId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getTermination() : telos.I2cApi.Java.I2cApi
  • getTestpin1() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • getTestpin2() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • getTestpinConfigurationAck() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationError() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationNack() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationStart() : telos.I2cApi.Java.I2cApi
  • getTestpinConfigurationStop() : telos.I2cApi.Java.I2cApi
  • getTimeBuf() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeHighSpeedSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeSp() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • getTimeSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • getTracer() : telos.I2cApi.Java.I2cApi
  • getTxDirection() : telos.I2cApi.Java.SmbMasterMessageQuickCommand
  • getUdid() : telos.I2cApi.Java.SmbArpMaster
  • getUdidVersion() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getUseAckAsTrigger() : telos.I2cApi.Java.Adc
  • getUseErrorAsTrigger() : telos.I2cApi.Java.Adc
  • getUseNackAsTrigger() : telos.I2cApi.Java.Adc
  • getUseStartAsTrigger() : telos.I2cApi.Java.Adc
  • getUseStopAsTrigger() : telos.I2cApi.Java.Adc
  • getUseTestpin1AsTrigger() : telos.I2cApi.Java.Adc
  • getUseTestpin2AsTrigger() : telos.I2cApi.Java.Adc
  • getVendorId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getVendorSpecificId() : telos.I2cApi.Java.SmbArpMaster.Udid
  • getWatchdog() : telos.I2cApi.Java.I2cApi
  • getWithPec() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageGroupCmd , telos.I2cApi.Java.SmbMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • getZoneSupport() : telos.I2cApi.Java.SmbArpMaster.Udid


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- h -

  • hashCode() : telos.I2cApi.Java.I2cAddress


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- i -

  • I2cAddress() : telos.I2cApi.Java.I2cAddress
  • I2cApi() : telos.I2cApi.Java.I2cApi
  • isAddressAvailable() : telos.I2cApi.Java.SmbArpMaster.Udid
  • isValidI2cAddress() : telos.I2cApi.Java.I2cAddress
  • isValidSmbAddress() : telos.I2cApi.Java.I2cAddress


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- l -

  • LevelsMaster() : telos.I2cApi.Java.NegativeTester.LevelsMaster


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- m -

  • MessagesMaster() : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • MessagesSlave() : telos.I2cApi.Java.NegativeTester.MessagesSlave


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- n -

  • NegativeTesterMaster() : telos.I2cApi.Java.NegativeTesterMaster
  • NegativeTesterSlave() : telos.I2cApi.Java.NegativeTesterSlave


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- o -

  • open() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- p -

  • PmbusMasterMessage() : telos.I2cApi.Java.PmbusMasterMessage
  • PmbusMasterMessageCmd() : telos.I2cApi.Java.PmbusMasterMessageCmd
  • PmbusMasterMessageExtCmdByte() : telos.I2cApi.Java.PmbusMasterMessageExtCmdByte
  • PmbusMasterMessageExtCmdWord() : telos.I2cApi.Java.PmbusMasterMessageExtCmdWord
  • PmbusMasterMessageGroupCmd() : telos.I2cApi.Java.PmbusMasterMessageGroupCmd
  • PmbusMasterMessageReadByte() : telos.I2cApi.Java.PmbusMasterMessageReadByte
  • PmbusMasterMessageReadWord() : telos.I2cApi.Java.PmbusMasterMessageReadWord
  • PmbusMasterMessageWriteByte() : telos.I2cApi.Java.PmbusMasterMessageWriteByte
  • PmbusMasterMessageWriteWord() : telos.I2cApi.Java.PmbusMasterMessageWriteWord
  • prepareToArp() : telos.I2cApi.Java.SmbArpMaster


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- r -

  • receive() : telos.I2cApi.Java.I2cApi
  • receiveAckBit() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveAckBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveBit() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveByte() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveByteHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • receiveMessages() : telos.I2cApi.Java.InputTestpins , telos.I2cApi.Java.Tracer
  • resetDevice() : telos.I2cApi.Java.SmbArpMaster


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- s -

  • scanAddresses() : telos.I2cApi.Java.I2cApi
  • sendAckBit() : telos.I2cApi.Java.NegativeTesterMaster
  • sendAckBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendBit() : telos.I2cApi.Java.NegativeTesterMaster
  • sendBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendByte() : telos.I2cApi.Java.NegativeTesterMaster
  • sendByteHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendHighSpeedToken() : telos.I2cApi.Java.NegativeTesterMaster
  • sendNackBit() : telos.I2cApi.Java.NegativeTesterMaster
  • sendNackBitHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendPmbusMasterMessage() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiver() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiverHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiverWithoutStop() : telos.I2cApi.Java.NegativeTesterMaster
  • sendReceiverWithoutStopHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendRepeatedStart() : telos.I2cApi.Java.NegativeTesterMaster
  • sendRepeatedStartHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendSmbMasterMessage() : telos.I2cApi.Java.NegativeTesterMaster
  • sendStart() : telos.I2cApi.Java.NegativeTesterMaster
  • sendStop() : telos.I2cApi.Java.NegativeTesterMaster
  • sendStopHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitter() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterReceiver() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterReceiverHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterWithoutStop() : telos.I2cApi.Java.NegativeTesterMaster
  • sendTransmitterWithoutStopHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • setAddress() : telos.I2cApi.Java.I2cAddress , telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbArpMaster.Udid , telos.I2cApi.Java.SmbMasterMessage
  • setBitrate() : telos.I2cApi.Java.I2cApi , telos.I2cApi.Java.NegativeTesterMaster
  • setBitrateHighspeed() : telos.I2cApi.Java.I2cApi
  • setBitrateHighSpeed() : telos.I2cApi.Java.NegativeTesterMaster
  • setBusType() : telos.I2cApi.Java.I2cApi
  • setCommand() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageCmd
  • setCommandExtension() : telos.I2cApi.Java.PmbusMasterMessage
  • setCreateSpikes() : telos.I2cApi.Java.NegativeTesterMaster
  • setData() : telos.I2cApi.Java.PmbusMasterMessageCmd , telos.I2cApi.Java.PmbusMasterMessageExtCmdByte , telos.I2cApi.Java.PmbusMasterMessageExtCmdWord , telos.I2cApi.Java.SmbMasterMessageCmd32 , telos.I2cApi.Java.SmbMasterMessageCmd64 , telos.I2cApi.Java.SmbMasterMessageCmdBlock , telos.I2cApi.Java.SmbMasterMessageCmdByte , telos.I2cApi.Java.SmbMasterMessageCmdWord , telos.I2cApi.Java.SmbMasterMessageHostNotify , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • setDataRx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
  • setDataTx() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead , telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • setEnabled() : telos.I2cApi.Java.InputTestpins , telos.I2cApi.Java.Tracer
  • setHighLevelThreshold() : telos.I2cApi.Java.I2cApi
  • setHighspeedMasterCode() : telos.I2cApi.Java.I2cApi
  • setHighSpeedToken() : telos.I2cApi.Java.NegativeTesterMaster
  • setI2cVccSupply() : telos.I2cApi.Java.I2cApi
  • setIgnoreStretching() : telos.I2cApi.Java.NegativeTesterMaster
  • setLoopCount() : telos.I2cApi.Java.NegativeTesterMaster
  • setLoopMode() : telos.I2cApi.Java.NegativeTesterSlave
  • setLowLevelThreshold() : telos.I2cApi.Java.I2cApi
  • setMessageCountTrigger() : telos.I2cApi.Java.Adc
  • setMessageDataTrigger() : telos.I2cApi.Java.Adc
  • setNackBehaviour() : telos.I2cApi.Java.NegativeTesterMaster
  • setOutputTestpin() : telos.I2cApi.Java.I2cApi
  • setPreTrigger() : telos.I2cApi.Java.Adc
  • setRestartAfterNackOrStop() : telos.I2cApi.Java.NegativeTesterSlave
  • setSamplingRate() : telos.I2cApi.Java.Adc
  • setSlaveAddress() : telos.I2cApi.Java.NegativeTesterSlave
  • setSlaveAddressMask() : telos.I2cApi.Java.NegativeTesterSlave
  • setSlaveData() : telos.I2cApi.Java.I2cApi
  • setStopAtArbitrationLost() : telos.I2cApi.Java.NegativeTesterMaster
  • setStretching() : telos.I2cApi.Java.NegativeTesterSlave
  • setTermination() : telos.I2cApi.Java.I2cApi
  • setTestpin1() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • setTestpin2() : telos.I2cApi.Java.NegativeTesterMaster , telos.I2cApi.Java.NegativeTesterSlave
  • setTestpinConfiguration() : telos.I2cApi.Java.I2cApi
  • setTimeBuf() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedHdSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeHighSpeedSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeLowAfterHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeLowBeforeHigh() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeSp() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeSuSta() : telos.I2cApi.Java.NegativeTesterMaster
  • setTimeSuSto() : telos.I2cApi.Java.NegativeTesterMaster
  • setTxDirection() : telos.I2cApi.Java.SmbMasterMessageQuickCommand
  • setUseAckAsTrigger() : telos.I2cApi.Java.Adc
  • setUseErrorAsTrigger() : telos.I2cApi.Java.Adc
  • setUseNackAsTrigger() : telos.I2cApi.Java.Adc
  • setUseStartAsTrigger() : telos.I2cApi.Java.Adc
  • setUseStopAsTrigger() : telos.I2cApi.Java.Adc
  • setUseTestpin1AsTrigger() : telos.I2cApi.Java.Adc
  • setUseTestpin2AsTrigger() : telos.I2cApi.Java.Adc
  • setWatchdog() : telos.I2cApi.Java.I2cApi
  • setWithPec() : telos.I2cApi.Java.PmbusMasterMessage , telos.I2cApi.Java.PmbusMasterMessageGroupCmd , telos.I2cApi.Java.SmbMasterMessageCmd , telos.I2cApi.Java.SmbMasterMessageReceiveByte , telos.I2cApi.Java.SmbMasterMessageSendByte
  • SmbArpMaster() : telos.I2cApi.Java.SmbArpMaster
  • SmbMasterMessage() : telos.I2cApi.Java.SmbMasterMessage
  • SmbMasterMessageBlockRead() : telos.I2cApi.Java.SmbMasterMessageBlockRead
  • SmbMasterMessageBlockWrite() : telos.I2cApi.Java.SmbMasterMessageBlockWrite
  • SmbMasterMessageBlockWriteRead() : telos.I2cApi.Java.SmbMasterMessageBlockWriteRead
  • SmbMasterMessageCmd() : telos.I2cApi.Java.SmbMasterMessageCmd
  • SmbMasterMessageCmd32() : telos.I2cApi.Java.SmbMasterMessageCmd32
  • SmbMasterMessageCmd64() : telos.I2cApi.Java.SmbMasterMessageCmd64
  • SmbMasterMessageCmdBlock() : telos.I2cApi.Java.SmbMasterMessageCmdBlock
  • SmbMasterMessageCmdByte() : telos.I2cApi.Java.SmbMasterMessageCmdByte
  • SmbMasterMessageCmdProcessCall() : telos.I2cApi.Java.SmbMasterMessageCmdProcessCall
  • SmbMasterMessageCmdWord() : telos.I2cApi.Java.SmbMasterMessageCmdWord
  • SmbMasterMessageHostNotify() : telos.I2cApi.Java.SmbMasterMessageHostNotify
  • SmbMasterMessageQuickCommand() : telos.I2cApi.Java.SmbMasterMessageQuickCommand
  • SmbMasterMessageRead32() : telos.I2cApi.Java.SmbMasterMessageRead32
  • SmbMasterMessageRead64() : telos.I2cApi.Java.SmbMasterMessageRead64
  • SmbMasterMessageReadByte() : telos.I2cApi.Java.SmbMasterMessageReadByte
  • SmbMasterMessageReadWord() : telos.I2cApi.Java.SmbMasterMessageReadWord
  • SmbMasterMessageReceiveByte() : telos.I2cApi.Java.SmbMasterMessageReceiveByte
  • SmbMasterMessageSendByte() : telos.I2cApi.Java.SmbMasterMessageSendByte
  • SmbMasterMessageWrite32() : telos.I2cApi.Java.SmbMasterMessageWrite32
  • SmbMasterMessageWrite64() : telos.I2cApi.Java.SmbMasterMessageWrite64
  • SmbMasterMessageWriteByte() : telos.I2cApi.Java.SmbMasterMessageWriteByte
  • SmbMasterMessageWriteWord() : telos.I2cApi.Java.SmbMasterMessageWriteWord
  • start() : telos.I2cApi.Java.Adc
  • startImmediately() : telos.I2cApi.Java.Adc
  • startMaster() : telos.I2cApi.Java.NegativeTester
  • startSlave() : telos.I2cApi.Java.NegativeTester
  • stop() : telos.I2cApi.Java.NegativeTester


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- t -

  • toString() : telos.I2cApi.Java.I2cAddress
  • transferData() : telos.I2cApi.Java.Adc , telos.I2cApi.Java.SmbMaster
  • transmit() : telos.I2cApi.Java.I2cApi
  • transmitReceive() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- u -

  • Udid() : telos.I2cApi.Java.SmbArpMaster.Udid


I2C.Java API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- w -

  • waitForData() : telos.I2cApi.Java.I2cApi


I2C.Java API: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t

- a -

  • adc : telos.I2cApi.Java.Board
  • adc_max_pretrigger : telos.I2cApi.Java.Board
  • adc_sampling_depth : telos.I2cApi.Java.Board
  • adc_samplingrate : telos.I2cApi.Java.Board
  • adc_trigger_ack : telos.I2cApi.Java.Board
  • adc_trigger_data : telos.I2cApi.Java.Board
  • adc_trigger_error : telos.I2cApi.Java.Board
  • adc_trigger_immediately : telos.I2cApi.Java.Board
  • adc_trigger_msg_cnt : telos.I2cApi.Java.Board
  • adc_trigger_nack : telos.I2cApi.Java.Board
  • adc_trigger_start : telos.I2cApi.Java.Board
  • adc_trigger_stop : telos.I2cApi.Java.Board
  • adc_trigger_testpin1 : telos.I2cApi.Java.Board
  • adc_trigger_testpin2 : telos.I2cApi.Java.Board
  • adc_vcc : telos.I2cApi.Java.Board
  • addr : telos.I2cApi.Java.SmbArpMaster.Udid
  • ADDR_TYPE_DYNAMIC_PERSISTENT : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
  • ADDR_TYPE_DYNAMIC_VOLATILE : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
  • ADDR_TYPE_FIXED : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType
  • ADDR_TYPE_RANDOM : telos.I2cApi.Java.SmbArpMaster.Udid.AddressType

- b -

  • board_type : telos.I2cApi.Java.Board
  • BOARD_TYPE_CONNII : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_CONNII_MM : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_CONNII_MM2 : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_DUMMY : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_TRACII_XL : telos.I2cApi.Java.Board.BoardType
  • BOARD_TYPE_TRACII_XL2 : telos.I2cApi.Java.Board.BoardType
  • BUS_TYPE_I2C : telos.I2cApi.Java.I2cApi.BusType
  • bus_type_smb : telos.I2cApi.Java.Board
  • BUS_TYPE_SMB : telos.I2cApi.Java.I2cApi.BusType

- c -

  • confirmation : telos.I2cApi.Java.TracerMessage.TracerMessageData

- d -

  • data : telos.I2cApi.Java.TracerMessage , telos.I2cApi.Java.TracerMessage.TracerMessageData
  • DATA_CONFIRMATION_ACK : telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
  • DATA_CONFIRMATION_NACK : telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
  • DATA_CONFIRMATION_NONE : telos.I2cApi.Java.TracerMessage.TracerMessageDataConfirmation
  • data_max : telos.I2cApi.Java.AdcData
  • data_scl : telos.I2cApi.Java.AdcData
  • data_sda : telos.I2cApi.Java.AdcData
  • drive_sda : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave

- e -

  • enable_high_speed_current_source : telos.I2cApi.Java.NegativeTester.LevelsMaster

- g -

  • GENERAL_CALL : telos.I2cApi.Java.I2cAddress

- h -

  • high_level_threshold : telos.I2cApi.Java.Board

- i -

  • I2C_BUS_STATE_NORMAL : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_SCL_LOW : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_SCL_SDA_LOW : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_SDA_LOW : telos.I2cApi.Java.I2cApi.I2cBusState
  • I2C_BUS_STATE_UNKNOWN : telos.I2cApi.Java.I2cApi.I2cBusState
  • i2c_vcc_supply : telos.I2cApi.Java.Board
  • ignore_stretching : telos.I2cApi.Java.NegativeTester.LevelsMaster

- l -

  • levels : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • loop : telos.I2cApi.Java.NegativeTester.MessagesSlave
  • loop_cnt : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • low_level_threshold : telos.I2cApi.Java.Board

- m -

  • master : telos.I2cApi.Java.Board
  • master_bitrates : telos.I2cApi.Java.Board
  • master_bitrates_hs : telos.I2cApi.Java.Board
  • MFR_SPECIFIC_COMMAND_EXT : telos.I2cApi.Java.PmbusMasterMessage
  • MSG_DATA_LOST : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_FRAME_DATA : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_FRAME_START : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_FRAME_STOP : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_I2C_PROTOCOL_ERROR : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_SMB_POWER_OFF : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_SMB_POWER_ON : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • MSG_TRACER_RESTARTED : telos.I2cApi.Java.TracerMessage.TracerMessageType
  • msgs : telos.I2cApi.Java.NegativeTester.MessagesSlave

- n -

  • nack_behaviour : telos.I2cApi.Java.NegativeTester.MessagesMaster
  • NACK_GENERATE_STOP : telos.I2cApi.Java.NegativeTester.NackBehaviour
  • NACK_RELEASE_SCL_SDA : telos.I2cApi.Java.NegativeTester.NackBehaviour
  • NACK_RESTART : telos.I2cApi.Java.NegativeTester.NackBehaviour
  • negative_tester : telos.I2cApi.Java.Board

- p -

  • PMBUS_COMMAND_EXT : telos.I2cApi.Java.PmbusMasterMessage
  • PMBUS_ZONE_READ : telos.I2cApi.Java.I2cAddress
  • PMBUS_ZONE_WRITE : telos.I2cApi.Java.I2cAddress
  • pretrigger : telos.I2cApi.Java.AdcData

- r -

  • raw : telos.I2cApi.Java.SmbArpMaster.Udid
  • restart_after_nack_or_stop : telos.I2cApi.Java.NegativeTester.MessagesSlave

- s -

  • sampling_rate : telos.I2cApi.Java.AdcData
  • scl : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • sda : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • serial_number : telos.I2cApi.Java.Board
  • SMBUS_ALERT_RESPONSE : telos.I2cApi.Java.I2cAddress
  • SMBUS_DEVICE_DEFAULT : telos.I2cApi.Java.I2cAddress
  • SMBUS_HOST : telos.I2cApi.Java.I2cAddress
  • status : telos.I2cApi.Java.InputTestpinsMessage
  • status_available : telos.I2cApi.Java.InputTestpinsMessage
  • STOP_TRIGGER_ARBITRATION_LOST : telos.I2cApi.Java.NegativeTester.StopTrigger
  • STOP_TRIGGER_ARBITRATION_NOT_LOST : telos.I2cApi.Java.NegativeTester.StopTrigger
  • STOP_TRIGGER_NONE : telos.I2cApi.Java.NegativeTester.StopTrigger

- t -

  • termination : telos.I2cApi.Java.Board
  • testpin1 : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • testpin2 : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • testpin_ack : telos.I2cApi.Java.Board
  • testpin_error : telos.I2cApi.Java.Board
  • testpin_nack : telos.I2cApi.Java.Board
  • testpin_start : telos.I2cApi.Java.Board
  • testpin_stop : telos.I2cApi.Java.Board
  • testpins_in : telos.I2cApi.Java.Board
  • testpins_out : telos.I2cApi.Java.Board
  • time : telos.I2cApi.Java.NegativeTester.LevelsMaster , telos.I2cApi.Java.NegativeTester.LevelsSlave
  • TIMEBASE : telos.I2cApi.Java.NegativeTester
  • timestamp : telos.I2cApi.Java.InputTestpinsMessage , telos.I2cApi.Java.TracerMessage
  • timestamp_start : telos.I2cApi.Java.AdcData
  • timestamp_stop : telos.I2cApi.Java.AdcData
  • timestamp_timebase : telos.I2cApi.Java.Board
  • tracer : telos.I2cApi.Java.Board
  • type : telos.I2cApi.Java.TracerMessage


I2C.Java API: Examples

Examples
Here is a list of all examples:
  • adc_example.java
  • i2c_example.java
  • input_testpins_example.java
  • negative_tester_example.java
  • tracer_example.java


I2C.Java API: adc_example.java

adc_example.java

The following example demonstrates how to use the A/D converter with the I2C.Java API

import telos.I2cApi.Java.*;
import java.util.Vector;
public class adc_example
{
private static void showAdcInfo (Board hwinfo)
{
// Display serial number of the I2C interface.
System.out.println();
System.out.printf ("Serial number: 0x%04x", hwinfo.serial_number);
System.out.println();
// Display: A/D convert supported?
System.out.printf ("Supports A/D converter: %b", hwinfo.adc);
System.out.println();
// Return if there is no A/D converter support.
if (hwinfo.adc == false)
return;
// Display: Which events can be used to start the A/D converter.
System.out.print ("Supported trigger conditions: ");
if (hwinfo.adc_trigger_start == true)
System.out.print ("start ");
if (hwinfo.adc_trigger_stop == true)
System.out.print ("stop ");
if (hwinfo.adc_trigger_ack == true)
System.out.print ("ack ");
if (hwinfo.adc_trigger_testpin1 == true)
System.out.print ("testpin1 ");
if (hwinfo.adc_trigger_testpin2 == true)
System.out.print ("testpin2 ");
System.out.println();
// Display: Vcc of the A/D samples. This value specifies the
// voltage of the A/D converter value "255".
System.out.printf ("Vcc of A/D samples: %d mV", (int)hwinfo.adc_vcc);
System.out.println();
// Display the sampling rates supported by the A/D converter.
System.out.print ("Sampling rates: ");
for (int i=0; i < hwinfo.adc_samplingrate.length; i++)
System.out.printf ("%d ", hwinfo.adc_samplingrate[i]);
System.out.println();
// Display the maximum value for the pretrigger setting.
if (hwinfo.adc_max_pretrigger != -1)
{
System.out.printf ("Maximum pretrigger: %d", hwinfo.adc_max_pretrigger);
System.out.println();
}
else
System.out.println ("Pretrigger: N/A");
System.out.println();
}
/*
* Demonstrates the API of the A/D converter.
*/
private static void runAdcTest (I2cApi i2c)
{
Board hwinfo;
AdcData adc_data;
// Get a reference to the object describing the features
// of the used I2C interface.
hwinfo = i2c.getInfo();
// Configure the pretrigger. The pretrigger specifies the
// number of samples, which get stored by the A/D converter
// before detecting the trigger condition.
if (hwinfo.adc_max_pretrigger != ~0)
{
System.out.println ("Setting pretrigger to \"0\" ...");
i2c.getAdc().setPreTrigger (0);
}
// Configure the sampling rate of the A/D converter.
System.out.printf ("Setting sampling rate to \"%d\" Hz ...", hwinfo.adc_samplingrate[0]);
System.out.println();
i2c.getAdc().setSamplingRate (hwinfo.adc_samplingrate[0]);
// Use the I2C start and stop to start the A/D conversion.
System.out.println ("Setting trigger conditions ...");
if (hwinfo.adc_trigger_start == true)
i2c.getAdc().setUseStartAsTrigger (true);
if (hwinfo.adc_trigger_stop == true)
i2c.getAdc().setUseStopAsTrigger (true);
// Start the A/D converter.
System.out.print ("Starting A/D converter ...");
i2c.getAdc().start();
// wait for A/D data
do
{
// wait for new data (timeout: 10 ms)
i2c.waitForData (10 * 1000);
// transfer data
adc_data = i2c.getAdc().transferData();
}
while (adc_data == null);
// show some information
System.out.println (" finished.");
System.out.printf ("SCL samples: %d", adc_data.data_scl.length);
System.out.println();
System.out.printf ("SDA samples: %d", adc_data.data_sda.length);
System.out.println();
System.out.printf ("Timestamp first sample: %d", adc_data.timestamp_start);
System.out.println();
System.out.printf ("Timestamp last sample: %d", adc_data.timestamp_stop);
System.out.println();
System.out.printf ("Maximum value of SCL/SDA samples: %d", (int)adc_data.data_max);
System.out.println();
}
public static void main (String args[])
{
I2cApi i2c = null;
Vector<Board> list_of_boards = new Vector<Board>();;
int i;
try
{
// Create instance of I2C API.
i2c = new I2cApi();
// Get the description of all available I2C interfaces.
i2c.findBoards (list_of_boards);
// Open the first I2C interface supporting the negative tester mode.
for (i = 0; i < list_of_boards.size(); i++)
{
if (list_of_boards.get(i).adc == true)
{
i2c.open (list_of_boards.get (i));
break;
}
}
if (i == list_of_boards.size())
{
System.out.println ("No I2C interface with A/D converter has been found.");
return;
}
else
{
System.out.printf ("Using %s [0x%4h]",
i2c.getInfo().board_type.toString(),
i2c.getInfo().serial_number);
System.out.println();
}
// Show some informations about the used I2C interface.
showAdcInfo (i2c.getInfo());
// Run A/D converter demonstration.
runAdcTest (i2c);
// Close I2C interface.
i2c.close();
}
catch (Exception e)
{
System.out.println();
System.out.println();
System.out.println ("Error: " + e.getMessage());
}
finally
{
if (i2c != null)
{
i2c.dispose();
i2c = null;
}
}
}
};


I2C.Java API: i2c_example.java

i2c_example.java

The following example demonstrates how to use the I2C.Java API

import telos.I2cApi.Java.I2cApi;
import telos.I2cApi.Java.Board;
import telos.I2cApi.Java.I2cAddress;
import java.util.Vector;
public class i2c_example
{
public static void testI2c (I2cApi api) throws Exception
{
Vector<Board> list_of_boards = new Vector<Board>();
Board board_info;
byte[] data;
I2cAddress address;
// find all available I2C interfaces
api.findBoards (list_of_boards);
// show found I2C interfaces
System.out.println ("Found I2C Interfaces:");
for (int i=0 ; i < list_of_boards.size(); i++)
{
board_info = list_of_boards.elementAt(i);
System.out.printf (" %-14s %s%n",
board_info.getBoardTypeAsString(),
board_info.getSerialNumberAsString());
}
// open last I2C interface
System.out.println();
System.out.printf ("Opening %s (%s) ...%n",
list_of_boards.lastElement().getBoardTypeAsString(),
list_of_boards.lastElement().getSerialNumberAsString());
api.open (list_of_boards.lastElement());
// enable I2C Vcc supply, if necessary
/*
if ((api.getI2cVcc() < 1000) &&
(api.getInfo().i2c_vcc_supply.length > 0))
{
api.setI2cVccSupply (api.getInfo().i2c_vcc_supply[api.getInfo().i2c_vcc_supply.length / 2]);
System.out.printf ("%nSetting I2C Vcc Supply to %d mV%n", api.getI2cVccSupply());
}
*/
// show configuration of the I2C interface
System.out.println();
System.out.println ("Current Configuration:");
System.out.println (" I2C Vcc: " + api.getI2cVcc() + " mV");
System.out.println (" I2C Vcc Supply: " + api.getI2cVccSupply() + " mV");
System.out.println (" Termination: " + api.getTermination() + " Ohm");
System.out.println (" Low Threshold: " + api.getLowLevelThreshold() + " %");
System.out.println (" High Threshold: " + api.getHighLevelThreshold() + " %");
// show input testpins
System.out.print (" Input Testpins: ");
for (int i=0; i < api.getInfo().testpins_in; i++)
{
if (api.getInputTestpin (i) == true)
System.out.print("HIGH ");
else
System.out.print("LOW ");
}
System.out.println();
// show output testpins
System.out.print (" Output Testpins: ");
for (int i=0; i < api.getInfo().testpins_out; i++)
{
if (api.getOutputTestpin (i) == true)
System.out.print("HIGH ");
else
System.out.print("LOW ");
}
System.out.println();
// toggle output testpins
System.out.println ("");
System.out.println ("Toggle output testpins ...");
for (int i=0; i < api.getInfo().testpins_out; i++)
api.setOutputTestpin (i, !api.getOutputTestpin (i));
// create I2C address
address = new I2cAddress ((byte)0x50, false);
// enable slave
/*
System.out.println ("");
System.out.println ("Enabling I2C slave (" + address + ") emulation ...");
api.enableSlave (address, 256, true, (short)(~0));
*/
// master transmitter
System.out.println ("");
System.out.println ("Transmitting 10 bytes to \"" + address + "\" (address pointer: 0x00) ...");
data = new byte[11];
data[0] = 0x00;
for (byte i=0; i < 10; i++)
data[i+1] = i;
api.setBitrate (100000);
api.transmit (address, data);
// master receiver
System.out.print ("Receiving 10 bytes from \"" + address + "\" (address pointer: 0x00) ... ");
data = new byte[1];
data[0] = 0x00;
api.setBitrate (400000);
data = api.transmitReceive (address, data, 10);
for (byte i=0; i < data.length; i++)
{
System.out.print (data[i]);
System.out.print (" ");
}
// close I2C interface
api.close();
}
public static void main (String args[])
{
I2cApi api = null;
try
{
// create connection to I2C scheduler
api = new I2cApi();
// run some tests
testI2c (api);
}
catch (Exception e)
{
System.out.println();
System.out.println();
System.out.println ("Error: " + e.getMessage());
}
finally
{
if (api != null)
{
// destroy connection to the I2C scheduler
api.dispose();
api = null;
}
}
}
}


I2C.Java API: input_testpins_example.java

input_testpins_example.java

The following example demonstrates how to use the InputTestpins class with the I2C.Java API

import telos.I2cApi.Java.*;
import java.util.Vector;
public class input_testpins_example
{
private static void displayInputTestpinMessage (Board board,
InputTestpinsMessage msg)
{
for (int i=0; i < board.testpins_in; i++)
System.out.printf ("Testpin %d: Level = %d ", i, ((msg.status >> i) & 0x01));
System.out.println();
}
private static void testInputTestpins (I2cApi i2c)
{
InputTestpins testpins = i2c.getTracer().getInputTestpins();
InputTestpinsMessage[] msgs;
int cnt = 0;
// start logging of input testpin transitions
testpins.setEnabled (true);
// Display 10 transitions
while (cnt < 10)
{
msgs = testpins.receiveMessages();
for (int i=0; i < msgs.length; i++)
displayInputTestpinMessage (i2c.getInfo(), msgs[i]);
cnt += msgs.length;
}
// stop logging of input testpin transitions
testpins.setEnabled (false);
}
public static void main (String args[])
{
I2cApi i2c = null;
Vector<Board> list_of_boards = new Vector<Board>();;
int i;
try
{
// Create instance of I2C API.
i2c = new I2cApi();
// Get the description of all available I2C interfaces.
i2c.findBoards (list_of_boards);
// Open the first I2C interface supporting the negative tester mode.
for (i = 0; i < list_of_boards.size(); i++)
{
if (list_of_boards.get(i).tracer == true)
{
i2c.open (list_of_boards.get (i));
break;
}
}
if (i == list_of_boards.size())
{
System.out.println ("No I2C interface with tracer has been found.");
return;
}
else
{
System.out.printf ("Using %s [0x%4h]",
i2c.getInfo().board_type.toString(),
i2c.getInfo().serial_number);
System.out.println();
}
// demonstrate logging of input testpins
testInputTestpins (i2c);
// Close I2C interface.
i2c.close();
}
catch (Exception e)
{
System.out.println();
System.out.println();
System.out.println ("Error: " + e.getMessage());
}
finally
{
if (i2c != null)
{
i2c.dispose();
i2c = null;
}
}
}
};


I2C.Java API: negative_tester_example.java

negative_tester_example.java

The following example demonstrates how to use the Negative Tester with the I2C.Java API

import telos.I2cApi.Java.*;
import java.util.Vector;
public class negative_tester_example
{
/***********************************************************************/
/***********************************************************************/
private static void showTiming (NegativeTesterMaster neg_tester_master)
{
if (neg_tester_master.getBitrate() != -1)
System.out.println("Timings (" + neg_tester_master.getBitrate() + "Hz)");
else
System.out.println ("Timings");
System.out.println (" t_HD;STA: " + NegativeTester.convertTicksToNanoseconds (neg_tester_master.getTimeHdSta()) + " ns");
System.out.println (" t_SU;STA: " + NegativeTester.convertTicksToNanoseconds (neg_tester_master.getTimeSuSta()) + " ns");
System.out.println (" t_SU;STO: " + NegativeTester.convertTicksToNanoseconds (neg_tester_master.getTimeSuSto()) + " ns");
System.out.println (" t_BUF: " + NegativeTester.convertTicksToNanoseconds (neg_tester_master.getTimeBuf()) + " ns");
System.out.println (" t_LOW: " + NegativeTester.convertTicksToNanoseconds (neg_tester_master.getTimeLowBeforeHigh() +
neg_tester_master.getTimeLowAfterHigh()) + " ns");
System.out.println (" t_HIGH: " + NegativeTester.convertTicksToNanoseconds (neg_tester_master.getTimeHigh()) + " ns");
}
/***********************************************************************/
/***********************************************************************/
public static void NegativeTesterMaster (I2cApi i2c) throws Exception
{
NegativeTesterMaster master;
I2cAddress address;
byte[] data;
master = new NegativeTesterMaster();
// send messages one time
master.setLoopCount ((short)1);
// do not ignore clock stretching
master.setIgnoreStretching (false);
// generate STOP after receiving NACK
master.setNackBehaviour (NegativeTester.NackBehaviour.NACK_GENERATE_STOP);
// stop after receiving an arbitration lost
master.setStopAtArbitrationLost (true);
// create I2C address
address = new I2cAddress ((short)0x50, false);
// create container of 256 data bytes
data = new byte[256];
for (int i=0; i < 256; i++)
data[i] = (byte)i;
// create first message: send 256 data bytes to 0x50
master.setBitrate (100000);
master.sendTransmitter (address, data);
// show info for first message
System.out.println ("-----------------------------------------------------");
System.out.println ("Message (1): send 256 data bytes to 0x50 (100 kHz)");
showTiming (master);
// create second message: read 32 data bytes from 0x50
master.setBitrate (400000);
master.sendReceiver (address, 32);
// show info for second message
System.out.println ("-----------------------------------------------------");
System.out.println ("Message (2): read 32 data bytes from 0x50 (400 kHz)");
showTiming (master);
// create third message: send one data byte to 0x50
master.setBitrate (100000);
master.sendStart();
master.sendByte ((byte) (address.getAddress() << 1));
master.receiveAckBit (false);
master.setBitrate (400000);
master.sendByte ((byte)0x00);
master.receiveAckBit (false);
master.sendStop();
// show info for third message
System.out.println ("-----------------------------------------------------");
System.out.println ("Message (3): send one data byte to 0x50 (100/400 kHz)");
// create fourth message: read one data byte from 0x50
master.setBitrate (100000);
master.setTimeHdSta (master.getTimeHdSta() * 2);
master.sendStart();
master.sendByte ((byte) ((address.getAddress() << 1) | 0x01));
master.receiveAckBit (false);
master.receiveByte();
master.sendNackBit();
master.sendStop();
// show info for fourth message
System.out.println ("-----------------------------------------------------");
System.out.println ("Message (4): read one data byte from 0x50 (100 kHz)");
showTiming (master);
// create fifth message: send 256 data bytes to 0x50 containing spikes
master.setBitrate (100000);
master.setCreateSpikes (true);
master.sendTransmitter (address, data);
master.setCreateSpikes (false);
// show info for fifth message
System.out.println ("-----------------------------------------------------");
System.out.println ("Message (5): send 256 data bytes to 0x50 containing");
System.out.println (" spikes (100 kHz)");
System.out.println ("-----------------------------------------------------");
// create sixth message: send 256 data bytes to 0x50 using high-speed mode
master.setBitrate (100000);
master.setBitrateHighSpeed (1000000);
master.sendTransmitterHighSpeed (address, data);
// show info for sixth message
System.out.println ("-----------------------------------------------------");
System.out.println ("Message (6): send 256 data bytes to 0x50 using");
System.out.println (" high-speed mode (1 MHz)");
System.out.println ("-----------------------------------------------------");
// start negative tester
i2c.getNegativeTester().startMaster (master.getMessages());
// wait till the tester has finished
while (i2c.getNegativeTester().getIsRunning() == true);
}
/***********************************************************************/
/***********************************************************************/
public static void NegativeTesterSlave (I2cApi i2c)
{
NegativeTesterSlave slave;
byte[] data;
slave = new NegativeTesterSlave();
// listen to I2C address 0x60
slave.setSlaveAddress ((byte)(0x60 << 1));
// set don't care mask of the I2C address
slave.setSlaveAddressMask ((byte)0xfe);
// disable loop mode
slave.setLoopMode (false);
// create container of 256 data bytes
data = new byte[256];
for (int i = 0; i < 256; i++)
data[i] = (byte)i;
// expect up to 100 data byte from the master transmitter
slave.createReceiver(100);
// stretch low of SCL to 20 us
slave.setStretching (NegativeTester.convertNanosecondsToTicks(20000));
// send up to 256 byte to the master receiver
slave.createTransmitter(data);
// start negative tester
i2c.getNegativeTester().startSlave (slave.getMessages());
// wait till the tester has finished
while (i2c.getNegativeTester().getIsRunning() == true);
}
public static void main (String args[])
{
I2cApi i2c = null;
Vector<Board> list_of_boards = new Vector<Board>();;
int i;
try
{
// Create instance of I2C API.
i2c = new I2cApi();
// Get the description of all available I2C interfaces.
i2c.findBoards (list_of_boards);
// Open the first I2C interface supporting the negative tester mode.
for (i = 0; i < list_of_boards.size(); i++)
{
if (list_of_boards.get(i).negative_tester == true)
{
i2c.open (list_of_boards.get (i));
break;
}
}
if (i == list_of_boards.size())
{
System.out.println ("No I2C interface with negative tester support has been found.");
return;
}
else
{
System.out.printf ("Using %s [0x%4h]",
i2c.getInfo().board_type.toString(),
i2c.getInfo().serial_number);
System.out.println();
}
// Use negative tester.
NegativeTesterMaster (i2c);
// NegativeTesterSlave (i2c);
// Close I2C interface.
i2c.close();
}
catch (Exception e)
{
System.out.println();
System.out.println();
System.out.println ("Error: " + e.getMessage());
}
finally
{
if (i2c != null)
{
i2c.dispose();
i2c = null;
}
}
}
};


I2C.Java API: tracer_example.java

tracer_example.java

The following example demonstrates how to use the Tracer with the I2C.Java API

import telos.I2cApi.Java.*;
import java.util.Vector;
public class tracer_example
{
private static void displayTraceData (TracerMessage[] data)
{
int i;
for (i=0; i < data.length; i++)
{
// Display type of the message.
switch (data[i].type)
{
case MSG_FRAME_START:
System.out.print ("START ");
break;
case MSG_FRAME_STOP:
System.out.print ("STOP ");
break;
case MSG_FRAME_DATA:
System.out.printf ("DATA (FRAME) 0x%02x", data[i].data.data);
switch (data[i].data.confirmation)
{
case DATA_CONFIRMATION_NONE:
System.out.print (" (NONE)");
break;
case DATA_CONFIRMATION_ACK:
System.out.print (" (ACK) ");
break;
case DATA_CONFIRMATION_NACK:
System.out.print (" (NACK)");
break;
}
break;
case MSG_I2C_PROTOCOL_ERROR:
System.out.print ("ERROR ");
break;
}
// If there is a timestamp available for a message, display
// this timestamp.
if (data[i].timestamp != -1)
System.out.printf (" 0x%08x", data[i].timestamp);
System.out.println();
}
}
private static void tracer (I2cApi i2c)
{
TracerMessage[] trace_data;
int cnt;
// Disable I2C address filter to get all messages.
i2c.getTracer().enableAllAddresses();
// Enable tracer.
i2c.getTracer().setEnabled (true);
// Get at least 1000 messages.
cnt = 1000;
while (cnt > 0)
{
// wait for new data (timeout: 10 ms)
i2c.waitForData (10 * 1000);
// Get messages from the I2C API.
trace_data = i2c.getTracer().receiveMessages();
// Calculate the number of messages to be received.
cnt -= trace_data.length;
// Display the received messages and delete the messages.
displayTraceData (trace_data);
}
// Disable tracer.
i2c.getTracer().setEnabled (false);
}
public static void main (String args[])
{
I2cApi i2c = null;
Vector<Board> list_of_boards = new Vector<Board>();;
int i;
try
{
// Create instance of I2C API.
i2c = new I2cApi();
// Get the description of all available I2C interfaces.
i2c.findBoards (list_of_boards);
// Open the first I2C interface supporting the negative tester mode.
for (i = 0; i < list_of_boards.size(); i++)
{
if (list_of_boards.get(i).tracer == true)
{
i2c.open (list_of_boards.get (i));
break;
}
}
if (i == list_of_boards.size())
{
System.out.println ("No I2C interface with tracer has been found.");
return;
}
else
{
System.out.printf ("Using %s [0x%4h]",
i2c.getInfo().board_type.toString(),
i2c.getInfo().serial_number);
System.out.println();
}
tracer (i2c);
// Close I2C interface.
i2c.close();
}
catch (Exception e)
{
System.out.println();
System.out.println();
System.out.println ("Error: " + e.getMessage());
}
finally
{
if (i2c != null)
{
i2c.dispose();
i2c = null;
}
}
}
};


I2C.Java API: Class Index

Class Index
A | B | I | L | M | N | P | S | T | U
A
L
PmbusMasterMessageCmd (telos.I2cApi.Java) SmbMasterMessageCmd32 (telos.I2cApi.Java) SmbMasterMessageWriteWord (telos.I2cApi.Java)
PmbusMasterMessageExtCmdByte (telos.I2cApi.Java) SmbMasterMessageCmd64 (telos.I2cApi.Java) NegativeTester.StopTrigger (telos.I2cApi.Java)
Adc (telos.I2cApi.Java) NegativeTester.LevelsMaster (telos.I2cApi.Java) PmbusMasterMessageExtCmdWord (telos.I2cApi.Java) SmbMasterMessageCmdBlock (telos.I2cApi.Java)
T
AdcData (telos.I2cApi.Java) NegativeTester.LevelsSlave (telos.I2cApi.Java) PmbusMasterMessageGroupCmd (telos.I2cApi.Java) SmbMasterMessageCmdByte (telos.I2cApi.Java)
SmbArpMaster.Udid.AddressType (telos.I2cApi.Java)
M
PmbusMasterMessageReadByte (telos.I2cApi.Java) SmbMasterMessageCmdProcessCall (telos.I2cApi.Java) Tracer (telos.I2cApi.Java)
B
PmbusMasterMessageReadWord (telos.I2cApi.Java) SmbMasterMessageCmdWord (telos.I2cApi.Java) TracerMessage (telos.I2cApi.Java)
NegativeTester.MessageSlave (telos.I2cApi.Java) PmbusMasterMessageWriteByte (telos.I2cApi.Java) SmbMasterMessageHostNotify (telos.I2cApi.Java) TracerMessage.TracerMessageData (telos.I2cApi.Java)
Board (telos.I2cApi.Java) NegativeTester.MessagesMaster (telos.I2cApi.Java) PmbusMasterMessageWriteWord (telos.I2cApi.Java) SmbMasterMessageQuickCommand (telos.I2cApi.Java) TracerMessage.TracerMessageDataConfirmation (telos.I2cApi.Java)
Board.BoardType (telos.I2cApi.Java) NegativeTester.MessagesSlave (telos.I2cApi.Java)
S
SmbMasterMessageRead32 (telos.I2cApi.Java) TracerMessage.TracerMessageType (telos.I2cApi.Java)
I2cApi.BusType (telos.I2cApi.Java)
N
SmbMasterMessageRead64 (telos.I2cApi.Java)
U
I
SmbArpMaster (telos.I2cApi.Java) SmbMasterMessageReadByte (telos.I2cApi.Java)
NegativeTester.NackBehaviour (telos.I2cApi.Java) SmbMaster (telos.I2cApi.Java) SmbMasterMessageReadWord (telos.I2cApi.Java) SmbArpMaster.Udid (telos.I2cApi.Java)
I2cAddress (telos.I2cApi.Java) NegativeTester (telos.I2cApi.Java) SmbMasterMessage (telos.I2cApi.Java) SmbMasterMessageReceiveByte (telos.I2cApi.Java)
I2cApi (telos.I2cApi.Java) NegativeTesterMaster (telos.I2cApi.Java) SmbMasterMessageBlockRead (telos.I2cApi.Java) SmbMasterMessageSendByte (telos.I2cApi.Java)
I2cApi.I2cBusState (telos.I2cApi.Java) NegativeTesterSlave (telos.I2cApi.Java) SmbMasterMessageBlockWrite (telos.I2cApi.Java) SmbMasterMessageWrite32 (telos.I2cApi.Java)
InputTestpins (telos.I2cApi.Java)
P
SmbMasterMessageBlockWriteRead (telos.I2cApi.Java) SmbMasterMessageWrite64 (telos.I2cApi.Java)
InputTestpinsMessage (telos.I2cApi.Java) SmbMasterMessageCmd (telos.I2cApi.Java) SmbMasterMessageWriteByte (telos.I2cApi.Java)
PmbusMasterMessage (telos.I2cApi.Java)
A | B | I | L | M | N | P | S | T | U


I2C.Java API: Member List

  • SmbMasterMessageCmd
telos.I2cApi.Java.SmbMasterMessageCmd Member List

This is the complete list of members for telos.I2cApi.Java.SmbMasterMessageCmd, including all inherited members.

getAddress() | telos.I2cApi.Java.SmbMasterMessage
getCommand() | telos.I2cApi.Java.SmbMasterMessageCmd
getWithPec() | telos.I2cApi.Java.SmbMasterMessageCmd
setAddress(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
setCommand(byte cmd) | telos.I2cApi.Java.SmbMasterMessageCmd
setWithPec(boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessage() | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessage(I2cAddress i2c_address) | telos.I2cApi.Java.SmbMasterMessage
SmbMasterMessageCmd() | telos.I2cApi.Java.SmbMasterMessageCmd
SmbMasterMessageCmd(I2cAddress i2c_address, byte cmd, boolean with_pec) | telos.I2cApi.Java.SmbMasterMessageCmd


I2C.Java API: Java Directory Reference

  • src
  • telos
  • I2cApi
  • Java
Java Directory Reference

Files

file | Adc.java
file | AdcData.java
file | Board.java
file | I2cAddress.java
file | I2cApi.java
file | InputTestpins.java
file | InputTestpinsMessage.java
file | NegativeTester.java
file | NegativeTesterMaster.java
file | NegativeTesterSlave.java
file | PmbusMasterMessage.java
file | PmbusMasterMessageCmd.java
file | PmbusMasterMessageExtCmdByte.java
file | PmbusMasterMessageExtCmdWord.java
file | PmbusMasterMessageGroupCmd.java
file | PmbusMasterMessageReadByte.java
file | PmbusMasterMessageReadWord.java
file | PmbusMasterMessageWriteByte.java
file | PmbusMasterMessageWriteWord.java
file | SmbArpMaster.java
file | SmbMaster.java
file | SmbMasterMessage.java
file | SmbMasterMessageBlockRead.java
file | SmbMasterMessageBlockWrite.java
file | SmbMasterMessageBlockWriteRead.java
file | SmbMasterMessageCmd.java
file | SmbMasterMessageCmd32.java
file | SmbMasterMessageCmd64.java
file | SmbMasterMessageCmdBlock.java
file | SmbMasterMessageCmdByte.java
file | SmbMasterMessageCmdProcessCall.java
file | SmbMasterMessageCmdWord.java
file | SmbMasterMessageHostNotify.java
file | SmbMasterMessageQuickCommand.java
file | SmbMasterMessageRead32.java
file | SmbMasterMessageRead64.java
file | SmbMasterMessageReadByte.java
file | SmbMasterMessageReadWord.java
file | SmbMasterMessageReceiveByte.java
file | SmbMasterMessageSendByte.java
file | SmbMasterMessageWrite32.java
file | SmbMasterMessageWrite64.java
file | SmbMasterMessageWriteByte.java
file | SmbMasterMessageWriteWord.java
file | Tracer.java
file | TracerMessage.java


I2C.Java API: telos Directory Reference

  • src
  • telos
telos Directory Reference

Directories

directory I2cApi


I2C.Java API: I2cApi Directory Reference

  • src
  • telos
  • I2cApi
I2cApi Directory Reference

Directories

directory Java


I2C.Java API: src Directory Reference

  • src
src Directory Reference

Directories

directory telos


I2C.Java API: Main Page

I2C.Java API Documentation