telos.I2cApi.DotNet Namespace

I2C.NET API
telos.I2cApi.DotNet Namespace
Classes
 | Class | Description
 | Adc | There is an A/D converter on the Tracii XL and Tracii XL 2.0 interfaces. This class can be used to control the A/D converter.
Public class | AdcData | This class is used to store the data from Tracii XL's or Tracii XL 2.0's A/D converter. Instances of this class get passed to TransferData.
Public class | AdcDataList | This class is used to store the data from Tracii XL's or Tracii XL 2.0's A/D converter. Instances of this class get passed to AdcDataResultList.
Public class | ArrayListByte | This class implements a fast ArrayList for Byte values. The interface is more or less compatible to the interface of ArrayList.
Public class | Board | This is the main class of the I2C API, which communicates with an I2C interface via the I2C scheduler. To use the I2C API it is always necessary to create one instance of this class.
Public class | BoardRemote | This class can be used to retrieve a list of I2C interfaces connected to a list of local and/or remote I2C scheduler. Afterwards it is possible to open I2C interfaces.
Public class | BoardRemoteScheduler | Data type to store the remote address, the remote port, the password, and the current status of an I2C scheduler.
Public class | BoardRemoteSchedulers | Data type to store a number of Scheduler objects.
Public class | CacheGenericTKey, TValue | This class implements a cache container. The container stores a number of elements. This size limit can be configured by the caller. When the user excessed this size limit, the container removes the oldest element.
Public class | Exception | Abstract base class of all exceptions thrown by the I2C.NET API. This class is derived from the Exception class which is the base class for exceptions thrown by the Microsoft's .NET framework.
Public class | ExceptionAdc | Exception: This class serves as a base class for all exceptions thrown by the A/D converter module.
Public class | ExceptionAdcBusy | Exception: Because the A/D converter is busy, the requested command cannot be executed.
Public class | ExceptionAdcNotFinished | Exception: Cannot receive the A/D data from the hardware, because the sampling process has not been finished.
Public class | ExceptionAdcNotSupported | Exception: The hardware does not support the A/D converter mode.
Public class | ExceptionAdcPreTrigger | Exception: The A/D converter of the I2C interface does not support the specified pretrigger.
Public class | ExceptionAdcSamplingRate | Exception: The A/D converter of the I2C interface does not support the specified sampling rate.
Public class | ExceptionAdcTrigger | Exception: The A/D converter of the I2C interface does not support the specified trigger condition.
Public class | ExceptionArpI2cAddressesExhausted | Exception: Cannot assign an I2C address to all found slave devices. There are not enough free I2C addresses.
Public class | ExceptionArpInvalidResponse | Exception: Received an invalid response from the slave during the SMBus address resolution protocol (ARP).
Public class | ExceptionAuthentication | Exception: The authentication with the I2C scheduler failed. Check the password.
Public class | ExceptionBusType | Exception: The hardware does not support this bus type.
Public class | ExceptionDeviceOpen | Exception: It is not possible to execute the requested command, because no I2C interface has been opened. Open an I2C interface using [!:Board::Open] and try it again.
Public class | ExceptionDriverVersion | Exception: The used driver of the I2C interface has got the wrong version. To solve this problem, update the driver.
Public class | ExceptionHardwareIo | Exception: The opened I2C interface does not respond. Maybe the I2C interface has been disconnected from the PC.
Public class | ExceptionI2cAddress | Exception: The specified parameters do not specify a valid I2C slave address.
Public class | ExceptionI2cAddressRange | Exception: The specified parameters do not specify a valid I2C slave address range.
Public class | ExceptionI2cVcc | Exception: No power supply has been connected to the I2C Vcc pin of the I2C connector. Please connect the power supply providing the voltage of the I2C bus to the I2C Vcc pin of the I2C interface.
Public class | ExceptionI2cVccSupply | Exception: It is not possible to use the specified I2C Vcc supply voltage.
Public class | ExceptionInputTestpin | Exception: It is not possible to read the status of the specified input testpin.
Public class | ExceptionIo | Exception: An I/O error has occurred. Different reasons can cause this exception: e.g. there is no running I2C scheduler or the used I2C interface is no longer available.
Public class | ExceptionIrdDeviceVerification | This exception gets returned by the IrdDeviceVerifier class, when a IrdDevice object does not conform to the IRD specification.
Public class | ExceptionIrdLicense | Exception: The hardware does not have a license for the IRD support.
Public class | ExceptionIrdMap | This exception gets returned by the IrdMap class in the case of an error.
Public class | ExceptionIrdMaster | This exception gets thrown by the IrdMaster class.
Public class | ExceptionIrdReader | This exception gets returned by the IrdReader class in the case of an error.
Public class | ExceptionIrdWriter | This exception gets returned by the IrdWriter class in the case of an error.
Public class | ExceptionItemNotFound | Exception: The specified item has not been found.
Public class | ExceptionLevelThreshold | Exception: It is not possible to use the specified level thresholds.
Public class | ExceptionLicenseData | Exception: Failed to set the registration code.
Public class | ExceptionMaster | Exception: This class serves as a base class for all exceptions thrown by the master module.
Public class | ExceptionMasterAddress | Exception: There is no slave responsible for this I2C address.
Public class | ExceptionMasterArbitration | Exception: The master module of the I2C interface has lost the bus arbitration. At the moment the I2C bus is used by an other master.
Public class | ExceptionMasterBusy | Exception: The master is busy.
Public class | ExceptionMasterI2cProtocol | Exception: The master module has detected an I2C protocol error on the I2C bus. Due to this error the transfer has been cancelled.
Public class | ExceptionMasterIncompleteRx | Exception: If it is not possible to read the requested number of bytes from the slave as master receiver, this exception is thrown.
Public class | ExceptionMasterIncompleteTx | Exception: If the slave does not acknowledge all bytes send by the I2C interface as master transmitter, this exception is thrown.
Public class | ExceptionMasterInvalidBitrate | Exception: The specified master bitrate is not valid.
Public class | ExceptionMasterInvalidMasterCode | Exception: The specified high-speed master code is not valid.
Public class | ExceptionMasterInvalidTransfer | Exception: The used I2C interface does not support the specified I2C transfer (e.g. the I2C interface does not support all possible combinations of combined transfers).
Public class | ExceptionMasterMessageListDataType | Exception: Cannot add the given MasterMessage object to the MasterMessageList, because the data array of the master message contains objects of a wrong type (only byte is a valid type).
Public class | ExceptionMasterNotSupported | Exception: The hardware does not support the master mode.
Public class | ExceptionMasterRunning | Exception: Cannot execute the requested command, because the master is already running.
Public class | ExceptionMasterSmbInvalidSize | Exception: A SMBus block transfer can contain 1..32 data bytes.
Public class | ExceptionMasterSmbPecFailed | Exception: The packet error checking (PEC) has failed. The PEC byte does not match the transferred data.
Public class | ExceptionMasterTimeout | Exception: A timeout has occurred during transferring a master message (SCL low for more than 500 ms).
Public class | ExceptionMasterWatchdogTimeout | Exception: A timeout has occurred during transferring a master message (watchdog expired).
Public class | ExceptionNegativeTester | Exception: This class serves as a base class for all exceptions thrown by the negative tester module.
Public class | ExceptionNegativeTesterBusy | Exception: The negative tester cannot be used, because it is already in use or because the I2C interface is busy.
Public class | ExceptionNegativeTesterInvalidArgument | Exception: On of the parameters passed to the negative tester module is not valid.
Public class | ExceptionNegativeTesterNotSupported | Exception: The opened I2C interface does not support the negative tester.
Public class | ExceptionNullPointer | Exception: Pointer is set to "0".
Public class | ExceptionOpen | Exception: It is not possible to open the specified I2C interface. Maybe the board is no longer attached to the PC?
Public class | ExceptionOutputTestpin | Exception: It is not possible to use the specified output testpin configuration.
Public class | ExceptionPlugInManager | This exception gets returned by the PlugInManager class in the case of an error.
Public class | ExceptionPlugInManagerRegister | Exception: Failed to register the specified plug-in.
Public class | ExceptionSchedulerBusy | Exception: Cannot connect to the I2C scheduler, because the scheduler is busy. The scheduler can handle only a limited number of simultaneous connections.
Public class | ExceptionSchedulerVersion | Exception: The running I2C scheduler has got the wrong version. To solve this problem, use a scheduler with the version number specified in the description of the exception.
Public class | ExceptionServiceContractExpired | Exception: This version of the I2C software cannot be used with the opened I2C interface, because the service contract of this board has been expired.
Public class | ExceptionSlaveRamEnhanced | Exception: This class serves as a base class for all exceptions thrown by the SlaveRamEnhanced module.
Public class | ExceptionSlaveRamEnhancedAddress | Exception: The SlaveRamEnhanced does not support the specified I2C address.
Public class | ExceptionSlaveRamEnhancedBusy | Exception: Cannot change the configuration of SlaveRamEnhanced, while it is enabled.
Public class | ExceptionSlaveRamEnhancedMemorySize | Exception: The SlaveRamEnhanced does not support the specified memory size. The memory size can be set to 1..256 bytes."
Public class | ExceptionSlaveRamEnhancedNotSupported | Exception: The opened I2C interface does not support the SlaveRamEnhanced.
Public class | ExceptionSlaveRamEnhancedSetData | Exception: Failed to set the data of SlaveRamEnhanced. Please check the start address and the number of data bytes to be set.
Public class | ExceptionSlaveRamEnhancedTimeout | Exception: The SlaveRamEnhanced does not support the specified timeout. The timeout can be set to 1..1275 ms or N/A (-1 ms).
Public class | ExceptionSmbI2cAddress | Exception: The SMBus does not support 10 bit addresses.
Public class | ExceptionTermination | Exception: It is not possible to use the specified termination for SCL/SDA.
Public class | ExceptionThreading | Exception: A method or property of Board has been called from a thread, which has not created this object. Please read the documentation of Board regarding the usage of threads.
Public class | ExceptionTraceDataFindCanceled | This exception gets returned by the TraceDataFind class, if the search has been canceled.
Public class | ExceptionTracer | Exception: This class serves as a base class for all exceptions thrown by the tracer module.
Public class | ExceptionTracerBusy | Exception: The tracer is busy.
Public class | ExceptionTracerFilter | Exception: An error occurred while setting the I2C address filter.
Public class | ExceptionTracerMessageList | Exception: This class serves as a base class for all exceptions thrown by the TracerMessageList.
Public class | ExceptionTracerMessageListIo | Exception: An I/O error occurred while accessing one of the temp files used by the TracerMessageList.
Public class | ExceptionTracerMessageListOutOfRange | Exception: One of the arguments passed to a method of the TracerMessageList is out of range.
Public class | ExceptionTracerMsgListMissing | Exception: No TracerMessageList has been specified.
Public class | ExceptionTracerNotSupported | Exception: The hardware does not support the trace mode.
Public class | ExceptionTraciiCpu | Exception: This class serves as a base class for all exceptions thrown by the TraciiCpu module.
Public class | ExceptionTraciiCpuBusy | Exception: The TraciiCpu cannot be used, because it is already in use or because the master module of the I2C interface is in use.
Public class | ExceptionTraciiCpuNotSupported | Exception: The opened I2C interface does not support the TraciiCpu.
Public class | ExceptionTraciiCpuProgramSize | Exception: The specified program image has got false size. Images for the TraciiCpu have got a size of 1024 bytes.
Public class | FindLogicContainerMessage | This class defines a find rule on message level.
Public class | FindLogicContainerSubMessage | This class defines a find rule on sub message level.
Public class | FindRuleByteTime | This class defines a find rule on sub message level.
Public class | FindRuleData | This class defines a find rule on sub message level.
Public class | FindRuleDataValue | Contains all necessary parameters of one data byte.
Public class | FindRuleDataAnyPos | This class defines a find rule on sub message level.
Public class | FindRuleDataAnyPosValue | Contains all necessary parameters of one data byte.
Public class | FindRuleDataLength | This class defines a find rule on sub message level.
Public class | FindRuleDataStatus | This class defines a find rule on sub message level.
Public class | FindRuleError | This class defines a find rule on message level.
Public class | FindRuleI2cAddress | This class defines a find rule on sub message level.
Public class | FindRuleI2cAddressStatus | This class defines a find rule on sub message level.
Public class | FindRuleIdleTime | This class defines a find rule on message level.
Public class | FindRuleIrdRegister | This class defines a find rule on IRD register level.
Public class | FindRuleIrdValue | This class defines a find rule on IRD value level.
Public class | FindRuleMessage | This class is used as base class for find rules on message level.
Public class | FindRuleMessageTime | This class defines a find rule on message level.
Public class | FindRuleSubMessage | This class is used as base class for find rules on sub message level.
Public class | FindRuleSubMessageContainerAnyPos | This class defines a find rule on message level.
Public class | FindRuleSubMessageContainerWithPos | This class defines a find rule on message level.
Public class | FindRuleSubMessageContainerWithPosSubMessage | Stores all needed information for one sub message rule.
Public class | FindRuleSubMessageTime | This class defines a find rule on sub message level.
Public class | FindRuleTestPin | This class defines a find rule on message level.
Public class | FindSequence | This container can be used to store a number of find rules on message level, which get applied one after the other. After the last rule matches, the complete find sequence matches.
Public class | HardwareInfo | This class is used to store information about an I2C interface. E.g. it can be used to get information about the type of the interface and the available features. The properties HardwareInfoOfOpenBoard and ListOfBoards are using objects of this type.
Public class | I2cAddress | This class stores a 7 or 10 bit I2C address.
Public class | I2cAddressRange | This class stores a I2C address range.
 | InputTestpins | Some I2C interfaces like Tracii XL contains input testpins. This class can be used to log transitions of these input testpins.
Public class | InputTestpinsMessage | Each time a InputTestpins object detects a transition of the input testpins, a message of this type gets generated. The message stores the status of the testpins after the transition and the timestamp of the transition.
Public class | InputTestpinsMessageList | Instances of this class are used by InputTestpins to store InputTestpinsMessage objects.
Public class | InputTestpinsMessageListInputTestpinsMessageTimestampCompare | Compares two InputTestpinsMessage objects based on their timestamps.
Public class | IrdCompiler | Converts an IRD (I2C Register Description) file into a C# source code file.
Public class | IrdDevice | This class is used to stored the content of a parsed IRD (I2C Register Description) file. A IRD file describes the registers of an I2C/SMBus device.
Public class | IrdDeviceRegister | This class is used to store the information about one register. A register describes the lowest layer of a device. This information describes how data gets read and written.
Public class | IrdDeviceType | Base class for IrdDeviceTypeAscii, IrdDeviceTypeString, IrdDeviceTypeArray, and IrdDeviceTypeInt.
Public class | IrdDeviceTypeArray | This class is used to store the information about an array type.
Public class | IrdDeviceTypeAscii | This class is used to store the information about an ASCII type.
Public class | IrdDeviceTypeAsciiRange | This class is used to store a range.
Public class | IrdDeviceTypeInt | This class is used to store the information about an integer type.
Public class | IrdDeviceTypeIntValueName | Stores the name of a value or a range of values.
Public class | IrdDeviceTypeIntValueNameInt32 | Stores the name of a value or a range of values. Used for Int32 values.
Public class | IrdDeviceTypeIntValueNameUInt32 | Stores the name of a value or a range of values. Used for UInt32 values.
Public class | IrdDeviceTypeString | This class is used to store the information about a string type.
Public class | IrdDeviceUdid | This class is used to store an UDID, which stands for "Unique Device Identifier". These IDs a part of the SMBus ARP protocol.
Public class | IrdDeviceValue | This class is used to store the information about a value. A value interprets the content of registers. E.g. a status register containing 8 status bits can be described as 8 values.
Public class | IrdDeviceValueSource | This class is used to define which register should be used as a source for the value.
Public class | IrdDeviceVerifier | This class contains an IrdDevice verifier. It can be used to test whether an IrdDevice object conforms to the IRD specification.
Public class | IrdMap | This class can be used to map I2C addresses to alias names, IRD (I2C Register Description) files, and plug-in files.
Public class | IrdMapDevice | Stores information of a device specified by an IRD file or a plug-in file.
Public class | IrdMapEntry | Stores information for one I2C address.
Public class | IrdMapEntryEventArgs | Event arguments used for the EntryChanged event.
Public class | IrdMapSerializationData | This class gets used for the serialization of the settings of the IrdMap class.
Public class | IrdMaster | This class can be used to send/receive IRD master messages.
Public class | IrdMasterValue | One value of the IC.
Public class | IrdMasterValueGroup | Group of values. One value in a group cannot be read or written without reading or writing all other values of the group.
Public class | IrdMasterValueGroups | Stores all value groups of an IC.
Public class | IrdMasterMessage | This class is used as a base class for all IRD master messages.
Public class | IrdMasterMessageRx | This class is used for IRD master receiver messages.
Public class | IrdMasterMessageTx | This class is used for IRD master transmitter messages.
Public class | IrdReader | Reads an IRD (I2C Register Description) file into the RAM and returns the parsed result as IrdDevice object.
Public class | IrdTraceFormatter | This class converts parsed tracer messages, which are stored in IrdTraceValueList objects, into a number of strings. These strings can be used e.g. for user outputs.
Public class | IrdTraceFormatterPlugInMessage | This class stores the strings of one formatted plug-in message. Objects of this class get created by GetPlugInMsg(Int32).
Public class | IrdTraceFormatterPlugInMessageBase | This class stores the strings of one formatted plug-in message (base class).
Public class | IrdTraceFormatterPlugInMessageError | This class stores the strings of one formatted plug-in message containing errors. Objects of this class get created by GetPlugInMsg(Int32).
Public class | IrdTraceFormatterRawSubMessage | This class stores the strings of one formatted raw sub message. Objects of this class get created by GetRawMsg(Int32).
Public class | IrdTraceFormatterRawSubMessageBase | This class stores the strings of one formatted raw sub message (base class).
Public class | IrdTraceFormatterRawSubMessageError | This class stores the strings of one formatted raw sub message containing errors. Objects of this class get created by GetRawMsg(Int32).
Public class | IrdTraceFormatterRegisterMessage | This class stores the strings of one formatted register message. Objects of this class get created by GetRegisterMsg(Int32).
Public class | IrdTraceFormatterRegisterMessageBase | This class stores the strings of one formatted register message (base class).
Public class | IrdTraceFormatterRegisterMessageError | This class stores the strings of one formatted register message containing errors. Objects of this class get created by GetRegisterMsg(Int32).
Public class | IrdTraceFormatterValueMessage | This class stores the strings of one formatted value message. Objects of this class get created by GetValueMsg(Int32).
Public class | IrdTraceFormatterValueMessageBase | This class stores the strings of one formatted value message (base class).
Public class | IrdTraceFormatterValueMessageError | This class stores the strings of one formatted value message containing errors. Objects of this class get created by GetValueMsg(Int32).
Public class | IrdTraceFormatterMessage | This class stores one formatted message.
Public class | IrdTraceRegisterData | Stores one access to a register of an I2C slave.
Public class | IrdTraceRegisterDataBase | Base class of IrdTraceRegisterData and IrdTraceRegisterError.
Public class | IrdTraceRegisterDataContainer | Stores one complete raw I2C message and the corresponding register accesses.
Public class | IrdTraceRegisterError | When the IrdTraceRegisterParser class detects an error during parsing access to registers of I2C slaves, it creates objects of this type.
Public class | IrdTraceValueData | Stores one access to a value of an I2C slave.
Public class | IrdTraceValueDataRegister | Stores information about a used register.
Public class | IrdTraceValueDataBase | Base class of IrdTraceValueData and IrdTraceValueError.
Public class | IrdTraceValueDataContainer | Stores one complete raw I2C message and the corresponding register and value accesses.
Public class | IrdTraceValueError | When the IrdTraceValueParser class detects an error during parsing access to values of I2C slaves, it creates objects of this type.
Public class | IrdTraceValueList | This class parses the elements of a ParsedTracerMessageList and returns the parsed I2C messages to the caller. The IrdTraceValueDataContainer objects created by this parser contains the messages in three formats: ParsedTraceDataBase, IrdTraceRegisterDataBase, and IrdTraceValueDataBase.
Public class | IrdWriter | Writes an IrdDevice object to an IRD (I2C Register Description) file.
 | Master | This class is used for master transmitter/receiver transfers on the I2C bus.
Public class | MasterTransferDataStatusEventArgs | Event arguments used for the TransferDataStatus event.
Public class | MasterMessage | Specifies the interface of a master message. Objects of this type can be added to a MasterMessageList. This type is used to pass the data to the TransferData(MasterMessage) method.
Public class | MasterMessageList | Container used to store the messages of one I2C master transfer. This type is used to pass the data to the TransferData(MasterMessageList) method.
Public class | MasterMessageRx | Stores a master receiver message. This type is used to pass the data to the TransferData(MasterMessage) method.
Public class | MasterMessageTx | Stores a master transmitter message. This type is used to pass the data to the TransferData(MasterMessage) method.
Public class | MathExpression | Converts a mathematical formula to a binary tree, which can be used to calculate with this formula.
Public class | MathExpressionNodeFunction | Implementation of the MathExpressionINode interface, which stores a mathematical function.
Public class | MathExpressionNodeOperator | Implementation of the MathExpressionINode interface, which stores an operator.
Public class | MathExpressionNodeValue | Implementation of the MathExpressionINode interface, which stores a numerical constant.
Public class | MathExpressionNodeVariable | Implementation of the MathExpressionINode interface, which stores a variable.
 | NegativeTester | This class provides a negative tester.
Public class | NegativeTesterCompletionEventArgs | Event arguments used for the Completion event.
Public class | NegativeTesterLevelsMaster | Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the master mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next NegativeTesterLevelsMaster packet.
Public class | NegativeTesterLevelsSlave | Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the slave mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next NegativeTesterLevelsSlave packet.
Public class | NegativeTesterMessageSlave | Contains the NegativeTesterLevelsSlave objects for one I2C submessage (from the START condition to the next STOP or REPEATED START condition).
Public class | NegativeTesterMessagesMaster | Contains all information needed by the negative tester to work in master mode.
Public class | NegativeTesterMessagesSlave | Contains all information needed by the negative tester to work in slave mode.
Public class | NegativeTesterMaster | This class offers a high-level master interface for the negative tester implemented in the NegativeTester class.
Public class | NegativeTesterSlave | This class offers a high-level slave interface for the negative tester implemented in the NegativeTester class.
Public class | ParsedTimestamp | Converts a given timestamp value into real time. The time gets splitted into values for days, hours, minutes, seconds, milliseconds, microseconds, and nanoseconds.
Public class | ParsedTraceData | This class is used to store the data of a normal submessage parsed by Parse(Int32).
Public class | ParsedTraceDataBase | This base class is used to store the data of a submessage parsed by Parse(Int32).
Public class | ParsedTraceDataError | This class is used to store the data of an error parsed by Parse(Int32).
Public class | ParsedTracerMessageList | This class parses the elements of a TracerMessageList and returns the parsed I2C submessages to the caller. To improve the speed of the parser the class contains a cache, which stores a number of parsed submessages.
 | PlugInInterface | This base class specifies the interface of plug-in assemblies, which are used to interpret the trace data to or from an IC.
Public class | PlugInInterfaceDevice | This class stores the information about one IC supported by a plug-in assembly.
Public class | PlugInManager | This class is responsible for loading trace plug-ins, which implement the PlugInInterface interface.
Public class | PlugInManagerDevice | This class stores the information about one IC supported by the plug-in manager.
Public class | PlugInRawTraceData | Implements a wrapper around a ParsedTracerMessageList object. Such a list is used to store the I2C messages, which have been traced.
Public class | PlugInTraceData | Stores one message to an I2C slave, which has been parsed by a plug-in.
Public class | PlugInTraceDataBase | Base class of PlugInTraceData and PlugInTraceError.
Public class | PlugInTraceDataContainer | Stores one complete I2C message, which has been parsed by plug-ins.
Public class | PlugInTraceError | When the PlugInTraceParser class detects an error during parsing messages to I2C slaves using plug-ins, it creates objects of this type.
Public class | PlugInTraceParser | This parser uses plug-ins (classes derived from PlugInInterface) to interpret I2C messages.
Public class | PmbusMasterMessage | This class is used as a base class for the PMBus master messages supporting the "extended command" byte.
Public class | PmbusMasterMessageCmd | This class contains a submessage of a "Group Command" PMBus master message. Instances of this class are stored in PmbusMasterMessageGroupCmd objects.
Public class | PmbusMasterMessageExtCmdByte | This class is used as a base class for the "Extended Command: Write Byte" and "Extended Command: Read Byte" PMBus master messages.
Public class | PmbusMasterMessageExtCmdWord | This class is used as a base class for the "Extended Command: Write Word" and "Extended Command: Read Word" PMBus master messages.
Public class | PmbusMasterMessageGroupCmd | This class specifies a "Group Command" (see section 5.2.3 in the standard) master message for the PMBus.
Public class | PmbusMasterMessageReadByte | This class specifies a "Extended Command: Read Byte" (see section 5.2.4 in the standard) master message for the PMBus.
Public class | PmbusMasterMessageReadWord | This class specifies a "Extended Command: Read Word" (see section 5.2.5 in the standard) master message for the PMBus.
Public class | PmbusMasterMessageWriteByte | This class specifies a "Extended Command: Write Byte" (see section 5.2.4 in the standard) master message for the PMBus.
Public class | PmbusMasterMessageWriteWord | This class specifies a "Extended Command: Write Word" (see section 5.2.5 in the standard) master message for the PMBus.
Public class | ReadOnlyListEnumeratorT | Implements the IEnumeratorT interface for IReadOnlyListT.
Public class | ServiceContracts | This structure specifies the service contracts of an I2C interface.
Public class | SlaveRam | Tracii XL can emulate an I2C RAM slave. This class can be used to enable/disable this slave. The slave will listen on the specified I2C address.
Public class | SlaveRamEnhanced | Tracii XL 2.0 contains an enhanced I2C RAM slave. The slave emulates a RAM with up to 256 bytes. The I2C address and the memory size of the RAM can be configured. The RAM supports auto incrementing the address pointer.
Public class | SmbArpMaster | This class implements the SMBus address resolution protocol (ARP).
Public class | SmbArpMasterUdid | Each SMBus slave device supporting ARP has got an UDID.
Public class | SmbMaster | This class can be used to send master messages to a SMBus and a PMBus.
Public class | SmbMasterMessage | This class is used as a base class for all SMBus master messages.
Public class | SmbMasterMessageBlockRead | This class specifies a "Block Read" (see section 6.5.7 in the standard) master message for the SMBus.
Public class | SmbMasterMessageBlockWrite | This class specifies a "Block Write" (see section 6.5.7 in the standard) master message for the SMBus.
Public class | SmbMasterMessageBlockWriteRead | This class specifies a "Block Write - Block Read Process Call" (see section 6.5.8 in the standard) master message for the SMBus.
Public class | SmbMasterMessageCmd | This class is used as a base class for all SMBus master messages, which contain a command and an optional PEC byte.
Public class | SmbMasterMessageCmd32 | This class is used as a base class for the "Write 32" and "Read 32" SMBus master messages.
Public class | SmbMasterMessageCmd64 | This class is used as a base class for the "Write 64" and "Read 64" SMBus master messages.
Public class | SmbMasterMessageCmdBlock | This class is used as a base class for the "Block Write" and "Block Read" SMBus master messages.
Public class | SmbMasterMessageCmdByte | This class is used as a base class for the "Write Byte" and "Read Byte" SMBus master messages.
Public class | SmbMasterMessageCmdProcessCall | This class specifies a "Process Call" (see section 6.5.6 in the standard) master message for the SMBus.
Public class | SmbMasterMessageCmdWord | This class is used as a base class for the "Write Word" and "Read Word" SMBus master messages.
Public class | SmbMasterMessageHostNotify | This class specifies a "Host Notify" (see section 6.5.9 in the standard) master message for the SMBus.
Public class | SmbMasterMessageQuickCommand | This class specifies a "Quick Command" (see section 6.5.1 in the standard) master message for the SMBus.
Public class | SmbMasterMessageRead32 | This class specifies a "Read 32" (see section 6.5.11 in the standard) master message for the SMBus.
Public class | SmbMasterMessageRead64 | This class specifies a "Read 64" (see section 6.5.13 in the standard) master message for the SMBus.
Public class | SmbMasterMessageReadByte | This class specifies a "Read Byte" (see section 6.5.5 in the standard) master message for the SMBus.
Public class | SmbMasterMessageReadWord | This class specifies a "Read Word" (see section 6.5.5 in the standard) master message for the SMBus.
Public class | SmbMasterMessageReceiveByte | This class specifies a "Receive Byte" (see section 6.5.3 in the standard) master message for the SMBus.
Public class | SmbMasterMessageSendByte | This class specifies a "Send Byte" (see section 6.5.2 in the standard) master message for the SMBus.
Public class | SmbMasterMessageWrite32 | This class specifies a "Write 32" (see section 6.5.10 in the standard) master message for the SMBus.
Public class | SmbMasterMessageWrite64 | This class specifies a "Write 64" (see section 6.5.12 in the standard) master message for the SMBus.
Public class | SmbMasterMessageWriteByte | This class specifies a "Write Byte" (see section 6.5.4 in the standard) master message for the SMBus.
Public class | SmbMasterMessageWriteWord | This class specifies a "Write Word" (see section 6.5.4 in the standard) master message for the SMBus.
Public class | SoftwareLicenses | This structure specifies the software licenses of an I2C interface. Software can only be used together with an I2C interface, if the interface has got the needed license.
Public class | SvnAttribute |
Public class | TraceDataFind | This class can be used to search for I2C messages in a ParsedTracerMessageList object.
Public class | TraceDataFindProgressChangedArgs | Arguments of the ProgressChanged event.
 | Tracer | This class can be used to use the tracer functionality of the I2C interfaces. It is possible to start/stop the tracer module and to filter I2C messages regarding their I2C slave addresses.
Public class | TracerMessage | This class is used to store one trace message created by the methods of the Tracer class.
Public class | TracerMessageList | Instances of this list are used to store the I2C messages received from the hardware.
Public class | TracerStartReferencesList | Class to store the list of indices pointing to the start of I2C messages.
Structures
 | Structure | Description
Public structure | TracerMessageData | This structure is used for MSG_FRAME_DATA messages to store the data transferred over the I2C bus.
Interfaces
 | Interface | Description
Public interface | IReadOnlyListT | This interface represents a read-only list, which can be accessed using an index or an enumerator.
Public interface | MathExpressionINode | Interface of a node, which is part of the binary tree.
Delegates
 | Delegate | Description
Public delegate | MathExpressionFuncT, TResult | Encapsulates a method that has one parameter and returns a value.
Enumerations
 | Enumeration | Description
Public enumeration | BoardBusTypes | Enumeration to store the bus type.
Public enumeration | BoardI2cBusStates | Enumeration to store the state of the I2C bus.
Public enumeration | BoardType | Enum to specify the type of the I2C interface.
Public enumeration | FindLogicContainerMessageLogic | Enumeration to specify the type of the logic operation.
Public enumeration | FindLogicContainerSubMessageLogic | Enumeration to specify the type of the logic operation.
Public enumeration | FindRuleDataStatusNackAck | Enumeration to choose between NACK and ACK.
Public enumeration | FindRuleErrorErrorType | Enumeration to specify the type of the error.
Public enumeration | FindRuleIrdRegisterPecType | Enumeration to specify the result of the SMBus packet error checking (PEC).
Public enumeration | FindRuleIrdRegisterTxRx | Enumeration to specify the transfer direction.
Public enumeration | FindRuleIrdValuePecType | Enumeration to specify the result of the SMBus packet error checking (PEC).
Public enumeration | FindRuleIrdValueTxRx | Enumeration to specify the transfer direction.
Public enumeration | FindRuleSubMessageContainerAnyPosTxRx | Enumeration to specify the transfer direction.
Public enumeration | FindRuleSubMessageContainerWithPosSubMessageTxRx | Enumeration to specify the transfer direction.
Public enumeration | FindRuleTestPinState | Enumeration to specify whether the rule matches an edge or a level.
Public enumeration | IrdDeviceBusType | Enumeration to describe the bus type.
Public enumeration | IrdDeviceBusySignal | Enumeration to describe the busy signal method. This method defines how a device signals that it is busy at the moment.
Public enumeration | IrdDeviceByteOrdering | Enumeration to describe the byte ordering/endianess.
Public enumeration | IrdDeviceRegisterFormat | Enumeration to describe the format/type of a register. This information specifies how to transfer the data and the width of the data.
Public enumeration | IrdDeviceValueDirection | Enumeration to describe the direction of a value.
Public enumeration | IrdTraceFormatterRawDataFormatStyle | Specifies the format of the Data string.
Public enumeration | IrdTraceRegisterDataDirection | Enumeration to specify the direction of a transfer.
Public enumeration | IrdTraceRegisterDataPec | Enumeration to specify the result of the SMBus packet error checking (PEC).
Public enumeration | IrdTraceRegisterErrorError | Enumeration to specify reason of an error.
Public enumeration | IrdTraceValueDataDirection | Enumeration to specify the direction of a transfer.
Public enumeration | IrdTraceValueDataPec | Enumeration to specify the result of the SMBus packet error checking (PEC).
Public enumeration | IrdTraceValueErrorError | Enumeration to specify reason of an error.
Public enumeration | IrdTraceValueErrorType | Enumeration to specify which parses has detected an error.
Public enumeration | NegativeTesterENackBehaviour | Enumeration to specify the behaviour after receiving a NACK on the I2C bus.
Public enumeration | NegativeTesterEResult | Enumeration to specify the result when the program of the negative tester has been finished.
Public enumeration | NegativeTesterEStopTrigger | Enumeration to specify trigger, which can stop the negative tester.
Public enumeration | ParsedTimestampTimeResolution | Enumeration to specify the time resolution.
Public enumeration | ParsedTraceDataBusSpeed | This enumeration is used to store the speed of an I2C transfer.
Public enumeration | ParsedTraceDataDataDirection | This enumeration is used to store the direction of an I2C transfer.
Public enumeration | ParsedTraceDataI2cAddressComplete | This enumeration is used to store whether all bytes of an I2C address are available.
Public enumeration | ParsedTraceDataI2cAddressStatus | This enumeration is used to store the status of an I2C address.
Public enumeration | ParsedTraceDataErrorErrorType | This enumeration is used to store the type of the error.
Public enumeration | PlugInTraceErrorError | Enumeration to specify reason of an error.
Public enumeration | SmbArpMasterUdidAddrType | This enumeration specifies the I2C address type used by a slave device.
Public enumeration | TraceDataFindDirection | Enumeration to specify the search direction.
Public enumeration | TracerMessageDataConfirmation | This enumeration is used for MSG_FRAME_DATA messages. It indicates whether an ACK or NACK has been received after the data message.
Public enumeration | TracerMessageType | Enumeration to specify the type of an I2C message. The types can be categorized into two groups: frame-based messages, and protocol errors.
Send comments on this topic to tsupport@telos.de


Adc Class

Adc Class
There is an A/D converter on the Tracii XL and Tracii XL 2.0 interfaces. This class can be used to control the A/D converter.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetAdc

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Adc : IDisposable
Public NotInheritable Class Adc
    Implements IDisposable
public ref class Adc sealed : IDisposable
[<SealedAttribute>]
type Adc =
    class
        interface IDisposable
    end

The Adc type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels the running A/D converter.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessageDataTrigger | Returns the current configuration of the data trigger. If both values are empty, this trigger has been diabled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnSamplingCompletion | Triggers a "sampling completion" event.
Public method | OnTransmissionCompletion | Triggers a "transmission completion" event.
Public method | SetMessageDataTrigger | This method sets the data trigger. It triggers the A/D converter when an I2C message is sent to the bus, whose data bytes after the START condition equal the data bytes specified to this trigger.
Public method | Start | Enables the A/D converter. The hardware will wait for one of the specified trigger event
Public method | StartImmediately | Enables the A/D converter. The hardware will not wait for one of the specified trigger events. Instead it starts the sampling process immediately.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData | This function tells the hardware to transmit the sampled A/D values from the hardware to the application.
Public method | TransferData(AdcData) | This function tells the hardware to transmit the sampled A/D values from the hardware to the application.
Top
Properties
 | Name | Description
Public property | AdcDataResultList | List to which TransferData adds completed A/D shots.
Public property | MessageCountTrigger | Specifies the "message count" trigger. It triggers the A/D converter after receiving the specified number of I2C messages. A value of "0" diables this trigger.
Public property | PreTrigger | Specifies how many samples should be stored before the trigger event [samples/channel].
Public property | SamplingCompleted | Tests whether the hardware has finished the sampling process. At this time the samples are stored in the internal memory of the I2C interface. To transfer the samples to the program, it is necessary to call TransferData.
Public property | SamplingRate | Sampling rate of the A/D converter [Hz].
Public property | TransmissionCompleted | When the complete A/D data has been transferred from the hardware to the PC, this property returns "true". At this time the AdcData object passed to TransferData contains valid data.
Public property | UseAckAsTrigger | Specifies whether an I2C ACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseErrorAsTrigger | Specifies whether an I2C ERROR should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseNackAsTrigger | Specifies whether an I2C NACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseStartAsTrigger | Specifies whether an I2C start condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseStopAsTrigger | Specifies whether an I2C stop condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseTestpin1AsTrigger | Specifies whether testpin 1 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseTestpin2AsTrigger | Specifies whether testpin 2 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Top
Events
 | Name | Description
Public event | SamplingCompletion | This event gets fired when the hardware has finished the sampling process. At this time the samples are stored in the internal memory of Tracii XL / Tracii XL 2.0. To transfer the samples to the program, it is necessary to call TransferData.
Public event | TransmissionCompletion | This event gets fired when the complete A/D data has been transferred from the hardware to the application.
Top
Remarks

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the Adc property.

Normally the following steps are necessary to use the A/D converter:

  1. Configure the A/D converter (sampling rate, pretrigger, trigger events).
  2. Register sampling and transmission completion events.
  3. Register a AdcDataList object.
  4. Use Start to start the converter.
  5. Call WaitForData(Int32) in a loop till all data has been transferred to the PC.
  6. When the hardware has finished the sampling process, the sampling completion event gets called. Normally the event handler should request the transmission of the sampled data using TransferData
  7. Wait till the transmission completion event gets called.
Examples
The following example demonstrates how to use the class with C#:
Copy
using telos.I2cApi.DotNet;
using System;
using System.Collections.Generic;

namespace MyNamespace
{
  class I2c
  {
    /***********************************************************************/
    /// <summary>
    /// Displays some information about the A/D features supported by
    /// an I2C interface.
    /// </summary>
    /***********************************************************************/

    public void AdcInfo (HardwareInfo hwinfo)
    {
      // Display serial number of the I2C interface.
      Console.WriteLine ("Serial number: 0x" +
                        hwinfo.SerialNumber.ToString ("X4"));

      // Display: A/D convert supported?
      Console.WriteLine ("Supports A/D converter: " + hwinfo.Adc);

      // Return if there is no A/D converter support.
      if (hwinfo.Adc == false)
        return;

      // Display: Which events can be used to start the A/D converter.
      Console.Write ("Supported trigger conditions: ");
      if (hwinfo.AdcTriggerStart == true)
        Console.Write ("start ");
      if (hwinfo.AdcTriggerStop == true)
        Console.Write ("stop ");
      if (hwinfo.AdcTriggerAck == true)
        Console.Write ("ack ");
      if (hwinfo.AdcTriggerTestpin1 == true)
        Console.Write ("testpin1 ");
      if (hwinfo.AdcTriggerTestpin2 == true)
        Console.Write ("testpin2 ");
      Console.WriteLine ("");

      // Display: Vcc of the A/D samples. This value specifies the
      //          voltage of the A/D converter value "255".
      Console.WriteLine ("Vcc of A/D samples: " + hwinfo.AdcVcc + " mV");

      // Display the sampling rates supported by the A/D converter.
      Console.Write ("Sampling rates: ");
      foreach (uint sampling_rate in hwinfo.AdcSamplingrate)
        Console.Write (sampling_rate + " ");
      Console.WriteLine (" Hz");

      // Display the maximum value for the pretrigger setting.
      if (hwinfo.AdcMaxPretrigger != uint.MaxValue)
        Console.WriteLine ("Maximum pretrigger: " + hwinfo.AdcMaxPretrigger);
      else
        Console.WriteLine ("Pretrigger: N/A");

      Console.WriteLine ("");
    }

    /***********************************************************************/
    /// <summary>
    /// This function gets called when an I2C interface has finished the
    /// sampling process. It requests the transmission of the A/D data
    /// from the I2C interface to the application.
    /// </summary>
    /***********************************************************************/

    private void AdcTestSamplingCompletion (object sender, EventArgs e)
    {
      Console.WriteLine ("Sampling finished.");

      // Create object to be used to store the A/D values.
      adc_data = new AdcData();

      // Request the transmission of the A/D value from the
      // I2C interface to the application.
      ((Adc)sender).TransferData (adc_data);

      Console.Write ("Starting data transmission ...");
    }

    /***********************************************************************/
    /// <summary>
    /// This function gets called when the API has transmitted all A/D
    /// data to the application. The completion of the transmission is
    /// signaled to the "main" function using a boolean variable.
    /// </summary>
    /***********************************************************************/

    private void AdcTestTransmissionCompletion (object sender, EventArgs e)
    {
      // Display some information about the received A/D samples.
      Console.WriteLine ("finished.");
      Console.WriteLine ("SCL samples: " + adc_data.DataScl.Length);
      Console.WriteLine ("SDA samples: " + adc_data.DataSda.Length);
      Console.WriteLine ("Timestamp first sample: 0x" +
                         adc_data.TimestampStart.ToString ("X16"));
      Console.WriteLine ("Timestamp last sample: 0x" +
                         adc_data.TimestampStop.ToString ("X16"));

      // Signal the end of the A/D conversion.
      adc_running = false;
    }

    /***********************************************************************/
    /// <summary>
    /// Demonstrates the API of the A/D converter.
    /// </summary>
    /***********************************************************************/

    public void AdcTest (Board board)
    {
      // Get a reference to the object describing the features
      // of the used I2C board.
      HardwareInfo  hwinfo = board.HardwareInfoOfOpenBoard;

      // Configure the pretrigger. The pretrigger specifies the
      // number of samples, which get stored by the A/D converter
      // before detecting the trigger condition.
      if (hwinfo.AdcMaxPretrigger != uint.MaxValue)
      {
        Console.WriteLine ("Setting pretrigger to \"0\" ...");
        board.Adc.PreTrigger = 0;
      }

      // Configure the sampling rate of the A/D converter.
      Console.WriteLine ("Setting sampling rate to \"" +
                         hwinfo.AdcSamplingrate[0] + "\" Hz ...");
      board.Adc.SamplingRate = (int)(uint)hwinfo.AdcSamplingrate[0];

      // Use the I2C start and stop to start the A/D conversion.
      Console.WriteLine ("Setting trigger conditions ...");
      if (hwinfo.AdcTriggerStart == true)
        board.Adc.UseStartAsTrigger = true;

      if (hwinfo.AdcTriggerStop == true)
        board.Adc.UseStopAsTrigger = true;

      // Register event handler, which gets called by the API
      // when the hardware has finished the sampling process.
      board.Adc.SamplingCompletion +=
        new EventHandler (AdcTestSamplingCompletion);

      // Register event handler, which gets called by the API
      // when the application/API has received all A/D values
      // from the I2C board.
      board.Adc.TransmissionCompletion +=
        new EventHandler (AdcTestTransmissionCompletion);

      // status variable to be changed by the OnTransmissionCompletion
      adc_running = true;

      Console.WriteLine ("Starting A/D converter ...");
      board.Adc.Start();

      // Sleep until we have received the OnTransmissionCompletion
      // event. It is very important to call Board::WaitForData()
      // when the A/D converter has been activated, because this
      // method is responsible for transfer of the data to the
      // application and the firing of the events.
      while (adc_running)
        board.WaitForData (TimeSpan.FromSeconds (10));
    }

    private AdcData  adc_data;
    private bool     adc_running;
  }

  class MyClass
  {
    [STAThread]
    static void Main(string[] args)
    {
      Board  board = null;

      try
      {
        I2c                 i2c = new I2c();
        List<HardwareInfo>  hwinfo;
        int                 i;

        // Create connection to I2C scheduler.
        board = new Board();

        // Get the description of all available I2C interfaces.
        hwinfo = board.ListOfBoards;

        // Display some information about the I2C interfaces.
        foreach (HardwareInfo hwinfo_item in hwinfo)
          i2c.AdcInfo (hwinfo_item);

        // Open an I2C interface supporting the A/D converter mode.
        for (i = hwinfo.Count-1; i >= 0; i--)
        {
          if (hwinfo[i].Adc == true)
          {
            board.Open (hwinfo[i]);
            break;
          }
        }

        // I2C interface with A/D license found?
        if (board.IsOpen == false)
        {
          Console.WriteLine("No I2C interface with A/D mode support has been found.");
          return;
        }
        else
        {
          Console.WriteLine (string.Format ("Using {0} [0x{1:X4}]",
                                            board.HardwareInfoOfOpenBoard.BoardType,
                                            board.HardwareInfoOfOpenBoard.SerialNumber));
        }

        // Execute test.
        i2c.AdcTest(board);

        // Close connection to the I2C interface.
        board.Close();
      }
      catch (System.Exception exp)
      {
        Console.WriteLine ("Error: " + exp.Message);
      }
      finally
      {
        // Free all resources allocated by the board object.
        // It is very important to call this method before the
        // garbage collector destroys the unused Board object.
        if (board != null)
          board.Dispose();
      }
    }
  }
}
See Also

Reference

telos.I2cApi.DotNet Namespace


Adc Methods

Adc Methods

The Adc type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels the running A/D converter.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessageDataTrigger | Returns the current configuration of the data trigger. If both values are empty, this trigger has been diabled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnSamplingCompletion | Triggers a "sampling completion" event.
Public method | OnTransmissionCompletion | Triggers a "transmission completion" event.
Public method | SetMessageDataTrigger | This method sets the data trigger. It triggers the A/D converter when an I2C message is sent to the bus, whose data bytes after the START condition equal the data bytes specified to this trigger.
Public method | Start | Enables the A/D converter. The hardware will wait for one of the specified trigger event
Public method | StartImmediately | Enables the A/D converter. The hardware will not wait for one of the specified trigger events. Instead it starts the sampling process immediately.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData | This function tells the hardware to transmit the sampled A/D values from the hardware to the application.
Public method | TransferData(AdcData) | This function tells the hardware to transmit the sampled A/D values from the hardware to the application.
Top
See Also

Reference

Adc Class


Adc.Cancel Method

AdcCancel Method
Cancels the running A/D converter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
void Cancel()
member Cancel : unit -> unit
See Also

Reference

Adc Class


Adc.Dispose Method

AdcDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

Adc Class


Adc.Dispose Method

AdcDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Adc Class
Dispose Overload


Adc.Dispose Method (Boolean)

AdcDispose Method (Boolean)
Releases the unmanaged resources used by the Adc and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.Adc.Dispose(System.Boolean)"]

See Also

Reference

Adc Class
Dispose Overload


Adc.Finalize Method

AdcFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

Adc Class


Adc.GetMessageDataTrigger Method

AdcGetMessageDataTrigger Method
Returns the current configuration of the data trigger. If both values are empty, this trigger has been diabled.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetMessageDataTrigger(
    IList<byte> data,
    IList<byte> dont_care
)
Public Sub GetMessageDataTrigger (
    data As IList(Of Byte),
    dont_care As IList(Of Byte)
)
public:
void GetMessageDataTrigger(
    IList<unsigned char>^ data,
    IList<unsigned char>^ dont_care
)
member GetMessageDataTrigger :
        data : IList<byte> *
        dont_care : IList<byte> -> unit

Parameters

data
Type: System.Collections.GenericIList Byte
data bytes to be searched
dont_care
Type: System.Collections.GenericIList Byte
"don't care" mask
See Also

Reference

Adc Class


Adc.OnSamplingCompletion Method

AdcOnSamplingCompletion Method
Triggers a "sampling completion" event.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void OnSamplingCompletion()
Public Sub OnSamplingCompletion
public:
void OnSamplingCompletion()
member OnSamplingCompletion : unit -> unit
See Also

Reference

Adc Class


Adc.OnTransmissionCompletion Method

AdcOnTransmissionCompletion Method
Triggers a "transmission completion" event.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void OnTransmissionCompletion()
Public Sub OnTransmissionCompletion
public:
void OnTransmissionCompletion()
member OnTransmissionCompletion : unit -> unit
See Also

Reference

Adc Class


Adc.SetMessageDataTrigger Method

AdcSetMessageDataTrigger Method
This method sets the data trigger. It triggers the A/D converter when an I2C message is sent to the bus, whose data bytes after the START condition equal the data bytes specified to this trigger.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetMessageDataTrigger(
    IList<byte> data,
    IList<byte> dont_care
)
Public Sub SetMessageDataTrigger (
    data As IList(Of Byte),
    dont_care As IList(Of Byte)
)
public:
void SetMessageDataTrigger(
    IList<unsigned char>^ data,
    IList<unsigned char>^ dont_care
)
member SetMessageDataTrigger :
        data : IList<byte> *
        dont_care : IList<byte> -> unit

Parameters

data
Type: System.Collections.GenericIList Byte
data bytes to be searched
dont_care
Type: System.Collections.GenericIList Byte
"don't care" mask
Remarks

A "don't care" mask is offered so that individual bits can be excluded from the comparison ("0xff" means all bits are compared).

Both parameters passed to this method have to contain the same number of bytes. If both parameters are empty, this trigger gets disabled.

The AdcTriggerData variable can be used to find out whether the used I2C interface supports this trigger and how many data bytes can be specified.

See Also

Reference

Adc Class


Adc.Start Method

AdcStart Method
Enables the A/D converter. The hardware will wait for one of the specified trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
Remarks

This functions works asynchronously and returns immediately to the caller.

After calling this method the program has to call WaitForData(Int32) until the OnSamplingCompletion event handler gets called.

See Also

Reference

Adc Class


Adc.StartImmediately Method

AdcStartImmediately Method
Enables the A/D converter. The hardware will not wait for one of the specified trigger events. Instead it starts the sampling process immediately.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void StartImmediately()
Public Sub StartImmediately
public:
void StartImmediately()
member StartImmediately : unit -> unit
Remarks

This functions works asynchronously and returns immediately to the caller.

After calling this method the program has to call WaitForData(Int32) until the OnSamplingCompletion event handler gets called.

See Also

Reference

Adc Class


Adc.TransferData Method

AdcTransferData Method
Overload List
 | Name | Description
Public method | TransferData | This function tells the hardware to transmit the sampled A/D values from the hardware to the application.
Public method | TransferData(AdcData) | This function tells the hardware to transmit the sampled A/D values from the hardware to the application.
Top
See Also

Reference

Adc Class


Adc.TransferData Method

AdcTransferData Method
This function tells the hardware to transmit the sampled A/D values from the hardware to the application.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData()
Public Sub TransferData
public:
void TransferData()
member TransferData : unit -> unit
Remarks

The samples get stored in the AdcDataList object passed to this method. Most programs will call this function in the OnSamplingCompletion event handler.

This functions works asynchronously and returns immediately to the caller.

After calling this method the program has to call WaitForData(Int32) until the OnTransmissionCompletion event handler gets called. This event signals that the AdcDataList object contains a new AdcData object.

Before this method is used, a AdcDataList must be passed to the AdcDataResultList property.

See Also

Reference

Adc Class
TransferData Overload


Adc.TransferData Method (AdcData)

AdcTransferData Method (AdcData)
This function tells the hardware to transmit the sampled A/D values from the hardware to the application.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    AdcData data
)
Public Sub TransferData (
    data As AdcData
)
public:
void TransferData(
    AdcData^ data
)
member TransferData :
        data : AdcData -> unit

Parameters

data
Type: telos.I2cApi.DotNetAdcData
data of the A/D converter
Remarks

The samples get stored in the AdcData object passed to this method. Most programs will call this function in the OnSamplingCompletion event handler.

This functions works asynchronously and returns immediately to the caller.

After calling this method the program has to call WaitForData(Int32) until the OnTransmissionCompletion event handler gets called. This event signals that the AdcData object contains valid data.

See Also

Reference

Adc Class
TransferData Overload


Adc Properties

Adc Properties

The Adc type exposes the following members.

Properties
 | Name | Description
Public property | AdcDataResultList | List to which TransferData adds completed A/D shots.
Public property | MessageCountTrigger | Specifies the "message count" trigger. It triggers the A/D converter after receiving the specified number of I2C messages. A value of "0" diables this trigger.
Public property | PreTrigger | Specifies how many samples should be stored before the trigger event [samples/channel].
Public property | SamplingCompleted | Tests whether the hardware has finished the sampling process. At this time the samples are stored in the internal memory of the I2C interface. To transfer the samples to the program, it is necessary to call TransferData.
Public property | SamplingRate | Sampling rate of the A/D converter [Hz].
Public property | TransmissionCompleted | When the complete A/D data has been transferred from the hardware to the PC, this property returns "true". At this time the AdcData object passed to TransferData contains valid data.
Public property | UseAckAsTrigger | Specifies whether an I2C ACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseErrorAsTrigger | Specifies whether an I2C ERROR should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseNackAsTrigger | Specifies whether an I2C NACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseStartAsTrigger | Specifies whether an I2C start condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseStopAsTrigger | Specifies whether an I2C stop condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseTestpin1AsTrigger | Specifies whether testpin 1 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Public property | UseTestpin2AsTrigger | Specifies whether testpin 2 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.
Top
See Also

Reference

Adc Class


Adc.AdcDataResultList Property

AdcAdcDataResultList Property
List to which TransferData adds completed A/D shots.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public AdcDataList AdcDataResultList { set; }
Public WriteOnly Property AdcDataResultList As AdcDataList
    Set
public:
property AdcDataList^ AdcDataResultList {
    void set (AdcDataList^ value);
}
member AdcDataResultList : AdcDataList with set

Property Value

Type: AdcDataList
See Also

Reference

Adc Class


Adc.MessageCountTrigger Property

AdcMessageCountTrigger Property
Specifies the "message count" trigger. It triggers the A/D converter after receiving the specified number of I2C messages. A value of "0" diables this trigger.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte MessageCountTrigger { get; set; }
Public Property MessageCountTrigger As Byte
    Get
    Set
public:
property unsigned char MessageCountTrigger {
    unsigned char get ();
    void set (unsigned char value);
}
member MessageCountTrigger : byte with get, set

Property Value

Type: Byte
Remarks

Example: the following messages are sent to the I2C bus: SP, SSP, SSP. A value of "1" will trigger on the first start condition. A value of "3" will trigger on the fourth start condition.

The AdcTriggerMsgCnt variable can be used to find out whether the used I2C interface supports this trigger.

See Also

Reference

Adc Class


Adc.PreTrigger Property

AdcPreTrigger Property
Specifies how many samples should be stored before the trigger event [samples/channel].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int PreTrigger { get; set; }
Public Property PreTrigger As Integer
    Get
    Set
public:
property int PreTrigger {
    int get ();
    void set (int value);
}
member PreTrigger : int with get, set

Property Value

Type: Int32
Remarks
The maximum value for the pretrigger can be found in the AdcMaxPretrigger variable.
See Also

Reference

Adc Class


Adc.SamplingCompleted Property

AdcSamplingCompleted Property
Tests whether the hardware has finished the sampling process. At this time the samples are stored in the internal memory of the I2C interface. To transfer the samples to the program, it is necessary to call TransferData.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SamplingCompleted { get; }
Public ReadOnly Property SamplingCompleted As Boolean
    Get
public:
property bool SamplingCompleted {
    bool get ();
}
member SamplingCompleted : bool with get

Property Value

Type: Boolean
See Also

Reference

Adc Class


Adc.SamplingRate Property

AdcSamplingRate Property
Sampling rate of the A/D converter [Hz].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int SamplingRate { get; set; }
Public Property SamplingRate As Integer
    Get
    Set
public:
property int SamplingRate {
    int get ();
    void set (int value);
}
member SamplingRate : int with get, set

Property Value

Type: Int32
Remarks
Valid values for the sampling rate can be found in the AdcSamplingrate variable.
See Also

Reference

Adc Class


Adc.TransmissionCompleted Property

AdcTransmissionCompleted Property
When the complete A/D data has been transferred from the hardware to the PC, this property returns "true". At this time the AdcData object passed to TransferData contains valid data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TransmissionCompleted { get; }
Public ReadOnly Property TransmissionCompleted As Boolean
    Get
public:
property bool TransmissionCompleted {
    bool get ();
}
member TransmissionCompleted : bool with get

Property Value

Type: Boolean
See Also

Reference

Adc Class


Adc.UseAckAsTrigger Property

AdcUseAckAsTrigger Property
Specifies whether an I2C ACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseAckAsTrigger { get; set; }
Public Property UseAckAsTrigger As Boolean
    Get
    Set
public:
property bool UseAckAsTrigger {
    bool get ();
    void set (bool value);
}
member UseAckAsTrigger : bool with get, set

Property Value

Type: Boolean
Remarks
The AdcTriggerAck variable can be used to find out whether the used I2C interface supports the use of the ACK condition as trigger event.
See Also

Reference

Adc Class


Adc.UseErrorAsTrigger Property

AdcUseErrorAsTrigger Property
Specifies whether an I2C ERROR should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseErrorAsTrigger { get; set; }
Public Property UseErrorAsTrigger As Boolean
    Get
    Set
public:
property bool UseErrorAsTrigger {
    bool get ();
    void set (bool value);
}
member UseErrorAsTrigger : bool with get, set

Property Value

Type: Boolean
Remarks
The AdcTriggerError variable can be used to find out whether the used I2C interface supports the use of the ERROR condition as trigger event.
See Also

Reference

Adc Class


Adc.UseNackAsTrigger Property

AdcUseNackAsTrigger Property
Specifies whether an I2C NACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseNackAsTrigger { get; set; }
Public Property UseNackAsTrigger As Boolean
    Get
    Set
public:
property bool UseNackAsTrigger {
    bool get ();
    void set (bool value);
}
member UseNackAsTrigger : bool with get, set

Property Value

Type: Boolean
Remarks
The AdcTriggerNack variable can be used to find out whether the used I2C interface supports the use of the NACK condition as trigger event.
See Also

Reference

Adc Class


Adc.UseStartAsTrigger Property

AdcUseStartAsTrigger Property
Specifies whether an I2C start condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseStartAsTrigger { get; set; }
Public Property UseStartAsTrigger As Boolean
    Get
    Set
public:
property bool UseStartAsTrigger {
    bool get ();
    void set (bool value);
}
member UseStartAsTrigger : bool with get, set

Property Value

Type: Boolean
Remarks
The AdcTriggerStart variable can be used to find out whether the used I2C interface supports the use of the start condition as trigger event.
See Also

Reference

Adc Class


Adc.UseStopAsTrigger Property

AdcUseStopAsTrigger Property
Specifies whether an I2C stop condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseStopAsTrigger { get; set; }
Public Property UseStopAsTrigger As Boolean
    Get
    Set
public:
property bool UseStopAsTrigger {
    bool get ();
    void set (bool value);
}
member UseStopAsTrigger : bool with get, set

Property Value

Type: Boolean
Remarks
The AdcTriggerStop variable can be used to find out whether the used I2C interface supports the use of the stop condition as trigger event.
See Also

Reference

Adc Class


Adc.UseTestpin1AsTrigger Property

AdcUseTestpin1AsTrigger Property
Specifies whether testpin 1 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseTestpin1AsTrigger { get; set; }
Public Property UseTestpin1AsTrigger As Boolean
    Get
    Set
public:
property bool UseTestpin1AsTrigger {
    bool get ();
    void set (bool value);
}
member UseTestpin1AsTrigger : bool with get, set

Property Value

Type: Boolean
Remarks
The AdcTriggerTestpin1 variable can be used to find out whether the used I2C interface supports the use of testpin 1 as trigger event.
See Also

Reference

Adc Class


Adc.UseTestpin2AsTrigger Property

AdcUseTestpin2AsTrigger Property
Specifies whether testpin 2 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool UseTestpin2AsTrigger { get; set; }
Public Property UseTestpin2AsTrigger As Boolean
    Get
    Set
public:
property bool UseTestpin2AsTrigger {
    bool get ();
    void set (bool value);
}
member UseTestpin2AsTrigger : bool with get, set

Property Value

Type: Boolean
Remarks
The AdcTriggerTestpin2 variable can be used to find out whether the used I2C interface supports the use of testpin 2 as trigger event.
See Also

Reference

Adc Class


Adc Events

Adc Events

The Adc type exposes the following members.

Events
 | Name | Description
Public event | SamplingCompletion | This event gets fired when the hardware has finished the sampling process. At this time the samples are stored in the internal memory of Tracii XL / Tracii XL 2.0. To transfer the samples to the program, it is necessary to call TransferData.
Public event | TransmissionCompletion | This event gets fired when the complete A/D data has been transferred from the hardware to the application.
Top
See Also

Reference

Adc Class


Adc.SamplingCompletion Event

AdcSamplingCompletion Event
This event gets fired when the hardware has finished the sampling process. At this time the samples are stored in the internal memory of Tracii XL / Tracii XL 2.0. To transfer the samples to the program, it is necessary to call TransferData.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SamplingCompletion
Public Event SamplingCompletion As EventHandler
public:
 event EventHandler^ SamplingCompletion {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SamplingCompletion : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Adc Class


Adc.TransmissionCompletion Event

AdcTransmissionCompletion Event
This event gets fired when the complete A/D data has been transferred from the hardware to the application.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TransmissionCompletion
Public Event TransmissionCompletion As EventHandler
public:
 event EventHandler^ TransmissionCompletion {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member TransmissionCompletion : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Adc Class


AdcData Class

AdcData Class
This class is used to store the data from Tracii XL's or Tracii XL 2.0's A/D converter. Instances of this class get passed to TransferData.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetAdcData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class AdcData : ICloneable
Public NotInheritable Class AdcData
    Implements ICloneable
public ref class AdcData sealed : ICloneable
[<SealedAttribute>]
type AdcData =
    class
        interface ICloneable
    end

The AdcData type exposes the following members.

Constructors
 | Name | Description
Public method | AdcData | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | ContainsTimestamp | Tests whether the given timestamp is within the ADC shot.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DataMax | maximum value of SCL/SDA samples
Public property | DataScl | all SCL samples
Public property | DataSda | all SDA samples
Public property | Pretrigger | pretrigger [samples/channel]
Public property | SamplingRate | sampling rate
Public property | TimestampStart | timestamp of the first SCL/SDA sample (see TimestampTimebase for the timebase)
Public property | TimestampStop | timestamp of the last SCL/SDA sample (see TimestampTimebase for the timebase)
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


AdcData Constructor

AdcData Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public AdcData()
Public Sub New
public:
AdcData()
new : unit -> AdcData
See Also

Reference

AdcData Class


AdcData Methods

AdcData Methods

The AdcData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | ContainsTimestamp | Tests whether the given timestamp is within the ADC shot.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AdcData Class


AdcData.Clone Method

AdcDataClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

AdcData Class


AdcData.ContainsTimestamp Method

AdcDataContainsTimestamp Method
Tests whether the given timestamp is within the ADC shot.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ContainsTimestamp(
    ulong timestamp
)
Public Function ContainsTimestamp (
    timestamp As ULong
) As Boolean
public:
bool ContainsTimestamp(
    unsigned long long timestamp
)
member ContainsTimestamp :
        timestamp : uint64 -> bool

Parameters

timestamp
Type: SystemUInt64
timestamp

Return Value

Type: Boolean
within the shot (true), not within the shot (false)
See Also

Reference

AdcData Class


AdcData Properties

AdcData Properties

The AdcData type exposes the following members.

Properties
 | Name | Description
Public property | DataMax | maximum value of SCL/SDA samples
Public property | DataScl | all SCL samples
Public property | DataSda | all SDA samples
Public property | Pretrigger | pretrigger [samples/channel]
Public property | SamplingRate | sampling rate
Public property | TimestampStart | timestamp of the first SCL/SDA sample (see TimestampTimebase for the timebase)
Public property | TimestampStop | timestamp of the last SCL/SDA sample (see TimestampTimebase for the timebase)
Top
See Also

Reference

AdcData Class


AdcData.DataMax Property

AdcDataDataMax Property
maximum value of SCL/SDA samples

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte DataMax { get; set; }
Public Property DataMax As Byte
    Get
    Set
public:
property unsigned char DataMax {
    unsigned char get ();
    void set (unsigned char value);
}
member DataMax : byte with get, set

Property Value

Type: Byte
See Also

Reference

AdcData Class


AdcData.DataScl Property

AdcDataDataScl Property
all SCL samples

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] DataScl { get; set; }
Public Property DataScl As Byte()
    Get
    Set
public:
property array<unsigned char>^ DataScl {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member DataScl : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

AdcData Class


AdcData.DataSda Property

AdcDataDataSda Property
all SDA samples

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] DataSda { get; set; }
Public Property DataSda As Byte()
    Get
    Set
public:
property array<unsigned char>^ DataSda {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member DataSda : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

AdcData Class


AdcData.Pretrigger Property

AdcDataPretrigger Property
pretrigger [samples/channel]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort Pretrigger { get; set; }
Public Property Pretrigger As UShort
    Get
    Set
public:
property unsigned short Pretrigger {
    unsigned short get ();
    void set (unsigned short value);
}
member Pretrigger : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

AdcData Class


AdcData.SamplingRate Property

AdcDataSamplingRate Property
sampling rate

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint SamplingRate { get; set; }
Public Property SamplingRate As UInteger
    Get
    Set
public:
property unsigned int SamplingRate {
    unsigned int get ();
    void set (unsigned int value);
}
member SamplingRate : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

AdcData Class


AdcData.TimestampStart Property

AdcDataTimestampStart Property
timestamp of the first SCL/SDA sample (see TimestampTimebase for the timebase)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong TimestampStart { get; set; }
Public Property TimestampStart As ULong
    Get
    Set
public:
property unsigned long long TimestampStart {
    unsigned long long get ();
    void set (unsigned long long value);
}
member TimestampStart : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

AdcData Class


AdcData.TimestampStop Property

AdcDataTimestampStop Property
timestamp of the last SCL/SDA sample (see TimestampTimebase for the timebase)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong TimestampStop { get; set; }
Public Property TimestampStop As ULong
    Get
    Set
public:
property unsigned long long TimestampStop {
    unsigned long long get ();
    void set (unsigned long long value);
}
member TimestampStop : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

AdcData Class


AdcDataList Class

AdcDataList Class
This class is used to store the data from Tracii XL's or Tracii XL 2.0's A/D converter. Instances of this class get passed to AdcDataResultList.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetAdcDataList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class AdcDataList : IReadOnlyList<AdcData>,
    IDisposable
Public NotInheritable Class AdcDataList
    Implements IReadOnlyList(Of AdcData), IDisposable
public ref class AdcDataList sealed : IReadOnlyList<AdcData^>,
    IDisposable
[<SealedAttribute>]
type AdcDataList =
    class
        interface IReadOnlyList<AdcData>
        interface IDisposable
    end

The AdcDataList type exposes the following members.

Constructors
 | Name | Description
Public method | AdcDataList | Constructor.
Top
Methods
 | Name | Description
Public method | Add | Adds the object to the end of the list.
Public method | Clear | Removes all elements from the list.
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetAdcDataByTimestamp | Searches for the AdcData object, which covers the specified time.
Public method | GetAdcDataByTimestampRange | Searches for the AdcData objects, which cover the specified range of time.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Searches for the index of the AdcData object, which covers the specified time.
Public method | GetIndicesByTimestampRange | Searches for the indices of the AdcData objects, which cover the specified range of time.
Public method | GetNextIndexByTimestamp | Searches for the index of the AdcData object, which has been captured after the specified time.
Public method | GetPreviousOrCurrentIndexByTimestamp | Searches for the index of the AdcData object. If there is an object covering the specified time, its index gets returned. Otherwise the object gets returned, which has been captured before the specified time.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAt | Removes the element at the specified index of the list.
Public method | RemoveOlderThanTimestamp | Removes all AdcData objects from the list, which starts before the given time.
Public method | RemoveRange | Removes a range of elements from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Number of elements stored currently in the list.
Public property | Item |
Public property | Pretrigger | Returns the pretrigger of the element at the given index [samples/channel].
Public property | SamplingRate | Returns the sampling rate of the element at the given index [samples/channel].
Public property | TimestampStart | Returns the start timestamp of the element at the given index.
Public property | TimestampStop | Returns the stop timestamp of the element at the given index.
Top
Remarks
The data is not kept in memory. Instead it gets written to the hard disc. So the number of items, which can be stored in an instance of this class is limited only by the free space on the hard disc.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


AdcDataList Constructor

AdcDataList Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public AdcDataList()
Public Sub New
public:
AdcDataList()
new : unit -> AdcDataList
See Also

Reference

AdcDataList Class


AdcDataList Methods

AdcDataList Methods

The AdcDataList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the object to the end of the list.
Public method | Clear | Removes all elements from the list.
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetAdcDataByTimestamp | Searches for the AdcData object, which covers the specified time.
Public method | GetAdcDataByTimestampRange | Searches for the AdcData objects, which cover the specified range of time.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Searches for the index of the AdcData object, which covers the specified time.
Public method | GetIndicesByTimestampRange | Searches for the indices of the AdcData objects, which cover the specified range of time.
Public method | GetNextIndexByTimestamp | Searches for the index of the AdcData object, which has been captured after the specified time.
Public method | GetPreviousOrCurrentIndexByTimestamp | Searches for the index of the AdcData object. If there is an object covering the specified time, its index gets returned. Otherwise the object gets returned, which has been captured before the specified time.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAt | Removes the element at the specified index of the list.
Public method | RemoveOlderThanTimestamp | Removes all AdcData objects from the list, which starts before the given time.
Public method | RemoveRange | Removes a range of elements from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AdcDataList Class


AdcDataList.Add Method

AdcDataListAdd Method
Adds the object to the end of the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    AdcData data
)
Public Sub Add (
    data As AdcData
)
public:
void Add(
    AdcData^ data
)
member Add :
        data : AdcData -> unit

Parameters

data
Type: telos.I2cApi.DotNetAdcData
data to be added
See Also

Reference

AdcDataList Class


AdcDataList.Clear Method

AdcDataListClear Method
Removes all elements from the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

AdcDataList Class


AdcDataList.Dispose Method

AdcDataListDispose Method
Overload List
 | Name | Description
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

AdcDataList Class


AdcDataList.Dispose Method

AdcDataListDispose Method
Dispose.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AdcDataList Class
Dispose Overload


AdcDataList.Dispose Method (Boolean)

AdcDataListDispose Method (Boolean)
Releases the unmanaged resources used by the AdcDataList and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.AdcDataList.Dispose(System.Boolean)"]

See Also

Reference

AdcDataList Class
Dispose Overload


AdcDataList.Finalize Method

AdcDataListFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

AdcDataList Class


AdcDataList.GetAdcDataByTimestamp Method

AdcDataListGetAdcDataByTimestamp Method
Searches for the AdcData object, which covers the specified time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public AdcData GetAdcDataByTimestamp(
    ulong timestamp
)
Public Function GetAdcDataByTimestamp (
    timestamp As ULong
) As AdcData
public:
AdcData^ GetAdcDataByTimestamp(
    unsigned long long timestamp
)
member GetAdcDataByTimestamp :
        timestamp : uint64 -> AdcData

Parameters

timestamp
Type: SystemUInt64
timestamp

Return Value

Type: AdcData
AdcData object for this time or N/A (0)
See Also

Reference

AdcDataList Class


AdcDataList.GetAdcDataByTimestampRange Method

AdcDataListGetAdcDataByTimestampRange Method
Searches for the AdcData objects, which cover the specified range of time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public AdcData[] GetAdcDataByTimestampRange(
    ulong timestamp_start,
    ulong timestamp_stop
)
Public Function GetAdcDataByTimestampRange (
    timestamp_start As ULong,
    timestamp_stop As ULong
) As AdcData()
public:
array<AdcData^>^ GetAdcDataByTimestampRange(
    unsigned long long timestamp_start,
    unsigned long long timestamp_stop
)
member GetAdcDataByTimestampRange :
        timestamp_start : uint64 *
        timestamp_stop : uint64 -> AdcData[]

Parameters

timestamp_start
Type: SystemUInt64
start timestamp
timestamp_stop
Type: SystemUInt64
stop timestamp

Return Value

Type: AdcData
AdcData objects for this time range
See Also

Reference

AdcDataList Class


AdcDataList.GetEnumerator Method

AdcDataListGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<AdcData> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of AdcData)
public:
virtual IEnumerator<AdcData^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<AdcData>
override GetEnumerator : unit -> IEnumerator<AdcData>

Return Value

Type: IEnumerator AdcData
enumerator
See Also

Reference

AdcDataList Class


AdcDataList.GetEnumerator_NonGeneric Method

AdcDataListGetEnumerator_NonGeneric Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator_NonGeneric()
Public Function GetEnumerator_NonGeneric As IEnumerator
public:
virtual IEnumerator^ GetEnumerator_NonGeneric() sealed
abstract GetEnumerator_NonGeneric : unit -> IEnumerator
override GetEnumerator_NonGeneric : unit -> IEnumerator

Return Value

Type: IEnumerator
enumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

AdcDataList Class


AdcDataList.GetIndexByTimestamp Method

AdcDataListGetIndexByTimestamp Method
Searches for the index of the AdcData object, which covers the specified time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetIndexByTimestamp(
    ulong timestamp
)
Public Function GetIndexByTimestamp (
    timestamp As ULong
) As Integer
public:
int GetIndexByTimestamp(
    unsigned long long timestamp
)
member GetIndexByTimestamp :
        timestamp : uint64 -> int

Parameters

timestamp
Type: SystemUInt64
timestamp

Return Value

Type: Int32
index or N/A (-1)
See Also

Reference

AdcDataList Class


AdcDataList.GetIndicesByTimestampRange Method

AdcDataListGetIndicesByTimestampRange Method
Searches for the indices of the AdcData objects, which cover the specified range of time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] GetIndicesByTimestampRange(
    ulong timestamp_start,
    ulong timestamp_stop
)
Public Function GetIndicesByTimestampRange (
    timestamp_start As ULong,
    timestamp_stop As ULong
) As Integer()
public:
array<int>^ GetIndicesByTimestampRange(
    unsigned long long timestamp_start,
    unsigned long long timestamp_stop
)
member GetIndicesByTimestampRange :
        timestamp_start : uint64 *
        timestamp_stop : uint64 -> int[]

Parameters

timestamp_start
Type: SystemUInt64
start timestamp
timestamp_stop
Type: SystemUInt64
stop timestamp

Return Value

Type: Int32
indices
See Also

Reference

AdcDataList Class


AdcDataList.GetNextIndexByTimestamp Method

AdcDataListGetNextIndexByTimestamp Method
Searches for the index of the AdcData object, which has been captured after the specified time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetNextIndexByTimestamp(
    ulong timestamp
)
Public Function GetNextIndexByTimestamp (
    timestamp As ULong
) As Integer
public:
int GetNextIndexByTimestamp(
    unsigned long long timestamp
)
member GetNextIndexByTimestamp :
        timestamp : uint64 -> int

Parameters

timestamp
Type: SystemUInt64
timestamp

Return Value

Type: Int32
index or N/A (-1)
See Also

Reference

AdcDataList Class


AdcDataList.GetPreviousOrCurrentIndexByTimestamp Method

AdcDataListGetPreviousOrCurrentIndexByTimestamp Method
Searches for the index of the AdcData object. If there is an object covering the specified time, its index gets returned. Otherwise the object gets returned, which has been captured before the specified time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetPreviousOrCurrentIndexByTimestamp(
    ulong timestamp
)
Public Function GetPreviousOrCurrentIndexByTimestamp (
    timestamp As ULong
) As Integer
public:
int GetPreviousOrCurrentIndexByTimestamp(
    unsigned long long timestamp
)
member GetPreviousOrCurrentIndexByTimestamp :
        timestamp : uint64 -> int

Parameters

timestamp
Type: SystemUInt64
timestamp

Return Value

Type: Int32
index or N/A (-1)
See Also

Reference

AdcDataList Class


AdcDataList.RemoveAt Method

AdcDataListRemoveAt Method
Removes the element at the specified index of the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
void RemoveAt(
    int index
)
member RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
the zero-based index of the element to remove
See Also

Reference

AdcDataList Class


AdcDataList.RemoveOlderThanTimestamp Method

AdcDataListRemoveOlderThanTimestamp Method
Removes all AdcData objects from the list, which starts before the given time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveOlderThanTimestamp(
    ulong timestamp
)
Public Sub RemoveOlderThanTimestamp (
    timestamp As ULong
)
public:
void RemoveOlderThanTimestamp(
    unsigned long long timestamp
)
member RemoveOlderThanTimestamp :
        timestamp : uint64 -> unit

Parameters

timestamp
Type: SystemUInt64
timestamp
See Also

Reference

AdcDataList Class


AdcDataList.RemoveRange Method

AdcDataListRemoveRange Method
Removes a range of elements from the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveRange(
    int index,
    int count
)
Public Sub RemoveRange (
    index As Integer,
    count As Integer
)
public:
void RemoveRange(
    int index,
    int count
)
member RemoveRange :
        index : int *
        count : int -> unit

Parameters

index
Type: SystemInt32
the zero-based starting index of the range of elements to remove
count
Type: SystemInt32
the number of elements to remove
See Also

Reference

AdcDataList Class


AdcDataList Properties

AdcDataList Properties

The AdcDataList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Number of elements stored currently in the list.
Public property | Item |
Public property | Pretrigger | Returns the pretrigger of the element at the given index [samples/channel].
Public property | SamplingRate | Returns the sampling rate of the element at the given index [samples/channel].
Public property | TimestampStart | Returns the start timestamp of the element at the given index.
Public property | TimestampStop | Returns the stop timestamp of the element at the given index.
Top
See Also

Reference

AdcDataList Class


AdcDataList.Count Property

AdcDataListCount Property
Number of elements stored currently in the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IReadOnlyListTCount
See Also

Reference

AdcDataList Class


AdcDataList.Item Property

AdcDataListItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.AdcDataList.Item(System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual AdcData this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As AdcData
    Get
public:
virtual property AdcData^ default[int index] {
    AdcData^ get (int index);
}
abstract Item : AdcData with get
override Item : AdcData with get

Parameters

index
Type: SystemInt32

Property Value

Type: AdcData

Implements

IReadOnlyListTItemInt32
See Also

Reference

AdcDataList Class


AdcDataList.Pretrigger Property

AdcDataListPretrigger Property
Returns the pretrigger of the element at the given index [samples/channel].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort this[
    int index
] { get; }
Public ReadOnly Property Pretrigger (
    index As Integer
) As UShort
    Get
public:
property unsigned short Pretrigger[int index] {
    unsigned short get (int index);
}
member Pretrigger : uint16 with get

Parameters

index
Type: SystemInt32

Property Value

Type: UInt16
See Also

Reference

AdcDataList Class


AdcDataList.SamplingRate Property

AdcDataListSamplingRate Property
Returns the sampling rate of the element at the given index [samples/channel].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint this[
    int index
] { get; }
Public ReadOnly Property SamplingRate (
    index As Integer
) As UInteger
    Get
public:
property unsigned int SamplingRate[int index] {
    unsigned int get (int index);
}
member SamplingRate : uint32 with get

Parameters

index
Type: SystemInt32

Property Value

Type: UInt32
See Also

Reference

AdcDataList Class


AdcDataList.TimestampStart Property

AdcDataListTimestampStart Property
Returns the start timestamp of the element at the given index.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong this[
    int index
] { get; }
Public ReadOnly Property TimestampStart (
    index As Integer
) As ULong
    Get
public:
property unsigned long long TimestampStart[int index] {
    unsigned long long get (int index);
}
member TimestampStart : uint64 with get

Parameters

index
Type: SystemInt32

Property Value

Type: UInt64
See Also

Reference

AdcDataList Class


AdcDataList.TimestampStop Property

AdcDataListTimestampStop Property
Returns the stop timestamp of the element at the given index.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong this[
    int index
] { get; }
Public ReadOnly Property TimestampStop (
    index As Integer
) As ULong
    Get
public:
property unsigned long long TimestampStop[int index] {
    unsigned long long get (int index);
}
member TimestampStop : uint64 with get

Parameters

index
Type: SystemInt32

Property Value

Type: UInt64
See Also

Reference

AdcDataList Class


ArrayListByte Class

ArrayListByte Class
This class implements a fast ArrayList for Byte values. The interface is more or less compatible to the interface of ArrayList.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetArrayListByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class ArrayListByte : ICloneable,
    IEquatable<ArrayListByte>, IReadOnlyList<byte>, ISerializable, IDisposable
<SerializableAttribute>
Public NotInheritable Class ArrayListByte
    Implements ICloneable, IEquatable(Of ArrayListByte),
    IReadOnlyList(Of Byte), ISerializable, IDisposable
[SerializableAttribute]
public ref class ArrayListByte sealed : ICloneable,
    IEquatable<ArrayListByte^>, IReadOnlyList<unsigned char>,
    ISerializable, IDisposable
[<SealedAttribute>]
[<SerializableAttribute>]
type ArrayListByte =
    class
        interface ICloneable
        interface IEquatable<ArrayListByte>
        interface IReadOnlyList<byte>
        interface ISerializable
        interface IDisposable
    end

The ArrayListByte type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayListByte | Constructor.
Public method | ArrayListByte(IEnumerableByte) | Constructor.
Top
Methods
 | Name | Description
Public method | Add | Adds the specified data byte to the end of the list.
Public method | Clear | Clears the list.
Public method | Clone | Creates a deep copy of the object.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals(Object) | Tests whether both ArrayListByte objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(ArrayListByte) | Tests whether both ArrayListByte objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | This method is part of the ISerializable interface. It gets used to serialize this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAt | Deletes the element at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality | Tests whether both ArrayListByte objects are equal.
Inequality | Tests whether both ArrayListByte objects are unequal.
Top
Properties
 | Name | Description
Public property | ByteArray | Sets/gets all data bytes as a byte array.
Public property | Count | Gets the number of elements stored in the list.
Public property | Item |
Top
Remarks
Supports the ICloneable, IEquatableT, IReadOnlyListT, and ISerializable interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ArrayListByte Constructor

ArrayListByte Constructor
Overload List
 | Name | Description
Public method | ArrayListByte | Constructor.
Public method | ArrayListByte(IEnumerableByte) | Constructor.
Top
See Also

Reference

ArrayListByte Class


ArrayListByte Constructor

ArrayListByte Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayListByte()
Public Sub New
public:
ArrayListByte()
new : unit -> ArrayListByte
See Also

Reference

ArrayListByte Class
ArrayListByte Overload


ArrayListByte Constructor (IEnumerable(Byte))

ArrayListByte Constructor (IEnumerableByte)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayListByte(
    IEnumerable<byte> data
)
Public Sub New (
    data As IEnumerable(Of Byte)
)
public:
ArrayListByte(
    IEnumerable<unsigned char>^ data
)
new :
        data : IEnumerable<byte> -> ArrayListByte

Parameters

data
Type: System.Collections.GenericIEnumerable Byte
data to be used for initialization
See Also

Reference

ArrayListByte Class
ArrayListByte Overload


ArrayListByte Methods

ArrayListByte Methods

The ArrayListByte type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified data byte to the end of the list.
Public method | Clear | Clears the list.
Public method | Clone | Creates a deep copy of the object.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals(Object) | Tests whether both ArrayListByte objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(ArrayListByte) | Tests whether both ArrayListByte objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | This method is part of the ISerializable interface. It gets used to serialize this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAt | Deletes the element at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ArrayListByte Class


ArrayListByte.Add Method

ArrayListByteAdd Method
Adds the specified data byte to the end of the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    byte data
)
Public Sub Add (
    data As Byte
)
public:
void Add(
    unsigned char data
)
member Add :
        data : byte -> unit

Parameters

data
Type: SystemByte
byte to be added
See Also

Reference

ArrayListByte Class


ArrayListByte.Clear Method

ArrayListByteClear Method
Clears the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ArrayListByte Class


ArrayListByte.Clone Method

ArrayListByteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

ArrayListByte Class


ArrayListByte.Dispose Method

ArrayListByteDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

ArrayListByte Class


ArrayListByte.Dispose Method

ArrayListByteDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ArrayListByte Class
Dispose Overload


ArrayListByte.Dispose Method (Boolean)

ArrayListByteDispose Method (Boolean)
Releases the unmanaged resources used by the ArrayListByte and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.ArrayListByte.Dispose(System.Boolean)"]

See Also

Reference

ArrayListByte Class
Dispose Overload


ArrayListByte.Equals Method

ArrayListByteEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both ArrayListByte objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(ArrayListByte) | Tests whether both ArrayListByte objects are equal.
Top
See Also

Reference

ArrayListByte Class


ArrayListByte.Equals Method (Object)

ArrayListByteEquals Method (Object)
Tests whether both ArrayListByte objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
compare with this object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

ArrayListByte Class
Equals Overload


ArrayListByte.Equals Method (ArrayListByte)

ArrayListByteEquals Method (ArrayListByte)
Tests whether both ArrayListByte objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    ArrayListByte obj
)
Public Function Equals (
    obj As ArrayListByte
) As Boolean
public:
virtual bool Equals(
    ArrayListByte^ obj
) sealed
abstract Equals :
        obj : ArrayListByte -> bool
override Equals :
        obj : ArrayListByte -> bool

Parameters

obj
Type: telos.I2cApi.DotNetArrayListByte
compare with this object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

ArrayListByte Class
Equals Overload


ArrayListByte.GetEnumerator Method

ArrayListByteGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<byte> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Byte)
public:
virtual IEnumerator<unsigned char>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<byte>
override GetEnumerator : unit -> IEnumerator<byte>

Return Value

Type: IEnumerator Byte
enumerator
See Also

Reference

ArrayListByte Class


ArrayListByte.GetEnumerator_NonGeneric Method

ArrayListByteGetEnumerator_NonGeneric Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator_NonGeneric()
Public Function GetEnumerator_NonGeneric As IEnumerator
public:
virtual IEnumerator^ GetEnumerator_NonGeneric() sealed
abstract GetEnumerator_NonGeneric : unit -> IEnumerator
override GetEnumerator_NonGeneric : unit -> IEnumerator

Return Value

Type: IEnumerator
enumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ArrayListByte Class


ArrayListByte.GetObjectData Method

ArrayListByteGetObjectData Method
This method is part of the ISerializable interface. It gets used to serialize this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
SerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
StreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ArrayListByte Class


ArrayListByte.RemoveAt Method

ArrayListByteRemoveAt Method
Deletes the element at the specified index.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
void RemoveAt(
    int index
)
member RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
index of the element to be deleted
See Also

Reference

ArrayListByte Class


ArrayListByte Operators

ArrayListByte Operators

The ArrayListByte type exposes the following members.

Operators
Name | Description
Equality | Tests whether both ArrayListByte objects are equal.
Inequality | Tests whether both ArrayListByte objects are unequal.
Top
See Also

Reference

ArrayListByte Class


ArrayListByte.Equality Operator

ArrayListByteEquality Operator
Tests whether both ArrayListByte objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    ArrayListByte list1,
    ArrayListByte list2
)
Public Shared Operator = (
    list1 As ArrayListByte,
    list2 As ArrayListByte
) As Boolean
public:
static bool operator ==(
    ArrayListByte^ list1,
    ArrayListByte^ list2
)
static let inline (=)
        list1 : ArrayListByte *
        list2 : ArrayListByte  : bool

Parameters

list1
Type: telos.I2cApi.DotNetArrayListByte
first list of bytes
list2
Type: telos.I2cApi.DotNetArrayListByte
second list of bytes

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

ArrayListByte Class


ArrayListByte.Inequality Operator

ArrayListByteInequality Operator
Tests whether both ArrayListByte objects are unequal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    ArrayListByte list1,
    ArrayListByte list2
)
Public Shared Operator <> (
    list1 As ArrayListByte,
    list2 As ArrayListByte
) As Boolean
public:
static bool operator !=(
    ArrayListByte^ list1,
    ArrayListByte^ list2
)
static let inline (<>)
        list1 : ArrayListByte *
        list2 : ArrayListByte  : bool

Parameters

list1
Type: telos.I2cApi.DotNetArrayListByte
first list of bytes
list2
Type: telos.I2cApi.DotNetArrayListByte
second list of bytes

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

ArrayListByte Class


ArrayListByte Properties

ArrayListByte Properties

The ArrayListByte type exposes the following members.

Properties
 | Name | Description
Public property | ByteArray | Sets/gets all data bytes as a byte array.
Public property | Count | Gets the number of elements stored in the list.
Public property | Item |
Top
See Also

Reference

ArrayListByte Class


ArrayListByte.ByteArray Property

ArrayListByteByteArray Property
Sets/gets all data bytes as a byte array.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] ByteArray { get; set; }
Public Property ByteArray As Byte()
    Get
    Set
public:
property array<unsigned char>^ ByteArray {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ByteArray : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ArrayListByte Class


ArrayListByte.Count Property

ArrayListByteCount Property
Gets the number of elements stored in the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IReadOnlyListTCount
See Also

Reference

ArrayListByte Class


ArrayListByte.Item Property

ArrayListByteItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.ArrayListByte.Item(System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual byte this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As Byte
    Get
    Set
public:
virtual property unsigned char default[int index] {
    unsigned char get (int index);
    void set (int index, unsigned char value);
}
abstract Item : byte with get, set
override Item : byte with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: Byte

Implements

IReadOnlyListTItemInt32
See Also

Reference

ArrayListByte Class


Board Class

Board Class
This is the main class of the I2C API, which communicates with an I2C interface via the I2C scheduler. To use the I2C API it is always necessary to create one instance of this class.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetBoard

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Board : IDisposable
Public NotInheritable Class Board
    Implements IDisposable
public ref class Board sealed : IDisposable
[<SealedAttribute>]
type Board =
    class
        interface IDisposable
    end

The Board type exposes the following members.

Constructors
 | Name | Description
Public method | Board | Constructor.
Public method | Board(String, UInt16, String) | Constructor: establishes a connection over TCP/IP to an I2C scheduler on a remote system.
Top
Methods
 | Name | Description
Public method | Close | Closes the connection to the I2C interface.
Public method | Dispose | Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize(): this method gets called by .NET's GC, when the object gets destroyed. It is very important to call Dispose before this happens. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputTestpin(ICollectionBoolean) | Returns the current status of the input testpins.
Public method | GetInputTestpin(Int32) | Returns the current status of the specified input testpin. The number of available input testpins is stored in the TestpinsIn, which can be accessed using the HardwareInfoOfOpenBoard property.
Public method | GetOutputTestpin(ICollectionBoolean) | Returns the levels of the hardware's output testpins.
Public method | GetOutputTestpin(Int32) | Returns the level of one of the hardware's output testpins. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using HardwareInfoOfOpenBoard.
 | GetSchedulerIpPort | Returns the TCP/IP port used by the local I2C scheduler.
 | GetSchedulerRemoteAccess | Gets the configuration for the I2C scheduler's remote access feature. It is possible to connect to the I2C scheduler on other PCs over TCP/IP.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBoardAvailable | Tests whether the specified I2C interface is available.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open(HardwareInfo) | Connects an object of this class with the specified I2C interface.
Public method | Open(BoardType, UInt16) | Connects an object of this class with the specified I2C interface.
Public method | PingScheduler | Pings the I2C scheduler. This can be used to ensure that the remote I2C scheduler is still alive.
Public method | SetOutputTestpin(ICollectionBoolean) | Sets the hardware's output testpins to the specified levels. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public method | SetOutputTestpin(Int32, Boolean) | Sets one of the hardware's output testpins to the specified level. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.
 | SetSchedulerIpPort | Configures the TCP/IP port to be used by the local I2C scheduler.
 | SetSchedulerRemoteAccess | Configures the remote access feature of the I2C scheduler. It is possible to connect to the I2C scheduler on other PCs over TCP/IP.
Public method | StoreLicenseData | Sends a registration code to the hardware. This is used to unlock special features of the hardware.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForData(Int32) | This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.
Public method | WaitForData(TimeSpan) | This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.
Top
Properties
 | Name | Description
Public property | AckActivatesTestpin | Configures the testpin (out) of the hardware. If the hardware detects an ACK condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | Adc | This property can be used to get access to the A/D converter functionality of the I2C interface connected to this object.
Public property | BusType | Some I2C interfaces supports variants of the I2C bus like e.g. the SMBus. This property configures the type of the bus currently connected to the I2C interface.
Public property | ErrorActivatesTestpin | Configures the testpin (out) of the hardware. If the hardware detects an ERROR condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | HardwareInfoOfOpenBoard | Returns the hardware information of the I2C interface, to which this object is connected to.
Public property | HighLevelThreshold | Sets/gets the high level threshold [percent]. This threshold defines the voltage range on SCL/SDA interpreted as logical "1". Valid values for the high level threshold of the opened I2C interface are stored in the HighLevelThreshold variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | I2cBusLoad | Returns the load of the I2C bus [%].
Public property | I2cBusState | Returns the state of the I2C bus. This can be used to detect a hanging (more than 500 ms low) SCL and/or SDA.
Public property | I2cVcc | Returns the Vcc voltage of the I2C bus [mV].
Public property | I2cVccSupply | Sets the I2C Vcc supply voltage [mV].
Public property | IsOpen | Returns whether the instance is connected to an I2C interface.
Public property | ListOfBoards | Returns a list of all available I2C interfaces. Reading this property is expensive, so it is recommended to store a reference to the returned ListT.
Public property | LowLevelThreshold | Sets/gets the low level threshold [percent]. This threshold defines the voltage range on SCL/SDA interpreted as logical "0". Valid values for the low level threshold of the opened I2C interface are stored in the LowLevelThreshold variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | Master | This property can be used to get access to the master functionality of the I2C interface connected to this object.
Public property | NackActivatesTestpin | Configures the testpin (out) of the hardware. If the hardware detects an NACK condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | NegativeTester | This property can be used to get access to the negative tester functionality of the I2C interface connected to this object.
Public property | RequiredServiceContract | Returns the minimal service contract required by an I2C interface to be used with the running I2C scheduler.
Public property | SchedulerIpAddress | Returns the IP address of the I2C scheduler.
Public property | SchedulerVersion | Returns the version of the running I2C scheduler.
Public property | SlaveRamEnhanced | This property can be used to get access to the slave functionality of the I2C interface connected to this object.
Public property | StartActivatesTestpin | Configures the testpin (out) of the hardware. When the hardware detects a START condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | StopActivatesTestpin | Configures the testpin (out) of the hardware. When the hardware detects a STOP condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | TerminationScl | Sets/gets the termination of SCL [Ohm]. Valid values for the termination of the opened I2C interface are stored in the Termination variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | TerminationSda | Sets/gets the termination of SDA [Ohm]. Valid values for the termination of the opened I2C interface are stored in the Termination variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | Tracer | This property can be used to get access to the tracer functionality of the I2C interface connected to this object.
Top
Events
 | Name | Description
Public event | BoardAddedRemoved | This event gets fired, when the user connects a new I2C interface to the PC or disconnects an existing one.
Top
Remarks

To communicate with e.g. the tracer module of an I2C interface the following steps are necessary:

  1. Create an instance of this class.
  2. Request the list of available I2C interfaces using ListOfBoards.
  3. Open an I2C interface supporting the tracer module using Open(HardwareInfo).
  4. Use the Tracer property to get a reference to the Tracer object created and managed by this class.
  5. Use the Tracer object to communicate with the tracer module.
  6. Close the I2C interface using Close
  7. When an instance of this class is no longer needed, it must be destroyed manually. This can be done in C++ using "delete". In all other .NET languages Dispose can be called. It is very important to call this method before the GC destroys the object.

Thread-safety: All classes of the I2C API are thread-safe as long as you call methods of instances of these classes only in those threads, which have been used to create the instances. One thread-safety problem arises due to .NET's garbage collector (GC), which has been implemented as its own thread. If the GC destroys instances of the Board class, this can cause thread-safety problems, if the application has not previously called the Dispose method.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


Board Constructor

Board Constructor
Overload List
 | Name | Description
Public method | Board | Constructor.
Public method | Board(String, UInt16, String) | Constructor: establishes a connection over TCP/IP to an I2C scheduler on a remote system.
Top
See Also

Reference

Board Class


Board Constructor

Board Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Board()
Public Sub New
public:
Board()
new : unit -> Board
See Also

Reference

Board Class
Board Overload


Board Constructor (String, UInt16, String)

Board Constructor (String, UInt16, String)
Constructor: establishes a connection over TCP/IP to an I2C scheduler on a remote system.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Board(
    string ip_address,
    ushort ip_port,
    string password
)
Public Sub New (
    ip_address As String,
    ip_port As UShort,
    password As String
)
public:
Board(
    String^ ip_address,
    unsigned short ip_port,
    String^ password
)
new :
        ip_address : string *
        ip_port : uint16 *
        password : string -> Board

Parameters

ip_address
Type: SystemString
TCP/IP address of the remote system
ip_port
Type: SystemUInt16
TCP/IP port of the remote system
password
Type: SystemString
authentication password of the remote system
See Also

Reference

Board Class
Board Overload


Board Methods

Board Methods

The Board type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the connection to the I2C interface.
Public method | Dispose | Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize(): this method gets called by .NET's GC, when the object gets destroyed. It is very important to call Dispose before this happens. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputTestpin(ICollectionBoolean) | Returns the current status of the input testpins.
Public method | GetInputTestpin(Int32) | Returns the current status of the specified input testpin. The number of available input testpins is stored in the TestpinsIn, which can be accessed using the HardwareInfoOfOpenBoard property.
Public method | GetOutputTestpin(ICollectionBoolean) | Returns the levels of the hardware's output testpins.
Public method | GetOutputTestpin(Int32) | Returns the level of one of the hardware's output testpins. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using HardwareInfoOfOpenBoard.
 | GetSchedulerIpPort | Returns the TCP/IP port used by the local I2C scheduler.
 | GetSchedulerRemoteAccess | Gets the configuration for the I2C scheduler's remote access feature. It is possible to connect to the I2C scheduler on other PCs over TCP/IP.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBoardAvailable | Tests whether the specified I2C interface is available.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open(HardwareInfo) | Connects an object of this class with the specified I2C interface.
Public method | Open(BoardType, UInt16) | Connects an object of this class with the specified I2C interface.
Public method | PingScheduler | Pings the I2C scheduler. This can be used to ensure that the remote I2C scheduler is still alive.
Public method | SetOutputTestpin(ICollectionBoolean) | Sets the hardware's output testpins to the specified levels. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public method | SetOutputTestpin(Int32, Boolean) | Sets one of the hardware's output testpins to the specified level. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.
 | SetSchedulerIpPort | Configures the TCP/IP port to be used by the local I2C scheduler.
 | SetSchedulerRemoteAccess | Configures the remote access feature of the I2C scheduler. It is possible to connect to the I2C scheduler on other PCs over TCP/IP.
Public method | StoreLicenseData | Sends a registration code to the hardware. This is used to unlock special features of the hardware.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForData(Int32) | This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.
Public method | WaitForData(TimeSpan) | This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.
Top
See Also

Reference

Board Class


Board.Close Method

BoardClose Method
Closes the connection to the I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
See Also

Reference

Board Class


Board.Dispose Method

BoardDispose Method
Overload List
 | Name | Description
Public method | Dispose | Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

Board Class


Board.Dispose Method

BoardDispose Method
Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Board Class
Dispose Overload


Board.Dispose Method (Boolean)

BoardDispose Method (Boolean)
Releases the unmanaged resources used by the Board and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.Board.Dispose(System.Boolean)"]

See Also

Reference

Board Class
Dispose Overload


Board.Finalize Method

BoardFinalize Method
Finalize(): this method gets called by .NET's GC, when the object gets destroyed. It is very important to call Dispose before this happens.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

Board Class


Board.GetInputTestpin Method

BoardGetInputTestpin Method
Overload List
 | Name | Description
Public method | GetInputTestpin(ICollectionBoolean) | Returns the current status of the input testpins.
Public method | GetInputTestpin(Int32) | Returns the current status of the specified input testpin. The number of available input testpins is stored in the TestpinsIn, which can be accessed using the HardwareInfoOfOpenBoard property.
Top
See Also

Reference

Board Class


Board.GetInputTestpin Method (ICollection(Boolean))

BoardGetInputTestpin Method (ICollectionBoolean)
Returns the current status of the input testpins.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetInputTestpin(
    ICollection<bool> result
)
Public Sub GetInputTestpin (
    result As ICollection(Of Boolean)
)
public:
void GetInputTestpin(
    ICollection<bool>^ result
)
member GetInputTestpin :
        result : ICollection<bool> -> unit

Parameters

result
Type: System.Collections.GenericICollection Boolean
status of the testpins: low (false), high (true)
See Also

Reference

Board Class
GetInputTestpin Overload


Board.GetInputTestpin Method (Int32)

BoardGetInputTestpin Method (Int32)

Returns the current status of the specified input testpin.

The number of available input testpins is stored in the TestpinsIn, which can be accessed using the HardwareInfoOfOpenBoard property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool GetInputTestpin(
    int testpin
)
Public Function GetInputTestpin (
    testpin As Integer
) As Boolean
public:
bool GetInputTestpin(
    int testpin
)
member GetInputTestpin :
        testpin : int -> bool

Parameters

testpin
Type: SystemInt32
testpin to be read

Return Value

Type: Boolean
status of the testpin: low (false), high (true)
See Also

Reference

Board Class
GetInputTestpin Overload


Board.GetOutputTestpin Method

BoardGetOutputTestpin Method
Overload List
 | Name | Description
Public method | GetOutputTestpin(ICollectionBoolean) | Returns the levels of the hardware's output testpins.
Public method | GetOutputTestpin(Int32) | Returns the level of one of the hardware's output testpins. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using HardwareInfoOfOpenBoard.
Top
See Also

Reference

Board Class


Board.GetOutputTestpin Method (ICollection(Boolean))

BoardGetOutputTestpin Method (ICollectionBoolean)
Returns the levels of the hardware's output testpins.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetOutputTestpin(
    ICollection<bool> levels
)
Public Sub GetOutputTestpin (
    levels As ICollection(Of Boolean)
)
public:
void GetOutputTestpin(
    ICollection<bool>^ levels
)
member GetOutputTestpin :
        levels : ICollection<bool> -> unit

Parameters

levels
Type: System.Collections.GenericICollection Boolean
levels (as bool): low (false), high (true)
See Also

Reference

Board Class
GetOutputTestpin Overload


Board.GetOutputTestpin Method (Int32)

BoardGetOutputTestpin Method (Int32)
Returns the level of one of the hardware's output testpins. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using HardwareInfoOfOpenBoard.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool GetOutputTestpin(
    int testpin
)
Public Function GetOutputTestpin (
    testpin As Integer
) As Boolean
public:
bool GetOutputTestpin(
    int testpin
)
member GetOutputTestpin :
        testpin : int -> bool

Parameters

testpin
Type: SystemInt32
number of the testpin to be read

Return Value

Type: Boolean
level: low (false), high (true)
See Also

Reference

Board Class
GetOutputTestpin Overload


Board.GetSchedulerIpPort Method

BoardGetSchedulerIpPort Method
Returns the TCP/IP port used by the local I2C scheduler.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static ushort GetSchedulerIpPort()
Public Shared Function GetSchedulerIpPort As UShort
public:
static unsigned short GetSchedulerIpPort()
static member GetSchedulerIpPort : unit -> uint16

Return Value

Type: UInt16
TCP/IP port
See Also

Reference

Board Class


Board.GetSchedulerRemoteAccess Method

BoardGetSchedulerRemoteAccess Method
Gets the configuration for the I2C scheduler's remote access feature. It is possible to connect to the I2C scheduler on other PCs over TCP/IP.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static void GetSchedulerRemoteAccess(
    ref ValueType enabled,
    ref string password
)
Public Shared Sub GetSchedulerRemoteAccess (
    ByRef enabled As ValueType,
    ByRef password As String
)
public:
static void GetSchedulerRemoteAccess(
    ValueType^% enabled,
    String^% password
)
static member GetSchedulerRemoteAccess :
        enabled : ValueType byref *
        password : string byref -> unit

Parameters

enabled
Type: SystemValueType
remote access enabled (true), remote access disabled (false)
password
Type: SystemString
password for remote access
See Also

Reference

Board Class


Board.IsBoardAvailable Method

BoardIsBoardAvailable Method
Tests whether the specified I2C interface is available.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsBoardAvailable(
    ushort serial_number,
    BoardType board_type
)
Public Function IsBoardAvailable (
    serial_number As UShort,
    board_type As BoardType
) As Boolean
public:
bool IsBoardAvailable(
    unsigned short serial_number,
    BoardType board_type
)
member IsBoardAvailable :
        serial_number : uint16 *
        board_type : BoardType -> bool

Parameters

serial_number
Type: SystemUInt16
serial number of the I2C interface
board_type
Type: telos.I2cApi.DotNetBoardType
type of the I2C interface

Return Value

Type: Boolean
I2C interface available (true), not available (false)
See Also

Reference

Board Class


Board.Open Method

BoardOpen Method
Overload List
 | Name | Description
Public method | Open(HardwareInfo) | Connects an object of this class with the specified I2C interface.
Public method | Open(BoardType, UInt16) | Connects an object of this class with the specified I2C interface.
Top
See Also

Reference

Board Class


Board.Open Method (HardwareInfo)

BoardOpen Method (HardwareInfo)
Connects an object of this class with the specified I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Open(
    HardwareInfo hwinfo
)
Public Sub Open (
    hwinfo As HardwareInfo
)
public:
void Open(
    HardwareInfo^ hwinfo
)
member Open :
        hwinfo : HardwareInfo -> unit

Parameters

hwinfo
Type: telos.I2cApi.DotNetHardwareInfo
hardware information of the I2C interface to be opened
See Also

Reference

Board Class
Open Overload


Board.Open Method (BoardType, UInt16)

BoardOpen Method (BoardType, UInt16)
Connects an object of this class with the specified I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Open(
    BoardType board_type,
    ushort serial_number
)
Public Sub Open (
    board_type As BoardType,
    serial_number As UShort
)
public:
void Open(
    BoardType board_type,
    unsigned short serial_number
)
member Open :
        board_type : BoardType *
        serial_number : uint16 -> unit

Parameters

board_type
Type: telos.I2cApi.DotNetBoardType
type of the I2C interface to be opened
serial_number
Type: SystemUInt16
serial number of the I2C interface to be opened
See Also

Reference

Board Class
Open Overload


Board.PingScheduler Method

BoardPingScheduler Method
Pings the I2C scheduler. This can be used to ensure that the remote I2C scheduler is still alive.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void PingScheduler()
Public Sub PingScheduler
public:
void PingScheduler()
member PingScheduler : unit -> unit
See Also

Reference

Board Class


Board.SetOutputTestpin Method

BoardSetOutputTestpin Method
Overload List
 | Name | Description
Public method | SetOutputTestpin(ICollectionBoolean) | Sets the hardware's output testpins to the specified levels. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public method | SetOutputTestpin(Int32, Boolean) | Sets one of the hardware's output testpins to the specified level. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Top
See Also

Reference

Board Class


Board.SetOutputTestpin Method (ICollection(Boolean))

BoardSetOutputTestpin Method (ICollectionBoolean)
Sets the hardware's output testpins to the specified levels. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetOutputTestpin(
    ICollection<bool> levels
)
Public Sub SetOutputTestpin (
    levels As ICollection(Of Boolean)
)
public:
void SetOutputTestpin(
    ICollection<bool>^ levels
)
member SetOutputTestpin :
        levels : ICollection<bool> -> unit

Parameters

levels
Type: System.Collections.GenericICollection Boolean
levels to be set: low (false), high (true)
See Also

Reference

Board Class
SetOutputTestpin Overload


Board.SetOutputTestpin Method (Int32, Boolean)

BoardSetOutputTestpin Method (Int32, Boolean)
Sets one of the hardware's output testpins to the specified level. The number of available output testpins is stored in the TestpinsOut variable, which can be accessed using the HardwareInfoOfOpenBoard property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetOutputTestpin(
    int testpin,
    bool level
)
Public Sub SetOutputTestpin (
    testpin As Integer,
    level As Boolean
)
public:
void SetOutputTestpin(
    int testpin,
    bool level
)
member SetOutputTestpin :
        testpin : int *
        level : bool -> unit

Parameters

testpin
Type: SystemInt32
number of the testpin to be changed
level
Type: SystemBoolean
level to be set: low (false), high (true)
See Also

Reference

Board Class
SetOutputTestpin Overload


Board.SetSchedulerIpPort Method

BoardSetSchedulerIpPort Method
Configures the TCP/IP port to be used by the local I2C scheduler.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SetSchedulerIpPort(
    ushort port
)
Public Shared Sub SetSchedulerIpPort (
    port As UShort
)
public:
static void SetSchedulerIpPort(
    unsigned short port
)
static member SetSchedulerIpPort :
        port : uint16 -> unit

Parameters

port
Type: SystemUInt16
TCP/IP port
See Also

Reference

Board Class


Board.SetSchedulerRemoteAccess Method

BoardSetSchedulerRemoteAccess Method
Configures the remote access feature of the I2C scheduler. It is possible to connect to the I2C scheduler on other PCs over TCP/IP.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SetSchedulerRemoteAccess(
    bool enabled,
    string password
)
Public Shared Sub SetSchedulerRemoteAccess (
    enabled As Boolean,
    password As String
)
public:
static void SetSchedulerRemoteAccess(
    bool enabled,
    String^ password
)
static member SetSchedulerRemoteAccess :
        enabled : bool *
        password : string -> unit

Parameters

enabled
Type: SystemBoolean
enable remote access (true), disable remote access (false)
password
Type: SystemString
password for remote access
Remarks
This function allows to enable or disable this feature for the local I2C scheduler. Additional it is possible to limit the remote access by specifying a password.
See Also

Reference

Board Class


Board.StoreLicenseData Method

BoardStoreLicenseData Method
Sends a registration code to the hardware. This is used to unlock special features of the hardware.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void StoreLicenseData(
    byte[] data,
    bool renum
)
Public Sub StoreLicenseData (
    data As Byte(),
    renum As Boolean
)
public:
void StoreLicenseData(
    array<unsigned char>^ data,
    bool renum
)
member StoreLicenseData :
        data : byte[] *
        renum : bool -> unit

Parameters

data
Type: SystemByte
registration code
renum
Type: SystemBoolean
renumerate I2C interface?
Remarks
If it is necessary to send more than one registration to an I2C interface, it can be useful to disable the USB renumeration for all registration codes with exception of the last one.
See Also

Reference

Board Class


Board.WaitForData Method

BoardWaitForData Method
Overload List
 | Name | Description
Public method | WaitForData(Int32) | This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.
Public method | WaitForData(TimeSpan) | This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.
Top
See Also

Reference

Board Class


Board.WaitForData Method (Int32)

BoardWaitForData Method (Int32)
This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void WaitForData(
    int timeout_us
)
Public Sub WaitForData (
    timeout_us As Integer
)
public:
void WaitForData(
    int timeout_us
)
member WaitForData :
        timeout_us : int -> unit

Parameters

timeout_us
Type: SystemInt32
timeout [usec]
See Also

Reference

Board Class
WaitForData Overload


Board.WaitForData Method (TimeSpan)

BoardWaitForData Method (TimeSpan)
This function blocks until the API has received data from the scheduler. During this time the thread sleeps and does not consume CPU time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void WaitForData(
    TimeSpan timeout
)
Public Sub WaitForData (
    timeout As TimeSpan
)
public:
void WaitForData(
    TimeSpan timeout
)
member WaitForData :
        timeout : TimeSpan -> unit

Parameters

timeout
Type: SystemTimeSpan
timeout
See Also

Reference

Board Class
WaitForData Overload


Board Properties

Board Properties

The Board type exposes the following members.

Properties
 | Name | Description
Public property | AckActivatesTestpin | Configures the testpin (out) of the hardware. If the hardware detects an ACK condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | Adc | This property can be used to get access to the A/D converter functionality of the I2C interface connected to this object.
Public property | BusType | Some I2C interfaces supports variants of the I2C bus like e.g. the SMBus. This property configures the type of the bus currently connected to the I2C interface.
Public property | ErrorActivatesTestpin | Configures the testpin (out) of the hardware. If the hardware detects an ERROR condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | HardwareInfoOfOpenBoard | Returns the hardware information of the I2C interface, to which this object is connected to.
Public property | HighLevelThreshold | Sets/gets the high level threshold [percent]. This threshold defines the voltage range on SCL/SDA interpreted as logical "1". Valid values for the high level threshold of the opened I2C interface are stored in the HighLevelThreshold variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | I2cBusLoad | Returns the load of the I2C bus [%].
Public property | I2cBusState | Returns the state of the I2C bus. This can be used to detect a hanging (more than 500 ms low) SCL and/or SDA.
Public property | I2cVcc | Returns the Vcc voltage of the I2C bus [mV].
Public property | I2cVccSupply | Sets the I2C Vcc supply voltage [mV].
Public property | IsOpen | Returns whether the instance is connected to an I2C interface.
Public property | ListOfBoards | Returns a list of all available I2C interfaces. Reading this property is expensive, so it is recommended to store a reference to the returned ListT.
Public property | LowLevelThreshold | Sets/gets the low level threshold [percent]. This threshold defines the voltage range on SCL/SDA interpreted as logical "0". Valid values for the low level threshold of the opened I2C interface are stored in the LowLevelThreshold variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | Master | This property can be used to get access to the master functionality of the I2C interface connected to this object.
Public property | NackActivatesTestpin | Configures the testpin (out) of the hardware. If the hardware detects an NACK condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | NegativeTester | This property can be used to get access to the negative tester functionality of the I2C interface connected to this object.
Public property | RequiredServiceContract | Returns the minimal service contract required by an I2C interface to be used with the running I2C scheduler.
Public property | SchedulerIpAddress | Returns the IP address of the I2C scheduler.
Public property | SchedulerVersion | Returns the version of the running I2C scheduler.
Public property | SlaveRamEnhanced | This property can be used to get access to the slave functionality of the I2C interface connected to this object.
Public property | StartActivatesTestpin | Configures the testpin (out) of the hardware. When the hardware detects a START condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | StopActivatesTestpin | Configures the testpin (out) of the hardware. When the hardware detects a STOP condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.
Public property | TerminationScl | Sets/gets the termination of SCL [Ohm]. Valid values for the termination of the opened I2C interface are stored in the Termination variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | TerminationSda | Sets/gets the termination of SDA [Ohm]. Valid values for the termination of the opened I2C interface are stored in the Termination variable, which can be accessed using the HardwareInfoOfOpenBoard property.
Public property | Tracer | This property can be used to get access to the tracer functionality of the I2C interface connected to this object.
Top
See Also

Reference

Board Class


Board.AckActivatesTestpin Property

BoardAckActivatesTestpin Property
Configures the testpin (out) of the hardware. If the hardware detects an ACK condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AckActivatesTestpin { get; set; }
Public Property AckActivatesTestpin As Boolean
    Get
    Set
public:
property bool AckActivatesTestpin {
    bool get ();
    void set (bool value);
}
member AckActivatesTestpin : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Board Class


Board.Adc Property

BoardAdc Property
This property can be used to get access to the A/D converter functionality of the I2C interface connected to this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Adc Adc { get; }
Public ReadOnly Property Adc As Adc
    Get
public:
property Adc^ Adc {
    Adc^ get ();
}
member Adc : Adc with get

Property Value

Type: Adc
See Also

Reference

Board Class


Board.BusType Property

BoardBusType Property
Some I2C interfaces supports variants of the I2C bus like e.g. the SMBus. This property configures the type of the bus currently connected to the I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public BoardBusTypes BusType { get; set; }
Public Property BusType As BoardBusTypes
    Get
    Set
public:
property BoardBusTypes BusType {
    BoardBusTypes get ();
    void set (BoardBusTypes value);
}
member BusType : BoardBusTypes with get, set

Property Value

Type: BoardBusTypes
Remarks
At the moment there are two bus types: I2C and SMB. All I2C interfaces support the I2C bus. Whether a board supports the SMBus can be determined by evaluating BusTypeSmb variable, which can be accessed using the HardwareInfoOfOpenBoard property.
See Also

Reference

Board Class


Board.ErrorActivatesTestpin Property

BoardErrorActivatesTestpin Property
Configures the testpin (out) of the hardware. If the hardware detects an ERROR condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ErrorActivatesTestpin { get; set; }
Public Property ErrorActivatesTestpin As Boolean
    Get
    Set
public:
property bool ErrorActivatesTestpin {
    bool get ();
    void set (bool value);
}
member ErrorActivatesTestpin : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Board Class


Board.HardwareInfoOfOpenBoard Property

BoardHardwareInfoOfOpenBoard Property
Returns the hardware information of the I2C interface, to which this object is connected to.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public HardwareInfo HardwareInfoOfOpenBoard { get; }
Public ReadOnly Property HardwareInfoOfOpenBoard As HardwareInfo
    Get
public:
property HardwareInfo^ HardwareInfoOfOpenBoard {
    HardwareInfo^ get ();
}
member HardwareInfoOfOpenBoard : HardwareInfo with get

Property Value

Type: HardwareInfo
See Also

Reference

Board Class


Board.HighLevelThreshold Property

BoardHighLevelThreshold Property
Sets/gets the high level threshold [percent]. This threshold defines the voltage range on SCL/SDA interpreted as logical "1". Valid values for the high level threshold of the opened I2C interface are stored in the HighLevelThreshold variable, which can be accessed using the HardwareInfoOfOpenBoard property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte HighLevelThreshold { get; set; }
Public Property HighLevelThreshold As Byte
    Get
    Set
public:
property unsigned char HighLevelThreshold {
    unsigned char get ();
    void set (unsigned char value);
}
member HighLevelThreshold : byte with get, set

Property Value

Type: Byte
See Also

Reference

Board Class


Board.I2cBusLoad Property

BoardI2cBusLoad Property
Returns the load of the I2C bus [%].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte I2cBusLoad { get; }
Public ReadOnly Property I2cBusLoad As Byte
    Get
public:
property unsigned char I2cBusLoad {
    unsigned char get ();
}
member I2cBusLoad : byte with get

Property Value

Type: Byte
See Also

Reference

Board Class


Board.I2cBusState Property

BoardI2cBusState Property
Returns the state of the I2C bus. This can be used to detect a hanging (more than 500 ms low) SCL and/or SDA.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public BoardI2cBusStates I2cBusState { get; }
Public ReadOnly Property I2cBusState As BoardI2cBusStates
    Get
public:
property BoardI2cBusStates I2cBusState {
    BoardI2cBusStates get ();
}
member I2cBusState : BoardI2cBusStates with get

Property Value

Type: BoardI2cBusStates
See Also

Reference

Board Class


Board.I2cVcc Property

BoardI2cVcc Property
Returns the Vcc voltage of the I2C bus [mV].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort I2cVcc { get; }
Public ReadOnly Property I2cVcc As UShort
    Get
public:
property unsigned short I2cVcc {
    unsigned short get ();
}
member I2cVcc : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Board Class


Board.I2cVccSupply Property

BoardI2cVccSupply Property
Sets the I2C Vcc supply voltage [mV].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort I2cVccSupply { get; set; }
Public Property I2cVccSupply As UShort
    Get
    Set
public:
property unsigned short I2cVccSupply {
    unsigned short get ();
    void set (unsigned short value);
}
member I2cVccSupply : uint16 with get, set

Property Value

Type: UInt16
Remarks
Some I2C interfaces can supply the I2C Vcc pin. Valid values for the I2C Vcc supply voltage of the opened I2C interface are stored in the I2cVccSupply variable, which can be accessed using the HardwareInfoOfOpenBoard property.
See Also

Reference

Board Class


Board.IsOpen Property

BoardIsOpen Property
Returns whether the instance is connected to an I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOpen { get; }
Public ReadOnly Property IsOpen As Boolean
    Get
public:
property bool IsOpen {
    bool get ();
}
member IsOpen : bool with get

Property Value

Type: Boolean
See Also

Reference

Board Class


Board.ListOfBoards Property

BoardListOfBoards Property
Returns a list of all available I2C interfaces. Reading this property is expensive, so it is recommended to store a reference to the returned ListT.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<HardwareInfo> ListOfBoards { get; }
Public ReadOnly Property ListOfBoards As List(Of HardwareInfo)
    Get
public:
property List<HardwareInfo^>^ ListOfBoards {
    List<HardwareInfo^>^ get ();
}
member ListOfBoards : List<HardwareInfo> with get

Property Value

Type: List HardwareInfo
See Also

Reference

Board Class


Board.LowLevelThreshold Property

BoardLowLevelThreshold Property
Sets/gets the low level threshold [percent]. This threshold defines the voltage range on SCL/SDA interpreted as logical "0". Valid values for the low level threshold of the opened I2C interface are stored in the LowLevelThreshold variable, which can be accessed using the HardwareInfoOfOpenBoard property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte LowLevelThreshold { get; set; }
Public Property LowLevelThreshold As Byte
    Get
    Set
public:
property unsigned char LowLevelThreshold {
    unsigned char get ();
    void set (unsigned char value);
}
member LowLevelThreshold : byte with get, set

Property Value

Type: Byte
See Also

Reference

Board Class


Board.Master Property

BoardMaster Property
This property can be used to get access to the master functionality of the I2C interface connected to this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Master Master { get; }
Public ReadOnly Property Master As Master
    Get
public:
property Master^ Master {
    Master^ get ();
}
member Master : Master with get

Property Value

Type: Master
See Also

Reference

Board Class


Board.NackActivatesTestpin Property

BoardNackActivatesTestpin Property
Configures the testpin (out) of the hardware. If the hardware detects an NACK condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool NackActivatesTestpin { get; set; }
Public Property NackActivatesTestpin As Boolean
    Get
    Set
public:
property bool NackActivatesTestpin {
    bool get ();
    void set (bool value);
}
member NackActivatesTestpin : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Board Class


Board.NegativeTester Property

BoardNegativeTester Property
This property can be used to get access to the negative tester functionality of the I2C interface connected to this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTester NegativeTester { get; }
Public ReadOnly Property NegativeTester As NegativeTester
    Get
public:
property NegativeTester^ NegativeTester {
    NegativeTester^ get ();
}
member NegativeTester : NegativeTester with get

Property Value

Type: NegativeTester
See Also

Reference

Board Class


Board.RequiredServiceContract Property

BoardRequiredServiceContract Property
Returns the minimal service contract required by an I2C interface to be used with the running I2C scheduler.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime RequiredServiceContract { get; }
Public ReadOnly Property RequiredServiceContract As DateTime
    Get
public:
property DateTime RequiredServiceContract {
    DateTime get ();
}
member RequiredServiceContract : DateTime with get

Property Value

Type: DateTime
See Also

Reference

Board Class


Board.SchedulerIpAddress Property

BoardSchedulerIpAddress Property
Returns the IP address of the I2C scheduler.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string SchedulerIpAddress { get; }
Public ReadOnly Property SchedulerIpAddress As String
    Get
public:
property String^ SchedulerIpAddress {
    String^ get ();
}
member SchedulerIpAddress : string with get

Property Value

Type: String
See Also

Reference

Board Class


Board.SchedulerVersion Property

BoardSchedulerVersion Property
Returns the version of the running I2C scheduler.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Version SchedulerVersion { get; }
Public ReadOnly Property SchedulerVersion As Version
    Get
public:
property Version^ SchedulerVersion {
    Version^ get ();
}
member SchedulerVersion : Version with get

Property Value

Type: Version
See Also

Reference

Board Class


Board.SlaveRamEnhanced Property

BoardSlaveRamEnhanced Property
This property can be used to get access to the slave functionality of the I2C interface connected to this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SlaveRamEnhanced SlaveRamEnhanced { get; }
Public ReadOnly Property SlaveRamEnhanced As SlaveRamEnhanced
    Get
public:
property SlaveRamEnhanced^ SlaveRamEnhanced {
    SlaveRamEnhanced^ get ();
}
member SlaveRamEnhanced : SlaveRamEnhanced with get

Property Value

Type: SlaveRamEnhanced
See Also

Reference

Board Class


Board.StartActivatesTestpin Property

BoardStartActivatesTestpin Property
Configures the testpin (out) of the hardware. When the hardware detects a START condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool StartActivatesTestpin { get; set; }
Public Property StartActivatesTestpin As Boolean
    Get
    Set
public:
property bool StartActivatesTestpin {
    bool get ();
    void set (bool value);
}
member StartActivatesTestpin : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Board Class


Board.StopActivatesTestpin Property

BoardStopActivatesTestpin Property
Configures the testpin (out) of the hardware. When the hardware detects a STOP condition on the I2C bus, the testpin gets activated for one cycle. This feature can be used as a trigger.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool StopActivatesTestpin { get; set; }
Public Property StopActivatesTestpin As Boolean
    Get
    Set
public:
property bool StopActivatesTestpin {
    bool get ();
    void set (bool value);
}
member StopActivatesTestpin : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Board Class


Board.TerminationScl Property

BoardTerminationScl Property
Sets/gets the termination of SCL [Ohm]. Valid values for the termination of the opened I2C interface are stored in the Termination variable, which can be accessed using the HardwareInfoOfOpenBoard property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TerminationScl { get; set; }
Public Property TerminationScl As UInteger
    Get
    Set
public:
property unsigned int TerminationScl {
    unsigned int get ();
    void set (unsigned int value);
}
member TerminationScl : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Board Class


Board.TerminationSda Property

BoardTerminationSda Property
Sets/gets the termination of SDA [Ohm]. Valid values for the termination of the opened I2C interface are stored in the Termination variable, which can be accessed using the HardwareInfoOfOpenBoard property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TerminationSda { get; set; }
Public Property TerminationSda As UInteger
    Get
    Set
public:
property unsigned int TerminationSda {
    unsigned int get ();
    void set (unsigned int value);
}
member TerminationSda : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Board Class


Board.Tracer Property

BoardTracer Property
This property can be used to get access to the tracer functionality of the I2C interface connected to this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Tracer Tracer { get; }
Public ReadOnly Property Tracer As Tracer
    Get
public:
property Tracer^ Tracer {
    Tracer^ get ();
}
member Tracer : Tracer with get

Property Value

Type: Tracer
See Also

Reference

Board Class


Board Events

Board Events

The Board type exposes the following members.

Events
 | Name | Description
Public event | BoardAddedRemoved | This event gets fired, when the user connects a new I2C interface to the PC or disconnects an existing one.
Top
See Also

Reference

Board Class


Board.BoardAddedRemoved Event

BoardBoardAddedRemoved Event
This event gets fired, when the user connects a new I2C interface to the PC or disconnects an existing one.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BoardAddedRemoved
Public Event BoardAddedRemoved As EventHandler
public:
 event EventHandler^ BoardAddedRemoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member BoardAddedRemoved : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Board Class


Board.BusTypes Enumeration

BoardBusTypes Enumeration
Enumeration to store the bus type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum BusTypes
Public Enumeration BusTypes
public enum class BusTypes
type BusTypes
Members
Member name | Value | Description
BUS_TYPE_I2C | 0 | I2C bus
BUS_TYPE_SMB | 1 | SMBus
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


Board.I2cBusStates Enumeration

BoardI2cBusStates Enumeration
Enumeration to store the state of the I2C bus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum I2cBusStates
Public Enumeration I2cBusStates
public enum class I2cBusStates
type I2cBusStates
Members
Member name | Value | Description
I2C_BUS_STATE_UNKNOWN | 0 | the I2C interface does not support this feature
I2C_BUS_STATE_NORMAL | 1 | SCL and SDA are not low for more than 500 ms
I2C_BUS_STATE_SCL_LOW | 2 | SCL is low for more than 500 ms
I2C_BUS_STATE_SDA_LOW | 3 | SDA is low for more than 500 ms
I2C_BUS_STATE_SCL_SDA_LOW | 4 | SCL and SDA are low for more than 500 ms
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


BoardRemote Class

BoardRemote Class
This class can be used to retrieve a list of I2C interfaces connected to a list of local and/or remote I2C scheduler. Afterwards it is possible to open I2C interfaces.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetBoardRemote

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class BoardRemote : IDisposable
Public NotInheritable Class BoardRemote
    Implements IDisposable
public ref class BoardRemote sealed : IDisposable
[<SealedAttribute>]
type BoardRemote =
    class
        interface IDisposable
    end

The BoardRemote type exposes the following members.

Constructors
 | Name | Description
Public method | BoardRemote | Constructor
Top
Methods
 | Name | Description
Public method | CreateBoard | Creates a Board object with a connection to the specified I2C scheduler.
Public method | CreateOpenBoard(HardwareInfo) | Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C board. This Board object gets connected to the specified I2C interface.
Public method | CreateOpenBoard(BoardType, UInt16) | Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C interface. This Board object gets connected to the specified I2C interface.
Public method | DiscoverSchedulers | Searches for I2C schedulers in the local network.
Public method | Dispose | Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetHardwareInfo | Searches the specified I2C interface. If the I2C interface gets found, its HardwareInfo is returned. Otherwise null is returned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ListOfBoards | Gets a list of all I2C interfaces, which are connected to the I2C schedulers specified with the SchedulerList property.
Public property | SchedulerList | Sets/gets the list of I2C schedulers. It is not necessary to add the local I2C scheduler to the list, because it gets added automatically.
Top
Events
 | Name | Description
Public event | BoardAddedRemoved | This event gets fired, when the user connects a new I2C interface to one of the registered I2C schedulers or disconnects an existing one.
Public event | SchedulerStatusChanged | This event gets fired, when the status entry of one of the registered I2C schedulers has been changed.
Top
Remarks

Normally the following steps are necessary:

  1. Specify a list of I2C schedulers to be contacted using SchedulerList.
  2. Get a list of I2C interfaces with ListOfBoards.
  3. Create an open Board object for one of the found I2C interfaces using CreateOpenBoard(HardwareInfo).
  4. Call Dispose to free all resources allocated by an instance of this class. It is very important to call this method before the GC destroys the object.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


BoardRemote Constructor

BoardRemote Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public BoardRemote()
Public Sub New
public:
BoardRemote()
new : unit -> BoardRemote
See Also

Reference

BoardRemote Class


BoardRemote Methods

BoardRemote Methods

The BoardRemote type exposes the following members.

Methods
 | Name | Description
Public method | CreateBoard | Creates a Board object with a connection to the specified I2C scheduler.
Public method | CreateOpenBoard(HardwareInfo) | Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C board. This Board object gets connected to the specified I2C interface.
Public method | CreateOpenBoard(BoardType, UInt16) | Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C interface. This Board object gets connected to the specified I2C interface.
Public method | DiscoverSchedulers | Searches for I2C schedulers in the local network.
Public method | Dispose | Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetHardwareInfo | Searches the specified I2C interface. If the I2C interface gets found, its HardwareInfo is returned. Otherwise null is returned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BoardRemote Class


BoardRemote.CreateBoard Method

BoardRemoteCreateBoard Method
Creates a Board object with a connection to the specified I2C scheduler.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Board CreateBoard(
    string remote_address,
    ushort remote_port
)
Public Function CreateBoard (
    remote_address As String,
    remote_port As UShort
) As Board
public:
Board^ CreateBoard(
    String^ remote_address,
    unsigned short remote_port
)
member CreateBoard :
        remote_address : string *
        remote_port : uint16 -> Board

Parameters

remote_address
Type: SystemString
IP address or DNS name of the I2C scheduler
remote_port
Type: SystemUInt16
TCP/IP port of the I2C scheduler

Return Value

Type: Board
I2C board
See Also

Reference

BoardRemote Class


BoardRemote.CreateOpenBoard Method

BoardRemoteCreateOpenBoard Method
Overload List
 | Name | Description
Public method | CreateOpenBoard(HardwareInfo) | Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C board. This Board object gets connected to the specified I2C interface.
Public method | CreateOpenBoard(BoardType, UInt16) | Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C interface. This Board object gets connected to the specified I2C interface.
Top
See Also

Reference

BoardRemote Class


BoardRemote.CreateOpenBoard Method (HardwareInfo)

BoardRemoteCreateOpenBoard Method (HardwareInfo)
Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C board. This Board object gets connected to the specified I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Board CreateOpenBoard(
    HardwareInfo hwinfo
)
Public Function CreateOpenBoard (
    hwinfo As HardwareInfo
) As Board
public:
Board^ CreateOpenBoard(
    HardwareInfo^ hwinfo
)
member CreateOpenBoard :
        hwinfo : HardwareInfo -> Board

Parameters

hwinfo
Type: telos.I2cApi.DotNetHardwareInfo
I2C interface to be opened

Return Value

Type: Board
open I2C interface
See Also

Reference

BoardRemote Class
CreateOpenBoard Overload


BoardRemote.CreateOpenBoard Method (BoardType, UInt16)

BoardRemoteCreateOpenBoard Method (BoardType, UInt16)
Creates a Board objects with a connection to the I2C scheduler responsible for the specified I2C interface. This Board object gets connected to the specified I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Board CreateOpenBoard(
    BoardType board_type,
    ushort serial_number
)
Public Function CreateOpenBoard (
    board_type As BoardType,
    serial_number As UShort
) As Board
public:
Board^ CreateOpenBoard(
    BoardType board_type,
    unsigned short serial_number
)
member CreateOpenBoard :
        board_type : BoardType *
        serial_number : uint16 -> Board

Parameters

board_type
Type: telos.I2cApi.DotNetBoardType
type of the I2C interface to be opened
serial_number
Type: SystemUInt16
serial number of the I2C interface to be opened

Return Value

Type: Board
open I2C interface
See Also

Reference

BoardRemote Class
CreateOpenBoard Overload


BoardRemote.DiscoverSchedulers Method

BoardRemoteDiscoverSchedulers Method
Searches for I2C schedulers in the local network.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public BoardRemoteSchedulers DiscoverSchedulers(
    int timeout
)
Public Function DiscoverSchedulers (
    timeout As Integer
) As BoardRemoteSchedulers
public:
BoardRemoteSchedulers^ DiscoverSchedulers(
    int timeout
)
member DiscoverSchedulers :
        timeout : int -> BoardRemoteSchedulers

Parameters

timeout
Type: SystemInt32
timeout [s]

Return Value

Type: BoardRemoteSchedulers
found I2C schedulers
See Also

Reference

BoardRemote Class


BoardRemote.Dispose Method

BoardRemoteDispose Method
Overload List
 | Name | Description
Public method | Dispose | Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

BoardRemote Class


BoardRemote.Dispose Method

BoardRemoteDispose Method
Dispose: frees all resources which have been allocated by an instance of this class. After calling this method it is not longer valid to call methods of this object. The application has to dispose objects of this class before passing them to the GC.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BoardRemote Class
Dispose Overload


BoardRemote.Dispose Method (Boolean)

BoardRemoteDispose Method (Boolean)
Releases the unmanaged resources used by the BoardRemote and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.BoardRemote.Dispose(System.Boolean)"]

See Also

Reference

BoardRemote Class
Dispose Overload


BoardRemote.Finalize Method

BoardRemoteFinalize Method
Finalize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

BoardRemote Class


BoardRemote.GetHardwareInfo Method

BoardRemoteGetHardwareInfo Method
Searches the specified I2C interface. If the I2C interface gets found, its HardwareInfo is returned. Otherwise null is returned.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public HardwareInfo GetHardwareInfo(
    BoardType board_type,
    ushort serial_number
)
Public Function GetHardwareInfo (
    board_type As BoardType,
    serial_number As UShort
) As HardwareInfo
public:
HardwareInfo^ GetHardwareInfo(
    BoardType board_type,
    unsigned short serial_number
)
member GetHardwareInfo :
        board_type : BoardType *
        serial_number : uint16 -> HardwareInfo

Parameters

board_type
Type: telos.I2cApi.DotNetBoardType
type of the I2C interface
serial_number
Type: SystemUInt16
serial number of the I2C interface

Return Value

Type: HardwareInfo
HardwareInfo of the I2C interface
See Also

Reference

BoardRemote Class


BoardRemote Properties

BoardRemote Properties

The BoardRemote type exposes the following members.

Properties
 | Name | Description
Public property | ListOfBoards | Gets a list of all I2C interfaces, which are connected to the I2C schedulers specified with the SchedulerList property.
Public property | SchedulerList | Sets/gets the list of I2C schedulers. It is not necessary to add the local I2C scheduler to the list, because it gets added automatically.
Top
See Also

Reference

BoardRemote Class


BoardRemote.ListOfBoards Property

BoardRemoteListOfBoards Property
Gets a list of all I2C interfaces, which are connected to the I2C schedulers specified with the SchedulerList property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<HardwareInfo> ListOfBoards { get; }
Public ReadOnly Property ListOfBoards As List(Of HardwareInfo)
    Get
public:
property List<HardwareInfo^>^ ListOfBoards {
    List<HardwareInfo^>^ get ();
}
member ListOfBoards : List<HardwareInfo> with get

Property Value

Type: List HardwareInfo
See Also

Reference

BoardRemote Class


BoardRemote.SchedulerList Property

BoardRemoteSchedulerList Property
Sets/gets the list of I2C schedulers. It is not necessary to add the local I2C scheduler to the list, because it gets added automatically.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public BoardRemoteSchedulers SchedulerList { get; set; }
Public Property SchedulerList As BoardRemoteSchedulers
    Get
    Set
public:
property BoardRemoteSchedulers^ SchedulerList {
    BoardRemoteSchedulers^ get ();
    void set (BoardRemoteSchedulers^ value);
}
member SchedulerList : BoardRemoteSchedulers with get, set

Property Value

Type: BoardRemoteSchedulers
Remarks
The BoardRemote class works on a deep copy of the Schedulers object. SchedulerList does not return the same Schedulers instance, which has been passed to SchedulerList.
See Also

Reference

BoardRemote Class


BoardRemote Events

BoardRemote Events

The BoardRemote type exposes the following members.

Events
 | Name | Description
Public event | BoardAddedRemoved | This event gets fired, when the user connects a new I2C interface to one of the registered I2C schedulers or disconnects an existing one.
Public event | SchedulerStatusChanged | This event gets fired, when the status entry of one of the registered I2C schedulers has been changed.
Top
See Also

Reference

BoardRemote Class


BoardRemote.BoardAddedRemoved Event

BoardRemoteBoardAddedRemoved Event
This event gets fired, when the user connects a new I2C interface to one of the registered I2C schedulers or disconnects an existing one.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BoardAddedRemoved
Public Event BoardAddedRemoved As EventHandler
public:
 event EventHandler^ BoardAddedRemoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member BoardAddedRemoved : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

BoardRemote Class


BoardRemote.SchedulerStatusChanged Event

BoardRemoteSchedulerStatusChanged Event
This event gets fired, when the status entry of one of the registered I2C schedulers has been changed.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SchedulerStatusChanged
Public Event SchedulerStatusChanged As EventHandler
public:
 event EventHandler^ SchedulerStatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SchedulerStatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

BoardRemote Class


BoardRemote.Scheduler Class

BoardRemoteScheduler Class
Data type to store the remote address, the remote port, the password, and the current status of an I2C scheduler.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetBoardRemoteScheduler

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Scheduler : ICloneable,
    IEquatable<BoardRemoteScheduler>, ISerializable
<SerializableAttribute>
Public NotInheritable Class Scheduler
    Implements ICloneable, IEquatable(Of BoardRemoteScheduler),
    ISerializable
[SerializableAttribute]
public ref class Scheduler sealed : ICloneable,
    IEquatable<BoardRemoteScheduler^>, ISerializable
[<SealedAttribute>]
[<SerializableAttribute>]
type Scheduler =
    class
        interface ICloneable
        interface IEquatable<BoardRemoteScheduler>
        interface ISerializable
    end

The BoardRemoteScheduler type exposes the following members.

Constructors
 | Name | Description
Public method | BoardRemoteScheduler | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(BoardRemoteScheduler) | Tests whether both objects contain the same data.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the data contained in the object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Part of the ISerializable interface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | password | password
Public field | remote_address | IP address or DNS name
Public field | remote_port | TCP/IP port
Public field | status | status (e.g. "OK")
Top
Properties
 | Name | Description
Public property | IsRemoteAddressLocalHost | Tests whether remote_address is the local host (loopback).
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


BoardRemote.Scheduler Constructor

BoardRemoteScheduler Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Scheduler(
    string _remote_address,
    ushort _remote_port,
    string _password
)
Public Sub New (
    _remote_address As String,
    _remote_port As UShort,
    _password As String
)
public:
Scheduler(
    String^ _remote_address,
    unsigned short _remote_port,
    String^ _password
)
new :
        _remote_address : string *
        _remote_port : uint16 *
        _password : string -> Scheduler

Parameters

_remote_address
Type: SystemString
IP address or DNS name of the remote system
_remote_port
Type: SystemUInt16
TCP/IP port of the remote system
_password
Type: SystemString
authentication password of the remote system
See Also

Reference

BoardRemoteScheduler Class


Scheduler Fields

Scheduler Fields

The BoardRemoteScheduler type exposes the following members.

Fields
 | Name | Description
Public field | password | password
Public field | remote_address | IP address or DNS name
Public field | remote_port | TCP/IP port
Public field | status | status (e.g. "OK")
Top
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.password Field

BoardRemoteSchedulerpassword Field
password

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string password
Public password As String
public:
String^ password
val mutable password: string

Field Value

Type: String
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.remote_address Field

BoardRemoteSchedulerremote_address Field
IP address or DNS name

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string remote_address
Public remote_address As String
public:
String^ remote_address
val mutable remote_address: string

Field Value

Type: String
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.remote_port Field

BoardRemoteSchedulerremote_port Field
TCP/IP port

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort remote_port
Public remote_port As UShort
public:
unsigned short remote_port
val mutable remote_port: uint16

Field Value

Type: UInt16
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.status Field

BoardRemoteSchedulerstatus Field
status (e.g. "OK")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string status
Public status As String
public:
String^ status
val mutable status: string

Field Value

Type: String
See Also

Reference

BoardRemoteScheduler Class


Scheduler Methods

Scheduler Methods

The BoardRemoteScheduler type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(BoardRemoteScheduler) | Tests whether both objects contain the same data.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the data contained in the object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Part of the ISerializable interface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.Clone Method

BoardRemoteSchedulerClone Method
Creates a deep copy of this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy of this object

Implements

ICloneableClone
See Also

Reference

BoardRemoteScheduler Class


Scheduler.Equals Method

SchedulerEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(BoardRemoteScheduler) | Tests whether both objects contain the same data.
Top
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.Equals Method (BoardRemote.Scheduler)

BoardRemoteSchedulerEquals Method (BoardRemoteScheduler)
Tests whether both objects contain the same data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    BoardRemoteScheduler obj
)
Public Function Equals (
    obj As BoardRemoteScheduler
) As Boolean
public:
virtual bool Equals(
    BoardRemoteScheduler^ obj
) sealed
abstract Equals :
        obj : BoardRemoteScheduler -> bool
override Equals :
        obj : BoardRemoteScheduler -> bool

Parameters

obj
Type: telos.I2cApi.DotNetBoardRemoteScheduler
other object

Return Value

Type: Boolean
same data (true), different data (false).

Implements

IEquatableTEquals(T)
See Also

Reference

BoardRemoteScheduler Class
Equals Overload


BoardRemote.Scheduler.GetHashCode Method

BoardRemoteSchedulerGetHashCode Method
Returns the hash code for the data contained in the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.GetObjectData Method

BoardRemoteSchedulerGetObjectData Method
Part of the ISerializable interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
SerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
StreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BoardRemoteScheduler Class


Scheduler Properties

Scheduler Properties

The BoardRemoteScheduler type exposes the following members.

Properties
 | Name | Description
Public property | IsRemoteAddressLocalHost | Tests whether remote_address is the local host (loopback).
Top
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Scheduler.IsRemoteAddressLocalHost Property

BoardRemoteSchedulerIsRemoteAddressLocalHost Property
Tests whether remote_address is the local host (loopback).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsRemoteAddressLocalHost { get; }
Public ReadOnly Property IsRemoteAddressLocalHost As Boolean
    Get
public:
property bool IsRemoteAddressLocalHost {
    bool get ();
}
member IsRemoteAddressLocalHost : bool with get

Property Value

Type: Boolean
See Also

Reference

BoardRemoteScheduler Class


BoardRemote.Schedulers Class

BoardRemoteSchedulers Class
Data type to store a number of Scheduler objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList BoardRemoteScheduler
telos.I2cApi.DotNetBoardRemoteSchedulers

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class Schedulers : List<BoardRemoteScheduler>,
    ICloneable
<SerializableAttribute>
Public NotInheritable Class Schedulers
    Inherits List(Of BoardRemoteScheduler)
    Implements ICloneable
[SerializableAttribute]
public ref class Schedulers sealed : public List<BoardRemoteScheduler^>,
    ICloneable
[<SealedAttribute>]
[<SerializableAttribute>]
type Schedulers =
    class
        inherit List<BoardRemoteScheduler>
        interface ICloneable
    end

The BoardRemoteSchedulers type exposes the following members.

Constructors
 | Name | Description
Public method | BoardRemoteSchedulers | Initializes a new instance of the BoardRemoteSchedulers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List BoardRemoteScheduler .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List BoardRemoteScheduler .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List BoardRemoteScheduler .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List BoardRemoteScheduler .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | Clone | Creates a deep copy of this object.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List BoardRemoteScheduler .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List BoardRemoteScheduler .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List BoardRemoteScheduler .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List BoardRemoteScheduler .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndexByRemoteAddress | Returns the index of the item, which uses the specified remote address.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List BoardRemoteScheduler .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List BoardRemoteScheduler .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List BoardRemoteScheduler .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List BoardRemoteScheduler .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List BoardRemoteScheduler .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List BoardRemoteScheduler .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List BoardRemoteScheduler .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List BoardRemoteScheduler .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List BoardRemoteScheduler .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List BoardRemoteScheduler .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List BoardRemoteScheduler .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List BoardRemoteScheduler .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List BoardRemoteScheduler .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List BoardRemoteScheduler .)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


BoardRemote.Schedulers Constructor

BoardRemoteSchedulers Constructor
Initializes a new instance of the BoardRemoteSchedulers class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Schedulers()
Public Sub New
public:
Schedulers()
new : unit -> Schedulers
See Also

Reference

BoardRemoteSchedulers Class


Schedulers Methods

Schedulers Methods

The BoardRemoteSchedulers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List BoardRemoteScheduler .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List BoardRemoteScheduler .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List BoardRemoteScheduler .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List BoardRemoteScheduler .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | Clone | Creates a deep copy of this object.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List BoardRemoteScheduler .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List BoardRemoteScheduler .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List BoardRemoteScheduler .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List BoardRemoteScheduler .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List BoardRemoteScheduler .)
Public method | FindIndexByRemoteAddress | Returns the index of the item, which uses the specified remote address.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List BoardRemoteScheduler .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List BoardRemoteScheduler .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List BoardRemoteScheduler .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List BoardRemoteScheduler .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List BoardRemoteScheduler .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List BoardRemoteScheduler .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List BoardRemoteScheduler .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List BoardRemoteScheduler .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List BoardRemoteScheduler .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List BoardRemoteScheduler .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List BoardRemoteScheduler .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List BoardRemoteScheduler .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List BoardRemoteScheduler .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List BoardRemoteScheduler .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List BoardRemoteScheduler .)
Top
See Also

Reference

BoardRemoteSchedulers Class


BoardRemote.Schedulers.Clone Method

BoardRemoteSchedulersClone Method
Creates a deep copy of this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy of this object

Implements

ICloneableClone
See Also

Reference

BoardRemoteSchedulers Class


BoardRemote.Schedulers.FindIndexByRemoteAddress Method

BoardRemoteSchedulersFindIndexByRemoteAddress Method
Returns the index of the item, which uses the specified remote address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int FindIndexByRemoteAddress(
    string remote_address
)
Public Function FindIndexByRemoteAddress (
    remote_address As String
) As Integer
public:
int FindIndexByRemoteAddress(
    String^ remote_address
)
member FindIndexByRemoteAddress :
        remote_address : string -> int

Parameters

remote_address
Type: SystemString
remote address

Return Value

Type: Int32
index of the item or "-1"
See Also

Reference

BoardRemoteSchedulers Class


Schedulers Properties

Schedulers Properties

The BoardRemoteSchedulers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List BoardRemoteScheduler .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List BoardRemoteScheduler .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List BoardRemoteScheduler .)
Top
See Also

Reference

BoardRemoteSchedulers Class


BoardType Enumeration

BoardType Enumeration
Enum to specify the type of the I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum BoardType
Public Enumeration BoardType
public enum class BoardType
type BoardType
Members
Member name | Value | Description
TRACII_XL | 0 | Tracii XL
TRACII_XL2 | 1 | Tracii XL 2.0
CONNII | 2 | Connii
CONNII_MM | 3 | Connii MM
CONNII_MM2 | 4 | Connii MM 2.0
DUMMY | 5 | Dummy
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


CacheGeneric(TKey, TValue) Class

CacheGenericTKey, TValue Class
This class implements a cache container. The container stores a number of elements. This size limit can be configured by the caller. When the user excessed this size limit, the container removes the oldest element.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetCacheGenericTKey, TValue

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class CacheGeneric<TKey, TValue> : IDisposable
where TValue : class

Public Class CacheGeneric(Of TKey, TValue As Class)
    Implements IDisposable
generic<typename TKey, typename TValue>
where TValue : ref class
public ref class CacheGeneric : IDisposable
type CacheGeneric<'TKey, 'TValue when 'TValue : not struct> =
    class
        interface IDisposable
    end

Type Parameters

TKey
type of the key
TValue
type of the value

The CacheGenericTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | CacheGenericTKey, TValue | Constructor.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the cache.
Public method | AddOrOverwrite | Adds an item to the cache. If the item is already in the cache, it gets overwritten.
Public method | Clear | Clears the cache.
Public method | Dispose | Destructor/Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | If the cache contains an item for the given key, the item gets removed from the cache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisposeValues | If this property is set to "true", values get disposed before they are removed from the container.
Public property | Item |
Public property | Limit | Sets/gets the size limit of the container.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


CacheGeneric(TKey, TValue) Constructor

CacheGenericTKey, TValue Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public CacheGeneric()
Public Sub New
public:
CacheGeneric()
new : unit -> CacheGeneric
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue) Methods

CacheGenericTKey, TValue Methods

The CacheGenericTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the cache.
Public method | AddOrOverwrite | Adds an item to the cache. If the item is already in the cache, it gets overwritten.
Public method | Clear | Clears the cache.
Public method | Dispose | Destructor/Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | If the cache contains an item for the given key, the item gets removed from the cache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).Add Method

CacheGenericTKey, TValueAdd Method
Adds an item to the cache.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)
public:
void Add(
    TKey key,
    TValue value
)
member Add :
        key : 'TKey *
        value : 'TValue -> unit

Parameters

key
Type: TKey
key of the item
value
Type: TValue
value of the item
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).AddOrOverwrite Method

CacheGenericTKey, TValueAddOrOverwrite Method
Adds an item to the cache. If the item is already in the cache, it gets overwritten.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void AddOrOverwrite(
    TKey key,
    TValue value
)
Public Sub AddOrOverwrite (
    key As TKey,
    value As TValue
)
public:
void AddOrOverwrite(
    TKey key,
    TValue value
)
member AddOrOverwrite :
        key : 'TKey *
        value : 'TValue -> unit

Parameters

key
Type: TKey
key of the item
value
Type: TValue
value of the item
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).Clear Method

CacheGenericTKey, TValueClear Method
Clears the cache.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).Dispose Method

CacheGenericTKey, TValueDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor/Dispose.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).Dispose Method

CacheGenericTKey, TValueDispose Method
Destructor/Dispose.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CacheGenericTKey, TValue Class
Dispose Overload


CacheGeneric(TKey, TValue).Dispose Method (Boolean)

CacheGenericTKey, TValueDispose Method (Boolean)
Releases the unmanaged resources used by the CacheGenericTKey, TValue and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
)
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.CacheGeneric`2.Dispose(System.Boolean)"]

See Also

Reference

CacheGenericTKey, TValue Class
Dispose Overload


CacheGeneric(TKey, TValue).Remove Method

CacheGenericTKey, TValueRemove Method
If the cache contains an item for the given key, the item gets removed from the cache.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    TKey key
)
Public Sub Remove (
    key As TKey
)
public:
void Remove(
    TKey key
)
member Remove :
        key : 'TKey -> unit

Parameters

key
Type: TKey
key of the item
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue) Properties

CacheGenericTKey, TValue Properties

The CacheGenericTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | DisposeValues | If this property is set to "true", values get disposed before they are removed from the container.
Public property | Item |
Public property | Limit | Sets/gets the size limit of the container.
Top
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).DisposeValues Property

CacheGenericTKey, TValueDisposeValues Property
If this property is set to "true", values get disposed before they are removed from the container.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DisposeValues { get; set; }
Public Property DisposeValues As Boolean
    Get
    Set
public:
property bool DisposeValues {
    bool get ();
    void set (bool value);
}
member DisposeValues : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).Item Property

CacheGenericTKey, TValueItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.CacheGeneric`2.Item(`0)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TValue this[
    TKey key
] { get; }
Public ReadOnly Default Property Item (
    key As TKey
) As TValue
    Get
public:
property TValue default[TKey key] {
    TValue get (TKey key);
}
member Item : 'TValue with get

Parameters

key
Type: TKey

Property Value

Type: TValue
See Also

Reference

CacheGenericTKey, TValue Class


CacheGeneric(TKey, TValue).Limit Property

CacheGenericTKey, TValueLimit Property
Sets/gets the size limit of the container.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Limit { get; set; }
Public Property Limit As Integer
    Get
    Set
public:
property int Limit {
    int get ();
    void set (int value);
}
member Limit : int with get, set

Property Value

Type: Int32
See Also

Reference

CacheGenericTKey, TValue Class


Exception Class

Exception Class
Abstract base class of all exceptions thrown by the I2C.NET API. This class is derived from the Exception class which is the base class for exceptions thrown by the Microsoft's .NET framework.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
More...

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class Exception : Exception
Public MustInherit Class Exception
    Inherits Exception
public ref class Exception abstract : public Exception
[<AbstractClassAttribute>]
type Exception =
    class
        inherit Exception
    end

The Exception type exposes the following members.

Constructors
 | Name | Description
Protected method | Exception(String) | Constructor.
Protected method | Exception(String, Exception) | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Remarks
An application using the I2C.NET API should catch exceptions of this type or of the types of the derived exception class.
See Also

Reference

telos.I2cApi.DotNet Namespace
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionArpI2cAddressesExhausted
telos.I2cApi.DotNetExceptionArpInvalidResponse
telos.I2cApi.DotNetExceptionAuthentication
telos.I2cApi.DotNetExceptionBusType
telos.I2cApi.DotNetExceptionDeviceOpen
telos.I2cApi.DotNetExceptionDriverVersion
telos.I2cApi.DotNetExceptionHardwareIo
telos.I2cApi.DotNetExceptionI2cAddress
telos.I2cApi.DotNetExceptionI2cAddressRange
telos.I2cApi.DotNetExceptionI2cVcc
telos.I2cApi.DotNetExceptionI2cVccSupply
telos.I2cApi.DotNetExceptionInputTestpin
telos.I2cApi.DotNetExceptionIo
telos.I2cApi.DotNetExceptionIrdDeviceVerification
telos.I2cApi.DotNetExceptionIrdLicense
telos.I2cApi.DotNetExceptionIrdMap
telos.I2cApi.DotNetExceptionIrdReader
telos.I2cApi.DotNetExceptionIrdWriter
telos.I2cApi.DotNetExceptionItemNotFound
telos.I2cApi.DotNetExceptionLevelThreshold
telos.I2cApi.DotNetExceptionLicenseData
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterMessageListDataType
telos.I2cApi.DotNetExceptionNegativeTester
telos.I2cApi.DotNetExceptionNullPointer
telos.I2cApi.DotNetExceptionOpen
telos.I2cApi.DotNetExceptionOutputTestpin
telos.I2cApi.DotNetExceptionPlugInManager
telos.I2cApi.DotNetExceptionPlugInManagerRegister
telos.I2cApi.DotNetExceptionSchedulerBusy
telos.I2cApi.DotNetExceptionSchedulerVersion
telos.I2cApi.DotNetExceptionServiceContractExpired
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSmbI2cAddress
telos.I2cApi.DotNetExceptionTermination
telos.I2cApi.DotNetExceptionThreading
telos.I2cApi.DotNetExceptionTraceDataFindCanceled
telos.I2cApi.DotNetExceptionTracer
telos.I2cApi.DotNetExceptionTracerMessageList
telos.I2cApi.DotNetExceptionTraciiCpu


Exception Constructor

Exception Constructor
Overload List
 | Name | Description
Protected method | Exception(String) | Constructor.
Protected method | Exception(String, Exception) | Constructor.
Top
See Also

Reference

Exception Class


Exception Constructor (String)

Exception Constructor (String)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected Exception(
    string description
)
Protected Sub New (
    description As String
)
protected:
Exception(
    String^ description
)
new :
        description : string -> Exception

Parameters

description
Type: SystemString
description of the error
See Also

Reference

Exception Class
Exception Overload


Exception Constructor (String, Exception)

Exception Constructor (String, Exception)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected Exception(
    string description,
    Exception inner_exception
)
Protected Sub New (
    description As String,
    inner_exception As Exception
)
protected:
Exception(
    String^ description,
    Exception^ inner_exception
)
new :
        description : string *
        inner_exception : Exception -> Exception

Parameters

description
Type: SystemString
description of the error
inner_exception
Type: SystemException
inner exception
See Also

Reference

Exception Class
Exception Overload


Exception Methods

Exception Methods

The Exception type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Exception Class


Exception Properties

Exception Properties

The Exception type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

Exception Class


Exception Events

Exception Events

The Exception type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Exception Class


ExceptionAdc Class

ExceptionAdc Class
Exception: This class serves as a base class for all exceptions thrown by the A/D converter module.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
More...

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ExceptionAdc : Exception
Public MustInherit Class ExceptionAdc
    Inherits Exception
public ref class ExceptionAdc abstract : public Exception
[<AbstractClassAttribute>]
type ExceptionAdc =
    class
        inherit Exception
    end

The ExceptionAdc type exposes the following members.

Constructors
 | Name | Description
Protected method | ExceptionAdc | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionAdcBusy
telos.I2cApi.DotNetExceptionAdcNotFinished
telos.I2cApi.DotNetExceptionAdcNotSupported
telos.I2cApi.DotNetExceptionAdcPreTrigger
telos.I2cApi.DotNetExceptionAdcSamplingRate
telos.I2cApi.DotNetExceptionAdcTrigger


ExceptionAdc Constructor

ExceptionAdc Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected ExceptionAdc(
    string description
)
Protected Sub New (
    description As String
)
protected:
ExceptionAdc(
    String^ description
)
new :
        description : string -> ExceptionAdc

Parameters

description
Type: SystemString
description of the error
See Also

Reference

ExceptionAdc Class


ExceptionAdc Methods

ExceptionAdc Methods

The ExceptionAdc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdc Class


ExceptionAdc Properties

ExceptionAdc Properties

The ExceptionAdc type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdc Class


ExceptionAdc Events

ExceptionAdc Events

The ExceptionAdc type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdc Class


ExceptionAdcBusy Class

ExceptionAdcBusy Class
Exception: Because the A/D converter is busy, the requested command cannot be executed.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionAdcBusy

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionAdcBusy : ExceptionAdc
Public Class ExceptionAdcBusy
    Inherits ExceptionAdc
public ref class ExceptionAdcBusy : public ExceptionAdc
type ExceptionAdcBusy =
    class
        inherit ExceptionAdc
    end

The ExceptionAdcBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionAdcBusy Methods

ExceptionAdcBusy Methods

The ExceptionAdcBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcBusy Class


ExceptionAdcBusy Properties

ExceptionAdcBusy Properties

The ExceptionAdcBusy type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcBusy Class


ExceptionAdcBusy Events

ExceptionAdcBusy Events

The ExceptionAdcBusy type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcBusy Class


ExceptionAdcNotFinished Class

ExceptionAdcNotFinished Class
Exception: Cannot receive the A/D data from the hardware, because the sampling process has not been finished.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionAdcNotFinished

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionAdcNotFinished : ExceptionAdc
Public Class ExceptionAdcNotFinished
    Inherits ExceptionAdc
public ref class ExceptionAdcNotFinished : public ExceptionAdc
type ExceptionAdcNotFinished =
    class
        inherit ExceptionAdc
    end

The ExceptionAdcNotFinished type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionAdcNotFinished Methods

ExceptionAdcNotFinished Methods

The ExceptionAdcNotFinished type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcNotFinished Class


ExceptionAdcNotFinished Properties

ExceptionAdcNotFinished Properties

The ExceptionAdcNotFinished type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcNotFinished Class


ExceptionAdcNotFinished Events

ExceptionAdcNotFinished Events

The ExceptionAdcNotFinished type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcNotFinished Class


ExceptionAdcNotSupported Class

ExceptionAdcNotSupported Class
Exception: The hardware does not support the A/D converter mode.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionAdcNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionAdcNotSupported : ExceptionAdc
Public Class ExceptionAdcNotSupported
    Inherits ExceptionAdc
public ref class ExceptionAdcNotSupported : public ExceptionAdc
type ExceptionAdcNotSupported =
    class
        inherit ExceptionAdc
    end

The ExceptionAdcNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionAdcNotSupported Methods

ExceptionAdcNotSupported Methods

The ExceptionAdcNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcNotSupported Class


ExceptionAdcNotSupported Properties

ExceptionAdcNotSupported Properties

The ExceptionAdcNotSupported type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcNotSupported Class


ExceptionAdcNotSupported Events

ExceptionAdcNotSupported Events

The ExceptionAdcNotSupported type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcNotSupported Class


ExceptionAdcPreTrigger Class

ExceptionAdcPreTrigger Class
Exception: The A/D converter of the I2C interface does not support the specified pretrigger.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionAdcPreTrigger

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionAdcPreTrigger : ExceptionAdc
Public Class ExceptionAdcPreTrigger
    Inherits ExceptionAdc
public ref class ExceptionAdcPreTrigger : public ExceptionAdc
type ExceptionAdcPreTrigger =
    class
        inherit ExceptionAdc
    end

The ExceptionAdcPreTrigger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionAdcPreTrigger Methods

ExceptionAdcPreTrigger Methods

The ExceptionAdcPreTrigger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcPreTrigger Class


ExceptionAdcPreTrigger Properties

ExceptionAdcPreTrigger Properties

The ExceptionAdcPreTrigger type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcPreTrigger Class


ExceptionAdcPreTrigger Events

ExceptionAdcPreTrigger Events

The ExceptionAdcPreTrigger type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcPreTrigger Class


ExceptionAdcSamplingRate Class

ExceptionAdcSamplingRate Class
Exception: The A/D converter of the I2C interface does not support the specified sampling rate.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionAdcSamplingRate

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionAdcSamplingRate : ExceptionAdc
Public Class ExceptionAdcSamplingRate
    Inherits ExceptionAdc
public ref class ExceptionAdcSamplingRate : public ExceptionAdc
type ExceptionAdcSamplingRate =
    class
        inherit ExceptionAdc
    end

The ExceptionAdcSamplingRate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionAdcSamplingRate Methods

ExceptionAdcSamplingRate Methods

The ExceptionAdcSamplingRate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcSamplingRate Class


ExceptionAdcSamplingRate Properties

ExceptionAdcSamplingRate Properties

The ExceptionAdcSamplingRate type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcSamplingRate Class


ExceptionAdcSamplingRate Events

ExceptionAdcSamplingRate Events

The ExceptionAdcSamplingRate type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcSamplingRate Class


ExceptionAdcTrigger Class

ExceptionAdcTrigger Class
Exception: The A/D converter of the I2C interface does not support the specified trigger condition.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAdc
telos.I2cApi.DotNetExceptionAdcTrigger

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionAdcTrigger : ExceptionAdc
Public Class ExceptionAdcTrigger
    Inherits ExceptionAdc
public ref class ExceptionAdcTrigger : public ExceptionAdc
type ExceptionAdcTrigger =
    class
        inherit ExceptionAdc
    end

The ExceptionAdcTrigger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionAdcTrigger Methods

ExceptionAdcTrigger Methods

The ExceptionAdcTrigger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcTrigger Class


ExceptionAdcTrigger Properties

ExceptionAdcTrigger Properties

The ExceptionAdcTrigger type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcTrigger Class


ExceptionAdcTrigger Events

ExceptionAdcTrigger Events

The ExceptionAdcTrigger type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAdcTrigger Class


ExceptionArpI2cAddressesExhausted Class

ExceptionArpI2cAddressesExhausted Class
Exception: Cannot assign an I2C address to all found slave devices. There are not enough free I2C addresses.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionArpI2cAddressesExhausted

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionArpI2cAddressesExhausted : Exception
Public Class ExceptionArpI2cAddressesExhausted
    Inherits Exception
public ref class ExceptionArpI2cAddressesExhausted : public Exception
type ExceptionArpI2cAddressesExhausted =
    class
        inherit Exception
    end

The ExceptionArpI2cAddressesExhausted type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionArpI2cAddressesExhausted Methods

ExceptionArpI2cAddressesExhausted Methods

The ExceptionArpI2cAddressesExhausted type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionArpI2cAddressesExhausted Class


ExceptionArpI2cAddressesExhausted Properties

ExceptionArpI2cAddressesExhausted Properties

The ExceptionArpI2cAddressesExhausted type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionArpI2cAddressesExhausted Class


ExceptionArpI2cAddressesExhausted Events

ExceptionArpI2cAddressesExhausted Events

The ExceptionArpI2cAddressesExhausted type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionArpI2cAddressesExhausted Class


ExceptionArpInvalidResponse Class

ExceptionArpInvalidResponse Class
Exception: Received an invalid response from the slave during the SMBus address resolution protocol (ARP).
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionArpInvalidResponse

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionArpInvalidResponse : Exception
Public Class ExceptionArpInvalidResponse
    Inherits Exception
public ref class ExceptionArpInvalidResponse : public Exception
type ExceptionArpInvalidResponse =
    class
        inherit Exception
    end

The ExceptionArpInvalidResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionArpInvalidResponse Methods

ExceptionArpInvalidResponse Methods

The ExceptionArpInvalidResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionArpInvalidResponse Class


ExceptionArpInvalidResponse Properties

ExceptionArpInvalidResponse Properties

The ExceptionArpInvalidResponse type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionArpInvalidResponse Class


ExceptionArpInvalidResponse Events

ExceptionArpInvalidResponse Events

The ExceptionArpInvalidResponse type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionArpInvalidResponse Class


ExceptionAuthentication Class

ExceptionAuthentication Class
Exception: The authentication with the I2C scheduler failed. Check the password.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionAuthentication

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionAuthentication : Exception
Public Class ExceptionAuthentication
    Inherits Exception
public ref class ExceptionAuthentication : public Exception
type ExceptionAuthentication =
    class
        inherit Exception
    end

The ExceptionAuthentication type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionAuthentication Methods

ExceptionAuthentication Methods

The ExceptionAuthentication type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAuthentication Class


ExceptionAuthentication Properties

ExceptionAuthentication Properties

The ExceptionAuthentication type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAuthentication Class


ExceptionAuthentication Events

ExceptionAuthentication Events

The ExceptionAuthentication type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionAuthentication Class


ExceptionBusType Class

ExceptionBusType Class
Exception: The hardware does not support this bus type.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionBusType

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionBusType : Exception
Public Class ExceptionBusType
    Inherits Exception
public ref class ExceptionBusType : public Exception
type ExceptionBusType =
    class
        inherit Exception
    end

The ExceptionBusType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionBusType Methods

ExceptionBusType Methods

The ExceptionBusType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionBusType Class


ExceptionBusType Properties

ExceptionBusType Properties

The ExceptionBusType type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionBusType Class


ExceptionBusType Events

ExceptionBusType Events

The ExceptionBusType type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionBusType Class


ExceptionDeviceOpen Class

ExceptionDeviceOpen Class
Exception: It is not possible to execute the requested command, because no I2C interface has been opened. Open an I2C interface using [!:Board::Open] and try it again.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionDeviceOpen

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionDeviceOpen : Exception
Public Class ExceptionDeviceOpen
    Inherits Exception
public ref class ExceptionDeviceOpen : public Exception
type ExceptionDeviceOpen =
    class
        inherit Exception
    end

The ExceptionDeviceOpen type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionDeviceOpen Methods

ExceptionDeviceOpen Methods

The ExceptionDeviceOpen type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionDeviceOpen Class


ExceptionDeviceOpen Properties

ExceptionDeviceOpen Properties

The ExceptionDeviceOpen type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionDeviceOpen Class


ExceptionDeviceOpen Events

ExceptionDeviceOpen Events

The ExceptionDeviceOpen type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionDeviceOpen Class


ExceptionDriverVersion Class

ExceptionDriverVersion Class
Exception: The used driver of the I2C interface has got the wrong version. To solve this problem, update the driver.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionDriverVersion

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionDriverVersion : Exception
Public Class ExceptionDriverVersion
    Inherits Exception
public ref class ExceptionDriverVersion : public Exception
type ExceptionDriverVersion =
    class
        inherit Exception
    end

The ExceptionDriverVersion type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionDriverVersion Methods

ExceptionDriverVersion Methods

The ExceptionDriverVersion type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionDriverVersion Class


ExceptionDriverVersion Properties

ExceptionDriverVersion Properties

The ExceptionDriverVersion type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionDriverVersion Class


ExceptionDriverVersion Events

ExceptionDriverVersion Events

The ExceptionDriverVersion type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionDriverVersion Class


ExceptionHardwareIo Class

ExceptionHardwareIo Class
Exception: The opened I2C interface does not respond. Maybe the I2C interface has been disconnected from the PC.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionHardwareIo

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionHardwareIo : Exception
Public Class ExceptionHardwareIo
    Inherits Exception
public ref class ExceptionHardwareIo : public Exception
type ExceptionHardwareIo =
    class
        inherit Exception
    end

The ExceptionHardwareIo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionHardwareIo Methods

ExceptionHardwareIo Methods

The ExceptionHardwareIo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionHardwareIo Class


ExceptionHardwareIo Properties

ExceptionHardwareIo Properties

The ExceptionHardwareIo type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionHardwareIo Class


ExceptionHardwareIo Events

ExceptionHardwareIo Events

The ExceptionHardwareIo type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionHardwareIo Class


ExceptionI2cAddress Class

ExceptionI2cAddress Class
Exception: The specified parameters do not specify a valid I2C slave address.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionI2cAddress

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionI2cAddress : Exception
Public Class ExceptionI2cAddress
    Inherits Exception
public ref class ExceptionI2cAddress : public Exception
type ExceptionI2cAddress =
    class
        inherit Exception
    end

The ExceptionI2cAddress type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionI2cAddress | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionI2cAddress Constructor

ExceptionI2cAddress Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionI2cAddress(
    ushort address,
    bool ten_bit_address
)
Public Sub New (
    address As UShort,
    ten_bit_address As Boolean
)
public:
ExceptionI2cAddress(
    unsigned short address,
    bool ten_bit_address
)
new :
        address : uint16 *
        ten_bit_address : bool -> ExceptionI2cAddress

Parameters

address
Type: SystemUInt16
address
ten_bit_address
Type: SystemBoolean
10 bit address?
See Also

Reference

ExceptionI2cAddress Class


ExceptionI2cAddress Methods

ExceptionI2cAddress Methods

The ExceptionI2cAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cAddress Class


ExceptionI2cAddress Properties

ExceptionI2cAddress Properties

The ExceptionI2cAddress type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cAddress Class


ExceptionI2cAddress Events

ExceptionI2cAddress Events

The ExceptionI2cAddress type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cAddress Class


ExceptionI2cAddressRange Class

ExceptionI2cAddressRange Class
Exception: The specified parameters do not specify a valid I2C slave address range.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionI2cAddressRange

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionI2cAddressRange : Exception
Public Class ExceptionI2cAddressRange
    Inherits Exception
public ref class ExceptionI2cAddressRange : public Exception
type ExceptionI2cAddressRange =
    class
        inherit Exception
    end

The ExceptionI2cAddressRange type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionI2cAddressRange | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionI2cAddressRange Constructor

ExceptionI2cAddressRange Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionI2cAddressRange(
    I2cAddress addr1,
    I2cAddress addr2
)
Public Sub New (
    addr1 As I2cAddress,
    addr2 As I2cAddress
)
public:
ExceptionI2cAddressRange(
    I2cAddress^ addr1,
    I2cAddress^ addr2
)
new :
        addr1 : I2cAddress *
        addr2 : I2cAddress -> ExceptionI2cAddressRange

Parameters

addr1
Type: telos.I2cApi.DotNetI2cAddress
first I2C address
addr2
Type: telos.I2cApi.DotNetI2cAddress
last I2C address
See Also

Reference

ExceptionI2cAddressRange Class


ExceptionI2cAddressRange Methods

ExceptionI2cAddressRange Methods

The ExceptionI2cAddressRange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cAddressRange Class


ExceptionI2cAddressRange Properties

ExceptionI2cAddressRange Properties

The ExceptionI2cAddressRange type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cAddressRange Class


ExceptionI2cAddressRange Events

ExceptionI2cAddressRange Events

The ExceptionI2cAddressRange type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cAddressRange Class


ExceptionI2cVcc Class

ExceptionI2cVcc Class
Exception: No power supply has been connected to the I2C Vcc pin of the I2C connector. Please connect the power supply providing the voltage of the I2C bus to the I2C Vcc pin of the I2C interface.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionI2cVcc

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionI2cVcc : Exception
Public Class ExceptionI2cVcc
    Inherits Exception
public ref class ExceptionI2cVcc : public Exception
type ExceptionI2cVcc =
    class
        inherit Exception
    end

The ExceptionI2cVcc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionI2cVcc Methods

ExceptionI2cVcc Methods

The ExceptionI2cVcc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cVcc Class


ExceptionI2cVcc Properties

ExceptionI2cVcc Properties

The ExceptionI2cVcc type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cVcc Class


ExceptionI2cVcc Events

ExceptionI2cVcc Events

The ExceptionI2cVcc type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cVcc Class


ExceptionI2cVccSupply Class

ExceptionI2cVccSupply Class
Exception: It is not possible to use the specified I2C Vcc supply voltage.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionI2cVccSupply

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionI2cVccSupply : Exception
Public Class ExceptionI2cVccSupply
    Inherits Exception
public ref class ExceptionI2cVccSupply : public Exception
type ExceptionI2cVccSupply =
    class
        inherit Exception
    end

The ExceptionI2cVccSupply type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionI2cVccSupply Methods

ExceptionI2cVccSupply Methods

The ExceptionI2cVccSupply type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cVccSupply Class


ExceptionI2cVccSupply Properties

ExceptionI2cVccSupply Properties

The ExceptionI2cVccSupply type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cVccSupply Class


ExceptionI2cVccSupply Events

ExceptionI2cVccSupply Events

The ExceptionI2cVccSupply type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionI2cVccSupply Class


ExceptionInputTestpin Class

ExceptionInputTestpin Class
Exception: It is not possible to read the status of the specified input testpin.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionInputTestpin

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionInputTestpin : Exception
Public Class ExceptionInputTestpin
    Inherits Exception
public ref class ExceptionInputTestpin : public Exception
type ExceptionInputTestpin =
    class
        inherit Exception
    end

The ExceptionInputTestpin type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionInputTestpin Methods

ExceptionInputTestpin Methods

The ExceptionInputTestpin type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionInputTestpin Class


ExceptionInputTestpin Properties

ExceptionInputTestpin Properties

The ExceptionInputTestpin type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionInputTestpin Class


ExceptionInputTestpin Events

ExceptionInputTestpin Events

The ExceptionInputTestpin type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionInputTestpin Class


ExceptionIo Class

ExceptionIo Class
Exception: An I/O error has occurred. Different reasons can cause this exception: e.g. there is no running I2C scheduler or the used I2C interface is no longer available.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionIo

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionIo : Exception
Public Class ExceptionIo
    Inherits Exception
public ref class ExceptionIo : public Exception
type ExceptionIo =
    class
        inherit Exception
    end

The ExceptionIo type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionIo | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionIo Constructor

ExceptionIo Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIo()
Public Sub New
public:
ExceptionIo()
new : unit -> ExceptionIo
See Also

Reference

ExceptionIo Class


ExceptionIo Methods

ExceptionIo Methods

The ExceptionIo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIo Class


ExceptionIo Properties

ExceptionIo Properties

The ExceptionIo type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIo Class


ExceptionIo Events

ExceptionIo Events

The ExceptionIo type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIo Class


ExceptionIrdDeviceVerification Class

ExceptionIrdDeviceVerification Class
This exception gets returned by the IrdDeviceVerifier class, when a IrdDevice object does not conform to the IRD specification.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionIrdDeviceVerification

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionIrdDeviceVerification : Exception
Public Class ExceptionIrdDeviceVerification
    Inherits Exception
public ref class ExceptionIrdDeviceVerification : public Exception
type ExceptionIrdDeviceVerification =
    class
        inherit Exception
    end

The ExceptionIrdDeviceVerification type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionIrdDeviceVerification(String) | Constructor.
Public method | ExceptionIrdDeviceVerification(String, Exception) | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionIrdDeviceVerification Constructor

ExceptionIrdDeviceVerification Constructor
Overload List
 | Name | Description
Public method | ExceptionIrdDeviceVerification(String) | Constructor.
Public method | ExceptionIrdDeviceVerification(String, Exception) | Constructor.
Top
See Also

Reference

ExceptionIrdDeviceVerification Class


ExceptionIrdDeviceVerification Constructor (String)

ExceptionIrdDeviceVerification Constructor (String)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIrdDeviceVerification(
    string msg
)
Public Sub New (
    msg As String
)
public:
ExceptionIrdDeviceVerification(
    String^ msg
)
new :
        msg : string -> ExceptionIrdDeviceVerification

Parameters

msg
Type: SystemString
description of the error
See Also

Reference

ExceptionIrdDeviceVerification Class
ExceptionIrdDeviceVerification Overload


ExceptionIrdDeviceVerification Constructor (String, Exception)

ExceptionIrdDeviceVerification Constructor (String, Exception)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIrdDeviceVerification(
    string msg,
    Exception inner_exception
)
Public Sub New (
    msg As String,
    inner_exception As Exception
)
public:
ExceptionIrdDeviceVerification(
    String^ msg,
    Exception^ inner_exception
)
new :
        msg : string *
        inner_exception : Exception -> ExceptionIrdDeviceVerification

Parameters

msg
Type: SystemString
description of the error
inner_exception
Type: SystemException
inner exception
See Also

Reference

ExceptionIrdDeviceVerification Class
ExceptionIrdDeviceVerification Overload


ExceptionIrdDeviceVerification Methods

ExceptionIrdDeviceVerification Methods

The ExceptionIrdDeviceVerification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdDeviceVerification Class


ExceptionIrdDeviceVerification Properties

ExceptionIrdDeviceVerification Properties

The ExceptionIrdDeviceVerification type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdDeviceVerification Class


ExceptionIrdDeviceVerification Events

ExceptionIrdDeviceVerification Events

The ExceptionIrdDeviceVerification type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdDeviceVerification Class


ExceptionIrdLicense Class

ExceptionIrdLicense Class
Exception: The hardware does not have a license for the IRD support.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionIrdLicense

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionIrdLicense : Exception
Public Class ExceptionIrdLicense
    Inherits Exception
public ref class ExceptionIrdLicense : public Exception
type ExceptionIrdLicense =
    class
        inherit Exception
    end

The ExceptionIrdLicense type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionIrdLicense | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionIrdLicense Constructor

ExceptionIrdLicense Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIrdLicense()
Public Sub New
public:
ExceptionIrdLicense()
new : unit -> ExceptionIrdLicense
See Also

Reference

ExceptionIrdLicense Class


ExceptionIrdLicense Methods

ExceptionIrdLicense Methods

The ExceptionIrdLicense type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdLicense Class


ExceptionIrdLicense Properties

ExceptionIrdLicense Properties

The ExceptionIrdLicense type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdLicense Class


ExceptionIrdLicense Events

ExceptionIrdLicense Events

The ExceptionIrdLicense type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdLicense Class


ExceptionIrdMap Class

ExceptionIrdMap Class
This exception gets returned by the IrdMap class in the case of an error.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionIrdMap

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionIrdMap : Exception
Public Class ExceptionIrdMap
    Inherits Exception
public ref class ExceptionIrdMap : public Exception
type ExceptionIrdMap =
    class
        inherit Exception
    end

The ExceptionIrdMap type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionIrdMap | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionIrdMap Constructor

ExceptionIrdMap Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIrdMap(
    string msg
)
Public Sub New (
    msg As String
)
public:
ExceptionIrdMap(
    String^ msg
)
new :
        msg : string -> ExceptionIrdMap

Parameters

msg
Type: SystemString
message describing the error
See Also

Reference

ExceptionIrdMap Class


ExceptionIrdMap Methods

ExceptionIrdMap Methods

The ExceptionIrdMap type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdMap Class


ExceptionIrdMap Properties

ExceptionIrdMap Properties

The ExceptionIrdMap type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdMap Class


ExceptionIrdMap Events

ExceptionIrdMap Events

The ExceptionIrdMap type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdMap Class


ExceptionIrdMaster Class

ExceptionIrdMaster Class
This exception gets thrown by the IrdMaster class.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionIrdMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionIrdMaster : ExceptionMaster
Public Class ExceptionIrdMaster
    Inherits ExceptionMaster
public ref class ExceptionIrdMaster : public ExceptionMaster
type ExceptionIrdMaster =
    class
        inherit ExceptionMaster
    end

The ExceptionIrdMaster type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionIrdMaster | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionIrdMaster Constructor

ExceptionIrdMaster Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIrdMaster(
    string msg
)
Public Sub New (
    msg As String
)
public:
ExceptionIrdMaster(
    String^ msg
)
new :
        msg : string -> ExceptionIrdMaster

Parameters

msg
Type: SystemString
message describing the error
See Also

Reference

ExceptionIrdMaster Class


ExceptionIrdMaster Methods

ExceptionIrdMaster Methods

The ExceptionIrdMaster type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdMaster Class


ExceptionIrdMaster Properties

ExceptionIrdMaster Properties

The ExceptionIrdMaster type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdMaster Class


ExceptionIrdMaster Events

ExceptionIrdMaster Events

The ExceptionIrdMaster type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdMaster Class


ExceptionIrdReader Class

ExceptionIrdReader Class
This exception gets returned by the IrdReader class in the case of an error.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionIrdReader

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionIrdReader : Exception
Public Class ExceptionIrdReader
    Inherits Exception
public ref class ExceptionIrdReader : public Exception
type ExceptionIrdReader =
    class
        inherit Exception
    end

The ExceptionIrdReader type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionIrdReader | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionIrdReader Constructor

ExceptionIrdReader Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIrdReader(
    string msg
)
Public Sub New (
    msg As String
)
public:
ExceptionIrdReader(
    String^ msg
)
new :
        msg : string -> ExceptionIrdReader

Parameters

msg
Type: SystemString
message describing the error
See Also

Reference

ExceptionIrdReader Class


ExceptionIrdReader Methods

ExceptionIrdReader Methods

The ExceptionIrdReader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdReader Class


ExceptionIrdReader Properties

ExceptionIrdReader Properties

The ExceptionIrdReader type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdReader Class


ExceptionIrdReader Events

ExceptionIrdReader Events

The ExceptionIrdReader type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdReader Class


ExceptionIrdWriter Class

ExceptionIrdWriter Class
This exception gets returned by the IrdWriter class in the case of an error.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionIrdWriter

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionIrdWriter : Exception
Public Class ExceptionIrdWriter
    Inherits Exception
public ref class ExceptionIrdWriter : public Exception
type ExceptionIrdWriter =
    class
        inherit Exception
    end

The ExceptionIrdWriter type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionIrdWriter | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionIrdWriter Constructor

ExceptionIrdWriter Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionIrdWriter(
    string msg
)
Public Sub New (
    msg As String
)
public:
ExceptionIrdWriter(
    String^ msg
)
new :
        msg : string -> ExceptionIrdWriter

Parameters

msg
Type: SystemString
message describing the error
See Also

Reference

ExceptionIrdWriter Class


ExceptionIrdWriter Methods

ExceptionIrdWriter Methods

The ExceptionIrdWriter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdWriter Class


ExceptionIrdWriter Properties

ExceptionIrdWriter Properties

The ExceptionIrdWriter type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdWriter Class


ExceptionIrdWriter Events

ExceptionIrdWriter Events

The ExceptionIrdWriter type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionIrdWriter Class


ExceptionItemNotFound Class

ExceptionItemNotFound Class
Exception: The specified item has not been found.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionItemNotFound

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionItemNotFound : Exception
Public Class ExceptionItemNotFound
    Inherits Exception
public ref class ExceptionItemNotFound : public Exception
type ExceptionItemNotFound =
    class
        inherit Exception
    end

The ExceptionItemNotFound type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionItemNotFound | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionItemNotFound Constructor

ExceptionItemNotFound Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionItemNotFound()
Public Sub New
public:
ExceptionItemNotFound()
new : unit -> ExceptionItemNotFound
See Also

Reference

ExceptionItemNotFound Class


ExceptionItemNotFound Methods

ExceptionItemNotFound Methods

The ExceptionItemNotFound type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionItemNotFound Class


ExceptionItemNotFound Properties

ExceptionItemNotFound Properties

The ExceptionItemNotFound type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionItemNotFound Class


ExceptionItemNotFound Events

ExceptionItemNotFound Events

The ExceptionItemNotFound type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionItemNotFound Class


ExceptionLevelThreshold Class

ExceptionLevelThreshold Class
Exception: It is not possible to use the specified level thresholds.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionLevelThreshold

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionLevelThreshold : Exception
Public Class ExceptionLevelThreshold
    Inherits Exception
public ref class ExceptionLevelThreshold : public Exception
type ExceptionLevelThreshold =
    class
        inherit Exception
    end

The ExceptionLevelThreshold type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionLevelThreshold Methods

ExceptionLevelThreshold Methods

The ExceptionLevelThreshold type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionLevelThreshold Class


ExceptionLevelThreshold Properties

ExceptionLevelThreshold Properties

The ExceptionLevelThreshold type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionLevelThreshold Class


ExceptionLevelThreshold Events

ExceptionLevelThreshold Events

The ExceptionLevelThreshold type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionLevelThreshold Class


ExceptionLicenseData Class

ExceptionLicenseData Class
Exception: Failed to set the registration code.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionLicenseData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionLicenseData : Exception
Public Class ExceptionLicenseData
    Inherits Exception
public ref class ExceptionLicenseData : public Exception
type ExceptionLicenseData =
    class
        inherit Exception
    end

The ExceptionLicenseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionLicenseData Methods

ExceptionLicenseData Methods

The ExceptionLicenseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionLicenseData Class


ExceptionLicenseData Properties

ExceptionLicenseData Properties

The ExceptionLicenseData type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionLicenseData Class


ExceptionLicenseData Events

ExceptionLicenseData Events

The ExceptionLicenseData type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionLicenseData Class


ExceptionMaster Class

ExceptionMaster Class
Exception: This class serves as a base class for all exceptions thrown by the master module.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
More...

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ExceptionMaster : Exception
Public MustInherit Class ExceptionMaster
    Inherits Exception
public ref class ExceptionMaster abstract : public Exception
[<AbstractClassAttribute>]
type ExceptionMaster =
    class
        inherit Exception
    end

The ExceptionMaster type exposes the following members.

Constructors
 | Name | Description
Protected method | ExceptionMaster | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionIrdMaster
telos.I2cApi.DotNetExceptionMasterAddress
telos.I2cApi.DotNetExceptionMasterArbitration
telos.I2cApi.DotNetExceptionMasterBusy
telos.I2cApi.DotNetExceptionMasterI2cProtocol
telos.I2cApi.DotNetExceptionMasterIncompleteRx
telos.I2cApi.DotNetExceptionMasterIncompleteTx
telos.I2cApi.DotNetExceptionMasterInvalidBitrate
telos.I2cApi.DotNetExceptionMasterInvalidMasterCode
telos.I2cApi.DotNetExceptionMasterInvalidTransfer
telos.I2cApi.DotNetExceptionMasterNotSupported
telos.I2cApi.DotNetExceptionMasterRunning
telos.I2cApi.DotNetExceptionMasterSmbInvalidSize
telos.I2cApi.DotNetExceptionMasterSmbPecFailed
telos.I2cApi.DotNetExceptionMasterTimeout
telos.I2cApi.DotNetExceptionMasterWatchdogTimeout


ExceptionMaster Constructor

ExceptionMaster Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected ExceptionMaster(
    string description
)
Protected Sub New (
    description As String
)
protected:
ExceptionMaster(
    String^ description
)
new :
        description : string -> ExceptionMaster

Parameters

description
Type: SystemString
description of the error
See Also

Reference

ExceptionMaster Class


ExceptionMaster Methods

ExceptionMaster Methods

The ExceptionMaster type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMaster Class


ExceptionMaster Properties

ExceptionMaster Properties

The ExceptionMaster type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMaster Class


ExceptionMaster Events

ExceptionMaster Events

The ExceptionMaster type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMaster Class


ExceptionMasterAddress Class

ExceptionMasterAddress Class
Exception: There is no slave responsible for this I2C address.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterAddress

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterAddress : ExceptionMaster
Public Class ExceptionMasterAddress
    Inherits ExceptionMaster
public ref class ExceptionMasterAddress : public ExceptionMaster
type ExceptionMasterAddress =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterAddress Methods

ExceptionMasterAddress Methods

The ExceptionMasterAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterAddress Class


ExceptionMasterAddress Properties

ExceptionMasterAddress Properties

The ExceptionMasterAddress type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterAddress Class


ExceptionMasterAddress Events

ExceptionMasterAddress Events

The ExceptionMasterAddress type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterAddress Class


ExceptionMasterArbitration Class

ExceptionMasterArbitration Class
Exception: The master module of the I2C interface has lost the bus arbitration. At the moment the I2C bus is used by an other master.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterArbitration

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterArbitration : ExceptionMaster
Public Class ExceptionMasterArbitration
    Inherits ExceptionMaster
public ref class ExceptionMasterArbitration : public ExceptionMaster
type ExceptionMasterArbitration =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterArbitration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterArbitration Methods

ExceptionMasterArbitration Methods

The ExceptionMasterArbitration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterArbitration Class


ExceptionMasterArbitration Properties

ExceptionMasterArbitration Properties

The ExceptionMasterArbitration type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterArbitration Class


ExceptionMasterArbitration Events

ExceptionMasterArbitration Events

The ExceptionMasterArbitration type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterArbitration Class


ExceptionMasterBusy Class

ExceptionMasterBusy Class
Exception: The master is busy.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterBusy

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterBusy : ExceptionMaster
Public Class ExceptionMasterBusy
    Inherits ExceptionMaster
public ref class ExceptionMasterBusy : public ExceptionMaster
type ExceptionMasterBusy =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterBusy Methods

ExceptionMasterBusy Methods

The ExceptionMasterBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterBusy Class


ExceptionMasterBusy Properties

ExceptionMasterBusy Properties

The ExceptionMasterBusy type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterBusy Class


ExceptionMasterBusy Events

ExceptionMasterBusy Events

The ExceptionMasterBusy type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterBusy Class


ExceptionMasterI2cProtocol Class

ExceptionMasterI2cProtocol Class
Exception: The master module has detected an I2C protocol error on the I2C bus. Due to this error the transfer has been cancelled.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterI2cProtocol

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterI2cProtocol : ExceptionMaster
Public Class ExceptionMasterI2cProtocol
    Inherits ExceptionMaster
public ref class ExceptionMasterI2cProtocol : public ExceptionMaster
type ExceptionMasterI2cProtocol =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterI2cProtocol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterI2cProtocol Methods

ExceptionMasterI2cProtocol Methods

The ExceptionMasterI2cProtocol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterI2cProtocol Class


ExceptionMasterI2cProtocol Properties

ExceptionMasterI2cProtocol Properties

The ExceptionMasterI2cProtocol type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterI2cProtocol Class


ExceptionMasterI2cProtocol Events

ExceptionMasterI2cProtocol Events

The ExceptionMasterI2cProtocol type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterI2cProtocol Class


ExceptionMasterIncompleteRx Class

ExceptionMasterIncompleteRx Class
Exception: If it is not possible to read the requested number of bytes from the slave as master receiver, this exception is thrown.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterIncompleteRx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterIncompleteRx : ExceptionMaster
Public Class ExceptionMasterIncompleteRx
    Inherits ExceptionMaster
public ref class ExceptionMasterIncompleteRx : public ExceptionMaster
type ExceptionMasterIncompleteRx =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterIncompleteRx type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterIncompleteRx Methods

ExceptionMasterIncompleteRx Methods

The ExceptionMasterIncompleteRx type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterIncompleteRx Class


ExceptionMasterIncompleteRx Properties

ExceptionMasterIncompleteRx Properties

The ExceptionMasterIncompleteRx type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterIncompleteRx Class


ExceptionMasterIncompleteRx Events

ExceptionMasterIncompleteRx Events

The ExceptionMasterIncompleteRx type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterIncompleteRx Class


ExceptionMasterIncompleteTx Class

ExceptionMasterIncompleteTx Class
Exception: If the slave does not acknowledge all bytes send by the I2C interface as master transmitter, this exception is thrown.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterIncompleteTx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterIncompleteTx : ExceptionMaster
Public Class ExceptionMasterIncompleteTx
    Inherits ExceptionMaster
public ref class ExceptionMasterIncompleteTx : public ExceptionMaster
type ExceptionMasterIncompleteTx =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterIncompleteTx type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterIncompleteTx Methods

ExceptionMasterIncompleteTx Methods

The ExceptionMasterIncompleteTx type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterIncompleteTx Class


ExceptionMasterIncompleteTx Properties

ExceptionMasterIncompleteTx Properties

The ExceptionMasterIncompleteTx type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterIncompleteTx Class


ExceptionMasterIncompleteTx Events

ExceptionMasterIncompleteTx Events

The ExceptionMasterIncompleteTx type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterIncompleteTx Class


ExceptionMasterInvalidBitrate Class

ExceptionMasterInvalidBitrate Class
Exception: The specified master bitrate is not valid.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterInvalidBitrate

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterInvalidBitrate : ExceptionMaster
Public Class ExceptionMasterInvalidBitrate
    Inherits ExceptionMaster
public ref class ExceptionMasterInvalidBitrate : public ExceptionMaster
type ExceptionMasterInvalidBitrate =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterInvalidBitrate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterInvalidBitrate Methods

ExceptionMasterInvalidBitrate Methods

The ExceptionMasterInvalidBitrate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidBitrate Class


ExceptionMasterInvalidBitrate Properties

ExceptionMasterInvalidBitrate Properties

The ExceptionMasterInvalidBitrate type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidBitrate Class


ExceptionMasterInvalidBitrate Events

ExceptionMasterInvalidBitrate Events

The ExceptionMasterInvalidBitrate type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidBitrate Class


ExceptionMasterInvalidMasterCode Class

ExceptionMasterInvalidMasterCode Class
Exception: The specified high-speed master code is not valid.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterInvalidMasterCode

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterInvalidMasterCode : ExceptionMaster
Public Class ExceptionMasterInvalidMasterCode
    Inherits ExceptionMaster
public ref class ExceptionMasterInvalidMasterCode : public ExceptionMaster
type ExceptionMasterInvalidMasterCode =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterInvalidMasterCode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterInvalidMasterCode Methods

ExceptionMasterInvalidMasterCode Methods

The ExceptionMasterInvalidMasterCode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidMasterCode Class


ExceptionMasterInvalidMasterCode Properties

ExceptionMasterInvalidMasterCode Properties

The ExceptionMasterInvalidMasterCode type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidMasterCode Class


ExceptionMasterInvalidMasterCode Events

ExceptionMasterInvalidMasterCode Events

The ExceptionMasterInvalidMasterCode type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidMasterCode Class


ExceptionMasterInvalidTransfer Class

ExceptionMasterInvalidTransfer Class
Exception: The used I2C interface does not support the specified I2C transfer (e.g. the I2C interface does not support all possible combinations of combined transfers).
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterInvalidTransfer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterInvalidTransfer : ExceptionMaster
Public Class ExceptionMasterInvalidTransfer
    Inherits ExceptionMaster
public ref class ExceptionMasterInvalidTransfer : public ExceptionMaster
type ExceptionMasterInvalidTransfer =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterInvalidTransfer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterInvalidTransfer Methods

ExceptionMasterInvalidTransfer Methods

The ExceptionMasterInvalidTransfer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidTransfer Class


ExceptionMasterInvalidTransfer Properties

ExceptionMasterInvalidTransfer Properties

The ExceptionMasterInvalidTransfer type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidTransfer Class


ExceptionMasterInvalidTransfer Events

ExceptionMasterInvalidTransfer Events

The ExceptionMasterInvalidTransfer type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterInvalidTransfer Class


ExceptionMasterMessageListDataType Class

ExceptionMasterMessageListDataType Class
Exception: Cannot add the given MasterMessage object to the MasterMessageList, because the data array of the master message contains objects of a wrong type (only byte is a valid type).
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMasterMessageListDataType

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterMessageListDataType : Exception
Public Class ExceptionMasterMessageListDataType
    Inherits Exception
public ref class ExceptionMasterMessageListDataType : public Exception
type ExceptionMasterMessageListDataType =
    class
        inherit Exception
    end

The ExceptionMasterMessageListDataType type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionMasterMessageListDataType | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterMessageListDataType Constructor

ExceptionMasterMessageListDataType Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionMasterMessageListDataType()
Public Sub New
public:
ExceptionMasterMessageListDataType()
new : unit -> ExceptionMasterMessageListDataType
See Also

Reference

ExceptionMasterMessageListDataType Class


ExceptionMasterMessageListDataType Methods

ExceptionMasterMessageListDataType Methods

The ExceptionMasterMessageListDataType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterMessageListDataType Class


ExceptionMasterMessageListDataType Properties

ExceptionMasterMessageListDataType Properties

The ExceptionMasterMessageListDataType type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterMessageListDataType Class


ExceptionMasterMessageListDataType Events

ExceptionMasterMessageListDataType Events

The ExceptionMasterMessageListDataType type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterMessageListDataType Class


ExceptionMasterNotSupported Class

ExceptionMasterNotSupported Class
Exception: The hardware does not support the master mode.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterNotSupported : ExceptionMaster
Public Class ExceptionMasterNotSupported
    Inherits ExceptionMaster
public ref class ExceptionMasterNotSupported : public ExceptionMaster
type ExceptionMasterNotSupported =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterNotSupported Methods

ExceptionMasterNotSupported Methods

The ExceptionMasterNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterNotSupported Class


ExceptionMasterNotSupported Properties

ExceptionMasterNotSupported Properties

The ExceptionMasterNotSupported type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterNotSupported Class


ExceptionMasterNotSupported Events

ExceptionMasterNotSupported Events

The ExceptionMasterNotSupported type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterNotSupported Class


ExceptionMasterRunning Class

ExceptionMasterRunning Class
Exception: Cannot execute the requested command, because the master is already running.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterRunning

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterRunning : ExceptionMaster
Public Class ExceptionMasterRunning
    Inherits ExceptionMaster
public ref class ExceptionMasterRunning : public ExceptionMaster
type ExceptionMasterRunning =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterRunning type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterRunning Methods

ExceptionMasterRunning Methods

The ExceptionMasterRunning type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterRunning Class


ExceptionMasterRunning Properties

ExceptionMasterRunning Properties

The ExceptionMasterRunning type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterRunning Class


ExceptionMasterRunning Events

ExceptionMasterRunning Events

The ExceptionMasterRunning type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterRunning Class


ExceptionMasterSmbInvalidSize Class

ExceptionMasterSmbInvalidSize Class
Exception: A SMBus block transfer can contain 1..32 data bytes.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterSmbInvalidSize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterSmbInvalidSize : ExceptionMaster
Public Class ExceptionMasterSmbInvalidSize
    Inherits ExceptionMaster
public ref class ExceptionMasterSmbInvalidSize : public ExceptionMaster
type ExceptionMasterSmbInvalidSize =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterSmbInvalidSize type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionMasterSmbInvalidSize | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterSmbInvalidSize Constructor

ExceptionMasterSmbInvalidSize Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionMasterSmbInvalidSize()
Public Sub New
public:
ExceptionMasterSmbInvalidSize()
new : unit -> ExceptionMasterSmbInvalidSize
See Also

Reference

ExceptionMasterSmbInvalidSize Class


ExceptionMasterSmbInvalidSize Methods

ExceptionMasterSmbInvalidSize Methods

The ExceptionMasterSmbInvalidSize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterSmbInvalidSize Class


ExceptionMasterSmbInvalidSize Properties

ExceptionMasterSmbInvalidSize Properties

The ExceptionMasterSmbInvalidSize type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterSmbInvalidSize Class


ExceptionMasterSmbInvalidSize Events

ExceptionMasterSmbInvalidSize Events

The ExceptionMasterSmbInvalidSize type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterSmbInvalidSize Class


ExceptionMasterSmbPecFailed Class

ExceptionMasterSmbPecFailed Class
Exception: The packet error checking (PEC) has failed. The PEC byte does not match the transferred data.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterSmbPecFailed

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterSmbPecFailed : ExceptionMaster
Public Class ExceptionMasterSmbPecFailed
    Inherits ExceptionMaster
public ref class ExceptionMasterSmbPecFailed : public ExceptionMaster
type ExceptionMasterSmbPecFailed =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterSmbPecFailed type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterSmbPecFailed Methods

ExceptionMasterSmbPecFailed Methods

The ExceptionMasterSmbPecFailed type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterSmbPecFailed Class


ExceptionMasterSmbPecFailed Properties

ExceptionMasterSmbPecFailed Properties

The ExceptionMasterSmbPecFailed type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterSmbPecFailed Class


ExceptionMasterSmbPecFailed Events

ExceptionMasterSmbPecFailed Events

The ExceptionMasterSmbPecFailed type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterSmbPecFailed Class


ExceptionMasterTimeout Class

ExceptionMasterTimeout Class
Exception: A timeout has occurred during transferring a master message (SCL low for more than 500 ms).
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterTimeout

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterTimeout : ExceptionMaster
Public Class ExceptionMasterTimeout
    Inherits ExceptionMaster
public ref class ExceptionMasterTimeout : public ExceptionMaster
type ExceptionMasterTimeout =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterTimeout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterTimeout Methods

ExceptionMasterTimeout Methods

The ExceptionMasterTimeout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterTimeout Class


ExceptionMasterTimeout Properties

ExceptionMasterTimeout Properties

The ExceptionMasterTimeout type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterTimeout Class


ExceptionMasterTimeout Events

ExceptionMasterTimeout Events

The ExceptionMasterTimeout type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterTimeout Class


ExceptionMasterWatchdogTimeout Class

ExceptionMasterWatchdogTimeout Class
Exception: A timeout has occurred during transferring a master message (watchdog expired).
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionMaster
telos.I2cApi.DotNetExceptionMasterWatchdogTimeout

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMasterWatchdogTimeout : ExceptionMaster
Public Class ExceptionMasterWatchdogTimeout
    Inherits ExceptionMaster
public ref class ExceptionMasterWatchdogTimeout : public ExceptionMaster
type ExceptionMasterWatchdogTimeout =
    class
        inherit ExceptionMaster
    end

The ExceptionMasterWatchdogTimeout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionMasterWatchdogTimeout Methods

ExceptionMasterWatchdogTimeout Methods

The ExceptionMasterWatchdogTimeout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterWatchdogTimeout Class


ExceptionMasterWatchdogTimeout Properties

ExceptionMasterWatchdogTimeout Properties

The ExceptionMasterWatchdogTimeout type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterWatchdogTimeout Class


ExceptionMasterWatchdogTimeout Events

ExceptionMasterWatchdogTimeout Events

The ExceptionMasterWatchdogTimeout type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionMasterWatchdogTimeout Class


ExceptionNegativeTester Class

ExceptionNegativeTester Class
Exception: This class serves as a base class for all exceptions thrown by the negative tester module.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionNegativeTester
telos.I2cApi.DotNetExceptionNegativeTesterBusy
telos.I2cApi.DotNetExceptionNegativeTesterInvalidArgument
telos.I2cApi.DotNetExceptionNegativeTesterNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ExceptionNegativeTester : Exception
Public MustInherit Class ExceptionNegativeTester
    Inherits Exception
public ref class ExceptionNegativeTester abstract : public Exception
[<AbstractClassAttribute>]
type ExceptionNegativeTester =
    class
        inherit Exception
    end

The ExceptionNegativeTester type exposes the following members.

Constructors
 | Name | Description
Protected method | ExceptionNegativeTester | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionNegativeTester Constructor

ExceptionNegativeTester Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected ExceptionNegativeTester(
    string description
)
Protected Sub New (
    description As String
)
protected:
ExceptionNegativeTester(
    String^ description
)
new :
        description : string -> ExceptionNegativeTester

Parameters

description
Type: SystemString
description of the error
See Also

Reference

ExceptionNegativeTester Class


ExceptionNegativeTester Methods

ExceptionNegativeTester Methods

The ExceptionNegativeTester type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTester Class


ExceptionNegativeTester Properties

ExceptionNegativeTester Properties

The ExceptionNegativeTester type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTester Class


ExceptionNegativeTester Events

ExceptionNegativeTester Events

The ExceptionNegativeTester type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTester Class


ExceptionNegativeTesterBusy Class

ExceptionNegativeTesterBusy Class
Exception: The negative tester cannot be used, because it is already in use or because the I2C interface is busy.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionNegativeTester
telos.I2cApi.DotNetExceptionNegativeTesterBusy

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionNegativeTesterBusy : ExceptionNegativeTester
Public Class ExceptionNegativeTesterBusy
    Inherits ExceptionNegativeTester
public ref class ExceptionNegativeTesterBusy : public ExceptionNegativeTester
type ExceptionNegativeTesterBusy =
    class
        inherit ExceptionNegativeTester
    end

The ExceptionNegativeTesterBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionNegativeTesterBusy Methods

ExceptionNegativeTesterBusy Methods

The ExceptionNegativeTesterBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterBusy Class


ExceptionNegativeTesterBusy Properties

ExceptionNegativeTesterBusy Properties

The ExceptionNegativeTesterBusy type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterBusy Class


ExceptionNegativeTesterBusy Events

ExceptionNegativeTesterBusy Events

The ExceptionNegativeTesterBusy type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterBusy Class


ExceptionNegativeTesterInvalidArgument Class

ExceptionNegativeTesterInvalidArgument Class
Exception: On of the parameters passed to the negative tester module is not valid.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionNegativeTester
telos.I2cApi.DotNetExceptionNegativeTesterInvalidArgument

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionNegativeTesterInvalidArgument : ExceptionNegativeTester
Public Class ExceptionNegativeTesterInvalidArgument
    Inherits ExceptionNegativeTester
public ref class ExceptionNegativeTesterInvalidArgument : public ExceptionNegativeTester
type ExceptionNegativeTesterInvalidArgument =
    class
        inherit ExceptionNegativeTester
    end

The ExceptionNegativeTesterInvalidArgument type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionNegativeTesterInvalidArgument | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionNegativeTesterInvalidArgument Constructor

ExceptionNegativeTesterInvalidArgument Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionNegativeTesterInvalidArgument(
    string description
)
Public Sub New (
    description As String
)
public:
ExceptionNegativeTesterInvalidArgument(
    String^ description
)
new :
        description : string -> ExceptionNegativeTesterInvalidArgument

Parameters

description
Type: SystemString
description
See Also

Reference

ExceptionNegativeTesterInvalidArgument Class


ExceptionNegativeTesterInvalidArgument Methods

ExceptionNegativeTesterInvalidArgument Methods

The ExceptionNegativeTesterInvalidArgument type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterInvalidArgument Class


ExceptionNegativeTesterInvalidArgument Properties

ExceptionNegativeTesterInvalidArgument Properties

The ExceptionNegativeTesterInvalidArgument type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterInvalidArgument Class


ExceptionNegativeTesterInvalidArgument Events

ExceptionNegativeTesterInvalidArgument Events

The ExceptionNegativeTesterInvalidArgument type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterInvalidArgument Class


ExceptionNegativeTesterNotSupported Class

ExceptionNegativeTesterNotSupported Class
Exception: The opened I2C interface does not support the negative tester.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionNegativeTester
telos.I2cApi.DotNetExceptionNegativeTesterNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionNegativeTesterNotSupported : ExceptionNegativeTester
Public Class ExceptionNegativeTesterNotSupported
    Inherits ExceptionNegativeTester
public ref class ExceptionNegativeTesterNotSupported : public ExceptionNegativeTester
type ExceptionNegativeTesterNotSupported =
    class
        inherit ExceptionNegativeTester
    end

The ExceptionNegativeTesterNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionNegativeTesterNotSupported Methods

ExceptionNegativeTesterNotSupported Methods

The ExceptionNegativeTesterNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterNotSupported Class


ExceptionNegativeTesterNotSupported Properties

ExceptionNegativeTesterNotSupported Properties

The ExceptionNegativeTesterNotSupported type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterNotSupported Class


ExceptionNegativeTesterNotSupported Events

ExceptionNegativeTesterNotSupported Events

The ExceptionNegativeTesterNotSupported type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNegativeTesterNotSupported Class


ExceptionNullPointer Class

ExceptionNullPointer Class
Exception: Pointer is set to "0".
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionNullPointer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionNullPointer : Exception
Public Class ExceptionNullPointer
    Inherits Exception
public ref class ExceptionNullPointer : public Exception
type ExceptionNullPointer =
    class
        inherit Exception
    end

The ExceptionNullPointer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionNullPointer Methods

ExceptionNullPointer Methods

The ExceptionNullPointer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNullPointer Class


ExceptionNullPointer Properties

ExceptionNullPointer Properties

The ExceptionNullPointer type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNullPointer Class


ExceptionNullPointer Events

ExceptionNullPointer Events

The ExceptionNullPointer type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionNullPointer Class


ExceptionOpen Class

ExceptionOpen Class
Exception: It is not possible to open the specified I2C interface. Maybe the board is no longer attached to the PC?
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionOpen

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionOpen : Exception
Public Class ExceptionOpen
    Inherits Exception
public ref class ExceptionOpen : public Exception
type ExceptionOpen =
    class
        inherit Exception
    end

The ExceptionOpen type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionOpen Methods

ExceptionOpen Methods

The ExceptionOpen type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionOpen Class


ExceptionOpen Properties

ExceptionOpen Properties

The ExceptionOpen type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionOpen Class


ExceptionOpen Events

ExceptionOpen Events

The ExceptionOpen type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionOpen Class


ExceptionOutputTestpin Class

ExceptionOutputTestpin Class
Exception: It is not possible to use the specified output testpin configuration.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionOutputTestpin

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionOutputTestpin : Exception
Public Class ExceptionOutputTestpin
    Inherits Exception
public ref class ExceptionOutputTestpin : public Exception
type ExceptionOutputTestpin =
    class
        inherit Exception
    end

The ExceptionOutputTestpin type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionOutputTestpin Methods

ExceptionOutputTestpin Methods

The ExceptionOutputTestpin type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionOutputTestpin Class


ExceptionOutputTestpin Properties

ExceptionOutputTestpin Properties

The ExceptionOutputTestpin type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionOutputTestpin Class


ExceptionOutputTestpin Events

ExceptionOutputTestpin Events

The ExceptionOutputTestpin type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionOutputTestpin Class


ExceptionPlugInManager Class

ExceptionPlugInManager Class
This exception gets returned by the PlugInManager class in the case of an error.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionPlugInManager

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionPlugInManager : Exception
Public Class ExceptionPlugInManager
    Inherits Exception
public ref class ExceptionPlugInManager : public Exception
type ExceptionPlugInManager =
    class
        inherit Exception
    end

The ExceptionPlugInManager type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionPlugInManager(String) | Constructor
Public method | ExceptionPlugInManager(String, Exception) | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionPlugInManager Constructor

ExceptionPlugInManager Constructor
Overload List
 | Name | Description
Public method | ExceptionPlugInManager(String) | Constructor
Public method | ExceptionPlugInManager(String, Exception) | Constructor
Top
See Also

Reference

ExceptionPlugInManager Class


ExceptionPlugInManager Constructor (String)

ExceptionPlugInManager Constructor (String)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionPlugInManager(
    string msg
)
Public Sub New (
    msg As String
)
public:
ExceptionPlugInManager(
    String^ msg
)
new :
        msg : string -> ExceptionPlugInManager

Parameters

msg
Type: SystemString
message describing the error
See Also

Reference

ExceptionPlugInManager Class
ExceptionPlugInManager Overload


ExceptionPlugInManager Constructor (String, Exception)

ExceptionPlugInManager Constructor (String, Exception)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionPlugInManager(
    string msg,
    Exception inner_exception
)
Public Sub New (
    msg As String,
    inner_exception As Exception
)
public:
ExceptionPlugInManager(
    String^ msg,
    Exception^ inner_exception
)
new :
        msg : string *
        inner_exception : Exception -> ExceptionPlugInManager

Parameters

msg
Type: SystemString
message describing the error
inner_exception
Type: SystemException
inner exception
See Also

Reference

ExceptionPlugInManager Class
ExceptionPlugInManager Overload


ExceptionPlugInManager Methods

ExceptionPlugInManager Methods

The ExceptionPlugInManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionPlugInManager Class


ExceptionPlugInManager Properties

ExceptionPlugInManager Properties

The ExceptionPlugInManager type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionPlugInManager Class


ExceptionPlugInManager Events

ExceptionPlugInManager Events

The ExceptionPlugInManager type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionPlugInManager Class


ExceptionPlugInManagerRegister Class

ExceptionPlugInManagerRegister Class
Exception: Failed to register the specified plug-in.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionPlugInManagerRegister

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionPlugInManagerRegister : Exception
Public Class ExceptionPlugInManagerRegister
    Inherits Exception
public ref class ExceptionPlugInManagerRegister : public Exception
type ExceptionPlugInManagerRegister =
    class
        inherit Exception
    end

The ExceptionPlugInManagerRegister type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionPlugInManagerRegister | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionPlugInManagerRegister Constructor

ExceptionPlugInManagerRegister Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionPlugInManagerRegister()
Public Sub New
public:
ExceptionPlugInManagerRegister()
new : unit -> ExceptionPlugInManagerRegister
See Also

Reference

ExceptionPlugInManagerRegister Class


ExceptionPlugInManagerRegister Methods

ExceptionPlugInManagerRegister Methods

The ExceptionPlugInManagerRegister type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionPlugInManagerRegister Class


ExceptionPlugInManagerRegister Properties

ExceptionPlugInManagerRegister Properties

The ExceptionPlugInManagerRegister type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionPlugInManagerRegister Class


ExceptionPlugInManagerRegister Events

ExceptionPlugInManagerRegister Events

The ExceptionPlugInManagerRegister type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionPlugInManagerRegister Class


ExceptionSchedulerBusy Class

ExceptionSchedulerBusy Class
Exception: Cannot connect to the I2C scheduler, because the scheduler is busy. The scheduler can handle only a limited number of simultaneous connections.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSchedulerBusy

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSchedulerBusy : Exception
Public Class ExceptionSchedulerBusy
    Inherits Exception
public ref class ExceptionSchedulerBusy : public Exception
type ExceptionSchedulerBusy =
    class
        inherit Exception
    end

The ExceptionSchedulerBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSchedulerBusy Methods

ExceptionSchedulerBusy Methods

The ExceptionSchedulerBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSchedulerBusy Class


ExceptionSchedulerBusy Properties

ExceptionSchedulerBusy Properties

The ExceptionSchedulerBusy type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSchedulerBusy Class


ExceptionSchedulerBusy Events

ExceptionSchedulerBusy Events

The ExceptionSchedulerBusy type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSchedulerBusy Class


ExceptionSchedulerVersion Class

ExceptionSchedulerVersion Class
Exception: The running I2C scheduler has got the wrong version. To solve this problem, use a scheduler with the version number specified in the description of the exception.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSchedulerVersion

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSchedulerVersion : Exception
Public Class ExceptionSchedulerVersion
    Inherits Exception
public ref class ExceptionSchedulerVersion : public Exception
type ExceptionSchedulerVersion =
    class
        inherit Exception
    end

The ExceptionSchedulerVersion type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSchedulerVersion Methods

ExceptionSchedulerVersion Methods

The ExceptionSchedulerVersion type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSchedulerVersion Class


ExceptionSchedulerVersion Properties

ExceptionSchedulerVersion Properties

The ExceptionSchedulerVersion type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSchedulerVersion Class


ExceptionSchedulerVersion Events

ExceptionSchedulerVersion Events

The ExceptionSchedulerVersion type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSchedulerVersion Class


ExceptionServiceContractExpired Class

ExceptionServiceContractExpired Class
Exception: This version of the I2C software cannot be used with the opened I2C interface, because the service contract of this board has been expired.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionServiceContractExpired

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionServiceContractExpired : Exception
Public Class ExceptionServiceContractExpired
    Inherits Exception
public ref class ExceptionServiceContractExpired : public Exception
type ExceptionServiceContractExpired =
    class
        inherit Exception
    end

The ExceptionServiceContractExpired type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionServiceContractExpired Methods

ExceptionServiceContractExpired Methods

The ExceptionServiceContractExpired type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionServiceContractExpired Class


ExceptionServiceContractExpired Properties

ExceptionServiceContractExpired Properties

The ExceptionServiceContractExpired type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionServiceContractExpired Class


ExceptionServiceContractExpired Events

ExceptionServiceContractExpired Events

The ExceptionServiceContractExpired type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionServiceContractExpired Class


ExceptionSlaveRamEnhanced Class

ExceptionSlaveRamEnhanced Class
Exception: This class serves as a base class for all exceptions thrown by the SlaveRamEnhanced module.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
More...

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ExceptionSlaveRamEnhanced : Exception
Public MustInherit Class ExceptionSlaveRamEnhanced
    Inherits Exception
public ref class ExceptionSlaveRamEnhanced abstract : public Exception
[<AbstractClassAttribute>]
type ExceptionSlaveRamEnhanced =
    class
        inherit Exception
    end

The ExceptionSlaveRamEnhanced type exposes the following members.

Constructors
 | Name | Description
Protected method | ExceptionSlaveRamEnhanced | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSlaveRamEnhancedAddress
telos.I2cApi.DotNetExceptionSlaveRamEnhancedBusy
telos.I2cApi.DotNetExceptionSlaveRamEnhancedMemorySize
telos.I2cApi.DotNetExceptionSlaveRamEnhancedNotSupported
telos.I2cApi.DotNetExceptionSlaveRamEnhancedSetData
telos.I2cApi.DotNetExceptionSlaveRamEnhancedTimeout


ExceptionSlaveRamEnhanced Constructor

ExceptionSlaveRamEnhanced Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected ExceptionSlaveRamEnhanced(
    string description
)
Protected Sub New (
    description As String
)
protected:
ExceptionSlaveRamEnhanced(
    String^ description
)
new :
        description : string -> ExceptionSlaveRamEnhanced

Parameters

description
Type: SystemString
description of the error
See Also

Reference

ExceptionSlaveRamEnhanced Class


ExceptionSlaveRamEnhanced Methods

ExceptionSlaveRamEnhanced Methods

The ExceptionSlaveRamEnhanced type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhanced Class


ExceptionSlaveRamEnhanced Properties

ExceptionSlaveRamEnhanced Properties

The ExceptionSlaveRamEnhanced type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhanced Class


ExceptionSlaveRamEnhanced Events

ExceptionSlaveRamEnhanced Events

The ExceptionSlaveRamEnhanced type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhanced Class


ExceptionSlaveRamEnhancedAddress Class

ExceptionSlaveRamEnhancedAddress Class
Exception: The SlaveRamEnhanced does not support the specified I2C address.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSlaveRamEnhancedAddress

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSlaveRamEnhancedAddress : ExceptionSlaveRamEnhanced
Public Class ExceptionSlaveRamEnhancedAddress
    Inherits ExceptionSlaveRamEnhanced
public ref class ExceptionSlaveRamEnhancedAddress : public ExceptionSlaveRamEnhanced
type ExceptionSlaveRamEnhancedAddress =
    class
        inherit ExceptionSlaveRamEnhanced
    end

The ExceptionSlaveRamEnhancedAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSlaveRamEnhancedAddress Methods

ExceptionSlaveRamEnhancedAddress Methods

The ExceptionSlaveRamEnhancedAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedAddress Class


ExceptionSlaveRamEnhancedAddress Properties

ExceptionSlaveRamEnhancedAddress Properties

The ExceptionSlaveRamEnhancedAddress type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedAddress Class


ExceptionSlaveRamEnhancedAddress Events

ExceptionSlaveRamEnhancedAddress Events

The ExceptionSlaveRamEnhancedAddress type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedAddress Class


ExceptionSlaveRamEnhancedBusy Class

ExceptionSlaveRamEnhancedBusy Class
Exception: Cannot change the configuration of SlaveRamEnhanced, while it is enabled.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSlaveRamEnhancedBusy

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSlaveRamEnhancedBusy : ExceptionSlaveRamEnhanced
Public Class ExceptionSlaveRamEnhancedBusy
    Inherits ExceptionSlaveRamEnhanced
public ref class ExceptionSlaveRamEnhancedBusy : public ExceptionSlaveRamEnhanced
type ExceptionSlaveRamEnhancedBusy =
    class
        inherit ExceptionSlaveRamEnhanced
    end

The ExceptionSlaveRamEnhancedBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSlaveRamEnhancedBusy Methods

ExceptionSlaveRamEnhancedBusy Methods

The ExceptionSlaveRamEnhancedBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedBusy Class


ExceptionSlaveRamEnhancedBusy Properties

ExceptionSlaveRamEnhancedBusy Properties

The ExceptionSlaveRamEnhancedBusy type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedBusy Class


ExceptionSlaveRamEnhancedBusy Events

ExceptionSlaveRamEnhancedBusy Events

The ExceptionSlaveRamEnhancedBusy type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedBusy Class


ExceptionSlaveRamEnhancedMemorySize Class

ExceptionSlaveRamEnhancedMemorySize Class
Exception: The SlaveRamEnhanced does not support the specified memory size. The memory size can be set to 1..256 bytes."
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSlaveRamEnhancedMemorySize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSlaveRamEnhancedMemorySize : ExceptionSlaveRamEnhanced
Public Class ExceptionSlaveRamEnhancedMemorySize
    Inherits ExceptionSlaveRamEnhanced
public ref class ExceptionSlaveRamEnhancedMemorySize : public ExceptionSlaveRamEnhanced
type ExceptionSlaveRamEnhancedMemorySize =
    class
        inherit ExceptionSlaveRamEnhanced
    end

The ExceptionSlaveRamEnhancedMemorySize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSlaveRamEnhancedMemorySize Methods

ExceptionSlaveRamEnhancedMemorySize Methods

The ExceptionSlaveRamEnhancedMemorySize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedMemorySize Class


ExceptionSlaveRamEnhancedMemorySize Properties

ExceptionSlaveRamEnhancedMemorySize Properties

The ExceptionSlaveRamEnhancedMemorySize type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedMemorySize Class


ExceptionSlaveRamEnhancedMemorySize Events

ExceptionSlaveRamEnhancedMemorySize Events

The ExceptionSlaveRamEnhancedMemorySize type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedMemorySize Class


ExceptionSlaveRamEnhancedNotSupported Class

ExceptionSlaveRamEnhancedNotSupported Class
Exception: The opened I2C interface does not support the SlaveRamEnhanced.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSlaveRamEnhancedNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSlaveRamEnhancedNotSupported : ExceptionSlaveRamEnhanced
Public Class ExceptionSlaveRamEnhancedNotSupported
    Inherits ExceptionSlaveRamEnhanced
public ref class ExceptionSlaveRamEnhancedNotSupported : public ExceptionSlaveRamEnhanced
type ExceptionSlaveRamEnhancedNotSupported =
    class
        inherit ExceptionSlaveRamEnhanced
    end

The ExceptionSlaveRamEnhancedNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSlaveRamEnhancedNotSupported Methods

ExceptionSlaveRamEnhancedNotSupported Methods

The ExceptionSlaveRamEnhancedNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedNotSupported Class


ExceptionSlaveRamEnhancedNotSupported Properties

ExceptionSlaveRamEnhancedNotSupported Properties

The ExceptionSlaveRamEnhancedNotSupported type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedNotSupported Class


ExceptionSlaveRamEnhancedNotSupported Events

ExceptionSlaveRamEnhancedNotSupported Events

The ExceptionSlaveRamEnhancedNotSupported type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedNotSupported Class


ExceptionSlaveRamEnhancedSetData Class

ExceptionSlaveRamEnhancedSetData Class
Exception: Failed to set the data of SlaveRamEnhanced. Please check the start address and the number of data bytes to be set.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSlaveRamEnhancedSetData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSlaveRamEnhancedSetData : ExceptionSlaveRamEnhanced
Public Class ExceptionSlaveRamEnhancedSetData
    Inherits ExceptionSlaveRamEnhanced
public ref class ExceptionSlaveRamEnhancedSetData : public ExceptionSlaveRamEnhanced
type ExceptionSlaveRamEnhancedSetData =
    class
        inherit ExceptionSlaveRamEnhanced
    end

The ExceptionSlaveRamEnhancedSetData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSlaveRamEnhancedSetData Methods

ExceptionSlaveRamEnhancedSetData Methods

The ExceptionSlaveRamEnhancedSetData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedSetData Class


ExceptionSlaveRamEnhancedSetData Properties

ExceptionSlaveRamEnhancedSetData Properties

The ExceptionSlaveRamEnhancedSetData type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedSetData Class


ExceptionSlaveRamEnhancedSetData Events

ExceptionSlaveRamEnhancedSetData Events

The ExceptionSlaveRamEnhancedSetData type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedSetData Class


ExceptionSlaveRamEnhancedTimeout Class

ExceptionSlaveRamEnhancedTimeout Class
Exception: The SlaveRamEnhanced does not support the specified timeout. The timeout can be set to 1..1275 ms or N/A (-1 ms).
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSlaveRamEnhanced
telos.I2cApi.DotNetExceptionSlaveRamEnhancedTimeout

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSlaveRamEnhancedTimeout : ExceptionSlaveRamEnhanced
Public Class ExceptionSlaveRamEnhancedTimeout
    Inherits ExceptionSlaveRamEnhanced
public ref class ExceptionSlaveRamEnhancedTimeout : public ExceptionSlaveRamEnhanced
type ExceptionSlaveRamEnhancedTimeout =
    class
        inherit ExceptionSlaveRamEnhanced
    end

The ExceptionSlaveRamEnhancedTimeout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSlaveRamEnhancedTimeout Methods

ExceptionSlaveRamEnhancedTimeout Methods

The ExceptionSlaveRamEnhancedTimeout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedTimeout Class


ExceptionSlaveRamEnhancedTimeout Properties

ExceptionSlaveRamEnhancedTimeout Properties

The ExceptionSlaveRamEnhancedTimeout type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedTimeout Class


ExceptionSlaveRamEnhancedTimeout Events

ExceptionSlaveRamEnhancedTimeout Events

The ExceptionSlaveRamEnhancedTimeout type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSlaveRamEnhancedTimeout Class


ExceptionSmbI2cAddress Class

ExceptionSmbI2cAddress Class
Exception: The SMBus does not support 10 bit addresses.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionSmbI2cAddress

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionSmbI2cAddress : Exception
Public Class ExceptionSmbI2cAddress
    Inherits Exception
public ref class ExceptionSmbI2cAddress : public Exception
type ExceptionSmbI2cAddress =
    class
        inherit Exception
    end

The ExceptionSmbI2cAddress type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionSmbI2cAddress | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionSmbI2cAddress Constructor

ExceptionSmbI2cAddress Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionSmbI2cAddress()
Public Sub New
public:
ExceptionSmbI2cAddress()
new : unit -> ExceptionSmbI2cAddress
See Also

Reference

ExceptionSmbI2cAddress Class


ExceptionSmbI2cAddress Methods

ExceptionSmbI2cAddress Methods

The ExceptionSmbI2cAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSmbI2cAddress Class


ExceptionSmbI2cAddress Properties

ExceptionSmbI2cAddress Properties

The ExceptionSmbI2cAddress type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSmbI2cAddress Class


ExceptionSmbI2cAddress Events

ExceptionSmbI2cAddress Events

The ExceptionSmbI2cAddress type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionSmbI2cAddress Class


ExceptionTermination Class

ExceptionTermination Class
Exception: It is not possible to use the specified termination for SCL/SDA.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTermination

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTermination : Exception
Public Class ExceptionTermination
    Inherits Exception
public ref class ExceptionTermination : public Exception
type ExceptionTermination =
    class
        inherit Exception
    end

The ExceptionTermination type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTermination Methods

ExceptionTermination Methods

The ExceptionTermination type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTermination Class


ExceptionTermination Properties

ExceptionTermination Properties

The ExceptionTermination type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTermination Class


ExceptionTermination Events

ExceptionTermination Events

The ExceptionTermination type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTermination Class


ExceptionThreading Class

ExceptionThreading Class
Exception: A method or property of Board has been called from a thread, which has not created this object. Please read the documentation of Board regarding the usage of threads.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionThreading

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionThreading : Exception
Public Class ExceptionThreading
    Inherits Exception
public ref class ExceptionThreading : public Exception
type ExceptionThreading =
    class
        inherit Exception
    end

The ExceptionThreading type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionThreading | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionThreading Constructor

ExceptionThreading Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionThreading()
Public Sub New
public:
ExceptionThreading()
new : unit -> ExceptionThreading
See Also

Reference

ExceptionThreading Class


ExceptionThreading Methods

ExceptionThreading Methods

The ExceptionThreading type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionThreading Class


ExceptionThreading Properties

ExceptionThreading Properties

The ExceptionThreading type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionThreading Class


ExceptionThreading Events

ExceptionThreading Events

The ExceptionThreading type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionThreading Class


ExceptionTraceDataFindCanceled Class

ExceptionTraceDataFindCanceled Class
This exception gets returned by the TraceDataFind class, if the search has been canceled.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTraceDataFindCanceled

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTraceDataFindCanceled : Exception
Public Class ExceptionTraceDataFindCanceled
    Inherits Exception
public ref class ExceptionTraceDataFindCanceled : public Exception
type ExceptionTraceDataFindCanceled =
    class
        inherit Exception
    end

The ExceptionTraceDataFindCanceled type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionTraceDataFindCanceled | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTraceDataFindCanceled Constructor

ExceptionTraceDataFindCanceled Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionTraceDataFindCanceled(
    string msg
)
Public Sub New (
    msg As String
)
public:
ExceptionTraceDataFindCanceled(
    String^ msg
)
new :
        msg : string -> ExceptionTraceDataFindCanceled

Parameters

msg
Type: SystemString
message describing the error
See Also

Reference

ExceptionTraceDataFindCanceled Class


ExceptionTraceDataFindCanceled Methods

ExceptionTraceDataFindCanceled Methods

The ExceptionTraceDataFindCanceled type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraceDataFindCanceled Class


ExceptionTraceDataFindCanceled Properties

ExceptionTraceDataFindCanceled Properties

The ExceptionTraceDataFindCanceled type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraceDataFindCanceled Class


ExceptionTraceDataFindCanceled Events

ExceptionTraceDataFindCanceled Events

The ExceptionTraceDataFindCanceled type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraceDataFindCanceled Class


ExceptionTracer Class

ExceptionTracer Class
Exception: This class serves as a base class for all exceptions thrown by the tracer module.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracer
telos.I2cApi.DotNetExceptionTracerBusy
telos.I2cApi.DotNetExceptionTracerFilter
telos.I2cApi.DotNetExceptionTracerMsgListMissing
telos.I2cApi.DotNetExceptionTracerNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ExceptionTracer : Exception
Public MustInherit Class ExceptionTracer
    Inherits Exception
public ref class ExceptionTracer abstract : public Exception
[<AbstractClassAttribute>]
type ExceptionTracer =
    class
        inherit Exception
    end

The ExceptionTracer type exposes the following members.

Constructors
 | Name | Description
Protected method | ExceptionTracer | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracer Constructor

ExceptionTracer Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected ExceptionTracer(
    string description
)
Protected Sub New (
    description As String
)
protected:
ExceptionTracer(
    String^ description
)
new :
        description : string -> ExceptionTracer

Parameters

description
Type: SystemString
description of the error
See Also

Reference

ExceptionTracer Class


ExceptionTracer Methods

ExceptionTracer Methods

The ExceptionTracer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracer Class


ExceptionTracer Properties

ExceptionTracer Properties

The ExceptionTracer type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracer Class


ExceptionTracer Events

ExceptionTracer Events

The ExceptionTracer type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracer Class


ExceptionTracerBusy Class

ExceptionTracerBusy Class
Exception: The tracer is busy.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracer
telos.I2cApi.DotNetExceptionTracerBusy

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTracerBusy : ExceptionTracer
Public Class ExceptionTracerBusy
    Inherits ExceptionTracer
public ref class ExceptionTracerBusy : public ExceptionTracer
type ExceptionTracerBusy =
    class
        inherit ExceptionTracer
    end

The ExceptionTracerBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracerBusy Methods

ExceptionTracerBusy Methods

The ExceptionTracerBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerBusy Class


ExceptionTracerBusy Properties

ExceptionTracerBusy Properties

The ExceptionTracerBusy type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerBusy Class


ExceptionTracerBusy Events

ExceptionTracerBusy Events

The ExceptionTracerBusy type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerBusy Class


ExceptionTracerFilter Class

ExceptionTracerFilter Class
Exception: An error occurred while setting the I2C address filter.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracer
telos.I2cApi.DotNetExceptionTracerFilter

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTracerFilter : ExceptionTracer
Public Class ExceptionTracerFilter
    Inherits ExceptionTracer
public ref class ExceptionTracerFilter : public ExceptionTracer
type ExceptionTracerFilter =
    class
        inherit ExceptionTracer
    end

The ExceptionTracerFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracerFilter Methods

ExceptionTracerFilter Methods

The ExceptionTracerFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerFilter Class


ExceptionTracerFilter Properties

ExceptionTracerFilter Properties

The ExceptionTracerFilter type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerFilter Class


ExceptionTracerFilter Events

ExceptionTracerFilter Events

The ExceptionTracerFilter type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerFilter Class


ExceptionTracerMessageList Class

ExceptionTracerMessageList Class
Exception: This class serves as a base class for all exceptions thrown by the TracerMessageList.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracerMessageList
telos.I2cApi.DotNetExceptionTracerMessageListIo
telos.I2cApi.DotNetExceptionTracerMessageListOutOfRange

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTracerMessageList : Exception
Public Class ExceptionTracerMessageList
    Inherits Exception
public ref class ExceptionTracerMessageList : public Exception
type ExceptionTracerMessageList =
    class
        inherit Exception
    end

The ExceptionTracerMessageList type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionTracerMessageList(String) | Constructor.
Public method | ExceptionTracerMessageList(String, Exception) | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracerMessageList Constructor

ExceptionTracerMessageList Constructor
Overload List
 | Name | Description
Public method | ExceptionTracerMessageList(String) | Constructor.
Public method | ExceptionTracerMessageList(String, Exception) | Constructor.
Top
See Also

Reference

ExceptionTracerMessageList Class


ExceptionTracerMessageList Constructor (String)

ExceptionTracerMessageList Constructor (String)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionTracerMessageList(
    string description
)
Public Sub New (
    description As String
)
public:
ExceptionTracerMessageList(
    String^ description
)
new :
        description : string -> ExceptionTracerMessageList

Parameters

description
Type: SystemString
description
See Also

Reference

ExceptionTracerMessageList Class
ExceptionTracerMessageList Overload


ExceptionTracerMessageList Constructor (String, Exception)

ExceptionTracerMessageList Constructor (String, Exception)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionTracerMessageList(
    string description,
    Exception inner_exception
)
Public Sub New (
    description As String,
    inner_exception As Exception
)
public:
ExceptionTracerMessageList(
    String^ description,
    Exception^ inner_exception
)
new :
        description : string *
        inner_exception : Exception -> ExceptionTracerMessageList

Parameters

description
Type: SystemString
description
inner_exception
Type: SystemException
inner exception
See Also

Reference

ExceptionTracerMessageList Class
ExceptionTracerMessageList Overload


ExceptionTracerMessageList Methods

ExceptionTracerMessageList Methods

The ExceptionTracerMessageList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageList Class


ExceptionTracerMessageList Properties

ExceptionTracerMessageList Properties

The ExceptionTracerMessageList type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageList Class


ExceptionTracerMessageList Events

ExceptionTracerMessageList Events

The ExceptionTracerMessageList type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageList Class


ExceptionTracerMessageListIo Class

ExceptionTracerMessageListIo Class
Exception: An I/O error occurred while accessing one of the temp files used by the TracerMessageList.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracerMessageList
telos.I2cApi.DotNetExceptionTracerMessageListIo

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTracerMessageListIo : ExceptionTracerMessageList
Public Class ExceptionTracerMessageListIo
    Inherits ExceptionTracerMessageList
public ref class ExceptionTracerMessageListIo : public ExceptionTracerMessageList
type ExceptionTracerMessageListIo =
    class
        inherit ExceptionTracerMessageList
    end

The ExceptionTracerMessageListIo type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionTracerMessageListIo(String) | Constructor.
Public method | ExceptionTracerMessageListIo(String, Exception) | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracerMessageListIo Constructor

ExceptionTracerMessageListIo Constructor
Overload List
 | Name | Description
Public method | ExceptionTracerMessageListIo(String) | Constructor.
Public method | ExceptionTracerMessageListIo(String, Exception) | Constructor.
Top
See Also

Reference

ExceptionTracerMessageListIo Class


ExceptionTracerMessageListIo Constructor (String)

ExceptionTracerMessageListIo Constructor (String)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionTracerMessageListIo(
    string description
)
Public Sub New (
    description As String
)
public:
ExceptionTracerMessageListIo(
    String^ description
)
new :
        description : string -> ExceptionTracerMessageListIo

Parameters

description
Type: SystemString
description
See Also

Reference

ExceptionTracerMessageListIo Class
ExceptionTracerMessageListIo Overload


ExceptionTracerMessageListIo Constructor (String, Exception)

ExceptionTracerMessageListIo Constructor (String, Exception)
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionTracerMessageListIo(
    string description,
    Exception inner_exception
)
Public Sub New (
    description As String,
    inner_exception As Exception
)
public:
ExceptionTracerMessageListIo(
    String^ description,
    Exception^ inner_exception
)
new :
        description : string *
        inner_exception : Exception -> ExceptionTracerMessageListIo

Parameters

description
Type: SystemString
description
inner_exception
Type: SystemException
inner exception
See Also

Reference

ExceptionTracerMessageListIo Class
ExceptionTracerMessageListIo Overload


ExceptionTracerMessageListIo Methods

ExceptionTracerMessageListIo Methods

The ExceptionTracerMessageListIo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageListIo Class


ExceptionTracerMessageListIo Properties

ExceptionTracerMessageListIo Properties

The ExceptionTracerMessageListIo type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageListIo Class


ExceptionTracerMessageListIo Events

ExceptionTracerMessageListIo Events

The ExceptionTracerMessageListIo type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageListIo Class


ExceptionTracerMessageListOutOfRange Class

ExceptionTracerMessageListOutOfRange Class
Exception: One of the arguments passed to a method of the TracerMessageList is out of range.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracerMessageList
telos.I2cApi.DotNetExceptionTracerMessageListOutOfRange

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTracerMessageListOutOfRange : ExceptionTracerMessageList
Public Class ExceptionTracerMessageListOutOfRange
    Inherits ExceptionTracerMessageList
public ref class ExceptionTracerMessageListOutOfRange : public ExceptionTracerMessageList
type ExceptionTracerMessageListOutOfRange =
    class
        inherit ExceptionTracerMessageList
    end

The ExceptionTracerMessageListOutOfRange type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionTracerMessageListOutOfRange | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracerMessageListOutOfRange Constructor

ExceptionTracerMessageListOutOfRange Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionTracerMessageListOutOfRange()
Public Sub New
public:
ExceptionTracerMessageListOutOfRange()
new : unit -> ExceptionTracerMessageListOutOfRange
See Also

Reference

ExceptionTracerMessageListOutOfRange Class


ExceptionTracerMessageListOutOfRange Methods

ExceptionTracerMessageListOutOfRange Methods

The ExceptionTracerMessageListOutOfRange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageListOutOfRange Class


ExceptionTracerMessageListOutOfRange Properties

ExceptionTracerMessageListOutOfRange Properties

The ExceptionTracerMessageListOutOfRange type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageListOutOfRange Class


ExceptionTracerMessageListOutOfRange Events

ExceptionTracerMessageListOutOfRange Events

The ExceptionTracerMessageListOutOfRange type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMessageListOutOfRange Class


ExceptionTracerMsgListMissing Class

ExceptionTracerMsgListMissing Class
Exception: No TracerMessageList has been specified.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracer
telos.I2cApi.DotNetExceptionTracerMsgListMissing

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTracerMsgListMissing : ExceptionTracer
Public Class ExceptionTracerMsgListMissing
    Inherits ExceptionTracer
public ref class ExceptionTracerMsgListMissing : public ExceptionTracer
type ExceptionTracerMsgListMissing =
    class
        inherit ExceptionTracer
    end

The ExceptionTracerMsgListMissing type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionTracerMsgListMissing | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracerMsgListMissing Constructor

ExceptionTracerMsgListMissing Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ExceptionTracerMsgListMissing()
Public Sub New
public:
ExceptionTracerMsgListMissing()
new : unit -> ExceptionTracerMsgListMissing
See Also

Reference

ExceptionTracerMsgListMissing Class


ExceptionTracerMsgListMissing Methods

ExceptionTracerMsgListMissing Methods

The ExceptionTracerMsgListMissing type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMsgListMissing Class


ExceptionTracerMsgListMissing Properties

ExceptionTracerMsgListMissing Properties

The ExceptionTracerMsgListMissing type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMsgListMissing Class


ExceptionTracerMsgListMissing Events

ExceptionTracerMsgListMissing Events

The ExceptionTracerMsgListMissing type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerMsgListMissing Class


ExceptionTracerNotSupported Class

ExceptionTracerNotSupported Class
Exception: The hardware does not support the trace mode.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTracer
telos.I2cApi.DotNetExceptionTracerNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTracerNotSupported : ExceptionTracer
Public Class ExceptionTracerNotSupported
    Inherits ExceptionTracer
public ref class ExceptionTracerNotSupported : public ExceptionTracer
type ExceptionTracerNotSupported =
    class
        inherit ExceptionTracer
    end

The ExceptionTracerNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTracerNotSupported Methods

ExceptionTracerNotSupported Methods

The ExceptionTracerNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerNotSupported Class


ExceptionTracerNotSupported Properties

ExceptionTracerNotSupported Properties

The ExceptionTracerNotSupported type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerNotSupported Class


ExceptionTracerNotSupported Events

ExceptionTracerNotSupported Events

The ExceptionTracerNotSupported type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTracerNotSupported Class


ExceptionTraciiCpu Class

ExceptionTraciiCpu Class
Exception: This class serves as a base class for all exceptions thrown by the TraciiCpu module.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTraciiCpu
telos.I2cApi.DotNetExceptionTraciiCpuBusy
telos.I2cApi.DotNetExceptionTraciiCpuNotSupported
telos.I2cApi.DotNetExceptionTraciiCpuProgramSize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ExceptionTraciiCpu : Exception
Public MustInherit Class ExceptionTraciiCpu
    Inherits Exception
public ref class ExceptionTraciiCpu abstract : public Exception
[<AbstractClassAttribute>]
type ExceptionTraciiCpu =
    class
        inherit Exception
    end

The ExceptionTraciiCpu type exposes the following members.

Constructors
 | Name | Description
Protected method | ExceptionTraciiCpu | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTraciiCpu Constructor

ExceptionTraciiCpu Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected ExceptionTraciiCpu(
    string description
)
Protected Sub New (
    description As String
)
protected:
ExceptionTraciiCpu(
    String^ description
)
new :
        description : string -> ExceptionTraciiCpu

Parameters

description
Type: SystemString
description of the error
See Also

Reference

ExceptionTraciiCpu Class


ExceptionTraciiCpu Methods

ExceptionTraciiCpu Methods

The ExceptionTraciiCpu type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpu Class


ExceptionTraciiCpu Properties

ExceptionTraciiCpu Properties

The ExceptionTraciiCpu type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpu Class


ExceptionTraciiCpu Events

ExceptionTraciiCpu Events

The ExceptionTraciiCpu type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpu Class


ExceptionTraciiCpuBusy Class

ExceptionTraciiCpuBusy Class
Exception: The TraciiCpu cannot be used, because it is already in use or because the master module of the I2C interface is in use.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTraciiCpu
telos.I2cApi.DotNetExceptionTraciiCpuBusy

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTraciiCpuBusy : ExceptionTraciiCpu
Public Class ExceptionTraciiCpuBusy
    Inherits ExceptionTraciiCpu
public ref class ExceptionTraciiCpuBusy : public ExceptionTraciiCpu
type ExceptionTraciiCpuBusy =
    class
        inherit ExceptionTraciiCpu
    end

The ExceptionTraciiCpuBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTraciiCpuBusy Methods

ExceptionTraciiCpuBusy Methods

The ExceptionTraciiCpuBusy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuBusy Class


ExceptionTraciiCpuBusy Properties

ExceptionTraciiCpuBusy Properties

The ExceptionTraciiCpuBusy type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuBusy Class


ExceptionTraciiCpuBusy Events

ExceptionTraciiCpuBusy Events

The ExceptionTraciiCpuBusy type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuBusy Class


ExceptionTraciiCpuNotSupported Class

ExceptionTraciiCpuNotSupported Class
Exception: The opened I2C interface does not support the TraciiCpu.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTraciiCpu
telos.I2cApi.DotNetExceptionTraciiCpuNotSupported

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTraciiCpuNotSupported : ExceptionTraciiCpu
Public Class ExceptionTraciiCpuNotSupported
    Inherits ExceptionTraciiCpu
public ref class ExceptionTraciiCpuNotSupported : public ExceptionTraciiCpu
type ExceptionTraciiCpuNotSupported =
    class
        inherit ExceptionTraciiCpu
    end

The ExceptionTraciiCpuNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTraciiCpuNotSupported Methods

ExceptionTraciiCpuNotSupported Methods

The ExceptionTraciiCpuNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuNotSupported Class


ExceptionTraciiCpuNotSupported Properties

ExceptionTraciiCpuNotSupported Properties

The ExceptionTraciiCpuNotSupported type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuNotSupported Class


ExceptionTraciiCpuNotSupported Events

ExceptionTraciiCpuNotSupported Events

The ExceptionTraciiCpuNotSupported type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuNotSupported Class


ExceptionTraciiCpuProgramSize Class

ExceptionTraciiCpuProgramSize Class
Exception: The specified program image has got false size. Images for the TraciiCpu have got a size of 1024 bytes.
Inheritance Hierarchy
SystemObject
SystemException
telos.I2cApi.DotNetException
telos.I2cApi.DotNetExceptionTraciiCpu
telos.I2cApi.DotNetExceptionTraciiCpuProgramSize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ExceptionTraciiCpuProgramSize : ExceptionTraciiCpu
Public Class ExceptionTraciiCpuProgramSize
    Inherits ExceptionTraciiCpu
public ref class ExceptionTraciiCpuProgramSize : public ExceptionTraciiCpu
type ExceptionTraciiCpuProgramSize =
    class
        inherit ExceptionTraciiCpu
    end

The ExceptionTraciiCpuProgramSize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ExceptionTraciiCpuProgramSize Methods

ExceptionTraciiCpuProgramSize Methods

The ExceptionTraciiCpuProgramSize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuProgramSize Class


ExceptionTraciiCpuProgramSize Properties

ExceptionTraciiCpuProgramSize Properties

The ExceptionTraciiCpuProgramSize type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuProgramSize Class


ExceptionTraciiCpuProgramSize Events

ExceptionTraciiCpuProgramSize Events

The ExceptionTraciiCpuProgramSize type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExceptionTraciiCpuProgramSize Class


FindLogicContainerMessage Class

FindLogicContainerMessage Class
This class defines a find rule on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindLogicContainerMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindLogicContainerMessage : FindRuleMessage,
    IEquatable<FindLogicContainerMessage>
Public NotInheritable Class FindLogicContainerMessage
    Inherits FindRuleMessage
    Implements IEquatable(Of FindLogicContainerMessage)
public ref class FindLogicContainerMessage sealed : public FindRuleMessage,
    IEquatable<FindLogicContainerMessage^>
[<SealedAttribute>]
type FindLogicContainerMessage =
    class
        inherit FindRuleMessage
        interface IEquatable<FindLogicContainerMessage>
    end

The FindLogicContainerMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FindLogicContainerMessage | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindLogicContainerMessage) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | LogicOperation | logic operation to combine the results of the rules
Public property | Rules | message rules to be combined
Top
Remarks
This container combines the results of FindRuleMessage rules using the specified logic operation.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindLogicContainerMessage Constructor

FindLogicContainerMessage Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindLogicContainerMessage()
Public Sub New
public:
FindLogicContainerMessage()
new : unit -> FindLogicContainerMessage
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage Methods

FindLogicContainerMessage Methods

The FindLogicContainerMessage type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindLogicContainerMessage) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage.Equals Method

FindLogicContainerMessageEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindLogicContainerMessage) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage.Equals Method (Object)

FindLogicContainerMessageEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindLogicContainerMessage Class
Equals Overload


FindLogicContainerMessage.Equals Method (FindLogicContainerMessage)

FindLogicContainerMessageEquals Method (FindLogicContainerMessage)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindLogicContainerMessage obj
)
Public Function Equals (
    obj As FindLogicContainerMessage
) As Boolean
public:
virtual bool Equals(
    FindLogicContainerMessage^ obj
) sealed
abstract Equals :
        obj : FindLogicContainerMessage -> bool
override Equals :
        obj : FindLogicContainerMessage -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindLogicContainerMessage
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindLogicContainerMessage Class
Equals Overload


FindLogicContainerMessage.GetHashCode Method

FindLogicContainerMessageGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage.ToString Method

FindLogicContainerMessageToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage Properties

FindLogicContainerMessage Properties

The FindLogicContainerMessage type exposes the following members.

Properties
 | Name | Description
Public property | LogicOperation | logic operation to combine the results of the rules
Public property | Rules | message rules to be combined
Top
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage.LogicOperation Property

FindLogicContainerMessageLogicOperation Property
logic operation to combine the results of the rules

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindLogicContainerMessageLogic LogicOperation { get; set; }
Public Property LogicOperation As FindLogicContainerMessageLogic
    Get
    Set
public:
property FindLogicContainerMessageLogic LogicOperation {
    FindLogicContainerMessageLogic get ();
    void set (FindLogicContainerMessageLogic value);
}
member LogicOperation : FindLogicContainerMessageLogic with get, set

Property Value

Type: FindLogicContainerMessageLogic
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage.Rules Property

FindLogicContainerMessageRules Property
message rules to be combined

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<FindRuleMessage> Rules { get; set; }
Public Property Rules As List(Of FindRuleMessage)
    Get
    Set
public:
property List<FindRuleMessage^>^ Rules {
    List<FindRuleMessage^>^ get ();
    void set (List<FindRuleMessage^>^ value);
}
member Rules : List<FindRuleMessage> with get, set

Property Value

Type: List FindRuleMessage
See Also

Reference

FindLogicContainerMessage Class


FindLogicContainerMessage.Logic Enumeration

FindLogicContainerMessageLogic Enumeration
Enumeration to specify the type of the logic operation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Logic
Public Enumeration Logic
public enum class Logic
type Logic
Members
Member name | Value | Description
AND | 0 | AND
OR | 1 | OR
XOR | 2 | XOR
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindLogicContainerSubMessage Class

FindLogicContainerSubMessage Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindLogicContainerSubMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindLogicContainerSubMessage : FindRuleSubMessage,
    IEquatable<FindLogicContainerSubMessage>
Public NotInheritable Class FindLogicContainerSubMessage
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindLogicContainerSubMessage)
public ref class FindLogicContainerSubMessage sealed : public FindRuleSubMessage,
    IEquatable<FindLogicContainerSubMessage^>
[<SealedAttribute>]
type FindLogicContainerSubMessage =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindLogicContainerSubMessage>
    end

The FindLogicContainerSubMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FindLogicContainerSubMessage | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindLogicContainerSubMessage) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | LogicOperation | logic operation to combine the results of the rules
Public property | Rules | sub message rules to be combined
Top
Remarks
This container combines the results of FindRuleSubMessage rules using the specified logic operation.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindLogicContainerSubMessage Constructor

FindLogicContainerSubMessage Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindLogicContainerSubMessage()
Public Sub New
public:
FindLogicContainerSubMessage()
new : unit -> FindLogicContainerSubMessage
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage Methods

FindLogicContainerSubMessage Methods

The FindLogicContainerSubMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindLogicContainerSubMessage) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage.Equals Method

FindLogicContainerSubMessageEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindLogicContainerSubMessage) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage.Equals Method (Object)

FindLogicContainerSubMessageEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindLogicContainerSubMessage Class
Equals Overload


FindLogicContainerSubMessage.Equals Method (FindLogicContainerSubMessage)

FindLogicContainerSubMessageEquals Method (FindLogicContainerSubMessage)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindLogicContainerSubMessage obj
)
Public Function Equals (
    obj As FindLogicContainerSubMessage
) As Boolean
public:
virtual bool Equals(
    FindLogicContainerSubMessage^ obj
) sealed
abstract Equals :
        obj : FindLogicContainerSubMessage -> bool
override Equals :
        obj : FindLogicContainerSubMessage -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindLogicContainerSubMessage
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindLogicContainerSubMessage Class
Equals Overload


FindLogicContainerSubMessage.GetHashCode Method

FindLogicContainerSubMessageGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage.ToString Method

FindLogicContainerSubMessageToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage Properties

FindLogicContainerSubMessage Properties

The FindLogicContainerSubMessage type exposes the following members.

Properties
 | Name | Description
Public property | LogicOperation | logic operation to combine the results of the rules
Public property | Rules | sub message rules to be combined
Top
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage.LogicOperation Property

FindLogicContainerSubMessageLogicOperation Property
logic operation to combine the results of the rules

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindLogicContainerSubMessageLogic LogicOperation { get; set; }
Public Property LogicOperation As FindLogicContainerSubMessageLogic
    Get
    Set
public:
property FindLogicContainerSubMessageLogic LogicOperation {
    FindLogicContainerSubMessageLogic get ();
    void set (FindLogicContainerSubMessageLogic value);
}
member LogicOperation : FindLogicContainerSubMessageLogic with get, set

Property Value

Type: FindLogicContainerSubMessageLogic
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage.Rules Property

FindLogicContainerSubMessageRules Property
sub message rules to be combined

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<FindRuleSubMessage> Rules { get; set; }
Public Property Rules As List(Of FindRuleSubMessage)
    Get
    Set
public:
property List<FindRuleSubMessage^>^ Rules {
    List<FindRuleSubMessage^>^ get ();
    void set (List<FindRuleSubMessage^>^ value);
}
member Rules : List<FindRuleSubMessage> with get, set

Property Value

Type: List FindRuleSubMessage
See Also

Reference

FindLogicContainerSubMessage Class


FindLogicContainerSubMessage.Logic Enumeration

FindLogicContainerSubMessageLogic Enumeration
Enumeration to specify the type of the logic operation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Logic
Public Enumeration Logic
public enum class Logic
type Logic
Members
Member name | Value | Description
AND | 0 | AND
OR | 1 | OR
XOR | 2 | XOR
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleByteTime Class

FindRuleByteTime Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleByteTime

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleByteTime : FindRuleSubMessage,
    IEquatable<FindRuleByteTime>
Public NotInheritable Class FindRuleByteTime
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleByteTime)
public ref class FindRuleByteTime sealed : public FindRuleSubMessage,
    IEquatable<FindRuleByteTime^>
[<SealedAttribute>]
type FindRuleByteTime =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleByteTime>
    end

The FindRuleByteTime type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleByteTime | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleByteTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
Remarks
An I2C sub message matches this rule, if the times for the transmission of each of the data bytes lies within the specified range.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleByteTime Constructor

FindRuleByteTime Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleByteTime()
Public Sub New
public:
FindRuleByteTime()
new : unit -> FindRuleByteTime
See Also

Reference

FindRuleByteTime Class


FindRuleByteTime Methods

FindRuleByteTime Methods

The FindRuleByteTime type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleByteTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleByteTime Class


FindRuleByteTime.Equals Method

FindRuleByteTimeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleByteTime) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleByteTime Class


FindRuleByteTime.Equals Method (Object)

FindRuleByteTimeEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleByteTime Class
Equals Overload


FindRuleByteTime.Equals Method (FindRuleByteTime)

FindRuleByteTimeEquals Method (FindRuleByteTime)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleByteTime obj
)
Public Function Equals (
    obj As FindRuleByteTime
) As Boolean
public:
virtual bool Equals(
    FindRuleByteTime^ obj
) sealed
abstract Equals :
        obj : FindRuleByteTime -> bool
override Equals :
        obj : FindRuleByteTime -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleByteTime
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleByteTime Class
Equals Overload


FindRuleByteTime.GetHashCode Method

FindRuleByteTimeGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleByteTime Class


FindRuleByteTime.ToString Method

FindRuleByteTimeToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleByteTime Class


FindRuleByteTime Properties

FindRuleByteTime Properties

The FindRuleByteTime type exposes the following members.

Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
See Also

Reference

FindRuleByteTime Class


FindRuleByteTime.MaximumTime Property

FindRuleByteTimeMaximumTime Property
maximum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MaximumTime { get; set; }
Public Property MaximumTime As ULong
    Get
    Set
public:
property unsigned long long MaximumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MaximumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleByteTime Class


FindRuleByteTime.MinimumTime Property

FindRuleByteTimeMinimumTime Property
minimum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MinimumTime { get; set; }
Public Property MinimumTime As ULong
    Get
    Set
public:
property unsigned long long MinimumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MinimumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleByteTime Class


FindRuleData Class

FindRuleData Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleData : FindRuleSubMessage,
    IEquatable<FindRuleData>
Public NotInheritable Class FindRuleData
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleData)
public ref class FindRuleData sealed : public FindRuleSubMessage,
    IEquatable<FindRuleData^>
[<SealedAttribute>]
type FindRuleData =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleData>
    end

The FindRuleData type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleData | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleData) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Values | data bytes to be matched
Top
Remarks
An I2C sub message matches this rule, if the data bytes at the specified positions have the specified values.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleData Constructor

FindRuleData Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleData()
Public Sub New
public:
FindRuleData()
new : unit -> FindRuleData
See Also

Reference

FindRuleData Class


FindRuleData Methods

FindRuleData Methods

The FindRuleData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleData) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleData Class


FindRuleData.Equals Method

FindRuleDataEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleData) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleData Class


FindRuleData.Equals Method (Object)

FindRuleDataEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleData Class
Equals Overload


FindRuleData.Equals Method (FindRuleData)

FindRuleDataEquals Method (FindRuleData)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleData obj
)
Public Function Equals (
    obj As FindRuleData
) As Boolean
public:
virtual bool Equals(
    FindRuleData^ obj
) sealed
abstract Equals :
        obj : FindRuleData -> bool
override Equals :
        obj : FindRuleData -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleData
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleData Class
Equals Overload


FindRuleData.GetHashCode Method

FindRuleDataGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleData Class


FindRuleData.ToString Method

FindRuleDataToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleData Class


FindRuleData Properties

FindRuleData Properties

The FindRuleData type exposes the following members.

Properties
 | Name | Description
Public property | Values | data bytes to be matched
Top
See Also

Reference

FindRuleData Class


FindRuleData.Values Property

FindRuleDataValues Property
data bytes to be matched

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<FindRuleDataValue> Values { get; set; }
Public Property Values As List(Of FindRuleDataValue)
    Get
    Set
public:
property List<FindRuleDataValue^>^ Values {
    List<FindRuleDataValue^>^ get ();
    void set (List<FindRuleDataValue^>^ value);
}
member Values : List<FindRuleDataValue> with get, set

Property Value

Type: List FindRuleDataValue
See Also

Reference

FindRuleData Class


FindRuleData.Value Class

FindRuleDataValue Class
Contains all necessary parameters of one data byte.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleDataValue

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Value : IEquatable<FindRuleDataValue>
Public NotInheritable Class Value
    Implements IEquatable(Of FindRuleDataValue)
public ref class Value sealed : IEquatable<FindRuleDataValue^>
[<SealedAttribute>]
type Value =
    class
        interface IEquatable<FindRuleDataValue>
    end

The FindRuleDataValue type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleDataValue | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataValue) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Data | data byte
Public property | DontCare | don't care mask for the data byte ("0xff" means all bits of Data are compared)
Public property | Position | position of the data byte (e.g. "0" means first byte after I2C address)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleData.Value Constructor

FindRuleDataValue Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Value()
Public Sub New
public:
Value()
new : unit -> Value
See Also

Reference

FindRuleDataValue Class


Value Methods

Value Methods

The FindRuleDataValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataValue) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindRuleDataValue Class


Value.Equals Method

ValueEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataValue) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleDataValue Class


FindRuleData.Value.Equals Method (Object)

FindRuleDataValueEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleDataValue Class
Equals Overload


FindRuleData.Value.Equals Method (FindRuleData.Value)

FindRuleDataValueEquals Method (FindRuleDataValue)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleDataValue obj
)
Public Function Equals (
    obj As FindRuleDataValue
) As Boolean
public:
virtual bool Equals(
    FindRuleDataValue^ obj
) sealed
abstract Equals :
        obj : FindRuleDataValue -> bool
override Equals :
        obj : FindRuleDataValue -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleDataValue
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleDataValue Class
Equals Overload


FindRuleData.Value.GetHashCode Method

FindRuleDataValueGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleDataValue Class


Value Properties

Value Properties

The FindRuleDataValue type exposes the following members.

Properties
 | Name | Description
Public property | Data | data byte
Public property | DontCare | don't care mask for the data byte ("0xff" means all bits of Data are compared)
Public property | Position | position of the data byte (e.g. "0" means first byte after I2C address)
Top
See Also

Reference

FindRuleDataValue Class


FindRuleData.Value.Data Property

FindRuleDataValueData Property
data byte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Data { get; set; }
Public Property Data As Byte
    Get
    Set
public:
property unsigned char Data {
    unsigned char get ();
    void set (unsigned char value);
}
member Data : byte with get, set

Property Value

Type: Byte
See Also

Reference

FindRuleDataValue Class


FindRuleData.Value.DontCare Property

FindRuleDataValueDontCare Property
don't care mask for the data byte ("0xff" means all bits of Data are compared)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte DontCare { get; set; }
Public Property DontCare As Byte
    Get
    Set
public:
property unsigned char DontCare {
    unsigned char get ();
    void set (unsigned char value);
}
member DontCare : byte with get, set

Property Value

Type: Byte
See Also

Reference

FindRuleDataValue Class


FindRuleData.Value.Position Property

FindRuleDataValuePosition Property
position of the data byte (e.g. "0" means first byte after I2C address)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Position { get; set; }
Public Property Position As Integer
    Get
    Set
public:
property int Position {
    int get ();
    void set (int value);
}
member Position : int with get, set

Property Value

Type: Int32
See Also

Reference

FindRuleDataValue Class


FindRuleDataAnyPos Class

FindRuleDataAnyPos Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleDataAnyPos

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleDataAnyPos : FindRuleSubMessage,
    IEquatable<FindRuleDataAnyPos>
Public NotInheritable Class FindRuleDataAnyPos
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleDataAnyPos)
public ref class FindRuleDataAnyPos sealed : public FindRuleSubMessage,
    IEquatable<FindRuleDataAnyPos^>
[<SealedAttribute>]
type FindRuleDataAnyPos =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleDataAnyPos>
    end

The FindRuleDataAnyPos type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleDataAnyPos | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataAnyPos) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Values | data bytes to be matched
Top
Remarks
An I2C sub message matches this rule, if it contains the specified byte sequence.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleDataAnyPos Constructor

FindRuleDataAnyPos Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleDataAnyPos()
Public Sub New
public:
FindRuleDataAnyPos()
new : unit -> FindRuleDataAnyPos
See Also

Reference

FindRuleDataAnyPos Class


FindRuleDataAnyPos Methods

FindRuleDataAnyPos Methods

The FindRuleDataAnyPos type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataAnyPos) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleDataAnyPos Class


FindRuleDataAnyPos.Equals Method

FindRuleDataAnyPosEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataAnyPos) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleDataAnyPos Class


FindRuleDataAnyPos.Equals Method (Object)

FindRuleDataAnyPosEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleDataAnyPos Class
Equals Overload


FindRuleDataAnyPos.Equals Method (FindRuleDataAnyPos)

FindRuleDataAnyPosEquals Method (FindRuleDataAnyPos)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleDataAnyPos obj
)
Public Function Equals (
    obj As FindRuleDataAnyPos
) As Boolean
public:
virtual bool Equals(
    FindRuleDataAnyPos^ obj
) sealed
abstract Equals :
        obj : FindRuleDataAnyPos -> bool
override Equals :
        obj : FindRuleDataAnyPos -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleDataAnyPos
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleDataAnyPos Class
Equals Overload


FindRuleDataAnyPos.GetHashCode Method

FindRuleDataAnyPosGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleDataAnyPos Class


FindRuleDataAnyPos.ToString Method

FindRuleDataAnyPosToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleDataAnyPos Class


FindRuleDataAnyPos Properties

FindRuleDataAnyPos Properties

The FindRuleDataAnyPos type exposes the following members.

Properties
 | Name | Description
Public property | Values | data bytes to be matched
Top
See Also

Reference

FindRuleDataAnyPos Class


FindRuleDataAnyPos.Values Property

FindRuleDataAnyPosValues Property
data bytes to be matched

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<FindRuleDataAnyPosValue> Values { get; set; }
Public Property Values As List(Of FindRuleDataAnyPosValue)
    Get
    Set
public:
property List<FindRuleDataAnyPosValue^>^ Values {
    List<FindRuleDataAnyPosValue^>^ get ();
    void set (List<FindRuleDataAnyPosValue^>^ value);
}
member Values : List<FindRuleDataAnyPosValue> with get, set

Property Value

Type: List FindRuleDataAnyPosValue
See Also

Reference

FindRuleDataAnyPos Class


FindRuleDataAnyPos.Value Class

FindRuleDataAnyPosValue Class
Contains all necessary parameters of one data byte.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleDataAnyPosValue

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Value : IEquatable<FindRuleDataAnyPosValue>
Public NotInheritable Class Value
    Implements IEquatable(Of FindRuleDataAnyPosValue)
public ref class Value sealed : IEquatable<FindRuleDataAnyPosValue^>
[<SealedAttribute>]
type Value =
    class
        interface IEquatable<FindRuleDataAnyPosValue>
    end

The FindRuleDataAnyPosValue type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleDataAnyPosValue | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataAnyPosValue) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Data | data byte
Public property | DontCare | don't care mask for the data byte ("0xff" means all bits of Data are compared)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleDataAnyPos.Value Constructor

FindRuleDataAnyPosValue Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Value()
Public Sub New
public:
Value()
new : unit -> Value
See Also

Reference

FindRuleDataAnyPosValue Class


Value Methods

Value Methods

The FindRuleDataAnyPosValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataAnyPosValue) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindRuleDataAnyPosValue Class


Value.Equals Method

ValueEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataAnyPosValue) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleDataAnyPosValue Class


FindRuleDataAnyPos.Value.Equals Method (Object)

FindRuleDataAnyPosValueEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleDataAnyPosValue Class
Equals Overload


FindRuleDataAnyPos.Value.Equals Method (FindRuleDataAnyPos.Value)

FindRuleDataAnyPosValueEquals Method (FindRuleDataAnyPosValue)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleDataAnyPosValue obj
)
Public Function Equals (
    obj As FindRuleDataAnyPosValue
) As Boolean
public:
virtual bool Equals(
    FindRuleDataAnyPosValue^ obj
) sealed
abstract Equals :
        obj : FindRuleDataAnyPosValue -> bool
override Equals :
        obj : FindRuleDataAnyPosValue -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleDataAnyPosValue
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleDataAnyPosValue Class
Equals Overload


FindRuleDataAnyPos.Value.GetHashCode Method

FindRuleDataAnyPosValueGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleDataAnyPosValue Class


Value Properties

Value Properties

The FindRuleDataAnyPosValue type exposes the following members.

Properties
 | Name | Description
Public property | Data | data byte
Public property | DontCare | don't care mask for the data byte ("0xff" means all bits of Data are compared)
Top
See Also

Reference

FindRuleDataAnyPosValue Class


FindRuleDataAnyPos.Value.Data Property

FindRuleDataAnyPosValueData Property
data byte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Data { get; set; }
Public Property Data As Byte
    Get
    Set
public:
property unsigned char Data {
    unsigned char get ();
    void set (unsigned char value);
}
member Data : byte with get, set

Property Value

Type: Byte
See Also

Reference

FindRuleDataAnyPosValue Class


FindRuleDataAnyPos.Value.DontCare Property

FindRuleDataAnyPosValueDontCare Property
don't care mask for the data byte ("0xff" means all bits of Data are compared)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte DontCare { get; set; }
Public Property DontCare As Byte
    Get
    Set
public:
property unsigned char DontCare {
    unsigned char get ();
    void set (unsigned char value);
}
member DontCare : byte with get, set

Property Value

Type: Byte
See Also

Reference

FindRuleDataAnyPosValue Class


FindRuleDataLength Class

FindRuleDataLength Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleDataLength

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleDataLength : FindRuleSubMessage,
    IEquatable<FindRuleDataLength>
Public NotInheritable Class FindRuleDataLength
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleDataLength)
public ref class FindRuleDataLength sealed : public FindRuleSubMessage,
    IEquatable<FindRuleDataLength^>
[<SealedAttribute>]
type FindRuleDataLength =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleDataLength>
    end

The FindRuleDataLength type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleDataLength | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataLength) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | MaximumLength | maximum length [bytes]
Public property | MinimumLength | minimum length [bytes]
Top
Remarks
An I2C sub message matches this rule, if the number of data bytes in the sub messages lie within the specified range.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleDataLength Constructor

FindRuleDataLength Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleDataLength()
Public Sub New
public:
FindRuleDataLength()
new : unit -> FindRuleDataLength
See Also

Reference

FindRuleDataLength Class


FindRuleDataLength Methods

FindRuleDataLength Methods

The FindRuleDataLength type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataLength) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleDataLength Class


FindRuleDataLength.Equals Method

FindRuleDataLengthEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataLength) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleDataLength Class


FindRuleDataLength.Equals Method (Object)

FindRuleDataLengthEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleDataLength Class
Equals Overload


FindRuleDataLength.Equals Method (FindRuleDataLength)

FindRuleDataLengthEquals Method (FindRuleDataLength)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleDataLength obj
)
Public Function Equals (
    obj As FindRuleDataLength
) As Boolean
public:
virtual bool Equals(
    FindRuleDataLength^ obj
) sealed
abstract Equals :
        obj : FindRuleDataLength -> bool
override Equals :
        obj : FindRuleDataLength -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleDataLength
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleDataLength Class
Equals Overload


FindRuleDataLength.GetHashCode Method

FindRuleDataLengthGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleDataLength Class


FindRuleDataLength.ToString Method

FindRuleDataLengthToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleDataLength Class


FindRuleDataLength Properties

FindRuleDataLength Properties

The FindRuleDataLength type exposes the following members.

Properties
 | Name | Description
Public property | MaximumLength | maximum length [bytes]
Public property | MinimumLength | minimum length [bytes]
Top
See Also

Reference

FindRuleDataLength Class


FindRuleDataLength.MaximumLength Property

FindRuleDataLengthMaximumLength Property
maximum length [bytes]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int MaximumLength { get; set; }
Public Property MaximumLength As Integer
    Get
    Set
public:
property int MaximumLength {
    int get ();
    void set (int value);
}
member MaximumLength : int with get, set

Property Value

Type: Int32
See Also

Reference

FindRuleDataLength Class


FindRuleDataLength.MinimumLength Property

FindRuleDataLengthMinimumLength Property
minimum length [bytes]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int MinimumLength { get; set; }
Public Property MinimumLength As Integer
    Get
    Set
public:
property int MinimumLength {
    int get ();
    void set (int value);
}
member MinimumLength : int with get, set

Property Value

Type: Int32
See Also

Reference

FindRuleDataLength Class


FindRuleDataStatus Class

FindRuleDataStatus Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleDataStatus

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleDataStatus : FindRuleSubMessage,
    IEquatable<FindRuleDataStatus>
Public NotInheritable Class FindRuleDataStatus
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleDataStatus)
public ref class FindRuleDataStatus sealed : public FindRuleSubMessage,
    IEquatable<FindRuleDataStatus^>
[<SealedAttribute>]
type FindRuleDataStatus =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleDataStatus>
    end

The FindRuleDataStatus type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleDataStatus | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataStatus) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Status | search for NACK or ACK
Top
Remarks

An I2C sub message matches this rule, if the data bytes of the sub message have got the specified status.

If the Status property is set to ACK, all data bytes must be acknowledged to match the search. If the property is set to NACK, one data bytes must not be acknowledged.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleDataStatus Constructor

FindRuleDataStatus Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleDataStatus()
Public Sub New
public:
FindRuleDataStatus()
new : unit -> FindRuleDataStatus
See Also

Reference

FindRuleDataStatus Class


FindRuleDataStatus Methods

FindRuleDataStatus Methods

The FindRuleDataStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataStatus) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleDataStatus Class


FindRuleDataStatus.Equals Method

FindRuleDataStatusEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleDataStatus) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleDataStatus Class


FindRuleDataStatus.Equals Method (Object)

FindRuleDataStatusEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleDataStatus Class
Equals Overload


FindRuleDataStatus.Equals Method (FindRuleDataStatus)

FindRuleDataStatusEquals Method (FindRuleDataStatus)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleDataStatus obj
)
Public Function Equals (
    obj As FindRuleDataStatus
) As Boolean
public:
virtual bool Equals(
    FindRuleDataStatus^ obj
) sealed
abstract Equals :
        obj : FindRuleDataStatus -> bool
override Equals :
        obj : FindRuleDataStatus -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleDataStatus
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleDataStatus Class
Equals Overload


FindRuleDataStatus.GetHashCode Method

FindRuleDataStatusGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleDataStatus Class


FindRuleDataStatus.ToString Method

FindRuleDataStatusToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleDataStatus Class


FindRuleDataStatus Properties

FindRuleDataStatus Properties

The FindRuleDataStatus type exposes the following members.

Properties
 | Name | Description
Public property | Status | search for NACK or ACK
Top
See Also

Reference

FindRuleDataStatus Class


FindRuleDataStatus.Status Property

FindRuleDataStatusStatus Property
search for NACK or ACK

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleDataStatusNackAck Status { get; set; }
Public Property Status As FindRuleDataStatusNackAck
    Get
    Set
public:
property FindRuleDataStatusNackAck Status {
    FindRuleDataStatusNackAck get ();
    void set (FindRuleDataStatusNackAck value);
}
member Status : FindRuleDataStatusNackAck with get, set

Property Value

Type: FindRuleDataStatusNackAck
See Also

Reference

FindRuleDataStatus Class


FindRuleDataStatus.NackAck Enumeration

FindRuleDataStatusNackAck Enumeration
Enumeration to choose between NACK and ACK.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum NackAck
Public Enumeration NackAck
public enum class NackAck
type NackAck
Members
Member name | Value | Description
NACK | 0 | NACK
ACK | 1 | ACK
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleError Class

FindRuleError Class
This class defines a find rule on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleError : FindRuleMessage,
    IEquatable<FindRuleError>
Public NotInheritable Class FindRuleError
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleError)
public ref class FindRuleError sealed : public FindRuleMessage,
    IEquatable<FindRuleError^>
[<SealedAttribute>]
type FindRuleError =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleError>
    end

The FindRuleError type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleError | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleError) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Error | type of the error
Top
Remarks
An I2C message matches this rule, if the message contains the type of error, which has been specified using the Error property.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleError Constructor

FindRuleError Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleError()
Public Sub New
public:
FindRuleError()
new : unit -> FindRuleError
See Also

Reference

FindRuleError Class


FindRuleError Methods

FindRuleError Methods

The FindRuleError type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleError) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleError Class


FindRuleError.Equals Method

FindRuleErrorEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleError) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleError Class


FindRuleError.Equals Method (Object)

FindRuleErrorEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleError Class
Equals Overload


FindRuleError.Equals Method (FindRuleError)

FindRuleErrorEquals Method (FindRuleError)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleError obj
)
Public Function Equals (
    obj As FindRuleError
) As Boolean
public:
virtual bool Equals(
    FindRuleError^ obj
) sealed
abstract Equals :
        obj : FindRuleError -> bool
override Equals :
        obj : FindRuleError -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleError
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleError Class
Equals Overload


FindRuleError.GetHashCode Method

FindRuleErrorGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleError Class


FindRuleError.ToString Method

FindRuleErrorToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleError Class


FindRuleError Properties

FindRuleError Properties

The FindRuleError type exposes the following members.

Properties
 | Name | Description
Public property | Error | type of the error
Top
See Also

Reference

FindRuleError Class


FindRuleError.Error Property

FindRuleErrorError Property
type of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleErrorErrorType Error { get; set; }
Public Property Error As FindRuleErrorErrorType
    Get
    Set
public:
property FindRuleErrorErrorType Error {
    FindRuleErrorErrorType get ();
    void set (FindRuleErrorErrorType value);
}
member Error : FindRuleErrorErrorType with get, set

Property Value

Type: FindRuleErrorErrorType
See Also

Reference

FindRuleError Class


FindRuleError.ErrorType Enumeration

FindRuleErrorErrorType Enumeration
Enumeration to specify the type of the error.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum ErrorType
Public Enumeration ErrorType
public enum class ErrorType
type ErrorType
Members
Member name | Value | Description
I2C_PROTOCOL_ERROR | 0 | I2C protocol error
SMBUS_POWER_ON | 1 | SMBus power on
SMBUS_POWER_OFF | 2 | SMBus power off
TRACER_RESTARTED | 3 | tracer restarted
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleI2cAddress Class

FindRuleI2cAddress Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleI2cAddress

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleI2cAddress : FindRuleSubMessage,
    IEquatable<FindRuleI2cAddress>
Public NotInheritable Class FindRuleI2cAddress
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleI2cAddress)
public ref class FindRuleI2cAddress sealed : public FindRuleSubMessage,
    IEquatable<FindRuleI2cAddress^>
[<SealedAttribute>]
type FindRuleI2cAddress =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleI2cAddress>
    end

The FindRuleI2cAddress type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleI2cAddress | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleI2cAddress) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | I2cAddresses | I2C addresses
Top
Remarks
An I2C sub message matches this rule, if it has been sent to an I2C address, which has been specified in the I2cAddresses property.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleI2cAddress Constructor

FindRuleI2cAddress Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleI2cAddress()
Public Sub New
public:
FindRuleI2cAddress()
new : unit -> FindRuleI2cAddress
See Also

Reference

FindRuleI2cAddress Class


FindRuleI2cAddress Methods

FindRuleI2cAddress Methods

The FindRuleI2cAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleI2cAddress) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleI2cAddress Class


FindRuleI2cAddress.Equals Method

FindRuleI2cAddressEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleI2cAddress) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleI2cAddress Class


FindRuleI2cAddress.Equals Method (Object)

FindRuleI2cAddressEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleI2cAddress Class
Equals Overload


FindRuleI2cAddress.Equals Method (FindRuleI2cAddress)

FindRuleI2cAddressEquals Method (FindRuleI2cAddress)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleI2cAddress obj
)
Public Function Equals (
    obj As FindRuleI2cAddress
) As Boolean
public:
virtual bool Equals(
    FindRuleI2cAddress^ obj
) sealed
abstract Equals :
        obj : FindRuleI2cAddress -> bool
override Equals :
        obj : FindRuleI2cAddress -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleI2cAddress
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleI2cAddress Class
Equals Overload


FindRuleI2cAddress.GetHashCode Method

FindRuleI2cAddressGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleI2cAddress Class


FindRuleI2cAddress.ToString Method

FindRuleI2cAddressToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleI2cAddress Class


FindRuleI2cAddress Properties

FindRuleI2cAddress Properties

The FindRuleI2cAddress type exposes the following members.

Properties
 | Name | Description
Public property | I2cAddresses | I2C addresses
Top
See Also

Reference

FindRuleI2cAddress Class


FindRuleI2cAddress.I2cAddresses Property

FindRuleI2cAddressI2cAddresses Property
I2C addresses

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<I2cAddress> I2cAddresses { get; set; }
Public Property I2cAddresses As List(Of I2cAddress)
    Get
    Set
public:
property List<I2cAddress^>^ I2cAddresses {
    List<I2cAddress^>^ get ();
    void set (List<I2cAddress^>^ value);
}
member I2cAddresses : List<I2cAddress> with get, set

Property Value

Type: List I2cAddress
See Also

Reference

FindRuleI2cAddress Class


FindRuleI2cAddressStatus Class

FindRuleI2cAddressStatus Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleI2cAddressStatus

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleI2cAddressStatus : FindRuleSubMessage,
    IEquatable<FindRuleI2cAddressStatus>
Public NotInheritable Class FindRuleI2cAddressStatus
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleI2cAddressStatus)
public ref class FindRuleI2cAddressStatus sealed : public FindRuleSubMessage,
    IEquatable<FindRuleI2cAddressStatus^>
[<SealedAttribute>]
type FindRuleI2cAddressStatus =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleI2cAddressStatus>
    end

The FindRuleI2cAddressStatus type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleI2cAddressStatus | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleI2cAddressStatus) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | FindWithAck | rule matches, if the I2C address has been acknowledged
Public property | FindWithNack | rule matches, if the I2C address has not been acknowledged
Public property | FindWithNoConfirmation | rule matches, if the ACK/NACK bit of the I2C address is missing
Top
Remarks

An I2C sub message matches this rule, if the ACK/NACK bit of the I2C address has one of the states specified by the properties.

If e.g. FindWithNack and FindWithNoConfirmation are set to "true", any I2C sub message will match this rule whose ACK/NACK bit has got the NACK or the "no confirmation" state.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleI2cAddressStatus Constructor

FindRuleI2cAddressStatus Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleI2cAddressStatus()
Public Sub New
public:
FindRuleI2cAddressStatus()
new : unit -> FindRuleI2cAddressStatus
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus Methods

FindRuleI2cAddressStatus Methods

The FindRuleI2cAddressStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleI2cAddressStatus) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus.Equals Method

FindRuleI2cAddressStatusEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleI2cAddressStatus) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus.Equals Method (Object)

FindRuleI2cAddressStatusEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleI2cAddressStatus Class
Equals Overload


FindRuleI2cAddressStatus.Equals Method (FindRuleI2cAddressStatus)

FindRuleI2cAddressStatusEquals Method (FindRuleI2cAddressStatus)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleI2cAddressStatus obj
)
Public Function Equals (
    obj As FindRuleI2cAddressStatus
) As Boolean
public:
virtual bool Equals(
    FindRuleI2cAddressStatus^ obj
) sealed
abstract Equals :
        obj : FindRuleI2cAddressStatus -> bool
override Equals :
        obj : FindRuleI2cAddressStatus -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleI2cAddressStatus
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleI2cAddressStatus Class
Equals Overload


FindRuleI2cAddressStatus.GetHashCode Method

FindRuleI2cAddressStatusGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus.ToString Method

FindRuleI2cAddressStatusToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus Properties

FindRuleI2cAddressStatus Properties

The FindRuleI2cAddressStatus type exposes the following members.

Properties
 | Name | Description
Public property | FindWithAck | rule matches, if the I2C address has been acknowledged
Public property | FindWithNack | rule matches, if the I2C address has not been acknowledged
Public property | FindWithNoConfirmation | rule matches, if the ACK/NACK bit of the I2C address is missing
Top
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus.FindWithAck Property

FindRuleI2cAddressStatusFindWithAck Property
rule matches, if the I2C address has been acknowledged

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FindWithAck { get; set; }
Public Property FindWithAck As Boolean
    Get
    Set
public:
property bool FindWithAck {
    bool get ();
    void set (bool value);
}
member FindWithAck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus.FindWithNack Property

FindRuleI2cAddressStatusFindWithNack Property
rule matches, if the I2C address has not been acknowledged

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FindWithNack { get; set; }
Public Property FindWithNack As Boolean
    Get
    Set
public:
property bool FindWithNack {
    bool get ();
    void set (bool value);
}
member FindWithNack : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleI2cAddressStatus.FindWithNoConfirmation Property

FindRuleI2cAddressStatusFindWithNoConfirmation Property
rule matches, if the ACK/NACK bit of the I2C address is missing

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool FindWithNoConfirmation { get; set; }
Public Property FindWithNoConfirmation As Boolean
    Get
    Set
public:
property bool FindWithNoConfirmation {
    bool get ();
    void set (bool value);
}
member FindWithNoConfirmation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FindRuleI2cAddressStatus Class


FindRuleIdleTime Class

FindRuleIdleTime Class
This class defines a find rule on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleIdleTime

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleIdleTime : FindRuleMessage,
    IEquatable<FindRuleIdleTime>
Public NotInheritable Class FindRuleIdleTime
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleIdleTime)
public ref class FindRuleIdleTime sealed : public FindRuleMessage,
    IEquatable<FindRuleIdleTime^>
[<SealedAttribute>]
type FindRuleIdleTime =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleIdleTime>
    end

The FindRuleIdleTime type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleIdleTime | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIdleTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
Remarks
An I2C message matches this rule, if the time between the STOP condition of the previous and the START condition of the current message lies within the specified range.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleIdleTime Constructor

FindRuleIdleTime Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleIdleTime()
Public Sub New
public:
FindRuleIdleTime()
new : unit -> FindRuleIdleTime
See Also

Reference

FindRuleIdleTime Class


FindRuleIdleTime Methods

FindRuleIdleTime Methods

The FindRuleIdleTime type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIdleTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleIdleTime Class


FindRuleIdleTime.Equals Method

FindRuleIdleTimeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIdleTime) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleIdleTime Class


FindRuleIdleTime.Equals Method (Object)

FindRuleIdleTimeEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleIdleTime Class
Equals Overload


FindRuleIdleTime.Equals Method (FindRuleIdleTime)

FindRuleIdleTimeEquals Method (FindRuleIdleTime)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleIdleTime obj
)
Public Function Equals (
    obj As FindRuleIdleTime
) As Boolean
public:
virtual bool Equals(
    FindRuleIdleTime^ obj
) sealed
abstract Equals :
        obj : FindRuleIdleTime -> bool
override Equals :
        obj : FindRuleIdleTime -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleIdleTime
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleIdleTime Class
Equals Overload


FindRuleIdleTime.GetHashCode Method

FindRuleIdleTimeGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleIdleTime Class


FindRuleIdleTime.ToString Method

FindRuleIdleTimeToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleIdleTime Class


FindRuleIdleTime Properties

FindRuleIdleTime Properties

The FindRuleIdleTime type exposes the following members.

Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
See Also

Reference

FindRuleIdleTime Class


FindRuleIdleTime.MaximumTime Property

FindRuleIdleTimeMaximumTime Property
maximum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MaximumTime { get; set; }
Public Property MaximumTime As ULong
    Get
    Set
public:
property unsigned long long MaximumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MaximumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleIdleTime Class


FindRuleIdleTime.MinimumTime Property

FindRuleIdleTimeMinimumTime Property
minimum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MinimumTime { get; set; }
Public Property MinimumTime As ULong
    Get
    Set
public:
property unsigned long long MinimumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MinimumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleIdleTime Class


FindRuleIrdRegister Class

FindRuleIrdRegister Class
This class defines a find rule on IRD register level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleIrdRegister

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleIrdRegister : FindRuleMessage,
    IEquatable<FindRuleIrdRegister>
Public NotInheritable Class FindRuleIrdRegister
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleIrdRegister)
public ref class FindRuleIrdRegister sealed : public FindRuleMessage,
    IEquatable<FindRuleIrdRegister^>
[<SealedAttribute>]
type FindRuleIrdRegister =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleIrdRegister>
    end

The FindRuleIrdRegister type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleIrdRegister | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIrdRegister) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Data | data
Public property | Data2nd | data (used for Direction == TX_RX)
Public property | Direction | direction
Public property | Id | ID of the register (as used by Id) or N/A ("null")
Public property | Pec | packet error checking
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleIrdRegister Constructor

FindRuleIrdRegister Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleIrdRegister()
Public Sub New
public:
FindRuleIrdRegister()
new : unit -> FindRuleIrdRegister
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister Methods

FindRuleIrdRegister Methods

The FindRuleIrdRegister type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIrdRegister) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.Equals Method

FindRuleIrdRegisterEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIrdRegister) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.Equals Method (Object)

FindRuleIrdRegisterEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleIrdRegister Class
Equals Overload


FindRuleIrdRegister.Equals Method (FindRuleIrdRegister)

FindRuleIrdRegisterEquals Method (FindRuleIrdRegister)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleIrdRegister obj
)
Public Function Equals (
    obj As FindRuleIrdRegister
) As Boolean
public:
virtual bool Equals(
    FindRuleIrdRegister^ obj
) sealed
abstract Equals :
        obj : FindRuleIrdRegister -> bool
override Equals :
        obj : FindRuleIrdRegister -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleIrdRegister
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleIrdRegister Class
Equals Overload


FindRuleIrdRegister.GetHashCode Method

FindRuleIrdRegisterGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.ToString Method

FindRuleIrdRegisterToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister Properties

FindRuleIrdRegister Properties

The FindRuleIrdRegister type exposes the following members.

Properties
 | Name | Description
Public property | Data | data
Public property | Data2nd | data (used for Direction == TX_RX)
Public property | Direction | direction
Public property | Id | ID of the register (as used by Id) or N/A ("null")
Public property | Pec | packet error checking
Top
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.Data Property

FindRuleIrdRegisterData Property
data

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] Data { get; set; }
Public Property Data As Byte()
    Get
    Set
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Data : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.Data2nd Property

FindRuleIrdRegisterData2nd Property
data (used for Direction == TX_RX)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] Data2nd { get; set; }
Public Property Data2nd As Byte()
    Get
    Set
public:
property array<unsigned char>^ Data2nd {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Data2nd : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.Direction Property

FindRuleIrdRegisterDirection Property
direction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleIrdRegisterTxRx Direction { get; set; }
Public Property Direction As FindRuleIrdRegisterTxRx
    Get
    Set
public:
property FindRuleIrdRegisterTxRx Direction {
    FindRuleIrdRegisterTxRx get ();
    void set (FindRuleIrdRegisterTxRx value);
}
member Direction : FindRuleIrdRegisterTxRx with get, set

Property Value

Type: FindRuleIrdRegisterTxRx
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.Id Property

FindRuleIrdRegisterId Property
ID of the register (as used by Id) or N/A ("null")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.Pec Property

FindRuleIrdRegisterPec Property
packet error checking

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleIrdRegisterPecType Pec { get; set; }
Public Property Pec As FindRuleIrdRegisterPecType
    Get
    Set
public:
property FindRuleIrdRegisterPecType Pec {
    FindRuleIrdRegisterPecType get ();
    void set (FindRuleIrdRegisterPecType value);
}
member Pec : FindRuleIrdRegisterPecType with get, set

Property Value

Type: FindRuleIrdRegisterPecType
See Also

Reference

FindRuleIrdRegister Class


FindRuleIrdRegister.PecType Enumeration

FindRuleIrdRegisterPecType Enumeration
Enumeration to specify the result of the SMBus packet error checking (PEC).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum PecType
Public Enumeration PecType
public enum class PecType
type PecType
Members
Member name | Value | Description
PEC_IGNORED | 0 | PEC is ignored
PEC_NA | 1 | PEC not available
PEC_NACK | 2 | PEC has not been acknowledged
PEC_CHECKSUM_ERROR | 3 | PEC checksum error
PEC_OK | 4 | PEC ok
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleIrdRegister.TxRx Enumeration

FindRuleIrdRegisterTxRx Enumeration
Enumeration to specify the transfer direction.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum TxRx
Public Enumeration TxRx
public enum class TxRx
type TxRx
Members
Member name | Value | Description
TX_RX_IGNORED | 0 | direction is ignored
TX | 1 | transmit
RX | 2 | receive
TX_RX | 3 | transmit or receive
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleIrdValue Class

FindRuleIrdValue Class
This class defines a find rule on IRD value level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleIrdValue

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleIrdValue : FindRuleMessage,
    IEquatable<FindRuleIrdValue>
Public NotInheritable Class FindRuleIrdValue
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleIrdValue)
public ref class FindRuleIrdValue sealed : public FindRuleMessage,
    IEquatable<FindRuleIrdValue^>
[<SealedAttribute>]
type FindRuleIrdValue =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleIrdValue>
    end

The FindRuleIrdValue type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleIrdValue | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIrdValue) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Direction | direction
Public property | Id | ID of the value (as used by Id) or N/A ("null")
Public property | Pec | packet error checking
Public property | ValueRawMax | maximum value or N/A ("null")
Public property | ValueRawMin | minimum value or N/A ("null")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleIrdValue Constructor

FindRuleIrdValue Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleIrdValue()
Public Sub New
public:
FindRuleIrdValue()
new : unit -> FindRuleIrdValue
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue Methods

FindRuleIrdValue Methods

The FindRuleIrdValue type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIrdValue) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.Equals Method

FindRuleIrdValueEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleIrdValue) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.Equals Method (Object)

FindRuleIrdValueEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleIrdValue Class
Equals Overload


FindRuleIrdValue.Equals Method (FindRuleIrdValue)

FindRuleIrdValueEquals Method (FindRuleIrdValue)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleIrdValue obj
)
Public Function Equals (
    obj As FindRuleIrdValue
) As Boolean
public:
virtual bool Equals(
    FindRuleIrdValue^ obj
) sealed
abstract Equals :
        obj : FindRuleIrdValue -> bool
override Equals :
        obj : FindRuleIrdValue -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleIrdValue
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleIrdValue Class
Equals Overload


FindRuleIrdValue.GetHashCode Method

FindRuleIrdValueGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.ToString Method

FindRuleIrdValueToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue Properties

FindRuleIrdValue Properties

The FindRuleIrdValue type exposes the following members.

Properties
 | Name | Description
Public property | Direction | direction
Public property | Id | ID of the value (as used by Id) or N/A ("null")
Public property | Pec | packet error checking
Public property | ValueRawMax | maximum value or N/A ("null")
Public property | ValueRawMin | minimum value or N/A ("null")
Top
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.Direction Property

FindRuleIrdValueDirection Property
direction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleIrdValueTxRx Direction { get; set; }
Public Property Direction As FindRuleIrdValueTxRx
    Get
    Set
public:
property FindRuleIrdValueTxRx Direction {
    FindRuleIrdValueTxRx get ();
    void set (FindRuleIrdValueTxRx value);
}
member Direction : FindRuleIrdValueTxRx with get, set

Property Value

Type: FindRuleIrdValueTxRx
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.Id Property

FindRuleIrdValueId Property
ID of the value (as used by Id) or N/A ("null")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.Pec Property

FindRuleIrdValuePec Property
packet error checking

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleIrdValuePecType Pec { get; set; }
Public Property Pec As FindRuleIrdValuePecType
    Get
    Set
public:
property FindRuleIrdValuePecType Pec {
    FindRuleIrdValuePecType get ();
    void set (FindRuleIrdValuePecType value);
}
member Pec : FindRuleIrdValuePecType with get, set

Property Value

Type: FindRuleIrdValuePecType
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.ValueRawMax Property

FindRuleIrdValueValueRawMax Property
maximum value or N/A ("null")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object ValueRawMax { get; set; }
Public Property ValueRawMax As Object
    Get
    Set
public:
property Object^ ValueRawMax {
    Object^ get ();
    void set (Object^ value);
}
member ValueRawMax : Object with get, set

Property Value

Type: Object
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.ValueRawMin Property

FindRuleIrdValueValueRawMin Property
minimum value or N/A ("null")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object ValueRawMin { get; set; }
Public Property ValueRawMin As Object
    Get
    Set
public:
property Object^ ValueRawMin {
    Object^ get ();
    void set (Object^ value);
}
member ValueRawMin : Object with get, set

Property Value

Type: Object
See Also

Reference

FindRuleIrdValue Class


FindRuleIrdValue.PecType Enumeration

FindRuleIrdValuePecType Enumeration
Enumeration to specify the result of the SMBus packet error checking (PEC).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum PecType
Public Enumeration PecType
public enum class PecType
type PecType
Members
Member name | Value | Description
PEC_IGNORED | 0 | PEC is ignored
PEC_NA | 1 | PEC not available
PEC_ERROR | 2 | PEC checksum error
PEC_OK | 3 | PEC ok
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleIrdValue.TxRx Enumeration

FindRuleIrdValueTxRx Enumeration
Enumeration to specify the transfer direction.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum TxRx
Public Enumeration TxRx
public enum class TxRx
type TxRx
Members
Member name | Value | Description
TX | 0 | transmit
RX | 1 | receive
TX_RX | 2 | transmit or receive
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleMessage Class

FindRuleMessage Class
This class is used as base class for find rules on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
More...

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class FindRuleMessage
Public MustInherit Class FindRuleMessage
public ref class FindRuleMessage abstract
[<AbstractClassAttribute>]
type FindRuleMessage =  class end

The FindRuleMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleMessage | Initializes a new instance of the FindRuleMessage class
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindLogicContainerMessage
telos.I2cApi.DotNetFindRuleError
telos.I2cApi.DotNetFindRuleIdleTime
telos.I2cApi.DotNetFindRuleIrdRegister
telos.I2cApi.DotNetFindRuleIrdValue
telos.I2cApi.DotNetFindRuleMessageTime
telos.I2cApi.DotNetFindRuleSubMessageContainerAnyPos
telos.I2cApi.DotNetFindRuleSubMessageContainerWithPos
telos.I2cApi.DotNetFindRuleTestPin


FindRuleMessage Constructor

FindRuleMessage Constructor
Initializes a new instance of the FindRuleMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleMessage()
Public Sub New
public:
FindRuleMessage()
new : unit -> FindRuleMessage
See Also

Reference

FindRuleMessage Class


FindRuleMessage Methods

FindRuleMessage Methods

The FindRuleMessage type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindRuleMessage Class


FindRuleMessage.ByteArrayToString Method

FindRuleMessageByteArrayToString Method
Converts a byte array to a hexadecimal string.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected string ByteArrayToString(
    byte[] data
)
Protected Function ByteArrayToString (
    data As Byte()
) As String
protected:
String^ ByteArrayToString(
    array<unsigned char>^ data
)
member ByteArrayToString :
        data : byte[] -> string

Parameters

data
Type: SystemByte
byte array

Return Value

Type: String
hexadecimal string
See Also

Reference

FindRuleMessage Class


FindRuleMessageTime Class

FindRuleMessageTime Class
This class defines a find rule on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleMessageTime

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleMessageTime : FindRuleMessage,
    IEquatable<FindRuleMessageTime>
Public NotInheritable Class FindRuleMessageTime
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleMessageTime)
public ref class FindRuleMessageTime sealed : public FindRuleMessage,
    IEquatable<FindRuleMessageTime^>
[<SealedAttribute>]
type FindRuleMessageTime =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleMessageTime>
    end

The FindRuleMessageTime type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleMessageTime | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleMessageTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
Remarks
An I2C message matches this rule, if the time for the transmission of the message lies within the specified range.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleMessageTime Constructor

FindRuleMessageTime Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleMessageTime()
Public Sub New
public:
FindRuleMessageTime()
new : unit -> FindRuleMessageTime
See Also

Reference

FindRuleMessageTime Class


FindRuleMessageTime Methods

FindRuleMessageTime Methods

The FindRuleMessageTime type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleMessageTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleMessageTime Class


FindRuleMessageTime.Equals Method

FindRuleMessageTimeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleMessageTime) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleMessageTime Class


FindRuleMessageTime.Equals Method (Object)

FindRuleMessageTimeEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleMessageTime Class
Equals Overload


FindRuleMessageTime.Equals Method (FindRuleMessageTime)

FindRuleMessageTimeEquals Method (FindRuleMessageTime)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleMessageTime obj
)
Public Function Equals (
    obj As FindRuleMessageTime
) As Boolean
public:
virtual bool Equals(
    FindRuleMessageTime^ obj
) sealed
abstract Equals :
        obj : FindRuleMessageTime -> bool
override Equals :
        obj : FindRuleMessageTime -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleMessageTime
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleMessageTime Class
Equals Overload


FindRuleMessageTime.GetHashCode Method

FindRuleMessageTimeGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleMessageTime Class


FindRuleMessageTime.ToString Method

FindRuleMessageTimeToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleMessageTime Class


FindRuleMessageTime Properties

FindRuleMessageTime Properties

The FindRuleMessageTime type exposes the following members.

Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
See Also

Reference

FindRuleMessageTime Class


FindRuleMessageTime.MaximumTime Property

FindRuleMessageTimeMaximumTime Property
maximum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MaximumTime { get; set; }
Public Property MaximumTime As ULong
    Get
    Set
public:
property unsigned long long MaximumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MaximumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleMessageTime Class


FindRuleMessageTime.MinimumTime Property

FindRuleMessageTimeMinimumTime Property
minimum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MinimumTime { get; set; }
Public Property MinimumTime As ULong
    Get
    Set
public:
property unsigned long long MinimumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MinimumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleMessageTime Class


FindRuleSubMessage Class

FindRuleSubMessage Class
This class is used as base class for find rules on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
More...

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class FindRuleSubMessage
Public MustInherit Class FindRuleSubMessage
public ref class FindRuleSubMessage abstract
[<AbstractClassAttribute>]
type FindRuleSubMessage =  class end

The FindRuleSubMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleSubMessage | Initializes a new instance of the FindRuleSubMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindLogicContainerSubMessage
telos.I2cApi.DotNetFindRuleByteTime
telos.I2cApi.DotNetFindRuleData
telos.I2cApi.DotNetFindRuleDataAnyPos
telos.I2cApi.DotNetFindRuleDataLength
telos.I2cApi.DotNetFindRuleDataStatus
telos.I2cApi.DotNetFindRuleI2cAddress
telos.I2cApi.DotNetFindRuleI2cAddressStatus
telos.I2cApi.DotNetFindRuleSubMessageTime


FindRuleSubMessage Constructor

FindRuleSubMessage Constructor
Initializes a new instance of the FindRuleSubMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessage()
Public Sub New
public:
FindRuleSubMessage()
new : unit -> FindRuleSubMessage
See Also

Reference

FindRuleSubMessage Class


FindRuleSubMessage Methods

FindRuleSubMessage Methods

The FindRuleSubMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindRuleSubMessage Class


FindRuleSubMessageContainerAnyPos Class

FindRuleSubMessageContainerAnyPos Class
This class defines a find rule on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleSubMessageContainerAnyPos

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleSubMessageContainerAnyPos : FindRuleMessage,
    IEquatable<FindRuleSubMessageContainerAnyPos>
Public NotInheritable Class FindRuleSubMessageContainerAnyPos
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleSubMessageContainerAnyPos)
public ref class FindRuleSubMessageContainerAnyPos sealed : public FindRuleMessage,
    IEquatable<FindRuleSubMessageContainerAnyPos^>
[<SealedAttribute>]
type FindRuleSubMessageContainerAnyPos =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleSubMessageContainerAnyPos>
    end

The FindRuleSubMessageContainerAnyPos type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleSubMessageContainerAnyPos | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerAnyPos) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Direction | direction
Public property | SubMessage | find rule on sub message level
Top
Remarks
An I2C message matches this rule, if one of its sub messages matches the specified transfer direction and the find rule on sub message level.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleSubMessageContainerAnyPos Constructor

FindRuleSubMessageContainerAnyPos Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessageContainerAnyPos()
Public Sub New
public:
FindRuleSubMessageContainerAnyPos()
new : unit -> FindRuleSubMessageContainerAnyPos
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos Methods

FindRuleSubMessageContainerAnyPos Methods

The FindRuleSubMessageContainerAnyPos type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerAnyPos) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos.Equals Method

FindRuleSubMessageContainerAnyPosEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerAnyPos) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos.Equals Method (Object)

FindRuleSubMessageContainerAnyPosEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleSubMessageContainerAnyPos Class
Equals Overload


FindRuleSubMessageContainerAnyPos.Equals Method (FindRuleSubMessageContainerAnyPos)

FindRuleSubMessageContainerAnyPosEquals Method (FindRuleSubMessageContainerAnyPos)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleSubMessageContainerAnyPos obj
)
Public Function Equals (
    obj As FindRuleSubMessageContainerAnyPos
) As Boolean
public:
virtual bool Equals(
    FindRuleSubMessageContainerAnyPos^ obj
) sealed
abstract Equals :
        obj : FindRuleSubMessageContainerAnyPos -> bool
override Equals :
        obj : FindRuleSubMessageContainerAnyPos -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleSubMessageContainerAnyPos
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleSubMessageContainerAnyPos Class
Equals Overload


FindRuleSubMessageContainerAnyPos.GetHashCode Method

FindRuleSubMessageContainerAnyPosGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos.ToString Method

FindRuleSubMessageContainerAnyPosToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos Properties

FindRuleSubMessageContainerAnyPos Properties

The FindRuleSubMessageContainerAnyPos type exposes the following members.

Properties
 | Name | Description
Public property | Direction | direction
Public property | SubMessage | find rule on sub message level
Top
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos.Direction Property

FindRuleSubMessageContainerAnyPosDirection Property
direction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessageContainerAnyPosTxRx Direction { get; set; }
Public Property Direction As FindRuleSubMessageContainerAnyPosTxRx
    Get
    Set
public:
property FindRuleSubMessageContainerAnyPosTxRx Direction {
    FindRuleSubMessageContainerAnyPosTxRx get ();
    void set (FindRuleSubMessageContainerAnyPosTxRx value);
}
member Direction : FindRuleSubMessageContainerAnyPosTxRx with get, set

Property Value

Type: FindRuleSubMessageContainerAnyPosTxRx
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos.SubMessage Property

FindRuleSubMessageContainerAnyPosSubMessage Property
find rule on sub message level

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessage SubMessage { get; set; }
Public Property SubMessage As FindRuleSubMessage
    Get
    Set
public:
property FindRuleSubMessage^ SubMessage {
    FindRuleSubMessage^ get ();
    void set (FindRuleSubMessage^ value);
}
member SubMessage : FindRuleSubMessage with get, set

Property Value

Type: FindRuleSubMessage
See Also

Reference

FindRuleSubMessageContainerAnyPos Class


FindRuleSubMessageContainerAnyPos.TxRx Enumeration

FindRuleSubMessageContainerAnyPosTxRx Enumeration
Enumeration to specify the transfer direction.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum TxRx
Public Enumeration TxRx
public enum class TxRx
type TxRx
Members
Member name | Value | Description
TX | 0 | transmit
RX | 1 | receive
TX_RX | 2 | transmit or receive
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleSubMessageContainerWithPos Class

FindRuleSubMessageContainerWithPos Class
This class defines a find rule on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleSubMessageContainerWithPos

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleSubMessageContainerWithPos : FindRuleMessage,
    IEquatable<FindRuleSubMessageContainerWithPos>
Public NotInheritable Class FindRuleSubMessageContainerWithPos
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleSubMessageContainerWithPos)
public ref class FindRuleSubMessageContainerWithPos sealed : public FindRuleMessage,
    IEquatable<FindRuleSubMessageContainerWithPos^>
[<SealedAttribute>]
type FindRuleSubMessageContainerWithPos =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleSubMessageContainerWithPos>
    end

The FindRuleSubMessageContainerWithPos type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleSubMessageContainerWithPos | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerWithPos) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | SubMessages | sub message rules
Top
Remarks
An I2C message matches this rule, if the sub messages at the specified positions match the specified transfer directions and find rules on sub message level.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleSubMessageContainerWithPos Constructor

FindRuleSubMessageContainerWithPos Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessageContainerWithPos()
Public Sub New
public:
FindRuleSubMessageContainerWithPos()
new : unit -> FindRuleSubMessageContainerWithPos
See Also

Reference

FindRuleSubMessageContainerWithPos Class


FindRuleSubMessageContainerWithPos Methods

FindRuleSubMessageContainerWithPos Methods

The FindRuleSubMessageContainerWithPos type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerWithPos) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleSubMessageContainerWithPos Class


FindRuleSubMessageContainerWithPos.Equals Method

FindRuleSubMessageContainerWithPosEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerWithPos) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleSubMessageContainerWithPos Class


FindRuleSubMessageContainerWithPos.Equals Method (Object)

FindRuleSubMessageContainerWithPosEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleSubMessageContainerWithPos Class
Equals Overload


FindRuleSubMessageContainerWithPos.Equals Method (FindRuleSubMessageContainerWithPos)

FindRuleSubMessageContainerWithPosEquals Method (FindRuleSubMessageContainerWithPos)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleSubMessageContainerWithPos obj
)
Public Function Equals (
    obj As FindRuleSubMessageContainerWithPos
) As Boolean
public:
virtual bool Equals(
    FindRuleSubMessageContainerWithPos^ obj
) sealed
abstract Equals :
        obj : FindRuleSubMessageContainerWithPos -> bool
override Equals :
        obj : FindRuleSubMessageContainerWithPos -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleSubMessageContainerWithPos
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleSubMessageContainerWithPos Class
Equals Overload


FindRuleSubMessageContainerWithPos.GetHashCode Method

FindRuleSubMessageContainerWithPosGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleSubMessageContainerWithPos Class


FindRuleSubMessageContainerWithPos.ToString Method

FindRuleSubMessageContainerWithPosToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleSubMessageContainerWithPos Class


FindRuleSubMessageContainerWithPos Properties

FindRuleSubMessageContainerWithPos Properties

The FindRuleSubMessageContainerWithPos type exposes the following members.

Properties
 | Name | Description
Public property | SubMessages | sub message rules
Top
See Also

Reference

FindRuleSubMessageContainerWithPos Class


FindRuleSubMessageContainerWithPos.SubMessages Property

FindRuleSubMessageContainerWithPosSubMessages Property
sub message rules

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<FindRuleSubMessageContainerWithPosSubMessage> SubMessages { get; set; }
Public Property SubMessages As List(Of FindRuleSubMessageContainerWithPosSubMessage)
    Get
    Set
public:
property List<FindRuleSubMessageContainerWithPosSubMessage^>^ SubMessages {
    List<FindRuleSubMessageContainerWithPosSubMessage^>^ get ();
    void set (List<FindRuleSubMessageContainerWithPosSubMessage^>^ value);
}
member SubMessages : List<FindRuleSubMessageContainerWithPosSubMessage> with get, set

Property Value

Type: List FindRuleSubMessageContainerWithPosSubMessage
See Also

Reference

FindRuleSubMessageContainerWithPos Class


FindRuleSubMessageContainerWithPos.SubMessage Class

FindRuleSubMessageContainerWithPosSubMessage Class
Stores all needed information for one sub message rule.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessageContainerWithPosSubMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SubMessage : IEquatable<FindRuleSubMessageContainerWithPosSubMessage>
Public NotInheritable Class SubMessage
    Implements IEquatable(Of FindRuleSubMessageContainerWithPosSubMessage)
public ref class SubMessage sealed : IEquatable<FindRuleSubMessageContainerWithPosSubMessage^>
[<SealedAttribute>]
type SubMessage =
    class
        interface IEquatable<FindRuleSubMessageContainerWithPosSubMessage>
    end

The FindRuleSubMessageContainerWithPosSubMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleSubMessageContainerWithPosSubMessage | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerWithPosSubMessage) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | direction
Public property | Position | position within the message
Public property | Rule | find rule on sub message level
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleSubMessageContainerWithPos.SubMessage Constructor

FindRuleSubMessageContainerWithPosSubMessage Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SubMessage()
Public Sub New
public:
SubMessage()
new : unit -> SubMessage
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


SubMessage Methods

SubMessage Methods

The FindRuleSubMessageContainerWithPosSubMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerWithPosSubMessage) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


SubMessage.Equals Method

SubMessageEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageContainerWithPosSubMessage) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


FindRuleSubMessageContainerWithPos.SubMessage.Equals Method (Object)

FindRuleSubMessageContainerWithPosSubMessageEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class
Equals Overload


FindRuleSubMessageContainerWithPos.SubMessage.Equals Method (FindRuleSubMessageContainerWithPos.SubMessage)

FindRuleSubMessageContainerWithPosSubMessageEquals Method (FindRuleSubMessageContainerWithPosSubMessage)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleSubMessageContainerWithPosSubMessage obj
)
Public Function Equals (
    obj As FindRuleSubMessageContainerWithPosSubMessage
) As Boolean
public:
virtual bool Equals(
    FindRuleSubMessageContainerWithPosSubMessage^ obj
) sealed
abstract Equals :
        obj : FindRuleSubMessageContainerWithPosSubMessage -> bool
override Equals :
        obj : FindRuleSubMessageContainerWithPosSubMessage -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleSubMessageContainerWithPosSubMessage
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class
Equals Overload


FindRuleSubMessageContainerWithPos.SubMessage.GetHashCode Method

FindRuleSubMessageContainerWithPosSubMessageGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


SubMessage Properties

SubMessage Properties

The FindRuleSubMessageContainerWithPosSubMessage type exposes the following members.

Properties
 | Name | Description
Public property | Direction | direction
Public property | Position | position within the message
Public property | Rule | find rule on sub message level
Top
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


FindRuleSubMessageContainerWithPos.SubMessage.Direction Property

FindRuleSubMessageContainerWithPosSubMessageDirection Property
direction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessageContainerWithPosSubMessageTxRx Direction { get; set; }
Public Property Direction As FindRuleSubMessageContainerWithPosSubMessageTxRx
    Get
    Set
public:
property FindRuleSubMessageContainerWithPosSubMessageTxRx Direction {
    FindRuleSubMessageContainerWithPosSubMessageTxRx get ();
    void set (FindRuleSubMessageContainerWithPosSubMessageTxRx value);
}
member Direction : FindRuleSubMessageContainerWithPosSubMessageTxRx with get, set

Property Value

Type: FindRuleSubMessageContainerWithPosSubMessageTxRx
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


FindRuleSubMessageContainerWithPos.SubMessage.Position Property

FindRuleSubMessageContainerWithPosSubMessagePosition Property
position within the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Position { get; set; }
Public Property Position As Integer
    Get
    Set
public:
property int Position {
    int get ();
    void set (int value);
}
member Position : int with get, set

Property Value

Type: Int32
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


FindRuleSubMessageContainerWithPos.SubMessage.Rule Property

FindRuleSubMessageContainerWithPosSubMessageRule Property
find rule on sub message level

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessage Rule { get; set; }
Public Property Rule As FindRuleSubMessage
    Get
    Set
public:
property FindRuleSubMessage^ Rule {
    FindRuleSubMessage^ get ();
    void set (FindRuleSubMessage^ value);
}
member Rule : FindRuleSubMessage with get, set

Property Value

Type: FindRuleSubMessage
See Also

Reference

FindRuleSubMessageContainerWithPosSubMessage Class


FindRuleSubMessageContainerWithPos.SubMessage.TxRx Enumeration

FindRuleSubMessageContainerWithPosSubMessageTxRx Enumeration
Enumeration to specify the transfer direction.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum TxRx
Public Enumeration TxRx
public enum class TxRx
type TxRx
Members
Member name | Value | Description
TX | 0 | transmit
RX | 1 | receive
TX_RX | 2 | transmit or receive
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleSubMessageTime Class

FindRuleSubMessageTime Class
This class defines a find rule on sub message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleSubMessage
telos.I2cApi.DotNetFindRuleSubMessageTime

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleSubMessageTime : FindRuleSubMessage,
    IEquatable<FindRuleSubMessageTime>
Public NotInheritable Class FindRuleSubMessageTime
    Inherits FindRuleSubMessage
    Implements IEquatable(Of FindRuleSubMessageTime)
public ref class FindRuleSubMessageTime sealed : public FindRuleSubMessage,
    IEquatable<FindRuleSubMessageTime^>
[<SealedAttribute>]
type FindRuleSubMessageTime =
    class
        inherit FindRuleSubMessage
        interface IEquatable<FindRuleSubMessageTime>
    end

The FindRuleSubMessageTime type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleSubMessageTime | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
Remarks
An I2C sub message matches this rule, if the time for the transmission of the sub message lies within the specified range.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleSubMessageTime Constructor

FindRuleSubMessageTime Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleSubMessageTime()
Public Sub New
public:
FindRuleSubMessageTime()
new : unit -> FindRuleSubMessageTime
See Also

Reference

FindRuleSubMessageTime Class


FindRuleSubMessageTime Methods

FindRuleSubMessageTime Methods

The FindRuleSubMessageTime type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageTime) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleSubMessageTime Class


FindRuleSubMessageTime.Equals Method

FindRuleSubMessageTimeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleSubMessageTime) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleSubMessageTime Class


FindRuleSubMessageTime.Equals Method (Object)

FindRuleSubMessageTimeEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleSubMessageTime Class
Equals Overload


FindRuleSubMessageTime.Equals Method (FindRuleSubMessageTime)

FindRuleSubMessageTimeEquals Method (FindRuleSubMessageTime)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleSubMessageTime obj
)
Public Function Equals (
    obj As FindRuleSubMessageTime
) As Boolean
public:
virtual bool Equals(
    FindRuleSubMessageTime^ obj
) sealed
abstract Equals :
        obj : FindRuleSubMessageTime -> bool
override Equals :
        obj : FindRuleSubMessageTime -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleSubMessageTime
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleSubMessageTime Class
Equals Overload


FindRuleSubMessageTime.GetHashCode Method

FindRuleSubMessageTimeGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleSubMessageTime Class


FindRuleSubMessageTime.ToString Method

FindRuleSubMessageTimeToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleSubMessageTime Class


FindRuleSubMessageTime Properties

FindRuleSubMessageTime Properties

The FindRuleSubMessageTime type exposes the following members.

Properties
 | Name | Description
Public property | MaximumTime | maximum time [timestamp]
Public property | MinimumTime | minimum time [timestamp]
Top
See Also

Reference

FindRuleSubMessageTime Class


FindRuleSubMessageTime.MaximumTime Property

FindRuleSubMessageTimeMaximumTime Property
maximum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MaximumTime { get; set; }
Public Property MaximumTime As ULong
    Get
    Set
public:
property unsigned long long MaximumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MaximumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleSubMessageTime Class


FindRuleSubMessageTime.MinimumTime Property

FindRuleSubMessageTimeMinimumTime Property
minimum time [timestamp]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MinimumTime { get; set; }
Public Property MinimumTime As ULong
    Get
    Set
public:
property unsigned long long MinimumTime {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MinimumTime : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

FindRuleSubMessageTime Class


FindRuleTestPin Class

FindRuleTestPin Class
This class defines a find rule on message level.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindRuleMessage
telos.I2cApi.DotNetFindRuleTestPin

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindRuleTestPin : FindRuleMessage,
    IEquatable<FindRuleTestPin>
Public NotInheritable Class FindRuleTestPin
    Inherits FindRuleMessage
    Implements IEquatable(Of FindRuleTestPin)
public ref class FindRuleTestPin sealed : public FindRuleMessage,
    IEquatable<FindRuleTestPin^>
[<SealedAttribute>]
type FindRuleTestPin =
    class
        inherit FindRuleMessage
        interface IEquatable<FindRuleTestPin>
    end

The FindRuleTestPin type exposes the following members.

Constructors
 | Name | Description
Public method | FindRuleTestPin | Constructor.
Top
Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleTestPin) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | TestPin | index of the input testpin
Public property | TestPinState | state the rule will match
Top
Remarks
An I2C message matches this rule, if in parallel to the I2C message the specified condition is satisfied by one of the input testpins.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindRuleTestPin Constructor

FindRuleTestPin Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleTestPin()
Public Sub New
public:
FindRuleTestPin()
new : unit -> FindRuleTestPin
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin Methods

FindRuleTestPin Methods

The FindRuleTestPin type exposes the following members.

Methods
 | Name | Description
Protected method | ByteArrayToString | Converts a byte array to a hexadecimal string. (Inherited from FindRuleMessage.)
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleTestPin) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin.Equals Method

FindRuleTestPinEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindRuleTestPin) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin.Equals Method (Object)

FindRuleTestPinEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindRuleTestPin Class
Equals Overload


FindRuleTestPin.Equals Method (FindRuleTestPin)

FindRuleTestPinEquals Method (FindRuleTestPin)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindRuleTestPin obj
)
Public Function Equals (
    obj As FindRuleTestPin
) As Boolean
public:
virtual bool Equals(
    FindRuleTestPin^ obj
) sealed
abstract Equals :
        obj : FindRuleTestPin -> bool
override Equals :
        obj : FindRuleTestPin -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindRuleTestPin
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindRuleTestPin Class
Equals Overload


FindRuleTestPin.GetHashCode Method

FindRuleTestPinGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin.ToString Method

FindRuleTestPinToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin Properties

FindRuleTestPin Properties

The FindRuleTestPin type exposes the following members.

Properties
 | Name | Description
Public property | TestPin | index of the input testpin
Public property | TestPinState | state the rule will match
Top
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin.TestPin Property

FindRuleTestPinTestPin Property
index of the input testpin

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int TestPin { get; set; }
Public Property TestPin As Integer
    Get
    Set
public:
property int TestPin {
    int get ();
    void set (int value);
}
member TestPin : int with get, set

Property Value

Type: Int32
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin.TestPinState Property

FindRuleTestPinTestPinState Property
state the rule will match

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindRuleTestPinState TestPinState { get; set; }
Public Property TestPinState As FindRuleTestPinState
    Get
    Set
public:
property FindRuleTestPinState TestPinState {
    FindRuleTestPinState get ();
    void set (FindRuleTestPinState value);
}
member TestPinState : FindRuleTestPinState with get, set

Property Value

Type: FindRuleTestPinState
See Also

Reference

FindRuleTestPin Class


FindRuleTestPin.State Enumeration

FindRuleTestPinState Enumeration
Enumeration to specify whether the rule matches an edge or a level.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum State
Public Enumeration State
public enum class State
type State
Members
Member name | Value | Description
RISING_EDGE | 0 | rising edge
FALLING_EDGE | 1 | falling edge
HIGH_LEVEL | 2 | high level
LOW_LEVEL | 3 | low level
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindSequence Class

FindSequence Class
This container can be used to store a number of find rules on message level, which get applied one after the other. After the last rule matches, the complete find sequence matches.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetFindSequence

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class FindSequence : IEquatable<FindSequence>
Public NotInheritable Class FindSequence
    Implements IEquatable(Of FindSequence)
public ref class FindSequence sealed : IEquatable<FindSequence^>
[<SealedAttribute>]
type FindSequence =
    class
        interface IEquatable<FindSequence>
    end

The FindSequence type exposes the following members.

Constructors
 | Name | Description
Public method | FindSequence | Constructor.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindSequence) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Messages | message rules
Top
Remarks

This class is used by the class TraceDataFind.

The Find(Int32, TraceDataFindDirection) method of TraceDataFind will use the first rule for the first match. Starting from the message, which matches the first rule, Find(Int32, TraceDataFindDirection) applies the second rule and so on.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


FindSequence Constructor

FindSequence Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindSequence()
Public Sub New
public:
FindSequence()
new : unit -> FindSequence
See Also

Reference

FindSequence Class


FindSequence Methods

FindSequence Methods

The FindSequence type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindSequence) | Determines whether this instance contains the same data as the other instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a string representation of the rule. (Overrides ObjectToString.)
Top
See Also

Reference

FindSequence Class


FindSequence.Equals Method

FindSequenceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether this instance contains the same data as the other instance. (Overrides ObjectEquals(Object).)
Public method | Equals(FindSequence) | Determines whether this instance contains the same data as the other instance.
Top
See Also

Reference

FindSequence Class


FindSequence.Equals Method (Object)

FindSequenceEquals Method (Object)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other instance

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

FindSequence Class
Equals Overload


FindSequence.Equals Method (FindSequence)

FindSequenceEquals Method (FindSequence)
Determines whether this instance contains the same data as the other instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    FindSequence obj
)
Public Function Equals (
    obj As FindSequence
) As Boolean
public:
virtual bool Equals(
    FindSequence^ obj
) sealed
abstract Equals :
        obj : FindSequence -> bool
override Equals :
        obj : FindSequence -> bool

Parameters

obj
Type: telos.I2cApi.DotNetFindSequence
other instance

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

FindSequence Class
Equals Overload


FindSequence.GetHashCode Method

FindSequenceGetHashCode Method
Returns the hash code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

FindSequence Class


FindSequence.ToString Method

FindSequenceToString Method
Creates a string representation of the rule.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

FindSequence Class


FindSequence Properties

FindSequence Properties

The FindSequence type exposes the following members.

Properties
 | Name | Description
Public property | Messages | message rules
Top
See Also

Reference

FindSequence Class


FindSequence.Messages Property

FindSequenceMessages Property
message rules

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<FindRuleMessage> Messages { get; set; }
Public Property Messages As List(Of FindRuleMessage)
    Get
    Set
public:
property List<FindRuleMessage^>^ Messages {
    List<FindRuleMessage^>^ get ();
    void set (List<FindRuleMessage^>^ value);
}
member Messages : List<FindRuleMessage> with get, set

Property Value

Type: List FindRuleMessage
See Also

Reference

FindSequence Class


HardwareInfo Class

HardwareInfo Class
This class is used to store information about an I2C interface. E.g. it can be used to get information about the type of the interface and the available features. The properties HardwareInfoOfOpenBoard and ListOfBoards are using objects of this type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetHardwareInfo

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class HardwareInfo : ICloneable
Public NotInheritable Class HardwareInfo
    Implements ICloneable
public ref class HardwareInfo sealed : ICloneable
[<SealedAttribute>]
type HardwareInfo =
    class
        interface ICloneable
    end

The HardwareInfo type exposes the following members.

Constructors
 | Name | Description
Public method | HardwareInfo | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoardTypeAsString | Converts a BoardType value into a human readable string describing the type of I2C interface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Adc | A/D converter available
Public property | AdcMaxPretrigger | A/D converter: maximum allowed pretrigger
Public property | AdcSamplingDepth | A/D converter: sampling depth
Public property | AdcSamplingrate | possible sampling rates for the A/D converter
Public property | AdcTriggerAck | A/D converter: ACK condition can be used as trigger event
Public property | AdcTriggerData | A/D converter: number of data bytes, which be can used as trigger event
Public property | AdcTriggerError | A/D converter: ERROR condition can be used as trigger event
Public property | AdcTriggerImmediately | A/D converter: can be started immediately without trigger event
Public property | AdcTriggerMsgCnt | A/D converter: message count can be used as trigger event
Public property | AdcTriggerNack | A/D converter: NACK condition can be used as trigger event
Public property | AdcTriggerStart | A/D converter: START condition can be used as trigger event
Public property | AdcTriggerStop | A/D converter: STOP condition can be used as trigger event
Public property | AdcTriggerTestpin1 | A/D converter: testpin 1 can be used as trigger event
Public property | AdcTriggerTestpin2 | A/D converter: testpin 2 can be used as trigger event
Public property | AdcVcc | voltage of the A/D value "255" (e.g. 5,5E3 mV) or N/A (MaxValue)
Public property | BoardType | type of the I2C interface
Public property | BusTypeSmb | can be used with a SMBus?
Public property | DemoLicense | demo license: all features can be used?
Public property | DnsName | DNS name of the I2C scheduler responsible for this I2C interface
Public property | HighLevelThreshold | possible values for the high level threshold
Public property | I2cVccSupply | possible values for the I2C Vcc supply voltage
Public property | InternalSerialNumber | internal serial number
Public property | IpAddress | IP address of the I2C scheduler responsible for this I2C interface
Public property | IpPort | TCP/IP port of the I2C scheduler responsible for this I2C interface
Public property | Ld | license data
Public property | LowLevelThreshold | possible values for the low level threshold
Public property | Master | can be used as master
Public property | MasterMaxRx | master: maximum number of bytes which can be received in one I2C message
Public property | MasterSamplingRate | master: possible values for the bitrate
Public property | MasterSamplingRateHs | master: possible values for the high speed bitrate
Public property | NegativeTester | negative tester available?
Public property | Port | name of the port (e.g. "USB" or "LPT1")
Public property | RequiredServiceContract | required expiration date of service contract
Public property | RequiredVersions | required versions
Public property | SerialNumber | serial number
Public property | ServiceContract | expiration dates of service contract
Public property | SoftwareLicenses | software that can be used
Public property | Termination | possible values for the SDA/SCL termination
Public property | TestpinAck | ACK condition can trigger testpin (out)
Public property | TestpinError | ERROR condition can trigger testpin (out)
Public property | TestpinNack | NACK condition can trigger testpin (out)
Public property | TestpinsIn | number of input testpins
Public property | TestpinsOut | number of output testpins
Public property | TestpinStart | START condition can trigger testpin (out)
Public property | TestpinStop | STOP condition can trigger testpin (out)
Public property | TimestampTimebase | timebase of the timestamps (e.g 3E6 Hz) or N/A (MaxValue)
Public property | Tracer | can be used as tracer
Public property | Versions | versions
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


HardwareInfo Constructor

HardwareInfo Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public HardwareInfo()
Public Sub New
public:
HardwareInfo()
new : unit -> HardwareInfo
See Also

Reference

HardwareInfo Class


HardwareInfo Methods

HardwareInfo Methods

The HardwareInfo type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoardTypeAsString | Converts a BoardType value into a human readable string describing the type of I2C interface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HardwareInfo Class


HardwareInfo.Clone Method

HardwareInfoClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

HardwareInfo Class


HardwareInfo.GetBoardTypeAsString Method

HardwareInfoGetBoardTypeAsString Method
Converts a BoardType value into a human readable string describing the type of I2C interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static string GetBoardTypeAsString(
    BoardType board_type
)
Public Shared Function GetBoardTypeAsString (
    board_type As BoardType
) As String
public:
static String^ GetBoardTypeAsString(
    BoardType board_type
)
static member GetBoardTypeAsString :
        board_type : BoardType -> string

Parameters

board_type
Type: telos.I2cApi.DotNetBoardType
type of the I2C interface

Return Value

Type: String
type of the I2C interface as string
See Also

Reference

HardwareInfo Class


HardwareInfo Properties

HardwareInfo Properties

The HardwareInfo type exposes the following members.

Properties
 | Name | Description
Public property | Adc | A/D converter available
Public property | AdcMaxPretrigger | A/D converter: maximum allowed pretrigger
Public property | AdcSamplingDepth | A/D converter: sampling depth
Public property | AdcSamplingrate | possible sampling rates for the A/D converter
Public property | AdcTriggerAck | A/D converter: ACK condition can be used as trigger event
Public property | AdcTriggerData | A/D converter: number of data bytes, which be can used as trigger event
Public property | AdcTriggerError | A/D converter: ERROR condition can be used as trigger event
Public property | AdcTriggerImmediately | A/D converter: can be started immediately without trigger event
Public property | AdcTriggerMsgCnt | A/D converter: message count can be used as trigger event
Public property | AdcTriggerNack | A/D converter: NACK condition can be used as trigger event
Public property | AdcTriggerStart | A/D converter: START condition can be used as trigger event
Public property | AdcTriggerStop | A/D converter: STOP condition can be used as trigger event
Public property | AdcTriggerTestpin1 | A/D converter: testpin 1 can be used as trigger event
Public property | AdcTriggerTestpin2 | A/D converter: testpin 2 can be used as trigger event
Public property | AdcVcc | voltage of the A/D value "255" (e.g. 5,5E3 mV) or N/A (MaxValue)
Public property | BoardType | type of the I2C interface
Public property | BusTypeSmb | can be used with a SMBus?
Public property | DemoLicense | demo license: all features can be used?
Public property | DnsName | DNS name of the I2C scheduler responsible for this I2C interface
Public property | HighLevelThreshold | possible values for the high level threshold
Public property | I2cVccSupply | possible values for the I2C Vcc supply voltage
Public property | InternalSerialNumber | internal serial number
Public property | IpAddress | IP address of the I2C scheduler responsible for this I2C interface
Public property | IpPort | TCP/IP port of the I2C scheduler responsible for this I2C interface
Public property | Ld | license data
Public property | LowLevelThreshold | possible values for the low level threshold
Public property | Master | can be used as master
Public property | MasterMaxRx | master: maximum number of bytes which can be received in one I2C message
Public property | MasterSamplingRate | master: possible values for the bitrate
Public property | MasterSamplingRateHs | master: possible values for the high speed bitrate
Public property | NegativeTester | negative tester available?
Public property | Port | name of the port (e.g. "USB" or "LPT1")
Public property | RequiredServiceContract | required expiration date of service contract
Public property | RequiredVersions | required versions
Public property | SerialNumber | serial number
Public property | ServiceContract | expiration dates of service contract
Public property | SoftwareLicenses | software that can be used
Public property | Termination | possible values for the SDA/SCL termination
Public property | TestpinAck | ACK condition can trigger testpin (out)
Public property | TestpinError | ERROR condition can trigger testpin (out)
Public property | TestpinNack | NACK condition can trigger testpin (out)
Public property | TestpinsIn | number of input testpins
Public property | TestpinsOut | number of output testpins
Public property | TestpinStart | START condition can trigger testpin (out)
Public property | TestpinStop | STOP condition can trigger testpin (out)
Public property | TimestampTimebase | timebase of the timestamps (e.g 3E6 Hz) or N/A (MaxValue)
Public property | Tracer | can be used as tracer
Public property | Versions | versions
Top
See Also

Reference

HardwareInfo Class


HardwareInfo.Adc Property

HardwareInfoAdc Property
A/D converter available

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Adc { get; set; }
Public Property Adc As Boolean
    Get
    Set
public:
property bool Adc {
    bool get ();
    void set (bool value);
}
member Adc : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcMaxPretrigger Property

HardwareInfoAdcMaxPretrigger Property
A/D converter: maximum allowed pretrigger

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint AdcMaxPretrigger { get; set; }
Public Property AdcMaxPretrigger As UInteger
    Get
    Set
public:
property unsigned int AdcMaxPretrigger {
    unsigned int get ();
    void set (unsigned int value);
}
member AdcMaxPretrigger : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcSamplingDepth Property

HardwareInfoAdcSamplingDepth Property
A/D converter: sampling depth

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint AdcSamplingDepth { get; set; }
Public Property AdcSamplingDepth As UInteger
    Get
    Set
public:
property unsigned int AdcSamplingDepth {
    unsigned int get ();
    void set (unsigned int value);
}
member AdcSamplingDepth : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcSamplingrate Property

HardwareInfoAdcSamplingrate Property
possible sampling rates for the A/D converter

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint[] AdcSamplingrate { get; set; }
Public Property AdcSamplingrate As UInteger()
    Get
    Set
public:
property array<unsigned int>^ AdcSamplingrate {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}
member AdcSamplingrate : uint32[] with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerAck Property

HardwareInfoAdcTriggerAck Property
A/D converter: ACK condition can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerAck { get; set; }
Public Property AdcTriggerAck As Boolean
    Get
    Set
public:
property bool AdcTriggerAck {
    bool get ();
    void set (bool value);
}
member AdcTriggerAck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerData Property

HardwareInfoAdcTriggerData Property
A/D converter: number of data bytes, which be can used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte AdcTriggerData { get; set; }
Public Property AdcTriggerData As Byte
    Get
    Set
public:
property unsigned char AdcTriggerData {
    unsigned char get ();
    void set (unsigned char value);
}
member AdcTriggerData : byte with get, set

Property Value

Type: Byte
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerError Property

HardwareInfoAdcTriggerError Property
A/D converter: ERROR condition can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerError { get; set; }
Public Property AdcTriggerError As Boolean
    Get
    Set
public:
property bool AdcTriggerError {
    bool get ();
    void set (bool value);
}
member AdcTriggerError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerImmediately Property

HardwareInfoAdcTriggerImmediately Property
A/D converter: can be started immediately without trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerImmediately { get; set; }
Public Property AdcTriggerImmediately As Boolean
    Get
    Set
public:
property bool AdcTriggerImmediately {
    bool get ();
    void set (bool value);
}
member AdcTriggerImmediately : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerMsgCnt Property

HardwareInfoAdcTriggerMsgCnt Property
A/D converter: message count can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerMsgCnt { get; set; }
Public Property AdcTriggerMsgCnt As Boolean
    Get
    Set
public:
property bool AdcTriggerMsgCnt {
    bool get ();
    void set (bool value);
}
member AdcTriggerMsgCnt : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerNack Property

HardwareInfoAdcTriggerNack Property
A/D converter: NACK condition can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerNack { get; set; }
Public Property AdcTriggerNack As Boolean
    Get
    Set
public:
property bool AdcTriggerNack {
    bool get ();
    void set (bool value);
}
member AdcTriggerNack : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerStart Property

HardwareInfoAdcTriggerStart Property
A/D converter: START condition can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerStart { get; set; }
Public Property AdcTriggerStart As Boolean
    Get
    Set
public:
property bool AdcTriggerStart {
    bool get ();
    void set (bool value);
}
member AdcTriggerStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerStop Property

HardwareInfoAdcTriggerStop Property
A/D converter: STOP condition can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerStop { get; set; }
Public Property AdcTriggerStop As Boolean
    Get
    Set
public:
property bool AdcTriggerStop {
    bool get ();
    void set (bool value);
}
member AdcTriggerStop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerTestpin1 Property

HardwareInfoAdcTriggerTestpin1 Property
A/D converter: testpin 1 can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerTestpin1 { get; set; }
Public Property AdcTriggerTestpin1 As Boolean
    Get
    Set
public:
property bool AdcTriggerTestpin1 {
    bool get ();
    void set (bool value);
}
member AdcTriggerTestpin1 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcTriggerTestpin2 Property

HardwareInfoAdcTriggerTestpin2 Property
A/D converter: testpin 2 can be used as trigger event

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AdcTriggerTestpin2 { get; set; }
Public Property AdcTriggerTestpin2 As Boolean
    Get
    Set
public:
property bool AdcTriggerTestpin2 {
    bool get ();
    void set (bool value);
}
member AdcTriggerTestpin2 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.AdcVcc Property

HardwareInfoAdcVcc Property
voltage of the A/D value "255" (e.g. 5,5E3 mV) or N/A (MaxValue)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort AdcVcc { get; set; }
Public Property AdcVcc As UShort
    Get
    Set
public:
property unsigned short AdcVcc {
    unsigned short get ();
    void set (unsigned short value);
}
member AdcVcc : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareInfo Class


HardwareInfo.BoardType Property

HardwareInfoBoardType Property
type of the I2C interface

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public BoardType BoardType { get; set; }
Public Property BoardType As BoardType
    Get
    Set
public:
property BoardType BoardType {
    BoardType get ();
    void set (BoardType value);
}
member BoardType : BoardType with get, set

Property Value

Type: BoardType
See Also

Reference

HardwareInfo Class


HardwareInfo.BusTypeSmb Property

HardwareInfoBusTypeSmb Property
can be used with a SMBus?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool BusTypeSmb { get; set; }
Public Property BusTypeSmb As Boolean
    Get
    Set
public:
property bool BusTypeSmb {
    bool get ();
    void set (bool value);
}
member BusTypeSmb : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.DemoLicense Property

HardwareInfoDemoLicense Property
demo license: all features can be used?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DemoLicense { get; set; }
Public Property DemoLicense As Boolean
    Get
    Set
public:
property bool DemoLicense {
    bool get ();
    void set (bool value);
}
member DemoLicense : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.DnsName Property

HardwareInfoDnsName Property
DNS name of the I2C scheduler responsible for this I2C interface

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string DnsName { get; set; }
Public Property DnsName As String
    Get
    Set
public:
property String^ DnsName {
    String^ get ();
    void set (String^ value);
}
member DnsName : string with get, set

Property Value

Type: String
See Also

Reference

HardwareInfo Class


HardwareInfo.HighLevelThreshold Property

HardwareInfoHighLevelThreshold Property
possible values for the high level threshold

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] HighLevelThreshold { get; set; }
Public Property HighLevelThreshold As Byte()
    Get
    Set
public:
property array<unsigned char>^ HighLevelThreshold {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member HighLevelThreshold : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

HardwareInfo Class


HardwareInfo.I2cVccSupply Property

HardwareInfoI2cVccSupply Property
possible values for the I2C Vcc supply voltage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort[] I2cVccSupply { get; set; }
Public Property I2cVccSupply As UShort()
    Get
    Set
public:
property array<unsigned short>^ I2cVccSupply {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}
member I2cVccSupply : uint16[] with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareInfo Class


HardwareInfo.InternalSerialNumber Property

HardwareInfoInternalSerialNumber Property
internal serial number

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong InternalSerialNumber { get; set; }
Public Property InternalSerialNumber As ULong
    Get
    Set
public:
property unsigned long long InternalSerialNumber {
    unsigned long long get ();
    void set (unsigned long long value);
}
member InternalSerialNumber : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

HardwareInfo Class


HardwareInfo.IpAddress Property

HardwareInfoIpAddress Property
IP address of the I2C scheduler responsible for this I2C interface

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IPAddress IpAddress { get; set; }
Public Property IpAddress As IPAddress
    Get
    Set
public:
property IPAddress^ IpAddress {
    IPAddress^ get ();
    void set (IPAddress^ value);
}
member IpAddress : IPAddress with get, set

Property Value

Type: IPAddress
See Also

Reference

HardwareInfo Class


HardwareInfo.IpPort Property

HardwareInfoIpPort Property
TCP/IP port of the I2C scheduler responsible for this I2C interface

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort IpPort { get; set; }
Public Property IpPort As UShort
    Get
    Set
public:
property unsigned short IpPort {
    unsigned short get ();
    void set (unsigned short value);
}
member IpPort : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareInfo Class


HardwareInfo.Ld Property

HardwareInfoLd Property
license data

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort[] Ld { get; set; }
Public Property Ld As UShort()
    Get
    Set
public:
property array<unsigned short>^ Ld {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}
member Ld : uint16[] with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareInfo Class


HardwareInfo.LowLevelThreshold Property

HardwareInfoLowLevelThreshold Property
possible values for the low level threshold

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] LowLevelThreshold { get; set; }
Public Property LowLevelThreshold As Byte()
    Get
    Set
public:
property array<unsigned char>^ LowLevelThreshold {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member LowLevelThreshold : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

HardwareInfo Class


HardwareInfo.Master Property

HardwareInfoMaster Property
can be used as master

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Master { get; set; }
Public Property Master As Boolean
    Get
    Set
public:
property bool Master {
    bool get ();
    void set (bool value);
}
member Master : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.MasterMaxRx Property

HardwareInfoMasterMaxRx Property
master: maximum number of bytes which can be received in one I2C message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MasterMaxRx { get; set; }
Public Property MasterMaxRx As UInteger
    Get
    Set
public:
property unsigned int MasterMaxRx {
    unsigned int get ();
    void set (unsigned int value);
}
member MasterMaxRx : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.MasterSamplingRate Property

HardwareInfoMasterSamplingRate Property
master: possible values for the bitrate

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint[] MasterSamplingRate { get; set; }
Public Property MasterSamplingRate As UInteger()
    Get
    Set
public:
property array<unsigned int>^ MasterSamplingRate {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}
member MasterSamplingRate : uint32[] with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.MasterSamplingRateHs Property

HardwareInfoMasterSamplingRateHs Property
master: possible values for the high speed bitrate

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint[] MasterSamplingRateHs { get; set; }
Public Property MasterSamplingRateHs As UInteger()
    Get
    Set
public:
property array<unsigned int>^ MasterSamplingRateHs {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}
member MasterSamplingRateHs : uint32[] with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.NegativeTester Property

HardwareInfoNegativeTester Property
negative tester available?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool NegativeTester { get; set; }
Public Property NegativeTester As Boolean
    Get
    Set
public:
property bool NegativeTester {
    bool get ();
    void set (bool value);
}
member NegativeTester : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.Port Property

HardwareInfoPort Property
name of the port (e.g. "USB" or "LPT1")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Port { get; set; }
Public Property Port As String
    Get
    Set
public:
property String^ Port {
    String^ get ();
    void set (String^ value);
}
member Port : string with get, set

Property Value

Type: String
See Also

Reference

HardwareInfo Class


HardwareInfo.RequiredServiceContract Property

HardwareInfoRequiredServiceContract Property
required expiration date of service contract

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime RequiredServiceContract { get; set; }
Public Property RequiredServiceContract As DateTime
    Get
    Set
public:
property DateTime RequiredServiceContract {
    DateTime get ();
    void set (DateTime value);
}
member RequiredServiceContract : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

HardwareInfo Class


HardwareInfo.RequiredVersions Property

HardwareInfoRequiredVersions Property
required versions

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, Version> RequiredVersions { get; set; }
Public Property RequiredVersions As Dictionary(Of String, Version)
    Get
    Set
public:
property Dictionary<String^, Version^>^ RequiredVersions {
    Dictionary<String^, Version^>^ get ();
    void set (Dictionary<String^, Version^>^ value);
}
member RequiredVersions : Dictionary<string, Version> with get, set

Property Value

Type: Dictionary String, Version
See Also

Reference

HardwareInfo Class


HardwareInfo.SerialNumber Property

HardwareInfoSerialNumber Property
serial number

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort SerialNumber { get; set; }
Public Property SerialNumber As UShort
    Get
    Set
public:
property unsigned short SerialNumber {
    unsigned short get ();
    void set (unsigned short value);
}
member SerialNumber : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareInfo Class


HardwareInfo.ServiceContract Property

HardwareInfoServiceContract Property
expiration dates of service contract

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ServiceContracts ServiceContract { get; set; }
Public Property ServiceContract As ServiceContracts
    Get
    Set
public:
property ServiceContracts^ ServiceContract {
    ServiceContracts^ get ();
    void set (ServiceContracts^ value);
}
member ServiceContract : ServiceContracts with get, set

Property Value

Type: ServiceContracts
See Also

Reference

HardwareInfo Class


HardwareInfo.SoftwareLicenses Property

HardwareInfoSoftwareLicenses Property
software that can be used

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SoftwareLicenses SoftwareLicenses { get; set; }
Public Property SoftwareLicenses As SoftwareLicenses
    Get
    Set
public:
property SoftwareLicenses^ SoftwareLicenses {
    SoftwareLicenses^ get ();
    void set (SoftwareLicenses^ value);
}
member SoftwareLicenses : SoftwareLicenses with get, set

Property Value

Type: SoftwareLicenses
See Also

Reference

HardwareInfo Class


HardwareInfo.Termination Property

HardwareInfoTermination Property
possible values for the SDA/SCL termination

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint[] Termination { get; set; }
Public Property Termination As UInteger()
    Get
    Set
public:
property array<unsigned int>^ Termination {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}
member Termination : uint32[] with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.TestpinAck Property

HardwareInfoTestpinAck Property
ACK condition can trigger testpin (out)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TestpinAck { get; set; }
Public Property TestpinAck As Boolean
    Get
    Set
public:
property bool TestpinAck {
    bool get ();
    void set (bool value);
}
member TestpinAck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.TestpinError Property

HardwareInfoTestpinError Property
ERROR condition can trigger testpin (out)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TestpinError { get; set; }
Public Property TestpinError As Boolean
    Get
    Set
public:
property bool TestpinError {
    bool get ();
    void set (bool value);
}
member TestpinError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.TestpinNack Property

HardwareInfoTestpinNack Property
NACK condition can trigger testpin (out)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TestpinNack { get; set; }
Public Property TestpinNack As Boolean
    Get
    Set
public:
property bool TestpinNack {
    bool get ();
    void set (bool value);
}
member TestpinNack : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.TestpinsIn Property

HardwareInfoTestpinsIn Property
number of input testpins

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte TestpinsIn { get; set; }
Public Property TestpinsIn As Byte
    Get
    Set
public:
property unsigned char TestpinsIn {
    unsigned char get ();
    void set (unsigned char value);
}
member TestpinsIn : byte with get, set

Property Value

Type: Byte
See Also

Reference

HardwareInfo Class


HardwareInfo.TestpinsOut Property

HardwareInfoTestpinsOut Property
number of output testpins

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte TestpinsOut { get; set; }
Public Property TestpinsOut As Byte
    Get
    Set
public:
property unsigned char TestpinsOut {
    unsigned char get ();
    void set (unsigned char value);
}
member TestpinsOut : byte with get, set

Property Value

Type: Byte
See Also

Reference

HardwareInfo Class


HardwareInfo.TestpinStart Property

HardwareInfoTestpinStart Property
START condition can trigger testpin (out)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TestpinStart { get; set; }
Public Property TestpinStart As Boolean
    Get
    Set
public:
property bool TestpinStart {
    bool get ();
    void set (bool value);
}
member TestpinStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.TestpinStop Property

HardwareInfoTestpinStop Property
STOP condition can trigger testpin (out)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TestpinStop { get; set; }
Public Property TestpinStop As Boolean
    Get
    Set
public:
property bool TestpinStop {
    bool get ();
    void set (bool value);
}
member TestpinStop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.TimestampTimebase Property

HardwareInfoTimestampTimebase Property
timebase of the timestamps (e.g 3E6 Hz) or N/A (MaxValue)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimestampTimebase { get; set; }
Public Property TimestampTimebase As UInteger
    Get
    Set
public:
property unsigned int TimestampTimebase {
    unsigned int get ();
    void set (unsigned int value);
}
member TimestampTimebase : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

HardwareInfo Class


HardwareInfo.Tracer Property

HardwareInfoTracer Property
can be used as tracer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Tracer { get; set; }
Public Property Tracer As Boolean
    Get
    Set
public:
property bool Tracer {
    bool get ();
    void set (bool value);
}
member Tracer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareInfo Class


HardwareInfo.Versions Property

HardwareInfoVersions Property
versions

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, Version> Versions { get; set; }
Public Property Versions As Dictionary(Of String, Version)
    Get
    Set
public:
property Dictionary<String^, Version^>^ Versions {
    Dictionary<String^, Version^>^ get ();
    void set (Dictionary<String^, Version^>^ value);
}
member Versions : Dictionary<string, Version> with get, set

Property Value

Type: Dictionary String, Version
See Also

Reference

HardwareInfo Class


I2cAddress Class

I2cAddress Class
This class stores a 7 or 10 bit I2C address.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetI2cAddress

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class I2cAddress : ICloneable,
    IEquatable<I2cAddress>, IComparable<I2cAddress>, ISerializable
<SerializableAttribute>
Public NotInheritable Class I2cAddress
    Implements ICloneable, IEquatable(Of I2cAddress),
    IComparable(Of I2cAddress), ISerializable
[SerializableAttribute]
public ref class I2cAddress sealed : ICloneable,
    IEquatable<I2cAddress^>, IComparable<I2cAddress^>, ISerializable
[<SealedAttribute>]
[<SerializableAttribute>]
type I2cAddress =
    class
        interface ICloneable
        interface IEquatable<I2cAddress>
        interface IComparable<I2cAddress>
        interface ISerializable
    end

The I2cAddress type exposes the following members.

Constructors
 | Name | Description
Public method | I2cAddress | Constructor: the created instance contains a valid but undefined I2C address.
Public method | I2cAddress(UInt16, Boolean) | Constructor: sets a 7 or 10 bit I2C address.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | CompareTo | Compares the I2C address with the I2C address given as a parameter.
Public method | Equals(Object) | Tests whether both I2C addresses are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(I2cAddress) | Tests whether both I2C addresses are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this I2C address. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Part of the ISerializable interface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidI2cAddress | Tests whether the given I2C address is valid.
 | IsValidSmbAddress | Tests whether the given I2C address is valid for SMBus devices.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAddress | Sets a 7 or 10 bit I2C address to be stored in this object.
Public method | ToString | Returns the I2C address stored in this object as string. (Overrides ObjectToString.)
Public method | VerifySMBAddress | Verifies that the object contains a valid SMBus address. If the address is not valid for the SMBus, this method throws a ExceptionSmbI2cAddress exception.
Top
Operators
Name | Description
Decrement | Operator "--".
Equality | Operator "==".
GreaterThan | Operator ">".
GreaterThanOrEqual | Operator ">=".
Increment | Operator "++".
Inequality | Operator "!=".
LessThan | Operator "<".
LessThanOrEqual | Operator "<=".
Top
Fields
Name | Description
GENERAL_CALL | general call I2C address
PMBUS_ZONE_READ | PMBus ZONE READ address
PMBUS_ZONE_WRITE | PMBus ZONE WRITE address
SMBUS_ALERT_RESPONSE | SMBus alert response address
SMBUS_DEVICE_DEFAULT | SMBus device default address
SMBUS_HOST | SMBus host address
Top
Properties
 | Name | Description
Public property | Address | Returns the 7 or 10 bit I2C address stored in this object. To test whether the returned value specifies a 7 or 10 bit I2C address the IsTenBitAddress property has to be used.
Public property | IsTenBitAddress | Returns whether the value of Address specifies a 7 or 10 bit I2C address.
Top
Remarks

The I2C.NET API uses the I2C address format specified in the I2C standard. Some IC manufacturer use different formats in their datasheets. E.g. they specify 7 bit addresses in an 8 bit representation, where the whole address gets shifted one bit to the left.

Supports the ICloneable, ISerializable, IEquatableT, and IComparable interfaces.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


I2cAddress Constructor

I2cAddress Constructor
Overload List
 | Name | Description
Public method | I2cAddress | Constructor: the created instance contains a valid but undefined I2C address.
Public method | I2cAddress(UInt16, Boolean) | Constructor: sets a 7 or 10 bit I2C address.
Top
See Also

Reference

I2cAddress Class


I2cAddress Constructor

I2cAddress Constructor
Constructor: the created instance contains a valid but undefined I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress()
Public Sub New
public:
I2cAddress()
new : unit -> I2cAddress
See Also

Reference

I2cAddress Class
I2cAddress Overload


I2cAddress Constructor (UInt16, Boolean)

I2cAddress Constructor (UInt16, Boolean)
Constructor: sets a 7 or 10 bit I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress(
    ushort address,
    bool ten_bit_address
)
Public Sub New (
    address As UShort,
    ten_bit_address As Boolean
)
public:
I2cAddress(
    unsigned short address,
    bool ten_bit_address
)
new :
        address : uint16 *
        ten_bit_address : bool -> I2cAddress

Parameters

address
Type: SystemUInt16
I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address
Type: SystemBoolean
10 bit address?
See Also

Reference

I2cAddress Class
I2cAddress Overload


I2cAddress Fields

I2cAddress Fields

The I2cAddress type exposes the following members.

Fields
Name | Description
GENERAL_CALL | general call I2C address
PMBUS_ZONE_READ | PMBus ZONE READ address
PMBUS_ZONE_WRITE | PMBus ZONE WRITE address
SMBUS_ALERT_RESPONSE | SMBus alert response address
SMBUS_DEVICE_DEFAULT | SMBus device default address
SMBUS_HOST | SMBus host address
Top
See Also

Reference

I2cAddress Class


I2cAddress.GENERAL_CALL Field

I2cAddressGENERAL_CALL Field
general call I2C address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly I2cAddress GENERAL_CALL
Public Shared ReadOnly GENERAL_CALL As I2cAddress
public:
static initonly I2cAddress^ GENERAL_CALL
static val GENERAL_CALL: I2cAddress

Field Value

Type: I2cAddress
See Also

Reference

I2cAddress Class


I2cAddress.PMBUS_ZONE_READ Field

I2cAddressPMBUS_ZONE_READ Field
PMBus ZONE READ address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly I2cAddress PMBUS_ZONE_READ
Public Shared ReadOnly PMBUS_ZONE_READ As I2cAddress
public:
static initonly I2cAddress^ PMBUS_ZONE_READ
static val PMBUS_ZONE_READ: I2cAddress

Field Value

Type: I2cAddress
See Also

Reference

I2cAddress Class


I2cAddress.PMBUS_ZONE_WRITE Field

I2cAddressPMBUS_ZONE_WRITE Field
PMBus ZONE WRITE address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly I2cAddress PMBUS_ZONE_WRITE
Public Shared ReadOnly PMBUS_ZONE_WRITE As I2cAddress
public:
static initonly I2cAddress^ PMBUS_ZONE_WRITE
static val PMBUS_ZONE_WRITE: I2cAddress

Field Value

Type: I2cAddress
See Also

Reference

I2cAddress Class


I2cAddress.SMBUS_ALERT_RESPONSE Field

I2cAddressSMBUS_ALERT_RESPONSE Field
SMBus alert response address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly I2cAddress SMBUS_ALERT_RESPONSE
Public Shared ReadOnly SMBUS_ALERT_RESPONSE As I2cAddress
public:
static initonly I2cAddress^ SMBUS_ALERT_RESPONSE
static val SMBUS_ALERT_RESPONSE: I2cAddress

Field Value

Type: I2cAddress
See Also

Reference

I2cAddress Class


I2cAddress.SMBUS_DEVICE_DEFAULT Field

I2cAddressSMBUS_DEVICE_DEFAULT Field
SMBus device default address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly I2cAddress SMBUS_DEVICE_DEFAULT
Public Shared ReadOnly SMBUS_DEVICE_DEFAULT As I2cAddress
public:
static initonly I2cAddress^ SMBUS_DEVICE_DEFAULT
static val SMBUS_DEVICE_DEFAULT: I2cAddress

Field Value

Type: I2cAddress
See Also

Reference

I2cAddress Class


I2cAddress.SMBUS_HOST Field

I2cAddressSMBUS_HOST Field
SMBus host address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly I2cAddress SMBUS_HOST
Public Shared ReadOnly SMBUS_HOST As I2cAddress
public:
static initonly I2cAddress^ SMBUS_HOST
static val SMBUS_HOST: I2cAddress

Field Value

Type: I2cAddress
See Also

Reference

I2cAddress Class


I2cAddress Methods

I2cAddress Methods

The I2cAddress type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | CompareTo | Compares the I2C address with the I2C address given as a parameter.
Public method | Equals(Object) | Tests whether both I2C addresses are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(I2cAddress) | Tests whether both I2C addresses are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this I2C address. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Part of the ISerializable interface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidI2cAddress | Tests whether the given I2C address is valid.
 | IsValidSmbAddress | Tests whether the given I2C address is valid for SMBus devices.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAddress | Sets a 7 or 10 bit I2C address to be stored in this object.
Public method | ToString | Returns the I2C address stored in this object as string. (Overrides ObjectToString.)
Public method | VerifySMBAddress | Verifies that the object contains a valid SMBus address. If the address is not valid for the SMBus, this method throws a ExceptionSmbI2cAddress exception.
Top
See Also

Reference

I2cAddress Class


I2cAddress.Clone Method

I2cAddressClone Method
Creates a deep copy of this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy of this object

Implements

ICloneableClone
See Also

Reference

I2cAddress Class


I2cAddress.CompareTo Method

I2cAddressCompareTo Method
Compares the I2C address with the I2C address given as a parameter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    I2cAddress addr
)
Public Function CompareTo (
    addr As I2cAddress
) As Integer
public:
virtual int CompareTo(
    I2cAddress^ addr
) sealed
abstract CompareTo :
        addr : I2cAddress -> int
override CompareTo :
        addr : I2cAddress -> int

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address to be used for the comparison

Return Value

Type: Int32
result of the comparison

Implements

IComparableTCompareTo(T)
See Also

Reference

I2cAddress Class


I2cAddress.Equals Method

I2cAddressEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both I2C addresses are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(I2cAddress) | Tests whether both I2C addresses are equal.
Top
See Also

Reference

I2cAddress Class


I2cAddress.Equals Method (Object)

I2cAddressEquals Method (Object)
Tests whether both I2C addresses are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other I2C address

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

I2cAddress Class
Equals Overload


I2cAddress.Equals Method (I2cAddress)

I2cAddressEquals Method (I2cAddress)
Tests whether both I2C addresses are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    I2cAddress addr
)
Public Function Equals (
    addr As I2cAddress
) As Boolean
public:
virtual bool Equals(
    I2cAddress^ addr
) sealed
abstract Equals :
        addr : I2cAddress -> bool
override Equals :
        addr : I2cAddress -> bool

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
other I2C address

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

I2cAddress Class
Equals Overload


I2cAddress.GetHashCode Method

I2cAddressGetHashCode Method
Returns a hash code for this I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
hash code
See Also

Reference

I2cAddress Class


I2cAddress.GetObjectData Method

I2cAddressGetObjectData Method
Part of the ISerializable interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
SerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
StreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

I2cAddress Class


I2cAddress.IsValidI2cAddress Method

I2cAddressIsValidI2cAddress Method
Tests whether the given I2C address is valid.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidI2cAddress(
    ushort address,
    bool ten_bit_address
)
Public Shared Function IsValidI2cAddress (
    address As UShort,
    ten_bit_address As Boolean
) As Boolean
public:
static bool IsValidI2cAddress(
    unsigned short address,
    bool ten_bit_address
)
static member IsValidI2cAddress :
        address : uint16 *
        ten_bit_address : bool -> bool

Parameters

address
Type: SystemUInt16
I2C address
ten_bit_address
Type: SystemBoolean
10 bit address?

Return Value

Type: Boolean
valid (true), not valid (false)
See Also

Reference

I2cAddress Class


I2cAddress.IsValidSmbAddress Method

I2cAddressIsValidSmbAddress Method
Tests whether the given I2C address is valid for SMBus devices.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidSmbAddress(
    ushort address,
    bool ten_bit_address
)
Public Shared Function IsValidSmbAddress (
    address As UShort,
    ten_bit_address As Boolean
) As Boolean
public:
static bool IsValidSmbAddress(
    unsigned short address,
    bool ten_bit_address
)
static member IsValidSmbAddress :
        address : uint16 *
        ten_bit_address : bool -> bool

Parameters

address
Type: SystemUInt16
I2C address
ten_bit_address
Type: SystemBoolean
10 bit address?

Return Value

Type: Boolean
valid (true), not valid (false)
See Also

Reference

I2cAddress Class


I2cAddress.SetAddress Method

I2cAddressSetAddress Method
Sets a 7 or 10 bit I2C address to be stored in this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetAddress(
    ushort address,
    bool ten_bit_address
)
Public Sub SetAddress (
    address As UShort,
    ten_bit_address As Boolean
)
public:
void SetAddress(
    unsigned short address,
    bool ten_bit_address
)
member SetAddress :
        address : uint16 *
        ten_bit_address : bool -> unit

Parameters

address
Type: SystemUInt16
I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address
Type: SystemBoolean
10 bit address?
See Also

Reference

I2cAddress Class


I2cAddress.ToString Method

I2cAddressToString Method
Returns the I2C address stored in this object as string.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
I2C address
See Also

Reference

I2cAddress Class


I2cAddress.VerifySMBAddress Method

I2cAddressVerifySMBAddress Method
Verifies that the object contains a valid SMBus address. If the address is not valid for the SMBus, this method throws a ExceptionSmbI2cAddress exception.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void VerifySMBAddress()
Public Sub VerifySMBAddress
public:
void VerifySMBAddress()
member VerifySMBAddress : unit -> unit
See Also

Reference

I2cAddress Class


I2cAddress Operators

I2cAddress Operators

The I2cAddress type exposes the following members.

Operators
Name | Description
Decrement | Operator "--".
Equality | Operator "==".
GreaterThan | Operator ">".
GreaterThanOrEqual | Operator ">=".
Increment | Operator "++".
Inequality | Operator "!=".
LessThan | Operator "<".
LessThanOrEqual | Operator "<=".
Top
See Also

Reference

I2cAddress Class


I2cAddress.Decrement Operator

I2cAddressDecrement Operator
Operator "--".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static I2cAddress operator --(
    I2cAddress addr
)
Public Shared Operator -- (
    addr As I2cAddress
) As I2cAddress
public:
static I2cAddress^ operator --(
    I2cAddress^ addr
)
static let inline (--)
        addr : I2cAddress  : I2cAddress

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: I2cAddress
I2C address
See Also

Reference

I2cAddress Class


I2cAddress.Equality Operator

I2cAddressEquality Operator
Operator "==".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    I2cAddress addr1,
    I2cAddress addr2
)
Public Shared Operator = (
    addr1 As I2cAddress,
    addr2 As I2cAddress
) As Boolean
public:
static bool operator ==(
    I2cAddress^ addr1,
    I2cAddress^ addr2
)
static let inline (=)
        addr1 : I2cAddress *
        addr2 : I2cAddress  : bool

Parameters

addr1
Type: telos.I2cApi.DotNetI2cAddress
I2C address 1
addr2
Type: telos.I2cApi.DotNetI2cAddress
I2C address 2

Return Value

Type: Boolean
addr1 == addr2
See Also

Reference

I2cAddress Class


I2cAddress.GreaterThan Operator

I2cAddressGreaterThan Operator
Operator ">".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    I2cAddress addr1,
    I2cAddress addr2
)
Public Shared Operator > (
    addr1 As I2cAddress,
    addr2 As I2cAddress
) As Boolean
public:
static bool operator >(
    I2cAddress^ addr1,
    I2cAddress^ addr2
)
static let inline (>)
        addr1 : I2cAddress *
        addr2 : I2cAddress  : bool

Parameters

addr1
Type: telos.I2cApi.DotNetI2cAddress
I2C address 1
addr2
Type: telos.I2cApi.DotNetI2cAddress
I2C address 2

Return Value

Type: Boolean
addr1 > addr2
See Also

Reference

I2cAddress Class


I2cAddress.GreaterThanOrEqual Operator

I2cAddressGreaterThanOrEqual Operator
Operator ">=".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator >=(
    I2cAddress addr1,
    I2cAddress addr2
)
Public Shared Operator >= (
    addr1 As I2cAddress,
    addr2 As I2cAddress
) As Boolean
public:
static bool operator >=(
    I2cAddress^ addr1,
    I2cAddress^ addr2
)
static let inline (>=)
        addr1 : I2cAddress *
        addr2 : I2cAddress  : bool

Parameters

addr1
Type: telos.I2cApi.DotNetI2cAddress
I2C address 1
addr2
Type: telos.I2cApi.DotNetI2cAddress
I2C address 2

Return Value

Type: Boolean
addr1 >= addr2
See Also

Reference

I2cAddress Class


I2cAddress.Increment Operator

I2cAddressIncrement Operator
Operator "++".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static I2cAddress operator ++(
    I2cAddress addr
)
Public Shared Operator ++ (
    addr As I2cAddress
) As I2cAddress
public:
static I2cAddress^ operator ++(
    I2cAddress^ addr
)
static let inline (++)
        addr : I2cAddress  : I2cAddress

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: I2cAddress
I2C address
See Also

Reference

I2cAddress Class


I2cAddress.Inequality Operator

I2cAddressInequality Operator
Operator "!=".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    I2cAddress addr1,
    I2cAddress addr2
)
Public Shared Operator <> (
    addr1 As I2cAddress,
    addr2 As I2cAddress
) As Boolean
public:
static bool operator !=(
    I2cAddress^ addr1,
    I2cAddress^ addr2
)
static let inline (<>)
        addr1 : I2cAddress *
        addr2 : I2cAddress  : bool

Parameters

addr1
Type: telos.I2cApi.DotNetI2cAddress
I2C address 1
addr2
Type: telos.I2cApi.DotNetI2cAddress
I2C address 2

Return Value

Type: Boolean
addr1 != addr2
See Also

Reference

I2cAddress Class


I2cAddress.LessThan Operator

I2cAddressLessThan Operator
Operator "<".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    I2cAddress addr1,
    I2cAddress addr2
)
Public Shared Operator < (
    addr1 As I2cAddress,
    addr2 As I2cAddress
) As Boolean
public:
static bool operator <(
    I2cAddress^ addr1,
    I2cAddress^ addr2
)
static let inline (<)
        addr1 : I2cAddress *
        addr2 : I2cAddress  : bool

Parameters

addr1
Type: telos.I2cApi.DotNetI2cAddress
I2C address 1
addr2
Type: telos.I2cApi.DotNetI2cAddress
I2C address 2

Return Value

Type: Boolean
addr1 < addr2
See Also

Reference

I2cAddress Class


I2cAddress.LessThanOrEqual Operator

I2cAddressLessThanOrEqual Operator
Operator "<=".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator <=(
    I2cAddress addr1,
    I2cAddress addr2
)
Public Shared Operator <= (
    addr1 As I2cAddress,
    addr2 As I2cAddress
) As Boolean
public:
static bool operator <=(
    I2cAddress^ addr1,
    I2cAddress^ addr2
)
static let inline (<=)
        addr1 : I2cAddress *
        addr2 : I2cAddress  : bool

Parameters

addr1
Type: telos.I2cApi.DotNetI2cAddress
I2C address 1
addr2
Type: telos.I2cApi.DotNetI2cAddress
I2C address 2

Return Value

Type: Boolean
addr1 <= addr2
See Also

Reference

I2cAddress Class


I2cAddress Properties

I2cAddress Properties

The I2cAddress type exposes the following members.

Properties
 | Name | Description
Public property | Address | Returns the 7 or 10 bit I2C address stored in this object. To test whether the returned value specifies a 7 or 10 bit I2C address the IsTenBitAddress property has to be used.
Public property | IsTenBitAddress | Returns whether the value of Address specifies a 7 or 10 bit I2C address.
Top
See Also

Reference

I2cAddress Class


I2cAddress.Address Property

I2cAddressAddress Property
Returns the 7 or 10 bit I2C address stored in this object. To test whether the returned value specifies a 7 or 10 bit I2C address the IsTenBitAddress property has to be used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort Address { get; }
Public ReadOnly Property Address As UShort
    Get
public:
property unsigned short Address {
    unsigned short get ();
}
member Address : uint16 with get

Property Value

Type: UInt16
See Also

Reference

I2cAddress Class


I2cAddress.IsTenBitAddress Property

I2cAddressIsTenBitAddress Property
Returns whether the value of Address specifies a 7 or 10 bit I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsTenBitAddress { get; }
Public ReadOnly Property IsTenBitAddress As Boolean
    Get
public:
property bool IsTenBitAddress {
    bool get ();
}
member IsTenBitAddress : bool with get

Property Value

Type: Boolean
See Also

Reference

I2cAddress Class


I2cAddressRange Class

I2cAddressRange Class
This class stores a I2C address range.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetI2cAddressRange

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class I2cAddressRange : ICloneable,
    IEquatable<I2cAddressRange>
Public NotInheritable Class I2cAddressRange
    Implements ICloneable, IEquatable(Of I2cAddressRange)
public ref class I2cAddressRange sealed : ICloneable,
    IEquatable<I2cAddressRange^>
[<SealedAttribute>]
type I2cAddressRange =
    class
        interface ICloneable
        interface IEquatable<I2cAddressRange>
    end

The I2cAddressRange type exposes the following members.

Constructors
 | Name | Description
Public method | I2cAddressRange | Constructor: the created instance contains a valid but undefined I2C address range.
Public method | I2cAddressRange(I2cAddress, I2cAddress) | Constructor: creates an I2C address range with the specified first and last elements.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | Equals(Object) | Tests whether both I2C address ranges are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(I2cAddressRange) | Tests whether both I2C address ranges are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInRange | Tests whether the given I2C address is in the I2C address range.
Public method | IsOverlapping | Tests whether the given I2C address range is overlapping with the I2C address range of this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the I2C address range stored in this object as string. (Overrides ObjectToString.)
Top
Operators
Name | Description
Equality | Operator "==".
Inequality | Operator "!=".
Top
Properties
 | Name | Description
Public property | First | Sets/gets the first I2C address of the range.
Public property | I2cAddressesAsArray | Returns a list, which contains all I2C addresses of the I2C range specified by an object of this class.
Public property | Last | Sets/gets the last I2C address of the range.
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


I2cAddressRange Constructor

I2cAddressRange Constructor
Overload List
 | Name | Description
Public method | I2cAddressRange | Constructor: the created instance contains a valid but undefined I2C address range.
Public method | I2cAddressRange(I2cAddress, I2cAddress) | Constructor: creates an I2C address range with the specified first and last elements.
Top
See Also

Reference

I2cAddressRange Class


I2cAddressRange Constructor

I2cAddressRange Constructor
Constructor: the created instance contains a valid but undefined I2C address range.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddressRange()
Public Sub New
public:
I2cAddressRange()
new : unit -> I2cAddressRange
See Also

Reference

I2cAddressRange Class
I2cAddressRange Overload


I2cAddressRange Constructor (I2cAddress, I2cAddress)

I2cAddressRange Constructor (I2cAddress, I2cAddress)
Constructor: creates an I2C address range with the specified first and last elements.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddressRange(
    I2cAddress first,
    I2cAddress last
)
Public Sub New (
    first As I2cAddress,
    last As I2cAddress
)
public:
I2cAddressRange(
    I2cAddress^ first,
    I2cAddress^ last
)
new :
        first : I2cAddress *
        last : I2cAddress -> I2cAddressRange

Parameters

first
Type: telos.I2cApi.DotNetI2cAddress
first I2C address of the range
last
Type: telos.I2cApi.DotNetI2cAddress
last I2C address of the range
See Also

Reference

I2cAddressRange Class
I2cAddressRange Overload


I2cAddressRange Methods

I2cAddressRange Methods

The I2cAddressRange type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | Equals(Object) | Tests whether both I2C address ranges are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(I2cAddressRange) | Tests whether both I2C address ranges are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInRange | Tests whether the given I2C address is in the I2C address range.
Public method | IsOverlapping | Tests whether the given I2C address range is overlapping with the I2C address range of this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the I2C address range stored in this object as string. (Overrides ObjectToString.)
Top
See Also

Reference

I2cAddressRange Class


I2cAddressRange.Clone Method

I2cAddressRangeClone Method
Creates a deep copy of this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy of this object

Implements

ICloneableClone
See Also

Reference

I2cAddressRange Class


I2cAddressRange.Equals Method

I2cAddressRangeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both I2C address ranges are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(I2cAddressRange) | Tests whether both I2C address ranges are equal.
Top
See Also

Reference

I2cAddressRange Class


I2cAddressRange.Equals Method (Object)

I2cAddressRangeEquals Method (Object)
Tests whether both I2C address ranges are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other I2C address range

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

I2cAddressRange Class
Equals Overload


I2cAddressRange.Equals Method (I2cAddressRange)

I2cAddressRangeEquals Method (I2cAddressRange)
Tests whether both I2C address ranges are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    I2cAddressRange range
)
Public Function Equals (
    range As I2cAddressRange
) As Boolean
public:
virtual bool Equals(
    I2cAddressRange^ range
) sealed
abstract Equals :
        range : I2cAddressRange -> bool
override Equals :
        range : I2cAddressRange -> bool

Parameters

range
Type: telos.I2cApi.DotNetI2cAddressRange
other I2C address range

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

I2cAddressRange Class
Equals Overload


I2cAddressRange.IsInRange Method

I2cAddressRangeIsInRange Method
Tests whether the given I2C address is in the I2C address range.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsInRange(
    I2cAddress addr
)
Public Function IsInRange (
    addr As I2cAddress
) As Boolean
public:
bool IsInRange(
    I2cAddress^ addr
)
member IsInRange :
        addr : I2cAddress -> bool

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address to be tested

Return Value

Type: Boolean
I2C address is not in the range (false), I2C address is in the range (true)
See Also

Reference

I2cAddressRange Class


I2cAddressRange.IsOverlapping Method

I2cAddressRangeIsOverlapping Method
Tests whether the given I2C address range is overlapping with the I2C address range of this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOverlapping(
    I2cAddressRange range
)
Public Function IsOverlapping (
    range As I2cAddressRange
) As Boolean
public:
bool IsOverlapping(
    I2cAddressRange^ range
)
member IsOverlapping :
        range : I2cAddressRange -> bool

Parameters

range
Type: telos.I2cApi.DotNetI2cAddressRange
I2C address range to be tested

Return Value

Type: Boolean
I2C address is not overlapping (false), I2C address is overlapping (true)
See Also

Reference

I2cAddressRange Class


I2cAddressRange.ToString Method

I2cAddressRangeToString Method
Returns the I2C address range stored in this object as string.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
I2C address range
See Also

Reference

I2cAddressRange Class


I2cAddressRange Operators

I2cAddressRange Operators

The I2cAddressRange type exposes the following members.

Operators
Name | Description
Equality | Operator "==".
Inequality | Operator "!=".
Top
See Also

Reference

I2cAddressRange Class


I2cAddressRange.Equality Operator

I2cAddressRangeEquality Operator
Operator "==".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    I2cAddressRange range1,
    I2cAddressRange range2
)
Public Shared Operator = (
    range1 As I2cAddressRange,
    range2 As I2cAddressRange
) As Boolean
public:
static bool operator ==(
    I2cAddressRange^ range1,
    I2cAddressRange^ range2
)
static let inline (=)
        range1 : I2cAddressRange *
        range2 : I2cAddressRange  : bool

Parameters

range1
Type: telos.I2cApi.DotNetI2cAddressRange
I2C address range 1
range2
Type: telos.I2cApi.DotNetI2cAddressRange
I2C address range 2

Return Value

Type: Boolean
range1 == range2
See Also

Reference

I2cAddressRange Class


I2cAddressRange.Inequality Operator

I2cAddressRangeInequality Operator
Operator "!=".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    I2cAddressRange range1,
    I2cAddressRange range2
)
Public Shared Operator <> (
    range1 As I2cAddressRange,
    range2 As I2cAddressRange
) As Boolean
public:
static bool operator !=(
    I2cAddressRange^ range1,
    I2cAddressRange^ range2
)
static let inline (<>)
        range1 : I2cAddressRange *
        range2 : I2cAddressRange  : bool

Parameters

range1
Type: telos.I2cApi.DotNetI2cAddressRange
I2C address range 1
range2
Type: telos.I2cApi.DotNetI2cAddressRange
I2C address range 2

Return Value

Type: Boolean
range1 != range2
See Also

Reference

I2cAddressRange Class


I2cAddressRange Properties

I2cAddressRange Properties

The I2cAddressRange type exposes the following members.

Properties
 | Name | Description
Public property | First | Sets/gets the first I2C address of the range.
Public property | I2cAddressesAsArray | Returns a list, which contains all I2C addresses of the I2C range specified by an object of this class.
Public property | Last | Sets/gets the last I2C address of the range.
Top
See Also

Reference

I2cAddressRange Class


I2cAddressRange.First Property

I2cAddressRangeFirst Property
Sets/gets the first I2C address of the range.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress First { get; set; }
Public Property First As I2cAddress
    Get
    Set
public:
property I2cAddress^ First {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member First : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

I2cAddressRange Class


I2cAddressRange.I2cAddressesAsArray Property

I2cAddressRangeI2cAddressesAsArray Property
Returns a list, which contains all I2C addresses of the I2C range specified by an object of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<I2cAddress> I2cAddressesAsArray { get; }
Public ReadOnly Property I2cAddressesAsArray As List(Of I2cAddress)
    Get
public:
property List<I2cAddress^>^ I2cAddressesAsArray {
    List<I2cAddress^>^ get ();
}
member I2cAddressesAsArray : List<I2cAddress> with get

Property Value

Type: List I2cAddress
See Also

Reference

I2cAddressRange Class


I2cAddressRange.Last Property

I2cAddressRangeLast Property
Sets/gets the last I2C address of the range.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Last { get; set; }
Public Property Last As I2cAddress
    Get
    Set
public:
property I2cAddress^ Last {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Last : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

I2cAddressRange Class


InputTestpins Class

InputTestpins Class
Some I2C interfaces like Tracii XL contains input testpins. This class can be used to log transitions of these input testpins.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetInputTestpins

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InputTestpins : IDisposable
Public NotInheritable Class InputTestpins
    Implements IDisposable
public ref class InputTestpins sealed : IDisposable
[<SealedAttribute>]
type InputTestpins =
    class
        interface IDisposable
    end

The InputTestpins type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReceiveMessages | Receives messages describing transitions of the input testpins. The result is stored in the instance specified by InputTestpinsMsgList
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Enables or disables the logging of the input testpins. Whenever one of the input testpins changes its status, the new status of all testpins and the timestamp of the transition get stored. The transitions are stored into the list specified by InputTestpinsMsgList.
Public property | InputTestpinsMsgList | Sets/gets the InputTestpinsMessageList instance, into which the traced testpin transitions are stored.
Top
Remarks

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the InputTestpins property.

Normally the following steps are necessary to use this class:

  1. Specify an InputTestpinsMessageList instance, which should be used for storing the transitions.
  2. Enable the logging functionality using the Enabled property.
  3. Call WaitForData(Int32) and ReceiveMessages in a loop to get the log messages.
  4. Disable logging functionality using the Enabled property.
Examples
The following example demonstrates how to use this class with C#:
Copy
using telos.I2cApi.DotNet;
using System;
using System.Collections.Generic;

namespace MyNamespace
{
  class MyClass
  {
    /***********************************************************************/
    /// <summary>
    /// Displays one <see cref="InputTestpinsMessage"/> message.
    /// </summary>
    /***********************************************************************/

    static void DisplayInputTestpinMessage (HardwareInfo hwinfo,
                                            InputTestpinsMessage msg)
    {
      for (int i=0; i < hwinfo.TestpinsIn; i++)
        Console.WriteLine ("Testpin " + i.ToString() + ": Level = " +
                           ((msg.Status >> i) & 0x01).ToString());
      Console.WriteLine ("");
    }

    /***********************************************************************/
    /// <summary>
    /// Logs and displays at least 10 transitions of the input testpins.
    /// </summary>
    /***********************************************************************/

    static void TestInputTestpins (Board board)
    {
      InputTestpins             testpins = board.Tracer.InputTestpins;
      InputTestpinsMessageList  msgs;

      // create container for the traced transitions and pass it
      // to the API
      msgs = new InputTestpinsMessageList();
      testpins.InputTestpinsMsgList = msgs;

      // start logging of input testpin transitions
      testpins.Enabled = true;

      // trace at least 10 transitions
      while (msgs.Count < 10)
      {
        board.WaitForData (TimeSpan.FromMilliseconds (100));
        testpins.ReceiveMessages();
      }

      // stop logging of input testpin transitions
      testpins.Enabled = false;

      // display traced data
      foreach (InputTestpinsMessage msg in msgs)
        DisplayInputTestpinMessage(board.HardwareInfoOfOpenBoard, msg);
    }

    [STAThread]
    static void Main(string[] args)
    {
      Board  board = null;

      try
      {
        List<HardwareInfo>  hwinfo;
        int                 i;

        // Create board instance.
        board = new Board();

        // Get the description of all available I2C interfaces.
        hwinfo = board.ListOfBoards;

        // Open the first Tracii XL interface.
        for (i = hwinfo.Count-1; i >= 0; i--)
        {
          if (hwinfo[i].TestpinsIn > 0)
          {
            board.Open (hwinfo[i]);
            break;
          }
        }

        // I2C interface with testpin support found?
        if (board.IsOpen == false)
        {
          Console.WriteLine("No I2C interface with testpin support has been found.");
          return;
        }
        else
        {
          Console.WriteLine(string.Format("Using {0} [0x{1:X4}]",
                                          board.HardwareInfoOfOpenBoard.BoardType,
                                          board.HardwareInfoOfOpenBoard.SerialNumber));
        }

        // execute test
        TestInputTestpins(board);

        // close connection to the I2C interface
        board.Close();
      }
      catch (System.Exception exp)
      {
        Console.WriteLine ("Error: " + exp.Message);
      }
      finally
      {
        // Free all resources allocated by the board object.
        // It is very important to call this method before the
        // garbage collector destroys the unused Board object.
        if (board != null)
          board.Dispose();
      }
    }
  }
}
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


InputTestpins Methods

InputTestpins Methods

The InputTestpins type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReceiveMessages | Receives messages describing transitions of the input testpins. The result is stored in the instance specified by InputTestpinsMsgList
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InputTestpins Class


InputTestpins.Dispose Method

InputTestpinsDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

InputTestpins Class


InputTestpins.Dispose Method

InputTestpinsDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

InputTestpins Class
Dispose Overload


InputTestpins.Dispose Method (Boolean)

InputTestpinsDispose Method (Boolean)
Releases the unmanaged resources used by the InputTestpins and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.InputTestpins.Dispose(System.Boolean)"]

See Also

Reference

InputTestpins Class
Dispose Overload


InputTestpins.Finalize Method

InputTestpinsFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

InputTestpins Class


InputTestpins.ReceiveMessages Method

InputTestpinsReceiveMessages Method
Receives messages describing transitions of the input testpins. The result is stored in the instance specified by InputTestpinsMsgList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReceiveMessages()
Public Sub ReceiveMessages
public:
void ReceiveMessages()
member ReceiveMessages : unit -> unit
Remarks
The InputTestpinsMsgList gets locked (Monitor) while this method is running.
See Also

Reference

InputTestpins Class


InputTestpins Properties

InputTestpins Properties

The InputTestpins type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enables or disables the logging of the input testpins. Whenever one of the input testpins changes its status, the new status of all testpins and the timestamp of the transition get stored. The transitions are stored into the list specified by InputTestpinsMsgList.
Public property | InputTestpinsMsgList | Sets/gets the InputTestpinsMessageList instance, into which the traced testpin transitions are stored.
Top
See Also

Reference

InputTestpins Class


InputTestpins.Enabled Property

InputTestpinsEnabled Property
Enables or disables the logging of the input testpins. Whenever one of the input testpins changes its status, the new status of all testpins and the timestamp of the transition get stored. The transitions are stored into the list specified by InputTestpinsMsgList.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InputTestpins Class


InputTestpins.InputTestpinsMsgList Property

InputTestpinsInputTestpinsMsgList Property
Sets/gets the InputTestpinsMessageList instance, into which the traced testpin transitions are stored.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public InputTestpinsMessageList InputTestpinsMsgList { get; set; }
Public Property InputTestpinsMsgList As InputTestpinsMessageList
    Get
    Set
public:
property InputTestpinsMessageList^ InputTestpinsMsgList {
    InputTestpinsMessageList^ get ();
    void set (InputTestpinsMessageList^ value);
}
member InputTestpinsMsgList : InputTestpinsMessageList with get, set

Property Value

Type: InputTestpinsMessageList
See Also

Reference

InputTestpins Class


InputTestpinsMessage Class

InputTestpinsMessage Class
Each time a InputTestpins object detects a transition of the input testpins, a message of this type gets generated. The message stores the status of the testpins after the transition and the timestamp of the transition.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetInputTestpinsMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InputTestpinsMessage : ICloneable
Public NotInheritable Class InputTestpinsMessage
    Implements ICloneable
public ref class InputTestpinsMessage sealed : ICloneable
[<SealedAttribute>]
type InputTestpinsMessage =
    class
        interface ICloneable
    end

The InputTestpinsMessage type exposes the following members.

Constructors
 | Name | Description
Public method | InputTestpinsMessage | Initializes a new instance of the InputTestpinsMessage class
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Returns the status for the specified testpin.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Status | status after the transition
Public property | StatusAvailable | status available?
Public property | Timestamp | timestamp of the transition (see TimestampTimebase for the timebase)
Top
Remarks

The number of available input testpins can be determined using the TestpinsIn variable. For each available input testpin one bit in the status variable is used to store the testpin level after the transition. The level of testpin 0 gets stored in bit 0 (LSB), testpin 1 in bit 1 and so on.

If StatusAvailable is "false", the status of the testpins should be considered as unknown starting from this time.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


InputTestpinsMessage Constructor

InputTestpinsMessage Constructor
Initializes a new instance of the InputTestpinsMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public InputTestpinsMessage()
Public Sub New
public:
InputTestpinsMessage()
new : unit -> InputTestpinsMessage
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessage Methods

InputTestpinsMessage Methods

The InputTestpinsMessage type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Returns the status for the specified testpin.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessage.Clone Method

InputTestpinsMessageClone Method
Creates a deep copy.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copy

Implements

ICloneableClone
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessage.GetStatus Method

InputTestpinsMessageGetStatus Method
Returns the status for the specified testpin.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool GetStatus(
    int testpin
)
Public Function GetStatus (
    testpin As Integer
) As Boolean
public:
bool GetStatus(
    int testpin
)
member GetStatus :
        testpin : int -> bool

Parameters

testpin
Type: SystemInt32
testpin (0..7)

Return Value

Type: Boolean
status of the testpin
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessage Properties

InputTestpinsMessage Properties

The InputTestpinsMessage type exposes the following members.

Properties
 | Name | Description
Public property | Status | status after the transition
Public property | StatusAvailable | status available?
Public property | Timestamp | timestamp of the transition (see TimestampTimebase for the timebase)
Top
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessage.Status Property

InputTestpinsMessageStatus Property
status after the transition

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Status { get; set; }
Public Property Status As Byte
    Get
    Set
public:
property unsigned char Status {
    unsigned char get ();
    void set (unsigned char value);
}
member Status : byte with get, set

Property Value

Type: Byte
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessage.StatusAvailable Property

InputTestpinsMessageStatusAvailable Property
status available?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool StatusAvailable { get; set; }
Public Property StatusAvailable As Boolean
    Get
    Set
public:
property bool StatusAvailable {
    bool get ();
    void set (bool value);
}
member StatusAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessage.Timestamp Property

InputTestpinsMessageTimestamp Property
timestamp of the transition (see TimestampTimebase for the timebase)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong Timestamp { get; set; }
Public Property Timestamp As ULong
    Get
    Set
public:
property unsigned long long Timestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member Timestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

InputTestpinsMessage Class


InputTestpinsMessageList Class

InputTestpinsMessageList Class
Instances of this class are used by InputTestpins to store InputTestpinsMessage objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList InputTestpinsMessage
telos.I2cApi.DotNetInputTestpinsMessageList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InputTestpinsMessageList : List<InputTestpinsMessage>
Public NotInheritable Class InputTestpinsMessageList
    Inherits List(Of InputTestpinsMessage)
public ref class InputTestpinsMessageList sealed : public List<InputTestpinsMessage^>
[<SealedAttribute>]
type InputTestpinsMessageList =
    class
        inherit List<InputTestpinsMessage>
    end

The InputTestpinsMessageList type exposes the following members.

Constructors
 | Name | Description
Public method | InputTestpinsMessageList | Initializes a new instance of the InputTestpinsMessageList class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(UInt64) | Executes [!:List{T}::BinarySearch (T, IComparer<T>^)] for the given timestamp using InputTestpinsMessageListInputTestpinsMessageTimestampCompare.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List InputTestpinsMessage .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List InputTestpinsMessage .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List InputTestpinsMessage .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List InputTestpinsMessage .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List InputTestpinsMessage .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List InputTestpinsMessage .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List InputTestpinsMessage .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List InputTestpinsMessage .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List InputTestpinsMessage .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List InputTestpinsMessage .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List InputTestpinsMessage .)
Public method | GetFirstIndexWithinTimestampRange | Returns the index of the first message, which has occurred within the specified timestamp range. If there is no message within this range, the method returns "-1".
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the message, which has occurred at the specified timestamp. If it is not possible, to match the timestamp exactly, the next message with a larger timestamp gets returned. If the timestamp is out of the range of the complete list, this method returns "-1".
Public method | GetLastIndexWithinTimestampRange | Returns the index of the last message, which has occurred within the specified timestamp range. If there is no message within this range, the method returns "-1".
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List InputTestpinsMessage .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List InputTestpinsMessage .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List InputTestpinsMessage .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List InputTestpinsMessage .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List InputTestpinsMessage .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List InputTestpinsMessage .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List InputTestpinsMessage .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List InputTestpinsMessage .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | RemoveOlderThanTimestamp | Removes all InputTestpinsMessage objects from the list, which have captured before the given time.
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List InputTestpinsMessage .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List InputTestpinsMessage .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List InputTestpinsMessage .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List InputTestpinsMessage .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List InputTestpinsMessage .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List InputTestpinsMessage .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List InputTestpinsMessage .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List InputTestpinsMessage .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List InputTestpinsMessage .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List InputTestpinsMessage .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List InputTestpinsMessage .)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


InputTestpinsMessageList Constructor

InputTestpinsMessageList Constructor
Initializes a new instance of the InputTestpinsMessageList class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public InputTestpinsMessageList()
Public Sub New
public:
InputTestpinsMessageList()
new : unit -> InputTestpinsMessageList
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList Methods

InputTestpinsMessageList Methods

The InputTestpinsMessageList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(UInt64) | Executes [!:List{T}::BinarySearch (T, IComparer<T>^)] for the given timestamp using InputTestpinsMessageListInputTestpinsMessageTimestampCompare.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List InputTestpinsMessage .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List InputTestpinsMessage .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List InputTestpinsMessage .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List InputTestpinsMessage .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List InputTestpinsMessage .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List InputTestpinsMessage .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List InputTestpinsMessage .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List InputTestpinsMessage .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List InputTestpinsMessage .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List InputTestpinsMessage .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List InputTestpinsMessage .)
Public method | GetFirstIndexWithinTimestampRange | Returns the index of the first message, which has occurred within the specified timestamp range. If there is no message within this range, the method returns "-1".
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the message, which has occurred at the specified timestamp. If it is not possible, to match the timestamp exactly, the next message with a larger timestamp gets returned. If the timestamp is out of the range of the complete list, this method returns "-1".
Public method | GetLastIndexWithinTimestampRange | Returns the index of the last message, which has occurred within the specified timestamp range. If there is no message within this range, the method returns "-1".
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List InputTestpinsMessage .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List InputTestpinsMessage .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List InputTestpinsMessage .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List InputTestpinsMessage .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List InputTestpinsMessage .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List InputTestpinsMessage .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List InputTestpinsMessage .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List InputTestpinsMessage .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List InputTestpinsMessage .)
Public method | RemoveOlderThanTimestamp | Removes all InputTestpinsMessage objects from the list, which have captured before the given time.
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List InputTestpinsMessage .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List InputTestpinsMessage .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List InputTestpinsMessage .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List InputTestpinsMessage .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List InputTestpinsMessage .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List InputTestpinsMessage .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List InputTestpinsMessage .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List InputTestpinsMessage .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List InputTestpinsMessage .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List InputTestpinsMessage .)
Top
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList.BinarySearch Method

InputTestpinsMessageListBinarySearch Method
Overload List
 | Name | Description
Public method | BinarySearch(UInt64) | Executes [!:List{T}::BinarySearch (T, IComparer<T>^)] for the given timestamp using InputTestpinsMessageListInputTestpinsMessageTimestampCompare.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List InputTestpinsMessage .)
Top
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList.BinarySearch Method (UInt64)

InputTestpinsMessageListBinarySearch Method (UInt64)
Executes [!:List{T}::BinarySearch (T, IComparer<T>^)] for the given timestamp using InputTestpinsMessageListInputTestpinsMessageTimestampCompare.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int BinarySearch(
    ulong timestamp
)
Public Function BinarySearch (
    timestamp As ULong
) As Integer
public:
int BinarySearch(
    unsigned long long timestamp
)
member BinarySearch :
        timestamp : uint64 -> int

Parameters

timestamp
Type: SystemUInt64
timestamp to be searched for

Return Value

Type: Int32
The zero-based index of the message, if it is found; otherwise, a negative number that is the bitwise complement of the index of the next element that is larger than item or, if there is no larger element, the bitwise complement of Count.
See Also

Reference

InputTestpinsMessageList Class
BinarySearch Overload


InputTestpinsMessageList.GetFirstIndexWithinTimestampRange Method

InputTestpinsMessageListGetFirstIndexWithinTimestampRange Method
Returns the index of the first message, which has occurred within the specified timestamp range. If there is no message within this range, the method returns "-1".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetFirstIndexWithinTimestampRange(
    ulong timestamp_start,
    ulong timestamp_stop
)
Public Function GetFirstIndexWithinTimestampRange (
    timestamp_start As ULong,
    timestamp_stop As ULong
) As Integer
public:
int GetFirstIndexWithinTimestampRange(
    unsigned long long timestamp_start,
    unsigned long long timestamp_stop
)
member GetFirstIndexWithinTimestampRange :
        timestamp_start : uint64 *
        timestamp_stop : uint64 -> int

Parameters

timestamp_start
Type: SystemUInt64
start of the timestamp range
timestamp_stop
Type: SystemUInt64
stop of the timestamp range

Return Value

Type: Int32
index of the found message or "-1"
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList.GetIndexByTimestamp Method

InputTestpinsMessageListGetIndexByTimestamp Method
Returns the index of the message, which has occurred at the specified timestamp. If it is not possible, to match the timestamp exactly, the next message with a larger timestamp gets returned. If the timestamp is out of the range of the complete list, this method returns "-1".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetIndexByTimestamp(
    ulong timestamp
)
Public Function GetIndexByTimestamp (
    timestamp As ULong
) As Integer
public:
int GetIndexByTimestamp(
    unsigned long long timestamp
)
member GetIndexByTimestamp :
        timestamp : uint64 -> int

Parameters

timestamp
Type: SystemUInt64
timestamp to be searched for

Return Value

Type: Int32
index of the found message or "-1"
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList.GetLastIndexWithinTimestampRange Method

InputTestpinsMessageListGetLastIndexWithinTimestampRange Method
Returns the index of the last message, which has occurred within the specified timestamp range. If there is no message within this range, the method returns "-1".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetLastIndexWithinTimestampRange(
    ulong timestamp_start,
    ulong timestamp_stop
)
Public Function GetLastIndexWithinTimestampRange (
    timestamp_start As ULong,
    timestamp_stop As ULong
) As Integer
public:
int GetLastIndexWithinTimestampRange(
    unsigned long long timestamp_start,
    unsigned long long timestamp_stop
)
member GetLastIndexWithinTimestampRange :
        timestamp_start : uint64 *
        timestamp_stop : uint64 -> int

Parameters

timestamp_start
Type: SystemUInt64
start of the timestamp range
timestamp_stop
Type: SystemUInt64
stop of the timestamp range

Return Value

Type: Int32
index of the found message or "-1"
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList.RemoveOlderThanTimestamp Method

InputTestpinsMessageListRemoveOlderThanTimestamp Method
Removes all InputTestpinsMessage objects from the list, which have captured before the given time.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveOlderThanTimestamp(
    ulong timestamp
)
Public Sub RemoveOlderThanTimestamp (
    timestamp As ULong
)
public:
void RemoveOlderThanTimestamp(
    unsigned long long timestamp
)
member RemoveOlderThanTimestamp :
        timestamp : uint64 -> unit

Parameters

timestamp
Type: SystemUInt64
timestamp
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList Properties

InputTestpinsMessageList Properties

The InputTestpinsMessageList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List InputTestpinsMessage .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List InputTestpinsMessage .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List InputTestpinsMessage .)
Top
See Also

Reference

InputTestpinsMessageList Class


InputTestpinsMessageList.InputTestpinsMessageTimestampCompare Class

InputTestpinsMessageListInputTestpinsMessageTimestampCompare Class
Compares two InputTestpinsMessage objects based on their timestamps.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetInputTestpinsMessageListInputTestpinsMessageTimestampCompare

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class InputTestpinsMessageTimestampCompare : IComparer<InputTestpinsMessage>
Public NotInheritable Class InputTestpinsMessageTimestampCompare
    Implements IComparer(Of InputTestpinsMessage)
public ref class InputTestpinsMessageTimestampCompare sealed : IComparer<InputTestpinsMessage^>
[<SealedAttribute>]
type InputTestpinsMessageTimestampCompare =
    class
        interface IComparer<InputTestpinsMessage>
    end

The InputTestpinsMessageListInputTestpinsMessageTimestampCompare type exposes the following members.

Constructors
 | Name | Description
Public method | InputTestpinsMessageListInputTestpinsMessageTimestampCompare | Initializes a new instance of the InputTestpinsMessageListInputTestpinsMessageTimestampCompare class
Top
Methods
 | Name | Description
Public method | Compare | Compares both InputTestpinsMessage objects based on their timestamps.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


InputTestpinsMessageList.InputTestpinsMessageTimestampCompare Constructor

InputTestpinsMessageListInputTestpinsMessageTimestampCompare Constructor
Initializes a new instance of the InputTestpinsMessageListInputTestpinsMessageTimestampCompare class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public InputTestpinsMessageTimestampCompare()
Public Sub New
public:
InputTestpinsMessageTimestampCompare()
new : unit -> InputTestpinsMessageTimestampCompare
See Also

Reference

InputTestpinsMessageListInputTestpinsMessageTimestampCompare Class


InputTestpinsMessageTimestampCompare Methods

InputTestpinsMessageTimestampCompare Methods

The InputTestpinsMessageListInputTestpinsMessageTimestampCompare type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares both InputTestpinsMessage objects based on their timestamps.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InputTestpinsMessageListInputTestpinsMessageTimestampCompare Class


InputTestpinsMessageList.InputTestpinsMessageTimestampCompare.Compare Method

InputTestpinsMessageListInputTestpinsMessageTimestampCompareCompare Method
Compares both InputTestpinsMessage objects based on their timestamps.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    InputTestpinsMessage x,
    InputTestpinsMessage y
)
Public Function Compare (
    x As InputTestpinsMessage,
    y As InputTestpinsMessage
) As Integer
public:
virtual int Compare(
    InputTestpinsMessage^ x,
    InputTestpinsMessage^ y
) sealed
abstract Compare :
        x : InputTestpinsMessage *
        y : InputTestpinsMessage -> int
override Compare :
        x : InputTestpinsMessage *
        y : InputTestpinsMessage -> int

Parameters

x
Type: telos.I2cApi.DotNetInputTestpinsMessage
message 1
y
Type: telos.I2cApi.DotNetInputTestpinsMessage
message 2

Return Value

Type: Int32
-1 (x < y), 1 (x > y), 0 (x == y)

Implements

IComparerTCompare(T, T)
See Also

Reference

InputTestpinsMessageListInputTestpinsMessageTimestampCompare Class


IrdCompiler Class

IrdCompiler Class
Converts an IRD (I2C Register Description) file into a C# source code file.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdCompiler

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdCompiler
Public NotInheritable Class IrdCompiler
public ref class IrdCompiler sealed
[<SealedAttribute>]
type IrdCompiler =  class end

The IrdCompiler type exposes the following members.

Constructors
 | Name | Description
Public method | IrdCompiler | Constructor.
Top
Methods
 | Name | Description
Public method | Compile | Converts the given IRD file into a C# source code file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The created source code file contains one class, which offers a type-safe interface for reading and writing the values of an IC offer the I2C bus.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdCompiler Constructor

IrdCompiler Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdCompiler()
Public Sub New
public:
IrdCompiler()
new : unit -> IrdCompiler
See Also

Reference

IrdCompiler Class


IrdCompiler Methods

IrdCompiler Methods

The IrdCompiler type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Converts the given IRD file into a C# source code file.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdCompiler Class


IrdCompiler.Compile Method

IrdCompilerCompile Method
Converts the given IRD file into a C# source code file.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Compile(
    string ird_path,
    string csharp_path
)
Public Sub Compile (
    ird_path As String,
    csharp_path As String
)
public:
void Compile(
    String^ ird_path,
    String^ csharp_path
)
member Compile :
        ird_path : string *
        csharp_path : string -> unit

Parameters

ird_path
Type: SystemString
name of the IRD file
csharp_path
Type: SystemString
name of the C# source code file
See Also

Reference

IrdCompiler Class


IrdDevice Class

IrdDevice Class
This class is used to stored the content of a parsed IRD (I2C Register Description) file. A IRD file describes the registers of an I2C/SMBus device.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDevice

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdDevice : ICloneable,
    IEquatable<IrdDevice>
Public NotInheritable Class IrdDevice
    Implements ICloneable, IEquatable(Of IrdDevice)
public ref class IrdDevice sealed : ICloneable,
    IEquatable<IrdDevice^>
[<SealedAttribute>]
type IrdDevice =
    class
        interface ICloneable
        interface IEquatable<IrdDevice>
    end

The IrdDevice type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDevice | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDevice) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQuickCommandRegister | Returns the register description for a quick command.
Public method | GetRegisterBySubAddrRead | Returns the register description for the specified register (read).
Public method | GetRegisterBySubAddrWrite | Returns the register description for the specified register (write).
Public method | GetSendReceiveByteRegister | Returns the register description for send receive byte.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValuesByRegister | Returns the values, which are using data of the specified register.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | After changing member variables of this class it is necessary to call this method to update internal caches.
Top
Properties
 | Name | Description
Public property | AutoIncrement | supports auto increment of the sub address?
Public property | BusySignalisation | busy signal
Public property | Comment | comment
Public property | Description | description (e.g. "256 Byte RAM")
Public property | DeviceType | type (e.g. "RAM")
Public property | I2cAddresses | possible I2C addresses (as I2cAddress or I2cAddressRange objects)
Public property | I2cBusType | type of the bus
Public property | Manufacturer | manufacturer (e.g. "Philips")
Public property | Name | name (e.g. "PCF 8570 P")
Public property | PecSupport | support for SMBus PEC (packet error checking)?
Public property | Registers | registers (key: id, value: IrdDeviceRegister)
Public property | SmBusUdid | SMBus UDID (or "0" for N/A)
Public property | SubAddrByteOrdering | byte ordering of the sub address
Public property | SubAddrWidth | width of the sub address (e.g. "1" for a BYTE)
Public property | Types | types (key: id, value: IrdDeviceTypeInt, IrdDeviceTypeAscii, IrdDeviceTypeString, IrdDeviceTypeArray)
Public property | Values | values
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice Constructor

IrdDevice Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDevice()
Public Sub New
public:
IrdDevice()
new : unit -> IrdDevice
See Also

Reference

IrdDevice Class


IrdDevice Methods

IrdDevice Methods

The IrdDevice type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDevice) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQuickCommandRegister | Returns the register description for a quick command.
Public method | GetRegisterBySubAddrRead | Returns the register description for the specified register (read).
Public method | GetRegisterBySubAddrWrite | Returns the register description for the specified register (write).
Public method | GetSendReceiveByteRegister | Returns the register description for send receive byte.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValuesByRegister | Returns the values, which are using data of the specified register.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | After changing member variables of this class it is necessary to call this method to update internal caches.
Top
See Also

Reference

IrdDevice Class


IrdDevice.Clone Method

IrdDeviceClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDevice Class


IrdDevice.Equals Method

IrdDeviceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDevice) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDevice Class


IrdDevice.Equals Method (Object)

IrdDeviceEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDevice Class
Equals Overload


IrdDevice.Equals Method (IrdDevice)

IrdDeviceEquals Method (IrdDevice)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDevice obj
)
Public Function Equals (
    obj As IrdDevice
) As Boolean
public:
virtual bool Equals(
    IrdDevice^ obj
) sealed
abstract Equals :
        obj : IrdDevice -> bool
override Equals :
        obj : IrdDevice -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDevice
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDevice Class
Equals Overload


IrdDevice.GetQuickCommandRegister Method

IrdDeviceGetQuickCommandRegister Method
Returns the register description for a quick command.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceRegister GetQuickCommandRegister()
Public Function GetQuickCommandRegister As IrdDeviceRegister
public:
IrdDeviceRegister^ GetQuickCommandRegister()
member GetQuickCommandRegister : unit -> IrdDeviceRegister

Return Value

Type: IrdDeviceRegister
register description or N/A ("0")
See Also

Reference

IrdDevice Class


IrdDevice.GetRegisterBySubAddrRead Method

IrdDeviceGetRegisterBySubAddrRead Method
Returns the register description for the specified register (read).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceRegister GetRegisterBySubAddrRead(
    uint reg
)
Public Function GetRegisterBySubAddrRead (
    reg As UInteger
) As IrdDeviceRegister
public:
IrdDeviceRegister^ GetRegisterBySubAddrRead(
    unsigned int reg
)
member GetRegisterBySubAddrRead :
        reg : uint32 -> IrdDeviceRegister

Parameters

reg
Type: SystemUInt32
register

Return Value

Type: IrdDeviceRegister
register description or N/A ("0")
See Also

Reference

IrdDevice Class


IrdDevice.GetRegisterBySubAddrWrite Method

IrdDeviceGetRegisterBySubAddrWrite Method
Returns the register description for the specified register (write).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceRegister GetRegisterBySubAddrWrite(
    uint reg
)
Public Function GetRegisterBySubAddrWrite (
    reg As UInteger
) As IrdDeviceRegister
public:
IrdDeviceRegister^ GetRegisterBySubAddrWrite(
    unsigned int reg
)
member GetRegisterBySubAddrWrite :
        reg : uint32 -> IrdDeviceRegister

Parameters

reg
Type: SystemUInt32
register

Return Value

Type: IrdDeviceRegister
register description or N/A ("0")
See Also

Reference

IrdDevice Class


IrdDevice.GetSendReceiveByteRegister Method

IrdDeviceGetSendReceiveByteRegister Method
Returns the register description for send receive byte.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceRegister GetSendReceiveByteRegister()
Public Function GetSendReceiveByteRegister As IrdDeviceRegister
public:
IrdDeviceRegister^ GetSendReceiveByteRegister()
member GetSendReceiveByteRegister : unit -> IrdDeviceRegister

Return Value

Type: IrdDeviceRegister
register description or N/A ("0")
See Also

Reference

IrdDevice Class


IrdDevice.GetValuesByRegister Method

IrdDeviceGetValuesByRegister Method
Returns the values, which are using data of the specified register.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdDeviceValue> GetValuesByRegister(
    string reg
)
Public Function GetValuesByRegister (
    reg As String
) As List(Of IrdDeviceValue)
public:
List<IrdDeviceValue^>^ GetValuesByRegister(
    String^ reg
)
member GetValuesByRegister :
        reg : string -> List<IrdDeviceValue>

Parameters

reg
Type: SystemString
register

Return Value

Type: List IrdDeviceValue
list of values
See Also

Reference

IrdDevice Class


IrdDevice.Update Method

IrdDeviceUpdate Method
After changing member variables of this class it is necessary to call this method to update internal caches.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
void Update()
member Update : unit -> unit
See Also

Reference

IrdDevice Class


IrdDevice Properties

IrdDevice Properties

The IrdDevice type exposes the following members.

Properties
 | Name | Description
Public property | AutoIncrement | supports auto increment of the sub address?
Public property | BusySignalisation | busy signal
Public property | Comment | comment
Public property | Description | description (e.g. "256 Byte RAM")
Public property | DeviceType | type (e.g. "RAM")
Public property | I2cAddresses | possible I2C addresses (as I2cAddress or I2cAddressRange objects)
Public property | I2cBusType | type of the bus
Public property | Manufacturer | manufacturer (e.g. "Philips")
Public property | Name | name (e.g. "PCF 8570 P")
Public property | PecSupport | support for SMBus PEC (packet error checking)?
Public property | Registers | registers (key: id, value: IrdDeviceRegister)
Public property | SmBusUdid | SMBus UDID (or "0" for N/A)
Public property | SubAddrByteOrdering | byte ordering of the sub address
Public property | SubAddrWidth | width of the sub address (e.g. "1" for a BYTE)
Public property | Types | types (key: id, value: IrdDeviceTypeInt, IrdDeviceTypeAscii, IrdDeviceTypeString, IrdDeviceTypeArray)
Public property | Values | values
Top
See Also

Reference

IrdDevice Class


IrdDevice.AutoIncrement Property

IrdDeviceAutoIncrement Property
supports auto increment of the sub address?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AutoIncrement { get; set; }
Public Property AutoIncrement As Boolean
    Get
    Set
public:
property bool AutoIncrement {
    bool get ();
    void set (bool value);
}
member AutoIncrement : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDevice Class


IrdDevice.BusySignalisation Property

IrdDeviceBusySignalisation Property
busy signal

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceBusySignal BusySignalisation { get; set; }
Public Property BusySignalisation As IrdDeviceBusySignal
    Get
    Set
public:
property IrdDeviceBusySignal BusySignalisation {
    IrdDeviceBusySignal get ();
    void set (IrdDeviceBusySignal value);
}
member BusySignalisation : IrdDeviceBusySignal with get, set

Property Value

Type: IrdDeviceBusySignal
See Also

Reference

IrdDevice Class


IrdDevice.Comment Property

IrdDeviceComment Property
comment

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
See Also

Reference

IrdDevice Class


IrdDevice.Description Property

IrdDeviceDescription Property
description (e.g. "256 Byte RAM")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

IrdDevice Class


IrdDevice.DeviceType Property

IrdDeviceDeviceType Property
type (e.g. "RAM")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string DeviceType { get; set; }
Public Property DeviceType As String
    Get
    Set
public:
property String^ DeviceType {
    String^ get ();
    void set (String^ value);
}
member DeviceType : string with get, set

Property Value

Type: String
See Also

Reference

IrdDevice Class


IrdDevice.I2cAddresses Property

IrdDeviceI2cAddresses Property
possible I2C addresses (as I2cAddress or I2cAddressRange objects)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList I2cAddresses { get; set; }
Public Property I2cAddresses As ArrayList
    Get
    Set
public:
property ArrayList^ I2cAddresses {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
member I2cAddresses : ArrayList with get, set

Property Value

Type: ArrayList
See Also

Reference

IrdDevice Class


IrdDevice.I2cBusType Property

IrdDeviceI2cBusType Property
type of the bus

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceBusType I2cBusType { get; set; }
Public Property I2cBusType As IrdDeviceBusType
    Get
    Set
public:
property IrdDeviceBusType I2cBusType {
    IrdDeviceBusType get ();
    void set (IrdDeviceBusType value);
}
member I2cBusType : IrdDeviceBusType with get, set

Property Value

Type: IrdDeviceBusType
See Also

Reference

IrdDevice Class


IrdDevice.Manufacturer Property

IrdDeviceManufacturer Property
manufacturer (e.g. "Philips")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

IrdDevice Class


IrdDevice.Name Property

IrdDeviceName Property
name (e.g. "PCF 8570 P")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdDevice Class


IrdDevice.PecSupport Property

IrdDevicePecSupport Property
support for SMBus PEC (packet error checking)?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool PecSupport { get; set; }
Public Property PecSupport As Boolean
    Get
    Set
public:
property bool PecSupport {
    bool get ();
    void set (bool value);
}
member PecSupport : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDevice Class


IrdDevice.Registers Property

IrdDeviceRegisters Property
registers (key: id, value: IrdDeviceRegister)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, IrdDeviceRegister> Registers { get; set; }
Public Property Registers As Dictionary(Of String, IrdDeviceRegister)
    Get
    Set
public:
property Dictionary<String^, IrdDeviceRegister^>^ Registers {
    Dictionary<String^, IrdDeviceRegister^>^ get ();
    void set (Dictionary<String^, IrdDeviceRegister^>^ value);
}
member Registers : Dictionary<string, IrdDeviceRegister> with get, set

Property Value

Type: Dictionary String, IrdDeviceRegister
See Also

Reference

IrdDevice Class


IrdDevice.SmBusUdid Property

IrdDeviceSmBusUdid Property
SMBus UDID (or "0" for N/A)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceUdid SmBusUdid { get; set; }
Public Property SmBusUdid As IrdDeviceUdid
    Get
    Set
public:
property IrdDeviceUdid^ SmBusUdid {
    IrdDeviceUdid^ get ();
    void set (IrdDeviceUdid^ value);
}
member SmBusUdid : IrdDeviceUdid with get, set

Property Value

Type: IrdDeviceUdid
See Also

Reference

IrdDevice Class


IrdDevice.SubAddrByteOrdering Property

IrdDeviceSubAddrByteOrdering Property
byte ordering of the sub address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceByteOrdering SubAddrByteOrdering { get; set; }
Public Property SubAddrByteOrdering As IrdDeviceByteOrdering
    Get
    Set
public:
property IrdDeviceByteOrdering SubAddrByteOrdering {
    IrdDeviceByteOrdering get ();
    void set (IrdDeviceByteOrdering value);
}
member SubAddrByteOrdering : IrdDeviceByteOrdering with get, set

Property Value

Type: IrdDeviceByteOrdering
See Also

Reference

IrdDevice Class


IrdDevice.SubAddrWidth Property

IrdDeviceSubAddrWidth Property
width of the sub address (e.g. "1" for a BYTE)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint SubAddrWidth { get; set; }
Public Property SubAddrWidth As UInteger
    Get
    Set
public:
property unsigned int SubAddrWidth {
    unsigned int get ();
    void set (unsigned int value);
}
member SubAddrWidth : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDevice Class


IrdDevice.Types Property

IrdDeviceTypes Property
types (key: id, value: IrdDeviceTypeInt, IrdDeviceTypeAscii, IrdDeviceTypeString, IrdDeviceTypeArray)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, IrdDeviceType> Types { get; set; }
Public Property Types As Dictionary(Of String, IrdDeviceType)
    Get
    Set
public:
property Dictionary<String^, IrdDeviceType^>^ Types {
    Dictionary<String^, IrdDeviceType^>^ get ();
    void set (Dictionary<String^, IrdDeviceType^>^ value);
}
member Types : Dictionary<string, IrdDeviceType> with get, set

Property Value

Type: Dictionary String, IrdDeviceType
See Also

Reference

IrdDevice Class


IrdDevice.Values Property

IrdDeviceValues Property
values

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdDeviceValue> Values { get; set; }
Public Property Values As List(Of IrdDeviceValue)
    Get
    Set
public:
property List<IrdDeviceValue^>^ Values {
    List<IrdDeviceValue^>^ get ();
    void set (List<IrdDeviceValue^>^ value);
}
member Values : List<IrdDeviceValue> with get, set

Property Value

Type: List IrdDeviceValue
See Also

Reference

IrdDevice Class


IrdDevice.BusType Enumeration

IrdDeviceBusType Enumeration
Enumeration to describe the bus type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum BusType
Public Enumeration BusType
public enum class BusType
type BusType
Members
Member name | Value | Description
I2C | 0 | I2C
SMB | 1 | SMBus
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.BusySignal Enumeration

IrdDeviceBusySignal Enumeration
Enumeration to describe the busy signal method. This method defines how a device signals that it is busy at the moment.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum BusySignal
Public Enumeration BusySignal
public enum class BusySignal
type BusySignal
Members
Member name | Value | Description
NONE | 0 | no busy signal available
NACK | 1 | device uses a NACK on the I2C address
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.ByteOrdering Enumeration

IrdDeviceByteOrdering Enumeration
Enumeration to describe the byte ordering/endianess.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum ByteOrdering
Public Enumeration ByteOrdering
public enum class ByteOrdering
type ByteOrdering
Members
Member name | Value | Description
BIG_ENDIAN | 0 | big endian
LITTLE_ENDIAN | 1 | little endian
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Register Class

IrdDeviceRegister Class
This class is used to store the information about one register. A register describes the lowest layer of a device. This information describes how data gets read and written.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceRegister

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Register : ICloneable,
    IEquatable<IrdDeviceRegister>
Public NotInheritable Class Register
    Implements ICloneable, IEquatable(Of IrdDeviceRegister)
public ref class Register sealed : ICloneable,
    IEquatable<IrdDeviceRegister^>
[<SealedAttribute>]
type Register =
    class
        interface ICloneable
        interface IEquatable<IrdDeviceRegister>
    end

The IrdDeviceRegister type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceRegister | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceRegister) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FormatOfRegister | format of the register
Public property | Id | identifier
Public property | Name | name of the register
Public property | Por | power on reset value
Public property | PorAvailable | power on reset value available?
Public property | SubAddrRead | sub address of the register (read mode)
Public property | SubAddrReadAvailable | sub address available (read mode)?
Public property | SubAddrWrite | sub address of the register (write mode)
Public property | SubAddrWriteAvailable | sub address available (write mode)?
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Register Constructor

IrdDeviceRegister Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Register()
Public Sub New
public:
Register()
new : unit -> Register
See Also

Reference

IrdDeviceRegister Class


Register Methods

Register Methods

The IrdDeviceRegister type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceRegister) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.Clone Method

IrdDeviceRegisterClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceRegister Class


Register.Equals Method

RegisterEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceRegister) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.Equals Method (Object)

IrdDeviceRegisterEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDeviceRegister Class
Equals Overload


IrdDevice.Register.Equals Method (IrdDevice.Register)

IrdDeviceRegisterEquals Method (IrdDeviceRegister)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceRegister obj
)
Public Function Equals (
    obj As IrdDeviceRegister
) As Boolean
public:
virtual bool Equals(
    IrdDeviceRegister^ obj
) sealed
abstract Equals :
        obj : IrdDeviceRegister -> bool
override Equals :
        obj : IrdDeviceRegister -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceRegister
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceRegister Class
Equals Overload


Register Properties

Register Properties

The IrdDeviceRegister type exposes the following members.

Properties
 | Name | Description
Public property | FormatOfRegister | format of the register
Public property | Id | identifier
Public property | Name | name of the register
Public property | Por | power on reset value
Public property | PorAvailable | power on reset value available?
Public property | SubAddrRead | sub address of the register (read mode)
Public property | SubAddrReadAvailable | sub address available (read mode)?
Public property | SubAddrWrite | sub address of the register (write mode)
Public property | SubAddrWriteAvailable | sub address available (write mode)?
Top
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.FormatOfRegister Property

IrdDeviceRegisterFormatOfRegister Property
format of the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceRegisterFormat FormatOfRegister { get; set; }
Public Property FormatOfRegister As IrdDeviceRegisterFormat
    Get
    Set
public:
property IrdDeviceRegisterFormat FormatOfRegister {
    IrdDeviceRegisterFormat get ();
    void set (IrdDeviceRegisterFormat value);
}
member FormatOfRegister : IrdDeviceRegisterFormat with get, set

Property Value

Type: IrdDeviceRegisterFormat
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.Id Property

IrdDeviceRegisterId Property
identifier

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.Name Property

IrdDeviceRegisterName Property
name of the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.Por Property

IrdDeviceRegisterPor Property
power on reset value

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Por { get; set; }
Public Property Por As UInteger
    Get
    Set
public:
property unsigned int Por {
    unsigned int get ();
    void set (unsigned int value);
}
member Por : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.PorAvailable Property

IrdDeviceRegisterPorAvailable Property
power on reset value available?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool PorAvailable { get; set; }
Public Property PorAvailable As Boolean
    Get
    Set
public:
property bool PorAvailable {
    bool get ();
    void set (bool value);
}
member PorAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.SubAddrRead Property

IrdDeviceRegisterSubAddrRead Property
sub address of the register (read mode)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint SubAddrRead { get; set; }
Public Property SubAddrRead As UInteger
    Get
    Set
public:
property unsigned int SubAddrRead {
    unsigned int get ();
    void set (unsigned int value);
}
member SubAddrRead : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.SubAddrReadAvailable Property

IrdDeviceRegisterSubAddrReadAvailable Property
sub address available (read mode)?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SubAddrReadAvailable { get; set; }
Public Property SubAddrReadAvailable As Boolean
    Get
    Set
public:
property bool SubAddrReadAvailable {
    bool get ();
    void set (bool value);
}
member SubAddrReadAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.SubAddrWrite Property

IrdDeviceRegisterSubAddrWrite Property
sub address of the register (write mode)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint SubAddrWrite { get; set; }
Public Property SubAddrWrite As UInteger
    Get
    Set
public:
property unsigned int SubAddrWrite {
    unsigned int get ();
    void set (unsigned int value);
}
member SubAddrWrite : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.SubAddrWriteAvailable Property

IrdDeviceRegisterSubAddrWriteAvailable Property
sub address available (write mode)?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SubAddrWriteAvailable { get; set; }
Public Property SubAddrWriteAvailable As Boolean
    Get
    Set
public:
property bool SubAddrWriteAvailable {
    bool get ();
    void set (bool value);
}
member SubAddrWriteAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDeviceRegister Class


IrdDevice.Register.Format Enumeration

IrdDeviceRegisterFormat Enumeration
Enumeration to describe the format/type of a register. This information specifies how to transfer the data and the width of the data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Format
Public Enumeration Format
public enum class Format
type Format
Members
Member name | Value | Description
QUICK_CMD | 0 | quick command (S, ADDR, P)
EMPTY | 1 | empty (S, ADDR, SUB_ADDR, P)
SEND_RECV_BYTE | 2 | send receive byte (S, ADDR, BYTE, P)
BYTE | 3 | byte (S, ADDR, SUB_ADDR, DATA_BYTE, P)
WORD | 4 | word (S, ADDR, SUB_ADDR, DATA_WORD, P)
DWORD | 5 | dword (S, ADDR, SUB_ADDR, DATA_DWORD, P)
SMB_PC | 6 | SMB process call transfer
SMB_BLOCK | 7 | SMB block transfer
SMB_BLOCK_PC | 8 | SMB block write - block read process call transfer
BLOCK | 9 | block transfer
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Type Class

IrdDeviceType Class
Base class for IrdDeviceTypeAscii, IrdDeviceTypeString, IrdDeviceTypeArray, and IrdDeviceTypeInt.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceType
telos.I2cApi.DotNetIrdDeviceTypeArray
telos.I2cApi.DotNetIrdDeviceTypeAscii
telos.I2cApi.DotNetIrdDeviceTypeInt
telos.I2cApi.DotNetIrdDeviceTypeString

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class Type : ICloneable,
    IEquatable<IrdDeviceType>
Public MustInherit Class Type
    Implements ICloneable, IEquatable(Of IrdDeviceType)
public ref class Type abstract : ICloneable,
    IEquatable<IrdDeviceType^>
[<AbstractClassAttribute>]
type Type =
    class
        interface ICloneable
        interface IEquatable<IrdDeviceType>
    end

The IrdDeviceType type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceType | Constructor.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceType) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Id | identifier
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Type Constructor

IrdDeviceType Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Type()
Public Sub New
public:
Type()
new : unit -> Type
See Also

Reference

IrdDeviceType Class


Type Methods

Type Methods

The IrdDeviceType type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceType) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceType Class


IrdDevice.Type.Clone Method

IrdDeviceTypeClone Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.IrdDevice.Type.Clone"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object
public:
virtual Object^ Clone() abstract
abstract Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.IrdDevice.Type.Clone"]

Implements

ICloneableClone
See Also

Reference

IrdDeviceType Class


Type.Equals Method

TypeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceType) |
Top
See Also

Reference

IrdDeviceType Class


IrdDevice.Type.Equals Method (Object)

IrdDeviceTypeEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDeviceType Class
Equals Overload


IrdDevice.Type.Equals Method (IrdDevice.Type)

IrdDeviceTypeEquals Method (IrdDeviceType)

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.IrdDevice.Type.Equals(telos.I2cApi.DotNet.IrdDevice.Type)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract bool Equals(
    IrdDeviceType obj
)
Public MustOverride Function Equals (
    obj As IrdDeviceType
) As Boolean
public:
virtual bool Equals(
    IrdDeviceType^ obj
) abstract
abstract Equals :
        obj : IrdDeviceType -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceType

[Missing <param name="obj"/> documentation for "M:telos.I2cApi.DotNet.IrdDevice.Type.Equals(telos.I2cApi.DotNet.IrdDevice.Type)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.IrdDevice.Type.Equals(telos.I2cApi.DotNet.IrdDevice.Type)"]

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceType Class
Equals Overload


Type Properties

Type Properties

The IrdDeviceType type exposes the following members.

Properties
 | Name | Description
Public property | Id | identifier
Top
See Also

Reference

IrdDeviceType Class


IrdDevice.Type.Id Property

IrdDeviceTypeId Property
identifier

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceType Class


IrdDevice.TypeArray Class

IrdDeviceTypeArray Class
This class is used to store the information about an array type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceType
telos.I2cApi.DotNetIrdDeviceTypeArray

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TypeArray : IrdDeviceType,
    IEquatable<IrdDeviceTypeArray>
Public NotInheritable Class TypeArray
    Inherits IrdDeviceType
    Implements IEquatable(Of IrdDeviceTypeArray)
public ref class TypeArray sealed : public IrdDeviceType,
    IEquatable<IrdDeviceTypeArray^>
[<SealedAttribute>]
type TypeArray =
    class
        inherit IrdDeviceType
        interface IEquatable<IrdDeviceTypeArray>
    end

The IrdDeviceTypeArray type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeArray | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeArray) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Id | identifier (Inherited from IrdDeviceType.)
Public property | Length | length of the array
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeArray Constructor

IrdDeviceTypeArray Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TypeArray()
Public Sub New
public:
TypeArray()
new : unit -> TypeArray
See Also

Reference

IrdDeviceTypeArray Class


TypeArray Methods

TypeArray Methods

The IrdDeviceTypeArray type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeArray) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeArray Class


IrdDevice.TypeArray.Clone Method

IrdDeviceTypeArrayClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceTypeArray Class


TypeArray.Equals Method

TypeArrayEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeArray) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceTypeArray Class


IrdDevice.TypeArray.Equals Method (IrdDevice.Type)

IrdDeviceTypeArrayEquals Method (IrdDeviceType)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    IrdDeviceType obj
)
Public Overrides NotOverridable Function Equals (
    obj As IrdDeviceType
) As Boolean
public:
virtual bool Equals(
    IrdDeviceType^ obj
) override sealed
abstract Equals :
        obj : IrdDeviceType -> bool
override Equals :
        obj : IrdDeviceType -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceType
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeArray Class
Equals Overload


IrdDevice.TypeArray.Equals Method (IrdDevice.TypeArray)

IrdDeviceTypeArrayEquals Method (IrdDeviceTypeArray)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceTypeArray obj
)
Public Function Equals (
    obj As IrdDeviceTypeArray
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeArray^ obj
) sealed
abstract Equals :
        obj : IrdDeviceTypeArray -> bool
override Equals :
        obj : IrdDeviceTypeArray -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeArray
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeArray Class
Equals Overload


TypeArray Properties

TypeArray Properties

The IrdDeviceTypeArray type exposes the following members.

Properties
 | Name | Description
Public property | Id | identifier (Inherited from IrdDeviceType.)
Public property | Length | length of the array
Top
See Also

Reference

IrdDeviceTypeArray Class


IrdDevice.TypeArray.Length Property

IrdDeviceTypeArrayLength Property
length of the array

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Length { get; set; }
Public Property Length As UInteger
    Get
    Set
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}
member Length : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeArray Class


IrdDevice.TypeAscii Class

IrdDeviceTypeAscii Class
This class is used to store the information about an ASCII type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceType
telos.I2cApi.DotNetIrdDeviceTypeAscii

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TypeAscii : IrdDeviceType,
    IEquatable<IrdDeviceTypeAscii>
Public NotInheritable Class TypeAscii
    Inherits IrdDeviceType
    Implements IEquatable(Of IrdDeviceTypeAscii)
public ref class TypeAscii sealed : public IrdDeviceType,
    IEquatable<IrdDeviceTypeAscii^>
[<SealedAttribute>]
type TypeAscii =
    class
        inherit IrdDeviceType
        interface IEquatable<IrdDeviceTypeAscii>
    end

The IrdDeviceTypeAscii type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeAscii | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeAscii) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Tests whether the passed character is valid for the type defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Ranges | valid values/characters
Top
Properties
 | Name | Description
Public property | Id | identifier (Inherited from IrdDeviceType.)
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeAscii Constructor

IrdDeviceTypeAscii Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TypeAscii()
Public Sub New
public:
TypeAscii()
new : unit -> TypeAscii
See Also

Reference

IrdDeviceTypeAscii Class


TypeAscii Fields

TypeAscii Fields

The IrdDeviceTypeAscii type exposes the following members.

Fields
 | Name | Description
Public field | Ranges | valid values/characters
Top
See Also

Reference

IrdDeviceTypeAscii Class


IrdDevice.TypeAscii.Ranges Field

IrdDeviceTypeAsciiRanges Field
valid values/characters

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdDeviceTypeAsciiRange> Ranges
Public Ranges As List(Of IrdDeviceTypeAsciiRange)
public:
List<IrdDeviceTypeAsciiRange^>^ Ranges
val mutable Ranges: List<IrdDeviceTypeAsciiRange>

Field Value

Type: List IrdDeviceTypeAsciiRange
See Also

Reference

IrdDeviceTypeAscii Class


TypeAscii Methods

TypeAscii Methods

The IrdDeviceTypeAscii type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeAscii) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Tests whether the passed character is valid for the type defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeAscii Class


IrdDevice.TypeAscii.Clone Method

IrdDeviceTypeAsciiClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceTypeAscii Class


TypeAscii.Equals Method

TypeAsciiEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeAscii) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceTypeAscii Class


IrdDevice.TypeAscii.Equals Method (IrdDevice.Type)

IrdDeviceTypeAsciiEquals Method (IrdDeviceType)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    IrdDeviceType obj
)
Public Overrides NotOverridable Function Equals (
    obj As IrdDeviceType
) As Boolean
public:
virtual bool Equals(
    IrdDeviceType^ obj
) override sealed
abstract Equals :
        obj : IrdDeviceType -> bool
override Equals :
        obj : IrdDeviceType -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceType
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeAscii Class
Equals Overload


IrdDevice.TypeAscii.Equals Method (IrdDevice.TypeAscii)

IrdDeviceTypeAsciiEquals Method (IrdDeviceTypeAscii)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceTypeAscii obj
)
Public Function Equals (
    obj As IrdDeviceTypeAscii
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeAscii^ obj
) sealed
abstract Equals :
        obj : IrdDeviceTypeAscii -> bool
override Equals :
        obj : IrdDeviceTypeAscii -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeAscii
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeAscii Class
Equals Overload


IrdDevice.TypeAscii.IsValid Method

IrdDeviceTypeAsciiIsValid Method
Tests whether the passed character is valid for the type defined by an instance of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsValid(
    char value
)
Public Function IsValid (
    value As Char
) As Boolean
public:
bool IsValid(
    wchar_t value
)
member IsValid :
        value : char -> bool

Parameters

value
Type: SystemChar
character to be tested

Return Value

Type: Boolean
valid (true), not valid (false)
See Also

Reference

IrdDeviceTypeAscii Class


TypeAscii Properties

TypeAscii Properties

The IrdDeviceTypeAscii type exposes the following members.

Properties
 | Name | Description
Public property | Id | identifier (Inherited from IrdDeviceType.)
Top
See Also

Reference

IrdDeviceTypeAscii Class


IrdDevice.TypeAscii.Range Class

IrdDeviceTypeAsciiRange Class
This class is used to store a range.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceTypeAsciiRange

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Range : ICloneable,
    IEquatable<IrdDeviceTypeAsciiRange>
Public NotInheritable Class Range
    Implements ICloneable, IEquatable(Of IrdDeviceTypeAsciiRange)
public ref class Range sealed : ICloneable,
    IEquatable<IrdDeviceTypeAsciiRange^>
[<SealedAttribute>]
type Range =
    class
        interface ICloneable
        interface IEquatable<IrdDeviceTypeAsciiRange>
    end

The IrdDeviceTypeAsciiRange type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeAsciiRange | Initializes a new instance of the IrdDeviceTypeAsciiRange class
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Contains | Tests whether the passed value is in the range defined by an instance of this class.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceTypeAsciiRange) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverlapping | Tests whether the passed range is overlapping with the range defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Start | first element
Public property | Stop | last element
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeAscii.Range Constructor

IrdDeviceTypeAsciiRange Constructor
Initializes a new instance of the IrdDeviceTypeAsciiRange class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Range()
Public Sub New
public:
Range()
new : unit -> Range
See Also

Reference

IrdDeviceTypeAsciiRange Class


Range Methods

Range Methods

The IrdDeviceTypeAsciiRange type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Contains | Tests whether the passed value is in the range defined by an instance of this class.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceTypeAsciiRange) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverlapping | Tests whether the passed range is overlapping with the range defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeAsciiRange Class


IrdDevice.TypeAscii.Range.Clone Method

IrdDeviceTypeAsciiRangeClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceTypeAsciiRange Class


IrdDevice.TypeAscii.Range.Contains Method

IrdDeviceTypeAsciiRangeContains Method
Tests whether the passed value is in the range defined by an instance of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    uint value
)
Public Function Contains (
    value As UInteger
) As Boolean
public:
bool Contains(
    unsigned int value
)
member Contains :
        value : uint32 -> bool

Parameters

value
Type: SystemUInt32
value to be tested

Return Value

Type: Boolean
in range (true), not in range (false)
See Also

Reference

IrdDeviceTypeAsciiRange Class


Range.Equals Method

RangeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceTypeAsciiRange) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceTypeAsciiRange Class


IrdDevice.TypeAscii.Range.Equals Method (Object)

IrdDeviceTypeAsciiRangeEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDeviceTypeAsciiRange Class
Equals Overload


IrdDevice.TypeAscii.Range.Equals Method (IrdDevice.TypeAscii.Range)

IrdDeviceTypeAsciiRangeEquals Method (IrdDeviceTypeAsciiRange)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceTypeAsciiRange obj
)
Public Function Equals (
    obj As IrdDeviceTypeAsciiRange
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeAsciiRange^ obj
) sealed
abstract Equals :
        obj : IrdDeviceTypeAsciiRange -> bool
override Equals :
        obj : IrdDeviceTypeAsciiRange -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeAsciiRange
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeAsciiRange Class
Equals Overload


IrdDevice.TypeAscii.Range.IsOverlapping Method

IrdDeviceTypeAsciiRangeIsOverlapping Method
Tests whether the passed range is overlapping with the range defined by an instance of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOverlapping(
    IrdDeviceTypeAsciiRange range
)
Public Function IsOverlapping (
    range As IrdDeviceTypeAsciiRange
) As Boolean
public:
bool IsOverlapping(
    IrdDeviceTypeAsciiRange^ range
)
member IsOverlapping :
        range : IrdDeviceTypeAsciiRange -> bool

Parameters

range
Type: telos.I2cApi.DotNetIrdDeviceTypeAsciiRange
range to be tested

Return Value

Type: Boolean
is overlapping (true), is not overlapping (false)
See Also

Reference

IrdDeviceTypeAsciiRange Class


Range Properties

Range Properties

The IrdDeviceTypeAsciiRange type exposes the following members.

Properties
 | Name | Description
Public property | Start | first element
Public property | Stop | last element
Top
See Also

Reference

IrdDeviceTypeAsciiRange Class


IrdDevice.TypeAscii.Range.Start Property

IrdDeviceTypeAsciiRangeStart Property
first element

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Start { get; set; }
Public Property Start As UInteger
    Get
    Set
public:
property unsigned int Start {
    unsigned int get ();
    void set (unsigned int value);
}
member Start : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeAsciiRange Class


IrdDevice.TypeAscii.Range.Stop Property

IrdDeviceTypeAsciiRangeStop Property
last element

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Stop { get; set; }
Public Property Stop As UInteger
    Get
    Set
public:
property unsigned int Stop {
    unsigned int get ();
    void set (unsigned int value);
}
member Stop : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeAsciiRange Class


IrdDevice.TypeInt Class

IrdDeviceTypeInt Class
This class is used to store the information about an integer type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceType
telos.I2cApi.DotNetIrdDeviceTypeInt

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TypeInt : IrdDeviceType,
    IEquatable<IrdDeviceTypeInt>
Public NotInheritable Class TypeInt
    Inherits IrdDeviceType
    Implements IEquatable(Of IrdDeviceTypeInt)
public ref class TypeInt sealed : public IrdDeviceType,
    IEquatable<IrdDeviceTypeInt^>
[<SealedAttribute>]
type TypeInt =
    class
        inherit IrdDeviceType
        interface IEquatable<IrdDeviceTypeInt>
    end

The IrdDeviceTypeInt type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeInt | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeInt) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueName(Int32) | Returns the name of the specified Int32 value or "".
Public method | GetValueName(UInt32) | Returns the name of the specified UInt32 value or "".
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Divider | scale values with this divider before displaying
Public property | Formula | use this formula before displaying values
Public property | Id | identifier (Inherited from IrdDeviceType.)
Public property | SignedValue | signed integer type?
Public property | StartRangeS | first valid value of the type (signed)
Public property | StartRangeU | first valid value of the type (unsigned)
Public property | StopRangeS | last valid value of the type (signed)
Public property | StopRangeU | last valid value of the type (unsigned)
Public property | ValueNames | names of values
Public property | Width | width (e.g. "2" for a WORD)
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeInt Constructor

IrdDeviceTypeInt Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TypeInt()
Public Sub New
public:
TypeInt()
new : unit -> TypeInt
See Also

Reference

IrdDeviceTypeInt Class


TypeInt Methods

TypeInt Methods

The IrdDeviceTypeInt type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeInt) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueName(Int32) | Returns the name of the specified Int32 value or "".
Public method | GetValueName(UInt32) | Returns the name of the specified UInt32 value or "".
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.Clone Method

IrdDeviceTypeIntClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceTypeInt Class


TypeInt.Equals Method

TypeIntEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeInt) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.Equals Method (IrdDevice.Type)

IrdDeviceTypeIntEquals Method (IrdDeviceType)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    IrdDeviceType obj
)
Public Overrides NotOverridable Function Equals (
    obj As IrdDeviceType
) As Boolean
public:
virtual bool Equals(
    IrdDeviceType^ obj
) override sealed
abstract Equals :
        obj : IrdDeviceType -> bool
override Equals :
        obj : IrdDeviceType -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceType
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeInt Class
Equals Overload


IrdDevice.TypeInt.Equals Method (IrdDevice.TypeInt)

IrdDeviceTypeIntEquals Method (IrdDeviceTypeInt)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceTypeInt obj
)
Public Function Equals (
    obj As IrdDeviceTypeInt
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeInt^ obj
) sealed
abstract Equals :
        obj : IrdDeviceTypeInt -> bool
override Equals :
        obj : IrdDeviceTypeInt -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeInt
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeInt Class
Equals Overload


TypeInt.GetValueName Method

TypeIntGetValueName Method
Overload List
 | Name | Description
Public method | GetValueName(Int32) | Returns the name of the specified Int32 value or "".
Public method | GetValueName(UInt32) | Returns the name of the specified UInt32 value or "".
Top
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.GetValueName Method (Int32)

IrdDeviceTypeIntGetValueName Method (Int32)
Returns the name of the specified Int32 value or "".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetValueName(
    int val
)
Public Function GetValueName (
    val As Integer
) As String
public:
String^ GetValueName(
    int val
)
member GetValueName :
        val : int -> string

Parameters

val
Type: SystemInt32
value

Return Value

Type: String
name of the value or ""
See Also

Reference

IrdDeviceTypeInt Class
GetValueName Overload


IrdDevice.TypeInt.GetValueName Method (UInt32)

IrdDeviceTypeIntGetValueName Method (UInt32)
Returns the name of the specified UInt32 value or "".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetValueName(
    uint val
)
Public Function GetValueName (
    val As UInteger
) As String
public:
String^ GetValueName(
    unsigned int val
)
member GetValueName :
        val : uint32 -> string

Parameters

val
Type: SystemUInt32
value

Return Value

Type: String
name of the value or ""
See Also

Reference

IrdDeviceTypeInt Class
GetValueName Overload


TypeInt Properties

TypeInt Properties

The IrdDeviceTypeInt type exposes the following members.

Properties
 | Name | Description
Public property | Divider | scale values with this divider before displaying
Public property | Formula | use this formula before displaying values
Public property | Id | identifier (Inherited from IrdDeviceType.)
Public property | SignedValue | signed integer type?
Public property | StartRangeS | first valid value of the type (signed)
Public property | StartRangeU | first valid value of the type (unsigned)
Public property | StopRangeS | last valid value of the type (signed)
Public property | StopRangeU | last valid value of the type (unsigned)
Public property | ValueNames | names of values
Public property | Width | width (e.g. "2" for a WORD)
Top
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.Divider Property

IrdDeviceTypeIntDivider Property
scale values with this divider before displaying

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public double Divider { get; set; }
Public Property Divider As Double
    Get
    Set
public:
property double Divider {
    double get ();
    void set (double value);
}
member Divider : float with get, set

Property Value

Type: Double
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.Formula Property

IrdDeviceTypeIntFormula Property
use this formula before displaying values

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Formula { get; set; }
Public Property Formula As String
    Get
    Set
public:
property String^ Formula {
    String^ get ();
    void set (String^ value);
}
member Formula : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.SignedValue Property

IrdDeviceTypeIntSignedValue Property
signed integer type?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SignedValue { get; set; }
Public Property SignedValue As Boolean
    Get
    Set
public:
property bool SignedValue {
    bool get ();
    void set (bool value);
}
member SignedValue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.StartRangeS Property

IrdDeviceTypeIntStartRangeS Property
first valid value of the type (signed)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int StartRangeS { get; set; }
Public Property StartRangeS As Integer
    Get
    Set
public:
property int StartRangeS {
    int get ();
    void set (int value);
}
member StartRangeS : int with get, set

Property Value

Type: Int32
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.StartRangeU Property

IrdDeviceTypeIntStartRangeU Property
first valid value of the type (unsigned)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint StartRangeU { get; set; }
Public Property StartRangeU As UInteger
    Get
    Set
public:
property unsigned int StartRangeU {
    unsigned int get ();
    void set (unsigned int value);
}
member StartRangeU : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.StopRangeS Property

IrdDeviceTypeIntStopRangeS Property
last valid value of the type (signed)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int StopRangeS { get; set; }
Public Property StopRangeS As Integer
    Get
    Set
public:
property int StopRangeS {
    int get ();
    void set (int value);
}
member StopRangeS : int with get, set

Property Value

Type: Int32
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.StopRangeU Property

IrdDeviceTypeIntStopRangeU Property
last valid value of the type (unsigned)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint StopRangeU { get; set; }
Public Property StopRangeU As UInteger
    Get
    Set
public:
property unsigned int StopRangeU {
    unsigned int get ();
    void set (unsigned int value);
}
member StopRangeU : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.ValueNames Property

IrdDeviceTypeIntValueNames Property
names of values

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdDeviceTypeIntValueName> ValueNames { get; set; }
Public Property ValueNames As List(Of IrdDeviceTypeIntValueName)
    Get
    Set
public:
property List<IrdDeviceTypeIntValueName^>^ ValueNames {
    List<IrdDeviceTypeIntValueName^>^ get ();
    void set (List<IrdDeviceTypeIntValueName^>^ value);
}
member ValueNames : List<IrdDeviceTypeIntValueName> with get, set

Property Value

Type: List IrdDeviceTypeIntValueName
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.Width Property

IrdDeviceTypeIntWidth Property
width (e.g. "2" for a WORD)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Width { get; set; }
Public Property Width As Byte
    Get
    Set
public:
property unsigned char Width {
    unsigned char get ();
    void set (unsigned char value);
}
member Width : byte with get, set

Property Value

Type: Byte
See Also

Reference

IrdDeviceTypeInt Class


IrdDevice.TypeInt.ValueName Class

IrdDeviceTypeIntValueName Class
Stores the name of a value or a range of values.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceTypeIntValueName
telos.I2cApi.DotNetIrdDeviceTypeIntValueNameInt32
telos.I2cApi.DotNetIrdDeviceTypeIntValueNameUInt32

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ValueName : ICloneable,
    IEquatable<IrdDeviceTypeIntValueName>
Public MustInherit Class ValueName
    Implements ICloneable, IEquatable(Of IrdDeviceTypeIntValueName)
public ref class ValueName abstract : ICloneable,
    IEquatable<IrdDeviceTypeIntValueName^>
[<AbstractClassAttribute>]
type ValueName =
    class
        interface ICloneable
        interface IEquatable<IrdDeviceTypeIntValueName>
    end

The IrdDeviceTypeIntValueName type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeIntValueName | Initializes a new instance of the IrdDeviceTypeIntValueName class
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceTypeIntValueName) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeInt.ValueName Constructor

IrdDeviceTypeIntValueName Constructor
Initializes a new instance of the IrdDeviceTypeIntValueName class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueName()
Public Sub New
public:
ValueName()
new : unit -> ValueName
See Also

Reference

IrdDeviceTypeIntValueName Class


ValueName Methods

ValueName Methods

The IrdDeviceTypeIntValueName type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceTypeIntValueName) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeIntValueName Class


IrdDevice.TypeInt.ValueName.Clone Method

IrdDeviceTypeIntValueNameClone Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName.Clone"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object
public:
virtual Object^ Clone() abstract
abstract Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName.Clone"]

Implements

ICloneableClone
See Also

Reference

IrdDeviceTypeIntValueName Class


ValueName.Equals Method

ValueNameEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceTypeIntValueName) |
Top
See Also

Reference

IrdDeviceTypeIntValueName Class


IrdDevice.TypeInt.ValueName.Equals Method (Object)

IrdDeviceTypeIntValueNameEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDeviceTypeIntValueName Class
Equals Overload


IrdDevice.TypeInt.ValueName.Equals Method (IrdDevice.TypeInt.ValueName)

IrdDeviceTypeIntValueNameEquals Method (IrdDeviceTypeIntValueName)

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName.Equals(telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract bool Equals(
    IrdDeviceTypeIntValueName obj
)
Public MustOverride Function Equals (
    obj As IrdDeviceTypeIntValueName
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeIntValueName^ obj
) abstract
abstract Equals :
        obj : IrdDeviceTypeIntValueName -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeIntValueName

[Missing <param name="obj"/> documentation for "M:telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName.Equals(telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName.Equals(telos.I2cApi.DotNet.IrdDevice.TypeInt.ValueName)"]

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeIntValueName Class
Equals Overload


IrdDevice.TypeInt.ValueNameInt32 Class

IrdDeviceTypeIntValueNameInt32 Class
Stores the name of a value or a range of values. Used for Int32 values.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceTypeIntValueName
telos.I2cApi.DotNetIrdDeviceTypeIntValueNameInt32

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ValueNameInt32 : IrdDeviceTypeIntValueName,
    ICloneable, IEquatable<IrdDeviceTypeIntValueNameInt32>
Public NotInheritable Class ValueNameInt32
    Inherits IrdDeviceTypeIntValueName
    Implements ICloneable, IEquatable(Of IrdDeviceTypeIntValueNameInt32)
public ref class ValueNameInt32 sealed : public IrdDeviceTypeIntValueName,
    ICloneable, IEquatable<IrdDeviceTypeIntValueNameInt32^>
[<SealedAttribute>]
type ValueNameInt32 =
    class
        inherit IrdDeviceTypeIntValueName
        interface ICloneable
        interface IEquatable<IrdDeviceTypeIntValueNameInt32>
    end

The IrdDeviceTypeIntValueNameInt32 type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeIntValueNameInt32 | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeIntValueNameClone.)
Public method | Contains | Tests whether the passed value is in the range defined by an instance of this class.
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceTypeIntValueName.)
Public method | Equals(IrdDeviceTypeIntValueName) | Tests whether both objects are equal. (Overrides IrdDeviceTypeIntValueNameEquals(IrdDeviceTypeIntValueName).)
Public method | Equals(IrdDeviceTypeIntValueNameInt32) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverlapping | Tests whether the passed range is overlapping with the range defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | value name
Public property | Start | first value
Public property | Stop | last value
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeInt.ValueNameInt32 Constructor

IrdDeviceTypeIntValueNameInt32 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueNameInt32()
Public Sub New
public:
ValueNameInt32()
new : unit -> ValueNameInt32
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


ValueNameInt32 Methods

ValueNameInt32 Methods

The IrdDeviceTypeIntValueNameInt32 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeIntValueNameClone.)
Public method | Contains | Tests whether the passed value is in the range defined by an instance of this class.
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceTypeIntValueName.)
Public method | Equals(IrdDeviceTypeIntValueName) | Tests whether both objects are equal. (Overrides IrdDeviceTypeIntValueNameEquals(IrdDeviceTypeIntValueName).)
Public method | Equals(IrdDeviceTypeIntValueNameInt32) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverlapping | Tests whether the passed range is overlapping with the range defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


IrdDevice.TypeInt.ValueNameInt32.Clone Method

IrdDeviceTypeIntValueNameInt32Clone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
ICloneableClone
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


IrdDevice.TypeInt.ValueNameInt32.Contains Method

IrdDeviceTypeIntValueNameInt32Contains Method
Tests whether the passed value is in the range defined by an instance of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    int value
)
Public Function Contains (
    value As Integer
) As Boolean
public:
bool Contains(
    int value
)
member Contains :
        value : int -> bool

Parameters

value
Type: SystemInt32
value to be tested

Return Value

Type: Boolean
in range (true), not in range (false)
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


ValueNameInt32.Equals Method

ValueNameInt32Equals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceTypeIntValueName.)
Public method | Equals(IrdDeviceTypeIntValueName) | Tests whether both objects are equal. (Overrides IrdDeviceTypeIntValueNameEquals(IrdDeviceTypeIntValueName).)
Public method | Equals(IrdDeviceTypeIntValueNameInt32) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


IrdDevice.TypeInt.ValueNameInt32.Equals Method (IrdDevice.TypeInt.ValueName)

IrdDeviceTypeIntValueNameInt32Equals Method (IrdDeviceTypeIntValueName)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    IrdDeviceTypeIntValueName obj
)
Public Overrides NotOverridable Function Equals (
    obj As IrdDeviceTypeIntValueName
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeIntValueName^ obj
) override sealed
abstract Equals :
        obj : IrdDeviceTypeIntValueName -> bool
override Equals :
        obj : IrdDeviceTypeIntValueName -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeIntValueName
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class
Equals Overload


IrdDevice.TypeInt.ValueNameInt32.Equals Method (IrdDevice.TypeInt.ValueNameInt32)

IrdDeviceTypeIntValueNameInt32Equals Method (IrdDeviceTypeIntValueNameInt32)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceTypeIntValueNameInt32 obj
)
Public Function Equals (
    obj As IrdDeviceTypeIntValueNameInt32
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeIntValueNameInt32^ obj
) sealed
abstract Equals :
        obj : IrdDeviceTypeIntValueNameInt32 -> bool
override Equals :
        obj : IrdDeviceTypeIntValueNameInt32 -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeIntValueNameInt32
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class
Equals Overload


IrdDevice.TypeInt.ValueNameInt32.IsOverlapping Method

IrdDeviceTypeIntValueNameInt32IsOverlapping Method
Tests whether the passed range is overlapping with the range defined by an instance of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOverlapping(
    IrdDeviceTypeIntValueNameInt32 range
)
Public Function IsOverlapping (
    range As IrdDeviceTypeIntValueNameInt32
) As Boolean
public:
bool IsOverlapping(
    IrdDeviceTypeIntValueNameInt32^ range
)
member IsOverlapping :
        range : IrdDeviceTypeIntValueNameInt32 -> bool

Parameters

range
Type: telos.I2cApi.DotNetIrdDeviceTypeIntValueNameInt32
range to be tested

Return Value

Type: Boolean
is overlapping (true), is not overlapping (false)
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


ValueNameInt32 Properties

ValueNameInt32 Properties

The IrdDeviceTypeIntValueNameInt32 type exposes the following members.

Properties
 | Name | Description
Public property | Name | value name
Public property | Start | first value
Public property | Stop | last value
Top
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


IrdDevice.TypeInt.ValueNameInt32.Name Property

IrdDeviceTypeIntValueNameInt32Name Property
value name

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


IrdDevice.TypeInt.ValueNameInt32.Start Property

IrdDeviceTypeIntValueNameInt32Start Property
first value

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Type: Int32
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


IrdDevice.TypeInt.ValueNameInt32.Stop Property

IrdDeviceTypeIntValueNameInt32Stop Property
last value

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Stop { get; set; }
Public Property Stop As Integer
    Get
    Set
public:
property int Stop {
    int get ();
    void set (int value);
}
member Stop : int with get, set

Property Value

Type: Int32
See Also

Reference

IrdDeviceTypeIntValueNameInt32 Class


IrdDevice.TypeInt.ValueNameUInt32 Class

IrdDeviceTypeIntValueNameUInt32 Class
Stores the name of a value or a range of values. Used for UInt32 values.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceTypeIntValueName
telos.I2cApi.DotNetIrdDeviceTypeIntValueNameUInt32

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ValueNameUInt32 : IrdDeviceTypeIntValueName,
    IEquatable<IrdDeviceTypeIntValueNameUInt32>
Public NotInheritable Class ValueNameUInt32
    Inherits IrdDeviceTypeIntValueName
    Implements IEquatable(Of IrdDeviceTypeIntValueNameUInt32)
public ref class ValueNameUInt32 sealed : public IrdDeviceTypeIntValueName,
    IEquatable<IrdDeviceTypeIntValueNameUInt32^>
[<SealedAttribute>]
type ValueNameUInt32 =
    class
        inherit IrdDeviceTypeIntValueName
        interface IEquatable<IrdDeviceTypeIntValueNameUInt32>
    end

The IrdDeviceTypeIntValueNameUInt32 type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeIntValueNameUInt32 | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeIntValueNameClone.)
Public method | Contains | Tests whether the passed value is in the range defined by an instance of this class.
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceTypeIntValueName.)
Public method | Equals(IrdDeviceTypeIntValueName) | Tests whether both objects are equal. (Overrides IrdDeviceTypeIntValueNameEquals(IrdDeviceTypeIntValueName).)
Public method | Equals(IrdDeviceTypeIntValueNameUInt32) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverlapping | Tests whether the passed range is overlapping with the range defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | value name
Public property | Start | first value
Public property | Stop | last value
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeInt.ValueNameUInt32 Constructor

IrdDeviceTypeIntValueNameUInt32 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueNameUInt32()
Public Sub New
public:
ValueNameUInt32()
new : unit -> ValueNameUInt32
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


ValueNameUInt32 Methods

ValueNameUInt32 Methods

The IrdDeviceTypeIntValueNameUInt32 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeIntValueNameClone.)
Public method | Contains | Tests whether the passed value is in the range defined by an instance of this class.
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceTypeIntValueName.)
Public method | Equals(IrdDeviceTypeIntValueName) | Tests whether both objects are equal. (Overrides IrdDeviceTypeIntValueNameEquals(IrdDeviceTypeIntValueName).)
Public method | Equals(IrdDeviceTypeIntValueNameUInt32) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverlapping | Tests whether the passed range is overlapping with the range defined by an instance of this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


IrdDevice.TypeInt.ValueNameUInt32.Clone Method

IrdDeviceTypeIntValueNameUInt32Clone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


IrdDevice.TypeInt.ValueNameUInt32.Contains Method

IrdDeviceTypeIntValueNameUInt32Contains Method
Tests whether the passed value is in the range defined by an instance of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    uint value
)
Public Function Contains (
    value As UInteger
) As Boolean
public:
bool Contains(
    unsigned int value
)
member Contains :
        value : uint32 -> bool

Parameters

value
Type: SystemUInt32
value to be tested

Return Value

Type: Boolean
in range (true), not in range (false)
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


ValueNameUInt32.Equals Method

ValueNameUInt32Equals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceTypeIntValueName.)
Public method | Equals(IrdDeviceTypeIntValueName) | Tests whether both objects are equal. (Overrides IrdDeviceTypeIntValueNameEquals(IrdDeviceTypeIntValueName).)
Public method | Equals(IrdDeviceTypeIntValueNameUInt32) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


IrdDevice.TypeInt.ValueNameUInt32.Equals Method (IrdDevice.TypeInt.ValueName)

IrdDeviceTypeIntValueNameUInt32Equals Method (IrdDeviceTypeIntValueName)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    IrdDeviceTypeIntValueName obj
)
Public Overrides NotOverridable Function Equals (
    obj As IrdDeviceTypeIntValueName
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeIntValueName^ obj
) override sealed
abstract Equals :
        obj : IrdDeviceTypeIntValueName -> bool
override Equals :
        obj : IrdDeviceTypeIntValueName -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeIntValueName
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class
Equals Overload


IrdDevice.TypeInt.ValueNameUInt32.Equals Method (IrdDevice.TypeInt.ValueNameUInt32)

IrdDeviceTypeIntValueNameUInt32Equals Method (IrdDeviceTypeIntValueNameUInt32)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceTypeIntValueNameUInt32 obj
)
Public Function Equals (
    obj As IrdDeviceTypeIntValueNameUInt32
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeIntValueNameUInt32^ obj
) sealed
abstract Equals :
        obj : IrdDeviceTypeIntValueNameUInt32 -> bool
override Equals :
        obj : IrdDeviceTypeIntValueNameUInt32 -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeIntValueNameUInt32
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class
Equals Overload


IrdDevice.TypeInt.ValueNameUInt32.IsOverlapping Method

IrdDeviceTypeIntValueNameUInt32IsOverlapping Method
Tests whether the passed range is overlapping with the range defined by an instance of this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsOverlapping(
    IrdDeviceTypeIntValueNameUInt32 range
)
Public Function IsOverlapping (
    range As IrdDeviceTypeIntValueNameUInt32
) As Boolean
public:
bool IsOverlapping(
    IrdDeviceTypeIntValueNameUInt32^ range
)
member IsOverlapping :
        range : IrdDeviceTypeIntValueNameUInt32 -> bool

Parameters

range
Type: telos.I2cApi.DotNetIrdDeviceTypeIntValueNameUInt32
range to be tested

Return Value

Type: Boolean
is overlapping (true), is not overlapping (false)
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


ValueNameUInt32 Properties

ValueNameUInt32 Properties

The IrdDeviceTypeIntValueNameUInt32 type exposes the following members.

Properties
 | Name | Description
Public property | Name | value name
Public property | Start | first value
Public property | Stop | last value
Top
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


IrdDevice.TypeInt.ValueNameUInt32.Name Property

IrdDeviceTypeIntValueNameUInt32Name Property
value name

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


IrdDevice.TypeInt.ValueNameUInt32.Start Property

IrdDeviceTypeIntValueNameUInt32Start Property
first value

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Start { get; set; }
Public Property Start As UInteger
    Get
    Set
public:
property unsigned int Start {
    unsigned int get ();
    void set (unsigned int value);
}
member Start : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


IrdDevice.TypeInt.ValueNameUInt32.Stop Property

IrdDeviceTypeIntValueNameUInt32Stop Property
last value

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Stop { get; set; }
Public Property Stop As UInteger
    Get
    Set
public:
property unsigned int Stop {
    unsigned int get ();
    void set (unsigned int value);
}
member Stop : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeIntValueNameUInt32 Class


IrdDevice.TypeString Class

IrdDeviceTypeString Class
This class is used to store the information about a string type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceType
telos.I2cApi.DotNetIrdDeviceTypeString

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TypeString : IrdDeviceType,
    IEquatable<IrdDeviceTypeString>
Public NotInheritable Class TypeString
    Inherits IrdDeviceType
    Implements IEquatable(Of IrdDeviceTypeString)
public ref class TypeString sealed : public IrdDeviceType,
    IEquatable<IrdDeviceTypeString^>
[<SealedAttribute>]
type TypeString =
    class
        inherit IrdDeviceType
        interface IEquatable<IrdDeviceTypeString>
    end

The IrdDeviceTypeString type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceTypeString | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeString) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AllowedAscii | identifier of IrdDeviceTypeAscii object defining the allowed characters
Public property | Id | identifier (Inherited from IrdDeviceType.)
Public property | MaxLength | maximum allowed length of the string (without '\\0')
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.TypeString Constructor

IrdDeviceTypeString Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TypeString()
Public Sub New
public:
TypeString()
new : unit -> TypeString
See Also

Reference

IrdDeviceTypeString Class


TypeString Methods

TypeString Methods

The IrdDeviceTypeString type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides IrdDeviceTypeClone.)
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeString) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceTypeString Class


IrdDevice.TypeString.Clone Method

IrdDeviceTypeStringClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceTypeString Class


TypeString.Equals Method

TypeStringEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Inherited from IrdDeviceType.)
Public method | Equals(IrdDeviceType) | Tests whether both objects are equal. (Overrides IrdDeviceTypeEquals(IrdDeviceType).)
Public method | Equals(IrdDeviceTypeString) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceTypeString Class


IrdDevice.TypeString.Equals Method (IrdDevice.Type)

IrdDeviceTypeStringEquals Method (IrdDeviceType)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    IrdDeviceType obj
)
Public Overrides NotOverridable Function Equals (
    obj As IrdDeviceType
) As Boolean
public:
virtual bool Equals(
    IrdDeviceType^ obj
) override sealed
abstract Equals :
        obj : IrdDeviceType -> bool
override Equals :
        obj : IrdDeviceType -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceType
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeString Class
Equals Overload


IrdDevice.TypeString.Equals Method (IrdDevice.TypeString)

IrdDeviceTypeStringEquals Method (IrdDeviceTypeString)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceTypeString obj
)
Public Function Equals (
    obj As IrdDeviceTypeString
) As Boolean
public:
virtual bool Equals(
    IrdDeviceTypeString^ obj
) sealed
abstract Equals :
        obj : IrdDeviceTypeString -> bool
override Equals :
        obj : IrdDeviceTypeString -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceTypeString
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceTypeString Class
Equals Overload


TypeString Properties

TypeString Properties

The IrdDeviceTypeString type exposes the following members.

Properties
 | Name | Description
Public property | AllowedAscii | identifier of IrdDeviceTypeAscii object defining the allowed characters
Public property | Id | identifier (Inherited from IrdDeviceType.)
Public property | MaxLength | maximum allowed length of the string (without '\\0')
Top
See Also

Reference

IrdDeviceTypeString Class


IrdDevice.TypeString.AllowedAscii Property

IrdDeviceTypeStringAllowedAscii Property
identifier of IrdDeviceTypeAscii object defining the allowed characters

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string AllowedAscii { get; set; }
Public Property AllowedAscii As String
    Get
    Set
public:
property String^ AllowedAscii {
    String^ get ();
    void set (String^ value);
}
member AllowedAscii : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceTypeString Class


IrdDevice.TypeString.MaxLength Property

IrdDeviceTypeStringMaxLength Property
maximum allowed length of the string (without '\\0')

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MaxLength { get; set; }
Public Property MaxLength As UInteger
    Get
    Set
public:
property unsigned int MaxLength {
    unsigned int get ();
    void set (unsigned int value);
}
member MaxLength : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceTypeString Class


IrdDevice.Udid Class

IrdDeviceUdid Class
This class is used to store an UDID, which stands for "Unique Device Identifier". These IDs a part of the SMBus ARP protocol.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceUdid

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Udid : ICloneable, IEquatable<IrdDeviceUdid>
Public NotInheritable Class Udid
    Implements ICloneable, IEquatable(Of IrdDeviceUdid)
public ref class Udid sealed : ICloneable,
    IEquatable<IrdDeviceUdid^>
[<SealedAttribute>]
type Udid =
    class
        interface ICloneable
        interface IEquatable<IrdDeviceUdid>
    end

The IrdDeviceUdid type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceUdid | Initializes a new instance of the IrdDeviceUdid class
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceUdid) | Tests whether both UDIDs are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DeviceId | device ID
Public property | VendorId | vendor ID
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Udid Constructor

IrdDeviceUdid Constructor
Initializes a new instance of the IrdDeviceUdid class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Udid()
Public Sub New
public:
Udid()
new : unit -> Udid
See Also

Reference

IrdDeviceUdid Class


Udid Methods

Udid Methods

The IrdDeviceUdid type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceUdid) | Tests whether both UDIDs are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceUdid Class


IrdDevice.Udid.Clone Method

IrdDeviceUdidClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceUdid Class


Udid.Equals Method

UdidEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceUdid) | Tests whether both UDIDs are equal.
Top
See Also

Reference

IrdDeviceUdid Class


IrdDevice.Udid.Equals Method (Object)

IrdDeviceUdidEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDeviceUdid Class
Equals Overload


IrdDevice.Udid.Equals Method (IrdDevice.Udid)

IrdDeviceUdidEquals Method (IrdDeviceUdid)
Tests whether both UDIDs are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceUdid udid
)
Public Function Equals (
    udid As IrdDeviceUdid
) As Boolean
public:
virtual bool Equals(
    IrdDeviceUdid^ udid
) sealed
abstract Equals :
        udid : IrdDeviceUdid -> bool
override Equals :
        udid : IrdDeviceUdid -> bool

Parameters

udid
Type: telos.I2cApi.DotNetIrdDeviceUdid
other UDID

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceUdid Class
Equals Overload


Udid Properties

Udid Properties

The IrdDeviceUdid type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | device ID
Public property | VendorId | vendor ID
Top
See Also

Reference

IrdDeviceUdid Class


IrdDevice.Udid.DeviceId Property

IrdDeviceUdidDeviceId Property
device ID

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort DeviceId { get; set; }
Public Property DeviceId As UShort
    Get
    Set
public:
property unsigned short DeviceId {
    unsigned short get ();
    void set (unsigned short value);
}
member DeviceId : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

IrdDeviceUdid Class


IrdDevice.Udid.VendorId Property

IrdDeviceUdidVendorId Property
vendor ID

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort VendorId { get; set; }
Public Property VendorId As UShort
    Get
    Set
public:
property unsigned short VendorId {
    unsigned short get ();
    void set (unsigned short value);
}
member VendorId : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

IrdDeviceUdid Class


IrdDevice.Value Class

IrdDeviceValue Class
This class is used to store the information about a value. A value interprets the content of registers. E.g. a status register containing 8 status bits can be described as 8 values.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceValue

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Value : ICloneable,
    IEquatable<IrdDeviceValue>
Public NotInheritable Class Value
    Implements ICloneable, IEquatable(Of IrdDeviceValue)
public ref class Value sealed : ICloneable,
    IEquatable<IrdDeviceValue^>
[<SealedAttribute>]
type Value =
    class
        interface ICloneable
        interface IEquatable<IrdDeviceValue>
    end

The IrdDeviceValue type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceValue | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceValue) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Bcd | binary coded decimal?
Public property | DirectionOfValue | direction
Public property | ElementWidth | number of bits used for one byte (used for IrdDeviceTypeString and IrdDeviceTypeArray)
Public property | Id | identifier
Public property | Name | name
Public property | Offset | offset, which gets subtracted from the source value
Public property | SignedValue | two's complement used by source value?
Public property | Sources | registers containing the value
Public property | TypeName | identifier of the IrdDeviceType object, which should be used to interpret the register
Public property | Unit | unit
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Value Constructor

IrdDeviceValue Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Value()
Public Sub New
public:
Value()
new : unit -> Value
See Also

Reference

IrdDeviceValue Class


Value Methods

Value Methods

The IrdDeviceValue type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceValue) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Clone Method

IrdDeviceValueClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceValue Class


Value.Equals Method

ValueEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceValue) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Equals Method (Object)

IrdDeviceValueEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDeviceValue Class
Equals Overload


IrdDevice.Value.Equals Method (IrdDevice.Value)

IrdDeviceValueEquals Method (IrdDeviceValue)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceValue obj
)
Public Function Equals (
    obj As IrdDeviceValue
) As Boolean
public:
virtual bool Equals(
    IrdDeviceValue^ obj
) sealed
abstract Equals :
        obj : IrdDeviceValue -> bool
override Equals :
        obj : IrdDeviceValue -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceValue
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceValue Class
Equals Overload


Value Properties

Value Properties

The IrdDeviceValue type exposes the following members.

Properties
 | Name | Description
Public property | Bcd | binary coded decimal?
Public property | DirectionOfValue | direction
Public property | ElementWidth | number of bits used for one byte (used for IrdDeviceTypeString and IrdDeviceTypeArray)
Public property | Id | identifier
Public property | Name | name
Public property | Offset | offset, which gets subtracted from the source value
Public property | SignedValue | two's complement used by source value?
Public property | Sources | registers containing the value
Public property | TypeName | identifier of the IrdDeviceType object, which should be used to interpret the register
Public property | Unit | unit
Top
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Bcd Property

IrdDeviceValueBcd Property
binary coded decimal?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Bcd { get; set; }
Public Property Bcd As Boolean
    Get
    Set
public:
property bool Bcd {
    bool get ();
    void set (bool value);
}
member Bcd : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.DirectionOfValue Property

IrdDeviceValueDirectionOfValue Property
direction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceValueDirection DirectionOfValue { get; set; }
Public Property DirectionOfValue As IrdDeviceValueDirection
    Get
    Set
public:
property IrdDeviceValueDirection DirectionOfValue {
    IrdDeviceValueDirection get ();
    void set (IrdDeviceValueDirection value);
}
member DirectionOfValue : IrdDeviceValueDirection with get, set

Property Value

Type: IrdDeviceValueDirection
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.ElementWidth Property

IrdDeviceValueElementWidth Property
number of bits used for one byte (used for IrdDeviceTypeString and IrdDeviceTypeArray)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte ElementWidth { get; set; }
Public Property ElementWidth As Byte
    Get
    Set
public:
property unsigned char ElementWidth {
    unsigned char get ();
    void set (unsigned char value);
}
member ElementWidth : byte with get, set

Property Value

Type: Byte
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Id Property

IrdDeviceValueId Property
identifier

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Name Property

IrdDeviceValueName Property
name

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Offset Property

IrdDeviceValueOffset Property
offset, which gets subtracted from the source value

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set
public:
property int Offset {
    int get ();
    void set (int value);
}
member Offset : int with get, set

Property Value

Type: Int32
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.SignedValue Property

IrdDeviceValueSignedValue Property
two's complement used by source value?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SignedValue { get; set; }
Public Property SignedValue As Boolean
    Get
    Set
public:
property bool SignedValue {
    bool get ();
    void set (bool value);
}
member SignedValue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Sources Property

IrdDeviceValueSources Property
registers containing the value

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdDeviceValueSource> Sources { get; set; }
Public Property Sources As List(Of IrdDeviceValueSource)
    Get
    Set
public:
property List<IrdDeviceValueSource^>^ Sources {
    List<IrdDeviceValueSource^>^ get ();
    void set (List<IrdDeviceValueSource^>^ value);
}
member Sources : List<IrdDeviceValueSource> with get, set

Property Value

Type: List IrdDeviceValueSource
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.TypeName Property

IrdDeviceValueTypeName Property
identifier of the IrdDeviceType object, which should be used to interpret the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}
member TypeName : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Unit Property

IrdDeviceValueUnit Property
unit

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Unit { get; set; }
Public Property Unit As String
    Get
    Set
public:
property String^ Unit {
    String^ get ();
    void set (String^ value);
}
member Unit : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceValue Class


IrdDevice.Value.Direction Enumeration

IrdDeviceValueDirection Enumeration
Enumeration to describe the direction of a value.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
type Direction
Members
Member name | Value | Description
READ_WRITE | 0 | read-write
READ_ONLY | 1 | read-only
WRITE_ONLY | 2 | write-only
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Value.Source Class

IrdDeviceValueSource Class
This class is used to define which register should be used as a source for the value.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceValueSource

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Source : ICloneable,
    IEquatable<IrdDeviceValueSource>
Public NotInheritable Class Source
    Implements ICloneable, IEquatable(Of IrdDeviceValueSource)
public ref class Source sealed : ICloneable,
    IEquatable<IrdDeviceValueSource^>
[<SealedAttribute>]
type Source =
    class
        interface ICloneable
        interface IEquatable<IrdDeviceValueSource>
    end

The IrdDeviceValueSource type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceValueSource | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceValueSource) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Reg | identifier of the IrdDeviceRegister object
Public property | StartBit | first bit of the register
Public property | StartByte | first byte of the register
Public property | StopBit | last bit of the register
Public property | StopByte | last byte of the register
Top
Remarks
Supports the ICloneable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDevice.Value.Source Constructor

IrdDeviceValueSource Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Source()
Public Sub New
public:
Source()
new : unit -> Source
See Also

Reference

IrdDeviceValueSource Class


Source Methods

Source Methods

The IrdDeviceValueSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceValueSource) | Tests whether both objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdDeviceValueSource Class


IrdDevice.Value.Source.Clone Method

IrdDeviceValueSourceClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

IrdDeviceValueSource Class


Source.Equals Method

SourceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether both objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdDeviceValueSource) | Tests whether both objects are equal.
Top
See Also

Reference

IrdDeviceValueSource Class


IrdDevice.Value.Source.Equals Method (Object)

IrdDeviceValueSourceEquals Method (Object)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other object

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdDeviceValueSource Class
Equals Overload


IrdDevice.Value.Source.Equals Method (IrdDevice.Value.Source)

IrdDeviceValueSourceEquals Method (IrdDeviceValueSource)
Tests whether both objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdDeviceValueSource obj
)
Public Function Equals (
    obj As IrdDeviceValueSource
) As Boolean
public:
virtual bool Equals(
    IrdDeviceValueSource^ obj
) sealed
abstract Equals :
        obj : IrdDeviceValueSource -> bool
override Equals :
        obj : IrdDeviceValueSource -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdDeviceValueSource
other object

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdDeviceValueSource Class
Equals Overload


Source Properties

Source Properties

The IrdDeviceValueSource type exposes the following members.

Properties
 | Name | Description
Public property | Reg | identifier of the IrdDeviceRegister object
Public property | StartBit | first bit of the register
Public property | StartByte | first byte of the register
Public property | StopBit | last bit of the register
Public property | StopByte | last byte of the register
Top
See Also

Reference

IrdDeviceValueSource Class


IrdDevice.Value.Source.Reg Property

IrdDeviceValueSourceReg Property
identifier of the IrdDeviceRegister object

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Reg { get; set; }
Public Property Reg As String
    Get
    Set
public:
property String^ Reg {
    String^ get ();
    void set (String^ value);
}
member Reg : string with get, set

Property Value

Type: String
See Also

Reference

IrdDeviceValueSource Class


IrdDevice.Value.Source.StartBit Property

IrdDeviceValueSourceStartBit Property
first bit of the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint StartBit { get; set; }
Public Property StartBit As UInteger
    Get
    Set
public:
property unsigned int StartBit {
    unsigned int get ();
    void set (unsigned int value);
}
member StartBit : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceValueSource Class


IrdDevice.Value.Source.StartByte Property

IrdDeviceValueSourceStartByte Property
first byte of the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint StartByte { get; set; }
Public Property StartByte As UInteger
    Get
    Set
public:
property unsigned int StartByte {
    unsigned int get ();
    void set (unsigned int value);
}
member StartByte : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceValueSource Class


IrdDevice.Value.Source.StopBit Property

IrdDeviceValueSourceStopBit Property
last bit of the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint StopBit { get; set; }
Public Property StopBit As UInteger
    Get
    Set
public:
property unsigned int StopBit {
    unsigned int get ();
    void set (unsigned int value);
}
member StopBit : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceValueSource Class


IrdDevice.Value.Source.StopByte Property

IrdDeviceValueSourceStopByte Property
last byte of the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint StopByte { get; set; }
Public Property StopByte As UInteger
    Get
    Set
public:
property unsigned int StopByte {
    unsigned int get ();
    void set (unsigned int value);
}
member StopByte : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdDeviceValueSource Class


IrdDeviceVerifier Class

IrdDeviceVerifier Class
This class contains an IrdDevice verifier. It can be used to test whether an IrdDevice object conforms to the IRD specification.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdDeviceVerifier

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdDeviceVerifier
Public NotInheritable Class IrdDeviceVerifier
public ref class IrdDeviceVerifier sealed
[<SealedAttribute>]
type IrdDeviceVerifier =  class end

The IrdDeviceVerifier type exposes the following members.

Constructors
 | Name | Description
Public method | IrdDeviceVerifier | Initializes a new instance of the IrdDeviceVerifier class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Verifies the given IrdDevice object. If the content of the object does not conform to the IRD specification, an exception of type ExceptionIrdDeviceVerification gets thrown.
Public method | VerifyHeader | Verifies I2cAddresses, Manufacturer, Name, SubAddrWidth, and PecSupport of dev. If the content of the object does not conform to the IRD specification, an exception of type ExceptionIrdDeviceVerification gets thrown.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdDeviceVerifier Constructor

IrdDeviceVerifier Constructor
Initializes a new instance of the IrdDeviceVerifier class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceVerifier()
Public Sub New
public:
IrdDeviceVerifier()
new : unit -> IrdDeviceVerifier
See Also

Reference

IrdDeviceVerifier Class


IrdDeviceVerifier Methods

IrdDeviceVerifier Methods

The IrdDeviceVerifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | Verifies the given IrdDevice object. If the content of the object does not conform to the IRD specification, an exception of type ExceptionIrdDeviceVerification gets thrown.
Public method | VerifyHeader | Verifies I2cAddresses, Manufacturer, Name, SubAddrWidth, and PecSupport of dev. If the content of the object does not conform to the IRD specification, an exception of type ExceptionIrdDeviceVerification gets thrown.
Top
See Also

Reference

IrdDeviceVerifier Class


IrdDeviceVerifier.Verify Method

IrdDeviceVerifierVerify Method
Verifies the given IrdDevice object. If the content of the object does not conform to the IRD specification, an exception of type ExceptionIrdDeviceVerification gets thrown.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Verify(
    IrdDevice dev
)
Public Sub Verify (
    dev As IrdDevice
)
public:
void Verify(
    IrdDevice^ dev
)
member Verify :
        dev : IrdDevice -> unit

Parameters

dev
Type: telos.I2cApi.DotNetIrdDevice
IRD description to be verified
See Also

Reference

IrdDeviceVerifier Class


IrdDeviceVerifier.VerifyHeader Method

IrdDeviceVerifierVerifyHeader Method
Verifies I2cAddresses, Manufacturer, Name, SubAddrWidth, and PecSupport of dev. If the content of the object does not conform to the IRD specification, an exception of type ExceptionIrdDeviceVerification gets thrown.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void VerifyHeader(
    IrdDevice dev
)
Public Sub VerifyHeader (
    dev As IrdDevice
)
public:
void VerifyHeader(
    IrdDevice^ dev
)
member VerifyHeader :
        dev : IrdDevice -> unit

Parameters

dev
Type: telos.I2cApi.DotNetIrdDevice
IRD description to be verified
See Also

Reference

IrdDeviceVerifier Class


IrdMap Class

IrdMap Class
This class can be used to map I2C addresses to alias names, IRD (I2C Register Description) files, and plug-in files.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMap

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdMap
Public NotInheritable Class IrdMap
public ref class IrdMap sealed
[<SealedAttribute>]
type IrdMap =  class end

The IrdMap type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMap | Constructor
Top
Methods
 | Name | Description
Public method | ChangeAddress | Changes the I2C address of a mapping.
Public method | Clear | Removes all I2C addresses.
Public method | Contains | Tests whether an alias name or an IRD file has been registered for the specified I2C address.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlias | Returns the alias name for the specified I2C address.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIrdDevice |
Public method | GetIrdFile | Returns the name of the IRD file for the specified I2C address.
Public method | GetIrdFileByUdid | Searches in the specified directories for an IRD file, which matches the specified SMBus UDID value. This method returns the description of the device specified in the found IRD file.
Public method | GetIrdFileDescription | Returns the description of the IRD file used for the specified I2C address.
Public method | GetIrdFiles | Searches in the specified directories for IRD files. This method returns the description of the devices specified in the found IRD files.
Public method | GetPlugInFile | Returns the name of the plug-in file for the specified I2C address.
Public method | GetPlugInFileDescription | Returns the description of the plug-in file used for the specified I2C address.
Public method | GetPlugInFiles | Searches in the specified directories for plug-in files. This method returns the description of the devices specified in the found plug-in files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified I2C address.
Public method | SetAlias | Sets the specified alias name for the specified I2C address.
Public method | SetIrdFile | Sets the name of the IRD file for the specified I2C address.
Public method | SetPlugInFile | Sets the name of the plug-in file for the specified I2C address.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | I2cAddresses | Returns a list of all I2C addresses which are mapped.
Public property | IrdDirectories | Sets/gets the directories, in which an IrdMap instance searches for IRD files.
Public property | PlugInDirectories | Sets/gets the directories, in which an IrdMap instance searches for plug-in files.
Public property | Serialization | Sets/gets the current I2C address to IRD/plug-in/alias mapping, which has set.
Top
Events
 | Name | Description
Public event | EntryChanged | This event gets fired when one entry in the IrdMap has changed.
Public event | MappingChanged | This event gets fired when the IrdMap has changed.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMap Constructor

IrdMap Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMap()
Public Sub New
public:
IrdMap()
new : unit -> IrdMap
See Also

Reference

IrdMap Class


IrdMap Methods

IrdMap Methods

The IrdMap type exposes the following members.

Methods
 | Name | Description
Public method | ChangeAddress | Changes the I2C address of a mapping.
Public method | Clear | Removes all I2C addresses.
Public method | Contains | Tests whether an alias name or an IRD file has been registered for the specified I2C address.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlias | Returns the alias name for the specified I2C address.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIrdDevice |
Public method | GetIrdFile | Returns the name of the IRD file for the specified I2C address.
Public method | GetIrdFileByUdid | Searches in the specified directories for an IRD file, which matches the specified SMBus UDID value. This method returns the description of the device specified in the found IRD file.
Public method | GetIrdFileDescription | Returns the description of the IRD file used for the specified I2C address.
Public method | GetIrdFiles | Searches in the specified directories for IRD files. This method returns the description of the devices specified in the found IRD files.
Public method | GetPlugInFile | Returns the name of the plug-in file for the specified I2C address.
Public method | GetPlugInFileDescription | Returns the description of the plug-in file used for the specified I2C address.
Public method | GetPlugInFiles | Searches in the specified directories for plug-in files. This method returns the description of the devices specified in the found plug-in files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified I2C address.
Public method | SetAlias | Sets the specified alias name for the specified I2C address.
Public method | SetIrdFile | Sets the name of the IRD file for the specified I2C address.
Public method | SetPlugInFile | Sets the name of the plug-in file for the specified I2C address.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMap Class


IrdMap.ChangeAddress Method

IrdMapChangeAddress Method
Changes the I2C address of a mapping.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ChangeAddress(
    I2cAddress old_addr,
    I2cAddress new_addr
)
Public Sub ChangeAddress (
    old_addr As I2cAddress,
    new_addr As I2cAddress
)
public:
void ChangeAddress(
    I2cAddress^ old_addr,
    I2cAddress^ new_addr
)
member ChangeAddress :
        old_addr : I2cAddress *
        new_addr : I2cAddress -> unit

Parameters

old_addr
Type: telos.I2cApi.DotNetI2cAddress
old I2C address
new_addr
Type: telos.I2cApi.DotNetI2cAddress
new I2C address
See Also

Reference

IrdMap Class


IrdMap.Clear Method

IrdMapClear Method
Removes all I2C addresses.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

IrdMap Class


IrdMap.Contains Method

IrdMapContains Method
Tests whether an alias name or an IRD file has been registered for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    I2cAddress addr
)
Public Function Contains (
    addr As I2cAddress
) As Boolean
public:
bool Contains(
    I2cAddress^ addr
)
member Contains :
        addr : I2cAddress -> bool

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: Boolean
registered (true), not registered (false)
See Also

Reference

IrdMap Class


IrdMap.GetAlias Method

IrdMapGetAlias Method
Returns the alias name for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetAlias(
    I2cAddress addr
)
Public Function GetAlias (
    addr As I2cAddress
) As String
public:
String^ GetAlias(
    I2cAddress^ addr
)
member GetAlias :
        addr : I2cAddress -> string

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: String
alias name or ""
See Also

Reference

IrdMap Class


IrdMap.GetIrdDevice Method

IrdMapGetIrdDevice Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.IrdMap.GetIrdDevice(telos.I2cApi.DotNet.I2cAddress,System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDevice GetIrdDevice(
    I2cAddress addr,
    int h
)
Public Function GetIrdDevice (
    addr As I2cAddress,
    h As Integer
) As IrdDevice
public:
IrdDevice^ GetIrdDevice(
    I2cAddress^ addr,
    int h
)
member GetIrdDevice :
        addr : I2cAddress *
        h : int -> IrdDevice

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress

[Missing <param name="addr"/> documentation for "M:telos.I2cApi.DotNet.IrdMap.GetIrdDevice(telos.I2cApi.DotNet.I2cAddress,System.Int32)"]

h
Type: SystemInt32

[Missing <param name="h"/> documentation for "M:telos.I2cApi.DotNet.IrdMap.GetIrdDevice(telos.I2cApi.DotNet.I2cAddress,System.Int32)"]

Return Value

Type: IrdDevice

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.IrdMap.GetIrdDevice(telos.I2cApi.DotNet.I2cAddress,System.Int32)"]

See Also

Reference

IrdMap Class


IrdMap.GetIrdFile Method

IrdMapGetIrdFile Method
Returns the name of the IRD file for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetIrdFile(
    I2cAddress addr
)
Public Function GetIrdFile (
    addr As I2cAddress
) As String
public:
String^ GetIrdFile(
    I2cAddress^ addr
)
member GetIrdFile :
        addr : I2cAddress -> string

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: String
name of the IRD file or ""
See Also

Reference

IrdMap Class


IrdMap.GetIrdFileByUdid Method

IrdMapGetIrdFileByUdid Method
Searches in the specified directories for an IRD file, which matches the specified SMBus UDID value. This method returns the description of the device specified in the found IRD file.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMapDevice GetIrdFileByUdid(
    IrdDeviceUdid udid
)
Public Function GetIrdFileByUdid (
    udid As IrdDeviceUdid
) As IrdMapDevice
public:
IrdMapDevice^ GetIrdFileByUdid(
    IrdDeviceUdid^ udid
)
member GetIrdFileByUdid :
        udid : IrdDeviceUdid -> IrdMapDevice

Parameters

udid
Type: telos.I2cApi.DotNetIrdDeviceUdid
SMBus UDID to be searched for

Return Value

Type: IrdMapDevice
description of the found device or N/A ("0")
See Also

Reference

IrdMap Class


IrdMap.GetIrdFileDescription Method

IrdMapGetIrdFileDescription Method
Returns the description of the IRD file used for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMapDevice GetIrdFileDescription(
    I2cAddress addr
)
Public Function GetIrdFileDescription (
    addr As I2cAddress
) As IrdMapDevice
public:
IrdMapDevice^ GetIrdFileDescription(
    I2cAddress^ addr
)
member GetIrdFileDescription :
        addr : I2cAddress -> IrdMapDevice

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: IrdMapDevice
description of the IRD file or "0"
See Also

Reference

IrdMap Class


IrdMap.GetIrdFiles Method

IrdMapGetIrdFiles Method
Searches in the specified directories for IRD files. This method returns the description of the devices specified in the found IRD files.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdMapDevice> GetIrdFiles(
    IList<string> errors
)
Public Function GetIrdFiles (
    errors As IList(Of String)
) As List(Of IrdMapDevice)
public:
List<IrdMapDevice^>^ GetIrdFiles(
    IList<String^>^ errors
)
member GetIrdFiles :
        errors : IList<string> -> List<IrdMapDevice>

Parameters

errors
Type: System.Collections.GenericIList String
list of errors or N/A ("0")

Return Value

Type: List IrdMapDevice
description of the found devices
Remarks
If it is not possible to open/read some of the found files, this method adds the error message to a list of errors.
See Also

Reference

IrdMap Class


IrdMap.GetPlugInFile Method

IrdMapGetPlugInFile Method
Returns the name of the plug-in file for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetPlugInFile(
    I2cAddress addr
)
Public Function GetPlugInFile (
    addr As I2cAddress
) As String
public:
String^ GetPlugInFile(
    I2cAddress^ addr
)
member GetPlugInFile :
        addr : I2cAddress -> string

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: String
name of the plug-in file or ""
See Also

Reference

IrdMap Class


IrdMap.GetPlugInFileDescription Method

IrdMapGetPlugInFileDescription Method
Returns the description of the plug-in file used for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMapDevice GetPlugInFileDescription(
    I2cAddress addr
)
Public Function GetPlugInFileDescription (
    addr As I2cAddress
) As IrdMapDevice
public:
IrdMapDevice^ GetPlugInFileDescription(
    I2cAddress^ addr
)
member GetPlugInFileDescription :
        addr : I2cAddress -> IrdMapDevice

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address

Return Value

Type: IrdMapDevice
description of the plug-in file or "0"
See Also

Reference

IrdMap Class


IrdMap.GetPlugInFiles Method

IrdMapGetPlugInFiles Method
Searches in the specified directories for plug-in files. This method returns the description of the devices specified in the found plug-in files.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdMapDevice> GetPlugInFiles(
    IList<string> errors
)
Public Function GetPlugInFiles (
    errors As IList(Of String)
) As List(Of IrdMapDevice)
public:
List<IrdMapDevice^>^ GetPlugInFiles(
    IList<String^>^ errors
)
member GetPlugInFiles :
        errors : IList<string> -> List<IrdMapDevice>

Parameters

errors
Type: System.Collections.GenericIList String
list of errors or N/A ("0")

Return Value

Type: List IrdMapDevice
description of the found devices
Remarks
If it is not possible to open/read some of the found files, this method adds the error message to a list of errors.
See Also

Reference

IrdMap Class


IrdMap.Remove Method

IrdMapRemove Method
Removes the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    I2cAddress addr
)
Public Sub Remove (
    addr As I2cAddress
)
public:
void Remove(
    I2cAddress^ addr
)
member Remove :
        addr : I2cAddress -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
See Also

Reference

IrdMap Class


IrdMap.SetAlias Method

IrdMapSetAlias Method
Sets the specified alias name for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetAlias(
    I2cAddress addr,
    string str
)
Public Sub SetAlias (
    addr As I2cAddress,
    str As String
)
public:
void SetAlias(
    I2cAddress^ addr,
    String^ str
)
member SetAlias :
        addr : I2cAddress *
        str : string -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
str
Type: SystemString
alias name
See Also

Reference

IrdMap Class


IrdMap.SetIrdFile Method

IrdMapSetIrdFile Method
Sets the name of the IRD file for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetIrdFile(
    I2cAddress addr,
    string filename
)
Public Sub SetIrdFile (
    addr As I2cAddress,
    filename As String
)
public:
void SetIrdFile(
    I2cAddress^ addr,
    String^ filename
)
member SetIrdFile :
        addr : I2cAddress *
        filename : string -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
filename
Type: SystemString
name of the IRD file
See Also

Reference

IrdMap Class


IrdMap.SetPlugInFile Method

IrdMapSetPlugInFile Method
Sets the name of the plug-in file for the specified I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetPlugInFile(
    I2cAddress addr,
    string filename
)
Public Sub SetPlugInFile (
    addr As I2cAddress,
    filename As String
)
public:
void SetPlugInFile(
    I2cAddress^ addr,
    String^ filename
)
member SetPlugInFile :
        addr : I2cAddress *
        filename : string -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
filename
Type: SystemString
name of the plug-in file
See Also

Reference

IrdMap Class


IrdMap Properties

IrdMap Properties

The IrdMap type exposes the following members.

Properties
 | Name | Description
Public property | I2cAddresses | Returns a list of all I2C addresses which are mapped.
Public property | IrdDirectories | Sets/gets the directories, in which an IrdMap instance searches for IRD files.
Public property | PlugInDirectories | Sets/gets the directories, in which an IrdMap instance searches for plug-in files.
Public property | Serialization | Sets/gets the current I2C address to IRD/plug-in/alias mapping, which has set.
Top
See Also

Reference

IrdMap Class


IrdMap.I2cAddresses Property

IrdMapI2cAddresses Property
Returns a list of all I2C addresses which are mapped.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<I2cAddress> I2cAddresses { get; }
Public ReadOnly Property I2cAddresses As List(Of I2cAddress)
    Get
public:
property List<I2cAddress^>^ I2cAddresses {
    List<I2cAddress^>^ get ();
}
member I2cAddresses : List<I2cAddress> with get

Property Value

Type: List I2cAddress
See Also

Reference

IrdMap Class


IrdMap.IrdDirectories Property

IrdMapIrdDirectories Property
Sets/gets the directories, in which an IrdMap instance searches for IRD files.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<string> IrdDirectories { get; set; }
Public Property IrdDirectories As List(Of String)
    Get
    Set
public:
property List<String^>^ IrdDirectories {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member IrdDirectories : List<string> with get, set

Property Value

Type: List String
See Also

Reference

IrdMap Class


IrdMap.PlugInDirectories Property

IrdMapPlugInDirectories Property
Sets/gets the directories, in which an IrdMap instance searches for plug-in files.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<string> PlugInDirectories { get; set; }
Public Property PlugInDirectories As List(Of String)
    Get
    Set
public:
property List<String^>^ PlugInDirectories {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member PlugInDirectories : List<string> with get, set

Property Value

Type: List String
See Also

Reference

IrdMap Class


IrdMap.Serialization Property

IrdMapSerialization Property
Sets/gets the current I2C address to IRD/plug-in/alias mapping, which has set.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMapSerializationData Serialization { get; set; }
Public Property Serialization As IrdMapSerializationData
    Get
    Set
public:
property IrdMapSerializationData^ Serialization {
    IrdMapSerializationData^ get ();
    void set (IrdMapSerializationData^ value);
}
member Serialization : IrdMapSerializationData with get, set

Property Value

Type: IrdMapSerializationData
Remarks
This can be used to store the current mapping.
See Also

Reference

IrdMap Class


IrdMap Events

IrdMap Events

The IrdMap type exposes the following members.

Events
 | Name | Description
Public event | EntryChanged | This event gets fired when one entry in the IrdMap has changed.
Public event | MappingChanged | This event gets fired when the IrdMap has changed.
Top
See Also

Reference

IrdMap Class


IrdMap.EntryChanged Event

IrdMapEntryChanged Event
This event gets fired when one entry in the IrdMap has changed.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<IrdMapEntryEventArgs> EntryChanged
Public Event EntryChanged As EventHandler(Of IrdMapEntryEventArgs)
public:
 event EventHandler<IrdMapEntryEventArgs^>^ EntryChanged {
    void add (EventHandler<IrdMapEntryEventArgs^>^ value);
    void remove (EventHandler<IrdMapEntryEventArgs^>^ value);
}
member EntryChanged : IEvent<EventHandler<IrdMapEntryEventArgs>,
    IrdMapEntryEventArgs>

Value

Type: SystemEventHandler IrdMapEntryEventArgs
See Also

Reference

IrdMap Class


IrdMap.MappingChanged Event

IrdMapMappingChanged Event
This event gets fired when the IrdMap has changed.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MappingChanged
Public Event MappingChanged As EventHandler
public:
 event EventHandler^ MappingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MappingChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IrdMap Class


IrdMap.Device Class

IrdMapDevice Class
Stores information of a device specified by an IRD file or a plug-in file.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMapDevice

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Device
Public NotInheritable Class Device
public ref class Device sealed
[<SealedAttribute>]
type Device =  class end

The IrdMapDevice type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMapDevice | Initializes a new instance of the IrdMapDevice class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | description (e.g. "256 Byte RAM")
Public property | DeviceType | type (e.g. "RAM")
Public property | File | name of the IRD file
Public property | I2cAddresses | possible I2C addresses (as I2cAddress or I2cAddressRange objects)
Public property | Manufacturer | manufacturer (e.g. "Philips")
Public property | Name | name (e.g. "PCF 8570 P")
Public property | Udid | SMBus UDID or N/A ("0")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMap.Device Constructor

IrdMapDevice Constructor
Initializes a new instance of the IrdMapDevice class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Device()
Public Sub New
public:
Device()
new : unit -> Device
See Also

Reference

IrdMapDevice Class


Device Methods

Device Methods

The IrdMapDevice type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMapDevice Class


Device Properties

Device Properties

The IrdMapDevice type exposes the following members.

Properties
 | Name | Description
Public property | Description | description (e.g. "256 Byte RAM")
Public property | DeviceType | type (e.g. "RAM")
Public property | File | name of the IRD file
Public property | I2cAddresses | possible I2C addresses (as I2cAddress or I2cAddressRange objects)
Public property | Manufacturer | manufacturer (e.g. "Philips")
Public property | Name | name (e.g. "PCF 8570 P")
Public property | Udid | SMBus UDID or N/A ("0")
Top
See Also

Reference

IrdMapDevice Class


IrdMap.Device.Description Property

IrdMapDeviceDescription Property
description (e.g. "256 Byte RAM")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapDevice Class


IrdMap.Device.DeviceType Property

IrdMapDeviceDeviceType Property
type (e.g. "RAM")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string DeviceType { get; set; }
Public Property DeviceType As String
    Get
    Set
public:
property String^ DeviceType {
    String^ get ();
    void set (String^ value);
}
member DeviceType : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapDevice Class


IrdMap.Device.File Property

IrdMapDeviceFile Property
name of the IRD file

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string File { get; set; }
Public Property File As String
    Get
    Set
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
member File : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapDevice Class


IrdMap.Device.I2cAddresses Property

IrdMapDeviceI2cAddresses Property
possible I2C addresses (as I2cAddress or I2cAddressRange objects)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList I2cAddresses { get; set; }
Public Property I2cAddresses As ArrayList
    Get
    Set
public:
property ArrayList^ I2cAddresses {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
member I2cAddresses : ArrayList with get, set

Property Value

Type: ArrayList
See Also

Reference

IrdMapDevice Class


IrdMap.Device.Manufacturer Property

IrdMapDeviceManufacturer Property
manufacturer (e.g. "Philips")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapDevice Class


IrdMap.Device.Name Property

IrdMapDeviceName Property
name (e.g. "PCF 8570 P")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapDevice Class


IrdMap.Device.Udid Property

IrdMapDeviceUdid Property
SMBus UDID or N/A ("0")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceUdid Udid { get; set; }
Public Property Udid As IrdDeviceUdid
    Get
    Set
public:
property IrdDeviceUdid^ Udid {
    IrdDeviceUdid^ get ();
    void set (IrdDeviceUdid^ value);
}
member Udid : IrdDeviceUdid with get, set

Property Value

Type: IrdDeviceUdid
See Also

Reference

IrdMapDevice Class


IrdMap.Entry Class

IrdMapEntry Class
Stores information for one I2C address.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMapEntry

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Entry : ICloneable
Public NotInheritable Class Entry
    Implements ICloneable
public ref class Entry sealed : ICloneable
[<SealedAttribute>]
type Entry =
    class
        interface ICloneable
    end

The IrdMapEntry type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMapEntry | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address
Public property | Alias | alias name
Public property | Ird | parsed IRD file
Public property | IrdFilename | name of IRD file
Public property | Plugin | loaded plug-in file
Public property | PluginFilename | name of plug-in file
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMap.Entry Constructor

IrdMapEntry Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Entry()
Public Sub New
public:
Entry()
new : unit -> Entry
See Also

Reference

IrdMapEntry Class


Entry Methods

Entry Methods

The IrdMapEntry type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMapEntry Class


IrdMap.Entry.Clone Method

IrdMapEntryClone Method
Creates a deep copy of this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy of this object

Implements

ICloneableClone
See Also

Reference

IrdMapEntry Class


Entry Properties

Entry Properties

The IrdMapEntry type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address
Public property | Alias | alias name
Public property | Ird | parsed IRD file
Public property | IrdFilename | name of IRD file
Public property | Plugin | loaded plug-in file
Public property | PluginFilename | name of plug-in file
Top
See Also

Reference

IrdMapEntry Class


IrdMap.Entry.Address Property

IrdMapEntryAddress Property
I2C address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

IrdMapEntry Class


IrdMap.Entry.Alias Property

IrdMapEntryAlias Property
alias name

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set
public:
property String^ Alias {
    String^ get ();
    void set (String^ value);
}
member Alias : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapEntry Class


IrdMap.Entry.Ird Property

IrdMapEntryIrd Property
parsed IRD file

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDevice Ird { get; set; }
Public Property Ird As IrdDevice
    Get
    Set
public:
property IrdDevice^ Ird {
    IrdDevice^ get ();
    void set (IrdDevice^ value);
}
member Ird : IrdDevice with get, set

Property Value

Type: IrdDevice
See Also

Reference

IrdMapEntry Class


IrdMap.Entry.IrdFilename Property

IrdMapEntryIrdFilename Property
name of IRD file

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string IrdFilename { get; set; }
Public Property IrdFilename As String
    Get
    Set
public:
property String^ IrdFilename {
    String^ get ();
    void set (String^ value);
}
member IrdFilename : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapEntry Class


IrdMap.Entry.Plugin Property

IrdMapEntryPlugin Property
loaded plug-in file

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInInterface Plugin { get; set; }
Public Property Plugin As PlugInInterface
    Get
    Set
public:
property PlugInInterface^ Plugin {
    PlugInInterface^ get ();
    void set (PlugInInterface^ value);
}
member Plugin : PlugInInterface with get, set

Property Value

Type: PlugInInterface
See Also

Reference

IrdMapEntry Class


IrdMap.Entry.PluginFilename Property

IrdMapEntryPluginFilename Property
name of plug-in file

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string PluginFilename { get; set; }
Public Property PluginFilename As String
    Get
    Set
public:
property String^ PluginFilename {
    String^ get ();
    void set (String^ value);
}
member PluginFilename : string with get, set

Property Value

Type: String
See Also

Reference

IrdMapEntry Class


IrdMap.EntryEventArgs Class

IrdMapEntryEventArgs Class
Event arguments used for the EntryChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
telos.I2cApi.DotNetIrdMapEntryEventArgs

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class EntryEventArgs : EventArgs
Public Class EntryEventArgs
    Inherits EventArgs
public ref class EntryEventArgs : public EventArgs
type EntryEventArgs =
    class
        inherit EventArgs
    end

The IrdMapEntryEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMapEntryEventArgs | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NewEntry | new entry
Public property | OldEntry | old entry
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMap.EntryEventArgs Constructor

IrdMapEntryEventArgs Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public EntryEventArgs(
    IrdMapEntry old_entry,
    IrdMapEntry new_entry
)
Public Sub New (
    old_entry As IrdMapEntry,
    new_entry As IrdMapEntry
)
public:
EntryEventArgs(
    IrdMapEntry^ old_entry,
    IrdMapEntry^ new_entry
)
new :
        old_entry : IrdMapEntry *
        new_entry : IrdMapEntry -> EntryEventArgs

Parameters

old_entry
Type: telos.I2cApi.DotNetIrdMapEntry
old entry
new_entry
Type: telos.I2cApi.DotNetIrdMapEntry
new entry
See Also

Reference

IrdMapEntryEventArgs Class


EntryEventArgs Methods

EntryEventArgs Methods

The IrdMapEntryEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMapEntryEventArgs Class


EntryEventArgs Properties

EntryEventArgs Properties

The IrdMapEntryEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewEntry | new entry
Public property | OldEntry | old entry
Top
See Also

Reference

IrdMapEntryEventArgs Class


IrdMap.EntryEventArgs.NewEntry Property

IrdMapEntryEventArgsNewEntry Property
new entry

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMapEntry NewEntry { get; set; }
Public Property NewEntry As IrdMapEntry
    Get
    Set
public:
property IrdMapEntry^ NewEntry {
    IrdMapEntry^ get ();
    void set (IrdMapEntry^ value);
}
member NewEntry : IrdMapEntry with get, set

Property Value

Type: IrdMapEntry
See Also

Reference

IrdMapEntryEventArgs Class


IrdMap.EntryEventArgs.OldEntry Property

IrdMapEntryEventArgsOldEntry Property
old entry

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMapEntry OldEntry { get; set; }
Public Property OldEntry As IrdMapEntry
    Get
    Set
public:
property IrdMapEntry^ OldEntry {
    IrdMapEntry^ get ();
    void set (IrdMapEntry^ value);
}
member OldEntry : IrdMapEntry with get, set

Property Value

Type: IrdMapEntry
See Also

Reference

IrdMapEntryEventArgs Class


IrdMap.SerializationData Class

IrdMapSerializationData Class
This class gets used for the serialization of the settings of the IrdMap class.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMapSerializationData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class SerializationData : ISerializable,
    IEquatable<IrdMapSerializationData>
<SerializableAttribute>
Public NotInheritable Class SerializationData
    Implements ISerializable, IEquatable(Of IrdMapSerializationData)
[SerializableAttribute]
public ref class SerializationData sealed : ISerializable,
    IEquatable<IrdMapSerializationData^>
[<SealedAttribute>]
[<SerializableAttribute>]
type SerializationData =
    class
        interface ISerializable
        interface IEquatable<IrdMapSerializationData>
    end

The IrdMapSerializationData type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMapSerializationData | Constructor
Top
Methods
 | Name | Description
Public method | Equals(Object) | Tests whether two IrdMapSerializationData objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdMapSerializationData) | Tests whether two IrdMapSerializationData objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Part of the ISerializable interface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | m_alias_names | alias names
Public field | m_i2c_addresses | I2C addresses
Public field | m_ird_files | IRD filenames
Public field | m_plugin_files | plug-in filenames
Top
Remarks
Supports the ISerializable and IEquatableT interfaces.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMap.SerializationData Constructor

IrdMapSerializationData Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SerializationData()
Public Sub New
public:
SerializationData()
new : unit -> SerializationData
See Also

Reference

IrdMapSerializationData Class


SerializationData Fields

SerializationData Fields

The IrdMapSerializationData type exposes the following members.

Fields
 | Name | Description
Public field | m_alias_names | alias names
Public field | m_i2c_addresses | I2C addresses
Public field | m_ird_files | IRD filenames
Public field | m_plugin_files | plug-in filenames
Top
See Also

Reference

IrdMapSerializationData Class


IrdMap.SerializationData.m_alias_names Field

IrdMapSerializationDatam_alias_names Field
alias names

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList m_alias_names
Public m_alias_names As ArrayList
public:
ArrayList^ m_alias_names
val mutable m_alias_names: ArrayList

Field Value

Type: ArrayList
See Also

Reference

IrdMapSerializationData Class


IrdMap.SerializationData.m_i2c_addresses Field

IrdMapSerializationDatam_i2c_addresses Field
I2C addresses

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList m_i2c_addresses
Public m_i2c_addresses As ArrayList
public:
ArrayList^ m_i2c_addresses
val mutable m_i2c_addresses: ArrayList

Field Value

Type: ArrayList
See Also

Reference

IrdMapSerializationData Class


IrdMap.SerializationData.m_ird_files Field

IrdMapSerializationDatam_ird_files Field
IRD filenames

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList m_ird_files
Public m_ird_files As ArrayList
public:
ArrayList^ m_ird_files
val mutable m_ird_files: ArrayList

Field Value

Type: ArrayList
See Also

Reference

IrdMapSerializationData Class


IrdMap.SerializationData.m_plugin_files Field

IrdMapSerializationDatam_plugin_files Field
plug-in filenames

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList m_plugin_files
Public m_plugin_files As ArrayList
public:
ArrayList^ m_plugin_files
val mutable m_plugin_files: ArrayList

Field Value

Type: ArrayList
See Also

Reference

IrdMapSerializationData Class


SerializationData Methods

SerializationData Methods

The IrdMapSerializationData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Tests whether two IrdMapSerializationData objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdMapSerializationData) | Tests whether two IrdMapSerializationData objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Part of the ISerializable interface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMapSerializationData Class


SerializationData.Equals Method

SerializationDataEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Tests whether two IrdMapSerializationData objects are equal. (Overrides ObjectEquals(Object).)
Public method | Equals(IrdMapSerializationData) | Tests whether two IrdMapSerializationData objects are equal.
Top
See Also

Reference

IrdMapSerializationData Class


IrdMap.SerializationData.Equals Method (Object)

IrdMapSerializationDataEquals Method (Object)
Tests whether two IrdMapSerializationData objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
other IrdMapSerializationData

Return Value

Type: Boolean
equal (true), not equal (false)
See Also

Reference

IrdMapSerializationData Class
Equals Overload


IrdMap.SerializationData.Equals Method (IrdMap.SerializationData)

IrdMapSerializationDataEquals Method (IrdMapSerializationData)
Tests whether two IrdMapSerializationData objects are equal.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IrdMapSerializationData obj
)
Public Function Equals (
    obj As IrdMapSerializationData
) As Boolean
public:
virtual bool Equals(
    IrdMapSerializationData^ obj
) sealed
abstract Equals :
        obj : IrdMapSerializationData -> bool
override Equals :
        obj : IrdMapSerializationData -> bool

Parameters

obj
Type: telos.I2cApi.DotNetIrdMapSerializationData
other IrdMapSerializationData

Return Value

Type: Boolean
equal (true), not equal (false)

Implements

IEquatableTEquals(T)
See Also

Reference

IrdMapSerializationData Class
Equals Overload


IrdMap.SerializationData.GetObjectData Method

IrdMapSerializationDataGetObjectData Method
Part of the ISerializable interface.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
SerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
StreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

IrdMapSerializationData Class


IrdMaster Class

IrdMaster Class
This class can be used to send/receive IRD master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdMaster
Public NotInheritable Class IrdMaster
public ref class IrdMaster sealed
[<SealedAttribute>]
type IrdMaster =  class end

The IrdMaster type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMaster | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueGroups | Returns the groups of value groups.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData | Transfers the given IRD master message to the I2C slave.
Top
Remarks

Normally the following steps are necessary to use the IRD master module of an I2C interface:

  1. Configure the master module (I2C bitrates).
  2. Get a group of value groups using GetValueGroups(I2cAddress).
  3. Create an IrdMasterMessage for one of the IrdMasterValue objects.
  4. Transfer the IrdMasterMessage using TransferData(IrdMasterMessage).
  5. Evaluate the result of the transfer stored in the object passed to TransferData(IrdMasterMessage).
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMaster Constructor

IrdMaster Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMaster(
    Board board,
    IrdMap ird_map
)
Public Sub New (
    board As Board,
    ird_map As IrdMap
)
public:
IrdMaster(
    Board^ board,
    IrdMap^ ird_map
)
new :
        board : Board *
        ird_map : IrdMap -> IrdMaster

Parameters

board
Type: telos.I2cApi.DotNetBoard
I2C interface to be used for the transfer
ird_map
Type: telos.I2cApi.DotNetIrdMap
I2C address to IRD mapping
See Also

Reference

IrdMaster Class


IrdMaster Methods

IrdMaster Methods

The IrdMaster type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueGroups | Returns the groups of value groups.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData | Transfers the given IRD master message to the I2C slave.
Top
See Also

Reference

IrdMaster Class


IrdMaster.GetValueGroups Method

IrdMasterGetValueGroups Method
Returns the groups of value groups.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMasterValueGroups GetValueGroups(
    I2cAddress i2c_addr
)
Public Function GetValueGroups (
    i2c_addr As I2cAddress
) As IrdMasterValueGroups
public:
IrdMasterValueGroups^ GetValueGroups(
    I2cAddress^ i2c_addr
)
member GetValueGroups :
        i2c_addr : I2cAddress -> IrdMasterValueGroups

Parameters

i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave

Return Value

Type: IrdMasterValueGroups
groups of value groups
See Also

Reference

IrdMaster Class


IrdMaster.TransferData Method

IrdMasterTransferData Method
Transfers the given IRD master message to the I2C slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    IrdMasterMessage msg
)
Public Sub TransferData (
    msg As IrdMasterMessage
)
public:
void TransferData(
    IrdMasterMessage^ msg
)
member TransferData :
        msg : IrdMasterMessage -> unit

Parameters

msg
Type: telos.I2cApi.DotNetIrdMasterMessage
IRD master message
See Also

Reference

IrdMaster Class


IrdMaster.Value Class

IrdMasterValue Class
One value of the IC.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMasterValue

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Value
Public NotInheritable Class Value
public ref class Value sealed
[<SealedAttribute>]
type Value =  class end

The IrdMasterValue type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMasterValue | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | Gets the value's IrdDeviceValueDirection object.
Public property | Id | Gets the unique ID of the value.
Public property | IsProcessCall | Gets whether this value is based on a SMBus process call or block write-block read process call.
Public property | Name | Gets the value's name.
Public property | Por | Gets the value's power on reset value (POR).
Public property | Type | Gets the value's IrdDeviceType object.
Public property | TypeAscii | If the IrdDeviceType object returned by Type has got the type IrdDeviceTypeString, this method can be used to return the IrdDeviceTypeAscii object referenced by the IrdDeviceTypeString object.
Public property | Unit | Gets the unit used by the value.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMaster.Value Constructor

IrdMasterValue Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Value(
    IrdDeviceValue val,
    IrdDevice ird_device
)
Public Sub New (
    val As IrdDeviceValue,
    ird_device As IrdDevice
)
public:
Value(
    IrdDeviceValue^ val,
    IrdDevice^ ird_device
)
new :
        val : IrdDeviceValue *
        ird_device : IrdDevice -> Value

Parameters

val
Type: telos.I2cApi.DotNetIrdDeviceValue
IRD description of the value
ird_device
Type: telos.I2cApi.DotNetIrdDevice
IRD description of the IC
See Also

Reference

IrdMasterValue Class


Value Methods

Value Methods

The IrdMasterValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMasterValue Class


Value Properties

Value Properties

The IrdMasterValue type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Gets the value's IrdDeviceValueDirection object.
Public property | Id | Gets the unique ID of the value.
Public property | IsProcessCall | Gets whether this value is based on a SMBus process call or block write-block read process call.
Public property | Name | Gets the value's name.
Public property | Por | Gets the value's power on reset value (POR).
Public property | Type | Gets the value's IrdDeviceType object.
Public property | TypeAscii | If the IrdDeviceType object returned by Type has got the type IrdDeviceTypeString, this method can be used to return the IrdDeviceTypeAscii object referenced by the IrdDeviceTypeString object.
Public property | Unit | Gets the unit used by the value.
Top
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.Direction Property

IrdMasterValueDirection Property
Gets the value's IrdDeviceValueDirection object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceValueDirection Direction { get; }
Public ReadOnly Property Direction As IrdDeviceValueDirection
    Get
public:
property IrdDeviceValueDirection Direction {
    IrdDeviceValueDirection get ();
}
member Direction : IrdDeviceValueDirection with get

Property Value

Type: IrdDeviceValueDirection
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.Id Property

IrdMasterValueId Property
Gets the unique ID of the value.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

Type: String
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.IsProcessCall Property

IrdMasterValueIsProcessCall Property
Gets whether this value is based on a SMBus process call or block write-block read process call.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsProcessCall { get; }
Public ReadOnly Property IsProcessCall As Boolean
    Get
public:
property bool IsProcessCall {
    bool get ();
}
member IsProcessCall : bool with get

Property Value

Type: Boolean
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.Name Property

IrdMasterValueName Property
Gets the value's name.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.Por Property

IrdMasterValuePor Property
Gets the value's power on reset value (POR).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Por { get; }
Public ReadOnly Property Por As Object
    Get
public:
property Object^ Por {
    Object^ get ();
}
member Por : Object with get

Property Value

Type: Object
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.Type Property

IrdMasterValueType Property
Gets the value's IrdDeviceType object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceType Type { get; }
Public ReadOnly Property Type As IrdDeviceType
    Get
public:
property IrdDeviceType^ Type {
    IrdDeviceType^ get ();
}
member Type : IrdDeviceType with get

Property Value

Type: IrdDeviceType
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.TypeAscii Property

IrdMasterValueTypeAscii Property
If the IrdDeviceType object returned by Type has got the type IrdDeviceTypeString, this method can be used to return the IrdDeviceTypeAscii object referenced by the IrdDeviceTypeString object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceTypeAscii TypeAscii { get; }
Public ReadOnly Property TypeAscii As IrdDeviceTypeAscii
    Get
public:
property IrdDeviceTypeAscii^ TypeAscii {
    IrdDeviceTypeAscii^ get ();
}
member TypeAscii : IrdDeviceTypeAscii with get

Property Value

Type: IrdDeviceTypeAscii
See Also

Reference

IrdMasterValue Class


IrdMaster.Value.Unit Property

IrdMasterValueUnit Property
Gets the unit used by the value.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Unit { get; }
Public ReadOnly Property Unit As String
    Get
public:
property String^ Unit {
    String^ get ();
}
member Unit : string with get

Property Value

Type: String
See Also

Reference

IrdMasterValue Class


IrdMaster.ValueGroup Class

IrdMasterValueGroup Class
Group of values. One value in a group cannot be read or written without reading or writing all other values of the group.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList IrdMasterValue
telos.I2cApi.DotNetIrdMasterValueGroup

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ValueGroup : List<IrdMasterValue>
Public NotInheritable Class ValueGroup
    Inherits List(Of IrdMasterValue)
public ref class ValueGroup sealed : public List<IrdMasterValue^>
[<SealedAttribute>]
type ValueGroup =
    class
        inherit List<IrdMasterValue>
    end

The IrdMasterValueGroup type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMasterValueGroup | Initializes a new instance of the IrdMasterValueGroup class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List IrdMasterValue .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List IrdMasterValue .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List IrdMasterValue .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValue .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValue .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValue .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List IrdMasterValue .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List IrdMasterValue .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List IrdMasterValue .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List IrdMasterValue .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValue .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValue .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValue .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValue .)
Public method | FindIndexById | Returns the index of the IrdMasterValue, which uses the given identifier.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValue .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValue .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List IrdMasterValue .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List IrdMasterValue .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List IrdMasterValue .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValue .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValue .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List IrdMasterValue .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List IrdMasterValue .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValue .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValue .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List IrdMasterValue .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List IrdMasterValue .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List IrdMasterValue .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List IrdMasterValue .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List IrdMasterValue .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List IrdMasterValue .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List IrdMasterValue .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List IrdMasterValue .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List IrdMasterValue .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List IrdMasterValue .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List IrdMasterValue .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List IrdMasterValue .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List IrdMasterValue .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List IrdMasterValue .)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMaster.ValueGroup Constructor

IrdMasterValueGroup Constructor
Initializes a new instance of the IrdMasterValueGroup class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueGroup()
Public Sub New
public:
ValueGroup()
new : unit -> ValueGroup
See Also

Reference

IrdMasterValueGroup Class


ValueGroup Methods

ValueGroup Methods

The IrdMasterValueGroup type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List IrdMasterValue .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List IrdMasterValue .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List IrdMasterValue .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValue .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValue .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValue .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List IrdMasterValue .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List IrdMasterValue .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List IrdMasterValue .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List IrdMasterValue .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValue .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValue .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValue .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValue .)
Public method | FindIndexById | Returns the index of the IrdMasterValue, which uses the given identifier.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValue .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValue .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List IrdMasterValue .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List IrdMasterValue .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List IrdMasterValue .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValue .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValue .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List IrdMasterValue .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List IrdMasterValue .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValue .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValue .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValue .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List IrdMasterValue .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List IrdMasterValue .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List IrdMasterValue .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List IrdMasterValue .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List IrdMasterValue .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List IrdMasterValue .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List IrdMasterValue .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List IrdMasterValue .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List IrdMasterValue .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List IrdMasterValue .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List IrdMasterValue .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List IrdMasterValue .)
Top
See Also

Reference

IrdMasterValueGroup Class


IrdMaster.ValueGroup.FindIndexById Method

IrdMasterValueGroupFindIndexById Method
Returns the index of the IrdMasterValue, which uses the given identifier.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int FindIndexById(
    string id
)
Public Function FindIndexById (
    id As String
) As Integer
public:
int FindIndexById(
    String^ id
)
member FindIndexById :
        id : string -> int

Parameters

id
Type: SystemString
identifier

Return Value

Type: Int32
index or N/A (-1)
See Also

Reference

IrdMasterValueGroup Class


ValueGroup Properties

ValueGroup Properties

The IrdMasterValueGroup type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List IrdMasterValue .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List IrdMasterValue .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List IrdMasterValue .)
Top
See Also

Reference

IrdMasterValueGroup Class


IrdMaster.ValueGroups Class

IrdMasterValueGroups Class
Stores all value groups of an IC.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList IrdMasterValueGroup
telos.I2cApi.DotNetIrdMasterValueGroups

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ValueGroups : List<IrdMasterValueGroup>
Public NotInheritable Class ValueGroups
    Inherits List(Of IrdMasterValueGroup)
public ref class ValueGroups sealed : public List<IrdMasterValueGroup^>
[<SealedAttribute>]
type ValueGroups =
    class
        inherit List<IrdMasterValueGroup>
    end

The IrdMasterValueGroups type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMasterValueGroups | Initializes a new instance of the IrdMasterValueGroups class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List IrdMasterValueGroup .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValueGroup .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValueGroup .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValueGroup .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List IrdMasterValueGroup .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List IrdMasterValueGroup .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValueGroup .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValueGroup .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndexById | Returns the index of the IrdMasterValueGroup, which contains a IrdMasterValue object using the given identifier.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List IrdMasterValueGroup .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValueGroup .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValueGroup .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValueGroup .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List IrdMasterValueGroup .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List IrdMasterValueGroup .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List IrdMasterValueGroup .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List IrdMasterValueGroup .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List IrdMasterValueGroup .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List IrdMasterValueGroup .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List IrdMasterValueGroup .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List IrdMasterValueGroup .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List IrdMasterValueGroup .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List IrdMasterValueGroup .)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMaster.ValueGroups Constructor

IrdMasterValueGroups Constructor
Initializes a new instance of the IrdMasterValueGroups class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueGroups()
Public Sub New
public:
ValueGroups()
new : unit -> ValueGroups
See Also

Reference

IrdMasterValueGroups Class


ValueGroups Methods

ValueGroups Methods

The IrdMasterValueGroups type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List IrdMasterValueGroup .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValueGroup .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValueGroup .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List IrdMasterValueGroup .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List IrdMasterValueGroup .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List IrdMasterValueGroup .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValueGroup .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List IrdMasterValueGroup .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValueGroup .)
Public method | FindIndexById | Returns the index of the IrdMasterValueGroup, which contains a IrdMasterValue object using the given identifier.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List IrdMasterValueGroup .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List IrdMasterValueGroup .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List IrdMasterValueGroup .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List IrdMasterValueGroup .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List IrdMasterValueGroup .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List IrdMasterValueGroup .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List IrdMasterValueGroup .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List IrdMasterValueGroup .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List IrdMasterValueGroup .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List IrdMasterValueGroup .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List IrdMasterValueGroup .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List IrdMasterValueGroup .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List IrdMasterValueGroup .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List IrdMasterValueGroup .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List IrdMasterValueGroup .)
Top
See Also

Reference

IrdMasterValueGroups Class


IrdMaster.ValueGroups.FindIndexById Method

IrdMasterValueGroupsFindIndexById Method
Returns the index of the IrdMasterValueGroup, which contains a IrdMasterValue object using the given identifier.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int FindIndexById(
    string id
)
Public Function FindIndexById (
    id As String
) As Integer
public:
int FindIndexById(
    String^ id
)
member FindIndexById :
        id : string -> int

Parameters

id
Type: SystemString
identifier

Return Value

Type: Int32
index or N/A (-1)
See Also

Reference

IrdMasterValueGroups Class


ValueGroups Properties

ValueGroups Properties

The IrdMasterValueGroups type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List IrdMasterValueGroup .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List IrdMasterValueGroup .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List IrdMasterValueGroup .)
Top
See Also

Reference

IrdMasterValueGroups Class


IrdMasterMessage Class

IrdMasterMessage Class
This class is used as a base class for all IRD master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMasterMessage
telos.I2cApi.DotNetIrdMasterMessageRx
telos.I2cApi.DotNetIrdMasterMessageTx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class IrdMasterMessage
Public MustInherit Class IrdMasterMessage
public ref class IrdMasterMessage abstract
[<AbstractClassAttribute>]
type IrdMasterMessage =  class end

The IrdMasterMessage type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMasterMessage | Constructor
Top
Methods
 | Name | Description
Protected method | CheckDirection | Throws an exception, if the direction of the value with the given index does not have the correct direction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_data | data for the values, which are part of the value group
Top
Properties
 | Name | Description
Public property | Address | Gets the I2C address.
Public property | DataAsArrayInt32 | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.
Public property | DataAsArrayString | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.
Public property | DataAsAsciiInt32 | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.
Public property | DataAsAsciiString | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.
Public property | DataAsIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsStringInt32 | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.
Public property | DataAsStringString | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.
Public property | DataAsUIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsUIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataCount | Gets the number of values, which are part of the value group.
Public property | Type | Gets the type of the specified value.
Public property | ValueGroup | Gets the group of values to be written/read using this message.
Top
Remarks
Instances of classes derived from this class can be sent with the TransferData(IrdMasterMessage) method.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMasterMessage Constructor

IrdMasterMessage Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMasterMessage(
    I2cAddress i2c_addr,
    IrdMasterValueGroup value_group,
    bool check_range
)
Public Sub New (
    i2c_addr As I2cAddress,
    value_group As IrdMasterValueGroup,
    check_range As Boolean
)
public:
IrdMasterMessage(
    I2cAddress^ i2c_addr,
    IrdMasterValueGroup^ value_group,
    bool check_range
)
new :
        i2c_addr : I2cAddress *
        value_group : IrdMasterValueGroup *
        check_range : bool -> IrdMasterMessage

Parameters

i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
value_group
Type: telos.I2cApi.DotNetIrdMasterValueGroup
group of values to be written/read using this message
check_range
Type: SystemBoolean
check data passed to the data properties to be in range
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage Fields

IrdMasterMessage Fields

The IrdMasterMessage type exposes the following members.

Fields
 | Name | Description
Protected field | m_data | data for the values, which are part of the value group
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.m_data Field

IrdMasterMessagem_data Field
data for the values, which are part of the value group

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected Object[] m_data
Protected m_data As Object()
protected:
array<Object^>^ m_data
val mutable m_data: Object[]

Field Value

Type: Object
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage Methods

IrdMasterMessage Methods

The IrdMasterMessage type exposes the following members.

Methods
 | Name | Description
Protected method | CheckDirection | Throws an exception, if the direction of the value with the given index does not have the correct direction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.CheckDirection Method

IrdMasterMessageCheckDirection Method
Throws an exception, if the direction of the value with the given index does not have the correct direction.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected abstract void CheckDirection(
    int index
)
Protected MustOverride Sub CheckDirection (
    index As Integer
)
protected:
virtual void CheckDirection(
    int index
) abstract
abstract CheckDirection :
        index : int -> unit

Parameters

index
Type: SystemInt32
index of the value in the value group
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage Properties

IrdMasterMessage Properties

The IrdMasterMessage type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the I2C address.
Public property | DataAsArrayInt32 | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.
Public property | DataAsArrayString | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.
Public property | DataAsAsciiInt32 | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.
Public property | DataAsAsciiString | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.
Public property | DataAsIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsStringInt32 | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.
Public property | DataAsStringString | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.
Public property | DataAsUIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsUIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataCount | Gets the number of values, which are part of the value group.
Public property | Type | Gets the type of the specified value.
Public property | ValueGroup | Gets the group of values to be written/read using this message.
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.Address Property

IrdMasterMessageAddress Property
Gets the I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; }
Public ReadOnly Property Address As I2cAddress
    Get
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
}
member Address : I2cAddress with get

Property Value

Type: I2cAddress
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.DataAsArray Property

IrdMasterMessageDataAsArray Property
Overload List
 | Name | Description
Public property | DataAsArrayInt32 | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.
Public property | DataAsArrayString | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.DataAsArray Property (Int32)

IrdMasterMessageDataAsArray Property (Int32)
Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<byte> this[
    int index
] { get; set; }
Public Property DataAsArray (
    index As Integer
) As List(Of Byte)
    Get
    Set
public:
property List<unsigned char>^ DataAsArray[int index] {
    List<unsigned char>^ get (int index);
    void set (int index, List<unsigned char>^ value);
}
member DataAsArray : List<byte> with get, set

Parameters

index
Type: SystemInt32
index of the value in the value group

Property Value

Type: List Byte
See Also

Reference

IrdMasterMessage Class
DataAsArray Overload


IrdMasterMessage.DataAsArray Property (String)

IrdMasterMessageDataAsArray Property (String)
Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<byte> this[
    string id
] { get; set; }
Public Property DataAsArray (
    id As String
) As List(Of Byte)
    Get
    Set
public:
property List<unsigned char>^ DataAsArray[String^ id] {
    List<unsigned char>^ get (String^ id);
    void set (String^ id, List<unsigned char>^ value);
}
member DataAsArray : List<byte> with get, set

Parameters

id
Type: SystemString
identifier of the value

Property Value

Type: List Byte
See Also

Reference

IrdMasterMessage Class
DataAsArray Overload


IrdMasterMessage.DataAsAscii Property

IrdMasterMessageDataAsAscii Property
Overload List
 | Name | Description
Public property | DataAsAsciiInt32 | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.
Public property | DataAsAsciiString | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.DataAsAscii Property (Int32)

IrdMasterMessageDataAsAscii Property (Int32)
Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public char this[
    int index
] { get; set; }
Public Property DataAsAscii (
    index As Integer
) As Char
    Get
    Set
public:
property wchar_t DataAsAscii[int index] {
    wchar_t get (int index);
    void set (int index, wchar_t value);
}
member DataAsAscii : char with get, set

Parameters

index
Type: SystemInt32
index of the value in the value group

Property Value

Type: Char
See Also

Reference

IrdMasterMessage Class
DataAsAscii Overload


IrdMasterMessage.DataAsAscii Property (String)

IrdMasterMessageDataAsAscii Property (String)
Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public char this[
    string id
] { get; set; }
Public Property DataAsAscii (
    id As String
) As Char
    Get
    Set
public:
property wchar_t DataAsAscii[String^ id] {
    wchar_t get (String^ id);
    void set (String^ id, wchar_t value);
}
member DataAsAscii : char with get, set

Parameters

id
Type: SystemString
identifier of the value

Property Value

Type: Char
See Also

Reference

IrdMasterMessage Class
DataAsAscii Overload


IrdMasterMessage.DataAsInt Property

IrdMasterMessageDataAsInt Property
Overload List
 | Name | Description
Public property | DataAsIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.DataAsInt Property (Int32)

IrdMasterMessageDataAsInt Property (Int32)
Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int this[
    int index
] { get; set; }
Public Property DataAsInt (
    index As Integer
) As Integer
    Get
    Set
public:
property int DataAsInt[int index] {
    int get (int index);
    void set (int index, int value);
}
member DataAsInt : int with get, set

Parameters

index
Type: SystemInt32
index of the value in the value group

Property Value

Type: Int32
See Also

Reference

IrdMasterMessage Class
DataAsInt Overload


IrdMasterMessage.DataAsInt Property (String)

IrdMasterMessageDataAsInt Property (String)
Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int this[
    string id
] { get; set; }
Public Property DataAsInt (
    id As String
) As Integer
    Get
    Set
public:
property int DataAsInt[String^ id] {
    int get (String^ id);
    void set (String^ id, int value);
}
member DataAsInt : int with get, set

Parameters

id
Type: SystemString
identifier of the value

Property Value

Type: Int32
See Also

Reference

IrdMasterMessage Class
DataAsInt Overload


IrdMasterMessage.DataAsString Property

IrdMasterMessageDataAsString Property
Overload List
 | Name | Description
Public property | DataAsStringInt32 | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.
Public property | DataAsStringString | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.DataAsString Property (Int32)

IrdMasterMessageDataAsString Property (Int32)
Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string this[
    int index
] { get; set; }
Public Property DataAsString (
    index As Integer
) As String
    Get
    Set
public:
property String^ DataAsString[int index] {
    String^ get (int index);
    void set (int index, String^ value);
}
member DataAsString : string with get, set

Parameters

index
Type: SystemInt32
index of the value in the value group

Property Value

Type: String
See Also

Reference

IrdMasterMessage Class
DataAsString Overload


IrdMasterMessage.DataAsString Property (String)

IrdMasterMessageDataAsString Property (String)
Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string this[
    string id
] { get; set; }
Public Property DataAsString (
    id As String
) As String
    Get
    Set
public:
property String^ DataAsString[String^ id] {
    String^ get (String^ id);
    void set (String^ id, String^ value);
}
member DataAsString : string with get, set

Parameters

id
Type: SystemString
identifier of the value

Property Value

Type: String
See Also

Reference

IrdMasterMessage Class
DataAsString Overload


IrdMasterMessage.DataAsUInt Property

IrdMasterMessageDataAsUInt Property
Overload List
 | Name | Description
Public property | DataAsUIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Public property | DataAsUIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.
Top
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.DataAsUInt Property (Int32)

IrdMasterMessageDataAsUInt Property (Int32)
Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint this[
    int index
] { get; set; }
Public Property DataAsUInt (
    index As Integer
) As UInteger
    Get
    Set
public:
property unsigned int DataAsUInt[int index] {
    unsigned int get (int index);
    void set (int index, unsigned int value);
}
member DataAsUInt : uint32 with get, set

Parameters

index
Type: SystemInt32
index of the value in the value group

Property Value

Type: UInt32
See Also

Reference

IrdMasterMessage Class
DataAsUInt Overload


IrdMasterMessage.DataAsUInt Property (String)

IrdMasterMessageDataAsUInt Property (String)
Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint this[
    string id
] { get; set; }
Public Property DataAsUInt (
    id As String
) As UInteger
    Get
    Set
public:
property unsigned int DataAsUInt[String^ id] {
    unsigned int get (String^ id);
    void set (String^ id, unsigned int value);
}
member DataAsUInt : uint32 with get, set

Parameters

id
Type: SystemString
identifier of the value

Property Value

Type: UInt32
See Also

Reference

IrdMasterMessage Class
DataAsUInt Overload


IrdMasterMessage.DataCount Property

IrdMasterMessageDataCount Property
Gets the number of values, which are part of the value group.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int DataCount { get; }
Public ReadOnly Property DataCount As Integer
    Get
public:
property int DataCount {
    int get ();
}
member DataCount : int with get

Property Value

Type: Int32
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.Type Property

IrdMasterMessageType Property
Gets the type of the specified value.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceType this[
    int index
] { get; }
Public ReadOnly Property Type (
    index As Integer
) As IrdDeviceType
    Get
public:
property IrdDeviceType^ Type[int index] {
    IrdDeviceType^ get (int index);
}
member Type : IrdDeviceType with get

Parameters

index
Type: SystemInt32
index of the value in the value group

Property Value

Type: IrdDeviceType
See Also

Reference

IrdMasterMessage Class


IrdMasterMessage.ValueGroup Property

IrdMasterMessageValueGroup Property
Gets the group of values to be written/read using this message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMasterValueGroup ValueGroup { get; }
Public ReadOnly Property ValueGroup As IrdMasterValueGroup
    Get
public:
property IrdMasterValueGroup^ ValueGroup {
    IrdMasterValueGroup^ get ();
}
member ValueGroup : IrdMasterValueGroup with get

Property Value

Type: IrdMasterValueGroup
See Also

Reference

IrdMasterMessage Class


IrdMasterMessageRx Class

IrdMasterMessageRx Class
This class is used for IRD master receiver messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMasterMessage
telos.I2cApi.DotNetIrdMasterMessageRx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdMasterMessageRx : IrdMasterMessage
Public NotInheritable Class IrdMasterMessageRx
    Inherits IrdMasterMessage
public ref class IrdMasterMessageRx sealed : public IrdMasterMessage
[<SealedAttribute>]
type IrdMasterMessageRx =
    class
        inherit IrdMasterMessage
    end

The IrdMasterMessageRx type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMasterMessageRx | Constructor
Top
Methods
 | Name | Description
Protected method | CheckDirection | Throws an exception, if the direction of the value with the given index is write-only. (Overrides IrdMasterMessageCheckDirection(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_data | data for the values, which are part of the value group (Inherited from IrdMasterMessage.)
Top
Properties
 | Name | Description
Public property | Address | Gets the I2C address. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayInt32 | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayString | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiInt32 | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiString | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringInt32 | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringString | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataCount | Gets the number of values, which are part of the value group. (Inherited from IrdMasterMessage.)
Public property | Type | Gets the type of the specified value. (Inherited from IrdMasterMessage.)
Public property | ValueGroup | Gets the group of values to be written/read using this message. (Inherited from IrdMasterMessage.)
Top
Remarks
Instances of this class can be sent with the TransferData(IrdMasterMessage) method.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMasterMessageRx Constructor

IrdMasterMessageRx Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMasterMessageRx(
    I2cAddress i2c_addr,
    IrdMasterValueGroup value_group
)
Public Sub New (
    i2c_addr As I2cAddress,
    value_group As IrdMasterValueGroup
)
public:
IrdMasterMessageRx(
    I2cAddress^ i2c_addr,
    IrdMasterValueGroup^ value_group
)
new :
        i2c_addr : I2cAddress *
        value_group : IrdMasterValueGroup -> IrdMasterMessageRx

Parameters

i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
value_group
Type: telos.I2cApi.DotNetIrdMasterValueGroup
group of values to be written/read using this message
See Also

Reference

IrdMasterMessageRx Class


IrdMasterMessageRx Fields

IrdMasterMessageRx Fields

The IrdMasterMessageRx type exposes the following members.

Fields
 | Name | Description
Protected field | m_data | data for the values, which are part of the value group (Inherited from IrdMasterMessage.)
Top
See Also

Reference

IrdMasterMessageRx Class


IrdMasterMessageRx Methods

IrdMasterMessageRx Methods

The IrdMasterMessageRx type exposes the following members.

Methods
 | Name | Description
Protected method | CheckDirection | Throws an exception, if the direction of the value with the given index is write-only. (Overrides IrdMasterMessageCheckDirection(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMasterMessageRx Class


IrdMasterMessageRx.CheckDirection Method

IrdMasterMessageRxCheckDirection Method
Throws an exception, if the direction of the value with the given index is write-only.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void CheckDirection(
    int index
)
Protected Overrides NotOverridable Sub CheckDirection (
    index As Integer
)
protected:
virtual void CheckDirection(
    int index
) override sealed
abstract CheckDirection :
        index : int -> unit
override CheckDirection :
        index : int -> unit

Parameters

index
Type: SystemInt32
index of the value in the value group
See Also

Reference

IrdMasterMessageRx Class


IrdMasterMessageRx Properties

IrdMasterMessageRx Properties

The IrdMasterMessageRx type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the I2C address. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayInt32 | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayString | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiInt32 | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiString | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringInt32 | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringString | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataCount | Gets the number of values, which are part of the value group. (Inherited from IrdMasterMessage.)
Public property | Type | Gets the type of the specified value. (Inherited from IrdMasterMessage.)
Public property | ValueGroup | Gets the group of values to be written/read using this message. (Inherited from IrdMasterMessage.)
Top
See Also

Reference

IrdMasterMessageRx Class


IrdMasterMessageTx Class

IrdMasterMessageTx Class
This class is used for IRD master transmitter messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdMasterMessage
telos.I2cApi.DotNetIrdMasterMessageTx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdMasterMessageTx : IrdMasterMessage
Public NotInheritable Class IrdMasterMessageTx
    Inherits IrdMasterMessage
public ref class IrdMasterMessageTx sealed : public IrdMasterMessage
[<SealedAttribute>]
type IrdMasterMessageTx =
    class
        inherit IrdMasterMessage
    end

The IrdMasterMessageTx type exposes the following members.

Constructors
 | Name | Description
Public method | IrdMasterMessageTx | Constructor
Top
Methods
 | Name | Description
Protected method | CheckDirection | Throws an exception, if the direction of the value with the given index is read-only. (Overrides IrdMasterMessageCheckDirection(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDefaultData | Sets a valid default for each of the values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_data | data for the values, which are part of the value group (Inherited from IrdMasterMessage.)
Top
Properties
 | Name | Description
Public property | Address | Gets the I2C address. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayInt32 | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayString | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiInt32 | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiString | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringInt32 | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringString | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataCount | Gets the number of values, which are part of the value group. (Inherited from IrdMasterMessage.)
Public property | Type | Gets the type of the specified value. (Inherited from IrdMasterMessage.)
Public property | ValueGroup | Gets the group of values to be written/read using this message. (Inherited from IrdMasterMessage.)
Top
Remarks
Instances of this class can be sent with the TransferData(IrdMasterMessage) method.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdMasterMessageTx Constructor

IrdMasterMessageTx Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMasterMessageTx(
    I2cAddress i2c_addr,
    IrdMasterValueGroup value_group
)
Public Sub New (
    i2c_addr As I2cAddress,
    value_group As IrdMasterValueGroup
)
public:
IrdMasterMessageTx(
    I2cAddress^ i2c_addr,
    IrdMasterValueGroup^ value_group
)
new :
        i2c_addr : I2cAddress *
        value_group : IrdMasterValueGroup -> IrdMasterMessageTx

Parameters

i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
value_group
Type: telos.I2cApi.DotNetIrdMasterValueGroup
group of values to be written/read using this message
See Also

Reference

IrdMasterMessageTx Class


IrdMasterMessageTx Fields

IrdMasterMessageTx Fields

The IrdMasterMessageTx type exposes the following members.

Fields
 | Name | Description
Protected field | m_data | data for the values, which are part of the value group (Inherited from IrdMasterMessage.)
Top
See Also

Reference

IrdMasterMessageTx Class


IrdMasterMessageTx Methods

IrdMasterMessageTx Methods

The IrdMasterMessageTx type exposes the following members.

Methods
 | Name | Description
Protected method | CheckDirection | Throws an exception, if the direction of the value with the given index is read-only. (Overrides IrdMasterMessageCheckDirection(Int32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDefaultData | Sets a valid default for each of the values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdMasterMessageTx Class


IrdMasterMessageTx.CheckDirection Method

IrdMasterMessageTxCheckDirection Method
Throws an exception, if the direction of the value with the given index is read-only.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void CheckDirection(
    int index
)
Protected Overrides NotOverridable Sub CheckDirection (
    index As Integer
)
protected:
virtual void CheckDirection(
    int index
) override sealed
abstract CheckDirection :
        index : int -> unit
override CheckDirection :
        index : int -> unit

Parameters

index
Type: SystemInt32
index of the value in the value group
See Also

Reference

IrdMasterMessageTx Class


IrdMasterMessageTx.SetDefaultData Method

IrdMasterMessageTxSetDefaultData Method
Sets a valid default for each of the values.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultData()
Public Sub SetDefaultData
public:
void SetDefaultData()
member SetDefaultData : unit -> unit
See Also

Reference

IrdMasterMessageTx Class


IrdMasterMessageTx Properties

IrdMasterMessageTx Properties

The IrdMasterMessageTx type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the I2C address. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayInt32 | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsArrayString | Sets/gets the array for the specified value. The value has to be of the IrdDeviceTypeArray type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiInt32 | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsAsciiString | Sets/gets the character for the specified value. The value has to be of the IrdDeviceTypeAscii type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringInt32 | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsStringString | Sets/gets the string for the specified value. The value has to be of the IrdDeviceTypeString type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntInt32 | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataAsUIntString | Sets/gets the integer for the specified value. The value has to be of the IrdDeviceTypeInt type. (Inherited from IrdMasterMessage.)
Public property | DataCount | Gets the number of values, which are part of the value group. (Inherited from IrdMasterMessage.)
Public property | Type | Gets the type of the specified value. (Inherited from IrdMasterMessage.)
Public property | ValueGroup | Gets the group of values to be written/read using this message. (Inherited from IrdMasterMessage.)
Top
See Also

Reference

IrdMasterMessageTx Class


IrdReader Class

IrdReader Class
Reads an IRD (I2C Register Description) file into the RAM and returns the parsed result as IrdDevice object.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdReader

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdReader
Public NotInheritable Class IrdReader
public ref class IrdReader sealed
[<SealedAttribute>]
type IrdReader =  class end

The IrdReader type exposes the following members.

Constructors
 | Name | Description
Public method | IrdReader | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Parses the specified IRD file and returns the result as object.
Public method | ReadHeader | Parses the header of the specified IRD file and returns the result as object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CryptKey | Sets the key used for the decryption of encrypted IRD files. The key must have 24 bytes. To set no decryption key "0" can be used.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdReader Constructor

IrdReader Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdReader()
Public Sub New
public:
IrdReader()
new : unit -> IrdReader
See Also

Reference

IrdReader Class


IrdReader Methods

IrdReader Methods

The IrdReader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Parses the specified IRD file and returns the result as object.
Public method | ReadHeader | Parses the header of the specified IRD file and returns the result as object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdReader Class


IrdReader.Read Method

IrdReaderRead Method
Parses the specified IRD file and returns the result as object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDevice Read(
    string filename
)
Public Function Read (
    filename As String
) As IrdDevice
public:
IrdDevice^ Read(
    String^ filename
)
member Read :
        filename : string -> IrdDevice

Parameters

filename
Type: SystemString
filename of the IRD file

Return Value

Type: IrdDevice
result as IrdDevice object
Remarks
It is possible to read standard text IRD files or encrypted IRD files. If no decryption key gets specified (CryptKey = 0), this method tries to parse the IRD file as standard text file.
See Also

Reference

IrdReader Class


IrdReader.ReadHeader Method

IrdReaderReadHeader Method
Parses the header of the specified IRD file and returns the result as object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDevice ReadHeader(
    string filename
)
Public Function ReadHeader (
    filename As String
) As IrdDevice
public:
IrdDevice^ ReadHeader(
    String^ filename
)
member ReadHeader :
        filename : string -> IrdDevice

Parameters

filename
Type: SystemString
filename of the IRD file

Return Value

Type: IrdDevice
result as IrdDevice object
Remarks
It is possible to read standard text IRD files or encrypted IRD files. If no decryption key gets specified (CryptKey = 0), this method tries to parse the IRD file as standard text file.
See Also

Reference

IrdReader Class


IrdReader Properties

IrdReader Properties

The IrdReader type exposes the following members.

Properties
 | Name | Description
Public property | CryptKey | Sets the key used for the decryption of encrypted IRD files. The key must have 24 bytes. To set no decryption key "0" can be used.
Top
See Also

Reference

IrdReader Class


IrdReader.CryptKey Property

IrdReaderCryptKey Property
Sets the key used for the decryption of encrypted IRD files. The key must have 24 bytes. To set no decryption key "0" can be used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] CryptKey { set; }
Public WriteOnly Property CryptKey As Byte()
    Set
public:
property array<unsigned char>^ CryptKey {
    void set (array<unsigned char>^ value);
}
member CryptKey : byte[] with set

Property Value

Type: Byte
See Also

Reference

IrdReader Class


IrdTraceFormatter Class

IrdTraceFormatter Class
This class converts parsed tracer messages, which are stored in IrdTraceValueList objects, into a number of strings. These strings can be used e.g. for user outputs.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatter

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceFormatter : IReadOnlyList<IrdTraceFormatterMessage>,
    IDisposable
Public NotInheritable Class IrdTraceFormatter
    Implements IReadOnlyList(Of IrdTraceFormatterMessage), IDisposable
public ref class IrdTraceFormatter sealed : IReadOnlyList<IrdTraceFormatterMessage^>,
    IDisposable
[<SealedAttribute>]
type IrdTraceFormatter =
    class
        interface IReadOnlyList<IrdTraceFormatterMessage>
        interface IDisposable
    end

The IrdTraceFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatter | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAbsTime | Returns the absolute start time of the message.
Public method | GetAbsTimeComplete | Returns the absolute start time of the message using the complete format (e.g. "0 16:30:27.200.431").
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHardwareInfo | Returns the used HardwareInfo instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIrdMap | Returns the used IrdMap instance.
Public method | GetMsgTime | Returns the time of the message (between START and STOP condition).
Public method | GetPlugInMsg | Formats one plug-in message.
Public method | GetRawMsg | Formats one raw message.
Public method | GetRegisterMsg | Formats one register message.
Public method | GetToPrevMsgTime | Returns the bus idle time between this and the previous message.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueMsg | Formats one value message.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MutexEnter | Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexExit | Unlocks the ParsedTracerMessageList to be parsed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of the available I2C messages.
Public property | DataAsHex | Use the hexadecimal format for data bytes?
Public property | I2cAddressesAs8Bit | Use the 8 bit format for I2C addresses?
Public property | I2cAddressesAsHex | Use the hexadecimal format for I2C addresses?
Public property | Item |
Public property | RawDataFormat | Configures the format of the Data string.
Public property | ValueRegisterNames | The registers, which have been involved into a transfer get stored in Registers. Normally the registers are described by their sub address and the involved bits (e.g. "0x20 (0.0)"). If this property is set to "true", the name of the registers (e.g. "0x20 CONFIG (0.0)") gets added.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter Constructor

IrdTraceFormatter Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatter(
    IrdTraceValueList msgs,
    int cache_size
)
Public Sub New (
    msgs As IrdTraceValueList,
    cache_size As Integer
)
public:
IrdTraceFormatter(
    IrdTraceValueList^ msgs,
    int cache_size
)
new :
        msgs : IrdTraceValueList *
        cache_size : int -> IrdTraceFormatter

Parameters

msgs
Type: telos.I2cApi.DotNetIrdTraceValueList
parsed messages
cache_size
Type: SystemInt32
number of formatted messages to be kept in the internal cache
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter Methods

IrdTraceFormatter Methods

The IrdTraceFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAbsTime | Returns the absolute start time of the message.
Public method | GetAbsTimeComplete | Returns the absolute start time of the message using the complete format (e.g. "0 16:30:27.200.431").
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHardwareInfo | Returns the used HardwareInfo instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIrdMap | Returns the used IrdMap instance.
Public method | GetMsgTime | Returns the time of the message (between START and STOP condition).
Public method | GetPlugInMsg | Formats one plug-in message.
Public method | GetRawMsg | Formats one raw message.
Public method | GetRegisterMsg | Formats one register message.
Public method | GetToPrevMsgTime | Returns the bus idle time between this and the previous message.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueMsg | Formats one value message.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MutexEnter | Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexExit | Unlocks the ParsedTracerMessageList to be parsed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.Dispose Method

IrdTraceFormatterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.Dispose Method

IrdTraceFormatterDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

IrdTraceFormatter Class
Dispose Overload


IrdTraceFormatter.Dispose Method (Boolean)

IrdTraceFormatterDispose Method (Boolean)
Releases the unmanaged resources used by the IrdTraceFormatter and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.IrdTraceFormatter.Dispose(System.Boolean)"]

See Also

Reference

IrdTraceFormatter Class
Dispose Overload


IrdTraceFormatter.GetAbsTime Method

IrdTraceFormatterGetAbsTime Method
Returns the absolute start time of the message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetAbsTime(
    int index,
    ulong abs_time_offset
)
Public Function GetAbsTime (
    index As Integer,
    abs_time_offset As ULong
) As String
public:
String^ GetAbsTime(
    int index,
    unsigned long long abs_time_offset
)
member GetAbsTime :
        index : int *
        abs_time_offset : uint64 -> string

Parameters

index
Type: SystemInt32
index of the message
abs_time_offset
Type: SystemUInt64
offset to be subtracted (as timestamp)

Return Value

Type: String
absolute start time
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetAbsTimeComplete Method

IrdTraceFormatterGetAbsTimeComplete Method
Returns the absolute start time of the message using the complete format (e.g. "0 16:30:27.200.431").

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetAbsTimeComplete(
    int index,
    ulong abs_time_offset
)
Public Function GetAbsTimeComplete (
    index As Integer,
    abs_time_offset As ULong
) As String
public:
String^ GetAbsTimeComplete(
    int index,
    unsigned long long abs_time_offset
)
member GetAbsTimeComplete :
        index : int *
        abs_time_offset : uint64 -> string

Parameters

index
Type: SystemInt32
index of the message
abs_time_offset
Type: SystemUInt64
offset to be subtracted (as timestamp)

Return Value

Type: String
absolute start time
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetEnumerator Method

IrdTraceFormatterGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<IrdTraceFormatterMessage> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IrdTraceFormatterMessage)
public:
virtual IEnumerator<IrdTraceFormatterMessage^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<IrdTraceFormatterMessage>
override GetEnumerator : unit -> IEnumerator<IrdTraceFormatterMessage>

Return Value

Type: IEnumerator IrdTraceFormatterMessage
enumerator
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetEnumerator_NonGeneric Method

IrdTraceFormatterGetEnumerator_NonGeneric Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator_NonGeneric()
Public Function GetEnumerator_NonGeneric As IEnumerator
public:
virtual IEnumerator^ GetEnumerator_NonGeneric() sealed
abstract GetEnumerator_NonGeneric : unit -> IEnumerator
override GetEnumerator_NonGeneric : unit -> IEnumerator

Return Value

Type: IEnumerator
enumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetHardwareInfo Method

IrdTraceFormatterGetHardwareInfo Method
Returns the used HardwareInfo instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public HardwareInfo GetHardwareInfo()
Public Function GetHardwareInfo As HardwareInfo
public:
HardwareInfo^ GetHardwareInfo()
member GetHardwareInfo : unit -> HardwareInfo

Return Value

Type: HardwareInfo
used HardwareInfo
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetIrdMap Method

IrdTraceFormatterGetIrdMap Method
Returns the used IrdMap instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMap GetIrdMap()
Public Function GetIrdMap As IrdMap
public:
IrdMap^ GetIrdMap()
member GetIrdMap : unit -> IrdMap

Return Value

Type: IrdMap
used IrdMap
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetMsgTime Method

IrdTraceFormatterGetMsgTime Method
Returns the time of the message (between START and STOP condition).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetMsgTime(
    int index
)
Public Function GetMsgTime (
    index As Integer
) As String
public:
String^ GetMsgTime(
    int index
)
member GetMsgTime :
        index : int -> string

Parameters

index
Type: SystemInt32
index of the message

Return Value

Type: String
message time
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetPlugInMsg Method

IrdTraceFormatterGetPlugInMsg Method
Formats one plug-in message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterPlugInMessageBase[] GetPlugInMsg(
    int index
)
Public Function GetPlugInMsg (
    index As Integer
) As IrdTraceFormatterPlugInMessageBase()
public:
array<IrdTraceFormatterPlugInMessageBase^>^ GetPlugInMsg(
    int index
)
member GetPlugInMsg :
        index : int -> IrdTraceFormatterPlugInMessageBase[]

Parameters

index
Type: SystemInt32
index of the message

Return Value

Type: IrdTraceFormatterPlugInMessageBase
formatted message
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetRawMsg Method

IrdTraceFormatterGetRawMsg Method
Formats one raw message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterRawSubMessageBase[] GetRawMsg(
    int index
)
Public Function GetRawMsg (
    index As Integer
) As IrdTraceFormatterRawSubMessageBase()
public:
array<IrdTraceFormatterRawSubMessageBase^>^ GetRawMsg(
    int index
)
member GetRawMsg :
        index : int -> IrdTraceFormatterRawSubMessageBase[]

Parameters

index
Type: SystemInt32
index of the message

Return Value

Type: IrdTraceFormatterRawSubMessageBase
formatted message
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetRegisterMsg Method

IrdTraceFormatterGetRegisterMsg Method
Formats one register message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterRegisterMessageBase[] GetRegisterMsg(
    int index
)
Public Function GetRegisterMsg (
    index As Integer
) As IrdTraceFormatterRegisterMessageBase()
public:
array<IrdTraceFormatterRegisterMessageBase^>^ GetRegisterMsg(
    int index
)
member GetRegisterMsg :
        index : int -> IrdTraceFormatterRegisterMessageBase[]

Parameters

index
Type: SystemInt32
index of the message

Return Value

Type: IrdTraceFormatterRegisterMessageBase
formatted message
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetToPrevMsgTime Method

IrdTraceFormatterGetToPrevMsgTime Method
Returns the bus idle time between this and the previous message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetToPrevMsgTime(
    int index
)
Public Function GetToPrevMsgTime (
    index As Integer
) As String
public:
String^ GetToPrevMsgTime(
    int index
)
member GetToPrevMsgTime :
        index : int -> string

Parameters

index
Type: SystemInt32
index of the message

Return Value

Type: String
idle time
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.GetValueMsg Method

IrdTraceFormatterGetValueMsg Method
Formats one value message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterValueMessageBase[] GetValueMsg(
    int index
)
Public Function GetValueMsg (
    index As Integer
) As IrdTraceFormatterValueMessageBase()
public:
array<IrdTraceFormatterValueMessageBase^>^ GetValueMsg(
    int index
)
member GetValueMsg :
        index : int -> IrdTraceFormatterValueMessageBase[]

Parameters

index
Type: SystemInt32
index of the message

Return Value

Type: IrdTraceFormatterValueMessageBase
formatted message
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.MutexEnter Method

IrdTraceFormatterMutexEnter Method
Overload List
 | Name | Description
Public method | MutexEnter | Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Top
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.MutexEnter Method

IrdTraceFormatterMutexEnter Method
Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void MutexEnter()
Public Sub MutexEnter
public:
void MutexEnter()
member MutexEnter : unit -> unit
See Also

Reference

IrdTraceFormatter Class
MutexEnter Overload


IrdTraceFormatter.MutexEnter Method (TimeSpan)

IrdTraceFormatterMutexEnter Method (TimeSpan)
Locks the IrdTraceValueList to be formatted. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool MutexEnter(
    TimeSpan timeout
)
Public Function MutexEnter (
    timeout As TimeSpan
) As Boolean
public:
bool MutexEnter(
    TimeSpan timeout
)
member MutexEnter :
        timeout : TimeSpan -> bool

Parameters

timeout
Type: SystemTimeSpan
timeout

Return Value

Type: Boolean
lock acquired (true), not acquired (false)
See Also

Reference

IrdTraceFormatter Class
MutexEnter Overload


IrdTraceFormatter.MutexExit Method

IrdTraceFormatterMutexExit Method
Unlocks the ParsedTracerMessageList to be parsed.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void MutexExit()
Public Sub MutexExit
public:
void MutexExit()
member MutexExit : unit -> unit
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter Properties

IrdTraceFormatter Properties

The IrdTraceFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of the available I2C messages.
Public property | DataAsHex | Use the hexadecimal format for data bytes?
Public property | I2cAddressesAs8Bit | Use the 8 bit format for I2C addresses?
Public property | I2cAddressesAsHex | Use the hexadecimal format for I2C addresses?
Public property | Item |
Public property | RawDataFormat | Configures the format of the Data string.
Public property | ValueRegisterNames | The registers, which have been involved into a transfer get stored in Registers. Normally the registers are described by their sub address and the involved bits (e.g. "0x20 (0.0)"). If this property is set to "true", the name of the registers (e.g. "0x20 CONFIG (0.0)") gets added.
Top
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.Count Property

IrdTraceFormatterCount Property
Gets the number of the available I2C messages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IReadOnlyListTCount
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.DataAsHex Property

IrdTraceFormatterDataAsHex Property
Use the hexadecimal format for data bytes?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DataAsHex { get; set; }
Public Property DataAsHex As Boolean
    Get
    Set
public:
property bool DataAsHex {
    bool get ();
    void set (bool value);
}
member DataAsHex : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.I2cAddressesAs8Bit Property

IrdTraceFormatterI2cAddressesAs8Bit Property
Use the 8 bit format for I2C addresses?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool I2cAddressesAs8Bit { get; set; }
Public Property I2cAddressesAs8Bit As Boolean
    Get
    Set
public:
property bool I2cAddressesAs8Bit {
    bool get ();
    void set (bool value);
}
member I2cAddressesAs8Bit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.I2cAddressesAsHex Property

IrdTraceFormatterI2cAddressesAsHex Property
Use the hexadecimal format for I2C addresses?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool I2cAddressesAsHex { get; set; }
Public Property I2cAddressesAsHex As Boolean
    Get
    Set
public:
property bool I2cAddressesAsHex {
    bool get ();
    void set (bool value);
}
member I2cAddressesAsHex : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.Item Property

IrdTraceFormatterItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.IrdTraceFormatter.Item(System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual IrdTraceFormatterMessage this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As IrdTraceFormatterMessage
    Get
public:
virtual property IrdTraceFormatterMessage^ default[int index] {
    IrdTraceFormatterMessage^ get (int index);
}
abstract Item : IrdTraceFormatterMessage with get
override Item : IrdTraceFormatterMessage with get

Parameters

index
Type: SystemInt32

Property Value

Type: IrdTraceFormatterMessage

Implements

IReadOnlyListTItemInt32
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.RawDataFormat Property

IrdTraceFormatterRawDataFormat Property
Configures the format of the Data string.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterRawDataFormatStyle RawDataFormat { get; set; }
Public Property RawDataFormat As IrdTraceFormatterRawDataFormatStyle
    Get
    Set
public:
property IrdTraceFormatterRawDataFormatStyle RawDataFormat {
    IrdTraceFormatterRawDataFormatStyle get ();
    void set (IrdTraceFormatterRawDataFormatStyle value);
}
member RawDataFormat : IrdTraceFormatterRawDataFormatStyle with get, set

Property Value

Type: IrdTraceFormatterRawDataFormatStyle
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.ValueRegisterNames Property

IrdTraceFormatterValueRegisterNames Property
The registers, which have been involved into a transfer get stored in Registers. Normally the registers are described by their sub address and the involved bits (e.g. "0x20 (0.0)"). If this property is set to "true", the name of the registers (e.g. "0x20 CONFIG (0.0)") gets added.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ValueRegisterNames { get; set; }
Public Property ValueRegisterNames As Boolean
    Get
    Set
public:
property bool ValueRegisterNames {
    bool get ();
    void set (bool value);
}
member ValueRegisterNames : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdTraceFormatter Class


IrdTraceFormatter.PlugInMessage Class

IrdTraceFormatterPlugInMessage Class
This class stores the strings of one formatted plug-in message. Objects of this class get created by GetPlugInMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterPlugInMessageBase
telos.I2cApi.DotNetIrdTraceFormatterPlugInMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInMessage : IrdTraceFormatterPlugInMessageBase
Public NotInheritable Class PlugInMessage
    Inherits IrdTraceFormatterPlugInMessageBase
public ref class PlugInMessage sealed : public IrdTraceFormatterPlugInMessageBase
[<SealedAttribute>]
type PlugInMessage =
    class
        inherit IrdTraceFormatterPlugInMessageBase
    end

The IrdTraceFormatterPlugInMessage type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterPlugInMessage | Initializes a new instance of the IrdTraceFormatterPlugInMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | Value | value (e.g. "Tuner: On")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.PlugInMessage Constructor

IrdTraceFormatterPlugInMessage Constructor
Initializes a new instance of the IrdTraceFormatterPlugInMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInMessage()
Public Sub New
public:
PlugInMessage()
new : unit -> PlugInMessage
See Also

Reference

IrdTraceFormatterPlugInMessage Class


PlugInMessage Methods

PlugInMessage Methods

The IrdTraceFormatterPlugInMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterPlugInMessage Class


PlugInMessage Properties

PlugInMessage Properties

The IrdTraceFormatterPlugInMessage type exposes the following members.

Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | Value | value (e.g. "Tuner: On")
Top
See Also

Reference

IrdTraceFormatterPlugInMessage Class


IrdTraceFormatter.PlugInMessage.Value Property

IrdTraceFormatterPlugInMessageValue Property
value (e.g. "Tuner: On")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterPlugInMessage Class


IrdTraceFormatter.PlugInMessageBase Class

IrdTraceFormatterPlugInMessageBase Class
This class stores the strings of one formatted plug-in message (base class).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterPlugInMessageBase
telos.I2cApi.DotNetIrdTraceFormatterPlugInMessage
telos.I2cApi.DotNetIrdTraceFormatterPlugInMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PlugInMessageBase
Public MustInherit Class PlugInMessageBase
public ref class PlugInMessageBase abstract
[<AbstractClassAttribute>]
type PlugInMessageBase =  class end

The IrdTraceFormatterPlugInMessageBase type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterPlugInMessageBase | Initializes a new instance of the IrdTraceFormatterPlugInMessageBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Status | status ("OK", "ERR", or "")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.PlugInMessageBase Constructor

IrdTraceFormatterPlugInMessageBase Constructor
Initializes a new instance of the IrdTraceFormatterPlugInMessageBase class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInMessageBase()
Public Sub New
public:
PlugInMessageBase()
new : unit -> PlugInMessageBase
See Also

Reference

IrdTraceFormatterPlugInMessageBase Class


PlugInMessageBase Methods

PlugInMessageBase Methods

The IrdTraceFormatterPlugInMessageBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterPlugInMessageBase Class


PlugInMessageBase Properties

PlugInMessageBase Properties

The IrdTraceFormatterPlugInMessageBase type exposes the following members.

Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Status | status ("OK", "ERR", or "")
Top
See Also

Reference

IrdTraceFormatterPlugInMessageBase Class


IrdTraceFormatter.PlugInMessageBase.I2cAddr Property

IrdTraceFormatterPlugInMessageBaseI2cAddr Property
I2C address (e.g. "0x50")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddr { get; set; }
Public Property I2cAddr As String
    Get
    Set
public:
property String^ I2cAddr {
    String^ get ();
    void set (String^ value);
}
member I2cAddr : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterPlugInMessageBase Class


IrdTraceFormatter.PlugInMessageBase.I2cAddrAlias Property

IrdTraceFormatterPlugInMessageBaseI2cAddrAlias Property
alias name of the IC (e.g. "Tuner")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrAlias { get; set; }
Public Property I2cAddrAlias As String
    Get
    Set
public:
property String^ I2cAddrAlias {
    String^ get ();
    void set (String^ value);
}
member I2cAddrAlias : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterPlugInMessageBase Class


IrdTraceFormatter.PlugInMessageBase.I2cAddrType Property

IrdTraceFormatterPlugInMessageBaseI2cAddrType Property
type of the I2C address ("7", "8", "10", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrType { get; set; }
Public Property I2cAddrType As String
    Get
    Set
public:
property String^ I2cAddrType {
    String^ get ();
    void set (String^ value);
}
member I2cAddrType : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterPlugInMessageBase Class


IrdTraceFormatter.PlugInMessageBase.Status Property

IrdTraceFormatterPlugInMessageBaseStatus Property
status ("OK", "ERR", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterPlugInMessageBase Class


IrdTraceFormatter.PlugInMessageError Class

IrdTraceFormatterPlugInMessageError Class
This class stores the strings of one formatted plug-in message containing errors. Objects of this class get created by GetPlugInMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterPlugInMessageBase
telos.I2cApi.DotNetIrdTraceFormatterPlugInMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInMessageError : IrdTraceFormatterPlugInMessageBase
Public NotInheritable Class PlugInMessageError
    Inherits IrdTraceFormatterPlugInMessageBase
public ref class PlugInMessageError sealed : public IrdTraceFormatterPlugInMessageBase
[<SealedAttribute>]
type PlugInMessageError =
    class
        inherit IrdTraceFormatterPlugInMessageBase
    end

The IrdTraceFormatterPlugInMessageError type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterPlugInMessageError | Initializes a new instance of the IrdTraceFormatterPlugInMessageError class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.PlugInMessageError Constructor

IrdTraceFormatterPlugInMessageError Constructor
Initializes a new instance of the IrdTraceFormatterPlugInMessageError class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInMessageError()
Public Sub New
public:
PlugInMessageError()
new : unit -> PlugInMessageError
See Also

Reference

IrdTraceFormatterPlugInMessageError Class


PlugInMessageError Methods

PlugInMessageError Methods

The IrdTraceFormatterPlugInMessageError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterPlugInMessageError Class


PlugInMessageError Properties

PlugInMessageError Properties

The IrdTraceFormatterPlugInMessageError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterPlugInMessageBase.)
Top
See Also

Reference

IrdTraceFormatterPlugInMessageError Class


IrdTraceFormatter.PlugInMessageError.ErrorDescription Property

IrdTraceFormatterPlugInMessageErrorErrorDescription Property
description of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ErrorDescription { get; set; }
Public Property ErrorDescription As String
    Get
    Set
public:
property String^ ErrorDescription {
    String^ get ();
    void set (String^ value);
}
member ErrorDescription : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterPlugInMessageError Class


IrdTraceFormatter.RawDataFormatStyle Enumeration

IrdTraceFormatterRawDataFormatStyle Enumeration
Specifies the format of the Data string.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum RawDataFormatStyle
Public Enumeration RawDataFormatStyle
public enum class RawDataFormatStyle
type RawDataFormatStyle
Members
Member name | Value | Description
RAW_DATA_FORMAT_ASCII | 0 | ASCII format
RAW_DATA_FORMAT_ESCAPE | 1 | escape format
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.RawSubMessage Class

IrdTraceFormatterRawSubMessage Class
This class stores the strings of one formatted raw sub message. Objects of this class get created by GetRawMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterRawSubMessageBase
telos.I2cApi.DotNetIrdTraceFormatterRawSubMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RawSubMessage : IrdTraceFormatterRawSubMessageBase
Public NotInheritable Class RawSubMessage
    Inherits IrdTraceFormatterRawSubMessageBase
public ref class RawSubMessage sealed : public IrdTraceFormatterRawSubMessageBase
[<SealedAttribute>]
type RawSubMessage =
    class
        inherit IrdTraceFormatterRawSubMessageBase
    end

The IrdTraceFormatterRawSubMessage type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterRawSubMessage | Initializes a new instance of the IrdTraceFormatterRawSubMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Data | data bytes of the transfer
Public property | DataLength | number of data bytes in the transfer
Public property | Direction | direction ("TX", "RX", or "")
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Speed | speed ("LS", "HS")
Public property | StartStop | START/STOP conditions ("SP", "S ", " P", or "")
Public property | Status | status ("OK", "NACK", "ADDR", "ERR", or "") (Inherited from IrdTraceFormatterRawSubMessageBase.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.RawSubMessage Constructor

IrdTraceFormatterRawSubMessage Constructor
Initializes a new instance of the IrdTraceFormatterRawSubMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public RawSubMessage()
Public Sub New
public:
RawSubMessage()
new : unit -> RawSubMessage
See Also

Reference

IrdTraceFormatterRawSubMessage Class


RawSubMessage Methods

RawSubMessage Methods

The IrdTraceFormatterRawSubMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterRawSubMessage Class


RawSubMessage Properties

RawSubMessage Properties

The IrdTraceFormatterRawSubMessage type exposes the following members.

Properties
 | Name | Description
Public property | Data | data bytes of the transfer
Public property | DataLength | number of data bytes in the transfer
Public property | Direction | direction ("TX", "RX", or "")
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Speed | speed ("LS", "HS")
Public property | StartStop | START/STOP conditions ("SP", "S ", " P", or "")
Public property | Status | status ("OK", "NACK", "ADDR", "ERR", or "") (Inherited from IrdTraceFormatterRawSubMessageBase.)
Top
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.Data Property

IrdTraceFormatterRawSubMessageData Property
data bytes of the transfer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Data { get; set; }
Public Property Data As String
    Get
    Set
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}
member Data : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.DataLength Property

IrdTraceFormatterRawSubMessageDataLength Property
number of data bytes in the transfer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string DataLength { get; set; }
Public Property DataLength As String
    Get
    Set
public:
property String^ DataLength {
    String^ get ();
    void set (String^ value);
}
member DataLength : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.Direction Property

IrdTraceFormatterRawSubMessageDirection Property
direction ("TX", "RX", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Direction { get; set; }
Public Property Direction As String
    Get
    Set
public:
property String^ Direction {
    String^ get ();
    void set (String^ value);
}
member Direction : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.I2cAddr Property

IrdTraceFormatterRawSubMessageI2cAddr Property
I2C address (e.g. "0x50")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddr { get; set; }
Public Property I2cAddr As String
    Get
    Set
public:
property String^ I2cAddr {
    String^ get ();
    void set (String^ value);
}
member I2cAddr : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.I2cAddrAlias Property

IrdTraceFormatterRawSubMessageI2cAddrAlias Property
alias name of the IC (e.g. "Tuner")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrAlias { get; set; }
Public Property I2cAddrAlias As String
    Get
    Set
public:
property String^ I2cAddrAlias {
    String^ get ();
    void set (String^ value);
}
member I2cAddrAlias : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.I2cAddrType Property

IrdTraceFormatterRawSubMessageI2cAddrType Property
type of the I2C address ("7", "8", "10", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrType { get; set; }
Public Property I2cAddrType As String
    Get
    Set
public:
property String^ I2cAddrType {
    String^ get ();
    void set (String^ value);
}
member I2cAddrType : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.Speed Property

IrdTraceFormatterRawSubMessageSpeed Property
speed ("LS", "HS")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Speed { get; set; }
Public Property Speed As String
    Get
    Set
public:
property String^ Speed {
    String^ get ();
    void set (String^ value);
}
member Speed : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessage.StartStop Property

IrdTraceFormatterRawSubMessageStartStop Property
START/STOP conditions ("SP", "S ", " P", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string StartStop { get; set; }
Public Property StartStop As String
    Get
    Set
public:
property String^ StartStop {
    String^ get ();
    void set (String^ value);
}
member StartStop : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessage Class


IrdTraceFormatter.RawSubMessageBase Class

IrdTraceFormatterRawSubMessageBase Class
This class stores the strings of one formatted raw sub message (base class).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterRawSubMessageBase
telos.I2cApi.DotNetIrdTraceFormatterRawSubMessage
telos.I2cApi.DotNetIrdTraceFormatterRawSubMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class RawSubMessageBase
Public MustInherit Class RawSubMessageBase
public ref class RawSubMessageBase abstract
[<AbstractClassAttribute>]
type RawSubMessageBase =  class end

The IrdTraceFormatterRawSubMessageBase type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterRawSubMessageBase | Initializes a new instance of the IrdTraceFormatterRawSubMessageBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Status | status ("OK", "NACK", "ADDR", "ERR", or "")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.RawSubMessageBase Constructor

IrdTraceFormatterRawSubMessageBase Constructor
Initializes a new instance of the IrdTraceFormatterRawSubMessageBase class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public RawSubMessageBase()
Public Sub New
public:
RawSubMessageBase()
new : unit -> RawSubMessageBase
See Also

Reference

IrdTraceFormatterRawSubMessageBase Class


RawSubMessageBase Methods

RawSubMessageBase Methods

The IrdTraceFormatterRawSubMessageBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterRawSubMessageBase Class


RawSubMessageBase Properties

RawSubMessageBase Properties

The IrdTraceFormatterRawSubMessageBase type exposes the following members.

Properties
 | Name | Description
Public property | Status | status ("OK", "NACK", "ADDR", "ERR", or "")
Top
See Also

Reference

IrdTraceFormatterRawSubMessageBase Class


IrdTraceFormatter.RawSubMessageBase.Status Property

IrdTraceFormatterRawSubMessageBaseStatus Property
status ("OK", "NACK", "ADDR", "ERR", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessageBase Class


IrdTraceFormatter.RawSubMessageError Class

IrdTraceFormatterRawSubMessageError Class
This class stores the strings of one formatted raw sub message containing errors. Objects of this class get created by GetRawMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterRawSubMessageBase
telos.I2cApi.DotNetIrdTraceFormatterRawSubMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RawSubMessageError : IrdTraceFormatterRawSubMessageBase
Public NotInheritable Class RawSubMessageError
    Inherits IrdTraceFormatterRawSubMessageBase
public ref class RawSubMessageError sealed : public IrdTraceFormatterRawSubMessageBase
[<SealedAttribute>]
type RawSubMessageError =
    class
        inherit IrdTraceFormatterRawSubMessageBase
    end

The IrdTraceFormatterRawSubMessageError type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterRawSubMessageError | Initializes a new instance of the IrdTraceFormatterRawSubMessageError class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | Status | status ("OK", "NACK", "ADDR", "ERR", or "") (Inherited from IrdTraceFormatterRawSubMessageBase.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.RawSubMessageError Constructor

IrdTraceFormatterRawSubMessageError Constructor
Initializes a new instance of the IrdTraceFormatterRawSubMessageError class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public RawSubMessageError()
Public Sub New
public:
RawSubMessageError()
new : unit -> RawSubMessageError
See Also

Reference

IrdTraceFormatterRawSubMessageError Class


RawSubMessageError Methods

RawSubMessageError Methods

The IrdTraceFormatterRawSubMessageError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterRawSubMessageError Class


RawSubMessageError Properties

RawSubMessageError Properties

The IrdTraceFormatterRawSubMessageError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | Status | status ("OK", "NACK", "ADDR", "ERR", or "") (Inherited from IrdTraceFormatterRawSubMessageBase.)
Top
See Also

Reference

IrdTraceFormatterRawSubMessageError Class


IrdTraceFormatter.RawSubMessageError.ErrorDescription Property

IrdTraceFormatterRawSubMessageErrorErrorDescription Property
description of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ErrorDescription { get; set; }
Public Property ErrorDescription As String
    Get
    Set
public:
property String^ ErrorDescription {
    String^ get ();
    void set (String^ value);
}
member ErrorDescription : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRawSubMessageError Class


IrdTraceFormatter.RegisterMessage Class

IrdTraceFormatterRegisterMessage Class
This class stores the strings of one formatted register message. Objects of this class get created by GetRegisterMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterRegisterMessageBase
telos.I2cApi.DotNetIrdTraceFormatterRegisterMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RegisterMessage : IrdTraceFormatterRegisterMessageBase
Public NotInheritable Class RegisterMessage
    Inherits IrdTraceFormatterRegisterMessageBase
public ref class RegisterMessage sealed : public IrdTraceFormatterRegisterMessageBase
[<SealedAttribute>]
type RegisterMessage =
    class
        inherit IrdTraceFormatterRegisterMessageBase
    end

The IrdTraceFormatterRegisterMessage type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterRegisterMessage | Initializes a new instance of the IrdTraceFormatterRegisterMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | direction ("TX", "RX", "TX/RX", or "")
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | PecStatus | SMBus PEC ("OK", "NACK", "ERR", or "")
Public property | RegName | name of the register (e.g. "Luminance")
Public property | RegValue | register value (e.g. "0x30")
Public property | Status | status ("OK", "ERR", or "NACK") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | Value | value stored in the register (e.g. "0x35")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.RegisterMessage Constructor

IrdTraceFormatterRegisterMessage Constructor
Initializes a new instance of the IrdTraceFormatterRegisterMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public RegisterMessage()
Public Sub New
public:
RegisterMessage()
new : unit -> RegisterMessage
See Also

Reference

IrdTraceFormatterRegisterMessage Class


RegisterMessage Methods

RegisterMessage Methods

The IrdTraceFormatterRegisterMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterRegisterMessage Class


RegisterMessage Properties

RegisterMessage Properties

The IrdTraceFormatterRegisterMessage type exposes the following members.

Properties
 | Name | Description
Public property | Direction | direction ("TX", "RX", "TX/RX", or "")
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | PecStatus | SMBus PEC ("OK", "NACK", "ERR", or "")
Public property | RegName | name of the register (e.g. "Luminance")
Public property | RegValue | register value (e.g. "0x30")
Public property | Status | status ("OK", "ERR", or "NACK") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | Value | value stored in the register (e.g. "0x35")
Top
See Also

Reference

IrdTraceFormatterRegisterMessage Class


IrdTraceFormatter.RegisterMessage.Direction Property

IrdTraceFormatterRegisterMessageDirection Property
direction ("TX", "RX", "TX/RX", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Direction { get; set; }
Public Property Direction As String
    Get
    Set
public:
property String^ Direction {
    String^ get ();
    void set (String^ value);
}
member Direction : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessage Class


IrdTraceFormatter.RegisterMessage.PecStatus Property

IrdTraceFormatterRegisterMessagePecStatus Property
SMBus PEC ("OK", "NACK", "ERR", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string PecStatus { get; set; }
Public Property PecStatus As String
    Get
    Set
public:
property String^ PecStatus {
    String^ get ();
    void set (String^ value);
}
member PecStatus : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessage Class


IrdTraceFormatter.RegisterMessage.RegName Property

IrdTraceFormatterRegisterMessageRegName Property
name of the register (e.g. "Luminance")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string RegName { get; set; }
Public Property RegName As String
    Get
    Set
public:
property String^ RegName {
    String^ get ();
    void set (String^ value);
}
member RegName : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessage Class


IrdTraceFormatter.RegisterMessage.RegValue Property

IrdTraceFormatterRegisterMessageRegValue Property
register value (e.g. "0x30")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string RegValue { get; set; }
Public Property RegValue As String
    Get
    Set
public:
property String^ RegValue {
    String^ get ();
    void set (String^ value);
}
member RegValue : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessage Class


IrdTraceFormatter.RegisterMessage.Value Property

IrdTraceFormatterRegisterMessageValue Property
value stored in the register (e.g. "0x35")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessage Class


IrdTraceFormatter.RegisterMessageBase Class

IrdTraceFormatterRegisterMessageBase Class
This class stores the strings of one formatted register message (base class).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterRegisterMessageBase
telos.I2cApi.DotNetIrdTraceFormatterRegisterMessage
telos.I2cApi.DotNetIrdTraceFormatterRegisterMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class RegisterMessageBase
Public MustInherit Class RegisterMessageBase
public ref class RegisterMessageBase abstract
[<AbstractClassAttribute>]
type RegisterMessageBase =  class end

The IrdTraceFormatterRegisterMessageBase type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterRegisterMessageBase | Initializes a new instance of the IrdTraceFormatterRegisterMessageBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Status | status ("OK", "ERR", or "NACK")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.RegisterMessageBase Constructor

IrdTraceFormatterRegisterMessageBase Constructor
Initializes a new instance of the IrdTraceFormatterRegisterMessageBase class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public RegisterMessageBase()
Public Sub New
public:
RegisterMessageBase()
new : unit -> RegisterMessageBase
See Also

Reference

IrdTraceFormatterRegisterMessageBase Class


RegisterMessageBase Methods

RegisterMessageBase Methods

The IrdTraceFormatterRegisterMessageBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterRegisterMessageBase Class


RegisterMessageBase Properties

RegisterMessageBase Properties

The IrdTraceFormatterRegisterMessageBase type exposes the following members.

Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Status | status ("OK", "ERR", or "NACK")
Top
See Also

Reference

IrdTraceFormatterRegisterMessageBase Class


IrdTraceFormatter.RegisterMessageBase.I2cAddr Property

IrdTraceFormatterRegisterMessageBaseI2cAddr Property
I2C address (e.g. "0x50")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddr { get; set; }
Public Property I2cAddr As String
    Get
    Set
public:
property String^ I2cAddr {
    String^ get ();
    void set (String^ value);
}
member I2cAddr : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessageBase Class


IrdTraceFormatter.RegisterMessageBase.I2cAddrAlias Property

IrdTraceFormatterRegisterMessageBaseI2cAddrAlias Property
alias name of the IC (e.g. "Tuner")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrAlias { get; set; }
Public Property I2cAddrAlias As String
    Get
    Set
public:
property String^ I2cAddrAlias {
    String^ get ();
    void set (String^ value);
}
member I2cAddrAlias : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessageBase Class


IrdTraceFormatter.RegisterMessageBase.I2cAddrType Property

IrdTraceFormatterRegisterMessageBaseI2cAddrType Property
type of the I2C address ("7", "8", "10", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrType { get; set; }
Public Property I2cAddrType As String
    Get
    Set
public:
property String^ I2cAddrType {
    String^ get ();
    void set (String^ value);
}
member I2cAddrType : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessageBase Class


IrdTraceFormatter.RegisterMessageBase.Status Property

IrdTraceFormatterRegisterMessageBaseStatus Property
status ("OK", "ERR", or "NACK")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessageBase Class


IrdTraceFormatter.RegisterMessageError Class

IrdTraceFormatterRegisterMessageError Class
This class stores the strings of one formatted register message containing errors. Objects of this class get created by GetRegisterMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterRegisterMessageBase
telos.I2cApi.DotNetIrdTraceFormatterRegisterMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RegisterMessageError : IrdTraceFormatterRegisterMessageBase
Public NotInheritable Class RegisterMessageError
    Inherits IrdTraceFormatterRegisterMessageBase
public ref class RegisterMessageError sealed : public IrdTraceFormatterRegisterMessageBase
[<SealedAttribute>]
type RegisterMessageError =
    class
        inherit IrdTraceFormatterRegisterMessageBase
    end

The IrdTraceFormatterRegisterMessageError type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterRegisterMessageError | Initializes a new instance of the IrdTraceFormatterRegisterMessageError class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | Status | status ("OK", "ERR", or "NACK") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.RegisterMessageError Constructor

IrdTraceFormatterRegisterMessageError Constructor
Initializes a new instance of the IrdTraceFormatterRegisterMessageError class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public RegisterMessageError()
Public Sub New
public:
RegisterMessageError()
new : unit -> RegisterMessageError
See Also

Reference

IrdTraceFormatterRegisterMessageError Class


RegisterMessageError Methods

RegisterMessageError Methods

The IrdTraceFormatterRegisterMessageError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterRegisterMessageError Class


RegisterMessageError Properties

RegisterMessageError Properties

The IrdTraceFormatterRegisterMessageError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Public property | Status | status ("OK", "ERR", or "NACK") (Inherited from IrdTraceFormatterRegisterMessageBase.)
Top
See Also

Reference

IrdTraceFormatterRegisterMessageError Class


IrdTraceFormatter.RegisterMessageError.ErrorDescription Property

IrdTraceFormatterRegisterMessageErrorErrorDescription Property
description of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ErrorDescription { get; set; }
Public Property ErrorDescription As String
    Get
    Set
public:
property String^ ErrorDescription {
    String^ get ();
    void set (String^ value);
}
member ErrorDescription : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterRegisterMessageError Class


IrdTraceFormatter.ValueMessage Class

IrdTraceFormatterValueMessage Class
This class stores the strings of one formatted value message. Objects of this class get created by GetValueMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterValueMessageBase
telos.I2cApi.DotNetIrdTraceFormatterValueMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ValueMessage : IrdTraceFormatterValueMessageBase
Public NotInheritable Class ValueMessage
    Inherits IrdTraceFormatterValueMessageBase
public ref class ValueMessage sealed : public IrdTraceFormatterValueMessageBase
[<SealedAttribute>]
type ValueMessage =
    class
        inherit IrdTraceFormatterValueMessageBase
    end

The IrdTraceFormatterValueMessage type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterValueMessage | Initializes a new instance of the IrdTraceFormatterValueMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Direction | direction ("TX", "RX", or "")
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | Name | name of the value (e.g. "Luminance")
Public property | OutOfRange | out of range ("OK" or "RANGE")
Public property | PecStatus | SMBus PEC ("OK", "ERR", or "")
Public property | Registers | involved registers
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | Value | value (e.g. "20 % (0x33)")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.ValueMessage Constructor

IrdTraceFormatterValueMessage Constructor
Initializes a new instance of the IrdTraceFormatterValueMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueMessage()
Public Sub New
public:
ValueMessage()
new : unit -> ValueMessage
See Also

Reference

IrdTraceFormatterValueMessage Class


ValueMessage Methods

ValueMessage Methods

The IrdTraceFormatterValueMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterValueMessage Class


ValueMessage Properties

ValueMessage Properties

The IrdTraceFormatterValueMessage type exposes the following members.

Properties
 | Name | Description
Public property | Direction | direction ("TX", "RX", or "")
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | Name | name of the value (e.g. "Luminance")
Public property | OutOfRange | out of range ("OK" or "RANGE")
Public property | PecStatus | SMBus PEC ("OK", "ERR", or "")
Public property | Registers | involved registers
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | Value | value (e.g. "20 % (0x33)")
Top
See Also

Reference

IrdTraceFormatterValueMessage Class


IrdTraceFormatter.ValueMessage.Direction Property

IrdTraceFormatterValueMessageDirection Property
direction ("TX", "RX", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Direction { get; set; }
Public Property Direction As String
    Get
    Set
public:
property String^ Direction {
    String^ get ();
    void set (String^ value);
}
member Direction : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessage Class


IrdTraceFormatter.ValueMessage.Name Property

IrdTraceFormatterValueMessageName Property
name of the value (e.g. "Luminance")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessage Class


IrdTraceFormatter.ValueMessage.OutOfRange Property

IrdTraceFormatterValueMessageOutOfRange Property
out of range ("OK" or "RANGE")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string OutOfRange { get; set; }
Public Property OutOfRange As String
    Get
    Set
public:
property String^ OutOfRange {
    String^ get ();
    void set (String^ value);
}
member OutOfRange : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessage Class


IrdTraceFormatter.ValueMessage.PecStatus Property

IrdTraceFormatterValueMessagePecStatus Property
SMBus PEC ("OK", "ERR", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string PecStatus { get; set; }
Public Property PecStatus As String
    Get
    Set
public:
property String^ PecStatus {
    String^ get ();
    void set (String^ value);
}
member PecStatus : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessage Class


IrdTraceFormatter.ValueMessage.Registers Property

IrdTraceFormatterValueMessageRegisters Property
involved registers

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] Registers { get; set; }
Public Property Registers As String()
    Get
    Set
public:
property array<String^>^ Registers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Registers : string[] with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessage Class


IrdTraceFormatter.ValueMessage.Value Property

IrdTraceFormatterValueMessageValue Property
value (e.g. "20 % (0x33)")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessage Class


IrdTraceFormatter.ValueMessageBase Class

IrdTraceFormatterValueMessageBase Class
This class stores the strings of one formatted value message (base class).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterValueMessageBase
telos.I2cApi.DotNetIrdTraceFormatterValueMessage
telos.I2cApi.DotNetIrdTraceFormatterValueMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ValueMessageBase
Public MustInherit Class ValueMessageBase
public ref class ValueMessageBase abstract
[<AbstractClassAttribute>]
type ValueMessageBase =  class end

The IrdTraceFormatterValueMessageBase type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterValueMessageBase | Initializes a new instance of the IrdTraceFormatterValueMessageBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Status | status ("OK", "ERR", or "")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.ValueMessageBase Constructor

IrdTraceFormatterValueMessageBase Constructor
Initializes a new instance of the IrdTraceFormatterValueMessageBase class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueMessageBase()
Public Sub New
public:
ValueMessageBase()
new : unit -> ValueMessageBase
See Also

Reference

IrdTraceFormatterValueMessageBase Class


ValueMessageBase Methods

ValueMessageBase Methods

The IrdTraceFormatterValueMessageBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterValueMessageBase Class


ValueMessageBase Properties

ValueMessageBase Properties

The IrdTraceFormatterValueMessageBase type exposes the following members.

Properties
 | Name | Description
Public property | I2cAddr | I2C address (e.g. "0x50")
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner")
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "")
Public property | Status | status ("OK", "ERR", or "")
Top
See Also

Reference

IrdTraceFormatterValueMessageBase Class


IrdTraceFormatter.ValueMessageBase.I2cAddr Property

IrdTraceFormatterValueMessageBaseI2cAddr Property
I2C address (e.g. "0x50")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddr { get; set; }
Public Property I2cAddr As String
    Get
    Set
public:
property String^ I2cAddr {
    String^ get ();
    void set (String^ value);
}
member I2cAddr : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessageBase Class


IrdTraceFormatter.ValueMessageBase.I2cAddrAlias Property

IrdTraceFormatterValueMessageBaseI2cAddrAlias Property
alias name of the IC (e.g. "Tuner")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrAlias { get; set; }
Public Property I2cAddrAlias As String
    Get
    Set
public:
property String^ I2cAddrAlias {
    String^ get ();
    void set (String^ value);
}
member I2cAddrAlias : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessageBase Class


IrdTraceFormatter.ValueMessageBase.I2cAddrType Property

IrdTraceFormatterValueMessageBaseI2cAddrType Property
type of the I2C address ("7", "8", "10", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string I2cAddrType { get; set; }
Public Property I2cAddrType As String
    Get
    Set
public:
property String^ I2cAddrType {
    String^ get ();
    void set (String^ value);
}
member I2cAddrType : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessageBase Class


IrdTraceFormatter.ValueMessageBase.Status Property

IrdTraceFormatterValueMessageBaseStatus Property
status ("OK", "ERR", or "")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessageBase Class


IrdTraceFormatter.ValueMessageError Class

IrdTraceFormatterValueMessageError Class
This class stores the strings of one formatted value message containing errors. Objects of this class get created by GetValueMsg(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterValueMessageBase
telos.I2cApi.DotNetIrdTraceFormatterValueMessageError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ValueMessageError : IrdTraceFormatterValueMessageBase
Public NotInheritable Class ValueMessageError
    Inherits IrdTraceFormatterValueMessageBase
public ref class ValueMessageError sealed : public IrdTraceFormatterValueMessageBase
[<SealedAttribute>]
type ValueMessageError =
    class
        inherit IrdTraceFormatterValueMessageBase
    end

The IrdTraceFormatterValueMessageError type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterValueMessageError | Initializes a new instance of the IrdTraceFormatterValueMessageError class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatter.ValueMessageError Constructor

IrdTraceFormatterValueMessageError Constructor
Initializes a new instance of the IrdTraceFormatterValueMessageError class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ValueMessageError()
Public Sub New
public:
ValueMessageError()
new : unit -> ValueMessageError
See Also

Reference

IrdTraceFormatterValueMessageError Class


ValueMessageError Methods

ValueMessageError Methods

The IrdTraceFormatterValueMessageError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterValueMessageError Class


ValueMessageError Properties

ValueMessageError Properties

The IrdTraceFormatterValueMessageError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorDescription | description of the error
Public property | I2cAddr | I2C address (e.g. "0x50") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrAlias | alias name of the IC (e.g. "Tuner") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | I2cAddrType | type of the I2C address ("7", "8", "10", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Public property | Status | status ("OK", "ERR", or "") (Inherited from IrdTraceFormatterValueMessageBase.)
Top
See Also

Reference

IrdTraceFormatterValueMessageError Class


IrdTraceFormatter.ValueMessageError.ErrorDescription Property

IrdTraceFormatterValueMessageErrorErrorDescription Property
description of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ErrorDescription { get; set; }
Public Property ErrorDescription As String
    Get
    Set
public:
property String^ ErrorDescription {
    String^ get ();
    void set (String^ value);
}
member ErrorDescription : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterValueMessageError Class


IrdTraceFormatterMessage Class

IrdTraceFormatterMessage Class
This class stores one formatted message.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceFormatterMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceFormatterMessage
Public NotInheritable Class IrdTraceFormatterMessage
public ref class IrdTraceFormatterMessage sealed
[<SealedAttribute>]
type IrdTraceFormatterMessage =  class end

The IrdTraceFormatterMessage type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceFormatterMessage | Initializes a new instance of the IrdTraceFormatterMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | MsgTime | message time
Public property | PluginMsg | formatted plug-in submessages
Public property | RawMsg | formatted raw submessages
Public property | RegisterMsg | formatted register submessages
Public property | ToPrevMsgTime | time to previous message
Public property | ValueMsg | formatted value submessages
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceFormatterMessage Constructor

IrdTraceFormatterMessage Constructor
Initializes a new instance of the IrdTraceFormatterMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterMessage()
Public Sub New
public:
IrdTraceFormatterMessage()
new : unit -> IrdTraceFormatterMessage
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage Methods

IrdTraceFormatterMessage Methods

The IrdTraceFormatterMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage Properties

IrdTraceFormatterMessage Properties

The IrdTraceFormatterMessage type exposes the following members.

Properties
 | Name | Description
Public property | MsgTime | message time
Public property | PluginMsg | formatted plug-in submessages
Public property | RawMsg | formatted raw submessages
Public property | RegisterMsg | formatted register submessages
Public property | ToPrevMsgTime | time to previous message
Public property | ValueMsg | formatted value submessages
Top
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage.MsgTime Property

IrdTraceFormatterMessageMsgTime Property
message time

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string MsgTime { get; set; }
Public Property MsgTime As String
    Get
    Set
public:
property String^ MsgTime {
    String^ get ();
    void set (String^ value);
}
member MsgTime : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage.PluginMsg Property

IrdTraceFormatterMessagePluginMsg Property
formatted plug-in submessages

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterPlugInMessageBase[] PluginMsg { get; set; }
Public Property PluginMsg As IrdTraceFormatterPlugInMessageBase()
    Get
    Set
public:
property array<IrdTraceFormatterPlugInMessageBase^>^ PluginMsg {
    array<IrdTraceFormatterPlugInMessageBase^>^ get ();
    void set (array<IrdTraceFormatterPlugInMessageBase^>^ value);
}
member PluginMsg : IrdTraceFormatterPlugInMessageBase[] with get, set

Property Value

Type: IrdTraceFormatterPlugInMessageBase
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage.RawMsg Property

IrdTraceFormatterMessageRawMsg Property
formatted raw submessages

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterRawSubMessageBase[] RawMsg { get; set; }
Public Property RawMsg As IrdTraceFormatterRawSubMessageBase()
    Get
    Set
public:
property array<IrdTraceFormatterRawSubMessageBase^>^ RawMsg {
    array<IrdTraceFormatterRawSubMessageBase^>^ get ();
    void set (array<IrdTraceFormatterRawSubMessageBase^>^ value);
}
member RawMsg : IrdTraceFormatterRawSubMessageBase[] with get, set

Property Value

Type: IrdTraceFormatterRawSubMessageBase
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage.RegisterMsg Property

IrdTraceFormatterMessageRegisterMsg Property
formatted register submessages

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterRegisterMessageBase[] RegisterMsg { get; set; }
Public Property RegisterMsg As IrdTraceFormatterRegisterMessageBase()
    Get
    Set
public:
property array<IrdTraceFormatterRegisterMessageBase^>^ RegisterMsg {
    array<IrdTraceFormatterRegisterMessageBase^>^ get ();
    void set (array<IrdTraceFormatterRegisterMessageBase^>^ value);
}
member RegisterMsg : IrdTraceFormatterRegisterMessageBase[] with get, set

Property Value

Type: IrdTraceFormatterRegisterMessageBase
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage.ToPrevMsgTime Property

IrdTraceFormatterMessageToPrevMsgTime Property
time to previous message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToPrevMsgTime { get; set; }
Public Property ToPrevMsgTime As String
    Get
    Set
public:
property String^ ToPrevMsgTime {
    String^ get ();
    void set (String^ value);
}
member ToPrevMsgTime : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceFormatterMessage.ValueMsg Property

IrdTraceFormatterMessageValueMsg Property
formatted value submessages

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceFormatterValueMessageBase[] ValueMsg { get; set; }
Public Property ValueMsg As IrdTraceFormatterValueMessageBase()
    Get
    Set
public:
property array<IrdTraceFormatterValueMessageBase^>^ ValueMsg {
    array<IrdTraceFormatterValueMessageBase^>^ get ();
    void set (array<IrdTraceFormatterValueMessageBase^>^ value);
}
member ValueMsg : IrdTraceFormatterValueMessageBase[] with get, set

Property Value

Type: IrdTraceFormatterValueMessageBase
See Also

Reference

IrdTraceFormatterMessage Class


IrdTraceRegisterData Class

IrdTraceRegisterData Class
Stores one access to a register of an I2C slave.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceRegisterDataBase
telos.I2cApi.DotNetIrdTraceRegisterData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceRegisterData : IrdTraceRegisterDataBase
Public NotInheritable Class IrdTraceRegisterData
    Inherits IrdTraceRegisterDataBase
public ref class IrdTraceRegisterData sealed : public IrdTraceRegisterDataBase
[<SealedAttribute>]
type IrdTraceRegisterData =
    class
        inherit IrdTraceRegisterDataBase
    end

The IrdTraceRegisterData type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceRegisterData | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceRegisterDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceRegisterDataBase.)
Public property | Data | data
Public property | Data2nd | data (used for TransferDirection == DIRECTION_TX_RX)
Public property | DataOk | all data bytes with ACK?
Public property | Reg | register
Public property | RegIrd | IRD register description
Public property | SmBusPec | SMBus PEC
Public property | TransferDirection | direction
Top
Remarks
Objects of this class gets created by the IrdTraceRegisterParser class.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceRegisterData Constructor

IrdTraceRegisterData Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterData()
Public Sub New
public:
IrdTraceRegisterData()
new : unit -> IrdTraceRegisterData
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData Methods

IrdTraceRegisterData Methods

The IrdTraceRegisterData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData Properties

IrdTraceRegisterData Properties

The IrdTraceRegisterData type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceRegisterDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceRegisterDataBase.)
Public property | Data | data
Public property | Data2nd | data (used for TransferDirection == DIRECTION_TX_RX)
Public property | DataOk | all data bytes with ACK?
Public property | Reg | register
Public property | RegIrd | IRD register description
Public property | SmBusPec | SMBus PEC
Public property | TransferDirection | direction
Top
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.Data Property

IrdTraceRegisterDataData Property
data

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] Data { get; set; }
Public Property Data As Byte()
    Get
    Set
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Data : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.Data2nd Property

IrdTraceRegisterDataData2nd Property
data (used for TransferDirection == DIRECTION_TX_RX)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] Data2nd { get; set; }
Public Property Data2nd As Byte()
    Get
    Set
public:
property array<unsigned char>^ Data2nd {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Data2nd : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.DataOk Property

IrdTraceRegisterDataDataOk Property
all data bytes with ACK?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DataOk { get; set; }
Public Property DataOk As Boolean
    Get
    Set
public:
property bool DataOk {
    bool get ();
    void set (bool value);
}
member DataOk : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.Reg Property

IrdTraceRegisterDataReg Property
register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Reg { get; set; }
Public Property Reg As UInteger
    Get
    Set
public:
property unsigned int Reg {
    unsigned int get ();
    void set (unsigned int value);
}
member Reg : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.RegIrd Property

IrdTraceRegisterDataRegIrd Property
IRD register description

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdDeviceRegister RegIrd { get; set; }
Public Property RegIrd As IrdDeviceRegister
    Get
    Set
public:
property IrdDeviceRegister^ RegIrd {
    IrdDeviceRegister^ get ();
    void set (IrdDeviceRegister^ value);
}
member RegIrd : IrdDeviceRegister with get, set

Property Value

Type: IrdDeviceRegister
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.SmBusPec Property

IrdTraceRegisterDataSmBusPec Property
SMBus PEC

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterDataPec SmBusPec { get; set; }
Public Property SmBusPec As IrdTraceRegisterDataPec
    Get
    Set
public:
property IrdTraceRegisterDataPec SmBusPec {
    IrdTraceRegisterDataPec get ();
    void set (IrdTraceRegisterDataPec value);
}
member SmBusPec : IrdTraceRegisterDataPec with get, set

Property Value

Type: IrdTraceRegisterDataPec
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.TransferDirection Property

IrdTraceRegisterDataTransferDirection Property
direction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterDataDirection TransferDirection { get; set; }
Public Property TransferDirection As IrdTraceRegisterDataDirection
    Get
    Set
public:
property IrdTraceRegisterDataDirection TransferDirection {
    IrdTraceRegisterDataDirection get ();
    void set (IrdTraceRegisterDataDirection value);
}
member TransferDirection : IrdTraceRegisterDataDirection with get, set

Property Value

Type: IrdTraceRegisterDataDirection
See Also

Reference

IrdTraceRegisterData Class


IrdTraceRegisterData.Direction Enumeration

IrdTraceRegisterDataDirection Enumeration
Enumeration to specify the direction of a transfer.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
type Direction
Members
Member name | Value | Description
DIRECTION_TX | 0 | transmit
DIRECTION_RX | 1 | receive
DIRECTION_TX_RX | 2 | transmit and receive
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceRegisterData.Pec Enumeration

IrdTraceRegisterDataPec Enumeration
Enumeration to specify the result of the SMBus packet error checking (PEC).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Pec
Public Enumeration Pec
public enum class Pec
type Pec
Members
Member name | Value | Description
PEC_NA | 0 | PEC not available
PEC_NACK | 1 | PEC has not been acknowledged
PEC_CHECKSUM_ERROR | 2 | PEC checksum error
PEC_OK | 3 | PEC ok
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceRegisterDataBase Class

IrdTraceRegisterDataBase Class
Base class of IrdTraceRegisterData and IrdTraceRegisterError.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceRegisterDataBase
telos.I2cApi.DotNetIrdTraceRegisterData
telos.I2cApi.DotNetIrdTraceRegisterError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class IrdTraceRegisterDataBase
Public MustInherit Class IrdTraceRegisterDataBase
public ref class IrdTraceRegisterDataBase abstract
[<AbstractClassAttribute>]
type IrdTraceRegisterDataBase =  class end

The IrdTraceRegisterDataBase type exposes the following members.

Constructors
 | Name | Description
Protected method | IrdTraceRegisterDataBase | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceRegisterDataBase Constructor

IrdTraceRegisterDataBase Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected IrdTraceRegisterDataBase(
    I2cAddress i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
Protected Sub New (
    i2c_addr As I2cAddress,
    i2c_addr_complete As ParsedTraceDataI2cAddressComplete
)
protected:
IrdTraceRegisterDataBase(
    I2cAddress^ i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
new :
        i2c_addr : I2cAddress *
        i2c_addr_complete : ParsedTraceDataI2cAddressComplete -> IrdTraceRegisterDataBase

Parameters

i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
i2c_addr_complete
Type: telos.I2cApi.DotNetParsedTraceDataI2cAddressComplete
I2C address complete?
See Also

Reference

IrdTraceRegisterDataBase Class


IrdTraceRegisterDataBase Methods

IrdTraceRegisterDataBase Methods

The IrdTraceRegisterDataBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceRegisterDataBase Class


IrdTraceRegisterDataBase Properties

IrdTraceRegisterDataBase Properties

The IrdTraceRegisterDataBase type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Top
See Also

Reference

IrdTraceRegisterDataBase Class


IrdTraceRegisterDataBase.Address Property

IrdTraceRegisterDataBaseAddress Property
I2C address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

IrdTraceRegisterDataBase Class


IrdTraceRegisterDataBase.AddressComplete Property

IrdTraceRegisterDataBaseAddressComplete Property
I2C address complete?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataI2cAddressComplete AddressComplete { get; set; }
Public Property AddressComplete As ParsedTraceDataI2cAddressComplete
    Get
    Set
public:
property ParsedTraceDataI2cAddressComplete AddressComplete {
    ParsedTraceDataI2cAddressComplete get ();
    void set (ParsedTraceDataI2cAddressComplete value);
}
member AddressComplete : ParsedTraceDataI2cAddressComplete with get, set

Property Value

Type: ParsedTraceDataI2cAddressComplete
See Also

Reference

IrdTraceRegisterDataBase Class


IrdTraceRegisterDataContainer Class

IrdTraceRegisterDataContainer Class
Stores one complete raw I2C message and the corresponding register accesses.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceRegisterDataContainer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceRegisterDataContainer
Public NotInheritable Class IrdTraceRegisterDataContainer
public ref class IrdTraceRegisterDataContainer sealed
[<SealedAttribute>]
type IrdTraceRegisterDataContainer =  class end

The IrdTraceRegisterDataContainer type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceRegisterDataContainer | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CombinedMsgIndex | number of the complete I2C message
Public property | ParsedMsgs | raw I2C message
Public property | ParsedRegisters | register accesses
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
Remarks
It gets created by the IrdTraceRegisterParser class.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceRegisterDataContainer Constructor

IrdTraceRegisterDataContainer Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterDataContainer()
Public Sub New
public:
IrdTraceRegisterDataContainer()
new : unit -> IrdTraceRegisterDataContainer
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterDataContainer Methods

IrdTraceRegisterDataContainer Methods

The IrdTraceRegisterDataContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterDataContainer Properties

IrdTraceRegisterDataContainer Properties

The IrdTraceRegisterDataContainer type exposes the following members.

Properties
 | Name | Description
Public property | CombinedMsgIndex | number of the complete I2C message
Public property | ParsedMsgs | raw I2C message
Public property | ParsedRegisters | register accesses
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterDataContainer.CombinedMsgIndex Property

IrdTraceRegisterDataContainerCombinedMsgIndex Property
number of the complete I2C message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int CombinedMsgIndex { get; set; }
Public Property CombinedMsgIndex As Integer
    Get
    Set
public:
property int CombinedMsgIndex {
    int get ();
    void set (int value);
}
member CombinedMsgIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterDataContainer.ParsedMsgs Property

IrdTraceRegisterDataContainerParsedMsgs Property
raw I2C message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataBase[] ParsedMsgs { get; set; }
Public Property ParsedMsgs As ParsedTraceDataBase()
    Get
    Set
public:
property array<ParsedTraceDataBase^>^ ParsedMsgs {
    array<ParsedTraceDataBase^>^ get ();
    void set (array<ParsedTraceDataBase^>^ value);
}
member ParsedMsgs : ParsedTraceDataBase[] with get, set

Property Value

Type: ParsedTraceDataBase
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterDataContainer.ParsedRegisters Property

IrdTraceRegisterDataContainerParsedRegisters Property
register accesses

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdTraceRegisterDataBase> ParsedRegisters { get; set; }
Public Property ParsedRegisters As List(Of IrdTraceRegisterDataBase)
    Get
    Set
public:
property List<IrdTraceRegisterDataBase^>^ ParsedRegisters {
    List<IrdTraceRegisterDataBase^>^ get ();
    void set (List<IrdTraceRegisterDataBase^>^ value);
}
member ParsedRegisters : List<IrdTraceRegisterDataBase> with get, set

Property Value

Type: List IrdTraceRegisterDataBase
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterDataContainer.StartTimestamp Property

IrdTraceRegisterDataContainerStartTimestamp Property
first timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StartTimestamp { get; set; }
Public Property StartTimestamp As ULong
    Get
    Set
public:
property unsigned long long StartTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StartTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterDataContainer.StopTimestamp Property

IrdTraceRegisterDataContainerStopTimestamp Property
last timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StopTimestamp { get; set; }
Public Property StopTimestamp As ULong
    Get
    Set
public:
property unsigned long long StopTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StopTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

IrdTraceRegisterDataContainer Class


IrdTraceRegisterError Class

IrdTraceRegisterError Class
When the IrdTraceRegisterParser class detects an error during parsing access to registers of I2C slaves, it creates objects of this type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceRegisterDataBase
telos.I2cApi.DotNetIrdTraceRegisterError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceRegisterError : IrdTraceRegisterDataBase
Public NotInheritable Class IrdTraceRegisterError
    Inherits IrdTraceRegisterDataBase
public ref class IrdTraceRegisterError sealed : public IrdTraceRegisterDataBase
[<SealedAttribute>]
type IrdTraceRegisterError =
    class
        inherit IrdTraceRegisterDataBase
    end

The IrdTraceRegisterError type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceRegisterError | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceRegisterDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceRegisterDataBase.)
Public property | ErrorReason | reason of the error
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceRegisterError Constructor

IrdTraceRegisterError Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterError(
    IrdTraceRegisterErrorError error_value,
    I2cAddress i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
Public Sub New (
    error_value As IrdTraceRegisterErrorError,
    i2c_addr As I2cAddress,
    i2c_addr_complete As ParsedTraceDataI2cAddressComplete
)
public:
IrdTraceRegisterError(
    IrdTraceRegisterErrorError error_value,
    I2cAddress^ i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
new :
        error_value : IrdTraceRegisterErrorError *
        i2c_addr : I2cAddress *
        i2c_addr_complete : ParsedTraceDataI2cAddressComplete -> IrdTraceRegisterError

Parameters

error_value
Type: telos.I2cApi.DotNetIrdTraceRegisterErrorError
type of the error
i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
i2c_addr_complete
Type: telos.I2cApi.DotNetParsedTraceDataI2cAddressComplete
I2C address complete?
See Also

Reference

IrdTraceRegisterError Class


IrdTraceRegisterError Methods

IrdTraceRegisterError Methods

The IrdTraceRegisterError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceRegisterError Class


IrdTraceRegisterError Properties

IrdTraceRegisterError Properties

The IrdTraceRegisterError type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceRegisterDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceRegisterDataBase.)
Public property | ErrorReason | reason of the error
Top
See Also

Reference

IrdTraceRegisterError Class


IrdTraceRegisterError.ErrorReason Property

IrdTraceRegisterErrorErrorReason Property
reason of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterErrorError ErrorReason { get; set; }
Public Property ErrorReason As IrdTraceRegisterErrorError
    Get
    Set
public:
property IrdTraceRegisterErrorError ErrorReason {
    IrdTraceRegisterErrorError get ();
    void set (IrdTraceRegisterErrorError value);
}
member ErrorReason : IrdTraceRegisterErrorError with get, set

Property Value

Type: IrdTraceRegisterErrorError
See Also

Reference

IrdTraceRegisterError Class


IrdTraceRegisterError.Error Enumeration

IrdTraceRegisterErrorError Enumeration
Enumeration to specify reason of an error.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Error
Public Enumeration Error
public enum class Error
type Error
Members
Member name | Value | Description
ERROR_I2C_PROTOCOL | 0 | I2C protocol error
ERROR_SMB_POWER_ON | 1 | SMBus power on
ERROR_SMB_POWER_OFF | 2 | SMBus power off
ERROR_TRACER_RESTARTED | 3 | tracer restarted
ERROR_MSG_INCOMPLETE | 4 | message incomplete: START or/and STOP condition missing
ERROR_I2C_ADDRESS | 5 | I2C address has not been acknowledged
ERROR_IRD_DESCRIPTION_NA | 6 | there is no IRD description for this I2C address
ERROR_SUB_ADDR_INCOMPLETE | 7 | subaddress is not complete
ERROR_SUB_ADDR_NACK | 8 | subaddress has not been acknowledged
ERROR_SUB_ADDR_UNKNOWN | 9 | subaddress is unknown
ERROR_SUB_ADDR_INVALID | 10 | subaddress is invalid for this IC
ERROR_DATA_INCOMPLETE | 11 | transfer does not contain all data bytes of the register
ERROR_SMB_INVALID | 12 | nvalid SMB transfer
ERROR_ADDITIONAL_DATA | 13 | additional data bytes available, which have not been parsed
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueData Class

IrdTraceValueData Class
Stores one access to a value of an I2C slave.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceValueDataBase
telos.I2cApi.DotNetIrdTraceValueData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceValueData : IrdTraceValueDataBase
Public NotInheritable Class IrdTraceValueData
    Inherits IrdTraceValueDataBase
public ref class IrdTraceValueData sealed : public IrdTraceValueDataBase
[<SealedAttribute>]
type IrdTraceValueData =
    class
        inherit IrdTraceValueDataBase
    end

The IrdTraceValueData type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceValueData | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceValueDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceValueDataBase.)
Public property | Id | identifier
Public property | Name | name
Public property | Registers | involved registers
Public property | SmBusPec | SMBus PEC
Public property | TransferDirection | direction
Public property | Unit | unit (e.g. "cm")
Public property | ValueComplete | combination of value_raw, value_string, and unit
Public property | ValueOutOfRange | value: out of range?
Public property | ValueRaw | value (e.g. as Int32 object)
Public property | ValueString | description of the value (e.g. "True")
Top
Remarks
Objects of this class gets created by the IrdTraceValueParser class.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueData Constructor

IrdTraceValueData Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueData()
Public Sub New
public:
IrdTraceValueData()
new : unit -> IrdTraceValueData
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData Methods

IrdTraceValueData Methods

The IrdTraceValueData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData Properties

IrdTraceValueData Properties

The IrdTraceValueData type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceValueDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceValueDataBase.)
Public property | Id | identifier
Public property | Name | name
Public property | Registers | involved registers
Public property | SmBusPec | SMBus PEC
Public property | TransferDirection | direction
Public property | Unit | unit (e.g. "cm")
Public property | ValueComplete | combination of value_raw, value_string, and unit
Public property | ValueOutOfRange | value: out of range?
Public property | ValueRaw | value (e.g. as Int32 object)
Public property | ValueString | description of the value (e.g. "True")
Top
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.Id Property

IrdTraceValueDataId Property
identifier

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.Name Property

IrdTraceValueDataName Property
name

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.Registers Property

IrdTraceValueDataRegisters Property
involved registers

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<IrdTraceValueDataRegister> Registers { get; set; }
Public Property Registers As List(Of IrdTraceValueDataRegister)
    Get
    Set
public:
property List<IrdTraceValueDataRegister^>^ Registers {
    List<IrdTraceValueDataRegister^>^ get ();
    void set (List<IrdTraceValueDataRegister^>^ value);
}
member Registers : List<IrdTraceValueDataRegister> with get, set

Property Value

Type: List IrdTraceValueDataRegister
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.SmBusPec Property

IrdTraceValueDataSmBusPec Property
SMBus PEC

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueDataPec SmBusPec { get; set; }
Public Property SmBusPec As IrdTraceValueDataPec
    Get
    Set
public:
property IrdTraceValueDataPec SmBusPec {
    IrdTraceValueDataPec get ();
    void set (IrdTraceValueDataPec value);
}
member SmBusPec : IrdTraceValueDataPec with get, set

Property Value

Type: IrdTraceValueDataPec
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.TransferDirection Property

IrdTraceValueDataTransferDirection Property
direction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueDataDirection TransferDirection { get; set; }
Public Property TransferDirection As IrdTraceValueDataDirection
    Get
    Set
public:
property IrdTraceValueDataDirection TransferDirection {
    IrdTraceValueDataDirection get ();
    void set (IrdTraceValueDataDirection value);
}
member TransferDirection : IrdTraceValueDataDirection with get, set

Property Value

Type: IrdTraceValueDataDirection
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.Unit Property

IrdTraceValueDataUnit Property
unit (e.g. "cm")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Unit { get; set; }
Public Property Unit As String
    Get
    Set
public:
property String^ Unit {
    String^ get ();
    void set (String^ value);
}
member Unit : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.ValueComplete Property

IrdTraceValueDataValueComplete Property
combination of value_raw, value_string, and unit

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ValueComplete { get; set; }
Public Property ValueComplete As String
    Get
    Set
public:
property String^ ValueComplete {
    String^ get ();
    void set (String^ value);
}
member ValueComplete : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.ValueOutOfRange Property

IrdTraceValueDataValueOutOfRange Property
value: out of range?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ValueOutOfRange { get; set; }
Public Property ValueOutOfRange As Boolean
    Get
    Set
public:
property bool ValueOutOfRange {
    bool get ();
    void set (bool value);
}
member ValueOutOfRange : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.ValueRaw Property

IrdTraceValueDataValueRaw Property
value (e.g. as Int32 object)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object ValueRaw { get; set; }
Public Property ValueRaw As Object
    Get
    Set
public:
property Object^ ValueRaw {
    Object^ get ();
    void set (Object^ value);
}
member ValueRaw : Object with get, set

Property Value

Type: Object
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.ValueString Property

IrdTraceValueDataValueString Property
description of the value (e.g. "True")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ValueString { get; set; }
Public Property ValueString As String
    Get
    Set
public:
property String^ ValueString {
    String^ get ();
    void set (String^ value);
}
member ValueString : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueData Class


IrdTraceValueData.Direction Enumeration

IrdTraceValueDataDirection Enumeration
Enumeration to specify the direction of a transfer.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
type Direction
Members
Member name | Value | Description
DIRECTION_TX | 0 | transmit
DIRECTION_RX | 1 | receive
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueData.Pec Enumeration

IrdTraceValueDataPec Enumeration
Enumeration to specify the result of the SMBus packet error checking (PEC).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Pec
Public Enumeration Pec
public enum class Pec
type Pec
Members
Member name | Value | Description
PEC_NA | 0 | PEC not available
PEC_ERROR | 1 | PEC checksum error
PEC_OK | 2 | PEC ok
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueData.Register Class

IrdTraceValueDataRegister Class
Stores information about a used register.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceValueDataRegister

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Register
Public NotInheritable Class Register
public ref class Register sealed
[<SealedAttribute>]
type Register =  class end

The IrdTraceValueDataRegister type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceValueDataRegister | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Bits | bits used from the register
Public property | Name | name of the register
Public property | SubAddress | sub address in hexadecimal format
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueData.Register Constructor

IrdTraceValueDataRegister Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Register()
Public Sub New
public:
Register()
new : unit -> Register
See Also

Reference

IrdTraceValueDataRegister Class


Register Methods

Register Methods

The IrdTraceValueDataRegister type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceValueDataRegister Class


Register Properties

Register Properties

The IrdTraceValueDataRegister type exposes the following members.

Properties
 | Name | Description
Public property | Bits | bits used from the register
Public property | Name | name of the register
Public property | SubAddress | sub address in hexadecimal format
Top
See Also

Reference

IrdTraceValueDataRegister Class


IrdTraceValueData.Register.Bits Property

IrdTraceValueDataRegisterBits Property
bits used from the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Bits { get; set; }
Public Property Bits As String
    Get
    Set
public:
property String^ Bits {
    String^ get ();
    void set (String^ value);
}
member Bits : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueDataRegister Class


IrdTraceValueData.Register.Name Property

IrdTraceValueDataRegisterName Property
name of the register

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueDataRegister Class


IrdTraceValueData.Register.SubAddress Property

IrdTraceValueDataRegisterSubAddress Property
sub address in hexadecimal format

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string SubAddress { get; set; }
Public Property SubAddress As String
    Get
    Set
public:
property String^ SubAddress {
    String^ get ();
    void set (String^ value);
}
member SubAddress : string with get, set

Property Value

Type: String
See Also

Reference

IrdTraceValueDataRegister Class


IrdTraceValueDataBase Class

IrdTraceValueDataBase Class
Base class of IrdTraceValueData and IrdTraceValueError.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceValueDataBase
telos.I2cApi.DotNetIrdTraceValueData
telos.I2cApi.DotNetIrdTraceValueError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class IrdTraceValueDataBase
Public MustInherit Class IrdTraceValueDataBase
public ref class IrdTraceValueDataBase abstract
[<AbstractClassAttribute>]
type IrdTraceValueDataBase =  class end

The IrdTraceValueDataBase type exposes the following members.

Constructors
 | Name | Description
Protected method | IrdTraceValueDataBase | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueDataBase Constructor

IrdTraceValueDataBase Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected IrdTraceValueDataBase(
    I2cAddress i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
Protected Sub New (
    i2c_addr As I2cAddress,
    i2c_addr_complete As ParsedTraceDataI2cAddressComplete
)
protected:
IrdTraceValueDataBase(
    I2cAddress^ i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
new :
        i2c_addr : I2cAddress *
        i2c_addr_complete : ParsedTraceDataI2cAddressComplete -> IrdTraceValueDataBase

Parameters

i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
i2c_addr_complete
Type: telos.I2cApi.DotNetParsedTraceDataI2cAddressComplete
I2C address complete
See Also

Reference

IrdTraceValueDataBase Class


IrdTraceValueDataBase Methods

IrdTraceValueDataBase Methods

The IrdTraceValueDataBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceValueDataBase Class


IrdTraceValueDataBase Properties

IrdTraceValueDataBase Properties

The IrdTraceValueDataBase type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Top
See Also

Reference

IrdTraceValueDataBase Class


IrdTraceValueDataBase.Address Property

IrdTraceValueDataBaseAddress Property
I2C address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

IrdTraceValueDataBase Class


IrdTraceValueDataBase.AddressComplete Property

IrdTraceValueDataBaseAddressComplete Property
I2C address complete?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataI2cAddressComplete AddressComplete { get; set; }
Public Property AddressComplete As ParsedTraceDataI2cAddressComplete
    Get
    Set
public:
property ParsedTraceDataI2cAddressComplete AddressComplete {
    ParsedTraceDataI2cAddressComplete get ();
    void set (ParsedTraceDataI2cAddressComplete value);
}
member AddressComplete : ParsedTraceDataI2cAddressComplete with get, set

Property Value

Type: ParsedTraceDataI2cAddressComplete
See Also

Reference

IrdTraceValueDataBase Class


IrdTraceValueDataContainer Class

IrdTraceValueDataContainer Class
Stores one complete raw I2C message and the corresponding register and value accesses.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceValueDataContainer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceValueDataContainer
Public NotInheritable Class IrdTraceValueDataContainer
public ref class IrdTraceValueDataContainer sealed
[<SealedAttribute>]
type IrdTraceValueDataContainer =  class end

The IrdTraceValueDataContainer type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceValueDataContainer | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CombinedMsgIndex | number of the complete I2C message
Public property | ParsedRawMsgs | raw I2C message
Public property | ParsedRegisters | register accesses
Public property | ParsedValues | value accesses
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
Remarks
It gets created by the IrdTraceValueParser class.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueDataContainer Constructor

IrdTraceValueDataContainer Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueDataContainer()
Public Sub New
public:
IrdTraceValueDataContainer()
new : unit -> IrdTraceValueDataContainer
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer Methods

IrdTraceValueDataContainer Methods

The IrdTraceValueDataContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer Properties

IrdTraceValueDataContainer Properties

The IrdTraceValueDataContainer type exposes the following members.

Properties
 | Name | Description
Public property | CombinedMsgIndex | number of the complete I2C message
Public property | ParsedRawMsgs | raw I2C message
Public property | ParsedRegisters | register accesses
Public property | ParsedValues | value accesses
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer.CombinedMsgIndex Property

IrdTraceValueDataContainerCombinedMsgIndex Property
number of the complete I2C message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int CombinedMsgIndex { get; set; }
Public Property CombinedMsgIndex As Integer
    Get
    Set
public:
property int CombinedMsgIndex {
    int get ();
    void set (int value);
}
member CombinedMsgIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer.ParsedRawMsgs Property

IrdTraceValueDataContainerParsedRawMsgs Property
raw I2C message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataBase[] ParsedRawMsgs { get; set; }
Public Property ParsedRawMsgs As ParsedTraceDataBase()
    Get
    Set
public:
property array<ParsedTraceDataBase^>^ ParsedRawMsgs {
    array<ParsedTraceDataBase^>^ get ();
    void set (array<ParsedTraceDataBase^>^ value);
}
member ParsedRawMsgs : ParsedTraceDataBase[] with get, set

Property Value

Type: ParsedTraceDataBase
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer.ParsedRegisters Property

IrdTraceValueDataContainerParsedRegisters Property
register accesses

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterDataBase[] ParsedRegisters { get; set; }
Public Property ParsedRegisters As IrdTraceRegisterDataBase()
    Get
    Set
public:
property array<IrdTraceRegisterDataBase^>^ ParsedRegisters {
    array<IrdTraceRegisterDataBase^>^ get ();
    void set (array<IrdTraceRegisterDataBase^>^ value);
}
member ParsedRegisters : IrdTraceRegisterDataBase[] with get, set

Property Value

Type: IrdTraceRegisterDataBase
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer.ParsedValues Property

IrdTraceValueDataContainerParsedValues Property
value accesses

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueDataBase[] ParsedValues { get; set; }
Public Property ParsedValues As IrdTraceValueDataBase()
    Get
    Set
public:
property array<IrdTraceValueDataBase^>^ ParsedValues {
    array<IrdTraceValueDataBase^>^ get ();
    void set (array<IrdTraceValueDataBase^>^ value);
}
member ParsedValues : IrdTraceValueDataBase[] with get, set

Property Value

Type: IrdTraceValueDataBase
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer.StartTimestamp Property

IrdTraceValueDataContainerStartTimestamp Property
first timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StartTimestamp { get; set; }
Public Property StartTimestamp As ULong
    Get
    Set
public:
property unsigned long long StartTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StartTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueDataContainer.StopTimestamp Property

IrdTraceValueDataContainerStopTimestamp Property
last timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StopTimestamp { get; set; }
Public Property StopTimestamp As ULong
    Get
    Set
public:
property unsigned long long StopTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StopTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

IrdTraceValueDataContainer Class


IrdTraceValueError Class

IrdTraceValueError Class
When the IrdTraceValueParser class detects an error during parsing access to values of I2C slaves, it creates objects of this type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceValueDataBase
telos.I2cApi.DotNetIrdTraceValueError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceValueError : IrdTraceValueDataBase
Public NotInheritable Class IrdTraceValueError
    Inherits IrdTraceValueDataBase
public ref class IrdTraceValueError sealed : public IrdTraceValueDataBase
[<SealedAttribute>]
type IrdTraceValueError =
    class
        inherit IrdTraceValueDataBase
    end

The IrdTraceValueError type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceValueError(IrdTraceRegisterErrorError, I2cAddress, ParsedTraceDataI2cAddressComplete) | Constructor
Public method | IrdTraceValueError(IrdTraceValueErrorError, I2cAddress, ParsedTraceDataI2cAddressComplete) | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceValueDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceValueDataBase.)
Public property | ErrorRegister | reason of the error
Public property | ErrorType | type of the error
Public property | ErrorValue | reason of the error
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueError Constructor

IrdTraceValueError Constructor
Overload List
 | Name | Description
Public method | IrdTraceValueError(IrdTraceRegisterErrorError, I2cAddress, ParsedTraceDataI2cAddressComplete) | Constructor
Public method | IrdTraceValueError(IrdTraceValueErrorError, I2cAddress, ParsedTraceDataI2cAddressComplete) | Constructor
Top
See Also

Reference

IrdTraceValueError Class


IrdTraceValueError Constructor (IrdTraceRegisterError.Error, I2cAddress, ParsedTraceData.I2cAddressComplete)

IrdTraceValueError Constructor (IrdTraceRegisterErrorError, I2cAddress, ParsedTraceDataI2cAddressComplete)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueError(
    IrdTraceRegisterErrorError error,
    I2cAddress i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
Public Sub New (
    error As IrdTraceRegisterErrorError,
    i2c_addr As I2cAddress,
    i2c_addr_complete As ParsedTraceDataI2cAddressComplete
)
public:
IrdTraceValueError(
    IrdTraceRegisterErrorError error,
    I2cAddress^ i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
new :
        error : IrdTraceRegisterErrorError *
        i2c_addr : I2cAddress *
        i2c_addr_complete : ParsedTraceDataI2cAddressComplete -> IrdTraceValueError

Parameters

error
Type: telos.I2cApi.DotNetIrdTraceRegisterErrorError
type of the error
i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
i2c_addr_complete
Type: telos.I2cApi.DotNetParsedTraceDataI2cAddressComplete
I2C address complete
See Also

Reference

IrdTraceValueError Class
IrdTraceValueError Overload


IrdTraceValueError Constructor (IrdTraceValueError.Error, I2cAddress, ParsedTraceData.I2cAddressComplete)

IrdTraceValueError Constructor (IrdTraceValueErrorError, I2cAddress, ParsedTraceDataI2cAddressComplete)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueError(
    IrdTraceValueErrorError error,
    I2cAddress i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
Public Sub New (
    error As IrdTraceValueErrorError,
    i2c_addr As I2cAddress,
    i2c_addr_complete As ParsedTraceDataI2cAddressComplete
)
public:
IrdTraceValueError(
    IrdTraceValueErrorError error,
    I2cAddress^ i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
new :
        error : IrdTraceValueErrorError *
        i2c_addr : I2cAddress *
        i2c_addr_complete : ParsedTraceDataI2cAddressComplete -> IrdTraceValueError

Parameters

error
Type: telos.I2cApi.DotNetIrdTraceValueErrorError
type of the error
i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
i2c_addr_complete
Type: telos.I2cApi.DotNetParsedTraceDataI2cAddressComplete
I2C address complete
See Also

Reference

IrdTraceValueError Class
IrdTraceValueError Overload


IrdTraceValueError Methods

IrdTraceValueError Methods

The IrdTraceValueError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceValueError Class


IrdTraceValueError Properties

IrdTraceValueError Properties

The IrdTraceValueError type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address (Inherited from IrdTraceValueDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from IrdTraceValueDataBase.)
Public property | ErrorRegister | reason of the error
Public property | ErrorType | type of the error
Public property | ErrorValue | reason of the error
Top
See Also

Reference

IrdTraceValueError Class


IrdTraceValueError.ErrorRegister Property

IrdTraceValueErrorErrorRegister Property
reason of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceRegisterErrorError ErrorRegister { get; set; }
Public Property ErrorRegister As IrdTraceRegisterErrorError
    Get
    Set
public:
property IrdTraceRegisterErrorError ErrorRegister {
    IrdTraceRegisterErrorError get ();
    void set (IrdTraceRegisterErrorError value);
}
member ErrorRegister : IrdTraceRegisterErrorError with get, set

Property Value

Type: IrdTraceRegisterErrorError
See Also

Reference

IrdTraceValueError Class


IrdTraceValueError.ErrorType Property

IrdTraceValueErrorErrorType Property
type of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueErrorType ErrorType { get; set; }
Public Property ErrorType As IrdTraceValueErrorType
    Get
    Set
public:
property IrdTraceValueErrorType ErrorType {
    IrdTraceValueErrorType get ();
    void set (IrdTraceValueErrorType value);
}
member ErrorType : IrdTraceValueErrorType with get, set

Property Value

Type: IrdTraceValueErrorType
See Also

Reference

IrdTraceValueError Class


IrdTraceValueError.ErrorValue Property

IrdTraceValueErrorErrorValue Property
reason of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueErrorError ErrorValue { get; set; }
Public Property ErrorValue As IrdTraceValueErrorError
    Get
    Set
public:
property IrdTraceValueErrorError ErrorValue {
    IrdTraceValueErrorError get ();
    void set (IrdTraceValueErrorError value);
}
member ErrorValue : IrdTraceValueErrorError with get, set

Property Value

Type: IrdTraceValueErrorError
See Also

Reference

IrdTraceValueError Class


IrdTraceValueError.Error Enumeration

IrdTraceValueErrorError Enumeration
Enumeration to specify reason of an error.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Error
Public Enumeration Error
public enum class Error
type Error
Members
Member name | Value | Description
ERROR_VALUE_INCOMPLETE | 0 | value incomplete
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueError.Type Enumeration

IrdTraceValueErrorType Enumeration
Enumeration to specify which parses has detected an error.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Type
Public Enumeration Type
public enum class Type
type Type
Members
Member name | Value | Description
TYPE_REGISTER | 0 | error on register level (see ErrorRegister)
TYPE_VALUE | 1 | error on value level (see ErrorValue)
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueList Class

IrdTraceValueList Class
This class parses the elements of a ParsedTracerMessageList and returns the parsed I2C messages to the caller. The IrdTraceValueDataContainer objects created by this parser contains the messages in three formats: ParsedTraceDataBase, IrdTraceRegisterDataBase, and IrdTraceValueDataBase.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdTraceValueList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdTraceValueList : IDisposable
Public NotInheritable Class IrdTraceValueList
    Implements IDisposable
public ref class IrdTraceValueList sealed : IDisposable
[<SealedAttribute>]
type IrdTraceValueList =
    class
        interface IDisposable
    end

The IrdTraceValueList type exposes the following members.

Constructors
 | Name | Description
Public method | IrdTraceValueList | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHardwareInfo | Returns the used HardwareInfo instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, the method returns the item whose timestamp is smaller than the searched timestamp.
Public method | GetIrdMap | Returns the used IrdMap instance.
Public method | GetItem | Returns one complete parsed I2C message.
Public method | GetParsedTracerMessageList | Returns the ParsedTracerMessageList.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MutexEnter | Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexExit | Unlocks the ParsedTracerMessageList to be parsed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CompleteValuesUsingPreviousMessages | Sets/gets whether parsing of previous I2C messages is enabled.
Public property | Count | Gets the number of the available I2C messages.
Top
Remarks

To improve the speed of the parser the class contains a cache, which stores a number of parsed messages.

Before using the methods and properties of this class, it is necessary to call the MutexEnter or [!:MutexEnter(System::TimeSpan)] method. This locks the instance of this class and the instance of the ParsedTracerMessageList. At the end it is necessary to release this mutex calling MutexExit.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdTraceValueList Constructor

IrdTraceValueList Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueList(
    ParsedTracerMessageList msgs,
    IrdMap ird_map,
    HardwareInfo hwinfo,
    int cache_size
)
Public Sub New (
    msgs As ParsedTracerMessageList,
    ird_map As IrdMap,
    hwinfo As HardwareInfo,
    cache_size As Integer
)
public:
IrdTraceValueList(
    ParsedTracerMessageList^ msgs,
    IrdMap^ ird_map,
    HardwareInfo^ hwinfo,
    int cache_size
)
new :
        msgs : ParsedTracerMessageList *
        ird_map : IrdMap *
        hwinfo : HardwareInfo *
        cache_size : int -> IrdTraceValueList

Parameters

msgs
Type: telos.I2cApi.DotNetParsedTracerMessageList
I2C messages to be parsed
ird_map
Type: telos.I2cApi.DotNetIrdMap
I2C address to IRD map
hwinfo
Type: telos.I2cApi.DotNetHardwareInfo
HardwareInfo of the I2C interface, which has been used to trace the I2C messages
cache_size
Type: SystemInt32
number of parsed messages to be kept in the internal cache
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList Methods

IrdTraceValueList Methods

The IrdTraceValueList type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHardwareInfo | Returns the used HardwareInfo instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, the method returns the item whose timestamp is smaller than the searched timestamp.
Public method | GetIrdMap | Returns the used IrdMap instance.
Public method | GetItem | Returns one complete parsed I2C message.
Public method | GetParsedTracerMessageList | Returns the ParsedTracerMessageList.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MutexEnter | Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexExit | Unlocks the ParsedTracerMessageList to be parsed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.Dispose Method

IrdTraceValueListDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.Dispose Method

IrdTraceValueListDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

IrdTraceValueList Class
Dispose Overload


IrdTraceValueList.Dispose Method (Boolean)

IrdTraceValueListDispose Method (Boolean)
Releases the unmanaged resources used by the IrdTraceValueList and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.IrdTraceValueList.Dispose(System.Boolean)"]

See Also

Reference

IrdTraceValueList Class
Dispose Overload


IrdTraceValueList.GetHardwareInfo Method

IrdTraceValueListGetHardwareInfo Method
Returns the used HardwareInfo instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public HardwareInfo GetHardwareInfo()
Public Function GetHardwareInfo As HardwareInfo
public:
HardwareInfo^ GetHardwareInfo()
member GetHardwareInfo : unit -> HardwareInfo

Return Value

Type: HardwareInfo
used HardwareInfo
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.GetIndexByTimestamp Method

IrdTraceValueListGetIndexByTimestamp Method
Returns the index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, the method returns the item whose timestamp is smaller than the searched timestamp.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetIndexByTimestamp(
    ulong ts
)
Public Function GetIndexByTimestamp (
    ts As ULong
) As Integer
public:
int GetIndexByTimestamp(
    unsigned long long ts
)
member GetIndexByTimestamp :
        ts : uint64 -> int

Parameters

ts
Type: SystemUInt64
searched timestamp

Return Value

Type: Int32
index of the I2C message
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.GetIrdMap Method

IrdTraceValueListGetIrdMap Method
Returns the used IrdMap instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdMap GetIrdMap()
Public Function GetIrdMap As IrdMap
public:
IrdMap^ GetIrdMap()
member GetIrdMap : unit -> IrdMap

Return Value

Type: IrdMap
used IrdMap
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.GetItem Method

IrdTraceValueListGetItem Method
Returns one complete parsed I2C message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueDataContainer GetItem(
    int combined_msg_index
)
Public Function GetItem (
    combined_msg_index As Integer
) As IrdTraceValueDataContainer
public:
IrdTraceValueDataContainer^ GetItem(
    int combined_msg_index
)
member GetItem :
        combined_msg_index : int -> IrdTraceValueDataContainer

Parameters

combined_msg_index
Type: SystemInt32
index of the message

Return Value

Type: IrdTraceValueDataContainer
parsed I2C message
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.GetParsedTracerMessageList Method

IrdTraceValueListGetParsedTracerMessageList Method
Returns the ParsedTracerMessageList.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTracerMessageList GetParsedTracerMessageList()
Public Function GetParsedTracerMessageList As ParsedTracerMessageList
public:
ParsedTracerMessageList^ GetParsedTracerMessageList()
member GetParsedTracerMessageList : unit -> ParsedTracerMessageList

Return Value

Type: ParsedTracerMessageList
list of parsed tracer messages
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.MutexEnter Method

IrdTraceValueListMutexEnter Method
Overload List
 | Name | Description
Public method | MutexEnter | Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Top
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.MutexEnter Method

IrdTraceValueListMutexEnter Method
Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void MutexEnter()
Public Sub MutexEnter
public:
void MutexEnter()
member MutexEnter : unit -> unit
See Also

Reference

IrdTraceValueList Class
MutexEnter Overload


IrdTraceValueList.MutexEnter Method (TimeSpan)

IrdTraceValueListMutexEnter Method (TimeSpan)
Locks the ParsedTracerMessageList to be parsed. A thread is allowed to call MutexEnter(TimeSpan) recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool MutexEnter(
    TimeSpan timeout
)
Public Function MutexEnter (
    timeout As TimeSpan
) As Boolean
public:
bool MutexEnter(
    TimeSpan timeout
)
member MutexEnter :
        timeout : TimeSpan -> bool

Parameters

timeout
Type: SystemTimeSpan
timeout

Return Value

Type: Boolean
lock acquired (true), not acquired (false)
See Also

Reference

IrdTraceValueList Class
MutexEnter Overload


IrdTraceValueList.MutexExit Method

IrdTraceValueListMutexExit Method
Unlocks the ParsedTracerMessageList to be parsed.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void MutexExit()
Public Sub MutexExit
public:
void MutexExit()
member MutexExit : unit -> unit
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList Properties

IrdTraceValueList Properties

The IrdTraceValueList type exposes the following members.

Properties
 | Name | Description
Public property | CompleteValuesUsingPreviousMessages | Sets/gets whether parsing of previous I2C messages is enabled.
Public property | Count | Gets the number of the available I2C messages.
Top
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.CompleteValuesUsingPreviousMessages Property

IrdTraceValueListCompleteValuesUsingPreviousMessages Property
Sets/gets whether parsing of previous I2C messages is enabled.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool CompleteValuesUsingPreviousMessages { get; set; }
Public Property CompleteValuesUsingPreviousMessages As Boolean
    Get
    Set
public:
property bool CompleteValuesUsingPreviousMessages {
    bool get ();
    void set (bool value);
}
member CompleteValuesUsingPreviousMessages : bool with get, set

Property Value

Type: Boolean
Remarks
If an I2C message does not contain all necessary registers to parse the values of the message, it is possible to get the content of these registers from previous I2C messages.
See Also

Reference

IrdTraceValueList Class


IrdTraceValueList.Count Property

IrdTraceValueListCount Property
Gets the number of the available I2C messages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

IrdTraceValueList Class


IrdWriter Class

IrdWriter Class
Writes an IrdDevice object to an IRD (I2C Register Description) file.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetIrdWriter

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class IrdWriter
Public NotInheritable Class IrdWriter
public ref class IrdWriter sealed
[<SealedAttribute>]
type IrdWriter =  class end

The IrdWriter type exposes the following members.

Constructors
 | Name | Description
Public method | IrdWriter | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Stores the given device description object as IRD file.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IrdWriter Constructor

IrdWriter Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdWriter()
Public Sub New
public:
IrdWriter()
new : unit -> IrdWriter
See Also

Reference

IrdWriter Class


IrdWriter Methods

IrdWriter Methods

The IrdWriter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Stores the given device description object as IRD file.
Top
See Also

Reference

IrdWriter Class


IrdWriter.Write Method

IrdWriterWrite Method
Stores the given device description object as IRD file.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string filename,
    byte[] crypt_key,
    IrdDevice device
)
Public Sub Write (
    filename As String,
    crypt_key As Byte(),
    device As IrdDevice
)
public:
void Write(
    String^ filename,
    array<unsigned char>^ crypt_key,
    IrdDevice^ device
)
member Write :
        filename : string *
        crypt_key : byte[] *
        device : IrdDevice -> unit

Parameters

filename
Type: SystemString
filename of the IRD file to be created
crypt_key
Type: SystemByte
encryption key (24 bytes)
device
Type: telos.I2cApi.DotNetIrdDevice
device description to be written
Remarks
It is possible to create standard text IRD files or encrypted IRD files. If no encryption key gets specified (crypt_key = 0), this method creates a standard text IRD file.
See Also

Reference

IrdWriter Class


IReadOnlyList(T) Interface

IReadOnlyListT Interface
This interface represents a read-only list, which can be accessed using an index or an enumerator.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IReadOnlyList<T> : IEnumerable<T>

Public Interface IReadOnlyList(Of T)
    Inherits IEnumerable(Of T)
generic<typename T>
public interface class IReadOnlyList : IEnumerable<T>
type IReadOnlyList<'T> =
    interface
        interface IEnumerable<'T>
    end

Type Parameters

T
type of the items, which are stored in the container

The IReadOnlyListT type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements stored in the list.
Public property | Item |
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


IReadOnlyList(T) Methods

IReadOnlyListT Methods

The IReadOnlyListT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T .)
Top
See Also

Reference

IReadOnlyListT Interface


IReadOnlyList(T) Properties

IReadOnlyListT Properties

The IReadOnlyListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements stored in the list.
Public property | Item |
Top
See Also

Reference

IReadOnlyListT Interface


IReadOnlyList(T).Count Property

IReadOnlyListTCount Property
Gets the number of elements stored in the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IReadOnlyListT Interface


IReadOnlyList(T).Item Property

IReadOnlyListTItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.IReadOnlyList`1.Item(System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
T this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As T
    Get
property T default[int index] {
    T get (int index);
}
abstract Item : 'T with get

Parameters

index
Type: SystemInt32

Property Value

Type: T
See Also

Reference

IReadOnlyListT Interface


Master Class

Master Class
This class is used for master transmitter/receiver transfers on the I2C bus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Master : IDisposable
Public NotInheritable Class Master
    Implements IDisposable
public ref class Master sealed : IDisposable
[<SealedAttribute>]
type Master =
    class
        interface IDisposable
    end

The Master type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScanAddresses(I2cAddressRange, Int32) | Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.
Public method | ScanAddresses(I2cAddress, I2cAddress, Int32) | Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData(MasterMessage) | Sends the given master transmitter or master receiver message to the I2C bus.
Public method | TransferData(MasterMessageList) | Sends the given list of master transmitter and master receiver messages as one message to the I2C bus. If the list contains more than one object, the I2C combined mode (repeated start) is used.
Top
Properties
 | Name | Description
Public property | Bitrate | Sets/gets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the I2C clock.
Public property | BitrateHs | Sets/gets the I2C high speed bitrate (SCL) [Hz]. If this value is not zero, the I2C interface will use the high speed mode to transfer the data to the slave. The high speed initialisation token on the I2C bus is sent using the bitrate specified with the Bitrate property.
Public property | HsMasterCode | Sets/gets the I2C high speed master code.
Public property | Watchdog | Enables/disables the watchdog of the master module.
Top
Events
 | Name | Description
Public event | TransferDataStatus | This event, which gets fired periodically, reports the status of the currently running master transfer.
Top
Remarks

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the Master property.

Normally the following steps are necessary to use the master module of an I2C interface:

  1. Configure the master module (I2C bitrates).
  2. Create a data object:
    • Master transmitter transfer: create a MasterMessageTx object.
    • Master receiver transfer: create a MasterMessageRx object.
    • Combined mode transfer: create a MasterMessageList object containing MasterMessageTx and/or MasterMessageRx objects.
  3. Pass the created object to the I2C.NET API using TransferData(MasterMessageList).
  4. Evaluate the result of the transfer stored in the objects passed to TransferData(MasterMessageList).
Examples
The following example demonstrates how to use this class in C#:
Copy
using telos.I2cApi.DotNet;
using System;
using System.Collections.Generic;

namespace MyNamespace
{
    class MyClass
    {
    /***********************************************************************/
    /// <summary>
    /// This function demonstrates how to sent data as master transmitter
    /// to an I2C device. In this example 256 bytes of data are sent to a
    /// device with the slave address 0x50 (7 bit).
    /// </summary>
    /***********************************************************************/

    static void MasterTransmitter (Master master)
    {
      // Create an List<byte> containing the data to be sent to
      // the slave (0..255).
      List<byte>  data = new List<byte>();

      for (int i=0; i < 256; i++)
        data.Add ((byte) i);

      // Create an I2cAddress containing the address of the I2C slave
      // (7 bit address: 0x50).
      I2cAddress  address = new I2cAddress (0x50, false);

      // Create a master transmitter object.
      MasterMessageTx  tx_msg = new MasterMessageTx (address, data);

      // Set the master bitrate to 100 kHz.
      master.Bitrate = 100000;

      // Transfer the data to the I2C slave.
      master.TransferData (tx_msg);

      // Display the number of bytes transferred to the slave.
      Console.WriteLine (string.Format("Transmitted {0} bytes successfully as master transmitter.",
                                       tx_msg.BytesTransferred));
    }

    /***********************************************************************/
    /// <summary>
    /// This function demonstrates how to read data as master receiver
    /// from an I2C device. In this example 256 bytes of data are read
    /// from a device with the slave address 0x50 (7 bit).
    /// </summary>
    /***********************************************************************/

    static void MasterReceiver (Master master)
    {
      // Create an I2cAddress containing the address of the I2C slave
      // (7 bit address: 0x50).
      I2cAddress  address = new I2cAddress (0x50, false);

      // Create a master receiver object (number of bytes to be
      // read is 256).
      MasterMessageRx  rx_msg = new MasterMessageRx (address, 256);

      // Set the master bitrate to 400 kHz.
      master.Bitrate = 400000;

      // Transfer the data to the I2C slave.
      master.TransferData (rx_msg);

      // Display the number of bytes received from the slave.
      Console.WriteLine (string.Format ("Received {0} bytes successfully as master receiver.",
                                        rx_msg.BytesTransferred));

      // Display the data received from the slave.
      foreach (byte data_byte in rx_msg.Data)
       Console.Write (string.Format("{0:x2} ", data_byte));
      Console.WriteLine();
    }

    /***********************************************************************/
    /// <summary>
    /// <para>
    /// This function demonstrates the so-called I2C combined mode, which
    /// consists of a combination of several master transmitter and
    /// master receiver transfers. In this example the combined mode
    /// transfer consists of one master transmitter transfer and one
    /// master receiver transfer. On the I2C bus the transfer looks like
    /// that:
    /// </para><para>
    /// START, ADDR/W, DATA, START, ADDR/R, 10 * DATA, STOP
    /// </para>
    /// </summary>
    /***********************************************************************/

    static void MasterCombined (Master master)
    {
      // Create an array containing the data to be sent the the slave (0x00).
      byte[]  data = new byte[] { 0x00 };

      // Create an I2cAddress containing the address of the I2C slave
      // (7 bit address: 0x50).
      I2cAddress  address = new I2cAddress (0x50, false);

      // Create MasterMessageList object, which is used to store the
      // MasterMessageTx and MasterMessageRx objects of one combined
      // mode transfer.
      MasterMessageList  msgs = new MasterMessageList();

      // Create a master transmitter object.
      msgs.Add (new MasterMessageTx (address, data));

      // Create a master receiver object (number of bytes to be
      // read is 10).
      msgs.Add (new MasterMessageRx (address, 10));

      // Set the master bitrate to 400 kHz.
      master.Bitrate = 400000;

      // Transfer the data to the I2C slave.
      master.TransferData (msgs);

      // Display the number of bytes transferred to/from the slave.
      Console.WriteLine (string.Format("Transmitted {0} bytes successfully as master transmitter.",
                                       ((MasterMessageTx) msgs[0]).BytesTransferred));
      Console.WriteLine (string.Format("Received {0} bytes successfully as master receiver.",
                                       ((MasterMessageRx) msgs[1]).BytesTransferred));
    }

    /***********************************************************************/
    /// <summary>
    /// <para>
    /// This function demonstrates the master functionality for the
    /// System Management Bus (SMBus). The following messages are sent
    /// to the SMBus: "Read Byte", "Write Word", and "Block Read".
    /// </para><para>
    /// The optional "Packet Error Checking" (PEC) can be enabled by a
    /// parameter.
    /// </para>
    /// </summary>
    /***********************************************************************/

    static void MasterSmb (Board board, bool with_pec)
    {
      SmbMasterMessageReadByte   read_byte;
      SmbMasterMessageWriteWord  write_word;
      SmbMasterMessageBlockRead  block_read;
      SmbMaster                  smb_master;
      I2cAddress                 address;

      // Create an I2cAddress containing the address of the SMBus slave
      // (7 bit address: 0x50).
      address = new I2cAddress (0x50, false);

      // Create SMBus master.
      smb_master = new SmbMaster (board);

      // Set the master bitrate to 100 kHz.
      board.Master.Bitrate = 100000;

      // Create "Read Byte" message.
      read_byte = new SmbMasterMessageReadByte();
      read_byte.Address = address;
      read_byte.Command = 0x00;
      read_byte.WithPec = with_pec;

      // Transfer message to the SMBus slave.
      smb_master.TransferData (read_byte);

      // Display result of the message.
      Console.WriteLine (string.Format ("\"Read Byte\" (command: 0x{0:X2}) result: 0x{1:X2}",
                                        read_byte.Command,
                                        read_byte.Data));

      // Create "Write Word" message.
      write_word = new SmbMasterMessageWriteWord();
      write_word.Address = address;
      write_word.Command = 0x01;
      write_word.Data = 0x1234;
      write_word.WithPec = with_pec;

      // Transfer message to the SMBus slave.
      smb_master.TransferData (write_word);

      // Display result of the message.
      Console.WriteLine (string.Format ("\"Write Word\" (command: 0x{0:X2}) written: 0x{1:X4}",
                                        write_word.Command,
                                        write_word.Data));

      // Create "Block Read" message.
      block_read = new SmbMasterMessageBlockRead();
      block_read.Address = address;
      block_read.Command = 0x02;
      block_read.WithPec = with_pec;

      // Transfer message to the SMBus slave.
      smb_master.TransferData (block_read);

      // Display result of the message.
      Console.Write (string.Format ("\"Block Read\" (command: 0x{0:X2}) result:",
                                    block_read.Command));
      foreach (byte data_byte in block_read.Data)
        Console.Write (string.Format (" 0x{0:X2}",data_byte));
      Console.WriteLine();
    }

    /***********************************************************************/
    /// <summary>
    /// <para>
    /// This function demonstrates the master functionality for the
    /// Power Management Bus (PMBus). The following messages are sent to
    /// the PMBus: "Read Byte", "Write Word", and "Group Command".
    /// </para><para>
    /// The optional "Packet Error Checking" (PEC) can be enabled by a
    /// parameter.
    /// </para>
    /// </summary>
    /***********************************************************************/

    static void MasterPmbus (Board board, bool with_pec)
    {
      PmbusMasterMessageReadByte   read_byte;
      PmbusMasterMessageWriteWord  write_word;
      PmbusMasterMessageGroupCmd   group_cmd;
      PmbusMasterMessageCmd        cmd;
      SmbMaster                    smb_master;
      I2cAddress                   address;

      // Create an I2cAddress containing the address of the SMBus slave
      // (7 bit address: 0x50).
      address = new I2cAddress (0x50, false);

      // Create SMBus master.
      smb_master = new SmbMaster (board);

      // Set the master bitrate to 100 kHz.
      board.Master.Bitrate = 100000;

      // Create "Read Byte" message.
      read_byte = new PmbusMasterMessageReadByte();
      read_byte.Address = address;
      read_byte.CommandExtension = PmbusMasterMessage.PMBUS_COMMAND_EXT;
      read_byte.Command = 0x00;
      read_byte.WithPec = with_pec;

      // Transfer message to the SMBus slave.
      smb_master.TransferData (read_byte);

      // Display result of the message.
      Console.WriteLine (string.Format("\"Read Byte\" (command: 0x{0:X2}, command extension: 0x{1:X2}) result: 0x{2:X2}",
                                       read_byte.Command,
                                       read_byte.CommandExtension,
                                       read_byte.Data));

      // Create "Write Word" message.
      write_word = new PmbusMasterMessageWriteWord();
      write_word.Address = address;
      write_word.CommandExtension = PmbusMasterMessage.PMBUS_COMMAND_EXT;
      write_word.Command = 0x01;
      write_word.Data = 0x1234;
      write_word.WithPec = with_pec;

      // Transfer message to the SMBus slave.
      smb_master.TransferData (write_word);

      // Display result of the message.
      Console.WriteLine (string.Format ("\"Write Word\" (command: 0x{0:X2}, command extension: 0x{1:X2}) written: 0x{2:X4}",
                                        write_word.Command,
                                        write_word.CommandExtension,
                                        write_word.Data));

      // Create "Group Command" message.
      group_cmd = new PmbusMasterMessageGroupCmd();
      group_cmd.WithPec = with_pec;

      for (byte i=0; i < 10; i++)
      {
        cmd = new PmbusMasterMessageCmd();
        cmd.Address = address;
        cmd.Command = i;
        cmd.Data.Add (i);
        group_cmd.Add (cmd);
      }

      // Transfer message to the SMBus slave.
      smb_master.TransferData (group_cmd);

      // Display result of the message.
      Console.Write ("\"Group Command\" commands:");
      foreach (PmbusMasterMessageCmd group_cmd_item in group_cmd)
        Console.Write (string.Format (" 0x{0:X2}", group_cmd_item.Command));
      Console.WriteLine ("");
    }

    [STAThread]
    static void Main(string[] args)
    {
      Board  board = null;

      try
      {
        // Open an I2C interface with master license
        board = new Board();
        for (int i=board.ListOfBoards.Count-1; i >= 0; i--)
        {
          if (board.ListOfBoards[i].Master == true)
          {
            board.Open (board.ListOfBoards[i]);
            break;
          }
        }

        // No I2C interface with master license found?
        if (board.IsOpen == false)
        {
          Console.WriteLine("No I2C interface with master license has been found.");
          return;
        }
        else
        {
          Console.WriteLine(string.Format("Using {0} [0x{1:X4}]",
                                          board.HardwareInfoOfOpenBoard.BoardType,
                                          board.HardwareInfoOfOpenBoard.SerialNumber));
        }

        // Demonstrate a master transmitter transfer.
        MasterTransmitter (board.Master);

        // Demonstrate a master receiver transfer.
        MasterReceiver (board.Master);

        // Demonstrate a combined mode transfer.
        MasterCombined (board.Master);

        if (board.HardwareInfoOfOpenBoard.BusTypeSmb == true)
        {
          // Demonstrate SMBus transfers (without PEC)
          MasterSmb (board, false);

          // Demonstrate SMBus transfers (with PEC)
          MasterSmb (board, true);

          // Demonstrate PMBus transfers (without PEC)
          MasterPmbus (board, false);

          // Demonstrate SMBus transfers (with PEC)
          MasterPmbus (board, true);
        }

        // Close I2C interface.
        board.Close();
      }
      catch (System.Exception exp)
      {
        Console.WriteLine ("Error: " + exp.Message);
      }
      finally
      {
        // Free all resources allocated by the board object.
        // It is very important to call this method before the
        // garbage collector destroys the unused Board object.
        if (board != null)
          board.Dispose();
      }
    }
  }
}
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


Master Methods

Master Methods

The Master type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScanAddresses(I2cAddressRange, Int32) | Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.
Public method | ScanAddresses(I2cAddress, I2cAddress, Int32) | Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData(MasterMessage) | Sends the given master transmitter or master receiver message to the I2C bus.
Public method | TransferData(MasterMessageList) | Sends the given list of master transmitter and master receiver messages as one message to the I2C bus. If the list contains more than one object, the I2C combined mode (repeated start) is used.
Top
See Also

Reference

Master Class


Master.Dispose Method

MasterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

Master Class


Master.Dispose Method

MasterDispose Method
Dispose.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Master Class
Dispose Overload


Master.Dispose Method (Boolean)

MasterDispose Method (Boolean)
Releases the unmanaged resources used by the Master and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.Master.Dispose(System.Boolean)"]

See Also

Reference

Master Class
Dispose Overload


Master.ScanAddresses Method

MasterScanAddresses Method
Overload List
 | Name | Description
Public method | ScanAddresses(I2cAddressRange, Int32) | Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.
Public method | ScanAddresses(I2cAddress, I2cAddress, Int32) | Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.
Top
See Also

Reference

Master Class


Master.ScanAddresses Method (I2cAddressRange, Int32)

MasterScanAddresses Method (I2cAddressRange, Int32)
Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress[] ScanAddresses(
    I2cAddressRange addr_range,
    int busy_timeout
)
Public Function ScanAddresses (
    addr_range As I2cAddressRange,
    busy_timeout As Integer
) As I2cAddress()
public:
array<I2cAddress^>^ ScanAddresses(
    I2cAddressRange^ addr_range,
    int busy_timeout
)
member ScanAddresses :
        addr_range : I2cAddressRange *
        busy_timeout : int -> I2cAddress[]

Parameters

addr_range
Type: telos.I2cApi.DotNetI2cAddressRange
address range to be scanned
busy_timeout
Type: SystemInt32
timeout for bus busy

Return Value

Type: I2cAddress
found I2C slaves
Remarks
If the I2C bus is busy, this method tries to scan the I2C bus as long as the specified timeout has not expired.
See Also

Reference

Master Class
ScanAddresses Overload


Master.ScanAddresses Method (I2cAddress, I2cAddress, Int32)

MasterScanAddresses Method (I2cAddress, I2cAddress, Int32)
Scans the I2C bus connected to the I2C interface for slaves. Therefore the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned as an array.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress[] ScanAddresses(
    I2cAddress start,
    I2cAddress stop,
    int busy_timeout
)
Public Function ScanAddresses (
    start As I2cAddress,
    stop As I2cAddress,
    busy_timeout As Integer
) As I2cAddress()
public:
array<I2cAddress^>^ ScanAddresses(
    I2cAddress^ start,
    I2cAddress^ stop,
    int busy_timeout
)
member ScanAddresses :
        start : I2cAddress *
        stop : I2cAddress *
        busy_timeout : int -> I2cAddress[]

Parameters

start
Type: telos.I2cApi.DotNetI2cAddress
start of the address range to be scanned
stop
Type: telos.I2cApi.DotNetI2cAddress
stop of the address range to be scanned
busy_timeout
Type: SystemInt32
timeout for bus busy [s]

Return Value

Type: I2cAddress
found I2C slaves
Remarks
If the I2C bus is busy, this method tries to scan the I2C bus as long as the specified timeout has not expired.
See Also

Reference

Master Class
ScanAddresses Overload


Master.TransferData Method

MasterTransferData Method
Overload List
 | Name | Description
Public method | TransferData(MasterMessage) | Sends the given master transmitter or master receiver message to the I2C bus.
Public method | TransferData(MasterMessageList) | Sends the given list of master transmitter and master receiver messages as one message to the I2C bus. If the list contains more than one object, the I2C combined mode (repeated start) is used.
Top
See Also

Reference

Master Class


Master.TransferData Method (MasterMessage)

MasterTransferData Method (MasterMessage)
Sends the given master transmitter or master receiver message to the I2C bus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    MasterMessage msg
)
Public Sub TransferData (
    msg As MasterMessage
)
public:
void TransferData(
    MasterMessage^ msg
)
member TransferData :
        msg : MasterMessage -> unit

Parameters

msg
Type: telos.I2cApi.DotNetMasterMessage
master transmitter/receiver object
Remarks

The result of the transfer is stored in the same object.

The msg object gets locked in this method, before it gets read or written.

See Also

Reference

Master Class
TransferData Overload


Master.TransferData Method (MasterMessageList)

MasterTransferData Method (MasterMessageList)
Sends the given list of master transmitter and master receiver messages as one message to the I2C bus. If the list contains more than one object, the I2C combined mode (repeated start) is used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    MasterMessageList msgs
)
Public Sub TransferData (
    msgs As MasterMessageList
)
public:
void TransferData(
    MasterMessageList^ msgs
)
member TransferData :
        msgs : MasterMessageList -> unit

Parameters

msgs
Type: telos.I2cApi.DotNetMasterMessageList
list of master transmitter/receiver objects
Remarks

The result of the transfer is stored in the same objects.

The msgs object gets locked in this method, before it gets read or written.

See Also

Reference

Master Class
TransferData Overload


Master Properties

Master Properties

The Master type exposes the following members.

Properties
 | Name | Description
Public property | Bitrate | Sets/gets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the I2C clock.
Public property | BitrateHs | Sets/gets the I2C high speed bitrate (SCL) [Hz]. If this value is not zero, the I2C interface will use the high speed mode to transfer the data to the slave. The high speed initialisation token on the I2C bus is sent using the bitrate specified with the Bitrate property.
Public property | HsMasterCode | Sets/gets the I2C high speed master code.
Public property | Watchdog | Enables/disables the watchdog of the master module.
Top
See Also

Reference

Master Class


Master.Bitrate Property

MasterBitrate Property
Sets/gets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the I2C clock.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Bitrate { get; set; }
Public Property Bitrate As UInteger
    Get
    Set
public:
property unsigned int Bitrate {
    unsigned int get ();
    void set (unsigned int value);
}
member Bitrate : uint32 with get, set

Property Value

Type: UInt32
Remarks
Valid values for the bitrate can be found in the MasterSamplingRate variable.
See Also

Reference

Master Class


Master.BitrateHs Property

MasterBitrateHs Property
Sets/gets the I2C high speed bitrate (SCL) [Hz]. If this value is not zero, the I2C interface will use the high speed mode to transfer the data to the slave. The high speed initialisation token on the I2C bus is sent using the bitrate specified with the Bitrate property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint BitrateHs { get; set; }
Public Property BitrateHs As UInteger
    Get
    Set
public:
property unsigned int BitrateHs {
    unsigned int get ();
    void set (unsigned int value);
}
member BitrateHs : uint32 with get, set

Property Value

Type: UInt32
Remarks

To disable the high speed mode, set this value to "0". The default high speed bitrate is "0".

Valid values for the high speed bitrate can be found in the MasterSamplingRateHs variable.

See Also

Reference

Master Class


Master.HsMasterCode Property

MasterHsMasterCode Property
Sets/gets the I2C high speed master code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte HsMasterCode { get; set; }
Public Property HsMasterCode As Byte
    Get
    Set
public:
property unsigned char HsMasterCode {
    unsigned char get ();
    void set (unsigned char value);
}
member HsMasterCode : byte with get, set

Property Value

Type: Byte
Remarks

Valid master codes are 0x08, 0x0a, 0x0c, and 0x0e. The default master code is 0x08.

See Also

Reference

Master Class


Master.Watchdog Property

MasterWatchdog Property
Enables/disables the watchdog of the master module.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort Watchdog { get; set; }
Public Property Watchdog As UShort
    Get
    Set
public:
property unsigned short Watchdog {
    unsigned short get ();
    void set (unsigned short value);
}
member Watchdog : uint16 with get, set

Property Value

Type: UInt16
Remarks

If the watchdog expires during transferring data over the I2C bus using TransferData(MasterMessage) or TransferData(MasterMessageList), the function closes the I2C interface and throws an ExceptionMasterWatchdogTimeout exception.

Under normal conditions this will never happen. This method is especially interesting for an industrial enviroment.

The watchdog is disabled by default (timeout is MaxValue). Timeout values unequal MaxValue enable the watchdog. The smallest possible timeout is 5 seconds. The unit are seconds.

See Also

Reference

Master Class


Master Events

Master Events

The Master type exposes the following members.

Events
 | Name | Description
Public event | TransferDataStatus | This event, which gets fired periodically, reports the status of the currently running master transfer.
Top
See Also

Reference

Master Class


Master.TransferDataStatus Event

MasterTransferDataStatus Event
This event, which gets fired periodically, reports the status of the currently running master transfer.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<MasterTransferDataStatusEventArgs> TransferDataStatus
Public Event TransferDataStatus As EventHandler(Of MasterTransferDataStatusEventArgs)
public:
 event EventHandler<MasterTransferDataStatusEventArgs^>^ TransferDataStatus {
    void add (EventHandler<MasterTransferDataStatusEventArgs^>^ value);
    void remove (EventHandler<MasterTransferDataStatusEventArgs^>^ value);
}
member TransferDataStatus : IEvent<EventHandler<MasterTransferDataStatusEventArgs>,
    MasterTransferDataStatusEventArgs>

Value

Type: SystemEventHandler MasterTransferDataStatusEventArgs
See Also

Reference

Master Class


Master.TransferDataStatusEventArgs Class

MasterTransferDataStatusEventArgs Class
Event arguments used for the TransferDataStatus event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
telos.I2cApi.DotNetMasterTransferDataStatusEventArgs

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class TransferDataStatusEventArgs : EventArgs
Public Class TransferDataStatusEventArgs
    Inherits EventArgs
public ref class TransferDataStatusEventArgs : public EventArgs
type TransferDataStatusEventArgs =
    class
        inherit EventArgs
    end

The MasterTransferDataStatusEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MasterTransferDataStatusEventArgs | Initializes a new instance of the MasterTransferDataStatusEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContinueMaster | continue master (true), stop master (false)
Public property | CurrentPosition | current position of transfer
Public property | MaximumPosition | number of bytes to be transferred
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


Master.TransferDataStatusEventArgs Constructor

MasterTransferDataStatusEventArgs Constructor
Initializes a new instance of the MasterTransferDataStatusEventArgs class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TransferDataStatusEventArgs()
Public Sub New
public:
TransferDataStatusEventArgs()
new : unit -> TransferDataStatusEventArgs
See Also

Reference

MasterTransferDataStatusEventArgs Class


TransferDataStatusEventArgs Methods

TransferDataStatusEventArgs Methods

The MasterTransferDataStatusEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MasterTransferDataStatusEventArgs Class


TransferDataStatusEventArgs Properties

TransferDataStatusEventArgs Properties

The MasterTransferDataStatusEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ContinueMaster | continue master (true), stop master (false)
Public property | CurrentPosition | current position of transfer
Public property | MaximumPosition | number of bytes to be transferred
Top
See Also

Reference

MasterTransferDataStatusEventArgs Class


Master.TransferDataStatusEventArgs.ContinueMaster Property

MasterTransferDataStatusEventArgsContinueMaster Property
continue master (true), stop master (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ContinueMaster { get; set; }
Public Property ContinueMaster As Boolean
    Get
    Set
public:
property bool ContinueMaster {
    bool get ();
    void set (bool value);
}
member ContinueMaster : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MasterTransferDataStatusEventArgs Class


Master.TransferDataStatusEventArgs.CurrentPosition Property

MasterTransferDataStatusEventArgsCurrentPosition Property
current position of transfer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint CurrentPosition { get; set; }
Public Property CurrentPosition As UInteger
    Get
    Set
public:
property unsigned int CurrentPosition {
    unsigned int get ();
    void set (unsigned int value);
}
member CurrentPosition : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

MasterTransferDataStatusEventArgs Class


Master.TransferDataStatusEventArgs.MaximumPosition Property

MasterTransferDataStatusEventArgsMaximumPosition Property
number of bytes to be transferred

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MaximumPosition { get; set; }
Public Property MaximumPosition As UInteger
    Get
    Set
public:
property unsigned int MaximumPosition {
    unsigned int get ();
    void set (unsigned int value);
}
member MaximumPosition : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

MasterTransferDataStatusEventArgs Class


MasterMessage Class

MasterMessage Class
Specifies the interface of a master message. Objects of this type can be added to a MasterMessageList. This type is used to pass the data to the TransferData(MasterMessage) method.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMasterMessage
telos.I2cApi.DotNetMasterMessageRx
telos.I2cApi.DotNetMasterMessageTx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class MasterMessage : ICloneable,
    IDisposable
Public MustInherit Class MasterMessage
    Implements ICloneable, IDisposable
public ref class MasterMessage abstract : ICloneable,
    IDisposable
[<AbstractClassAttribute>]
type MasterMessage =
    class
        interface ICloneable
        interface IDisposable
    end

The MasterMessage type exposes the following members.

Constructors
 | Name | Description
Protected method | MasterMessage | Constructor
Protected method | MasterMessage(I2cAddress) | Constructor: sets the I2C address of the slave.
Protected method | MasterMessage(I2cAddress, IEnumerableByte) | Constructor: sets the I2C address of the slave and the data array used to store the data exchanged with the slave.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Public property | Data | Gets the list containing the data to be sent to the I2C slave as master transmitter or the data received from the I2C slave as master receiver.
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MasterMessage Constructor

MasterMessage Constructor
Overload List
 | Name | Description
Protected method | MasterMessage | Constructor
Protected method | MasterMessage(I2cAddress) | Constructor: sets the I2C address of the slave.
Protected method | MasterMessage(I2cAddress, IEnumerableByte) | Constructor: sets the I2C address of the slave and the data array used to store the data exchanged with the slave.
Top
See Also

Reference

MasterMessage Class


MasterMessage Constructor

MasterMessage Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected MasterMessage()
Protected Sub New
protected:
MasterMessage()
new : unit -> MasterMessage
See Also

Reference

MasterMessage Class
MasterMessage Overload


MasterMessage Constructor (I2cAddress)

MasterMessage Constructor (I2cAddress)
Constructor: sets the I2C address of the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected MasterMessage(
    I2cAddress i2c_address
)
Protected Sub New (
    i2c_address As I2cAddress
)
protected:
MasterMessage(
    I2cAddress^ i2c_address
)
new :
        i2c_address : I2cAddress -> MasterMessage

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave (deep copy)
See Also

Reference

MasterMessage Class
MasterMessage Overload


MasterMessage Constructor (I2cAddress, IEnumerable(Byte))

MasterMessage Constructor (I2cAddress, IEnumerableByte)
Constructor: sets the I2C address of the slave and the data array used to store the data exchanged with the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected MasterMessage(
    I2cAddress i2c_address,
    IEnumerable<byte> data
)
Protected Sub New (
    i2c_address As I2cAddress,
    data As IEnumerable(Of Byte)
)
protected:
MasterMessage(
    I2cAddress^ i2c_address,
    IEnumerable<unsigned char>^ data
)
new :
        i2c_address : I2cAddress *
        data : IEnumerable<byte> -> MasterMessage

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave (deep copy)
data
Type: System.Collections.GenericIEnumerable Byte
data to be exchanged with the slave (deep copy)
See Also

Reference

MasterMessage Class
MasterMessage Overload


MasterMessage Methods

MasterMessage Methods

The MasterMessage type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MasterMessage Class


MasterMessage.Clone Method

MasterMessageClone Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.MasterMessage.Clone"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object
public:
virtual Object^ Clone() abstract
abstract Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.MasterMessage.Clone"]

Implements

ICloneableClone
See Also

Reference

MasterMessage Class


MasterMessage.Dispose Method

MasterMessageDispose Method
Overload List
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Top
See Also

Reference

MasterMessage Class


MasterMessage.Dispose Method

MasterMessageDispose Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.MasterMessage.Dispose"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MasterMessage Class
Dispose Overload


MasterMessage.Dispose Method (Boolean)

MasterMessageDispose Method (Boolean)
Releases the unmanaged resources used by the MasterMessage and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
)
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.MasterMessage.Dispose(System.Boolean)"]

See Also

Reference

MasterMessage Class
Dispose Overload


MasterMessage Properties

MasterMessage Properties

The MasterMessage type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Public property | Data | Gets the list containing the data to be sent to the I2C slave as master transmitter or the data received from the I2C slave as master receiver.
Top
See Also

Reference

MasterMessage Class


MasterMessage.Address Property

MasterMessageAddress Property
Sets/gets the I2C address of the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

MasterMessage Class


MasterMessage.Data Property

MasterMessageData Property
Gets the list containing the data to be sent to the I2C slave as master transmitter or the data received from the I2C slave as master receiver.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<byte> Data { get; }
Public ReadOnly Property Data As List(Of Byte)
    Get
public:
property List<unsigned char>^ Data {
    List<unsigned char>^ get ();
}
member Data : List<byte> with get

Property Value

Type: List Byte
See Also

Reference

MasterMessage Class


MasterMessageList Class

MasterMessageList Class
Container used to store the messages of one I2C master transfer. This type is used to pass the data to the TransferData(MasterMessageList) method.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList MasterMessage
telos.I2cApi.DotNetMasterMessageList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MasterMessageList : List<MasterMessage>
Public NotInheritable Class MasterMessageList
    Inherits List(Of MasterMessage)
public ref class MasterMessageList sealed : public List<MasterMessage^>
[<SealedAttribute>]
type MasterMessageList =
    class
        inherit List<MasterMessage>
    end

The MasterMessageList type exposes the following members.

Constructors
 | Name | Description
Public method | MasterMessageList | Initializes a new instance of the MasterMessageList class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List MasterMessage .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List MasterMessage .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List MasterMessage .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List MasterMessage .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List MasterMessage .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List MasterMessage .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List MasterMessage .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List MasterMessage .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List MasterMessage .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List MasterMessage .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List MasterMessage .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List MasterMessage .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List MasterMessage .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List MasterMessage .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List MasterMessage .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List MasterMessage .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List MasterMessage .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List MasterMessage .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List MasterMessage .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List MasterMessage .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List MasterMessage .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List MasterMessage .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List MasterMessage .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List MasterMessage .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List MasterMessage .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List MasterMessage .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List MasterMessage .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List MasterMessage .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List MasterMessage .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List MasterMessage .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List MasterMessage .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List MasterMessage .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List MasterMessage .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List MasterMessage .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List MasterMessage .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List MasterMessage .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List MasterMessage .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List MasterMessage .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List MasterMessage .)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MasterMessageList Constructor

MasterMessageList Constructor
Initializes a new instance of the MasterMessageList class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MasterMessageList()
Public Sub New
public:
MasterMessageList()
new : unit -> MasterMessageList
See Also

Reference

MasterMessageList Class


MasterMessageList Methods

MasterMessageList Methods

The MasterMessageList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List MasterMessage .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List MasterMessage .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List MasterMessage .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List MasterMessage .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List MasterMessage .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List MasterMessage .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List MasterMessage .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List MasterMessage .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List MasterMessage .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List MasterMessage .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List MasterMessage .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List MasterMessage .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List MasterMessage .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List MasterMessage .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List MasterMessage .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List MasterMessage .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List MasterMessage .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List MasterMessage .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List MasterMessage .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List MasterMessage .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List MasterMessage .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List MasterMessage .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List MasterMessage .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List MasterMessage .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List MasterMessage .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List MasterMessage .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List MasterMessage .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List MasterMessage .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List MasterMessage .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List MasterMessage .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List MasterMessage .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List MasterMessage .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List MasterMessage .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List MasterMessage .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List MasterMessage .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List MasterMessage .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List MasterMessage .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List MasterMessage .)
Top
See Also

Reference

MasterMessageList Class


MasterMessageList Properties

MasterMessageList Properties

The MasterMessageList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List MasterMessage .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List MasterMessage .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List MasterMessage .)
Top
See Also

Reference

MasterMessageList Class


MasterMessageRx Class

MasterMessageRx Class
Stores a master receiver message. This type is used to pass the data to the TransferData(MasterMessage) method.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMasterMessage
telos.I2cApi.DotNetMasterMessageRx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MasterMessageRx : MasterMessage
Public NotInheritable Class MasterMessageRx
    Inherits MasterMessage
public ref class MasterMessageRx sealed : public MasterMessage
[<SealedAttribute>]
type MasterMessageRx =
    class
        inherit MasterMessage
    end

The MasterMessageRx type exposes the following members.

Constructors
 | Name | Description
Public method | MasterMessageRx | Constructor: creates a valid but undefined and empty master receiver message.
Public method | MasterMessageRx(I2cAddress, UInt32) | Constructor: sets the I2C address of the slave and the number of bytes to be read from the slave.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides MasterMessageClone.)
Public method | Dispose | (Inherited from MasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from MasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from MasterMessage.)
Public property | BytesTransferred | Gets how many data bytes have been received successfully from the slave. This value gets set by TransferData(MasterMessage). If no error occurred, this value should be equal to NumberOfBytes.
Public property | Data | Gets the list containing the data to be sent to the I2C slave as master transmitter or the data received from the I2C slave as master receiver. (Inherited from MasterMessage.)
Public property | NumberOfBytes | Gets/sets the number of bytes to be read from the I2C slave.
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MasterMessageRx Constructor

MasterMessageRx Constructor
Overload List
 | Name | Description
Public method | MasterMessageRx | Constructor: creates a valid but undefined and empty master receiver message.
Public method | MasterMessageRx(I2cAddress, UInt32) | Constructor: sets the I2C address of the slave and the number of bytes to be read from the slave.
Top
See Also

Reference

MasterMessageRx Class


MasterMessageRx Constructor

MasterMessageRx Constructor
Constructor: creates a valid but undefined and empty master receiver message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MasterMessageRx()
Public Sub New
public:
MasterMessageRx()
new : unit -> MasterMessageRx
See Also

Reference

MasterMessageRx Class
MasterMessageRx Overload


MasterMessageRx Constructor (I2cAddress, UInt32)

MasterMessageRx Constructor (I2cAddress, UInt32)
Constructor: sets the I2C address of the slave and the number of bytes to be read from the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MasterMessageRx(
    I2cAddress addr,
    uint number_bytes
)
Public Sub New (
    addr As I2cAddress,
    number_bytes As UInteger
)
public:
MasterMessageRx(
    I2cAddress^ addr,
    unsigned int number_bytes
)
new :
        addr : I2cAddress *
        number_bytes : uint32 -> MasterMessageRx

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave (deep copy)
number_bytes
Type: SystemUInt32
number of bytes to be read
See Also

Reference

MasterMessageRx Class
MasterMessageRx Overload


MasterMessageRx Methods

MasterMessageRx Methods

The MasterMessageRx type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides MasterMessageClone.)
Public method | Dispose | (Inherited from MasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from MasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MasterMessageRx Class


MasterMessageRx.Clone Method

MasterMessageRxClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy of this object

Implements

ICloneableClone
See Also

Reference

MasterMessageRx Class


MasterMessageRx Properties

MasterMessageRx Properties

The MasterMessageRx type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from MasterMessage.)
Public property | BytesTransferred | Gets how many data bytes have been received successfully from the slave. This value gets set by TransferData(MasterMessage). If no error occurred, this value should be equal to NumberOfBytes.
Public property | Data | Gets the list containing the data to be sent to the I2C slave as master transmitter or the data received from the I2C slave as master receiver. (Inherited from MasterMessage.)
Public property | NumberOfBytes | Gets/sets the number of bytes to be read from the I2C slave.
Top
See Also

Reference

MasterMessageRx Class


MasterMessageRx.BytesTransferred Property

MasterMessageRxBytesTransferred Property
Gets how many data bytes have been received successfully from the slave. This value gets set by TransferData(MasterMessage). If no error occurred, this value should be equal to NumberOfBytes.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint BytesTransferred { get; }
Public ReadOnly Property BytesTransferred As UInteger
    Get
public:
property unsigned int BytesTransferred {
    unsigned int get ();
}
member BytesTransferred : uint32 with get

Property Value

Type: UInt32
See Also

Reference

MasterMessageRx Class


MasterMessageRx.NumberOfBytes Property

MasterMessageRxNumberOfBytes Property
Gets/sets the number of bytes to be read from the I2C slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint NumberOfBytes { get; set; }
Public Property NumberOfBytes As UInteger
    Get
    Set
public:
property unsigned int NumberOfBytes {
    unsigned int get ();
    void set (unsigned int value);
}
member NumberOfBytes : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

MasterMessageRx Class


MasterMessageTx Class

MasterMessageTx Class
Stores a master transmitter message. This type is used to pass the data to the TransferData(MasterMessage) method.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMasterMessage
telos.I2cApi.DotNetMasterMessageTx

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MasterMessageTx : MasterMessage
Public NotInheritable Class MasterMessageTx
    Inherits MasterMessage
public ref class MasterMessageTx sealed : public MasterMessage
[<SealedAttribute>]
type MasterMessageTx =
    class
        inherit MasterMessage
    end

The MasterMessageTx type exposes the following members.

Constructors
 | Name | Description
Public method | MasterMessageTx | Constructor: creates a valid but undefined and empty master transmitter message.
Public method | MasterMessageTx(I2cAddress, IEnumerableByte) | Constructor: sets the I2C address of the slave and the data to be sent to this slave.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides MasterMessageClone.)
Public method | Dispose | (Inherited from MasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from MasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from MasterMessage.)
Public property | BytesTransferred | Sets/gets how many of the data bytes have been transmitted successfully to the slave. This value gets set by TransferData(MasterMessage). If the complete message has been transmitted successfully, the returned value should be equal to [!:MasterMessageTx::Data::Count].
Public property | Data | Gets the list containing the data to be sent to the I2C slave as master transmitter or the data received from the I2C slave as master receiver. (Inherited from MasterMessage.)
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MasterMessageTx Constructor

MasterMessageTx Constructor
Overload List
 | Name | Description
Public method | MasterMessageTx | Constructor: creates a valid but undefined and empty master transmitter message.
Public method | MasterMessageTx(I2cAddress, IEnumerableByte) | Constructor: sets the I2C address of the slave and the data to be sent to this slave.
Top
See Also

Reference

MasterMessageTx Class


MasterMessageTx Constructor

MasterMessageTx Constructor
Constructor: creates a valid but undefined and empty master transmitter message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MasterMessageTx()
Public Sub New
public:
MasterMessageTx()
new : unit -> MasterMessageTx
See Also

Reference

MasterMessageTx Class
MasterMessageTx Overload


MasterMessageTx Constructor (I2cAddress, IEnumerable(Byte))

MasterMessageTx Constructor (I2cAddress, IEnumerableByte)
Constructor: sets the I2C address of the slave and the data to be sent to this slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MasterMessageTx(
    I2cAddress addr,
    IEnumerable<byte> data
)
Public Sub New (
    addr As I2cAddress,
    data As IEnumerable(Of Byte)
)
public:
MasterMessageTx(
    I2cAddress^ addr,
    IEnumerable<unsigned char>^ data
)
new :
        addr : I2cAddress *
        data : IEnumerable<byte> -> MasterMessageTx

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave (deep copy)
data
Type: System.Collections.GenericIEnumerable Byte
data to be sent
See Also

Reference

MasterMessageTx Class
MasterMessageTx Overload


MasterMessageTx Methods

MasterMessageTx Methods

The MasterMessageTx type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides MasterMessageClone.)
Public method | Dispose | (Inherited from MasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from MasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MasterMessageTx Class


MasterMessageTx.Clone Method

MasterMessageTxClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy of this object

Implements

ICloneableClone
See Also

Reference

MasterMessageTx Class


MasterMessageTx Properties

MasterMessageTx Properties

The MasterMessageTx type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from MasterMessage.)
Public property | BytesTransferred | Sets/gets how many of the data bytes have been transmitted successfully to the slave. This value gets set by TransferData(MasterMessage). If the complete message has been transmitted successfully, the returned value should be equal to [!:MasterMessageTx::Data::Count].
Public property | Data | Gets the list containing the data to be sent to the I2C slave as master transmitter or the data received from the I2C slave as master receiver. (Inherited from MasterMessage.)
Top
See Also

Reference

MasterMessageTx Class


MasterMessageTx.BytesTransferred Property

MasterMessageTxBytesTransferred Property
Sets/gets how many of the data bytes have been transmitted successfully to the slave. This value gets set by TransferData(MasterMessage). If the complete message has been transmitted successfully, the returned value should be equal to [!:MasterMessageTx::Data::Count].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint BytesTransferred { get; set; }
Public Property BytesTransferred As UInteger
    Get
    Set
public:
property unsigned int BytesTransferred {
    unsigned int get ();
    void set (unsigned int value);
}
member BytesTransferred : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

MasterMessageTx Class


MathExpression Class

MathExpression Class
Converts a mathematical formula to a binary tree, which can be used to calculate with this formula.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMathExpression

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MathExpression
Public NotInheritable Class MathExpression
public ref class MathExpression sealed
[<SealedAttribute>]
type MathExpression =  class end

The MathExpression type exposes the following members.

Constructors
 | Name | Description
Public method | MathExpression | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Converts the mathematical formula to an MathExpressionINode object, which can be used to calculate with the formula.
Public method | Solve | Solves the formula in the MathExpressionINode object, i.e. "(x*3)-5" is converted to "(y+5)/3".
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CultureInfo | Gets/sets the culture info used for parsing the formula.
Public property | VariableNames | Gets/sets the variable names.
Top
Remarks
The Parse(String) methods converts a formula like e.g. "2 * cos(x) - 5.0" to an MathExpressionINode object. The variables of the formula have to be registered using the VariableNames property. The MathExpressionINode object can be used to do calculations with the formula.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MathExpression Constructor

MathExpression Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MathExpression()
Public Sub New
public:
MathExpression()
new : unit -> MathExpression
See Also

Reference

MathExpression Class


MathExpression Methods

MathExpression Methods

The MathExpression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Converts the mathematical formula to an MathExpressionINode object, which can be used to calculate with the formula.
Public method | Solve | Solves the formula in the MathExpressionINode object, i.e. "(x*3)-5" is converted to "(y+5)/3".
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MathExpression Class


MathExpression.Parse Method

MathExpressionParse Method
Converts the mathematical formula to an MathExpressionINode object, which can be used to calculate with the formula.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MathExpressionINode Parse(
    string formula
)
Public Function Parse (
    formula As String
) As MathExpressionINode
public:
MathExpressionINode^ Parse(
    String^ formula
)
member Parse :
        formula : string -> MathExpressionINode

Parameters

formula
Type: SystemString
mathematical formula

Return Value

Type: MathExpressionINode
object for calculations
See Also

Reference

MathExpression Class


MathExpression.Solve Method

MathExpressionSolve Method
Solves the formula in the MathExpressionINode object, i.e. "(x*3)-5" is converted to "(y+5)/3".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MathExpressionINode Solve(
    MathExpressionINode node,
    string var_name,
    string result_name
)
Public Function Solve (
    node As MathExpressionINode,
    var_name As String,
    result_name As String
) As MathExpressionINode
public:
MathExpressionINode^ Solve(
    MathExpressionINode^ node,
    String^ var_name,
    String^ result_name
)
member Solve :
        node : MathExpressionINode *
        var_name : string *
        result_name : string -> MathExpressionINode

Parameters

node
Type: telos.I2cApi.DotNetMathExpressionINode
node to be solved
var_name
Type: SystemString
name of the variable (e.g. "x")
result_name
Type: SystemString
name of the result (e.g. "y")

Return Value

Type: MathExpressionINode
solved node or N/A
See Also

Reference

MathExpression Class


MathExpression Properties

MathExpression Properties

The MathExpression type exposes the following members.

Properties
 | Name | Description
Public property | CultureInfo | Gets/sets the culture info used for parsing the formula.
Public property | VariableNames | Gets/sets the variable names.
Top
See Also

Reference

MathExpression Class


MathExpression.CultureInfo Property

MathExpressionCultureInfo Property
Gets/sets the culture info used for parsing the formula.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public CultureInfo CultureInfo { get; set; }
Public Property CultureInfo As CultureInfo
    Get
    Set
public:
property CultureInfo^ CultureInfo {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}
member CultureInfo : CultureInfo with get, set

Property Value

Type: CultureInfo
See Also

Reference

MathExpression Class


MathExpression.VariableNames Property

MathExpressionVariableNames Property
Gets/sets the variable names.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] VariableNames { get; set; }
Public Property VariableNames As String()
    Get
    Set
public:
property array<String^>^ VariableNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VariableNames : string[] with get, set

Property Value

Type: String
See Also

Reference

MathExpression Class


MathExpression.Func(T, TResult) Delegate

MathExpressionFuncT, TResult Delegate
Encapsulates a method that has one parameter and returns a value.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public delegate TResult Func<T, TResult>(
    T arg
)

Public Delegate Function Func(Of T, TResult) (
    arg As T
) As TResult
generic<typename T, typename TResult>
public delegate TResult Func(
    T arg
)
type Func =
    delegate of
        arg : 'T -> 'TResult

Parameters

arg
Type: T

Type Parameters

T
type of the parameter
TResult
type of the return value

Return Value

Type: TResult
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MathExpression.INode Interface

MathExpressionINode Interface
Interface of a node, which is part of the binary tree.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public interface INode : ICloneable, IFormattable
Public Interface INode
    Inherits ICloneable, IFormattable
public interface class INode : ICloneable,
    IFormattable
type INode =
    interface
        interface ICloneable
        interface IFormattable
    end

The MathExpressionINode type exposes the following members.

Methods
 | Name | Description
Public method | Calculate |
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | ToCSharpCode |
Public method | ToString | Formats the value of the current instance using the specified format. (Inherited from IFormattable.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


INode Methods

INode Methods

The MathExpressionINode type exposes the following members.

Methods
 | Name | Description
Public method | Calculate |
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | ToCSharpCode |
Public method | ToString | Formats the value of the current instance using the specified format. (Inherited from IFormattable.)
Top
See Also

Reference

MathExpressionINode Interface


MathExpression.INode.Calculate Method

MathExpressionINodeCalculate Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.MathExpression.INode.Calculate(System.Collections.Generic.Dictionary{System.String,System.Double})"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
double Calculate(
    Dictionary<string, double> variables
)
Function Calculate (
    variables As Dictionary(Of String, Double)
) As Double
double Calculate(
    Dictionary<String^, double>^ variables
)
abstract Calculate :
        variables : Dictionary<string, float> -> float

Parameters

variables
Type: System.Collections.GenericDictionary String, Double

[Missing <param name="variables"/> documentation for "M:telos.I2cApi.DotNet.MathExpression.INode.Calculate(System.Collections.Generic.Dictionary{System.String,System.Double})"]

Return Value

Type: Double

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.MathExpression.INode.Calculate(System.Collections.Generic.Dictionary{System.String,System.Double})"]

See Also

Reference

MathExpressionINode Interface


MathExpression.INode.ToCSharpCode Method

MathExpressionINodeToCSharpCode Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.MathExpression.INode.ToCSharpCode"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
string ToCSharpCode()
Function ToCSharpCode As String
String^ ToCSharpCode()
abstract ToCSharpCode : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.MathExpression.INode.ToCSharpCode"]

See Also

Reference

MathExpressionINode Interface


MathExpression.NodeFunction Class

MathExpressionNodeFunction Class
Implementation of the MathExpressionINode interface, which stores a mathematical function.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMathExpressionNodeFunction

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NodeFunction : MathExpressionINode
Public NotInheritable Class NodeFunction
    Implements MathExpressionINode
public ref class NodeFunction sealed : MathExpressionINode
[<SealedAttribute>]
type NodeFunction =
    class
        interface MathExpressionINode
    end

The MathExpressionNodeFunction type exposes the following members.

Constructors
 | Name | Description
Public method | MathExpressionNodeFunction | Initializes a new instance of the MathExpressionNodeFunction class
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
Properties
 | Name | Description
Public property | Function | Gets/sets the mathematical function.
Public property | FunctionName | Gets/sets the name of the mathematical function.
Public property | Node | Gets/sets the node to which the mathematical function gets applied.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MathExpression.NodeFunction Constructor

MathExpressionNodeFunction Constructor
Initializes a new instance of the MathExpressionNodeFunction class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NodeFunction()
Public Sub New
public:
NodeFunction()
new : unit -> NodeFunction
See Also

Reference

MathExpressionNodeFunction Class


NodeFunction Methods

NodeFunction Methods

The MathExpressionNodeFunction type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeFunction.Calculate Method

MathExpressionNodeFunctionCalculate Method
Calculates the result.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public double Calculate(
    Dictionary<string, double> variables
)
Public Function Calculate (
    variables As Dictionary(Of String, Double)
) As Double
public:
virtual double Calculate(
    Dictionary<String^, double>^ variables
) sealed
abstract Calculate :
        variables : Dictionary<string, float> -> float
override Calculate :
        variables : Dictionary<string, float> -> float

Parameters

variables
Type: System.Collections.GenericDictionary String, Double
values to be used for the variables in the formula

Return Value

Type: Double
result of the calculation

Implements

MathExpressionINodeCalculate(DictionaryString, Double)
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeFunction.Clone Method

MathExpressionNodeFunctionClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeFunction.ToCSharpCode Method

MathExpressionNodeFunctionToCSharpCode Method
Converts the node instance to C# code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToCSharpCode()
Public Function ToCSharpCode As String
public:
virtual String^ ToCSharpCode() sealed
abstract ToCSharpCode : unit -> string
override ToCSharpCode : unit -> string

Return Value

Type: String
C# code

Implements

MathExpressionINodeToCSharpCode
See Also

Reference

MathExpressionNodeFunction Class


NodeFunction.ToString Method

NodeFunctionToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeFunction.ToString Method

MathExpressionNodeFunctionToString Method
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeFunction Class
ToString Overload


MathExpression.NodeFunction.ToString Method (String, IFormatProvider)

MathExpressionNodeFunctionToString Method (String, IFormatProvider)
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string

Parameters

format
Type: SystemString
format
provider
Type: SystemIFormatProvider
format provider

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeFunction Class
ToString Overload


NodeFunction Properties

NodeFunction Properties

The MathExpressionNodeFunction type exposes the following members.

Properties
 | Name | Description
Public property | Function | Gets/sets the mathematical function.
Public property | FunctionName | Gets/sets the name of the mathematical function.
Public property | Node | Gets/sets the node to which the mathematical function gets applied.
Top
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeFunction.Function Property

MathExpressionNodeFunctionFunction Property
Gets/sets the mathematical function.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MathExpressionFunc<double, double> Function { get; set; }
Public Property Function As MathExpressionFunc(Of Double, Double)
    Get
    Set
public:
property MathExpressionFunc<double, double>^ Function {
    MathExpressionFunc<double, double>^ get ();
    void set (MathExpressionFunc<double, double>^ value);
}
member Function : MathExpressionFunc<float, float> with get, set

Property Value

Type: MathExpressionFunc Double, Double
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeFunction.FunctionName Property

MathExpressionNodeFunctionFunctionName Property
Gets/sets the name of the mathematical function.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string FunctionName { get; set; }
Public Property FunctionName As String
    Get
    Set
public:
property String^ FunctionName {
    String^ get ();
    void set (String^ value);
}
member FunctionName : string with get, set

Property Value

Type: String
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeFunction.Node Property

MathExpressionNodeFunctionNode Property
Gets/sets the node to which the mathematical function gets applied.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MathExpressionINode Node { get; set; }
Public Property Node As MathExpressionINode
    Get
    Set
public:
property MathExpressionINode^ Node {
    MathExpressionINode^ get ();
    void set (MathExpressionINode^ value);
}
member Node : MathExpressionINode with get, set

Property Value

Type: MathExpressionINode
See Also

Reference

MathExpressionNodeFunction Class


MathExpression.NodeOperator Class

MathExpressionNodeOperator Class
Implementation of the MathExpressionINode interface, which stores an operator.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMathExpressionNodeOperator

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NodeOperator : MathExpressionINode
Public NotInheritable Class NodeOperator
    Implements MathExpressionINode
public ref class NodeOperator sealed : MathExpressionINode
[<SealedAttribute>]
type NodeOperator =
    class
        interface MathExpressionINode
    end

The MathExpressionNodeOperator type exposes the following members.

Constructors
 | Name | Description
Public method | MathExpressionNodeOperator | Initializes a new instance of the MathExpressionNodeOperator class
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
Properties
 | Name | Description
Public property | Left | Gets/sets the left operand.
Public property | Operator | Gets/sets the operator.
Public property | Right | Gets/sets the right operand.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MathExpression.NodeOperator Constructor

MathExpressionNodeOperator Constructor
Initializes a new instance of the MathExpressionNodeOperator class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NodeOperator()
Public Sub New
public:
NodeOperator()
new : unit -> NodeOperator
See Also

Reference

MathExpressionNodeOperator Class


NodeOperator Methods

NodeOperator Methods

The MathExpressionNodeOperator type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeOperator.Calculate Method

MathExpressionNodeOperatorCalculate Method
Calculates the result.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public double Calculate(
    Dictionary<string, double> variables
)
Public Function Calculate (
    variables As Dictionary(Of String, Double)
) As Double
public:
virtual double Calculate(
    Dictionary<String^, double>^ variables
) sealed
abstract Calculate :
        variables : Dictionary<string, float> -> float
override Calculate :
        variables : Dictionary<string, float> -> float

Parameters

variables
Type: System.Collections.GenericDictionary String, Double
values to be used for the variables in the formula

Return Value

Type: Double
result of the calculation

Implements

MathExpressionINodeCalculate(DictionaryString, Double)
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeOperator.Clone Method

MathExpressionNodeOperatorClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeOperator.ToCSharpCode Method

MathExpressionNodeOperatorToCSharpCode Method
Converts the node instance to C# code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToCSharpCode()
Public Function ToCSharpCode As String
public:
virtual String^ ToCSharpCode() sealed
abstract ToCSharpCode : unit -> string
override ToCSharpCode : unit -> string

Return Value

Type: String
C# code

Implements

MathExpressionINodeToCSharpCode
See Also

Reference

MathExpressionNodeOperator Class


NodeOperator.ToString Method

NodeOperatorToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeOperator.ToString Method

MathExpressionNodeOperatorToString Method
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeOperator Class
ToString Overload


MathExpression.NodeOperator.ToString Method (String, IFormatProvider)

MathExpressionNodeOperatorToString Method (String, IFormatProvider)
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string

Parameters

format
Type: SystemString
format
provider
Type: SystemIFormatProvider
format provider

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeOperator Class
ToString Overload


NodeOperator Properties

NodeOperator Properties

The MathExpressionNodeOperator type exposes the following members.

Properties
 | Name | Description
Public property | Left | Gets/sets the left operand.
Public property | Operator | Gets/sets the operator.
Public property | Right | Gets/sets the right operand.
Top
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeOperator.Left Property

MathExpressionNodeOperatorLeft Property
Gets/sets the left operand.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MathExpressionINode Left { get; set; }
Public Property Left As MathExpressionINode
    Get
    Set
public:
property MathExpressionINode^ Left {
    MathExpressionINode^ get ();
    void set (MathExpressionINode^ value);
}
member Left : MathExpressionINode with get, set

Property Value

Type: MathExpressionINode
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeOperator.Operator Property

MathExpressionNodeOperatorOperator Property
Gets/sets the operator.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public char Operator { get; set; }
Public Property Operator As Char
    Get
    Set
public:
property wchar_t Operator {
    wchar_t get ();
    void set (wchar_t value);
}
member Operator : char with get, set

Property Value

Type: Char
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeOperator.Right Property

MathExpressionNodeOperatorRight Property
Gets/sets the right operand.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MathExpressionINode Right { get; set; }
Public Property Right As MathExpressionINode
    Get
    Set
public:
property MathExpressionINode^ Right {
    MathExpressionINode^ get ();
    void set (MathExpressionINode^ value);
}
member Right : MathExpressionINode with get, set

Property Value

Type: MathExpressionINode
See Also

Reference

MathExpressionNodeOperator Class


MathExpression.NodeValue Class

MathExpressionNodeValue Class
Implementation of the MathExpressionINode interface, which stores a numerical constant.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMathExpressionNodeValue

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NodeValue : MathExpressionINode
Public NotInheritable Class NodeValue
    Implements MathExpressionINode
public ref class NodeValue sealed : MathExpressionINode
[<SealedAttribute>]
type NodeValue =
    class
        interface MathExpressionINode
    end

The MathExpressionNodeValue type exposes the following members.

Constructors
 | Name | Description
Public method | MathExpressionNodeValue | Initializes a new instance of the MathExpressionNodeValue class
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
Properties
 | Name | Description
Public property | Value | Gets/sets the numerical constant.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MathExpression.NodeValue Constructor

MathExpressionNodeValue Constructor
Initializes a new instance of the MathExpressionNodeValue class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NodeValue()
Public Sub New
public:
NodeValue()
new : unit -> NodeValue
See Also

Reference

MathExpressionNodeValue Class


NodeValue Methods

NodeValue Methods

The MathExpressionNodeValue type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeValue Class


MathExpression.NodeValue.Calculate Method

MathExpressionNodeValueCalculate Method
Calculates the result.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public double Calculate(
    Dictionary<string, double> variables
)
Public Function Calculate (
    variables As Dictionary(Of String, Double)
) As Double
public:
virtual double Calculate(
    Dictionary<String^, double>^ variables
) sealed
abstract Calculate :
        variables : Dictionary<string, float> -> float
override Calculate :
        variables : Dictionary<string, float> -> float

Parameters

variables
Type: System.Collections.GenericDictionary String, Double
values to be used for the variables in the formula

Return Value

Type: Double
result of the calculation

Implements

MathExpressionINodeCalculate(DictionaryString, Double)
See Also

Reference

MathExpressionNodeValue Class


MathExpression.NodeValue.Clone Method

MathExpressionNodeValueClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object
See Also

Reference

MathExpressionNodeValue Class


MathExpression.NodeValue.ToCSharpCode Method

MathExpressionNodeValueToCSharpCode Method
Converts the node instance to C# code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToCSharpCode()
Public Function ToCSharpCode As String
public:
virtual String^ ToCSharpCode() sealed
abstract ToCSharpCode : unit -> string
override ToCSharpCode : unit -> string

Return Value

Type: String
C# code

Implements

MathExpressionINodeToCSharpCode
See Also

Reference

MathExpressionNodeValue Class


NodeValue.ToString Method

NodeValueToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeValue Class


MathExpression.NodeValue.ToString Method

MathExpressionNodeValueToString Method
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeValue Class
ToString Overload


MathExpression.NodeValue.ToString Method (String, IFormatProvider)

MathExpressionNodeValueToString Method (String, IFormatProvider)
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string

Parameters

format
Type: SystemString
format
provider
Type: SystemIFormatProvider
format provider

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeValue Class
ToString Overload


NodeValue Properties

NodeValue Properties

The MathExpressionNodeValue type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets/sets the numerical constant.
Top
See Also

Reference

MathExpressionNodeValue Class


MathExpression.NodeValue.Value Property

MathExpressionNodeValueValue Property
Gets/sets the numerical constant.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

MathExpressionNodeValue Class


MathExpression.NodeVariable Class

MathExpressionNodeVariable Class
Implementation of the MathExpressionINode interface, which stores a variable.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetMathExpressionNodeVariable

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NodeVariable : MathExpressionINode
Public NotInheritable Class NodeVariable
    Implements MathExpressionINode
public ref class NodeVariable sealed : MathExpressionINode
[<SealedAttribute>]
type NodeVariable =
    class
        interface MathExpressionINode
    end

The MathExpressionNodeVariable type exposes the following members.

Constructors
 | Name | Description
Public method | MathExpressionNodeVariable | Initializes a new instance of the MathExpressionNodeVariable class
Top
Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
Properties
 | Name | Description
Public property | Name | Gets/sets the name of the variable.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


MathExpression.NodeVariable Constructor

MathExpressionNodeVariable Constructor
Initializes a new instance of the MathExpressionNodeVariable class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NodeVariable()
Public Sub New
public:
NodeVariable()
new : unit -> NodeVariable
See Also

Reference

MathExpressionNodeVariable Class


NodeVariable Methods

NodeVariable Methods

The MathExpressionNodeVariable type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates the result.
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSharpCode | Converts the node instance to C# code.
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeVariable Class


MathExpression.NodeVariable.Calculate Method

MathExpressionNodeVariableCalculate Method
Calculates the result.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public double Calculate(
    Dictionary<string, double> variables
)
Public Function Calculate (
    variables As Dictionary(Of String, Double)
) As Double
public:
virtual double Calculate(
    Dictionary<String^, double>^ variables
) sealed
abstract Calculate :
        variables : Dictionary<string, float> -> float
override Calculate :
        variables : Dictionary<string, float> -> float

Parameters

variables
Type: System.Collections.GenericDictionary String, Double
values to be used for the variables in the formula

Return Value

Type: Double
result of the calculation

Implements

MathExpressionINodeCalculate(DictionaryString, Double)
See Also

Reference

MathExpressionNodeVariable Class


MathExpression.NodeVariable.Clone Method

MathExpressionNodeVariableClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object
See Also

Reference

MathExpressionNodeVariable Class


MathExpression.NodeVariable.ToCSharpCode Method

MathExpressionNodeVariableToCSharpCode Method
Converts the node instance to C# code.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToCSharpCode()
Public Function ToCSharpCode As String
public:
virtual String^ ToCSharpCode() sealed
abstract ToCSharpCode : unit -> string
override ToCSharpCode : unit -> string

Return Value

Type: String
C# code

Implements

MathExpressionINodeToCSharpCode
See Also

Reference

MathExpressionNodeVariable Class


NodeVariable.ToString Method

NodeVariableToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the node instance to a string representation. (Overrides ObjectToString.)
Public method | ToString(String, IFormatProvider) | Converts the node instance to a string representation.
Top
See Also

Reference

MathExpressionNodeVariable Class


MathExpression.NodeVariable.ToString Method

MathExpressionNodeVariableToString Method
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeVariable Class
ToString Overload


MathExpression.NodeVariable.ToString Method (String, IFormatProvider)

MathExpressionNodeVariableToString Method (String, IFormatProvider)
Converts the node instance to a string representation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string

Parameters

format
Type: SystemString
format
provider
Type: SystemIFormatProvider
format provider

Return Value

Type: String
string representation
See Also

Reference

MathExpressionNodeVariable Class
ToString Overload


NodeVariable Properties

NodeVariable Properties

The MathExpressionNodeVariable type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets/sets the name of the variable.
Top
See Also

Reference

MathExpressionNodeVariable Class


MathExpression.NodeVariable.Name Property

MathExpressionNodeVariableName Property
Gets/sets the name of the variable.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MathExpressionNodeVariable Class


NegativeTester Class

NegativeTester Class
This class provides a negative tester.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetNegativeTester

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NegativeTester : IDisposable
Public NotInheritable Class NegativeTester
    Implements IDisposable
public ref class NegativeTester sealed : IDisposable
[<SealedAttribute>]
type NegativeTester =
    class
        interface IDisposable
    end

The NegativeTester type exposes the following members.

Methods
 | Name | Description
 | ConvertNanosecondsToTicks | Converts a time in nanoseconds to the ticks used by this class.
 | ConvertTicksToNanoseconds | Converts the ticks used by this class to a time in nanoseconds.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartMaster | Loads the given master messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterMaster.
Public method | StartSlave | Loads the given slave messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterSlave.
Public method | Stop | Stops the negative tester.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
TIMEBASE | timebase: 16 MHz
Top
Properties
 | Name | Description
Public property | IsRunning | Returns whether the negative tester is currently running.
Top
Events
 | Name | Description
Public event | Completion | Completion event, which gets called when the negative testing is going from the running to the idle state.
Top
Remarks

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the NegativeTester property.

Normally the following steps are necessary:

  1. Create a NegativeTesterMessagesMaster or NegativeTesterMessageSlave object. This can be done manually or using the high-level interfaces NegativeTesterMaster or NegativeTesterSlave.
  2. Subscribe to the completion event.
  3. Pass this object to the API and start the negative tester using StartMaster(NegativeTesterMessagesMaster) or StartSlave(NegativeTesterMessagesSlave).

Times get specified as multiple of TIMEBASE.

Examples
The following example demonstrates how to use this class in C#:
Copy
using telos.I2cApi.DotNet;
using System;
using System.Collections.Generic;

namespace MyNamespace
{
    class I2c
    {
    /***********************************************************************/
    /// <summary>
    /// Callback function for the negative tester.
    /// </summary>
    /***********************************************************************/

    private void NegativeTesterCompletion (object sender,
                                           NegativeTester.CompletionEventArgs e)
    {
      Console.WriteLine (string.Format ("Result of the negative tester: {0}", e.Result));
      m_finished = true;
    }

    /***********************************************************************/
    /// <summary>
    /// Shows the currently used timing of the negative tester master.
    /// </summary>
    /// <param name="neg_tester_master">negative tester master</param>
    /***********************************************************************/

    private void ShowTiming (NegativeTesterMaster neg_tester_master)
    {
      if (neg_tester_master.Bitrate != uint.MaxValue)
        Console.WriteLine (string.Format ("Timings ({0} Hz)", neg_tester_master.Bitrate));
      else
        Console.WriteLine ("Timings");

      Console.WriteLine (string.Format ("  t_HD;STA: {0} ns", NegativeTester.ConvertTicksToNanoseconds (neg_tester_master.TimeHdSta)));
      Console.WriteLine (string.Format ("  t_SU;STA: {0} ns", NegativeTester.ConvertTicksToNanoseconds (neg_tester_master.TimeSuSta)));
      Console.WriteLine (string.Format ("  t_SU;STO: {0} ns", NegativeTester.ConvertTicksToNanoseconds (neg_tester_master.TimeSuSto)));
      Console.WriteLine (string.Format ("  t_BUF:    {0} ns", NegativeTester.ConvertTicksToNanoseconds (neg_tester_master.TimeBuf)));
      Console.WriteLine (string.Format ("  t_LOW:    {0} ns", NegativeTester.ConvertTicksToNanoseconds (neg_tester_master.TimeLowBeforeHigh +
                                                                                neg_tester_master.TimeLowAfterHigh)));
      Console.WriteLine (string.Format ("  t_HIGH:   {0} ns", NegativeTester.ConvertTicksToNanoseconds (neg_tester_master.TimeHigh)));
    }

    /***********************************************************************/
    /// <summary>
    /// <para>
    /// Demonstrates how to create master messages for the negative
    /// tester using the <see cref="NegativeTesterMaster"/> class.
    /// </para><para>
    /// Creates four I2C messages, sends them to the negative tester and
    /// waits until the tester has transferred all messages.
    /// </para>
    /// </summary>
    /***********************************************************************/

    public void NegativeTesterMaster (Board board)
    {
      NegativeTesterMaster   master;
      I2cAddress             addr;
      List<byte>             data;

      master = new NegativeTesterMaster();

      // create address of I2C slave
      addr = new I2cAddress (0x50, false);

      // send messages one time
      master.LoopCount = 1;

      // do not ignore clock stretching
      master.IgnoreStretching = false;

      // generate STOP after receiving NACK
      master.NackBehaviour = NegativeTester.ENackBehaviour.NACK_GENERATE_STOP;

      // stop after receiving an arbitration lost
      master.StopAtArbitrationLost = true;

      // create container of 256 data bytes
      data = new List<byte>();
      for (int i=0; i < 256; i++)
        data.Add ((byte) i);

      // create first message: send 256 data bytes to 0x50
      master.Bitrate = 100000;
      master.SendTransmitter (addr, data);

      // show info for first message
      Console.WriteLine ("-----------------------------------------------------");
      Console.WriteLine ("Message (1): send 256 data bytes to 0x50 (100 kHz)");
      ShowTiming (master);

      // create second message: read 32 data bytes from 0x50
      master.Bitrate = 400000;
      master.SendReceiver (addr, 32);

      // show info for second message
      Console.WriteLine ("-----------------------------------------------------");
      Console.WriteLine ("Message (2): read 32 data bytes from 0x50 (400 kHz)");
      ShowTiming (master);

      // create third message: send one data byte to 0x50
      master.Bitrate = 100000;
      master.SendStart();
      master.SendByte ((byte) (addr.Address << 1));
      master.ReceiveAckBit (false);
      master.Bitrate = 400000;
      master.SendByte (0x00);
      master.ReceiveAckBit (false);
      master.SendStop();

      // show info for third message
      Console.WriteLine ("-----------------------------------------------------");
      Console.WriteLine ("Message (3): send one data byte to 0x50 (100/400 kHz)");

      // create fourth message: read one data byte from 0x50
      master.Bitrate = 100000;
      master.TimeHdSta = master.TimeHdSta * 2;
      master.SendStart();
      master.SendByte ((byte) ((addr.Address << 1) | 0x01));
      master.ReceiveAckBit (false);
      master.ReceiveByte();
      master.SendNackBit();
      master.SendStop();

      // show info for fourth message
      Console.WriteLine ("-----------------------------------------------------");
      Console.WriteLine ("Message (4): read one data byte from 0x50 (100 kHz)");
      ShowTiming (master);

      // create fifth message: send 256 data bytes to 0x50 containing spikes
      master.Bitrate = 100000;
      master.CreateSpikes = true;
      master.SendTransmitter(addr, data);
      master.CreateSpikes = false;

      // show info for fifth message
      Console.WriteLine("-----------------------------------------------------");
      Console.WriteLine("Message (5): send 256 data bytes to 0x50 containing");
      Console.WriteLine("             spikes (100 kHz)");
      Console.WriteLine("-----------------------------------------------------");

      // create sixth message: send 256 data bytes to 0x50 using high-speed mode
      master.Bitrate = 100000;
      master.BitrateHighSpeed = 1000000;
      master.SendTransmitterHighSpeed(addr, data);

      // show info for sixth message
      Console.WriteLine("-----------------------------------------------------");
      Console.WriteLine("Message (6): send 256 data bytes to 0x50 using");
      Console.WriteLine("             high-speed mode (1 MHz)");
      Console.WriteLine("-----------------------------------------------------");

      // register callback function, which gets called after the
      // messages have been transfered
      board.NegativeTester.Completion += new EventHandler<NegativeTester.CompletionEventArgs>(NegativeTesterCompletion);

      m_finished = false;

      // start negative tester
      board.NegativeTester.StartMaster (master.GetMessages());

      // wait till the tester has finished
      while (m_finished == false)
        board.WaitForData (TimeSpan.FromSeconds (10));
    }

    /***********************************************************************/
    /// <summary>
    /// <para>
    /// Demonstrates how to create slave messages for the negative
    /// tester using the <see cref="NegativeTesterSlave"/> class.
    /// </para><para>
    /// Creates two I2C messages, sends them to the negative tester and
    /// waits until the tester has transferred all messages.
    /// </para>
    /// </summary>
    /***********************************************************************/

    public void NegativeTesterSlave (Board board)
    {
      NegativeTesterSlave  slave;
      List<byte>           data;

      slave = new NegativeTesterSlave();

      // listen to I2C address 0x60
      slave.SlaveAddress = 0x60 << 1;

      // set don't care mask of the I2C address
      slave.SlaveAddressMask = 0xfe;

      // disable loop mode
      slave.LoopMode = false;

      // create container of 256 data bytes
      data = new List<byte>();
      for (int i = 0; i < 256; i++)
        data.Add((byte)i);

      // expect up to 100 data byte from the master transmitter
      slave.CreateReceiver(100);

      // stretch low of SCL to 20 us
      slave.Stretching = NegativeTester.ConvertNanosecondsToTicks(20000);

      // send up to 256 byte to the master receiver
      slave.CreateTransmitter(data);

      // register callback function, which gets called after the
      // messages have been transfered
      board.NegativeTester.Completion += new EventHandler<NegativeTester.CompletionEventArgs>(NegativeTesterCompletion);

      m_finished = false;

      // start negative tester
      board.NegativeTester.StartSlave(slave.GetMessages());

      // wait till the tester has finished
      while (m_finished == false)
        board.WaitForData(TimeSpan.FromSeconds(10));
    }

    private bool m_finished;
  };

  class MyClass
  {
    [STAThread]
    static void Main(string[] args)
    {
      Board               board = null;
      List<HardwareInfo>  hwinfo;
      I2c                 i2c;

      try
      {
        // Open the first available I2C interface.
        board = new Board();

        // Get the description of all available I2C interfaces.
        hwinfo = board.ListOfBoards;

        // Open the first I2C interface supporting the negative
        // tester mode.
        foreach (HardwareInfo hwinfo_item in hwinfo)
        {
          if (hwinfo_item.NegativeTester == true)
          {
            board.Open(hwinfo_item);
            break;
          }
        }
        if (board.IsOpen == false)
        {
          Console.WriteLine("No I2C interface with negative tester support has been found.");
          return;
        }
        else
        {
          Console.WriteLine(string.Format("Using {0} [0x{1:X4}]",
                                          board.HardwareInfoOfOpenBoard.BoardType,
                                          board.HardwareInfoOfOpenBoard.SerialNumber));
        }

        // Start tests.
        i2c = new I2c();
        i2c.NegativeTesterMaster (board);
        // i2c.NegativeTesterSlave (board);

        // Close I2C interface.
        board.Close();
      }
      catch (System.Exception exp)
      {
        Console.WriteLine ("Error: " + exp.Message);
      }
      finally
      {
        // Free all resources allocated by the board object.
        // It is very important to call this method before the
        // garbage collector destroys the unused Board object.
        if (board != null)
          board.Dispose();
      }
    }
  }
}
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester Fields

NegativeTester Fields

The NegativeTester type exposes the following members.

Fields
Name | Description
TIMEBASE | timebase: 16 MHz
Top
See Also

Reference

NegativeTester Class


NegativeTester.TIMEBASE Field

NegativeTesterTIMEBASE Field
timebase: 16 MHz

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static readonly uint TIMEBASE
Public Shared ReadOnly TIMEBASE As UInteger
public:
static initonly unsigned int TIMEBASE
static val TIMEBASE: uint32

Field Value

Type: UInt32
See Also

Reference

NegativeTester Class


NegativeTester Methods

NegativeTester Methods

The NegativeTester type exposes the following members.

Methods
 | Name | Description
 | ConvertNanosecondsToTicks | Converts a time in nanoseconds to the ticks used by this class.
 | ConvertTicksToNanoseconds | Converts the ticks used by this class to a time in nanoseconds.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartMaster | Loads the given master messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterMaster.
Public method | StartSlave | Loads the given slave messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterSlave.
Public method | Stop | Stops the negative tester.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTester Class


NegativeTester.ConvertNanosecondsToTicks Method

NegativeTesterConvertNanosecondsToTicks Method
Converts a time in nanoseconds to the ticks used by this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static uint ConvertNanosecondsToTicks(
    ulong nanoseconds
)
Public Shared Function ConvertNanosecondsToTicks (
    nanoseconds As ULong
) As UInteger
public:
static unsigned int ConvertNanosecondsToTicks(
    unsigned long long nanoseconds
)
static member ConvertNanosecondsToTicks :
        nanoseconds : uint64 -> uint32

Parameters

nanoseconds
Type: SystemUInt64
time [ns]

Return Value

Type: UInt32
ticks
See Also

Reference

NegativeTester Class


NegativeTester.ConvertTicksToNanoseconds Method

NegativeTesterConvertTicksToNanoseconds Method
Converts the ticks used by this class to a time in nanoseconds.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static ulong ConvertTicksToNanoseconds(
    uint ticks
)
Public Shared Function ConvertTicksToNanoseconds (
    ticks As UInteger
) As ULong
public:
static unsigned long long ConvertTicksToNanoseconds(
    unsigned int ticks
)
static member ConvertTicksToNanoseconds :
        ticks : uint32 -> uint64

Parameters

ticks
Type: SystemUInt32
ticks

Return Value

Type: UInt64
time [ns]
See Also

Reference

NegativeTester Class


NegativeTester.Dispose Method

NegativeTesterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

NegativeTester Class


NegativeTester.Dispose Method

NegativeTesterDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NegativeTester Class
Dispose Overload


NegativeTester.Dispose Method (Boolean)

NegativeTesterDispose Method (Boolean)
Releases the unmanaged resources used by the NegativeTester and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.NegativeTester.Dispose(System.Boolean)"]

See Also

Reference

NegativeTester Class
Dispose Overload


NegativeTester.StartMaster Method

NegativeTesterStartMaster Method
Loads the given master messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterMaster.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void StartMaster(
    NegativeTesterMessagesMaster msgs
)
Public Sub StartMaster (
    msgs As NegativeTesterMessagesMaster
)
public:
void StartMaster(
    NegativeTesterMessagesMaster^ msgs
)
member StartMaster :
        msgs : NegativeTesterMessagesMaster -> unit

Parameters

msgs
Type: telos.I2cApi.DotNetNegativeTesterMessagesMaster
messages to be sent
Remarks
While the negative tester is running, IsRunning returns "true".
See Also

Reference

NegativeTester Class


NegativeTester.StartSlave Method

NegativeTesterStartSlave Method
Loads the given slave messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like NegativeTesterSlave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void StartSlave(
    NegativeTesterMessagesSlave msgs
)
Public Sub StartSlave (
    msgs As NegativeTesterMessagesSlave
)
public:
void StartSlave(
    NegativeTesterMessagesSlave^ msgs
)
member StartSlave :
        msgs : NegativeTesterMessagesSlave -> unit

Parameters

msgs
Type: telos.I2cApi.DotNetNegativeTesterMessagesSlave
messages to be sent
Remarks
While the negative tester is running, IsRunning returns "true".
See Also

Reference

NegativeTester Class


NegativeTester.Stop Method

NegativeTesterStop Method
Stops the negative tester.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Stop(
    bool stop_immediately
)
Public Sub Stop (
    stop_immediately As Boolean
)
public:
void Stop(
    bool stop_immediately
)
member Stop :
        stop_immediately : bool -> unit

Parameters

stop_immediately
Type: SystemBoolean
stop immediately
Remarks

If stop_immediately is set to "true", the negative tester stops immediately. Afterwards the I2C bus and its slave can be in an undefined state.

If it is set to "false", the negative tester stops after the current iteration of the image. This is only useful, if the the image gets executed in loop mode.

See Also

Reference

NegativeTester Class


NegativeTester Properties

NegativeTester Properties

The NegativeTester type exposes the following members.

Properties
 | Name | Description
Public property | IsRunning | Returns whether the negative tester is currently running.
Top
See Also

Reference

NegativeTester Class


NegativeTester.IsRunning Property

NegativeTesterIsRunning Property
Returns whether the negative tester is currently running.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
public:
property bool IsRunning {
    bool get ();
}
member IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

NegativeTester Class


NegativeTester Events

NegativeTester Events

The NegativeTester type exposes the following members.

Events
 | Name | Description
Public event | Completion | Completion event, which gets called when the negative testing is going from the running to the idle state.
Top
See Also

Reference

NegativeTester Class


NegativeTester.Completion Event

NegativeTesterCompletion Event
Completion event, which gets called when the negative testing is going from the running to the idle state.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NegativeTesterCompletionEventArgs> Completion
Public Event Completion As EventHandler(Of NegativeTesterCompletionEventArgs)
public:
 event EventHandler<NegativeTesterCompletionEventArgs^>^ Completion {
    void add (EventHandler<NegativeTesterCompletionEventArgs^>^ value);
    void remove (EventHandler<NegativeTesterCompletionEventArgs^>^ value);
}
member Completion : IEvent<EventHandler<NegativeTesterCompletionEventArgs>,
    NegativeTesterCompletionEventArgs>

Value

Type: SystemEventHandler NegativeTesterCompletionEventArgs
See Also

Reference

NegativeTester Class


NegativeTester.CompletionEventArgs Class

NegativeTesterCompletionEventArgs Class
Event arguments used for the Completion event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
telos.I2cApi.DotNetNegativeTesterCompletionEventArgs

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class CompletionEventArgs : EventArgs
Public Class CompletionEventArgs
    Inherits EventArgs
public ref class CompletionEventArgs : public EventArgs
type CompletionEventArgs =
    class
        inherit EventArgs
    end

The NegativeTesterCompletionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterCompletionEventArgs | Initializes a new instance of the NegativeTesterCompletionEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Result | result
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.CompletionEventArgs Constructor

NegativeTesterCompletionEventArgs Constructor
Initializes a new instance of the NegativeTesterCompletionEventArgs class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public CompletionEventArgs()
Public Sub New
public:
CompletionEventArgs()
new : unit -> CompletionEventArgs
See Also

Reference

NegativeTesterCompletionEventArgs Class


CompletionEventArgs Methods

CompletionEventArgs Methods

The NegativeTesterCompletionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTesterCompletionEventArgs Class


CompletionEventArgs Properties

CompletionEventArgs Properties

The NegativeTesterCompletionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Result | result
Top
See Also

Reference

NegativeTesterCompletionEventArgs Class


NegativeTester.CompletionEventArgs.Result Property

NegativeTesterCompletionEventArgsResult Property
result

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterEResult Result { get; set; }
Public Property Result As NegativeTesterEResult
    Get
    Set
public:
property NegativeTesterEResult Result {
    NegativeTesterEResult get ();
    void set (NegativeTesterEResult value);
}
member Result : NegativeTesterEResult with get, set

Property Value

Type: NegativeTesterEResult
See Also

Reference

NegativeTesterCompletionEventArgs Class


NegativeTester.ENackBehaviour Enumeration

NegativeTesterENackBehaviour Enumeration
Enumeration to specify the behaviour after receiving a NACK on the I2C bus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum ENackBehaviour
Public Enumeration ENackBehaviour
public enum class ENackBehaviour
type ENackBehaviour
Members
Member name | Value | Description
NACK_RELEASE_SCL_SDA | 0 | no action, release SCL and SDA
NACK_GENERATE_STOP | 1 | generate a STOP condition with static timing
NACK_RESTART | 2 | release SCL and SDA and restart the negative tester script
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.EResult Enumeration

NegativeTesterEResult Enumeration
Enumeration to specify the result when the program of the negative tester has been finished.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum EResult
Public Enumeration EResult
public enum class EResult
type EResult
Members
Member name | Value | Description
RESULT_OK | 0 | no errors
RESULT_ARBITRATION_LOST | 1 | arbitration lost
RESULT_NACK | 2 | received NACK from slave
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.EStopTrigger Enumeration

NegativeTesterEStopTrigger Enumeration
Enumeration to specify trigger, which can stop the negative tester.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum EStopTrigger
Public Enumeration EStopTrigger
public enum class EStopTrigger
type EStopTrigger
Members
Member name | Value | Description
STOP_TRIGGER_NONE | 0 | nothing stops the negative tester
STOP_TRIGGER_ARBITRATION_LOST | 1 | the negative tester stops when loosing the arbitration
STOP_TRIGGER_ARBITRATION_NOT_LOST | 2 | the negative tester stops when not loosing the arbitration
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.LevelsMaster Class

NegativeTesterLevelsMaster Class
Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the master mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next NegativeTesterLevelsMaster packet.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetNegativeTesterLevelsMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LevelsMaster
Public NotInheritable Class LevelsMaster
public ref class LevelsMaster sealed
[<SealedAttribute>]
type LevelsMaster =  class end

The NegativeTesterLevelsMaster type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterLevelsMaster | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DriveSda | SDA line is driven by: master (true), slave (slave)
Public property | EnableHighSpeedCurrentSource | enable the current source of the I2C high-speed mode
Public property | IgnoreStretching | ignore clock (SCL) stretching
Public property | Scl | level of the SCL line: high (true), low (false)
Public property | Sda | level of the SDA line: high (true), low (false)
Public property | StopTrigger | specifies the condition which can stop the negative tester
Public property | Testpin1 | level of the testpin1 line: high (true), low (false)
Public property | Testpin2 | level of the testpin1 line: high (true), low (false)
Public property | Time | time to wait before executing next transition (see TIMEBASE for the timebase)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.LevelsMaster Constructor

NegativeTesterLevelsMaster Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public LevelsMaster()
Public Sub New
public:
LevelsMaster()
new : unit -> LevelsMaster
See Also

Reference

NegativeTesterLevelsMaster Class


LevelsMaster Methods

LevelsMaster Methods

The NegativeTesterLevelsMaster type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTesterLevelsMaster Class


LevelsMaster Properties

LevelsMaster Properties

The NegativeTesterLevelsMaster type exposes the following members.

Properties
 | Name | Description
Public property | DriveSda | SDA line is driven by: master (true), slave (slave)
Public property | EnableHighSpeedCurrentSource | enable the current source of the I2C high-speed mode
Public property | IgnoreStretching | ignore clock (SCL) stretching
Public property | Scl | level of the SCL line: high (true), low (false)
Public property | Sda | level of the SDA line: high (true), low (false)
Public property | StopTrigger | specifies the condition which can stop the negative tester
Public property | Testpin1 | level of the testpin1 line: high (true), low (false)
Public property | Testpin2 | level of the testpin1 line: high (true), low (false)
Public property | Time | time to wait before executing next transition (see TIMEBASE for the timebase)
Top
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.DriveSda Property

NegativeTesterLevelsMasterDriveSda Property
SDA line is driven by: master (true), slave (slave)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DriveSda { get; set; }
Public Property DriveSda As Boolean
    Get
    Set
public:
property bool DriveSda {
    bool get ();
    void set (bool value);
}
member DriveSda : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.EnableHighSpeedCurrentSource Property

NegativeTesterLevelsMasterEnableHighSpeedCurrentSource Property
enable the current source of the I2C high-speed mode

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool EnableHighSpeedCurrentSource { get; set; }
Public Property EnableHighSpeedCurrentSource As Boolean
    Get
    Set
public:
property bool EnableHighSpeedCurrentSource {
    bool get ();
    void set (bool value);
}
member EnableHighSpeedCurrentSource : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.IgnoreStretching Property

NegativeTesterLevelsMasterIgnoreStretching Property
ignore clock (SCL) stretching

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreStretching { get; set; }
Public Property IgnoreStretching As Boolean
    Get
    Set
public:
property bool IgnoreStretching {
    bool get ();
    void set (bool value);
}
member IgnoreStretching : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.Scl Property

NegativeTesterLevelsMasterScl Property
level of the SCL line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Scl { get; set; }
Public Property Scl As Boolean
    Get
    Set
public:
property bool Scl {
    bool get ();
    void set (bool value);
}
member Scl : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.Sda Property

NegativeTesterLevelsMasterSda Property
level of the SDA line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Sda { get; set; }
Public Property Sda As Boolean
    Get
    Set
public:
property bool Sda {
    bool get ();
    void set (bool value);
}
member Sda : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.StopTrigger Property

NegativeTesterLevelsMasterStopTrigger Property
specifies the condition which can stop the negative tester

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterEStopTrigger StopTrigger { get; set; }
Public Property StopTrigger As NegativeTesterEStopTrigger
    Get
    Set
public:
property NegativeTesterEStopTrigger StopTrigger {
    NegativeTesterEStopTrigger get ();
    void set (NegativeTesterEStopTrigger value);
}
member StopTrigger : NegativeTesterEStopTrigger with get, set

Property Value

Type: NegativeTesterEStopTrigger
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.Testpin1 Property

NegativeTesterLevelsMasterTestpin1 Property
level of the testpin1 line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin1 { get; set; }
Public Property Testpin1 As Boolean
    Get
    Set
public:
property bool Testpin1 {
    bool get ();
    void set (bool value);
}
member Testpin1 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.Testpin2 Property

NegativeTesterLevelsMasterTestpin2 Property
level of the testpin1 line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin2 { get; set; }
Public Property Testpin2 As Boolean
    Get
    Set
public:
property bool Testpin2 {
    bool get ();
    void set (bool value);
}
member Testpin2 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsMaster.Time Property

NegativeTesterLevelsMasterTime Property
time to wait before executing next transition (see TIMEBASE for the timebase)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Time { get; set; }
Public Property Time As UInteger
    Get
    Set
public:
property unsigned int Time {
    unsigned int get ();
    void set (unsigned int value);
}
member Time : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterLevelsMaster Class


NegativeTester.LevelsSlave Class

NegativeTesterLevelsSlave Class
Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the slave mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next NegativeTesterLevelsSlave packet.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetNegativeTesterLevelsSlave

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class LevelsSlave
Public NotInheritable Class LevelsSlave
public ref class LevelsSlave sealed
[<SealedAttribute>]
type LevelsSlave =  class end

The NegativeTesterLevelsSlave type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterLevelsSlave | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DriveSda | SDA line is driven by: slave (true), master (slave)
Public property | Scl | level of the SCL line: high (true), low (false)
Public property | Sda | level of the SDA line: high (true), low (false)
Public property | Testpin1 | level of the testpin1 line: high (true), low (false)
Public property | Testpin2 | level of the testpin1 line: high (true), low (false)
Public property | Time | time to wait before executing next transition (see TIMEBASE for the timebase)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.LevelsSlave Constructor

NegativeTesterLevelsSlave Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public LevelsSlave()
Public Sub New
public:
LevelsSlave()
new : unit -> LevelsSlave
See Also

Reference

NegativeTesterLevelsSlave Class


LevelsSlave Methods

LevelsSlave Methods

The NegativeTesterLevelsSlave type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTesterLevelsSlave Class


LevelsSlave Properties

LevelsSlave Properties

The NegativeTesterLevelsSlave type exposes the following members.

Properties
 | Name | Description
Public property | DriveSda | SDA line is driven by: slave (true), master (slave)
Public property | Scl | level of the SCL line: high (true), low (false)
Public property | Sda | level of the SDA line: high (true), low (false)
Public property | Testpin1 | level of the testpin1 line: high (true), low (false)
Public property | Testpin2 | level of the testpin1 line: high (true), low (false)
Public property | Time | time to wait before executing next transition (see TIMEBASE for the timebase)
Top
See Also

Reference

NegativeTesterLevelsSlave Class


NegativeTester.LevelsSlave.DriveSda Property

NegativeTesterLevelsSlaveDriveSda Property
SDA line is driven by: slave (true), master (slave)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool DriveSda { get; set; }
Public Property DriveSda As Boolean
    Get
    Set
public:
property bool DriveSda {
    bool get ();
    void set (bool value);
}
member DriveSda : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsSlave Class


NegativeTester.LevelsSlave.Scl Property

NegativeTesterLevelsSlaveScl Property
level of the SCL line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Scl { get; set; }
Public Property Scl As Boolean
    Get
    Set
public:
property bool Scl {
    bool get ();
    void set (bool value);
}
member Scl : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsSlave Class


NegativeTester.LevelsSlave.Sda Property

NegativeTesterLevelsSlaveSda Property
level of the SDA line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Sda { get; set; }
Public Property Sda As Boolean
    Get
    Set
public:
property bool Sda {
    bool get ();
    void set (bool value);
}
member Sda : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsSlave Class


NegativeTester.LevelsSlave.Testpin1 Property

NegativeTesterLevelsSlaveTestpin1 Property
level of the testpin1 line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin1 { get; set; }
Public Property Testpin1 As Boolean
    Get
    Set
public:
property bool Testpin1 {
    bool get ();
    void set (bool value);
}
member Testpin1 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsSlave Class


NegativeTester.LevelsSlave.Testpin2 Property

NegativeTesterLevelsSlaveTestpin2 Property
level of the testpin1 line: high (true), low (false)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin2 { get; set; }
Public Property Testpin2 As Boolean
    Get
    Set
public:
property bool Testpin2 {
    bool get ();
    void set (bool value);
}
member Testpin2 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterLevelsSlave Class


NegativeTester.LevelsSlave.Time Property

NegativeTesterLevelsSlaveTime Property
time to wait before executing next transition (see TIMEBASE for the timebase)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Time { get; set; }
Public Property Time As UInteger
    Get
    Set
public:
property unsigned int Time {
    unsigned int get ();
    void set (unsigned int value);
}
member Time : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterLevelsSlave Class


NegativeTester.MessageSlave Class

NegativeTesterMessageSlave Class
Contains the NegativeTesterLevelsSlave objects for one I2C submessage (from the START condition to the next STOP or REPEATED START condition).
Inheritance Hierarchy
SystemObject
System.Collections.GenericList NegativeTesterLevelsSlave
telos.I2cApi.DotNetNegativeTesterMessageSlave

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MessageSlave : List<NegativeTesterLevelsSlave>
Public NotInheritable Class MessageSlave
    Inherits List(Of NegativeTesterLevelsSlave)
public ref class MessageSlave sealed : public List<NegativeTesterLevelsSlave^>
[<SealedAttribute>]
type MessageSlave =
    class
        inherit List<NegativeTesterLevelsSlave>
    end

The NegativeTesterMessageSlave type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterMessageSlave | Constructor.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List NegativeTesterLevelsSlave .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List NegativeTesterLevelsSlave .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List NegativeTesterLevelsSlave .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List NegativeTesterLevelsSlave .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.MessageSlave Constructor

NegativeTesterMessageSlave Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MessageSlave()
Public Sub New
public:
MessageSlave()
new : unit -> MessageSlave
See Also

Reference

NegativeTesterMessageSlave Class


MessageSlave Methods

MessageSlave Methods

The NegativeTesterMessageSlave type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List NegativeTesterLevelsSlave .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List NegativeTesterLevelsSlave .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List NegativeTesterLevelsSlave .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List NegativeTesterLevelsSlave .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List NegativeTesterLevelsSlave .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List NegativeTesterLevelsSlave .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List NegativeTesterLevelsSlave .)
Top
See Also

Reference

NegativeTesterMessageSlave Class


MessageSlave Properties

MessageSlave Properties

The NegativeTesterMessageSlave type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List NegativeTesterLevelsSlave .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List NegativeTesterLevelsSlave .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List NegativeTesterLevelsSlave .)
Top
See Also

Reference

NegativeTesterMessageSlave Class


NegativeTester.MessagesMaster Class

NegativeTesterMessagesMaster Class
Contains all information needed by the negative tester to work in master mode.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetNegativeTesterMessagesMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MessagesMaster
Public NotInheritable Class MessagesMaster
public ref class MessagesMaster sealed
[<SealedAttribute>]
type MessagesMaster =  class end

The NegativeTesterMessagesMaster type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterMessagesMaster | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsVhd | Returns the content of this object as VHDL stimuli (VHD).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Levels | levels to be sent to the I2C bus
Public property | LoopCnt | how often the levels get written to the I2C bus (0x400: infinite)
Public property | NackBehaviour | behaviour of the negative tester after receiving a NACK
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.MessagesMaster Constructor

NegativeTesterMessagesMaster Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MessagesMaster()
Public Sub New
public:
MessagesMaster()
new : unit -> MessagesMaster
See Also

Reference

NegativeTesterMessagesMaster Class


MessagesMaster Methods

MessagesMaster Methods

The NegativeTesterMessagesMaster type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsVhd | Returns the content of this object as VHDL stimuli (VHD).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTesterMessagesMaster Class


NegativeTester.MessagesMaster.GetAsVhd Method

NegativeTesterMessagesMasterGetAsVhd Method
Returns the content of this object as VHDL stimuli (VHD).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string GetAsVhd()
Public Function GetAsVhd As String
public:
String^ GetAsVhd()
member GetAsVhd : unit -> string

Return Value

Type: String
VHDL stimuli
See Also

Reference

NegativeTesterMessagesMaster Class


MessagesMaster Properties

MessagesMaster Properties

The NegativeTesterMessagesMaster type exposes the following members.

Properties
 | Name | Description
Public property | Levels | levels to be sent to the I2C bus
Public property | LoopCnt | how often the levels get written to the I2C bus (0x400: infinite)
Public property | NackBehaviour | behaviour of the negative tester after receiving a NACK
Top
See Also

Reference

NegativeTesterMessagesMaster Class


NegativeTester.MessagesMaster.Levels Property

NegativeTesterMessagesMasterLevels Property
levels to be sent to the I2C bus

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<NegativeTesterLevelsMaster> Levels { get; set; }
Public Property Levels As List(Of NegativeTesterLevelsMaster)
    Get
    Set
public:
property List<NegativeTesterLevelsMaster^>^ Levels {
    List<NegativeTesterLevelsMaster^>^ get ();
    void set (List<NegativeTesterLevelsMaster^>^ value);
}
member Levels : List<NegativeTesterLevelsMaster> with get, set

Property Value

Type: List NegativeTesterLevelsMaster
See Also

Reference

NegativeTesterMessagesMaster Class


NegativeTester.MessagesMaster.LoopCnt Property

NegativeTesterMessagesMasterLoopCnt Property
how often the levels get written to the I2C bus (0x400: infinite)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort LoopCnt { get; set; }
Public Property LoopCnt As UShort
    Get
    Set
public:
property unsigned short LoopCnt {
    unsigned short get ();
    void set (unsigned short value);
}
member LoopCnt : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

NegativeTesterMessagesMaster Class


NegativeTester.MessagesMaster.NackBehaviour Property

NegativeTesterMessagesMasterNackBehaviour Property
behaviour of the negative tester after receiving a NACK

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterENackBehaviour NackBehaviour { get; set; }
Public Property NackBehaviour As NegativeTesterENackBehaviour
    Get
    Set
public:
property NegativeTesterENackBehaviour NackBehaviour {
    NegativeTesterENackBehaviour get ();
    void set (NegativeTesterENackBehaviour value);
}
member NackBehaviour : NegativeTesterENackBehaviour with get, set

Property Value

Type: NegativeTesterENackBehaviour
See Also

Reference

NegativeTesterMessagesMaster Class


NegativeTester.MessagesSlave Class

NegativeTesterMessagesSlave Class
Contains all information needed by the negative tester to work in slave mode.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetNegativeTesterMessagesSlave

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class MessagesSlave
Public NotInheritable Class MessagesSlave
public ref class MessagesSlave sealed
[<SealedAttribute>]
type MessagesSlave =  class end

The NegativeTesterMessagesSlave type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterMessagesSlave | Constructor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Loop | loop mode?
Public property | Msgs | submessages to be sent to the I2C bus
Public property | RestartAfterNackOrStop | jump to the beginning of the first submessage after receiving a NACK or STOP?
Public property | SlaveAddr | I2C address and R/W bit of the emulated slave (8 bit format)
Public property | SlaveAddrDc | don't care mask for slave_addr
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTester.MessagesSlave Constructor

NegativeTesterMessagesSlave Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public MessagesSlave()
Public Sub New
public:
MessagesSlave()
new : unit -> MessagesSlave
See Also

Reference

NegativeTesterMessagesSlave Class


MessagesSlave Methods

MessagesSlave Methods

The NegativeTesterMessagesSlave type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTesterMessagesSlave Class


MessagesSlave Properties

MessagesSlave Properties

The NegativeTesterMessagesSlave type exposes the following members.

Properties
 | Name | Description
Public property | Loop | loop mode?
Public property | Msgs | submessages to be sent to the I2C bus
Public property | RestartAfterNackOrStop | jump to the beginning of the first submessage after receiving a NACK or STOP?
Public property | SlaveAddr | I2C address and R/W bit of the emulated slave (8 bit format)
Public property | SlaveAddrDc | don't care mask for slave_addr
Top
See Also

Reference

NegativeTesterMessagesSlave Class


NegativeTester.MessagesSlave.Loop Property

NegativeTesterMessagesSlaveLoop Property
loop mode?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Loop { get; set; }
Public Property Loop As Boolean
    Get
    Set
public:
property bool Loop {
    bool get ();
    void set (bool value);
}
member Loop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterMessagesSlave Class


NegativeTester.MessagesSlave.Msgs Property

NegativeTesterMessagesSlaveMsgs Property
submessages to be sent to the I2C bus

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<NegativeTesterMessageSlave> Msgs { get; set; }
Public Property Msgs As List(Of NegativeTesterMessageSlave)
    Get
    Set
public:
property List<NegativeTesterMessageSlave^>^ Msgs {
    List<NegativeTesterMessageSlave^>^ get ();
    void set (List<NegativeTesterMessageSlave^>^ value);
}
member Msgs : List<NegativeTesterMessageSlave> with get, set

Property Value

Type: List NegativeTesterMessageSlave
See Also

Reference

NegativeTesterMessagesSlave Class


NegativeTester.MessagesSlave.RestartAfterNackOrStop Property

NegativeTesterMessagesSlaveRestartAfterNackOrStop Property
jump to the beginning of the first submessage after receiving a NACK or STOP?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool RestartAfterNackOrStop { get; set; }
Public Property RestartAfterNackOrStop As Boolean
    Get
    Set
public:
property bool RestartAfterNackOrStop {
    bool get ();
    void set (bool value);
}
member RestartAfterNackOrStop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterMessagesSlave Class


NegativeTester.MessagesSlave.SlaveAddr Property

NegativeTesterMessagesSlaveSlaveAddr Property
I2C address and R/W bit of the emulated slave (8 bit format)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte SlaveAddr { get; set; }
Public Property SlaveAddr As Byte
    Get
    Set
public:
property unsigned char SlaveAddr {
    unsigned char get ();
    void set (unsigned char value);
}
member SlaveAddr : byte with get, set

Property Value

Type: Byte
See Also

Reference

NegativeTesterMessagesSlave Class


NegativeTester.MessagesSlave.SlaveAddrDc Property

NegativeTesterMessagesSlaveSlaveAddrDc Property
don't care mask for slave_addr

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte SlaveAddrDc { get; set; }
Public Property SlaveAddrDc As Byte
    Get
    Set
public:
property unsigned char SlaveAddrDc {
    unsigned char get ();
    void set (unsigned char value);
}
member SlaveAddrDc : byte with get, set

Property Value

Type: Byte
See Also

Reference

NegativeTesterMessagesSlave Class


NegativeTesterMaster Class

NegativeTesterMaster Class
This class offers a high-level master interface for the negative tester implemented in the NegativeTester class.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetNegativeTesterMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NegativeTesterMaster : IDisposable
Public NotInheritable Class NegativeTesterMaster
    Implements IDisposable
public ref class NegativeTesterMaster sealed : IDisposable
[<SealedAttribute>]
type NegativeTesterMaster =
    class
        interface IDisposable
    end

The NegativeTesterMaster type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterMaster | Constructor.
Top
Methods
 | Name | Description
Public method | Clear | Clears the stored transitions and messages.
Public method | Delay | Waits for the specified time. During this time the levels of the lines will not be changed. This can be used e.g. to add a gap between two transfers.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages | Returns the messages, which have been created using the "Send" and "Receive" methods of this class. This data can be passed to a NegativeTester instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReceiveAckBit | Reads an ACK/NACK. It can be configured, whether the negative tester should stop after receiving a NACK.
Public method | ReceiveAckBitHighSpeed | Reads an ACK/NACK (high-speed mode). It can be configured, whether the negative tester should stop after receiving a NACK.
Public method | ReceiveBit | Reads a data bit.
Public method | ReceiveBitHighSpeed | Reads a data bit (high-speed mode).
Public method | ReceiveByte | Reads a data byte.
Public method | ReceiveByteHighSpeed | Reads a data byte (high-speed mode).
Public method | SendAckBit | Sends an ACK.
Public method | SendAckBitHighSpeed | Sends an ACK (high-speed mode).
Public method | SendBit | Sends a data bit.
Public method | SendBitHighSpeed | Sends a data bit (high-speed mode).
Public method | SendByte | Sends a data byte.
Public method | SendByteHighSpeed | Sends a data byte (high-speed mode).
Public method | SendHighSpeedToken | Sends the high-speed token.
Public method | SendNackBit | Sends a NACK.
Public method | SendNackBitHighSpeed | Sends a NACK (high-speed mode).
Public method | SendPmbusMasterMessage(PmbusMasterMessage) | Sends a PMBus message to the I2C slave.
Public method | SendPmbusMasterMessage(PmbusMasterMessageGroupCmd) | Sends a PMBus message to the I2C slave.
Public method | SendReceiver | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave.
Public method | SendReceiverHighSpeed | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The I2C high-speed mode is used.
Public method | SendReceiverWithoutStop | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out.
Public method | SendReceiverWithoutStopHighSpeed | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out. The I2C high-speed mode is used.
Public method | SendRepeatedStart | Sends a repeated start condition.
Public method | SendRepeatedStartHighSpeed | Sends a repeated start condition (high-speed mode).
Public method | SendSmbMasterMessage | Sends a SMBus message to the I2C slave.
Public method | SendStart | Sends a start condition.
Public method | SendStop | Sends a stop condition.
Public method | SendStopHighSpeed | Sends a stop condition (high-speed mode).
Public method | SendTransmitter | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message.
Public method | SendTransmitterHighSpeed | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The I2C high-speed mode is used.
Public method | SendTransmitterReceiver | Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave.
Public method | SendTransmitterReceiverHighSpeed | Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave. The I2C high-speed mode is used.
Public method | SendTransmitterWithoutStop | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out.
Public method | SendTransmitterWithoutStopHighSpeed | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out. The I2C high-speed mode is used.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Bitrate | Sets/gets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.
Public property | BitrateHighSpeed | Sets/gets the I2C high-speed bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 1 MHz.
Public property | CreateSpikes | Configures whether spikes with a length of TimeSp should be added to the I2C messages.
Public property | HighSpeedToken | Configures the high-speed mode token (0x08, 0x0a, 0x0c, 0x0e).
Public property | IgnoreStretching | The detection of clock stretching in the hardware can be disabled. This property enables or disables the clock stretching support.
Public property | LoopCount | The loop count specifies how often the negative tester sends the NegativeTesterMessagesMaster data to the I2C bus. This property sets the loop count.
Public property | NackBehaviour | Configures the behaviour of the negative tester after receiving a NACK on the I2C bus.
Public property | StopAtArbitrationLost | Configures whether the negative tester stops after the detection of arbitration lost. If this property is set to "false", an arbitration lost gets ignored.
Public property | Testpin1 | Sets/gets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".
Public property | Testpin2 | Sets/gets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".
Public property | TimeBuf | Sets/gets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHdSta | Sets/gets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHigh | Sets/gets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedHdSta | Sets/gets the "hold time START condition" (t_HD;STA) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedHigh | Sets/gets the "HIGH period of the SCL clock" (t_HIGH) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedLowAfterHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) for I2C high-speed mode as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedLowBeforeHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) for I2C high-speed mode as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedSuSta | Sets/gets the "set-up time repeated START condition" (t_SU;STA) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedSuSto | Sets/gets the "set-up time for STOP condition" (t_SU;STO) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeLowAfterHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeLowBeforeHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeSp | Sets/gets the "pulse width of spikes" (t_SP) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically.
Public property | TimeSuSta | Sets/gets the "set-up time repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeSuSto | Sets/gets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Top
Remarks

Normally the following steps are necessary:

  1. Configure the interface:
    • Configure the bitrate using Bitrate.
    • Configure the behaviour regarding clock stretching using IgnoreStretching.
    • Configure the behaviour regarding arbitration using StopAtArbitrationLost.
    • Configure the loop counter using LoopCount.
    • Configure the NACK behaviour using NackBehaviour.
  2. Send conditions, bits, bytes, or even complete I2C messages using the "Send" and "Receive" methods.
  3. Create an object containing all transitions created by step two using GetMessages.
  4. Pass this object to the NegativeTester class.

START Condition: A START condition gets transmitted like this:

Copy
SDA  High    *-----

     Low           *-----*-----

SCL  High    *-----*-----

     Low                 *-----

             |--1--|--2--|--3--|
  1. t_BUF/2 as specified by TimeBuf.
  2. t_HD;STA as specified by TimeHdSta.
  3. t_LOW after t_HIGH as specified by TimeLowAfterHigh.

Repeated START Condition: A Repeated START condition gets transmitted like this:

Copy
SDA  High    *-----*-----

     Low                 *-----*-----

SCL  High          *-----*-----

     Low     *-----            *-----

             |--1--|--2--|--3--|--4--|
  1. t_LOW before t_HIGH as specified by TimeLowBeforeHigh.
  2. t_SU;STA as specified by TimeSuSta.
  3. t_HD;STA as specified by TimeHdSta.
  4. t_LOW after t_HIGH as specified by TimeLowAfterHigh.

STOP Condition: A STOP condition gets transmitted like this:

Copy
SDA  High                *-----

     Low     *-----*-----

SCL  High          *-----*-----

     Low     *-----

             |--1--|--2--|--3--|
  1. t_LOW before t_HIGH as specified by TimeLowBeforeHigh.
  2. t_SU;STO as specified by TimeSuSto.
  3. t_BUF/2 as specified by TimeBuf.

Data Bits: A data bit gets transmitted like this:

Copy
SDA  High    *-----*-----*-----           SDA  High

     Low                                       Low     *-----*-----*-----

SCL  High          *-----                 SCL  High          *-----

     Low     *-----      *-----                Low     *-----      *-----

             |--1--|--2--|--3--|                       |--1--|--2--|--3--|
  1. t_LOW before t_HIGH as specified by TimeLowBeforeHigh.
  2. t_HIGH as specified by TimeHigh.
  3. t_LOW after t_HIGH as specified by TimeLowAfterHigh.

The timebase of the times used by the negative tester is specified in TIMEBASE.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTesterMaster Constructor

NegativeTesterMaster Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterMaster()
Public Sub New
public:
NegativeTesterMaster()
new : unit -> NegativeTesterMaster
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster Methods

NegativeTesterMaster Methods

The NegativeTesterMaster type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the stored transitions and messages.
Public method | Delay | Waits for the specified time. During this time the levels of the lines will not be changed. This can be used e.g. to add a gap between two transfers.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages | Returns the messages, which have been created using the "Send" and "Receive" methods of this class. This data can be passed to a NegativeTester instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReceiveAckBit | Reads an ACK/NACK. It can be configured, whether the negative tester should stop after receiving a NACK.
Public method | ReceiveAckBitHighSpeed | Reads an ACK/NACK (high-speed mode). It can be configured, whether the negative tester should stop after receiving a NACK.
Public method | ReceiveBit | Reads a data bit.
Public method | ReceiveBitHighSpeed | Reads a data bit (high-speed mode).
Public method | ReceiveByte | Reads a data byte.
Public method | ReceiveByteHighSpeed | Reads a data byte (high-speed mode).
Public method | SendAckBit | Sends an ACK.
Public method | SendAckBitHighSpeed | Sends an ACK (high-speed mode).
Public method | SendBit | Sends a data bit.
Public method | SendBitHighSpeed | Sends a data bit (high-speed mode).
Public method | SendByte | Sends a data byte.
Public method | SendByteHighSpeed | Sends a data byte (high-speed mode).
Public method | SendHighSpeedToken | Sends the high-speed token.
Public method | SendNackBit | Sends a NACK.
Public method | SendNackBitHighSpeed | Sends a NACK (high-speed mode).
Public method | SendPmbusMasterMessage(PmbusMasterMessage) | Sends a PMBus message to the I2C slave.
Public method | SendPmbusMasterMessage(PmbusMasterMessageGroupCmd) | Sends a PMBus message to the I2C slave.
Public method | SendReceiver | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave.
Public method | SendReceiverHighSpeed | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The I2C high-speed mode is used.
Public method | SendReceiverWithoutStop | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out.
Public method | SendReceiverWithoutStopHighSpeed | Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out. The I2C high-speed mode is used.
Public method | SendRepeatedStart | Sends a repeated start condition.
Public method | SendRepeatedStartHighSpeed | Sends a repeated start condition (high-speed mode).
Public method | SendSmbMasterMessage | Sends a SMBus message to the I2C slave.
Public method | SendStart | Sends a start condition.
Public method | SendStop | Sends a stop condition.
Public method | SendStopHighSpeed | Sends a stop condition (high-speed mode).
Public method | SendTransmitter | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message.
Public method | SendTransmitterHighSpeed | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The I2C high-speed mode is used.
Public method | SendTransmitterReceiver | Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave.
Public method | SendTransmitterReceiverHighSpeed | Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave. The I2C high-speed mode is used.
Public method | SendTransmitterWithoutStop | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out.
Public method | SendTransmitterWithoutStopHighSpeed | Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out. The I2C high-speed mode is used.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.Clear Method

NegativeTesterMasterClear Method
Clears the stored transitions and messages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.Delay Method

NegativeTesterMasterDelay Method
Waits for the specified time. During this time the levels of the lines will not be changed. This can be used e.g. to add a gap between two transfers.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Delay(
    uint time
)
Public Sub Delay (
    time As UInteger
)
public:
void Delay(
    unsigned int time
)
member Delay :
        time : uint32 -> unit

Parameters

time
Type: SystemUInt32
time to delay
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.Dispose Method

NegativeTesterMasterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.Dispose Method

NegativeTesterMasterDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NegativeTesterMaster Class
Dispose Overload


NegativeTesterMaster.Dispose Method (Boolean)

NegativeTesterMasterDispose Method (Boolean)
Releases the unmanaged resources used by the NegativeTesterMaster and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.NegativeTesterMaster.Dispose(System.Boolean)"]

See Also

Reference

NegativeTesterMaster Class
Dispose Overload


NegativeTesterMaster.Finalize Method

NegativeTesterMasterFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.GetMessages Method

NegativeTesterMasterGetMessages Method
Returns the messages, which have been created using the "Send" and "Receive" methods of this class. This data can be passed to a NegativeTester instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterMessagesMaster GetMessages()
Public Function GetMessages As NegativeTesterMessagesMaster
public:
NegativeTesterMessagesMaster^ GetMessages()
member GetMessages : unit -> NegativeTesterMessagesMaster

Return Value

Type: NegativeTesterMessagesMaster
messages
Remarks
To reset the messages use the Clear method.
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.ReceiveAckBit Method

NegativeTesterMasterReceiveAckBit Method
Reads an ACK/NACK. It can be configured, whether the negative tester should stop after receiving a NACK.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReceiveAckBit(
    bool ignore_nack
)
Public Sub ReceiveAckBit (
    ignore_nack As Boolean
)
public:
void ReceiveAckBit(
    bool ignore_nack
)
member ReceiveAckBit :
        ignore_nack : bool -> unit

Parameters

ignore_nack
Type: SystemBoolean
stop after NACK (false), continue after NACK (true)
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.ReceiveAckBitHighSpeed Method

NegativeTesterMasterReceiveAckBitHighSpeed Method
Reads an ACK/NACK (high-speed mode). It can be configured, whether the negative tester should stop after receiving a NACK.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReceiveAckBitHighSpeed(
    bool ignore_nack
)
Public Sub ReceiveAckBitHighSpeed (
    ignore_nack As Boolean
)
public:
void ReceiveAckBitHighSpeed(
    bool ignore_nack
)
member ReceiveAckBitHighSpeed :
        ignore_nack : bool -> unit

Parameters

ignore_nack
Type: SystemBoolean
stop after NACK (false), continue after NACK (true)
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.ReceiveBit Method

NegativeTesterMasterReceiveBit Method
Reads a data bit.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReceiveBit()
Public Sub ReceiveBit
public:
void ReceiveBit()
member ReceiveBit : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.ReceiveBitHighSpeed Method

NegativeTesterMasterReceiveBitHighSpeed Method
Reads a data bit (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReceiveBitHighSpeed(
    bool enable_current_source
)
Public Sub ReceiveBitHighSpeed (
    enable_current_source As Boolean
)
public:
void ReceiveBitHighSpeed(
    bool enable_current_source
)
member ReceiveBitHighSpeed :
        enable_current_source : bool -> unit

Parameters

enable_current_source
Type: SystemBoolean
current source: enabled (true), disabled (false)
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.ReceiveByte Method

NegativeTesterMasterReceiveByte Method
Reads a data byte.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReceiveByte()
Public Sub ReceiveByte
public:
void ReceiveByte()
member ReceiveByte : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.ReceiveByteHighSpeed Method

NegativeTesterMasterReceiveByteHighSpeed Method
Reads a data byte (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ReceiveByteHighSpeed()
Public Sub ReceiveByteHighSpeed
public:
void ReceiveByteHighSpeed()
member ReceiveByteHighSpeed : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendAckBit Method

NegativeTesterMasterSendAckBit Method
Sends an ACK.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendAckBit()
Public Sub SendAckBit
public:
void SendAckBit()
member SendAckBit : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendAckBitHighSpeed Method

NegativeTesterMasterSendAckBitHighSpeed Method
Sends an ACK (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendAckBitHighSpeed()
Public Sub SendAckBitHighSpeed
public:
void SendAckBitHighSpeed()
member SendAckBitHighSpeed : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendBit Method

NegativeTesterMasterSendBit Method
Sends a data bit.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendBit(
    bool data
)
Public Sub SendBit (
    data As Boolean
)
public:
void SendBit(
    bool data
)
member SendBit :
        data : bool -> unit

Parameters

data
Type: SystemBoolean
data bit: 1 (true), 0 (false)
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendBitHighSpeed Method

NegativeTesterMasterSendBitHighSpeed Method
Sends a data bit (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendBitHighSpeed(
    bool data,
    bool enable_current_source
)
Public Sub SendBitHighSpeed (
    data As Boolean,
    enable_current_source As Boolean
)
public:
void SendBitHighSpeed(
    bool data,
    bool enable_current_source
)
member SendBitHighSpeed :
        data : bool *
        enable_current_source : bool -> unit

Parameters

data
Type: SystemBoolean
data bit: 1 (true), 0 (false)
enable_current_source
Type: SystemBoolean
current source: enabled (true), disabled (false)
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendByte Method

NegativeTesterMasterSendByte Method
Sends a data byte.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendByte(
    byte data
)
Public Sub SendByte (
    data As Byte
)
public:
void SendByte(
    unsigned char data
)
member SendByte :
        data : byte -> unit

Parameters

data
Type: SystemByte
data byte
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendByteHighSpeed Method

NegativeTesterMasterSendByteHighSpeed Method
Sends a data byte (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendByteHighSpeed(
    byte data
)
Public Sub SendByteHighSpeed (
    data As Byte
)
public:
void SendByteHighSpeed(
    unsigned char data
)
member SendByteHighSpeed :
        data : byte -> unit

Parameters

data
Type: SystemByte
data byte
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendHighSpeedToken Method

NegativeTesterMasterSendHighSpeedToken Method
Sends the high-speed token.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendHighSpeedToken()
Public Sub SendHighSpeedToken
public:
void SendHighSpeedToken()
member SendHighSpeedToken : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendNackBit Method

NegativeTesterMasterSendNackBit Method
Sends a NACK.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendNackBit()
Public Sub SendNackBit
public:
void SendNackBit()
member SendNackBit : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendNackBitHighSpeed Method

NegativeTesterMasterSendNackBitHighSpeed Method
Sends a NACK (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendNackBitHighSpeed()
Public Sub SendNackBitHighSpeed
public:
void SendNackBitHighSpeed()
member SendNackBitHighSpeed : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendPmbusMasterMessage Method

NegativeTesterMasterSendPmbusMasterMessage Method
Overload List
 | Name | Description
Public method | SendPmbusMasterMessage(PmbusMasterMessage) | Sends a PMBus message to the I2C slave.
Public method | SendPmbusMasterMessage(PmbusMasterMessageGroupCmd) | Sends a PMBus message to the I2C slave.
Top
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendPmbusMasterMessage Method (PmbusMasterMessage)

NegativeTesterMasterSendPmbusMasterMessage Method (PmbusMasterMessage)
Sends a PMBus message to the I2C slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendPmbusMasterMessage(
    PmbusMasterMessage msg
)
Public Sub SendPmbusMasterMessage (
    msg As PmbusMasterMessage
)
public:
void SendPmbusMasterMessage(
    PmbusMasterMessage^ msg
)
member SendPmbusMasterMessage :
        msg : PmbusMasterMessage -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessage
PMBus message
See Also

Reference

NegativeTesterMaster Class
SendPmbusMasterMessage Overload


NegativeTesterMaster.SendPmbusMasterMessage Method (PmbusMasterMessageGroupCmd)

NegativeTesterMasterSendPmbusMasterMessage Method (PmbusMasterMessageGroupCmd)
Sends a PMBus message to the I2C slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendPmbusMasterMessage(
    PmbusMasterMessageGroupCmd msg
)
Public Sub SendPmbusMasterMessage (
    msg As PmbusMasterMessageGroupCmd
)
public:
void SendPmbusMasterMessage(
    PmbusMasterMessageGroupCmd^ msg
)
member SendPmbusMasterMessage :
        msg : PmbusMasterMessageGroupCmd -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessageGroupCmd
PMBus message
See Also

Reference

NegativeTesterMaster Class
SendPmbusMasterMessage Overload


NegativeTesterMaster.SendReceiver Method

NegativeTesterMasterSendReceiver Method
Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendReceiver(
    I2cAddress addr,
    uint cnt
)
Public Sub SendReceiver (
    addr As I2cAddress,
    cnt As UInteger
)
public:
void SendReceiver(
    I2cAddress^ addr,
    unsigned int cnt
)
member SendReceiver :
        addr : I2cAddress *
        cnt : uint32 -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cnt
Type: SystemUInt32
number of bytes to be read
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendReceiverHighSpeed Method

NegativeTesterMasterSendReceiverHighSpeed Method
Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The I2C high-speed mode is used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendReceiverHighSpeed(
    I2cAddress addr,
    uint cnt
)
Public Sub SendReceiverHighSpeed (
    addr As I2cAddress,
    cnt As UInteger
)
public:
void SendReceiverHighSpeed(
    I2cAddress^ addr,
    unsigned int cnt
)
member SendReceiverHighSpeed :
        addr : I2cAddress *
        cnt : uint32 -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cnt
Type: SystemUInt32
number of bytes to be read
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendReceiverWithoutStop Method

NegativeTesterMasterSendReceiverWithoutStop Method
Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendReceiverWithoutStop(
    bool repeated_start,
    I2cAddress addr,
    uint cnt
)
Public Sub SendReceiverWithoutStop (
    repeated_start As Boolean,
    addr As I2cAddress,
    cnt As UInteger
)
public:
void SendReceiverWithoutStop(
    bool repeated_start,
    I2cAddress^ addr,
    unsigned int cnt
)
member SendReceiverWithoutStop :
        repeated_start : bool *
        addr : I2cAddress *
        cnt : uint32 -> unit

Parameters

repeated_start
Type: SystemBoolean
repeated start (true), normal start (false)
addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cnt
Type: SystemUInt32
number of bytes to be read
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendReceiverWithoutStopHighSpeed Method

NegativeTesterMasterSendReceiverWithoutStopHighSpeed Method
Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out. The I2C high-speed mode is used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendReceiverWithoutStopHighSpeed(
    bool repeated_start,
    I2cAddress addr,
    uint cnt
)
Public Sub SendReceiverWithoutStopHighSpeed (
    repeated_start As Boolean,
    addr As I2cAddress,
    cnt As UInteger
)
public:
void SendReceiverWithoutStopHighSpeed(
    bool repeated_start,
    I2cAddress^ addr,
    unsigned int cnt
)
member SendReceiverWithoutStopHighSpeed :
        repeated_start : bool *
        addr : I2cAddress *
        cnt : uint32 -> unit

Parameters

repeated_start
Type: SystemBoolean
repeated start (true), normal start (false)
addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cnt
Type: SystemUInt32
number of bytes to be read
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendRepeatedStart Method

NegativeTesterMasterSendRepeatedStart Method
Sends a repeated start condition.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendRepeatedStart()
Public Sub SendRepeatedStart
public:
void SendRepeatedStart()
member SendRepeatedStart : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendRepeatedStartHighSpeed Method

NegativeTesterMasterSendRepeatedStartHighSpeed Method
Sends a repeated start condition (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendRepeatedStartHighSpeed()
Public Sub SendRepeatedStartHighSpeed
public:
void SendRepeatedStartHighSpeed()
member SendRepeatedStartHighSpeed : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendSmbMasterMessage Method

NegativeTesterMasterSendSmbMasterMessage Method
Sends a SMBus message to the I2C slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendSmbMasterMessage(
    SmbMasterMessage msg
)
Public Sub SendSmbMasterMessage (
    msg As SmbMasterMessage
)
public:
void SendSmbMasterMessage(
    SmbMasterMessage^ msg
)
member SendSmbMasterMessage :
        msg : SmbMasterMessage -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessage
SMBus message
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendStart Method

NegativeTesterMasterSendStart Method
Sends a start condition.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendStart()
Public Sub SendStart
public:
void SendStart()
member SendStart : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendStop Method

NegativeTesterMasterSendStop Method
Sends a stop condition.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendStop()
Public Sub SendStop
public:
void SendStop()
member SendStop : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendStopHighSpeed Method

NegativeTesterMasterSendStopHighSpeed Method
Sends a stop condition (high-speed mode).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendStopHighSpeed()
Public Sub SendStopHighSpeed
public:
void SendStopHighSpeed()
member SendStopHighSpeed : unit -> unit
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendTransmitter Method

NegativeTesterMasterSendTransmitter Method
Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendTransmitter(
    I2cAddress addr,
    IEnumerable<byte> data
)
Public Sub SendTransmitter (
    addr As I2cAddress,
    data As IEnumerable(Of Byte)
)
public:
void SendTransmitter(
    I2cAddress^ addr,
    IEnumerable<unsigned char>^ data
)
member SendTransmitter :
        addr : I2cAddress *
        data : IEnumerable<byte> -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendTransmitterHighSpeed Method

NegativeTesterMasterSendTransmitterHighSpeed Method
Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The I2C high-speed mode is used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendTransmitterHighSpeed(
    I2cAddress addr,
    IEnumerable<byte> data
)
Public Sub SendTransmitterHighSpeed (
    addr As I2cAddress,
    data As IEnumerable(Of Byte)
)
public:
void SendTransmitterHighSpeed(
    I2cAddress^ addr,
    IEnumerable<unsigned char>^ data
)
member SendTransmitterHighSpeed :
        addr : I2cAddress *
        data : IEnumerable<byte> -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendTransmitterReceiver Method

NegativeTesterMasterSendTransmitterReceiver Method
Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendTransmitterReceiver(
    I2cAddress addr,
    IEnumerable<byte> tx_data,
    uint rx_cnt
)
Public Sub SendTransmitterReceiver (
    addr As I2cAddress,
    tx_data As IEnumerable(Of Byte),
    rx_cnt As UInteger
)
public:
void SendTransmitterReceiver(
    I2cAddress^ addr,
    IEnumerable<unsigned char>^ tx_data,
    unsigned int rx_cnt
)
member SendTransmitterReceiver :
        addr : I2cAddress *
        tx_data : IEnumerable<byte> *
        rx_cnt : uint32 -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
tx_data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
rx_cnt
Type: SystemUInt32
number of bytes to be read
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendTransmitterReceiverHighSpeed Method

NegativeTesterMasterSendTransmitterReceiverHighSpeed Method
Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave. The I2C high-speed mode is used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendTransmitterReceiverHighSpeed(
    I2cAddress addr,
    IEnumerable<byte> tx_data,
    uint rx_cnt
)
Public Sub SendTransmitterReceiverHighSpeed (
    addr As I2cAddress,
    tx_data As IEnumerable(Of Byte),
    rx_cnt As UInteger
)
public:
void SendTransmitterReceiverHighSpeed(
    I2cAddress^ addr,
    IEnumerable<unsigned char>^ tx_data,
    unsigned int rx_cnt
)
member SendTransmitterReceiverHighSpeed :
        addr : I2cAddress *
        tx_data : IEnumerable<byte> *
        rx_cnt : uint32 -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
tx_data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
rx_cnt
Type: SystemUInt32
number of bytes to be read
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendTransmitterWithoutStop Method

NegativeTesterMasterSendTransmitterWithoutStop Method
Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendTransmitterWithoutStop(
    bool repeated_start,
    I2cAddress addr,
    IEnumerable<byte> data
)
Public Sub SendTransmitterWithoutStop (
    repeated_start As Boolean,
    addr As I2cAddress,
    data As IEnumerable(Of Byte)
)
public:
void SendTransmitterWithoutStop(
    bool repeated_start,
    I2cAddress^ addr,
    IEnumerable<unsigned char>^ data
)
member SendTransmitterWithoutStop :
        repeated_start : bool *
        addr : I2cAddress *
        data : IEnumerable<byte> -> unit

Parameters

repeated_start
Type: SystemBoolean
repeated start (true), normal start (false)
addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.SendTransmitterWithoutStopHighSpeed Method

NegativeTesterMasterSendTransmitterWithoutStopHighSpeed Method
Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out. The I2C high-speed mode is used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SendTransmitterWithoutStopHighSpeed(
    bool repeated_start,
    I2cAddress addr,
    IEnumerable<byte> data
)
Public Sub SendTransmitterWithoutStopHighSpeed (
    repeated_start As Boolean,
    addr As I2cAddress,
    data As IEnumerable(Of Byte)
)
public:
void SendTransmitterWithoutStopHighSpeed(
    bool repeated_start,
    I2cAddress^ addr,
    IEnumerable<unsigned char>^ data
)
member SendTransmitterWithoutStopHighSpeed :
        repeated_start : bool *
        addr : I2cAddress *
        data : IEnumerable<byte> -> unit

Parameters

repeated_start
Type: SystemBoolean
repeated start (true), normal start (false)
addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster Properties

NegativeTesterMaster Properties

The NegativeTesterMaster type exposes the following members.

Properties
 | Name | Description
Public property | Bitrate | Sets/gets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.
Public property | BitrateHighSpeed | Sets/gets the I2C high-speed bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 1 MHz.
Public property | CreateSpikes | Configures whether spikes with a length of TimeSp should be added to the I2C messages.
Public property | HighSpeedToken | Configures the high-speed mode token (0x08, 0x0a, 0x0c, 0x0e).
Public property | IgnoreStretching | The detection of clock stretching in the hardware can be disabled. This property enables or disables the clock stretching support.
Public property | LoopCount | The loop count specifies how often the negative tester sends the NegativeTesterMessagesMaster data to the I2C bus. This property sets the loop count.
Public property | NackBehaviour | Configures the behaviour of the negative tester after receiving a NACK on the I2C bus.
Public property | StopAtArbitrationLost | Configures whether the negative tester stops after the detection of arbitration lost. If this property is set to "false", an arbitration lost gets ignored.
Public property | Testpin1 | Sets/gets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".
Public property | Testpin2 | Sets/gets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".
Public property | TimeBuf | Sets/gets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHdSta | Sets/gets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHigh | Sets/gets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedHdSta | Sets/gets the "hold time START condition" (t_HD;STA) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedHigh | Sets/gets the "HIGH period of the SCL clock" (t_HIGH) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedLowAfterHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) for I2C high-speed mode as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedLowBeforeHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) for I2C high-speed mode as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedSuSta | Sets/gets the "set-up time repeated START condition" (t_SU;STA) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeHighSpeedSuSto | Sets/gets the "set-up time for STOP condition" (t_SU;STO) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeLowAfterHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeLowBeforeHigh | Sets/gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeSp | Sets/gets the "pulse width of spikes" (t_SP) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically.
Public property | TimeSuSta | Sets/gets the "set-up time repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Public property | TimeSuSto | Sets/gets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.
Top
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.Bitrate Property

NegativeTesterMasterBitrate Property
Sets/gets the I2C bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Bitrate { get; set; }
Public Property Bitrate As UInteger
    Get
    Set
public:
property unsigned int Bitrate {
    unsigned int get ();
    void set (unsigned int value);
}
member Bitrate : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.BitrateHighSpeed Property

NegativeTesterMasterBitrateHighSpeed Property
Sets/gets the I2C high-speed bitrate (SCL) [Hz] used by the hardware, when the hardware generates the clock. The default bitrate is 1 MHz.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint BitrateHighSpeed { get; set; }
Public Property BitrateHighSpeed As UInteger
    Get
    Set
public:
property unsigned int BitrateHighSpeed {
    unsigned int get ();
    void set (unsigned int value);
}
member BitrateHighSpeed : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.CreateSpikes Property

NegativeTesterMasterCreateSpikes Property
Configures whether spikes with a length of TimeSp should be added to the I2C messages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool CreateSpikes { get; set; }
Public Property CreateSpikes As Boolean
    Get
    Set
public:
property bool CreateSpikes {
    bool get ();
    void set (bool value);
}
member CreateSpikes : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.HighSpeedToken Property

NegativeTesterMasterHighSpeedToken Property
Configures the high-speed mode token (0x08, 0x0a, 0x0c, 0x0e).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte HighSpeedToken { get; set; }
Public Property HighSpeedToken As Byte
    Get
    Set
public:
property unsigned char HighSpeedToken {
    unsigned char get ();
    void set (unsigned char value);
}
member HighSpeedToken : byte with get, set

Property Value

Type: Byte
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.IgnoreStretching Property

NegativeTesterMasterIgnoreStretching Property
The detection of clock stretching in the hardware can be disabled. This property enables or disables the clock stretching support.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreStretching { get; set; }
Public Property IgnoreStretching As Boolean
    Get
    Set
public:
property bool IgnoreStretching {
    bool get ();
    void set (bool value);
}
member IgnoreStretching : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.LoopCount Property

NegativeTesterMasterLoopCount Property
The loop count specifies how often the negative tester sends the NegativeTesterMessagesMaster data to the I2C bus. This property sets the loop count.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort LoopCount { get; set; }
Public Property LoopCount As UShort
    Get
    Set
public:
property unsigned short LoopCount {
    unsigned short get ();
    void set (unsigned short value);
}
member LoopCount : uint16 with get, set

Property Value

Type: UInt16
Remarks
Valid values are: 1 .. 1024. The value 1024 sets the loop to infinite.
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.NackBehaviour Property

NegativeTesterMasterNackBehaviour Property
Configures the behaviour of the negative tester after receiving a NACK on the I2C bus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterENackBehaviour NackBehaviour { get; set; }
Public Property NackBehaviour As NegativeTesterENackBehaviour
    Get
    Set
public:
property NegativeTesterENackBehaviour NackBehaviour {
    NegativeTesterENackBehaviour get ();
    void set (NegativeTesterENackBehaviour value);
}
member NackBehaviour : NegativeTesterENackBehaviour with get, set

Property Value

Type: NegativeTesterENackBehaviour
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.StopAtArbitrationLost Property

NegativeTesterMasterStopAtArbitrationLost Property
Configures whether the negative tester stops after the detection of arbitration lost. If this property is set to "false", an arbitration lost gets ignored.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool StopAtArbitrationLost { get; set; }
Public Property StopAtArbitrationLost As Boolean
    Get
    Set
public:
property bool StopAtArbitrationLost {
    bool get ();
    void set (bool value);
}
member StopAtArbitrationLost : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.Testpin1 Property

NegativeTesterMasterTestpin1 Property
Sets/gets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin1 { get; set; }
Public Property Testpin1 As Boolean
    Get
    Set
public:
property bool Testpin1 {
    bool get ();
    void set (bool value);
}
member Testpin1 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.Testpin2 Property

NegativeTesterMasterTestpin2 Property
Sets/gets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin2 { get; set; }
Public Property Testpin2 As Boolean
    Get
    Set
public:
property bool Testpin2 {
    bool get ();
    void set (bool value);
}
member Testpin2 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeBuf Property

NegativeTesterMasterTimeBuf Property
Sets/gets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeBuf { get; set; }
Public Property TimeBuf As UInteger
    Get
    Set
public:
property unsigned int TimeBuf {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeBuf : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHdSta Property

NegativeTesterMasterTimeHdSta Property
Sets/gets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHdSta { get; set; }
Public Property TimeHdSta As UInteger
    Get
    Set
public:
property unsigned int TimeHdSta {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHdSta : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHigh Property

NegativeTesterMasterTimeHigh Property
Sets/gets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHigh { get; set; }
Public Property TimeHigh As UInteger
    Get
    Set
public:
property unsigned int TimeHigh {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHigh : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHighSpeedHdSta Property

NegativeTesterMasterTimeHighSpeedHdSta Property
Sets/gets the "hold time START condition" (t_HD;STA) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHighSpeedHdSta { get; set; }
Public Property TimeHighSpeedHdSta As UInteger
    Get
    Set
public:
property unsigned int TimeHighSpeedHdSta {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHighSpeedHdSta : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHighSpeedHigh Property

NegativeTesterMasterTimeHighSpeedHigh Property
Sets/gets the "HIGH period of the SCL clock" (t_HIGH) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHighSpeedHigh { get; set; }
Public Property TimeHighSpeedHigh As UInteger
    Get
    Set
public:
property unsigned int TimeHighSpeedHigh {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHighSpeedHigh : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHighSpeedLowAfterHigh Property

NegativeTesterMasterTimeHighSpeedLowAfterHigh Property
Sets/gets the "LOW period of the SCL clock" (t_LOW) for I2C high-speed mode as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHighSpeedLowAfterHigh { get; set; }
Public Property TimeHighSpeedLowAfterHigh As UInteger
    Get
    Set
public:
property unsigned int TimeHighSpeedLowAfterHigh {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHighSpeedLowAfterHigh : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHighSpeedLowBeforeHigh Property

NegativeTesterMasterTimeHighSpeedLowBeforeHigh Property
Sets/gets the "LOW period of the SCL clock" (t_LOW) for I2C high-speed mode as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHighSpeedLowBeforeHigh { get; set; }
Public Property TimeHighSpeedLowBeforeHigh As UInteger
    Get
    Set
public:
property unsigned int TimeHighSpeedLowBeforeHigh {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHighSpeedLowBeforeHigh : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHighSpeedSuSta Property

NegativeTesterMasterTimeHighSpeedSuSta Property
Sets/gets the "set-up time repeated START condition" (t_SU;STA) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHighSpeedSuSta { get; set; }
Public Property TimeHighSpeedSuSta As UInteger
    Get
    Set
public:
property unsigned int TimeHighSpeedSuSta {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHighSpeedSuSta : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeHighSpeedSuSto Property

NegativeTesterMasterTimeHighSpeedSuSto Property
Sets/gets the "set-up time for STOP condition" (t_SU;STO) for I2C high-speed mode as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeHighSpeedSuSto { get; set; }
Public Property TimeHighSpeedSuSto As UInteger
    Get
    Set
public:
property unsigned int TimeHighSpeedSuSto {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeHighSpeedSuSto : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeLowAfterHigh Property

NegativeTesterMasterTimeLowAfterHigh Property
Sets/gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeLowAfterHigh { get; set; }
Public Property TimeLowAfterHigh As UInteger
    Get
    Set
public:
property unsigned int TimeLowAfterHigh {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeLowAfterHigh : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeLowBeforeHigh Property

NegativeTesterMasterTimeLowBeforeHigh Property
Sets/gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeLowBeforeHigh { get; set; }
Public Property TimeLowBeforeHigh As UInteger
    Get
    Set
public:
property unsigned int TimeLowBeforeHigh {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeLowBeforeHigh : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeSp Property

NegativeTesterMasterTimeSp Property
Sets/gets the "pulse width of spikes" (t_SP) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeSp { get; set; }
Public Property TimeSp As UInteger
    Get
    Set
public:
property unsigned int TimeSp {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeSp : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeSuSta Property

NegativeTesterMasterTimeSuSta Property
Sets/gets the "set-up time repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeSuSta { get; set; }
Public Property TimeSuSta As UInteger
    Get
    Set
public:
property unsigned int TimeSuSta {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeSuSta : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterMaster.TimeSuSto Property

NegativeTesterMasterTimeSuSto Property
Sets/gets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint TimeSuSto { get; set; }
Public Property TimeSuSto As UInteger
    Get
    Set
public:
property unsigned int TimeSuSto {
    unsigned int get ();
    void set (unsigned int value);
}
member TimeSuSto : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterMaster Class


NegativeTesterSlave Class

NegativeTesterSlave Class
This class offers a high-level slave interface for the negative tester implemented in the NegativeTester class.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetNegativeTesterSlave

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class NegativeTesterSlave : IDisposable
Public NotInheritable Class NegativeTesterSlave
    Implements IDisposable
public ref class NegativeTesterSlave sealed : IDisposable
[<SealedAttribute>]
type NegativeTesterSlave =
    class
        interface IDisposable
    end

The NegativeTesterSlave type exposes the following members.

Constructors
 | Name | Description
Public method | NegativeTesterSlave | Constructor.
Top
Methods
 | Name | Description
Public method | Clear | Clears the stored transitions and messages.
Public method | CreateReceiver | Create the transitions to transfer the specified number of bytes as slave receiver.
Public method | CreateReceiverAckBit | Creates the transitions to send an ACK as slave receiver.
Public method | CreateReceiverBit | Creates the transitions to transfer one data bit as slave receiver.
Public method | CreateReceiverByte | Creates the transitions to transfer one data byte as slave receiver.
Public method | CreateReceiverNackBit | Creates the transitions to send an NACK as slave receiver.
Public method | CreateStart | Creates the transitions to accept an I2C slave address and the following acknowledge.
Public method | CreateTransmitter | Create the transitions to transfer the specified data as slave transmitter.
Public method | CreateTransmitterAckBit | Creates the transitions to accept an ACK/NACK as slave transmitter.
Public method | CreateTransmitterBit | Creates the transitions to transfer one data bit as slave transmitter.
Public method | CreateTransmitterByte | Creates the transitions to transfer one data byte as slave transmitter.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages | Returns the submessages, which have been created using the "Create" methods of this class. This data can be passed to a NegativeTester instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | LoopMode | The loop mode specifies the behaviour of the negative tester after processing the last specified submessage. It can stop the negative tester or restart with the first specified submessage.
Public property | RestartAfterNackOrStop | If the negative tester detects a STOP condition on the I2C bus or sends a NACK as slave receiver, there are two possibilities on how to proceed: jump to the beginning of the first submessage or jump to the next submessage.
Public property | SlaveAddress | In the slave mode the negative tester is listening on an I2C slave address. This property sets/gets the I2C slave address.
Public property | SlaveAddressMask | It is possible the set a don't care mask for the I2C slave address configured by the SlaveAddress property. This property contains the don't care mask.
Public property | Stretching | Sets/gets the stretching time. The slave will stretch the low level part of SCL to this time for each bit.
Public property | Testpin1 | Sets/gets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".
Public property | Testpin2 | Sets/gets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".
Top
Remarks

Normally the following steps are necessary:

  1. Configure the interface:
    • Configure the behaviour regarding clock stretching using Stretching.
    • Set the I2C address of the emulated slave using SlaveAddress and SlaveAddressMask.
  2. Create the expected transfers using the "Create" methods.
  3. Create an object containing all transitions created by step two using GetMessages.
  4. Pass this object to the NegativeTester class.

The timebase of the times used by the negative tester is specified in TIMEBASE.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


NegativeTesterSlave Constructor

NegativeTesterSlave Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterSlave()
Public Sub New
public:
NegativeTesterSlave()
new : unit -> NegativeTesterSlave
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave Methods

NegativeTesterSlave Methods

The NegativeTesterSlave type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the stored transitions and messages.
Public method | CreateReceiver | Create the transitions to transfer the specified number of bytes as slave receiver.
Public method | CreateReceiverAckBit | Creates the transitions to send an ACK as slave receiver.
Public method | CreateReceiverBit | Creates the transitions to transfer one data bit as slave receiver.
Public method | CreateReceiverByte | Creates the transitions to transfer one data byte as slave receiver.
Public method | CreateReceiverNackBit | Creates the transitions to send an NACK as slave receiver.
Public method | CreateStart | Creates the transitions to accept an I2C slave address and the following acknowledge.
Public method | CreateTransmitter | Create the transitions to transfer the specified data as slave transmitter.
Public method | CreateTransmitterAckBit | Creates the transitions to accept an ACK/NACK as slave transmitter.
Public method | CreateTransmitterBit | Creates the transitions to transfer one data bit as slave transmitter.
Public method | CreateTransmitterByte | Creates the transitions to transfer one data byte as slave transmitter.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages | Returns the submessages, which have been created using the "Create" methods of this class. This data can be passed to a NegativeTester instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.Clear Method

NegativeTesterSlaveClear Method
Clears the stored transitions and messages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateReceiver Method

NegativeTesterSlaveCreateReceiver Method
Create the transitions to transfer the specified number of bytes as slave receiver.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateReceiver(
    uint cnt
)
Public Sub CreateReceiver (
    cnt As UInteger
)
public:
void CreateReceiver(
    unsigned int cnt
)
member CreateReceiver :
        cnt : uint32 -> unit

Parameters

cnt
Type: SystemUInt32
number of bytes to be transferred
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateReceiverAckBit Method

NegativeTesterSlaveCreateReceiverAckBit Method
Creates the transitions to send an ACK as slave receiver.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateReceiverAckBit()
Public Sub CreateReceiverAckBit
public:
void CreateReceiverAckBit()
member CreateReceiverAckBit : unit -> unit
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateReceiverBit Method

NegativeTesterSlaveCreateReceiverBit Method
Creates the transitions to transfer one data bit as slave receiver.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateReceiverBit()
Public Sub CreateReceiverBit
public:
void CreateReceiverBit()
member CreateReceiverBit : unit -> unit
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateReceiverByte Method

NegativeTesterSlaveCreateReceiverByte Method
Creates the transitions to transfer one data byte as slave receiver.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateReceiverByte()
Public Sub CreateReceiverByte
public:
void CreateReceiverByte()
member CreateReceiverByte : unit -> unit
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateReceiverNackBit Method

NegativeTesterSlaveCreateReceiverNackBit Method
Creates the transitions to send an NACK as slave receiver.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateReceiverNackBit()
Public Sub CreateReceiverNackBit
public:
void CreateReceiverNackBit()
member CreateReceiverNackBit : unit -> unit
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateStart Method

NegativeTesterSlaveCreateStart Method
Creates the transitions to accept an I2C slave address and the following acknowledge.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateStart()
Public Sub CreateStart
public:
void CreateStart()
member CreateStart : unit -> unit
Remarks
This method has to be used at positions, where a START condition, an I2C address, and an acknowledge are expected.
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateTransmitter Method

NegativeTesterSlaveCreateTransmitter Method
Create the transitions to transfer the specified data as slave transmitter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateTransmitter(
    IEnumerable<byte> data
)
Public Sub CreateTransmitter (
    data As IEnumerable(Of Byte)
)
public:
void CreateTransmitter(
    IEnumerable<unsigned char>^ data
)
member CreateTransmitter :
        data : IEnumerable<byte> -> unit

Parameters

data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateTransmitterAckBit Method

NegativeTesterSlaveCreateTransmitterAckBit Method
Creates the transitions to accept an ACK/NACK as slave transmitter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateTransmitterAckBit()
Public Sub CreateTransmitterAckBit
public:
void CreateTransmitterAckBit()
member CreateTransmitterAckBit : unit -> unit
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateTransmitterBit Method

NegativeTesterSlaveCreateTransmitterBit Method
Creates the transitions to transfer one data bit as slave transmitter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateTransmitterBit(
    bool data
)
Public Sub CreateTransmitterBit (
    data As Boolean
)
public:
void CreateTransmitterBit(
    bool data
)
member CreateTransmitterBit :
        data : bool -> unit

Parameters

data
Type: SystemBoolean
bit to be transmitted
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.CreateTransmitterByte Method

NegativeTesterSlaveCreateTransmitterByte Method
Creates the transitions to transfer one data byte as slave transmitter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void CreateTransmitterByte(
    byte data
)
Public Sub CreateTransmitterByte (
    data As Byte
)
public:
void CreateTransmitterByte(
    unsigned char data
)
member CreateTransmitterByte :
        data : byte -> unit

Parameters

data
Type: SystemByte
byte to be transmitted
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.Dispose Method

NegativeTesterSlaveDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.Dispose Method

NegativeTesterSlaveDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NegativeTesterSlave Class
Dispose Overload


NegativeTesterSlave.Dispose Method (Boolean)

NegativeTesterSlaveDispose Method (Boolean)
Releases the unmanaged resources used by the NegativeTesterSlave and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.NegativeTesterSlave.Dispose(System.Boolean)"]

See Also

Reference

NegativeTesterSlave Class
Dispose Overload


NegativeTesterSlave.Finalize Method

NegativeTesterSlaveFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.GetMessages Method

NegativeTesterSlaveGetMessages Method
Returns the submessages, which have been created using the "Create" methods of this class. This data can be passed to a NegativeTester instance.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public NegativeTesterMessagesSlave GetMessages()
Public Function GetMessages As NegativeTesterMessagesSlave
public:
NegativeTesterMessagesSlave^ GetMessages()
member GetMessages : unit -> NegativeTesterMessagesSlave

Return Value

Type: NegativeTesterMessagesSlave
submessages
Remarks
To reset the submessages use the Clear method.
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave Properties

NegativeTesterSlave Properties

The NegativeTesterSlave type exposes the following members.

Properties
 | Name | Description
Public property | LoopMode | The loop mode specifies the behaviour of the negative tester after processing the last specified submessage. It can stop the negative tester or restart with the first specified submessage.
Public property | RestartAfterNackOrStop | If the negative tester detects a STOP condition on the I2C bus or sends a NACK as slave receiver, there are two possibilities on how to proceed: jump to the beginning of the first submessage or jump to the next submessage.
Public property | SlaveAddress | In the slave mode the negative tester is listening on an I2C slave address. This property sets/gets the I2C slave address.
Public property | SlaveAddressMask | It is possible the set a don't care mask for the I2C slave address configured by the SlaveAddress property. This property contains the don't care mask.
Public property | Stretching | Sets/gets the stretching time. The slave will stretch the low level part of SCL to this time for each bit.
Public property | Testpin1 | Sets/gets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".
Public property | Testpin2 | Sets/gets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".
Top
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.LoopMode Property

NegativeTesterSlaveLoopMode Property
The loop mode specifies the behaviour of the negative tester after processing the last specified submessage. It can stop the negative tester or restart with the first specified submessage.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool LoopMode { get; set; }
Public Property LoopMode As Boolean
    Get
    Set
public:
property bool LoopMode {
    bool get ();
    void set (bool value);
}
member LoopMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.RestartAfterNackOrStop Property

NegativeTesterSlaveRestartAfterNackOrStop Property
If the negative tester detects a STOP condition on the I2C bus or sends a NACK as slave receiver, there are two possibilities on how to proceed: jump to the beginning of the first submessage or jump to the next submessage.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool RestartAfterNackOrStop { get; set; }
Public Property RestartAfterNackOrStop As Boolean
    Get
    Set
public:
property bool RestartAfterNackOrStop {
    bool get ();
    void set (bool value);
}
member RestartAfterNackOrStop : bool with get, set

Property Value

Type: Boolean
Remarks
If this property is set to "true", the negative tester jumps to the first submessage.
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.SlaveAddress Property

NegativeTesterSlaveSlaveAddress Property
In the slave mode the negative tester is listening on an I2C slave address. This property sets/gets the I2C slave address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte SlaveAddress { get; set; }
Public Property SlaveAddress As Byte
    Get
    Set
public:
property unsigned char SlaveAddress {
    unsigned char get ();
    void set (unsigned char value);
}
member SlaveAddress : byte with get, set

Property Value

Type: Byte
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.SlaveAddressMask Property

NegativeTesterSlaveSlaveAddressMask Property
It is possible the set a don't care mask for the I2C slave address configured by the SlaveAddress property. This property contains the don't care mask.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte SlaveAddressMask { get; set; }
Public Property SlaveAddressMask As Byte
    Get
    Set
public:
property unsigned char SlaveAddressMask {
    unsigned char get ();
    void set (unsigned char value);
}
member SlaveAddressMask : byte with get, set

Property Value

Type: Byte
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.Stretching Property

NegativeTesterSlaveStretching Property
Sets/gets the stretching time. The slave will stretch the low level part of SCL to this time for each bit.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Stretching { get; set; }
Public Property Stretching As UInteger
    Get
    Set
public:
property unsigned int Stretching {
    unsigned int get ();
    void set (unsigned int value);
}
member Stretching : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.Testpin1 Property

NegativeTesterSlaveTestpin1 Property
Sets/gets the state of testpin 1. The value "true" stands for "high", the value "false" for "low".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin1 { get; set; }
Public Property Testpin1 As Boolean
    Get
    Set
public:
property bool Testpin1 {
    bool get ();
    void set (bool value);
}
member Testpin1 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterSlave Class


NegativeTesterSlave.Testpin2 Property

NegativeTesterSlaveTestpin2 Property
Sets/gets the state of testpin 2. The value "true" stands for "high", the value "false" for "low".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Testpin2 { get; set; }
Public Property Testpin2 As Boolean
    Get
    Set
public:
property bool Testpin2 {
    bool get ();
    void set (bool value);
}
member Testpin2 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NegativeTesterSlave Class


ParsedTimestamp Class

ParsedTimestamp Class
Converts a given timestamp value into real time. The time gets splitted into values for days, hours, minutes, seconds, milliseconds, microseconds, and nanoseconds.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetParsedTimestamp

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ParsedTimestamp : ICloneable
Public NotInheritable Class ParsedTimestamp
    Implements ICloneable
public ref class ParsedTimestamp sealed : ICloneable
[<SealedAttribute>]
type ParsedTimestamp =
    class
        interface ICloneable
    end

The ParsedTimestamp type exposes the following members.

Constructors
 | Name | Description
Public method | ParsedTimestamp | Constructor: parses the given timestamp and stores the real time value in this class.
Top
Methods
 | Name | Description
Public method | Clone | Returns a new ParsedTimestamp object with the same values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTimestamp | Parses the given timestamp and stores the real time value in this class.
Public method | ToString | Returns the parsed timestamp as string (e.g. 7.32 ms). (Overrides ObjectToString.)
Public method | ToStringComplete | Returns the parsed timestamp as string (e.g. 3 s 20 ms 05 us 20 ns).
Public method | ToStringFrequency | Returns the corresponding frequency of the parsed timestamp as string (e.g. 7.32 kHz).
Public method | ToStringTimecode | Returns the parsed timestamp as string (e.g. 0 16:30:27.200.431).
Top
Properties
 | Name | Description
Public property | Days | Sets/gets the number of days.
Public property | Hours | Sets/gets the number of hours.
Public property | MicroSeconds | Sets/gets the number of microseconds.
Public property | MilliSeconds | Sets/gets the number of milliseconds.
Public property | Minutes | Sets/gets the number of minutes.
Public property | NanoSeconds | Sets/gets the number of nanoseconds.
Public property | Seconds | Sets/gets the number of seconds.
Public property | TimeSpan | Gets the timestamp as TimeSpan.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTimestamp Constructor

ParsedTimestamp Constructor
Constructor: parses the given timestamp and stores the real time value in this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTimestamp(
    ulong timestamp,
    uint timebase
)
Public Sub New (
    timestamp As ULong,
    timebase As UInteger
)
public:
ParsedTimestamp(
    unsigned long long timestamp,
    unsigned int timebase
)
new :
        timestamp : uint64 *
        timebase : uint32 -> ParsedTimestamp

Parameters

timestamp
Type: SystemUInt64
timestamp to be parsed
timebase
Type: SystemUInt32
timebase of the timestamp
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp Methods

ParsedTimestamp Methods

The ParsedTimestamp type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a new ParsedTimestamp object with the same values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTimestamp | Parses the given timestamp and stores the real time value in this class.
Public method | ToString | Returns the parsed timestamp as string (e.g. 7.32 ms). (Overrides ObjectToString.)
Public method | ToStringComplete | Returns the parsed timestamp as string (e.g. 3 s 20 ms 05 us 20 ns).
Public method | ToStringFrequency | Returns the corresponding frequency of the parsed timestamp as string (e.g. 7.32 kHz).
Public method | ToStringTimecode | Returns the parsed timestamp as string (e.g. 0 16:30:27.200.431).
Top
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.Clone Method

ParsedTimestampClone Method
Returns a new ParsedTimestamp object with the same values.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
new object

Implements

ICloneableClone
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.SetTimestamp Method

ParsedTimestampSetTimestamp Method
Parses the given timestamp and stores the real time value in this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetTimestamp(
    ulong timestamp,
    uint timebase
)
Public Sub SetTimestamp (
    timestamp As ULong,
    timebase As UInteger
)
public:
void SetTimestamp(
    unsigned long long timestamp,
    unsigned int timebase
)
member SetTimestamp :
        timestamp : uint64 *
        timebase : uint32 -> unit

Parameters

timestamp
Type: SystemUInt64
timestamp to be parsed
timebase
Type: SystemUInt32
timebase of the timestamp
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.ToString Method

ParsedTimestampToString Method
Returns the parsed timestamp as string (e.g. 7.32 ms).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
parsed timestamp
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.ToStringComplete Method

ParsedTimestampToStringComplete Method
Returns the parsed timestamp as string (e.g. 3 s 20 ms 05 us 20 ns).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToStringComplete(
    ParsedTimestampTimeResolution res
)
Public Function ToStringComplete (
    res As ParsedTimestampTimeResolution
) As String
public:
String^ ToStringComplete(
    ParsedTimestampTimeResolution res
)
member ToStringComplete :
        res : ParsedTimestampTimeResolution -> string

Parameters

res
Type: telos.I2cApi.DotNetParsedTimestampTimeResolution
resolution of the time

Return Value

Type: String
parsed timestamp
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.ToStringFrequency Method

ParsedTimestampToStringFrequency Method
Returns the corresponding frequency of the parsed timestamp as string (e.g. 7.32 kHz).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToStringFrequency()
Public Function ToStringFrequency As String
public:
String^ ToStringFrequency()
member ToStringFrequency : unit -> string

Return Value

Type: String
frequency
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.ToStringTimecode Method

ParsedTimestampToStringTimecode Method
Returns the parsed timestamp as string (e.g. 0 16:30:27.200.431).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string ToStringTimecode(
    ParsedTimestampTimeResolution res
)
Public Function ToStringTimecode (
    res As ParsedTimestampTimeResolution
) As String
public:
String^ ToStringTimecode(
    ParsedTimestampTimeResolution res
)
member ToStringTimecode :
        res : ParsedTimestampTimeResolution -> string

Parameters

res
Type: telos.I2cApi.DotNetParsedTimestampTimeResolution
resolution of the time

Return Value

Type: String
parsed timestamp
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp Properties

ParsedTimestamp Properties

The ParsedTimestamp type exposes the following members.

Properties
 | Name | Description
Public property | Days | Sets/gets the number of days.
Public property | Hours | Sets/gets the number of hours.
Public property | MicroSeconds | Sets/gets the number of microseconds.
Public property | MilliSeconds | Sets/gets the number of milliseconds.
Public property | Minutes | Sets/gets the number of minutes.
Public property | NanoSeconds | Sets/gets the number of nanoseconds.
Public property | Seconds | Sets/gets the number of seconds.
Public property | TimeSpan | Gets the timestamp as TimeSpan.
Top
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.Days Property

ParsedTimestampDays Property
Sets/gets the number of days.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Days { get; set; }
Public Property Days As UInteger
    Get
    Set
public:
property unsigned int Days {
    unsigned int get ();
    void set (unsigned int value);
}
member Days : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.Hours Property

ParsedTimestampHours Property
Sets/gets the number of hours.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Hours { get; set; }
Public Property Hours As UInteger
    Get
    Set
public:
property unsigned int Hours {
    unsigned int get ();
    void set (unsigned int value);
}
member Hours : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.MicroSeconds Property

ParsedTimestampMicroSeconds Property
Sets/gets the number of microseconds.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MicroSeconds { get; set; }
Public Property MicroSeconds As UInteger
    Get
    Set
public:
property unsigned int MicroSeconds {
    unsigned int get ();
    void set (unsigned int value);
}
member MicroSeconds : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.MilliSeconds Property

ParsedTimestampMilliSeconds Property
Sets/gets the number of milliseconds.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MilliSeconds { get; set; }
Public Property MilliSeconds As UInteger
    Get
    Set
public:
property unsigned int MilliSeconds {
    unsigned int get ();
    void set (unsigned int value);
}
member MilliSeconds : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.Minutes Property

ParsedTimestampMinutes Property
Sets/gets the number of minutes.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Minutes { get; set; }
Public Property Minutes As UInteger
    Get
    Set
public:
property unsigned int Minutes {
    unsigned int get ();
    void set (unsigned int value);
}
member Minutes : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.NanoSeconds Property

ParsedTimestampNanoSeconds Property
Sets/gets the number of nanoseconds.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint NanoSeconds { get; set; }
Public Property NanoSeconds As UInteger
    Get
    Set
public:
property unsigned int NanoSeconds {
    unsigned int get ();
    void set (unsigned int value);
}
member NanoSeconds : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.Seconds Property

ParsedTimestampSeconds Property
Sets/gets the number of seconds.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Seconds { get; set; }
Public Property Seconds As UInteger
    Get
    Set
public:
property unsigned int Seconds {
    unsigned int get ();
    void set (unsigned int value);
}
member Seconds : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.TimeSpan Property

ParsedTimestampTimeSpan Property
Gets the timestamp as TimeSpan.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TimeSpan TimeSpan { get; }
Public ReadOnly Property TimeSpan As TimeSpan
    Get
public:
property TimeSpan TimeSpan {
    TimeSpan get ();
}
member TimeSpan : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

ParsedTimestamp Class


ParsedTimestamp.TimeResolution Enumeration

ParsedTimestampTimeResolution Enumeration
Enumeration to specify the time resolution.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum TimeResolution
Public Enumeration TimeResolution
public enum class TimeResolution
type TimeResolution
Members
Member name | Value | Description
DAYS | 0 | days
HOURS | 1 | hours
MINUTES | 2 | minutes
SECONDS | 3 | seconds
MILLISECONDS | 4 | milliseconds
MICROSECONDS | 5 | microseconds
NANOSECONDS | 6 | nanoseconds
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceData Class

ParsedTraceData Class
This class is used to store the data of a normal submessage parsed by Parse(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetParsedTraceDataBase
telos.I2cApi.DotNetParsedTraceData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ParsedTraceData : ParsedTraceDataBase
Public NotInheritable Class ParsedTraceData
    Inherits ParsedTraceDataBase
public ref class ParsedTraceData sealed : public ParsedTraceDataBase
[<SealedAttribute>]
type ParsedTraceData =
    class
        inherit ParsedTraceDataBase
    end

The ParsedTraceData type exposes the following members.

Constructors
 | Name | Description
Public method | ParsedTraceData | Constructor.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides ParsedTraceDataBaseClone.)
Public method | Dispose | (Inherited from ParsedTraceDataBase.)
Protected method | Dispose(Boolean) | (Inherited from ParsedTraceDataBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Public property | AddressStatus | I2C address status
Public property | Data | data bytes of the message
Public property | Direction | direction: read/write
Public property | FirstDataByteIndex | index of the first data byte in the TracerMessageList
Public property | MaxTimestampDiff | maximum timestamp difference between two data bytes
Public property | MinTimestampDiff | minimum timestamp difference between two data bytes
Public property | NackPos | position of NACKs in the data list
Public property | NumberOfAckDataBytes | Gets the number of data bytes, which have been transmitted with an acknowledge.
Public property | Speed | speed
Public property | StartCond | START condition available
Public property | StartTimestamp | first timestamp of the message (Inherited from ParsedTraceDataBase.)
Public property | StopCond | STOP condition available
Public property | StopTimestamp | last timestamp of the message (Inherited from ParsedTraceDataBase.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceData Constructor

ParsedTraceData Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceData()
Public Sub New
public:
ParsedTraceData()
new : unit -> ParsedTraceData
See Also

Reference

ParsedTraceData Class


ParsedTraceData Methods

ParsedTraceData Methods

The ParsedTraceData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides ParsedTraceDataBaseClone.)
Public method | Dispose | (Inherited from ParsedTraceDataBase.)
Protected method | Dispose(Boolean) | (Inherited from ParsedTraceDataBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParsedTraceData Class


ParsedTraceData.Clone Method

ParsedTraceDataClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

ParsedTraceData Class


ParsedTraceData Properties

ParsedTraceData Properties

The ParsedTraceData type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Public property | AddressStatus | I2C address status
Public property | Data | data bytes of the message
Public property | Direction | direction: read/write
Public property | FirstDataByteIndex | index of the first data byte in the TracerMessageList
Public property | MaxTimestampDiff | maximum timestamp difference between two data bytes
Public property | MinTimestampDiff | minimum timestamp difference between two data bytes
Public property | NackPos | position of NACKs in the data list
Public property | NumberOfAckDataBytes | Gets the number of data bytes, which have been transmitted with an acknowledge.
Public property | Speed | speed
Public property | StartCond | START condition available
Public property | StartTimestamp | first timestamp of the message (Inherited from ParsedTraceDataBase.)
Public property | StopCond | STOP condition available
Public property | StopTimestamp | last timestamp of the message (Inherited from ParsedTraceDataBase.)
Top
See Also

Reference

ParsedTraceData Class


ParsedTraceData.Address Property

ParsedTraceDataAddress Property
I2C address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

ParsedTraceData Class


ParsedTraceData.AddressComplete Property

ParsedTraceDataAddressComplete Property
I2C address complete?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataI2cAddressComplete AddressComplete { get; set; }
Public Property AddressComplete As ParsedTraceDataI2cAddressComplete
    Get
    Set
public:
property ParsedTraceDataI2cAddressComplete AddressComplete {
    ParsedTraceDataI2cAddressComplete get ();
    void set (ParsedTraceDataI2cAddressComplete value);
}
member AddressComplete : ParsedTraceDataI2cAddressComplete with get, set

Property Value

Type: ParsedTraceDataI2cAddressComplete
See Also

Reference

ParsedTraceData Class


ParsedTraceData.AddressStatus Property

ParsedTraceDataAddressStatus Property
I2C address status

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataI2cAddressStatus AddressStatus { get; set; }
Public Property AddressStatus As ParsedTraceDataI2cAddressStatus
    Get
    Set
public:
property ParsedTraceDataI2cAddressStatus AddressStatus {
    ParsedTraceDataI2cAddressStatus get ();
    void set (ParsedTraceDataI2cAddressStatus value);
}
member AddressStatus : ParsedTraceDataI2cAddressStatus with get, set

Property Value

Type: ParsedTraceDataI2cAddressStatus
See Also

Reference

ParsedTraceData Class


ParsedTraceData.Data Property

ParsedTraceDataData Property
data bytes of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] Data { get; set; }
Public Property Data As Byte()
    Get
    Set
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Data : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ParsedTraceData Class


ParsedTraceData.Direction Property

ParsedTraceDataDirection Property
direction: read/write

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataDataDirection Direction { get; set; }
Public Property Direction As ParsedTraceDataDataDirection
    Get
    Set
public:
property ParsedTraceDataDataDirection Direction {
    ParsedTraceDataDataDirection get ();
    void set (ParsedTraceDataDataDirection value);
}
member Direction : ParsedTraceDataDataDirection with get, set

Property Value

Type: ParsedTraceDataDataDirection
See Also

Reference

ParsedTraceData Class


ParsedTraceData.FirstDataByteIndex Property

ParsedTraceDataFirstDataByteIndex Property
index of the first data byte in the TracerMessageList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int FirstDataByteIndex { get; set; }
Public Property FirstDataByteIndex As Integer
    Get
    Set
public:
property int FirstDataByteIndex {
    int get ();
    void set (int value);
}
member FirstDataByteIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ParsedTraceData Class


ParsedTraceData.MaxTimestampDiff Property

ParsedTraceDataMaxTimestampDiff Property
maximum timestamp difference between two data bytes

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MaxTimestampDiff { get; set; }
Public Property MaxTimestampDiff As ULong
    Get
    Set
public:
property unsigned long long MaxTimestampDiff {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MaxTimestampDiff : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

ParsedTraceData Class


ParsedTraceData.MinTimestampDiff Property

ParsedTraceDataMinTimestampDiff Property
minimum timestamp difference between two data bytes

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong MinTimestampDiff { get; set; }
Public Property MinTimestampDiff As ULong
    Get
    Set
public:
property unsigned long long MinTimestampDiff {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MinTimestampDiff : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

ParsedTraceData Class


ParsedTraceData.NackPos Property

ParsedTraceDataNackPos Property
position of NACKs in the data list

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] NackPos { get; set; }
Public Property NackPos As Integer()
    Get
    Set
public:
property array<int>^ NackPos {
    array<int>^ get ();
    void set (array<int>^ value);
}
member NackPos : int[] with get, set

Property Value

Type: Int32
See Also

Reference

ParsedTraceData Class


ParsedTraceData.NumberOfAckDataBytes Property

ParsedTraceDataNumberOfAckDataBytes Property
Gets the number of data bytes, which have been transmitted with an acknowledge.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int NumberOfAckDataBytes { get; }
Public ReadOnly Property NumberOfAckDataBytes As Integer
    Get
public:
property int NumberOfAckDataBytes {
    int get ();
}
member NumberOfAckDataBytes : int with get

Property Value

Type: Int32
See Also

Reference

ParsedTraceData Class


ParsedTraceData.Speed Property

ParsedTraceDataSpeed Property
speed

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataBusSpeed Speed { get; set; }
Public Property Speed As ParsedTraceDataBusSpeed
    Get
    Set
public:
property ParsedTraceDataBusSpeed Speed {
    ParsedTraceDataBusSpeed get ();
    void set (ParsedTraceDataBusSpeed value);
}
member Speed : ParsedTraceDataBusSpeed with get, set

Property Value

Type: ParsedTraceDataBusSpeed
See Also

Reference

ParsedTraceData Class


ParsedTraceData.StartCond Property

ParsedTraceDataStartCond Property
START condition available

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool StartCond { get; set; }
Public Property StartCond As Boolean
    Get
    Set
public:
property bool StartCond {
    bool get ();
    void set (bool value);
}
member StartCond : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ParsedTraceData Class


ParsedTraceData.StopCond Property

ParsedTraceDataStopCond Property
STOP condition available

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool StopCond { get; set; }
Public Property StopCond As Boolean
    Get
    Set
public:
property bool StopCond {
    bool get ();
    void set (bool value);
}
member StopCond : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ParsedTraceData Class


ParsedTraceData.BusSpeed Enumeration

ParsedTraceDataBusSpeed Enumeration
This enumeration is used to store the speed of an I2C transfer.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum BusSpeed
Public Enumeration BusSpeed
public enum class BusSpeed
type BusSpeed
Members
Member name | Value | Description
FULL_SPEED | 0 | full-speed
HIGH_SPEED | 1 | high-speed
UNKNOWN_SPEED | 2 | unknown
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceData.DataDirection Enumeration

ParsedTraceDataDataDirection Enumeration
This enumeration is used to store the direction of an I2C transfer.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum DataDirection
Public Enumeration DataDirection
public enum class DataDirection
type DataDirection
Members
Member name | Value | Description
DIRECTION_TX | 0 | transmit
DIRECTION_RX | 1 | receive
DIRECTION_UNKNOWN | 2 | unknown
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceData.I2cAddressComplete Enumeration

ParsedTraceDataI2cAddressComplete Enumeration
This enumeration is used to store whether all bytes of an I2C address are available.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum I2cAddressComplete
Public Enumeration I2cAddressComplete
public enum class I2cAddressComplete
type I2cAddressComplete
Members
Member name | Value | Description
I2C_ADDRESS_MISSING | 0 | I2C address is missing
I2C_ADDRESS_MISSING_10BIT_LSB | 1 | 2nd byte of a 10 bit I2C address is missing
I2C_ADDRESS_COMPLETE | 2 | I2C address is complete
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceData.I2cAddressStatus Enumeration

ParsedTraceDataI2cAddressStatus Enumeration
This enumeration is used to store the status of an I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum I2cAddressStatus
Public Enumeration I2cAddressStatus
public enum class I2cAddressStatus
type I2cAddressStatus
Members
Member name | Value | Description
I2C_ADDRESS_NOT_AVAILABLE | 0 | I2C address is not available
I2C_ADDRESS_NO_CONFIRMATION | 1 | I2C address without confirmation
I2C_ADDRESS_NACK | 2 | I2C address has not been acknowledged
I2C_ADDRESS_OK | 3 | I2C address has been acknowledged
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceDataBase Class

ParsedTraceDataBase Class
This base class is used to store the data of a submessage parsed by Parse(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetParsedTraceDataBase
telos.I2cApi.DotNetParsedTraceData
telos.I2cApi.DotNetParsedTraceDataError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ParsedTraceDataBase : ICloneable,
    IDisposable
Public MustInherit Class ParsedTraceDataBase
    Implements ICloneable, IDisposable
public ref class ParsedTraceDataBase abstract : ICloneable,
    IDisposable
[<AbstractClassAttribute>]
type ParsedTraceDataBase =
    class
        interface ICloneable
        interface IDisposable
    end

The ParsedTraceDataBase type exposes the following members.

Constructors
 | Name | Description
Public method | ParsedTraceDataBase | Initializes a new instance of the ParsedTraceDataBase class
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceDataBase Constructor

ParsedTraceDataBase Constructor
Initializes a new instance of the ParsedTraceDataBase class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataBase()
Public Sub New
public:
ParsedTraceDataBase()
new : unit -> ParsedTraceDataBase
See Also

Reference

ParsedTraceDataBase Class


ParsedTraceDataBase Methods

ParsedTraceDataBase Methods

The ParsedTraceDataBase type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParsedTraceDataBase Class


ParsedTraceDataBase.Clone Method

ParsedTraceDataBaseClone Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.ParsedTraceDataBase.Clone"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object
public:
virtual Object^ Clone() abstract
abstract Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.ParsedTraceDataBase.Clone"]

Implements

ICloneableClone
See Also

Reference

ParsedTraceDataBase Class


ParsedTraceDataBase.Dispose Method

ParsedTraceDataBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Top
See Also

Reference

ParsedTraceDataBase Class


ParsedTraceDataBase.Dispose Method

ParsedTraceDataBaseDispose Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.ParsedTraceDataBase.Dispose"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ParsedTraceDataBase Class
Dispose Overload


ParsedTraceDataBase.Dispose Method (Boolean)

ParsedTraceDataBaseDispose Method (Boolean)
Releases the unmanaged resources used by the ParsedTraceDataBase and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
)
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.ParsedTraceDataBase.Dispose(System.Boolean)"]

See Also

Reference

ParsedTraceDataBase Class
Dispose Overload


ParsedTraceDataBase Properties

ParsedTraceDataBase Properties

The ParsedTraceDataBase type exposes the following members.

Properties
 | Name | Description
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
See Also

Reference

ParsedTraceDataBase Class


ParsedTraceDataBase.StartTimestamp Property

ParsedTraceDataBaseStartTimestamp Property
first timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StartTimestamp { get; set; }
Public Property StartTimestamp As ULong
    Get
    Set
public:
property unsigned long long StartTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StartTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

ParsedTraceDataBase Class


ParsedTraceDataBase.StopTimestamp Property

ParsedTraceDataBaseStopTimestamp Property
last timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StopTimestamp { get; set; }
Public Property StopTimestamp As ULong
    Get
    Set
public:
property unsigned long long StopTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StopTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

ParsedTraceDataBase Class


ParsedTraceDataError Class

ParsedTraceDataError Class
This class is used to store the data of an error parsed by Parse(Int32).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetParsedTraceDataBase
telos.I2cApi.DotNetParsedTraceDataError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ParsedTraceDataError : ParsedTraceDataBase
Public NotInheritable Class ParsedTraceDataError
    Inherits ParsedTraceDataBase
public ref class ParsedTraceDataError sealed : public ParsedTraceDataBase
[<SealedAttribute>]
type ParsedTraceDataError =
    class
        inherit ParsedTraceDataBase
    end

The ParsedTraceDataError type exposes the following members.

Constructors
 | Name | Description
Public method | ParsedTraceDataError | Initializes a new instance of the ParsedTraceDataError class
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides ParsedTraceDataBaseClone.)
Public method | Dispose | (Inherited from ParsedTraceDataBase.)
Protected method | Dispose(Boolean) | (Inherited from ParsedTraceDataBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Error | type of the error
Public property | StartTimestamp | first timestamp of the message (Inherited from ParsedTraceDataBase.)
Public property | StopTimestamp | last timestamp of the message (Inherited from ParsedTraceDataBase.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTraceDataError Constructor

ParsedTraceDataError Constructor
Initializes a new instance of the ParsedTraceDataError class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataError()
Public Sub New
public:
ParsedTraceDataError()
new : unit -> ParsedTraceDataError
See Also

Reference

ParsedTraceDataError Class


ParsedTraceDataError Methods

ParsedTraceDataError Methods

The ParsedTraceDataError type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides ParsedTraceDataBaseClone.)
Public method | Dispose | (Inherited from ParsedTraceDataBase.)
Protected method | Dispose(Boolean) | (Inherited from ParsedTraceDataBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParsedTraceDataError Class


ParsedTraceDataError.Clone Method

ParsedTraceDataErrorClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

ParsedTraceDataError Class


ParsedTraceDataError Properties

ParsedTraceDataError Properties

The ParsedTraceDataError type exposes the following members.

Properties
 | Name | Description
Public property | Error | type of the error
Public property | StartTimestamp | first timestamp of the message (Inherited from ParsedTraceDataBase.)
Public property | StopTimestamp | last timestamp of the message (Inherited from ParsedTraceDataBase.)
Top
See Also

Reference

ParsedTraceDataError Class


ParsedTraceDataError.Error Property

ParsedTraceDataErrorError Property
type of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataErrorErrorType Error { get; set; }
Public Property Error As ParsedTraceDataErrorErrorType
    Get
    Set
public:
property ParsedTraceDataErrorErrorType Error {
    ParsedTraceDataErrorErrorType get ();
    void set (ParsedTraceDataErrorErrorType value);
}
member Error : ParsedTraceDataErrorErrorType with get, set

Property Value

Type: ParsedTraceDataErrorErrorType
See Also

Reference

ParsedTraceDataError Class


ParsedTraceDataError.ErrorType Enumeration

ParsedTraceDataErrorErrorType Enumeration
This enumeration is used to store the type of the error.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum ErrorType
Public Enumeration ErrorType
public enum class ErrorType
type ErrorType
Members
Member name | Value | Description
I2C_PROTOCOL_ERROR | 0 | I2C protocol error
SMB_POWER_ON | 1 | SMBus power on
SMB_POWER_OFF | 2 | SMBus power off
TRACER_RESTARTED | 3 | tracer restarted
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTracerMessageList Class

ParsedTracerMessageList Class
This class parses the elements of a TracerMessageList and returns the parsed I2C submessages to the caller. To improve the speed of the parser the class contains a cache, which stores a number of parsed submessages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetParsedTracerMessageList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ParsedTracerMessageList : IReadOnlyList<ParsedTraceDataBase>,
    IDisposable
Public NotInheritable Class ParsedTracerMessageList
    Implements IReadOnlyList(Of ParsedTraceDataBase), IDisposable
public ref class ParsedTracerMessageList sealed : IReadOnlyList<ParsedTraceDataBase^>,
    IDisposable
[<SealedAttribute>]
type ParsedTracerMessageList =
    class
        interface IReadOnlyList<ParsedTraceDataBase>
        interface IDisposable
    end

The ParsedTracerMessageList type exposes the following members.

Constructors
 | Name | Description
Public method | ParsedTracerMessageList | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCombinedIndexByTimestamp | Returns the combined index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, this method throws an ExceptionItemNotFound exception.
Public method | GetCompleteMessage | Returns the complete message (consisting of a number of submessages) specified by the index. The number of complete messages can be determined by using the CompleteMessageCount property.
Public method | GetCompleteMessageIndex(Int32) | This method searches the index of the first submessage of a complete message.
Public method | GetCompleteMessageIndex(Int32, Int32) | This method searches the index of the first submessage of a complete message.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, this method throws an ExceptionItemNotFound exception.
Public method | GetTracerMessageList | Returns the TracerMessageList.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MutexEnter | Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexExit | Unlocks the TracerMessageList instance, which has been passed to this class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CompleteMessageCount | Gets the number of the available complete I2C messages.
Public property | Count | Gets the number of the available I2C submessages.
Public property | Item |
Top
Remarks
Before using the methods and properties of this class, it is necessary to call the MutexEnter or [!:MutexEnter(System::TimeSpan)] method. This locks the instance of this class and the instance of the TracerMessageList. At the end it is necessary to release this mutex calling MutexExit.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ParsedTracerMessageList Constructor

ParsedTracerMessageList Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTracerMessageList(
    TracerMessageList msgs,
    int cache_size
)
Public Sub New (
    msgs As TracerMessageList,
    cache_size As Integer
)
public:
ParsedTracerMessageList(
    TracerMessageList^ msgs,
    int cache_size
)
new :
        msgs : TracerMessageList *
        cache_size : int -> ParsedTracerMessageList

Parameters

msgs
Type: telos.I2cApi.DotNetTracerMessageList
TracerMessageList to be parsed
cache_size
Type: SystemInt32
number of parsed submessage stored in the internal cache
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList Methods

ParsedTracerMessageList Methods

The ParsedTracerMessageList type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCombinedIndexByTimestamp | Returns the combined index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, this method throws an ExceptionItemNotFound exception.
Public method | GetCompleteMessage | Returns the complete message (consisting of a number of submessages) specified by the index. The number of complete messages can be determined by using the CompleteMessageCount property.
Public method | GetCompleteMessageIndex(Int32) | This method searches the index of the first submessage of a complete message.
Public method | GetCompleteMessageIndex(Int32, Int32) | This method searches the index of the first submessage of a complete message.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, this method throws an ExceptionItemNotFound exception.
Public method | GetTracerMessageList | Returns the TracerMessageList.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MutexEnter | Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexExit | Unlocks the TracerMessageList instance, which has been passed to this class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.Dispose Method

ParsedTracerMessageListDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.Dispose Method

ParsedTracerMessageListDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ParsedTracerMessageList Class
Dispose Overload


ParsedTracerMessageList.Dispose Method (Boolean)

ParsedTracerMessageListDispose Method (Boolean)
Releases the unmanaged resources used by the ParsedTracerMessageList and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.ParsedTracerMessageList.Dispose(System.Boolean)"]

See Also

Reference

ParsedTracerMessageList Class
Dispose Overload


ParsedTracerMessageList.GetCombinedIndexByTimestamp Method

ParsedTracerMessageListGetCombinedIndexByTimestamp Method
Returns the combined index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, this method throws an ExceptionItemNotFound exception.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetCombinedIndexByTimestamp(
    ulong ts,
    bool match_exactly
)
Public Function GetCombinedIndexByTimestamp (
    ts As ULong,
    match_exactly As Boolean
) As Integer
public:
int GetCombinedIndexByTimestamp(
    unsigned long long ts,
    bool match_exactly
)
member GetCombinedIndexByTimestamp :
        ts : uint64 *
        match_exactly : bool -> int

Parameters

ts
Type: SystemUInt64
searched timestamp
match_exactly
Type: SystemBoolean
throw an exception (true), return item with smaller timestamp (false)

Return Value

Type: Int32
combined index of the item
Remarks
If the match_exactly parameter is false and the specified timestamp is not within an I2C message, the method returns the item whose timestamp is smaller than the searched timestamp.
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.GetCompleteMessage Method

ParsedTracerMessageListGetCompleteMessage Method
Returns the complete message (consisting of a number of submessages) specified by the index. The number of complete messages can be determined by using the CompleteMessageCount property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataBase[] GetCompleteMessage(
    int combined_index
)
Public Function GetCompleteMessage (
    combined_index As Integer
) As ParsedTraceDataBase()
public:
array<ParsedTraceDataBase^>^ GetCompleteMessage(
    int combined_index
)
member GetCompleteMessage :
        combined_index : int -> ParsedTraceDataBase[]

Parameters

combined_index
Type: SystemInt32
I2C message to be parsed

Return Value

Type: ParsedTraceDataBase
parsed I2C message
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.GetCompleteMessageIndex Method

ParsedTracerMessageListGetCompleteMessageIndex Method
Overload List
 | Name | Description
Public method | GetCompleteMessageIndex(Int32) | This method searches the index of the first submessage of a complete message.
Public method | GetCompleteMessageIndex(Int32, Int32) | This method searches the index of the first submessage of a complete message.
Top
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.GetCompleteMessageIndex Method (Int32)

ParsedTracerMessageListGetCompleteMessageIndex Method (Int32)
This method searches the index of the first submessage of a complete message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetCompleteMessageIndex(
    int index
)
Public Function GetCompleteMessageIndex (
    index As Integer
) As Integer
public:
int GetCompleteMessageIndex(
    int index
)
member GetCompleteMessageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
index of the submessage

Return Value

Type: Int32
index of the first submessage in a complete message
Remarks

In the case of a standard master transmitter or master receiver message, this method simply returns the index received by the caller.

If the specified submessage is part of a combined transfer, it returns the index of the first submessage of the transfer.

See Also

Reference

ParsedTracerMessageList Class
GetCompleteMessageIndex Overload


ParsedTracerMessageList.GetCompleteMessageIndex Method (Int32, Int32)

ParsedTracerMessageListGetCompleteMessageIndex Method (Int32, Int32)
This method searches the index of the first submessage of a complete message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetCompleteMessageIndex(
    int index,
    int offset
)
Public Function GetCompleteMessageIndex (
    index As Integer,
    offset As Integer
) As Integer
public:
int GetCompleteMessageIndex(
    int index,
    int offset
)
member GetCompleteMessageIndex :
        index : int *
        offset : int -> int

Parameters

index
Type: SystemInt32
index of the submessage
offset
Type: SystemInt32
number of messages to go forward or backward

Return Value

Type: Int32
index of the first submessage in a complete message (or MinValue or MaxValue)
Remarks
The complete message gets specified by the two arguments of this method. The index argument specifies the index of a submessage. If this submessage is part of a combined transfer, the method searches for the first submessage of the transfer. Afterwards this method goes a number of transfers, specified by offset parameter, forward or backward and returns the index of the first submessage of the found transfer.
See Also

Reference

ParsedTracerMessageList Class
GetCompleteMessageIndex Overload


ParsedTracerMessageList.GetEnumerator Method

ParsedTracerMessageListGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<ParsedTraceDataBase> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of ParsedTraceDataBase)
public:
virtual IEnumerator<ParsedTraceDataBase^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<ParsedTraceDataBase>
override GetEnumerator : unit -> IEnumerator<ParsedTraceDataBase>

Return Value

Type: IEnumerator ParsedTraceDataBase
enumerator
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.GetEnumerator_NonGeneric Method

ParsedTracerMessageListGetEnumerator_NonGeneric Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator_NonGeneric()
Public Function GetEnumerator_NonGeneric As IEnumerator
public:
virtual IEnumerator^ GetEnumerator_NonGeneric() sealed
abstract GetEnumerator_NonGeneric : unit -> IEnumerator
override GetEnumerator_NonGeneric : unit -> IEnumerator

Return Value

Type: IEnumerator
enumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.GetIndexByTimestamp Method

ParsedTracerMessageListGetIndexByTimestamp Method
Returns the index of the parsed I2C message, which contains the specified timestamp. If the timestamp is not within an I2C message, this method throws an ExceptionItemNotFound exception.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetIndexByTimestamp(
    ulong ts,
    bool match_exactly
)
Public Function GetIndexByTimestamp (
    ts As ULong,
    match_exactly As Boolean
) As Integer
public:
int GetIndexByTimestamp(
    unsigned long long ts,
    bool match_exactly
)
member GetIndexByTimestamp :
        ts : uint64 *
        match_exactly : bool -> int

Parameters

ts
Type: SystemUInt64
searched timestamp
match_exactly
Type: SystemBoolean
throw an exception (true), return item with smaller timestamp (false)

Return Value

Type: Int32
index of the item
Remarks
If the match_exactly parameter is false and the specified timestamp is not within an I2C message, the method returns the item whose timestamp is smaller than the searched timestamp.
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.GetTracerMessageList Method

ParsedTracerMessageListGetTracerMessageList Method
Returns the TracerMessageList.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessageList GetTracerMessageList()
Public Function GetTracerMessageList As TracerMessageList
public:
TracerMessageList^ GetTracerMessageList()
member GetTracerMessageList : unit -> TracerMessageList

Return Value

Type: TracerMessageList
TracerMessageList
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.MutexEnter Method

ParsedTracerMessageListMutexEnter Method
Overload List
 | Name | Description
Public method | MutexEnter | Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Public method | MutexEnter(TimeSpan) | Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.
Top
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.MutexEnter Method

ParsedTracerMessageListMutexEnter Method
Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void MutexEnter()
Public Sub MutexEnter
public:
void MutexEnter()
member MutexEnter : unit -> unit
See Also

Reference

ParsedTracerMessageList Class
MutexEnter Overload


ParsedTracerMessageList.MutexEnter Method (TimeSpan)

ParsedTracerMessageListMutexEnter Method (TimeSpan)
Locks the TracerMessageList instance, which has been passed to this class. A thread is allowed to call MutexEnter() recursively. If the thread calls this method e.g. three times, it has to call MutexExit three times to release the mutex.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool MutexEnter(
    TimeSpan timeout
)
Public Function MutexEnter (
    timeout As TimeSpan
) As Boolean
public:
bool MutexEnter(
    TimeSpan timeout
)
member MutexEnter :
        timeout : TimeSpan -> bool

Parameters

timeout
Type: SystemTimeSpan
timeout

Return Value

Type: Boolean
lock acquired (true), not acquired (false)
See Also

Reference

ParsedTracerMessageList Class
MutexEnter Overload


ParsedTracerMessageList.MutexExit Method

ParsedTracerMessageListMutexExit Method
Unlocks the TracerMessageList instance, which has been passed to this class.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void MutexExit()
Public Sub MutexExit
public:
void MutexExit()
member MutexExit : unit -> unit
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList Properties

ParsedTracerMessageList Properties

The ParsedTracerMessageList type exposes the following members.

Properties
 | Name | Description
Public property | CompleteMessageCount | Gets the number of the available complete I2C messages.
Public property | Count | Gets the number of the available I2C submessages.
Public property | Item |
Top
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.CompleteMessageCount Property

ParsedTracerMessageListCompleteMessageCount Property
Gets the number of the available complete I2C messages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int CompleteMessageCount { get; }
Public ReadOnly Property CompleteMessageCount As Integer
    Get
public:
property int CompleteMessageCount {
    int get ();
}
member CompleteMessageCount : int with get

Property Value

Type: Int32
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.Count Property

ParsedTracerMessageListCount Property
Gets the number of the available I2C submessages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IReadOnlyListTCount
See Also

Reference

ParsedTracerMessageList Class


ParsedTracerMessageList.Item Property

ParsedTracerMessageListItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.ParsedTracerMessageList.Item(System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual ParsedTraceDataBase this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As ParsedTraceDataBase
    Get
public:
virtual property ParsedTraceDataBase^ default[int index] {
    ParsedTraceDataBase^ get (int index);
}
abstract Item : ParsedTraceDataBase with get
override Item : ParsedTraceDataBase with get

Parameters

index
Type: SystemInt32

Property Value

Type: ParsedTraceDataBase

Implements

IReadOnlyListTItemInt32
See Also

Reference

ParsedTracerMessageList Class


PlugInInterface Class

PlugInInterface Class
This base class specifies the interface of plug-in assemblies, which are used to interpret the trace data to or from an IC.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInInterface

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PlugInInterface
Public MustInherit Class PlugInInterface
public ref class PlugInInterface abstract
[<AbstractClassAttribute>]
type PlugInInterface =  class end

The PlugInInterface type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInInterface | Initializes a new instance of the PlugInInterface class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InterpretData | This methods gets called by the I2C framework when it wants the plug-in to interpret the I2C tracer message at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | HardwareInfo | If the plug-in needs information about the used I2C interface, it can overload this method, which gets called by the PlugInManager during the device registration to pass the HardwareInfo to the plug-in.
Public property | SupportedDevice | Gets a description of the IC, whose I2C traffic can be parsed by implemented plug-in.
Top
Remarks

This makes it possible to write e.g. an assembly that can interpret the data of an I2C RAM like the "Philips PCF8570P".

To use this interface create a new "class library" project and add a class with the name "PlugIn" to the project. This class has to be derived from the PlugInInterface class.

The PlugInManager will create instances of such implementations of the PlugInInterface.

Examples

The following example demonstrates how to write a tracer plug-in for I2C Studio in C#.

A plug-in is simply a .NET "class library" containing a class called "PlugIn", which has to be derived from PlugInInterface.

Copy
/*************************************************************

   Copyright (c) 2006-2014 telos Systementwicklung GmbH,
   Hamburg (Germany)

                    http://www.telos.de

   This file demonstrates how to use the plug-in interface
   of the I2C framework.

 *************************************************************/

using telos.I2cApi.DotNet;
using System;
using System.Collections.Generic;
using System.Text;

public sealed class PlugIn : PlugInInterface
{
  /***********************************************************/
  /// <summary>
  /// This method describes the IC, whose traffic can be
  /// parsed by the plug-in.
  /// </summary>
  /***********************************************************/

  public override PlugInInterface.Device SupportedDevice
  {
    get
    {
      I2cAddressRange        address_range;
      List<I2cAddressRange>  address_ranges;

      // create I2C address range containing I2C addresses, which are
      // supported by this IC
      address_ranges = new List<I2cAddressRange>();
      address_range = new I2cAddressRange (new I2cAddress (0x40, false),
                                           new I2cAddress (0x4f, false));
      address_ranges.Add (address_range);

      // create an object describing the IC
      return new PlugInInterface.Device ("telos",
                                         "Example Plug-In",
                                         "This plug-in demonstrates how to use the plug-in interface.",
                                         address_ranges);
    }
  }

  /***********************************************************/
  /// <summary>
  /// Interprets the I2C message with the specified index.
  /// </summary>
  /***********************************************************/

  public override string InterpretData (PlugInRawTraceData data, int index)
  {
    ParsedTraceData[]  msg;
    ParsedTraceData    sub_msg;
    StringBuilder      result;

    // create object for the result of the parser
    result = new StringBuilder();

    // get the I2C message to be parsed by the plug-in
    msg = data[index];

    // iterate over the submessages of the I2C message
    for (int i=0; i < msg.Length; i++)
    {
      // new line
      if (i > 0)
        result.Append ("\n");

      // get the submessage
      sub_msg = msg[i];

      // output the direction of the submessage
      switch (sub_msg.Direction)
      {
        case ParsedTraceData.DataDirection.DIRECTION_TX:
          result.Append ("TX: ");
          break;

        case ParsedTraceData.DataDirection.DIRECTION_RX:
          result.Append("RX: ");
          break;

        default:
          continue;
      }

      // output the data bytes of the submessage
      for (int a=0; a < sub_msg.Data.Length; a++)
      {
        if (a > 0)
          result.Append (" ");

        result.AppendFormat ("{0:X2}", sub_msg.Data[a]);
      }
    }

    // return result
    return (result.ToString());
  }
}
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInInterface Constructor

PlugInInterface Constructor
Initializes a new instance of the PlugInInterface class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInInterface()
Public Sub New
public:
PlugInInterface()
new : unit -> PlugInInterface
See Also

Reference

PlugInInterface Class


PlugInInterface Methods

PlugInInterface Methods

The PlugInInterface type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InterpretData | This methods gets called by the I2C framework when it wants the plug-in to interpret the I2C tracer message at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInInterface Class


PlugInInterface.InterpretData Method

PlugInInterfaceInterpretData Method
This methods gets called by the I2C framework when it wants the plug-in to interpret the I2C tracer message at the specified index.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract string InterpretData(
    PlugInRawTraceData data,
    int index
)
Public MustOverride Function InterpretData (
    data As PlugInRawTraceData,
    index As Integer
) As String
public:
virtual String^ InterpretData(
    PlugInRawTraceData^ data,
    int index
) abstract
abstract InterpretData :
        data : PlugInRawTraceData *
        index : int -> string

Parameters

data
Type: telos.I2cApi.DotNetPlugInRawTraceData
I2C tracer messages
index
Type: SystemInt32
of the message to be parsed

Return Value

Type: String
interpreted message
Remarks

Normally the implementation simply gets the message to be parsed with "data[index]". Sometimes it is necessary to parse even some previous messages. These messages can be received from the data parameter, too. Getting previous messages is always an expensive operation, which should be limited to a minimum.

The result gets returned as a string.

See Also

Reference

PlugInInterface Class


PlugInInterface Properties

PlugInInterface Properties

The PlugInInterface type exposes the following members.

Properties
 | Name | Description
Public property | HardwareInfo | If the plug-in needs information about the used I2C interface, it can overload this method, which gets called by the PlugInManager during the device registration to pass the HardwareInfo to the plug-in.
Public property | SupportedDevice | Gets a description of the IC, whose I2C traffic can be parsed by implemented plug-in.
Top
See Also

Reference

PlugInInterface Class


PlugInInterface.HardwareInfo Property

PlugInInterfaceHardwareInfo Property
If the plug-in needs information about the used I2C interface, it can overload this method, which gets called by the PlugInManager during the device registration to pass the HardwareInfo to the plug-in.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual HardwareInfo HardwareInfo { set; }
Public Overridable WriteOnly Property HardwareInfo As HardwareInfo
    Set
public:
virtual property HardwareInfo^ HardwareInfo {
    void set (HardwareInfo^ value);
}
abstract HardwareInfo : HardwareInfo with set
override HardwareInfo : HardwareInfo with set

Property Value

Type: HardwareInfo
Remarks
The default method does nothing.
See Also

Reference

PlugInInterface Class


PlugInInterface.SupportedDevice Property

PlugInInterfaceSupportedDevice Property
Gets a description of the IC, whose I2C traffic can be parsed by implemented plug-in.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract PlugInInterfaceDevice SupportedDevice { get; }
Public MustOverride ReadOnly Property SupportedDevice As PlugInInterfaceDevice
    Get
public:
virtual property PlugInInterfaceDevice^ SupportedDevice {
    PlugInInterfaceDevice^ get () abstract;
}
abstract SupportedDevice : PlugInInterfaceDevice with get

Property Value

Type: PlugInInterfaceDevice
See Also

Reference

PlugInInterface Class


PlugInInterface.Device Class

PlugInInterfaceDevice Class
This class stores the information about one IC supported by a plug-in assembly.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInInterfaceDevice

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Device : ICloneable
Public NotInheritable Class Device
    Implements ICloneable
public ref class Device sealed : ICloneable
[<SealedAttribute>]
type Device =
    class
        interface ICloneable
    end

The PlugInInterfaceDevice type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInInterfaceDevice | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | description of the IC (e.g. "SRAM with 256 bytes")
Public property | I2cAddresses | I2C addresses supported by the IC
Public property | Manufacturer | manufacturer of the IC (e.g. "Philips")
Public property | Name | name of the IC (e.g. "PCF8570P")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInInterface.Device Constructor

PlugInInterfaceDevice Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Device(
    string manufacturer,
    string name,
    string description,
    IEnumerable<I2cAddressRange> i2c_addresses
)
Public Sub New (
    manufacturer As String,
    name As String,
    description As String,
    i2c_addresses As IEnumerable(Of I2cAddressRange)
)
public:
Device(
    String^ manufacturer,
    String^ name,
    String^ description,
    IEnumerable<I2cAddressRange^>^ i2c_addresses
)
new :
        manufacturer : string *
        name : string *
        description : string *
        i2c_addresses : IEnumerable<I2cAddressRange> -> Device

Parameters

manufacturer
Type: SystemString
manufacturer of the IC (e.g. "Philips")
name
Type: SystemString
name of the IC (e.g. "PCF8570P")
description
Type: SystemString
description of the IC (e.g. "SRAM with 256 bytes")
i2c_addresses
Type: System.Collections.GenericIEnumerable I2cAddressRange
I2C addresses supported by the IC
See Also

Reference

PlugInInterfaceDevice Class


Device Methods

Device Methods

The PlugInInterfaceDevice type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInInterfaceDevice Class


PlugInInterface.Device.Clone Method

PlugInInterfaceDeviceClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PlugInInterfaceDevice Class


Device Properties

Device Properties

The PlugInInterfaceDevice type exposes the following members.

Properties
 | Name | Description
Public property | Description | description of the IC (e.g. "SRAM with 256 bytes")
Public property | I2cAddresses | I2C addresses supported by the IC
Public property | Manufacturer | manufacturer of the IC (e.g. "Philips")
Public property | Name | name of the IC (e.g. "PCF8570P")
Top
See Also

Reference

PlugInInterfaceDevice Class


PlugInInterface.Device.Description Property

PlugInInterfaceDeviceDescription Property
description of the IC (e.g. "SRAM with 256 bytes")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

PlugInInterfaceDevice Class


PlugInInterface.Device.I2cAddresses Property

PlugInInterfaceDeviceI2cAddresses Property
I2C addresses supported by the IC

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<I2cAddressRange> I2cAddresses { get; set; }
Public Property I2cAddresses As List(Of I2cAddressRange)
    Get
    Set
public:
property List<I2cAddressRange^>^ I2cAddresses {
    List<I2cAddressRange^>^ get ();
    void set (List<I2cAddressRange^>^ value);
}
member I2cAddresses : List<I2cAddressRange> with get, set

Property Value

Type: List I2cAddressRange
See Also

Reference

PlugInInterfaceDevice Class


PlugInInterface.Device.Manufacturer Property

PlugInInterfaceDeviceManufacturer Property
manufacturer of the IC (e.g. "Philips")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

PlugInInterfaceDevice Class


PlugInInterface.Device.Name Property

PlugInInterfaceDeviceName Property
name of the IC (e.g. "PCF8570P")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

PlugInInterfaceDevice Class


PlugInManager Class

PlugInManager Class
This class is responsible for loading trace plug-ins, which implement the PlugInInterface interface.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInManager

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInManager
Public NotInheritable Class PlugInManager
public ref class PlugInManager sealed
[<SealedAttribute>]
type PlugInManager =  class end

The PlugInManager type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInManager | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlugInFiles | Searches in the specified directories for plug-in files. This method returns the description of the devices specified in the found plug-in files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadAssembly | Creates an instance of the specified plug-in.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PlugInDirectories | Sets/gets the names of the directories containing the plug-in assemblies.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInManager Constructor

PlugInManager Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInManager()
Public Sub New
public:
PlugInManager()
new : unit -> PlugInManager
See Also

Reference

PlugInManager Class


PlugInManager Methods

PlugInManager Methods

The PlugInManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlugInFiles | Searches in the specified directories for plug-in files. This method returns the description of the devices specified in the found plug-in files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadAssembly | Creates an instance of the specified plug-in.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInManager Class


PlugInManager.GetPlugInFiles Method

PlugInManagerGetPlugInFiles Method
Searches in the specified directories for plug-in files. This method returns the description of the devices specified in the found plug-in files.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<PlugInManagerDevice> GetPlugInFiles(
    IList<string> errors
)
Public Function GetPlugInFiles (
    errors As IList(Of String)
) As List(Of PlugInManagerDevice)
public:
List<PlugInManagerDevice^>^ GetPlugInFiles(
    IList<String^>^ errors
)
member GetPlugInFiles :
        errors : IList<string> -> List<PlugInManagerDevice>

Parameters

errors
Type: System.Collections.GenericIList String
list of errors or N/A ("0")

Return Value

Type: List PlugInManagerDevice
description of the found devices
Remarks
If it is not possible to open/read some of the found files, this method adds the error message to a list of errors.
See Also

Reference

PlugInManager Class


PlugInManager.LoadAssembly Method

PlugInManagerLoadAssembly Method
Creates an instance of the specified plug-in.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInInterface LoadAssembly(
    string filename
)
Public Function LoadAssembly (
    filename As String
) As PlugInInterface
public:
PlugInInterface^ LoadAssembly(
    String^ filename
)
member LoadAssembly :
        filename : string -> PlugInInterface

Parameters

filename
Type: SystemString
file name of the plug-in assembly

Return Value

Type: PlugInInterface
plug-in instance
Remarks
If the plug-in is not found, this method searches for the plug-in in all plug-in directories. If the plug-in is found, the filename passed to this method gets updated.
See Also

Reference

PlugInManager Class


PlugInManager Properties

PlugInManager Properties

The PlugInManager type exposes the following members.

Properties
 | Name | Description
Public property | PlugInDirectories | Sets/gets the names of the directories containing the plug-in assemblies.
Top
See Also

Reference

PlugInManager Class


PlugInManager.PlugInDirectories Property

PlugInManagerPlugInDirectories Property
Sets/gets the names of the directories containing the plug-in assemblies.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<string> PlugInDirectories { get; set; }
Public Property PlugInDirectories As List(Of String)
    Get
    Set
public:
property List<String^>^ PlugInDirectories {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member PlugInDirectories : List<string> with get, set

Property Value

Type: List String
See Also

Reference

PlugInManager Class


PlugInManager.Device Class

PlugInManagerDevice Class
This class stores the information about one IC supported by the plug-in manager.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInManagerDevice

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Device : ICloneable
Public NotInheritable Class Device
    Implements ICloneable
public ref class Device sealed : ICloneable
[<SealedAttribute>]
type Device =
    class
        interface ICloneable
    end

The PlugInManagerDevice type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInManagerDevice | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | description of the IC (e.g. "SRAM with 256 bytes")
Public property | Filename | file name of the assembly containing the interpreter
Public property | I2cAddresses | I2C addresses supported by the IC
Public property | Manufacturer | manufacturer of the IC (e.g. "Philips")
Public property | Name | name of the IC (e.g. "PCF8570P")
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInManager.Device Constructor

PlugInManagerDevice Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Device(
    PlugInInterfaceDevice plugin_infos,
    string filename
)
Public Sub New (
    plugin_infos As PlugInInterfaceDevice,
    filename As String
)
public:
Device(
    PlugInInterfaceDevice^ plugin_infos,
    String^ filename
)
new :
        plugin_infos : PlugInInterfaceDevice *
        filename : string -> Device

Parameters

plugin_infos
Type: telos.I2cApi.DotNetPlugInInterfaceDevice
information about a device supported by a plug-in
filename
Type: SystemString
file name of the assembly containing the interpreter
See Also

Reference

PlugInManagerDevice Class


Device Methods

Device Methods

The PlugInManagerDevice type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInManagerDevice Class


PlugInManager.Device.Clone Method

PlugInManagerDeviceClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PlugInManagerDevice Class


Device Properties

Device Properties

The PlugInManagerDevice type exposes the following members.

Properties
 | Name | Description
Public property | Description | description of the IC (e.g. "SRAM with 256 bytes")
Public property | Filename | file name of the assembly containing the interpreter
Public property | I2cAddresses | I2C addresses supported by the IC
Public property | Manufacturer | manufacturer of the IC (e.g. "Philips")
Public property | Name | name of the IC (e.g. "PCF8570P")
Top
See Also

Reference

PlugInManagerDevice Class


PlugInManager.Device.Description Property

PlugInManagerDeviceDescription Property
description of the IC (e.g. "SRAM with 256 bytes")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

PlugInManagerDevice Class


PlugInManager.Device.Filename Property

PlugInManagerDeviceFilename Property
file name of the assembly containing the interpreter

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; set; }
Public Property Filename As String
    Get
    Set
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}
member Filename : string with get, set

Property Value

Type: String
See Also

Reference

PlugInManagerDevice Class


PlugInManager.Device.I2cAddresses Property

PlugInManagerDeviceI2cAddresses Property
I2C addresses supported by the IC

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<I2cAddressRange> I2cAddresses { get; set; }
Public Property I2cAddresses As List(Of I2cAddressRange)
    Get
    Set
public:
property List<I2cAddressRange^>^ I2cAddresses {
    List<I2cAddressRange^>^ get ();
    void set (List<I2cAddressRange^>^ value);
}
member I2cAddresses : List<I2cAddressRange> with get, set

Property Value

Type: List I2cAddressRange
See Also

Reference

PlugInManagerDevice Class


PlugInManager.Device.Manufacturer Property

PlugInManagerDeviceManufacturer Property
manufacturer of the IC (e.g. "Philips")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

PlugInManagerDevice Class


PlugInManager.Device.Name Property

PlugInManagerDeviceName Property
name of the IC (e.g. "PCF8570P")

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

PlugInManagerDevice Class


PlugInRawTraceData Class

PlugInRawTraceData Class
Implements a wrapper around a ParsedTracerMessageList object. Such a list is used to store the I2C messages, which have been traced.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInRawTraceData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInRawTraceData : IDisposable
Public NotInheritable Class PlugInRawTraceData
    Implements IDisposable
public ref class PlugInRawTraceData sealed : IDisposable
[<SealedAttribute>]
type PlugInRawTraceData =
    class
        interface IDisposable
    end

The PlugInRawTraceData type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInRawTraceData | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Item |
Top
Remarks

The main differences between this class and the ParsedTracerMessageList are:

  • read-only: it is not possible to modify the trace data
  • only (sub-)messages for one I2C address can be accessed
  • only (sub-)messages with the indices 0..comb_msg_index can be accessed

Instances of this class get passed to classes implementing the PlugInInterface interface.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInRawTraceData Constructor

PlugInRawTraceData Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInRawTraceData(
    ParsedTracerMessageList parsed_msgs,
    I2cAddress i2c_addr,
    int comb_msg_index
)
Public Sub New (
    parsed_msgs As ParsedTracerMessageList,
    i2c_addr As I2cAddress,
    comb_msg_index As Integer
)
public:
PlugInRawTraceData(
    ParsedTracerMessageList^ parsed_msgs,
    I2cAddress^ i2c_addr,
    int comb_msg_index
)
new :
        parsed_msgs : ParsedTracerMessageList *
        i2c_addr : I2cAddress *
        comb_msg_index : int -> PlugInRawTraceData

Parameters

parsed_msgs
Type: telos.I2cApi.DotNetParsedTracerMessageList
I2C trace messages
i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
limit access to messages with this I2C address
comb_msg_index
Type: SystemInt32
limit access to messages with the indices 0..x
See Also

Reference

PlugInRawTraceData Class


PlugInRawTraceData Methods

PlugInRawTraceData Methods

The PlugInRawTraceData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInRawTraceData Class


PlugInRawTraceData.Dispose Method

PlugInRawTraceDataDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

PlugInRawTraceData Class


PlugInRawTraceData.Dispose Method

PlugInRawTraceDataDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PlugInRawTraceData Class
Dispose Overload


PlugInRawTraceData.Dispose Method (Boolean)

PlugInRawTraceDataDispose Method (Boolean)
Releases the unmanaged resources used by the PlugInRawTraceData and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.PlugInRawTraceData.Dispose(System.Boolean)"]

See Also

Reference

PlugInRawTraceData Class
Dispose Overload


PlugInRawTraceData Properties

PlugInRawTraceData Properties

The PlugInRawTraceData type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Top
See Also

Reference

PlugInRawTraceData Class


PlugInRawTraceData.Item Property

PlugInRawTraceDataItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.PlugInRawTraceData.Item(System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceData[] this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ParsedTraceData()
    Get
public:
property array<ParsedTraceData^>^ default[int index] {
    array<ParsedTraceData^>^ get (int index);
}
member Item : ParsedTraceData[] with get

Parameters

index
Type: SystemInt32

Property Value

Type: ParsedTraceData
See Also

Reference

PlugInRawTraceData Class


PlugInTraceData Class

PlugInTraceData Class
Stores one message to an I2C slave, which has been parsed by a plug-in.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInTraceDataBase
telos.I2cApi.DotNetPlugInTraceData

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInTraceData : PlugInTraceDataBase
Public NotInheritable Class PlugInTraceData
    Inherits PlugInTraceDataBase
public ref class PlugInTraceData sealed : public PlugInTraceDataBase
[<SealedAttribute>]
type PlugInTraceData =
    class
        inherit PlugInTraceDataBase
    end

The PlugInTraceData type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInTraceData | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address (Inherited from PlugInTraceDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from PlugInTraceDataBase.)
Public property | Message | message
Top
Remarks
Objects of this class gets created by the PlugInTraceParser class.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInTraceData Constructor

PlugInTraceData Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInTraceData(
    string msg,
    I2cAddress i2c_addr
)
Public Sub New (
    msg As String,
    i2c_addr As I2cAddress
)
public:
PlugInTraceData(
    String^ msg,
    I2cAddress^ i2c_addr
)
new :
        msg : string *
        i2c_addr : I2cAddress -> PlugInTraceData

Parameters

msg
Type: SystemString
message
i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
See Also

Reference

PlugInTraceData Class


PlugInTraceData Methods

PlugInTraceData Methods

The PlugInTraceData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInTraceData Class


PlugInTraceData Properties

PlugInTraceData Properties

The PlugInTraceData type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address (Inherited from PlugInTraceDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from PlugInTraceDataBase.)
Public property | Message | message
Top
See Also

Reference

PlugInTraceData Class


PlugInTraceData.Message Property

PlugInTraceDataMessage Property
message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

PlugInTraceData Class


PlugInTraceDataBase Class

PlugInTraceDataBase Class
Base class of PlugInTraceData and PlugInTraceError.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInTraceDataBase
telos.I2cApi.DotNetPlugInTraceData
telos.I2cApi.DotNetPlugInTraceError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PlugInTraceDataBase
Public MustInherit Class PlugInTraceDataBase
public ref class PlugInTraceDataBase abstract
[<AbstractClassAttribute>]
type PlugInTraceDataBase =  class end

The PlugInTraceDataBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PlugInTraceDataBase | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInTraceDataBase Constructor

PlugInTraceDataBase Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected PlugInTraceDataBase(
    I2cAddress i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
Protected Sub New (
    i2c_addr As I2cAddress,
    i2c_addr_complete As ParsedTraceDataI2cAddressComplete
)
protected:
PlugInTraceDataBase(
    I2cAddress^ i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
new :
        i2c_addr : I2cAddress *
        i2c_addr_complete : ParsedTraceDataI2cAddressComplete -> PlugInTraceDataBase

Parameters

i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
i2c_addr_complete
Type: telos.I2cApi.DotNetParsedTraceDataI2cAddressComplete
I2C address complete
See Also

Reference

PlugInTraceDataBase Class


PlugInTraceDataBase Methods

PlugInTraceDataBase Methods

The PlugInTraceDataBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInTraceDataBase Class


PlugInTraceDataBase Properties

PlugInTraceDataBase Properties

The PlugInTraceDataBase type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address
Public property | AddressComplete | I2C address complete?
Top
See Also

Reference

PlugInTraceDataBase Class


PlugInTraceDataBase.Address Property

PlugInTraceDataBaseAddress Property
I2C address

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

PlugInTraceDataBase Class


PlugInTraceDataBase.AddressComplete Property

PlugInTraceDataBaseAddressComplete Property
I2C address complete?

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTraceDataI2cAddressComplete AddressComplete { get; set; }
Public Property AddressComplete As ParsedTraceDataI2cAddressComplete
    Get
    Set
public:
property ParsedTraceDataI2cAddressComplete AddressComplete {
    ParsedTraceDataI2cAddressComplete get ();
    void set (ParsedTraceDataI2cAddressComplete value);
}
member AddressComplete : ParsedTraceDataI2cAddressComplete with get, set

Property Value

Type: ParsedTraceDataI2cAddressComplete
See Also

Reference

PlugInTraceDataBase Class


PlugInTraceDataContainer Class

PlugInTraceDataContainer Class
Stores one complete I2C message, which has been parsed by plug-ins.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInTraceDataContainer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInTraceDataContainer
Public NotInheritable Class PlugInTraceDataContainer
public ref class PlugInTraceDataContainer sealed
[<SealedAttribute>]
type PlugInTraceDataContainer =  class end

The PlugInTraceDataContainer type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInTraceDataContainer | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CombinedMsgIndex | number of the complete I2C message
Public property | ParsedMsgs | raw I2C message
Public property | PluginMsgs | message parsed by plug-ins
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
Remarks
It gets created by the PlugInTraceParser class.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInTraceDataContainer Constructor

PlugInTraceDataContainer Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInTraceDataContainer()
Public Sub New
public:
PlugInTraceDataContainer()
new : unit -> PlugInTraceDataContainer
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceDataContainer Methods

PlugInTraceDataContainer Methods

The PlugInTraceDataContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceDataContainer Properties

PlugInTraceDataContainer Properties

The PlugInTraceDataContainer type exposes the following members.

Properties
 | Name | Description
Public property | CombinedMsgIndex | number of the complete I2C message
Public property | ParsedMsgs | raw I2C message
Public property | PluginMsgs | message parsed by plug-ins
Public property | StartTimestamp | first timestamp of the message
Public property | StopTimestamp | last timestamp of the message
Top
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceDataContainer.CombinedMsgIndex Property

PlugInTraceDataContainerCombinedMsgIndex Property
number of the complete I2C message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int CombinedMsgIndex { get; set; }
Public Property CombinedMsgIndex As Integer
    Get
    Set
public:
property int CombinedMsgIndex {
    int get ();
    void set (int value);
}
member CombinedMsgIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceDataContainer.ParsedMsgs Property

PlugInTraceDataContainerParsedMsgs Property
raw I2C message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<ParsedTraceDataBase> ParsedMsgs { get; set; }
Public Property ParsedMsgs As List(Of ParsedTraceDataBase)
    Get
    Set
public:
property List<ParsedTraceDataBase^>^ ParsedMsgs {
    List<ParsedTraceDataBase^>^ get ();
    void set (List<ParsedTraceDataBase^>^ value);
}
member ParsedMsgs : List<ParsedTraceDataBase> with get, set

Property Value

Type: List ParsedTraceDataBase
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceDataContainer.PluginMsgs Property

PlugInTraceDataContainerPluginMsgs Property
message parsed by plug-ins

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<PlugInTraceDataBase> PluginMsgs { get; set; }
Public Property PluginMsgs As List(Of PlugInTraceDataBase)
    Get
    Set
public:
property List<PlugInTraceDataBase^>^ PluginMsgs {
    List<PlugInTraceDataBase^>^ get ();
    void set (List<PlugInTraceDataBase^>^ value);
}
member PluginMsgs : List<PlugInTraceDataBase> with get, set

Property Value

Type: List PlugInTraceDataBase
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceDataContainer.StartTimestamp Property

PlugInTraceDataContainerStartTimestamp Property
first timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StartTimestamp { get; set; }
Public Property StartTimestamp As ULong
    Get
    Set
public:
property unsigned long long StartTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StartTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceDataContainer.StopTimestamp Property

PlugInTraceDataContainerStopTimestamp Property
last timestamp of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong StopTimestamp { get; set; }
Public Property StopTimestamp As ULong
    Get
    Set
public:
property unsigned long long StopTimestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member StopTimestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

PlugInTraceDataContainer Class


PlugInTraceError Class

PlugInTraceError Class
When the PlugInTraceParser class detects an error during parsing messages to I2C slaves using plug-ins, it creates objects of this type.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInTraceDataBase
telos.I2cApi.DotNetPlugInTraceError

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInTraceError : PlugInTraceDataBase
Public NotInheritable Class PlugInTraceError
    Inherits PlugInTraceDataBase
public ref class PlugInTraceError sealed : public PlugInTraceDataBase
[<SealedAttribute>]
type PlugInTraceError =
    class
        inherit PlugInTraceDataBase
    end

The PlugInTraceError type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInTraceError | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | I2C address (Inherited from PlugInTraceDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from PlugInTraceDataBase.)
Public property | ErrorReason | reason of the error
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInTraceError Constructor

PlugInTraceError Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInTraceError(
    PlugInTraceErrorError error_value,
    I2cAddress i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
Public Sub New (
    error_value As PlugInTraceErrorError,
    i2c_addr As I2cAddress,
    i2c_addr_complete As ParsedTraceDataI2cAddressComplete
)
public:
PlugInTraceError(
    PlugInTraceErrorError error_value,
    I2cAddress^ i2c_addr,
    ParsedTraceDataI2cAddressComplete i2c_addr_complete
)
new :
        error_value : PlugInTraceErrorError *
        i2c_addr : I2cAddress *
        i2c_addr_complete : ParsedTraceDataI2cAddressComplete -> PlugInTraceError

Parameters

error_value
Type: telos.I2cApi.DotNetPlugInTraceErrorError
error reason
i2c_addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address
i2c_addr_complete
Type: telos.I2cApi.DotNetParsedTraceDataI2cAddressComplete
I2C address complete
See Also

Reference

PlugInTraceError Class


PlugInTraceError Methods

PlugInTraceError Methods

The PlugInTraceError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInTraceError Class


PlugInTraceError Properties

PlugInTraceError Properties

The PlugInTraceError type exposes the following members.

Properties
 | Name | Description
Public property | Address | I2C address (Inherited from PlugInTraceDataBase.)
Public property | AddressComplete | I2C address complete? (Inherited from PlugInTraceDataBase.)
Public property | ErrorReason | reason of the error
Top
See Also

Reference

PlugInTraceError Class


PlugInTraceError.ErrorReason Property

PlugInTraceErrorErrorReason Property
reason of the error

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInTraceErrorError ErrorReason { get; set; }
Public Property ErrorReason As PlugInTraceErrorError
    Get
    Set
public:
property PlugInTraceErrorError ErrorReason {
    PlugInTraceErrorError get ();
    void set (PlugInTraceErrorError value);
}
member ErrorReason : PlugInTraceErrorError with get, set

Property Value

Type: PlugInTraceErrorError
See Also

Reference

PlugInTraceError Class


PlugInTraceError.Error Enumeration

PlugInTraceErrorError Enumeration
Enumeration to specify reason of an error.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Error
Public Enumeration Error
public enum class Error
type Error
Members
Member name | Value | Description
ERROR_I2C_PROTOCOL | 0 | I2C protocol error
ERROR_SMB_POWER_ON | 1 | SMBus power on
ERROR_SMB_POWER_OFF | 2 | SMBus power off
ERROR_TRACER_RESTARTED | 3 | tracer restarted
ERROR_MSG_INCOMPLETE | 4 | message incomplete: START or/and STOP condition missing
ERROR_I2C_ADDRESS | 5 | I2C address has not been acknowledged
ERROR_PLUGIN_DESCRIPTION_NA | 6 | there is no IRD description for this I2C address
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInTraceParser Class

PlugInTraceParser Class
This parser uses plug-ins (classes derived from PlugInInterface) to interpret I2C messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPlugInTraceParser

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PlugInTraceParser : IDisposable
Public NotInheritable Class PlugInTraceParser
    Implements IDisposable
public ref class PlugInTraceParser sealed : IDisposable
[<SealedAttribute>]
type PlugInTraceParser =
    class
        interface IDisposable
    end

The PlugInTraceParser type exposes the following members.

Constructors
 | Name | Description
Public method | PlugInTraceParser | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parses one complete message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The plug-ins to be used are registered in the IrdMap. Typically each plug-in can interpret the protocol of one IC type.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PlugInTraceParser Constructor

PlugInTraceParser Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInTraceParser(
    ParsedTracerMessageList msgs,
    HardwareInfo hwinfo,
    IrdMap ird_map
)
Public Sub New (
    msgs As ParsedTracerMessageList,
    hwinfo As HardwareInfo,
    ird_map As IrdMap
)
public:
PlugInTraceParser(
    ParsedTracerMessageList^ msgs,
    HardwareInfo^ hwinfo,
    IrdMap^ ird_map
)
new :
        msgs : ParsedTracerMessageList *
        hwinfo : HardwareInfo *
        ird_map : IrdMap -> PlugInTraceParser

Parameters

msgs
Type: telos.I2cApi.DotNetParsedTracerMessageList
raw I2C messages
hwinfo
Type: telos.I2cApi.DotNetHardwareInfo
HardwareInfo of the I2C interface, which has been used to trace the I2C messages
ird_map
Type: telos.I2cApi.DotNetIrdMap
I2C address to IRD map
See Also

Reference

PlugInTraceParser Class


PlugInTraceParser Methods

PlugInTraceParser Methods

The PlugInTraceParser type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parses one complete message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlugInTraceParser Class


PlugInTraceParser.Dispose Method

PlugInTraceParserDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

PlugInTraceParser Class


PlugInTraceParser.Dispose Method

PlugInTraceParserDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PlugInTraceParser Class
Dispose Overload


PlugInTraceParser.Dispose Method (Boolean)

PlugInTraceParserDispose Method (Boolean)
Releases the unmanaged resources used by the PlugInTraceParser and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.PlugInTraceParser.Dispose(System.Boolean)"]

See Also

Reference

PlugInTraceParser Class
Dispose Overload


PlugInTraceParser.Parse Method

PlugInTraceParserParse Method
Parses one complete message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PlugInTraceDataContainer Parse(
    int combined_msg_index
)
Public Function Parse (
    combined_msg_index As Integer
) As PlugInTraceDataContainer
public:
PlugInTraceDataContainer^ Parse(
    int combined_msg_index
)
member Parse :
        combined_msg_index : int -> PlugInTraceDataContainer

Parameters

combined_msg_index
Type: SystemInt32
index of the message

Return Value

Type: PlugInTraceDataContainer
parsed message (interpreted by plug-ins)
See Also

Reference

PlugInTraceParser Class


PmbusMasterMessage Class

PmbusMasterMessage Class
This class is used as a base class for the PMBus master messages supporting the "extended command" byte.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessage
telos.I2cApi.DotNetPmbusMasterMessageExtCmdByte
telos.I2cApi.DotNetPmbusMasterMessageExtCmdWord

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PmbusMasterMessage : ICloneable,
    IDisposable
Public MustInherit Class PmbusMasterMessage
    Implements ICloneable, IDisposable
public ref class PmbusMasterMessage abstract : ICloneable,
    IDisposable
[<AbstractClassAttribute>]
type PmbusMasterMessage =
    class
        interface ICloneable
        interface IDisposable
    end

The PmbusMasterMessage type exposes the following members.

Constructors
 | Name | Description
Protected method | PmbusMasterMessage | Constructor
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
MFR_SPECIFIC_COMMAND_EXT | command extension: manufacturer specific
PMBUS_COMMAND_EXT | command extension: PMBus
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Public property | Command | Sets/gets the command byte of the message.
Public property | CommandExtension | Sets/gets the command extension byte of the message.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
Remarks

The PMBus is specified in:

Copy
PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added.

The number of commands, which is limited to 256 on the SMBus, has been extended by the introduction of the "extended command" byte.

There are different message types supporting the "extended command" byte:

  • Write Byte
  • Read Byte
  • Write Word
  • Read Word

A PMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the PMBus with the TransferData(PmbusMasterMessage) method.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessage Constructor

PmbusMasterMessage Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected PmbusMasterMessage(
    I2cAddress i2c_address,
    byte cmd,
    byte cmd_ext,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    cmd_ext As Byte,
    with_pec As Boolean
)
protected:
PmbusMasterMessage(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char cmd_ext,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        cmd_ext : byte *
        with_pec : bool -> PmbusMasterMessage

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
cmd_ext
Type: SystemByte
command extension byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage Fields

PmbusMasterMessage Fields

The PmbusMasterMessage type exposes the following members.

Fields
Name | Description
MFR_SPECIFIC_COMMAND_EXT | command extension: manufacturer specific
PMBUS_COMMAND_EXT | command extension: PMBus
Top
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.MFR_SPECIFIC_COMMAND_EXT Field

PmbusMasterMessageMFR_SPECIFIC_COMMAND_EXT Field
command extension: manufacturer specific

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public const byte MFR_SPECIFIC_COMMAND_EXT
Public Const MFR_SPECIFIC_COMMAND_EXT As Byte
public:
literal unsigned char MFR_SPECIFIC_COMMAND_EXT
static val mutable MFR_SPECIFIC_COMMAND_EXT: byte

Field Value

Type: Byte
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.PMBUS_COMMAND_EXT Field

PmbusMasterMessagePMBUS_COMMAND_EXT Field
command extension: PMBus

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public const byte PMBUS_COMMAND_EXT
Public Const PMBUS_COMMAND_EXT As Byte
public:
literal unsigned char PMBUS_COMMAND_EXT
static val mutable PMBUS_COMMAND_EXT: byte

Field Value

Type: Byte
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage Methods

PmbusMasterMessage Methods

The PmbusMasterMessage type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.Clone Method

PmbusMasterMessageClone Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.PmbusMasterMessage.Clone"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object
public:
virtual Object^ Clone() abstract
abstract Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.PmbusMasterMessage.Clone"]

Implements

ICloneableClone
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.Dispose Method

PmbusMasterMessageDispose Method
Overload List
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Top
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.Dispose Method

PmbusMasterMessageDispose Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.PmbusMasterMessage.Dispose"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PmbusMasterMessage Class
Dispose Overload


PmbusMasterMessage.Dispose Method (Boolean)

PmbusMasterMessageDispose Method (Boolean)
Releases the unmanaged resources used by the PmbusMasterMessage and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
)
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.PmbusMasterMessage.Dispose(System.Boolean)"]

See Also

Reference

PmbusMasterMessage Class
Dispose Overload


PmbusMasterMessage Properties

PmbusMasterMessage Properties

The PmbusMasterMessage type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Public property | Command | Sets/gets the command byte of the message.
Public property | CommandExtension | Sets/gets the command extension byte of the message.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.Address Property

PmbusMasterMessageAddress Property
Sets/gets the I2C address of the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
Remarks
The SMBus supports only 7-bit I2C addresses.
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.Command Property

PmbusMasterMessageCommand Property
Sets/gets the command byte of the message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Command { get; set; }
Public Property Command As Byte
    Get
    Set
public:
property unsigned char Command {
    unsigned char get ();
    void set (unsigned char value);
}
member Command : byte with get, set

Property Value

Type: Byte
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.CommandExtension Property

PmbusMasterMessageCommandExtension Property
Sets/gets the command extension byte of the message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte CommandExtension { get; set; }
Public Property CommandExtension As Byte
    Get
    Set
public:
property unsigned char CommandExtension {
    unsigned char get ();
    void set (unsigned char value);
}
member CommandExtension : byte with get, set

Property Value

Type: Byte
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessage.WithPec Property

PmbusMasterMessageWithPec Property
Sets/gets whether the message will use PEC or not.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool WithPec { get; set; }
Public Property WithPec As Boolean
    Get
    Set
public:
property bool WithPec {
    bool get ();
    void set (bool value);
}
member WithPec : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PmbusMasterMessage Class


PmbusMasterMessageCmd Class

PmbusMasterMessageCmd Class
This class contains a submessage of a "Group Command" PMBus master message. Instances of this class are stored in PmbusMasterMessageGroupCmd objects.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessageCmd

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PmbusMasterMessageCmd : ICloneable
Public NotInheritable Class PmbusMasterMessageCmd
    Implements ICloneable
public ref class PmbusMasterMessageCmd sealed : ICloneable
[<SealedAttribute>]
type PmbusMasterMessageCmd =
    class
        interface ICloneable
    end

The PmbusMasterMessageCmd type exposes the following members.

Constructors
 | Name | Description
Public method | PmbusMasterMessageCmd | Constructor
Public method | PmbusMasterMessageCmd(I2cAddress, Byte, IEnumerableByte) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Public property | Command | Sets/gets the command byte of the message.
Public property | Data | Gets the data to be transmitted.
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageCmd Constructor

PmbusMasterMessageCmd Constructor
Overload List
 | Name | Description
Public method | PmbusMasterMessageCmd | Constructor
Public method | PmbusMasterMessageCmd(I2cAddress, Byte, IEnumerableByte) | Constructor
Top
See Also

Reference

PmbusMasterMessageCmd Class


PmbusMasterMessageCmd Constructor

PmbusMasterMessageCmd Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageCmd()
Public Sub New
public:
PmbusMasterMessageCmd()
new : unit -> PmbusMasterMessageCmd
See Also

Reference

PmbusMasterMessageCmd Class
PmbusMasterMessageCmd Overload


PmbusMasterMessageCmd Constructor (I2cAddress, Byte, IEnumerable(Byte))

PmbusMasterMessageCmd Constructor (I2cAddress, Byte, IEnumerableByte)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageCmd(
    I2cAddress i2c_address,
    byte cmd,
    IEnumerable<byte> data
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As IEnumerable(Of Byte)
)
public:
PmbusMasterMessageCmd(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    IEnumerable<unsigned char>^ data
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : IEnumerable<byte> -> PmbusMasterMessageCmd

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: System.Collections.GenericIEnumerable Byte
data to be transmitted
See Also

Reference

PmbusMasterMessageCmd Class
PmbusMasterMessageCmd Overload


PmbusMasterMessageCmd Methods

PmbusMasterMessageCmd Methods

The PmbusMasterMessageCmd type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessageCmd Class


PmbusMasterMessageCmd.Clone Method

PmbusMasterMessageCmdClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PmbusMasterMessageCmd Class


PmbusMasterMessageCmd Properties

PmbusMasterMessageCmd Properties

The PmbusMasterMessageCmd type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Public property | Command | Sets/gets the command byte of the message.
Public property | Data | Gets the data to be transmitted.
Top
See Also

Reference

PmbusMasterMessageCmd Class


PmbusMasterMessageCmd.Address Property

PmbusMasterMessageCmdAddress Property
Sets/gets the I2C address of the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
Remarks
The SMBus supports only 7-bit I2C addresses.
See Also

Reference

PmbusMasterMessageCmd Class


PmbusMasterMessageCmd.Command Property

PmbusMasterMessageCmdCommand Property
Sets/gets the command byte of the message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Command { get; set; }
Public Property Command As Byte
    Get
    Set
public:
property unsigned char Command {
    unsigned char get ();
    void set (unsigned char value);
}
member Command : byte with get, set

Property Value

Type: Byte
See Also

Reference

PmbusMasterMessageCmd Class


PmbusMasterMessageCmd.Data Property

PmbusMasterMessageCmdData Property
Gets the data to be transmitted.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<byte> Data { get; }
Public ReadOnly Property Data As List(Of Byte)
    Get
public:
property List<unsigned char>^ Data {
    List<unsigned char>^ get ();
}
member Data : List<byte> with get

Property Value

Type: List Byte
See Also

Reference

PmbusMasterMessageCmd Class


PmbusMasterMessageExtCmdByte Class

PmbusMasterMessageExtCmdByte Class
This class is used as a base class for the "Extended Command: Write Byte" and "Extended Command: Read Byte" PMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessage
telos.I2cApi.DotNetPmbusMasterMessageExtCmdByte
telos.I2cApi.DotNetPmbusMasterMessageReadByte
telos.I2cApi.DotNetPmbusMasterMessageWriteByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PmbusMasterMessageExtCmdByte : PmbusMasterMessage
Public MustInherit Class PmbusMasterMessageExtCmdByte
    Inherits PmbusMasterMessage
public ref class PmbusMasterMessageExtCmdByte abstract : public PmbusMasterMessage
[<AbstractClassAttribute>]
type PmbusMasterMessageExtCmdByte =
    class
        inherit PmbusMasterMessage
    end

The PmbusMasterMessageExtCmdByte type exposes the following members.

Constructors
 | Name | Description
Protected method | PmbusMasterMessageExtCmdByte | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from PmbusMasterMessage.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageExtCmdByte Constructor

PmbusMasterMessageExtCmdByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected PmbusMasterMessageExtCmdByte(
    I2cAddress i2c_address,
    byte cmd,
    byte cmd_ext,
    byte data,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    cmd_ext As Byte,
    data As Byte,
    with_pec As Boolean
)
protected:
PmbusMasterMessageExtCmdByte(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char cmd_ext,
    unsigned char data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        cmd_ext : byte *
        data : byte *
        with_pec : bool -> PmbusMasterMessageExtCmdByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
cmd_ext
Type: SystemByte
command extension byte
data
Type: SystemByte
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessageExtCmdByte Class


PmbusMasterMessageExtCmdByte Methods

PmbusMasterMessageExtCmdByte Methods

The PmbusMasterMessageExtCmdByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from PmbusMasterMessage.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessageExtCmdByte Class


PmbusMasterMessageExtCmdByte Properties

PmbusMasterMessageExtCmdByte Properties

The PmbusMasterMessageExtCmdByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

PmbusMasterMessageExtCmdByte Class


PmbusMasterMessageExtCmdByte.Data Property

PmbusMasterMessageExtCmdByteData Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Data { get; set; }
Public Property Data As Byte
    Get
    Set
public:
property unsigned char Data {
    unsigned char get ();
    void set (unsigned char value);
}
member Data : byte with get, set

Property Value

Type: Byte
See Also

Reference

PmbusMasterMessageExtCmdByte Class


PmbusMasterMessageExtCmdWord Class

PmbusMasterMessageExtCmdWord Class
This class is used as a base class for the "Extended Command: Write Word" and "Extended Command: Read Word" PMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessage
telos.I2cApi.DotNetPmbusMasterMessageExtCmdWord
telos.I2cApi.DotNetPmbusMasterMessageReadWord
telos.I2cApi.DotNetPmbusMasterMessageWriteWord

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PmbusMasterMessageExtCmdWord : PmbusMasterMessage
Public MustInherit Class PmbusMasterMessageExtCmdWord
    Inherits PmbusMasterMessage
public ref class PmbusMasterMessageExtCmdWord abstract : public PmbusMasterMessage
[<AbstractClassAttribute>]
type PmbusMasterMessageExtCmdWord =
    class
        inherit PmbusMasterMessage
    end

The PmbusMasterMessageExtCmdWord type exposes the following members.

Constructors
 | Name | Description
Protected method | PmbusMasterMessageExtCmdWord | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from PmbusMasterMessage.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageExtCmdWord Constructor

PmbusMasterMessageExtCmdWord Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected PmbusMasterMessageExtCmdWord(
    I2cAddress i2c_address,
    byte cmd,
    byte cmd_ext,
    ushort data,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    cmd_ext As Byte,
    data As UShort,
    with_pec As Boolean
)
protected:
PmbusMasterMessageExtCmdWord(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char cmd_ext,
    unsigned short data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        cmd_ext : byte *
        data : uint16 *
        with_pec : bool -> PmbusMasterMessageExtCmdWord

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
cmd_ext
Type: SystemByte
command extension byte
data
Type: SystemUInt16
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessageExtCmdWord Class


PmbusMasterMessageExtCmdWord Methods

PmbusMasterMessageExtCmdWord Methods

The PmbusMasterMessageExtCmdWord type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from PmbusMasterMessage.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessageExtCmdWord Class


PmbusMasterMessageExtCmdWord Properties

PmbusMasterMessageExtCmdWord Properties

The PmbusMasterMessageExtCmdWord type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

PmbusMasterMessageExtCmdWord Class


PmbusMasterMessageExtCmdWord.Data Property

PmbusMasterMessageExtCmdWordData Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort Data { get; set; }
Public Property Data As UShort
    Get
    Set
public:
property unsigned short Data {
    unsigned short get ();
    void set (unsigned short value);
}
member Data : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

PmbusMasterMessageExtCmdWord Class


PmbusMasterMessageGroupCmd Class

PmbusMasterMessageGroupCmd Class
This class specifies a "Group Command" (see section 5.2.3 in the standard) master message for the PMBus.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList PmbusMasterMessageCmd
telos.I2cApi.DotNetPmbusMasterMessageGroupCmd

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PmbusMasterMessageGroupCmd : List<PmbusMasterMessageCmd>,
    ICloneable
Public NotInheritable Class PmbusMasterMessageGroupCmd
    Inherits List(Of PmbusMasterMessageCmd)
    Implements ICloneable
public ref class PmbusMasterMessageGroupCmd sealed : public List<PmbusMasterMessageCmd^>,
    ICloneable
[<SealedAttribute>]
type PmbusMasterMessageGroupCmd =
    class
        inherit List<PmbusMasterMessageCmd>
        interface ICloneable
    end

The PmbusMasterMessageGroupCmd type exposes the following members.

Constructors
 | Name | Description
Public method | PmbusMasterMessageGroupCmd | Constructor
Public method | PmbusMasterMessageGroupCmd(IEnumerablePmbusMasterMessageCmd, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List PmbusMasterMessageCmd .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List PmbusMasterMessageCmd .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List PmbusMasterMessageCmd .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List PmbusMasterMessageCmd .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Clone | Creates a deep copy of the object.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List PmbusMasterMessageCmd .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List PmbusMasterMessageCmd .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List PmbusMasterMessageCmd .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List PmbusMasterMessageCmd .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List PmbusMasterMessageCmd .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List PmbusMasterMessageCmd .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List PmbusMasterMessageCmd .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List PmbusMasterMessageCmd .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List PmbusMasterMessageCmd .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List PmbusMasterMessageCmd .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
Remarks

The PMBus is specified in:

Copy
PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added.

A PMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the PMBus with the TransferData(PmbusMasterMessageGroupCmd) method.

Supports the ICloneable interface.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageGroupCmd Constructor

PmbusMasterMessageGroupCmd Constructor
Overload List
 | Name | Description
Public method | PmbusMasterMessageGroupCmd | Constructor
Public method | PmbusMasterMessageGroupCmd(IEnumerablePmbusMasterMessageCmd, Boolean) | Constructor
Top
See Also

Reference

PmbusMasterMessageGroupCmd Class


PmbusMasterMessageGroupCmd Constructor

PmbusMasterMessageGroupCmd Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageGroupCmd()
Public Sub New
public:
PmbusMasterMessageGroupCmd()
new : unit -> PmbusMasterMessageGroupCmd
See Also

Reference

PmbusMasterMessageGroupCmd Class
PmbusMasterMessageGroupCmd Overload


PmbusMasterMessageGroupCmd Constructor (IEnumerable(PmbusMasterMessageCmd), Boolean)

PmbusMasterMessageGroupCmd Constructor (IEnumerablePmbusMasterMessageCmd, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageGroupCmd(
    IEnumerable<PmbusMasterMessageCmd> cmds,
    bool with_pec
)
Public Sub New (
    cmds As IEnumerable(Of PmbusMasterMessageCmd),
    with_pec As Boolean
)
public:
PmbusMasterMessageGroupCmd(
    IEnumerable<PmbusMasterMessageCmd^>^ cmds,
    bool with_pec
)
new :
        cmds : IEnumerable<PmbusMasterMessageCmd> *
        with_pec : bool -> PmbusMasterMessageGroupCmd

Parameters

cmds
Type: System.Collections.GenericIEnumerable PmbusMasterMessageCmd
commands to be transmitted
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessageGroupCmd Class
PmbusMasterMessageGroupCmd Overload


PmbusMasterMessageGroupCmd Methods

PmbusMasterMessageGroupCmd Methods

The PmbusMasterMessageGroupCmd type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List PmbusMasterMessageCmd .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List PmbusMasterMessageCmd .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List PmbusMasterMessageCmd .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List PmbusMasterMessageCmd .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Clone | Creates a deep copy of the object.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List PmbusMasterMessageCmd .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List PmbusMasterMessageCmd .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List PmbusMasterMessageCmd .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List PmbusMasterMessageCmd .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List PmbusMasterMessageCmd .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List PmbusMasterMessageCmd .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List PmbusMasterMessageCmd .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List PmbusMasterMessageCmd .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List PmbusMasterMessageCmd .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List PmbusMasterMessageCmd .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List PmbusMasterMessageCmd .)
Top
See Also

Reference

PmbusMasterMessageGroupCmd Class


PmbusMasterMessageGroupCmd.Clone Method

PmbusMasterMessageGroupCmdClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PmbusMasterMessageGroupCmd Class


PmbusMasterMessageGroupCmd Properties

PmbusMasterMessageGroupCmd Properties

The PmbusMasterMessageGroupCmd type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List PmbusMasterMessageCmd .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List PmbusMasterMessageCmd .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List PmbusMasterMessageCmd .)
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

PmbusMasterMessageGroupCmd Class


PmbusMasterMessageGroupCmd.WithPec Property

PmbusMasterMessageGroupCmdWithPec Property
Sets/gets whether the message will use PEC or not.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool WithPec { get; set; }
Public Property WithPec As Boolean
    Get
    Set
public:
property bool WithPec {
    bool get ();
    void set (bool value);
}
member WithPec : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PmbusMasterMessageGroupCmd Class


PmbusMasterMessageReadByte Class

PmbusMasterMessageReadByte Class
This class specifies a "Extended Command: Read Byte" (see section 5.2.4 in the standard) master message for the PMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessage
telos.I2cApi.DotNetPmbusMasterMessageExtCmdByte
telos.I2cApi.DotNetPmbusMasterMessageReadByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PmbusMasterMessageReadByte : PmbusMasterMessageExtCmdByte
Public NotInheritable Class PmbusMasterMessageReadByte
    Inherits PmbusMasterMessageExtCmdByte
public ref class PmbusMasterMessageReadByte sealed : public PmbusMasterMessageExtCmdByte
[<SealedAttribute>]
type PmbusMasterMessageReadByte =
    class
        inherit PmbusMasterMessageExtCmdByte
    end

The PmbusMasterMessageReadByte type exposes the following members.

Constructors
 | Name | Description
Public method | PmbusMasterMessageReadByte | Constructor
Public method | PmbusMasterMessageReadByte(I2cAddress, Byte, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageReadByte Constructor

PmbusMasterMessageReadByte Constructor
Overload List
 | Name | Description
Public method | PmbusMasterMessageReadByte | Constructor
Public method | PmbusMasterMessageReadByte(I2cAddress, Byte, Byte, Boolean) | Constructor
Top
See Also

Reference

PmbusMasterMessageReadByte Class


PmbusMasterMessageReadByte Constructor

PmbusMasterMessageReadByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageReadByte()
Public Sub New
public:
PmbusMasterMessageReadByte()
new : unit -> PmbusMasterMessageReadByte
See Also

Reference

PmbusMasterMessageReadByte Class
PmbusMasterMessageReadByte Overload


PmbusMasterMessageReadByte Constructor (I2cAddress, Byte, Byte, Boolean)

PmbusMasterMessageReadByte Constructor (I2cAddress, Byte, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageReadByte(
    I2cAddress i2c_address,
    byte cmd,
    byte cmd_ext,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    cmd_ext As Byte,
    with_pec As Boolean
)
public:
PmbusMasterMessageReadByte(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char cmd_ext,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        cmd_ext : byte *
        with_pec : bool -> PmbusMasterMessageReadByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
cmd_ext
Type: SystemByte
command extension byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessageReadByte Class
PmbusMasterMessageReadByte Overload


PmbusMasterMessageReadByte Methods

PmbusMasterMessageReadByte Methods

The PmbusMasterMessageReadByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessageReadByte Class


PmbusMasterMessageReadByte.Clone Method

PmbusMasterMessageReadByteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PmbusMasterMessageReadByte Class


PmbusMasterMessageReadByte Properties

PmbusMasterMessageReadByte Properties

The PmbusMasterMessageReadByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

PmbusMasterMessageReadByte Class


PmbusMasterMessageReadWord Class

PmbusMasterMessageReadWord Class
This class specifies a "Extended Command: Read Word" (see section 5.2.5 in the standard) master message for the PMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessage
telos.I2cApi.DotNetPmbusMasterMessageExtCmdWord
telos.I2cApi.DotNetPmbusMasterMessageReadWord

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PmbusMasterMessageReadWord : PmbusMasterMessageExtCmdWord
Public NotInheritable Class PmbusMasterMessageReadWord
    Inherits PmbusMasterMessageExtCmdWord
public ref class PmbusMasterMessageReadWord sealed : public PmbusMasterMessageExtCmdWord
[<SealedAttribute>]
type PmbusMasterMessageReadWord =
    class
        inherit PmbusMasterMessageExtCmdWord
    end

The PmbusMasterMessageReadWord type exposes the following members.

Constructors
 | Name | Description
Public method | PmbusMasterMessageReadWord | Constructor
Public method | PmbusMasterMessageReadWord(I2cAddress, Byte, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageReadWord Constructor

PmbusMasterMessageReadWord Constructor
Overload List
 | Name | Description
Public method | PmbusMasterMessageReadWord | Constructor
Public method | PmbusMasterMessageReadWord(I2cAddress, Byte, Byte, Boolean) | Constructor
Top
See Also

Reference

PmbusMasterMessageReadWord Class


PmbusMasterMessageReadWord Constructor

PmbusMasterMessageReadWord Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageReadWord()
Public Sub New
public:
PmbusMasterMessageReadWord()
new : unit -> PmbusMasterMessageReadWord
See Also

Reference

PmbusMasterMessageReadWord Class
PmbusMasterMessageReadWord Overload


PmbusMasterMessageReadWord Constructor (I2cAddress, Byte, Byte, Boolean)

PmbusMasterMessageReadWord Constructor (I2cAddress, Byte, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageReadWord(
    I2cAddress i2c_address,
    byte cmd,
    byte cmd_ext,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    cmd_ext As Byte,
    with_pec As Boolean
)
public:
PmbusMasterMessageReadWord(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char cmd_ext,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        cmd_ext : byte *
        with_pec : bool -> PmbusMasterMessageReadWord

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
cmd_ext
Type: SystemByte
command extension byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessageReadWord Class
PmbusMasterMessageReadWord Overload


PmbusMasterMessageReadWord Methods

PmbusMasterMessageReadWord Methods

The PmbusMasterMessageReadWord type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessageReadWord Class


PmbusMasterMessageReadWord.Clone Method

PmbusMasterMessageReadWordClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PmbusMasterMessageReadWord Class


PmbusMasterMessageReadWord Properties

PmbusMasterMessageReadWord Properties

The PmbusMasterMessageReadWord type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

PmbusMasterMessageReadWord Class


PmbusMasterMessageWriteByte Class

PmbusMasterMessageWriteByte Class
This class specifies a "Extended Command: Write Byte" (see section 5.2.4 in the standard) master message for the PMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessage
telos.I2cApi.DotNetPmbusMasterMessageExtCmdByte
telos.I2cApi.DotNetPmbusMasterMessageWriteByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PmbusMasterMessageWriteByte : PmbusMasterMessageExtCmdByte
Public NotInheritable Class PmbusMasterMessageWriteByte
    Inherits PmbusMasterMessageExtCmdByte
public ref class PmbusMasterMessageWriteByte sealed : public PmbusMasterMessageExtCmdByte
[<SealedAttribute>]
type PmbusMasterMessageWriteByte =
    class
        inherit PmbusMasterMessageExtCmdByte
    end

The PmbusMasterMessageWriteByte type exposes the following members.

Constructors
 | Name | Description
Public method | PmbusMasterMessageWriteByte | Constructor
Public method | PmbusMasterMessageWriteByte(I2cAddress, Byte, Byte, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageWriteByte Constructor

PmbusMasterMessageWriteByte Constructor
Overload List
 | Name | Description
Public method | PmbusMasterMessageWriteByte | Constructor
Public method | PmbusMasterMessageWriteByte(I2cAddress, Byte, Byte, Byte, Boolean) | Constructor
Top
See Also

Reference

PmbusMasterMessageWriteByte Class


PmbusMasterMessageWriteByte Constructor

PmbusMasterMessageWriteByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageWriteByte()
Public Sub New
public:
PmbusMasterMessageWriteByte()
new : unit -> PmbusMasterMessageWriteByte
See Also

Reference

PmbusMasterMessageWriteByte Class
PmbusMasterMessageWriteByte Overload


PmbusMasterMessageWriteByte Constructor (I2cAddress, Byte, Byte, Byte, Boolean)

PmbusMasterMessageWriteByte Constructor (I2cAddress, Byte, Byte, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageWriteByte(
    I2cAddress i2c_address,
    byte cmd,
    byte cmd_ext,
    byte data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    cmd_ext As Byte,
    data As Byte,
    with_pec As Boolean
)
public:
PmbusMasterMessageWriteByte(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char cmd_ext,
    unsigned char data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        cmd_ext : byte *
        data : byte *
        with_pec : bool -> PmbusMasterMessageWriteByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
cmd_ext
Type: SystemByte
command extension byte
data
Type: SystemByte
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessageWriteByte Class
PmbusMasterMessageWriteByte Overload


PmbusMasterMessageWriteByte Methods

PmbusMasterMessageWriteByte Methods

The PmbusMasterMessageWriteByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessageWriteByte Class


PmbusMasterMessageWriteByte.Clone Method

PmbusMasterMessageWriteByteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PmbusMasterMessageWriteByte Class


PmbusMasterMessageWriteByte Properties

PmbusMasterMessageWriteByte Properties

The PmbusMasterMessageWriteByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

PmbusMasterMessageWriteByte Class


PmbusMasterMessageWriteWord Class

PmbusMasterMessageWriteWord Class
This class specifies a "Extended Command: Write Word" (see section 5.2.5 in the standard) master message for the PMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetPmbusMasterMessage
telos.I2cApi.DotNetPmbusMasterMessageExtCmdWord
telos.I2cApi.DotNetPmbusMasterMessageWriteWord

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PmbusMasterMessageWriteWord : PmbusMasterMessageExtCmdWord
Public NotInheritable Class PmbusMasterMessageWriteWord
    Inherits PmbusMasterMessageExtCmdWord
public ref class PmbusMasterMessageWriteWord sealed : public PmbusMasterMessageExtCmdWord
[<SealedAttribute>]
type PmbusMasterMessageWriteWord =
    class
        inherit PmbusMasterMessageExtCmdWord
    end

The PmbusMasterMessageWriteWord type exposes the following members.

Constructors
 | Name | Description
Public method | PmbusMasterMessageWriteWord | Constructor
Public method | PmbusMasterMessageWriteWord(I2cAddress, Byte, Byte, UInt16, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


PmbusMasterMessageWriteWord Constructor

PmbusMasterMessageWriteWord Constructor
Overload List
 | Name | Description
Public method | PmbusMasterMessageWriteWord | Constructor
Public method | PmbusMasterMessageWriteWord(I2cAddress, Byte, Byte, UInt16, Boolean) | Constructor
Top
See Also

Reference

PmbusMasterMessageWriteWord Class


PmbusMasterMessageWriteWord Constructor

PmbusMasterMessageWriteWord Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageWriteWord()
Public Sub New
public:
PmbusMasterMessageWriteWord()
new : unit -> PmbusMasterMessageWriteWord
See Also

Reference

PmbusMasterMessageWriteWord Class
PmbusMasterMessageWriteWord Overload


PmbusMasterMessageWriteWord Constructor (I2cAddress, Byte, Byte, UInt16, Boolean)

PmbusMasterMessageWriteWord Constructor (I2cAddress, Byte, Byte, UInt16, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public PmbusMasterMessageWriteWord(
    I2cAddress i2c_address,
    byte cmd,
    byte cmd_ext,
    ushort data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    cmd_ext As Byte,
    data As UShort,
    with_pec As Boolean
)
public:
PmbusMasterMessageWriteWord(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char cmd_ext,
    unsigned short data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        cmd_ext : byte *
        data : uint16 *
        with_pec : bool -> PmbusMasterMessageWriteWord

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
cmd_ext
Type: SystemByte
command extension byte
data
Type: SystemUInt16
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

PmbusMasterMessageWriteWord Class
PmbusMasterMessageWriteWord Overload


PmbusMasterMessageWriteWord Methods

PmbusMasterMessageWriteWord Methods

The PmbusMasterMessageWriteWord type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides PmbusMasterMessageClone.)
Public method | Dispose | (Inherited from PmbusMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from PmbusMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PmbusMasterMessageWriteWord Class


PmbusMasterMessageWriteWord.Clone Method

PmbusMasterMessageWriteWordClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

PmbusMasterMessageWriteWord Class


PmbusMasterMessageWriteWord Properties

PmbusMasterMessageWriteWord Properties

The PmbusMasterMessageWriteWord type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from PmbusMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from PmbusMasterMessage.)
Public property | CommandExtension | Sets/gets the command extension byte of the message. (Inherited from PmbusMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from PmbusMasterMessageExtCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from PmbusMasterMessage.)
Top
See Also

Reference

PmbusMasterMessageWriteWord Class


ReadOnlyListEnumerator(T) Class

ReadOnlyListEnumeratorT Class
Implements the IEnumeratorT interface for IReadOnlyListT.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetReadOnlyListEnumeratorT

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ReadOnlyListEnumerator<T> : IEnumerator<T>

Public Class ReadOnlyListEnumerator(Of T)
    Implements IEnumerator(Of T)
generic<typename T>
public ref class ReadOnlyListEnumerator : IEnumerator<T>
type ReadOnlyListEnumerator<'T> =
    class
        interface IEnumerator<'T>
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:telos.I2cApi.DotNet.ReadOnlyListEnumerator`1"]

The ReadOnlyListEnumeratorT type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyListEnumeratorT | Constructor.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Current_Generic | Gets the element at the current position.
Public property | Current_NonGeneric | Gets the element at the current position.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ReadOnlyListEnumerator(T) Constructor

ReadOnlyListEnumeratorT Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyListEnumerator(
    IReadOnlyList<T> list
)
Public Sub New (
    list As IReadOnlyList(Of T)
)
public:
ReadOnlyListEnumerator(
    IReadOnlyList<T>^ list
)
new :
        list : IReadOnlyList<'T> -> ReadOnlyListEnumerator

Parameters

list
Type: telos.I2cApi.DotNetIReadOnlyList T
list
See Also

Reference

ReadOnlyListEnumeratorT Class


ReadOnlyListEnumerator(T) Methods

ReadOnlyListEnumeratorT Methods

The ReadOnlyListEnumeratorT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadOnlyListEnumeratorT Class


ReadOnlyListEnumerator(T).Dispose Method

ReadOnlyListEnumeratorTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

ReadOnlyListEnumeratorT Class


ReadOnlyListEnumerator(T).Dispose Method

ReadOnlyListEnumeratorTDispose Method
Releases all resources.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

ReadOnlyListEnumeratorT Class
Dispose Overload


ReadOnlyListEnumerator(T).Dispose Method (Boolean)

ReadOnlyListEnumeratorTDispose Method (Boolean)
Releases the unmanaged resources used by the ReadOnlyListEnumeratorT and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
)
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.ReadOnlyListEnumerator`1.Dispose(System.Boolean)"]

See Also

Reference

ReadOnlyListEnumeratorT Class
Dispose Overload


ReadOnlyListEnumerator(T).MoveNext Method

ReadOnlyListEnumeratorTMoveNext Method
Advances the enumerator to the next element of the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Boolean
successfully advanced to next element (true), passed the end of the collection (false)
See Also

Reference

ReadOnlyListEnumeratorT Class


ReadOnlyListEnumerator(T).Reset Method

ReadOnlyListEnumeratorTReset Method
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ReadOnlyListEnumeratorT Class


ReadOnlyListEnumerator(T) Properties

ReadOnlyListEnumeratorT Properties

The ReadOnlyListEnumeratorT generic type exposes the following members.

Properties
 | Name | Description
Public property | Current_Generic | Gets the element at the current position.
Public property | Current_NonGeneric | Gets the element at the current position.
Top
See Also

Reference

ReadOnlyListEnumeratorT Class


ReadOnlyListEnumerator(T).Current_Generic Property

ReadOnlyListEnumeratorTCurrent_Generic Property
Gets the element at the current position.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public T Current_Generic { get; }
Public ReadOnly Property Current_Generic As T
    Get
public:
virtual property T Current_Generic {
    T get () sealed;
}
abstract Current_Generic : 'T with get
override Current_Generic : 'T with get

Property Value

Type: T

Implements

IEnumeratorTCurrent
See Also

Reference

ReadOnlyListEnumeratorT Class


ReadOnlyListEnumerator(T).Current_NonGeneric Property

ReadOnlyListEnumeratorTCurrent_NonGeneric Property
Gets the element at the current position.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Current_NonGeneric { get; }
Public ReadOnly Property Current_NonGeneric As Object
    Get
public:
virtual property Object^ Current_NonGeneric {
    Object^ get () sealed;
}
abstract Current_NonGeneric : Object with get
override Current_NonGeneric : Object with get

Property Value

Type: Object

Implements

IEnumeratorCurrent
See Also

Reference

ReadOnlyListEnumeratorT Class


ServiceContracts Class

ServiceContracts Class
This structure specifies the service contracts of an I2C interface.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetServiceContracts

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceContracts : ICloneable
Public NotInheritable Class ServiceContracts
    Implements ICloneable
public ref class ServiceContracts sealed : ICloneable
[<SealedAttribute>]
type ServiceContracts =
    class
        interface ICloneable
    end

The ServiceContracts type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceContracts | Initializes a new instance of the ServiceContracts class
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsNotAvailable | Tests whether the given service contract value is equivalent to N/A.
 | IsUnlimited | Tests whether the given service contract value is equivalent to unlimited.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Adc | A/D converter
Public property | Flasher | flasher
Public property | Ird | IRD
Public property | Labview | Labview VIs
Public property | Master | master
Public property | MasterHs | master high-speed
Public property | NegativeTester | negative tester
Public property | Tracer | tracer
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


ServiceContracts Constructor

ServiceContracts Constructor
Initializes a new instance of the ServiceContracts class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ServiceContracts()
Public Sub New
public:
ServiceContracts()
new : unit -> ServiceContracts
See Also

Reference

ServiceContracts Class


ServiceContracts Methods

ServiceContracts Methods

The ServiceContracts type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsNotAvailable | Tests whether the given service contract value is equivalent to N/A.
 | IsUnlimited | Tests whether the given service contract value is equivalent to unlimited.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceContracts Class


ServiceContracts.Clone Method

ServiceContractsClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

ServiceContracts Class


ServiceContracts.IsNotAvailable Method

ServiceContractsIsNotAvailable Method
Tests whether the given service contract value is equivalent to N/A.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsNotAvailable(
    DateTime service_contract
)
Public Shared Function IsNotAvailable (
    service_contract As DateTime
) As Boolean
public:
static bool IsNotAvailable(
    DateTime service_contract
)
static member IsNotAvailable :
        service_contract : DateTime -> bool

Parameters

service_contract
Type: SystemDateTime
value to be tested

Return Value

Type: Boolean
equivalent (true), not equivalent
See Also

Reference

ServiceContracts Class


ServiceContracts.IsUnlimited Method

ServiceContractsIsUnlimited Method
Tests whether the given service contract value is equivalent to unlimited.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsUnlimited(
    DateTime service_contract
)
Public Shared Function IsUnlimited (
    service_contract As DateTime
) As Boolean
public:
static bool IsUnlimited(
    DateTime service_contract
)
static member IsUnlimited :
        service_contract : DateTime -> bool

Parameters

service_contract
Type: SystemDateTime
value to be tested

Return Value

Type: Boolean
equivalent (true), not equivalent
See Also

Reference

ServiceContracts Class


ServiceContracts Properties

ServiceContracts Properties

The ServiceContracts type exposes the following members.

Properties
 | Name | Description
Public property | Adc | A/D converter
Public property | Flasher | flasher
Public property | Ird | IRD
Public property | Labview | Labview VIs
Public property | Master | master
Public property | MasterHs | master high-speed
Public property | NegativeTester | negative tester
Public property | Tracer | tracer
Top
See Also

Reference

ServiceContracts Class


ServiceContracts.Adc Property

ServiceContractsAdc Property
A/D converter

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime Adc { get; set; }
Public Property Adc As DateTime
    Get
    Set
public:
property DateTime Adc {
    DateTime get ();
    void set (DateTime value);
}
member Adc : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


ServiceContracts.Flasher Property

ServiceContractsFlasher Property
flasher

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime Flasher { get; set; }
Public Property Flasher As DateTime
    Get
    Set
public:
property DateTime Flasher {
    DateTime get ();
    void set (DateTime value);
}
member Flasher : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


ServiceContracts.Ird Property

ServiceContractsIrd Property
IRD

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime Ird { get; set; }
Public Property Ird As DateTime
    Get
    Set
public:
property DateTime Ird {
    DateTime get ();
    void set (DateTime value);
}
member Ird : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


ServiceContracts.Labview Property

ServiceContractsLabview Property
Labview VIs

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime Labview { get; set; }
Public Property Labview As DateTime
    Get
    Set
public:
property DateTime Labview {
    DateTime get ();
    void set (DateTime value);
}
member Labview : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


ServiceContracts.Master Property

ServiceContractsMaster Property
master

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime Master { get; set; }
Public Property Master As DateTime
    Get
    Set
public:
property DateTime Master {
    DateTime get ();
    void set (DateTime value);
}
member Master : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


ServiceContracts.MasterHs Property

ServiceContractsMasterHs Property
master high-speed

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime MasterHs { get; set; }
Public Property MasterHs As DateTime
    Get
    Set
public:
property DateTime MasterHs {
    DateTime get ();
    void set (DateTime value);
}
member MasterHs : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


ServiceContracts.NegativeTester Property

ServiceContractsNegativeTester Property
negative tester

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime NegativeTester { get; set; }
Public Property NegativeTester As DateTime
    Get
    Set
public:
property DateTime NegativeTester {
    DateTime get ();
    void set (DateTime value);
}
member NegativeTester : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


ServiceContracts.Tracer Property

ServiceContractsTracer Property
tracer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public DateTime Tracer { get; set; }
Public Property Tracer As DateTime
    Get
    Set
public:
property DateTime Tracer {
    DateTime get ();
    void set (DateTime value);
}
member Tracer : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServiceContracts Class


SlaveRam Class

SlaveRam Class
Tracii XL can emulate an I2C RAM slave. This class can be used to enable/disable this slave. The slave will listen on the specified I2C address.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSlaveRam

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SlaveRam : IDisposable
Public NotInheritable Class SlaveRam
    Implements IDisposable
public ref class SlaveRam sealed : IDisposable
[<SealedAttribute>]
type SlaveRam =
    class
        interface IDisposable
    end

The SlaveRam type exposes the following members.

Constructors
 | Name | Description
Public method | SlaveRam | Constructor.
Top
Methods
 | Name | Description
Public method | Disable | Disables the RAM emulation.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Enable | Enables the RAM emulation. The RAM will listen on the specified I2C address. Only 7 bit I2C addresses can be used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Gets the I2C address of the emulated RAM.
Public property | Enabled | Returns whether the RAM emulation is running.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SlaveRam Constructor

SlaveRam Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SlaveRam(
    Board board
)
Public Sub New (
    board As Board
)
public:
SlaveRam(
    Board^ board
)
new :
        board : Board -> SlaveRam

Parameters

board
Type: telos.I2cApi.DotNetBoard
Tracii XL interface to be used
See Also

Reference

SlaveRam Class


SlaveRam Methods

SlaveRam Methods

The SlaveRam type exposes the following members.

Methods
 | Name | Description
Public method | Disable | Disables the RAM emulation.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Enable | Enables the RAM emulation. The RAM will listen on the specified I2C address. Only 7 bit I2C addresses can be used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SlaveRam Class


SlaveRam.Disable Method

SlaveRamDisable Method
Disables the RAM emulation.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Disable()
Public Sub Disable
public:
void Disable()
member Disable : unit -> unit
See Also

Reference

SlaveRam Class


SlaveRam.Dispose Method

SlaveRamDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

SlaveRam Class


SlaveRam.Dispose Method

SlaveRamDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SlaveRam Class
Dispose Overload


SlaveRam.Dispose Method (Boolean)

SlaveRamDispose Method (Boolean)
Releases the unmanaged resources used by the SlaveRam and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.SlaveRam.Dispose(System.Boolean)"]

See Also

Reference

SlaveRam Class
Dispose Overload


SlaveRam.Enable Method

SlaveRamEnable Method
Enables the RAM emulation. The RAM will listen on the specified I2C address. Only 7 bit I2C addresses can be used.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Enable(
    I2cAddress i2c_address
)
Public Sub Enable (
    i2c_address As I2cAddress
)
public:
void Enable(
    I2cAddress^ i2c_address
)
member Enable :
        i2c_address : I2cAddress -> unit

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
See Also

Reference

SlaveRam Class


SlaveRam.Finalize Method

SlaveRamFinalize Method
Finalize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

SlaveRam Class


SlaveRam Properties

SlaveRam Properties

The SlaveRam type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the I2C address of the emulated RAM.
Public property | Enabled | Returns whether the RAM emulation is running.
Top
See Also

Reference

SlaveRam Class


SlaveRam.Address Property

SlaveRamAddress Property
Gets the I2C address of the emulated RAM.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; }
Public ReadOnly Property Address As I2cAddress
    Get
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
}
member Address : I2cAddress with get

Property Value

Type: I2cAddress
See Also

Reference

SlaveRam Class


SlaveRam.Enabled Property

SlaveRamEnabled Property
Returns whether the RAM emulation is running.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
public:
property bool Enabled {
    bool get ();
}
member Enabled : bool with get

Property Value

Type: Boolean
See Also

Reference

SlaveRam Class


SlaveRamEnhanced Class

SlaveRamEnhanced Class
Tracii XL 2.0 contains an enhanced I2C RAM slave. The slave emulates a RAM with up to 256 bytes. The I2C address and the memory size of the RAM can be configured. The RAM supports auto incrementing the address pointer.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSlaveRamEnhanced

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SlaveRamEnhanced : IDisposable
Public NotInheritable Class SlaveRamEnhanced
    Implements IDisposable
public ref class SlaveRamEnhanced sealed : IDisposable
[<SealedAttribute>]
type SlaveRamEnhanced =
    class
        interface IDisposable
    end

The SlaveRamEnhanced type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetData | Gets the current content of the emulated RAM.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetData | Sets one or several bytes in the emulate RAM.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Gets/sets the I2C address, which the slave RAM is listening on.
Public property | AddressMask | Gets/sets the I2C address mask. By default the mask is set to 0x3ff so that the slave will listen to the address, which has been configured by Address. If the mask is set to 0x00, the slave will answer on all 7-bit or 10-bit I2C addresses.
Public property | AutoIncrement | Gets/sets whether auto increment is enabled or disabled. If auto increment is enabled, the address pointer of the RAM gets incremented automatically after reading or writing bytes.
Public property | Enabled | Enables/disables the slave RAM.
Public property | MemorySize | Gets/sets the size of the emulated RAM (1..256). If auto increment has been enabled, the address pointer gets reset to zero after reaching the end of the memory.
Public property | Timeout | Gets/sets the timeout. If the transfer of one byte takes longer than the specified time, the RAM goes back to idle mode. This can be useful, if the RAM misses e.g. a clock cycle in slave transmitter mode and would block SDA for infinity. The timeout can be disabled by setting it to "-1 ms".
Top
Remarks

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the SlaveRamEnhanced property.

Normally the following steps are necessary to use the I2C RAM slave:

  1. Set the slave address using the Address property.
  2. Set the memory size using the MemorySize property.
  3. Configure auto increment using the AutoIncrement property.
  4. Enable the slave using the Enabled property.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SlaveRamEnhanced Methods

SlaveRamEnhanced Methods

The SlaveRamEnhanced type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetData | Gets the current content of the emulated RAM.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetData | Sets one or several bytes in the emulate RAM.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.Dispose Method

SlaveRamEnhancedDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.Dispose Method

SlaveRamEnhancedDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SlaveRamEnhanced Class
Dispose Overload


SlaveRamEnhanced.Dispose Method (Boolean)

SlaveRamEnhancedDispose Method (Boolean)
Releases the unmanaged resources used by the SlaveRamEnhanced and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.SlaveRamEnhanced.Dispose(System.Boolean)"]

See Also

Reference

SlaveRamEnhanced Class
Dispose Overload


SlaveRamEnhanced.Finalize Method

SlaveRamEnhancedFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.GetData Method

SlaveRamEnhancedGetData Method
Gets the current content of the emulated RAM.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] GetData()
Public Function GetData As Byte()
public:
array<unsigned char>^ GetData()
member GetData : unit -> byte[]

Return Value

Type: Byte
data read for the RAM
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.SetData Method

SlaveRamEnhancedSetData Method
Sets one or several bytes in the emulate RAM.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetData(
    byte start_address,
    byte[] data
)
Public Sub SetData (
    start_address As Byte,
    data As Byte()
)
public:
void SetData(
    unsigned char start_address,
    array<unsigned char>^ data
)
member SetData :
        start_address : byte *
        data : byte[] -> unit

Parameters

start_address
Type: SystemByte
address of the first byte to be set
data
Type: SystemByte
data to be set
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced Properties

SlaveRamEnhanced Properties

The SlaveRamEnhanced type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets/sets the I2C address, which the slave RAM is listening on.
Public property | AddressMask | Gets/sets the I2C address mask. By default the mask is set to 0x3ff so that the slave will listen to the address, which has been configured by Address. If the mask is set to 0x00, the slave will answer on all 7-bit or 10-bit I2C addresses.
Public property | AutoIncrement | Gets/sets whether auto increment is enabled or disabled. If auto increment is enabled, the address pointer of the RAM gets incremented automatically after reading or writing bytes.
Public property | Enabled | Enables/disables the slave RAM.
Public property | MemorySize | Gets/sets the size of the emulated RAM (1..256). If auto increment has been enabled, the address pointer gets reset to zero after reaching the end of the memory.
Public property | Timeout | Gets/sets the timeout. If the transfer of one byte takes longer than the specified time, the RAM goes back to idle mode. This can be useful, if the RAM misses e.g. a clock cycle in slave transmitter mode and would block SDA for infinity. The timeout can be disabled by setting it to "-1 ms".
Top
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.Address Property

SlaveRamEnhancedAddress Property
Gets/sets the I2C address, which the slave RAM is listening on.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.AddressMask Property

SlaveRamEnhancedAddressMask Property
Gets/sets the I2C address mask. By default the mask is set to 0x3ff so that the slave will listen to the address, which has been configured by Address. If the mask is set to 0x00, the slave will answer on all 7-bit or 10-bit I2C addresses.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort AddressMask { get; set; }
Public Property AddressMask As UShort
    Get
    Set
public:
property unsigned short AddressMask {
    unsigned short get ();
    void set (unsigned short value);
}
member AddressMask : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.AutoIncrement Property

SlaveRamEnhancedAutoIncrement Property
Gets/sets whether auto increment is enabled or disabled. If auto increment is enabled, the address pointer of the RAM gets incremented automatically after reading or writing bytes.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AutoIncrement { get; set; }
Public Property AutoIncrement As Boolean
    Get
    Set
public:
property bool AutoIncrement {
    bool get ();
    void set (bool value);
}
member AutoIncrement : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.Enabled Property

SlaveRamEnhancedEnabled Property
Enables/disables the slave RAM.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.MemorySize Property

SlaveRamEnhancedMemorySize Property
Gets/sets the size of the emulated RAM (1..256). If auto increment has been enabled, the address pointer gets reset to zero after reaching the end of the memory.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint MemorySize { get; set; }
Public Property MemorySize As UInteger
    Get
    Set
public:
property unsigned int MemorySize {
    unsigned int get ();
    void set (unsigned int value);
}
member MemorySize : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SlaveRamEnhanced Class


SlaveRamEnhanced.Timeout Property

SlaveRamEnhancedTimeout Property
Gets/sets the timeout. If the transfer of one byte takes longer than the specified time, the RAM goes back to idle mode. This can be useful, if the RAM misses e.g. a clock cycle in slave transmitter mode and would block SDA for infinity. The timeout can be disabled by setting it to "-1 ms".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

SlaveRamEnhanced Class


SmbArpMaster Class

SmbArpMaster Class
This class implements the SMBus address resolution protocol (ARP).
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbArpMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbArpMaster : IDisposable
Public NotInheritable Class SmbArpMaster
    Implements IDisposable
public ref class SmbArpMaster sealed : IDisposable
[<SealedAttribute>]
type SmbArpMaster =
    class
        interface IDisposable
    end

The SmbArpMaster type exposes the following members.

Constructors
 | Name | Description
Public method | SmbArpMaster | Constructor
Top
Methods
 | Name | Description
Public method | AssignAddress | Sends a SMBus "Assign Address" command.
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteArp | This method executes the complete ARP process. After sending "Prepare to ARP" to the SMBus, this method assigns an I2C address to each found slave device.
Protected method | Finalize | Destructor (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUdid(SmbArpMasterUdid) | Sends a SMBus "Get UDID (General)" command.
Public method | GetUdid(I2cAddress, SmbArpMasterUdid) | Sends a SMBus "Get UDID (Directed)" command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareToArp | Sends a SMBus "Prepare to ARP" command.
Public method | ResetDevice | Sends a SMBus "Reset Device (General)" command.
Public method | ResetDevice(I2cAddress) | Sends a SMBus "Reset Device ARP (Directed)" command.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

The SMBus is specified in:

Copy
System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Normally only the ExecuteArp(IEnumerableI2cAddress) method has to be used. This method assigns I2C addresses to all found slave devices.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbArpMaster Constructor

SmbArpMaster Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbArpMaster(
    Board board
)
Public Sub New (
    board As Board
)
public:
SmbArpMaster(
    Board^ board
)
new :
        board : Board -> SmbArpMaster

Parameters

board
Type: telos.I2cApi.DotNetBoard
I2C interface
See Also

Reference

SmbArpMaster Class


SmbArpMaster Methods

SmbArpMaster Methods

The SmbArpMaster type exposes the following members.

Methods
 | Name | Description
Public method | AssignAddress | Sends a SMBus "Assign Address" command.
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteArp | This method executes the complete ARP process. After sending "Prepare to ARP" to the SMBus, this method assigns an I2C address to each found slave device.
Protected method | Finalize | Destructor (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUdid(SmbArpMasterUdid) | Sends a SMBus "Get UDID (General)" command.
Public method | GetUdid(I2cAddress, SmbArpMasterUdid) | Sends a SMBus "Get UDID (Directed)" command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareToArp | Sends a SMBus "Prepare to ARP" command.
Public method | ResetDevice | Sends a SMBus "Reset Device (General)" command.
Public method | ResetDevice(I2cAddress) | Sends a SMBus "Reset Device ARP (Directed)" command.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbArpMaster Class


SmbArpMaster.AssignAddress Method

SmbArpMasterAssignAddress Method
Sends a SMBus "Assign Address" command.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void AssignAddress(
    SmbArpMasterUdid udid,
    I2cAddress addr
)
Public Sub AssignAddress (
    udid As SmbArpMasterUdid,
    addr As I2cAddress
)
public:
void AssignAddress(
    SmbArpMasterUdid^ udid,
    I2cAddress^ addr
)
member AssignAddress :
        udid : SmbArpMasterUdid *
        addr : I2cAddress -> unit

Parameters

udid
Type: telos.I2cApi.DotNetSmbArpMasterUdid
UDID of the slave device
addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address to be assigned to the slave device
See Also

Reference

SmbArpMaster Class


SmbArpMaster.Dispose Method

SmbArpMasterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

SmbArpMaster Class


SmbArpMaster.Dispose Method

SmbArpMasterDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SmbArpMaster Class
Dispose Overload


SmbArpMaster.Dispose Method (Boolean)

SmbArpMasterDispose Method (Boolean)
Releases the unmanaged resources used by the SmbArpMaster and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.SmbArpMaster.Dispose(System.Boolean)"]

See Also

Reference

SmbArpMaster Class
Dispose Overload


SmbArpMaster.ExecuteArp Method

SmbArpMasterExecuteArp Method
This method executes the complete ARP process. After sending "Prepare to ARP" to the SMBus, this method assigns an I2C address to each found slave device.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbArpMasterUdid[] ExecuteArp(
    IEnumerable<I2cAddress> reserved_addr
)
Public Function ExecuteArp (
    reserved_addr As IEnumerable(Of I2cAddress)
) As SmbArpMasterUdid()
public:
array<SmbArpMasterUdid^>^ ExecuteArp(
    IEnumerable<I2cAddress^>^ reserved_addr
)
member ExecuteArp :
        reserved_addr : IEnumerable<I2cAddress> -> SmbArpMasterUdid[]

Parameters

reserved_addr
Type: System.Collections.GenericIEnumerable I2cAddress
I2C addresses, which cannot be assigned to ARP slaves

Return Value

Type: SmbArpMasterUdid
UDID information of the found slave devices
Remarks
If there are slave devices on the SMBus, which do not support the ARP protocol, their I2C address must be added to the reserved_addr parameter.
See Also

Reference

SmbArpMaster Class


SmbArpMaster.Finalize Method

SmbArpMasterFinalize Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

SmbArpMaster Class


SmbArpMaster.GetUdid Method

SmbArpMasterGetUdid Method
Overload List
 | Name | Description
Public method | GetUdid(SmbArpMasterUdid) | Sends a SMBus "Get UDID (General)" command.
Public method | GetUdid(I2cAddress, SmbArpMasterUdid) | Sends a SMBus "Get UDID (Directed)" command.
Top
See Also

Reference

SmbArpMaster Class


SmbArpMaster.GetUdid Method (SmbArpMaster.Udid)

SmbArpMasterGetUdid Method (SmbArpMasterUdid)
Sends a SMBus "Get UDID (General)" command.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetUdid(
    SmbArpMasterUdid udid
)
Public Sub GetUdid (
    udid As SmbArpMasterUdid
)
public:
void GetUdid(
    SmbArpMasterUdid^ udid
)
member GetUdid :
        udid : SmbArpMasterUdid -> unit

Parameters

udid
Type: telos.I2cApi.DotNetSmbArpMasterUdid
read UDID
See Also

Reference

SmbArpMaster Class
GetUdid Overload


SmbArpMaster.GetUdid Method (I2cAddress, SmbArpMaster.Udid)

SmbArpMasterGetUdid Method (I2cAddress, SmbArpMasterUdid)
Sends a SMBus "Get UDID (Directed)" command.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void GetUdid(
    I2cAddress addr,
    SmbArpMasterUdid udid
)
Public Sub GetUdid (
    addr As I2cAddress,
    udid As SmbArpMasterUdid
)
public:
void GetUdid(
    I2cAddress^ addr,
    SmbArpMasterUdid^ udid
)
member GetUdid :
        addr : I2cAddress *
        udid : SmbArpMasterUdid -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave device to be queried
udid
Type: telos.I2cApi.DotNetSmbArpMasterUdid
read UDID
See Also

Reference

SmbArpMaster Class
GetUdid Overload


SmbArpMaster.PrepareToArp Method

SmbArpMasterPrepareToArp Method
Sends a SMBus "Prepare to ARP" command.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void PrepareToArp()
Public Sub PrepareToArp
public:
void PrepareToArp()
member PrepareToArp : unit -> unit
See Also

Reference

SmbArpMaster Class


SmbArpMaster.ResetDevice Method

SmbArpMasterResetDevice Method
Overload List
 | Name | Description
Public method | ResetDevice | Sends a SMBus "Reset Device (General)" command.
Public method | ResetDevice(I2cAddress) | Sends a SMBus "Reset Device ARP (Directed)" command.
Top
See Also

Reference

SmbArpMaster Class


SmbArpMaster.ResetDevice Method

SmbArpMasterResetDevice Method
Sends a SMBus "Reset Device (General)" command.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ResetDevice()
Public Sub ResetDevice
public:
void ResetDevice()
member ResetDevice : unit -> unit
See Also

Reference

SmbArpMaster Class
ResetDevice Overload


SmbArpMaster.ResetDevice Method (I2cAddress)

SmbArpMasterResetDevice Method (I2cAddress)
Sends a SMBus "Reset Device ARP (Directed)" command.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ResetDevice(
    I2cAddress addr
)
Public Sub ResetDevice (
    addr As I2cAddress
)
public:
void ResetDevice(
    I2cAddress^ addr
)
member ResetDevice :
        addr : I2cAddress -> unit

Parameters

addr
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the the slave device
See Also

Reference

SmbArpMaster Class
ResetDevice Overload


SmbArpMaster.Udid Class

SmbArpMasterUdid Class
Each SMBus slave device supporting ARP has got an UDID.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbArpMasterUdid

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Udid : IDisposable
Public NotInheritable Class Udid
    Implements IDisposable
public ref class Udid sealed : IDisposable
[<SealedAttribute>]
type Udid =
    class
        interface IDisposable
    end

The SmbArpMasterUdid type exposes the following members.

Constructors
 | Name | Description
Public method | SmbArpMasterUdid | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetAddress | Returns the I2C address of the slave device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAddressAvailable | Tests whether the slave device has got an I2C address.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAddress | Sets the I2C address of the slave device.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AddressType | Gets the "Address Type".
Public property | AsfSupport | Gets "ASF Support".
Public property | DeviceId | Gets the "Device ID".
Public property | IpmiSupport | Gets "IPMI Support".
Public property | OemSupport | Gets "OEM Support".
Public property | PecSupport | Gets "PEC Supported".
Public property | RawUdid | Gets the raw UDID bytes as used on the SMBus.
Public property | SiliconRevision | Gets the "Silicion Revision ID".
Public property | SmbusVersion | Gets the "SMBus Version".
Public property | SubsystemDeviceId | Gets the "Subsystem Device ID".
Public property | SubsystemVendorId | Gets the "Subsystem Vendor ID".
Public property | UdidVersion | Gets the "UDID Version".
Public property | VendorId | Gets the "Vendor ID".
Public property | VendorSpecificId | Gets the "Vendor Specific ID".
Public property | ZoneSupport | Gets "ZONE Support".
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbArpMaster.Udid Constructor

SmbArpMasterUdid Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Udid()
Public Sub New
public:
Udid()
new : unit -> Udid
See Also

Reference

SmbArpMasterUdid Class


Udid Methods

Udid Methods

The SmbArpMasterUdid type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetAddress | Returns the I2C address of the slave device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAddressAvailable | Tests whether the slave device has got an I2C address.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAddress | Sets the I2C address of the slave device.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbArpMasterUdid Class


Udid.Dispose Method

UdidDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.Dispose Method

SmbArpMasterUdidDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SmbArpMasterUdid Class
Dispose Overload


SmbArpMaster.Udid.Dispose Method (Boolean)

SmbArpMasterUdidDispose Method (Boolean)
Releases the unmanaged resources used by the SmbArpMasterUdid and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.SmbArpMaster.Udid.Dispose(System.Boolean)"]

See Also

Reference

SmbArpMasterUdid Class
Dispose Overload


SmbArpMaster.Udid.Finalize Method

SmbArpMasterUdidFinalize Method
Finalize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.GetAddress Method

SmbArpMasterUdidGetAddress Method
Returns the I2C address of the slave device.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress GetAddress()
Public Function GetAddress As I2cAddress
public:
I2cAddress^ GetAddress()
member GetAddress : unit -> I2cAddress

Return Value

Type: I2cAddress
I2C slave address
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.IsAddressAvailable Method

SmbArpMasterUdidIsAddressAvailable Method
Tests whether the slave device has got an I2C address.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsAddressAvailable()
Public Function IsAddressAvailable As Boolean
public:
bool IsAddressAvailable()
member IsAddressAvailable : unit -> bool

Return Value

Type: Boolean
I2C address available (true), I2C address not available (false)
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.SetAddress Method

SmbArpMasterUdidSetAddress Method
Sets the I2C address of the slave device.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetAddress(
    I2cAddress address
)
Public Sub SetAddress (
    address As I2cAddress
)
public:
void SetAddress(
    I2cAddress^ address
)
member SetAddress :
        address : I2cAddress -> unit

Parameters

address
Type: telos.I2cApi.DotNetI2cAddress
I2C slave address
See Also

Reference

SmbArpMasterUdid Class


Udid Properties

Udid Properties

The SmbArpMasterUdid type exposes the following members.

Properties
 | Name | Description
Public property | AddressType | Gets the "Address Type".
Public property | AsfSupport | Gets "ASF Support".
Public property | DeviceId | Gets the "Device ID".
Public property | IpmiSupport | Gets "IPMI Support".
Public property | OemSupport | Gets "OEM Support".
Public property | PecSupport | Gets "PEC Supported".
Public property | RawUdid | Gets the raw UDID bytes as used on the SMBus.
Public property | SiliconRevision | Gets the "Silicion Revision ID".
Public property | SmbusVersion | Gets the "SMBus Version".
Public property | SubsystemDeviceId | Gets the "Subsystem Device ID".
Public property | SubsystemVendorId | Gets the "Subsystem Vendor ID".
Public property | UdidVersion | Gets the "UDID Version".
Public property | VendorId | Gets the "Vendor ID".
Public property | VendorSpecificId | Gets the "Vendor Specific ID".
Public property | ZoneSupport | Gets "ZONE Support".
Top
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.AddressType Property

SmbArpMasterUdidAddressType Property
Gets the "Address Type".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbArpMasterUdidAddrType AddressType { get; }
Public ReadOnly Property AddressType As SmbArpMasterUdidAddrType
    Get
public:
property SmbArpMasterUdidAddrType AddressType {
    SmbArpMasterUdidAddrType get ();
}
member AddressType : SmbArpMasterUdidAddrType with get

Property Value

Type: SmbArpMasterUdidAddrType
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.AsfSupport Property

SmbArpMasterUdidAsfSupport Property
Gets "ASF Support".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AsfSupport { get; }
Public ReadOnly Property AsfSupport As Boolean
    Get
public:
property bool AsfSupport {
    bool get ();
}
member AsfSupport : bool with get

Property Value

Type: Boolean
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.DeviceId Property

SmbArpMasterUdidDeviceId Property
Gets the "Device ID".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort DeviceId { get; }
Public ReadOnly Property DeviceId As UShort
    Get
public:
property unsigned short DeviceId {
    unsigned short get ();
}
member DeviceId : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.IpmiSupport Property

SmbArpMasterUdidIpmiSupport Property
Gets "IPMI Support".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IpmiSupport { get; }
Public ReadOnly Property IpmiSupport As Boolean
    Get
public:
property bool IpmiSupport {
    bool get ();
}
member IpmiSupport : bool with get

Property Value

Type: Boolean
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.OemSupport Property

SmbArpMasterUdidOemSupport Property
Gets "OEM Support".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool OemSupport { get; }
Public ReadOnly Property OemSupport As Boolean
    Get
public:
property bool OemSupport {
    bool get ();
}
member OemSupport : bool with get

Property Value

Type: Boolean
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.PecSupport Property

SmbArpMasterUdidPecSupport Property
Gets "PEC Supported".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool PecSupport { get; }
Public ReadOnly Property PecSupport As Boolean
    Get
public:
property bool PecSupport {
    bool get ();
}
member PecSupport : bool with get

Property Value

Type: Boolean
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.RawUdid Property

SmbArpMasterUdidRawUdid Property
Gets the raw UDID bytes as used on the SMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte[] RawUdid { get; }
Public ReadOnly Property RawUdid As Byte()
    Get
public:
property array<unsigned char>^ RawUdid {
    array<unsigned char>^ get ();
}
member RawUdid : byte[] with get

Property Value

Type: Byte
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.SiliconRevision Property

SmbArpMasterUdidSiliconRevision Property
Gets the "Silicion Revision ID".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte SiliconRevision { get; }
Public ReadOnly Property SiliconRevision As Byte
    Get
public:
property unsigned char SiliconRevision {
    unsigned char get ();
}
member SiliconRevision : byte with get

Property Value

Type: Byte
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.SmbusVersion Property

SmbArpMasterUdidSmbusVersion Property
Gets the "SMBus Version".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte SmbusVersion { get; }
Public ReadOnly Property SmbusVersion As Byte
    Get
public:
property unsigned char SmbusVersion {
    unsigned char get ();
}
member SmbusVersion : byte with get

Property Value

Type: Byte
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.SubsystemDeviceId Property

SmbArpMasterUdidSubsystemDeviceId Property
Gets the "Subsystem Device ID".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort SubsystemDeviceId { get; }
Public ReadOnly Property SubsystemDeviceId As UShort
    Get
public:
property unsigned short SubsystemDeviceId {
    unsigned short get ();
}
member SubsystemDeviceId : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.SubsystemVendorId Property

SmbArpMasterUdidSubsystemVendorId Property
Gets the "Subsystem Vendor ID".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort SubsystemVendorId { get; }
Public ReadOnly Property SubsystemVendorId As UShort
    Get
public:
property unsigned short SubsystemVendorId {
    unsigned short get ();
}
member SubsystemVendorId : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.UdidVersion Property

SmbArpMasterUdidUdidVersion Property
Gets the "UDID Version".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte UdidVersion { get; }
Public ReadOnly Property UdidVersion As Byte
    Get
public:
property unsigned char UdidVersion {
    unsigned char get ();
}
member UdidVersion : byte with get

Property Value

Type: Byte
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.VendorId Property

SmbArpMasterUdidVendorId Property
Gets the "Vendor ID".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort VendorId { get; }
Public ReadOnly Property VendorId As UShort
    Get
public:
property unsigned short VendorId {
    unsigned short get ();
}
member VendorId : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.VendorSpecificId Property

SmbArpMasterUdidVendorSpecificId Property
Gets the "Vendor Specific ID".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint VendorSpecificId { get; }
Public ReadOnly Property VendorSpecificId As UInteger
    Get
public:
property unsigned int VendorSpecificId {
    unsigned int get ();
}
member VendorSpecificId : uint32 with get

Property Value

Type: UInt32
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.ZoneSupport Property

SmbArpMasterUdidZoneSupport Property
Gets "ZONE Support".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ZoneSupport { get; }
Public ReadOnly Property ZoneSupport As Boolean
    Get
public:
property bool ZoneSupport {
    bool get ();
}
member ZoneSupport : bool with get

Property Value

Type: Boolean
See Also

Reference

SmbArpMasterUdid Class


SmbArpMaster.Udid.AddrType Enumeration

SmbArpMasterUdidAddrType Enumeration
This enumeration specifies the I2C address type used by a slave device.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum AddrType
Public Enumeration AddrType
public enum class AddrType
type AddrType
Members
Member name | Value | Description
ADDR_TYPE_FIXED | 0 | fixed address device
ADDR_TYPE_DYNAMIC_PERSISTENT | 1 | dynamic and persistent address device
ADDR_TYPE_DYNAMIC_VOLATILE | 2 | dynamic and volatile address device
ADDR_TYPE_RANDOM | 3 | random number device
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMaster Class

SmbMaster Class
This class can be used to send master messages to a SMBus and a PMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMaster

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMaster : IDisposable
Public NotInheritable Class SmbMaster
    Implements IDisposable
public ref class SmbMaster sealed : IDisposable
[<SealedAttribute>]
type SmbMaster =
    class
        interface IDisposable
    end

The SmbMaster type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMaster | Constructor: the I2C interface has to support the SMBus. Whether an I2C interface supports the SMBus can be determined by evaluating BusTypeSmb variable, which can be accessed using HardwareInfoOfOpenBoard.
Top
Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingAlerts | If at least one SMBus slave has pulled the SMBALERT line to low, this method sends "Alert Response" messages to get a list of devices in alert state (see section A.2 in the standard).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData(PmbusMasterMessage) | Sends a master message to the PMBus.
Public method | TransferData(PmbusMasterMessageGroupCmd) | Sends a "Group Command" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageReadByte) | Sends a "Extended Command: Read Byte" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageReadWord) | Sends a "Extended Command: Read Word" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageWriteByte) | Sends a "Extended Command: Write Byte" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageWriteWord) | Sends a "Extended Command: Write Word" master message to the PMBus.
Public method | TransferData(SmbMasterMessage) | Sends a master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockRead) | Sends a "Block Read" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockWrite) | Sends a "Block Write" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockWriteRead) | Sends a "Block Write Read" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageCmdProcessCall) | Sends a "Process Call" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageHostNotify) | Sends a "Host Notify" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageQuickCommand) | Sends a "Quick Command" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageRead32) | Sends a "Read 32" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageRead64) | Sends a "Read 64" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReadByte) | Sends a "Read Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReadWord) | Sends a "Read Word" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReceiveByte) | Sends a "Receive Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageSendByte) | Sends a "Send Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWrite32) | Sends a "Write 32" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWrite64) | Sends a "Write 64" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWriteByte) | Sends a "Write Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWriteWord) | Sends a "Write Word" master message to the SMBus/PMBus.
Top
Remarks

The SMBus is specified in:

Copy
System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Different message types are defined by the SMBus:

  • Quick Command
  • Send Byte
  • Receive Byte
  • Write Byte
  • Read Byte
  • Write Word
  • Read Word
  • Write 32
  • Read 32
  • Write 64
  • Read 64
  • Process Call
  • Block Write
  • Block Read
  • Block Write - Block Read Process Call
  • Host Notify

A SMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

The PMBus is specified in:

Copy
PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added:

  • Write Byte (with extension code)
  • Read Byte (with extension code)
  • Write Word (with extension code)
  • Read Word (with extension code)
  • Group Command
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMaster Constructor

SmbMaster Constructor
Constructor: the I2C interface has to support the SMBus. Whether an I2C interface supports the SMBus can be determined by evaluating BusTypeSmb variable, which can be accessed using HardwareInfoOfOpenBoard.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMaster(
    Board board
)
Public Sub New (
    board As Board
)
public:
SmbMaster(
    Board^ board
)
new :
        board : Board -> SmbMaster

Parameters

board
Type: telos.I2cApi.DotNetBoard
Board object, to which the SMBus master messages should be sent.
See Also

Reference

SmbMaster Class


SmbMaster Methods

SmbMaster Methods

The SmbMaster type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingAlerts | If at least one SMBus slave has pulled the SMBALERT line to low, this method sends "Alert Response" messages to get a list of devices in alert state (see section A.2 in the standard).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransferData(PmbusMasterMessage) | Sends a master message to the PMBus.
Public method | TransferData(PmbusMasterMessageGroupCmd) | Sends a "Group Command" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageReadByte) | Sends a "Extended Command: Read Byte" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageReadWord) | Sends a "Extended Command: Read Word" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageWriteByte) | Sends a "Extended Command: Write Byte" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageWriteWord) | Sends a "Extended Command: Write Word" master message to the PMBus.
Public method | TransferData(SmbMasterMessage) | Sends a master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockRead) | Sends a "Block Read" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockWrite) | Sends a "Block Write" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockWriteRead) | Sends a "Block Write Read" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageCmdProcessCall) | Sends a "Process Call" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageHostNotify) | Sends a "Host Notify" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageQuickCommand) | Sends a "Quick Command" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageRead32) | Sends a "Read 32" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageRead64) | Sends a "Read 64" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReadByte) | Sends a "Read Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReadWord) | Sends a "Read Word" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReceiveByte) | Sends a "Receive Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageSendByte) | Sends a "Send Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWrite32) | Sends a "Write 32" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWrite64) | Sends a "Write 64" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWriteByte) | Sends a "Write Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWriteWord) | Sends a "Write Word" master message to the SMBus/PMBus.
Top
See Also

Reference

SmbMaster Class


SmbMaster.Dispose Method

SmbMasterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor
Protected method | Dispose(Boolean) |
Top
See Also

Reference

SmbMaster Class


SmbMaster.Dispose Method

SmbMasterDispose Method
Destructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SmbMaster Class
Dispose Overload


SmbMaster.Dispose Method (Boolean)

SmbMasterDispose Method (Boolean)
Releases the unmanaged resources used by the SmbMaster and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.SmbMaster.Dispose(System.Boolean)"]

See Also

Reference

SmbMaster Class
Dispose Overload


SmbMaster.Finalize Method

SmbMasterFinalize Method
Finalize

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

SmbMaster Class


SmbMaster.GetPendingAlerts Method

SmbMasterGetPendingAlerts Method
If at least one SMBus slave has pulled the SMBALERT line to low, this method sends "Alert Response" messages to get a list of devices in alert state (see section A.2 in the standard).

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress[] GetPendingAlerts(
    bool ignore_alert_pin
)
Public Function GetPendingAlerts (
    ignore_alert_pin As Boolean
) As I2cAddress()
public:
array<I2cAddress^>^ GetPendingAlerts(
    bool ignore_alert_pin
)
member GetPendingAlerts :
        ignore_alert_pin : bool -> I2cAddress[]

Parameters

ignore_alert_pin
Type: SystemBoolean
use SMBALERT line (false), ignore SMBALERT line (true)

Return Value

Type: I2cAddress
devices in alert state
See Also

Reference

SmbMaster Class


SmbMaster.TransferData Method

SmbMasterTransferData Method
Overload List
 | Name | Description
Public method | TransferData(PmbusMasterMessage) | Sends a master message to the PMBus.
Public method | TransferData(PmbusMasterMessageGroupCmd) | Sends a "Group Command" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageReadByte) | Sends a "Extended Command: Read Byte" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageReadWord) | Sends a "Extended Command: Read Word" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageWriteByte) | Sends a "Extended Command: Write Byte" master message to the PMBus.
Public method | TransferData(PmbusMasterMessageWriteWord) | Sends a "Extended Command: Write Word" master message to the PMBus.
Public method | TransferData(SmbMasterMessage) | Sends a master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockRead) | Sends a "Block Read" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockWrite) | Sends a "Block Write" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageBlockWriteRead) | Sends a "Block Write Read" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageCmdProcessCall) | Sends a "Process Call" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageHostNotify) | Sends a "Host Notify" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageQuickCommand) | Sends a "Quick Command" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageRead32) | Sends a "Read 32" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageRead64) | Sends a "Read 64" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReadByte) | Sends a "Read Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReadWord) | Sends a "Read Word" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageReceiveByte) | Sends a "Receive Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageSendByte) | Sends a "Send Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWrite32) | Sends a "Write 32" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWrite64) | Sends a "Write 64" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWriteByte) | Sends a "Write Byte" master message to the SMBus/PMBus.
Public method | TransferData(SmbMasterMessageWriteWord) | Sends a "Write Word" master message to the SMBus/PMBus.
Top
See Also

Reference

SmbMaster Class


SmbMaster.TransferData Method (PmbusMasterMessage)

SmbMasterTransferData Method (PmbusMasterMessage)
Sends a master message to the PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    PmbusMasterMessage msg
)
Public Sub TransferData (
    msg As PmbusMasterMessage
)
public:
void TransferData(
    PmbusMasterMessage^ msg
)
member TransferData :
        msg : PmbusMasterMessage -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessage
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (PmbusMasterMessageGroupCmd)

SmbMasterTransferData Method (PmbusMasterMessageGroupCmd)
Sends a "Group Command" master message to the PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    PmbusMasterMessageGroupCmd msg
)
Public Sub TransferData (
    msg As PmbusMasterMessageGroupCmd
)
public:
void TransferData(
    PmbusMasterMessageGroupCmd^ msg
)
member TransferData :
        msg : PmbusMasterMessageGroupCmd -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessageGroupCmd
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (PmbusMasterMessageReadByte)

SmbMasterTransferData Method (PmbusMasterMessageReadByte)
Sends a "Extended Command: Read Byte" master message to the PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    PmbusMasterMessageReadByte msg
)
Public Sub TransferData (
    msg As PmbusMasterMessageReadByte
)
public:
void TransferData(
    PmbusMasterMessageReadByte^ msg
)
member TransferData :
        msg : PmbusMasterMessageReadByte -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessageReadByte
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (PmbusMasterMessageReadWord)

SmbMasterTransferData Method (PmbusMasterMessageReadWord)
Sends a "Extended Command: Read Word" master message to the PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    PmbusMasterMessageReadWord msg
)
Public Sub TransferData (
    msg As PmbusMasterMessageReadWord
)
public:
void TransferData(
    PmbusMasterMessageReadWord^ msg
)
member TransferData :
        msg : PmbusMasterMessageReadWord -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessageReadWord
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (PmbusMasterMessageWriteByte)

SmbMasterTransferData Method (PmbusMasterMessageWriteByte)
Sends a "Extended Command: Write Byte" master message to the PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    PmbusMasterMessageWriteByte msg
)
Public Sub TransferData (
    msg As PmbusMasterMessageWriteByte
)
public:
void TransferData(
    PmbusMasterMessageWriteByte^ msg
)
member TransferData :
        msg : PmbusMasterMessageWriteByte -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessageWriteByte
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (PmbusMasterMessageWriteWord)

SmbMasterTransferData Method (PmbusMasterMessageWriteWord)
Sends a "Extended Command: Write Word" master message to the PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    PmbusMasterMessageWriteWord msg
)
Public Sub TransferData (
    msg As PmbusMasterMessageWriteWord
)
public:
void TransferData(
    PmbusMasterMessageWriteWord^ msg
)
member TransferData :
        msg : PmbusMasterMessageWriteWord -> unit

Parameters

msg
Type: telos.I2cApi.DotNetPmbusMasterMessageWriteWord
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessage)

SmbMasterTransferData Method (SmbMasterMessage)
Sends a master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessage msg
)
Public Sub TransferData (
    msg As SmbMasterMessage
)
public:
void TransferData(
    SmbMasterMessage^ msg
)
member TransferData :
        msg : SmbMasterMessage -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessage
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageBlockRead)

SmbMasterTransferData Method (SmbMasterMessageBlockRead)
Sends a "Block Read" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageBlockRead msg
)
Public Sub TransferData (
    msg As SmbMasterMessageBlockRead
)
public:
void TransferData(
    SmbMasterMessageBlockRead^ msg
)
member TransferData :
        msg : SmbMasterMessageBlockRead -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageBlockRead
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageBlockWrite)

SmbMasterTransferData Method (SmbMasterMessageBlockWrite)
Sends a "Block Write" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageBlockWrite msg
)
Public Sub TransferData (
    msg As SmbMasterMessageBlockWrite
)
public:
void TransferData(
    SmbMasterMessageBlockWrite^ msg
)
member TransferData :
        msg : SmbMasterMessageBlockWrite -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageBlockWrite
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageBlockWriteRead)

SmbMasterTransferData Method (SmbMasterMessageBlockWriteRead)
Sends a "Block Write Read" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageBlockWriteRead msg
)
Public Sub TransferData (
    msg As SmbMasterMessageBlockWriteRead
)
public:
void TransferData(
    SmbMasterMessageBlockWriteRead^ msg
)
member TransferData :
        msg : SmbMasterMessageBlockWriteRead -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageBlockWriteRead
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageCmdProcessCall)

SmbMasterTransferData Method (SmbMasterMessageCmdProcessCall)
Sends a "Process Call" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageCmdProcessCall msg
)
Public Sub TransferData (
    msg As SmbMasterMessageCmdProcessCall
)
public:
void TransferData(
    SmbMasterMessageCmdProcessCall^ msg
)
member TransferData :
        msg : SmbMasterMessageCmdProcessCall -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageCmdProcessCall
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageHostNotify)

SmbMasterTransferData Method (SmbMasterMessageHostNotify)
Sends a "Host Notify" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageHostNotify msg
)
Public Sub TransferData (
    msg As SmbMasterMessageHostNotify
)
public:
void TransferData(
    SmbMasterMessageHostNotify^ msg
)
member TransferData :
        msg : SmbMasterMessageHostNotify -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageHostNotify
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageQuickCommand)

SmbMasterTransferData Method (SmbMasterMessageQuickCommand)
Sends a "Quick Command" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageQuickCommand msg
)
Public Sub TransferData (
    msg As SmbMasterMessageQuickCommand
)
public:
void TransferData(
    SmbMasterMessageQuickCommand^ msg
)
member TransferData :
        msg : SmbMasterMessageQuickCommand -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageQuickCommand
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageRead32)

SmbMasterTransferData Method (SmbMasterMessageRead32)
Sends a "Read 32" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageRead32 msg
)
Public Sub TransferData (
    msg As SmbMasterMessageRead32
)
public:
void TransferData(
    SmbMasterMessageRead32^ msg
)
member TransferData :
        msg : SmbMasterMessageRead32 -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageRead32
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageRead64)

SmbMasterTransferData Method (SmbMasterMessageRead64)
Sends a "Read 64" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageRead64 msg
)
Public Sub TransferData (
    msg As SmbMasterMessageRead64
)
public:
void TransferData(
    SmbMasterMessageRead64^ msg
)
member TransferData :
        msg : SmbMasterMessageRead64 -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageRead64
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageReadByte)

SmbMasterTransferData Method (SmbMasterMessageReadByte)
Sends a "Read Byte" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageReadByte msg
)
Public Sub TransferData (
    msg As SmbMasterMessageReadByte
)
public:
void TransferData(
    SmbMasterMessageReadByte^ msg
)
member TransferData :
        msg : SmbMasterMessageReadByte -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageReadByte
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageReadWord)

SmbMasterTransferData Method (SmbMasterMessageReadWord)
Sends a "Read Word" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageReadWord msg
)
Public Sub TransferData (
    msg As SmbMasterMessageReadWord
)
public:
void TransferData(
    SmbMasterMessageReadWord^ msg
)
member TransferData :
        msg : SmbMasterMessageReadWord -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageReadWord
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageReceiveByte)

SmbMasterTransferData Method (SmbMasterMessageReceiveByte)
Sends a "Receive Byte" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageReceiveByte msg
)
Public Sub TransferData (
    msg As SmbMasterMessageReceiveByte
)
public:
void TransferData(
    SmbMasterMessageReceiveByte^ msg
)
member TransferData :
        msg : SmbMasterMessageReceiveByte -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageReceiveByte
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageSendByte)

SmbMasterTransferData Method (SmbMasterMessageSendByte)
Sends a "Send Byte" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageSendByte msg
)
Public Sub TransferData (
    msg As SmbMasterMessageSendByte
)
public:
void TransferData(
    SmbMasterMessageSendByte^ msg
)
member TransferData :
        msg : SmbMasterMessageSendByte -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageSendByte
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageWrite32)

SmbMasterTransferData Method (SmbMasterMessageWrite32)
Sends a "Write 32" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageWrite32 msg
)
Public Sub TransferData (
    msg As SmbMasterMessageWrite32
)
public:
void TransferData(
    SmbMasterMessageWrite32^ msg
)
member TransferData :
        msg : SmbMasterMessageWrite32 -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageWrite32
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageWrite64)

SmbMasterTransferData Method (SmbMasterMessageWrite64)
Sends a "Write 64" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageWrite64 msg
)
Public Sub TransferData (
    msg As SmbMasterMessageWrite64
)
public:
void TransferData(
    SmbMasterMessageWrite64^ msg
)
member TransferData :
        msg : SmbMasterMessageWrite64 -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageWrite64
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageWriteByte)

SmbMasterTransferData Method (SmbMasterMessageWriteByte)
Sends a "Write Byte" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageWriteByte msg
)
Public Sub TransferData (
    msg As SmbMasterMessageWriteByte
)
public:
void TransferData(
    SmbMasterMessageWriteByte^ msg
)
member TransferData :
        msg : SmbMasterMessageWriteByte -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageWriteByte
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMaster.TransferData Method (SmbMasterMessageWriteWord)

SmbMasterTransferData Method (SmbMasterMessageWriteWord)
Sends a "Write Word" master message to the SMBus/PMBus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void TransferData(
    SmbMasterMessageWriteWord msg
)
Public Sub TransferData (
    msg As SmbMasterMessageWriteWord
)
public:
void TransferData(
    SmbMasterMessageWriteWord^ msg
)
member TransferData :
        msg : SmbMasterMessageWriteWord -> unit

Parameters

msg
Type: telos.I2cApi.DotNetSmbMasterMessageWriteWord
master message to be sent
See Also

Reference

SmbMaster Class
TransferData Overload


SmbMasterMessage Class

SmbMasterMessage Class
This class is used as a base class for all SMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageHostNotify
telos.I2cApi.DotNetSmbMasterMessageQuickCommand
telos.I2cApi.DotNetSmbMasterMessageReceiveByte
telos.I2cApi.DotNetSmbMasterMessageSendByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SmbMasterMessage : ICloneable,
    IDisposable
Public MustInherit Class SmbMasterMessage
    Implements ICloneable, IDisposable
public ref class SmbMasterMessage abstract : ICloneable,
    IDisposable
[<AbstractClassAttribute>]
type SmbMasterMessage =
    class
        interface ICloneable
        interface IDisposable
    end

The SmbMasterMessage type exposes the following members.

Constructors
 | Name | Description
Protected method | SmbMasterMessage | Constructor
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Top
Remarks

The SMBus is specified in:

Copy
System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Different message types are defined by the SMBus:

  • Quick Command
  • Send Byte
  • Receive Byte
  • Write Byte
  • Read Byte
  • Write Word
  • Read Word
  • Write 32
  • Read 32
  • Write 64
  • Read 64
  • Process Call
  • Block Write
  • Block Read
  • Block Write - Block Read Process Call
  • Host Notify

A SMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the SMBus with the TransferData(SmbMasterMessage) method.

Supports the ICloneable interface.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessage Constructor

SmbMasterMessage Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected SmbMasterMessage(
    I2cAddress i2c_address
)
Protected Sub New (
    i2c_address As I2cAddress
)
protected:
SmbMasterMessage(
    I2cAddress^ i2c_address
)
new :
        i2c_address : I2cAddress -> SmbMasterMessage

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
Remarks
The SMBus supports only 7-bit I2C addresses.
See Also

Reference

SmbMasterMessage Class


SmbMasterMessage Methods

SmbMasterMessage Methods

The SmbMasterMessage type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessage Class


SmbMasterMessage.Clone Method

SmbMasterMessageClone Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.SmbMasterMessage.Clone"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object
public:
virtual Object^ Clone() abstract
abstract Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:telos.I2cApi.DotNet.SmbMasterMessage.Clone"]

Implements

ICloneableClone
See Also

Reference

SmbMasterMessage Class


SmbMasterMessage.Dispose Method

SmbMasterMessageDispose Method
Overload List
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Top
See Also

Reference

SmbMasterMessage Class


SmbMasterMessage.Dispose Method

SmbMasterMessageDispose Method

[Missing <summary> documentation for "M:telos.I2cApi.DotNet.SmbMasterMessage.Dispose"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SmbMasterMessage Class
Dispose Overload


SmbMasterMessage.Dispose Method (Boolean)

SmbMasterMessageDispose Method (Boolean)
Releases the unmanaged resources used by the SmbMasterMessage and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
)
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.SmbMasterMessage.Dispose(System.Boolean)"]

See Also

Reference

SmbMasterMessage Class
Dispose Overload


SmbMasterMessage Properties

SmbMasterMessage Properties

The SmbMasterMessage type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave.
Top
See Also

Reference

SmbMasterMessage Class


SmbMasterMessage.Address Property

SmbMasterMessageAddress Property
Sets/gets the I2C address of the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public I2cAddress Address { get; set; }
Public Property Address As I2cAddress
    Get
    Set
public:
property I2cAddress^ Address {
    I2cAddress^ get ();
    void set (I2cAddress^ value);
}
member Address : I2cAddress with get, set

Property Value

Type: I2cAddress
Remarks
The SMBus supports only 7-bit I2C addresses.
See Also

Reference

SmbMasterMessage Class


SmbMasterMessageBlockRead Class

SmbMasterMessageBlockRead Class
This class specifies a "Block Read" (see section 6.5.7 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdBlock
telos.I2cApi.DotNetSmbMasterMessageBlockRead

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageBlockRead : SmbMasterMessageCmdBlock
Public NotInheritable Class SmbMasterMessageBlockRead
    Inherits SmbMasterMessageCmdBlock
public ref class SmbMasterMessageBlockRead sealed : public SmbMasterMessageCmdBlock
[<SealedAttribute>]
type SmbMasterMessageBlockRead =
    class
        inherit SmbMasterMessageCmdBlock
    end

The SmbMasterMessageBlockRead type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageBlockRead | Constructor
Public method | SmbMasterMessageBlockRead(I2cAddress, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdBlock.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageBlockRead Constructor

SmbMasterMessageBlockRead Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageBlockRead | Constructor
Public method | SmbMasterMessageBlockRead(I2cAddress, Byte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageBlockRead Class


SmbMasterMessageBlockRead Constructor

SmbMasterMessageBlockRead Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageBlockRead()
Public Sub New
public:
SmbMasterMessageBlockRead()
new : unit -> SmbMasterMessageBlockRead
See Also

Reference

SmbMasterMessageBlockRead Class
SmbMasterMessageBlockRead Overload


SmbMasterMessageBlockRead Constructor (I2cAddress, Byte, Boolean)

SmbMasterMessageBlockRead Constructor (I2cAddress, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageBlockRead(
    I2cAddress i2c_address,
    byte cmd,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    with_pec As Boolean
)
public:
SmbMasterMessageBlockRead(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        with_pec : bool -> SmbMasterMessageBlockRead

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageBlockRead Class
SmbMasterMessageBlockRead Overload


SmbMasterMessageBlockRead Methods

SmbMasterMessageBlockRead Methods

The SmbMasterMessageBlockRead type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageBlockRead Class


SmbMasterMessageBlockRead.Clone Method

SmbMasterMessageBlockReadClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageBlockRead Class


SmbMasterMessageBlockRead Properties

SmbMasterMessageBlockRead Properties

The SmbMasterMessageBlockRead type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdBlock.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageBlockRead Class


SmbMasterMessageBlockWrite Class

SmbMasterMessageBlockWrite Class
This class specifies a "Block Write" (see section 6.5.7 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdBlock
telos.I2cApi.DotNetSmbMasterMessageBlockWrite

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageBlockWrite : SmbMasterMessageCmdBlock
Public NotInheritable Class SmbMasterMessageBlockWrite
    Inherits SmbMasterMessageCmdBlock
public ref class SmbMasterMessageBlockWrite sealed : public SmbMasterMessageCmdBlock
[<SealedAttribute>]
type SmbMasterMessageBlockWrite =
    class
        inherit SmbMasterMessageCmdBlock
    end

The SmbMasterMessageBlockWrite type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageBlockWrite | Constructor
Public method | SmbMasterMessageBlockWrite(I2cAddress, Byte, IEnumerableByte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdBlock.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageBlockWrite Constructor

SmbMasterMessageBlockWrite Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageBlockWrite | Constructor
Public method | SmbMasterMessageBlockWrite(I2cAddress, Byte, IEnumerableByte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageBlockWrite Class


SmbMasterMessageBlockWrite Constructor

SmbMasterMessageBlockWrite Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageBlockWrite()
Public Sub New
public:
SmbMasterMessageBlockWrite()
new : unit -> SmbMasterMessageBlockWrite
See Also

Reference

SmbMasterMessageBlockWrite Class
SmbMasterMessageBlockWrite Overload


SmbMasterMessageBlockWrite Constructor (I2cAddress, Byte, IEnumerable(Byte), Boolean)

SmbMasterMessageBlockWrite Constructor (I2cAddress, Byte, IEnumerableByte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageBlockWrite(
    I2cAddress i2c_address,
    byte cmd,
    IEnumerable<byte> data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As IEnumerable(Of Byte),
    with_pec As Boolean
)
public:
SmbMasterMessageBlockWrite(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    IEnumerable<unsigned char>^ data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : IEnumerable<byte> *
        with_pec : bool -> SmbMasterMessageBlockWrite

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: System.Collections.GenericIEnumerable Byte
data to be transmitted
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageBlockWrite Class
SmbMasterMessageBlockWrite Overload


SmbMasterMessageBlockWrite Methods

SmbMasterMessageBlockWrite Methods

The SmbMasterMessageBlockWrite type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageBlockWrite Class


SmbMasterMessageBlockWrite.Clone Method

SmbMasterMessageBlockWriteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageBlockWrite Class


SmbMasterMessageBlockWrite Properties

SmbMasterMessageBlockWrite Properties

The SmbMasterMessageBlockWrite type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdBlock.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageBlockWrite Class


SmbMasterMessageBlockWriteRead Class

SmbMasterMessageBlockWriteRead Class
This class specifies a "Block Write - Block Read Process Call" (see section 6.5.8 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageBlockWriteRead

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageBlockWriteRead : SmbMasterMessageCmd
Public NotInheritable Class SmbMasterMessageBlockWriteRead
    Inherits SmbMasterMessageCmd
public ref class SmbMasterMessageBlockWriteRead sealed : public SmbMasterMessageCmd
[<SealedAttribute>]
type SmbMasterMessageBlockWriteRead =
    class
        inherit SmbMasterMessageCmd
    end

The SmbMasterMessageBlockWriteRead type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageBlockWriteRead | Constructor
Public method | SmbMasterMessageBlockWriteRead(I2cAddress, Byte, IEnumerableByte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | DataRx | Returns the received data
Public property | DataTx | Gets the data to be transmitted.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageBlockWriteRead Constructor

SmbMasterMessageBlockWriteRead Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageBlockWriteRead | Constructor
Public method | SmbMasterMessageBlockWriteRead(I2cAddress, Byte, IEnumerableByte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageBlockWriteRead Class


SmbMasterMessageBlockWriteRead Constructor

SmbMasterMessageBlockWriteRead Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageBlockWriteRead()
Public Sub New
public:
SmbMasterMessageBlockWriteRead()
new : unit -> SmbMasterMessageBlockWriteRead
See Also

Reference

SmbMasterMessageBlockWriteRead Class
SmbMasterMessageBlockWriteRead Overload


SmbMasterMessageBlockWriteRead Constructor (I2cAddress, Byte, IEnumerable(Byte), Boolean)

SmbMasterMessageBlockWriteRead Constructor (I2cAddress, Byte, IEnumerableByte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageBlockWriteRead(
    I2cAddress i2c_address,
    byte cmd,
    IEnumerable<byte> data_tx,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data_tx As IEnumerable(Of Byte),
    with_pec As Boolean
)
public:
SmbMasterMessageBlockWriteRead(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    IEnumerable<unsigned char>^ data_tx,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data_tx : IEnumerable<byte> *
        with_pec : bool -> SmbMasterMessageBlockWriteRead

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data_tx
Type: System.Collections.GenericIEnumerable Byte
data to be transmitted
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageBlockWriteRead Class
SmbMasterMessageBlockWriteRead Overload


SmbMasterMessageBlockWriteRead Methods

SmbMasterMessageBlockWriteRead Methods

The SmbMasterMessageBlockWriteRead type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageBlockWriteRead Class


SmbMasterMessageBlockWriteRead.Clone Method

SmbMasterMessageBlockWriteReadClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageBlockWriteRead Class


SmbMasterMessageBlockWriteRead Properties

SmbMasterMessageBlockWriteRead Properties

The SmbMasterMessageBlockWriteRead type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | DataRx | Returns the received data
Public property | DataTx | Gets the data to be transmitted.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageBlockWriteRead Class


SmbMasterMessageBlockWriteRead.DataRx Property

SmbMasterMessageBlockWriteReadDataRx Property
Returns the received data

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<byte> DataRx { get; }
Public ReadOnly Property DataRx As List(Of Byte)
    Get
public:
property List<unsigned char>^ DataRx {
    List<unsigned char>^ get ();
}
member DataRx : List<byte> with get

Property Value

Type: List Byte
See Also

Reference

SmbMasterMessageBlockWriteRead Class


SmbMasterMessageBlockWriteRead.DataTx Property

SmbMasterMessageBlockWriteReadDataTx Property
Gets the data to be transmitted.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<byte> DataTx { get; }
Public ReadOnly Property DataTx As List(Of Byte)
    Get
public:
property List<unsigned char>^ DataTx {
    List<unsigned char>^ get ();
}
member DataTx : List<byte> with get

Property Value

Type: List Byte
See Also

Reference

SmbMasterMessageBlockWriteRead Class


SmbMasterMessageCmd Class

SmbMasterMessageCmd Class
This class is used as a base class for all SMBus master messages, which contain a command and an optional PEC byte.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
More...

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SmbMasterMessageCmd : SmbMasterMessage
Public MustInherit Class SmbMasterMessageCmd
    Inherits SmbMasterMessage
public ref class SmbMasterMessageCmd abstract : public SmbMasterMessage
[<AbstractClassAttribute>]
type SmbMasterMessageCmd =
    class
        inherit SmbMasterMessage
    end

The SmbMasterMessageCmd type exposes the following members.

Constructors
 | Name | Description
Protected method | SmbMasterMessageCmd | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageBlockWriteRead
telos.I2cApi.DotNetSmbMasterMessageCmd32
telos.I2cApi.DotNetSmbMasterMessageCmd64
telos.I2cApi.DotNetSmbMasterMessageCmdBlock
telos.I2cApi.DotNetSmbMasterMessageCmdByte
telos.I2cApi.DotNetSmbMasterMessageCmdProcessCall
telos.I2cApi.DotNetSmbMasterMessageCmdWord


SmbMasterMessageCmd Constructor

SmbMasterMessageCmd Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected SmbMasterMessageCmd(
    I2cAddress i2c_address,
    byte cmd,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    with_pec As Boolean
)
protected:
SmbMasterMessageCmd(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        with_pec : bool -> SmbMasterMessageCmd

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageCmd Class


SmbMasterMessageCmd Methods

SmbMasterMessageCmd Methods

The SmbMasterMessageCmd type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageCmd Class


SmbMasterMessageCmd Properties

SmbMasterMessageCmd Properties

The SmbMasterMessageCmd type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

SmbMasterMessageCmd Class


SmbMasterMessageCmd.Command Property

SmbMasterMessageCmdCommand Property
Sets/gets the command byte of the message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Command { get; set; }
Public Property Command As Byte
    Get
    Set
public:
property unsigned char Command {
    unsigned char get ();
    void set (unsigned char value);
}
member Command : byte with get, set

Property Value

Type: Byte
See Also

Reference

SmbMasterMessageCmd Class


SmbMasterMessageCmd.WithPec Property

SmbMasterMessageCmdWithPec Property
Sets/gets whether the message will use PEC or not.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool WithPec { get; set; }
Public Property WithPec As Boolean
    Get
    Set
public:
property bool WithPec {
    bool get ();
    void set (bool value);
}
member WithPec : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SmbMasterMessageCmd Class


SmbMasterMessageCmd32 Class

SmbMasterMessageCmd32 Class
This class is used as a base class for the "Write 32" and "Read 32" SMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmd32
telos.I2cApi.DotNetSmbMasterMessageRead32
telos.I2cApi.DotNetSmbMasterMessageWrite32

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SmbMasterMessageCmd32 : SmbMasterMessageCmd
Public MustInherit Class SmbMasterMessageCmd32
    Inherits SmbMasterMessageCmd
public ref class SmbMasterMessageCmd32 abstract : public SmbMasterMessageCmd
[<AbstractClassAttribute>]
type SmbMasterMessageCmd32 =
    class
        inherit SmbMasterMessageCmd
    end

The SmbMasterMessageCmd32 type exposes the following members.

Constructors
 | Name | Description
Protected method | SmbMasterMessageCmd32 | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageCmd32 Constructor

SmbMasterMessageCmd32 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected SmbMasterMessageCmd32(
    I2cAddress i2c_address,
    byte cmd,
    uint data,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As UInteger,
    with_pec As Boolean
)
protected:
SmbMasterMessageCmd32(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned int data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : uint32 *
        with_pec : bool -> SmbMasterMessageCmd32

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemUInt32
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageCmd32 Class


SmbMasterMessageCmd32 Methods

SmbMasterMessageCmd32 Methods

The SmbMasterMessageCmd32 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageCmd32 Class


SmbMasterMessageCmd32 Properties

SmbMasterMessageCmd32 Properties

The SmbMasterMessageCmd32 type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageCmd32 Class


SmbMasterMessageCmd32.Data Property

SmbMasterMessageCmd32Data Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public uint Data { get; set; }
Public Property Data As UInteger
    Get
    Set
public:
property unsigned int Data {
    unsigned int get ();
    void set (unsigned int value);
}
member Data : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SmbMasterMessageCmd32 Class


SmbMasterMessageCmd64 Class

SmbMasterMessageCmd64 Class
This class is used as a base class for the "Write 64" and "Read 64" SMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmd64
telos.I2cApi.DotNetSmbMasterMessageRead64
telos.I2cApi.DotNetSmbMasterMessageWrite64

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SmbMasterMessageCmd64 : SmbMasterMessageCmd
Public MustInherit Class SmbMasterMessageCmd64
    Inherits SmbMasterMessageCmd
public ref class SmbMasterMessageCmd64 abstract : public SmbMasterMessageCmd
[<AbstractClassAttribute>]
type SmbMasterMessageCmd64 =
    class
        inherit SmbMasterMessageCmd
    end

The SmbMasterMessageCmd64 type exposes the following members.

Constructors
 | Name | Description
Protected method | SmbMasterMessageCmd64 | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageCmd64 Constructor

SmbMasterMessageCmd64 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected SmbMasterMessageCmd64(
    I2cAddress i2c_address,
    byte cmd,
    ulong data,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As ULong,
    with_pec As Boolean
)
protected:
SmbMasterMessageCmd64(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned long long data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : uint64 *
        with_pec : bool -> SmbMasterMessageCmd64

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemUInt64
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageCmd64 Class


SmbMasterMessageCmd64 Methods

SmbMasterMessageCmd64 Methods

The SmbMasterMessageCmd64 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageCmd64 Class


SmbMasterMessageCmd64 Properties

SmbMasterMessageCmd64 Properties

The SmbMasterMessageCmd64 type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageCmd64 Class


SmbMasterMessageCmd64.Data Property

SmbMasterMessageCmd64Data Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong Data { get; set; }
Public Property Data As ULong
    Get
    Set
public:
property unsigned long long Data {
    unsigned long long get ();
    void set (unsigned long long value);
}
member Data : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

SmbMasterMessageCmd64 Class


SmbMasterMessageCmdBlock Class

SmbMasterMessageCmdBlock Class
This class is used as a base class for the "Block Write" and "Block Read" SMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdBlock
telos.I2cApi.DotNetSmbMasterMessageBlockRead
telos.I2cApi.DotNetSmbMasterMessageBlockWrite

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SmbMasterMessageCmdBlock : SmbMasterMessageCmd
Public MustInherit Class SmbMasterMessageCmdBlock
    Inherits SmbMasterMessageCmd
public ref class SmbMasterMessageCmdBlock abstract : public SmbMasterMessageCmd
[<AbstractClassAttribute>]
type SmbMasterMessageCmdBlock =
    class
        inherit SmbMasterMessageCmd
    end

The SmbMasterMessageCmdBlock type exposes the following members.

Constructors
 | Name | Description
Protected method | SmbMasterMessageCmdBlock | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageCmdBlock Constructor

SmbMasterMessageCmdBlock Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected SmbMasterMessageCmdBlock(
    I2cAddress i2c_address,
    byte cmd,
    IEnumerable<byte> data,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As IEnumerable(Of Byte),
    with_pec As Boolean
)
protected:
SmbMasterMessageCmdBlock(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    IEnumerable<unsigned char>^ data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : IEnumerable<byte> *
        with_pec : bool -> SmbMasterMessageCmdBlock

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: System.Collections.GenericIEnumerable Byte
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageCmdBlock Class


SmbMasterMessageCmdBlock Methods

SmbMasterMessageCmdBlock Methods

The SmbMasterMessageCmdBlock type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageCmdBlock Class


SmbMasterMessageCmdBlock Properties

SmbMasterMessageCmdBlock Properties

The SmbMasterMessageCmdBlock type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageCmdBlock Class


SmbMasterMessageCmdBlock.Data Property

SmbMasterMessageCmdBlockData Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public List<byte> Data { get; }
Public ReadOnly Property Data As List(Of Byte)
    Get
public:
property List<unsigned char>^ Data {
    List<unsigned char>^ get ();
}
member Data : List<byte> with get

Property Value

Type: List Byte
See Also

Reference

SmbMasterMessageCmdBlock Class


SmbMasterMessageCmdByte Class

SmbMasterMessageCmdByte Class
This class is used as a base class for the "Write Byte" and "Read Byte" SMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdByte
telos.I2cApi.DotNetSmbMasterMessageReadByte
telos.I2cApi.DotNetSmbMasterMessageWriteByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SmbMasterMessageCmdByte : SmbMasterMessageCmd
Public MustInherit Class SmbMasterMessageCmdByte
    Inherits SmbMasterMessageCmd
public ref class SmbMasterMessageCmdByte abstract : public SmbMasterMessageCmd
[<AbstractClassAttribute>]
type SmbMasterMessageCmdByte =
    class
        inherit SmbMasterMessageCmd
    end

The SmbMasterMessageCmdByte type exposes the following members.

Constructors
 | Name | Description
Protected method | SmbMasterMessageCmdByte | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageCmdByte Constructor

SmbMasterMessageCmdByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected SmbMasterMessageCmdByte(
    I2cAddress i2c_address,
    byte cmd,
    byte data,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As Byte,
    with_pec As Boolean
)
protected:
SmbMasterMessageCmdByte(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : byte *
        with_pec : bool -> SmbMasterMessageCmdByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemByte
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageCmdByte Class


SmbMasterMessageCmdByte Methods

SmbMasterMessageCmdByte Methods

The SmbMasterMessageCmdByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageCmdByte Class


SmbMasterMessageCmdByte Properties

SmbMasterMessageCmdByte Properties

The SmbMasterMessageCmdByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageCmdByte Class


SmbMasterMessageCmdByte.Data Property

SmbMasterMessageCmdByteData Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Data { get; set; }
Public Property Data As Byte
    Get
    Set
public:
property unsigned char Data {
    unsigned char get ();
    void set (unsigned char value);
}
member Data : byte with get, set

Property Value

Type: Byte
See Also

Reference

SmbMasterMessageCmdByte Class


SmbMasterMessageCmdProcessCall Class

SmbMasterMessageCmdProcessCall Class
This class specifies a "Process Call" (see section 6.5.6 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdProcessCall

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageCmdProcessCall : SmbMasterMessageCmd
Public NotInheritable Class SmbMasterMessageCmdProcessCall
    Inherits SmbMasterMessageCmd
public ref class SmbMasterMessageCmdProcessCall sealed : public SmbMasterMessageCmd
[<SealedAttribute>]
type SmbMasterMessageCmdProcessCall =
    class
        inherit SmbMasterMessageCmd
    end

The SmbMasterMessageCmdProcessCall type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageCmdProcessCall | Constructor
Public method | SmbMasterMessageCmdProcessCall(I2cAddress, Byte, UInt16, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | DataRx | Sets/gets the received data.
Public property | DataTx | Sets/gets the data to be transmitted.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageCmdProcessCall Constructor

SmbMasterMessageCmdProcessCall Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageCmdProcessCall | Constructor
Public method | SmbMasterMessageCmdProcessCall(I2cAddress, Byte, UInt16, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageCmdProcessCall Class


SmbMasterMessageCmdProcessCall Constructor

SmbMasterMessageCmdProcessCall Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageCmdProcessCall()
Public Sub New
public:
SmbMasterMessageCmdProcessCall()
new : unit -> SmbMasterMessageCmdProcessCall
See Also

Reference

SmbMasterMessageCmdProcessCall Class
SmbMasterMessageCmdProcessCall Overload


SmbMasterMessageCmdProcessCall Constructor (I2cAddress, Byte, UInt16, Boolean)

SmbMasterMessageCmdProcessCall Constructor (I2cAddress, Byte, UInt16, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageCmdProcessCall(
    I2cAddress i2c_address,
    byte cmd,
    ushort data_tx,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data_tx As UShort,
    with_pec As Boolean
)
public:
SmbMasterMessageCmdProcessCall(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned short data_tx,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data_tx : uint16 *
        with_pec : bool -> SmbMasterMessageCmdProcessCall

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data_tx
Type: SystemUInt16
data to be transmitted
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageCmdProcessCall Class
SmbMasterMessageCmdProcessCall Overload


SmbMasterMessageCmdProcessCall Methods

SmbMasterMessageCmdProcessCall Methods

The SmbMasterMessageCmdProcessCall type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageCmdProcessCall Class


SmbMasterMessageCmdProcessCall.Clone Method

SmbMasterMessageCmdProcessCallClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageCmdProcessCall Class


SmbMasterMessageCmdProcessCall Properties

SmbMasterMessageCmdProcessCall Properties

The SmbMasterMessageCmdProcessCall type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | DataRx | Sets/gets the received data.
Public property | DataTx | Sets/gets the data to be transmitted.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageCmdProcessCall Class


SmbMasterMessageCmdProcessCall.DataRx Property

SmbMasterMessageCmdProcessCallDataRx Property
Sets/gets the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort DataRx { get; set; }
Public Property DataRx As UShort
    Get
    Set
public:
property unsigned short DataRx {
    unsigned short get ();
    void set (unsigned short value);
}
member DataRx : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SmbMasterMessageCmdProcessCall Class


SmbMasterMessageCmdProcessCall.DataTx Property

SmbMasterMessageCmdProcessCallDataTx Property
Sets/gets the data to be transmitted.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort DataTx { get; set; }
Public Property DataTx As UShort
    Get
    Set
public:
property unsigned short DataTx {
    unsigned short get ();
    void set (unsigned short value);
}
member DataTx : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SmbMasterMessageCmdProcessCall Class


SmbMasterMessageCmdWord Class

SmbMasterMessageCmdWord Class
This class is used as a base class for the "Write Word" and "Read Word" SMBus master messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdWord
telos.I2cApi.DotNetSmbMasterMessageReadWord
telos.I2cApi.DotNetSmbMasterMessageWriteWord

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SmbMasterMessageCmdWord : SmbMasterMessageCmd
Public MustInherit Class SmbMasterMessageCmdWord
    Inherits SmbMasterMessageCmd
public ref class SmbMasterMessageCmdWord abstract : public SmbMasterMessageCmd
[<AbstractClassAttribute>]
type SmbMasterMessageCmdWord =
    class
        inherit SmbMasterMessageCmd
    end

The SmbMasterMessageCmdWord type exposes the following members.

Constructors
 | Name | Description
Protected method | SmbMasterMessageCmdWord | Constructor
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageCmdWord Constructor

SmbMasterMessageCmdWord Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected SmbMasterMessageCmdWord(
    I2cAddress i2c_address,
    byte cmd,
    ushort data,
    bool with_pec
)
Protected Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As UShort,
    with_pec As Boolean
)
protected:
SmbMasterMessageCmdWord(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned short data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : uint16 *
        with_pec : bool -> SmbMasterMessageCmdWord

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemUInt16
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageCmdWord Class


SmbMasterMessageCmdWord Methods

SmbMasterMessageCmdWord Methods

The SmbMasterMessageCmdWord type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SmbMasterMessage.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageCmdWord Class


SmbMasterMessageCmdWord Properties

SmbMasterMessageCmdWord Properties

The SmbMasterMessageCmdWord type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageCmdWord Class


SmbMasterMessageCmdWord.Data Property

SmbMasterMessageCmdWordData Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort Data { get; set; }
Public Property Data As UShort
    Get
    Set
public:
property unsigned short Data {
    unsigned short get ();
    void set (unsigned short value);
}
member Data : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SmbMasterMessageCmdWord Class


SmbMasterMessageHostNotify Class

SmbMasterMessageHostNotify Class
This class specifies a "Host Notify" (see section 6.5.9 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageHostNotify

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageHostNotify : SmbMasterMessage
Public NotInheritable Class SmbMasterMessageHostNotify
    Inherits SmbMasterMessage
public ref class SmbMasterMessageHostNotify sealed : public SmbMasterMessage
[<SealedAttribute>]
type SmbMasterMessageHostNotify =
    class
        inherit SmbMasterMessage
    end

The SmbMasterMessageHostNotify type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageHostNotify | Constructor
Public method | SmbMasterMessageHostNotify(I2cAddress, UInt16) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageHostNotify Constructor

SmbMasterMessageHostNotify Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageHostNotify | Constructor
Public method | SmbMasterMessageHostNotify(I2cAddress, UInt16) | Constructor
Top
See Also

Reference

SmbMasterMessageHostNotify Class


SmbMasterMessageHostNotify Constructor

SmbMasterMessageHostNotify Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageHostNotify()
Public Sub New
public:
SmbMasterMessageHostNotify()
new : unit -> SmbMasterMessageHostNotify
See Also

Reference

SmbMasterMessageHostNotify Class
SmbMasterMessageHostNotify Overload


SmbMasterMessageHostNotify Constructor (I2cAddress, UInt16)

SmbMasterMessageHostNotify Constructor (I2cAddress, UInt16)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageHostNotify(
    I2cAddress i2c_address,
    ushort data
)
Public Sub New (
    i2c_address As I2cAddress,
    data As UShort
)
public:
SmbMasterMessageHostNotify(
    I2cAddress^ i2c_address,
    unsigned short data
)
new :
        i2c_address : I2cAddress *
        data : uint16 -> SmbMasterMessageHostNotify

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
data
Type: SystemUInt16
data to be transferred
See Also

Reference

SmbMasterMessageHostNotify Class
SmbMasterMessageHostNotify Overload


SmbMasterMessageHostNotify Methods

SmbMasterMessageHostNotify Methods

The SmbMasterMessageHostNotify type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageHostNotify Class


SmbMasterMessageHostNotify.Clone Method

SmbMasterMessageHostNotifyClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageHostNotify Class


SmbMasterMessageHostNotify Properties

SmbMasterMessageHostNotify Properties

The SmbMasterMessageHostNotify type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Data | Sets/gets the data to be transmitted or the received data.
Top
See Also

Reference

SmbMasterMessageHostNotify Class


SmbMasterMessageHostNotify.Data Property

SmbMasterMessageHostNotifyData Property
Sets/gets the data to be transmitted or the received data.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ushort Data { get; set; }
Public Property Data As UShort
    Get
    Set
public:
property unsigned short Data {
    unsigned short get ();
    void set (unsigned short value);
}
member Data : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SmbMasterMessageHostNotify Class


SmbMasterMessageQuickCommand Class

SmbMasterMessageQuickCommand Class
This class specifies a "Quick Command" (see section 6.5.1 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageQuickCommand

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageQuickCommand : SmbMasterMessage
Public NotInheritable Class SmbMasterMessageQuickCommand
    Inherits SmbMasterMessage
public ref class SmbMasterMessageQuickCommand sealed : public SmbMasterMessage
[<SealedAttribute>]
type SmbMasterMessageQuickCommand =
    class
        inherit SmbMasterMessage
    end

The SmbMasterMessageQuickCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageQuickCommand | Constructor
Public method | SmbMasterMessageQuickCommand(I2cAddress, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | TxDirection | Sets/gets the direction of the transfer. If this property is set to "true", the direction is set to "master transmitter". Otherwise it is set to "master receiver".
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageQuickCommand Constructor

SmbMasterMessageQuickCommand Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageQuickCommand | Constructor
Public method | SmbMasterMessageQuickCommand(I2cAddress, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageQuickCommand Class


SmbMasterMessageQuickCommand Constructor

SmbMasterMessageQuickCommand Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageQuickCommand()
Public Sub New
public:
SmbMasterMessageQuickCommand()
new : unit -> SmbMasterMessageQuickCommand
See Also

Reference

SmbMasterMessageQuickCommand Class
SmbMasterMessageQuickCommand Overload


SmbMasterMessageQuickCommand Constructor (I2cAddress, Boolean)

SmbMasterMessageQuickCommand Constructor (I2cAddress, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageQuickCommand(
    I2cAddress i2c_address,
    bool tx_direction
)
Public Sub New (
    i2c_address As I2cAddress,
    tx_direction As Boolean
)
public:
SmbMasterMessageQuickCommand(
    I2cAddress^ i2c_address,
    bool tx_direction
)
new :
        i2c_address : I2cAddress *
        tx_direction : bool -> SmbMasterMessageQuickCommand

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
tx_direction
Type: SystemBoolean
direction: master transmitter(true), master receiver (false)
See Also

Reference

SmbMasterMessageQuickCommand Class
SmbMasterMessageQuickCommand Overload


SmbMasterMessageQuickCommand Methods

SmbMasterMessageQuickCommand Methods

The SmbMasterMessageQuickCommand type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageQuickCommand Class


SmbMasterMessageQuickCommand.Clone Method

SmbMasterMessageQuickCommandClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageQuickCommand Class


SmbMasterMessageQuickCommand Properties

SmbMasterMessageQuickCommand Properties

The SmbMasterMessageQuickCommand type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | TxDirection | Sets/gets the direction of the transfer. If this property is set to "true", the direction is set to "master transmitter". Otherwise it is set to "master receiver".
Top
See Also

Reference

SmbMasterMessageQuickCommand Class


SmbMasterMessageQuickCommand.TxDirection Property

SmbMasterMessageQuickCommandTxDirection Property
Sets/gets the direction of the transfer. If this property is set to "true", the direction is set to "master transmitter". Otherwise it is set to "master receiver".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool TxDirection { get; set; }
Public Property TxDirection As Boolean
    Get
    Set
public:
property bool TxDirection {
    bool get ();
    void set (bool value);
}
member TxDirection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SmbMasterMessageQuickCommand Class


SmbMasterMessageRead32 Class

SmbMasterMessageRead32 Class
This class specifies a "Read 32" (see section 6.5.11 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmd32
telos.I2cApi.DotNetSmbMasterMessageRead32

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageRead32 : SmbMasterMessageCmd32
Public NotInheritable Class SmbMasterMessageRead32
    Inherits SmbMasterMessageCmd32
public ref class SmbMasterMessageRead32 sealed : public SmbMasterMessageCmd32
[<SealedAttribute>]
type SmbMasterMessageRead32 =
    class
        inherit SmbMasterMessageCmd32
    end

The SmbMasterMessageRead32 type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageRead32 | Constructor
Public method | SmbMasterMessageRead32(I2cAddress, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd32.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageRead32 Constructor

SmbMasterMessageRead32 Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageRead32 | Constructor
Public method | SmbMasterMessageRead32(I2cAddress, Byte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageRead32 Class


SmbMasterMessageRead32 Constructor

SmbMasterMessageRead32 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageRead32()
Public Sub New
public:
SmbMasterMessageRead32()
new : unit -> SmbMasterMessageRead32
See Also

Reference

SmbMasterMessageRead32 Class
SmbMasterMessageRead32 Overload


SmbMasterMessageRead32 Constructor (I2cAddress, Byte, Boolean)

SmbMasterMessageRead32 Constructor (I2cAddress, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageRead32(
    I2cAddress i2c_address,
    byte cmd,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    with_pec As Boolean
)
public:
SmbMasterMessageRead32(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        with_pec : bool -> SmbMasterMessageRead32

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageRead32 Class
SmbMasterMessageRead32 Overload


SmbMasterMessageRead32 Methods

SmbMasterMessageRead32 Methods

The SmbMasterMessageRead32 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageRead32 Class


SmbMasterMessageRead32.Clone Method

SmbMasterMessageRead32Clone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageRead32 Class


SmbMasterMessageRead32 Properties

SmbMasterMessageRead32 Properties

The SmbMasterMessageRead32 type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd32.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageRead32 Class


SmbMasterMessageRead64 Class

SmbMasterMessageRead64 Class
This class specifies a "Read 64" (see section 6.5.13 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmd64
telos.I2cApi.DotNetSmbMasterMessageRead64

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageRead64 : SmbMasterMessageCmd64
Public NotInheritable Class SmbMasterMessageRead64
    Inherits SmbMasterMessageCmd64
public ref class SmbMasterMessageRead64 sealed : public SmbMasterMessageCmd64
[<SealedAttribute>]
type SmbMasterMessageRead64 =
    class
        inherit SmbMasterMessageCmd64
    end

The SmbMasterMessageRead64 type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageRead64 | Constructor
Public method | SmbMasterMessageRead64(I2cAddress, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd64.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageRead64 Constructor

SmbMasterMessageRead64 Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageRead64 | Constructor
Public method | SmbMasterMessageRead64(I2cAddress, Byte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageRead64 Class


SmbMasterMessageRead64 Constructor

SmbMasterMessageRead64 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageRead64()
Public Sub New
public:
SmbMasterMessageRead64()
new : unit -> SmbMasterMessageRead64
See Also

Reference

SmbMasterMessageRead64 Class
SmbMasterMessageRead64 Overload


SmbMasterMessageRead64 Constructor (I2cAddress, Byte, Boolean)

SmbMasterMessageRead64 Constructor (I2cAddress, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageRead64(
    I2cAddress i2c_address,
    byte cmd,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    with_pec As Boolean
)
public:
SmbMasterMessageRead64(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        with_pec : bool -> SmbMasterMessageRead64

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageRead64 Class
SmbMasterMessageRead64 Overload


SmbMasterMessageRead64 Methods

SmbMasterMessageRead64 Methods

The SmbMasterMessageRead64 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageRead64 Class


SmbMasterMessageRead64.Clone Method

SmbMasterMessageRead64Clone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageRead64 Class


SmbMasterMessageRead64 Properties

SmbMasterMessageRead64 Properties

The SmbMasterMessageRead64 type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd64.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageRead64 Class


SmbMasterMessageReadByte Class

SmbMasterMessageReadByte Class
This class specifies a "Read Byte" (see section 6.5.5 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdByte
telos.I2cApi.DotNetSmbMasterMessageReadByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageReadByte : SmbMasterMessageCmdByte
Public NotInheritable Class SmbMasterMessageReadByte
    Inherits SmbMasterMessageCmdByte
public ref class SmbMasterMessageReadByte sealed : public SmbMasterMessageCmdByte
[<SealedAttribute>]
type SmbMasterMessageReadByte =
    class
        inherit SmbMasterMessageCmdByte
    end

The SmbMasterMessageReadByte type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageReadByte | Constructor
Public method | SmbMasterMessageReadByte(I2cAddress, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageReadByte Constructor

SmbMasterMessageReadByte Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageReadByte | Constructor
Public method | SmbMasterMessageReadByte(I2cAddress, Byte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageReadByte Class


SmbMasterMessageReadByte Constructor

SmbMasterMessageReadByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageReadByte()
Public Sub New
public:
SmbMasterMessageReadByte()
new : unit -> SmbMasterMessageReadByte
See Also

Reference

SmbMasterMessageReadByte Class
SmbMasterMessageReadByte Overload


SmbMasterMessageReadByte Constructor (I2cAddress, Byte, Boolean)

SmbMasterMessageReadByte Constructor (I2cAddress, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageReadByte(
    I2cAddress i2c_address,
    byte cmd,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    with_pec As Boolean
)
public:
SmbMasterMessageReadByte(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        with_pec : bool -> SmbMasterMessageReadByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageReadByte Class
SmbMasterMessageReadByte Overload


SmbMasterMessageReadByte Methods

SmbMasterMessageReadByte Methods

The SmbMasterMessageReadByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageReadByte Class


SmbMasterMessageReadByte.Clone Method

SmbMasterMessageReadByteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageReadByte Class


SmbMasterMessageReadByte Properties

SmbMasterMessageReadByte Properties

The SmbMasterMessageReadByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageReadByte Class


SmbMasterMessageReadWord Class

SmbMasterMessageReadWord Class
This class specifies a "Read Word" (see section 6.5.5 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdWord
telos.I2cApi.DotNetSmbMasterMessageReadWord

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageReadWord : SmbMasterMessageCmdWord
Public NotInheritable Class SmbMasterMessageReadWord
    Inherits SmbMasterMessageCmdWord
public ref class SmbMasterMessageReadWord sealed : public SmbMasterMessageCmdWord
[<SealedAttribute>]
type SmbMasterMessageReadWord =
    class
        inherit SmbMasterMessageCmdWord
    end

The SmbMasterMessageReadWord type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageReadWord | Constructor
Public method | SmbMasterMessageReadWord(I2cAddress, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageReadWord Constructor

SmbMasterMessageReadWord Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageReadWord | Constructor
Public method | SmbMasterMessageReadWord(I2cAddress, Byte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageReadWord Class


SmbMasterMessageReadWord Constructor

SmbMasterMessageReadWord Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageReadWord()
Public Sub New
public:
SmbMasterMessageReadWord()
new : unit -> SmbMasterMessageReadWord
See Also

Reference

SmbMasterMessageReadWord Class
SmbMasterMessageReadWord Overload


SmbMasterMessageReadWord Constructor (I2cAddress, Byte, Boolean)

SmbMasterMessageReadWord Constructor (I2cAddress, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageReadWord(
    I2cAddress i2c_address,
    byte cmd,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    with_pec As Boolean
)
public:
SmbMasterMessageReadWord(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        with_pec : bool -> SmbMasterMessageReadWord

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageReadWord Class
SmbMasterMessageReadWord Overload


SmbMasterMessageReadWord Methods

SmbMasterMessageReadWord Methods

The SmbMasterMessageReadWord type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageReadWord Class


SmbMasterMessageReadWord.Clone Method

SmbMasterMessageReadWordClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageReadWord Class


SmbMasterMessageReadWord Properties

SmbMasterMessageReadWord Properties

The SmbMasterMessageReadWord type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageReadWord Class


SmbMasterMessageReceiveByte Class

SmbMasterMessageReceiveByte Class
This class specifies a "Receive Byte" (see section 6.5.3 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageReceiveByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageReceiveByte : SmbMasterMessage
Public NotInheritable Class SmbMasterMessageReceiveByte
    Inherits SmbMasterMessage
public ref class SmbMasterMessageReceiveByte sealed : public SmbMasterMessage
[<SealedAttribute>]
type SmbMasterMessageReceiveByte =
    class
        inherit SmbMasterMessage
    end

The SmbMasterMessageReceiveByte type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageReceiveByte | Constructor
Public method | SmbMasterMessageReceiveByte(I2cAddress, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Data | Sets/gets the data received from the slave.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageReceiveByte Constructor

SmbMasterMessageReceiveByte Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageReceiveByte | Constructor
Public method | SmbMasterMessageReceiveByte(I2cAddress, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageReceiveByte Class


SmbMasterMessageReceiveByte Constructor

SmbMasterMessageReceiveByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageReceiveByte()
Public Sub New
public:
SmbMasterMessageReceiveByte()
new : unit -> SmbMasterMessageReceiveByte
See Also

Reference

SmbMasterMessageReceiveByte Class
SmbMasterMessageReceiveByte Overload


SmbMasterMessageReceiveByte Constructor (I2cAddress, Boolean)

SmbMasterMessageReceiveByte Constructor (I2cAddress, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageReceiveByte(
    I2cAddress i2c_address,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    with_pec As Boolean
)
public:
SmbMasterMessageReceiveByte(
    I2cAddress^ i2c_address,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        with_pec : bool -> SmbMasterMessageReceiveByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageReceiveByte Class
SmbMasterMessageReceiveByte Overload


SmbMasterMessageReceiveByte Methods

SmbMasterMessageReceiveByte Methods

The SmbMasterMessageReceiveByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageReceiveByte Class


SmbMasterMessageReceiveByte.Clone Method

SmbMasterMessageReceiveByteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageReceiveByte Class


SmbMasterMessageReceiveByte Properties

SmbMasterMessageReceiveByte Properties

The SmbMasterMessageReceiveByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Data | Sets/gets the data received from the slave.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

SmbMasterMessageReceiveByte Class


SmbMasterMessageReceiveByte.Data Property

SmbMasterMessageReceiveByteData Property
Sets/gets the data received from the slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Data { get; set; }
Public Property Data As Byte
    Get
    Set
public:
property unsigned char Data {
    unsigned char get ();
    void set (unsigned char value);
}
member Data : byte with get, set

Property Value

Type: Byte
See Also

Reference

SmbMasterMessageReceiveByte Class


SmbMasterMessageReceiveByte.WithPec Property

SmbMasterMessageReceiveByteWithPec Property
Sets/gets whether the message will use PEC or not.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool WithPec { get; set; }
Public Property WithPec As Boolean
    Get
    Set
public:
property bool WithPec {
    bool get ();
    void set (bool value);
}
member WithPec : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SmbMasterMessageReceiveByte Class


SmbMasterMessageSendByte Class

SmbMasterMessageSendByte Class
This class specifies a "Send Byte" (see section 6.5.2 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageSendByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageSendByte : SmbMasterMessage
Public NotInheritable Class SmbMasterMessageSendByte
    Inherits SmbMasterMessage
public ref class SmbMasterMessageSendByte sealed : public SmbMasterMessage
[<SealedAttribute>]
type SmbMasterMessageSendByte =
    class
        inherit SmbMasterMessage
    end

The SmbMasterMessageSendByte type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageSendByte | Constructor
Public method | SmbMasterMessageSendByte(I2cAddress, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Data | Sets/gets the data to be sent to slave.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageSendByte Constructor

SmbMasterMessageSendByte Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageSendByte | Constructor
Public method | SmbMasterMessageSendByte(I2cAddress, Byte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageSendByte Class


SmbMasterMessageSendByte Constructor

SmbMasterMessageSendByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageSendByte()
Public Sub New
public:
SmbMasterMessageSendByte()
new : unit -> SmbMasterMessageSendByte
See Also

Reference

SmbMasterMessageSendByte Class
SmbMasterMessageSendByte Overload


SmbMasterMessageSendByte Constructor (I2cAddress, Byte, Boolean)

SmbMasterMessageSendByte Constructor (I2cAddress, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageSendByte(
    I2cAddress i2c_address,
    byte data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    data As Byte,
    with_pec As Boolean
)
public:
SmbMasterMessageSendByte(
    I2cAddress^ i2c_address,
    unsigned char data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        data : byte *
        with_pec : bool -> SmbMasterMessageSendByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
data
Type: SystemByte
data to be sent
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageSendByte Class
SmbMasterMessageSendByte Overload


SmbMasterMessageSendByte Methods

SmbMasterMessageSendByte Methods

The SmbMasterMessageSendByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageSendByte Class


SmbMasterMessageSendByte.Clone Method

SmbMasterMessageSendByteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageSendByte Class


SmbMasterMessageSendByte Properties

SmbMasterMessageSendByte Properties

The SmbMasterMessageSendByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Data | Sets/gets the data to be sent to slave.
Public property | WithPec | Sets/gets whether the message will use PEC or not.
Top
See Also

Reference

SmbMasterMessageSendByte Class


SmbMasterMessageSendByte.Data Property

SmbMasterMessageSendByteData Property
Sets/gets the data to be sent to slave.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Data { get; set; }
Public Property Data As Byte
    Get
    Set
public:
property unsigned char Data {
    unsigned char get ();
    void set (unsigned char value);
}
member Data : byte with get, set

Property Value

Type: Byte
See Also

Reference

SmbMasterMessageSendByte Class


SmbMasterMessageSendByte.WithPec Property

SmbMasterMessageSendByteWithPec Property
Sets/gets whether the message will use PEC or not.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool WithPec { get; set; }
Public Property WithPec As Boolean
    Get
    Set
public:
property bool WithPec {
    bool get ();
    void set (bool value);
}
member WithPec : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SmbMasterMessageSendByte Class


SmbMasterMessageWrite32 Class

SmbMasterMessageWrite32 Class
This class specifies a "Write 32" (see section 6.5.10 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmd32
telos.I2cApi.DotNetSmbMasterMessageWrite32

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageWrite32 : SmbMasterMessageCmd32
Public NotInheritable Class SmbMasterMessageWrite32
    Inherits SmbMasterMessageCmd32
public ref class SmbMasterMessageWrite32 sealed : public SmbMasterMessageCmd32
[<SealedAttribute>]
type SmbMasterMessageWrite32 =
    class
        inherit SmbMasterMessageCmd32
    end

The SmbMasterMessageWrite32 type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageWrite32 | Constructor
Public method | SmbMasterMessageWrite32(I2cAddress, Byte, UInt32, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd32.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageWrite32 Constructor

SmbMasterMessageWrite32 Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageWrite32 | Constructor
Public method | SmbMasterMessageWrite32(I2cAddress, Byte, UInt32, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageWrite32 Class


SmbMasterMessageWrite32 Constructor

SmbMasterMessageWrite32 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWrite32()
Public Sub New
public:
SmbMasterMessageWrite32()
new : unit -> SmbMasterMessageWrite32
See Also

Reference

SmbMasterMessageWrite32 Class
SmbMasterMessageWrite32 Overload


SmbMasterMessageWrite32 Constructor (I2cAddress, Byte, UInt32, Boolean)

SmbMasterMessageWrite32 Constructor (I2cAddress, Byte, UInt32, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWrite32(
    I2cAddress i2c_address,
    byte cmd,
    uint data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As UInteger,
    with_pec As Boolean
)
public:
SmbMasterMessageWrite32(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned int data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : uint32 *
        with_pec : bool -> SmbMasterMessageWrite32

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemUInt32
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageWrite32 Class
SmbMasterMessageWrite32 Overload


SmbMasterMessageWrite32 Methods

SmbMasterMessageWrite32 Methods

The SmbMasterMessageWrite32 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageWrite32 Class


SmbMasterMessageWrite32.Clone Method

SmbMasterMessageWrite32Clone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageWrite32 Class


SmbMasterMessageWrite32 Properties

SmbMasterMessageWrite32 Properties

The SmbMasterMessageWrite32 type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd32.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageWrite32 Class


SmbMasterMessageWrite64 Class

SmbMasterMessageWrite64 Class
This class specifies a "Write 64" (see section 6.5.12 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmd64
telos.I2cApi.DotNetSmbMasterMessageWrite64

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageWrite64 : SmbMasterMessageCmd64
Public NotInheritable Class SmbMasterMessageWrite64
    Inherits SmbMasterMessageCmd64
public ref class SmbMasterMessageWrite64 sealed : public SmbMasterMessageCmd64
[<SealedAttribute>]
type SmbMasterMessageWrite64 =
    class
        inherit SmbMasterMessageCmd64
    end

The SmbMasterMessageWrite64 type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageWrite64 | Constructor
Public method | SmbMasterMessageWrite64(I2cAddress, Byte, UInt64, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd64.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageWrite64 Constructor

SmbMasterMessageWrite64 Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageWrite64 | Constructor
Public method | SmbMasterMessageWrite64(I2cAddress, Byte, UInt64, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageWrite64 Class


SmbMasterMessageWrite64 Constructor

SmbMasterMessageWrite64 Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWrite64()
Public Sub New
public:
SmbMasterMessageWrite64()
new : unit -> SmbMasterMessageWrite64
See Also

Reference

SmbMasterMessageWrite64 Class
SmbMasterMessageWrite64 Overload


SmbMasterMessageWrite64 Constructor (I2cAddress, Byte, UInt64, Boolean)

SmbMasterMessageWrite64 Constructor (I2cAddress, Byte, UInt64, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWrite64(
    I2cAddress i2c_address,
    byte cmd,
    ulong data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As ULong,
    with_pec As Boolean
)
public:
SmbMasterMessageWrite64(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned long long data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : uint64 *
        with_pec : bool -> SmbMasterMessageWrite64

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemUInt64
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageWrite64 Class
SmbMasterMessageWrite64 Overload


SmbMasterMessageWrite64 Methods

SmbMasterMessageWrite64 Methods

The SmbMasterMessageWrite64 type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageWrite64 Class


SmbMasterMessageWrite64.Clone Method

SmbMasterMessageWrite64Clone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageWrite64 Class


SmbMasterMessageWrite64 Properties

SmbMasterMessageWrite64 Properties

The SmbMasterMessageWrite64 type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmd64.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageWrite64 Class


SmbMasterMessageWriteByte Class

SmbMasterMessageWriteByte Class
This class specifies a "Write Byte" (see section 6.5.4 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdByte
telos.I2cApi.DotNetSmbMasterMessageWriteByte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageWriteByte : SmbMasterMessageCmdByte
Public NotInheritable Class SmbMasterMessageWriteByte
    Inherits SmbMasterMessageCmdByte
public ref class SmbMasterMessageWriteByte sealed : public SmbMasterMessageCmdByte
[<SealedAttribute>]
type SmbMasterMessageWriteByte =
    class
        inherit SmbMasterMessageCmdByte
    end

The SmbMasterMessageWriteByte type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageWriteByte | Constructor
Public method | SmbMasterMessageWriteByte(I2cAddress, Byte, Byte, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageWriteByte Constructor

SmbMasterMessageWriteByte Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageWriteByte | Constructor
Public method | SmbMasterMessageWriteByte(I2cAddress, Byte, Byte, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageWriteByte Class


SmbMasterMessageWriteByte Constructor

SmbMasterMessageWriteByte Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWriteByte()
Public Sub New
public:
SmbMasterMessageWriteByte()
new : unit -> SmbMasterMessageWriteByte
See Also

Reference

SmbMasterMessageWriteByte Class
SmbMasterMessageWriteByte Overload


SmbMasterMessageWriteByte Constructor (I2cAddress, Byte, Byte, Boolean)

SmbMasterMessageWriteByte Constructor (I2cAddress, Byte, Byte, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWriteByte(
    I2cAddress i2c_address,
    byte cmd,
    byte data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As Byte,
    with_pec As Boolean
)
public:
SmbMasterMessageWriteByte(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned char data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : byte *
        with_pec : bool -> SmbMasterMessageWriteByte

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemByte
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageWriteByte Class
SmbMasterMessageWriteByte Overload


SmbMasterMessageWriteByte Methods

SmbMasterMessageWriteByte Methods

The SmbMasterMessageWriteByte type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageWriteByte Class


SmbMasterMessageWriteByte.Clone Method

SmbMasterMessageWriteByteClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageWriteByte Class


SmbMasterMessageWriteByte Properties

SmbMasterMessageWriteByte Properties

The SmbMasterMessageWriteByte type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdByte.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageWriteByte Class


SmbMasterMessageWriteWord Class

SmbMasterMessageWriteWord Class
This class specifies a "Write Word" (see section 6.5.4 in the standard) master message for the SMBus.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSmbMasterMessage
telos.I2cApi.DotNetSmbMasterMessageCmd
telos.I2cApi.DotNetSmbMasterMessageCmdWord
telos.I2cApi.DotNetSmbMasterMessageWriteWord

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SmbMasterMessageWriteWord : SmbMasterMessageCmdWord
Public NotInheritable Class SmbMasterMessageWriteWord
    Inherits SmbMasterMessageCmdWord
public ref class SmbMasterMessageWriteWord sealed : public SmbMasterMessageCmdWord
[<SealedAttribute>]
type SmbMasterMessageWriteWord =
    class
        inherit SmbMasterMessageCmdWord
    end

The SmbMasterMessageWriteWord type exposes the following members.

Constructors
 | Name | Description
Public method | SmbMasterMessageWriteWord | Constructor
Public method | SmbMasterMessageWriteWord(I2cAddress, Byte, UInt16, Boolean) | Constructor
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SmbMasterMessageWriteWord Constructor

SmbMasterMessageWriteWord Constructor
Overload List
 | Name | Description
Public method | SmbMasterMessageWriteWord | Constructor
Public method | SmbMasterMessageWriteWord(I2cAddress, Byte, UInt16, Boolean) | Constructor
Top
See Also

Reference

SmbMasterMessageWriteWord Class


SmbMasterMessageWriteWord Constructor

SmbMasterMessageWriteWord Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWriteWord()
Public Sub New
public:
SmbMasterMessageWriteWord()
new : unit -> SmbMasterMessageWriteWord
See Also

Reference

SmbMasterMessageWriteWord Class
SmbMasterMessageWriteWord Overload


SmbMasterMessageWriteWord Constructor (I2cAddress, Byte, UInt16, Boolean)

SmbMasterMessageWriteWord Constructor (I2cAddress, Byte, UInt16, Boolean)
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SmbMasterMessageWriteWord(
    I2cAddress i2c_address,
    byte cmd,
    ushort data,
    bool with_pec
)
Public Sub New (
    i2c_address As I2cAddress,
    cmd As Byte,
    data As UShort,
    with_pec As Boolean
)
public:
SmbMasterMessageWriteWord(
    I2cAddress^ i2c_address,
    unsigned char cmd,
    unsigned short data,
    bool with_pec
)
new :
        i2c_address : I2cAddress *
        cmd : byte *
        data : uint16 *
        with_pec : bool -> SmbMasterMessageWriteWord

Parameters

i2c_address
Type: telos.I2cApi.DotNetI2cAddress
I2C address of the slave
cmd
Type: SystemByte
command byte
data
Type: SystemUInt16
data to be transferred
with_pec
Type: SystemBoolean
use PEC (true), do not use PEC (false)
See Also

Reference

SmbMasterMessageWriteWord Class
SmbMasterMessageWriteWord Overload


SmbMasterMessageWriteWord Methods

SmbMasterMessageWriteWord Methods

The SmbMasterMessageWriteWord type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object. (Overrides SmbMasterMessageClone.)
Public method | Dispose | (Inherited from SmbMasterMessage.)
Protected method | Dispose(Boolean) | (Inherited from SmbMasterMessage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmbMasterMessageWriteWord Class


SmbMasterMessageWriteWord.Clone Method

SmbMasterMessageWriteWordClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public override sealed Object Clone()
Public Overrides NotOverridable Function Clone As Object
public:
virtual Object^ Clone() override sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
copied object

Implements

ICloneableClone
See Also

Reference

SmbMasterMessageWriteWord Class


SmbMasterMessageWriteWord Properties

SmbMasterMessageWriteWord Properties

The SmbMasterMessageWriteWord type exposes the following members.

Properties
 | Name | Description
Public property | Address | Sets/gets the I2C address of the slave. (Inherited from SmbMasterMessage.)
Public property | Command | Sets/gets the command byte of the message. (Inherited from SmbMasterMessageCmd.)
Public property | Data | Sets/gets the data to be transmitted or the received data. (Inherited from SmbMasterMessageCmdWord.)
Public property | WithPec | Sets/gets whether the message will use PEC or not. (Inherited from SmbMasterMessageCmd.)
Top
See Also

Reference

SmbMasterMessageWriteWord Class


SoftwareLicenses Class

SoftwareLicenses Class
This structure specifies the software licenses of an I2C interface. Software can only be used together with an I2C interface, if the interface has got the needed license.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetSoftwareLicenses

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SoftwareLicenses : ICloneable
Public NotInheritable Class SoftwareLicenses
    Implements ICloneable
public ref class SoftwareLicenses sealed : ICloneable
[<SealedAttribute>]
type SoftwareLicenses =
    class
        interface ICloneable
    end

The SoftwareLicenses type exposes the following members.

Constructors
 | Name | Description
Public method | SoftwareLicenses | Initializes a new instance of the SoftwareLicenses class
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Flasher | flasher
Public property | Ird | IRD
Public property | Labview | Labview VIs
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SoftwareLicenses Constructor

SoftwareLicenses Constructor
Initializes a new instance of the SoftwareLicenses class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SoftwareLicenses()
Public Sub New
public:
SoftwareLicenses()
new : unit -> SoftwareLicenses
See Also

Reference

SoftwareLicenses Class


SoftwareLicenses Methods

SoftwareLicenses Methods

The SoftwareLicenses type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SoftwareLicenses Class


SoftwareLicenses.Clone Method

SoftwareLicensesClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

SoftwareLicenses Class


SoftwareLicenses Properties

SoftwareLicenses Properties

The SoftwareLicenses type exposes the following members.

Properties
 | Name | Description
Public property | Flasher | flasher
Public property | Ird | IRD
Public property | Labview | Labview VIs
Top
See Also

Reference

SoftwareLicenses Class


SoftwareLicenses.Flasher Property

SoftwareLicensesFlasher Property
flasher

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Flasher { get; set; }
Public Property Flasher As Boolean
    Get
    Set
public:
property bool Flasher {
    bool get ();
    void set (bool value);
}
member Flasher : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SoftwareLicenses Class


SoftwareLicenses.Ird Property

SoftwareLicensesIrd Property
IRD

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Ird { get; set; }
Public Property Ird As Boolean
    Get
    Set
public:
property bool Ird {
    bool get ();
    void set (bool value);
}
member Ird : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SoftwareLicenses Class


SoftwareLicenses.Labview Property

SoftwareLicensesLabview Property
Labview VIs

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Labview { get; set; }
Public Property Labview As Boolean
    Get
    Set
public:
property bool Labview {
    bool get ();
    void set (bool value);
}
member Labview : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SoftwareLicenses Class


SvnAttribute Class

SvnAttribute Class

[Missing <summary> documentation for "T:telos.I2cApi.DotNet.SvnAttribute"]

Inheritance Hierarchy
SystemObject
SystemAttribute
telos.I2cApi.DotNetSvnAttribute

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class SvnAttribute : Attribute
Public NotInheritable Class SvnAttribute
    Inherits Attribute
public ref class SvnAttribute sealed : public Attribute
[<SealedAttribute>]
type SvnAttribute =
    class
        inherit Attribute
    end

The SvnAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SvnAttribute | Initializes a new instance of the SvnAttribute class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
 | AllSvnIds |
Public property | SvnId |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


SvnAttribute Constructor

SvnAttribute Constructor
Initializes a new instance of the SvnAttribute class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public SvnAttribute(
    string svn_id
)
Public Sub New (
    svn_id As String
)
public:
SvnAttribute(
    String^ svn_id
)
new :
        svn_id : string -> SvnAttribute

Parameters

svn_id
Type: SystemString

[Missing <param name="svn_id"/> documentation for "M:telos.I2cApi.DotNet.SvnAttribute.#ctor(System.String)"]

See Also

Reference

SvnAttribute Class


SvnAttribute Methods

SvnAttribute Methods

The SvnAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SvnAttribute Class


SvnAttribute Properties

SvnAttribute Properties

The SvnAttribute type exposes the following members.

Properties
 | Name | Description
 | AllSvnIds |
Public property | SvnId |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

SvnAttribute Class


SvnAttribute.AllSvnIds Property

SvnAttributeAllSvnIds Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.SvnAttribute.AllSvnIds"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public static string AllSvnIds { get; }
Public Shared ReadOnly Property AllSvnIds As String
    Get
public:
static property String^ AllSvnIds {
    String^ get ();
}
static member AllSvnIds : string with get

Property Value

Type: String
See Also

Reference

SvnAttribute Class


SvnAttribute.SvnId Property

SvnAttributeSvnId Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.SvnAttribute.SvnId"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string SvnId { get; }
Public ReadOnly Property SvnId As String
    Get
public:
property String^ SvnId {
    String^ get ();
}
member SvnId : string with get

Property Value

Type: String
See Also

Reference

SvnAttribute Class


TraceDataFind Class

TraceDataFind Class
This class can be used to search for I2C messages in a ParsedTracerMessageList object.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetTraceDataFind

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TraceDataFind
Public NotInheritable Class TraceDataFind
public ref class TraceDataFind sealed
[<SealedAttribute>]
type TraceDataFind =  class end

The TraceDataFind type exposes the following members.

Constructors
 | Name | Description
Public method | TraceDataFind | Initializes a new instance of the TraceDataFind class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches forward or backward for an I2C message.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FindPattern | Sets/gets the find rules, which get applied.
Public property | IrdValues | Sets/gets the IrdTraceValueList instance, which gets searched through.
Public property | Messages | Sets/gets the ParsedTracerMessageList instance, which gets searched through.
Public property | TestpinsMessages | Sets/gets the InputTestpinsMessageList instance, which gets searched through.
Top
Events
 | Name | Description
Public event | ProgressChanged | This event gets fired while Find(Int32, TraceDataFindDirection) is running.
Top
Remarks

Two steps are necessary to before an instance of this class can be used. At first it is necessary to pass the ParsedTracerMessageList instance to the class, which contains the I2C messages. As second steps the search criterions have to be specified.

After these two steps it is possible to search for the previous or the next occurrence of the search criterions.

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TraceDataFind Constructor

TraceDataFind Constructor
Initializes a new instance of the TraceDataFind class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TraceDataFind()
Public Sub New
public:
TraceDataFind()
new : unit -> TraceDataFind
See Also

Reference

TraceDataFind Class


TraceDataFind Methods

TraceDataFind Methods

The TraceDataFind type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches forward or backward for an I2C message.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TraceDataFind Class


TraceDataFind.Find Method

TraceDataFindFind Method
Searches forward or backward for an I2C message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Find(
    int start_idx,
    TraceDataFindDirection direction
)
Public Function Find (
    start_idx As Integer,
    direction As TraceDataFindDirection
) As Integer
public:
int Find(
    int start_idx,
    TraceDataFindDirection direction
)
member Find :
        start_idx : int *
        direction : TraceDataFindDirection -> int

Parameters

start_idx
Type: SystemInt32
index of the first message
direction
Type: telos.I2cApi.DotNetTraceDataFindDirection
search direction

Return Value

Type: Int32
index of the I2C message matching the last rule in the search sequence or "-1"
See Also

Reference

TraceDataFind Class


TraceDataFind Properties

TraceDataFind Properties

The TraceDataFind type exposes the following members.

Properties
 | Name | Description
Public property | FindPattern | Sets/gets the find rules, which get applied.
Public property | IrdValues | Sets/gets the IrdTraceValueList instance, which gets searched through.
Public property | Messages | Sets/gets the ParsedTracerMessageList instance, which gets searched through.
Public property | TestpinsMessages | Sets/gets the InputTestpinsMessageList instance, which gets searched through.
Top
See Also

Reference

TraceDataFind Class


TraceDataFind.FindPattern Property

TraceDataFindFindPattern Property
Sets/gets the find rules, which get applied.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public FindSequence FindPattern { get; set; }
Public Property FindPattern As FindSequence
    Get
    Set
public:
property FindSequence^ FindPattern {
    FindSequence^ get ();
    void set (FindSequence^ value);
}
member FindPattern : FindSequence with get, set

Property Value

Type: FindSequence
See Also

Reference

TraceDataFind Class


TraceDataFind.IrdValues Property

TraceDataFindIrdValues Property
Sets/gets the IrdTraceValueList instance, which gets searched through.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IrdTraceValueList IrdValues { get; set; }
Public Property IrdValues As IrdTraceValueList
    Get
    Set
public:
property IrdTraceValueList^ IrdValues {
    IrdTraceValueList^ get ();
    void set (IrdTraceValueList^ value);
}
member IrdValues : IrdTraceValueList with get, set

Property Value

Type: IrdTraceValueList
See Also

Reference

TraceDataFind Class


TraceDataFind.Messages Property

TraceDataFindMessages Property
Sets/gets the ParsedTracerMessageList instance, which gets searched through.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ParsedTracerMessageList Messages { get; set; }
Public Property Messages As ParsedTracerMessageList
    Get
    Set
public:
property ParsedTracerMessageList^ Messages {
    ParsedTracerMessageList^ get ();
    void set (ParsedTracerMessageList^ value);
}
member Messages : ParsedTracerMessageList with get, set

Property Value

Type: ParsedTracerMessageList
See Also

Reference

TraceDataFind Class


TraceDataFind.TestpinsMessages Property

TraceDataFindTestpinsMessages Property
Sets/gets the InputTestpinsMessageList instance, which gets searched through.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public InputTestpinsMessageList TestpinsMessages { get; set; }
Public Property TestpinsMessages As InputTestpinsMessageList
    Get
    Set
public:
property InputTestpinsMessageList^ TestpinsMessages {
    InputTestpinsMessageList^ get ();
    void set (InputTestpinsMessageList^ value);
}
member TestpinsMessages : InputTestpinsMessageList with get, set

Property Value

Type: InputTestpinsMessageList
See Also

Reference

TraceDataFind Class


TraceDataFind Events

TraceDataFind Events

The TraceDataFind type exposes the following members.

Events
 | Name | Description
Public event | ProgressChanged | This event gets fired while Find(Int32, TraceDataFindDirection) is running.
Top
See Also

Reference

TraceDataFind Class


TraceDataFind.ProgressChanged Event

TraceDataFindProgressChanged Event
This event gets fired while Find(Int32, TraceDataFindDirection) is running.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<TraceDataFindProgressChangedArgs> ProgressChanged
Public Event ProgressChanged As EventHandler(Of TraceDataFindProgressChangedArgs)
public:
 event EventHandler<TraceDataFindProgressChangedArgs^>^ ProgressChanged {
    void add (EventHandler<TraceDataFindProgressChangedArgs^>^ value);
    void remove (EventHandler<TraceDataFindProgressChangedArgs^>^ value);
}
member ProgressChanged : IEvent<EventHandler<TraceDataFindProgressChangedArgs>,
    TraceDataFindProgressChangedArgs>

Value

Type: SystemEventHandler TraceDataFindProgressChangedArgs
See Also

Reference

TraceDataFind Class


TraceDataFind.Direction Enumeration

TraceDataFindDirection Enumeration
Enumeration to specify the search direction.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
type Direction
Members
Member name | Value | Description
FORWARD | 0 | forward
BACKWARD | 1 | backward
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TraceDataFind.ProgressChangedArgs Class

TraceDataFindProgressChangedArgs Class
Arguments of the ProgressChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
telos.I2cApi.DotNetTraceDataFindProgressChangedArgs

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public class ProgressChangedArgs : EventArgs
Public Class ProgressChangedArgs
    Inherits EventArgs
public ref class ProgressChangedArgs : public EventArgs
type ProgressChangedArgs =
    class
        inherit EventArgs
    end

The TraceDataFindProgressChangedArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TraceDataFindProgressChangedArgs | Initializes a new instance of the TraceDataFindProgressChangedArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Cancel | Can be set by an event handler to cancel the currently running search.
Public property | Percent | progress [percent]
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TraceDataFind.ProgressChangedArgs Constructor

TraceDataFindProgressChangedArgs Constructor
Initializes a new instance of the TraceDataFindProgressChangedArgs class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ProgressChangedArgs()
Public Sub New
public:
ProgressChangedArgs()
new : unit -> ProgressChangedArgs
See Also

Reference

TraceDataFindProgressChangedArgs Class


ProgressChangedArgs Methods

ProgressChangedArgs Methods

The TraceDataFindProgressChangedArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TraceDataFindProgressChangedArgs Class


ProgressChangedArgs Properties

ProgressChangedArgs Properties

The TraceDataFindProgressChangedArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Can be set by an event handler to cancel the currently running search.
Public property | Percent | progress [percent]
Top
See Also

Reference

TraceDataFindProgressChangedArgs Class


TraceDataFind.ProgressChangedArgs.Cancel Property

TraceDataFindProgressChangedArgsCancel Property
Can be set by an event handler to cancel the currently running search.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TraceDataFindProgressChangedArgs Class


TraceDataFind.ProgressChangedArgs.Percent Property

TraceDataFindProgressChangedArgsPercent Property
progress [percent]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Percent { get; set; }
Public Property Percent As Integer
    Get
    Set
public:
property int Percent {
    int get ();
    void set (int value);
}
member Percent : int with get, set

Property Value

Type: Int32
See Also

Reference

TraceDataFindProgressChangedArgs Class


Tracer Class

Tracer Class
This class can be used to use the tracer functionality of the I2C interfaces. It is possible to start/stop the tracer module and to filter I2C messages regarding their I2C slave addresses.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetTracer

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class Tracer : IDisposable
Public NotInheritable Class Tracer
    Implements IDisposable
public ref class Tracer sealed : IDisposable
[<SealedAttribute>]
type Tracer =
    class
        interface IDisposable
    end

The Tracer type exposes the following members.

Methods
 | Name | Description
Public method | DisableAddress | This function can be used to disable an address in the filter.
Public method | DisableAllAddresses | This function can be used to disable all addresses in the filter.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | EnableAddress | This function can be used to enable an address in the filter.
Public method | EnableAllAddresses | This function can be used to enable all addresses in the filter. (default)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReceiveMessages | Reads I2C messages from the tracer module. The messages are stored in the TracerMessageList instance, which has been set using the TracerMsgList property.
Public method | ReceiveMessages(Int32) | Tries to read up to number_packets I2C message from the tracer module. The messages are stored in the TracerMessageList, which has been set using the TracerMsgList property.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Sets/gets whether the tracer module is enabled or disabled.
Public property | InputTestpins | Returns an object to get access to the input testpin logging functionality of the I2C interface connected to this object.
Public property | TracerMsgList | Sets/gets the TracerMessageList instance, which is used by ReceiveMessages. Into this instance the traced I2C messages get stored.
Top
Remarks

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the Tracer property.

Normally the following steps are necessary to use the tracer:

  1. Configure the I2C address filter (default: I2C address filter is disabled).
  2. Pass a TracerMessageList instance to the class.
  3. Enable the tracer using the Enabled property.
  4. Call WaitForData(Int32) and ReceiveMessages in a loop to get the trace messages.
  5. Disable the tracer using the Enabled property.
Examples
The following example demonstrates how to use this class in C#:
Copy
using telos.I2cApi.DotNet;
using System;
using System.Collections.Generic;

namespace MyNamespace
{
  class MyClass
  {
    /***********************************************************************/
    /// <summary>
    /// Displays the messages of the I2C tracer stored in the given data
    /// container on the console.
    /// </summary>
    ///
    /// <param name="data">tracer message list containing the messages
    ///                    to be displayed</param>
    /***********************************************************************/

    static void DisplayTraceDataRaw (TracerMessageList data)
    {
      int            i;
      TracerMessage  msg;

      // No messages available?
      if(data.Count == 0)
        return;

      // Display all messages.
      for (i=data.FirstElementIndex; i <= data.LastElementIndex; i++)
      {
        // Get one tracer message.
        msg = data[i];

        // Display type of the message.
        switch (msg.Type)
        {
          case TracerMessageType.MSG_FRAME_START:
            Console.Write ("START                      ");
            break;

          case TracerMessageType.MSG_FRAME_STOP:
            Console.Write ("STOP                       ");
            break;

          case TracerMessageType.MSG_FRAME_DATA:
            Console.Write (string.Format ("DATA (FRAME)   0x{0:X2}", msg.Data.Data));
            switch (msg.Data.Confirmation)
            {
              case TracerMessageDataConfirmation.DATA_CONFIRMATION_NONE:
                Console.Write (" (NONE) ");
                break;
              case TracerMessageDataConfirmation.DATA_CONFIRMATION_ACK:
                Console.Write (" (ACK)  ");
                break;
              case TracerMessageDataConfirmation.DATA_CONFIRMATION_NACK:
                Console.Write (" (NACK) ");
                break;
            }
            break;

          case TracerMessageType.MSG_I2C_PROTOCOL_ERROR:
            Console.Write ("ERROR                      ");
            break;

          case TracerMessageType.MSG_SMB_POWER_OFF:
            Console.Write ("SMB POWER OFF              ");
            break;

          case TracerMessageType.MSG_SMB_POWER_ON:
            Console.Write ("SMB POWER ON               ");
            break;
        }

        // Display the timestamp of a message. If the value is equal
        // to ulong.MaxValue there is no timestamp available for
        // this message.
        if (msg.Timestamp != ulong.MaxValue)
          Console.WriteLine (string.Format ("    0x{0:X16}", msg.Timestamp));
        else
          Console.WriteLine ("");
      }
    }

    /***********************************************************************/
    /// <summary>
    /// Receives messages from the I2C tracer for 30s and displays the
    /// messages on the console. The following settings are used: all
    /// I2C addresses enabled.
    /// </summary>
    ///
    /// <param name="board">open board</param>
    /***********************************************************************/

    static void TracerRaw (Board board)
    {
      TracerMessageList  trace_data;
      DateTime           stop_time;

      // Create tracer message list.
      trace_data = new TracerMessageList();

      try
      {
        // Disable I2C address filter to get all messages.
        board.Tracer.EnableAllAddresses();

        // Set the TracerMessageList, which stores the traced I2C
        // messages.
        board.Tracer.TracerMsgList = trace_data;

        // Enable tracer.
        board.Tracer.Enabled = true;

        // Calculate stop time.
        stop_time = DateTime.Now.AddSeconds(30);

        // Show information.
        Console.WriteLine("Tracing I2C messages for 30s (raw mode) ...");
        Console.WriteLine();

        // Tracer messages on the I2C bus for 30 s.
        while (DateTime.Now < stop_time)
        {
          // Sleep until there is something to do. It is very important
          // to call this method, because the following
          // ReceiveMessages() method works asynchronously. If we
          // do not call this function, the example would use 100%
          // of the available CPU power.
          board.WaitForData (TimeSpan.FromSeconds (10));

          // Get messages from the I2C API.
          board.Tracer.ReceiveMessages();

          // Display the received messages and delete the messages.
          DisplayTraceDataRaw (trace_data);
          trace_data.Clear();
        }

        // Disable tracer.
        board.Tracer.Enabled = false;
      }
      finally
      {
        // Deregister tracer message list.
        board.Tracer.TracerMsgList = null;

        // Destroy tracer message list.
        trace_data.Dispose();
      }
    }

    /***********************************************************************/
    /// <summary>
    /// Displays a parsed I2C message on the console.
    /// container on the console.
    /// </summary>
    ///
    /// <param name="msg">parsed I2C message</param>
    /// <param name="abs_time">absolute start time of the I2C message</param>
    /***********************************************************************/

    static void DisplayTraceDataParsed (IrdTraceFormatter.RawSubMessageBase[] msg, string abs_time)
    {
      IrdTraceFormatter.RawSubMessageBase   sub_msg;
      IrdTraceFormatter.RawSubMessage       sub_msg_data;
      IrdTraceFormatter.RawSubMessageError  sub_msg_error;
      string                                abs_time_internal;

      for (int i=0; i < msg.Length; i++)
      {
        // Get one sub message.
        sub_msg = msg[i];
        sub_msg_data = sub_msg as IrdTraceFormatter.RawSubMessage;
        sub_msg_error = sub_msg as IrdTraceFormatter.RawSubMessageError;

        // Show absolute time only for the first sub message.
        if (i == 0)
          abs_time_internal = abs_time;
        else
          abs_time_internal = "                   ";

        // Display sub message.
        if (sub_msg_data != null)
        {
          Console.WriteLine(string.Format("| {0} {1} {2} | {3} | {4} | {5} | {6} | {7}",
                                          sub_msg_data.Status,
                                          sub_msg_data.Speed,
                                          sub_msg_data.StartStop,
                                          sub_msg_data.I2cAddr,
                                          abs_time_internal,
                                          sub_msg_data.Direction,
                                          sub_msg_data.DataLength.PadLeft(2),
                                          sub_msg_data.Data));
        }
        else
        {
          Console.WriteLine(string.Format("| {0}      |      | {1} |    |    | {2}",
                                          sub_msg_error.Status,
                                          abs_time_internal,
                                          sub_msg_error.ErrorDescription));
        }
      }

      // Display message divider.
      Console.WriteLine("----------------------------------------------------------------------");
    }

    /***********************************************************************/
    /// <summary>
    /// Receives messages from the I2C tracer for 5s and displays the
    /// parsed messages on the console. The following settings are used:
    /// all I2C addresses enabled.
    /// </summary>
    ///
    /// <param name="board">open board</param>
    /***********************************************************************/

    static void TracerParsed(Board board)
    {
      TracerMessageList       trace_data;
      ParsedTracerMessageList parsed_trace_data;
      IrdTraceValueList       ird_trace_value_list;
      IrdTraceFormatter       ird_trace_formatter;
      IrdMap                  ird_map;
      DateTime                stop_time;
      IrdTraceFormatter.RawSubMessageBase[]  raw_message;
      string                                 raw_message_abs_time;

      // Create tracer message list.
      trace_data = new TracerMessageList();

      try
      {
        // Disable I2C address filter to get all messages.
        board.Tracer.EnableAllAddresses();

        // Set the TracerMessageList, which stores the traced I2C messages.
        board.Tracer.TracerMsgList = trace_data;

        // Create parsed tracer message list.
        parsed_trace_data = new ParsedTracerMessageList(trace_data, 10);

        // Create IRD map.
        ird_map = new IrdMap();

        // Create IRD trace value list.
        ird_trace_value_list = new IrdTraceValueList(parsed_trace_data,
                                                     ird_map,
                                                     board.HardwareInfoOfOpenBoard,
                                                     10);

        // Create IRD formatter.
        ird_trace_formatter = new IrdTraceFormatter(ird_trace_value_list, 10);

        // Enable tracer.
        board.Tracer.Enabled = true;

        // Calculate stop time.
        stop_time = DateTime.Now.AddSeconds(5);

        // Show information.
        Console.WriteLine();
        Console.WriteLine("Tracing I2C messages for 5s (parsed mode), please wait ...");

        // Tracer messages on the I2C bus for 5 s.
        while (DateTime.Now < stop_time)
        {
          // Sleep until there is something to do. It is very important
          // to call this method, because the following
          // ReceiveMessages() method works asynchronously. If we
          // do not call this function, the example would use 100%
          // of the available CPU power.
          board.WaitForData(TimeSpan.FromSeconds(10));

          // Get messages from the I2C API.
          board.Tracer.ReceiveMessages();
        }

        // Disable tracer.
        board.Tracer.Enabled = false;

        // Show information.
        Console.WriteLine();

        // Display messages.
        for (int i = 0; i < ird_trace_formatter.Count; i++)
        {
          // Get parsed raw message and absolute time.
          raw_message = ird_trace_formatter.GetRawMsg(i);
          raw_message_abs_time = ird_trace_formatter.GetAbsTimeComplete(i, 0);

          // Display message.
          DisplayTraceDataParsed(raw_message, raw_message_abs_time);
        }
      }
      finally
      {
        // Deregister tracer message list.
        board.Tracer.TracerMsgList = null;

        // Destroy tracer message list.
        trace_data.Dispose();
      }
    }

    [STAThread]
    static void Main(string[] args)
    {
      Board  board = null;

      try
      {
        // Open an I2C interface with tracer license.
        board = new Board();
        for (int i=board.ListOfBoards.Count-1; i >= 0; i--)
        {
          if (board.ListOfBoards[i].Tracer == true)
          {
            board.Open (board.ListOfBoards[i]);
            break;
          }
        }

        // No I2C interface with tracer license found?
        if (board.IsOpen == false)
        {
          Console.WriteLine("No I2C interface with tracer license has been found.");
          return;
        }
        else
        {
          Console.WriteLine(string.Format("Using {0} [0x{1:X4}]",
                                          board.HardwareInfoOfOpenBoard.BoardType,
                                          board.HardwareInfoOfOpenBoard.SerialNumber));
        }

        // Demonstrate the tracer (raw mode).
        TracerRaw (board);

        // Demonstrate the tracer (parsed mode).
        TracerParsed (board);

        // Close I2C interface.
        board.Close();
      }
      catch (System.Exception exp)
      {
        Console.WriteLine ("Error: " + exp.Message);
      }
      finally
      {
        // Free all resources allocated by the board object.
        // It is very important to call this method before the
        // garbage collector destroys the unused Board object.
        if (board != null)
          board.Dispose();
      }
    }
  }
}
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


Tracer Methods

Tracer Methods

The Tracer type exposes the following members.

Methods
 | Name | Description
Public method | DisableAddress | This function can be used to disable an address in the filter.
Public method | DisableAllAddresses | This function can be used to disable all addresses in the filter.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | EnableAddress | This function can be used to enable an address in the filter.
Public method | EnableAllAddresses | This function can be used to enable all addresses in the filter. (default)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReceiveMessages | Reads I2C messages from the tracer module. The messages are stored in the TracerMessageList instance, which has been set using the TracerMsgList property.
Public method | ReceiveMessages(Int32) | Tries to read up to number_packets I2C message from the tracer module. The messages are stored in the TracerMessageList, which has been set using the TracerMsgList property.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tracer Class


Tracer.DisableAddress Method

TracerDisableAddress Method
This function can be used to disable an address in the filter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void DisableAddress(
    I2cAddress address
)
Public Sub DisableAddress (
    address As I2cAddress
)
public:
void DisableAddress(
    I2cAddress^ address
)
member DisableAddress :
        address : I2cAddress -> unit

Parameters

address
Type: telos.I2cApi.DotNetI2cAddress
I2C address to be disabled
Remarks
The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.
See Also

Reference

Tracer Class


Tracer.DisableAllAddresses Method

TracerDisableAllAddresses Method
This function can be used to disable all addresses in the filter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void DisableAllAddresses()
Public Sub DisableAllAddresses
public:
void DisableAllAddresses()
member DisableAllAddresses : unit -> unit
Remarks
The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.
See Also

Reference

Tracer Class


Tracer.Dispose Method

TracerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

Tracer Class


Tracer.Dispose Method

TracerDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Tracer Class
Dispose Overload


Tracer.Dispose Method (Boolean)

TracerDispose Method (Boolean)
Releases the unmanaged resources used by the Tracer and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.Tracer.Dispose(System.Boolean)"]

See Also

Reference

Tracer Class
Dispose Overload


Tracer.EnableAddress Method

TracerEnableAddress Method
This function can be used to enable an address in the filter.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void EnableAddress(
    I2cAddress address
)
Public Sub EnableAddress (
    address As I2cAddress
)
public:
void EnableAddress(
    I2cAddress^ address
)
member EnableAddress :
        address : I2cAddress -> unit

Parameters

address
Type: telos.I2cApi.DotNetI2cAddress
I2C address to be enabled
Remarks
The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.
See Also

Reference

Tracer Class


Tracer.EnableAllAddresses Method

TracerEnableAllAddresses Method
This function can be used to enable all addresses in the filter. (default)

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void EnableAllAddresses()
Public Sub EnableAllAddresses
public:
void EnableAllAddresses()
member EnableAllAddresses : unit -> unit
Remarks
The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.
See Also

Reference

Tracer Class


Tracer.Finalize Method

TracerFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

Tracer Class


Tracer.ReceiveMessages Method

TracerReceiveMessages Method
Overload List
 | Name | Description
Public method | ReceiveMessages | Reads I2C messages from the tracer module. The messages are stored in the TracerMessageList instance, which has been set using the TracerMsgList property.
Public method | ReceiveMessages(Int32) | Tries to read up to number_packets I2C message from the tracer module. The messages are stored in the TracerMessageList, which has been set using the TracerMsgList property.
Top
See Also

Reference

Tracer Class


Tracer.ReceiveMessages Method

TracerReceiveMessages Method
Reads I2C messages from the tracer module. The messages are stored in the TracerMessageList instance, which has been set using the TracerMsgList property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int ReceiveMessages()
Public Function ReceiveMessages As Integer
public:
int ReceiveMessages()
member ReceiveMessages : unit -> int

Return Value

Type: Int32
numer of messages read
Remarks

This method will always return immediately.

Normally this method gets called in a loop together with WaitForData(Int32).

The list passed to this method gets locked (Monitor) while the method is running.

See Also

Reference

Tracer Class
ReceiveMessages Overload


Tracer.ReceiveMessages Method (Int32)

TracerReceiveMessages Method (Int32)
Tries to read up to number_packets I2C message from the tracer module. The messages are stored in the TracerMessageList, which has been set using the TracerMsgList property.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int ReceiveMessages(
    int number_packets
)
Public Function ReceiveMessages (
    number_packets As Integer
) As Integer
public:
int ReceiveMessages(
    int number_packets
)
member ReceiveMessages :
        number_packets : int -> int

Parameters

number_packets
Type: SystemInt32
number of I2C messages to be read

Return Value

Type: Int32
numer of messages read (0..number_packets)
Remarks

This function will not wait until all requested tracer messages are available. Instead this method will always return immediately.

Normally this method gets called in a loop together with WaitForData(Int32).

The list passed to this method gets locked (Monitor) while the method is running.

See Also

Reference

Tracer Class
ReceiveMessages Overload


Tracer Properties

Tracer Properties

The Tracer type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Sets/gets whether the tracer module is enabled or disabled.
Public property | InputTestpins | Returns an object to get access to the input testpin logging functionality of the I2C interface connected to this object.
Public property | TracerMsgList | Sets/gets the TracerMessageList instance, which is used by ReceiveMessages. Into this instance the traced I2C messages get stored.
Top
See Also

Reference

Tracer Class


Tracer.Enabled Property

TracerEnabled Property
Sets/gets whether the tracer module is enabled or disabled.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Tracer Class


Tracer.InputTestpins Property

TracerInputTestpins Property
Returns an object to get access to the input testpin logging functionality of the I2C interface connected to this object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public InputTestpins InputTestpins { get; }
Public ReadOnly Property InputTestpins As InputTestpins
    Get
public:
property InputTestpins^ InputTestpins {
    InputTestpins^ get ();
}
member InputTestpins : InputTestpins with get

Property Value

Type: InputTestpins
See Also

Reference

Tracer Class


Tracer.TracerMsgList Property

TracerTracerMsgList Property
Sets/gets the TracerMessageList instance, which is used by ReceiveMessages. Into this instance the traced I2C messages get stored.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessageList TracerMsgList { get; set; }
Public Property TracerMsgList As TracerMessageList
    Get
    Set
public:
property TracerMessageList^ TracerMsgList {
    TracerMessageList^ get ();
    void set (TracerMessageList^ value);
}
member TracerMsgList : TracerMessageList with get, set

Property Value

Type: TracerMessageList
See Also

Reference

Tracer Class


TracerMessage Class

TracerMessage Class
This class is used to store one trace message created by the methods of the Tracer class.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetTracerMessage

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TracerMessage : ICloneable
Public NotInheritable Class TracerMessage
    Implements ICloneable
public ref class TracerMessage sealed : ICloneable
[<SealedAttribute>]
type TracerMessage =
    class
        interface ICloneable
    end

The TracerMessage type exposes the following members.

Constructors
 | Name | Description
Public method | TracerMessage | Initializes a new instance of the TracerMessage class
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Data | data of a MSG_FRAME_DATA message
Public property | Timestamp | timestamp of the message or N/A (MaxValue), see TimestampTimebase for the timebase
Public property | Type | type of the message
Top
Remarks
Supports the ICloneable interface.
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TracerMessage Constructor

TracerMessage Constructor
Initializes a new instance of the TracerMessage class

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessage()
Public Sub New
public:
TracerMessage()
new : unit -> TracerMessage
See Also

Reference

TracerMessage Class


TracerMessage Methods

TracerMessage Methods

The TracerMessage type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TracerMessage Class


TracerMessage.Clone Method

TracerMessageClone Method
Creates a deep copy of the object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
deep copy

Implements

ICloneableClone
See Also

Reference

TracerMessage Class


TracerMessage Properties

TracerMessage Properties

The TracerMessage type exposes the following members.

Properties
 | Name | Description
Public property | Data | data of a MSG_FRAME_DATA message
Public property | Timestamp | timestamp of the message or N/A (MaxValue), see TimestampTimebase for the timebase
Public property | Type | type of the message
Top
See Also

Reference

TracerMessage Class


TracerMessage.Data Property

TracerMessageData Property
data of a MSG_FRAME_DATA message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessageData Data { get; set; }
Public Property Data As TracerMessageData
    Get
    Set
public:
property TracerMessageData Data {
    TracerMessageData get ();
    void set (TracerMessageData value);
}
member Data : TracerMessageData with get, set

Property Value

Type: TracerMessageData
See Also

Reference

TracerMessage Class


TracerMessage.Timestamp Property

TracerMessageTimestamp Property
timestamp of the message or N/A (MaxValue), see TimestampTimebase for the timebase

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public ulong Timestamp { get; set; }
Public Property Timestamp As ULong
    Get
    Set
public:
property unsigned long long Timestamp {
    unsigned long long get ();
    void set (unsigned long long value);
}
member Timestamp : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

TracerMessage Class


TracerMessage.Type Property

TracerMessageType Property
type of the message

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessageType Type { get; set; }
Public Property Type As TracerMessageType
    Get
    Set
public:
property TracerMessageType Type {
    TracerMessageType get ();
    void set (TracerMessageType value);
}
member Type : TracerMessageType with get, set

Property Value

Type: TracerMessageType
See Also

Reference

TracerMessage Class


TracerMessageData Structure

TracerMessageData Structure
This structure is used for MSG_FRAME_DATA messages to store the data transferred over the I2C bus.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public struct TracerMessageData
Public Structure TracerMessageData
public value class TracerMessageData
[<SealedAttribute>]
type TracerMessageData =  struct end

The TracerMessageData type exposes the following members.

Constructors
 | Name | Description
Public method | TracerMessageData | Constructor
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Properties
 | Name | Description
Public property | Confirmation | received confirmation
Public property | Data | transferred data byte
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TracerMessageData Constructor

TracerMessageData Constructor
Constructor

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessageData(
    byte data,
    TracerMessageDataConfirmation confirmation
)
Public Sub New (
    data As Byte,
    confirmation As TracerMessageDataConfirmation
)
public:
TracerMessageData(
    unsigned char data,
    TracerMessageDataConfirmation confirmation
)
new :
        data : byte *
        confirmation : TracerMessageDataConfirmation -> TracerMessageData

Parameters

data
Type: SystemByte
transferred data byte
confirmation
Type: telos.I2cApi.DotNetTracerMessageDataConfirmation
received confirmation
See Also

Reference

TracerMessageData Structure


TracerMessageData Methods

TracerMessageData Methods

The TracerMessageData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

TracerMessageData Structure


TracerMessageData Properties

TracerMessageData Properties

The TracerMessageData type exposes the following members.

Properties
 | Name | Description
Public property | Confirmation | received confirmation
Public property | Data | transferred data byte
Top
See Also

Reference

TracerMessageData Structure


TracerMessageData.Confirmation Property

TracerMessageDataConfirmation Property
received confirmation

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessageDataConfirmation Confirmation { get; set; }
Public Property Confirmation As TracerMessageDataConfirmation
    Get
    Set
public:
property TracerMessageDataConfirmation Confirmation {
    TracerMessageDataConfirmation get ();
    void set (TracerMessageDataConfirmation value);
}
member Confirmation : TracerMessageDataConfirmation with get, set

Property Value

Type: TracerMessageDataConfirmation
See Also

Reference

TracerMessageData Structure


TracerMessageData.Data Property

TracerMessageDataData Property
transferred data byte

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public byte Data { get; set; }
Public Property Data As Byte
    Get
    Set
public:
property unsigned char Data {
    unsigned char get ();
    void set (unsigned char value);
}
member Data : byte with get, set

Property Value

Type: Byte
See Also

Reference

TracerMessageData Structure


TracerMessageDataConfirmation Enumeration

TracerMessageDataConfirmation Enumeration
This enumeration is used for MSG_FRAME_DATA messages. It indicates whether an ACK or NACK has been received after the data message.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum TracerMessageDataConfirmation
Public Enumeration TracerMessageDataConfirmation
public enum class TracerMessageDataConfirmation
type TracerMessageDataConfirmation
Members
Member name | Value | Description
DATA_CONFIRMATION_NONE | 0 | none
DATA_CONFIRMATION_ACK | 1 | ACK
DATA_CONFIRMATION_NACK | 2 | NACK
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TracerMessageList Class

TracerMessageList Class
Instances of this list are used to store the I2C messages received from the hardware.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetTracerMessageList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TracerMessageList : IReadOnlyList<TracerMessage>,
    IDisposable
Public NotInheritable Class TracerMessageList
    Implements IReadOnlyList(Of TracerMessage), IDisposable
public ref class TracerMessageList sealed : IReadOnlyList<TracerMessage^>,
    IDisposable
[<SealedAttribute>]
type TracerMessageList =
    class
        interface IReadOnlyList<TracerMessage>
        interface IDisposable
    end

The TracerMessageList type exposes the following members.

Constructors
 | Name | Description
Public method | TracerMessageList | Constructor.
Top
Methods
 | Name | Description
Public method | Add(ICollectionTracerMessage) | Adds unmanaged tracer messages to the end of the list. If adding of additional objects would exceed the SizeLimitInMessages value, this method removes the oldest objects from the list before adding the new objects.
Public method | Add(TracerMessage) | Adds a managed tracer message to the end of the list. If adding an additional object would exceed the SizeLimitInMessages or the SizeLimitInKBytes value, this method removes the oldest object from the list before adding the new object.
Public method | Clear | Removes all messages from the list.
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the TracerMessage object in the list, which contains the specified timestamp.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Recover | This class uses temporary files to store the I2C messages. All temporary files of one instance are stored within one directory. This method allows to fill the list with the data from these temporary files. This can be used in the case of an error to recover an old list.
Public method | Remove | Removes the specified number of messages from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CombinedStartReferences | Returns a list containing the absolute indices of all START messages in the TracerMessageList, which follow a STOP messages.
Public property | Count | Gets the number of messages in the list.
Public property | FirstElementIndex | Returns the index of the first message in the list. If the list is empty, this method returns "-1".
Public property | Item |
Public property | LastElementIndex | Returns the index of the last message in the list. If the list is empty, this method returns "-1".
Public property | SizeLimitInKBytes | Sets/gets the maximum size in kBytes, which can be used by the list. If this threshold is exceeded, the oldest messages are deleted automatically. The default value is MaxValue.
Public property | SizeLimitInMessages | Sets/gets the maximum number of messages which can be stored in the list. If this threshold is exceeded, the oldest messages are deleted automatically. The default value is MaxValue.
Public property | StartReferences | Returns a list containing the absolute indices of all START messages in the TracerMessageList.
Public property | TempPath | Gets the path of the temp files.
Public property | UsedSpace | Returns the space currently used by the list on the hard disc [kBytes].
Top
Remarks

Each element added to the list will get an unique index. The index does not change even if an element gets removed from the list. If you add 5 elements to an empty list, the elements will get the identifiers 0..4. After removing the first element the list will contain the elements 1..4.

Before using any methods or properties of an instance of this class it is necessary to lock the object using Enter(Object). To unlock the object using Exit(Object).

See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TracerMessageList Constructor

TracerMessageList Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerMessageList()
Public Sub New
public:
TracerMessageList()
new : unit -> TracerMessageList
See Also

Reference

TracerMessageList Class


TracerMessageList Methods

TracerMessageList Methods

The TracerMessageList type exposes the following members.

Methods
 | Name | Description
Public method | Add(ICollectionTracerMessage) | Adds unmanaged tracer messages to the end of the list. If adding of additional objects would exceed the SizeLimitInMessages value, this method removes the oldest objects from the list before adding the new objects.
Public method | Add(TracerMessage) | Adds a managed tracer message to the end of the list. If adding an additional object would exceed the SizeLimitInMessages or the SizeLimitInKBytes value, this method removes the oldest object from the list before adding the new object.
Public method | Clear | Removes all messages from the list.
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetEnumerator_NonGeneric | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexByTimestamp | Returns the index of the TracerMessage object in the list, which contains the specified timestamp.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Recover | This class uses temporary files to store the I2C messages. All temporary files of one instance are stored within one directory. This method allows to fill the list with the data from these temporary files. This can be used in the case of an error to recover an old list.
Public method | Remove | Removes the specified number of messages from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TracerMessageList Class


TracerMessageList.Add Method

TracerMessageListAdd Method
Overload List
 | Name | Description
Public method | Add(ICollectionTracerMessage) | Adds unmanaged tracer messages to the end of the list. If adding of additional objects would exceed the SizeLimitInMessages value, this method removes the oldest objects from the list before adding the new objects.
Public method | Add(TracerMessage) | Adds a managed tracer message to the end of the list. If adding an additional object would exceed the SizeLimitInMessages or the SizeLimitInKBytes value, this method removes the oldest object from the list before adding the new object.
Top
See Also

Reference

TracerMessageList Class


TracerMessageList.Add Method (ICollection(TracerMessage))

TracerMessageListAdd Method (ICollectionTracerMessage)
Adds unmanaged tracer messages to the end of the list. If adding of additional objects would exceed the SizeLimitInMessages value, this method removes the oldest objects from the list before adding the new objects.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ICollection<TracerMessage> msgs
)
Public Sub Add (
    msgs As ICollection(Of TracerMessage)
)
public:
void Add(
    ICollection<TracerMessage^>^ msgs
)
member Add :
        msgs : ICollection<TracerMessage> -> unit

Parameters

msgs
Type: System.Collections.GenericICollection TracerMessage
messages to be added
Remarks
It is not necessary to lock the instance, before using this methods. Locking is done internally.
See Also

Reference

TracerMessageList Class
Add Overload


TracerMessageList.Add Method (TracerMessage)

TracerMessageListAdd Method (TracerMessage)
Adds a managed tracer message to the end of the list. If adding an additional object would exceed the SizeLimitInMessages or the SizeLimitInKBytes value, this method removes the oldest object from the list before adding the new object.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    TracerMessage msg
)
Public Sub Add (
    msg As TracerMessage
)
public:
void Add(
    TracerMessage^ msg
)
member Add :
        msg : TracerMessage -> unit

Parameters

msg
Type: telos.I2cApi.DotNetTracerMessage
message to be added
See Also

Reference

TracerMessageList Class
Add Overload


TracerMessageList.Clear Method

TracerMessageListClear Method
Removes all messages from the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TracerMessageList Class


TracerMessageList.Dispose Method

TracerMessageListDispose Method
Overload List
 | Name | Description
Public method | Dispose | Dispose.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

TracerMessageList Class


TracerMessageList.Dispose Method

TracerMessageListDispose Method
Dispose.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TracerMessageList Class
Dispose Overload


TracerMessageList.Dispose Method (Boolean)

TracerMessageListDispose Method (Boolean)
Releases the unmanaged resources used by the TracerMessageList and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.TracerMessageList.Dispose(System.Boolean)"]

See Also

Reference

TracerMessageList Class
Dispose Overload


TracerMessageList.Finalize Method

TracerMessageListFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

TracerMessageList Class


TracerMessageList.GetEnumerator Method

TracerMessageListGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<TracerMessage> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TracerMessage)
public:
virtual IEnumerator<TracerMessage^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<TracerMessage>
override GetEnumerator : unit -> IEnumerator<TracerMessage>

Return Value

Type: IEnumerator TracerMessage
enumerator
See Also

Reference

TracerMessageList Class


TracerMessageList.GetEnumerator_NonGeneric Method

TracerMessageListGetEnumerator_NonGeneric Method
Returns an enumerator that iterates through the collection.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator_NonGeneric()
Public Function GetEnumerator_NonGeneric As IEnumerator
public:
virtual IEnumerator^ GetEnumerator_NonGeneric() sealed
abstract GetEnumerator_NonGeneric : unit -> IEnumerator
override GetEnumerator_NonGeneric : unit -> IEnumerator

Return Value

Type: IEnumerator
enumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

TracerMessageList Class


TracerMessageList.GetIndexByTimestamp Method

TracerMessageListGetIndexByTimestamp Method
Returns the index of the TracerMessage object in the list, which contains the specified timestamp.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetIndexByTimestamp(
    ulong timestamp
)
Public Function GetIndexByTimestamp (
    timestamp As ULong
) As Integer
public:
int GetIndexByTimestamp(
    unsigned long long timestamp
)
member GetIndexByTimestamp :
        timestamp : uint64 -> int

Parameters

timestamp
Type: SystemUInt64
timestamp of the searched element

Return Value

Type: Int32
element nearest to the searched timestamp (-1)
Remarks

In most cases there is no element with matches exactly the specified timestamp. In such cases this function searches the two elements surrounding this timestamp and returns the element with the smaller index.

If the list is empty, this method returns "-1".

See Also

Reference

TracerMessageList Class


TracerMessageList.Recover Method

TracerMessageListRecover Method
This class uses temporary files to store the I2C messages. All temporary files of one instance are stored within one directory. This method allows to fill the list with the data from these temporary files. This can be used in the case of an error to recover an old list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Recover(
    string tmp_path
)
Public Sub Recover (
    tmp_path As String
)
public:
void Recover(
    String^ tmp_path
)
member Recover :
        tmp_path : string -> unit

Parameters

tmp_path
Type: SystemString
path of the temporary files
See Also

Reference

TracerMessageList Class


TracerMessageList.Remove Method

TracerMessageListRemove Method
Removes the specified number of messages from the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    int count
)
Public Sub Remove (
    count As Integer
)
public:
void Remove(
    int count
)
member Remove :
        count : int -> unit

Parameters

count
Type: SystemInt32
number of messages to be removed
See Also

Reference

TracerMessageList Class


TracerMessageList Properties

TracerMessageList Properties

The TracerMessageList type exposes the following members.

Properties
 | Name | Description
Public property | CombinedStartReferences | Returns a list containing the absolute indices of all START messages in the TracerMessageList, which follow a STOP messages.
Public property | Count | Gets the number of messages in the list.
Public property | FirstElementIndex | Returns the index of the first message in the list. If the list is empty, this method returns "-1".
Public property | Item |
Public property | LastElementIndex | Returns the index of the last message in the list. If the list is empty, this method returns "-1".
Public property | SizeLimitInKBytes | Sets/gets the maximum size in kBytes, which can be used by the list. If this threshold is exceeded, the oldest messages are deleted automatically. The default value is MaxValue.
Public property | SizeLimitInMessages | Sets/gets the maximum number of messages which can be stored in the list. If this threshold is exceeded, the oldest messages are deleted automatically. The default value is MaxValue.
Public property | StartReferences | Returns a list containing the absolute indices of all START messages in the TracerMessageList.
Public property | TempPath | Gets the path of the temp files.
Public property | UsedSpace | Returns the space currently used by the list on the hard disc [kBytes].
Top
See Also

Reference

TracerMessageList Class


TracerMessageList.CombinedStartReferences Property

TracerMessageListCombinedStartReferences Property
Returns a list containing the absolute indices of all START messages in the TracerMessageList, which follow a STOP messages.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerStartReferencesList CombinedStartReferences { get; }
Public ReadOnly Property CombinedStartReferences As TracerStartReferencesList
    Get
public:
property TracerStartReferencesList^ CombinedStartReferences {
    TracerStartReferencesList^ get ();
}
member CombinedStartReferences : TracerStartReferencesList with get

Property Value

Type: TracerStartReferencesList
See Also

Reference

TracerMessageList Class


TracerMessageList.Count Property

TracerMessageListCount Property
Gets the number of messages in the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IReadOnlyListTCount
See Also

Reference

TracerMessageList Class


TracerMessageList.FirstElementIndex Property

TracerMessageListFirstElementIndex Property
Returns the index of the first message in the list. If the list is empty, this method returns "-1".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int FirstElementIndex { get; }
Public ReadOnly Property FirstElementIndex As Integer
    Get
public:
property int FirstElementIndex {
    int get ();
}
member FirstElementIndex : int with get

Property Value

Type: Int32
See Also

Reference

TracerMessageList Class


TracerMessageList.Item Property

TracerMessageListItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.TracerMessageList.Item(System.Int32)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public virtual TracerMessage this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As TracerMessage
    Get
public:
virtual property TracerMessage^ default[int index] {
    TracerMessage^ get (int index);
}
abstract Item : TracerMessage with get
override Item : TracerMessage with get

Parameters

index
Type: SystemInt32

Property Value

Type: TracerMessage

Implements

IReadOnlyListTItemInt32
See Also

Reference

TracerMessageList Class


TracerMessageList.LastElementIndex Property

TracerMessageListLastElementIndex Property
Returns the index of the last message in the list. If the list is empty, this method returns "-1".

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int LastElementIndex { get; }
Public ReadOnly Property LastElementIndex As Integer
    Get
public:
property int LastElementIndex {
    int get ();
}
member LastElementIndex : int with get

Property Value

Type: Int32
See Also

Reference

TracerMessageList Class


TracerMessageList.SizeLimitInKBytes Property

TracerMessageListSizeLimitInKBytes Property
Sets/gets the maximum size in kBytes, which can be used by the list. If this threshold is exceeded, the oldest messages are deleted automatically. The default value is MaxValue.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int SizeLimitInKBytes { get; set; }
Public Property SizeLimitInKBytes As Integer
    Get
    Set
public:
property int SizeLimitInKBytes {
    int get ();
    void set (int value);
}
member SizeLimitInKBytes : int with get, set

Property Value

Type: Int32
See Also

Reference

TracerMessageList Class


TracerMessageList.SizeLimitInMessages Property

TracerMessageListSizeLimitInMessages Property
Sets/gets the maximum number of messages which can be stored in the list. If this threshold is exceeded, the oldest messages are deleted automatically. The default value is MaxValue.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int SizeLimitInMessages { get; set; }
Public Property SizeLimitInMessages As Integer
    Get
    Set
public:
property int SizeLimitInMessages {
    int get ();
    void set (int value);
}
member SizeLimitInMessages : int with get, set

Property Value

Type: Int32
See Also

Reference

TracerMessageList Class


TracerMessageList.StartReferences Property

TracerMessageListStartReferences Property
Returns a list containing the absolute indices of all START messages in the TracerMessageList.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerStartReferencesList StartReferences { get; }
Public ReadOnly Property StartReferences As TracerStartReferencesList
    Get
public:
property TracerStartReferencesList^ StartReferences {
    TracerStartReferencesList^ get ();
}
member StartReferences : TracerStartReferencesList with get

Property Value

Type: TracerStartReferencesList
See Also

Reference

TracerMessageList Class


TracerMessageList.TempPath Property

TracerMessageListTempPath Property
Gets the path of the temp files.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public string TempPath { get; }
Public ReadOnly Property TempPath As String
    Get
public:
property String^ TempPath {
    String^ get ();
}
member TempPath : string with get

Property Value

Type: String
See Also

Reference

TracerMessageList Class


TracerMessageList.UsedSpace Property

TracerMessageListUsedSpace Property
Returns the space currently used by the list on the hard disc [kBytes].

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int UsedSpace { get; }
Public ReadOnly Property UsedSpace As Integer
    Get
public:
property int UsedSpace {
    int get ();
}
member UsedSpace : int with get

Property Value

Type: Int32
See Also

Reference

TracerMessageList Class


TracerMessageType Enumeration

TracerMessageType Enumeration
Enumeration to specify the type of an I2C message. The types can be categorized into two groups: frame-based messages, and protocol errors.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public enum TracerMessageType
Public Enumeration TracerMessageType
public enum class TracerMessageType
type TracerMessageType
Members
Member name | Value | Description
MSG_FRAME_START | 0 | frame mode: START
MSG_FRAME_STOP | 1 | frame mode: STOP
MSG_FRAME_DATA | 2 | frame mode: DATA
MSG_I2C_PROTOCOL_ERROR | 3 | I2C protocol error
MSG_DATA_LOST | 4 | lost trace data (N/A)
MSG_SMB_POWER_ON | 5 | SMB power on
MSG_SMB_POWER_OFF | 6 | SMB power off
MSG_TRACER_RESTARTED | 7 | tracer has been restarted
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TracerStartReferencesList Class

TracerStartReferencesList Class
Class to store the list of indices pointing to the start of I2C messages.
Inheritance Hierarchy
SystemObject
telos.I2cApi.DotNetTracerStartReferencesList

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public sealed class TracerStartReferencesList : IDisposable
Public NotInheritable Class TracerStartReferencesList
    Implements IDisposable
public ref class TracerStartReferencesList sealed : IDisposable
[<SealedAttribute>]
type TracerStartReferencesList =
    class
        interface IDisposable
    end

The TracerStartReferencesList type exposes the following members.

Constructors
 | Name | Description
Public method | TracerStartReferencesList | Constructor.
Top
Methods
 | Name | Description
Public method | Add | Adds the specified data element to the end of the list.
Public method | ChangeFront | Modifies the first element of the list.
Public method | Clear | Removes all elements from the list.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLowerBound | Executes a binary search for the specified value in the list. This method returns the index of the element containing the specified value or the next smaller index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveFront | Removes the first elements from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements which are stored in the list.
Public property | Item |
Top
See Also

Reference

telos.I2cApi.DotNet Namespace
Send comments on this topic to tsupport@telos.de


TracerStartReferencesList Constructor

TracerStartReferencesList Constructor
Constructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public TracerStartReferencesList()
Public Sub New
public:
TracerStartReferencesList()
new : unit -> TracerStartReferencesList
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList Methods

TracerStartReferencesList Methods

The TracerStartReferencesList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified data element to the end of the list.
Public method | ChangeFront | Modifies the first element of the list.
Public method | Clear | Removes all elements from the list.
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalize. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLowerBound | Executes a binary search for the specified value in the list. This method returns the index of the element containing the specified value or the next smaller index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveFront | Removes the first elements from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.Add Method

TracerStartReferencesListAdd Method
Adds the specified data element to the end of the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    long data
)
Public Sub Add (
    data As Long
)
public:
void Add(
    long long data
)
member Add :
        data : int64 -> unit

Parameters

data
Type: SystemInt64
data to be added
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.ChangeFront Method

TracerStartReferencesListChangeFront Method
Modifies the first element of the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void ChangeFront(
    long data
)
Public Sub ChangeFront (
    data As Long
)
public:
void ChangeFront(
    long long data
)
member ChangeFront :
        data : int64 -> unit

Parameters

data
Type: SystemInt64
data to be set
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.Clear Method

TracerStartReferencesListClear Method
Removes all elements from the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.Dispose Method

TracerStartReferencesListDispose Method
Overload List
 | Name | Description
Public method | Dispose | Destructor.
Protected method | Dispose(Boolean) |
Top
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.Dispose Method

TracerStartReferencesListDispose Method
Destructor.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TracerStartReferencesList Class
Dispose Overload


TracerStartReferencesList.Dispose Method (Boolean)

TracerStartReferencesListDispose Method (Boolean)
Releases the unmanaged resources used by the TracerStartReferencesList and optionally releases the managed resources

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected void Dispose(
    bool A_0
)
Protected Sub Dispose (
    A_0 As Boolean
)
protected:
virtual void Dispose(
    bool A_0
) sealed
abstract Dispose :
        A_0 : bool -> unit
override Dispose :
        A_0 : bool -> unit

Parameters

A_0
Type: SystemBoolean

[Missing <param name="A_0"/> documentation for "M:telos.I2cApi.DotNet.TracerStartReferencesList.Dispose(System.Boolean)"]

See Also

Reference

TracerStartReferencesList Class
Dispose Overload


TracerStartReferencesList.Finalize Method

TracerStartReferencesListFinalize Method
Finalize.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
protected override sealed void Finalize()
Protected Overrides NotOverridable Sub Finalize
protected:
virtual void Finalize() override sealed
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.GetLowerBound Method

TracerStartReferencesListGetLowerBound Method
Executes a binary search for the specified value in the list. This method returns the index of the element containing the specified value or the next smaller index.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int GetLowerBound(
    long value
)
Public Function GetLowerBound (
    value As Long
) As Integer
public:
int GetLowerBound(
    long long value
)
member GetLowerBound :
        value : int64 -> int

Parameters

value
Type: SystemInt64
value to be searched

Return Value

Type: Int32
index of the found element
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.RemoveFront Method

TracerStartReferencesListRemoveFront Method
Removes the first elements from the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveFront(
    long count
)
Public Sub RemoveFront (
    count As Long
)
public:
void RemoveFront(
    long long count
)
member RemoveFront :
        count : int64 -> unit

Parameters

count
Type: SystemInt64
number of elements to be removed
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList Properties

TracerStartReferencesList Properties

The TracerStartReferencesList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements which are stored in the list.
Public property | Item |
Top
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.Count Property

TracerStartReferencesListCount Property
Gets the number of elements which are stored in the list.

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

TracerStartReferencesList Class


TracerStartReferencesList.Item Property

TracerStartReferencesListItem Property

[Missing <summary> documentation for "P:telos.I2cApi.DotNet.TracerStartReferencesList.Item(System.Int64)"]

Namespace: telos.I2cApi.DotNet
Assembly: i2capi_dotnet_net40 (in i2capi_dotnet_net40.dll) Version: 5.8.0.0
Syntax
C#
VB
C++
F#
Copy
public int this[
    long index
] { get; }
Public ReadOnly Default Property Item (
    index As Long
) As Integer
    Get
public:
property int default[long long index] {
    int get (long long index);
}
member Item : int with get

Parameters

index
Type: SystemInt64

Property Value

Type: Int32
See Also

Reference

TracerStartReferencesList Class