I2C.URT & I2C.URD API: Introduction to the I2C.URT & I2C.URD APIs

  • Main Page
  • Related Pages
Introduction to the I2C.URT & I2C.URD APIs

All telos I2C boards support the "Universal Register Tool" (URT) and the "Universal Register Debugger" (URD). Both tools released by NXP (found by Philips) can be used to manipulate and/or read out registers of ICs via I2C.

The support for all I2C boards from telos is implemented in the "i2ctelos.dll" library, which can be found in the "<Program Files>\telos Systementwicklung GmbH\I2C Studio\bin\" directory.

  • I2C.URT API
  • I2C.URD API
telos Systementwicklung GmbH (http://www.telos.info) Tue Sep 18 2018


I2C.URT & I2C.URD API: I2C.URT API

  • Main Page
  • Related Pages
I2C.URT API

The URT driver for all I2C interfaces from telos gets registered in the Windows registry. All tools based on the URT API should find an URT driver with the name "telos I2C".

At the moment the driver supports the following I2C interfaces: Connii, Connii MM, Connii MM 2.0, Tracii XL, Tracii XL 2.0, and Tracii 400. If more than one of telos' I2C interfaces is connected to the PC, the user can use the configuration dialog to choose the I2C interface.

Tracii 400 has to be connected to the first parallel port (LPT) of the PC.

It is possible to use the URT driver and other I2C tools like I2C Studio simultaneously with the same I2C interface.

telos Systementwicklung GmbH (http://www.telos.info) Tue Sep 18 2018


I2C.URT & I2C.URD API: I2C.URD API

  • Main Page
  • Related Pages
I2C.URD API

To use the URD support for all I2C interfaces from telos, it is necessary to specify the URD DLL in the *.urd files. The following lines have to be changed appropriately:

 #BeginRegisterList "c:\Program Files\telos Systementwicklung GmbH\I2C Studio\bin\i2ctelos.dll"

At the moment the following I2C interfaces are supported: Connii, Connii MM, Connii MM 2.0, Tracii XL, Tracii XL 2.0, and Tracii 400. If more than one of telos' I2C interfaces is connected to the PC, the URT driver will use the first interface found.

Tracii 400 has to be connected to the first parallel port (LPT) of the PC.

It is possible to use URD and other I2C tools like I2C Studio simultaneously with the same I2C interface.

telos Systementwicklung GmbH (http://www.telos.info) Tue Sep 18 2018


I2C.URT & I2C.URD API: Main Page

  • Main Page
  • Related Pages
I2C.URT & I2C.URD API Documentation
Introduction to the I2C.URT & I2C.URD APIs
telos Systementwicklung GmbH (http://www.telos.info) Tue Sep 18 2018


I2C.URT & I2C.URD API: Related Pages

  • Main Page
  • Related Pages
Related Pages
Here is a list of all related documentation pages:
Introduction to the I2C.URT & I2C.URD APIs
I2C.URT API
I2C.URD API
telos Systementwicklung GmbH (http://www.telos.info) Tue Sep 18 2018