I2C.C++ API: Introduction to the I2C.C++ API

  • Main Page
  • Related Pages
  • Namespaces
  • Classes
  • Examples
Introduction to the I2C.C++ API

1 Introduction

The I2C.C++ API can be used to write programs which communicate with devices connected to the I2C bus or which trace the traffic on an I2C bus. The I2C bus has been developed by Philips. Today it is widely used in consumer and industrial electronic devices like e.g. TV sets.

This API, which has been written using C++, communicates via the I2C scheduler and the driver with the I2C interfaces. Currently the following I2C interfaces are supported:

I2C Interface | Functionality
Tracii XL 2.0 | master, tracer, A/D converter
Tracii XL | master, tracer, A/D converter
Connii MM 2.0 | master, tracer
Connii MM | master, tracer
Connii | master
Negative Tester | negative tester
Dummy | master, tracer, A/D converter

The I2C scheduler is a program which gets started as service. The I2C scheduler acts as a multiplexer/demultiplexer. On one side it communicates with the I2C interfaces via the drivers and on the other side it communicates with the programs using the I2C API.

The most important class of the I2C API is telos::I2cApi::Cpp::CBoard. This class establishes a connection to the I2C scheduler and creates several subclasses, which are used to communicate with e.g. the master or the trace modules of the I2C interfaces. For beginners it is a good idea to have a look at the examples of the I2C.C++ API, which can be used as template for new programs.

2 Visual Studio settings

The I2C.C++ API consists of two main parts: the header files and the library. Both parts can be found in the installation directory.

The current implementation of the I2C.C++ API supports three compilers:

  • MS Visual C++ 11.0 (Visual Studio 2012)
  • MS Visual C++ 12.0 (Visual Studio 2013)
  • MS Visual C++ 14.0 (Visual Studio 2015)

2.1 Header files

If somebody starts writing his own program using the I2C.C++ API, it is necessary to add the directory containing the header files of the API to the header file search path of the used compiler. There are two ways to change the header file search path: add it to the global configuration of the compiler or add it to the settings of a project.

  • MS Visual C++ 11.0/12.0/14.0
    • Project settings: open the "Project/Properties" menu, choose "C/C++/General" of the dialog box, and add the search path to the "Additional Include Directories" text box.
    • Global settings: open the "Tools/Options" menu, choose "Projects and Solutions/VC++ Directories", select "Include files", and add the search path to the list.

2.2 Library

Due to several limitations of the linker it is not possible to distribute the library containing the implementation of the I2C.C++ API as DLL.

Instead the I2C.C++ library is distributed as static library (.lib). Such libraries can be used on the MS Windows platform only with the same compiler which has been used to generate the library. Additionally it is very important that the library and the program using this library are using the same "run-time library". Otherwise the behaviour of the API is undefined.

Due to these problems, the I2C.C++ library is distributed in twenty versions:

Compiler | Run-time Library | Library
Visual C++ 11.0 | Multi-threaded DLL (x86) | vc11.0\x86\i2capi_cpp_static_mt_dll_r.lib
Visual C++ 11.0 | Multi-threaded Debug DLL (x86) | vc11.0\x86\i2capi_cpp_static_mt_dll_d.lib
Visual C++ 11.0 | Multi-threaded DLL (x64) | vc11.0\x64\i2capi_cpp_static_mt_dll_r.lib
Visual C++ 11.0 | Multi-threaded Debug DLL (x64) | vc11.0\x64\i2capi_cpp_static_mt_dll_d.lib
Visual C++ 12.0 | Multi-threaded DLL (x86) | vc12.0\x86\i2capi_cpp_static_mt_dll_r.lib
Visual C++ 12.0 | Multi-threaded Debug DLL (x86) | vc12.0\x86\i2capi_cpp_static_mt_dll_d.lib
Visual C++ 12.0 | Multi-threaded DLL (x64) | vc12.0\x64\i2capi_cpp_static_mt_dll_r.lib
Visual C++ 12.0 | Multi-threaded Debug DLL (x64) | vc12.0\x64\i2capi_cpp_static_mt_dll_d.lib
Visual C++ 14.0 | Multi-threaded DLL (x86) | vc14.0\x86\i2capi_cpp_static_mt_dll_r.lib
Visual C++ 14.0 | Multi-threaded Debug DLL (x86) | vc14.0\x86\i2capi_cpp_static_mt_dll_d.lib
Visual C++ 14.0 | Multi-threaded DLL (x64) | vc14.0\x64\i2capi_cpp_static_mt_dll_r.lib
Visual C++ 14.0 | Multi-threaded Debug DLL (x64) | vc14.0\x64\i2capi_cpp_static_mt_dll_d.lib

One of these libraries has to be linked to programs using the I2C.C++ API. At first it is necessary to add the path of I2C.C++ library to the search path of the compiler. There are two ways to specify the path:

  • Visual C++ 11.0/12.0/14.0
    • Project settings: open the "Project/Properties" menu, choose "Linker/General" in the dialog box, and add the search path to the "Additional Library Directories" text box.
    • Global settings: open the "Tools/Options" menu, choose "Projects and Solutions/VC++ Directories", select "Library files", and add the search path to the list.

As next step it is necessary to specify the library to be used:

  • Visual C++ 11.0/12.0/14.0

    Open the "Project/Properties" menu, choose "Linker/Input" in the dialog box, and add the I2C.C++ and the Winsock (ws2_32.lib) libraries to the "Additional Dependencies" text box.

2.3 Miscellaneous

The I2C.C++ API uses two C++ features, which have to be enabled in the project settings: exceptions and run-time type informations (RTTI).

  • Visual C++ 11.0/12.0/14.0

    Open the "Project/Properties" menu, choose "C/C++/Code Generation" in the dialog box, and enable the "Enable C++ Exceptions" option. Choose "C/C++/Language" and enable the "Enabled Run-Time Type Info" option.

telos Systementwicklung GmbH (http://www.telos.info) Tue Sep 18 2018


I2C.C++ API: FAQ

  • Classes
  • Examples
FAQ

When I compile an application using the I2C.C++ API I get error messages like "error LNK2005: "public: __thiscall std::_Lockit::~_Lockit(void)" (??1_Lockit\@std\@\@QAE\@XZ) already defined".

You are trying to link your application with a library which has been compiled using a different "Run-time library". Your application has to use the same "Run-time library" as the I2C.C++ API does. If you use the MFC, select "Use MFC in a Static Library".

When I compile an application using the I2C.C++ API I get error messages like "error LNK2001: unresolved external symbol _WSAStartup\@8".

The I2C.C++ API uses the Winsock library of MS Windows. Since it is not possible to include library dependencies into static libraries, you have to link your application manually with the Winsock library. Please add "ws2_32.lib" to your project settings.

When I compile an MFC application using the I2C.C++ API I get error messages like "error C2872: 'CException' : ambiguous symbol".

Both the MFC and the I2C.C++ API are using a base class for exceptions with the same name. To solve this problem it is necessary to specify in the code which one should be used. This can be done using the namespaces: e.g. use telos::I2cApi::Cpp::CException instead of CException in your code.

The compiler reports missings types in "ws2tcpip.h".

The Winsock include files and libraries of your Visual Studio installation are too old. Please install a newer Windows SDK (>= 7.1). If you still get such error messages after the installation of the Windows SDK, you have to register the SDK in your Visual Studio manually. This can be done by opening the menu "Tools/Options" and choosing "Projects and Solutions/VC++ Directories".


I2C.C++ API: Credits

Credits

This online help has been written using the tool Doxygen, which is distributed under the GNU General Public License. The homepage of Doxygen can be found at:

http://www.doxygen.org


I2C.C++ API: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all documented namespaces with brief descriptions:
[detail level 123]
▼N telos | API's of telos Systementwicklung GmbH
▼N I2cApi | API's for the I2C bus
N Cpp | API's for the I2C bus written in C++


I2C.C++ API: telos Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces
telos Namespace Reference

API's of telos Systementwicklung GmbH.

Namespaces

I2cApi
API's for the I2C bus.


I2C.C++ API: telos::I2cApi Namespace Reference

  • Namespace List
  • Namespace Members
  • telos
  • I2cApi
Namespaces
telos::I2cApi Namespace Reference

API's for the I2C bus.

Namespaces

Cpp
API's for the I2C bus written in C++.


I2C.C++ API: telos::I2cApi::Cpp Namespace Reference

  • Namespace List
  • Namespace Members
  • telos
  • I2cApi
  • Cpp
Classes | Enumerations
telos::I2cApi::Cpp Namespace Reference

API's for the I2C bus written in C++.

Classes

class | CAdc
class | CBoard
class | CException
class | CExceptionAdc
class | CExceptionAdcBusy
class | CExceptionAdcNotFinished
class | CExceptionAdcNotSupported
class | CExceptionAdcPreTrigger
class | CExceptionAdcSamplingRate
class | CExceptionAdcTrigger
class | CExceptionArpI2cAddressesExhausted
class | CExceptionArpInvalidResponse
class | CExceptionAuthentication
class | CExceptionBusType
class | CExceptionDeviceOpen
class | CExceptionDriverVersion
class | CExceptionHardwareIo
class | CExceptionI2cAddress
class | CExceptionI2cVcc
class | CExceptionI2cVccSupply
class | CExceptionInputTestpin
class | CExceptionIo
class | CExceptionLevelThreshold
class | CExceptionMaster
class | CExceptionMasterAddress
class | CExceptionMasterArbitration
class | CExceptionMasterBusy
class | CExceptionMasterI2cProtocol
class | CExceptionMasterIncompleteRx
class | CExceptionMasterIncompleteTx
class | CExceptionMasterInvalidBitrate
class | CExceptionMasterInvalidMasterCode
class | CExceptionMasterInvalidTransfer
class | CExceptionMasterNotSupported
class | CExceptionMasterRunning
class | CExceptionMasterSmbInvalidSize
class | CExceptionMasterSmbPecFailed
class | CExceptionMasterTimeout
class | CExceptionMasterWatchdogTimeout
class | CExceptionNegativeTester
class | CExceptionNegativeTesterBusy
class | CExceptionNegativeTesterInvalidArgument
class | CExceptionNegativeTesterNotSupported
class | CExceptionNegativeTesterProgramSize
class | CExceptionNullPointer
class | CExceptionOpen
class | CExceptionOutputTestpin
class | CExceptionPullUpCurrent
class | CExceptionSchedulerBusy
class | CExceptionSchedulerVersion
class | CExceptionServiceContractExpired
class | CExceptionSlaveRamEnhanced
class | CExceptionSlaveRamEnhancedAddress
class | CExceptionSlaveRamEnhancedBusy
class | CExceptionSlaveRamEnhancedMemorySize
class | CExceptionSlaveRamEnhancedNotSupported
class | CExceptionSlaveRamEnhancedSetData
class | CExceptionSlaveRamEnhancedTimeout
class | CExceptionSmbI2cAddress
class | CExceptionTermination
class | CExceptionTracer
class | CExceptionTracerBusy
class | CExceptionTracerFilter
class | CExceptionTracerNotSupported
class | CExceptionTraciiCpu
class | CExceptionTraciiCpuBusy
class | CExceptionTraciiCpuNotSupported
class | CExceptionTraciiCpuProgramSize
class | CI2cAddress
class | CInputTestpins
class | CLanguage
class | CMaster
class | CMasterMessage
class | CMasterMessageRx
class | CMasterMessageTx
class | CNegativeTester
class | CNegativeTesterMaster
class | CNegativeTesterSlave
class | CPmbusMasterMessage
class | CPmbusMasterMessageCmd
class | CPmbusMasterMessageExtCmdByte
class | CPmbusMasterMessageExtCmdWord
class | CPmbusMasterMessageGroupCmd
class | CPmbusMasterMessageReadByte
class | CPmbusMasterMessageReadWord
class | CPmbusMasterMessageWriteByte
class | CPmbusMasterMessageWriteWord
class | CSlaveRam
class | CSlaveRamEnhanced
class | CSmbArpMaster
class | CSmbMaster
class | CSmbMasterMessage
class | CSmbMasterMessageBlockRead
class | CSmbMasterMessageBlockWrite
class | CSmbMasterMessageBlockWriteRead
class | CSmbMasterMessageCmd
class | CSmbMasterMessageCmd32
class | CSmbMasterMessageCmd64
class | CSmbMasterMessageCmdBlock
class | CSmbMasterMessageCmdByte
class | CSmbMasterMessageCmdProcessCall
class | CSmbMasterMessageCmdWord
class | CSmbMasterMessageHostNotify
class | CSmbMasterMessageQuickCommand
class | CSmbMasterMessageRead32
class | CSmbMasterMessageRead64
class | CSmbMasterMessageReadByte
class | CSmbMasterMessageReadWord
class | CSmbMasterMessageReceiveByte
class | CSmbMasterMessageSendByte
class | CSmbMasterMessageWrite32
class | CSmbMasterMessageWrite64
class | CSmbMasterMessageWriteByte
class | CSmbMasterMessageWriteWord
class | CTimestamp
class | CTracer
class | CTraciiCpu
struct | SAdcData
struct | SHardwareInfo
struct | SInputTestpinsMessage
struct | STracerMessage
struct | SVersionNumber

Enumerations

enum ETraciiType {
TRACII_XL = 2, TRACII_XL2 = 6, CONNII = 3, CONNII_MM = 5,
CONNII_MM2 = 7, DUMMY = 4
}
enum | ELanguageId { ENGLISH = 0, GERMAN = 1 }
enum ETracerMessageType {
MSG_FRAME_START, MSG_FRAME_STOP, MSG_FRAME_DATA, MSG_I2C_PROTOCOL_ERROR,
MSG_SMB_POWER_ON, MSG_SMB_POWER_OFF, MSG_TRACER_RESTARTED
}
enum | ETracerMessageDataConfirmation { DATA_CONFIRMATION_NONE, DATA_CONFIRMATION_ACK, DATA_CONFIRMATION_NACK }

Enumeration Type Documentation

enum telos::I2cApi::Cpp::ELanguageId

Enumeration that specifies the ID of the language.

Enumerator
ENGLISH | Global language is 'English'.
GERMAN | Global language is 'German'.
enum telos::I2cApi::Cpp::ETracerMessageDataConfirmation

This enumeration is used for MSG_FRAME_DATA messages. It indicates whether an ACK or NACK has been received after the data message.

Enumerator
DATA_CONFIRMATION_NONE | none
DATA_CONFIRMATION_ACK | ACK.
DATA_CONFIRMATION_NACK | NACK.
enum telos::I2cApi::Cpp::ETracerMessageType

Enumeration to specify the type of an I2C messages. The types can be categorized into two groups: frame-based messages, and miscellaneous messages.

Enumerator
MSG_FRAME_START | frame mode: START
MSG_FRAME_STOP | frame mode: STOP
MSG_FRAME_DATA | frame mode: DATA
MSG_I2C_PROTOCOL_ERROR | I2C protocol error.
MSG_SMB_POWER_ON | SMBus power on.
MSG_SMB_POWER_OFF | SMBus power off.
MSG_TRACER_RESTARTED | tracer has been restarted
enum telos::I2cApi::Cpp::ETraciiType

Enumeration to specify the type of the I2C interface.

Enumerator
TRACII_XL | TraciiXL.
TRACII_XL2 | TraciiXL2.
CONNII | Connii.
CONNII_MM | ConniiMM.
CONNII_MM2 | ConniiMM2.
DUMMY | dummy device


I2C.C++ API: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Enumerations
  • Enumerator
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • CONNII : telos::I2cApi::Cpp
  • CONNII_MM : telos::I2cApi::Cpp
  • CONNII_MM2 : telos::I2cApi::Cpp
  • DATA_CONFIRMATION_ACK : telos::I2cApi::Cpp
  • DATA_CONFIRMATION_NACK : telos::I2cApi::Cpp
  • DATA_CONFIRMATION_NONE : telos::I2cApi::Cpp
  • DUMMY : telos::I2cApi::Cpp
  • ELanguageId : telos::I2cApi::Cpp
  • ENGLISH : telos::I2cApi::Cpp
  • ETracerMessageDataConfirmation : telos::I2cApi::Cpp
  • ETracerMessageType : telos::I2cApi::Cpp
  • ETraciiType : telos::I2cApi::Cpp
  • GERMAN : telos::I2cApi::Cpp
  • MSG_FRAME_DATA : telos::I2cApi::Cpp
  • MSG_FRAME_START : telos::I2cApi::Cpp
  • MSG_FRAME_STOP : telos::I2cApi::Cpp
  • MSG_I2C_PROTOCOL_ERROR : telos::I2cApi::Cpp
  • MSG_SMB_POWER_OFF : telos::I2cApi::Cpp
  • MSG_SMB_POWER_ON : telos::I2cApi::Cpp
  • MSG_TRACER_RESTARTED : telos::I2cApi::Cpp
  • TRACII_XL : telos::I2cApi::Cpp
  • TRACII_XL2 : telos::I2cApi::Cpp


I2C.C++ API: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Enumerations
  • Enumerator
  • ELanguageId : telos::I2cApi::Cpp
  • ETracerMessageDataConfirmation : telos::I2cApi::Cpp
  • ETracerMessageType : telos::I2cApi::Cpp
  • ETraciiType : telos::I2cApi::Cpp


I2C.C++ API: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Enumerations
  • Enumerator
  • CONNII : telos::I2cApi::Cpp
  • CONNII_MM : telos::I2cApi::Cpp
  • CONNII_MM2 : telos::I2cApi::Cpp
  • DATA_CONFIRMATION_ACK : telos::I2cApi::Cpp
  • DATA_CONFIRMATION_NACK : telos::I2cApi::Cpp
  • DATA_CONFIRMATION_NONE : telos::I2cApi::Cpp
  • DUMMY : telos::I2cApi::Cpp
  • ENGLISH : telos::I2cApi::Cpp
  • GERMAN : telos::I2cApi::Cpp
  • MSG_FRAME_DATA : telos::I2cApi::Cpp
  • MSG_FRAME_START : telos::I2cApi::Cpp
  • MSG_FRAME_STOP : telos::I2cApi::Cpp
  • MSG_I2C_PROTOCOL_ERROR : telos::I2cApi::Cpp
  • MSG_SMB_POWER_OFF : telos::I2cApi::Cpp
  • MSG_SMB_POWER_ON : telos::I2cApi::Cpp
  • MSG_TRACER_RESTARTED : telos::I2cApi::Cpp
  • TRACII_XL : telos::I2cApi::Cpp
  • TRACII_XL2 : telos::I2cApi::Cpp


I2C.C++ API: Class List

  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345]
▼N telos | API's of telos Systementwicklung GmbH
▼N I2cApi | API's for the I2C bus
►N Cpp | API's for the I2C bus written in C++
C CAdc |
C CBoard |
C CException |
C CExceptionAdc |
C CExceptionAdcBusy |
C CExceptionAdcNotFinished |
C CExceptionAdcNotSupported |
C CExceptionAdcPreTrigger |
C CExceptionAdcSamplingRate |
C CExceptionAdcTrigger |
C CExceptionArpI2cAddressesExhausted |
C CExceptionArpInvalidResponse |
C CExceptionAuthentication |
C CExceptionBusType |
C CExceptionDeviceOpen |
C CExceptionDriverVersion |
C CExceptionHardwareIo |
C CExceptionI2cAddress |
C CExceptionI2cVcc |
C CExceptionI2cVccSupply |
C CExceptionInputTestpin |
C CExceptionIo |
C CExceptionLevelThreshold |
C CExceptionMaster |
C CExceptionMasterAddress |
C CExceptionMasterArbitration |
C CExceptionMasterBusy |
C CExceptionMasterI2cProtocol |
C CExceptionMasterIncompleteRx |
C CExceptionMasterIncompleteTx |
C CExceptionMasterInvalidBitrate |
C CExceptionMasterInvalidMasterCode |
C CExceptionMasterInvalidTransfer |
C CExceptionMasterNotSupported |
C CExceptionMasterRunning |
C CExceptionMasterSmbInvalidSize |
C CExceptionMasterSmbPecFailed |
C CExceptionMasterTimeout |
C CExceptionMasterWatchdogTimeout |
C CExceptionNegativeTester |
C CExceptionNegativeTesterBusy |
C CExceptionNegativeTesterInvalidArgument |
C CExceptionNegativeTesterNotSupported |
C CExceptionNegativeTesterProgramSize |
C CExceptionNullPointer |
C CExceptionOpen |
C CExceptionOutputTestpin |
C CExceptionPullUpCurrent |
C CExceptionSchedulerBusy |
C CExceptionSchedulerVersion |
C CExceptionServiceContractExpired |
C CExceptionSlaveRamEnhanced |
C CExceptionSlaveRamEnhancedAddress |
C CExceptionSlaveRamEnhancedBusy |
C CExceptionSlaveRamEnhancedMemorySize |
C CExceptionSlaveRamEnhancedNotSupported |
C CExceptionSlaveRamEnhancedSetData |
C CExceptionSlaveRamEnhancedTimeout |
C CExceptionSmbI2cAddress |
C CExceptionTermination |
C CExceptionTracer |
C CExceptionTracerBusy |
C CExceptionTracerFilter |
C CExceptionTracerNotSupported |
C CExceptionTraciiCpu |
C CExceptionTraciiCpuBusy |
C CExceptionTraciiCpuNotSupported |
C CExceptionTraciiCpuProgramSize |
C CI2cAddress |
C CInputTestpins |
C CLanguage |
C CMaster |
C CMasterMessage |
C CMasterMessageRx |
C CMasterMessageTx |
►C CNegativeTester |
C SLevelsMaster |
C SLevelsSlave |
C SMessagesMaster |
C SMessagesSlave |
C CNegativeTesterMaster |
C CNegativeTesterSlave |
C CPmbusMasterMessage |
C CPmbusMasterMessageCmd |
C CPmbusMasterMessageExtCmdByte |
C CPmbusMasterMessageExtCmdWord |
C CPmbusMasterMessageGroupCmd |
C CPmbusMasterMessageReadByte |
C CPmbusMasterMessageReadWord |
C CPmbusMasterMessageWriteByte |
C CPmbusMasterMessageWriteWord |
C CSlaveRam |
C CSlaveRamEnhanced |
►C CSmbArpMaster |
C CUdid |
C CSmbMaster |
C CSmbMasterMessage |
C CSmbMasterMessageBlockRead |
C CSmbMasterMessageBlockWrite |
C CSmbMasterMessageBlockWriteRead |
C CSmbMasterMessageCmd |
C CSmbMasterMessageCmd32 |
C CSmbMasterMessageCmd64 |
C CSmbMasterMessageCmdBlock |
C CSmbMasterMessageCmdByte |
C CSmbMasterMessageCmdProcessCall |
C CSmbMasterMessageCmdWord |
C CSmbMasterMessageHostNotify |
C CSmbMasterMessageQuickCommand |
C CSmbMasterMessageRead32 |
C CSmbMasterMessageRead64 |
C CSmbMasterMessageReadByte |
C CSmbMasterMessageReadWord |
C CSmbMasterMessageReceiveByte |
C CSmbMasterMessageSendByte |
C CSmbMasterMessageWrite32 |
C CSmbMasterMessageWrite64 |
C CSmbMasterMessageWriteByte |
C CSmbMasterMessageWriteWord |
C CTimestamp |
C CTracer |
C CTraciiCpu |
C SAdcData |
C SHardwareInfo |
C SInputTestpinsMessage |
C STracerMessage |
C SVersionNumber |


I2C.C++ API: telos::I2cApi::Cpp::CAdc Class Reference

  • Class Hierarchy
  • Class Members
  • telos
  • I2cApi
  • Cpp
  • CAdc
Public Types | Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CAdc Class Reference

#include <CAdc.h>

Public Types

typedef void(* CallBackFunction) (CAdc *adc, void *private_data)

Public Member Functions

void | SetSamplingRate (uint32_t sampling_rate)
Specifies the sampling rate of the A/D converter. More...
uint32_t | GetSamplingRate () const
Returns the sampling rate of the A/D converter. More...
void | SetPreTrigger (uint16_t pretrigger)
Specifies the pretrigger. More...
uint16_t | GetPreTrigger () const
Returns the pretrigger. More...
void | SetUseStartAsTrigger (bool trigger)
Use START condition as trigger. More...
bool | GetUseStartAsTrigger () const
Is START used as trigger? More...
void | SetUseStopAsTrigger (bool trigger)
Use STOP condition as trigger. More...
bool | GetUseStopAsTrigger () const
Is STOP used as trigger? More...
void | SetUseAckAsTrigger (bool trigger)
Use ACK condition as trigger. More...
bool | GetUseAckAsTrigger () const
Is ACK used as trigger? More...
void | SetUseNackAsTrigger (bool trigger)
Use NACK condition as trigger. More...
bool | GetUseNackAsTrigger () const
Is NACK used as trigger? More...
void | SetUseErrorAsTrigger (bool trigger)
Use ERROR condition as trigger. More...
bool | GetUseErrorAsTrigger () const
Is ERROR used as trigger? More...
void | SetUseTestpin1AsTrigger (bool trigger)
Use testpin 1 as trigger. More...
bool | GetUseTestpin1AsTrigger () const
Is testpin 1 used as trigger? More...
void | SetUseTestpin2AsTrigger (bool trigger)
Use testpin 2 as trigger. More...
bool | GetUseTestpin2AsTrigger () const
Is testpin 2 used as trigger? More...
void | SetMessageCountTrigger (uint8_t cnt)
Set "message count" trigger. More...
uint8_t | GetMessageCountTrigger () const
Get configuration of "message count" trigger. More...
void | SetMessageDataTrigger (const std::vector< uint8_t > &data, const std::vector< uint8_t > &dont_care)
Set data trigger. More...
void | GetMessageDataTrigger (std::vector< uint8_t > &data, std::vector< uint8_t > &dont_care) const
Get configuration of data trigger. More...
void | SetSamplingCompletionCallback (CallBackFunction fct, void *private_data)
Registers a sampling completion callback function. More...
bool | IsSamplingCompleted () const
Is sampling completed? More...
void | SetTransmissionCompletionCallback (CallBackFunction fct, void *private_data)
Registers a transmission completion callback function. More...
bool | IsTransmissionCompleted () const
Is transmission completed? More...
void | StartAdc ()
Starts A/D converter. More...
void | StartAdcImmediately ()
Starts A/D converter immediately. More...
void | RequestDataTransmission (SAdcData &data)
Requests the transmission of the A/D data. More...
void | CancelAdc ()
Cancels A/D converter. More...

Protected Member Functions

CAdc (CBoard *board)
Constructor. More...

Detailed Description

There is an A/D converter on the Tracii XL and Tracii XL 2.0 interfaces. This class can be used to control the A/D converter.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the CBoard::GetAdc() method.

Normally the following steps are necessary:

  1. Configure the A/D converter (sampling rate, pretrigger, trigger events).
  2. Register sampling and transmission completion callback functions.
  3. Use StartAdc() to start the converter.
  4. Call CBoard::WaitForData() in a loop till all data has been transferred to the host.
  5. When the hardware has finished the sampling process, the sampling completion callback gets called. Normally this callback function should request the transmission of the sampled data using RequestDataTransmission().
  6. Wait till the transmission completion callback gets called.
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
AdcExample.cpp.

Member Typedef Documentation

typedef void(* telos::I2cApi::Cpp::CAdc::CallBackFunction) (CAdc *adc, void *private_data)

Interface of callback functions, which can be registered using SetSamplingCompletionCallback() and SetTransmissionCompletionCallback().

Constructor & Destructor Documentation

CAdc::CAdc ( CBoard * board )
protected

Constructor.

Parameters
board pointer to CBoard object managing this object

Member Function Documentation

void CAdc::CancelAdc ( )

This function cancels the running A/D converter.

uint8_t CAdc::GetMessageCountTrigger ( ) const

Returns the current configuration of the "message count" trigger. When this trigger has been disabled, "0" gets returned.

Returns
number of I2C messages
void CAdc::GetMessageDataTrigger | ( | std::vector< uint8_t > & | data,
 |  | std::vector< uint8_t > & | dont_care
 | ) |  | const

Returns the current configuration of the data trigger. If both values are empty, this trigger has been diabled.

Parameters
data | data bytes to be searched
dont_care | "don't care" mask
uint16_t CAdc::GetPreTrigger ( ) const

Returns the used pretrigger of the A/D converter.

Returns
pretrigger [samples/channel]
uint32_t CAdc::GetSamplingRate ( ) const

Returns the used sampling rate of the A/D converter.

Returns
sampling rate [Hz]
bool CAdc::GetUseAckAsTrigger ( ) const

Returns whether an ACK condition is used as trigger.

Returns
ok (true), error (false)
bool CAdc::GetUseErrorAsTrigger ( ) const

Returns whether an error condition is used as trigger.

Returns
ok (true), error (false)
bool CAdc::GetUseNackAsTrigger ( ) const

Returns whether an NACK condition is used as trigger.

Returns
ok (true), error (false)
bool CAdc::GetUseStartAsTrigger ( ) const

Returns whether a START condition is used as trigger.

Returns
ok (true), error (false)
bool CAdc::GetUseStopAsTrigger ( ) const

Returns whether a STOP condition is used as trigger.

Returns
ok (true), error (false)
bool CAdc::GetUseTestpin1AsTrigger ( ) const

Returns whether testpin 1 is used as trigger.

Returns
ok (true), error (false)
bool CAdc::GetUseTestpin2AsTrigger ( ) const

Returns whether testpin 2 is used as trigger.

Returns
ok (true), error (false)
bool CAdc::IsSamplingCompleted ( ) const

Tests whether the hardware has finished the sampling process. At this time the samples are stored in the internal memory of Tracii XL. To transfer the samples to the program, it is necessary to call RequestDataTransmission().

Returns
sampling finished?
bool CAdc::IsTransmissionCompleted ( ) const

When the complete A/D data has been transferred from the hardware to the host, this function returns "true". At this time the SAdcData array passed to RequestDataTransmission() contains valid data.

Returns
transmission finished?
void CAdc::RequestDataTransmission ( SAdcData & data )

This function tells the hardware to transmit the sampled A/D values from the hardware to the application. The samples get stored in the SAdcData object passed to this function. Most programs will call this function in the SamplingCompletionCallback callback function.

This function works asynchronously and returns immediately to the caller.

After calling this method the program has to call CBoard::WaitForData() until the TransmissionCompletionCallback callback function gets called. This callback function signals that the SAdcData object contains valid data.

Parameters
data data of the A/D converter
Examples:
AdcExample.cpp.
void CAdc::SetMessageCountTrigger ( uint8_t cnt )

This method sets the "message count" trigger. It triggers the A/D converter after receiving the specified number of I2C messages. A value of "0" disables this trigger.

Example: the following messages are sent to the I2C bus: SP, SSP, SSP. A value of "1" will trigger on the first start condition. A value of "3" will trigger on the fourth start condition.

The SHardwareInfo::adc_trigger_msg_cnt variable can be used to find out whether the used I2C interface supports this trigger.

Parameters
cnt number of I2C messages
void CAdc::SetMessageDataTrigger | ( | const std::vector< uint8_t > & | data,
 |  | const std::vector< uint8_t > & | dont_care
 | ) |  |

This method sets the data trigger. It triggers the A/D converter when an I2C message is sent to the bus, whose data bytes after the START condition equal the data bytes specified to this trigger.

A "don't care" mask is offered so that individual bits can be excluded from the comparison ("0xff" means all bits of Data are compared).

Both parameters passed to this method have to contain the same number of bytes. If both parameters are empty, this trigger gets disabled.

The SHardwareInfo::adc_trigger_data variable can be used to find out whether the used I2C interface supports this trigger and how many data bytes can be specified.

Parameters
data | data bytes to be searched
dont_care | "don't care" mask
void CAdc::SetPreTrigger ( uint16_t pretrigger )

Specifies how many samples should be stored before the trigger event.

The maximum value for the pretrigger can be found in the SHardwareInfo::adc_max_pretrigger variable.

Parameters
pretrigger pretrigger [samples/channel]
Examples:
AdcExample.cpp.
void CAdc::SetSamplingCompletionCallback | ( | CallBackFunction | fct,
 |  | void * | private_data
 | ) |  |

Specifies a callback function, which gets called when the hardware finishes the sampling process. At this time the samples are stored in the internal memory of Tracii XL / Tracii XL 2.0. To transfer the samples to the program, it is necessary to call RequestDataTransmission().

To disable the callback function, set the pointer of the callback function to "0".

The caller can specify a private data pointer, which is passed to the callback function.

Parameters
fct | callback function or "0"
private_data | private data to be passed to callback function
Examples:
AdcExample.cpp.
void CAdc::SetSamplingRate ( uint32_t sampling_rate )

Sets the sampling rate of the A/D converter.

Valid values for the sampling rate can be found in the SHardwareInfo::adc_samplingrate variable.

Parameters
sampling_rate sampling rate [Hz]
Examples:
AdcExample.cpp.
void CAdc::SetTransmissionCompletionCallback | ( | CallBackFunction | fct,
 |  | void * | private_data
 | ) |  |

When the complete A/D data has been transferred from the hardware to the host, the callback function, which can be specified using this method, gets called. The callback function signals that the SAdcData array passed to RequestDataTransmission() contains valid data.

To disable the callback function, set the pointer of the callback function to "0".

The caller can specify a private data pointer, which is passed to the callback function.

Parameters
fct | callback function or "0"
private_data | private data to be passed to callback function
Examples:
AdcExample.cpp.
void CAdc::SetUseAckAsTrigger ( bool trigger )

Sets whether an I2C ACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The SHardwareInfo::adc_trigger_ack variable can be used to find out whether the used I2C interface supports the use of the I2C ACK as trigger event.

Parameters
trigger use as trigger: yes (true), no (false)
void CAdc::SetUseErrorAsTrigger ( bool trigger )

Sets whether an I2C error should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The SHardwareInfo::adc_trigger_error variable can be used to find out whether the used I2C interface supports the use of the I2C error as trigger event.

Parameters
trigger use as trigger: yes (true), no (false)
void CAdc::SetUseNackAsTrigger ( bool trigger )

Sets whether an I2C NACK should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The SHardwareInfo::adc_trigger_nack variable can be used to find out whether the used I2C interface supports the use of the I2C NACK as trigger event.

Parameters
trigger use as trigger: yes (true), no (false)
void CAdc::SetUseStartAsTrigger ( bool trigger )

Sets whether an I2C START condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The SHardwareInfo::adc_trigger_start variable can be used to find out whether the used I2C interface supports the use of the START condition as trigger event.

Parameters
trigger use as trigger: yes (true), no (false)
Examples:
AdcExample.cpp.
void CAdc::SetUseStopAsTrigger ( bool trigger )

Sets whether an I2C STOP condition should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The SHardwareInfo::adc_trigger_stop variable can be used to find out whether the used I2C interface supports the use of the STOP condition as trigger event.

Parameters
trigger use as trigger: yes (true), no (false)
Examples:
AdcExample.cpp.
void CAdc::SetUseTestpin1AsTrigger ( bool trigger )

Sets whether testpin 1 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The SHardwareInfo::adc_trigger_testpin1 variable can be used to find out whether the used I2C interface supports the use of testpin 1 as trigger event.

Parameters
trigger use as trigger: yes (true), no (false)
void CAdc::SetUseTestpin2AsTrigger ( bool trigger )

Sets whether testpin 2 should be used as a trigger for the A/D converter. It is possible to enable several trigger conditions simultaneously.

The SHardwareInfo::adc_trigger_testpin2 variable can be used to find out whether the used I2C interface supports the use of testpin 2 as trigger event.

Parameters
trigger use as trigger: yes (true), no (false)
void CAdc::StartAdc ( )

Enables the A/D converter. The hardware will wait for one of the specified trigger events. This function works asynchronously and returns immediately to the caller.

After calling this method the program has to call CBoard::WaitForData() until the SamplingCompletionCallback function gets called.

Examples:
AdcExample.cpp.
void CAdc::StartAdcImmediately ( )

Enables the A/D converter. The hardware will not wait for one of the specified trigger events. Instead it starts the sampling process immediately. This function works asynchronously and returns immediately to the caller.

After calling this method the program has to call CBoard::WaitForData() until the SamplingCompletionCallback function gets called.


I2C.C++ API: Member List

  • I2cApi
  • Cpp
  • CAdc
telos::I2cApi::Cpp::CAdc Member List

This is the complete list of members for telos::I2cApi::Cpp::CAdc, including all inherited members.

CAdc(CBoard *board) | telos::I2cApi::Cpp::CAdc | protected
CallBackFunction typedef | telos::I2cApi::Cpp::CAdc |
CancelAdc() | telos::I2cApi::Cpp::CAdc |
GetMessageCountTrigger() const | telos::I2cApi::Cpp::CAdc |
GetMessageDataTrigger(std::vector< uint8_t > &data, std::vector< uint8_t > &dont_care) const | telos::I2cApi::Cpp::CAdc |
GetPreTrigger() const | telos::I2cApi::Cpp::CAdc |
GetSamplingRate() const | telos::I2cApi::Cpp::CAdc |
GetUseAckAsTrigger() const | telos::I2cApi::Cpp::CAdc |
GetUseErrorAsTrigger() const | telos::I2cApi::Cpp::CAdc |
GetUseNackAsTrigger() const | telos::I2cApi::Cpp::CAdc |
GetUseStartAsTrigger() const | telos::I2cApi::Cpp::CAdc |
GetUseStopAsTrigger() const | telos::I2cApi::Cpp::CAdc |
GetUseTestpin1AsTrigger() const | telos::I2cApi::Cpp::CAdc |
GetUseTestpin2AsTrigger() const | telos::I2cApi::Cpp::CAdc |
IsSamplingCompleted() const | telos::I2cApi::Cpp::CAdc |
IsTransmissionCompleted() const | telos::I2cApi::Cpp::CAdc |
RequestDataTransmission(SAdcData &data) | telos::I2cApi::Cpp::CAdc |
SetMessageCountTrigger(uint8_t cnt) | telos::I2cApi::Cpp::CAdc |
SetMessageDataTrigger(const std::vector< uint8_t > &data, const std::vector< uint8_t > &dont_care) | telos::I2cApi::Cpp::CAdc |
SetPreTrigger(uint16_t pretrigger) | telos::I2cApi::Cpp::CAdc |
SetSamplingCompletionCallback(CallBackFunction fct, void *private_data) | telos::I2cApi::Cpp::CAdc |
SetSamplingRate(uint32_t sampling_rate) | telos::I2cApi::Cpp::CAdc |
SetTransmissionCompletionCallback(CallBackFunction fct, void *private_data) | telos::I2cApi::Cpp::CAdc |
SetUseAckAsTrigger(bool trigger) | telos::I2cApi::Cpp::CAdc |
SetUseErrorAsTrigger(bool trigger) | telos::I2cApi::Cpp::CAdc |
SetUseNackAsTrigger(bool trigger) | telos::I2cApi::Cpp::CAdc |
SetUseStartAsTrigger(bool trigger) | telos::I2cApi::Cpp::CAdc |
SetUseStopAsTrigger(bool trigger) | telos::I2cApi::Cpp::CAdc |
SetUseTestpin1AsTrigger(bool trigger) | telos::I2cApi::Cpp::CAdc |
SetUseTestpin2AsTrigger(bool trigger) | telos::I2cApi::Cpp::CAdc |
StartAdc() | telos::I2cApi::Cpp::CAdc |
StartAdcImmediately() | telos::I2cApi::Cpp::CAdc |


I2C.C++ API: telos::I2cApi::Cpp::CBoard Class Reference

  • CBoard
Public Types | Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CBoard Class Reference

#include <CBoard.h>

Public Types

enum EI2cBusState {
I2C_BUS_STATE_UNKNOWN, I2C_BUS_STATE_NORMAL, I2C_BUS_STATE_SCL_LOW, I2C_BUS_STATE_SDA_LOW,
I2C_BUS_STATE_SCL_SDA_LOW
}
Enumeration to store the state of the I2C bus. More...
enum | EBusType { BUS_TYPE_I2C, BUS_TYPE_SMB }
Enumeration to specify the bus type. More...
typedef void(* | CallBackFunction) (CBoard *board, void *private_data)

Public Member Functions

CBoard ()
Constructor. More...
CBoard (const std::string &ip_address, uint16_t ip_port, const std::string &password)
Constructor.
~CBoard ()
Destructor. More...
void | GetHardwareInfo (std::vector< SHardwareInfo > &hwinfo)
Gets the list of available I2C interfaces. More...
bool | IsDeviceAvailable (uint16_t serial_number, ETraciiType board_type)
Tests whether an I2C interface is available. More...
void | SetDeviceAddedRemovedCallback (CallBackFunction fct, void *private_data)
Registers a "device added/removed" callback. More...
void | OpenDevice (const SHardwareInfo &board)
Connects an object of this class with the specified I2C interface. More...
void | OpenDevice (ETraciiType board_type, unsigned short serial_number)
Connects an object of this class with the specified I2C interface. More...
void | CloseDevice ()
Closes the connection to the I2C interface. More...
bool | IsDeviceOpen ()
Is an object of this class connetected with an I2C interface? More...
const SHardwareInfo & | GetHardwareInfoOfOpenDevice () const
Returns the hardware information of the connected interface. More...
void | SetTerminationScl (uint32_t term)
Configures the termination of the I2C bus (SCL). More...
uint32_t | GetTerminationScl ()
Returns the current termination of the I2C bus (SCL). More...
void | SetTerminationSda (uint32_t term)
Configures the termination of the I2C bus (SDA). More...
uint32_t | GetTerminationSda ()
Returns the current termination of the I2C bus (SDA). More...
void | SetPullUpCurrentScl (uint32_t current)
Configures the pull up current of the I2C bus (SCL) [.1mA]. More...
uint32_t | GetPullUpCurrentScl ()
Returns the the pull up current of the I2C bus (SCL) [.1mA]. More...
void | SetPullUpCurrentSda (uint32_t current)
Configures the pull up current of the I2C bus (SDA) [.1mA]. More...
uint32_t | GetPullUpCurrentSda ()
Returns the the pull up current of the I2C bus (SDA) [.1mA]. More...
void | SetLevelThresholds (uint8_t low, uint8_t high)
Sets the level thresholds. More...
uint8_t | GetLowLevelThreshold ()
Returns the low level threshold. More...
uint8_t | GetHighLevelThreshold ()
Returns the high level threshold. More...
void | SetI2cVccSupply (uint16_t i2c_vcc)
Sets the I2C Vcc supply voltage. More...
uint16_t | GetI2cVccSupply ()
Returns the I2C Vcc supply voltage. More...
void | SetTestpinConfiguration (bool start, bool stop, bool ack, bool nack, bool error)
Configures the output testpin. More...
void | GetTestpinConfiguration (bool &start, bool &stop, bool &ack, bool &nack, bool &error)
Returns the configuration of output testpin. More...
void | SetOutputTestpin (int testpin, bool level)
Sets one of the output testpins to the specified level. More...
void | SetOutputTestpin (const std::vector< bool > &levels)
Sets the output testpins to the specified levels. More...
bool | GetOutputTestpin (int testpin)
Gets the level of one of the output testpins. More...
void | GetOutputTestpin (std::vector< bool > &levels)
Gets the levels of the output testpins. More...
bool | GetInputTestpin (int testpin)
Returns the current status of the specified input testpin. More...
void | GetInputTestpin (std::vector< bool > &levels)
Returns the current status of the input testpins. More...
uint16_t | GetI2cVcc ()
Returns the Vcc voltage of the I2C bus. More...
EI2cBusState GetI2cState ()
Returns the state of the I2C bus. More...
uint8_t | GetI2cBusLoad ()
Returns the load of the I2C bus. More...
void | SetBusType (EBusType bus_type)
Sets the bus type. More...
EBusType GetBusType ()
Returns the configured bus type. More...
const SVersionNumber & | GetSchedulerVersion () const
Returns the version of the I2C scheduler. More...
const std::string & | GetSchedulerIpAddress () const
Returns the IP address of the I2C scheduler. More...
void | WaitForData (int timeout)
This function blocks till the API has received new data. More...
void | WaitForData (const std::chrono::duration< int, std::micro > &timeout)
This function blocks till the API has received new data. More...
void | PingScheduler ()
Ping the I2C scheduler. More...
void | EnableLogging (const std::string &filename)
Return file handles which can be used with "select()".
CTracer & GetTracer ()
Returns a reference to the I2C tracer object. More...
const CTracer & | GetTracer () const
Returns a reference to the I2C tracer object. More...
CAdc & GetAdc ()
Returns a reference to the A/D converter object. More...
const CAdc & | GetAdc () const
Returns a reference to the A/D converter object. More...
CMaster & GetMaster ()
Returns a reference to the I2C master object. More...
const CMaster & | GetMaster () const
Returns a reference to the I2C master object. More...
CTraciiCpu & GetTraciiCpu ()
Returns a reference to the TraciiCPU object. More...
const CTraciiCpu & | GetTraciiCpu () const
Returns a reference to the TraciiCPU object. More...
CSlaveRamEnhanced & GetSlaveRamEnhanced ()
Returns a reference to the I2C slave RAM enhanced object. More...
const CSlaveRamEnhanced & | GetSlaveRamEnhanced () const
Returns a reference to the I2C slave RAM enhanced object. More...
CNegativeTester & GetNegativeTester ()
Returns a reference to the negative tester object. More...
const CNegativeTester & | GetNegativeTester () const
Returns a reference to the negative tester object. More...

Protected Member Functions

void GetCurrentTimestamp (CTimestamp &ts)

Detailed Description

This is the main class of the I2C API, which communicates with an I2C interface via the I2C scheduler. To use the I2C API it is always necessary to create one instance of this class.

To communicate with e.g. the tracer module of an I2C interface the following steps are necessary:

  1. Create an instance of this class.
  2. Request the list of available I2C interfaces using GetHardwareInfo().
  3. Open an I2C interface supporting the tracer module using OpenDevice().
  4. Use the GetTracer() method to get a reference to the CTracer object created and managed by this class.
  5. Use the CTracer object to communicate with the tracer module.
  6. Close the I2C interface using CloseDevice().
Thread-safety:
All classes of the I2C API are thread-safe as long as you call methods of instances of these classes only in those threads, which have been used to create the instances.
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.

Member Typedef Documentation

typedef void(* telos::I2cApi::Cpp::CBoard::CallBackFunction) (CBoard *board, void *private_data)

Interface of a callback function, which can be registered using SetDeviceAddedRemovedCallback().

Member Enumeration Documentation

enum telos::I2cApi::Cpp::CBoard::EBusType
Enumerator
BUS_TYPE_I2C | I2C bus.
BUS_TYPE_SMB | SMBus.
enum telos::I2cApi::Cpp::CBoard::EI2cBusState
Enumerator
I2C_BUS_STATE_UNKNOWN | the I2C interface does not support this feature
I2C_BUS_STATE_NORMAL | SCL and SDA are not low for more than 500 ms.
I2C_BUS_STATE_SCL_LOW | SCL is low for more than 500 ms.
I2C_BUS_STATE_SDA_LOW | SDA is low for more than 500 ms.
I2C_BUS_STATE_SCL_SDA_LOW | SCL and SDA are low for more than 500 ms.

Constructor & Destructor Documentation

CBoard::CBoard ( )

Constructor.

CBoard::~CBoard ( )

Destructor.

Member Function Documentation

void CBoard::CloseDevice ( )

Closes the connection to the interface.

Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.
CAdc & CBoard::GetAdc ( )

This function can be used to get access to the A/D converter functionality of the I2C interface connected to this object.

Returns
A/D converter object
Examples:
AdcExample.cpp.
const CAdc & CBoard::GetAdc ( ) const

This function can be used to get access to the A/D converter functionality of the I2C interface connected to this object.

Returns
A/D converter object
CBoard::EBusType CBoard::GetBusType ( )

Some I2C interfaces supports variants of the I2C bus like e.g. the SMBus. This method can be used to get the type of the bus currently connected to the I2C interface.

Returns
bus type
void CBoard::GetCurrentTimestamp ( CTimestamp & ts )
protected

Returns two file handles, which are used to communicate with the scheduler. These handles can be used together with "select()" to sleep till there is new data to be processed.

Parameters
in | returned input file handle
out | returned output file handle
Returns
ok (true), error (false)
Warning
This function is available only in the Linux version of the API.
void CBoard::GetHardwareInfo ( std::vector< SHardwareInfo > & hwinfo )

Requests a list of all available I2C interfaces.

Parameters
hwinfo list of available I2C interfaces
Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.
const SHardwareInfo & CBoard::GetHardwareInfoOfOpenDevice ( ) const

Returns the hardware information of the I2C interface, which this object is connected to.

Returns
hardware information
Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, and TracerCsvExample.cpp.
uint8_t CBoard::GetHighLevelThreshold ( )

Returns the high level threshold. This threshold defines the voltage range on SCL/SDA interpreted as logical "1".

Returns
high level threshold [percent]
uint8_t CBoard::GetI2cBusLoad ( )

Returns the load of the I2C bus.

Returns
load of the I2C bus [%] or ~0 (N/A)
CBoard::EI2cBusState CBoard::GetI2cState ( )

Returns the state of the I2C bus. This can be used to detect a hanging (more than 500 ms low) SCL and/or SDA.

Returns
state of the I2C bus
uint16_t CBoard::GetI2cVcc ( )

Returns the Vcc voltage of the I2C bus.

Returns
Vcc of the I2C bus [mV] or ~0 (N/A)
uint16_t CBoard::GetI2cVccSupply ( )

Returns the I2C Vcc supply voltage generated by the I2C interface.

To get the I2C Vcc voltage currently measured on the I2C interface (generated internally or externally) use GetI2cVcc().

Returns
I2C Vcc supply voltage [mV]
bool CBoard::GetInputTestpin ( int testpin )

Returns the current status of the specified input testpin.

The number of available input testpins is stored in the SHardwareInfo::testpins_in, which can be accessed using GetHardwareInfoOfOpenDevice().

Parameters
testpin testpin to be read
Returns
status of the testpin: low (false), high (true)
void CBoard::GetInputTestpin ( std::vector< bool > & levels )

Returns the current status of the input testpins.

Parameters
levels status of the testpins: low (false), high (true)
uint8_t CBoard::GetLowLevelThreshold ( )

Returns the low level threshold. This threshold defines the voltage range on SCL/SDA interpreted as logical "0".

Returns
low level threshold [percent]
CMaster & CBoard::GetMaster ( )

This function can be used to get access to the master functionality of the I2C interface connected to this object.

Returns
I2C master object
Examples:
MasterExample.cpp.
const CMaster & CBoard::GetMaster ( ) const

This function can be used to get access to the master functionality of the I2C interface connected to this object.

Returns
I2C master object
CNegativeTester & CBoard::GetNegativeTester ( )

This function can be used to get access to the negative tester functionality of the I2C interface connected to this object.

Returns
negative tester object
Examples:
NegativeTesterExample.cpp.
const CNegativeTester & CBoard::GetNegativeTester ( ) const

This function can be used to get access to the negative tester functionality of the I2C interface connected to this object.

Returns
negative tester object
bool CBoard::GetOutputTestpin ( int testpin )

Returns the level of one of the hardware's output testpins. The number of available output testpins is stored in the SHardwareInfo::testpins_out variable, which can be accessed using GetHardwareInfoOfOpenBoard().

Parameters
testpin number of the testpin to be read
Returns
level: low (false), high (true)
void CBoard::GetOutputTestpin ( std::vector< bool > & levels )

Returns the levels of the hardware's output testpins.

Parameters
levels levels: low (false), high (true)
uint32_t CBoard::GetPullUpCurrentScl ( )

Returns the pull-up current of SCL.

Returns
pull-up current [.1mA]
uint32_t CBoard::GetPullUpCurrentSda ( )

Returns the pull-up current of SDA.

Returns
pull-up current [.1mA]
const string & CBoard::GetSchedulerIpAddress ( ) const

Returns the IP address of the running I2C scheduler.

Returns
IP address of the I2C scheduler
const SVersionNumber & CBoard::GetSchedulerVersion ( ) const

Returns the version of the running I2C scheduler.

Returns
version of the I2C scheduler
CSlaveRamEnhanced & CBoard::GetSlaveRamEnhanced ( )

This function can be used to get access to the enhanced I2C slave RAM functionality of the I2C interface connected to this object.

Returns
enhanced I2C slave RAM object
const CSlaveRamEnhanced & CBoard::GetSlaveRamEnhanced ( ) const

This function can be used to get access to the enhanced I2C slave RAM functionality of the I2C interface connected to this object.

Returns
enhanced I2C slave RAM object
uint32_t CBoard::GetTerminationScl ( )

Returns the value of the current termination of SCL.

Returns
termination of SCL [Ohm] or N/A (~0)
uint32_t CBoard::GetTerminationSda ( )

Returns the value of the current termination of SDA.

Returns
termination of SDA [Ohm] or N/A (~0)
void CBoard::GetTestpinConfiguration | ( | bool & | start,
 |  | bool & | stop,
 |  | bool & | ack,
 |  | bool & | nack,
 |  | bool & | error
 | ) |  |

Returns the configuration of the hardware's output testpin. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Parameters
start | use start condition as event?
stop | use stop condition as event?
ack | use ack condition as event?
nack | use nack condition as event?
error | use error condition as event?
CTracer & CBoard::GetTracer ( )

This function can be used to get access to the tracer functionality of the I2C interface connected to this object.

Returns
tracer object
Examples:
InputTestpinsExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.
const CTracer & CBoard::GetTracer ( ) const

This function can be used to get access to the tracer functionality of the I2C interface connected to this object.

Returns
tracer object
CTraciiCpu & CBoard::GetTraciiCpu ( )

This function can be used to get access to the TraciiCPU functionality of the I2C interface connected to this object.

Returns
TraciiCPU object
const CTraciiCpu & CBoard::GetTraciiCpu ( ) const

This function can be used to get access to the TraciiCPU functionality of the I2C interface connected to this object.

Returns
TraciiCPU object
bool CBoard::IsDeviceAvailable | ( | uint16_t | serial_number,
 |  | ETraciiType | board_type
 | ) |  |

Tests whether the specified I2C interface is available.

Parameters
serial_number | serial number of the I2C interface
board_type | type of the I2C interface
Returns
board available (true), not available (false)
bool CBoard::IsDeviceOpen ( )

Tests whether an object of this class is connected to an I2C interface.

Returns
connected (true), not connected (false)
Examples:
NegativeTesterExample.cpp.
void CBoard::OpenDevice ( const SHardwareInfo & board )

Connects an object of this class with the specified I2C interface.

Parameters
board I2C interface
Returns
ok (true), error (false)
Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.
void CBoard::OpenDevice | ( | ETraciiType | board_type,
 |  | unsigned short | serial_number
 | ) |  |

Connects an object of this class with the specified I2C interface.

Parameters
board_type | type of the I2C interface
serial_number | serial number of the I2C interface
Returns
ok (true), error (false)
void CBoard::PingScheduler ( )

Pings the I2C scheduler. This can be used to ensure that the remote I2C scheduler is still alive.

void CBoard::SetBusType ( EBusType bus_type )

Some I2C interfaces supports variants of the I2C bus like e.g. the SMBus. This method can be used to set the type of the bus currently connected to the I2C interface.

At the moment there are two bus types: I2C and SMB. All I2C interfaces support the I2C bus. Whether an I2C interface supports the SMBus can be determined by evaluating SHardwareInfo::bus_type_smb variable, which can be accessed using GetHardwareInfoOfOpenDevice().

Parameters
bus_type bus type
void CBoard::SetDeviceAddedRemovedCallback | ( | CallBackFunction | fct,
 |  | void * | private_data
 | ) |  |

Registers a "device added/removed" callback. This callback gets fired, when the user connects a new I2C interface to the host or disconnects an existing one.

Parameters
fct | callback function to be fired
private_data | data to be passed to callback
void CBoard::SetI2cVccSupply ( uint16_t i2c_vcc )

Sets the I2C Vcc supply voltage.

Some I2C interfaces can supply the I2C Vcc pin. Valid values for the I2C Vcc supply voltage of the opened board are stored in the SHardwareInfo::i2c_vcc_supply variable, which can be accessed using GetHardwareInfoOfOpenBoard().

Parameters
i2c_vcc I2C Vcc supply voltage [mV]
void CBoard::SetLevelThresholds | ( | uint8_t | low,
 |  | uint8_t | high
 | ) |  |

Sets the low and high level thresholds.

The low level threshold defines the voltage range on SCL/SDA interpreted as logical "0". Valid values for the low level threshold of the opened I2C interface are stored in the SHardwareInfo::low_level_threshold variable, which can be accessed using GetHardwareInfoOfOpenBoard().

The high level threshold defines the voltage range on SCL/SDA interpreted as logical "1". Valid values for the high level threshold of the opened I2C interface are stored in the SHardwareInfo::high_level_threshold variable, which can be accessed using GetHardwareInfoOfOpenBoard().

Parameters
low | low level threshold [percent]
high | high level threshold [percent]
void CBoard::SetOutputTestpin | ( | int | testpin,
 |  | bool | level
 | ) |  |

Sets one of the hardware's output testpins to the specified level. The number of available output testpins is stored in the SHardwareInfo::testpins_out variable, which can be accessed using GetHardwareInfoOfOpenBoard().

Parameters
testpin | number of the testpin to be changed
level | level to be set: low (false), high (true)
void CBoard::SetOutputTestpin ( const std::vector< bool > & levels )

Sets the hardware's output testpins to the specified levels. The number of available output testpins is stored in the SHardwareInfo::testpins_out variable, which can be accessed using GetHardwareInfoOfOpenBoard().

Parameters
levels levels to be set: low (false), high (true)
void CBoard::SetPullUpCurrentScl ( uint32_t current_scl )

Configures the pull-up current of SCL.

Maximum value for the pull-up current of the opened I2C interface are stored in the SHardwareInfo::pull_up_current_max variable, which can be accessed using GetHardwareInfoOfOpenDevice().

Returns
pull-up current [.1mA]
void CBoard::SetPullUpCurrentSda ( uint32_t current_sda )

Configures the pull-up current of SDA.

Maximum value for the pull-up current of the opened I2C interface are stored in the SHardwareInfo::pull_up_current_max variable, which can be accessed using GetHardwareInfoOfOpenDevice().

Parameters
current_sda pull-up current of SDA [.1mA]
void CBoard::SetTerminationScl ( uint32_t term )

Configures the termination of SCL.

Valid values for the termination of the opened I2C interface are stored in the SHardwareInfo::termination variable, which can be accessed using GetHardwareInfoOfOpenDevice().

Parameters
term termination of SCL [Ohm]
void CBoard::SetTerminationSda ( uint32_t term )

Configures the termination of SDA.

Valid values for the termination of the opened I2C interface are stored in the SHardwareInfo::termination variable, which can be accessed using GetHardwareInfoOfOpenDevice().

Parameters
term termination of SDA [Ohm]
void CBoard::SetTestpinConfiguration | ( | bool | start,
 |  | bool | stop,
 |  | bool | ack,
 |  | bool | nack,
 |  | bool | error
 | ) |  |

Configures the output testpin of the hardware. If the hardware detects one of the enabled events on the I2C bus, the testpin is activated for one cycle. This feature can be used as a trigger.

Parameters
start | use start condition as event?
stop | use stop condition as event?
ack | use ack condition as event?
nack | use nack condition as event?
error | use error condition as event?
void CBoard::WaitForData ( int timeout )

This function blocks until the API has received data from the scheduler. During this time the process sleeps and does not use CPU time.

Parameters
timeout timeout [usec]
Returns
new data available (true), else (false)
Examples:
AdcExample.cpp, InputTestpinsExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.
void CBoard::WaitForData ( const std::chrono::duration< int, std::micro > & timeout )

This function blocks until the API has received data from the scheduler. During this time the process sleeps and does not use CPU time.

Parameters
timeout timeout
Returns
new data available (true), else (false)


I2C.C++ API: Member List

  • CBoard
telos::I2cApi::Cpp::CBoard Member List

This is the complete list of members for telos::I2cApi::Cpp::CBoard, including all inherited members.

BUS_TYPE_I2C enum value | telos::I2cApi::Cpp::CBoard |
BUS_TYPE_SMB enum value | telos::I2cApi::Cpp::CBoard |
CallBackFunction typedef | telos::I2cApi::Cpp::CBoard |
CBoard() | telos::I2cApi::Cpp::CBoard |
CBoard(const std::string &ip_address, uint16_t ip_port, const std::string &password) | telos::I2cApi::Cpp::CBoard |
CloseDevice() | telos::I2cApi::Cpp::CBoard |
EBusType enum name | telos::I2cApi::Cpp::CBoard |
EI2cBusState enum name | telos::I2cApi::Cpp::CBoard |
EnableLogging(const std::string &filename) | telos::I2cApi::Cpp::CBoard |
GetAdc() | telos::I2cApi::Cpp::CBoard |
GetAdc() const | telos::I2cApi::Cpp::CBoard |
GetBusType() | telos::I2cApi::Cpp::CBoard |
GetCurrentTimestamp(CTimestamp &ts) | telos::I2cApi::Cpp::CBoard | protected
GetHardwareInfo(std::vector< SHardwareInfo > &hwinfo) | telos::I2cApi::Cpp::CBoard |
GetHardwareInfoOfOpenDevice() const | telos::I2cApi::Cpp::CBoard |
GetHighLevelThreshold() | telos::I2cApi::Cpp::CBoard |
GetI2cBusLoad() | telos::I2cApi::Cpp::CBoard |
GetI2cState() | telos::I2cApi::Cpp::CBoard |
GetI2cVcc() | telos::I2cApi::Cpp::CBoard |
GetI2cVccSupply() | telos::I2cApi::Cpp::CBoard |
GetInputTestpin(int testpin) | telos::I2cApi::Cpp::CBoard |
GetInputTestpin(std::vector< bool > &levels) | telos::I2cApi::Cpp::CBoard |
GetLowLevelThreshold() | telos::I2cApi::Cpp::CBoard |
GetMaster() | telos::I2cApi::Cpp::CBoard |
GetMaster() const | telos::I2cApi::Cpp::CBoard |
GetNegativeTester() | telos::I2cApi::Cpp::CBoard |
GetNegativeTester() const | telos::I2cApi::Cpp::CBoard |
GetOutputTestpin(int testpin) | telos::I2cApi::Cpp::CBoard |
GetOutputTestpin(std::vector< bool > &levels) | telos::I2cApi::Cpp::CBoard |
GetPullUpCurrentScl() | telos::I2cApi::Cpp::CBoard |
GetPullUpCurrentSda() | telos::I2cApi::Cpp::CBoard |
GetSchedulerIpAddress() const | telos::I2cApi::Cpp::CBoard |
GetSchedulerVersion() const | telos::I2cApi::Cpp::CBoard |
GetSlaveRamEnhanced() | telos::I2cApi::Cpp::CBoard |
GetSlaveRamEnhanced() const | telos::I2cApi::Cpp::CBoard |
GetTerminationScl() | telos::I2cApi::Cpp::CBoard |
GetTerminationSda() | telos::I2cApi::Cpp::CBoard |
GetTestpinConfiguration(bool &start, bool &stop, bool &ack, bool &nack, bool &error) | telos::I2cApi::Cpp::CBoard |
GetTracer() | telos::I2cApi::Cpp::CBoard |
GetTracer() const | telos::I2cApi::Cpp::CBoard |
GetTraciiCpu() | telos::I2cApi::Cpp::CBoard |
GetTraciiCpu() const | telos::I2cApi::Cpp::CBoard |
I2C_BUS_STATE_NORMAL enum value | telos::I2cApi::Cpp::CBoard |
I2C_BUS_STATE_SCL_LOW enum value | telos::I2cApi::Cpp::CBoard |
I2C_BUS_STATE_SCL_SDA_LOW enum value | telos::I2cApi::Cpp::CBoard |
I2C_BUS_STATE_SDA_LOW enum value | telos::I2cApi::Cpp::CBoard |
I2C_BUS_STATE_UNKNOWN enum value | telos::I2cApi::Cpp::CBoard |
IsDeviceAvailable(uint16_t serial_number, ETraciiType board_type) | telos::I2cApi::Cpp::CBoard |
IsDeviceOpen() | telos::I2cApi::Cpp::CBoard |
OpenDevice(const SHardwareInfo &board) | telos::I2cApi::Cpp::CBoard |
OpenDevice(ETraciiType board_type, unsigned short serial_number) | telos::I2cApi::Cpp::CBoard |
PingScheduler() | telos::I2cApi::Cpp::CBoard |
SetBusType(EBusType bus_type) | telos::I2cApi::Cpp::CBoard |
SetDeviceAddedRemovedCallback(CallBackFunction fct, void *private_data) | telos::I2cApi::Cpp::CBoard |
SetI2cVccSupply(uint16_t i2c_vcc) | telos::I2cApi::Cpp::CBoard |
SetLevelThresholds(uint8_t low, uint8_t high) | telos::I2cApi::Cpp::CBoard |
SetOutputTestpin(int testpin, bool level) | telos::I2cApi::Cpp::CBoard |
SetOutputTestpin(const std::vector< bool > &levels) | telos::I2cApi::Cpp::CBoard |
SetPullUpCurrentScl(uint32_t current) | telos::I2cApi::Cpp::CBoard |
SetPullUpCurrentSda(uint32_t current) | telos::I2cApi::Cpp::CBoard |
SetTerminationScl(uint32_t term) | telos::I2cApi::Cpp::CBoard |
SetTerminationSda(uint32_t term) | telos::I2cApi::Cpp::CBoard |
SetTestpinConfiguration(bool start, bool stop, bool ack, bool nack, bool error) | telos::I2cApi::Cpp::CBoard |
WaitForData(int timeout) | telos::I2cApi::Cpp::CBoard |
WaitForData(const std::chrono::duration< int, std::micro > &timeout) | telos::I2cApi::Cpp::CBoard |
~CBoard() | telos::I2cApi::Cpp::CBoard |


I2C.C++ API: telos::I2cApi::Cpp::CException Class Reference

  • CException
Public Member Functions | Protected Attributes | List of all members
telos::I2cApi::Cpp::CException Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CException:
telos::I2cApi::Cpp::CExceptionAdc telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted telos::I2cApi::Cpp::CExceptionArpInvalidResponse telos::I2cApi::Cpp::CExceptionAuthentication telos::I2cApi::Cpp::CExceptionBusType telos::I2cApi::Cpp::CExceptionDeviceOpen telos::I2cApi::Cpp::CExceptionDriverVersion telos::I2cApi::Cpp::CExceptionHardwareIo telos::I2cApi::Cpp::CExceptionI2cAddress telos::I2cApi::Cpp::CExceptionI2cVcc telos::I2cApi::Cpp::CExceptionI2cVccSupply telos::I2cApi::Cpp::CExceptionInputTestpin telos::I2cApi::Cpp::CExceptionIo telos::I2cApi::Cpp::CExceptionLevelThreshold telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CExceptionNegativeTester telos::I2cApi::Cpp::CExceptionNullPointer telos::I2cApi::Cpp::CExceptionOpen telos::I2cApi::Cpp::CExceptionOutputTestpin telos::I2cApi::Cpp::CExceptionPullUpCurrent telos::I2cApi::Cpp::CExceptionSchedulerBusy telos::I2cApi::Cpp::CExceptionSchedulerVersion telos::I2cApi::Cpp::CExceptionServiceContractExpired telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced telos::I2cApi::Cpp::CExceptionSmbI2cAddress telos::I2cApi::Cpp::CExceptionTermination telos::I2cApi::Cpp::CExceptionTracer telos::I2cApi::Cpp::CExceptionTraciiCpu

Public Member Functions

const std::string & GetDescription () const

Protected Attributes

std::string m_description_en
description of the error

Detailed Description

All exceptions thrown by the I2C C++ API are derived from this base class.

Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.

Member Function Documentation

const string & CException::GetDescription ( ) const

Returns a description of the error.

Returns
description of the error
Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.


I2C.C++ API: Member List

  • CException
telos::I2cApi::Cpp::CException Member List

This is the complete list of members for telos::I2cApi::Cpp::CException, including all inherited members.

GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAdc Class Reference

  • CExceptionAdc
List of all members
telos::I2cApi::Cpp::CExceptionAdc Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAdc:
telos::I2cApi::Cpp::CException telos::I2cApi::Cpp::CExceptionAdcBusy telos::I2cApi::Cpp::CExceptionAdcNotFinished telos::I2cApi::Cpp::CExceptionAdcNotSupported telos::I2cApi::Cpp::CExceptionAdcPreTrigger telos::I2cApi::Cpp::CExceptionAdcSamplingRate telos::I2cApi::Cpp::CExceptionAdcTrigger

Additional Inherited Members

- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & | GetDescription () const
- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string | m_description_en
description of the error

Detailed Description

Exception: This class serves as a base class for all exceptions thrown by the A/D converter module.


I2C.C++ API: Member List

  • CExceptionAdc
telos::I2cApi::Cpp::CExceptionAdc Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAdc, including all inherited members.

GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAdcBusy Class Reference

  • CExceptionAdcBusy
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionAdcBusy Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAdcBusy:
telos::I2cApi::Cpp::CExceptionAdc telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionAdcBusy ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Because the A/D converter is busy, the requested command cannot be executed.

Constructor & Destructor Documentation

CExceptionAdcBusy::CExceptionAdcBusy ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionAdcBusy
telos::I2cApi::Cpp::CExceptionAdcBusy Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAdcBusy, including all inherited members.

CExceptionAdcBusy() | telos::I2cApi::Cpp::CExceptionAdcBusy |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAdcNotFinished Class Reference

  • CExceptionAdcNotFinished
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionAdcNotFinished Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAdcNotFinished:
telos::I2cApi::Cpp::CExceptionAdc telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionAdcNotFinished ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Cannot receive the A/D data from the hardware, because the sampling process has not been finished.

Constructor & Destructor Documentation

CExceptionAdcNotFinished::CExceptionAdcNotFinished ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionAdcNotFinished
telos::I2cApi::Cpp::CExceptionAdcNotFinished Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAdcNotFinished, including all inherited members.

CExceptionAdcNotFinished() | telos::I2cApi::Cpp::CExceptionAdcNotFinished |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAdcNotSupported Class Reference

  • CExceptionAdcNotSupported
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionAdcNotSupported Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAdcNotSupported:
telos::I2cApi::Cpp::CExceptionAdc telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionAdcNotSupported ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The hardware does not support the A/D converter mode.

Constructor & Destructor Documentation

CExceptionAdcNotSupported::CExceptionAdcNotSupported ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionAdcNotSupported
telos::I2cApi::Cpp::CExceptionAdcNotSupported Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAdcNotSupported, including all inherited members.

CExceptionAdcNotSupported() | telos::I2cApi::Cpp::CExceptionAdcNotSupported |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAdcPreTrigger Class Reference

  • CExceptionAdcPreTrigger
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionAdcPreTrigger Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAdcPreTrigger:
telos::I2cApi::Cpp::CExceptionAdc telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionAdcPreTrigger ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The A/D converter of the I2C interface does not support the specified pretrigger.

Constructor & Destructor Documentation

CExceptionAdcPreTrigger::CExceptionAdcPreTrigger ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionAdcPreTrigger
telos::I2cApi::Cpp::CExceptionAdcPreTrigger Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAdcPreTrigger, including all inherited members.

CExceptionAdcPreTrigger() | telos::I2cApi::Cpp::CExceptionAdcPreTrigger |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAdcSamplingRate Class Reference

  • CExceptionAdcSamplingRate
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionAdcSamplingRate Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAdcSamplingRate:
telos::I2cApi::Cpp::CExceptionAdc telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionAdcSamplingRate ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The A/D converter of the I2C interface does not support the specified sampling rate.

Constructor & Destructor Documentation

CExceptionAdcSamplingRate::CExceptionAdcSamplingRate ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionAdcSamplingRate
telos::I2cApi::Cpp::CExceptionAdcSamplingRate Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAdcSamplingRate, including all inherited members.

CExceptionAdcSamplingRate() | telos::I2cApi::Cpp::CExceptionAdcSamplingRate |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAdcTrigger Class Reference

  • CExceptionAdcTrigger
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionAdcTrigger Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAdcTrigger:
telos::I2cApi::Cpp::CExceptionAdc telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionAdcTrigger ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The A/D converter of the I2C interface does not support the specified trigger condition.

Constructor & Destructor Documentation

CExceptionAdcTrigger::CExceptionAdcTrigger ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionAdcTrigger
telos::I2cApi::Cpp::CExceptionAdcTrigger Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAdcTrigger, including all inherited members.

CExceptionAdcTrigger() | telos::I2cApi::Cpp::CExceptionAdcTrigger |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted Class Reference

  • CExceptionArpI2cAddressesExhausted
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionArpI2cAddressesExhausted ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Cannot assign an I2C address to all found slave devices. There are not enough free I2C addresses.

Constructor & Destructor Documentation

CExceptionArpI2cAddressesExhausted::CExceptionArpI2cAddressesExhausted ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionArpI2cAddressesExhausted
telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted, including all inherited members.

CExceptionArpI2cAddressesExhausted() | telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionArpInvalidResponse Class Reference

  • CExceptionArpInvalidResponse
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionArpInvalidResponse Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionArpInvalidResponse:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionArpInvalidResponse ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Received an invalid response from the slave during the SMBus address resolution protocol (ARP).

Constructor & Destructor Documentation

CExceptionArpInvalidResponse::CExceptionArpInvalidResponse ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionArpInvalidResponse
telos::I2cApi::Cpp::CExceptionArpInvalidResponse Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionArpInvalidResponse, including all inherited members.

CExceptionArpInvalidResponse() | telos::I2cApi::Cpp::CExceptionArpInvalidResponse |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionAuthentication Class Reference

  • CExceptionAuthentication
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionAuthentication Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionAuthentication:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionAuthentication ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The authentication with the I2C scheduler failed. Check the password.

Constructor & Destructor Documentation

CExceptionAuthentication::CExceptionAuthentication ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionAuthentication
telos::I2cApi::Cpp::CExceptionAuthentication Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionAuthentication, including all inherited members.

CExceptionAuthentication() | telos::I2cApi::Cpp::CExceptionAuthentication |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionBusType Class Reference

  • CExceptionBusType
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionBusType Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionBusType:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionBusType (CBoard::EBusType bus_type)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The hardware does not support this bus type.

Constructor & Destructor Documentation

CExceptionBusType::CExceptionBusType ( CBoard::EBusType bus_type )
explicit

Constructor.

Parameters
bus_type not supported bus type


I2C.C++ API: Member List

  • CExceptionBusType
telos::I2cApi::Cpp::CExceptionBusType Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionBusType, including all inherited members.

CExceptionBusType(CBoard::EBusType bus_type) | telos::I2cApi::Cpp::CExceptionBusType | explicit
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionDeviceOpen Class Reference

  • CExceptionDeviceOpen
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionDeviceOpen Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionDeviceOpen:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionDeviceOpen ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: It is not possible to execute the requested command, because no I2C interface has been opened. Open an I2C interface using CBoard::DeviceOpen() and try it again.

Constructor & Destructor Documentation

CExceptionDeviceOpen::CExceptionDeviceOpen ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionDeviceOpen
telos::I2cApi::Cpp::CExceptionDeviceOpen Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionDeviceOpen, including all inherited members.

CExceptionDeviceOpen() | telos::I2cApi::Cpp::CExceptionDeviceOpen |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionDriverVersion Class Reference

  • CExceptionDriverVersion
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionDriverVersion Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionDriverVersion:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionDriverVersion (const std::string &component, const SVersionNumber &available, const SVersionNumber &required)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The used driver of the I2C interface has got the wrong version. To solve this problem, update the driver.

Constructor & Destructor Documentation

CExceptionDriverVersion::CExceptionDriverVersion | ( | const std::string & | component,
 |  | const SVersionNumber & | available,
 |  | const SVersionNumber & | required
 | ) |  |

Constructor.

Parameters
component | name of the component of the driver, which has got the wrong version
available | version number of the componend currently used on the system
required | version number of the componend required by the I2C scheduler


I2C.C++ API: Member List

  • CExceptionDriverVersion
telos::I2cApi::Cpp::CExceptionDriverVersion Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionDriverVersion, including all inherited members.

CExceptionDriverVersion(const std::string &component, const SVersionNumber &available, const SVersionNumber &required) | telos::I2cApi::Cpp::CExceptionDriverVersion |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionHardwareIo Class Reference

  • CExceptionHardwareIo
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionHardwareIo Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionHardwareIo:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionHardwareIo ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The opened I2C interface does not respond. Maybe the I2C interface has been disconnected from the host.

Constructor & Destructor Documentation

CExceptionHardwareIo::CExceptionHardwareIo ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionHardwareIo
telos::I2cApi::Cpp::CExceptionHardwareIo Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionHardwareIo, including all inherited members.

CExceptionHardwareIo() | telos::I2cApi::Cpp::CExceptionHardwareIo |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionI2cAddress Class Reference

  • CExceptionI2cAddress
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionI2cAddress Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionI2cAddress:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionI2cAddress (uint16_t address, bool ten_bit_address)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The specified parameters do not specify a valid I2C slave address.

Constructor & Destructor Documentation

CExceptionI2cAddress::CExceptionI2cAddress | ( | uint16_t | address,
 |  | bool | ten_bit_address
 | ) |  |

Constructor.

Parameters
address | invalid I2C address
ten_bit_address | invalid 10 bit address?


I2C.C++ API: Member List

  • CExceptionI2cAddress
telos::I2cApi::Cpp::CExceptionI2cAddress Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionI2cAddress, including all inherited members.

CExceptionI2cAddress(uint16_t address, bool ten_bit_address) | telos::I2cApi::Cpp::CExceptionI2cAddress |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionI2cVcc Class Reference

  • CExceptionI2cVcc
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionI2cVcc Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionI2cVcc:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionI2cVcc (uint16_t voltage)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: No power supply has been connected to the I2C Vcc pin of the I2C connector. Please connect the power supply providing the voltage of the I2C bus to the I2C Vcc pin of the I2C interface.

Constructor & Destructor Documentation

CExceptionI2cVcc::CExceptionI2cVcc ( uint16_t voltage )
explicit

Constructor.

Parameters
voltage current voltage of the I2C bus


I2C.C++ API: Member List

  • CExceptionI2cVcc
telos::I2cApi::Cpp::CExceptionI2cVcc Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionI2cVcc, including all inherited members.

CExceptionI2cVcc(uint16_t voltage) | telos::I2cApi::Cpp::CExceptionI2cVcc | explicit
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionI2cVccSupply Class Reference

  • CExceptionI2cVccSupply
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionI2cVccSupply Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionI2cVccSupply:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionI2cVccSupply ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: It is not possible to use the specified I2C Vcc supply voltage.

Constructor & Destructor Documentation

CExceptionI2cVccSupply::CExceptionI2cVccSupply ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionI2cVccSupply
telos::I2cApi::Cpp::CExceptionI2cVccSupply Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionI2cVccSupply, including all inherited members.

CExceptionI2cVccSupply() | telos::I2cApi::Cpp::CExceptionI2cVccSupply |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionInputTestpin Class Reference

  • CExceptionInputTestpin
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionInputTestpin Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionInputTestpin:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionInputTestpin ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: It is not possible to read the status of the specified input testpin.

Constructor & Destructor Documentation

CExceptionInputTestpin::CExceptionInputTestpin ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionInputTestpin
telos::I2cApi::Cpp::CExceptionInputTestpin Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionInputTestpin, including all inherited members.

CExceptionInputTestpin() | telos::I2cApi::Cpp::CExceptionInputTestpin |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionIo Class Reference

  • CExceptionIo
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionIo Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionIo:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionIo ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: An I/O error has occurred. Different reasons can cause this exception: e.g. there is no running I2C scheduler or the used I2C interface is no longer available.

Constructor & Destructor Documentation

CExceptionIo::CExceptionIo ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionIo
telos::I2cApi::Cpp::CExceptionIo Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionIo, including all inherited members.

CExceptionIo() | telos::I2cApi::Cpp::CExceptionIo |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionLevelThreshold Class Reference

  • CExceptionLevelThreshold
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionLevelThreshold Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionLevelThreshold:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionLevelThreshold ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: It is not possible to use the specified level thresholds.

Constructor & Destructor Documentation

CExceptionLevelThreshold::CExceptionLevelThreshold ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionLevelThreshold
telos::I2cApi::Cpp::CExceptionLevelThreshold Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionLevelThreshold, including all inherited members.

CExceptionLevelThreshold() | telos::I2cApi::Cpp::CExceptionLevelThreshold |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMaster Class Reference

  • CExceptionMaster
List of all members
telos::I2cApi::Cpp::CExceptionMaster Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMaster:
telos::I2cApi::Cpp::CException telos::I2cApi::Cpp::CExceptionMasterAddress telos::I2cApi::Cpp::CExceptionMasterArbitration telos::I2cApi::Cpp::CExceptionMasterBusy telos::I2cApi::Cpp::CExceptionMasterI2cProtocol telos::I2cApi::Cpp::CExceptionMasterIncompleteRx telos::I2cApi::Cpp::CExceptionMasterIncompleteTx telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer telos::I2cApi::Cpp::CExceptionMasterNotSupported telos::I2cApi::Cpp::CExceptionMasterRunning telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed telos::I2cApi::Cpp::CExceptionMasterTimeout telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout

Additional Inherited Members

- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & | GetDescription () const
- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string | m_description_en
description of the error

Detailed Description

Exception: This class serves as a base class for all exceptions thrown by the master module.


I2C.C++ API: Member List

  • CExceptionMaster
telos::I2cApi::Cpp::CExceptionMaster Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMaster, including all inherited members.

GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterAddress Class Reference

  • CExceptionMasterAddress
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterAddress Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterAddress:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterAddress (const CMasterMessage &msg, bool first_part_ten_bit_addr)
bool | IsFirstPartTenBitAddr ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & | GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: There is no slave responsible for this I2C address.

Constructor & Destructor Documentation

CExceptionMasterAddress::CExceptionMasterAddress | ( | const CMasterMessage & | msg,
 |  | bool | first_part_ten_bit_addr
 | ) |  |

Constructor.

Member Function Documentation

bool CExceptionMasterAddress::IsFirstPartTenBitAddr ( )

When using a 10 bit I2C address, there are two address bytes. This method can be used to determine, whether the first byte of a 10 bit address has received a NACK.

Returns
first byte has received a NACK?


I2C.C++ API: Member List

  • CExceptionMasterAddress
telos::I2cApi::Cpp::CExceptionMasterAddress Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterAddress, including all inherited members.

CExceptionMasterAddress(const CMasterMessage &msg, bool first_part_ten_bit_addr) | telos::I2cApi::Cpp::CExceptionMasterAddress |
GetDescription() const | telos::I2cApi::Cpp::CException |
IsFirstPartTenBitAddr() | telos::I2cApi::Cpp::CExceptionMasterAddress |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterArbitration Class Reference

  • CExceptionMasterArbitration
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterArbitration Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterArbitration:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterArbitration ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The master module of the I2C interface has lost the bus arbitration. At the moment the I2C bus is used by an other master.

Constructor & Destructor Documentation

CExceptionMasterArbitration::CExceptionMasterArbitration ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterArbitration
telos::I2cApi::Cpp::CExceptionMasterArbitration Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterArbitration, including all inherited members.

CExceptionMasterArbitration() | telos::I2cApi::Cpp::CExceptionMasterArbitration |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterBusy Class Reference

  • CExceptionMasterBusy
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterBusy Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterBusy:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterBusy ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The master is busy.

Constructor & Destructor Documentation

CExceptionMasterBusy::CExceptionMasterBusy ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterBusy
telos::I2cApi::Cpp::CExceptionMasterBusy Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterBusy, including all inherited members.

CExceptionMasterBusy() | telos::I2cApi::Cpp::CExceptionMasterBusy |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterI2cProtocol Class Reference

  • CExceptionMasterI2cProtocol
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterI2cProtocol Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterI2cProtocol:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterI2cProtocol ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The master module has detected an I2C protocol error on the I2C bus. Due to this error the transfer has been canceled.

Constructor & Destructor Documentation

CExceptionMasterI2cProtocol::CExceptionMasterI2cProtocol ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterI2cProtocol
telos::I2cApi::Cpp::CExceptionMasterI2cProtocol Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterI2cProtocol, including all inherited members.

CExceptionMasterI2cProtocol() | telos::I2cApi::Cpp::CExceptionMasterI2cProtocol |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterIncompleteRx Class Reference

  • CExceptionMasterIncompleteRx
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterIncompleteRx Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterIncompleteRx:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterIncompleteRx (const CMasterMessageRx &msg)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: If it is not possible to read the requested number of bytes from the slave as master receiver, this exception is thrown.

Constructor & Destructor Documentation

CExceptionMasterIncompleteRx::CExceptionMasterIncompleteRx ( const CMasterMessageRx & msg )
explicit

Constructor.

Parameters
msg incomplete master receiver message


I2C.C++ API: Member List

  • CExceptionMasterIncompleteRx
telos::I2cApi::Cpp::CExceptionMasterIncompleteRx Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterIncompleteRx, including all inherited members.

CExceptionMasterIncompleteRx(const CMasterMessageRx &msg) | telos::I2cApi::Cpp::CExceptionMasterIncompleteRx | explicit
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterIncompleteTx Class Reference

  • CExceptionMasterIncompleteTx
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterIncompleteTx Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterIncompleteTx:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterIncompleteTx (const CMasterMessageTx &msg)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: If the slave does not acknowledge all bytes send by the I2C interface as master transmitter, this exception is thrown.

Constructor & Destructor Documentation

CExceptionMasterIncompleteTx::CExceptionMasterIncompleteTx ( const CMasterMessageTx & msg )
explicit

Constructor.

Parameters
msg incomplete master transmitter message


I2C.C++ API: Member List

  • CExceptionMasterIncompleteTx
telos::I2cApi::Cpp::CExceptionMasterIncompleteTx Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterIncompleteTx, including all inherited members.

CExceptionMasterIncompleteTx(const CMasterMessageTx &msg) | telos::I2cApi::Cpp::CExceptionMasterIncompleteTx | explicit
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate Class Reference

  • CExceptionMasterInvalidBitrate
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterInvalidBitrate ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The specified master bitrate is not valid.

Constructor & Destructor Documentation

CExceptionMasterInvalidBitrate::CExceptionMasterInvalidBitrate ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterInvalidBitrate
telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate, including all inherited members.

CExceptionMasterInvalidBitrate() | telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode Class Reference

  • CExceptionMasterInvalidMasterCode
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterInvalidMasterCode ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The specified high-speed master code is not valid.

Constructor & Destructor Documentation

CExceptionMasterInvalidMasterCode::CExceptionMasterInvalidMasterCode ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterInvalidMasterCode
telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode, including all inherited members.

CExceptionMasterInvalidMasterCode() | telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer Class Reference

  • CExceptionMasterInvalidTransfer
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterInvalidTransfer ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The used I2C interface does not support the specified I2C transfer (e.g. the I2C interface do not support all possible combinations of combined transfers).

Constructor & Destructor Documentation

CExceptionMasterInvalidTransfer::CExceptionMasterInvalidTransfer ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterInvalidTransfer
telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer, including all inherited members.

CExceptionMasterInvalidTransfer() | telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterNotSupported Class Reference

  • CExceptionMasterNotSupported
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterNotSupported Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterNotSupported:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterNotSupported ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The hardware does not support the master mode.

Constructor & Destructor Documentation

CExceptionMasterNotSupported::CExceptionMasterNotSupported ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterNotSupported
telos::I2cApi::Cpp::CExceptionMasterNotSupported Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterNotSupported, including all inherited members.

CExceptionMasterNotSupported() | telos::I2cApi::Cpp::CExceptionMasterNotSupported |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterRunning Class Reference

  • CExceptionMasterRunning
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterRunning Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterRunning:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterRunning ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Cannot execute the requested command, because the master is already running.

Constructor & Destructor Documentation

CExceptionMasterRunning::CExceptionMasterRunning ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterRunning
telos::I2cApi::Cpp::CExceptionMasterRunning Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterRunning, including all inherited members.

CExceptionMasterRunning() | telos::I2cApi::Cpp::CExceptionMasterRunning |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize Class Reference

  • CExceptionMasterSmbInvalidSize
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterSmbInvalidSize ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: A SMBus block transfer can contain 0..255 data bytes.

Constructor & Destructor Documentation

CExceptionMasterSmbInvalidSize::CExceptionMasterSmbInvalidSize ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterSmbInvalidSize
telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize, including all inherited members.

CExceptionMasterSmbInvalidSize() | telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed Class Reference

  • CExceptionMasterSmbPecFailed
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterSmbPecFailed ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The packet error checking (PEC) has failed. The PEC byte does not match the transferred data.

Constructor & Destructor Documentation

CExceptionMasterSmbPecFailed::CExceptionMasterSmbPecFailed ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterSmbPecFailed
telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed, including all inherited members.

CExceptionMasterSmbPecFailed() | telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterTimeout Class Reference

  • CExceptionMasterTimeout
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterTimeout Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterTimeout:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterTimeout (ETraciiType board_type)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: A timeout has occurred during transferring a master message (SCL low for more than 500 ms).

Constructor & Destructor Documentation

CExceptionMasterTimeout::CExceptionMasterTimeout ( ETraciiType board_type )
explicit

Constructor.

Parameters
board_type type of the used I2C interface


I2C.C++ API: Member List

  • CExceptionMasterTimeout
telos::I2cApi::Cpp::CExceptionMasterTimeout Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterTimeout, including all inherited members.

CExceptionMasterTimeout(ETraciiType board_type) | telos::I2cApi::Cpp::CExceptionMasterTimeout | explicit
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout Class Reference

  • CExceptionMasterWatchdogTimeout
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout:
telos::I2cApi::Cpp::CExceptionMaster telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionMasterWatchdogTimeout ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: A timeout has occurred during transferring a master message (watchdog expired).

Constructor & Destructor Documentation

CExceptionMasterWatchdogTimeout::CExceptionMasterWatchdogTimeout ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionMasterWatchdogTimeout
telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout, including all inherited members.

CExceptionMasterWatchdogTimeout() | telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionNegativeTester Class Reference

  • CExceptionNegativeTester
List of all members
telos::I2cApi::Cpp::CExceptionNegativeTester Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionNegativeTester:
telos::I2cApi::Cpp::CException telos::I2cApi::Cpp::CExceptionNegativeTesterBusy telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize

Additional Inherited Members

- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & | GetDescription () const
- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string | m_description_en
description of the error

Detailed Description

Exception: This class serves as a base class for all exceptions thrown by the negative tester module.


I2C.C++ API: Member List

  • CExceptionNegativeTester
telos::I2cApi::Cpp::CExceptionNegativeTester Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionNegativeTester, including all inherited members.

GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionNegativeTesterBusy Class Reference

  • CExceptionNegativeTesterBusy
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionNegativeTesterBusy Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionNegativeTesterBusy:
telos::I2cApi::Cpp::CExceptionNegativeTester telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionNegativeTesterBusy ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The negative tester cannot be used, because it is already in use or because the I2C interface is busy.

Constructor & Destructor Documentation

CExceptionNegativeTesterBusy::CExceptionNegativeTesterBusy ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionNegativeTesterBusy
telos::I2cApi::Cpp::CExceptionNegativeTesterBusy Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionNegativeTesterBusy, including all inherited members.

CExceptionNegativeTesterBusy() | telos::I2cApi::Cpp::CExceptionNegativeTesterBusy |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument Class Reference

  • CExceptionNegativeTesterInvalidArgument
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument:
telos::I2cApi::Cpp::CExceptionNegativeTester telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionNegativeTesterInvalidArgument (const std::string &desc)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: On of the parameters passed to the negative tester module is not valid.

Constructor & Destructor Documentation

CExceptionNegativeTesterInvalidArgument::CExceptionNegativeTesterInvalidArgument ( const std::string & desc )
explicit

Constructor.

Parameters
desc description of the error


I2C.C++ API: Member List

  • CExceptionNegativeTesterInvalidArgument
telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument, including all inherited members.

CExceptionNegativeTesterInvalidArgument(const std::string &desc) | telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument | explicit
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported Class Reference

  • CExceptionNegativeTesterNotSupported
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported:
telos::I2cApi::Cpp::CExceptionNegativeTester telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionNegativeTesterNotSupported ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The opened I2C interface does not support the negative tester.

Constructor & Destructor Documentation

CExceptionNegativeTesterNotSupported::CExceptionNegativeTesterNotSupported ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionNegativeTesterNotSupported
telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported, including all inherited members.

CExceptionNegativeTesterNotSupported() | telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize Class Reference

  • CExceptionNegativeTesterProgramSize
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize:
telos::I2cApi::Cpp::CExceptionNegativeTester telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionNegativeTesterProgramSize ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Too many commands have been passed to the negative tester module.

Constructor & Destructor Documentation

CExceptionNegativeTesterProgramSize::CExceptionNegativeTesterProgramSize ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionNegativeTesterProgramSize
telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize, including all inherited members.

CExceptionNegativeTesterProgramSize() | telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionNullPointer Class Reference

  • CExceptionNullPointer
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionNullPointer Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionNullPointer:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionNullPointer ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Pointer is set to "0".

Constructor & Destructor Documentation

CExceptionNullPointer::CExceptionNullPointer ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionNullPointer
telos::I2cApi::Cpp::CExceptionNullPointer Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionNullPointer, including all inherited members.

CExceptionNullPointer() | telos::I2cApi::Cpp::CExceptionNullPointer |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionOpen Class Reference

  • CExceptionOpen
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionOpen Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionOpen:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionOpen ()
CExceptionOpen (ETraciiType board_type, unsigned short serial_number)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: It is not possible to open the specified I2C interface. Maybe the board is no longer attached to the host?

Constructor & Destructor Documentation

CExceptionOpen::CExceptionOpen ( )

Constructor.

CExceptionOpen::CExceptionOpen | ( | ETraciiType | board_type,
 |  | unsigned short | serial_number
 | ) |  |

Constructor.

Parameters
board_type | type of the I2C interface
serial_number | serial number of the I2C interface


I2C.C++ API: Member List

  • CExceptionOpen
telos::I2cApi::Cpp::CExceptionOpen Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionOpen, including all inherited members.

CExceptionOpen() | telos::I2cApi::Cpp::CExceptionOpen |
CExceptionOpen(ETraciiType board_type, unsigned short serial_number) | telos::I2cApi::Cpp::CExceptionOpen |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionOutputTestpin Class Reference

  • CExceptionOutputTestpin
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionOutputTestpin Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionOutputTestpin:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionOutputTestpin ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Failed to get or set the output testpin configuration.

Constructor & Destructor Documentation

CExceptionOutputTestpin::CExceptionOutputTestpin ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionOutputTestpin
telos::I2cApi::Cpp::CExceptionOutputTestpin Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionOutputTestpin, including all inherited members.

CExceptionOutputTestpin() | telos::I2cApi::Cpp::CExceptionOutputTestpin |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionPullUpCurrent Class Reference

  • CExceptionPullUpCurrent
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionPullUpCurrent Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionPullUpCurrent:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionPullUpCurrent ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: It is not possible to use the specified termination for SCL/SDA.

Constructor & Destructor Documentation

CExceptionPullUpCurrent::CExceptionPullUpCurrent ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionPullUpCurrent
telos::I2cApi::Cpp::CExceptionPullUpCurrent Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionPullUpCurrent, including all inherited members.

CExceptionPullUpCurrent() | telos::I2cApi::Cpp::CExceptionPullUpCurrent |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSchedulerBusy Class Reference

  • CExceptionSchedulerBusy
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSchedulerBusy Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSchedulerBusy:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSchedulerBusy ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Cannot connect to the I2C scheduler, because the scheduler is busy. The scheduler can handle only a limited number of simultaneous connections.

Constructor & Destructor Documentation

CExceptionSchedulerBusy::CExceptionSchedulerBusy ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSchedulerBusy
telos::I2cApi::Cpp::CExceptionSchedulerBusy Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSchedulerBusy, including all inherited members.

CExceptionSchedulerBusy() | telos::I2cApi::Cpp::CExceptionSchedulerBusy |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSchedulerVersion Class Reference

  • CExceptionSchedulerVersion
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSchedulerVersion Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSchedulerVersion:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSchedulerVersion (unsigned short version_scheduler_major, unsigned short version_scheduler_minor, unsigned short version_scheduler_build, unsigned short version_api_major, unsigned short version_api_minor)
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The running I2C scheduler has got the wrong version. To solve this problem, use a scheduler with the version number specified in the description of the exception.

Constructor & Destructor Documentation

CExceptionSchedulerVersion::CExceptionSchedulerVersion | ( | unsigned short | version_scheduler_major,
 |  | unsigned short | version_scheduler_minor,
 |  | unsigned short | version_scheduler_build,
 |  | unsigned short | version_api_major,
 |  | unsigned short | version_api_minor
 | ) |  |

Constructor.

Parameters
version_scheduler_major | version number of the used I2C scheduler (major)
version_scheduler_minor | version number of the used I2C scheduler (minor)
version_scheduler_build | version number of the used I2C scheduler (build)
version_api_major | version number of the I2C scheduler expected by the I2C API (major)
version_api_minor | version number of the I2C scheduler expected by the I2C API (minor)


I2C.C++ API: Member List

  • CExceptionSchedulerVersion
telos::I2cApi::Cpp::CExceptionSchedulerVersion Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSchedulerVersion, including all inherited members.

CExceptionSchedulerVersion(unsigned short version_scheduler_major, unsigned short version_scheduler_minor, unsigned short version_scheduler_build, unsigned short version_api_major, unsigned short version_api_minor) | telos::I2cApi::Cpp::CExceptionSchedulerVersion |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionServiceContractExpired Class Reference

  • CExceptionServiceContractExpired
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionServiceContractExpired Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionServiceContractExpired:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionServiceContractExpired ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: This version of the I2C software cannot be used with the opened I2C interface, because the service contract of this interface has expired.

Constructor & Destructor Documentation

CExceptionServiceContractExpired::CExceptionServiceContractExpired ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionServiceContractExpired
telos::I2cApi::Cpp::CExceptionServiceContractExpired Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionServiceContractExpired, including all inherited members.

CExceptionServiceContractExpired() | telos::I2cApi::Cpp::CExceptionServiceContractExpired |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced Class Reference

  • CExceptionSlaveRamEnhanced
List of all members
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced:
telos::I2cApi::Cpp::CException telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout

Additional Inherited Members

- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & | GetDescription () const
- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string | m_description_en
description of the error

Detailed Description

Exception: This class serves as a base class for all exceptions thrown by the enhanced slave RAM module.


I2C.C++ API: Member List

  • CExceptionSlaveRamEnhanced
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced, including all inherited members.

GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress Class Reference

  • CExceptionSlaveRamEnhancedAddress
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress:
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSlaveRamEnhancedAddress ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The enhanced slave RAM does not support the specified I2C address.

Constructor & Destructor Documentation

CExceptionSlaveRamEnhancedAddress::CExceptionSlaveRamEnhancedAddress ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSlaveRamEnhancedAddress
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress, including all inherited members.

CExceptionSlaveRamEnhancedAddress() | telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy Class Reference

  • CExceptionSlaveRamEnhancedBusy
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy:
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSlaveRamEnhancedBusy ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Cannot change the configuration of the enhanced slave RAM, while it is enabled.

Constructor & Destructor Documentation

CExceptionSlaveRamEnhancedBusy::CExceptionSlaveRamEnhancedBusy ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSlaveRamEnhancedBusy
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy, including all inherited members.

CExceptionSlaveRamEnhancedBusy() | telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize Class Reference

  • CExceptionSlaveRamEnhancedMemorySize
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize:
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSlaveRamEnhancedMemorySize ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The enhanced slave RAM does not support the specified memory size. The memory size can be set to 1..256 bytes.

Constructor & Destructor Documentation

CExceptionSlaveRamEnhancedMemorySize::CExceptionSlaveRamEnhancedMemorySize ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSlaveRamEnhancedMemorySize
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize, including all inherited members.

CExceptionSlaveRamEnhancedMemorySize() | telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported Class Reference

  • CExceptionSlaveRamEnhancedNotSupported
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported:
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSlaveRamEnhancedNotSupported ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The opened I2C interface does not support the enhanced slave RAM.

Constructor & Destructor Documentation

CExceptionSlaveRamEnhancedNotSupported::CExceptionSlaveRamEnhancedNotSupported ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSlaveRamEnhancedNotSupported
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported, including all inherited members.

CExceptionSlaveRamEnhancedNotSupported() | telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData Class Reference

  • CExceptionSlaveRamEnhancedSetData
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData:
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSlaveRamEnhancedSetData ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: Failed to set the data of the emulated slave RAM. Please check the start address and the number of data bytes to be set.

Constructor & Destructor Documentation

CExceptionSlaveRamEnhancedSetData::CExceptionSlaveRamEnhancedSetData ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSlaveRamEnhancedSetData
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData, including all inherited members.

CExceptionSlaveRamEnhancedSetData() | telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout Class Reference

  • CExceptionSlaveRamEnhancedTimeout
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout:
telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSlaveRamEnhancedTimeout ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The enhanced slave RAM does not support the specified timeout. The timeout can be set to 1..1275 ms or N/A (~0).

Constructor & Destructor Documentation

CExceptionSlaveRamEnhancedTimeout::CExceptionSlaveRamEnhancedTimeout ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSlaveRamEnhancedTimeout
telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout, including all inherited members.

CExceptionSlaveRamEnhancedTimeout() | telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionSmbI2cAddress Class Reference

  • CExceptionSmbI2cAddress
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionSmbI2cAddress Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionSmbI2cAddress:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionSmbI2cAddress ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The SMBus does not support 10 bit addresses.

Constructor & Destructor Documentation

CExceptionSmbI2cAddress::CExceptionSmbI2cAddress ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionSmbI2cAddress
telos::I2cApi::Cpp::CExceptionSmbI2cAddress Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionSmbI2cAddress, including all inherited members.

CExceptionSmbI2cAddress() | telos::I2cApi::Cpp::CExceptionSmbI2cAddress |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTermination Class Reference

  • CExceptionTermination
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionTermination Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTermination:
telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionTermination ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: It is not possible to use the specified termination for SCL/SDA.

Constructor & Destructor Documentation

CExceptionTermination::CExceptionTermination ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionTermination
telos::I2cApi::Cpp::CExceptionTermination Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTermination, including all inherited members.

CExceptionTermination() | telos::I2cApi::Cpp::CExceptionTermination |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTracer Class Reference

  • CExceptionTracer
List of all members
telos::I2cApi::Cpp::CExceptionTracer Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTracer:
telos::I2cApi::Cpp::CException telos::I2cApi::Cpp::CExceptionTracerBusy telos::I2cApi::Cpp::CExceptionTracerFilter telos::I2cApi::Cpp::CExceptionTracerNotSupported

Additional Inherited Members

- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & | GetDescription () const
- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string | m_description_en
description of the error

Detailed Description

Exception: This class serves as a base class for all exceptions thrown by the tracer module.


I2C.C++ API: Member List

  • CExceptionTracer
telos::I2cApi::Cpp::CExceptionTracer Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTracer, including all inherited members.

GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTracerBusy Class Reference

  • CExceptionTracerBusy
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionTracerBusy Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTracerBusy:
telos::I2cApi::Cpp::CExceptionTracer telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionTracerBusy ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The tracer is busy.

Constructor & Destructor Documentation

CExceptionTracerBusy::CExceptionTracerBusy ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionTracerBusy
telos::I2cApi::Cpp::CExceptionTracerBusy Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTracerBusy, including all inherited members.

CExceptionTracerBusy() | telos::I2cApi::Cpp::CExceptionTracerBusy |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTracerFilter Class Reference

  • CExceptionTracerFilter
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionTracerFilter Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTracerFilter:
telos::I2cApi::Cpp::CExceptionTracer telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionTracerFilter ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: An error occurred while setting the I2C address filter.

Constructor & Destructor Documentation

CExceptionTracerFilter::CExceptionTracerFilter ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionTracerFilter
telos::I2cApi::Cpp::CExceptionTracerFilter Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTracerFilter, including all inherited members.

CExceptionTracerFilter() | telos::I2cApi::Cpp::CExceptionTracerFilter |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTracerNotSupported Class Reference

  • CExceptionTracerNotSupported
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionTracerNotSupported Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTracerNotSupported:
telos::I2cApi::Cpp::CExceptionTracer telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionTracerNotSupported ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The hardware does not support the trace mode.

Constructor & Destructor Documentation

CExceptionTracerNotSupported::CExceptionTracerNotSupported ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionTracerNotSupported
telos::I2cApi::Cpp::CExceptionTracerNotSupported Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTracerNotSupported, including all inherited members.

CExceptionTracerNotSupported() | telos::I2cApi::Cpp::CExceptionTracerNotSupported |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTraciiCpu Class Reference

  • CExceptionTraciiCpu
List of all members
telos::I2cApi::Cpp::CExceptionTraciiCpu Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTraciiCpu:
telos::I2cApi::Cpp::CException telos::I2cApi::Cpp::CExceptionTraciiCpuBusy telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize

Additional Inherited Members

- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & | GetDescription () const
- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string | m_description_en
description of the error

Detailed Description

Exception: This class serves as a base class for all exceptions thrown by the TraciiCPU module.


I2C.C++ API: Member List

  • CExceptionTraciiCpu
telos::I2cApi::Cpp::CExceptionTraciiCpu Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTraciiCpu, including all inherited members.

GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTraciiCpuBusy Class Reference

  • CExceptionTraciiCpuBusy
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionTraciiCpuBusy Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTraciiCpuBusy:
telos::I2cApi::Cpp::CExceptionTraciiCpu telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionTraciiCpuBusy ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The TraciiCPU cannot be used, because it is already in use or because the master module of the I2C interface is in use.

Constructor & Destructor Documentation

CExceptionTraciiCpuBusy::CExceptionTraciiCpuBusy ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionTraciiCpuBusy
telos::I2cApi::Cpp::CExceptionTraciiCpuBusy Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTraciiCpuBusy, including all inherited members.

CExceptionTraciiCpuBusy() | telos::I2cApi::Cpp::CExceptionTraciiCpuBusy |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported Class Reference

  • CExceptionTraciiCpuNotSupported
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported:
telos::I2cApi::Cpp::CExceptionTraciiCpu telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionTraciiCpuNotSupported ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The opened I2C interface does not support the TraciiCPU.

Constructor & Destructor Documentation

CExceptionTraciiCpuNotSupported::CExceptionTraciiCpuNotSupported ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionTraciiCpuNotSupported
telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported, including all inherited members.

CExceptionTraciiCpuNotSupported() | telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize Class Reference

  • CExceptionTraciiCpuProgramSize
Public Member Functions | List of all members
telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize Class Reference

#include <CException.h>

Inheritance diagram for telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize:
telos::I2cApi::Cpp::CExceptionTraciiCpu telos::I2cApi::Cpp::CException

Public Member Functions

CExceptionTraciiCpuProgramSize ()
- Public Member Functions inherited from telos::I2cApi::Cpp::CException
const std::string & GetDescription () const

Additional Inherited Members

- Protected Attributes inherited from telos::I2cApi::Cpp::CException
std::string m_description_en
description of the error

Detailed Description

Exception: The specified program image has got false size. Images for the TraciiCPU have got a size of 1024 bytes.

Constructor & Destructor Documentation

CExceptionTraciiCpuProgramSize::CExceptionTraciiCpuProgramSize ( )

Constructor.


I2C.C++ API: Member List

  • CExceptionTraciiCpuProgramSize
telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize Member List

This is the complete list of members for telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize, including all inherited members.

CExceptionTraciiCpuProgramSize() | telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize |
GetDescription() const | telos::I2cApi::Cpp::CException |
m_description_en | telos::I2cApi::Cpp::CException | protected


I2C.C++ API: telos::I2cApi::Cpp::CI2cAddress Class Reference

  • CI2cAddress
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
telos::I2cApi::Cpp::CI2cAddress Class Reference

#include <CI2cAddress.h>

Public Member Functions

CI2cAddress ()
CI2cAddress (uint16_t address, bool ten_bit_address)
void | SetAddress (uint16_t address, bool ten_bit_address)
uint16_t | GetAddress () const
bool | IsTenBitAddress () const
void | VerifySMBAddress () const
bool | operator< (const CI2cAddress &addr) const
bool | operator<= (const CI2cAddress &addr) const
bool | operator> (const CI2cAddress &addr) const
bool | operator>= (const CI2cAddress &addr) const
bool | operator== (const CI2cAddress &addr) const
bool | operator!= (const CI2cAddress &addr) const
CI2cAddress & operator++ ()
CI2cAddress | operator++ (int)
CI2cAddress & operator-- ()
CI2cAddress | operator-- (int)

Static Public Member Functions

static const std::vector< CI2cAddress > & | Get7BitAddresses ()
static const std::vector< CI2cAddress > & | Get10BitAddresses ()
static const std::vector< CI2cAddress > & | GetAllAddresses ()

Static Public Attributes

static const CI2cAddress | GENERAL_CALL
general call I2C address
static const CI2cAddress | SMBUS_HOST
SMBus host address.
static const CI2cAddress | SMBUS_ALERT_RESPONSE
SMBus alert response address.
static const CI2cAddress | SMBUS_DEVICE_DEFAULT
SMBus device default address.
static const CI2cAddress | PMBUS_ZONE_READ
PMBus ZONE READ address.
static const CI2cAddress | PMBUS_ZONE_WRITE
PMBus ZONE WRITE address.

Detailed Description

Stores a 7 or 10 bit I2C slave address.

The I2C.C++ API uses the I2C address format specified in the I2C standard. Some IC manufacturer use different formats in their datasheets. E.g. they specify 7 bit addresses in an 8 bit representation, where the whole address gets shifted one bit to the left.

Exceptions
telos::I2cApi::Cpp::CException
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp, and NegativeTesterExample.cpp.

Constructor & Destructor Documentation

CI2cAddress::CI2cAddress ( )

Constructor: the created instance contains a valid but undefined I2C address.

CI2cAddress::CI2cAddress | ( | uint16_t | address,
 |  | bool | ten_bit_address
 | ) |  |

Constructor: specifies a 7 or 10 bit I2C address.

Parameters
address | I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address | 10 bit address?

Member Function Documentation

const vector< CI2cAddress > & CI2cAddress::Get10BitAddresses ( )
static

Returns a vector containing all valid 10 bit I2C addresses.

Returns
10 bit I2C addresses
const vector< CI2cAddress > & CI2cAddress::Get7BitAddresses ( )
static

Returns a vector containing all valid 7 bit I2C addresses.

Returns
7 bit I2C addresses
uint16_t CI2cAddress::GetAddress ( ) const

Returns the I2C address stored in this object. To test whether the returned value specifies a 7 or 10 bit I2C address the IsTenBitAddress() function has to be used.

Returns
I2C address
Examples:
NegativeTesterExample.cpp.
const vector< CI2cAddress > & CI2cAddress::GetAllAddresses ( )
static

Returns a vector containing all valid I2C addresses.

Returns
I2C addresses
bool CI2cAddress::IsTenBitAddress ( ) const

Returns whether the value of GetAddress() specifies a 7 or 10 bit I2C address.

Returns
7 bit (false), 10 bit (true) address
bool CI2cAddress::operator!= ( const CI2cAddress & addr ) const

Operator "!=".

Parameters
addr I2C address
CI2cAddress & CI2cAddress::operator++ ( )

Operator "++".

Returns
I2C address
CI2cAddress CI2cAddress::operator++ ( int )

Operator "++".

Returns
I2C address
CI2cAddress & CI2cAddress::operator-- ( )

Operator "--".

Returns
I2C address
CI2cAddress CI2cAddress::operator-- ( int )

Operator "--".

Returns
I2C address
bool CI2cAddress::operator< ( const CI2cAddress & addr ) const

Operator "<".

Parameters
addr I2C address
bool CI2cAddress::operator<= ( const CI2cAddress & addr ) const

Operator "<=".

Parameters
addr I2C address
bool CI2cAddress::operator== ( const CI2cAddress & addr ) const

Operator "==".

Parameters
addr I2C address
bool CI2cAddress::operator> ( const CI2cAddress & addr ) const

Operator ">".

Parameters
addr I2C address
bool CI2cAddress::operator>= ( const CI2cAddress & addr ) const

Operator ">=".

Parameters
addr I2C address
void CI2cAddress::SetAddress | ( | uint16_t | address,
 |  | bool | ten_bit_address
 | ) |  |

Sets a 7 or 10 bit I2C address to be stored in this object

Parameters
address | I2C address: 0..3, 8..119, 124..127 (7 bit); 0..1023 (10 bit)
ten_bit_address | 10 bit address?
Examples:
NegativeTesterExample.cpp.
void CI2cAddress::VerifySMBAddress ( ) const

Verifies that the object contains a valid SMBus address. If the address is not valid for the SMBus, this method throws a CExceptionSmbI2cAddress exception.


I2C.C++ API: Member List

  • CI2cAddress
telos::I2cApi::Cpp::CI2cAddress Member List

This is the complete list of members for telos::I2cApi::Cpp::CI2cAddress, including all inherited members.

CI2cAddress() | telos::I2cApi::Cpp::CI2cAddress |
CI2cAddress(uint16_t address, bool ten_bit_address) | telos::I2cApi::Cpp::CI2cAddress |
GENERAL_CALL | telos::I2cApi::Cpp::CI2cAddress | static
Get10BitAddresses() | telos::I2cApi::Cpp::CI2cAddress | static
Get7BitAddresses() | telos::I2cApi::Cpp::CI2cAddress | static
GetAddress() const | telos::I2cApi::Cpp::CI2cAddress |
GetAllAddresses() | telos::I2cApi::Cpp::CI2cAddress | static
IsTenBitAddress() const | telos::I2cApi::Cpp::CI2cAddress |
operator!=(const CI2cAddress &addr) const | telos::I2cApi::Cpp::CI2cAddress |
operator++() | telos::I2cApi::Cpp::CI2cAddress |
operator++(int) | telos::I2cApi::Cpp::CI2cAddress |
operator--() | telos::I2cApi::Cpp::CI2cAddress |
operator--(int) | telos::I2cApi::Cpp::CI2cAddress |
operator<(const CI2cAddress &addr) const | telos::I2cApi::Cpp::CI2cAddress |
operator<=(const CI2cAddress &addr) const | telos::I2cApi::Cpp::CI2cAddress |
operator==(const CI2cAddress &addr) const | telos::I2cApi::Cpp::CI2cAddress |
operator>(const CI2cAddress &addr) const | telos::I2cApi::Cpp::CI2cAddress |
operator>=(const CI2cAddress &addr) const | telos::I2cApi::Cpp::CI2cAddress |
PMBUS_ZONE_READ | telos::I2cApi::Cpp::CI2cAddress | static
PMBUS_ZONE_WRITE | telos::I2cApi::Cpp::CI2cAddress | static
SetAddress(uint16_t address, bool ten_bit_address) | telos::I2cApi::Cpp::CI2cAddress |
SMBUS_ALERT_RESPONSE | telos::I2cApi::Cpp::CI2cAddress | static
SMBUS_DEVICE_DEFAULT | telos::I2cApi::Cpp::CI2cAddress | static
SMBUS_HOST | telos::I2cApi::Cpp::CI2cAddress | static
VerifySMBAddress() const | telos::I2cApi::Cpp::CI2cAddress |


I2C.C++ API: telos::I2cApi::Cpp::CInputTestpins Class Reference

  • CInputTestpins
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CInputTestpins Class Reference

#include <CInputTestpins.h>

Public Member Functions

void | Enable ()
void | Disable ()
bool | IsEnabled () const
int | ReceiveMessages (std::vector< SInputTestpinsMessage > &msgs, int number_packets)
int | ReceiveMessages (std::vector< SInputTestpinsMessage > &msgs)

Protected Member Functions

CInputTestpins (CBoard *board)

Detailed Description

Some I2C interfaces like Tracii XL contains input testpins. This class can be used to log transitions of these input testpins.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the CTracer::GetInputTestpins() method.

Normally the following steps are necessary to use this class:

  1. Enable the logging functionality using Enable().
  2. Call CBoard::WaitForData() and ReceiveMessages() in a loop to get the log messages.
  3. Disable logging functionality using the Disable() method.
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
InputTestpinsExample.cpp.

Constructor & Destructor Documentation

CInputTestpins::CInputTestpins ( CBoard * board )
protected

Constructor.

Parameters
board pointer to CBoard object managing this object

Member Function Documentation

void CInputTestpins::Disable ( )

Disables the logging of the input testpins.

Examples:
InputTestpinsExample.cpp.
void CInputTestpins::Enable ( )

Enables the logging of the input testpins. Whenever one of the input testpins changes its status, the new status of all testpins and the timestamp of the transition get stored. This data can be read using ReceiveMessages().

Examples:
InputTestpinsExample.cpp.
bool CInputTestpins::IsEnabled ( ) const

Tests whether the logging of the input testpins is enabled.

Returns
enabled (true), disabled (false)
int CInputTestpins::ReceiveMessages | ( | std::vector< SInputTestpinsMessage > & | msgs,
 |  | int | number_packets
 | ) |  |

Returns up to "number_packets" messages describing transitions of the input testpins. This function will not wait until all requested messages are available. Instead this function will return immediately.

Parameters
msgs | read messages
number_packets | number of messages to be read
Returns
number of messages read (0..number_packets)
Examples:
InputTestpinsExample.cpp.
int CInputTestpins::ReceiveMessages ( std::vector< SInputTestpinsMessage > & msgs )

Returns messages describing transitions of the input testpins.

Parameters
msgs read messages
Returns
number of messages read


I2C.C++ API: Member List

  • CInputTestpins
telos::I2cApi::Cpp::CInputTestpins Member List

This is the complete list of members for telos::I2cApi::Cpp::CInputTestpins, including all inherited members.

CInputTestpins(CBoard *board) | telos::I2cApi::Cpp::CInputTestpins | protected
Disable() | telos::I2cApi::Cpp::CInputTestpins |
Enable() | telos::I2cApi::Cpp::CInputTestpins |
IsEnabled() const | telos::I2cApi::Cpp::CInputTestpins |
ReceiveMessages(std::vector< SInputTestpinsMessage > &msgs, int number_packets) | telos::I2cApi::Cpp::CInputTestpins |
ReceiveMessages(std::vector< SInputTestpinsMessage > &msgs) | telos::I2cApi::Cpp::CInputTestpins |


I2C.C++ API: telos::I2cApi::Cpp::CLanguage Class Reference

  • CLanguage
Static Public Member Functions | List of all members
telos::I2cApi::Cpp::CLanguage Class Reference

#include <CLanguage.h>

Static Public Member Functions

static const ELanguageId | GetLanguageId ()
Gets the current language ID. More...
static void | SetLanguageId (const ELanguageId lang=ENGLISH)
Sets the current language ID. Default value is ENGLISH. More...

Detailed Description

This class provides static methods to handle language settings for the I2C.C++ API.

Member Function Documentation

const ELanguageId CLanguage::GetLanguageId ( )
static

Gets the current language ID.

Returns
Language ID
void CLanguage::SetLanguageId ( const ELanguageId lang = ENGLISH )
static

Sets the current language ID.

Parameters
lang language ID


I2C.C++ API: Member List

  • CLanguage
telos::I2cApi::Cpp::CLanguage Member List

This is the complete list of members for telos::I2cApi::Cpp::CLanguage, including all inherited members.

GetLanguageId() | telos::I2cApi::Cpp::CLanguage | static
SetLanguageId(const ELanguageId lang=ENGLISH) | telos::I2cApi::Cpp::CLanguage | static


I2C.C++ API: telos::I2cApi::Cpp::CMaster Class Reference

  • CMaster
Public Types | Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CMaster Class Reference

#include <CMaster.h>

Public Types

typedef bool(* TransferDataStatusCallBackFunction) (uint32_t current_pos, uint32_t max_pos, void *private_data)

Public Member Functions

void | SetBitrate (uint32_t bitrate)
Sets the bitrate of the I2C bus. More...
uint32_t | GetBitrate () const
Returns the bitrate of the I2C bus. More...
void | SetBitrateHighspeed (uint32_t bitrate)
Sets the bitrate for the high speed mode of the I2C bus. More...
uint32_t | GetBitrateHighspeed () const
Returns the bitrate for the high speed mode of the I2C bus. More...
void | SetHighspeedMasterCode (uint8_t master_code)
Sets the high speed master code. More...
uint8_t | GetHighspeedMasterCode () const
Returns the high speed master code. More...
void | SetWatchdog (uint16_t timeout)
Configures the watchdog. More...
void | SetWatchdog (const std::chrono::duration< uint16_t > &timeout)
Configures the watchdog. More...
uint16_t | GetWatchdog () const
Returns the current configuration of the watchdog. More...
void | TransferData (CMasterMessage &msg)
Sends a master transmitter/receiver message. More...
void | TransferData (std::vector< CMasterMessage * > &msgs)
Sends master transmitter/receiver messages. More...
void | ScanAddresses (const CI2cAddress &start, const CI2cAddress &stop, int timeout, std::vector< CI2cAddress > &result)
Scans the I2C bus for slaves. More...
void | ScanAddresses (const CI2cAddress &start, const CI2cAddress &stop, const std::chrono::duration< int > &timeout, std::vector< CI2cAddress > &result)
Scans the I2C bus for slaves. More...
void | ScanAddresses (const std::chrono::duration< int > &timeout, std::vector< CI2cAddress > &result)
Scans the I2C bus for slaves. More...
uint32_t | AutoDetectTermination (const CI2cAddress &address)
Detects the minimal required bus termination. More...
uint32_t | AutoDetectTermination ()
Detects the minimal required bus termination. More...
void | SetTransferDataStatusCallback (TransferDataStatusCallBackFunction fct, void *private_data)
Registers a TransferData() status callback. More...

Protected Member Functions

CMaster (CBoard *board)
Constructor. More...

Detailed Description

This class emulates an I2C master transmitter/receiver.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the CBoard::GetMaster() method.

Normally the following steps are necessary:

  1. Create a data object:
    • Master transmitter transfer: create a CMasterMessageTx object.
    • Master receiver transfer: create a CMasterMessageRx object.
    • Combined mode transfer: create a std::vector<CMasterMessage*> object containing CMasterMessageTx and/or CMasterMessageRx objects.
  2. Pass the created object to the I2C.C++ API using TransferData().
  3. Evaluate the result of the transfer stored in the objects passed to TransferData().
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Warning
It is very important to compile the application with RTTI enabled.
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Member Typedef Documentation

typedef bool(* telos::I2cApi::Cpp::CMaster::TransferDataStatusCallBackFunction) (uint32_t current_pos, uint32_t max_pos, void *private_data)

Interface of callback functions, which can be registered using SetTransferDataStatusCallback(). The "current_pos" parameter contains the current position of the transfer (number of received ACKs), "max_pos" contains the number of bytes to be transmitted.

Parameters
current_pos | current position of transfer
max_pos | number of bytes to be transferred

Constructor & Destructor Documentation

CMaster::CMaster ( CBoard * board )
protected

Constructor.

Parameters
board pointer to CBoard object managing this object

Member Function Documentation

uint32_t CMaster::AutoDetectTermination ( const CI2cAddress & address )

Detects the minimal required bus termination for the current configuration of bitrate and high-speed bitrate.

Parameters
address I2C slave to be used for detection
Returns
termination [Ohm]
uint32_t CMaster::AutoDetectTermination ( )

Detects the minimal required bus termination for the current configuration of bitrate and high-speed bitrate.

Returns
termination [Ohm]
uint32_t CMaster::GetBitrate ( ) const

Returns the I2C bitrate (SCL) used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Returns
I2C bitrate [Hz]
uint32_t CMaster::GetBitrateHighspeed ( ) const

Returns the I2C bitrate (SCL) of the high speed mode used by the hardware, when the hardware generates the clock. The default bitrate is "0".

Returns
I2C high speed bitrate [Hz]
uint8_t CMaster::GetHighspeedMasterCode ( ) const

Returns the high speed mode master code.

Returns
master code (8..11)
uint16_t CMaster::GetWatchdog ( ) const

Returns the current timeout value of the watchdog.

Returns
timeout [s]
void CMaster::ScanAddresses | ( | const CI2cAddress & | start,
 |  | const CI2cAddress & | stop,
 |  | int | busy_timeout,
 |  | std::vector< CI2cAddress > & | result
 | ) |  |

Scans the I2C bus connected to the I2C interface for slaves. Therefor the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned in the specified container.

If the I2C bus is busy, this method tries to scan the I2C bus as long as the specified timeout has not expired.

Parameters
start | start of the address range to be scanned
stop | stop of the address range to be scanned
busy_timeout | timeout for bus busy [s]
result | found I2C slaves
void CMaster::ScanAddresses | ( | const CI2cAddress & | start,
 |  | const CI2cAddress & | stop,
 |  | const std::chrono::duration< int > & | busy_timeout,
 |  | std::vector< CI2cAddress > & | result
 | ) |  |

Scans the I2C bus connected to the I2C interface for slaves. Therefor the method tries to read one byte from each I2C address in the specified address range. The addresses of all found slaves are returned in the specified container.

If the I2C bus is busy, this method tries to scan the I2C bus as long as the specified timeout has not expired.

Parameters
start | start of the address range to be scanned
stop | stop of the address range to be scanned
busy_timeout | timeout for bus busy
result | found I2C slaves
void CMaster::ScanAddresses | ( | const std::chrono::duration< int > & | busy_timeout,
 |  | std::vector< CI2cAddress > & | result
 | ) |  |

Scans the I2C bus connected to the I2C interface for slaves. Therefor the method tries to read one byte from each I2C address. The addresses of all found slaves are returned in the specified container.

If the I2C bus is busy, this method tries to scan the I2C bus as long as the specified timeout has not expired.

Parameters
busy_timeout | timeout for bus busy
result | found I2C slaves
void CMaster::SetBitrate ( uint32_t bitrate )

Sets the I2C bitrate (SCL) used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Valid values for the bitrate can be found in the SHardwareInfo::master_sampling_rate variable.

The resulting bitrate depends on the I2C bus termination which has to be adapted to the current I2C bus setup. See the I2C bus specification for more details.

Parameters
bitrate I2C bitrate [Hz]
Examples:
MasterExample.cpp.
void CMaster::SetBitrateHighspeed ( uint32_t bitrate )

Sets the I2C bitrate (SCL) of the high speed mode used by the hardware, when the hardware generates the clock. To disable the high speed mode, set this value to "0". The default highspeed bitrate is "0".

If this value is not zero, the I2C interface will use the high speed mode to transfer the data to the slave. The high speed initialisation token on the I2C bus is sent using the bitrate specified using SetBitrate().

Valid values for the high speed bitrate can be found in the SHardwareInfo::master_sampling_rate_hs variable.

The resulting bitrate depends on the I2C bus termination which has to be adapted to the current I2C bus setup. See the I2C bus specification for more details.

Parameters
bitrate I2C high speed bitrate [Hz] or "0"
void CMaster::SetHighspeedMasterCode ( uint8_t master_code )

Sets the high speed mode master code.

Parameters
master_code master code (0x08, 0x0a, 0x0c, 0x0e)
void CMaster::SetTransferDataStatusCallback | ( | TransferDataStatusCallBackFunction | fct,
 |  | void * | private_data
 | ) |  |

Specifies a callback function, which is used to report the status of the currently running master transfer. TransferData() calls this callback function periodically.

To disable the callback function, set the pointer of the callback function to "0".

The caller can specify a private data pointer, which is passed to the callback function.

Parameters
fct | callback function or "0"
private_data | private data to be passed to callback function
void CMaster::SetWatchdog ( uint16_t timeout )

Enables/disables the watchdog of the master module.

If the watchdog expires during transferring data over the I2C bus using TransferData(), the function closes the I2C interface and throws a CExceptionMasterWatchdogTimeout exception.

Under normal conditions this will never happen. This method is especially interesting for an industrial environment.

The watchdog is disabled by default (timeout is "~0"). Timeout values unequal "~0" enable the watchdog. The smallest possible timeout is 5 seconds.

Parameters
timeout timeout [s]
void CMaster::SetWatchdog ( const std::chrono::duration< uint16_t > & timeout )

Enables/disables the watchdog of the master module.

If the watchdog expires during transferring data over the I2C bus using TransferData(), the function closes the I2C interface and throws a CExceptionMasterWatchdogTimeout exception.

Under normal conditions this will never happen. This method is especially interesting for an industrial environment.

The watchdog is disabled by default (timeout is "0"). Timeout values unequal "0" enable the watchdog. The smallest possible timeout is 5 seconds.

Parameters
timeout timeout
void CMaster::TransferData ( CMasterMessage & msg )

Sends the given master transmitter or master receiver message to the I2C bus.

The result of the transfer is stored in the same object.

Parameters
msg master transmitter or master receiver message
Examples:
MasterExample.cpp.
void CMaster::TransferData ( std::vector< CMasterMessage * > & msgs )

Sends the given list of master transmitter and master receiver messages as one message to the I2C bus. If the list contains more than one object, the I2C combined mode (repeated start) is used.

Parameters
msgs list of master transmitter/receiver objects


I2C.C++ API: Member List

  • CMaster
telos::I2cApi::Cpp::CMaster Member List

This is the complete list of members for telos::I2cApi::Cpp::CMaster, including all inherited members.

AutoDetectTermination(const CI2cAddress &address) | telos::I2cApi::Cpp::CMaster |
AutoDetectTermination() | telos::I2cApi::Cpp::CMaster |
CMaster(CBoard *board) | telos::I2cApi::Cpp::CMaster | protected
GetBitrate() const | telos::I2cApi::Cpp::CMaster |
GetBitrateHighspeed() const | telos::I2cApi::Cpp::CMaster |
GetHighspeedMasterCode() const | telos::I2cApi::Cpp::CMaster |
GetWatchdog() const | telos::I2cApi::Cpp::CMaster |
ScanAddresses(const CI2cAddress &start, const CI2cAddress &stop, int timeout, std::vector< CI2cAddress > &result) | telos::I2cApi::Cpp::CMaster |
ScanAddresses(const CI2cAddress &start, const CI2cAddress &stop, const std::chrono::duration< int > &timeout, std::vector< CI2cAddress > &result) | telos::I2cApi::Cpp::CMaster |
ScanAddresses(const std::chrono::duration< int > &timeout, std::vector< CI2cAddress > &result) | telos::I2cApi::Cpp::CMaster |
SetBitrate(uint32_t bitrate) | telos::I2cApi::Cpp::CMaster |
SetBitrateHighspeed(uint32_t bitrate) | telos::I2cApi::Cpp::CMaster |
SetHighspeedMasterCode(uint8_t master_code) | telos::I2cApi::Cpp::CMaster |
SetTransferDataStatusCallback(TransferDataStatusCallBackFunction fct, void *private_data) | telos::I2cApi::Cpp::CMaster |
SetWatchdog(uint16_t timeout) | telos::I2cApi::Cpp::CMaster |
SetWatchdog(const std::chrono::duration< uint16_t > &timeout) | telos::I2cApi::Cpp::CMaster |
TransferData(CMasterMessage &msg) | telos::I2cApi::Cpp::CMaster |
TransferData(std::vector< CMasterMessage * > &msgs) | telos::I2cApi::Cpp::CMaster |
TransferDataStatusCallBackFunction typedef | telos::I2cApi::Cpp::CMaster |


I2C.C++ API: telos::I2cApi::Cpp::CMasterMessage Class Reference

  • CMasterMessage
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CMasterMessage Class Referenceabstract

#include <CMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CMasterMessage:
telos::I2cApi::Cpp::CMasterMessageRx telos::I2cApi::Cpp::CMasterMessageTx

Public Member Functions

virtual | ~CMasterMessage ()
Destructor.
void | SetAddress (const CI2cAddress &i2c_address)
Sets the I2C address of the slave. More...
const CI2cAddress & | GetAddress () const
Returns the I2C address of the slave. More...
void | SetData (const std::vector< uint8_t > &data)
Sets the data to be transmitted. More...
template<class InputIterator >
void | SetData (InputIterator first, InputIterator last)
Sets the data to be transmitted. More...
std::vector< uint8_t > & | GetData ()
Returns the data to be transmitted/received. More...
const std::vector< uint8_t > & | GetData () const
Returns the data to be transmitted/received. More...
virtual uint32_t | GetBytesTransferred () const =0
Returns the number of bytes transmitted/received.
bool | GetWeakTermination () const
Gets the weak termination status. More...

Protected Member Functions

CMasterMessage ()
Constructor. More...
CMasterMessage (const CI2cAddress &i2c_address)
Constructor: sets the I2C address of the slave. More...
void SetWeakTermination (bool weak_termination)
Sets the weak termination status. More...

Detailed Description

Specifies the interface of a master message. This type is used to pass the data to the CMaster::TransferData() function.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CMasterMessage::CMasterMessage ( )
protected

Constructor

CMasterMessage::CMasterMessage ( const CI2cAddress & i2c_address )
protected

Constructor: sets the I2C address of the slave.

Parameters
i2c_address I2C address of the slave

Member Function Documentation

const CI2cAddress & CMasterMessage::GetAddress ( ) const

Returns the I2C address of the slave.

Returns
I2C address of the slave
vector< uint8_t > & CMasterMessage::GetData ( )

Returns the vector containing the data to be sent to the I2C slave as master transmitter or the data received from an I2C slave as master receiver.

Returns
data to be sent or data received
const vector< uint8_t > & CMasterMessage::GetData ( ) const

Returns the vector containing the data to be sent to the I2C slave as master transmitter or the data received from an I2C slave as master receiver.

Returns
data to be sent or data received
bool CMasterMessage::GetWeakTermination ( ) const

Returns the weak termination status. If the master has to adapt the configured bitrate, because the bus capacitance is too high or the bus termination too low, this value is true.

Returns
termination is ok (false), termination is weak (true)
void CMasterMessage::SetAddress ( const CI2cAddress & i2c_address )

Sets the I2C address of the slave.

Parameters
i2c_address I2C address of the slave
void CMasterMessage::SetData ( const std::vector< uint8_t > & data )

Sets the vector containing the data to be sent to the I2C slave as master transmitter or the data received from an I2C slave as master receiver.

Parameters
data data to be sent or data received
template<class InputIterator >
void telos::I2cApi::Cpp::CMasterMessage::SetData | ( | InputIterator | first,
 |  | InputIterator | last
 | ) |  |
inline

Sets the data to be sent to the I2C slave as master transmitter or the data received from an I2C slave as master receiver.

Parameters
first | first position
last | last position
void CMasterMessage::SetWeakTermination ( bool weak_termination )
protected

Sets the weak termination status. If the master has to adapt the configured bitrate, because the bus capacitance is too high or the bus termination too low, this value is true.

Parameters
weak_termination termination is ok (false), termination is weak (true)


I2C.C++ API: Member List

  • CMasterMessage
telos::I2cApi::Cpp::CMasterMessage Member List

This is the complete list of members for telos::I2cApi::Cpp::CMasterMessage, including all inherited members.

CMasterMessage() | telos::I2cApi::Cpp::CMasterMessage | protected
CMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CMasterMessage | protected
GetAddress() const | telos::I2cApi::Cpp::CMasterMessage |
GetBytesTransferred() const =0 | telos::I2cApi::Cpp::CMasterMessage | pure virtual
GetData() | telos::I2cApi::Cpp::CMasterMessage |
GetData() const | telos::I2cApi::Cpp::CMasterMessage |
GetWeakTermination() const | telos::I2cApi::Cpp::CMasterMessage |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CMasterMessage |
SetData(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CMasterMessage |
SetData(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CMasterMessage | inline
SetWeakTermination(bool weak_termination) | telos::I2cApi::Cpp::CMasterMessage | protected
~CMasterMessage() | telos::I2cApi::Cpp::CMasterMessage | inlinevirtual


I2C.C++ API: telos::I2cApi::Cpp::CMasterMessageRx Class Reference

  • CMasterMessageRx
Public Member Functions | Protected Types | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CMasterMessageRx Class Reference

#include <CMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CMasterMessageRx:
telos::I2cApi::Cpp::CMasterMessage

Public Member Functions

CMasterMessageRx ()
Constructor. More...
CMasterMessageRx (const CI2cAddress &i2c_address, uint32_t number_of_bytes)
Constructor: sets the I2C slave address and the number of bytes. More...
void | SetNumberOfBytes (uint32_t number_of_bytes)
Sets the number of bytes to be read. More...
uint32_t | GetNumberOfBytes () const
Returns the number of bytes to be read. More...
uint32_t | GetBytesTransferred () const
Returns the number of bytes received from the slave. More...
- Public Member Functions inherited from telos::I2cApi::Cpp::CMasterMessage
virtual | ~CMasterMessage ()
Destructor.
void | SetAddress (const CI2cAddress &i2c_address)
Sets the I2C address of the slave. More...
const CI2cAddress & | GetAddress () const
Returns the I2C address of the slave. More...
void | SetData (const std::vector< uint8_t > &data)
Sets the data to be transmitted. More...
template<class InputIterator >
void | SetData (InputIterator first, InputIterator last)
Sets the data to be transmitted. More...
std::vector< uint8_t > & | GetData ()
Returns the data to be transmitted/received. More...
const std::vector< uint8_t > & | GetData () const
Returns the data to be transmitted/received. More...
bool | GetWeakTermination () const
Gets the weak termination status. More...

Protected Types

enum EBlockMode { BLOCK_MODE_NONE, BLOCK_MODE_WITHOUT_PEC, BLOCK_MODE_WITH_PEC }
Enumeration to specify the block mode. More...

Protected Member Functions

void | SetBlockMode (EBlockMode mode)
Sets the block type. More...
EBlockMode | GetBlockMode () const
Returns the block type. More...
- Protected Member Functions inherited from telos::I2cApi::Cpp::CMasterMessage
CMasterMessage ()
Constructor. More...
CMasterMessage (const CI2cAddress &i2c_address)
Constructor: sets the I2C address of the slave. More...
void | SetWeakTermination (bool weak_termination)
Sets the weak termination status. More...

Detailed Description

Stores a master receiver message. This type is used to pass the data to the CMaster::TransferData() function.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Member Enumeration Documentation

enum telos::I2cApi::Cpp::CMasterMessageRx::EBlockMode
protected
Enumerator
BLOCK_MODE_NONE | standard I2C message
BLOCK_MODE_WITHOUT_PEC | SMB block read/block write read.
BLOCK_MODE_WITH_PEC | SMB block read/block write read (with PEC)

Constructor & Destructor Documentation

CMasterMessageRx::CMasterMessageRx ( )

Constructor: creates a valid but undefined and empty master receiver message.

CMasterMessageRx::CMasterMessageRx | ( | const CI2cAddress & | i2c_address,
 |  | uint32_t | number_of_bytes
 | ) |  |

Constructor: sets the I2C address of the slave and the number of bytes to be read from the slave.

Parameters
i2c_address | I2C address of the slave
number_of_bytes | number of bytes to be read

Member Function Documentation

CMasterMessageRx::EBlockMode CMasterMessageRx::GetBlockMode ( ) const
protected

Returns the block mode.

Returns
block mode
uint32_t CMasterMessageRx::GetBytesTransferred ( ) const
virtual

Returns how many of the data bytes have been received successfully from the slave. This value gets set by CMaster::TransferData(). If no error occurred, this value should be equal to GetNumberOfBytes().

Returns
number of bytes transferred

Implements telos::I2cApi::Cpp::CMasterMessage.

uint32_t CMasterMessageRx::GetNumberOfBytes ( ) const

Returns the number of bytes to be read from the I2C slave.

Returns
number of bytes to be read
void CMasterMessageRx::SetBlockMode ( EBlockMode mode )
protected

This method sets the block mode. The block mode is needed for SMBus block read and block write read messages. In these messages the slave specifies the message length in the first byte (with or without a PEC).

Parameters
mode block mode
void CMasterMessageRx::SetNumberOfBytes ( uint32_t number_of_bytes )

Sets the number of bytes to be read from the I2C slave.

Parameters
number_of_bytes number of bytes to be read


I2C.C++ API: Member List

  • CMasterMessageRx
telos::I2cApi::Cpp::CMasterMessageRx Member List

This is the complete list of members for telos::I2cApi::Cpp::CMasterMessageRx, including all inherited members.

BLOCK_MODE_NONE enum value | telos::I2cApi::Cpp::CMasterMessageRx | protected
BLOCK_MODE_WITH_PEC enum value | telos::I2cApi::Cpp::CMasterMessageRx | protected
BLOCK_MODE_WITHOUT_PEC enum value | telos::I2cApi::Cpp::CMasterMessageRx | protected
CMasterMessage() | telos::I2cApi::Cpp::CMasterMessage | protected
CMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CMasterMessage | protected
CMasterMessageRx() | telos::I2cApi::Cpp::CMasterMessageRx |
CMasterMessageRx(const CI2cAddress &i2c_address, uint32_t number_of_bytes) | telos::I2cApi::Cpp::CMasterMessageRx |
EBlockMode enum name | telos::I2cApi::Cpp::CMasterMessageRx | protected
GetAddress() const | telos::I2cApi::Cpp::CMasterMessage |
GetBlockMode() const | telos::I2cApi::Cpp::CMasterMessageRx | protected
GetBytesTransferred() const | telos::I2cApi::Cpp::CMasterMessageRx | virtual
GetData() | telos::I2cApi::Cpp::CMasterMessage |
GetData() const | telos::I2cApi::Cpp::CMasterMessage |
GetNumberOfBytes() const | telos::I2cApi::Cpp::CMasterMessageRx |
GetWeakTermination() const | telos::I2cApi::Cpp::CMasterMessage |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CMasterMessage |
SetBlockMode(EBlockMode mode) | telos::I2cApi::Cpp::CMasterMessageRx | protected
SetData(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CMasterMessage |
SetData(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CMasterMessage | inline
SetNumberOfBytes(uint32_t number_of_bytes) | telos::I2cApi::Cpp::CMasterMessageRx |
SetWeakTermination(bool weak_termination) | telos::I2cApi::Cpp::CMasterMessage | protected
~CMasterMessage() | telos::I2cApi::Cpp::CMasterMessage | inlinevirtual


I2C.C++ API: telos::I2cApi::Cpp::CMasterMessageTx Class Reference

  • CMasterMessageTx
Public Member Functions | List of all members
telos::I2cApi::Cpp::CMasterMessageTx Class Reference

#include <CMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CMasterMessageTx:
telos::I2cApi::Cpp::CMasterMessage

Public Member Functions

CMasterMessageTx ()
Constructor. More...
CMasterMessageTx (const CI2cAddress &i2c_address, const std::vector< uint8_t > &data)
Constructor: sets the I2C slave address and the data. More...
template<class InputIterator >
CMasterMessageTx (const CI2cAddress &i2c_address, InputIterator data_first, InputIterator data_last)
Constructor: sets the I2C slave address and the data. More...
uint32_t | GetBytesTransferred () const
Returns the number of bytes transmitted. More...
void | SetBytesTransferred (uint32_t bytes_transferred)
Sets the number of bytes transmitted. More...
- Public Member Functions inherited from telos::I2cApi::Cpp::CMasterMessage
virtual | ~CMasterMessage ()
Destructor.
void | SetAddress (const CI2cAddress &i2c_address)
Sets the I2C address of the slave. More...
const CI2cAddress & | GetAddress () const
Returns the I2C address of the slave. More...
void | SetData (const std::vector< uint8_t > &data)
Sets the data to be transmitted. More...
template<class InputIterator >
void | SetData (InputIterator first, InputIterator last)
Sets the data to be transmitted. More...
std::vector< uint8_t > & | GetData ()
Returns the data to be transmitted/received. More...
const std::vector< uint8_t > & | GetData () const
Returns the data to be transmitted/received. More...
bool | GetWeakTermination () const
Gets the weak termination status. More...

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CMasterMessage
CMasterMessage ()
Constructor. More...
CMasterMessage (const CI2cAddress &i2c_address)
Constructor: sets the I2C address of the slave. More...
void SetWeakTermination (bool weak_termination)
Sets the weak termination status. More...

Detailed Description

Stores a master transmitter message. This type is used to pass the data to the CMaster::TransferData() function.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CMasterMessageTx::CMasterMessageTx ( )

Constructor: creates a valid but undefinied and empty master transmitter message.

CMasterMessageTx::CMasterMessageTx | ( | const CI2cAddress & | i2c_address,
 |  | const std::vector< uint8_t > & | data
 | ) |  |

Constructor: sets the I2C address of the slave and the data to be sent to this slave.

Parameters
i2c_address | I2C address of the slave
data | data to be sent
template<class InputIterator >
telos::I2cApi::Cpp::CMasterMessageTx::CMasterMessageTx | ( | const CI2cAddress & | i2c_address,
 |  | InputIterator | data_first,
 |  | InputIterator | data_last
 | ) |  |
inline

Constructor: sets the I2C address of the slave and the data to be sent to this slave.

Parameters
i2c_address | I2C address of the slave
data_first | first position of data to be sent
data_last | last position of data to be sent

Member Function Documentation

uint32_t CMasterMessageTx::GetBytesTransferred ( ) const
virtual

Returns how many of the data bytes have been transmitted successfully to the slave. This value gets set by CMaster::TransferData(). If the complete message has been transmitted successfully, the returned value should be equal to GetData().size().

Returns
number of bytes transferred

Implements telos::I2cApi::Cpp::CMasterMessage.

Examples:
MasterExample.cpp.
void CMasterMessageTx::SetBytesTransferred ( uint32_t bytes_transferred )

Sets how many of the data bytes have been transmitted successfully to the slave. This method is used by CMaster::TransferData().

Parameters
bytes_transferred number of bytes transferred


I2C.C++ API: Member List

  • CMasterMessageTx
telos::I2cApi::Cpp::CMasterMessageTx Member List

This is the complete list of members for telos::I2cApi::Cpp::CMasterMessageTx, including all inherited members.

CMasterMessage() | telos::I2cApi::Cpp::CMasterMessage | protected
CMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CMasterMessage | protected
CMasterMessageTx() | telos::I2cApi::Cpp::CMasterMessageTx |
CMasterMessageTx(const CI2cAddress &i2c_address, const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CMasterMessageTx |
CMasterMessageTx(const CI2cAddress &i2c_address, InputIterator data_first, InputIterator data_last) | telos::I2cApi::Cpp::CMasterMessageTx | inline
GetAddress() const | telos::I2cApi::Cpp::CMasterMessage |
GetBytesTransferred() const | telos::I2cApi::Cpp::CMasterMessageTx | virtual
GetData() | telos::I2cApi::Cpp::CMasterMessage |
GetData() const | telos::I2cApi::Cpp::CMasterMessage |
GetWeakTermination() const | telos::I2cApi::Cpp::CMasterMessage |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CMasterMessage |
SetBytesTransferred(uint32_t bytes_transferred) | telos::I2cApi::Cpp::CMasterMessageTx |
SetData(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CMasterMessage |
SetData(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CMasterMessage | inline
SetWeakTermination(bool weak_termination) | telos::I2cApi::Cpp::CMasterMessage | protected
~CMasterMessage() | telos::I2cApi::Cpp::CMasterMessage | inlinevirtual


I2C.C++ API: telos::I2cApi::Cpp::CNegativeTester Class Reference

  • CNegativeTester
Classes | Public Types | Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CNegativeTester Class Reference

#include <CNegativeTester.h>

Classes

struct | SLevelsMaster
struct | SLevelsSlave
struct | SMessagesMaster
struct | SMessagesSlave

Public Types

enum | EResult { RESULT_OK, RESULT_ARBITRATION_LOST, RESULT_NACK }
enum | EStopTrigger { STOP_TRIGGER_NONE, STOP_TRIGGER_ARBITRATION_LOST, STOP_TRIGGER_ARBITRATION_NOT_LOST }
enum | ENackBehaviour { NACK_RELEASE_SCL_SDA, NACK_GENERATE_STOP, NACK_RESTART }
typedef void(* | CallBackFunction) (CNegativeTester *tester, EResult result, void *private_data)
typedef std::vector< SLevelsSlave > | SMessageSlave
typedef std::chrono::duration< uint32_t, std::ratio< 1, 25000000 > > | Duration

Public Member Functions

void | StartMaster (const SMessagesMaster &msgs)
void | StartSlave (const SMessagesSlave &msgs)
void | Stop (bool stop_immediately)
bool | IsRunning () const
void | SetCompletionCallback (CallBackFunction fct, void *private_data)

Static Public Member Functions

static uint32_t | ConvertNanosecondsToTicks (uint64_t nanoseconds)
static uint64_t | ConvertTicksToNanoseconds (uint32_t ticks)

Static Public Attributes

static const uint32_t TIMEBASE = 75000000 / 3
timebase: 25 MHz

Protected Member Functions

CNegativeTester (CBoard *board)
Constructor. More...

Detailed Description

This class provides a negative tester.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the CBoard::GetNegativeTester() method.

Normally the following steps are necessary:

  1. Create a SMessageMaster or SMessageSlave object. This can be done manually or using the high-level interfaces CNegativeTesterMaster or CNegativeTesterSlave.
  2. Register a completion callback function using SetCompletionCallback().
  3. Pass this object to the API and start the negative tester using StartMaster() or StartSlave().

The timebase of the times used by the negative tester is specified in TIMEBASE.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
NegativeTesterExample.cpp.

Member Typedef Documentation

typedef void(* telos::I2cApi::Cpp::CNegativeTester::CallBackFunction) (CNegativeTester *tester, EResult result, void *private_data)

Interface of callback functions, which can be registered using SetCompletionCallback().

typedef std::chrono::duration<uint32_t, std::ratio<1, 25000000> > telos::I2cApi::Cpp::CNegativeTester::Duration

Instantiation of duration to represent the ticks used by the Negative Tester.

typedef std::vector<SLevelsSlave> telos::I2cApi::Cpp::CNegativeTester::SMessageSlave

Contains the SLevelsSlave objects for one I2C submessage (from the START condition to the next STOP or REPEATED START condition).

Member Enumeration Documentation

enum telos::I2cApi::Cpp::CNegativeTester::ENackBehaviour

Enumeration to specify the behaviour after receiving a NACK on the I2C bus.

Enumerator
NACK_RELEASE_SCL_SDA | no action, release SCL and SDA
NACK_GENERATE_STOP | generate a STOP condition with static timing (default value)
NACK_RESTART | release SCL and SDA and restart the negative tester script
enum telos::I2cApi::Cpp::CNegativeTester::EResult

Enumeration to specify the result when the program of the negative tester has been finished.

Enumerator
RESULT_OK | no errors
RESULT_ARBITRATION_LOST | arbitration lost
RESULT_NACK | received NACK from slave
enum telos::I2cApi::Cpp::CNegativeTester::EStopTrigger

Enumeration to specify trigger, which can stop the negative tester.

Enumerator
STOP_TRIGGER_NONE | nothing stops the negative tester
STOP_TRIGGER_ARBITRATION_LOST | the negative tester stops when loosing the arbitration
STOP_TRIGGER_ARBITRATION_NOT_LOST | the negative tester stops when not loosing the arbitration

Constructor & Destructor Documentation

CNegativeTester::CNegativeTester ( CBoard * board )
protected

Constructor.

Parameters
board pointer to CBoard object managing this object

Member Function Documentation

uint32_t CNegativeTester::ConvertNanosecondsToTicks ( uint64_t nanoseconds )
static

Converts a time in nanoseconds to the ticks used by this class.

Parameters
nanoseconds time [ns]
Returns
ticks
uint64_t CNegativeTester::ConvertTicksToNanoseconds ( uint32_t ticks )
static

Converts the ticks used by this class to a time in nanoseconds.

Parameters
ticks ticks
Returns
time [ns]
Examples:
NegativeTesterExample.cpp.
bool CNegativeTester::IsRunning ( ) const

Returns whether the negative tester is currently running.

Returns
running (true), not running (false)
void CNegativeTester::SetCompletionCallback | ( | CallBackFunction | fct,
 |  | void * | private_data
 | ) |  |

Registers a callback function, which gets called when the negative testing is going from the running to the idle state.

Parameters
fct | callback function to be called
private_data | private data to be passed to the callback function
Examples:
NegativeTesterExample.cpp.
void CNegativeTester::StartMaster ( const SMessagesMaster & msgs )

Loads the given master messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like CNegativeTesterMaster.

While the negative tester is running, IsRunning() returns "true".

Parameters
msgs messages to be sent
Examples:
NegativeTesterExample.cpp.
void CNegativeTester::StartSlave ( const SMessagesSlave & msgs )

Loads the given slave messages into the I2C interface and starts the negative tester. The transitions can be created manually or using a class like CNegativeTesterSlave.

While the negative tester is running, IsRunning() returns "true".

Parameters
msgs messages to be sent
void CNegativeTester::Stop ( bool stop_immediately )

Stops the negative tester.

If "stop_immediately" is set to "true", the negative tester stops immediately. Afterwards the I2C bus and its slave can be in an undefined state.

If it is set to "false", the negative tester stops after the current iteration of the image. This is only useful, if the the image gets executed in loop mode

Parameters
stop_immediately stop immediately


I2C.C++ API: Member List

  • CNegativeTester
telos::I2cApi::Cpp::CNegativeTester Member List

This is the complete list of members for telos::I2cApi::Cpp::CNegativeTester, including all inherited members.

CallBackFunction typedef | telos::I2cApi::Cpp::CNegativeTester |
CNegativeTester(CBoard *board) | telos::I2cApi::Cpp::CNegativeTester | protected
ConvertNanosecondsToTicks(uint64_t nanoseconds) | telos::I2cApi::Cpp::CNegativeTester | static
ConvertTicksToNanoseconds(uint32_t ticks) | telos::I2cApi::Cpp::CNegativeTester | static
Duration typedef | telos::I2cApi::Cpp::CNegativeTester |
ENackBehaviour enum name | telos::I2cApi::Cpp::CNegativeTester |
EResult enum name | telos::I2cApi::Cpp::CNegativeTester |
EStopTrigger enum name | telos::I2cApi::Cpp::CNegativeTester |
IsRunning() const | telos::I2cApi::Cpp::CNegativeTester |
NACK_GENERATE_STOP enum value | telos::I2cApi::Cpp::CNegativeTester |
NACK_RELEASE_SCL_SDA enum value | telos::I2cApi::Cpp::CNegativeTester |
NACK_RESTART enum value | telos::I2cApi::Cpp::CNegativeTester |
RESULT_ARBITRATION_LOST enum value | telos::I2cApi::Cpp::CNegativeTester |
RESULT_NACK enum value | telos::I2cApi::Cpp::CNegativeTester |
RESULT_OK enum value | telos::I2cApi::Cpp::CNegativeTester |
SetCompletionCallback(CallBackFunction fct, void *private_data) | telos::I2cApi::Cpp::CNegativeTester |
SMessageSlave typedef | telos::I2cApi::Cpp::CNegativeTester |
StartMaster(const SMessagesMaster &msgs) | telos::I2cApi::Cpp::CNegativeTester |
StartSlave(const SMessagesSlave &msgs) | telos::I2cApi::Cpp::CNegativeTester |
Stop(bool stop_immediately) | telos::I2cApi::Cpp::CNegativeTester |
STOP_TRIGGER_ARBITRATION_LOST enum value | telos::I2cApi::Cpp::CNegativeTester |
STOP_TRIGGER_ARBITRATION_NOT_LOST enum value | telos::I2cApi::Cpp::CNegativeTester |
STOP_TRIGGER_NONE enum value | telos::I2cApi::Cpp::CNegativeTester |
TIMEBASE | telos::I2cApi::Cpp::CNegativeTester | static


I2C.C++ API: telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster Struct Reference

  • CNegativeTester
  • SLevelsMaster
Public Member Functions | Public Attributes | List of all members
telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster Struct Reference

#include <CNegativeTester.h>

Public Member Functions

SLevelsMaster ()
constructor

Public Attributes

bool | scl
level of the SCL line: high (true), low (false)
bool | sda
level of the SDA line: high (true), low (false)
bool | testpin1
level of the testpin1 line: high (true), low (false)
bool | testpin2
level of the testpin1 line: high (true), low (false)
uint32_t | time
time to wait before executing next transition (see CNegativeTester::TIMEBASE for the timebase)
EStopTrigger stop_trigger
specifies the condition which can stop the negative tester
bool | ignore_stretching
ignore clock (SCL) stretching
bool | drive_sda
SDA line is driven by: master (true), slave (slave)
bool | enable_high_speed_current_source
enables high-speed mode current source

Detailed Description

Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the master mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next SLevelsMaster packet.


I2C.C++ API: Member List

  • CNegativeTester
  • SLevelsMaster
telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster Member List

This is the complete list of members for telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster, including all inherited members.

drive_sda | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
enable_high_speed_current_source | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
ignore_stretching | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
scl | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
sda | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
SLevelsMaster() | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster | inline
stop_trigger | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
testpin1 | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
testpin2 | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |
time | telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster |


I2C.C++ API: telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave Struct Reference

  • CNegativeTester
  • SLevelsSlave
Public Attributes | List of all members
telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave Struct Reference

#include <CNegativeTester.h>

Public Attributes

bool | scl
level of the SCL line: high (true), low (false)
bool | sda
level of the SDA line: high (true), low (false)
bool | testpin1
level of the testpin1 line: high (true), low (false)
bool | testpin2
level of the testpin1 line: high (true), low (false)
uint32_t | time
time to wait before executing next transition (see CNegativeTester::TIMEBASE for the timebase)
bool | drive_sda
SDA line is driven by: slave (true), master (slave)

Detailed Description

Contains the levels of SCL, SDA, testpin 1, and testpin 2 to be set in the slave mode. After writing these levels to the I2C bus, the tester waits the specified amount of time before processing the next SLevelsSlave packet.


I2C.C++ API: Member List

  • CNegativeTester
  • SLevelsSlave
telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave Member List

This is the complete list of members for telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave, including all inherited members.

drive_sda | telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
scl | telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
sda | telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
testpin1 | telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
testpin2 | telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
time | telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave


I2C.C++ API: telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster Struct Reference

  • CNegativeTester
  • SMessagesMaster
Public Member Functions | Public Attributes | List of all members
telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster Struct Reference

#include <CNegativeTester.h>

Public Member Functions

std::string GetAsVhd () const
Gets the messages as VHDL stimuli (VHD). More...

Public Attributes

std::vector< SLevelsMaster > | levels
levels to be sent to the I2C bus
uint16_t | loop_cnt
how often the levels get written to the I2C bus (0x400: infinite)
ENackBehaviour nack_behaviour
behaviour of the negative tester after receiving a NACK

Detailed Description

Contains all informations needed by the negative tester to work in master mode.

Member Function Documentation

string CNegativeTester::SMessagesMaster::GetAsVhd ( ) const

Gets the messages as VHDL stimuli (VHD).

Returns
VHDL stimuli


I2C.C++ API: Member List

  • CNegativeTester
  • SMessagesMaster
telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster Member List

This is the complete list of members for telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster, including all inherited members.

GetAsVhd() const | telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
levels | telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
loop_cnt | telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
nack_behaviour | telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster


I2C.C++ API: telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave Struct Reference

  • CNegativeTester
  • SMessagesSlave
Public Attributes | List of all members
telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave Struct Reference

#include <CNegativeTester.h>

Public Attributes

std::vector< SMessageSlave > | msgs
submessages to be sent to the I2C bus
bool | restart_after_nack_or_stop
jump to the beginning of the first submessage after receiving a NACK or STOP?
bool | loop
loop mode?
uint8_t | slave_addr
I2C address and R/W bit of the emulated slave (8 bit format)
uint8_t | slave_addr_dc
don't care mask for slave_addr

Detailed Description

Contains all informations needed by the negative tester to work in slave mode.


I2C.C++ API: Member List

  • CNegativeTester
  • SMessagesSlave
telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave Member List

This is the complete list of members for telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave, including all inherited members.

loop | telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
msgs | telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
restart_after_nack_or_stop | telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
slave_addr | telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
slave_addr_dc | telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave


I2C.C++ API: telos::I2cApi::Cpp::CNegativeTesterMaster Class Reference

  • CNegativeTesterMaster
Public Member Functions | List of all members
telos::I2cApi::Cpp::CNegativeTesterMaster Class Reference

#include <CNegativeTesterMaster.h>

Public Member Functions

CNegativeTesterMaster ()
void | SetBitrate (uint32_t bitrate)
uint32_t | GetBitrate () const
void | SetBitrateHighSpeed (uint32_t bitrate)
uint32_t | GetBitrateHighSpeed () const
uint32_t | GetTimeLowBeforeHigh () const
void | SetTimeLowBeforeHigh (uint32_t time)
uint32_t | GetTimeLowAfterHigh () const
void | SetTimeLowAfterHigh (uint32_t time)
uint32_t | GetTimeHigh () const
void | SetTimeHigh (uint32_t time)
uint32_t | GetTimeBuf () const
void | SetTimeBuf (uint32_t time)
uint32_t | GetTimeSuSta () const
void | SetTimeSuSta (uint32_t time)
uint32_t | GetTimeHdSta () const
void | SetTimeHdSta (uint32_t time)
uint32_t | GetTimeSuSto () const
void | SetTimeSuSto (uint32_t time)
uint32_t | GetTimeSp () const
void | SetTimeSp (uint32_t time)
void | SetTimeLowBeforeHigh (const CNegativeTester::Duration &time)
void | SetTimeLowAfterHigh (const CNegativeTester::Duration &time)
void | SetTimeHigh (const CNegativeTester::Duration &time)
void | SetTimeBuf (const CNegativeTester::Duration &time)
void | SetTimeSuSta (const CNegativeTester::Duration &time)
void | SetTimeHdSta (const CNegativeTester::Duration &time)
void | SetTimeSuSto (const CNegativeTester::Duration &time)
void | SetTimeSp (const CNegativeTester::Duration &time)
uint32_t | GetTimeHighSpeedLowBeforeHigh () const
void | SetTimeHighSpeedLowBeforeHigh (uint32_t time)
uint32_t | GetTimeHighSpeedLowAfterHigh () const
void | SetTimeHighSpeedLowAfterHigh (uint32_t time)
uint32_t | GetTimeHighSpeedHigh () const
void | SetTimeHighSpeedHigh (uint32_t time)
uint32_t | GetTimeHighSpeedSuSta () const
void | SetTimeHighSpeedSuSta (uint32_t time)
uint32_t | GetTimeHighSpeedHdSta () const
void | SetTimeHighSpeedHdSta (uint32_t time)
uint32_t | GetTimeHighSpeedSuSto () const
void | SetTimeHighSpeedSuSto (uint32_t time)
void | SetTimeHighSpeedLowBeforeHigh (const CNegativeTester::Duration &time)
void | SetTimeHighSpeedLowAfterHigh (const CNegativeTester::Duration &time)
void | SetTimeHighSpeedHigh (const CNegativeTester::Duration &time)
void | SetTimeHighSpeedSuSta (const CNegativeTester::Duration &time)
void | SetTimeHighSpeedHdSta (const CNegativeTester::Duration &time)
void | SetTimeHighSpeedSuSto (const CNegativeTester::Duration &time)
void | SetIgnoreStretching (bool stretching)
bool | GetIgnoreStretching () const
void | SetStopAtArbitrationLost (bool stop)
bool | GetStopAtArbitrationLost () const
void | SetLoopCount (uint16_t cnt)
uint16_t | GetLoopCount () const
void | SetNackBehaviour (CNegativeTester::ENackBehaviour behaviour)
CNegativeTester::ENackBehaviour | GetNackBehaviour () const
void | SetCreateSpikes (bool enabled)
bool | GetCreateSpikes () const
void | SetHighSpeedToken (uint8_t bitrate)
uint8_t | GetHighSpeedToken () const
void | Clear ()
void | SetTestpin1 (bool level)
bool | GetTestpin1 () const
void | SetTestpin2 (bool level)
bool | GetTestpin2 () const
void | SendStart ()
void | SendRepeatedStart ()
void | SendStop ()
void | SendRepeatedStartHighSpeed ()
void | SendStopHighSpeed ()
void | SendBit (bool data)
void | SendByte (uint8_t data)
void | SendAckBit ()
void | SendNackBit ()
void | SendBitHighSpeed (bool data, bool enable_current_source)
void | SendByteHighSpeed (uint8_t data)
void | SendAckBitHighSpeed ()
void | SendNackBitHighSpeed ()
void | ReceiveBit ()
void | ReceiveByte ()
void | ReceiveAckBit (bool ignore_nack)
void | ReceiveBitHighSpeed (bool enable_current_source)
void | ReceiveByteHighSpeed ()
void | ReceiveAckBitHighSpeed (bool ignore_nack)
void | SendTransmitterWithoutStop (bool repeated_start, const CI2cAddress &addr, const std::vector< uint8_t > &data)
void | SendReceiverWithoutStop (bool repeated_start, const CI2cAddress &addr, uint32_t cnt)
void | SendHighSpeedToken ()
void | SendTransmitterWithoutStopHighSpeed (bool repeated_start, const CI2cAddress &addr, const std::vector< uint8_t > &data)
void | SendReceiverWithoutStopHighSpeed (bool repeated_start, const CI2cAddress &addr, uint32_t cnt)
void | SendTransmitter (const CI2cAddress &addr, const std::vector< uint8_t > &data)
void | SendReceiver (const CI2cAddress &addr, uint32_t cnt)
void | SendTransmitterReceiver (const CI2cAddress &addr, const std::vector< uint8_t > &tx_data, uint32_t rx_cnt)
void | SendTransmitterHighSpeed (const CI2cAddress &addr, const std::vector< uint8_t > &data)
void | SendReceiverHighSpeed (const CI2cAddress &addr, uint32_t cnt)
void | SendTransmitterReceiverHighSpeed (const CI2cAddress &addr, const std::vector< uint8_t > &tx_data, uint32_t rx_cnt)
void | SendSmbMasterMessage (const CSmbMasterMessage &msg)
void | SendPmbusMasterMessage (const CPmbusMasterMessage &msg)
void | SendPmbusMasterMessage (const CPmbusMasterMessageGroupCmd &msg)
void | AddMessage (const CNegativeTester::SLevelsMaster &level)
void | Delay (uint32_t time)
void | Delay (const CNegativeTester::Duration &time)
const CNegativeTester::SMessagesMaster & | GetMessages () const

Detailed Description

This class offers a high-level master interface for the negative tester implemented in the CNegativeTester class.

Normally the following steps are necessary:

  1. Configure the interface:
    • Configure the bitrate using SetBitrate().
    • Configure the behaviour regarding clock stretching using SetIgnoreStretching().
    • Configure the behaviour regarding arbitration using SetStopAtArbitrationLost().
    • Configure the loop counter using SetLoopCount().
    • Configure the NACK behaviour using SetNackBehaviour().
  2. Send conditions, bits, bytes, or even complete I2C messages using the "Send" and "Receive" methods or add your own transitions using AddMessage().
  3. Create an object containing all transitions created by step two using GetMessages().
  4. Pass this object to the CNegativeTester class.

START Condition
A START condition gets transmitted like this:

SDA  High    *-----
     Low           *-----*-----
SCL  High    *-----*-----
     Low                 *-----
             |--1--|--2--|--3--|
  1. t_BUF/2 as specified by SetTimeBuf().
  2. t_HD;STA as specified by SetTimeHdSta().
  3. t_LOW after t_HIGH as specified by SetTimeLowAfterHigh().

Repeated START Condition
A Repeated START condition gets transmitted like this:

SDA  High    *-----*-----
     Low                 *-----*-----
SCL  High          *-----*-----
     Low     *-----            *-----
             |--1--|--2--|--3--|--4--|
  1. t_LOW before t_HIGH as specified by SetTimeLowBeforeHigh().
  2. t_SU;STA as specified by SetTimeSuSta().
  3. t_HD;STA as specified by SetTimeHdSta().
  4. t_LOW after t_HIGH as specified by SetTimeLowAfterHigh().

STOP Condition
A STOP condition gets transmitted like this:

SDA  High                *-----
     Low     *-----*-----
SCL  High          *-----*-----
     Low     *-----
             |--1--|--2--|--3--|
  1. t_LOW before t_HIGH as specified by SetTimeLowBeforeHigh().
  2. t_SU;STO as specified by SetTimeSuSto().
  3. t_BUF/2 as specified by SetTimeBuf().

Data Bits
A data bit gets transmitted like this:

SDA  High    *-----*-----*-----           SDA  High
     Low                                       Low     *-----*-----*-----
SCL  High          *-----                 SCL  High          *-----
     Low     *-----      *-----                Low     *-----      *-----
             |--1--|--2--|--3--|                       |--1--|--2--|--3--|
  1. t_LOW before t_HIGH as specified by SetTimeLowBeforeHigh().
  2. t_HIGH as specified by SetTimeHigh().
  3. t_LOW after t_HIGH as specified by SetTimeLowAfterHigh().

The timebase of the times used by the negative tester is specified in CNegativeTester::TIMEBASE.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
NegativeTesterExample.cpp.

Constructor & Destructor Documentation

CNegativeTesterMaster::CNegativeTesterMaster ( )

Constructor.

Member Function Documentation

void CNegativeTesterMaster::AddMessage ( const CNegativeTester::SLevelsMaster & level )

Adds a self defined CNegativeTester::SLevelsMaster instance to the message queue.

Parameters
level Instance of CNegativeTester::SLevelsMaster
void CNegativeTesterMaster::Clear ( )

Clears the stored transitions and messages.

void CNegativeTesterMaster::Delay ( uint32_t time )

Waits for the specified time. During this time the levels of the lines will not be changed. This can be used e.g. to add a gap between two transfers.

Parameters
time time to delay
void CNegativeTesterMaster::Delay ( const CNegativeTester::Duration & time )

Waits for the specified time. During this time the levels of the lines will not be changed. This can be used e.g. to add a gap between two transfers.

Parameters
time time to delay
uint32_t CNegativeTesterMaster::GetBitrate ( ) const

Returns the I2C bitrate (SCL) used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Returns
I2C bitrate [Hz]
Examples:
NegativeTesterExample.cpp.
uint32_t CNegativeTesterMaster::GetBitrateHighSpeed ( ) const

Returns the I2C high-speed bitrate (SCL) used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Returns
I2C high-speed bitrate [Hz]
bool CNegativeTesterMaster::GetCreateSpikes ( ) const

Returns whether spikes with a length of t_SP should be added to the I2C messages.

Returns
do not add spikes (false), add spikes (true)
uint8_t CNegativeTesterMaster::GetHighSpeedToken ( ) const

Returns the high-speed mode token.

Returns
high-speed mode token (8..11)
bool CNegativeTesterMaster::GetIgnoreStretching ( ) const

The detection of clock stretching in the hardware can be disabled. This methods returns the current configuration of clock stretching detection.

Returns
stretching detected (false), ignore stretching (true)
uint16_t CNegativeTesterMaster::GetLoopCount ( ) const

The loop count specifies how often the negative tester sends the SMessagesMaster data to the I2C bus. This method returns the loop count currently used.

The value 1024 stands for a infinite loop.

Returns
used loop count
const CNegativeTester::SMessagesMaster & CNegativeTesterMaster::GetMessages ( ) const

Returns the messages, which have been created using the "Send" and "Receive" methods of this class. This data can be passed to a CNegativeTester instance.

To reset the messages use the ::Clear() method.

Returns
messages
Examples:
NegativeTesterExample.cpp.
CNegativeTester::ENackBehaviour CNegativeTesterMaster::GetNackBehaviour ( ) const

Returns the configuration of the NACK behaviour.

Returns
NACK behaviour
bool CNegativeTesterMaster::GetStopAtArbitrationLost ( ) const

Gets whether the negative tester stops after the detection of arbitration lost.

Returns
stop after arbitration lost (true), continue after arbitration lost (false)
bool CNegativeTesterMaster::GetTestpin1 ( ) const

Returns the state of testpin 1.

Returns
high (true), low (false)
bool CNegativeTesterMaster::GetTestpin2 ( ) const

Returns the state of testpin 2.

Returns
high (true), low (false)
uint32_t CNegativeTesterMaster::GetTimeBuf ( ) const

Gets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification.

Returns
t_BUF time
Examples:
NegativeTesterExample.cpp.
uint32_t CNegativeTesterMaster::GetTimeHdSta ( ) const

Gets the "hold time START condition" (t_HD;STA) as described in the I2C specification.

Returns
t_HD;STA time
Examples:
NegativeTesterExample.cpp.
uint32_t CNegativeTesterMaster::GetTimeHigh ( ) const

Gets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification.

Returns
t_HIGH time
Examples:
NegativeTesterExample.cpp.
uint32_t CNegativeTesterMaster::GetTimeHighSpeedHdSta ( ) const

Gets the "hold time START condition" (t_HD;STA) as described in the I2C specification.

This value is used in high-speed mode.

Returns
t_HD;STA time
uint32_t CNegativeTesterMaster::GetTimeHighSpeedHigh ( ) const

Gets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification.

This value is used in high-speed mode.

Returns
t_HIGH time
uint32_t CNegativeTesterMaster::GetTimeHighSpeedLowAfterHigh ( ) const

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH).

This value is used in high-speed mode.

Returns
t_LOW time
uint32_t CNegativeTesterMaster::GetTimeHighSpeedLowBeforeHigh ( ) const

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH).

This value is used in high-speed mode.

Returns
t_LOW time
uint32_t CNegativeTesterMaster::GetTimeHighSpeedSuSta ( ) const

Gets the "hold time START condition" (t_HD;STA) as described in the I2C specification.

This value is used in high-speed mode.

Returns
t_HD;STA time
uint32_t CNegativeTesterMaster::GetTimeHighSpeedSuSto ( ) const

Gets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification.

This value is used in high-speed mode.

Returns
t_SU;STO time
uint32_t CNegativeTesterMaster::GetTimeLowAfterHigh ( ) const

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH).

Returns
t_LOW time
Examples:
NegativeTesterExample.cpp.
uint32_t CNegativeTesterMaster::GetTimeLowBeforeHigh ( ) const

Gets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH).

Returns
t_LOW time
Examples:
NegativeTesterExample.cpp.
uint32_t CNegativeTesterMaster::GetTimeSp ( ) const

Gets the "pulse width of spikes" (t_SP) as described in the I2C specification.

Returns
t_SP
uint32_t CNegativeTesterMaster::GetTimeSuSta ( ) const

Gets the "hold time START condition" (t_HD;STA) as described in the I2C specification.

Returns
t_HD;STA time
Examples:
NegativeTesterExample.cpp.
uint32_t CNegativeTesterMaster::GetTimeSuSto ( ) const

Gets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification.

Returns
t_SU;STO time
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::ReceiveAckBit ( bool ignore_nack )

Reads an ACK/NACK. It can be configured, whether the negative tester should stop after receiving a NACK.

Parameters
ignore_nack stop after NACK (false), continue after NACK (true)
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::ReceiveAckBitHighSpeed ( bool ignore_nack )

Reads an ACK/NACK. It can be configured, whether the negative tester should stop after receiving a NACK (high-speed mode).

Parameters
ignore_nack stop after NACK (false), continue after NACK (true)
void CNegativeTesterMaster::ReceiveBit ( )

Reads a data bit.

void CNegativeTesterMaster::ReceiveBitHighSpeed ( bool enable_current_source )

Reads a data bit (high-speed mode).

Parameters
enable_current_source current source: enabled (true), disabled (false)
void CNegativeTesterMaster::ReceiveByte ( )

Reads a data byte.

Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::ReceiveByteHighSpeed ( )

Reads a data byte (high-speed mode).

void CNegativeTesterMaster::SendAckBit ( )

Sends an ACK.

void CNegativeTesterMaster::SendAckBitHighSpeed ( )

Sends an ACK (high-speed mode).

void CNegativeTesterMaster::SendBit ( bool data )

Sends a data bit.

Parameters
data data bit: 1 (true), 0 (false)
void CNegativeTesterMaster::SendBitHighSpeed | ( | bool | data,
 |  | bool | enable_current_source
 | ) |  |

Sends a data bit (high-speed mode).

Parameters
data | data bit: 1 (true), 0 (false)
enable_current_source | current source: enabled (true), disabled (false)
void CNegativeTesterMaster::SendByte ( uint8_t data )

Sends a data byte.

Parameters
data data byte
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SendByteHighSpeed ( uint8_t data )

Sends a data byte (high-speed mode).

Parameters
data data byte
void CNegativeTesterMaster::SendHighSpeedToken ( )

Sends the high-speed token.

void CNegativeTesterMaster::SendNackBit ( )

Sends an NACK.

Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SendNackBitHighSpeed ( )

Sends an NACK (high-speed mode).

void CNegativeTesterMaster::SendPmbusMasterMessage ( const CPmbusMasterMessage & msg )

Sends a PMBus message to the I2C slave.

Parameters
msg PMBus message
void CNegativeTesterMaster::SendPmbusMasterMessage ( const CPmbusMasterMessageGroupCmd & msg )

Sends a PMBus message to the I2C slave.

Parameters
msg PMBus message
void CNegativeTesterMaster::SendReceiver | ( | const CI2cAddress & | addr,
 |  | uint32_t | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave.

Parameters
addr | I2C address of the slave
cnt | number of bytes to be read
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SendReceiverHighSpeed | ( | const CI2cAddress & | addr,
 |  | uint32_t | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The I2C high-speed mode is used.

Parameters
addr | I2C address of the slave
cnt | number of bytes to be read
void CNegativeTesterMaster::SendReceiverWithoutStop | ( | bool | repeated_start,
 |  | const CI2cAddress & | addr,
 |  | uint32_t | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out.

Parameters
repeated_start | repeated start (true), normal start (false)
addr | I2C address of the slave
cnt | number of bytes to be read
void CNegativeTesterMaster::SendReceiverWithoutStopHighSpeed | ( | bool | repeated_start,
 |  | const CI2cAddress & | addr,
 |  | uint32_t | cnt
 | ) |  |

Sends a master receiver message to the I2C slave with the specified address. The specified number of bytes get read from the slave. The stop condition at the end is left out. The I2C high-speed mode is used.

Parameters
repeated_start | repeated start (true), normal start (false)
addr | I2C address of the slave
cnt | number of bytes to be read
void CNegativeTesterMaster::SendRepeatedStart ( )

Sends a repeated start condition.

void CNegativeTesterMaster::SendRepeatedStartHighSpeed ( )

Sends a repeated start condition (high-speed mode).

void CNegativeTesterMaster::SendSmbMasterMessage ( const CSmbMasterMessage & msg )

Sends a SMBus message to the I2C slave.

Parameters
msg SMBus message
void CNegativeTesterMaster::SendStart ( )

Sends a start condition.

Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SendStop ( )

Sends a stop condition.

Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SendStopHighSpeed ( )

Sends a stop condition (high-speed mode).

void CNegativeTesterMaster::SendTransmitter | ( | const CI2cAddress & | addr,
 |  | const std::vector< uint8_t > & | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message.

Parameters
addr | I2C address of the slave
data | data to be transferred
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SendTransmitterHighSpeed | ( | const CI2cAddress & | addr,
 |  | const std::vector< uint8_t > & | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The I2C high-speed mode is used.

Parameters
addr | I2C address of the slave
data | data to be transferred
void CNegativeTesterMaster::SendTransmitterReceiver | ( | const CI2cAddress & | addr,
 |  | const std::vector< uint8_t > & | tx_data,
 |  | uint32_t | rx_cnt
 | ) |  |

Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave.

Parameters
addr | I2C address of the slave
tx_data | data to be transferred
rx_cnt | number of bytes to be read
void CNegativeTesterMaster::SendTransmitterReceiverHighSpeed | ( | const CI2cAddress & | addr,
 |  | const std::vector< uint8_t > & | tx_data,
 |  | uint32_t | rx_cnt
 | ) |  |

Sends a combined message consisting of a master transmitter and a receiver message to the I2C slave with the specified address. The specified data gets transferred to and the specified number of bytes get read from the slave. The I2C high-speed mode is used.

Parameters
addr | I2C address of the slave
tx_data | data to be transferred
rx_cnt | number of bytes to be read
void CNegativeTesterMaster::SendTransmitterWithoutStop | ( | bool | repeated_start,
 |  | const CI2cAddress & | addr,
 |  | const std::vector< uint8_t > & | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out.

Parameters
repeated_start | repeated start (true), normal start (false)
addr | I2C address of the slave
data | data to be transferred
void CNegativeTesterMaster::SendTransmitterWithoutStopHighSpeed | ( | bool | repeated_start,
 |  | const CI2cAddress & | addr,
 |  | const std::vector< uint8_t > & | data
 | ) |  |

Sends a master transmitter message to the I2C slave with the specified address. The given data gets transferred in this message. The stop condition at the end is left out. The I2C high-speed mode is used.

Parameters
repeated_start | repeated start (true), normal start (false)
addr | I2C address of the slave
data | data to be transferred
void CNegativeTesterMaster::SetBitrate ( uint32_t bitrate )

Sets the I2C bitrate (SCL) used by the hardware, when the hardware generates the clock. The default bitrate is 100 kHz.

Valid bitrate are: 1 Hz .. 2 MHz.

Parameters
bitrate I2C bitrate [Hz]
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SetBitrateHighSpeed ( uint32_t bitrate )

Sets the I2C high-speed bitrate (SCL) used by the hardware, when the hardware generates the clock. The default bitrate is 1 MHz.

Valid bitrate are: 400 kHz .. 3.57 MHz.

Parameters
bitrate I2C high-speed bitrate [Hz]
void CNegativeTesterMaster::SetCreateSpikes ( bool enabled )

Configures whether spikes with a length of t_SP should be added to the I2C messages.

Parameters
enabled do not add spikes (false), add spikes (true)
void CNegativeTesterMaster::SetHighSpeedToken ( uint8_t token )

Configures the high-speed mode token.

Parameters
token high-speed mode token (0x08, 0x0a, 0x0c, 0x0e)
void CNegativeTesterMaster::SetIgnoreStretching ( bool stretching )

The detection of clock stretching in the hardware can be disabled. This methods enables or disables the clock stretching support.

Parameters
stretching stretching detected (false), ignore stretching (true)
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SetLoopCount ( uint16_t cnt )

The loop count specifies how often the negative tester sends the SMessagesMaster data to the I2C bus. This method sets the loop count.

Valid values are: 1 .. 1024. The value 1024 sets the loop to infinite.

Parameters
cnt loop count to be used
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SetNackBehaviour ( CNegativeTester::ENackBehaviour behaviour )

Configures the behaviour of the negative tester after receiving a NACK on the I2C bus.

Parameters
behaviour NACK behaviour
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SetStopAtArbitrationLost ( bool stop )

Configures whether the negative tester stops after the detection of arbitration lost.

Parameters
stop stop after arbitration lost (true), continue after arbitration lost (false)
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SetTestpin1 ( bool level )

Sets the state of testpin 1.

Parameters
level high (true), low (false)
void CNegativeTesterMaster::SetTestpin2 ( bool level )

Sets the state of testpin 2.

Parameters
level high (true), low (false)
void CNegativeTesterMaster::SetTimeBuf ( uint32_t time )

Sets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_BUF time
void CNegativeTesterMaster::SetTimeBuf ( const CNegativeTester::Duration & time )

Sets the "bus free time between a STOP and START condition" (t_BUF) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_BUF time
void CNegativeTesterMaster::SetTimeHdSta ( uint32_t time )

Sets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_HD;STA time
Examples:
NegativeTesterExample.cpp.
void CNegativeTesterMaster::SetTimeHdSta ( const CNegativeTester::Duration & time )

Sets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_HD;STA time
void CNegativeTesterMaster::SetTimeHigh ( uint32_t time )

Sets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_HIGH time
void CNegativeTesterMaster::SetTimeHigh ( const CNegativeTester::Duration & time )

Sets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_HIGH time
void CNegativeTesterMaster::SetTimeHighSpeedHdSta ( uint32_t time )

Sets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_HD;STA time
void CNegativeTesterMaster::SetTimeHighSpeedHdSta ( const CNegativeTester::Duration & time )

Sets the "hold time START condition" (t_HD;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_HD;STA time
void CNegativeTesterMaster::SetTimeHighSpeedHigh ( uint32_t time )

Sets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_HIGH time
void CNegativeTesterMaster::SetTimeHighSpeedHigh ( const CNegativeTester::Duration & time )

Sets the "HIGH period of the SCL clock" (t_HIGH) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_HIGH time
void CNegativeTesterMaster::SetTimeHighSpeedLowAfterHigh ( uint32_t time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeHighSpeedLowAfterHigh ( const CNegativeTester::Duration & time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeHighSpeedLowBeforeHigh ( uint32_t time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeHighSpeedLowBeforeHigh ( const CNegativeTester::Duration & time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeHighSpeedSuSta ( uint32_t time )

Sets the "set-up repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_SU;STA time
void CNegativeTesterMaster::SetTimeHighSpeedSuSta ( const CNegativeTester::Duration & time )

Sets the "set-up repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_SU;STA time
void CNegativeTesterMaster::SetTimeHighSpeedSuSto ( uint32_t time )

Sets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_SU;STO time
void CNegativeTesterMaster::SetTimeHighSpeedSuSto ( const CNegativeTester::Duration & time )

Sets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

This value is used in high-speed mode.

Parameters
time t_SU;STO time
void CNegativeTesterMaster::SetTimeLowAfterHigh ( uint32_t time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeLowAfterHigh ( const CNegativeTester::Duration & time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW after t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeLowBeforeHigh ( uint32_t time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeLowBeforeHigh ( const CNegativeTester::Duration & time )

Sets the "LOW period of the SCL clock" (t_LOW) as described in the I2C specification (part of t_LOW before t_HIGH). Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_LOW time
void CNegativeTesterMaster::SetTimeSp ( uint32_t time )

Sets the "pulse width of spikes" (t_SP) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically.

Parameters
time t_SP
void CNegativeTesterMaster::SetTimeSp ( const CNegativeTester::Duration & time )

Sets the "pulse width of spikes" (t_SP) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically.

Parameters
time t_SP
void CNegativeTesterMaster::SetTimeSuSta ( uint32_t time )

Sets the "set-up repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_SU;STA time
void CNegativeTesterMaster::SetTimeSuSta ( const CNegativeTester::Duration & time )

Sets the "set-up repeated START condition" (t_SU;STA) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_SU;STA time
void CNegativeTesterMaster::SetTimeSuSto ( uint32_t time )

Sets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_SU;STO time
void CNegativeTesterMaster::SetTimeSuSto ( const CNegativeTester::Duration & time )

Sets the "set-up time for STOP condition" (t_SU;STO) as described in the I2C specification. Normally it is not necessary, to set this value. It gets configured automatically depending on the bitrate.

Parameters
time t_SU;STO time


I2C.C++ API: Member List

  • CNegativeTesterMaster
telos::I2cApi::Cpp::CNegativeTesterMaster Member List

This is the complete list of members for telos::I2cApi::Cpp::CNegativeTesterMaster, including all inherited members.

AddMessage(const CNegativeTester::SLevelsMaster &level) | telos::I2cApi::Cpp::CNegativeTesterMaster
Clear() | telos::I2cApi::Cpp::CNegativeTesterMaster
CNegativeTesterMaster() | telos::I2cApi::Cpp::CNegativeTesterMaster
Delay(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
Delay(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
GetBitrate() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetBitrateHighSpeed() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetCreateSpikes() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetHighSpeedToken() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetIgnoreStretching() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetLoopCount() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetMessages() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetNackBehaviour() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetStopAtArbitrationLost() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTestpin1() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTestpin2() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeBuf() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHdSta() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHigh() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHighSpeedHdSta() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHighSpeedHigh() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHighSpeedLowAfterHigh() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHighSpeedLowBeforeHigh() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHighSpeedSuSta() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeHighSpeedSuSto() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeLowAfterHigh() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeLowBeforeHigh() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeSp() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeSuSta() const | telos::I2cApi::Cpp::CNegativeTesterMaster
GetTimeSuSto() const | telos::I2cApi::Cpp::CNegativeTesterMaster
ReceiveAckBit(bool ignore_nack) | telos::I2cApi::Cpp::CNegativeTesterMaster
ReceiveAckBitHighSpeed(bool ignore_nack) | telos::I2cApi::Cpp::CNegativeTesterMaster
ReceiveBit() | telos::I2cApi::Cpp::CNegativeTesterMaster
ReceiveBitHighSpeed(bool enable_current_source) | telos::I2cApi::Cpp::CNegativeTesterMaster
ReceiveByte() | telos::I2cApi::Cpp::CNegativeTesterMaster
ReceiveByteHighSpeed() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendAckBit() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendAckBitHighSpeed() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendBit(bool data) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendBitHighSpeed(bool data, bool enable_current_source) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendByte(uint8_t data) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendByteHighSpeed(uint8_t data) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendHighSpeedToken() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendNackBit() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendNackBitHighSpeed() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendPmbusMasterMessage(const CPmbusMasterMessage &msg) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendPmbusMasterMessage(const CPmbusMasterMessageGroupCmd &msg) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendReceiver(const CI2cAddress &addr, uint32_t cnt) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendReceiverHighSpeed(const CI2cAddress &addr, uint32_t cnt) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendReceiverWithoutStop(bool repeated_start, const CI2cAddress &addr, uint32_t cnt) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendReceiverWithoutStopHighSpeed(bool repeated_start, const CI2cAddress &addr, uint32_t cnt) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendRepeatedStart() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendRepeatedStartHighSpeed() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendSmbMasterMessage(const CSmbMasterMessage &msg) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendStart() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendStop() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendStopHighSpeed() | telos::I2cApi::Cpp::CNegativeTesterMaster
SendTransmitter(const CI2cAddress &addr, const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendTransmitterHighSpeed(const CI2cAddress &addr, const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendTransmitterReceiver(const CI2cAddress &addr, const std::vector< uint8_t > &tx_data, uint32_t rx_cnt) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendTransmitterReceiverHighSpeed(const CI2cAddress &addr, const std::vector< uint8_t > &tx_data, uint32_t rx_cnt) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendTransmitterWithoutStop(bool repeated_start, const CI2cAddress &addr, const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CNegativeTesterMaster
SendTransmitterWithoutStopHighSpeed(bool repeated_start, const CI2cAddress &addr, const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetBitrate(uint32_t bitrate) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetBitrateHighSpeed(uint32_t bitrate) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetCreateSpikes(bool enabled) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetHighSpeedToken(uint8_t bitrate) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetIgnoreStretching(bool stretching) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetLoopCount(uint16_t cnt) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetNackBehaviour(CNegativeTester::ENackBehaviour behaviour) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetStopAtArbitrationLost(bool stop) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTestpin1(bool level) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTestpin2(bool level) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeBuf(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeBuf(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHdSta(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHdSta(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHigh(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHigh(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedHdSta(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedHdSta(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedHigh(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedHigh(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedLowAfterHigh(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedLowAfterHigh(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedLowBeforeHigh(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedLowBeforeHigh(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedSuSta(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedSuSta(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedSuSto(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeHighSpeedSuSto(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeLowAfterHigh(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeLowAfterHigh(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeLowBeforeHigh(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeLowBeforeHigh(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeSp(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeSp(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeSuSta(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeSuSta(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeSuSto(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterMaster
SetTimeSuSto(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterMaster


I2C.C++ API: telos::I2cApi::Cpp::CNegativeTesterSlave Class Reference

  • CNegativeTesterSlave
Public Member Functions | List of all members
telos::I2cApi::Cpp::CNegativeTesterSlave Class Reference

#include <CNegativeTesterSlave.h>

Public Member Functions

CNegativeTesterSlave ()
void | Clear ()
void | SetTestpin1 (bool level)
bool | GetTestpin1 () const
void | SetTestpin2 (bool level)
bool | GetTestpin2 () const
void | SetStretching (uint32_t time)
uint32_t | GetStretching () const
void | SetStretching (const CNegativeTester::Duration &time)
void | SetSlaveAddress (uint8_t addr)
uint8_t | GetSlaveAddress () const
void | SetSlaveAddressMask (uint8_t addr)
uint8_t | GetSlaveAddressMask () const
void | SetRestartAfterNackOrStop (bool restart)
bool | GetRestartAfterNackOrStop () const
void | SetLoopMode (bool loop)
bool | GetLoopMode () const
void | CreateStart ()
void | CreateTransmitterBit (bool data)
void | CreateTransmitterByte (uint8_t data)
void | CreateTransmitterAckBit ()
void | CreateReceiverBit ()
void | CreateReceiverByte ()
void | CreateReceiverAckBit ()
void | CreateReceiverNackBit ()
void | CreateTransmitter (const std::vector< uint8_t > &data)
void | CreateReceiver (uint32_t cnt)
void | AddMessage (const CNegativeTester::SLevelsSlave &level)
const CNegativeTester::SMessagesSlave & | GetMessages () const

Detailed Description

This class offers a high-level slave interface for the negative tester implemented in the CNegativeTester class.

Normally the following steps are necessary:

  1. Configure the interface:
    • Configure the behaviour regarding clock stretching using SetStretching().
    • Set the I2C address of the emulated slave using SetSlaveAddress() and SetSlaveAddressMask().
  2. Create the expected transfers using the "Create" methods.
  3. Create an object containing all transitions created by step two using GetMessages().
  4. Pass this object to the CNegativeTester class.

The timebase of the times used by the negative tester is specified in CNegativeTester::TIMEBASE.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CNegativeTesterSlave::CNegativeTesterSlave ( )

Constructor.

Member Function Documentation

void CNegativeTesterSlave::AddMessage ( const CNegativeTester::SLevelsSlave & level )

Adds a self defined CNegativeTester::SLevelsSlave instance to the message queue.

Parameters
level Instance of CNegativeTester::SLevelsSlave
void CNegativeTesterSlave::Clear ( )

Clears the stored transitions and messages.

void CNegativeTesterSlave::CreateReceiver ( uint32_t cnt )

Create the transitions to transfer the specified number of bytes as slave receiver.

Parameters
cnt number of bytes to be transferred
void CNegativeTesterSlave::CreateReceiverAckBit ( )

Creates the transitions to send an ACK as slave receiver.

void CNegativeTesterSlave::CreateReceiverBit ( )

Creates the transitions to transfer one data bit as slave receiver.

void CNegativeTesterSlave::CreateReceiverByte ( )

Creates the transitions to transfer one data byte as slave receiver.

void CNegativeTesterSlave::CreateReceiverNackBit ( )

Creates the transitions to send an NACK as slave receiver.

void CNegativeTesterSlave::CreateStart ( )

Creates the transitions to accept an I2C slave address and the following acknowledge.

This method has to be used at positions, where a START condition, an I2C address, and an acknowledge are expected.

void CNegativeTesterSlave::CreateTransmitter ( const std::vector< uint8_t > & data )

Create the transitions to transfer the specified data as slave transmitter.

Parameters
data data to be transferred
void CNegativeTesterSlave::CreateTransmitterAckBit ( )

Creates the transitions to accept an ACK/NACK as slave transmitter.

void CNegativeTesterSlave::CreateTransmitterBit ( bool data )

Creates the transitions to transfer one data bit as slave transmitter.

Parameters
data bit to be transmitted
void CNegativeTesterSlave::CreateTransmitterByte ( uint8_t data )

Creates the transitions to transfer one data byte as slave transmitter.

Parameters
data byte to be transmitted
bool CNegativeTesterSlave::GetLoopMode ( ) const

The loop mode specifies the behaviour of the negative tester after processing the last specified submessage. It can stop the negative tester or restart with the first specified submessage.

Returns
restart with first submessage?
const CNegativeTester::SMessagesSlave & CNegativeTesterSlave::GetMessages ( ) const

Returns the submessages, which have been created using the "Create" methods of this class. This data can be passed to a CNegativeTester instance.

To reset the submessages use the ::Clear() method.

Returns
submessages
bool CNegativeTesterSlave::GetRestartAfterNackOrStop ( ) const

If the negative tester detects a STOP condition on the I2C bus or sends a NACK as slave receiver, there are two possibilities on how to proceed: jump to the beginning of the first submessage or jump to the next submessage.

Returns
jump to the first submessage (true), jump to the next submessage (false)
uint8_t CNegativeTesterSlave::GetSlaveAddress ( ) const

In the slave mode the negative tester is listening on an I2C slave address. Returns the currently set I2C slave address.

Returns
I2C slave address
uint8_t CNegativeTesterSlave::GetSlaveAddressMask ( ) const

It is possible the set a don't care mask for the I2C slave address set by SetSlaveAddress(). This method returns the currently used don't care mask.

Returns
don't care mask
uint32_t CNegativeTesterSlave::GetStretching ( ) const

Returns the stretching time. The slave will stretch the low level part of SCL to this time for each bit.

Returns
stretching time
bool CNegativeTesterSlave::GetTestpin1 ( ) const

Returns the state of testpin 1.

Returns
high (true), low (false)
bool CNegativeTesterSlave::GetTestpin2 ( ) const

Returns the state of testpin 2.

Returns
high (true), low (false)
void CNegativeTesterSlave::SetLoopMode ( bool loop )

The loop mode specifies the behaviour of the negative tester after processing the last specified submessage. It can stop the negative tester or restart with the first specified submessage.

Parameters
loop restart with first submessage?
void CNegativeTesterSlave::SetRestartAfterNackOrStop ( bool restart )

If the negative tester detects a STOP condition on the I2C bus or sends a NACK as slave receiver, there are two possibilities on how to proceed: jump to the beginning of the first submessage or jump to the next submessage.

Parameters
restart jump to the first submessage (true), jump to the next submessage (false)
void CNegativeTesterSlave::SetSlaveAddress ( uint8_t addr )

In the slave mode the negative tester is listening on an I2C slave address. This method sets the I2C slave address.

Parameters
addr I2C slave address
void CNegativeTesterSlave::SetSlaveAddressMask ( uint8_t addr )

It is possible the set a don't care mask for the I2C slave address set by SetSlaveAddress(). This method sets the don't care mask.

Parameters
addr don't care mask
void CNegativeTesterSlave::SetStretching ( uint32_t time )

Sets the stretching time. The slave will stretch the low level part of SCL to this time for each bit.

Parameters
time stretching time
void CNegativeTesterSlave::SetStretching ( const CNegativeTester::Duration & time )

Sets the stretching time. The slave will stretch the low level part of SCL to this time for each bit.

Parameters
time stretching time
void CNegativeTesterSlave::SetTestpin1 ( bool level )

Sets the state of testpin 1.

Parameters
level high (true), low (false)
void CNegativeTesterSlave::SetTestpin2 ( bool level )

Sets the state of testpin 2.

Parameters
level high (true), low (false)


I2C.C++ API: Member List

  • CNegativeTesterSlave
telos::I2cApi::Cpp::CNegativeTesterSlave Member List

This is the complete list of members for telos::I2cApi::Cpp::CNegativeTesterSlave, including all inherited members.

AddMessage(const CNegativeTester::SLevelsSlave &level) | telos::I2cApi::Cpp::CNegativeTesterSlave
Clear() | telos::I2cApi::Cpp::CNegativeTesterSlave
CNegativeTesterSlave() | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateReceiver(uint32_t cnt) | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateReceiverAckBit() | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateReceiverBit() | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateReceiverByte() | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateReceiverNackBit() | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateStart() | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateTransmitter(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateTransmitterAckBit() | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateTransmitterBit(bool data) | telos::I2cApi::Cpp::CNegativeTesterSlave
CreateTransmitterByte(uint8_t data) | telos::I2cApi::Cpp::CNegativeTesterSlave
GetLoopMode() const | telos::I2cApi::Cpp::CNegativeTesterSlave
GetMessages() const | telos::I2cApi::Cpp::CNegativeTesterSlave
GetRestartAfterNackOrStop() const | telos::I2cApi::Cpp::CNegativeTesterSlave
GetSlaveAddress() const | telos::I2cApi::Cpp::CNegativeTesterSlave
GetSlaveAddressMask() const | telos::I2cApi::Cpp::CNegativeTesterSlave
GetStretching() const | telos::I2cApi::Cpp::CNegativeTesterSlave
GetTestpin1() const | telos::I2cApi::Cpp::CNegativeTesterSlave
GetTestpin2() const | telos::I2cApi::Cpp::CNegativeTesterSlave
SetLoopMode(bool loop) | telos::I2cApi::Cpp::CNegativeTesterSlave
SetRestartAfterNackOrStop(bool restart) | telos::I2cApi::Cpp::CNegativeTesterSlave
SetSlaveAddress(uint8_t addr) | telos::I2cApi::Cpp::CNegativeTesterSlave
SetSlaveAddressMask(uint8_t addr) | telos::I2cApi::Cpp::CNegativeTesterSlave
SetStretching(uint32_t time) | telos::I2cApi::Cpp::CNegativeTesterSlave
SetStretching(const CNegativeTester::Duration &time) | telos::I2cApi::Cpp::CNegativeTesterSlave
SetTestpin1(bool level) | telos::I2cApi::Cpp::CNegativeTesterSlave
SetTestpin2(bool level) | telos::I2cApi::Cpp::CNegativeTesterSlave


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessage Class Reference

  • CPmbusMasterMessage
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessage Class Reference

#include <CPmbusMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CPmbusMasterMessage:
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord telos::I2cApi::Cpp::CPmbusMasterMessageReadByte telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte telos::I2cApi::Cpp::CPmbusMasterMessageReadWord telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord

Public Member Functions

const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
uint8_t | GetCommandExtension () const
void | SetCommandExtension (uint8_t cmd_ext)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Static Public Attributes

static const uint8_t | PMBUS_COMMAND_EXT = 0xff
command extension: PMBus
static const uint8_t | MFR_SPECIFIC_COMMAND_EXT = 0xfe
command extension: manufacturer specific

Protected Member Functions

CPmbusMasterMessage (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)

Detailed Description

This class is used as a base class for the PMBus master messages supporting the "extended command" byte.

The PMBus is specified in:

PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added.

The number of commands, which is limited to 256 on the SMBus, has been extended by the introduction of the "extended command" byte.

There are different message types supporting the "extended command" byte:

  • Write Byte
  • Read Byte
  • Write Word
  • Read Word

A PMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the PMBus with the CSmbMaster::TransferData() method.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CPmbusMasterMessage::CPmbusMasterMessage | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | cmd_ext,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
cmd_ext | command extension byte
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

const CI2cAddress & CPmbusMasterMessage::GetAddress ( ) const

Returns the I2C address of the slave.

Returns
I2C address of the slave
uint8_t CPmbusMasterMessage::GetCommand ( ) const

Returns the command byte of the message.

Returns
command byte
Examples:
MasterExample.cpp.
uint8_t CPmbusMasterMessage::GetCommandExtension ( ) const

Returns the command extension byte of the message.

Returns
command extension byte
Examples:
MasterExample.cpp.
bool CPmbusMasterMessage::GetWithPec ( ) const

Returns whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void CPmbusMasterMessage::SetAddress ( const CI2cAddress & i2c_address )

Sets the I2C address of the slave.

The PMBus supports only 7-bit I2C addresses.

Parameters
i2c_address I2C address of the slave
Examples:
MasterExample.cpp.
void CPmbusMasterMessage::SetCommand ( uint8_t cmd )

Sets the command byte of the message.

Returns
command byte
Examples:
MasterExample.cpp.
void CPmbusMasterMessage::SetCommandExtension ( uint8_t cmd_ext )

Sets the command extension byte of the message.

Returns
command extension byte
Examples:
MasterExample.cpp.
void CPmbusMasterMessage::SetWithPec ( bool with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)
Examples:
MasterExample.cpp.


I2C.C++ API: Member List

  • CPmbusMasterMessage
telos::I2cApi::Cpp::CPmbusMasterMessage Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessage, including all inherited members.

CPmbusMasterMessage(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage | protected
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommandExtension() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommandExtension(uint8_t cmd_ext) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageCmd Class Reference

  • CPmbusMasterMessageCmd
Public Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageCmd Class Reference

#include <CPmbusMasterMessage.h>

Public Member Functions

CPmbusMasterMessageCmd ()
CPmbusMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data)
CPmbusMasterMessageCmd (const CSmbMasterMessageWriteByte &msg)
CPmbusMasterMessageCmd (const CSmbMasterMessageWriteWord &msg)
CPmbusMasterMessageCmd (const CSmbMasterMessageWrite32 &msg)
CPmbusMasterMessageCmd (const CSmbMasterMessageWrite64 &msg)
template<class InputIterator >
CPmbusMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, InputIterator data_first, InputIterator data_last)
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
std::vector< uint8_t > & | GetData ()
const std::vector< uint8_t > & | GetData () const
void | SetData (const std::vector< uint8_t > &data)
template<class InputIterator >
void | SetData (InputIterator first, InputIterator last)

Detailed Description

This class contains a submessage of a "Group Command" PMBus master message. Instances of this class are stored in CPmbusMasterMessageGroupCmd objects.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CPmbusMasterMessageCmd::CPmbusMasterMessageCmd ( )

Constructor

CPmbusMasterMessageCmd::CPmbusMasterMessageCmd | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | const std::vector< uint8_t > & | data
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transmitted
CPmbusMasterMessageCmd::CPmbusMasterMessageCmd ( const CSmbMasterMessageWriteByte & msg )

Constructor

Parameters
msg msg to be transmitted
CPmbusMasterMessageCmd::CPmbusMasterMessageCmd ( const CSmbMasterMessageWriteWord & msg )

Constructor

Parameters
msg msg to be transmitted
CPmbusMasterMessageCmd::CPmbusMasterMessageCmd ( const CSmbMasterMessageWrite32 & msg )

Constructor

Parameters
msg msg to be transmitted
CPmbusMasterMessageCmd::CPmbusMasterMessageCmd ( const CSmbMasterMessageWrite64 & msg )

Constructor

Parameters
msg msg to be transmitted
template<class InputIterator >
telos::I2cApi::Cpp::CPmbusMasterMessageCmd::CPmbusMasterMessageCmd | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | InputIterator | data_first,
 |  | InputIterator | data_last
 | ) |  |
inline

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data_first | first position of data to be transmitted
data_last | last position of data to be transmitted

Member Function Documentation

const CI2cAddress & CPmbusMasterMessageCmd::GetAddress ( ) const

Returns the I2C address of the slave.

Returns
I2C address of the slave
uint8_t CPmbusMasterMessageCmd::GetCommand ( ) const

Returns the command byte of the message.

Returns
command byte
Examples:
MasterExample.cpp.
std::vector< uint8_t > & CPmbusMasterMessageCmd::GetData ( )

Returns the data to be transmitted.

Returns
data to be transmitted
Examples:
MasterExample.cpp.
const std::vector< uint8_t > & CPmbusMasterMessageCmd::GetData ( ) const

Returns the data to be transmitted.

Returns
data to be transmitted
void CPmbusMasterMessageCmd::SetAddress ( const CI2cAddress & i2c_address )

Sets the I2C address of the slave.

The PMBus supports only 7-bit I2C addresses.

Parameters
i2c_address I2C address of the slave
Examples:
MasterExample.cpp.
void CPmbusMasterMessageCmd::SetCommand ( uint8_t cmd )

Sets the command byte of the message.

Returns
command byte
Examples:
MasterExample.cpp.
void CPmbusMasterMessageCmd::SetData ( const std::vector< uint8_t > & data )

Sets the data to be transmitted.

Parameters
data data to be transmitted
template<class InputIterator >
void telos::I2cApi::Cpp::CPmbusMasterMessageCmd::SetData | ( | InputIterator | first,
 |  | InputIterator | last
 | ) |  |
inline

Sets the data to be transmitted.

Parameters
first | first position of data to be transmitted
last | last position of data to be transmitted


I2C.C++ API: Member List

  • CPmbusMasterMessageCmd
telos::I2cApi::Cpp::CPmbusMasterMessageCmd Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageCmd, including all inherited members.

CPmbusMasterMessageCmd() | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
CPmbusMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
CPmbusMasterMessageCmd(const CSmbMasterMessageWriteByte &msg) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
CPmbusMasterMessageCmd(const CSmbMasterMessageWriteWord &msg) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
CPmbusMasterMessageCmd(const CSmbMasterMessageWrite32 &msg) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
CPmbusMasterMessageCmd(const CSmbMasterMessageWrite64 &msg) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
CPmbusMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, InputIterator data_first, InputIterator data_last) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd | inline
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
GetData() | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
SetData(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd |
SetData(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CPmbusMasterMessageCmd | inline


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte Class Reference

  • CPmbusMasterMessageExtCmdByte
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte Class Reference

#include <CPmbusMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte:
telos::I2cApi::Cpp::CPmbusMasterMessage telos::I2cApi::Cpp::CPmbusMasterMessageReadByte telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte

Public Member Functions

uint8_t | GetData () const
void | SetData (uint8_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
uint8_t | GetCommandExtension () const
void | SetCommandExtension (uint8_t cmd_ext)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Protected Member Functions

CPmbusMasterMessageExtCmdByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
CPmbusMasterMessage (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
static const uint8_t | PMBUS_COMMAND_EXT = 0xff
command extension: PMBus
static const uint8_t | MFR_SPECIFIC_COMMAND_EXT = 0xfe
command extension: manufacturer specific

Detailed Description

This class is used as a base class for the "Extended Command: Write Byte" and "Extended Command: Read Byte" PMBus master messages.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CPmbusMasterMessageExtCmdByte::CPmbusMasterMessageExtCmdByte | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | cmd_ext,
 |  | uint8_t | data,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
cmd_ext | command extension byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint8_t CPmbusMasterMessageExtCmdByte::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
Examples:
MasterExample.cpp.
void CPmbusMasterMessageExtCmdByte::SetData ( uint8_t data )

Sets the data to be transmitted or the received data.

Parameters
data data


I2C.C++ API: Member List

  • CPmbusMasterMessageExtCmdByte
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte, including all inherited members.

CPmbusMasterMessage(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage | protected
CPmbusMasterMessageExtCmdByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte | protected
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommandExtension() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetData() const | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte |
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommandExtension(uint8_t cmd_ext) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetData(uint8_t data) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord Class Reference

  • CPmbusMasterMessageExtCmdWord
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord Class Reference

#include <CPmbusMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord:
telos::I2cApi::Cpp::CPmbusMasterMessage telos::I2cApi::Cpp::CPmbusMasterMessageReadWord telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord

Public Member Functions

uint16_t | GetData () const
void | SetData (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
uint8_t | GetCommandExtension () const
void | SetCommandExtension (uint8_t cmd_ext)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Protected Member Functions

CPmbusMasterMessageExtCmdWord (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
CPmbusMasterMessage (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
static const uint8_t | PMBUS_COMMAND_EXT = 0xff
command extension: PMBus
static const uint8_t | MFR_SPECIFIC_COMMAND_EXT = 0xfe
command extension: manufacturer specific

Detailed Description

This class is used as a base class for the "Extended Command: Write Word" and "Extended Command: Read Word" PMBus master messages.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CPmbusMasterMessageExtCmdWord::CPmbusMasterMessageExtCmdWord | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | cmd_ext,
 |  | uint16_t | data,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
cmd_ext | command extension byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint16_t CPmbusMasterMessageExtCmdWord::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
Examples:
MasterExample.cpp.
void CPmbusMasterMessageExtCmdWord::SetData ( uint16_t data )

Sets the data to be transmitted or the received data.

Parameters
data data
Examples:
MasterExample.cpp.


I2C.C++ API: Member List

  • CPmbusMasterMessageExtCmdWord
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord, including all inherited members.

CPmbusMasterMessage(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage | protected
CPmbusMasterMessageExtCmdWord(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord | protected
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommandExtension() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetData() const | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord |
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommandExtension(uint8_t cmd_ext) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetData(uint16_t data) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd Class Reference

  • CPmbusMasterMessageGroupCmd
Public Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd Class Reference

#include <CPmbusMasterMessage.h>

Inherits vector< CPmbusMasterMessageCmd >.

Public Member Functions

CPmbusMasterMessageGroupCmd ()
CPmbusMasterMessageGroupCmd (const std::vector< CPmbusMasterMessageCmd > &cmds, bool with_pec)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Detailed Description

This class specifies a "Group Command" (see section 5.2.3 in the standard) master message for the PMBus.

The PMBus is specified in:

PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added.

A PMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the PMBus with the CSmbMaster::TransferData() method.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CPmbusMasterMessageGroupCmd::CPmbusMasterMessageGroupCmd ( )

Constructor

CPmbusMasterMessageGroupCmd::CPmbusMasterMessageGroupCmd | ( | const std::vector< CPmbusMasterMessageCmd > & | cmds,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
cmds | commands to be sent
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

bool CPmbusMasterMessageGroupCmd::GetWithPec ( ) const

Returns whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void CPmbusMasterMessageGroupCmd::SetWithPec ( bool with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)
Examples:
MasterExample.cpp.


I2C.C++ API: Member List

  • CPmbusMasterMessageGroupCmd
telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd, including all inherited members.

CPmbusMasterMessageGroupCmd() | telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
CPmbusMasterMessageGroupCmd(const std::vector< CPmbusMasterMessageCmd > &cmds, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageReadByte Class Reference

  • CPmbusMasterMessageReadByte
Public Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageReadByte Class Reference

#include <CPmbusMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CPmbusMasterMessageReadByte:
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte telos::I2cApi::Cpp::CPmbusMasterMessage

Public Member Functions

CPmbusMasterMessageReadByte ()
CPmbusMasterMessageReadByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
uint8_t | GetData () const
void | SetData (uint8_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
uint8_t | GetCommandExtension () const
void | SetCommandExtension (uint8_t cmd_ext)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
static const uint8_t | PMBUS_COMMAND_EXT = 0xff
command extension: PMBus
static const uint8_t | MFR_SPECIFIC_COMMAND_EXT = 0xfe
command extension: manufacturer specific
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
CPmbusMasterMessageExtCmdByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
CPmbusMasterMessage (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)

Detailed Description

This class specifies a "Extended Command: Read Byte" (see section 5.2.4 in the standard) master message for the PMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CPmbusMasterMessageReadByte::CPmbusMasterMessageReadByte ( )

Constructor

CPmbusMasterMessageReadByte::CPmbusMasterMessageReadByte | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | cmd_ext,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
cmd_ext | command extension byte
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CPmbusMasterMessageReadByte
telos::I2cApi::Cpp::CPmbusMasterMessageReadByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageReadByte, including all inherited members.

CPmbusMasterMessage(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage | protected
CPmbusMasterMessageExtCmdByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte | protected
CPmbusMasterMessageReadByte() | telos::I2cApi::Cpp::CPmbusMasterMessageReadByte |
CPmbusMasterMessageReadByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageReadByte |
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommandExtension() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetData() const | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte |
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommandExtension(uint8_t cmd_ext) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetData(uint8_t data) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageReadWord Class Reference

  • CPmbusMasterMessageReadWord
Public Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageReadWord Class Reference

#include <CPmbusMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CPmbusMasterMessageReadWord:
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord telos::I2cApi::Cpp::CPmbusMasterMessage

Public Member Functions

CPmbusMasterMessageReadWord ()
CPmbusMasterMessageReadWord (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
uint16_t | GetData () const
void | SetData (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
uint8_t | GetCommandExtension () const
void | SetCommandExtension (uint8_t cmd_ext)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
static const uint8_t | PMBUS_COMMAND_EXT = 0xff
command extension: PMBus
static const uint8_t | MFR_SPECIFIC_COMMAND_EXT = 0xfe
command extension: manufacturer specific
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
CPmbusMasterMessageExtCmdWord (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
CPmbusMasterMessage (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)

Detailed Description

This class specifies a "Extended Command: Read Word" (see section 5.2.5 in the standard) master message for the PMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CPmbusMasterMessageReadWord::CPmbusMasterMessageReadWord ( )

Constructor

CPmbusMasterMessageReadWord::CPmbusMasterMessageReadWord | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | cmd_ext,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
cmd_ext | command extension byte
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CPmbusMasterMessageReadWord
telos::I2cApi::Cpp::CPmbusMasterMessageReadWord Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageReadWord, including all inherited members.

CPmbusMasterMessage(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage | protected
CPmbusMasterMessageExtCmdWord(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord | protected
CPmbusMasterMessageReadWord() | telos::I2cApi::Cpp::CPmbusMasterMessageReadWord |
CPmbusMasterMessageReadWord(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageReadWord |
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommandExtension() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetData() const | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord |
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommandExtension(uint8_t cmd_ext) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetData(uint16_t data) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte Class Reference

  • CPmbusMasterMessageWriteByte
Public Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte Class Reference

#include <CPmbusMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte:
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte telos::I2cApi::Cpp::CPmbusMasterMessage

Public Member Functions

CPmbusMasterMessageWriteByte ()
CPmbusMasterMessageWriteByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
uint8_t | GetData () const
void | SetData (uint8_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
uint8_t | GetCommandExtension () const
void | SetCommandExtension (uint8_t cmd_ext)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
static const uint8_t | PMBUS_COMMAND_EXT = 0xff
command extension: PMBus
static const uint8_t | MFR_SPECIFIC_COMMAND_EXT = 0xfe
command extension: manufacturer specific
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
CPmbusMasterMessageExtCmdByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
CPmbusMasterMessage (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)

Detailed Description

This class specifies a "Extended Command: Write Byte" (see section 5.2.4 in the standard) master message for the PMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CPmbusMasterMessageWriteByte::CPmbusMasterMessageWriteByte ( )

Constructor

CPmbusMasterMessageWriteByte::CPmbusMasterMessageWriteByte | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | cmd_ext,
 |  | uint8_t | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
cmd_ext | command extension byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CPmbusMasterMessageWriteByte
telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte, including all inherited members.

CPmbusMasterMessage(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage | protected
CPmbusMasterMessageExtCmdByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte | protected
CPmbusMasterMessageWriteByte() | telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte |
CPmbusMasterMessageWriteByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte |
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommandExtension() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetData() const | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte |
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommandExtension(uint8_t cmd_ext) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetData(uint8_t data) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord Class Reference

  • CPmbusMasterMessageWriteWord
Public Member Functions | List of all members
telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord Class Reference

#include <CPmbusMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord:
telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord telos::I2cApi::Cpp::CPmbusMasterMessage

Public Member Functions

CPmbusMasterMessageWriteWord ()
CPmbusMasterMessageWriteWord (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
uint16_t | GetData () const
void | SetData (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
uint8_t | GetCommandExtension () const
void | SetCommandExtension (uint8_t cmd_ext)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)

Additional Inherited Members

- Static Public Attributes inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
static const uint8_t | PMBUS_COMMAND_EXT = 0xff
command extension: PMBus
static const uint8_t | MFR_SPECIFIC_COMMAND_EXT = 0xfe
command extension: manufacturer specific
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
CPmbusMasterMessageExtCmdWord (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CPmbusMasterMessage
CPmbusMasterMessage (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec)

Detailed Description

This class specifies a "Extended Command: Write Word" (see section 5.2.5 in the standard) master message for the PMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CPmbusMasterMessageWriteWord::CPmbusMasterMessageWriteWord ( )

Constructor

CPmbusMasterMessageWriteWord::CPmbusMasterMessageWriteWord | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | cmd_ext,
 |  | uint16_t | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
cmd_ext | command extension byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CPmbusMasterMessageWriteWord
telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord Member List

This is the complete list of members for telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord, including all inherited members.

CPmbusMasterMessage(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage | protected
CPmbusMasterMessageExtCmdWord(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord | protected
CPmbusMasterMessageWriteWord() | telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord |
CPmbusMasterMessageWriteWord(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t cmd_ext, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord |
GetAddress() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetCommandExtension() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
GetData() const | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord |
GetWithPec() const | telos::I2cApi::Cpp::CPmbusMasterMessage |
MFR_SPECIFIC_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
PMBUS_COMMAND_EXT | telos::I2cApi::Cpp::CPmbusMasterMessage | static
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetCommandExtension(uint8_t cmd_ext) | telos::I2cApi::Cpp::CPmbusMasterMessage |
SetData(uint16_t data) | telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CPmbusMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CSlaveRam Class Reference

  • CSlaveRam
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSlaveRam Class Reference

#include <CSlaveRam.h>

Public Member Functions

CSlaveRam (CTraciiCpu &tracii_cpu)
void | Enable (const CI2cAddress &i2c_address)
void | Disable ()
bool | IsEnabled () const
const CI2cAddress & | GetI2cAddress () const

Detailed Description

Tracii XL can emulate an I2C RAM slave. This class can be used to enable/disable this slave. The slave will listen on the specified I2C address.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSlaveRam::CSlaveRam ( CTraciiCpu & tracii_cpu )
explicit

Constructor.

Parameters
tracii_cpu TraciiCPU of the Tracii XL to be used

Member Function Documentation

void CSlaveRam::Disable ( )

Disables the RAM emulation.

void CSlaveRam::Enable ( const CI2cAddress & i2c_address )

Enables the RAM emulation. The RAM will listen on the specified I2C address. Only 7 bit I2C addresses can be used.

Parameters
i2c_address I2C address of the slave
const CI2cAddress & CSlaveRam::GetI2cAddress ( ) const

Returns the I2C adddress of the emulated RAM.

Returns
I2C address
bool CSlaveRam::IsEnabled ( ) const

Returns whether the RAM emulation is running.

Returns
running (true), not running (false)


I2C.C++ API: Member List

  • CSlaveRam
telos::I2cApi::Cpp::CSlaveRam Member List

This is the complete list of members for telos::I2cApi::Cpp::CSlaveRam, including all inherited members.

CSlaveRam(CTraciiCpu &tracii_cpu) | telos::I2cApi::Cpp::CSlaveRam | explicit
Disable() | telos::I2cApi::Cpp::CSlaveRam |
Enable(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSlaveRam |
GetI2cAddress() const | telos::I2cApi::Cpp::CSlaveRam |
IsEnabled() const | telos::I2cApi::Cpp::CSlaveRam |


I2C.C++ API: telos::I2cApi::Cpp::CSlaveRamEnhanced Class Reference

  • CSlaveRamEnhanced
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSlaveRamEnhanced Class Reference

#include <CSlaveRamEnhanced.h>

Public Member Functions

void | SetEnabled (bool enabled)
bool | GetEnabled () const
void | SetAddress (const CI2cAddress &address)
CI2cAddress | GetAddress () const
void | SetAddressMask (uint16_t mask)
uint16_t | GetAddressMask () const
void | SetMemorySize (uint32_t size)
uint32_t | GetMemorySize () const
void | SetAutoIncrement (bool auto_increment)
bool | GetAutoIncrement () const
void | SetTimeout (uint16_t timeout_ms)
uint16_t | GetTimeout () const
void | SetTimeout (const std::chrono::duration< uint16_t, std::milli > &timeout)
void | SetData (uint32_t start_address, const std::vector< uint8_t > &data)
template<class InputIterator >
void | SetData (uint32_t start_address, InputIterator data_first, InputIterator data_last)
void | GetData (std::vector< uint8_t > &data)

Protected Member Functions

CSlaveRamEnhanced (CBoard *board)

Detailed Description

Tracii XL 2.0 contains an enhanced I2C RAM slave. The slave emulates a RAM with up to 256 bytes. The I2C address and the memory size of the RAM can be configured. The RAM supports auto incrementing the address pointer.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the CBoard::GetSlaveRamEnhanced() method.

Normally the following steps are necessary:

  1. Set the slave address using SetAddress().
  2. Set the memory size using SetMemorySize().
  3. Configure auto increment using SetAutoIncrement().
  4. Enable slave using SetEnabled().
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSlaveRamEnhanced::CSlaveRamEnhanced ( CBoard * board )
protected

Constructor.

Parameters
board pointer to CBoard object managing this object

Member Function Documentation

CI2cAddress CSlaveRamEnhanced::GetAddress ( ) const

Gets the I2C address, which the slave RAM is listening on.

Returns
I2C address
uint16_t CSlaveRamEnhanced::GetAddressMask ( ) const

Gets the I2C address mask.

Returns
I2C address mask (0x00..0x3ff)
bool CSlaveRamEnhanced::GetAutoIncrement ( ) const

Gets whether auto increment is enabled or disabled. If auto increment is enabled, the address pointer of the RAM gets incremented automatically after reading or writing bytes.

Returns
enabled (true), disabled (false)
void CSlaveRamEnhanced::GetData ( std::vector< uint8_t > & data )

Gets the current content of the emulated RAM.

Parameters
data data read for the RAM
bool CSlaveRamEnhanced::GetEnabled ( ) const

Gets whether the slave RAM is enabled or disabled.

Returns
enabled (true), disabled (false)
uint32_t CSlaveRamEnhanced::GetMemorySize ( ) const

Gets the size of the emulated RAM. If auto increment has been enabled, the address pointer gets reset to zero after reaching the end of the memory.

Returns
size of the memory (1..256)
uint16_t CSlaveRamEnhanced::GetTimeout ( ) const

Gets the timeout. If the transfer of one byte takes longer than the specified time, the RAM goes back to idle mode. This can be useful, if the RAM misses e.g. a clock cycle in slave transmitter mode and would block SDA for infinity.

Returns
timeout [ms] or N/A ("~0")
void CSlaveRamEnhanced::SetAddress ( const CI2cAddress & address )

Sets the I2C address, which the slave RAM is listening on.

Parameters
address I2C address
void CSlaveRamEnhanced::SetAddressMask ( uint16_t mask )

Sets the I2C address mask. By default the mask is set to 0x3ff so that the slave will listen to the address, which has been configured by SetAddress(). If the mask is set to 0x00, the slave will answer on all 7-bit or 10-bit I2C addresses.

Parameters
mask I2C address mask (0x00..0x3ff)
void CSlaveRamEnhanced::SetAutoIncrement ( bool auto_increment )

Sets whether auto increment is enabled or disabled. If auto increment is enabled, the address pointer of the RAM gets incremented automatically after reading or writing bytes.

Parameters
auto_increment enabled (true), disabled (false)
void CSlaveRamEnhanced::SetData | ( | uint32_t | start_address,
 |  | const std::vector< uint8_t > & | data
 | ) |  |

Sets one or several bytes in the emulate RAM.

Parameters
start_address | address of the first byte to be set
data | data to be set
template<class InputIterator >
void telos::I2cApi::Cpp::CSlaveRamEnhanced::SetData | ( | uint32_t | start_address,
 |  | InputIterator | data_first,
 |  | InputIterator | data_last
 | ) |  |
inline

Sets one or several bytes in the emulate RAM.

Parameters
start_address | address of the first byte to be set
data_first | first position of data to be set
data_last | last position of data to be set
void CSlaveRamEnhanced::SetEnabled ( bool enabled )

Sets whether the slave RAM is enabled or disabled.

Parameters
enabled enabled (true), disabled (false)
void CSlaveRamEnhanced::SetMemorySize ( uint32_t size )

Sets the size of the emulated RAM. If auto increment has been enabled, the address pointer gets reset to zero after reaching the end of the memory.

Parameters
size size of the memory (1..256)
void CSlaveRamEnhanced::SetTimeout ( uint16_t timeout_ms )

Sets the timeout. If the transfer of one byte takes longer than the specified time, the RAM goes back to idle mode. This can be useful, if the RAM misses e.g. a clock cycle in slave transmitter mode and would block SDA for infinity.

Parameters
timeout_ms timeout [ms] or N/A ("~0")
void CSlaveRamEnhanced::SetTimeout ( const std::chrono::duration< uint16_t, std::milli > & timeout )

Sets the timeout. If the transfer of one byte takes longer than the specified time, the RAM goes back to idle mode. This can be useful, if the RAM misses e.g. a clock cycle in slave transmitter mode and would block SDA for infinity.

Parameters
timeout timeout or N/A ("0")


I2C.C++ API: Member List

  • CSlaveRamEnhanced
telos::I2cApi::Cpp::CSlaveRamEnhanced Member List

This is the complete list of members for telos::I2cApi::Cpp::CSlaveRamEnhanced, including all inherited members.

CSlaveRamEnhanced(CBoard *board) | telos::I2cApi::Cpp::CSlaveRamEnhanced | protected
GetAddress() const | telos::I2cApi::Cpp::CSlaveRamEnhanced |
GetAddressMask() const | telos::I2cApi::Cpp::CSlaveRamEnhanced |
GetAutoIncrement() const | telos::I2cApi::Cpp::CSlaveRamEnhanced |
GetData(std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
GetEnabled() const | telos::I2cApi::Cpp::CSlaveRamEnhanced |
GetMemorySize() const | telos::I2cApi::Cpp::CSlaveRamEnhanced |
GetTimeout() const | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetAddress(const CI2cAddress &address) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetAddressMask(uint16_t mask) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetAutoIncrement(bool auto_increment) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetData(uint32_t start_address, const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetData(uint32_t start_address, InputIterator data_first, InputIterator data_last) | telos::I2cApi::Cpp::CSlaveRamEnhanced | inline
SetEnabled(bool enabled) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetMemorySize(uint32_t size) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetTimeout(uint16_t timeout_ms) | telos::I2cApi::Cpp::CSlaveRamEnhanced |
SetTimeout(const std::chrono::duration< uint16_t, std::milli > &timeout) | telos::I2cApi::Cpp::CSlaveRamEnhanced |


I2C.C++ API: telos::I2cApi::Cpp::CSmbArpMaster Class Reference

  • CSmbArpMaster
Classes | Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbArpMaster Class Reference

#include <CSmbArpMaster.h>

Classes

class CUdid

Public Member Functions

CSmbArpMaster (CBoard &board)
void | PrepareToArp ()
void | ResetDevice ()
void | GetUdid (CUdid &udid)
void | AssignAddress (CUdid &udid, const CI2cAddress &addr)
void | GetUdid (const CI2cAddress &addr, CUdid &udid)
void | ResetDevice (const CI2cAddress &addr)
void | ExecuteArp (const std::vector< CI2cAddress > &reserved_addr, std::vector< CUdid > &devices)

Detailed Description

This class implements the SMBus address resolution protocol (ARP).

The SMBus is specified in:

System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Normally only the ExecuteArp() method has to be used. This method assigns I2C addresses to all found slave devices.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbArpMaster::CSmbArpMaster ( CBoard & board )
explicit

Constructor

Parameters
board I2C interface

Member Function Documentation

void CSmbArpMaster::AssignAddress | ( | CUdid & | udid,
 |  | const CI2cAddress & | addr
 | ) |  |

Sends a SMBus "Assign Address" command.

Parameters
udid | UDID of the slave device
addr | I2C address to be assigned to the slave device
void CSmbArpMaster::ExecuteArp | ( | const std::vector< CI2cAddress > & | reserved_addr,
 |  | std::vector< CUdid > & | devices
 | ) |  |

This method executes the complete ARP process. After sending "Prepare to ARP" to the SMBus, this method assigns an I2C address to each found slave device.

If there are slave devices on the SMBus, which do not support the ARP protocol, their I2C address must be added to the reserved_addr parameter.

Parameters
reserved_addr | I2C addresses, which cannot be assigned to ARP slaves
devices | UDID informations of the found slave devices
void CSmbArpMaster::GetUdid ( CUdid & udid )

Sends a SMBus "Get UDID (General)" command.

Parameters
udid read UDID
void CSmbArpMaster::GetUdid | ( | const CI2cAddress & | addr,
 |  | CUdid & | udid
 | ) |  |

Sends a SMBus "Get UDID (Directed)" command.

Parameters
addr | I2C address of the slave device to be queried
udid | read UDID
void CSmbArpMaster::PrepareToArp ( )

Sends a SMBus "Prepare to ARP" command.

void CSmbArpMaster::ResetDevice ( )

Sends a SMBus "Reset Device (General)" command.

void CSmbArpMaster::ResetDevice ( const CI2cAddress & addr )

Sends a SMBus "Reset Device ARP (Directed)" command.

Parameters
addr I2C address of the the slave device


I2C.C++ API: Member List

  • CSmbArpMaster
telos::I2cApi::Cpp::CSmbArpMaster Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbArpMaster, including all inherited members.

AssignAddress(CUdid &udid, const CI2cAddress &addr) | telos::I2cApi::Cpp::CSmbArpMaster |
CSmbArpMaster(CBoard &board) | telos::I2cApi::Cpp::CSmbArpMaster | explicit
ExecuteArp(const std::vector< CI2cAddress > &reserved_addr, std::vector< CUdid > &devices) | telos::I2cApi::Cpp::CSmbArpMaster |
GetUdid(CUdid &udid) | telos::I2cApi::Cpp::CSmbArpMaster |
GetUdid(const CI2cAddress &addr, CUdid &udid) | telos::I2cApi::Cpp::CSmbArpMaster |
PrepareToArp() | telos::I2cApi::Cpp::CSmbArpMaster |
ResetDevice() | telos::I2cApi::Cpp::CSmbArpMaster |
ResetDevice(const CI2cAddress &addr) | telos::I2cApi::Cpp::CSmbArpMaster |


I2C.C++ API: telos::I2cApi::Cpp::CSmbArpMaster::CUdid Class Reference

  • CSmbArpMaster
  • CUdid
Public Types | Public Member Functions | Public Attributes | List of all members
telos::I2cApi::Cpp::CSmbArpMaster::CUdid Class Reference

#include <CSmbArpMaster.h>

Public Types

enum EAddressType { ADDR_TYPE_FIXED = 0, ADDR_TYPE_DYNAMIC_PERSISTENT = 1, ADDR_TYPE_DYNAMIC_VOLATILE = 2, ADDR_TYPE_RANDOM = 3 }

Public Member Functions

EAddressType | GetAddressType () const
bool | GetPecSupport () const
uint8_t | GetUdidVersion () const
uint8_t | GetSiliconRevision () const
uint16_t | GetVendorId () const
uint16_t | GetDeviceId () const
bool | GetZoneSupport () const
bool | GetIpmiSupport () const
bool | GetAsfSupport () const
bool | GetOemSupport () const
uint8_t | GetSmbusVersion () const
uint16_t | GetSubsystemVendorId () const
uint16_t | GetSubsystemDeviceId () const
uint32_t | GetVendorSpecificId () const
bool | IsAddressAvailable () const
CI2cAddress | GetAddress () const
void | SetAddress (const CI2cAddress &address)

Public Attributes

uint8_t | raw [16]
raw UDID bytes as used on the SMBus
uint8_t | addr
raw "device slave addr" as used on the SMBus

Detailed Description

Each SMBus slave device supporting ARP has got an UDID.

Member Enumeration Documentation

enum telos::I2cApi::Cpp::CSmbArpMaster::CUdid::EAddressType

This enumeration specifies the I2C address type used by a slave device.

Enumerator
ADDR_TYPE_FIXED | fixed address device
ADDR_TYPE_DYNAMIC_PERSISTENT | dynamic and persistent address device
ADDR_TYPE_DYNAMIC_VOLATILE | dynamic and volatile address device
ADDR_TYPE_RANDOM | random number device

Member Function Documentation

CI2cAddress CSmbArpMaster::CUdid::GetAddress ( ) const

Returns the I2C address of the slave device.

Returns
I2C slave address
CSmbArpMaster::CUdid::EAddressType CSmbArpMaster::CUdid::GetAddressType ( ) const

Returns the "Address Type".

Returns
"Address Type"
bool CSmbArpMaster::CUdid::GetAsfSupport ( ) const

Returns "ASF Support".

Returns
"ASF Support"
uint16_t CSmbArpMaster::CUdid::GetDeviceId ( ) const

Returns the "Device ID".

Returns
"Device ID"
bool CSmbArpMaster::CUdid::GetIpmiSupport ( ) const

Returns "IPMI Support".

Returns
"IPMI Support"
bool CSmbArpMaster::CUdid::GetOemSupport ( ) const

Returns "OEM Support".

Returns
"OEM Support"
bool CSmbArpMaster::CUdid::GetPecSupport ( ) const

Returns "PEC Supported".

Returns
"PEC Supported"
uint8_t CSmbArpMaster::CUdid::GetSiliconRevision ( ) const

Returns the "Silicion Revision ID".

Returns
"Silicion Revision ID"
uint8_t CSmbArpMaster::CUdid::GetSmbusVersion ( ) const

Returns the "SMBus Version".

Returns
"SMBus Version"
uint16_t CSmbArpMaster::CUdid::GetSubsystemDeviceId ( ) const

Returns the "Subsystem Device ID".

Returns
"Subsystem Device ID"
uint16_t CSmbArpMaster::CUdid::GetSubsystemVendorId ( ) const

Returns the "Subsystem Vendor ID".

Returns
"Subsystem Vendor ID"
uint8_t CSmbArpMaster::CUdid::GetUdidVersion ( ) const

Returns the "UDID Version".

Returns
"UDID Version"
uint16_t CSmbArpMaster::CUdid::GetVendorId ( ) const

Returns the "Vendor ID".

Returns
"Vendor ID"
uint32_t CSmbArpMaster::CUdid::GetVendorSpecificId ( ) const

Returns the "Vendor Specific ID".

Returns
"Vendor Specific ID"
bool CSmbArpMaster::CUdid::GetZoneSupport ( ) const

Returns "ZONE Support".

Returns
"ZONE Support"
bool CSmbArpMaster::CUdid::IsAddressAvailable ( ) const

Tests whether the slave device has got an I2C address.

Returns
I2C address available (true), I2C address not available (false)
void CSmbArpMaster::CUdid::SetAddress ( const CI2cAddress & address )

Sets the I2C address of the slave device.

Parameters
address I2C slave address


I2C.C++ API: Member List

  • CSmbArpMaster
  • CUdid
telos::I2cApi::Cpp::CSmbArpMaster::CUdid Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbArpMaster::CUdid, including all inherited members.

addr | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
ADDR_TYPE_DYNAMIC_PERSISTENT enum value | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
ADDR_TYPE_DYNAMIC_VOLATILE enum value | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
ADDR_TYPE_FIXED enum value | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
ADDR_TYPE_RANDOM enum value | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
EAddressType enum name | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetAddress() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetAddressType() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetAsfSupport() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetDeviceId() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetIpmiSupport() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetOemSupport() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetPecSupport() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetSiliconRevision() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetSmbusVersion() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetSubsystemDeviceId() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetSubsystemVendorId() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetUdidVersion() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetVendorId() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetVendorSpecificId() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
GetZoneSupport() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
IsAddressAvailable() const | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
raw | telos::I2cApi::Cpp::CSmbArpMaster::CUdid
SetAddress(const CI2cAddress &address) | telos::I2cApi::Cpp::CSmbArpMaster::CUdid


I2C.C++ API: telos::I2cApi::Cpp::CSmbMaster Class Reference

  • CSmbMaster
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMaster Class Reference

#include <CSmbMaster.h>

Public Member Functions

CSmbMaster (CBoard &board)
void | CalculateCrc8 (uint8_t data, uint8_t &crc) const
void | TransferData (const CSmbMasterMessageQuickCommand &msg)
void | TransferData (const CSmbMasterMessageSendByte &msg)
void | TransferData (CSmbMasterMessageReceiveByte &msg)
void | TransferData (const CSmbMasterMessageWriteByte &msg)
void | TransferData (CSmbMasterMessageReadByte &msg)
void | TransferData (const CSmbMasterMessageWriteWord &msg)
void | TransferData (CSmbMasterMessageReadWord &msg)
void | TransferData (const CSmbMasterMessageWrite32 &msg)
void | TransferData (CSmbMasterMessageRead32 &msg)
void | TransferData (const CSmbMasterMessageWrite64 &msg)
void | TransferData (CSmbMasterMessageRead64 &msg)
void | TransferData (CSmbMasterMessageCmdProcessCall &msg)
void | TransferData (const CSmbMasterMessageBlockWrite &msg)
void | TransferData (CSmbMasterMessageBlockRead &msg)
void | TransferData (CSmbMasterMessageBlockWriteRead &msg)
void | TransferData (const CSmbMasterMessageHostNotify &msg)
void | TransferData (CSmbMasterMessage &msg)
void | TransferData (const CPmbusMasterMessageWriteByte &msg)
void | TransferData (CPmbusMasterMessageReadByte &msg)
void | TransferData (const CPmbusMasterMessageWriteWord &msg)
void | TransferData (CPmbusMasterMessageReadWord &msg)
void | TransferData (const CPmbusMasterMessageGroupCmd &msg)
void | TransferData (CPmbusMasterMessage &msg)
void | GetPendingAlerts (std::vector< CI2cAddress > &devices, bool ignore_alert_pin)

Detailed Description

This class can be used to send master messages to a SMBus and a PMBus.

The SMBus is specified in:

System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Different message types are defined by the SMBus:

  • Quick Command
  • Send Byte
  • Receive Byte
  • Write Byte
  • Read Byte
  • Write Word
  • Read Word
  • Write 32
  • Read 32
  • Write 64
  • Read 64
  • Process Call
  • Block Write
  • Block Read
  • Block Write - Block Read Process Call
  • Host Notify

A SMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

The PMBus is specified in:

PMBus
Revision 1.2
6 September 2010
http://pmbus.org/

This bus is based on the SMBus, but some additional message types have been added:

  • Write Byte (with extension code)
  • Read Byte (with extension code)
  • Write Word (with extension code)
  • Read Word (with extension code)
  • Group Command
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CSmbMaster::CSmbMaster ( CBoard & board )
explicit

Constructor: the I2C interface has to support the SMBus. Whether an I2C interface supports the SMBus can be determined by evaluating SHardwareInfo::bus_type_smb variable, which can be accessed using GetHardwareInfoOfOpenDevice().

Parameters
board CBoard object, to which the SMBus master messages should be sent.

Member Function Documentation

void CSmbMaster::CalculateCrc8 | ( | uint8_t | data,
 |  | uint8_t & | crc
 | ) |  | const

Calculates a CRC-8 checksum.

Parameters
data | data
crc | CRC-8 checksum
void CSmbMaster::GetPendingAlerts | ( | std::vector< CI2cAddress > & | devices,
 |  | bool | ignore_alert_pin
 | ) |  |

If at least one SMBus slave has pulled the SMBALERT line to low, this method sends "Alert Response" messages to get a list of devices in alert state (see section A.2 in the standard).

Parameters
devices | devices in alert state
ignore_alert_pin | use SMBALERT line (false), ignore SMBALERT line (true)
void CSmbMaster::TransferData ( const CSmbMasterMessageQuickCommand & msg )

Sends a "Quick Command" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CSmbMasterMessageSendByte & msg )

Sends a "Send Byte" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageReceiveByte & msg )

Sends a "Receive Byte" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CSmbMasterMessageWriteByte & msg )

Sends a "Write Byte" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageReadByte & msg )

Sends a "Read Byte" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CSmbMasterMessageWriteWord & msg )

Sends a "Write Word" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageReadWord & msg )

Sends a "Read Word" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CSmbMasterMessageWrite32 & msg )

Sends a "Write 32" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageRead32 & msg )

Sends a "Read 32" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CSmbMasterMessageWrite64 & msg )

Sends a "Write 64" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageRead64 & msg )

Sends a "Read 64" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageCmdProcessCall & msg )

Sends a "Process Call" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CSmbMasterMessageBlockWrite & msg )

Sends a "Block Write" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageBlockRead & msg )

Sends a "Block Read" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessageBlockWriteRead & msg )

Sends a "Block Write Read" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CSmbMasterMessageHostNotify & msg )

Sends a "Host Notify" master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CSmbMasterMessage & msg )

Sends a master message to the SMBus/PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CPmbusMasterMessageWriteByte & msg )

Sends a "Extended Command: Write Byte" master message to the PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CPmbusMasterMessageReadByte & msg )

Sends a "Extended Command: Read Byte" master message to the PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CPmbusMasterMessageWriteWord & msg )

Sends a "Extended Command: Write Word" master message to the PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CPmbusMasterMessageReadWord & msg )

Sends a "Extended Command: Read Word" master message to the PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( const CPmbusMasterMessageGroupCmd & msg )

Sends a "Group Command" master message to the PMBus.

Parameters
msg master message to be sent
void CSmbMaster::TransferData ( CPmbusMasterMessage & msg )

Sends a master message to the PMBus.

Parameters
msg master message to be sent


I2C.C++ API: Member List

  • CSmbMaster
telos::I2cApi::Cpp::CSmbMaster Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMaster, including all inherited members.

CalculateCrc8(uint8_t data, uint8_t &crc) const | telos::I2cApi::Cpp::CSmbMaster |
CSmbMaster(CBoard &board) | telos::I2cApi::Cpp::CSmbMaster | explicit
GetPendingAlerts(std::vector< CI2cAddress > &devices, bool ignore_alert_pin) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageQuickCommand &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageSendByte &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageReceiveByte &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageWriteByte &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageReadByte &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageWriteWord &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageReadWord &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageWrite32 &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageRead32 &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageWrite64 &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageRead64 &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageCmdProcessCall &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageBlockWrite &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageBlockRead &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessageBlockWriteRead &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CSmbMasterMessageHostNotify &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CSmbMasterMessage &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CPmbusMasterMessageWriteByte &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CPmbusMasterMessageReadByte &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CPmbusMasterMessageWriteWord &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CPmbusMasterMessageReadWord &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(const CPmbusMasterMessageGroupCmd &msg) | telos::I2cApi::Cpp::CSmbMaster |
TransferData(CPmbusMasterMessage &msg) | telos::I2cApi::Cpp::CSmbMaster |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessage Class Reference

  • CSmbMasterMessage
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessage Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessage:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessageHostNotify telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte telos::I2cApi::Cpp::CSmbMasterMessageSendByte telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead telos::I2cApi::Cpp::CSmbMasterMessageCmd32 telos::I2cApi::Cpp::CSmbMasterMessageCmd64 telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock telos::I2cApi::Cpp::CSmbMasterMessageCmdByte telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall telos::I2cApi::Cpp::CSmbMasterMessageCmdWord telos::I2cApi::Cpp::CSmbMasterMessageRead32 telos::I2cApi::Cpp::CSmbMasterMessageWrite32 telos::I2cApi::Cpp::CSmbMasterMessageRead64 telos::I2cApi::Cpp::CSmbMasterMessageWrite64 telos::I2cApi::Cpp::CSmbMasterMessageBlockRead telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite telos::I2cApi::Cpp::CSmbMasterMessageReadByte telos::I2cApi::Cpp::CSmbMasterMessageWriteByte telos::I2cApi::Cpp::CSmbMasterMessageReadWord telos::I2cApi::Cpp::CSmbMasterMessageWriteWord

Public Member Functions

const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Protected Member Functions

CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class is used as a base class for all SMBus master messages.

The SMBus is specified in:

System Management Bus
Version 3.0
20 Dec 2014
http://smbus.org/specs/

Different message types are defined by the SMBus:

  • Quick Command
  • Send Byte
  • Receive Byte
  • Write Byte
  • Read Byte
  • Write Word
  • Read Word
  • Write 32
  • Read 32
  • Write 64
  • Read 64
  • Process Call
  • Block Write
  • Block Read
  • Block Write - Block Read Process Call
  • Host Notify

A SMBus message can contain a PEC (Packet Error Code) as the last byte of a message. The PEC is a CRC-8 checksum.

Instances of classes derived from this class can be sent to the SMBus with the CSmbMaster::TransferData() method.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessage::CSmbMasterMessage ( const CI2cAddress & i2c_address )
protected

Constructor

The SMBus supports only 7-bit I2C addresses.

Parameters
i2c_address I2C address of the slave

Member Function Documentation

const CI2cAddress & CSmbMasterMessage::GetAddress ( ) const

Returns the I2C address of the slave.

Returns
I2C address of the slave
void CSmbMasterMessage::SetAddress ( const CI2cAddress & i2c_address )

Sets the I2C address of the slave.

The SMBus supports only 7-bit I2C addresses.

Parameters
i2c_address I2C address of the slave
Examples:
MasterExample.cpp.


I2C.C++ API: Member List

  • CSmbMasterMessage
telos::I2cApi::Cpp::CSmbMasterMessage Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessage, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageBlockRead Class Reference

  • CSmbMasterMessageBlockRead
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageBlockRead Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageBlockRead:
telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageBlockRead ()
CSmbMasterMessageBlockRead (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
std::vector< uint8_t > & | GetData ()
const std::vector< uint8_t > & | GetData () const
void | SetData (const std::vector< uint8_t > &data)
template<class InputIterator >
void | SetData (InputIterator first, InputIterator last)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
CSmbMasterMessageCmdBlock (const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Block Read" (see section 6.5.7 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CSmbMasterMessageBlockRead::CSmbMasterMessageBlockRead ( )

Constructor

CSmbMasterMessageBlockRead::CSmbMasterMessageBlockRead | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageBlockRead
telos::I2cApi::Cpp::CSmbMasterMessageBlockRead Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageBlockRead, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageBlockRead() | telos::I2cApi::Cpp::CSmbMasterMessageBlockRead |
CSmbMasterMessageBlockRead(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageBlockRead |
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdBlock(const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
SetData(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock | inline
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite Class Reference

  • CSmbMasterMessageBlockWrite
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite:
telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageBlockWrite ()
CSmbMasterMessageBlockWrite (const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec)
template<class InputIterator >
CSmbMasterMessageBlockWrite (const CI2cAddress &i2c_address, uint8_t cmd, InputIterator data_first, InputIterator data_last, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
std::vector< uint8_t > & | GetData ()
const std::vector< uint8_t > & | GetData () const
void | SetData (const std::vector< uint8_t > &data)
template<class InputIterator >
void | SetData (InputIterator first, InputIterator last)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
CSmbMasterMessageCmdBlock (const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Block Write" (see section 6.5.7 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageBlockWrite::CSmbMasterMessageBlockWrite ( )

Constructor

CSmbMasterMessageBlockWrite::CSmbMasterMessageBlockWrite | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | const std::vector< uint8_t > & | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transmitted
with_pec | use PEC (true), do not use PEC (false)
template<class InputIterator >
telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite::CSmbMasterMessageBlockWrite | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | InputIterator | data_first,
 |  | InputIterator | data_last,
 |  | bool | with_pec
 | ) |  |
inline

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data_first | first position of data to be transmitted
data_last | last position of data to be transmitted
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageBlockWrite
telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageBlockWrite() | telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite |
CSmbMasterMessageBlockWrite(const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite |
CSmbMasterMessageBlockWrite(const CI2cAddress &i2c_address, uint8_t cmd, InputIterator data_first, InputIterator data_last, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite | inline
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdBlock(const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
SetData(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock | inline
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead Class Reference

  • CSmbMasterMessageBlockWriteRead
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageBlockWriteRead ()
CSmbMasterMessageBlockWriteRead (const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data_tx, bool with_pec)
template<class InputIterator >
CSmbMasterMessageBlockWriteRead (const CI2cAddress &i2c_address, uint8_t cmd, InputIterator data_tx_first, InputIterator data_tx_last, bool with_pec)
std::vector< uint8_t > & | GetDataTx ()
const std::vector< uint8_t > & | GetDataTx () const
void | SetDataTx (const std::vector< uint8_t > &data)
template<class InputIterator >
void | SetDataTx (InputIterator first, InputIterator last)
std::vector< uint8_t > & | GetDataRx ()
const std::vector< uint8_t > & | GetDataRx () const
void | SetDataRx (const std::vector< uint8_t > &data)
template<class InputIterator >
void | SetDataRx (InputIterator first, InputIterator last)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Block Write - Block Read Process Call" (see section 6.5.8 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageBlockWriteRead::CSmbMasterMessageBlockWriteRead ( )

Constructor

CSmbMasterMessageBlockWriteRead::CSmbMasterMessageBlockWriteRead | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | const std::vector< uint8_t > & | data_tx,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data_tx | data to be transmitted
with_pec | use PEC (true), do not use PEC (false)
template<class InputIterator >
telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead::CSmbMasterMessageBlockWriteRead | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | InputIterator | data_tx_first,
 |  | InputIterator | data_tx_last,
 |  | bool | with_pec
 | ) |  |
inline

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data_tx_first | first position of data to be transmitted
data_tx_last | last position of data to be transmitted
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

std::vector< uint8_t > & CSmbMasterMessageBlockWriteRead::GetDataRx ( )

Returns the received data.

Returns
data received data
const std::vector< uint8_t > & CSmbMasterMessageBlockWriteRead::GetDataRx ( ) const

Returns the received data.

Returns
data received data
std::vector< uint8_t > & CSmbMasterMessageBlockWriteRead::GetDataTx ( )

Returns the data to be transmitted.

Returns
data to be transmitted
const std::vector< uint8_t > & CSmbMasterMessageBlockWriteRead::GetDataTx ( ) const

Returns the data to be transmitted.

Returns
data to be transmitted
void CSmbMasterMessageBlockWriteRead::SetDataRx ( const std::vector< uint8_t > & data )

Sets the received data.

Parameters
data data received data
template<class InputIterator >
void telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead::SetDataRx | ( | InputIterator | first,
 |  | InputIterator | last
 | ) |  |
inline

Sets the received data.

Parameters
first | first position of received data
last | last position of received data
void CSmbMasterMessageBlockWriteRead::SetDataTx ( const std::vector< uint8_t > & data )

Sets the data to be transmitted.

Parameters
data data to be transmitted
template<class InputIterator >
void telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead::SetDataTx | ( | InputIterator | first,
 |  | InputIterator | last
 | ) |  |
inline

Sets the data to be transmitted.

Parameters
first | first position of data to be transmitted
last | last position of data to be transmitted


I2C.C++ API: Member List

  • CSmbMasterMessageBlockWriteRead
telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageBlockWriteRead() | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
CSmbMasterMessageBlockWriteRead(const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data_tx, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
CSmbMasterMessageBlockWriteRead(const CI2cAddress &i2c_address, uint8_t cmd, InputIterator data_tx_first, InputIterator data_tx_last, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead | inline
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetDataRx() | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
GetDataRx() const | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
GetDataTx() | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
GetDataTx() const | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetDataRx(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
SetDataRx(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead | inline
SetDataTx(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead |
SetDataTx(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead | inline
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageCmd Class Reference

  • CSmbMasterMessageCmd
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageCmd Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageCmd:
telos::I2cApi::Cpp::CSmbMasterMessage telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead telos::I2cApi::Cpp::CSmbMasterMessageCmd32 telos::I2cApi::Cpp::CSmbMasterMessageCmd64 telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock telos::I2cApi::Cpp::CSmbMasterMessageCmdByte telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall telos::I2cApi::Cpp::CSmbMasterMessageCmdWord telos::I2cApi::Cpp::CSmbMasterMessageRead32 telos::I2cApi::Cpp::CSmbMasterMessageWrite32 telos::I2cApi::Cpp::CSmbMasterMessageRead64 telos::I2cApi::Cpp::CSmbMasterMessageWrite64 telos::I2cApi::Cpp::CSmbMasterMessageBlockRead telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite telos::I2cApi::Cpp::CSmbMasterMessageReadByte telos::I2cApi::Cpp::CSmbMasterMessageWriteByte telos::I2cApi::Cpp::CSmbMasterMessageReadWord telos::I2cApi::Cpp::CSmbMasterMessageWriteWord

Public Member Functions

uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Protected Member Functions

CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class is used as a base class for all SMBus master messages, which contain a command and an optional PEC byte.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageCmd::CSmbMasterMessageCmd | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint8_t CSmbMasterMessageCmd::GetCommand ( ) const

Returns the command byte of the message.

Returns
command byte
Examples:
MasterExample.cpp.
bool CSmbMasterMessageCmd::GetWithPec ( ) const

Returns whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void CSmbMasterMessageCmd::SetCommand ( uint8_t cmd )

Sets the command byte of the message.

Returns
command byte
Examples:
MasterExample.cpp.
void CSmbMasterMessageCmd::SetWithPec ( bool with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)
Examples:
MasterExample.cpp.


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageCmd32 Class Reference

  • CSmbMasterMessageCmd32
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageCmd32 Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageCmd32:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage telos::I2cApi::Cpp::CSmbMasterMessageRead32 telos::I2cApi::Cpp::CSmbMasterMessageWrite32

Public Member Functions

uint32_t | GetData () const
void | SetData (uint32_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Protected Member Functions

CSmbMasterMessageCmd32 (const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class is used as a base class for the "Write 32" and "Read 32" SMBus master messages.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageCmd32::CSmbMasterMessageCmd32 | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint32_t | data,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint32_t CSmbMasterMessageCmd32::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
void CSmbMasterMessageCmd32::SetData ( uint32_t data )

Sets the data to be transmitted or the received data.

Parameters
data data


I2C.C++ API: Member List

  • CSmbMasterMessageCmd32
telos::I2cApi::Cpp::CSmbMasterMessageCmd32 Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageCmd32, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmd32(const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint32_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageCmd64 Class Reference

  • CSmbMasterMessageCmd64
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageCmd64 Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageCmd64:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage telos::I2cApi::Cpp::CSmbMasterMessageRead64 telos::I2cApi::Cpp::CSmbMasterMessageWrite64

Public Member Functions

uint64_t | GetData () const
void | SetData (uint64_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Protected Member Functions

CSmbMasterMessageCmd64 (const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class is used as a base class for the "Write 64" and "Read 64" SMBus master messages.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageCmd64::CSmbMasterMessageCmd64 | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint64_t | data,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint64_t CSmbMasterMessageCmd64::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
void CSmbMasterMessageCmd64::SetData ( uint64_t data )

Sets the data to be transmitted or the received data.

Parameters
data data


I2C.C++ API: Member List

  • CSmbMasterMessageCmd64
telos::I2cApi::Cpp::CSmbMasterMessageCmd64 Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageCmd64, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmd64(const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint64_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock Class Reference

  • CSmbMasterMessageCmdBlock
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage telos::I2cApi::Cpp::CSmbMasterMessageBlockRead telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite

Public Member Functions

std::vector< uint8_t > & | GetData ()
const std::vector< uint8_t > & | GetData () const
void | SetData (const std::vector< uint8_t > &data)
template<class InputIterator >
void | SetData (InputIterator first, InputIterator last)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Protected Member Functions

CSmbMasterMessageCmdBlock (const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class is used as a base class for the "Block Write" and "Block Read" SMBus master messages.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageCmdBlock::CSmbMasterMessageCmdBlock | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | const std::vector< uint8_t > & | data,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

std::vector< uint8_t > & CSmbMasterMessageCmdBlock::GetData ( )

Returns the data to be transmitted or the received data.

Returns
data
Examples:
MasterExample.cpp.
const std::vector< uint8_t > & CSmbMasterMessageCmdBlock::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
void CSmbMasterMessageCmdBlock::SetData ( const std::vector< uint8_t > & data )

Sets the data to be transmitted or the received data.

Parameters
data data
template<class InputIterator >
void telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock::SetData | ( | InputIterator | first,
 |  | InputIterator | last
 | ) |  |
inline

Sets the data to be transmitted or the received data.

Parameters
first | first position of data
last | last position of data


I2C.C++ API: Member List

  • CSmbMasterMessageCmdBlock
telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdBlock(const CI2cAddress &i2c_address, uint8_t cmd, const std::vector< uint8_t > &data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(const std::vector< uint8_t > &data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock |
SetData(InputIterator first, InputIterator last) | telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock | inline
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageCmdByte Class Reference

  • CSmbMasterMessageCmdByte
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageCmdByte Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageCmdByte:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage telos::I2cApi::Cpp::CSmbMasterMessageReadByte telos::I2cApi::Cpp::CSmbMasterMessageWriteByte

Public Member Functions

uint8_t | GetData () const
void | SetData (uint8_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Protected Member Functions

CSmbMasterMessageCmdByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class is used as a base class for the "Write Byte" and "Read Byte" SMBus master messages.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageCmdByte::CSmbMasterMessageCmdByte | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | data,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint8_t CSmbMasterMessageCmdByte::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
Examples:
MasterExample.cpp.
void CSmbMasterMessageCmdByte::SetData ( uint8_t data )

Sets the data to be transmitted or the received data.

Parameters
data data


I2C.C++ API: Member List

  • CSmbMasterMessageCmdByte
telos::I2cApi::Cpp::CSmbMasterMessageCmdByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageCmdByte, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint8_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall Class Reference

  • CSmbMasterMessageCmdProcessCall
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageCmdProcessCall ()
CSmbMasterMessageCmdProcessCall (const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data_tx, bool with_pec)
uint16_t | GetDataTx () const
void | SetDataTx (uint16_t data)
uint16_t | GetDataRx () const
void | SetDataRx (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Process Call" (see section 6.5.6 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageCmdProcessCall::CSmbMasterMessageCmdProcessCall ( )

Constructor

CSmbMasterMessageCmdProcessCall::CSmbMasterMessageCmdProcessCall | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint16_t | data_tx,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data_tx | data to be transmitted
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint16_t CSmbMasterMessageCmdProcessCall::GetDataRx ( ) const

Returns the received data.

Returns
received data
uint16_t CSmbMasterMessageCmdProcessCall::GetDataTx ( ) const

Returns the data to be transmitted.

Returns
data to be transmitted
void CSmbMasterMessageCmdProcessCall::SetDataRx ( uint16_t data )

Sets the received data

Parameters
data received data
void CSmbMasterMessageCmdProcessCall::SetDataTx ( uint16_t data )

Sets the data to be transmitted

Parameters
data data to be transmitted


I2C.C++ API: Member List

  • CSmbMasterMessageCmdProcessCall
telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdProcessCall() | telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall |
CSmbMasterMessageCmdProcessCall(const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data_tx, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetDataRx() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall |
GetDataTx() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetDataRx(uint16_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall |
SetDataTx(uint16_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageCmdWord Class Reference

  • CSmbMasterMessageCmdWord
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageCmdWord Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageCmdWord:
telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage telos::I2cApi::Cpp::CSmbMasterMessageReadWord telos::I2cApi::Cpp::CSmbMasterMessageWriteWord

Public Member Functions

uint16_t | GetData () const
void | SetData (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Protected Member Functions

CSmbMasterMessageCmdWord (const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class is used as a base class for the "Write Word" and "Read Word" SMBus master messages.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageCmdWord::CSmbMasterMessageCmdWord | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint16_t | data,
 |  | bool | with_pec
 | ) |  |
protected

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint16_t CSmbMasterMessageCmdWord::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
Examples:
MasterExample.cpp.
void CSmbMasterMessageCmdWord::SetData ( uint16_t data )

Sets the data to be transmitted or the received data.

Parameters
data data
Examples:
MasterExample.cpp.


I2C.C++ API: Member List

  • CSmbMasterMessageCmdWord
telos::I2cApi::Cpp::CSmbMasterMessageCmdWord Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageCmdWord, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdWord(const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint16_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageHostNotify Class Reference

  • CSmbMasterMessageHostNotify
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageHostNotify Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageHostNotify:
telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageHostNotify ()
CSmbMasterMessageHostNotify (const CI2cAddress &i2c_address, uint16_t data)
uint16_t | GetData () const
void | SetData (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Host Notify" (see section 6.5.9 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageHostNotify::CSmbMasterMessageHostNotify ( )

Constructor

CSmbMasterMessageHostNotify::CSmbMasterMessageHostNotify | ( | const CI2cAddress & | i2c_address,
 |  | uint16_t | data
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
data | data to be transferred

Member Function Documentation

uint16_t CSmbMasterMessageHostNotify::GetData ( ) const

Returns the data to be transmitted or the received data.

Returns
data
void CSmbMasterMessageHostNotify::SetData ( uint16_t data )

Sets the data to be transmitted or the received data.

Parameters
data data


I2C.C++ API: Member List

  • CSmbMasterMessageHostNotify
telos::I2cApi::Cpp::CSmbMasterMessageHostNotify Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageHostNotify, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageHostNotify() | telos::I2cApi::Cpp::CSmbMasterMessageHostNotify |
CSmbMasterMessageHostNotify(const CI2cAddress &i2c_address, uint16_t data) | telos::I2cApi::Cpp::CSmbMasterMessageHostNotify |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageHostNotify |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetData(uint16_t data) | telos::I2cApi::Cpp::CSmbMasterMessageHostNotify |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand Class Reference

  • CSmbMasterMessageQuickCommand
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand:
telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageQuickCommand ()
CSmbMasterMessageQuickCommand (const CI2cAddress &i2c_address, bool tx_direction)
bool | GetTxDirection () const
void | SetTxDirection (bool tx_direction)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Quick Command" (see section 6.5.1 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageQuickCommand::CSmbMasterMessageQuickCommand ( )

Constructor

CSmbMasterMessageQuickCommand::CSmbMasterMessageQuickCommand | ( | const CI2cAddress & | i2c_address,
 |  | bool | tx_direction
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
tx_direction | direction: master transmitter (true), master receiver (false)

Member Function Documentation

bool CSmbMasterMessageQuickCommand::GetTxDirection ( ) const

Returns the direction of the transfer.

Returns
direction: master transmitter (true), master receiver (false)
void CSmbMasterMessageQuickCommand::SetTxDirection ( bool tx_direction )

Sets the direction of the transfer.

Parameters
tx_direction direction: master transmitter (true), master receiver (false)


I2C.C++ API: Member List

  • CSmbMasterMessageQuickCommand
telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageQuickCommand() | telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand |
CSmbMasterMessageQuickCommand(const CI2cAddress &i2c_address, bool tx_direction) | telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetTxDirection() const | telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetTxDirection(bool tx_direction) | telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageRead32 Class Reference

  • CSmbMasterMessageRead32
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageRead32 Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageRead32:
telos::I2cApi::Cpp::CSmbMasterMessageCmd32 telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageRead32 ()
CSmbMasterMessageRead32 (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd32
uint32_t | GetData () const
void | SetData (uint32_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd32
CSmbMasterMessageCmd32 (const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Read 32" (see section 6.5.11 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageRead32::CSmbMasterMessageRead32 ( )

Constructor

CSmbMasterMessageRead32::CSmbMasterMessageRead32 | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageRead32
telos::I2cApi::Cpp::CSmbMasterMessageRead32 Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageRead32, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmd32(const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 | protected
CSmbMasterMessageRead32() | telos::I2cApi::Cpp::CSmbMasterMessageRead32 |
CSmbMasterMessageRead32(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageRead32 |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint32_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageRead64 Class Reference

  • CSmbMasterMessageRead64
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageRead64 Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageRead64:
telos::I2cApi::Cpp::CSmbMasterMessageCmd64 telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageRead64 ()
CSmbMasterMessageRead64 (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd64
uint64_t | GetData () const
void | SetData (uint64_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd64
CSmbMasterMessageCmd64 (const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Read 64" (see section 6.5.13 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageRead64::CSmbMasterMessageRead64 ( )

Constructor

CSmbMasterMessageRead64::CSmbMasterMessageRead64 | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageRead64
telos::I2cApi::Cpp::CSmbMasterMessageRead64 Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageRead64, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmd64(const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 | protected
CSmbMasterMessageRead64() | telos::I2cApi::Cpp::CSmbMasterMessageRead64 |
CSmbMasterMessageRead64(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageRead64 |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint64_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageReadByte Class Reference

  • CSmbMasterMessageReadByte
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageReadByte Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageReadByte:
telos::I2cApi::Cpp::CSmbMasterMessageCmdByte telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageReadByte ()
CSmbMasterMessageReadByte (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
uint8_t | GetData () const
void | SetData (uint8_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
CSmbMasterMessageCmdByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Read Byte" (see section 6.5.5 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CSmbMasterMessageReadByte::CSmbMasterMessageReadByte ( )

Constructor

CSmbMasterMessageReadByte::CSmbMasterMessageReadByte | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageReadByte
telos::I2cApi::Cpp::CSmbMasterMessageReadByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageReadByte, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte | protected
CSmbMasterMessageReadByte() | telos::I2cApi::Cpp::CSmbMasterMessageReadByte |
CSmbMasterMessageReadByte(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageReadByte |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint8_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageReadWord Class Reference

  • CSmbMasterMessageReadWord
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageReadWord Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageReadWord:
telos::I2cApi::Cpp::CSmbMasterMessageCmdWord telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageReadWord ()
CSmbMasterMessageReadWord (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
uint16_t | GetData () const
void | SetData (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
CSmbMasterMessageCmdWord (const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Read Word" (see section 6.5.5 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageReadWord::CSmbMasterMessageReadWord ( )

Constructor

CSmbMasterMessageReadWord::CSmbMasterMessageReadWord | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageReadWord
telos::I2cApi::Cpp::CSmbMasterMessageReadWord Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageReadWord, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdWord(const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord | protected
CSmbMasterMessageReadWord() | telos::I2cApi::Cpp::CSmbMasterMessageReadWord |
CSmbMasterMessageReadWord(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageReadWord |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint16_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte Class Reference

  • CSmbMasterMessageReceiveByte
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte:
telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageReceiveByte ()
CSmbMasterMessageReceiveByte (const CI2cAddress &i2c_address, bool with_pec)
uint8_t | GetData () const
void | SetData (uint8_t data)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Receive Byte" (see section 6.5.3 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageReceiveByte::CSmbMasterMessageReceiveByte ( )

Constructor

CSmbMasterMessageReceiveByte::CSmbMasterMessageReceiveByte | ( | const CI2cAddress & | i2c_address,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint8_t CSmbMasterMessageReceiveByte::GetData ( ) const

Returns the data received from the slave.

Returns
data received from slave
bool CSmbMasterMessageReceiveByte::GetWithPec ( ) const

Returns whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void CSmbMasterMessageReceiveByte::SetData ( uint8_t data )

Sets the data received from the slave.

Parameters
data data received from slave
void CSmbMasterMessageReceiveByte::SetWithPec ( bool with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageReceiveByte
telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageReceiveByte() | telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte |
CSmbMasterMessageReceiveByte(const CI2cAddress &i2c_address, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetData(uint8_t data) | telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageSendByte Class Reference

  • CSmbMasterMessageSendByte
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageSendByte Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageSendByte:
telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageSendByte ()
CSmbMasterMessageSendByte (const CI2cAddress &i2c_address, uint8_t data, bool with_pec)
uint8_t | GetData () const
void | SetData (uint8_t data)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Send Byte" (see section 6.5.2 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageSendByte::CSmbMasterMessageSendByte ( )

Constructor

CSmbMasterMessageSendByte::CSmbMasterMessageSendByte | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
data | data to be sent
with_pec | use PEC (true), do not use PEC (false)

Member Function Documentation

uint8_t CSmbMasterMessageSendByte::GetData ( ) const

Returns the data to be sent to slave.

Returns
data to be sent
bool CSmbMasterMessageSendByte::GetWithPec ( ) const

Returns whether the message will use PEC or not.

Returns
use PEC (true), do not use PEC (false)
void CSmbMasterMessageSendByte::SetData ( uint8_t data )

Sets the data to be sent to slave.

Parameters
data data to be sent
void CSmbMasterMessageSendByte::SetWithPec ( bool with_pec )

Sets whether the message will use PEC or not.

Parameters
with_pec use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageSendByte
telos::I2cApi::Cpp::CSmbMasterMessageSendByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageSendByte, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageSendByte() | telos::I2cApi::Cpp::CSmbMasterMessageSendByte |
CSmbMasterMessageSendByte(const CI2cAddress &i2c_address, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageSendByte |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageSendByte |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageSendByte |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetData(uint8_t data) | telos::I2cApi::Cpp::CSmbMasterMessageSendByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageSendByte |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageWrite32 Class Reference

  • CSmbMasterMessageWrite32
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageWrite32 Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageWrite32:
telos::I2cApi::Cpp::CSmbMasterMessageCmd32 telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageWrite32 ()
CSmbMasterMessageWrite32 (const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd32
uint32_t | GetData () const
void | SetData (uint32_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd32
CSmbMasterMessageCmd32 (const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Write 32" (see section 6.5.10 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageWrite32::CSmbMasterMessageWrite32 ( )

Constructor

CSmbMasterMessageWrite32::CSmbMasterMessageWrite32 | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint32_t | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageWrite32
telos::I2cApi::Cpp::CSmbMasterMessageWrite32 Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageWrite32, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmd32(const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 | protected
CSmbMasterMessageWrite32() | telos::I2cApi::Cpp::CSmbMasterMessageWrite32 |
CSmbMasterMessageWrite32(const CI2cAddress &i2c_address, uint8_t cmd, uint32_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageWrite32 |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint32_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmd32 |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageWrite64 Class Reference

  • CSmbMasterMessageWrite64
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageWrite64 Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageWrite64:
telos::I2cApi::Cpp::CSmbMasterMessageCmd64 telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageWrite64 ()
CSmbMasterMessageWrite64 (const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd64
uint64_t | GetData () const
void | SetData (uint64_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd64
CSmbMasterMessageCmd64 (const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Write 64" (see section 6.5.12 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageWrite64::CSmbMasterMessageWrite64 ( )

Constructor

CSmbMasterMessageWrite64::CSmbMasterMessageWrite64 | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint64_t | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageWrite64
telos::I2cApi::Cpp::CSmbMasterMessageWrite64 Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageWrite64, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmd64(const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 | protected
CSmbMasterMessageWrite64() | telos::I2cApi::Cpp::CSmbMasterMessageWrite64 |
CSmbMasterMessageWrite64(const CI2cAddress &i2c_address, uint8_t cmd, uint64_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageWrite64 |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint64_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmd64 |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageWriteByte Class Reference

  • CSmbMasterMessageWriteByte
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageWriteByte Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageWriteByte:
telos::I2cApi::Cpp::CSmbMasterMessageCmdByte telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageWriteByte ()
CSmbMasterMessageWriteByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
uint8_t | GetData () const
void | SetData (uint8_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
CSmbMasterMessageCmdByte (const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Write Byte" (see section 6.5.4 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CSmbMasterMessageWriteByte::CSmbMasterMessageWriteByte ( )

Constructor

CSmbMasterMessageWriteByte::CSmbMasterMessageWriteByte | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint8_t | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageWriteByte
telos::I2cApi::Cpp::CSmbMasterMessageWriteByte Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageWriteByte, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte | protected
CSmbMasterMessageWriteByte() | telos::I2cApi::Cpp::CSmbMasterMessageWriteByte |
CSmbMasterMessageWriteByte(const CI2cAddress &i2c_address, uint8_t cmd, uint8_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageWriteByte |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint8_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdByte |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CSmbMasterMessageWriteWord Class Reference

  • CSmbMasterMessageWriteWord
Public Member Functions | List of all members
telos::I2cApi::Cpp::CSmbMasterMessageWriteWord Class Reference

#include <CSmbMasterMessage.h>

Inheritance diagram for telos::I2cApi::Cpp::CSmbMasterMessageWriteWord:
telos::I2cApi::Cpp::CSmbMasterMessageCmdWord telos::I2cApi::Cpp::CSmbMasterMessageCmd telos::I2cApi::Cpp::CSmbMasterMessage

Public Member Functions

CSmbMasterMessageWriteWord ()
CSmbMasterMessageWriteWord (const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
uint16_t | GetData () const
void | SetData (uint16_t data)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
uint8_t | GetCommand () const
void | SetCommand (uint8_t cmd)
bool | GetWithPec () const
void | SetWithPec (bool with_pec)
- Public Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
const CI2cAddress & | GetAddress () const
void | SetAddress (const CI2cAddress &i2c_address)

Additional Inherited Members

- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
CSmbMasterMessageCmdWord (const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessageCmd
CSmbMasterMessageCmd (const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec)
- Protected Member Functions inherited from telos::I2cApi::Cpp::CSmbMasterMessage
CSmbMasterMessage (const CI2cAddress &i2c_address)

Detailed Description

This class specifies a "Write Word" (see section 6.5.4 in the standard) master message for the SMBus.

Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH
Examples:
MasterExample.cpp.

Constructor & Destructor Documentation

CSmbMasterMessageWriteWord::CSmbMasterMessageWriteWord ( )

Constructor

CSmbMasterMessageWriteWord::CSmbMasterMessageWriteWord | ( | const CI2cAddress & | i2c_address,
 |  | uint8_t | cmd,
 |  | uint16_t | data,
 |  | bool | with_pec
 | ) |  |

Constructor

Parameters
i2c_address | I2C address of the slave
cmd | command byte
data | data to be transferred
with_pec | use PEC (true), do not use PEC (false)


I2C.C++ API: Member List

  • CSmbMasterMessageWriteWord
telos::I2cApi::Cpp::CSmbMasterMessageWriteWord Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageWriteWord, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
CSmbMasterMessageCmdWord(const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord | protected
CSmbMasterMessageWriteWord() | telos::I2cApi::Cpp::CSmbMasterMessageWriteWord |
CSmbMasterMessageWriteWord(const CI2cAddress &i2c_address, uint8_t cmd, uint16_t data, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageWriteWord |
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetData() const | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetData(uint16_t data) | telos::I2cApi::Cpp::CSmbMasterMessageCmdWord |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: telos::I2cApi::Cpp::CTimestamp Class Reference

  • CTimestamp
Public Member Functions | List of all members
telos::I2cApi::Cpp::CTimestamp Class Reference

#include <CTimestamp.h>

Public Member Functions

CTimestamp ()
Constructor. More...
CTimestamp (uint32_t msl, uint32_t lsl)
Constructor. More...
CTimestamp (uint64_t ts)
Constructor. More...
void | SetTimestamp (uint32_t msl, uint32_t lsl)
Sets the timestamp. More...
void | SetTimestamp (uint64_t ts)
Sets the timestamp. More...
uint32_t | GetTimestampMsl () const
Returns the most significant dword of the timestamp. More...
uint32_t | GetTimestampLsl () const
Returns the least significant dword of the timestamp. More...
uint64_t | GetTimestamp () const
Returns the timestamp. More...
std::string | GetTimestampAsHexString () const
Returns the 64 bit timestamp as hex string. More...
std::chrono::nanoseconds | GetTimestampAsDuration (const SHardwareInfo &hwinfo) const
Returns the 64 bit timestamp as duration. More...
void | SetInvalid ()
Sets the timestamp status to invalid. More...
bool | IsInvalid () const
Does the object contain a valid timestamp? More...
bool | operator< (const CTimestamp &ts) const
operator "<" More...
bool | operator<= (const CTimestamp &ts) const
operator "<=" More...
bool | operator> (const CTimestamp &ts) const
operator ">" More...
bool | operator>= (const CTimestamp &ts) const
operator ">=" More...
bool | operator== (const CTimestamp &ts) const
operator "==" More...
bool | operator!= (const CTimestamp &ts) const
operator "!=" More...
CTimestamp & operator-- ()
operator "--" More...
CTimestamp | operator-- (int)
operator "--" More...
CTimestamp & operator++ ()
operator "++" More...
CTimestamp | operator++ (int)
operator "++" More...

Detailed Description

Class to store and compare 64 bit timestamps. These timestamps are generated by the tracer CTracer, the input testpin tracer CInputTestpins, and the A/D converter CAdc.

If no timestamp is available, the method SetInvalid() can be used, to make a timestamp object invalid (MSL and LSL are set to "~0L").

The timebase of the timestamps is stored in SHardwareInfo::timestamp_timebase.

Author
telos Systementwicklung GmbH
Examples:
TracerCsvExample.cpp.

Constructor & Destructor Documentation

CTimestamp::CTimestamp ( )

Constructor: creates a timestamp object with an undefined value.

CTimestamp::CTimestamp | ( | uint32_t | msl,
 |  | uint32_t | lsl
 | ) |  |

Constructor: uses the two specified 32 bit values to initialise the 64 bit timestamp.

Parameters
msl | timestamp (most significant long)
lsl | timestamp (least significant long)
CTimestamp::CTimestamp ( uint64_t ts )
explicit

Constructor: uses the specified 64 bit value to initialise the 64 bit timestamp.

Parameters
ts timestamp

Member Function Documentation

uint64_t CTimestamp::GetTimestamp ( ) const

Returns the timestamp.

Returns
timestamp or N/A ("~0")
std::chrono::nanoseconds CTimestamp::GetTimestampAsDuration ( const SHardwareInfo & hwinfo ) const

Returns the timestamp as duration.

Parameters
hwinfo hardware information
Returns
duration
string CTimestamp::GetTimestampAsHexString ( ) const

Returns the timestamp as string.

Returns
timestamp
uint32_t CTimestamp::GetTimestampLsl ( ) const

Returns the least significant long value of the timestamp.

Returns
timestamp (least significant long) or N/A ("~0L")
Examples:
TracerCsvExample.cpp.
uint32_t CTimestamp::GetTimestampMsl ( ) const

Returns the most significant long value of the timestamp.

Returns
timestamp (most significant long) or N/A ("~0L")
Examples:
TracerCsvExample.cpp.
bool CTimestamp::IsInvalid ( ) const

Tests whether the object contains a valid timestamp.

Returns
invalid (true), valid (false)
Examples:
TracerCsvExample.cpp.
bool CTimestamp::operator!= ( const CTimestamp & ts ) const

operator "!="

Parameters
ts timestamp
CTimestamp & CTimestamp::operator++ ( )

operator "++"

Returns
timestamp
CTimestamp CTimestamp::operator++ ( int )

operator "++"

Returns
timestamp
CTimestamp & CTimestamp::operator-- ( )

operator "--"

Returns
timestamp
CTimestamp CTimestamp::operator-- ( int )

operator "--"

Returns
timestamp
bool CTimestamp::operator< ( const CTimestamp & ts ) const

operator "<"

Parameters
ts timestamp
bool CTimestamp::operator<= ( const CTimestamp & ts ) const

operator "<="

Parameters
ts timestamp
bool CTimestamp::operator== ( const CTimestamp & ts ) const

operator "=="

Parameters
ts timestamp
bool CTimestamp::operator> ( const CTimestamp & ts ) const

operator ">"

Parameters
ts timestamp
bool CTimestamp::operator>= ( const CTimestamp & ts ) const

operator ">="

Parameters
ts timestamp
void CTimestamp::SetInvalid ( )

Marks the timestamp is invalid.

void CTimestamp::SetTimestamp | ( | uint32_t | msl,
 |  | uint32_t | lsl
 | ) |  |

Sets the value of the timestamp object.

Parameters
msl | timestamp (most significant long)
lsl | timestamp (least significant long)
void CTimestamp::SetTimestamp ( uint64_t ts )

Sets the value of the timestamp object.

Parameters
ts timestamp


I2C.C++ API: Member List

  • CTimestamp
telos::I2cApi::Cpp::CTimestamp Member List

This is the complete list of members for telos::I2cApi::Cpp::CTimestamp, including all inherited members.

CTimestamp() | telos::I2cApi::Cpp::CTimestamp |
CTimestamp(uint32_t msl, uint32_t lsl) | telos::I2cApi::Cpp::CTimestamp |
CTimestamp(uint64_t ts) | telos::I2cApi::Cpp::CTimestamp | explicit
GetTimestamp() const | telos::I2cApi::Cpp::CTimestamp |
GetTimestampAsDuration(const SHardwareInfo &hwinfo) const | telos::I2cApi::Cpp::CTimestamp |
GetTimestampAsHexString() const | telos::I2cApi::Cpp::CTimestamp |
GetTimestampLsl() const | telos::I2cApi::Cpp::CTimestamp |
GetTimestampMsl() const | telos::I2cApi::Cpp::CTimestamp |
IsInvalid() const | telos::I2cApi::Cpp::CTimestamp |
operator!=(const CTimestamp &ts) const | telos::I2cApi::Cpp::CTimestamp |
operator++() | telos::I2cApi::Cpp::CTimestamp |
operator++(int) | telos::I2cApi::Cpp::CTimestamp |
operator--() | telos::I2cApi::Cpp::CTimestamp |
operator--(int) | telos::I2cApi::Cpp::CTimestamp |
operator<(const CTimestamp &ts) const | telos::I2cApi::Cpp::CTimestamp |
operator<=(const CTimestamp &ts) const | telos::I2cApi::Cpp::CTimestamp |
operator==(const CTimestamp &ts) const | telos::I2cApi::Cpp::CTimestamp |
operator>(const CTimestamp &ts) const | telos::I2cApi::Cpp::CTimestamp |
operator>=(const CTimestamp &ts) const | telos::I2cApi::Cpp::CTimestamp |
SetInvalid() | telos::I2cApi::Cpp::CTimestamp |
SetTimestamp(uint32_t msl, uint32_t lsl) | telos::I2cApi::Cpp::CTimestamp |
SetTimestamp(uint64_t ts) | telos::I2cApi::Cpp::CTimestamp |


I2C.C++ API: telos::I2cApi::Cpp::CTracer Class Reference

  • CTracer
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CTracer Class Reference

#include <CTracer.h>

Public Member Functions

void | Enable ()
Enables the I2C tracer. More...
void | Disable ()
Disables the I2C tracer. More...
bool | IsEnabled () const
Tests if the I2C tracer is enabled. More...
void | EnableAddress (const CI2cAddress &address)
Adds I2C addresses to the filter. More...
void | DisableAddress (const CI2cAddress &address)
Removes I2C address from the filter. More...
void | EnableAddressAll ()
Adds all 7/10 bit I2C addresses to the filter. More...
void | DisableAddressAll ()
Removes all 7/10 bit I2C addresses from the filter. More...
bool | IsAddressEnabled (const CI2cAddress &address) const
Is the I2C address enabled? More...
int | ReceiveMessage (STracerMessage &msg)
Tries to read one I2C message. More...
int | ReceiveMessages (std::vector< STracerMessage > &msgs, int number_packets)
Tries to read up to "number_packets" I2C messages. More...
int | ReceiveMessages (std::vector< STracerMessage > &msgs)
Tries to read multiple I2C messages. More...
CInputTestpins & GetInputTestpins ()
Returns a reference to the input testpin object. More...
const CInputTestpins & | GetInputTestpins () const
Returns a reference to the input testpin object. More...

Protected Member Functions

CTracer (CBoard *board)
Constructor. More...

Detailed Description

This class can be used to use the tracer functionality of the I2C interfaces. It is possible to start/stop the tracer module and to filter I2C messages regarding their I2C slave addresses.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the CBoard::GetTracer() method.

Normally the following steps are necessary to use the tracer:

  1. Configure the I2C address filter (default: I2C address filter is disabled).
  2. Enable the tracer using the Enable() method.
  3. Call CBoard::WaitForData() and ReceiveMessages() in a loop to get the trace messages.
  4. Disable the tracer using the Disable() method.
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CTracer::CTracer ( CBoard * board )
protected

Constructor.

Parameters
board pointer to CBoard object managing this object

Member Function Documentation

void CTracer::Disable ( )

Disables the tracer.

Examples:
TracerCsvExample.cpp, and TracerExample.cpp.
void CTracer::DisableAddress ( const CI2cAddress & address )

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

This function can be used to disable an address in this filter.

Parameters
address I2C address to be disabled
void CTracer::DisableAddressAll ( )

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

This function can be used to disable all addresses in this filter.

void CTracer::Enable ( )

Enables the tracer to receive the I2C messages sent on the I2C bus.

Examples:
TracerCsvExample.cpp, and TracerExample.cpp.
void CTracer::EnableAddress ( const CI2cAddress & address )

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

This function can be used to enable an address in this filter.

Parameters
address I2C address to be enabled
void CTracer::EnableAddressAll ( )

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

This function can be used to enable all addresses in this filter. (default)

Examples:
TracerCsvExample.cpp, and TracerExample.cpp.
CInputTestpins & CTracer::GetInputTestpins ( )

This function can be used to get access to the input testpin logging functionality of the I2C interface connected to this object.

Returns
input testpin object
Examples:
InputTestpinsExample.cpp.
const CInputTestpins & CTracer::GetInputTestpins ( ) const

This function can be used to get access to the input testpin logging functionality of the I2C interface connected to this object.

Returns
input testpin object
bool CTracer::IsAddressEnabled ( const CI2cAddress & address ) const

The I2C interfaces and the scheduler contain an I2C slave address filter. Only messages containing I2C slave addresses enabled in the filter get forwarded to the application.

Tests whether the specified I2C address is enabled or disabled in the address filter.

Parameters
address I2C address to be tested
Returns
enabled (true), disabled (false)
bool CTracer::IsEnabled ( ) const

Tests whether the tracer mode is enabled.

Returns
enabled (true), disabled (false)
int CTracer::ReceiveMessage ( STracerMessage & msg )

Tries to read one I2C message from the tracer module. This function will not wait until there is a tracer message available. Instead, this method will return immediately. If no message is available, the method returns "0" instead of "1".

Normally this function gets called in a loop together with CBoard::WaitForData().

Parameters
msg I2C message
Returns
number of messages read (0,1)
int CTracer::ReceiveMessages | ( | std::vector< STracerMessage > & | msgs,
 |  | int | number_packets
 | ) |  |

Tries to read up to "number_packets" I2C messages from the tracer module. This function will not wait until all requested tracer messages are available. Instead this function will return immediately.

Normally this function gets called in a loop together with CBoard::WaitForData().

Parameters
msgs | read I2C messages
number_packets | number of I2C messages to be read
Returns
numer of messages read (0..number_packets)
Examples:
TracerCsvExample.cpp, and TracerExample.cpp.
int CTracer::ReceiveMessages ( std::vector< STracerMessage > & msgs )

Tries to read multiple I2C messages from the tracer module.

Normally this function gets called in a loop together with CBoard::WaitForData().

Parameters
msgs read I2C messages
Returns
numer of messages read


I2C.C++ API: Member List

  • CTracer
telos::I2cApi::Cpp::CTracer Member List

This is the complete list of members for telos::I2cApi::Cpp::CTracer, including all inherited members.

CTracer(CBoard *board) | telos::I2cApi::Cpp::CTracer | protected
Disable() | telos::I2cApi::Cpp::CTracer |
DisableAddress(const CI2cAddress &address) | telos::I2cApi::Cpp::CTracer |
DisableAddressAll() | telos::I2cApi::Cpp::CTracer |
Enable() | telos::I2cApi::Cpp::CTracer |
EnableAddress(const CI2cAddress &address) | telos::I2cApi::Cpp::CTracer |
EnableAddressAll() | telos::I2cApi::Cpp::CTracer |
GetInputTestpins() | telos::I2cApi::Cpp::CTracer |
GetInputTestpins() const | telos::I2cApi::Cpp::CTracer |
IsAddressEnabled(const CI2cAddress &address) const | telos::I2cApi::Cpp::CTracer |
IsEnabled() const | telos::I2cApi::Cpp::CTracer |
ReceiveMessage(STracerMessage &msg) | telos::I2cApi::Cpp::CTracer |
ReceiveMessages(std::vector< STracerMessage > &msgs, int number_packets) | telos::I2cApi::Cpp::CTracer |
ReceiveMessages(std::vector< STracerMessage > &msgs) | telos::I2cApi::Cpp::CTracer |


I2C.C++ API: telos::I2cApi::Cpp::CTraciiCpu Class Reference

  • CTraciiCpu
Public Member Functions | Protected Member Functions | List of all members
telos::I2cApi::Cpp::CTraciiCpu Class Reference

#include <CTraciiCpu.h>

Public Member Functions

void | Start (const uint8_t *program, int program_length)
Start a program in the TraciiCPU. More...
void | Stop ()
Stop the program running in the TraciiCPU. More...
void | SendCommand (uint8_t command)
Send a command to the program running in the TraciiCPU. More...

Protected Member Functions

CTraciiCpu (CBoard *board)
Constructor. More...

Detailed Description

There is CPU called TraciiCPU on the Tracii XL interfaces. This class can be used to control this CPU.

Only the API itself can create instances of this class. Each I2C interface has got one instance of this class, which can be accessed using the CBoard::GetTraciiCpu() method.

Normally the following steps are necessary:

  1. Load a program into the TraciiCPU and start the program.
  2. Send parameters to the program.
  3. Stop the program.
Exceptions
telos::I2cApi::Cpp::CException
std::exception
Author
telos Systementwicklung GmbH

Constructor & Destructor Documentation

CTraciiCpu::CTraciiCpu ( CBoard * board )
protected

Constructor.

Parameters
board pointer to CBoard object managing this object

Member Function Documentation

void CTraciiCpu::SendCommand ( uint8_t command )

This method can be used to communicate with a program running in the TraciiCPU. The specified command data byte gets sent to a register, which can be read by the TraciiCPU.

Parameters
command command byte to be sent
void CTraciiCpu::Start | ( | const uint8_t * | program,
 |  | int | program_length
 | ) |  |

Loads the specified program into the TraciiCPU of a Tracii XL and starts the program. The program image must have a size of 1024 bytes.

Parameters
program | TraciiCPU program
program_length | length of the TraciiCPU program
void CTraciiCpu::Stop ( )

Stops the program running in the TraciiCPU.


I2C.C++ API: Member List

  • CTraciiCpu
telos::I2cApi::Cpp::CTraciiCpu Member List

This is the complete list of members for telos::I2cApi::Cpp::CTraciiCpu, including all inherited members.

CTraciiCpu(CBoard *board) | telos::I2cApi::Cpp::CTraciiCpu | protected
SendCommand(uint8_t command) | telos::I2cApi::Cpp::CTraciiCpu |
Start(const uint8_t *program, int program_length) | telos::I2cApi::Cpp::CTraciiCpu |
Stop() | telos::I2cApi::Cpp::CTraciiCpu |


I2C.C++ API: telos::I2cApi::Cpp::SAdcData Struct Reference

  • SAdcData
Public Attributes | List of all members
telos::I2cApi::Cpp::SAdcData Struct Reference

#include <CAdc.h>

Public Attributes

CTimestamp timestamp_start
timestamp of the first SCL/SDA sample
CTimestamp timestamp_stop
timestamp of the last SCL/SDA sample
std::vector< uint8_t > | data_scl
all SCL samples
std::vector< uint8_t > | data_sda
all SDA samples
uint8_t | data_max
maximum value of SCL/SDA samples
uint32_t | sampling_rate
sampling rate [Hz]
uint16_t | pretrigger
pretrigger [samples]

Detailed Description

This structure is used to store the data from the A/D converter. Instances of this structure get passed to CAdc::RequestDataTransmission().

Examples:
AdcExample.cpp.


I2C.C++ API: Member List

  • SAdcData
telos::I2cApi::Cpp::SAdcData Member List

This is the complete list of members for telos::I2cApi::Cpp::SAdcData, including all inherited members.

data_max | telos::I2cApi::Cpp::SAdcData
data_scl | telos::I2cApi::Cpp::SAdcData
data_sda | telos::I2cApi::Cpp::SAdcData
pretrigger | telos::I2cApi::Cpp::SAdcData
sampling_rate | telos::I2cApi::Cpp::SAdcData
timestamp_start | telos::I2cApi::Cpp::SAdcData
timestamp_stop | telos::I2cApi::Cpp::SAdcData


I2C.C++ API: telos::I2cApi::Cpp::SHardwareInfo Struct Reference

  • SHardwareInfo
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
telos::I2cApi::Cpp::SHardwareInfo Struct Reference

#include <CBoard.h>

Public Member Functions

SHardwareInfo ()
Constructor. More...

Static Public Member Functions

static std::string GetBoardTypeAsString (ETraciiType board_type)
Converts an ETraciiType value to a string. More...

Public Attributes

std::string | ip_address
IP address of the I2C scheduler responsible for this I2C interface.
uint16_t | ip_port
IP port of the I2C scheduler responsible for this I2C interface.
std::string | dns_name
DNS name of the I2C scheduler responsible for this I2C interface.
std::string | port
name of the port (e.g. "USB" or "LPT1")
uint16_t | serial_number
serial number
uint64_t | internal_serial_number
internal serial number
std::map< std::string, SVersionNumber > | versions
version numbers (of "firmware", "driver", and "fpga")
std::map< std::string, SVersionNumber > | required_versions
required version numbers (of "firmware", "driver", and "fpga")
ETraciiType board_type
type of the I2C interface
struct {
uint8_t tracer
tracer
uint8_t master
master
uint8_t master_hs
master high-speed
uint8_t adc
A/D converter.
uint8_t negative_tester
negative tester
uint8_t flasher
flasher
uint8_t ird
IRD.
uint8_t labview
Labview VIs.
} service_contract
expiration date of service contract (in month since since 31.01.2000)
uint16_t | required_service_contract
required expiration date of service contract (in month since since 31.01.2000)
uint32_t | timestamp_timebase
timebase of timestamps (e.g. 3E6 Hz) or N/A (~0)
bool | testpin_start
START condition can trigger testpin (out)
bool | testpin_stop
STOP condition can trigger testpin (out)
bool | testpin_ack
ACK condition can trigger testpin (out)
bool | testpin_error
ERROR condition can trigger testpin (out)
bool | testpin_nack
NACK condition can trigger testpin (out)
uint8_t | testpins_out
number of output testpins
uint8_t | testpins_in
number of input testpins
bool | tracer
can be used as tracer
bool | master
can be used as master receiver
bool | adc
A/D converter available?
bool | negative_tester
negative tester available?
bool | features_simultaneously
all features simultaneously?
bool | bus_type_smb
can be used with a SMBus?
struct {
bool labview
Labview VIs.
bool flasher
flasher
bool ird
IRD.
} software_licenses
software that can be used
bool | demo_license
demo license: all features can be used?
std::vector< uint32_t > | termination
possible values for the SCL/SDA termination
std::vector< uint8_t > | low_level_threshold
possible values for the low level threshold
std::vector< uint8_t > | high_level_threshold
possible values for the high level threshold
std::vector< uint16_t > | i2c_vcc_supply
possible values for the I2C Vcc supply voltage
std::vector< uint32_t > | adc_samplingrate
possible sampling rates to be used for the A/D converter
uint16_t | adc_vcc
voltage of the A/D value "255" (e.g. 5,5E3 mV) or N/A (~0)
uint32_t | adc_sampling_depth
A/D converter: sampling depth.
uint32_t | adc_max_pretrigger
A/D converter: maximum allowed pretrigger.
uint32_t | pull_up_current_max
Maximum value for pull-up-current for SCL/SDA.
bool | adc_trigger_start
A/D converter: START condition can be used as trigger event.
bool | adc_trigger_stop
A/D converter: STOP condition can be used as trigger event.
bool | adc_trigger_ack
A/D converter: ACK condition can be used as trigger event.
bool | adc_trigger_testpin1
A/D converter: testpin 1 can be used as trigger event.
bool | adc_trigger_testpin2
A/D converter: testpin 2 can be used as trigger event.
bool | adc_trigger_nack
A/D converter: NACK condition can be used as trigger event.
bool | adc_trigger_error
A/D converter: ERROR can be used as trigger event.
bool | adc_trigger_immediately
A/D converter: trigger immediately.
bool | adc_trigger_msg_cnt
A/D converter: message count can be used as trigger event.
uint8_t | adc_trigger_data
A/D converter: number of data bytes, which be can used as trigger event.
std::vector< uint32_t > | master_sampling_rate
master: possible values for the sampling rate
std::vector< uint32_t > | master_sampling_rate_hs
master: possible values for the high speed sampling rate
uint32_t | master_max_rx
master: maximum number of bytes which can be received in one I2C message
uint32_t | negative_tester_length
negative tester: length of the program

Detailed Description

This structure is used to store information about an I2C interface. E.g. it can be used to get information about the type of the interface and the available features. The methods CBoard::GetHardwareInfo() and CBoard::GetHardwareInfoOfOpenDevice() are using objects of this type.

Examples:
AdcExample.cpp, InputTestpinsExample.cpp, MasterExample.cpp, NegativeTesterExample.cpp, TracerCsvExample.cpp, and TracerExample.cpp.

Constructor & Destructor Documentation

SHardwareInfo::SHardwareInfo ( )

Constructor.

Member Function Documentation

string SHardwareInfo::GetBoardTypeAsString ( ETraciiType board_type )
static

Converts an ETraciiType value into a human readable string describing the type of I2C interface.

Parameters
board_type type of the I2C interface
Returns
type of the I2C interface as string


I2C.C++ API: Member List

  • SHardwareInfo
telos::I2cApi::Cpp::SHardwareInfo Member List

This is the complete list of members for telos::I2cApi::Cpp::SHardwareInfo, including all inherited members.

adc | telos::I2cApi::Cpp::SHardwareInfo |
adc | telos::I2cApi::Cpp::SHardwareInfo |
adc_max_pretrigger | telos::I2cApi::Cpp::SHardwareInfo |
adc_sampling_depth | telos::I2cApi::Cpp::SHardwareInfo |
adc_samplingrate | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_ack | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_data | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_error | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_immediately | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_msg_cnt | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_nack | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_start | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_stop | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_testpin1 | telos::I2cApi::Cpp::SHardwareInfo |
adc_trigger_testpin2 | telos::I2cApi::Cpp::SHardwareInfo |
adc_vcc | telos::I2cApi::Cpp::SHardwareInfo |
board_type | telos::I2cApi::Cpp::SHardwareInfo |
bus_type_smb | telos::I2cApi::Cpp::SHardwareInfo |
demo_license | telos::I2cApi::Cpp::SHardwareInfo |
dns_name | telos::I2cApi::Cpp::SHardwareInfo |
features_simultaneously | telos::I2cApi::Cpp::SHardwareInfo |
flasher | telos::I2cApi::Cpp::SHardwareInfo |
flasher | telos::I2cApi::Cpp::SHardwareInfo |
GetBoardTypeAsString(ETraciiType board_type) | telos::I2cApi::Cpp::SHardwareInfo | static
high_level_threshold | telos::I2cApi::Cpp::SHardwareInfo |
i2c_vcc_supply | telos::I2cApi::Cpp::SHardwareInfo |
internal_serial_number | telos::I2cApi::Cpp::SHardwareInfo |
ip_address | telos::I2cApi::Cpp::SHardwareInfo |
ip_port | telos::I2cApi::Cpp::SHardwareInfo |
ird | telos::I2cApi::Cpp::SHardwareInfo |
ird | telos::I2cApi::Cpp::SHardwareInfo |
labview | telos::I2cApi::Cpp::SHardwareInfo |
labview | telos::I2cApi::Cpp::SHardwareInfo |
low_level_threshold | telos::I2cApi::Cpp::SHardwareInfo |
master | telos::I2cApi::Cpp::SHardwareInfo |
master | telos::I2cApi::Cpp::SHardwareInfo |
master_hs | telos::I2cApi::Cpp::SHardwareInfo |
master_max_rx | telos::I2cApi::Cpp::SHardwareInfo |
master_sampling_rate | telos::I2cApi::Cpp::SHardwareInfo |
master_sampling_rate_hs | telos::I2cApi::Cpp::SHardwareInfo |
negative_tester | telos::I2cApi::Cpp::SHardwareInfo |
negative_tester | telos::I2cApi::Cpp::SHardwareInfo |
negative_tester_length | telos::I2cApi::Cpp::SHardwareInfo |
port | telos::I2cApi::Cpp::SHardwareInfo |
pull_up_current_max | telos::I2cApi::Cpp::SHardwareInfo |
required_service_contract | telos::I2cApi::Cpp::SHardwareInfo |
required_versions | telos::I2cApi::Cpp::SHardwareInfo |
serial_number | telos::I2cApi::Cpp::SHardwareInfo |
service_contract | telos::I2cApi::Cpp::SHardwareInfo |
SHardwareInfo() | telos::I2cApi::Cpp::SHardwareInfo |
software_licenses | telos::I2cApi::Cpp::SHardwareInfo |
termination | telos::I2cApi::Cpp::SHardwareInfo |
testpin_ack | telos::I2cApi::Cpp::SHardwareInfo |
testpin_error | telos::I2cApi::Cpp::SHardwareInfo |
testpin_nack | telos::I2cApi::Cpp::SHardwareInfo |
testpin_start | telos::I2cApi::Cpp::SHardwareInfo |
testpin_stop | telos::I2cApi::Cpp::SHardwareInfo |
testpins_in | telos::I2cApi::Cpp::SHardwareInfo |
testpins_out | telos::I2cApi::Cpp::SHardwareInfo |
timestamp_timebase | telos::I2cApi::Cpp::SHardwareInfo |
tracer | telos::I2cApi::Cpp::SHardwareInfo |
tracer | telos::I2cApi::Cpp::SHardwareInfo |
versions | telos::I2cApi::Cpp::SHardwareInfo |


I2C.C++ API: telos::I2cApi::Cpp::SInputTestpinsMessage Struct Reference

  • SInputTestpinsMessage
Public Attributes | List of all members
telos::I2cApi::Cpp::SInputTestpinsMessage Struct Reference

#include <CInputTestpins.h>

Public Attributes

uint8_t | status
status after the transition
CTimestamp timestamp
timestamp of the transition
bool | status_available
status unknown?

Detailed Description

Each time a CInputTestpins object detects a transition of the input testpins, a message of this type gets generated. The message stores the status of the testpins after the transition and the timestamp of the transition.

The number of available input testpins can be determined using the SHardwareInfo::testpins_in variable. For each available input testpin one bit in the status variable is used to store the testpin level after the transition. The level of testpin 0 gets stored in bit 0 (LSB), testpin 1 in bit 1 and so on.

If "status_available" is "false", the status of the testpins should be considered as unknown starting from this time.

Examples:
InputTestpinsExample.cpp.


I2C.C++ API: Member List

  • SInputTestpinsMessage
telos::I2cApi::Cpp::SInputTestpinsMessage Member List

This is the complete list of members for telos::I2cApi::Cpp::SInputTestpinsMessage, including all inherited members.

status | telos::I2cApi::Cpp::SInputTestpinsMessage
status_available | telos::I2cApi::Cpp::SInputTestpinsMessage
timestamp | telos::I2cApi::Cpp::SInputTestpinsMessage


I2C.C++ API: telos::I2cApi::Cpp::STracerMessage Struct Reference

  • STracerMessage
Public Attributes | List of all members
telos::I2cApi::Cpp::STracerMessage Struct Reference

#include <CTracer.h>

Public Attributes

ETracerMessageType type
type of the message
CTimestamp timestamp
timestamp of the message
struct {
uint8_t data
received data
ETracerMessageDataConfirmation confirmation
received confirmation (MSG_FRAME_DATA only)
} data
used for MSG_FRAME_DATA/MSG_BIT_DATA messages

Detailed Description

This structure is used to store one trace message created by the methods of the CTracer class.

Examples:
TracerCsvExample.cpp, and TracerExample.cpp.


I2C.C++ API: Member List

  • STracerMessage
telos::I2cApi::Cpp::STracerMessage Member List

This is the complete list of members for telos::I2cApi::Cpp::STracerMessage, including all inherited members.

confirmation | telos::I2cApi::Cpp::STracerMessage
data | telos::I2cApi::Cpp::STracerMessage
data | telos::I2cApi::Cpp::STracerMessage
timestamp | telos::I2cApi::Cpp::STracerMessage
type | telos::I2cApi::Cpp::STracerMessage


I2C.C++ API: telos::I2cApi::Cpp::SVersionNumber Struct Reference

  • SVersionNumber
Public Member Functions | Public Attributes | List of all members
telos::I2cApi::Cpp::SVersionNumber Struct Reference

#include <CBoard.h>

Public Member Functions

SVersionNumber ()
SVersionNumber (const SVersionNumber &source)
SVersionNumber & | operator= (const SVersionNumber &source)
bool | operator> (const SVersionNumber &source) const
bool | operator>= (const SVersionNumber &source) const
bool | operator< (const SVersionNumber &source) const
bool | operator<= (const SVersionNumber &source) const
bool | operator== (const SVersionNumber &source) const
bool | operator!= (const SVersionNumber &source) const

Public Attributes

uint16_t | major
major part of the version number
uint16_t | minor
minor part of the version number
uint16_t | build
build part of the version number

Detailed Description

This struct stores a version number of the format "major.minor-build" (e.g. 1.3-128).

Constructor & Destructor Documentation

SVersionNumber::SVersionNumber ( )

Constructor.

SVersionNumber::SVersionNumber ( const SVersionNumber & source )

Copy constructor.

Parameters
source object to be copied

Member Function Documentation

bool SVersionNumber::operator!= ( const SVersionNumber & source ) const

operator!=

Parameters
source object to be compared
Returns
false (==), true (!=)
bool SVersionNumber::operator< ( const SVersionNumber & source ) const

operator<

Parameters
source object to be compared
Returns
false (>=), true (<)
bool SVersionNumber::operator<= ( const SVersionNumber & source ) const

operator>

Parameters
source object to be compared
Returns
false (<=), true (>)
SVersionNumber & SVersionNumber::operator= ( const SVersionNumber & source )

operator=

Parameters
source object to be used as source
Returns
this object
bool SVersionNumber::operator== ( const SVersionNumber & source ) const

operator==

Parameters
source object to be compared
Returns
false (!=), true (==)
bool SVersionNumber::operator> ( const SVersionNumber & source ) const

operator>

Parameters
source object to be compared
Returns
false (<=), true (>)
bool SVersionNumber::operator>= ( const SVersionNumber & source ) const

operator>=

Parameters
source object to be compared
Returns
false (<), true (>=)


I2C.C++ API: Member List

  • SVersionNumber
telos::I2cApi::Cpp::SVersionNumber Member List

This is the complete list of members for telos::I2cApi::Cpp::SVersionNumber, including all inherited members.

build | telos::I2cApi::Cpp::SVersionNumber
major | telos::I2cApi::Cpp::SVersionNumber
minor | telos::I2cApi::Cpp::SVersionNumber
operator!=(const SVersionNumber &source) const | telos::I2cApi::Cpp::SVersionNumber
operator<(const SVersionNumber &source) const | telos::I2cApi::Cpp::SVersionNumber
operator<=(const SVersionNumber &source) const | telos::I2cApi::Cpp::SVersionNumber
operator=(const SVersionNumber &source) | telos::I2cApi::Cpp::SVersionNumber
operator==(const SVersionNumber &source) const | telos::I2cApi::Cpp::SVersionNumber
operator>(const SVersionNumber &source) const | telos::I2cApi::Cpp::SVersionNumber
operator>=(const SVersionNumber &source) const | telos::I2cApi::Cpp::SVersionNumber
SVersionNumber() | telos::I2cApi::Cpp::SVersionNumber
SVersionNumber(const SVersionNumber &source) | telos::I2cApi::Cpp::SVersionNumber


I2C.C++ API: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
C telos::I2cApi::Cpp::CAdc
C telos::I2cApi::Cpp::CBoard
▼C telos::I2cApi::Cpp::CException
►C telos::I2cApi::Cpp::CExceptionAdc
C telos::I2cApi::Cpp::CExceptionAdcBusy
C telos::I2cApi::Cpp::CExceptionAdcNotFinished
C telos::I2cApi::Cpp::CExceptionAdcNotSupported
C telos::I2cApi::Cpp::CExceptionAdcPreTrigger
C telos::I2cApi::Cpp::CExceptionAdcSamplingRate
C telos::I2cApi::Cpp::CExceptionAdcTrigger
C telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted
C telos::I2cApi::Cpp::CExceptionArpInvalidResponse
C telos::I2cApi::Cpp::CExceptionAuthentication
C telos::I2cApi::Cpp::CExceptionBusType
C telos::I2cApi::Cpp::CExceptionDeviceOpen
C telos::I2cApi::Cpp::CExceptionDriverVersion
C telos::I2cApi::Cpp::CExceptionHardwareIo
C telos::I2cApi::Cpp::CExceptionI2cAddress
C telos::I2cApi::Cpp::CExceptionI2cVcc
C telos::I2cApi::Cpp::CExceptionI2cVccSupply
C telos::I2cApi::Cpp::CExceptionInputTestpin
C telos::I2cApi::Cpp::CExceptionIo
C telos::I2cApi::Cpp::CExceptionLevelThreshold
►C telos::I2cApi::Cpp::CExceptionMaster
C telos::I2cApi::Cpp::CExceptionMasterAddress
C telos::I2cApi::Cpp::CExceptionMasterArbitration
C telos::I2cApi::Cpp::CExceptionMasterBusy
C telos::I2cApi::Cpp::CExceptionMasterI2cProtocol
C telos::I2cApi::Cpp::CExceptionMasterIncompleteRx
C telos::I2cApi::Cpp::CExceptionMasterIncompleteTx
C telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate
C telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode
C telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer
C telos::I2cApi::Cpp::CExceptionMasterNotSupported
C telos::I2cApi::Cpp::CExceptionMasterRunning
C telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize
C telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed
C telos::I2cApi::Cpp::CExceptionMasterTimeout
C telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout
►C telos::I2cApi::Cpp::CExceptionNegativeTester
C telos::I2cApi::Cpp::CExceptionNegativeTesterBusy
C telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument
C telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported
C telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize
C telos::I2cApi::Cpp::CExceptionNullPointer
C telos::I2cApi::Cpp::CExceptionOpen
C telos::I2cApi::Cpp::CExceptionOutputTestpin
C telos::I2cApi::Cpp::CExceptionPullUpCurrent
C telos::I2cApi::Cpp::CExceptionSchedulerBusy
C telos::I2cApi::Cpp::CExceptionSchedulerVersion
C telos::I2cApi::Cpp::CExceptionServiceContractExpired
►C telos::I2cApi::Cpp::CExceptionSlaveRamEnhanced
C telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress
C telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy
C telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize
C telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported
C telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData
C telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout
C telos::I2cApi::Cpp::CExceptionSmbI2cAddress
C telos::I2cApi::Cpp::CExceptionTermination
►C telos::I2cApi::Cpp::CExceptionTracer
C telos::I2cApi::Cpp::CExceptionTracerBusy
C telos::I2cApi::Cpp::CExceptionTracerFilter
C telos::I2cApi::Cpp::CExceptionTracerNotSupported
►C telos::I2cApi::Cpp::CExceptionTraciiCpu
C telos::I2cApi::Cpp::CExceptionTraciiCpuBusy
C telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported
C telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize
C telos::I2cApi::Cpp::CI2cAddress
C telos::I2cApi::Cpp::CInputTestpins
C telos::I2cApi::Cpp::CLanguage
C telos::I2cApi::Cpp::CMaster
▼C telos::I2cApi::Cpp::CMasterMessage
C telos::I2cApi::Cpp::CMasterMessageRx
C telos::I2cApi::Cpp::CMasterMessageTx
C telos::I2cApi::Cpp::CNegativeTester
C telos::I2cApi::Cpp::CNegativeTesterMaster
C telos::I2cApi::Cpp::CNegativeTesterSlave
▼C telos::I2cApi::Cpp::CPmbusMasterMessage
►C telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
C telos::I2cApi::Cpp::CPmbusMasterMessageReadByte
C telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte
►C telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
C telos::I2cApi::Cpp::CPmbusMasterMessageReadWord
C telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord
C telos::I2cApi::Cpp::CPmbusMasterMessageCmd
C telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
C telos::I2cApi::Cpp::CSlaveRam
C telos::I2cApi::Cpp::CSlaveRamEnhanced
C telos::I2cApi::Cpp::CSmbArpMaster
C telos::I2cApi::Cpp::CSmbMaster
▼C telos::I2cApi::Cpp::CSmbMasterMessage
►C telos::I2cApi::Cpp::CSmbMasterMessageCmd
C telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
►C telos::I2cApi::Cpp::CSmbMasterMessageCmd32
C telos::I2cApi::Cpp::CSmbMasterMessageRead32
C telos::I2cApi::Cpp::CSmbMasterMessageWrite32
►C telos::I2cApi::Cpp::CSmbMasterMessageCmd64
C telos::I2cApi::Cpp::CSmbMasterMessageRead64
C telos::I2cApi::Cpp::CSmbMasterMessageWrite64
►C telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
C telos::I2cApi::Cpp::CSmbMasterMessageBlockRead
C telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite
►C telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
C telos::I2cApi::Cpp::CSmbMasterMessageReadByte
C telos::I2cApi::Cpp::CSmbMasterMessageWriteByte
C telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
►C telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
C telos::I2cApi::Cpp::CSmbMasterMessageReadWord
C telos::I2cApi::Cpp::CSmbMasterMessageWriteWord
C telos::I2cApi::Cpp::CSmbMasterMessageHostNotify
C telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand
C telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
C telos::I2cApi::Cpp::CSmbMasterMessageSendByte
C telos::I2cApi::Cpp::CTimestamp
C telos::I2cApi::Cpp::CTracer
C telos::I2cApi::Cpp::CTraciiCpu
C telos::I2cApi::Cpp::CSmbArpMaster::CUdid
C telos::I2cApi::Cpp::SAdcData
C telos::I2cApi::Cpp::SHardwareInfo
C telos::I2cApi::Cpp::SInputTestpinsMessage
C telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster
C telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
C telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
C telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
C telos::I2cApi::Cpp::STracerMessage
C telos::I2cApi::Cpp::SVersionNumber


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • adc : telos::I2cApi::Cpp::SHardwareInfo
  • adc_max_pretrigger : telos::I2cApi::Cpp::SHardwareInfo
  • adc_sampling_depth : telos::I2cApi::Cpp::SHardwareInfo
  • adc_samplingrate : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_ack : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_data : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_error : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_immediately : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_msg_cnt : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_nack : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_start : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_stop : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_testpin1 : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_testpin2 : telos::I2cApi::Cpp::SHardwareInfo
  • adc_vcc : telos::I2cApi::Cpp::SHardwareInfo
  • AddMessage()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • addr : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ADDR_TYPE_DYNAMIC_PERSISTENT : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ADDR_TYPE_DYNAMIC_VOLATILE : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ADDR_TYPE_FIXED : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ADDR_TYPE_RANDOM : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • AssignAddress() : telos::I2cApi::Cpp::CSmbArpMaster
  • AutoDetectTermination() : telos::I2cApi::Cpp::CMaster


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BLOCK_MODE_NONE : telos::I2cApi::Cpp::CMasterMessageRx
  • BLOCK_MODE_WITH_PEC : telos::I2cApi::Cpp::CMasterMessageRx
  • BLOCK_MODE_WITHOUT_PEC : telos::I2cApi::Cpp::CMasterMessageRx
  • board_type : telos::I2cApi::Cpp::SHardwareInfo
  • build : telos::I2cApi::Cpp::SVersionNumber
  • BUS_TYPE_I2C : telos::I2cApi::Cpp::CBoard
  • BUS_TYPE_SMB : telos::I2cApi::Cpp::CBoard
  • bus_type_smb : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CAdc() : telos::I2cApi::Cpp::CAdc
  • CalculateCrc8() : telos::I2cApi::Cpp::CSmbMaster
  • CallBackFunction
: telos::I2cApi::Cpp::CAdc
, telos::I2cApi::Cpp::CBoard
, telos::I2cApi::Cpp::CNegativeTester
  • CancelAdc() : telos::I2cApi::Cpp::CAdc
  • CBoard() : telos::I2cApi::Cpp::CBoard
  • CExceptionAdcBusy() : telos::I2cApi::Cpp::CExceptionAdcBusy
  • CExceptionAdcNotFinished() : telos::I2cApi::Cpp::CExceptionAdcNotFinished
  • CExceptionAdcNotSupported() : telos::I2cApi::Cpp::CExceptionAdcNotSupported
  • CExceptionAdcPreTrigger() : telos::I2cApi::Cpp::CExceptionAdcPreTrigger
  • CExceptionAdcSamplingRate() : telos::I2cApi::Cpp::CExceptionAdcSamplingRate
  • CExceptionAdcTrigger() : telos::I2cApi::Cpp::CExceptionAdcTrigger
  • CExceptionArpI2cAddressesExhausted() : telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted
  • CExceptionArpInvalidResponse() : telos::I2cApi::Cpp::CExceptionArpInvalidResponse
  • CExceptionAuthentication() : telos::I2cApi::Cpp::CExceptionAuthentication
  • CExceptionBusType() : telos::I2cApi::Cpp::CExceptionBusType
  • CExceptionDeviceOpen() : telos::I2cApi::Cpp::CExceptionDeviceOpen
  • CExceptionDriverVersion() : telos::I2cApi::Cpp::CExceptionDriverVersion
  • CExceptionHardwareIo() : telos::I2cApi::Cpp::CExceptionHardwareIo
  • CExceptionI2cAddress() : telos::I2cApi::Cpp::CExceptionI2cAddress
  • CExceptionI2cVcc() : telos::I2cApi::Cpp::CExceptionI2cVcc
  • CExceptionI2cVccSupply() : telos::I2cApi::Cpp::CExceptionI2cVccSupply
  • CExceptionInputTestpin() : telos::I2cApi::Cpp::CExceptionInputTestpin
  • CExceptionIo() : telos::I2cApi::Cpp::CExceptionIo
  • CExceptionLevelThreshold() : telos::I2cApi::Cpp::CExceptionLevelThreshold
  • CExceptionMasterAddress() : telos::I2cApi::Cpp::CExceptionMasterAddress
  • CExceptionMasterArbitration() : telos::I2cApi::Cpp::CExceptionMasterArbitration
  • CExceptionMasterBusy() : telos::I2cApi::Cpp::CExceptionMasterBusy
  • CExceptionMasterI2cProtocol() : telos::I2cApi::Cpp::CExceptionMasterI2cProtocol
  • CExceptionMasterIncompleteRx() : telos::I2cApi::Cpp::CExceptionMasterIncompleteRx
  • CExceptionMasterIncompleteTx() : telos::I2cApi::Cpp::CExceptionMasterIncompleteTx
  • CExceptionMasterInvalidBitrate() : telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate
  • CExceptionMasterInvalidMasterCode() : telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode
  • CExceptionMasterInvalidTransfer() : telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer
  • CExceptionMasterNotSupported() : telos::I2cApi::Cpp::CExceptionMasterNotSupported
  • CExceptionMasterRunning() : telos::I2cApi::Cpp::CExceptionMasterRunning
  • CExceptionMasterSmbInvalidSize() : telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize
  • CExceptionMasterSmbPecFailed() : telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed
  • CExceptionMasterTimeout() : telos::I2cApi::Cpp::CExceptionMasterTimeout
  • CExceptionMasterWatchdogTimeout() : telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout
  • CExceptionNegativeTesterBusy() : telos::I2cApi::Cpp::CExceptionNegativeTesterBusy
  • CExceptionNegativeTesterInvalidArgument() : telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument
  • CExceptionNegativeTesterNotSupported() : telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported
  • CExceptionNegativeTesterProgramSize() : telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize
  • CExceptionNullPointer() : telos::I2cApi::Cpp::CExceptionNullPointer
  • CExceptionOpen() : telos::I2cApi::Cpp::CExceptionOpen
  • CExceptionOutputTestpin() : telos::I2cApi::Cpp::CExceptionOutputTestpin
  • CExceptionPullUpCurrent() : telos::I2cApi::Cpp::CExceptionPullUpCurrent
  • CExceptionSchedulerBusy() : telos::I2cApi::Cpp::CExceptionSchedulerBusy
  • CExceptionSchedulerVersion() : telos::I2cApi::Cpp::CExceptionSchedulerVersion
  • CExceptionServiceContractExpired() : telos::I2cApi::Cpp::CExceptionServiceContractExpired
  • CExceptionSlaveRamEnhancedAddress() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress
  • CExceptionSlaveRamEnhancedBusy() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy
  • CExceptionSlaveRamEnhancedMemorySize() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize
  • CExceptionSlaveRamEnhancedNotSupported() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported
  • CExceptionSlaveRamEnhancedSetData() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData
  • CExceptionSlaveRamEnhancedTimeout() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout
  • CExceptionSmbI2cAddress() : telos::I2cApi::Cpp::CExceptionSmbI2cAddress
  • CExceptionTermination() : telos::I2cApi::Cpp::CExceptionTermination
  • CExceptionTracerBusy() : telos::I2cApi::Cpp::CExceptionTracerBusy
  • CExceptionTracerFilter() : telos::I2cApi::Cpp::CExceptionTracerFilter
  • CExceptionTracerNotSupported() : telos::I2cApi::Cpp::CExceptionTracerNotSupported
  • CExceptionTraciiCpuBusy() : telos::I2cApi::Cpp::CExceptionTraciiCpuBusy
  • CExceptionTraciiCpuNotSupported() : telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported
  • CExceptionTraciiCpuProgramSize() : telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize
  • CI2cAddress() : telos::I2cApi::Cpp::CI2cAddress
  • CInputTestpins() : telos::I2cApi::Cpp::CInputTestpins
  • Clear()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • CloseDevice() : telos::I2cApi::Cpp::CBoard
  • CMaster() : telos::I2cApi::Cpp::CMaster
  • CMasterMessage() : telos::I2cApi::Cpp::CMasterMessage
  • CMasterMessageRx() : telos::I2cApi::Cpp::CMasterMessageRx
  • CMasterMessageTx() : telos::I2cApi::Cpp::CMasterMessageTx
  • CNegativeTester() : telos::I2cApi::Cpp::CNegativeTester
  • CNegativeTesterMaster() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • CNegativeTesterSlave() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • confirmation : telos::I2cApi::Cpp::STracerMessage
  • ConvertNanosecondsToTicks() : telos::I2cApi::Cpp::CNegativeTester
  • ConvertTicksToNanoseconds() : telos::I2cApi::Cpp::CNegativeTester
  • CPmbusMasterMessage() : telos::I2cApi::Cpp::CPmbusMasterMessage
  • CPmbusMasterMessageCmd() : telos::I2cApi::Cpp::CPmbusMasterMessageCmd
  • CPmbusMasterMessageExtCmdByte() : telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
  • CPmbusMasterMessageExtCmdWord() : telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
  • CPmbusMasterMessageGroupCmd() : telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
  • CPmbusMasterMessageReadByte() : telos::I2cApi::Cpp::CPmbusMasterMessageReadByte
  • CPmbusMasterMessageReadWord() : telos::I2cApi::Cpp::CPmbusMasterMessageReadWord
  • CPmbusMasterMessageWriteByte() : telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte
  • CPmbusMasterMessageWriteWord() : telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord
  • CreateReceiver() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverAckBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverByte() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverNackBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateStart() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitter() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitterAckBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitterBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitterByte() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CSlaveRam() : telos::I2cApi::Cpp::CSlaveRam
  • CSlaveRamEnhanced() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • CSmbArpMaster() : telos::I2cApi::Cpp::CSmbArpMaster
  • CSmbMaster() : telos::I2cApi::Cpp::CSmbMaster
  • CSmbMasterMessage() : telos::I2cApi::Cpp::CSmbMasterMessage
  • CSmbMasterMessageBlockRead() : telos::I2cApi::Cpp::CSmbMasterMessageBlockRead
  • CSmbMasterMessageBlockWrite() : telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite
  • CSmbMasterMessageBlockWriteRead() : telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
  • CSmbMasterMessageCmd() : telos::I2cApi::Cpp::CSmbMasterMessageCmd
  • CSmbMasterMessageCmd32() : telos::I2cApi::Cpp::CSmbMasterMessageCmd32
  • CSmbMasterMessageCmd64() : telos::I2cApi::Cpp::CSmbMasterMessageCmd64
  • CSmbMasterMessageCmdBlock() : telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
  • CSmbMasterMessageCmdByte() : telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
  • CSmbMasterMessageCmdProcessCall() : telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • CSmbMasterMessageCmdWord() : telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
  • CSmbMasterMessageHostNotify() : telos::I2cApi::Cpp::CSmbMasterMessageHostNotify
  • CSmbMasterMessageQuickCommand() : telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand
  • CSmbMasterMessageRead32() : telos::I2cApi::Cpp::CSmbMasterMessageRead32
  • CSmbMasterMessageRead64() : telos::I2cApi::Cpp::CSmbMasterMessageRead64
  • CSmbMasterMessageReadByte() : telos::I2cApi::Cpp::CSmbMasterMessageReadByte
  • CSmbMasterMessageReadWord() : telos::I2cApi::Cpp::CSmbMasterMessageReadWord
  • CSmbMasterMessageReceiveByte() : telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
  • CSmbMasterMessageSendByte() : telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • CSmbMasterMessageWrite32() : telos::I2cApi::Cpp::CSmbMasterMessageWrite32
  • CSmbMasterMessageWrite64() : telos::I2cApi::Cpp::CSmbMasterMessageWrite64
  • CSmbMasterMessageWriteByte() : telos::I2cApi::Cpp::CSmbMasterMessageWriteByte
  • CSmbMasterMessageWriteWord() : telos::I2cApi::Cpp::CSmbMasterMessageWriteWord
  • CTimestamp() : telos::I2cApi::Cpp::CTimestamp
  • CTracer() : telos::I2cApi::Cpp::CTracer
  • CTraciiCpu() : telos::I2cApi::Cpp::CTraciiCpu


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data : telos::I2cApi::Cpp::STracerMessage
  • data_max : telos::I2cApi::Cpp::SAdcData
  • data_scl : telos::I2cApi::Cpp::SAdcData
  • data_sda : telos::I2cApi::Cpp::SAdcData
  • Delay() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • demo_license : telos::I2cApi::Cpp::SHardwareInfo
  • Disable()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CSlaveRam
, telos::I2cApi::Cpp::CTracer
  • DisableAddress() : telos::I2cApi::Cpp::CTracer
  • DisableAddressAll() : telos::I2cApi::Cpp::CTracer
  • dns_name : telos::I2cApi::Cpp::SHardwareInfo
  • drive_sda : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • Duration : telos::I2cApi::Cpp::CNegativeTester


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EAddressType : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • EBlockMode : telos::I2cApi::Cpp::CMasterMessageRx
  • EBusType : telos::I2cApi::Cpp::CBoard
  • EI2cBusState : telos::I2cApi::Cpp::CBoard
  • Enable()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CSlaveRam
, telos::I2cApi::Cpp::CTracer
  • enable_high_speed_current_source : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster
  • EnableAddress() : telos::I2cApi::Cpp::CTracer
  • EnableAddressAll() : telos::I2cApi::Cpp::CTracer
  • EnableLogging() : telos::I2cApi::Cpp::CBoard
  • ENackBehaviour : telos::I2cApi::Cpp::CNegativeTester
  • EResult : telos::I2cApi::Cpp::CNegativeTester
  • EStopTrigger : telos::I2cApi::Cpp::CNegativeTester
  • ExecuteArp() : telos::I2cApi::Cpp::CSmbArpMaster


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • features_simultaneously : telos::I2cApi::Cpp::SHardwareInfo
  • flasher : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GENERAL_CALL : telos::I2cApi::Cpp::CI2cAddress
  • Get10BitAddresses() : telos::I2cApi::Cpp::CI2cAddress
  • Get7BitAddresses() : telos::I2cApi::Cpp::CI2cAddress
  • GetAdc() : telos::I2cApi::Cpp::CBoard
  • GetAddress()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbArpMaster::CUdid
, telos::I2cApi::Cpp::CSmbMasterMessage
  • GetAddressMask() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetAddressType() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetAllAddresses() : telos::I2cApi::Cpp::CI2cAddress
  • GetAsfSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetAsVhd() : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • GetAutoIncrement() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetBitrate()
: telos::I2cApi::Cpp::CMaster
, telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetBitrateHighspeed() : telos::I2cApi::Cpp::CMaster
  • GetBitrateHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetBlockMode() : telos::I2cApi::Cpp::CMasterMessageRx
  • GetBoardTypeAsString() : telos::I2cApi::Cpp::SHardwareInfo
  • GetBusType() : telos::I2cApi::Cpp::CBoard
  • GetBytesTransferred()
: telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CMasterMessageRx
, telos::I2cApi::Cpp::CMasterMessageTx
  • GetCommand()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
  • GetCommandExtension() : telos::I2cApi::Cpp::CPmbusMasterMessage
  • GetCreateSpikes() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetCurrentTimestamp() : telos::I2cApi::Cpp::CBoard
  • GetData()
: telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbMasterMessageCmd32
, telos::I2cApi::Cpp::CSmbMasterMessageCmd64
, telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
, telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
, telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
, telos::I2cApi::Cpp::CSmbMasterMessageHostNotify
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • GetDataRx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • GetDataTx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • GetDescription() : telos::I2cApi::Cpp::CException
  • GetDeviceId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetEnabled() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetHardwareInfo() : telos::I2cApi::Cpp::CBoard
  • GetHardwareInfoOfOpenDevice() : telos::I2cApi::Cpp::CBoard
  • GetHighLevelThreshold() : telos::I2cApi::Cpp::CBoard
  • GetHighspeedMasterCode() : telos::I2cApi::Cpp::CMaster
  • GetHighSpeedToken() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetI2cAddress() : telos::I2cApi::Cpp::CSlaveRam
  • GetI2cBusLoad() : telos::I2cApi::Cpp::CBoard
  • GetI2cState() : telos::I2cApi::Cpp::CBoard
  • GetI2cVcc() : telos::I2cApi::Cpp::CBoard
  • GetI2cVccSupply() : telos::I2cApi::Cpp::CBoard
  • GetIgnoreStretching() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetInputTestpin() : telos::I2cApi::Cpp::CBoard
  • GetInputTestpins() : telos::I2cApi::Cpp::CTracer
  • GetIpmiSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetLanguageId() : telos::I2cApi::Cpp::CLanguage
  • GetLoopCount() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetLoopMode() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetLowLevelThreshold() : telos::I2cApi::Cpp::CBoard
  • GetMaster() : telos::I2cApi::Cpp::CBoard
  • GetMemorySize() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetMessageCountTrigger() : telos::I2cApi::Cpp::CAdc
  • GetMessageDataTrigger() : telos::I2cApi::Cpp::CAdc
  • GetMessages()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetNackBehaviour() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetNegativeTester() : telos::I2cApi::Cpp::CBoard
  • GetNumberOfBytes() : telos::I2cApi::Cpp::CMasterMessageRx
  • GetOemSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetOutputTestpin() : telos::I2cApi::Cpp::CBoard
  • GetPecSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetPendingAlerts() : telos::I2cApi::Cpp::CSmbMaster
  • GetPreTrigger() : telos::I2cApi::Cpp::CAdc
  • GetPullUpCurrentScl() : telos::I2cApi::Cpp::CBoard
  • GetPullUpCurrentSda() : telos::I2cApi::Cpp::CBoard
  • GetRestartAfterNackOrStop() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSamplingRate() : telos::I2cApi::Cpp::CAdc
  • GetSchedulerIpAddress() : telos::I2cApi::Cpp::CBoard
  • GetSchedulerVersion() : telos::I2cApi::Cpp::CBoard
  • GetSiliconRevision() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetSlaveAddress() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSlaveAddressMask() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSlaveRamEnhanced() : telos::I2cApi::Cpp::CBoard
  • GetSmbusVersion() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetStopAtArbitrationLost() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetStretching() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSubsystemDeviceId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetSubsystemVendorId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetTerminationScl() : telos::I2cApi::Cpp::CBoard
  • GetTerminationSda() : telos::I2cApi::Cpp::CBoard
  • GetTestpin1()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetTestpin2()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetTestpinConfiguration() : telos::I2cApi::Cpp::CBoard
  • GetTimeBuf() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeout() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetTimeSp() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimestamp() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampAsDuration() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampAsHexString() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampLsl() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampMsl() : telos::I2cApi::Cpp::CTimestamp
  • GetTimeSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTracer() : telos::I2cApi::Cpp::CBoard
  • GetTraciiCpu() : telos::I2cApi::Cpp::CBoard
  • GetTxDirection() : telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand
  • GetUdid() : telos::I2cApi::Cpp::CSmbArpMaster
  • GetUdidVersion() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetUseAckAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseErrorAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseNackAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseStartAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseStopAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseTestpin1AsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseTestpin2AsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetVendorId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetVendorSpecificId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetWatchdog() : telos::I2cApi::Cpp::CMaster
  • GetWeakTermination() : telos::I2cApi::Cpp::CMasterMessage
  • GetWithPec()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • GetZoneSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • high_level_threshold : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • I2C_BUS_STATE_NORMAL : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_SCL_LOW : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_SCL_SDA_LOW : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_SDA_LOW : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_UNKNOWN : telos::I2cApi::Cpp::CBoard
  • i2c_vcc_supply : telos::I2cApi::Cpp::SHardwareInfo
  • ignore_stretching : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster
  • internal_serial_number : telos::I2cApi::Cpp::SHardwareInfo
  • ip_address : telos::I2cApi::Cpp::SHardwareInfo
  • ip_port : telos::I2cApi::Cpp::SHardwareInfo
  • ird : telos::I2cApi::Cpp::SHardwareInfo
  • IsAddressAvailable() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • IsAddressEnabled() : telos::I2cApi::Cpp::CTracer
  • IsDeviceAvailable() : telos::I2cApi::Cpp::CBoard
  • IsDeviceOpen() : telos::I2cApi::Cpp::CBoard
  • IsEnabled()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CSlaveRam
, telos::I2cApi::Cpp::CTracer
  • IsFirstPartTenBitAddr() : telos::I2cApi::Cpp::CExceptionMasterAddress
  • IsInvalid() : telos::I2cApi::Cpp::CTimestamp
  • IsRunning() : telos::I2cApi::Cpp::CNegativeTester
  • IsSamplingCompleted() : telos::I2cApi::Cpp::CAdc
  • IsTenBitAddress() : telos::I2cApi::Cpp::CI2cAddress
  • IsTransmissionCompleted() : telos::I2cApi::Cpp::CAdc


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • labview : telos::I2cApi::Cpp::SHardwareInfo
  • levels : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • loop : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
  • loop_cnt : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • low_level_threshold : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • m_description_en : telos::I2cApi::Cpp::CException
  • major : telos::I2cApi::Cpp::SVersionNumber
  • master : telos::I2cApi::Cpp::SHardwareInfo
  • master_hs : telos::I2cApi::Cpp::SHardwareInfo
  • master_max_rx : telos::I2cApi::Cpp::SHardwareInfo
  • master_sampling_rate : telos::I2cApi::Cpp::SHardwareInfo
  • master_sampling_rate_hs : telos::I2cApi::Cpp::SHardwareInfo
  • MFR_SPECIFIC_COMMAND_EXT : telos::I2cApi::Cpp::CPmbusMasterMessage
  • minor : telos::I2cApi::Cpp::SVersionNumber
  • msgs : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • nack_behaviour : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • NACK_GENERATE_STOP : telos::I2cApi::Cpp::CNegativeTester
  • NACK_RELEASE_SCL_SDA : telos::I2cApi::Cpp::CNegativeTester
  • NACK_RESTART : telos::I2cApi::Cpp::CNegativeTester
  • negative_tester : telos::I2cApi::Cpp::SHardwareInfo
  • negative_tester_length : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OpenDevice() : telos::I2cApi::Cpp::CBoard
  • operator!=()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator++() : telos::I2cApi::Cpp::CI2cAddress , telos::I2cApi::Cpp::CTimestamp
  • operator--() : telos::I2cApi::Cpp::CI2cAddress , telos::I2cApi::Cpp::CTimestamp
  • operator<()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator<=()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator=() : telos::I2cApi::Cpp::SVersionNumber
  • operator==()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator>()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator>=()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PingScheduler() : telos::I2cApi::Cpp::CBoard
  • PMBUS_COMMAND_EXT : telos::I2cApi::Cpp::CPmbusMasterMessage
  • PMBUS_ZONE_READ : telos::I2cApi::Cpp::CI2cAddress
  • PMBUS_ZONE_WRITE : telos::I2cApi::Cpp::CI2cAddress
  • port : telos::I2cApi::Cpp::SHardwareInfo
  • PrepareToArp() : telos::I2cApi::Cpp::CSmbArpMaster
  • pretrigger : telos::I2cApi::Cpp::SAdcData
  • pull_up_current_max : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • raw : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ReceiveAckBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveAckBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveByte() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveByteHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveMessage() : telos::I2cApi::Cpp::CTracer
  • ReceiveMessages()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CTracer
  • RequestDataTransmission() : telos::I2cApi::Cpp::CAdc
  • required_service_contract : telos::I2cApi::Cpp::SHardwareInfo
  • required_versions : telos::I2cApi::Cpp::SHardwareInfo
  • ResetDevice() : telos::I2cApi::Cpp::CSmbArpMaster
  • restart_after_nack_or_stop : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
  • RESULT_ARBITRATION_LOST : telos::I2cApi::Cpp::CNegativeTester
  • RESULT_NACK : telos::I2cApi::Cpp::CNegativeTester
  • RESULT_OK : telos::I2cApi::Cpp::CNegativeTester


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • sampling_rate : telos::I2cApi::Cpp::SAdcData
  • ScanAddresses() : telos::I2cApi::Cpp::CMaster
  • scl : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • sda : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • SendAckBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendAckBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendByte() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendByteHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendCommand() : telos::I2cApi::Cpp::CTraciiCpu
  • SendHighSpeedToken() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendNackBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendNackBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendPmbusMasterMessage() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiver() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiverHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiverWithoutStop() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiverWithoutStopHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendRepeatedStart() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendRepeatedStartHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendSmbMasterMessage() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendStart() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendStop() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendStopHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitter() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterReceiver() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterReceiverHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterWithoutStop() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterWithoutStopHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • serial_number : telos::I2cApi::Cpp::SHardwareInfo
  • service_contract : telos::I2cApi::Cpp::SHardwareInfo
  • SetAddress()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbArpMaster::CUdid
, telos::I2cApi::Cpp::CSmbMasterMessage
  • SetAddressMask() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetAutoIncrement() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetBitrate()
: telos::I2cApi::Cpp::CMaster
, telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetBitrateHighspeed() : telos::I2cApi::Cpp::CMaster
  • SetBitrateHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetBlockMode() : telos::I2cApi::Cpp::CMasterMessageRx
  • SetBusType() : telos::I2cApi::Cpp::CBoard
  • SetBytesTransferred() : telos::I2cApi::Cpp::CMasterMessageTx
  • SetCommand()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
  • SetCommandExtension() : telos::I2cApi::Cpp::CPmbusMasterMessage
  • SetCompletionCallback() : telos::I2cApi::Cpp::CNegativeTester
  • SetCreateSpikes() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetData()
: telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbMasterMessageCmd32
, telos::I2cApi::Cpp::CSmbMasterMessageCmd64
, telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
, telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
, telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
, telos::I2cApi::Cpp::CSmbMasterMessageHostNotify
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • SetDataRx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • SetDataTx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • SetDeviceAddedRemovedCallback() : telos::I2cApi::Cpp::CBoard
  • SetEnabled() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetHighspeedMasterCode() : telos::I2cApi::Cpp::CMaster
  • SetHighSpeedToken() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetI2cVccSupply() : telos::I2cApi::Cpp::CBoard
  • SetIgnoreStretching() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetInvalid() : telos::I2cApi::Cpp::CTimestamp
  • SetLanguageId() : telos::I2cApi::Cpp::CLanguage
  • SetLevelThresholds() : telos::I2cApi::Cpp::CBoard
  • SetLoopCount() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetLoopMode() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetMemorySize() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetMessageCountTrigger() : telos::I2cApi::Cpp::CAdc
  • SetMessageDataTrigger() : telos::I2cApi::Cpp::CAdc
  • SetNackBehaviour() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetNumberOfBytes() : telos::I2cApi::Cpp::CMasterMessageRx
  • SetOutputTestpin() : telos::I2cApi::Cpp::CBoard
  • SetPreTrigger() : telos::I2cApi::Cpp::CAdc
  • SetPullUpCurrentScl() : telos::I2cApi::Cpp::CBoard
  • SetPullUpCurrentSda() : telos::I2cApi::Cpp::CBoard
  • SetRestartAfterNackOrStop() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetSamplingCompletionCallback() : telos::I2cApi::Cpp::CAdc
  • SetSamplingRate() : telos::I2cApi::Cpp::CAdc
  • SetSlaveAddress() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetSlaveAddressMask() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetStopAtArbitrationLost() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetStretching() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetTerminationScl() : telos::I2cApi::Cpp::CBoard
  • SetTerminationSda() : telos::I2cApi::Cpp::CBoard
  • SetTestpin1()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetTestpin2()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetTestpinConfiguration() : telos::I2cApi::Cpp::CBoard
  • SetTimeBuf() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeout() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetTimeSp() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimestamp() : telos::I2cApi::Cpp::CTimestamp
  • SetTimeSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTransferDataStatusCallback() : telos::I2cApi::Cpp::CMaster
  • SetTransmissionCompletionCallback() : telos::I2cApi::Cpp::CAdc
  • SetTxDirection() : telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand
  • SetUseAckAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseErrorAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseNackAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseStartAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseStopAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseTestpin1AsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseTestpin2AsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetWatchdog() : telos::I2cApi::Cpp::CMaster
  • SetWeakTermination() : telos::I2cApi::Cpp::CMasterMessage
  • SetWithPec()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • SHardwareInfo() : telos::I2cApi::Cpp::SHardwareInfo
  • slave_addr : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
  • slave_addr_dc : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
  • SLevelsMaster() : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster
  • SMBUS_ALERT_RESPONSE : telos::I2cApi::Cpp::CI2cAddress
  • SMBUS_DEVICE_DEFAULT : telos::I2cApi::Cpp::CI2cAddress
  • SMBUS_HOST : telos::I2cApi::Cpp::CI2cAddress
  • SMessageSlave : telos::I2cApi::Cpp::CNegativeTester
  • software_licenses : telos::I2cApi::Cpp::SHardwareInfo
  • Start() : telos::I2cApi::Cpp::CTraciiCpu
  • StartAdc() : telos::I2cApi::Cpp::CAdc
  • StartAdcImmediately() : telos::I2cApi::Cpp::CAdc
  • StartMaster() : telos::I2cApi::Cpp::CNegativeTester
  • StartSlave() : telos::I2cApi::Cpp::CNegativeTester
  • status : telos::I2cApi::Cpp::SInputTestpinsMessage
  • status_available : telos::I2cApi::Cpp::SInputTestpinsMessage
  • Stop()
: telos::I2cApi::Cpp::CNegativeTester
, telos::I2cApi::Cpp::CTraciiCpu
  • stop_trigger : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster
  • STOP_TRIGGER_ARBITRATION_LOST : telos::I2cApi::Cpp::CNegativeTester
  • STOP_TRIGGER_ARBITRATION_NOT_LOST : telos::I2cApi::Cpp::CNegativeTester
  • STOP_TRIGGER_NONE : telos::I2cApi::Cpp::CNegativeTester
  • SVersionNumber() : telos::I2cApi::Cpp::SVersionNumber


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • termination : telos::I2cApi::Cpp::SHardwareInfo
  • testpin1 : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • testpin2 : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • testpin_ack : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_error : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_nack : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_start : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_stop : telos::I2cApi::Cpp::SHardwareInfo
  • testpins_in : telos::I2cApi::Cpp::SHardwareInfo
  • testpins_out : telos::I2cApi::Cpp::SHardwareInfo
  • time : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • TIMEBASE : telos::I2cApi::Cpp::CNegativeTester
  • timestamp : telos::I2cApi::Cpp::SInputTestpinsMessage , telos::I2cApi::Cpp::STracerMessage
  • timestamp_start : telos::I2cApi::Cpp::SAdcData
  • timestamp_stop : telos::I2cApi::Cpp::SAdcData
  • timestamp_timebase : telos::I2cApi::Cpp::SHardwareInfo
  • tracer : telos::I2cApi::Cpp::SHardwareInfo
  • TransferData()
: telos::I2cApi::Cpp::CMaster
, telos::I2cApi::Cpp::CSmbMaster
  • TransferDataStatusCallBackFunction : telos::I2cApi::Cpp::CMaster
  • type : telos::I2cApi::Cpp::STracerMessage


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • VerifySMBAddress() : telos::I2cApi::Cpp::CI2cAddress
  • versions : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WaitForData() : telos::I2cApi::Cpp::CBoard


I2C.C++ API: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~CBoard() : telos::I2cApi::Cpp::CBoard
  • ~CMasterMessage() : telos::I2cApi::Cpp::CMasterMessage


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- a -

  • AddMessage()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • AssignAddress() : telos::I2cApi::Cpp::CSmbArpMaster
  • AutoDetectTermination() : telos::I2cApi::Cpp::CMaster


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- c -

  • CAdc() : telos::I2cApi::Cpp::CAdc
  • CalculateCrc8() : telos::I2cApi::Cpp::CSmbMaster
  • CancelAdc() : telos::I2cApi::Cpp::CAdc
  • CBoard() : telos::I2cApi::Cpp::CBoard
  • CExceptionAdcBusy() : telos::I2cApi::Cpp::CExceptionAdcBusy
  • CExceptionAdcNotFinished() : telos::I2cApi::Cpp::CExceptionAdcNotFinished
  • CExceptionAdcNotSupported() : telos::I2cApi::Cpp::CExceptionAdcNotSupported
  • CExceptionAdcPreTrigger() : telos::I2cApi::Cpp::CExceptionAdcPreTrigger
  • CExceptionAdcSamplingRate() : telos::I2cApi::Cpp::CExceptionAdcSamplingRate
  • CExceptionAdcTrigger() : telos::I2cApi::Cpp::CExceptionAdcTrigger
  • CExceptionArpI2cAddressesExhausted() : telos::I2cApi::Cpp::CExceptionArpI2cAddressesExhausted
  • CExceptionArpInvalidResponse() : telos::I2cApi::Cpp::CExceptionArpInvalidResponse
  • CExceptionAuthentication() : telos::I2cApi::Cpp::CExceptionAuthentication
  • CExceptionBusType() : telos::I2cApi::Cpp::CExceptionBusType
  • CExceptionDeviceOpen() : telos::I2cApi::Cpp::CExceptionDeviceOpen
  • CExceptionDriverVersion() : telos::I2cApi::Cpp::CExceptionDriverVersion
  • CExceptionHardwareIo() : telos::I2cApi::Cpp::CExceptionHardwareIo
  • CExceptionI2cAddress() : telos::I2cApi::Cpp::CExceptionI2cAddress
  • CExceptionI2cVcc() : telos::I2cApi::Cpp::CExceptionI2cVcc
  • CExceptionI2cVccSupply() : telos::I2cApi::Cpp::CExceptionI2cVccSupply
  • CExceptionInputTestpin() : telos::I2cApi::Cpp::CExceptionInputTestpin
  • CExceptionIo() : telos::I2cApi::Cpp::CExceptionIo
  • CExceptionLevelThreshold() : telos::I2cApi::Cpp::CExceptionLevelThreshold
  • CExceptionMasterAddress() : telos::I2cApi::Cpp::CExceptionMasterAddress
  • CExceptionMasterArbitration() : telos::I2cApi::Cpp::CExceptionMasterArbitration
  • CExceptionMasterBusy() : telos::I2cApi::Cpp::CExceptionMasterBusy
  • CExceptionMasterI2cProtocol() : telos::I2cApi::Cpp::CExceptionMasterI2cProtocol
  • CExceptionMasterIncompleteRx() : telos::I2cApi::Cpp::CExceptionMasterIncompleteRx
  • CExceptionMasterIncompleteTx() : telos::I2cApi::Cpp::CExceptionMasterIncompleteTx
  • CExceptionMasterInvalidBitrate() : telos::I2cApi::Cpp::CExceptionMasterInvalidBitrate
  • CExceptionMasterInvalidMasterCode() : telos::I2cApi::Cpp::CExceptionMasterInvalidMasterCode
  • CExceptionMasterInvalidTransfer() : telos::I2cApi::Cpp::CExceptionMasterInvalidTransfer
  • CExceptionMasterNotSupported() : telos::I2cApi::Cpp::CExceptionMasterNotSupported
  • CExceptionMasterRunning() : telos::I2cApi::Cpp::CExceptionMasterRunning
  • CExceptionMasterSmbInvalidSize() : telos::I2cApi::Cpp::CExceptionMasterSmbInvalidSize
  • CExceptionMasterSmbPecFailed() : telos::I2cApi::Cpp::CExceptionMasterSmbPecFailed
  • CExceptionMasterTimeout() : telos::I2cApi::Cpp::CExceptionMasterTimeout
  • CExceptionMasterWatchdogTimeout() : telos::I2cApi::Cpp::CExceptionMasterWatchdogTimeout
  • CExceptionNegativeTesterBusy() : telos::I2cApi::Cpp::CExceptionNegativeTesterBusy
  • CExceptionNegativeTesterInvalidArgument() : telos::I2cApi::Cpp::CExceptionNegativeTesterInvalidArgument
  • CExceptionNegativeTesterNotSupported() : telos::I2cApi::Cpp::CExceptionNegativeTesterNotSupported
  • CExceptionNegativeTesterProgramSize() : telos::I2cApi::Cpp::CExceptionNegativeTesterProgramSize
  • CExceptionNullPointer() : telos::I2cApi::Cpp::CExceptionNullPointer
  • CExceptionOpen() : telos::I2cApi::Cpp::CExceptionOpen
  • CExceptionOutputTestpin() : telos::I2cApi::Cpp::CExceptionOutputTestpin
  • CExceptionPullUpCurrent() : telos::I2cApi::Cpp::CExceptionPullUpCurrent
  • CExceptionSchedulerBusy() : telos::I2cApi::Cpp::CExceptionSchedulerBusy
  • CExceptionSchedulerVersion() : telos::I2cApi::Cpp::CExceptionSchedulerVersion
  • CExceptionServiceContractExpired() : telos::I2cApi::Cpp::CExceptionServiceContractExpired
  • CExceptionSlaveRamEnhancedAddress() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedAddress
  • CExceptionSlaveRamEnhancedBusy() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedBusy
  • CExceptionSlaveRamEnhancedMemorySize() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedMemorySize
  • CExceptionSlaveRamEnhancedNotSupported() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedNotSupported
  • CExceptionSlaveRamEnhancedSetData() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedSetData
  • CExceptionSlaveRamEnhancedTimeout() : telos::I2cApi::Cpp::CExceptionSlaveRamEnhancedTimeout
  • CExceptionSmbI2cAddress() : telos::I2cApi::Cpp::CExceptionSmbI2cAddress
  • CExceptionTermination() : telos::I2cApi::Cpp::CExceptionTermination
  • CExceptionTracerBusy() : telos::I2cApi::Cpp::CExceptionTracerBusy
  • CExceptionTracerFilter() : telos::I2cApi::Cpp::CExceptionTracerFilter
  • CExceptionTracerNotSupported() : telos::I2cApi::Cpp::CExceptionTracerNotSupported
  • CExceptionTraciiCpuBusy() : telos::I2cApi::Cpp::CExceptionTraciiCpuBusy
  • CExceptionTraciiCpuNotSupported() : telos::I2cApi::Cpp::CExceptionTraciiCpuNotSupported
  • CExceptionTraciiCpuProgramSize() : telos::I2cApi::Cpp::CExceptionTraciiCpuProgramSize
  • CI2cAddress() : telos::I2cApi::Cpp::CI2cAddress
  • CInputTestpins() : telos::I2cApi::Cpp::CInputTestpins
  • Clear()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • CloseDevice() : telos::I2cApi::Cpp::CBoard
  • CMaster() : telos::I2cApi::Cpp::CMaster
  • CMasterMessage() : telos::I2cApi::Cpp::CMasterMessage
  • CMasterMessageRx() : telos::I2cApi::Cpp::CMasterMessageRx
  • CMasterMessageTx() : telos::I2cApi::Cpp::CMasterMessageTx
  • CNegativeTester() : telos::I2cApi::Cpp::CNegativeTester
  • CNegativeTesterMaster() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • CNegativeTesterSlave() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • ConvertNanosecondsToTicks() : telos::I2cApi::Cpp::CNegativeTester
  • ConvertTicksToNanoseconds() : telos::I2cApi::Cpp::CNegativeTester
  • CPmbusMasterMessage() : telos::I2cApi::Cpp::CPmbusMasterMessage
  • CPmbusMasterMessageCmd() : telos::I2cApi::Cpp::CPmbusMasterMessageCmd
  • CPmbusMasterMessageExtCmdByte() : telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
  • CPmbusMasterMessageExtCmdWord() : telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
  • CPmbusMasterMessageGroupCmd() : telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
  • CPmbusMasterMessageReadByte() : telos::I2cApi::Cpp::CPmbusMasterMessageReadByte
  • CPmbusMasterMessageReadWord() : telos::I2cApi::Cpp::CPmbusMasterMessageReadWord
  • CPmbusMasterMessageWriteByte() : telos::I2cApi::Cpp::CPmbusMasterMessageWriteByte
  • CPmbusMasterMessageWriteWord() : telos::I2cApi::Cpp::CPmbusMasterMessageWriteWord
  • CreateReceiver() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverAckBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverByte() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateReceiverNackBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateStart() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitter() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitterAckBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitterBit() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CreateTransmitterByte() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • CSlaveRam() : telos::I2cApi::Cpp::CSlaveRam
  • CSlaveRamEnhanced() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • CSmbArpMaster() : telos::I2cApi::Cpp::CSmbArpMaster
  • CSmbMaster() : telos::I2cApi::Cpp::CSmbMaster
  • CSmbMasterMessage() : telos::I2cApi::Cpp::CSmbMasterMessage
  • CSmbMasterMessageBlockRead() : telos::I2cApi::Cpp::CSmbMasterMessageBlockRead
  • CSmbMasterMessageBlockWrite() : telos::I2cApi::Cpp::CSmbMasterMessageBlockWrite
  • CSmbMasterMessageBlockWriteRead() : telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
  • CSmbMasterMessageCmd() : telos::I2cApi::Cpp::CSmbMasterMessageCmd
  • CSmbMasterMessageCmd32() : telos::I2cApi::Cpp::CSmbMasterMessageCmd32
  • CSmbMasterMessageCmd64() : telos::I2cApi::Cpp::CSmbMasterMessageCmd64
  • CSmbMasterMessageCmdBlock() : telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
  • CSmbMasterMessageCmdByte() : telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
  • CSmbMasterMessageCmdProcessCall() : telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • CSmbMasterMessageCmdWord() : telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
  • CSmbMasterMessageHostNotify() : telos::I2cApi::Cpp::CSmbMasterMessageHostNotify
  • CSmbMasterMessageQuickCommand() : telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand
  • CSmbMasterMessageRead32() : telos::I2cApi::Cpp::CSmbMasterMessageRead32
  • CSmbMasterMessageRead64() : telos::I2cApi::Cpp::CSmbMasterMessageRead64
  • CSmbMasterMessageReadByte() : telos::I2cApi::Cpp::CSmbMasterMessageReadByte
  • CSmbMasterMessageReadWord() : telos::I2cApi::Cpp::CSmbMasterMessageReadWord
  • CSmbMasterMessageReceiveByte() : telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
  • CSmbMasterMessageSendByte() : telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • CSmbMasterMessageWrite32() : telos::I2cApi::Cpp::CSmbMasterMessageWrite32
  • CSmbMasterMessageWrite64() : telos::I2cApi::Cpp::CSmbMasterMessageWrite64
  • CSmbMasterMessageWriteByte() : telos::I2cApi::Cpp::CSmbMasterMessageWriteByte
  • CSmbMasterMessageWriteWord() : telos::I2cApi::Cpp::CSmbMasterMessageWriteWord
  • CTimestamp() : telos::I2cApi::Cpp::CTimestamp
  • CTracer() : telos::I2cApi::Cpp::CTracer
  • CTraciiCpu() : telos::I2cApi::Cpp::CTraciiCpu


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- d -

  • Delay() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • Disable()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CSlaveRam
, telos::I2cApi::Cpp::CTracer
  • DisableAddress() : telos::I2cApi::Cpp::CTracer
  • DisableAddressAll() : telos::I2cApi::Cpp::CTracer


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- e -

  • Enable()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CSlaveRam
, telos::I2cApi::Cpp::CTracer
  • EnableAddress() : telos::I2cApi::Cpp::CTracer
  • EnableAddressAll() : telos::I2cApi::Cpp::CTracer
  • EnableLogging() : telos::I2cApi::Cpp::CBoard
  • ExecuteArp() : telos::I2cApi::Cpp::CSmbArpMaster


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- g -

  • Get10BitAddresses() : telos::I2cApi::Cpp::CI2cAddress
  • Get7BitAddresses() : telos::I2cApi::Cpp::CI2cAddress
  • GetAdc() : telos::I2cApi::Cpp::CBoard
  • GetAddress()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbArpMaster::CUdid
, telos::I2cApi::Cpp::CSmbMasterMessage
  • GetAddressMask() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetAddressType() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetAllAddresses() : telos::I2cApi::Cpp::CI2cAddress
  • GetAsfSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetAsVhd() : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • GetAutoIncrement() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetBitrate()
: telos::I2cApi::Cpp::CMaster
, telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetBitrateHighspeed() : telos::I2cApi::Cpp::CMaster
  • GetBitrateHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetBlockMode() : telos::I2cApi::Cpp::CMasterMessageRx
  • GetBoardTypeAsString() : telos::I2cApi::Cpp::SHardwareInfo
  • GetBusType() : telos::I2cApi::Cpp::CBoard
  • GetBytesTransferred()
: telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CMasterMessageRx
, telos::I2cApi::Cpp::CMasterMessageTx
  • GetCommand()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
  • GetCommandExtension() : telos::I2cApi::Cpp::CPmbusMasterMessage
  • GetCreateSpikes() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetCurrentTimestamp() : telos::I2cApi::Cpp::CBoard
  • GetData()
: telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbMasterMessageCmd32
, telos::I2cApi::Cpp::CSmbMasterMessageCmd64
, telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
, telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
, telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
, telos::I2cApi::Cpp::CSmbMasterMessageHostNotify
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • GetDataRx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • GetDataTx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • GetDescription() : telos::I2cApi::Cpp::CException
  • GetDeviceId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetEnabled() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetHardwareInfo() : telos::I2cApi::Cpp::CBoard
  • GetHardwareInfoOfOpenDevice() : telos::I2cApi::Cpp::CBoard
  • GetHighLevelThreshold() : telos::I2cApi::Cpp::CBoard
  • GetHighspeedMasterCode() : telos::I2cApi::Cpp::CMaster
  • GetHighSpeedToken() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetI2cAddress() : telos::I2cApi::Cpp::CSlaveRam
  • GetI2cBusLoad() : telos::I2cApi::Cpp::CBoard
  • GetI2cState() : telos::I2cApi::Cpp::CBoard
  • GetI2cVcc() : telos::I2cApi::Cpp::CBoard
  • GetI2cVccSupply() : telos::I2cApi::Cpp::CBoard
  • GetIgnoreStretching() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetInputTestpin() : telos::I2cApi::Cpp::CBoard
  • GetInputTestpins() : telos::I2cApi::Cpp::CTracer
  • GetIpmiSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetLanguageId() : telos::I2cApi::Cpp::CLanguage
  • GetLoopCount() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetLoopMode() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetLowLevelThreshold() : telos::I2cApi::Cpp::CBoard
  • GetMaster() : telos::I2cApi::Cpp::CBoard
  • GetMemorySize() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetMessageCountTrigger() : telos::I2cApi::Cpp::CAdc
  • GetMessageDataTrigger() : telos::I2cApi::Cpp::CAdc
  • GetMessages()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetNackBehaviour() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetNegativeTester() : telos::I2cApi::Cpp::CBoard
  • GetNumberOfBytes() : telos::I2cApi::Cpp::CMasterMessageRx
  • GetOemSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetOutputTestpin() : telos::I2cApi::Cpp::CBoard
  • GetPecSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetPendingAlerts() : telos::I2cApi::Cpp::CSmbMaster
  • GetPreTrigger() : telos::I2cApi::Cpp::CAdc
  • GetPullUpCurrentScl() : telos::I2cApi::Cpp::CBoard
  • GetPullUpCurrentSda() : telos::I2cApi::Cpp::CBoard
  • GetRestartAfterNackOrStop() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSamplingRate() : telos::I2cApi::Cpp::CAdc
  • GetSchedulerIpAddress() : telos::I2cApi::Cpp::CBoard
  • GetSchedulerVersion() : telos::I2cApi::Cpp::CBoard
  • GetSiliconRevision() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetSlaveAddress() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSlaveAddressMask() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSlaveRamEnhanced() : telos::I2cApi::Cpp::CBoard
  • GetSmbusVersion() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetStopAtArbitrationLost() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetStretching() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetSubsystemDeviceId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetSubsystemVendorId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetTerminationScl() : telos::I2cApi::Cpp::CBoard
  • GetTerminationSda() : telos::I2cApi::Cpp::CBoard
  • GetTestpin1()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetTestpin2()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • GetTestpinConfiguration() : telos::I2cApi::Cpp::CBoard
  • GetTimeBuf() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeHighSpeedSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeout() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • GetTimeSp() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimestamp() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampAsDuration() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampAsHexString() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampLsl() : telos::I2cApi::Cpp::CTimestamp
  • GetTimestampMsl() : telos::I2cApi::Cpp::CTimestamp
  • GetTimeSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTimeSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • GetTracer() : telos::I2cApi::Cpp::CBoard
  • GetTraciiCpu() : telos::I2cApi::Cpp::CBoard
  • GetTxDirection() : telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand
  • GetUdid() : telos::I2cApi::Cpp::CSmbArpMaster
  • GetUdidVersion() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetUseAckAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseErrorAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseNackAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseStartAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseStopAsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseTestpin1AsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetUseTestpin2AsTrigger() : telos::I2cApi::Cpp::CAdc
  • GetVendorId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetVendorSpecificId() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • GetWatchdog() : telos::I2cApi::Cpp::CMaster
  • GetWeakTermination() : telos::I2cApi::Cpp::CMasterMessage
  • GetWithPec()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • GetZoneSupport() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- i -

  • IsAddressAvailable() : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • IsAddressEnabled() : telos::I2cApi::Cpp::CTracer
  • IsDeviceAvailable() : telos::I2cApi::Cpp::CBoard
  • IsDeviceOpen() : telos::I2cApi::Cpp::CBoard
  • IsEnabled()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CSlaveRam
, telos::I2cApi::Cpp::CTracer
  • IsFirstPartTenBitAddr() : telos::I2cApi::Cpp::CExceptionMasterAddress
  • IsInvalid() : telos::I2cApi::Cpp::CTimestamp
  • IsRunning() : telos::I2cApi::Cpp::CNegativeTester
  • IsSamplingCompleted() : telos::I2cApi::Cpp::CAdc
  • IsTenBitAddress() : telos::I2cApi::Cpp::CI2cAddress
  • IsTransmissionCompleted() : telos::I2cApi::Cpp::CAdc


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- o -

  • OpenDevice() : telos::I2cApi::Cpp::CBoard
  • operator!=()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator++() : telos::I2cApi::Cpp::CI2cAddress , telos::I2cApi::Cpp::CTimestamp
  • operator--() : telos::I2cApi::Cpp::CI2cAddress , telos::I2cApi::Cpp::CTimestamp
  • operator<()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator<=()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator=() : telos::I2cApi::Cpp::SVersionNumber
  • operator==()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator>()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber
  • operator>=()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CTimestamp
, telos::I2cApi::Cpp::SVersionNumber


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- p -

  • PingScheduler() : telos::I2cApi::Cpp::CBoard
  • PrepareToArp() : telos::I2cApi::Cpp::CSmbArpMaster


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- r -

  • ReceiveAckBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveAckBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveByte() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveByteHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • ReceiveMessage() : telos::I2cApi::Cpp::CTracer
  • ReceiveMessages()
: telos::I2cApi::Cpp::CInputTestpins
, telos::I2cApi::Cpp::CTracer
  • RequestDataTransmission() : telos::I2cApi::Cpp::CAdc
  • ResetDevice() : telos::I2cApi::Cpp::CSmbArpMaster


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- s -

  • ScanAddresses() : telos::I2cApi::Cpp::CMaster
  • SendAckBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendAckBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendByte() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendByteHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendCommand() : telos::I2cApi::Cpp::CTraciiCpu
  • SendHighSpeedToken() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendNackBit() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendNackBitHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendPmbusMasterMessage() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiver() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiverHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiverWithoutStop() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendReceiverWithoutStopHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendRepeatedStart() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendRepeatedStartHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendSmbMasterMessage() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendStart() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendStop() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendStopHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitter() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterReceiver() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterReceiverHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterWithoutStop() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SendTransmitterWithoutStopHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetAddress()
: telos::I2cApi::Cpp::CI2cAddress
, telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbArpMaster::CUdid
, telos::I2cApi::Cpp::CSmbMasterMessage
  • SetAddressMask() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetAutoIncrement() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetBitrate()
: telos::I2cApi::Cpp::CMaster
, telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetBitrateHighspeed() : telos::I2cApi::Cpp::CMaster
  • SetBitrateHighSpeed() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetBlockMode() : telos::I2cApi::Cpp::CMasterMessageRx
  • SetBusType() : telos::I2cApi::Cpp::CBoard
  • SetBytesTransferred() : telos::I2cApi::Cpp::CMasterMessageTx
  • SetCommand()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
  • SetCommandExtension() : telos::I2cApi::Cpp::CPmbusMasterMessage
  • SetCompletionCallback() : telos::I2cApi::Cpp::CNegativeTester
  • SetCreateSpikes() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetData()
: telos::I2cApi::Cpp::CMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageCmd
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdByte
, telos::I2cApi::Cpp::CPmbusMasterMessageExtCmdWord
, telos::I2cApi::Cpp::CSlaveRamEnhanced
, telos::I2cApi::Cpp::CSmbMasterMessageCmd32
, telos::I2cApi::Cpp::CSmbMasterMessageCmd64
, telos::I2cApi::Cpp::CSmbMasterMessageCmdBlock
, telos::I2cApi::Cpp::CSmbMasterMessageCmdByte
, telos::I2cApi::Cpp::CSmbMasterMessageCmdWord
, telos::I2cApi::Cpp::CSmbMasterMessageHostNotify
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • SetDataRx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • SetDataTx()
: telos::I2cApi::Cpp::CSmbMasterMessageBlockWriteRead
, telos::I2cApi::Cpp::CSmbMasterMessageCmdProcessCall
  • SetDeviceAddedRemovedCallback() : telos::I2cApi::Cpp::CBoard
  • SetEnabled() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetHighspeedMasterCode() : telos::I2cApi::Cpp::CMaster
  • SetHighSpeedToken() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetI2cVccSupply() : telos::I2cApi::Cpp::CBoard
  • SetIgnoreStretching() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetInvalid() : telos::I2cApi::Cpp::CTimestamp
  • SetLanguageId() : telos::I2cApi::Cpp::CLanguage
  • SetLevelThresholds() : telos::I2cApi::Cpp::CBoard
  • SetLoopCount() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetLoopMode() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetMemorySize() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetMessageCountTrigger() : telos::I2cApi::Cpp::CAdc
  • SetMessageDataTrigger() : telos::I2cApi::Cpp::CAdc
  • SetNackBehaviour() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetNumberOfBytes() : telos::I2cApi::Cpp::CMasterMessageRx
  • SetOutputTestpin() : telos::I2cApi::Cpp::CBoard
  • SetPreTrigger() : telos::I2cApi::Cpp::CAdc
  • SetPullUpCurrentScl() : telos::I2cApi::Cpp::CBoard
  • SetPullUpCurrentSda() : telos::I2cApi::Cpp::CBoard
  • SetRestartAfterNackOrStop() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetSamplingCompletionCallback() : telos::I2cApi::Cpp::CAdc
  • SetSamplingRate() : telos::I2cApi::Cpp::CAdc
  • SetSlaveAddress() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetSlaveAddressMask() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetStopAtArbitrationLost() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetStretching() : telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetTerminationScl() : telos::I2cApi::Cpp::CBoard
  • SetTerminationSda() : telos::I2cApi::Cpp::CBoard
  • SetTestpin1()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetTestpin2()
: telos::I2cApi::Cpp::CNegativeTesterMaster
, telos::I2cApi::Cpp::CNegativeTesterSlave
  • SetTestpinConfiguration() : telos::I2cApi::Cpp::CBoard
  • SetTimeBuf() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedHdSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeHighSpeedSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeLowAfterHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeLowBeforeHigh() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeout() : telos::I2cApi::Cpp::CSlaveRamEnhanced
  • SetTimeSp() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimestamp() : telos::I2cApi::Cpp::CTimestamp
  • SetTimeSuSta() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTimeSuSto() : telos::I2cApi::Cpp::CNegativeTesterMaster
  • SetTransferDataStatusCallback() : telos::I2cApi::Cpp::CMaster
  • SetTransmissionCompletionCallback() : telos::I2cApi::Cpp::CAdc
  • SetTxDirection() : telos::I2cApi::Cpp::CSmbMasterMessageQuickCommand
  • SetUseAckAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseErrorAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseNackAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseStartAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseStopAsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseTestpin1AsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetUseTestpin2AsTrigger() : telos::I2cApi::Cpp::CAdc
  • SetWatchdog() : telos::I2cApi::Cpp::CMaster
  • SetWeakTermination() : telos::I2cApi::Cpp::CMasterMessage
  • SetWithPec()
: telos::I2cApi::Cpp::CPmbusMasterMessage
, telos::I2cApi::Cpp::CPmbusMasterMessageGroupCmd
, telos::I2cApi::Cpp::CSmbMasterMessageCmd
, telos::I2cApi::Cpp::CSmbMasterMessageReceiveByte
, telos::I2cApi::Cpp::CSmbMasterMessageSendByte
  • SHardwareInfo() : telos::I2cApi::Cpp::SHardwareInfo
  • SLevelsMaster() : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster
  • Start() : telos::I2cApi::Cpp::CTraciiCpu
  • StartAdc() : telos::I2cApi::Cpp::CAdc
  • StartAdcImmediately() : telos::I2cApi::Cpp::CAdc
  • StartMaster() : telos::I2cApi::Cpp::CNegativeTester
  • StartSlave() : telos::I2cApi::Cpp::CNegativeTester
  • Stop()
: telos::I2cApi::Cpp::CNegativeTester
, telos::I2cApi::Cpp::CTraciiCpu
  • SVersionNumber() : telos::I2cApi::Cpp::SVersionNumber


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- t -

  • TransferData()
: telos::I2cApi::Cpp::CMaster
, telos::I2cApi::Cpp::CSmbMaster


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- v -

  • VerifySMBAddress() : telos::I2cApi::Cpp::CI2cAddress


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- w -

  • WaitForData() : telos::I2cApi::Cpp::CBoard


I2C.C++ API: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~

- ~ -

  • ~CBoard() : telos::I2cApi::Cpp::CBoard
  • ~CMasterMessage() : telos::I2cApi::Cpp::CMasterMessage


I2C.C++ API: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- a -

  • adc : telos::I2cApi::Cpp::SHardwareInfo
  • adc_max_pretrigger : telos::I2cApi::Cpp::SHardwareInfo
  • adc_sampling_depth : telos::I2cApi::Cpp::SHardwareInfo
  • adc_samplingrate : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_ack : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_data : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_error : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_immediately : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_msg_cnt : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_nack : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_start : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_stop : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_testpin1 : telos::I2cApi::Cpp::SHardwareInfo
  • adc_trigger_testpin2 : telos::I2cApi::Cpp::SHardwareInfo
  • adc_vcc : telos::I2cApi::Cpp::SHardwareInfo
  • addr : telos::I2cApi::Cpp::CSmbArpMaster::CUdid

- b -

  • board_type : telos::I2cApi::Cpp::SHardwareInfo
  • build : telos::I2cApi::Cpp::SVersionNumber
  • bus_type_smb : telos::I2cApi::Cpp::SHardwareInfo

- c -

  • confirmation : telos::I2cApi::Cpp::STracerMessage

- d -

  • data : telos::I2cApi::Cpp::STracerMessage
  • data_max : telos::I2cApi::Cpp::SAdcData
  • data_scl : telos::I2cApi::Cpp::SAdcData
  • data_sda : telos::I2cApi::Cpp::SAdcData
  • demo_license : telos::I2cApi::Cpp::SHardwareInfo
  • dns_name : telos::I2cApi::Cpp::SHardwareInfo
  • drive_sda : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave

- e -

  • enable_high_speed_current_source : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster

- f -

  • features_simultaneously : telos::I2cApi::Cpp::SHardwareInfo
  • flasher : telos::I2cApi::Cpp::SHardwareInfo

- g -

  • GENERAL_CALL : telos::I2cApi::Cpp::CI2cAddress

- h -

  • high_level_threshold : telos::I2cApi::Cpp::SHardwareInfo

- i -

  • i2c_vcc_supply : telos::I2cApi::Cpp::SHardwareInfo
  • ignore_stretching : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster
  • internal_serial_number : telos::I2cApi::Cpp::SHardwareInfo
  • ip_address : telos::I2cApi::Cpp::SHardwareInfo
  • ip_port : telos::I2cApi::Cpp::SHardwareInfo
  • ird : telos::I2cApi::Cpp::SHardwareInfo

- l -

  • labview : telos::I2cApi::Cpp::SHardwareInfo
  • levels : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • loop : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
  • loop_cnt : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • low_level_threshold : telos::I2cApi::Cpp::SHardwareInfo

- m -

  • m_description_en : telos::I2cApi::Cpp::CException
  • major : telos::I2cApi::Cpp::SVersionNumber
  • master : telos::I2cApi::Cpp::SHardwareInfo
  • master_hs : telos::I2cApi::Cpp::SHardwareInfo
  • master_max_rx : telos::I2cApi::Cpp::SHardwareInfo
  • master_sampling_rate : telos::I2cApi::Cpp::SHardwareInfo
  • master_sampling_rate_hs : telos::I2cApi::Cpp::SHardwareInfo
  • MFR_SPECIFIC_COMMAND_EXT : telos::I2cApi::Cpp::CPmbusMasterMessage
  • minor : telos::I2cApi::Cpp::SVersionNumber
  • msgs : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave

- n -

  • nack_behaviour : telos::I2cApi::Cpp::CNegativeTester::SMessagesMaster
  • negative_tester : telos::I2cApi::Cpp::SHardwareInfo
  • negative_tester_length : telos::I2cApi::Cpp::SHardwareInfo

- p -

  • PMBUS_COMMAND_EXT : telos::I2cApi::Cpp::CPmbusMasterMessage
  • PMBUS_ZONE_READ : telos::I2cApi::Cpp::CI2cAddress
  • PMBUS_ZONE_WRITE : telos::I2cApi::Cpp::CI2cAddress
  • port : telos::I2cApi::Cpp::SHardwareInfo
  • pretrigger : telos::I2cApi::Cpp::SAdcData
  • pull_up_current_max : telos::I2cApi::Cpp::SHardwareInfo

- r -

  • raw : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • required_service_contract : telos::I2cApi::Cpp::SHardwareInfo
  • required_versions : telos::I2cApi::Cpp::SHardwareInfo
  • restart_after_nack_or_stop : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave

- s -

  • sampling_rate : telos::I2cApi::Cpp::SAdcData
  • scl : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • sda : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • serial_number : telos::I2cApi::Cpp::SHardwareInfo
  • service_contract : telos::I2cApi::Cpp::SHardwareInfo
  • slave_addr : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
  • slave_addr_dc : telos::I2cApi::Cpp::CNegativeTester::SMessagesSlave
  • SMBUS_ALERT_RESPONSE : telos::I2cApi::Cpp::CI2cAddress
  • SMBUS_DEVICE_DEFAULT : telos::I2cApi::Cpp::CI2cAddress
  • SMBUS_HOST : telos::I2cApi::Cpp::CI2cAddress
  • software_licenses : telos::I2cApi::Cpp::SHardwareInfo
  • status : telos::I2cApi::Cpp::SInputTestpinsMessage
  • status_available : telos::I2cApi::Cpp::SInputTestpinsMessage
  • stop_trigger : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster

- t -

  • termination : telos::I2cApi::Cpp::SHardwareInfo
  • testpin1 : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • testpin2 : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • testpin_ack : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_error : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_nack : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_start : telos::I2cApi::Cpp::SHardwareInfo
  • testpin_stop : telos::I2cApi::Cpp::SHardwareInfo
  • testpins_in : telos::I2cApi::Cpp::SHardwareInfo
  • testpins_out : telos::I2cApi::Cpp::SHardwareInfo
  • time : telos::I2cApi::Cpp::CNegativeTester::SLevelsMaster , telos::I2cApi::Cpp::CNegativeTester::SLevelsSlave
  • TIMEBASE : telos::I2cApi::Cpp::CNegativeTester
  • timestamp : telos::I2cApi::Cpp::SInputTestpinsMessage , telos::I2cApi::Cpp::STracerMessage
  • timestamp_start : telos::I2cApi::Cpp::SAdcData
  • timestamp_stop : telos::I2cApi::Cpp::SAdcData
  • timestamp_timebase : telos::I2cApi::Cpp::SHardwareInfo
  • tracer : telos::I2cApi::Cpp::SHardwareInfo
  • type : telos::I2cApi::Cpp::STracerMessage

- v -

  • versions : telos::I2cApi::Cpp::SHardwareInfo


I2C.C++ API: Class Members - Typedefs

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • CallBackFunction
: telos::I2cApi::Cpp::CAdc
, telos::I2cApi::Cpp::CBoard
, telos::I2cApi::Cpp::CNegativeTester
  • Duration : telos::I2cApi::Cpp::CNegativeTester
  • SMessageSlave : telos::I2cApi::Cpp::CNegativeTester
  • TransferDataStatusCallBackFunction : telos::I2cApi::Cpp::CMaster


I2C.C++ API: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • EAddressType : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • EBlockMode : telos::I2cApi::Cpp::CMasterMessageRx
  • EBusType : telos::I2cApi::Cpp::CBoard
  • EI2cBusState : telos::I2cApi::Cpp::CBoard
  • ENackBehaviour : telos::I2cApi::Cpp::CNegativeTester
  • EResult : telos::I2cApi::Cpp::CNegativeTester
  • EStopTrigger : telos::I2cApi::Cpp::CNegativeTester


I2C.C++ API: Class Members - Enumerator

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • ADDR_TYPE_DYNAMIC_PERSISTENT : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ADDR_TYPE_DYNAMIC_VOLATILE : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ADDR_TYPE_FIXED : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • ADDR_TYPE_RANDOM : telos::I2cApi::Cpp::CSmbArpMaster::CUdid
  • BLOCK_MODE_NONE : telos::I2cApi::Cpp::CMasterMessageRx
  • BLOCK_MODE_WITH_PEC : telos::I2cApi::Cpp::CMasterMessageRx
  • BLOCK_MODE_WITHOUT_PEC : telos::I2cApi::Cpp::CMasterMessageRx
  • BUS_TYPE_I2C : telos::I2cApi::Cpp::CBoard
  • BUS_TYPE_SMB : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_NORMAL : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_SCL_LOW : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_SCL_SDA_LOW : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_SDA_LOW : telos::I2cApi::Cpp::CBoard
  • I2C_BUS_STATE_UNKNOWN : telos::I2cApi::Cpp::CBoard
  • NACK_GENERATE_STOP : telos::I2cApi::Cpp::CNegativeTester
  • NACK_RELEASE_SCL_SDA : telos::I2cApi::Cpp::CNegativeTester
  • NACK_RESTART : telos::I2cApi::Cpp::CNegativeTester
  • RESULT_ARBITRATION_LOST : telos::I2cApi::Cpp::CNegativeTester
  • RESULT_NACK : telos::I2cApi::Cpp::CNegativeTester
  • RESULT_OK : telos::I2cApi::Cpp::CNegativeTester
  • STOP_TRIGGER_ARBITRATION_LOST : telos::I2cApi::Cpp::CNegativeTester
  • STOP_TRIGGER_ARBITRATION_NOT_LOST : telos::I2cApi::Cpp::CNegativeTester
  • STOP_TRIGGER_NONE : telos::I2cApi::Cpp::CNegativeTester


I2C.C++ API: Examples

Examples
Here is a list of all examples:
  • AdcExample.cpp
  • InputTestpinsExample.cpp
  • MasterExample.cpp
  • NegativeTesterExample.cpp
  • TracerCsvExample.cpp
  • TracerExample.cpp


I2C.C++ API: AdcExample.cpp

AdcExample.cpp

The following example demonstrates how to use the telos::I2cApi::Cpp::CAdc class:

/*************************************************************
Copyright (c) 2003-2015 telos Systementwicklung GmbH,
Hamburg (Germany)
http://www.telos.de
Demonstrates how to use the A/D classes with
the I2C.C++ API.
*************************************************************/
#include "CBoard.h"
#include "CAdc.h"
#include "CException.h"
#include <iostream>
using namespace telos::I2cApi::Cpp;
using namespace std;
/***********************************************************************/
/* This type is used to pass data to the callback functions. */
/***********************************************************************/
struct adc_t
{
SAdcData data;
bool running;
};
/***********************************************************************/
/* Displays some information about the A/D features supported by *
* an I2C interface. */
/***********************************************************************/
void AdcInfo (const SHardwareInfo &hwinfo)
{
// Display serial number of the I2C interface.
cout << "Serial number: 0x" << (hex)
<< hwinfo.serial_number << (dec) << endl;
// Display: A/D convert supported?
cout << "Supports A/D converter: " << hwinfo.adc << endl;
// Return if there is no A/D converter support.
if (hwinfo.adc == false)
return;
// Display: Which events can be used to start the A/D converter.
cout << "Supported trigger conditions: ";
if (hwinfo.adc_trigger_start == true)
cout << "start ";
if (hwinfo.adc_trigger_stop == true)
cout << "stop ";
if (hwinfo.adc_trigger_ack == true)
cout << "ack ";
if (hwinfo.adc_trigger_testpin1 == true)
cout << "testpin1 ";
if (hwinfo.adc_trigger_testpin2 == true)
cout << "testpin2 ";
cout << endl;
// Display: Vcc of the A/D samples. This value specifies the
// voltage of the A/D converter value "255".
cout << "Vcc of A/D samples: " << hwinfo.adc_vcc << " mV" << endl;
// Display the sampling rates supported by the A/D converter.
cout << "Sampling rates: ";
for (uint32_t samplingrate : hwinfo.adc_samplingrate)
cout << samplingrate << " ";
cout << endl;
// Display the maximum value for the pretrigger setting.
if (hwinfo.adc_max_pretrigger != ~0)
cout << "Maximum pretrigger: " << hwinfo.adc_max_pretrigger << endl;
else
cout << "Pretrigger: N/A" << endl;
cout << endl;
}
/***********************************************************************/
/* This function gets called when an I2C interface has finished *
* the sampling process. It requests the transmission of the A/D *
* data from the I2C interface to the application. */
/***********************************************************************/
void AdcTestSamplingCompletion (CAdc *adc, void *private_data)
{
cout << "Sampling finished." << endl;
// Request the transmission of the A/D value from the
// I2C interface to the application.
adc->RequestDataTransmission (*(static_cast<SAdcData*>(private_data)));
cout << "Starting data transmission ... " << flush;
}
/***********************************************************************/
/* This function gets called when the API has transmitted all A/D *
* data to the application. The completion of the transmission is *
* signalled to the "main" function using a boolean variable. */
/***********************************************************************/
void AdcTestTransmissionCompletion (CAdc *adc, void *private_data)
{
adc_t *adc_data = static_cast<adc_t*>(private_data);
// Display some informations about the received A/D samples.
cout << "finished." << endl;
cout << "SCL samples: " << adc_data->data.data_scl.size() << endl;
cout << "SDA samples: " << adc_data->data.data_sda.size() << endl;
cout << "Timestamp first sample: "
<< adc_data->data.timestamp_start.GetTimestampAsHexString() << endl;
cout << "Timestamp last sample: "
<< adc_data->data.timestamp_stop.GetTimestampAsHexString() << endl;
cout << "Maximum value of SCL/SDA samples: "
<< static_cast<unsigned int>(adc_data->data.data_max) << endl;
// Signal the end of the A/D conversion.
adc_data->running = false;
}
/***********************************************************************/
/* Demonstrates the API of the A/D converter. */
/***********************************************************************/
void AdcTest (CBoard &board)
{
adc_t adc;
// Get a reference to the object describing the features
// of the used I2C interface.
const SHardwareInfo &hwinfo = board.GetHardwareInfoOfOpenDevice();
// Configure the pretrigger. The pretrigger specifies the
// number of samples, which get stored by the A/D converter
// before detecting the trigger condition.
if (hwinfo.adc_max_pretrigger != ~0)
{
cout << "Setting pretrigger to \"0\" ..." << endl;
board.GetAdc().SetPreTrigger (0);
}
// Configure the sampling rate of the A/D converter.
cout << "Setting sampling rate to \""
<< hwinfo.adc_samplingrate[0] << "\" Hz ..." << endl;
board.GetAdc().SetSamplingRate (hwinfo.adc_samplingrate[0]);
// Use the I2C start and stop to start the A/D conversion.
cout << "Setting trigger conditions ..." << endl;
if (hwinfo.adc_trigger_start == true)
board.GetAdc().SetUseStartAsTrigger (true);
if (hwinfo.adc_trigger_stop == true)
board.GetAdc().SetUseStopAsTrigger (true);
// Register callback function, which gets called by the API
// when the hardware has finished the sampling process.
board.GetAdc().SetSamplingCompletionCallback (AdcTestSamplingCompletion,
&adc);
// Register callback function, which gets called by the API
// when the application/API has received all A/D values
// from the I2C interface.
board.GetAdc().SetTransmissionCompletionCallback (AdcTestTransmissionCompletion,
&adc);
// Status variable to be changed by the transmission completion
// callback function.
adc.running = true;
// Start the A/D converter.
cout << "Starting A/D converter ..." << endl;
board.GetAdc().StartAdc();
// Sleep until the transmission completion callback function
// has been called. It is very important to call
// CBoard::WaitForData() when the A/D converter has been
// activated, because this method is responsible for transferring
// the data to the application and calling the callback
// functions.
while (adc.running)
board.WaitForData (10*1000*1000);
}
/***********************************************************************/
/* Main function
/***********************************************************************/
int main (void)
{
try
{
CBoard board;
vector<SHardwareInfo> hwinfos;
// Get a list of all available I2C interfaces.
board.GetHardwareInfo (hwinfos);
// Open the first available I2C interface containing an
// A/D converter.
for (SHardwareInfo &hwinfo : hwinfos)
{
if (hwinfo.adc == true)
{
board.OpenDevice (hwinfo);
break;
}
}
// Show some informations about the used I2C interface.
AdcInfo (board.GetHardwareInfoOfOpenDevice());
// Demonstrate the A/D converter module.
AdcTest (board);
// Close I2C interface.
board.CloseDevice();
}
catch (CException &exp)
{
cout << "Error: " << exp.GetDescription() << endl;
return (1);
}
return (0);
}


I2C.C++ API: InputTestpinsExample.cpp

InputTestpinsExample.cpp

The following example demonstrates how to use the telos::I2cApi::Cpp::CInputTestpins class:

/*************************************************************
Copyright (c) 2003-2015 telos Systementwicklung GmbH,
Hamburg (Germany)
http://www.telos.de
Demonstrates how to use the input testpin classes with
the I2C.C++ API.
*************************************************************/
#include "CBoard.h"
#include "CException.h"
#include "CInputTestpins.h"
#include <vector>
#include <iostream>
using namespace telos::I2cApi::Cpp;
using namespace std;
/***********************************************************************/
/* Displays one SInputTestpinsMessage message.
/***********************************************************************/
void DisplayInputTestpinMessage (const SHardwareInfo &hwinfo,
const SInputTestpinsMessage &msg)
{
for (int i=0; i < hwinfo.testpins_in; i++)
cout << "Testpin " << i << ": Level = "
<< ((msg.status >> i) & 0x01) << endl;
cout << endl;
}
/***********************************************************************/
/* Logs and displays 10 transitions of the input testpins.
/***********************************************************************/
void TestInputTestpins (CBoard &board)
{
CInputTestpins &testpins = board.GetTracer().GetInputTestpins();
std::vector<SInputTestpinsMessage> msgs;
// start logging of input testpin transitions
testpins.Enable();
// Display 10 transitions
for (int i=0; i < 10; )
{
board.WaitForData (1000 * 100);
testpins.ReceiveMessages (msgs, 1);
if (msgs.size() > 0)
{
DisplayInputTestpinMessage (board.GetHardwareInfoOfOpenDevice(), msgs[0]);
msgs.clear();
i++;
}
}
// stop logging of input testpin transitions
testpins.Disable();
}
/***********************************************************************/
/* Main function
/***********************************************************************/
int main (void)
{
try
{
CBoard board;
vector<SHardwareInfo> hwinfos;
// Get a list of all available I2C interfaces.
board.GetHardwareInfo (hwinfos);
// Open the first available Tracii XL interface.
for (SHardwareInfo &hwinfo : hwinfos)
{
if (hwinfo.board_type == TRACII_XL)
{
board.OpenDevice (hwinfo);
break;
}
}
// Test input testpins.
TestInputTestpins (board);
// Close I2C interface.
board.CloseDevice();
}
catch (CException &exp)
{
cout << "Error: " << exp.GetDescription() << endl;
return (1);
}
return (0);
}


I2C.C++ API: MasterExample.cpp

MasterExample.cpp

The following example demonstrates how to use the telos::I2cApi::Cpp::CMaster class:

/*************************************************************
Copyright (c) 2005-2015 telos Systementwicklung GmbH,
Hamburg (Germany)
http://www.telos.de
Demonstrates how to use the master classes with
the I2C.C++ API.
*************************************************************/
#include "CBoard.h"
#include "CMaster.h"
#include "CMasterMessage.h"
#include "CSmbMaster.h"
#include "CSmbMasterMessage.h"
#include "CPmbusMasterMessage.h"
#include "CException.h"
#include <vector>
#include <iostream>
using namespace telos::I2cApi::Cpp;
using namespace std;
/***********************************************************************/
/* *
* This function demonstrates how to sent data as master transmitter *
* to an I2C device. In this example 256 bytes of data are sent to *
* a device with the slave address 0x50 (7 bit). *
* */
/***********************************************************************/
void MasterTransmitter (CMaster &master)
{
// Create a vector object containing the data to be sent to
// the slave (0..255).
vector<unsigned char> data;
for (int i=0; i < 256; i++)
data.push_back (i);
// Create an CI2cAddress containing the address of the I2C slave
// (7 bit address: 0x50).
CI2cAddress address (0x50, false);
// Create a master transmitter object.
CMasterMessageTx tx_msg (address, data);
// Set the master bitrate to 100 kHz.
master.SetBitrate (100000);
// Transfer the data to the I2C slave.
master.TransferData (tx_msg);
// Display the number of bytes transferred to the slave.
cout << "Transmitted " << tx_msg.GetBytesTransferred()
<< " bytes sucessfully as master transmitter." << endl;
}
/***********************************************************************/
/* *
* This function demonstrates how to read data as master receiver *
* from an I2C device. In this example 256 bytes of data are read *
* from a device with the slave address 0x50 (7 bit). *
* */
/***********************************************************************/
void MasterReceiver (CMaster &master)
{
// Create an I2cAddress containing the address of the I2C slave
// (7 bit address: 0x50).
CI2cAddress address (0x50, false);
// Create a master receiver object (number of bytes to be
// read is 256).
CMasterMessageRx rx_msg (address, 256);
// Set the master bitrate to 400 kHz.
master.SetBitrate (400000);
// Transfer the data to the I2C slave.
master.TransferData (rx_msg);
// Display the number of bytes received from the slave.
cout << "Received " << rx_msg.GetBytesTransferred()
<< " bytes sucessfully as master receiver." << endl;
// Display the data received from the slave.
for (uint8_t data : rx_msg.GetData())
cout << static_cast<unsigned int>(data) << " ";
cout << endl;
}
/***********************************************************************/
/* *
* This function demonstrates the so-called I2C combined mode, which *
* consists of a combination of several master transmitter and *
* master receiver transfers. In this example the combined mode *
* transfer consists of one master transmitter transfer and one *
* master receiver transfer. On the I2C bus the transfer looks like *
* that: *
* *
* START, ADDR/W, DATA, START, ADDR/R, 10 * DATA, STOP *
* */
/***********************************************************************/
void MasterCombined (CMaster &master)
{
CMasterMessageTx *tx_msg = 0;
CMasterMessageRx *rx_msg = 0;
try
{
// Create a vector containing the data to be sent to
// the slave (0).
vector <unsigned char> data;
data.push_back (0);
// Create an CI2cAddress containing the address of the I2C slave
// (7 bit address: 0x50).
CI2cAddress address (0x50, false);
// Create a vector object, which is used to store the
// CMasterMessageTx and CMasterMessageRx objects of one combined
// mode transfer.
vector <CMasterMessage*> msgs;
// Create a master transmitter object.
tx_msg = new CMasterMessageTx (address, data);
msgs.push_back (tx_msg);
// Create a master receiver object (number of bytes to be
// read is 10).
rx_msg = new CMasterMessageRx (address, 10);
msgs.push_back (rx_msg);
// Set the master bitrate to 400 kHz.
master.SetBitrate (400000);
// Transfer the data to the I2C slave.
master.TransferData (msgs);
// Display the number of bytes transferred to/from the slave.
cout << "Transmitted "
<< msgs[0]->GetBytesTransferred()
<< " bytes sucessfully as master transmitter." << endl;
cout << "Received "
<< msgs[1]->GetBytesTransferred()
<< " bytes sucessfully as master receiver." << endl;
}
catch (...)
{
// If an exceptions occurs, delete objects to prevent memory leak.
delete rx_msg;
delete tx_msg;
throw;
}
// Delete messages.
delete rx_msg;
delete tx_msg;
}
/***********************************************************************/
/* *
* This function demonstrates the master functionality for the *
* System Management Bus (SMBus). The following messages are sent *
* to the SMBus: "Read Byte", "Write Word", and "Block Read". *
* *
* The optional "Packet Error Checking" (PEC) can be enabled by a *
* parameter. *
* */
/***********************************************************************/
void MasterSmb (CBoard &board, bool with_pec)
{
CSmbMasterMessageReadByte read_byte;
CSmbMasterMessageWriteWord write_word;
CSmbMasterMessageBlockRead block_read;
CSmbMaster smb_master (board);
// Create an CI2cAddress containing the address of the SMBus slave
// (7 bit address: 0x50).
CI2cAddress address (0x50, false);
// Set the master bitrate to 100 kHz.
board.GetMaster().SetBitrate (100000);
// Create "Read Byte" message.
read_byte.SetAddress (address);
read_byte.SetCommand (0x00);
read_byte.SetWithPec (with_pec);
// Transfer message to the SMBus slave.
smb_master.TransferData (read_byte);
// Display result of the message.
cout << "\"Read Byte\" (command: 0x"
<< (hex) << static_cast<unsigned int>(read_byte.GetCommand())
<< ") result: 0x"
<< static_cast<unsigned int>(read_byte.GetData())
<< endl;
// Create "Write Word" message.
write_word.SetAddress (address);
write_word.SetCommand (0x01);
write_word.SetData (0x1234);
write_word.SetWithPec (with_pec);
// Transfer message to the SMBus slave.
smb_master.TransferData (write_word);
// Display result of the message.
cout << "\"Write Word\" (command: 0x"
<< (hex) << static_cast<unsigned int>(write_word.GetCommand())
<< ") written: 0x"
<< static_cast<unsigned int>(write_word.GetData())
<< endl;
// Create "Block Read" message.
block_read.SetAddress (address);
block_read.SetCommand (0x02);
block_read.SetWithPec (with_pec);
// Transfer message to the SMBus slave.
smb_master.TransferData (block_read);
// Display result of the message.
cout << "\"Block Read\" (command: 0x"
<< (hex) << static_cast<unsigned int>(block_read.GetCommand())
<< ") result:";
for (uint8_t data : block_read.GetData())
cout << " 0x" << static_cast<unsigned int>(data);
cout << endl;
}
/***********************************************************************/
/* *
* This function demonstrates the master functionality for the *
* Power Management Bus (PMBus). The following messages are sent *
* to the PMBus: "Read Byte", "Write Word", and "Group Command". *
* *
* The optional "Packet Error Checking" (PEC) can be enabled by a *
* parameter. *
* */
/***********************************************************************/
void MasterPmbus (CBoard &board, bool with_pec)
{
CPmbusMasterMessageReadByte read_byte;
CPmbusMasterMessageWriteWord write_word;
CPmbusMasterMessageGroupCmd group_cmd;
CPmbusMasterMessageCmd cmd;
CSmbMaster smb_master (board);
// Create an CI2cAddress containing the address of the PMBus slave
// (7 bit address: 0x50).
CI2cAddress address (0x50, false);
// Create "Read Byte" message.
read_byte.SetAddress (address);
read_byte.SetCommandExtension (CPmbusMasterMessage::PMBUS_COMMAND_EXT);
read_byte.SetCommand (0x00);
read_byte.SetWithPec (with_pec);
// Transfer message to the SMBus slave.
smb_master.TransferData (read_byte);
// Display result of the message.
cout << "\"Read Byte\" (command: 0x"
<< (hex) << static_cast<unsigned int>(read_byte.GetCommand())
<< ", command extension: 0x"
<< static_cast<unsigned int>(read_byte.GetCommandExtension())
<< ") result: 0x"
<< static_cast<unsigned int>(read_byte.GetData())
<< endl;
// Create "Write Word" message.
write_word.SetAddress (address);
write_word.SetCommandExtension (CPmbusMasterMessage::PMBUS_COMMAND_EXT);
write_word.SetCommand (0x01);
write_word.SetData (0x1234);
write_word.SetWithPec (with_pec);
// Transfer message to the SMBus slave.
smb_master.TransferData (write_word);
// Display result of the message.
cout << "\"Write Word\" (command: 0x"
<< (hex) << static_cast<unsigned int>(write_word.GetCommand())
<< ", command extension: 0x"
<< static_cast<unsigned int>(write_word.GetCommandExtension())
<< ") written: 0x"
<< static_cast<unsigned int>(write_word.GetData())
<< endl;
// Create "Group Command" message.
group_cmd.SetWithPec (with_pec);
cmd.SetAddress (address);
for (uint8_t i=0; i < 10; i++)
{
cmd.SetCommand (i);
cmd.GetData().push_back (i);
group_cmd.push_back (cmd);
}
// Transfer message to the SMBus slave.
smb_master.TransferData (group_cmd);
// Display result of the message.
cout << "\"Group Command\" commands:";
for (CPmbusMasterMessageCmd &cmd : group_cmd)
{
cout << (hex) << " 0x"
<< static_cast<unsigned int>(cmd.GetCommand());
}
cout << endl;
}
/***********************************************************************/
/* *
* Main function *
* */
/***********************************************************************/
int main (void)
{
try
{
CBoard board;
vector<SHardwareInfo> hwinfos;
// Get a list of all available I2C interfaces.
board.GetHardwareInfo (hwinfos);
// Open the first available I2C interface containing an
// I2C master transmitter.
for (SHardwareInfo &hwinfo : hwinfos)
{
if (hwinfo.master == true)
{
board.OpenDevice (hwinfo);
break;
}
}
// Demonstrate a master transmitter transfer.
MasterTransmitter (board.GetMaster());
// Demonstrate a master receiver transfer.
MasterReceiver (board.GetMaster());
// Demonstrate a combined mode transfer.
MasterCombined (board.GetMaster());
if (board.GetHardwareInfoOfOpenDevice().bus_type_smb == true)
{
// Demonstrate SMBus transfers (without PEC)
MasterSmb (board, false);
// Demonstrate SMBus transfers (with PEC)
MasterSmb (board, true);
// Demonstrate PMBus transfers (without PEC)
MasterPmbus (board, false);
// Demonstrate PMBus transfers (with PEC)
MasterPmbus (board, true);
}
// Close I2C interface.
board.CloseDevice();
}
catch (CException &exp)
{
cout << "Error: " << exp.GetDescription() << endl;
return (1);
}
return (0);
}


I2C.C++ API: NegativeTesterExample.cpp

NegativeTesterExample.cpp

The following example demonstrates how to use the telos::I2cApi::Cpp::CNegativeTester class:

/*************************************************************
Copyright (c) 2005-2015 telos Systementwicklung GmbH,
Hamburg (Germany)
http://www.telos.de
Demonstrates how to use the negative testing classes with
the I2C.C++ API.
*************************************************************/
#include "CBoard.h"
#include "CNegativeTester.h"
#include "CNegativeTesterMaster.h"
#include "CNegativeTesterSlave.h"
#include "CException.h"
#include "CI2cAddress.h"
#include <vector>
#include <iostream>
using namespace telos::I2cApi::Cpp;
using namespace std;
/***********************************************************************/
/* *
* Callback function for the negative tester. *
* */
/***********************************************************************/
void NegativeTesterMasterCallback (CNegativeTester *cb,
CNegativeTester::EResult result,
void *priv)
{
bool *finished;
finished = reinterpret_cast<bool*>(priv);
*finished = true;
switch (result)
{
case CNegativeTester::RESULT_OK:
cout << "Result: OK" << endl;
break;
case CNegativeTester::RESULT_ARBITRATION_LOST:
cout << "Result: Arbitration Lost" << endl;
break;
case CNegativeTester::RESULT_NACK:
cout << "Result: NACK" << endl;
break;
}
}
/***********************************************************************/
/* *
* Shows the currently used timing of the negative tester master. *
* */
/***********************************************************************/
void ShowTiming (const CNegativeTesterMaster &neg_tester_master)
{
if (neg_tester_master.GetBitrate() != ~0)
cout << "Timings (" << neg_tester_master.GetBitrate() << "Hz)" << endl;
else
cout << "Timings" << endl;
cout << " t_HD;STA: " << CNegativeTester::ConvertTicksToNanoseconds (neg_tester_master.GetTimeHdSta()) << " ns" << endl;
cout << " t_SU;STA: " << CNegativeTester::ConvertTicksToNanoseconds (neg_tester_master.GetTimeSuSta()) << " ns" << endl;
cout << " t_SU;STO: " << CNegativeTester::ConvertTicksToNanoseconds (neg_tester_master.GetTimeSuSto()) << " ns" << endl;
cout << " t_BUF: " << CNegativeTester::ConvertTicksToNanoseconds (neg_tester_master.GetTimeBuf()) << " ns" << endl;
cout << " t_LOW: " << CNegativeTester::ConvertTicksToNanoseconds (neg_tester_master.GetTimeLowBeforeHigh() +
neg_tester_master.GetTimeLowAfterHigh()) << " ns" << endl;
cout << " t_HIGH: " << CNegativeTester::ConvertTicksToNanoseconds (neg_tester_master.GetTimeHigh()) << " ns" << endl;
}
/***********************************************************************/
/* *
* Demonstrates how to create master messages for the negative *
* tester using the CNegativeTesterMaster class. *
* *
* Create four I2C messages, sends them to the negative tester and *
* waits until the tester has transfered all messages. *
* */
/***********************************************************************/
void NegativeTesterMaster (CBoard &board)
{
CNegativeTesterMaster master;
CI2cAddress addr;
vector<uint8_t> data;
bool finished = false;
// create address of I2C slave
addr.SetAddress (0x50, false);
// send messages one time
master.SetLoopCount (1);
// do not ignore clock stretching
master.SetIgnoreStretching (false);
// generate STOP after receiving NACK
master.SetNackBehaviour (CNegativeTester::NACK_GENERATE_STOP );
// stop after receiving an arbitration lost
master.SetStopAtArbitrationLost (true);
// create container of 256 data bytes
for (int i=0; i < 256; i++)
data.push_back (i);
// create first message: send 256 data bytes to 0x50
master.SetBitrate (100000);
master.SendTransmitter (addr, data);
// show info for first message
cout << "-----------------------------------------------------" << endl;
cout << "Message (1): send 256 data bytes to 0x50 (100 kHz)" << endl;
ShowTiming (master);
// create second message: read 32 data bytes from 0x50
master.SetBitrate (400000);
master.SendReceiver (addr, 32);
// show info for second message
cout << "-----------------------------------------------------" << endl;
cout << "Message (2): read 32 data bytes from 0x50 (400 kHz)" << endl;
ShowTiming (master);
// create third message: send one data byte to 0x50
master.SetBitrate (100000);
master.SendStart();
master.SendByte (addr.GetAddress() << 1);
master.ReceiveAckBit (false);
master.SetBitrate (400000);
master.SendByte (0x00);
master.ReceiveAckBit (false);
master.SendStop();
// show info for third message
cout << "-----------------------------------------------------" << endl;
cout << "Message (3): send one data byte to 0x50 (100/400 kHz)" << endl;
// create fourth message: read one data byte from 0x50
master.SetBitrate (100000);
master.SetTimeHdSta (master.GetTimeHdSta() * 2);
master.SendStart();
master.SendByte ((addr.GetAddress() << 1) | 0x01);
master.ReceiveAckBit (false);
master.ReceiveByte();
master.SendNackBit();
master.SendStop();
// show info for fourth message
cout << "-----------------------------------------------------" << endl;
cout << "Message (4): read one data byte from 0x50 (100 kHz)" << endl;
ShowTiming (master);
cout << "-----------------------------------------------------" << endl;
// register callback function, which gets called after the
// messages have been transfered
board.GetNegativeTester().SetCompletionCallback (NegativeTesterMasterCallback,
&finished);
// start negative tester
board.GetNegativeTester().StartMaster (master.GetMessages());
// wait till the tester has finished
while (finished == false)
board.WaitForData (10 * 1000 * 1000);
}
int main (void)
{
try
{
CBoard board;
vector<SHardwareInfo> hwinfos;
// Get a list of all available I2C interfaces.
board.GetHardwareInfo (hwinfos);
// Open first available negative tester.
for (SHardwareInfo &hwinfo : hwinfos)
{
if (hwinfo.negative_tester == true)
{
board.OpenDevice (hwinfo);
break;
}
}
// No negative tester found?
if (board.IsDeviceOpen() == false)
{
cout << "No I2C interface with negative tester support has been found." << endl;
return (1);
}
// negative tester: master mode
NegativeTesterMaster (board);
// Close I2C interface.
board.CloseDevice();
}
catch (CException &exp)
{
cout << "Error: " << exp.GetDescription() << endl;
return (1);
}
return (0);
}


I2C.C++ API: TracerCsvExample.cpp

TracerCsvExample.cpp

The following example demonstrates how trace the traffic on the I2C bus using the telos::I2cApi::Cpp::CTracer class. The result gets stored in the CSV format, which can be read using programs like Microsoft's Excel.

/*************************************************************
Copyright (c) 2005-2015 telos Systementwicklung GmbH,
Hamburg (Germany)
http://www.telos.de
Demonstrates how to use the tracer classes with
the I2C.C++ API.
*************************************************************/
#include "CBoard.h"
#include "CException.h"
#include "CTracer.h"
#include "CI2cAddress.h"
#include "CTimestamp.h"
#include <vector>
#include <string>
#include <iostream>
#include <iomanip>
#include <sstream>
#include <fstream>
#ifdef WIN32
#include <windows.h>
typedef UINT64 uint64_t;
#endif
using namespace telos::I2cApi::Cpp;
using namespace std;
struct COptions
{
string filename; // filename
int cnt; // number of messages to be traced
int split; // number of messages in each file
};
/***********************************************************************/
/* Converts the timestamp to a string. */
/***********************************************************************/
string DisplayTimestamp (const CTimestamp &ts, uint32_t timestamp_timebase)
{
stringstream str;
uint64_t my_ts = 0;
uint32_t hour = 0;
uint32_t min = 0;
uint32_t sec = 0;
uint32_t msec = 0;
uint32_t usec = 0;
// get timestamp
my_ts = ts.GetTimestampMsl();
my_ts = my_ts << 32;
my_ts |= ts.GetTimestampLsl();
// calculate hours
hour = my_ts / (timestamp_timebase * 60 * 60);
my_ts = my_ts % (timestamp_timebase * 60 * 60);
// calculate minutes
min = my_ts / (timestamp_timebase * 60);
my_ts = my_ts % (timestamp_timebase * 60);
// calculate seconds
sec = my_ts / timestamp_timebase;
my_ts = my_ts % timestamp_timebase;
timestamp_timebase /= 1000;
// calculate milliseconds
if (timestamp_timebase != 0)
{
msec = my_ts / timestamp_timebase;
my_ts = my_ts % timestamp_timebase;
timestamp_timebase /= 1000;
}
// calculate microseconds
if (timestamp_timebase != 0)
{
usec = my_ts / timestamp_timebase;
my_ts = my_ts % timestamp_timebase;
timestamp_timebase /= 1000;
}
// create string
str << setw (2) << setfill ('0')
<< hour << ":"
<< setw (2) << setfill ('0')
<< min << ":"
<< setw (2) << setfill ('0')
<< sec << "."
<< setw (4) << setfill ('0')
<< msec << "."
<< setw (4) << setfill ('0')
<< usec;
return (str.str());
}
/***********************************************************************/
/* Stores one I2C message in a logfile. */
/***********************************************************************/
void DisplayTraceData (const STracerMessage &data,
uint32_t timestamp_timebase,
ofstream &of)
{
// Display type of the message.
switch (data.type)
{
case MSG_FRAME_START:
of << "START;;";
break;
case MSG_FRAME_STOP:
of << "STOP;;";
break;
case MSG_FRAME_DATA:
of << (hex) << "DATA;0x"
<< static_cast<unsigned int>(data.data.data) << (dec);
switch (data.data.confirmation)
{
case DATA_CONFIRMATION_NONE:
of << ";NONE";
break;
case DATA_CONFIRMATION_ACK:
of << ";ACK";
break;
case DATA_CONFIRMATION_NACK:
of << ";NACK";
break;
}
break;
case MSG_I2C_PROTOCOL_ERROR:
of << "ERROR;;";
break;
}
// If there is a timestamp available for a message, display
// this timestamp.
if (data.timestamp.IsInvalid() == false)
of << ";" + DisplayTimestamp (data.timestamp, timestamp_timebase)
<< endl;
else
of << ";" << endl;
}
/***********************************************************************/
/* Creates a filename of the logfile. */
/***********************************************************************/
void CreateFilename (const COptions &opt, int filenr, string &filename)
{
stringstream str;
str << opt.filename;
if (opt.split != 0)
str << "_" << setw (2) << setfill ('0') << filenr;
str << ".csv";
filename = str.str();
}
/***********************************************************************/
/* Receives messages from the I2C tracer and logs the messages in the *
* specified file. The following settings are used: all I2C addresses *
* enabled. */
/***********************************************************************/
void Tracer (CBoard &board, const COptions &opt)
{
vector<STracerMessage> trace_data;
ofstream of;
int cnt;
int cnt3 = 0;
int filenr = 0;
string filename;
// Open logfile.
CreateFilename (opt, filenr, filename);
of.open (filename.c_str());
// Disable I2C address filter to get all messages.
board.GetTracer().EnableAddressAll();
// Enable tracer.
board.GetTracer().Enable();
cnt = 0;
while (cnt <= opt.cnt)
{
// Sleep until there is something to do. It is very important
// to call this method, because the following
// ReceiveMessages() method works asynchronously. If we
// do not call this function, the example would use 100%
// of the available CPU power.
board.WaitForData (10*1000*1000);
// Get up to 10 messages from the I2C API.
board.GetTracer().ReceiveMessages (trace_data, 10000);
// Calculate the number of received messages.
if (opt.cnt != 0)
cnt += trace_data.size();
// Log the received messages and delete the messages.
for (STracerMessage &trace_data_item : trace_data)
{
// Create new file?
if (opt.split != 0)
{
if (cnt3 > opt.split)
{
of.close();
filenr++;
CreateFilename (opt, filenr, filename);
of.open (filename.c_str());
cnt3=0;
}
}
// Store message.
DisplayTraceData (trace_data_item,
board.GetHardwareInfoOfOpenDevice().timestamp_timebase,
of);
cnt3++;
}
trace_data.clear();
}
// Disable tracer.
board.GetTracer().Disable();
}
/***********************************************************************/
/* Converts the command line parameter to a C++ vector. */
/***********************************************************************/
void Arg2Vector (int argc, char *argv[], vector<string> &args)
{
for (int i=1; i < argc; i++)
args.push_back (argv[i]);
}
/***********************************************************************/
/* Shows the command line parameters of the programm. */
/***********************************************************************/
void ShowHelp (void)
{
cout << "tracer_csv <options>" << endl << endl
<< "Options:" << endl
<< " -c <count> number of messages" << endl
<< " -f <filename> name of the logfiles" << endl
<< " -s <count> split files" << endl << endl;
}
/***********************************************************************/
/* Parses the command line parameters passed to this program, *
* store the result in an instance of the COptions class. */
/***********************************************************************/
bool ArgParser (int argc, char *argv[], COptions &opt)
{
vector<string> args;
// set default options
opt.cnt = 0;
opt.split = 0;
opt.filename = "trace_log";
try
{
// convert cmd line to vector
Arg2Vector (argc, argv, args);
// no arguments specified?
if (args.size() == 0)
{
ShowHelp();
return (false);
}
// parse cmd line
for (vector<string>::size_type i=0; i < args.size(); i++)
{
// cnt
if (args[i] == "-c")
{
opt.cnt = atoi (args.at(i+1).c_str());
i++;
}
// split
if (args[i] == "-s")
{
opt.split = atoi (args.at(i+1).c_str());
i++;
}
// filename
else if (args[i] == "-f")
{
opt.filename = args.at (i+1);
i++;
}
}
}
catch (...)
{
ShowHelp();
return (false);
}
return (true);
}
/***********************************************************************/
/* Main function */
/***********************************************************************/
int main (int argc, char *argv[])
{
try
{
CBoard board;
vector<SHardwareInfo> hwinfos;
COptions opt;
// Get a list of all available I2C interfaces.
board.GetHardwareInfo (hwinfos);
// Parse options received from the cmd line.
if (ArgParser (argc, argv, opt) == false)
return (1);
// Open the first available I2C interface containing an
// I2C tracer.
for (SHardwareInfo &hwinfo : hwinfos)
{
if ((hwinfo.tracer == true) &&
(hwinfo.board_type != DUMMY))
{
board.OpenDevice (hwinfo);
break;
}
}
// Demonstrate the tracer.
Tracer (board, opt);
// Close I2C interface.
board.CloseDevice();
}
catch (CException &exp)
{
cout << "Error: " << exp.GetDescription() << endl;
return (1);
}
return (0);
}


I2C.C++ API: TracerExample.cpp

TracerExample.cpp

The following example demonstrates how to use the telos::I2cApi::Cpp::CTracer class:

/*************************************************************
Copyright (c) 2003-2015 telos Systementwicklung GmbH,
Hamburg (Germany)
http://www.telos.de
Demonstrates how to use the tracer classes with
the I2C.C++ API.
*************************************************************/
#include "CBoard.h"
#include "CException.h"
#include "CTracer.h"
#include "CI2cAddress.h"
#include <vector>
#include <iostream>
using namespace telos::I2cApi::Cpp;
using namespace std;
/***********************************************************************/
/* Displays the messages of the I2C tracer stored in the given data *
* container on the console. */
/***********************************************************************/
void DisplayTraceData (const vector<STracerMessage> &data)
{
for (const STracerMessage &data_item : data)
{
// Display type of the message.
switch (data_item.type)
{
case MSG_FRAME_START:
cout << "START ";
break;
case MSG_FRAME_STOP:
cout << "STOP ";
break;
case MSG_FRAME_DATA:
cout << (hex) << "DATA (FRAME) 0x"
<< static_cast<unsigned int>(data_item.data.data) << (dec);
switch (data_item.data.confirmation)
{
case DATA_CONFIRMATION_NONE:
cout << " (NONE)";
break;
case DATA_CONFIRMATION_ACK:
cout << " (ACK) ";
break;
case DATA_CONFIRMATION_NACK:
cout << " (NACK)";
break;
}
break;
case MSG_I2C_PROTOCOL_ERROR:
cout << "ERROR ";
break;
}
// If there is a timestamp available for a message, display
// this timestamp.
if (data_item.timestamp.IsInvalid() == false)
cout << " 0x" + data_item.timestamp.GetTimestampAsHexString() << endl;
else
cout << endl;
}
}
/***********************************************************************/
/* Receives 1000 messages from the I2C tracer and displays the *
* messages on the console. The following settings are used: all *
* I2C addresses enabled. */
/***********************************************************************/
void Tracer (CBoard &board)
{
vector<STracerMessage> trace_data;
int cnt;
// Disable I2C address filter to get all messages.
board.GetTracer().EnableAddressAll();
// Enable tracer.
board.GetTracer().Enable();
// Get 1000 messages.
cnt = 1000;
while (cnt > 0)
{
// Sleep until there is something to do. It is very important
// to call this method, because the following
// ReceiveMessages() method works asynchronously. If we
// do not call this function, the example would use 100%
// of the available CPU power.
board.WaitForData (10*1000*1000);
// Get up to "cnt" messages from the I2C API.
board.GetTracer().ReceiveMessages (trace_data, cnt);
// Calculate the number of messages to be received.
cnt -= trace_data.size();
// Display the received messages and delete the messages.
DisplayTraceData (trace_data);
trace_data.clear();
}
// Disable tracer.
board.GetTracer().Disable();
}
/***********************************************************************/
/* Main function */
/***********************************************************************/
int main (void)
{
try
{
CBoard board;
vector<SHardwareInfo> hwinfos;
// Get a list of all available I2C interfaces.
board.GetHardwareInfo (hwinfos);
// Open the first available I2C interface containing an
// I2C tracer supporting the frame mode.
for (SHardwareInfo hwinfo : hwinfos)
{
if (hwinfo.tracer == true)
{
board.OpenDevice (hwinfo);
break;
}
}
// Demonstrate the tracer.
Tracer (board);
// Close I2C interface.
board.CloseDevice();
}
catch (CException &exp)
{
cout << "Error: " << exp.GetDescription() << endl;
return (1);
}
return (0);
}


I2C.C++ API: Class Index

Class Index
C | S
C
CExceptionMasterArbitration (telos::I2cApi::Cpp) CExceptionSlaveRamEnhancedAddress (telos::I2cApi::Cpp) CPmbusMasterMessageCmd (telos::I2cApi::Cpp) CSmbMasterMessageReadByte (telos::I2cApi::Cpp)
CExceptionMasterBusy (telos::I2cApi::Cpp) CExceptionSlaveRamEnhancedBusy (telos::I2cApi::Cpp) CPmbusMasterMessageExtCmdByte (telos::I2cApi::Cpp) CSmbMasterMessageReadWord (telos::I2cApi::Cpp)
CAdc (telos::I2cApi::Cpp) CExceptionMasterI2cProtocol (telos::I2cApi::Cpp) CExceptionSlaveRamEnhancedMemorySize (telos::I2cApi::Cpp) CPmbusMasterMessageExtCmdWord (telos::I2cApi::Cpp) CSmbMasterMessageReceiveByte (telos::I2cApi::Cpp)
CBoard (telos::I2cApi::Cpp) CExceptionMasterIncompleteRx (telos::I2cApi::Cpp) CExceptionSlaveRamEnhancedNotSupported (telos::I2cApi::Cpp) CPmbusMasterMessageGroupCmd (telos::I2cApi::Cpp) CSmbMasterMessageSendByte (telos::I2cApi::Cpp)
CException (telos::I2cApi::Cpp) CExceptionMasterIncompleteTx (telos::I2cApi::Cpp) CExceptionSlaveRamEnhancedSetData (telos::I2cApi::Cpp) CPmbusMasterMessageReadByte (telos::I2cApi::Cpp) CSmbMasterMessageWrite32 (telos::I2cApi::Cpp)
CExceptionAdc (telos::I2cApi::Cpp) CExceptionMasterInvalidBitrate (telos::I2cApi::Cpp) CExceptionSlaveRamEnhancedTimeout (telos::I2cApi::Cpp) CPmbusMasterMessageReadWord (telos::I2cApi::Cpp) CSmbMasterMessageWrite64 (telos::I2cApi::Cpp)
CExceptionAdcBusy (telos::I2cApi::Cpp) CExceptionMasterInvalidMasterCode (telos::I2cApi::Cpp) CExceptionSmbI2cAddress (telos::I2cApi::Cpp) CPmbusMasterMessageWriteByte (telos::I2cApi::Cpp) CSmbMasterMessageWriteByte (telos::I2cApi::Cpp)
CExceptionAdcNotFinished (telos::I2cApi::Cpp) CExceptionMasterInvalidTransfer (telos::I2cApi::Cpp) CExceptionTermination (telos::I2cApi::Cpp) CPmbusMasterMessageWriteWord (telos::I2cApi::Cpp) CSmbMasterMessageWriteWord (telos::I2cApi::Cpp)
CExceptionAdcNotSupported (telos::I2cApi::Cpp) CExceptionMasterNotSupported (telos::I2cApi::Cpp) CExceptionTracer (telos::I2cApi::Cpp) CSlaveRam (telos::I2cApi::Cpp) CTimestamp (telos::I2cApi::Cpp)
CExceptionAdcPreTrigger (telos::I2cApi::Cpp) CExceptionMasterRunning (telos::I2cApi::Cpp) CExceptionTracerBusy (telos::I2cApi::Cpp) CSlaveRamEnhanced (telos::I2cApi::Cpp) CTracer (telos::I2cApi::Cpp)
CExceptionAdcSamplingRate (telos::I2cApi::Cpp) CExceptionMasterSmbInvalidSize (telos::I2cApi::Cpp) CExceptionTracerFilter (telos::I2cApi::Cpp) CSmbArpMaster (telos::I2cApi::Cpp) CTraciiCpu (telos::I2cApi::Cpp)
CExceptionAdcTrigger (telos::I2cApi::Cpp) CExceptionMasterSmbPecFailed (telos::I2cApi::Cpp) CExceptionTracerNotSupported (telos::I2cApi::Cpp) CSmbMaster (telos::I2cApi::Cpp) CSmbArpMaster::CUdid (telos::I2cApi::Cpp)
CExceptionArpI2cAddressesExhausted (telos::I2cApi::Cpp) CExceptionMasterTimeout (telos::I2cApi::Cpp) CExceptionTraciiCpu (telos::I2cApi::Cpp) CSmbMasterMessage (telos::I2cApi::Cpp)
S
CExceptionArpInvalidResponse (telos::I2cApi::Cpp) CExceptionMasterWatchdogTimeout (telos::I2cApi::Cpp) CExceptionTraciiCpuBusy (telos::I2cApi::Cpp) CSmbMasterMessageBlockRead (telos::I2cApi::Cpp)
CExceptionAuthentication (telos::I2cApi::Cpp) CExceptionNegativeTester (telos::I2cApi::Cpp) CExceptionTraciiCpuNotSupported (telos::I2cApi::Cpp) CSmbMasterMessageBlockWrite (telos::I2cApi::Cpp) SAdcData (telos::I2cApi::Cpp)
CExceptionBusType (telos::I2cApi::Cpp) CExceptionNegativeTesterBusy (telos::I2cApi::Cpp) CExceptionTraciiCpuProgramSize (telos::I2cApi::Cpp) CSmbMasterMessageBlockWriteRead (telos::I2cApi::Cpp) SHardwareInfo (telos::I2cApi::Cpp)
CExceptionDeviceOpen (telos::I2cApi::Cpp) CExceptionNegativeTesterInvalidArgument (telos::I2cApi::Cpp) CI2cAddress (telos::I2cApi::Cpp) CSmbMasterMessageCmd (telos::I2cApi::Cpp) SInputTestpinsMessage (telos::I2cApi::Cpp)
CExceptionDriverVersion (telos::I2cApi::Cpp) CExceptionNegativeTesterNotSupported (telos::I2cApi::Cpp) CInputTestpins (telos::I2cApi::Cpp) CSmbMasterMessageCmd32 (telos::I2cApi::Cpp) CNegativeTester::SLevelsMaster (telos::I2cApi::Cpp)
CExceptionHardwareIo (telos::I2cApi::Cpp) CExceptionNegativeTesterProgramSize (telos::I2cApi::Cpp) CLanguage (telos::I2cApi::Cpp) CSmbMasterMessageCmd64 (telos::I2cApi::Cpp) CNegativeTester::SLevelsSlave (telos::I2cApi::Cpp)
CExceptionI2cAddress (telos::I2cApi::Cpp) CExceptionNullPointer (telos::I2cApi::Cpp) CMaster (telos::I2cApi::Cpp) CSmbMasterMessageCmdBlock (telos::I2cApi::Cpp) CNegativeTester::SMessagesMaster (telos::I2cApi::Cpp)
CExceptionI2cVcc (telos::I2cApi::Cpp) CExceptionOpen (telos::I2cApi::Cpp) CMasterMessage (telos::I2cApi::Cpp) CSmbMasterMessageCmdByte (telos::I2cApi::Cpp) CNegativeTester::SMessagesSlave (telos::I2cApi::Cpp)
CExceptionI2cVccSupply (telos::I2cApi::Cpp) CExceptionOutputTestpin (telos::I2cApi::Cpp) CMasterMessageRx (telos::I2cApi::Cpp) CSmbMasterMessageCmdProcessCall (telos::I2cApi::Cpp) STracerMessage (telos::I2cApi::Cpp)
CExceptionInputTestpin (telos::I2cApi::Cpp) CExceptionPullUpCurrent (telos::I2cApi::Cpp) CMasterMessageTx (telos::I2cApi::Cpp) CSmbMasterMessageCmdWord (telos::I2cApi::Cpp) SVersionNumber (telos::I2cApi::Cpp)
CExceptionIo (telos::I2cApi::Cpp) CExceptionSchedulerBusy (telos::I2cApi::Cpp) CNegativeTester (telos::I2cApi::Cpp) CSmbMasterMessageHostNotify (telos::I2cApi::Cpp)
CExceptionLevelThreshold (telos::I2cApi::Cpp) CExceptionSchedulerVersion (telos::I2cApi::Cpp) CNegativeTesterMaster (telos::I2cApi::Cpp) CSmbMasterMessageQuickCommand (telos::I2cApi::Cpp)
CExceptionMaster (telos::I2cApi::Cpp) CExceptionServiceContractExpired (telos::I2cApi::Cpp) CNegativeTesterSlave (telos::I2cApi::Cpp) CSmbMasterMessageRead32 (telos::I2cApi::Cpp)
CExceptionMasterAddress (telos::I2cApi::Cpp) CExceptionSlaveRamEnhanced (telos::I2cApi::Cpp) CPmbusMasterMessage (telos::I2cApi::Cpp) CSmbMasterMessageRead64 (telos::I2cApi::Cpp)
C | S


I2C.C++ API: Member List

  • CSmbMasterMessageCmd
telos::I2cApi::Cpp::CSmbMasterMessageCmd Member List

This is the complete list of members for telos::I2cApi::Cpp::CSmbMasterMessageCmd, including all inherited members.

CSmbMasterMessage(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage | protected
CSmbMasterMessageCmd(const CI2cAddress &i2c_address, uint8_t cmd, bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd | protected
GetAddress() const | telos::I2cApi::Cpp::CSmbMasterMessage |
GetCommand() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
GetWithPec() const | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetAddress(const CI2cAddress &i2c_address) | telos::I2cApi::Cpp::CSmbMasterMessage |
SetCommand(uint8_t cmd) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |
SetWithPec(bool with_pec) | telos::I2cApi::Cpp::CSmbMasterMessageCmd |


I2C.C++ API: Main Page

I2C.C++ API Documentation
Introduction to the I2C.C++ API


I2C.C++ API: Related Pages

Related Pages
Here is a list of all related documentation pages:
Introduction to the I2C.C++ API
FAQ
Credits